导言

《IBM Power&Storage售前技术火线速查手册》旨在帮助IBM和合作伙伴销售技术人员提升技术水平，及快速解决日常工作问题。本手册集成了IBM Power服务器和存储产品的常见售前问题；产品介绍、售前常用工具、文档及相关网站的链接；同时，提供最新制作的网络课程、网络课堂学习规划图给大家，帮助大家系统地学习IBM产品和技术。

本期常见问题的更新率达到了65%以上，更多特色亮点如下：

- 新增“携手 IBM，开启业务弹性之旅”栏目：介绍了与业务弹性相关技术、优势、解决方案等；并为您提供了相应的红皮书、案例以及相关资料的链接等；

- 新增“2011年第1季度热门问题排行榜”：通过该排行榜，您可以快速查看第1季度的热门问题和答案；

- 更新“IBM专家推荐热门书籍”栏目，由IBM资深专家推荐给大家一些与产品、技术相关的热门书籍，帮助大家提高自身技术水平；

- 更新“竞争分析工具”：及时更新了Power,存储和System x的竞争分析工具。Power竞争分析工具的版本为：Version 20.1 (May 4, 2011) ；存储竞争分析工具的版本为：Version 11.2 (April 22, 2011) ；

- 更新“Power 和 存储 产品配置文件中英文翻译工具”：在Power产品中英文翻译工具中，添加了新推出的Feature Code的翻译；存储产品中英文翻译工具中，添加了DS8800，SVC CG8的中英文翻译；

- 更新“Power 和 存储 产品销售手册快速查询通道”：在Power产品销售手册快速查询通道中，添加了PS703,PS704销售手册链接；在Storage产品销售手册快速查询通道中，更新了TS2900、SSPC、SVC、V7000、SAN384B等的销售手册链接、产品物理参数，便于大家快速查询新发布产品的信息；

- 更新“Power 和 存储 产品家族一览表”：在Power和存储产品家族一览表中，更新了当前的相关产品，便于大家查看目前在产的产品信息；

- 更新“IBM POWER7家族便捷指南”：可以直接查看Power服务器(BladeCenter PS700/PS701/PS702/PS703/PS704, Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780)的产品参数信息。

下面是各产品本期更新情况的链接：

Power System - What's New

Storage System - What's New

注：本期FAQ的内容适用于当前的情况，如有更新，请关注后续的更新版本。另外，如果手册中涉及到了产品的维保信息，请以产品部提供的实时信息为准。


What's New Power

What's New

1.更新了Power服务器销售手册快速查询通道

本期更新了Power服务器销售手册快速查询通道，在该工具中，增加了PS703，PS704的销售手册链接。

Power服务器销售手册快速查询通道

2.更新了Power家族服务器一览表

本期更新了Power家族服务器一览表，展现了目前在产的产品。

Power家族服务器一览表

3.更新了IBM POWER7家族便捷指南

本期更新了IBM POWER7家族便捷指南，可以直接查看Power服务器(BladeCenter PS700/PS701/PS702/PS703/PS704、Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780)的产品参数信息。

IBM POWER7家族便捷指南

4.更新了Power产品竞争工具链接

本期在Power产品速查手册的附录中，更新了最新版本的Power产品竞争工具链接。

Power产品速查手册附录

5.更新了Power产品配置文件中英文翻译工具

本期更新了Power产品配置文件中英文翻译工具，在该工具中，添加了新增的Feature Code信息。

Power产品配置文件中英文翻译工具

6.更新了Power服务器TPC-C估算器

本期更新了Power服务器TPC-C估算器，在该工具中，添加了Power 750服务器的rPerf值。

Power服务器TPC-C估算器

7.新增的网络课堂：(新增)

(1) PowerHA V7 与 Cluster Aware AIX（CAA)技术讨论

8.增加了31个新的热点问题：(新增)

(1) 刀片PS703/704产品介绍

(2) 刀片中心的fc#5045、fc#5869 Brocade SAN交换模块是否需要配置full-fabric的级联license

(3) 在e-config中，Power710/730可以配置的内置磁带机和磁带介绍

(4) 如何在Power720/740上配置3个以上分区

(5) 在e-config中，Power 720/740 可以配置的内置磁带机和磁带介绍

(6) Power720是否支持12X扩展柜？有什么条件？

(7) 哪些配置情况下会使Power 720/740的噪音增加

(8) Power 710/720/730/740/750,订购fc#2319关闭处理器之后，如何来重新激活处理器

(9) 7216-1U2磁带机、DVD一体机，是否支持订购两个磁带机，连接到两台Power服务器上面来使用

(10) SFF Storage I/O drawer fc#5887介绍

(11) fc#5887支持的分区数量？是否可以手动修改其分区的磁盘模式

(12) Power服务器能否在USB移动硬盘中安装操作系统并启动

(13) 哪些服务器可通过7042-CR6/7042-C08管理

(14) IBM Systems Director Management Console (SDMC)介绍

(15) FCoE与PowerHA SystemMirror for AIX 的兼容性

(16) SVC 6.1与PowerHA SystemMirror for AIX的兼容性

(17) IBM System Storage Storwize V7000与PowerHA SystemMirror for AIX的兼容性

(18) 用VIOS实现分区双机时，需要几个VIOS，以及串口心跳卡/网卡/HBA卡的数量应如何考虑

(19) 什么是CAA（Cluster Aware AIX）

(20) 什么是ASMI及简要介绍

(21) PowerHA 7.1可以安装到AIX 哪些版本中？是否支持通过VIOS访问共享存储？

(22) PowerHA 7.1还支持RS232串口心跳和磁盘心跳吗？其拓扑支持的心跳有何变化？

(23) PowerHA 7.1 可以通过 System Director 集中管理吗？

(24) 动态分区迁移(Live Partition Mobility)介绍

(25) 要实现动态分区迁移所具备的前提条件

(26) 被管理服务器所监控和管理的服务器是否均需购买Systems Director软件

(27) VMControl 版本及功能介绍

(28) 业界常见的服务器性能指标有哪些及简要介绍

(29) 一个根据业务需求估算TPC-C值的实例

(30) 为什么现在在配置中介质会出现ESD，如何避免？

(31) 如何通过e-config工具，配置C/C++, fortran, Cobol等开发环境

9.更新的FAQ：(最近更新)

(1) POWER7刀片服务器的参数对比

(2) Power刀片服务器与刀片中心(BladeCenter)的兼容性

(3) POWER7刀片服务器中, CIOv/CFFh属性的卡都有哪些Features都支持哪些操作系统

(4) Power刀片服务器上可选择哪些8Gb的光纤卡

(5) JS43，PS702和PS704是否集成了两个SASController？

(6) 刀片做HACMP推荐方案

(7) POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性

(8) 刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？

(9) BladeCenter H机箱中10个I/O插槽的配置规则

(10) BladeCenter S电源配置问题

(11) 如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？

(12) 如何在Power 520/550 服务器上创建RAID 5?

(13) 如何配置Power 520服务器内置磁盘分区的功能

(14) 如何配置Power 550 服务器内置磁盘分区的功能

(15) 如何在Power 570上创建RAID 5?

(16) Power 710/730/720/740硬件参数对比

(17) Power 750/755的区别

(18) Power 750(8233-E8B)的硬件特性

(19) Power 755(8236-E8C)的产品定位与硬件特性

(20) fc#2319 Factory Deconfiguration of 1-core的介绍

(21) POWER7 产品支持的操作系统

(22) POWER7服务器 CPU，MEM，DISK的配置规则

(23) POWER7全线产品家族分离背板总结

(24) AIX V7.1支持的硬件环境

(25) 哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因

(26) Power服务器支持分区的最大数量是多少？

(27) System P系列服务器的CPU, Memory, I/O的带宽

(28) POWER服务器处理器能否升级，以及升级后支持的数量

(29) 在没有HMC的情况下，如何远程管理Power服务器

(30) 什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号

(31) 什么是PowerVM

(32) 什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用

(33) 在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？

(34) PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么

(35) Power系列机型上共有多少种SAS连接线, 它们有什么不同

(36) System P 服务器如何选配置电源线

(37) 用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项

(38) Power服务器常用I/O抽屉配置方法

(39) System P服务器都支持哪一些类型的I/O Drawer

10.删除的FAQ：

(1) Power服务器的内置光驱是否可以进行DLPAR

(2) 将VIOS client AIX分区用于HA集群中的node时，要求配置双VIOS吗？以及原因

(3) 将VIOS client AIX分区用于HA集群中的node时，如果采用VIOS级别上的网络冗余功能，AIX操作系统和HA软件需要再对网络进行冗余设置吗? 如果不需要,HA支持单网卡配置吗

(4) 常见SAS RAID Controller Adapter 介绍

(5) 5765-SEP IBM Systems Director Standard Edition for Power Systems软件和5765-DRP IBM(R) Systems Director for Power Systems的区别是什么

(6) 5765-AME软件的功能，以及其相应的替代产品

(7) 刀片JS12/JS22与JS23/JS43的参数对比

(8) Power 575的Infiniband卡(fc5612)，需要订什么Infiniband线缆，才能连接到7874系列Infiniband交换机上？

(9) 没有硬盘槽位的fc#5873 I/O抽屉是否可以升级为带硬盘槽位的fc#5803？

(10) IP地址接管(IP Address Takeover IPAT)机制

(11) 做HA配置时，为了传输心跳信号，有哪些方案可以选择

(12) Linux on Power的高可用方案介绍

(13) 主要有哪些POWER6上的adapter、硬盘等设备是POWER7不支持的？

(14) 在一些Power机型中，支持内置RAID卡。在AIX 操作系统中，也可以使用LVM的mirror功能提供磁盘冗余保护。这两种磁盘冗余保护方式在性能和可用性上有何区别？

(15) 刀箱中配置新的fc#5449 QLogic 8 Gb光纤直通模块有什么需要注意的地方?

(16) Power 550 3.5GHz的处理器是否能升级为4.2GHz或者5.0GHz的处理器

(17) 在System P的HACMP方案里，推荐的e-config 配置范例

(注：本手册删除的FAQ，仍可通过如下链接查询：http://www-900.ibm.com/cn/support/viewdoc/knowledgebase)


目录 常见问题汇总

目录

IBM Power Systems 常见问题汇总

刀片服务器

POWER7刀片服务器的参数对比 (最近更新)

刀片PS703/704产品介绍 (新增)

Power刀片服务器与刀片中心(BladeCenter)的兼容性 (最近更新)

POWER7刀片服务器中, CIOv/CFFh属性的卡都有哪些Features都支持哪些操作系统 (最近更新)

Power刀片服务器上可选择哪些8Gb的光纤卡 (最近更新)

刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？

POWER6

Power 520(8203-E4A)

Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？

Power 520六种硬盘背板的介绍

Power 550(8204-E8A)

Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？

Power 550六种硬盘背板的介绍

Power 595(9119-FHA)

Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同?是否可以混插?

Power 595服务器是否支持热节点添加的功能？

POWER7

Power 710/730(8231-E2B)

Power 710/730硬盘背板介绍

Power 720(8202-E4B)/Power 740(8205-E6B)

Power 720/740支持的PCI槽位信息

Power 720/740硬盘背板介绍

Power720是否支持12X扩展柜？有什么条件 (新增)

Power 750(8233-E8B)

Power 750(8233-E8B)硬盘背板的介绍

Power 750/755的区别 (最近更新)

Power 750(8233-E8B)的硬件特性 (最近更新)

Power 755(8236-E8C)

Power 755(8236-E8C)的产品定位与硬件特性 (最近更新)

Power 770(9117-MMB)

Power 770/780的区别

Power 770/780硬盘背板介绍

Power 770(9117-MMB)的硬件特性

将Power 770/780放到T42机柜里，有哪些限制？

Power 780(9179-MHB)

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780(9179-MHB)的硬件特性

其他

哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因 (最近更新)

POWER7的主要技术特点？

POWER7服务器与POWER6的主要区别有哪些

IBM eDRAM技术的特别之处是什么

介绍POEWR7处理器的缓存信息

什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

请简要介绍一下POWER7处理器的主要创新技术

POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡

Power 710/720/730/740/750/755/770/780支持的PCI槽位信息

Power 710/730/720/740硬件参数对比(最近更新)

POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)?

fc#2319 Factory Deconfiguration of 1-core的介绍 (最近更新)

Power 710/720/730/740/750,订购fc#2319关闭处理器之后，如何来重新激活处理器 (新增)

POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug

I/O Drawer

什么是EXP 12S磁盘柜(产品号fc#5886)?可以用什么主机卡来连接它?是否有冗余电源和风扇?12S支持什么硬盘?

SFF Storage I/O drawer fc#5887介绍 (新增)

fc#5887支持的分区数量？是否可以手动修改其分区的磁盘模式 (新增)

Power服务器I/O Drawer硬件特性及介绍

Power 595支持哪些I/O抽屉，各有什么特点？

外设

P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号 (最近更新)

目前支持的几款HMC介绍及配置注意事项

在没有HMC的情况下，如何远程管理Power服务器 (最近更新)

哪些服务器可通过7042-CR6/7042-C08管理 (新增)

IBM Systems Director Management Console (SDMC)介绍 (新增)

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备?

7216-1U2介绍

7216-1U2磁带机、DVD一体机，是否支持订购两个磁带机，连接到两台Power服务器上面来使用 (新增)

USB移动硬盘设备介绍，以及与磁带驱动器的比较

Power服务器能否在USB移动硬盘中安装操作系统并启动 (新增)

虚拟化技术 (PowerVM)

动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

System P服务器分区技术中的Physical Shared Processor Pool,Multiple Shared Processor Pool, Shared Dedicated Capacity 介绍

PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

表格列举不同Power服务器的型号所能够支持的PowerVM的features

什么是PowerVM？ (最近更新)

PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用 (最近更新)

动态分区迁移(Live Partition Mobility)介绍 (新增)

要实现动态分区迁移所具备的前提条件 (新增)

IVE介绍及特性

刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？ (最近更新)

PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？ (最近更新)

Power服务器支持分区的最大数量是多少？ (最近更新)

目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况

用VIOS实现分区双机时，需要几个VIOS，以及串口心跳卡/网卡/HBA卡的数量应如何考虑 (新增)

Power服务器上使用NPIV的技术，是否需要额外的License

VMControl 版本及功能介绍? (新增)

PowerHA

System P服务器AIX与HACMP版本兼容性的问题; 另外，实施HACMP时，最常用的方法及所需要的基本硬件资源

Power 710/730与PowerHA SystemMirror for AIX的兼容性

Power 720/740与PowerHA SystemMirror for AIX的兼容性

Power 750与PowerHA SystemMirror的兼容性

Power 770/780与PowerHA SystemMirror for AIX的兼容性

POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性 (最近更新)

FCoE与PowerHA SystemMirror for AIX 的兼容性 (新增)

SVC 6.1与PowerHA SystemMirror for AIX的兼容性 (新增)

IBM System Storage Storwize V7000与PowerHA SystemMirror for AIX的兼容性 (新增)

什么是PowerHA SystemMirror?

PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术

PowerHA 7.1可以安装到AIX 哪些版本中？是否支持通过VIOS访问共享存储 (新增)

PowerHA 7.1还支持RS232串口心跳和磁盘心跳吗？其拓扑支持的心跳有何变化 (新增)

PowerHA 7.1 可以通过 System Director 集中管理吗 (新增)

什么是DB2 PureScale,它的主要功能以及特点介绍

什么是GPFS？以及其基本架构介绍

GPFS基本创建过程以及常见注意事项

GPFS中的Manager主要有哪几种,及区别

性能与物理参数

服务器性能参数

System P系列服务器的CPU, Memory, I/O的带宽 (最近更新)

业界常见的服务器性能指标有哪些及简要介绍 (新增)

一个根据业务需求估算TPC-C值的实例 (新增)

物理环境参数

System P系列服务器的尺寸、环境要求、功率和重量

其它

P系列服务器显卡介绍

Power System上Infiniband 产品的支持列表

什么是Power服务器的Storage Key?

什么是CAA（Cluster Aware AIX） (新增)

POWER服务器处理器能否升级，以及升级后支持的数量 (最近更新)

POWER6 产品支持的操作系统

POWER7 产品支持的操作系统 (最近更新)

AIX V6.1支持的硬件环境

AIX V7.1支持的硬件环境 (最近更新)

AIX EE 6.1版本包含哪些软件

什么是AIX Express Edition? 该版本有何要求？

AIX V7.1支持的几个新功能

IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

AIX V7.1 标准版，企业版，易捷版的区别

AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？

简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

什么是NIM？它的应用场景以及基本概念介绍

NIM中常见的资源类型以及各自的特点介绍

一个典型的NIM安装过程介绍

什么是ASMI及简要介绍 (新增)

POWER服务器的电源和耗电量计算方法

Power系列机型上共有多少种SAS连接线, 它们有什么不同? (最近更新)

FCoE支持的操作系统

为什么选择FCoE/FCoEE?

什么是IBM Systems Director Active Energy Manager?

IBM Systems Director 系统软件各个版本包含哪些软件

IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

被管理服务器所监控和管理的服务器是否均需购买Systems Director软件 (新增)


刀片服务器

POWER7刀片服务器的参数对比 (最近更新)

刀片PS703/704产品介绍 (新增)

Power刀片服务器与刀片中心(BladeCenter)的兼容性 (最近更新)

POWER7刀片服务器中, CIOv/CFFh属性的卡都有哪些Features都支持哪些操作系统 (最近更新)

Power刀片服务器上可选择哪些8Gb的光纤卡 (最近更新)

刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？


POWER7刀片服务器的参数对比

解答:

 | IBM BladeCenter PS700 Express | IBM BladeCenter PS701 Express | IBM BladeCenter PS702 Express | IBM BladeCenter PS703 Express | IBM BladeCenter PS704 Express
Architecture | POWER7 @ 3.0 GHz 4-Core (1 Socket x 4 Cores) Single Wide | POWER7 @ 3.0 GHz 8-core (1 Socket x 8 Cores) Single Wide | POWER7 @ 3.0 GHz 16-core (2 Socket x 8 Cores) Double Wide | POWER7 @ 2.4 GHz 16-core (2 Socket x 8 Cores) Single Wide | POWER7 @ 2.4 GHz 32-core (4 Socket x 8 Cores) Double Wide
Memory | 4GB to 64GB DDR3 (Chipkill) 4GB@1066MHz, 8GB@1066MHz 8 Dimm Slots | 4GB to 128GB DDR3 (Chipkill) 4GB@1066MHz, 8GB@1066MHz 16 Dimm Slots | 4GB to 256GB DDR3 (Chipkill) 4GB@1066MHz, 8GB@1066MHz 32 Dimm Slots | 4GB to 128GB DDR3 (Chipkill) 4GB@1066MHz, 8GB@1066MHz 16 Dimm Slots | 4GB to 256GB DDR3 (Chipkill) 4GB@1066MHz, 8GB@1066MHz 32 Dimm Slots
DASD / Bays | 0-2 SAS disk | 0-1 SAS disk | 0-2 SAS disk | 0-1 SAS disk or 0-2 Solid States | 0-2 SAS disk or 0-4 Solid State
Expansion Card Slots | 1 PCI-E CIOv Expansion Card | 1 PCI-E CIOv Expansion Car | 2 PCI-E CIOv Expansion Card | 1 PCI-E CIOv Expansion Card | 2 PCI-E CIOv Expansion Card
 | 1 PCI-E CFFh ExpansionCard | 1 PCI-E CFFh ExpansionCard | 2 PCI-E CFFh ExpansionCard | 1 PCI-E CFFh ExpansionCard | 2 PCI-E CFFh ExpansionCard
Integrated Features | Keyboard, Video, and Mouse | Keyboard, Video, and Mouse | Keyboard, Video, and Mouse | Keyboard, Video, and Mouse | Keyboard, Video, and Mouse
 | Dual Port 1Gb Ethernet | Dual Port 1Gb Ethernet | Quad Port 1Gb Ethernet | Dual Port 1Gb Ethernet | Quad Port 1Gb Ethernet
 | SAS Controller | SAS Controller | SAS Controller | SAS Controller | SAS Controller
 | USB | USB | USB | USB | USB
Scalability Support | N/A | Yes – Factory or Customer Upgrade | Yes – Factory or Customer Upgrade | N/A | N/A
Fibre Support | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis)
Redundant Power | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis)
Redundant Cooling | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis) | Yes (via BladeCenter Chassis)
Service Processor | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL)
Virtualization | IBM PowerVM (optional Editions) | IBM PowerVM (optional Editions) | IBM PowerVM (optional Editions) | IBM PowerVM (optional Editions) | IBM PowerVM (optional Editions)
Systems Management | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology
OS Support | AIX, i, Linux | AIX, i, Linux | AIX, i, Linux | AIX, i, Linux | AIX, i, Linux
BladeCenter Chassis Support | BCE, BCH*, BCHT, BCT, BCS* | BCH*, BCHT, BCS* | BCH*, BCHT, BCS* | BCH*, BCHT, BCS* | BCH*, BCHT, BCS*

* In Power Systems Channel

突出价值点：该参数表列出了目前Power家族新推出的POWER7的刀片服务器。刀片服务器与机架式服务器比较，其主要优势在于：更加节能和节省空间。 PS700/PS701/PS702/PS703/PS704拥有了IBM Active Energy Manger 和EnergySCale的技术，能帮助监控和控制供电和制冷;还可以支持开源的集群管理软件：xCAT；与JS的刀片服务器相比，具有更高的rPerf值。


刀片PS703/704产品介绍

解答:

刀片PS703/704产品信息如下：

 | PS703 （7981-73X） | PS704 （7981-74X）
CPU | 16 Core @ 2.4 GHz | 32 Core @ 2.4 GHz
L2 & L3 Cache | 位于芯片上 | 位于芯片上
DDR3内存 | 多达128GB, 16个内存插槽 | 多达256GB, 32个内存插槽
SAS硬盘槽位 | 1 | 2
I/O 扩展卡 | 1个CIOv，1个CFFh | 2个CIOv，2个CFFh
集成以太网端口 | 2个 | 4个
冗余电源 | Yes | Yes
冗余的Cooling | Yes | Yes
服务处理器 | Yes | Yes
绿色节能 | Power save/Power cap | Power Save/Power Cap

突出价值点： IBM五款POWER7的刀片，从4-core到32-core，为客户提供了多种的选择。客户可以根据实际需要，进行相应的选择。


Power刀片服务器与刀片中心(BladeCenter)的兼容性

解答：

PS700/701/702/703/704，JS12/22/23/43与刀片中心(BladeCenter)的兼容性如下（划√的表示兼容）：

 | PS700 | PS701 | PS702 | PS703 | PS704 | JS12 | JS22 | JS23 | JS43
BCE | √ |  |  |  |  | √ |  |  |
BCT |  |  |  |  |  | √ |  |  |
BCH | √ | √ | √ | √ | √ | √ | √ | √ | √
BCHT | √ | √ | √ | √ | √ | √ | √ | √ | √
BCS | √ | √ | √ | √ | √ | √ | √ | √ | √

突出价值点：每款刀片均被多款刀片中心所支持。这便于客户进行整合。


POWER7刀片服务器中, CIOvCFFh属性的卡都有哪些Features都支持哪些操作系统

解答：

Card Name | Form Factor | Feature Code | Supported OS
 |  |  | PS700/701/702/703/704
Emulex 8GB Fibre Channel | CIOv | 8240 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 4Gb Fibre Channel | CIOv | 8241 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 8GB Fibre Channel | CIOv | 8242 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
Broadcom 2-port Gb Ethernet Expansion Card | CIOv | 8243 | AIX Version 7.1 with Service Pack 2, or later AIX Version 6.1 with the 6100-06 Technology Level with Service Pack 3, or later SUSE Linux Enterprise Server 10 Service Pack 3 for POWER, or later SUSE Linux Enterprise Server 11 Service Pack 1 for POWER, or later Red Hat Enterprise Linux Version 5.5 for POWER, or later Red Hat Enterprise Linux Version 4.8 for POWER, or later IBM i 6.1.1, or later with VIOS 2.2.0, or later IBM i 7.1, or later with VIOS 2.2.0, or later Note: Assignment of this controller to VIOS requires VIOS 2.2 or later.
3Gb SAS Pass-through | CIOv | 8246 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 4Gb Fibre Channel and Broadcom 1 GB Ethernet Combo | CFFh | 8252 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
Mellanox 4X InfiniBand Dual Port | CFFh | 8258 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i not supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 8Gb Fibre Channel | CFFh | 8271 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 2-port 10Gb Converged Network Adapter | CFFh | 8275 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
Broadcom 2/4-port Ethernet Expansion Card | CFFh | 8291 | AIX Version 7.1 AIX Version 6.1 with the 6100-06 Technology Level, or later AIX Version 6.1 with the 6100-05 Technology Level and SP 3, or later AIX Version 6.1 with the 6100-04 Technology Level and SP 7, or later AIX Version 6.1 with the 6100-03 Technology Level and SP 7, or later AIX Version 5.3 with the 5300-12 Technology Level and Service Pack 2, or later AIX Version 5.3 with the 5300-11 Technology Level and Service Pack 5, or later AIX Version 5.3 with the 5300-10 Technology Level and Service Pack 5, or later IBM i 6.1.1, or later with VIOS 2.2.0, or later IBM i 7.1, or later with VIOS 2.2.0, or later SUSE Linux Enterprise Server 10 Service Pack 3 for POWER, or later SUSE Linux Enterprise Server 11 Service Pack 1 for POWER, or later Red Hat Enterprise Linux Version 5.5 for POWER, or later Note: Assignment of this controller to VIOS requires VIOS 2.2 or later.

Top


Power刀片服务器上可选择哪些8Gb的光纤卡

解答：

在JS12和JS22上,可以选择的8Gb光纤卡为:

fc#8271 QLogic 8 Gb Fibre Channel Expansion Card (CFFh)

在JS23，JS43，PS700，PS701，PS702，PS703，PS704上,可以选择的8Gb光纤卡为:

fc#8240 Emulex 8Gb Fibre Channel Expansion Card (CIOv) for IBM BladeCenter

fc#8242 QLogic 8Gb Fibre Channel Expansion Card (CIOv) for IBM BladeCenter

fc#8271 QLogic 8 Gb Fibre Channel Expansion Card (CFFh)

在JS12, JS22, JS23, PS700, PS701，PS703上,最多可以选配一块8Gb光纤卡,在JS43，PS702和PS704上可以选配两块8Gb光纤卡。

突出价值点：JS12, JS22, JS23，JS43，PS700，PS701，PS702，PS703，PS704刀片服务器能够支持8Gb光纤卡，使得数据传输更快，有效降低系统因为数据通道而产生的时延，提高用户体验。

Top


刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

解答:

CIOv/CFFv是标准、横插的PCI槽位，CFFh是高速、竖插的PCI槽位。其中CFFv是PCI-X的，CIOv/CFFh是PCIe的. 当选择BCH刀箱时，CIOv/CFFv的卡与刀箱上bay1/2/3/4上的标准交换/直通模块相连, CFFh的卡与刀箱上bay7/8/9/10上的高速交换/直通模块相连。请参考如下示意图：


POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？

解答：

POWER7系列刀片主板没有集成显卡，也不支持HMC管理，如需对POWER7刀片进行管理，可以通过以下途径：

1.刀片中心上的高级管理模块，适合对刀片服务器硬件进行管理，如远程开关机、查看日志等。

2.通过SOL模式，适合对新装刀片进行管理，如安装操作系统等。

3.通过SSH模式，适合对已有系统的刀片进行管理，如安装软件、服务等。

突出价值点：可通过多种方式对POWER7系列刀片进行管理，提高灵活度。


POWER6

Power 520(8203-E4A)

Power 550(8204-E8A)

Power 595(9119-FHA)


Power 520(8203-E4A)

Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？

Power 520六种硬盘背板的介绍


Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？

解答:

Power 520(8203-E4A)支持两种类型的RAID卡，一种为内置RAID子卡，一种为外插RAID卡。具体介绍如下：

1. 内置RAID子卡：

内置RAID可以使用RAID子卡fc#5679，这个卡支持RAID 0,5,6和10，它不会占用主板的PCI槽位；使用RAID子卡fc#5679做RAID时必须配置DASD背板fc#8345,fc#8346,fc#8340或者fc#8310，它支持硬件RAID 0,5,6和10。支持双路径，假如一个SAS端口出现问题，那么RAID控制器将会自动切换路径到第二个端口去连接磁盘，另外RAID控制器还提供缓存保护功能，不会造成因缓存失效而带来数据的丢失；fc#5679 RAID子卡支持创建热备盘，支持从Array中的磁盘启动。

2. 外插RAID卡：

PCI-X DDR Dual-X4 3GB SAS RAID卡（fc#5902）适用于高性能的应用，使用两个fc#5902通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5902)必须成对配置，其写缓存为175MB。主要可用于连接(fc#5886)EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10；

PCI-X DDR Dual X4 SAS卡fc#5912用于连接POWER6的外部SAS磁盘扩展柜以及I/O抽屉，使用两个fc#5912可以支持连接到SAS磁盘的冗余路径，提供高的系统可用性。主要与fc#5886 EXP12S SAS磁盘扩展抽屉一起使用，支持RAID 0和10。

PCIe Dual-x4 SAS卡（fc#5901）用于连接SAS磁盘扩展柜fc#5886，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF硬盘。支持RAID0 和 RAID 10；

PCIe 380MB Cache Dual - x4 3Gb SAS RAID卡（fc#5903/fc#5805）适用于高性能的应用，使用两个fc#5903/fc#5805通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5903/fc#5805)必须成对配置，其写缓存为380MB。主要可用于连接(fc#5886) EXP12S SAS硬盘扩展柜，或者fc#5802 - PCIe 12X IO抽屉中的SAS SFF硬盘，它支持RAID 0,5,6和10；

PCI-X DDR 1.5GB Cache SAS RAID Adapter(fc#5904),适用于高性能的应用，支持1.5GB的写缓存和1.6GB的读缓存，需要占用两个PCI-X槽位，可用于连接Power 520内置硬盘或者(fc#5886) EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10。

注意：fc#5902和fc#5903的RAID卡已经停产了。由fc#5805替代原有的fc#5903的RAID卡。

突出价值点：Power 520支持多种RAID卡，方便根据需求做适合的选择，增加的RAID功能有效提高了数据的可靠性和访问性能。


Power 520六种硬盘背板的介绍

解答：

Power 520的e-config工具支持六种硬盘背板，分别为:fc#8308，fc#8310，fc#8341，fc#8345，fc#8340和fc#8346。默认的硬盘背板为fc#8340。

下面介绍一下这几种硬盘背板：

fc#8308与fc#8341的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，没有对外的SAS端口，一个5.25英寸的半高的磁带机，fc#8308支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8341是支持IDE的DVD-ROM或者DVD-RAM。

fc#8310与fc#8345的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，一个对外的SAS端口，该端口可以连接一个fc#5886的SAS硬盘笼子（通过fc#3668连接）;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10，通过fc#3670的线支持硬盘背板的分离，一个5.25英寸的半高的磁带机，fc#8310支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8345是支持IDE的DVD-ROM或者DVD-RAM。

fc#8340与fc#8346的硬盘背板相似，支持8块2.5英寸的硬盘（SFF Small Form Factor），一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10;通过fc#3670的线支持硬盘背板的分离，每个通道支持4块硬盘，支持连接SATA的DVD-ROM或者DVD-RAM以及一个5.25英寸的半高的磁带机。

fc#8310,fc#8345,fc#8340或者fc#8346支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3670分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

注意：fc#8341，fc#8345和fc#8346的硬盘背板已经停产，如果要配置3.5英寸的硬盘，需要配置fc#8310或者fc#8308的硬盘背板；如果要配置2.5英寸的硬盘，需要配置fc#8340的硬盘背板。

突出价值点：多种硬盘背板可供选择，更加方便灵活地根据需求做出配置，同时提供了RAID功能的支持。


Power 550(8204-E8A)

Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？

Power 550六种硬盘背板的介绍


Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？

解答:

1. Power 550支持两种类型的RAID卡，一种为内置RAID子卡，一种为外插RAID卡。具体介绍如下：

(1) 内置RAID子卡：

内置RAID可以使用RAID子卡fc#5679，这个卡支持RAID 0,5,6和10，它不会占用主板的PCI槽位；使用RAID子卡fc#5679做RAID时必须配置DASD背板fc#8345,fc#8346,fc#8340或者fc#8310，它支持硬件RAID 0,5,6和10。支持双路径，假如一个SAS端口出现问题，那么RAID控制器将会自动切换路径到第二个端口去连接磁盘，另外RAID控制器还提供缓存保护功能，不会造成因缓存失效而带来数据的丢失；fc#5679 RAID子卡支持创建热备盘，支持从Array中的磁盘启动。

(2) 外插RAID卡

PCI-X DDR Dual X4 3GB SAS RAID卡fc#5902适用于高性能的应用，使用两个fc#5902通过正确的连接到SAS硬盘，可以支持冗余的路径保护，fc#5902必须成对配置。主要可用于连接fc#5886 EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10；

PCI-X DDR Dual X4 SAS卡fc#5912用于连接POWER6的外部SAS磁盘扩展柜以及I/O抽屉，使用两个卡fc#5912可以支持连接到SAS磁盘的冗余路径，提供高的系统可用性。主要与fc#5886 EXP12S SAS磁盘扩展抽屉一起使用，支持RAID 0和10；

PCIe Dual-x4 SAS卡（fc#5901）用于连接SAS磁盘扩展柜fc#5886，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF硬盘。支持RAID0 和 RAID 10；

PCIe 380MB Cache Dual - x4 3Gb SAS RAID卡（fc#5903/fc#5805）适用于高性能的应用，使用两个fc#5903/fc#5805通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5903/fc#5805)必须成对配置，其写缓存为380MB。主要可用于连接(fc#5886) EXP12S SAS硬盘扩展柜，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF 硬盘，它支持RAID 0,5,6和10；

PCI-X DDR 1.5GB Cache SAS RAID Adapter(fc#5904)可以支持RAID 0,5,6和10，使用fc#8310或者fc#8346的背板，通过连接SAS线fc#3679 + SAS线fc#3669来实现第二个LPAR的RAID功能，或者通过SAS y型连接线(fc#3692、fc#3693、fc#3694)连接fc#5886 EXP 12S硬盘扩展柜，实现RAID功能。

2. Power 550不支持内部的SCSI驱动器，也就是不支持内部的SCSI RAID功能；另外，也不支持外部的SCSI RAID功能。

注意：fc#5902和fc#5903的RAID卡已经停产了。由fc#5805替代原有的fc#5903的RAID卡。

突出价值点：Power550支持内置的RAID卡，它不占用PCI槽位，节省了外接I/O的成本。

Top


Power 550六种硬盘背板的介绍

解答：

Power 550的e-config工具支持六种硬盘背板，分别为:fc#8308，fc#8310，fc#8341，fc#8345，fc#8340和fc#8346。默认的硬盘背板为fc#8340。

下面介绍一下这几种硬盘背板：

fc#8308与fc#8341的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，没有对外的SAS端口，一个5.25英寸的半高的磁带机，fc#8308支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8341是支持IDE的DVD-ROM 或者DVD-RAM。

fc#8310与fc#8345的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，一个对外的SAS端口，该端口可以连接一个fc#5886的SAS硬盘笼子（通过fc#3668连接）;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10，通过fc#3669的线支持硬盘背板的分离，一个5.25英寸的半高的磁带机，fc#8310支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8345是支持IDE的DVD-ROM 或者DVD-RAM。

fc#8340与fc#8346的硬盘背板相似，支持8块2.5英寸的硬盘（SFF Small Form Factor），一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10;通过fc#3669的线支持硬盘背板的分离，每个通道支持4块硬盘，支持连接SATA的DVD-ROM或者DVD-RAM以及一个5.25英寸的半高的磁带机。。

fc#8310,fc#8345,fc#8340或者fc#8346支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

注意：fc#8341，fc#8345和fc#8346的硬盘背板已经停产，如果要配置3.5英寸的硬盘，需要配置fc#8310或者fc#8308的硬盘背板；如果要配置2.5英寸的硬盘，需要配置fc#8340的硬盘背板。

突出价值点：多种硬盘背板可供选择，更加方便灵活地根据需求做出配置，同时提供了RAID功能的支持。


Power 595(9119-FHA)

Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同？是否可以混插

Power 595服务器是否支持热节点添加的功能？


Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同？是否可以混插

解答：

Power 595的fc#4695(0/8-core POWER6 5.0GHz CoD , 0-core Active Processor Book)和fc#4705(0/8-core, 64GB Enabled POWER6 5.0GHz CoD , 0-core Active Processor Book)都是5.0GHz 8核的Processor Book，它们之间的区别主要是Processor Book 中的DCA(Distributed Converter Assembly)的区别。(DCA主要用与为Processor Book提供配电和直流转换器的功能)。

fc#4705能提供更强大的DCA功能，因此它能支持fc#5697 - 0/64GB DDR2 Memory(4X16GB) DIMMS, 400 MHz, POWER6 CoD Memory的内存，而fc#4695不能支持fc#5697 64GB的内存。

如果要选择fc#5697 64GB的内存，需要选择fc#4705。

注意：不允许在新购订单(Initial Order)中混用fc#4695和fc#4705两种处理器。

但是可以在升级订单(MES)中混用的，有一个前提条件：系统中不允许有fc#5697或fc#8205(0/64 GB DDR2 Memory)的内存。

客户可以免费将已有的处理器单元fc#4695升级到fc#4705，在升级的同时，也可以新订购fc#4705处理器单元。

突出价值点：Power 595的Processor Book中的DCA提供强大的配电和直流转换功能，使得595最大可以支持4TB的内存，从而为系统提供强大的内存支持。


Power 595服务器是否支持热节点添加的功能？

解答：

是的，Power 595服务器支持热节点添加功能。

IBM Power 595服务器通过新的可靠性、可用性和可维护性功能，增强了客户对支持大型应用程序和大型数据库的能力，其中就包括热节点添加和热节点修复的功能。Power 595服务器现在支持在线增加新的处理器节点到CEC主柜中而整个系统不需要断电（热节点添加）。新增加的处理器节点及其中的内存和GX板卡将在业务运行的同时升级和安装到这个系统中。新增加的资源如处理器等，可以根据需求分配到现有应用中或创建新的分区。Power 595服务器中失败的一个处理器节点现在可以在线地将其移除、修复而整个系统不需要断电（热节点修复）。这种修复是通过使该处理器节点失效并移除。当修复完成后，这个节点可以在线添加回来，并且它的资源可立即用于分配给新的或现有的应用环境。热节点修复的另一个设计理念也是旨在用此方法，可以在线的添加处理器节点内的内存，可以在不断电的情况下，增加内存容量。

需要注意的是，这些功能需要微码版本的支持，对于现有的595服务器，需要系统升级后的固件级别是eFW 3.4.0或更高的版本。

突出价值点：这些功能为Power 595保证了极具竞争优势的可靠性、可用性和可维护性。

Top


POWER7

Power 710/730(8231-E2B)

Power 720/740(8202-E4B/8205-E6B)

Power 750(8233-E8B)

Power 755(8236-E8C)

Power 770(9117-MMB)

Power 780(9179-MHB)

其他


Power 710/730(8231-E2B)

Power 710/730硬盘背板介绍


Power 710/730 硬盘背板介绍

解答：

Power 710/730有三种硬盘背板，它们是fc#5267, fc#5263, fc#5268。其区别如下：

 | fc#5267 | fc#5263 | fc#5268
硬盘槽位数 | 6 | 3 | 6
是否支持DVD | 支持 | 支持 | 支持
是否支持磁带机 | 不支持 | 支持 | 不支持
AIX / Linux support | 支持 | 支持 | 支持
JBOD / RAID 0 | 支持 | 支持 | 支持
RAID 5/6/10 | 不支持 | 不支持 | 支持
背板分离 | 不支持 | 不支持 | 不支持

另外，fc#5268有一个SAS Port，可用来连接fc#5886扩展柜。但是，4-core的Power 710不支持SAS Port。

突出价值点：三种硬盘背板为客户提供了选择的多样性。客户可以根据不同的功能需求来选择相应的硬盘背板。


Power 720/740 (8202-E4B)/(8205-E6B)

Power 720/740支持的PCI槽位信息

Power 720/740硬盘背板介绍

Power720是否支持12X扩展柜？有什么条件 (新增)


Power 720/740支持的PCI槽位信息

解答：

Power 720/740默认支持4个PCIe的槽位，可以支持普通的PCIe的卡。

可以通过内置的PCI扩展柜：fc#5610(PCIe Riser Card (Gen1))/fc#5685(PCIe Riser Card (Gen2))，扩展4个Low-Profile的PCIe槽位。支持Low-Profile的卡；扩展时，只能选择一种类型的PCI扩展柜，这两种类型的PCI扩展柜均占用的是GX++ Slot1的槽位。

如果要扩展PCI-X的卡，需要配置PCI-X的扩展抽屉-fc#5796。一个fc#5796支持6个PCI-X的槽位。

如果要扩展PCIe的卡，需要配置PCIe的扩展抽屉-fc#5802或者fc#5877。一个fc#5802/fc#5877支持10个PCIe槽位。

其中fc#5610为第一代的PCIe Riser Card，fc#5685为第二代的PCIe Riser Card。
与fc#5610上PCIe LP槽位相比，fc#5685的PCIe LP槽位提供了更高的带宽，具体细节如下：
PCIe Gen1: 2.5 GHz (~ 2 GB/sec )
PCIe Gen2: 5.0 GHz (~ 4 GB/sec )
另外，fc#5284 PCIe2 LP 2-Port 10GbE SR Adapter和fc#5286 PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter只能用于fc#5685的PCIe Riser Card上。

注意：

如果是4C的Power 720，只支持配置一个fc#5610/fc#5685，扩展4个PCIe Low-Profile槽位，不支持扩展外置的IO抽屉。
如果是6C或者8C的Power 720，只有一个GX+的槽位可用，此时，要么配置fc#5610/fc#5685，要么配置外置的扩展柜。
如果是4C或者6C的Power 740(一个处理器板的时候)，只有一个GX+的槽位可用，此时，要么配置fc#5610/fc#5685，要么配置外置的扩展柜。

突出价值点：Power 720/740支持PCI-X，PCIe，PCIe Low-Profile这几种类型的PCI槽位，可以根据客户的不同需求，进行PCI槽位的扩展，提高了Power 720/740服务器的扩展能力。


Power 720/740 硬盘背板介绍

解答：

Power 720/740有三种硬盘背板方案，它们是fc#5618, fc#5618+fc#5631, fc#5630。其区别如下：

 | #5618 | #5618+5631 | #5630
硬盘槽位数 | 6 | 3+3 | 8
是否支持DVD | 支持 | 支持 | 支持
是否支持磁带机 | 支持 | 支持 | 支持
AIX / Linux support | 支持 | 支持 | 支持
JBOD / RAID 0 | 支持 | 支持 | 支持
RAID 10 | 不支持 | 部分支持注 | 支持
RAID 5/6 | 不支持 | 不支持 | 支持
背板分离 | 不支持 | 支持 | 不支持

注：RAID 10 only on the 3 drives associated with fc#5631。

另外，fc#5630有一个SAS Port，可用来连接fc#5886扩展柜。

突出价值点：三种硬盘背板方案为客户提供了选择的多样性。客户可以根据不同的功能需求来选择相应的硬盘背板方案。


Power 720是否支持12X扩展柜？有什么条件

解答:

Power 720只有1块处理器卡，支持4-core/6-core/8-core。

其中：

4-core的不支持12X扩展柜，最大支持64 GB内存。

6－core/8-core支持一个12X环路，连接相应12X扩展柜，最大支持128GB内存。


Power 750(8233-E8B)

Power 750(8233-E8B)硬盘背板的介绍

Power 750/755的区别 (最近更新)

Power 750(8233-E8B)的硬件特性 (最近更新)


Power 750(8233-E8B)硬盘背板的介绍

解答:

Power 750，只支持一种类型的硬盘背板：fc#8340。

该硬盘背板fc#8340与Power 520和Power 550上的fc#8346硬盘背板相似。

支持8块2.5英寸的硬盘(SFF Small Form Factor)；

一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子；

配合fc#5679的内置RAID子卡，可以提供内部硬盘的RAID功能，支持RAID 0,5,6和10；

通过fc#3669和fc#3679的SAS线支持硬盘背板的分离，每个通道支持4块硬盘；

支持连接SATA的DVD-RAM以及一个5.25英寸的半高的磁带机。

fc#8340支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

突出价值点：该硬盘背板为POWER7产品发布时新推出的硬盘背板，可以实现内置硬盘的背板分离和内置硬盘的RAID功能。


Power 750/755的区别

Power 750和Power 755的区别

解答:

Power 750和Power 755的区别如下表：

Feature | Power 755 | Power 750
OS | AIX, Linux | AIX, IBM i, Linux
Processors | 32-core @ 3.3 GHz or 3.6GHz 4 Sockets | 8, 16, 24, 32 Core at 3.0 GHz,3.2 GHz, 3.3GHz,3.55GHz,3.6GHz 6，12，18，24 Core at 3.7GHz 1-4 Sockets
Memory | 128 – 256 GB 4GB & 8GB DIMMS | 8 – 512 GB 4GB, 8GB, 16GB DIMMS
GX slot support | Yes 1 GX++ for IB clustering only | Yes, 1 GX+ & 1 GX++ for IB clustering or for I/O drawer expansion
175 MB Cache RAID | No | Yes
Split Backplane | No | Yes
Integrated Ethernet | Quad GbE or Dual 10GbE | Quad GbE or Dual 10GbE
Virtualization | No PowerVM support | PowerVM Express, Standard and Enterprise
DASD / Bays | 8 SFF SAS HDD /10k and 15K SFF drives SDD | 8 SFF SAS HDD / SDD 10k and 15K SFF drives
Internal Tape | No | Yes
Performance Metric | TFLOPS | rPerf, CPW
Active Memory Expansion | No | Yes
Target Workloads | HPC:Weather/Climate modeling, computational chemistry, physics, prtroleum reservoir modeling | Commercial:DB, Virtualized app servers and consol of comp UNIX and Linux apps

突出价值点：Power 750和755均为POWER7的服务器，这两款产品分别支持不同的运用环境。其中：Power 755比较适合于中小型，高强度的并行运算工作和算法，效率高，操作性强，其主要针对运行高度并行的计算密集型工作负载和算法而优化，例如天气与气候建模、计算化学、物理和石油储量建模等。而Power 750主要适用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器；用于中到大型数据库服务器。


Power 750(8233-E8B)的硬件特性

解答:

下面是Power750(8233-E8B)的硬件特性表：

处理器 | POWER7处理器 3.0 GHZ 8/16/24/32 Core 3.3 GHZ 8/16/24/32 Core 3.5 GHZ 8/16/24/32 Core 3.2 GHZ 8/16/24/32 Core 3.6 GHZ 8/16/24/32 Core 3.7 GHZ 6/12/18/24 Core
内存 | 最多512 GB的DDR3内存
SAS硬盘槽位 | 8个2.5寸的SFF硬盘槽位 (Opt: cache & RAID-5/6)
PCI内存插槽 | PCIe x8: 3个 PCI-X DDR: 2个
GX插槽 | 最多2个（与PCIe共享槽位）
集成的SAS/SATA控制器 | 是
系统集成端口 | 3个USB口, 2个Serial口, 2个HMC口
集成的虚拟以太网(IVE)卡 | 两种可选的IVE卡： 4端口的千兆以太网卡 双端口的万兆以太网卡
内置媒体槽位 | 1个DVD槽位 1个磁带机槽位
IO抽屉数量 | PCIe I/O抽屉：最多4个 PCI-x I/O抽屉：最多8个
级联 | 12X SDR/DDR (InfiniBand技术)
冗余电源 | 是

突出价值点：Power 750采用POWER7技术，在性能和能耗方面有着突出的表现，是数据库服务器和应用服务器的理想选择。


Power 755(8236-E8C)

Power 755(8236-E8C)的产品定位与硬件特性 (最近更新)


Power 755(8236-E8C)的产品定位与硬件特性

解答:

Power 755面向中小型的集群环境，最多支持64个节点的集群。（而Power 575面向大型和超大型的集群环境）

Power 755的硬件特性如下表所示：

处理器 | POWER7处理器 3.3 GHZ 32 Core 3.6 GHZ 32 Core
内存 | 最多256 GB的DDR3内存
SAS硬盘槽位 | 8个2.5寸的SFF硬盘槽位
PCI内存插槽 | PCIe x8:3个 PCI-X DDR:2个
GX插槽 | 1个（与PCIe共享槽位）
系统集成端口 | 3个USB口, 2个Serial口, 2个HMC口
集成的虚拟以太网(IVE)卡 | 两种可选的IVE卡： 4端口的千兆以太网卡 双端口的万兆以太网卡
内置媒体槽位 | 1个DVD槽位 （没有内置的磁带机槽位）
集群 | 多达64个节点 （通过Ethernet 或InfiniBand进行集群）
冗余电源 | 是
性能 | 0.84 TFlops

突出价值点：与Power 575一样，Power 755每个节点为32处理器核心。但相比Power 575节点，Power 755节点的性能高40%，耗电量降低2/3，占地面积减少37%。


Power 770(9117-MMB)

Power 770/780的区别

Power 770/780硬盘背板介绍

Power 770(9117-MMB)的硬件特性

将Power 770/780放到T42机柜里，有哪些限制？


Power 770/780的区别

解答:

Power 770和Power 780服务器的主要区别如下：

1) 处理器：

Power 770提供了一个单一处理器的选择：6 Core 3.5GHz；
Power 780提供了一个单一处理器的选择，但可以运行在的MaxCore模式或TurboCore模式，每个处理器板支持：
MaxCore模式 - 8 Core 3.86GHz
TurboCore模式 - 4 Core 4.14GHz

2) 软件授权级别：

Power 770 - Medium
Power 780 - Large

此外，Power 780服务器为客户提供了一个免费的PowerCare服务。

突出价值点：Power 770优化各种类型的商业工作负载；Power 780新一代的高端服务器，具有先进模块化设计和 POWER7 TurboCore 模式。


Power 770/780硬盘背板介绍

解答:

Power 770/780硬盘背板信息介绍如下：

1)Power 770/780每个CEC单元的硬盘背板支持6块2.5寸的SFF硬盘。每个硬盘背板有两个SAS控制器，每个控制器各控制3块硬盘，支持RAID 10。因此，Power 770/780每个CEC单元的6块内置磁盘默认支持两个分区(LPAR)，每个分区3块硬盘。如下图所示：

2)Power 770/780的硬盘背板也支持增加第三个SAS控制器(需要添加fc#5901和fc#1815)。在这种情况下，每个控制器控制2块硬盘，支持RAID 10。此时Power 770/780每个CEC单元的6块内置磁盘支持三个分区(LPAR)，每个分区2块硬盘。如下图所示：

3) Power 770/780的硬盘背板也支持不被分离，SAS控制器同时控制六块硬盘。通过添加fc#5662，给这六块盘做RAID 5和RAID 6。如下图所示：

4) 当Power 770/780的硬盘背板不被分离时，可以通过集成的SAS Port连接一个fc#5886扩展柜。此时需要添加fc#5662和fc#1819。如下图所示：

注意：在一个CEC抽屉内，如果硬盘背板设置为2分（没加内置RAID卡时的缺省状态）或者3分磁盘链路，在不同磁盘链路上可以分别配置SSD和HDD硬盘。但是在同一磁盘链路里不可以混配。

突出价值点：Power 770/780每个CEC单元的硬盘背板使用起来很方便，可以根据客户的不同需求进行相应的配置。

Top


Power 770(9117-MMB)的硬件特性

解答:

Power 770是POWER7家族最新推出的一款中高端服务器，是中高端数据库服务器和应用服务器的极佳选择。

下面是Power 770的硬件特性表：

Power 770
Processor Technology | 6 Cores@3.5 GHz
L3 Cache | On Chip
Redundant Power&Cooling | Yes
Redundant Server Processor | Yes/Two Enclosure minimum
Redundant Clock | Yes/Two Enclosure minimum
Concurrent Add Support | Yes
Concurrent Service | Yes
System Unit | Single Enclosure | 4 Enclosures
Processors | Up to 2 Sockets | 8 Sockets
DDR3 Memory (Buffered) | Up to 512 GB | Up to 2 TB
SAS/SSD SFF Bays | 6 | 24
DVD-RAM Media Bays | 1 Slim-line | 4 Slim-line
SAS / SATA Controller | 2/1 | 8/4
PCIe bays | 6 PCIe | 24 PCIe
GX++ Slots (12X DDR) | 2 | 8
Integrated Ethernet | Std: Quad 1Gb Opt: Dual 10Gb + Dual 1 Gb | Std: Four Quad 1Gb Opt: Four x Dual 10Gb + Dual 1 Gb
USB | 3 | 12
12X I/O Drawers w/ PCI slots | Max: 4 PCIe, 8 PCI-X | Max: 16 PCIe, 32 PCI-X

突出价值点：Power 770采用POWER7技术，它集中高端服务器和POWER7家族的优点于一身，是数据库服务器和应用服务器的理想选择。


将Power 770/780放到T42机柜里，有哪些限制？

解答：

将Power 770/780放到机柜里时，因为7014-T42/B42, 或 fc#0553机柜在EIA 37(第37U)的底部有一处凸起，为了不跟前面板或前边弯曲的连接线冲突，一台Power 770或780不能同时占据EIA 36(第36U)和EIA 37(第37U)的位置。


Power 780(9179-MHB)

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780(9179-MHB)的硬件特性


Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么，它们有什么区别， 各有什么特点

解答:

MaxCore Mode与TurboCore Mode是Power 780服务器的一个技术亮点，它们是指POWER7处理器的两种不同的工作模式，其中TurboCore模式能够选择优化系统的频率和高速缓存利用率，从而为数据库和事务工作负载提供每内核最高性能。

在MaxCore Mode下，处理器主频为3.86GHz，所有的处理器都是激活的，L3级缓存平分给所有的处理器，即4MB每处理器；在TurboCore Mode下，服务器自动优化系统的频率和高速缓存利用率，此时处理器主频为4.14GHz，处理器有一半是激活的，L3级缓存平分给所有激活的处理器，即8MB每处理器，这使得单个处理器获得的L3级缓存是MaxCore Mode下的两倍，并结合处理器主频的提升从而使得单个处理器的运算能力相当于POWER6处理器的1.5倍，并降低了机器的耗电量。请注意，目前在POWER7的其它机型上还不支持TurboCore Mode。

突出价值点:TurboCore模式能够选择优化系统的频率和高速缓存利用率，从而为数据库和事务工作负载提供每内核最高性能。


Power 780(9179-MHB)的硬件特性

解答:

Power 780是POWER7家族最新推出的一款中高端服务器，是中高端数据库服务器和应用服务器的极佳选择。T42机柜可以配置fc#6250带有Power 780标示的机柜。

下面是Power 780的硬件特性表：

Power 780
Processor Technology | 4 Cores@4.14 GHz TurboCore 8 Cores@3.86 GHz
L3 Cache | On Chip
Redundant Power & Cooling | Yes
Redundant Server Processor | Yes/Two Enclosure minimum
Redundant Clock | Yes/Two Enclosure minimum
Concurrent Add Support | Yes
Concurrent Service | Yes
System Unit | Single Enclosure | 4 Enclosures
Processors | 2 Sockets | 8 Sockets
DDR3 Memory (Buffered) | Up to 512 GB | Up to 2 TB
SAS/SSD SFF Bays(CEC) | 6 | 24
DVD-RAM Media Bays | 1 Slim-line | 4 Slim-line
SAS / SATA Controller | 2/1 | 8/4
PCIe (CEC) | 6 PCIe | 24 PCIe
GX++ Slots (12X DDR) | 2 | 8
Integrated Ethernet | Std: Quad 1Gb Opt: Dual 10Gb + Dual 1 Gb | Std: Four Quad 1Gb Opt: Four x Dual 10Gb + Dual 1 Gb
USB | 3 | 12
12X I/O Drawers w/ PCI slots | Max: 4 PCIe, 8 PCI-X | Max: 16 PCIe, 32 PCI-X

突出价值点：Power 780采用POWER7技术，它集中高端服务器和POWER7家族的优点于一身，是数据库服务器和应用服务器的理想选择。


POWER7-其他

其他

哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因 (最近更新)

POWER7的主要技术特点？

POWER7服务器与POWER6的主要区别有哪些

IBM eDRAM技术的特别之处是什么

介绍POEWR7处理器的缓存信息

什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

请简要介绍一下POWER7处理器的主要创新技术

POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡

Power 710/720/730/740/750/755/770/780支持的PCI槽位信息

Power 710/730/720/740硬件参数对比(最近更新)

POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)

fc#2319 Factory Deconfiguration of 1-core的介绍 (最近更新)

Power 710/720/730/740/750,订购fc#2319关闭处理器之后，如何来重新激活处理器 (新增)

POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug


哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因

解答:

所有POWER7机器皆可支持Active Memory Expansion。需要在购买服务器时选购该Feature Code。

具体信息如下：
PS700/701/702/703/704：fc#4796；
Power 710/730：fc#4795；
Power 720：fc#4793；
Power 740：fc#4794；
Power 750：fc#4792；
Power 770/780：fc#4791。

使用该功能，不需要配置PowerVM功能。因为该功能是在分区内部运行过程中对内存进行部分压缩、优化管理，来提高可用内存的，本身并不涉及分区间的资源动态分配。

另外，我们知道，POWER7 server可以运行在 POWER6模式或POWER7 模式下。需要注意，如果要使用Active Memory Expansion，POWER7 server需要运行在 POWER7 模式下。

其对操作系统和硬件的最低要求为：
1. HMC: V7R7.1.0.0
2. eFW: 7.1
3. AIX: 6.1 TL4 SP2

所以，如果定购server时只选定了AIX v5.3，则在system-->memory下，Active Memory Expansion 的Feature Code会自动隐藏，而无法选购。


POWER7的主要技术特点？

解答:

POWER7的主要特性如下：

* 芯片面积567mm2: 45nm 硅绝缘、铜互联制造工艺, eDRAM

* 相当于27亿个晶体管的处理能力

* 实际使用12亿个晶体管

* eDRAM技术使能耗使用效率提高

NOTE: Nahalem使用了23亿个晶体管

* 8个处理器内核

* 每核12个执行单元

* 每核4路SMT

* 每芯片32个线程

* 每核256KB二级缓存

* 片内32MB共享的eDRAM三级缓存

* 双DDR3内存控制器

* 每芯片100GB/s内存带宽

* 可扩展到32个芯片互联

* 每芯片360GB/s SMP带宽

* 可以同时维持20000个缓存一致性操作

* 硬件指令和数据预取

* 与POWER6二进制兼容

* 第四代的SMP总线构架

* 第三代多线程技术-SMT4

突出价值点：这是一款“划时代”的产品，专为“智慧地球”打造，重新定义业界对性能的观点，POWER7处理器的诞生为小型机开启了新纪元。


POWER7服务器与POWER6的主要区别有哪些

解答:

POWER7和POWER6服务器的基本设计没有根本性的不同，但也有以下的区别：

*POWER6每芯片封装2个处理器，POWER7每芯片封装8个处理器；

*为满足CPU的吞吐量，内存带宽及内存容量都随之增加；

*更多的IO处理来满足数据到内存的请求 - POWER7将利用当前最新的IO抽屉，计划每台服务器支持更多的IO抽屉。

突出价值点：在性能、新技术、绿色节能上POWER7完全超越了现在的POWER6，成为RISC处理器新的王者。


IBM eDRAM技术的特别之处是什么

解答:

IBM eDRAM技术的特点如下：

*优点：大密度，更低的功耗要求，更少的软错误，以及更好的性能；

*提高了处理器芯片内内存的性能，与传统的SRAM（静态随机存取内存）相比，只需约三分之一的空间和五分之一的功耗；

*更少的晶体管，更低的功耗需求；

*全新的、处理器芯片内的SOI内存技术/提供了有史以来最快的访问速度；

*对于较大的缓存容量，与目前处理器芯片内的SRAM相比，eDRAM提供了更好的性能。

突出价值点："IBM is effectively doubling microprocessor performance beyond what classical scaling alone can achieve,” said Dr. Subramanian Iyer, DE (Distinguished Engineer).


介绍POWER7处理器的缓存信息

解答:

一级缓存：32KB的指令缓存，32KB的数据缓存；

二级缓存：256KB/处理器核心，即2MB/处理器芯片；

三级缓存：8个处理器核心共享32MB的三级缓存。

与POWER6处理器不同，POWER7处理器把三级缓存从芯片外移动到了芯片内部，采用片上的eDRAM(嵌入式的动态随机存储器)技术。

突出价值点：1)相比POWER6处理器的二级缓存，POWER7处理器的二级缓存与处理器核心结合得更紧密，因此，POWER7二级缓存几乎能达到一级缓存的速度。
2)由于采用了片上的eDRAM作为三级缓存，POWER7处理器的三级缓存几乎能达到POWER6二级缓存的速度，而且比POWER6三级缓存的软错误率更低。
3)由于采用了更好的设计理念和技术，POWER7的缓存能为客户带来更高的价值(速度更快/带宽更大/软错误率更低)。


什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

解答:

Thermal Power Management Device(TPMD)是服务器内的一个硬件模块,由一个微处理器和数据收集模块组成, 通过它使用能源管理软件可以收集服务器的功耗和温度状态，从而调节机器的处理器主频和内存使用率,进而降低服务器的功耗和温度。

POWER6和POWER7服务器都有TPMD模块。

当服务器的功耗和温度超过上限值时,TPMD会降低处理器的电压和主频或是强制释放部分内存,从而降低服务器的能量消耗和温度；当功耗和温度低于上限时,TPMD会允许处理器根据应用的需要而超频运行。

突出价值点:TPMD动态调节服务器的处理器主频和内存使用率,从而降低服务器的功耗和温度。


请简要介绍一下POWER7处理器的主要创新技术

解答:

POWER7处理器的主要有四种创新技术：

1、IBM独有eDRAM 技术：

.只需要传统SRAM 1/3的空间，1/5的电力，同时降低250倍的错误几率，减少1.5B晶体管；
.实现POWER7 on-chip 32MB L3缓存，较片外缓存延迟只有1/6，带宽提升2倍，实现POWER7高性能。

2、SMT4智能并发多线程：

.根据不同模式，智能支持SMT1, SMT2, SMT4，最大限度利用处理器资源；
.当负载能够受益于多线程时，SMT2模式较SMT1提升50%，SMT4模式较SMT1提升80%。

3、TurboCore Mode：

.每核处理器的L3缓存增加一倍，带宽增加一倍，主频提升至4.1GHz，性能较POWER6每核提升50%以上；
.为数据库应用获得每核处理器最大性能，降低license成本。

4、Active Memory Expansion：
.在POWER7系统上，可以有效扩展达100%的物理内存；
.使POWER7系统具有更强大的整合能力，为SAP等应用提供更多的内存。


POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

解答：

基于 POWER7 的系统针对分区提供 2 种模式：P6/P6+模式和P7模式。其区别如下表所示：

P6 / P6+ MODE | P7 MODE | Customer Value
2-Thread SMT | 4-Thread SMT | 吞吐能力、CPU 利用率
8 Storage Keys | 32 Storage Keys | RAS、数据隔离的颗粒度、提升应用键的使用
VMX (Vector Multimedia Extension / AltiVec) 支持单精度浮点运算，不支持双精度浮点运算 | VSX (Vector Scalar Extension) 支持双精度浮点运算 | 高性能计算
Affinity OFF by Default | 3-tier Memory, MicroPartition Affinity | 提升系统性能
64-core/128-thread Scaling | 32-core / 128-thread Scaling 64-core / 256-thread Scaling 256-core / 1024-thread Scaling | 高可扩展、服务器整合
EnergyScale CPU Idle | EnergyScale CPU Idle and Folding with NAP and SLEEP | 提升能源效率
N/A | Active Memory Expansion | 扩展内存容量

同一台POWER7服务器内的不同LPAR可以运行在不同模式下。

突出价值点：POWER7服务器针对分区提供P6/P6+和P7两种模式，而且同一台POWER7服务器内的不同LPAR可以运行在不同模式下。这给了用户很大的灵活性。

Top


Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡

解答：

LP是Low profile的缩写，LP适配卡是比原来POWER服务器常见的普通PCI卡的高度要矮。LP卡只能插在LP插槽上使用。目前只有Power 710/730上，和选配了LP插槽的Power 720/740上能够使用LP适配卡。

目前有13款LP卡发布，每块LP卡都有对应的完全相同电器特性的普通卡对应，区别仅仅是卡的挡板高度。如下：

fc#2053 PCIe LP RAID & SSD SAS Adapter 3Gb (fc#2054/2055)
fc#5269 PCIe LP POWER GXT145 Graphics Accelerator (fc#5748)
fc#5270 PCIe LP 10Gb FCoE 2-port Adapter (fc#5708)
fc#5271 PCIe LP 4-Port 10/100/1000 Base-TX Ethernet Adapter (fc#5717)
fc#5272 PCIe LP 10GbE CX4 1-port Adapter (fc#5732)
fc#5273 PCIe LP 8Gb 2-Port Fibre Channel Adapter (fc#5735)
fc#5274 PCIe LP 2-Port 1GbE SX Adapter (fc#5768)
fc#5275 PCIe LP 10GbE SR 1-port Adapter (fc#5769)
fc#5276 PCIe LP 4Gb 2-Port Fibre Channel Adapter (fc#5774)
fc#5277 PCIe LP 4-Port Async EIA-232 Adapter (fc#5785)
fc#5278 PCIe LP 2-x4-port SAS Adapter 3Gb (fc#5901)
fc#5284 PCIe2 LP 2-port 10GbE SR Adapter
fc#5286 PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter

其中fc#5284和fc#5286只能用于fc#5685的PCIe Riser Card上，其他的PCIe LP卡既可用于fc#5610，又可用于fc#5685。


Power 710/720/730/740/750/755/770/780支持的PCI槽位信息

解答：

机型 | 710/730 | 720 | 740 | 750 | 755 | 770/780
系统抽屉内PCI槽位 | 4 PCIe LP** | 4 PCIe + 4 PCIe LP(通过PCIe Riser Card,可选) | 4 PCIe + 4 PCIe LP(通过PCIe Riser Card,可选) | 2 PCI-X + 3 PCIe | 2 PCI-X + 3 PCIe | 6 PCIe/CEC Max 24 PCIe
是否支持PCIe Riser Card * | No | Yes | Yes | No | No | No
是否支持I/O扩展柜 | No | Yes | Yes | Yes | No | Yes
最大PCI槽位(用PCI-X 12X扩展柜) | 4 PCIe LP | 24 PCI-X+ 4 PCIe | 48 PCI-X + 4 PCIe | 50 PCI-X + 1 PCIe | 2 PCI-X + 3 PCIe | 24 PCIe + 192 PCI-X
最大PCI槽位(用PCIe 12X 扩展柜) | 4 PCIe LP | 24 PCIe | 44 PCIe | 2 PCI-X + 41 PCIe | 2 PCI-X + 3 PCIe | 184 PCIe

* PCIe Riser Card会占用掉一个GX++槽位。
** LP: Low Profile。


Power 710/730/720/740硬件参数对比

解答：

 | Power 710 | Power 720 | Power 730 | Power 740
Footprint, packaging | 2U rack | 4U rack, tower | 2U rack | 4U rack, tower
Number of processor sockets | 1 | 1 | 2 | 1 or 2
Number of cores | 4, 6, 8 | 4, 6, 8 | 8, 12, 16 | 4, 6, 8, 12, 16
GHz clock | 3.0, 3.7, 3.55 | 3.0 | 3.0, 3.7, 3.55 | 3.3, 3.7, 3.55
Max GB memory | 64GB | 64 (4-core) 128 (6/8-core) | 128 | 256
Max disk storage in system unit | 1.8TB | 2.4TB | 1.8TB | 2.4TB
PCI slots in system unit | PCIe LP: 4 | PCIe: 4+4LP | PCIe LP: 4 | PCIe: 4+4LP
LPARs | 80 | 80 | 160 | 160
12X I/O Drawers | No | 4-core No 6/8-core Yes | No | Yes
Disk-only I/O drawers (#5886) | 4-core No 6/8-core Yes | 4-core No 6/8-core Yes | Yes | Yes
Power requirements | 100-240VAC | 100-240VAC | 200-240VAC | 200-240VAC


POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)

解答：

Power710/720/730/740支持IVM的管理。

管理PowerVM的分区可以使用PowerVM内置的IVM软件或通过一个硬件管理控制台(HMC)。 IVM易于使用，有助于减少管理虚拟设备、处理器和分区所需的时间和精力。 HMC对于低端服务器并不是个必选的设备，但HMC可以支持更多的虚拟分区和更高的整体系统管理和控制水平。

突出价值点：低端服务器可以通过PowerVM集成的IVM实现一定的虚拟化功能，帮助客户节省成本。


fc#2319 Factory Deconfiguration of 1-core的介绍

解答：

这个fc#2319 适用于以下POWER7的服务器：Power 710，Power 730，Power 720，Power 740和Power 750。

fc#2319 - Factory Deconfiguration of 1-core，是工厂deconfiguration 1核的处理器来优化的软件授权。fc#2319的最大数量是所购买服务器的物理处理器数量减一，例如：对于4 core的系统，fc#2319最大为3；对于6 core的系统，fc#2319最大为5；对于8 core的系统，fc#2319最大为7；对于32 core的Power 750，fc#2319最大为31；此时只需购买1core的软件授权，比如AIX的授权，便于客户降低初期软件成本。

突出价值点：使得入门级客户以更低的软件成本，选择更适合的服务器。


Power 710/720/730/740/750,订购fc#2319关闭处理器之后，如何来重新激活处理器

解答:

需要两个步骤来重新激活处理器：

1. 通过e-config下一个MES订单，MES中减少相应fc#2319的数量，相关软件的处理器授权也同时会加上来。走下MES订单流程。

2. 服务器管理员通过ASMI来把关闭的处理器激活，详细操作步骤请查询IBM InfoCenter。


POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug

解答:

POWER7 Server中，目前已发布并可下单的非刀片式Server主要有Power 710/720/730/740/750/755/770/780。

其中，Power 750/755/770/780上所有的PCI Slot都是支持Hotplug的。12X I/O扩展抽屉上的PCI Slot也支持Hotplug。但是需要注意，IVE和集成SAS RAID子卡是不支持Hotplug的。

关于Power 710/720/730/740，系统抽屉内的PCI Slot目前不支持Hotplug。Power 720/740 系统抽屉内可以选配的附加4个PCIe Low Profile Slot也不支持Hotplug。但是，Power 720/740可以通过GX++卡来扩展12X I/O抽屉，12X I/O扩展抽屉上的PCI Slot支持Hotplug。


IO Drawer

什么是EXP 12S磁盘柜（产品号fc#5886）？可以用什么主机卡来连接它？是否有冗余电源和风扇？12S支持什么硬盘

SFF Storage I/O drawer fc#5887介绍 (新增)

fc#5887支持的分区数量？是否可以手动修改其分区的磁盘模式 (新增)

Power服务器I/O Drawer硬件特性及介绍

Power 595支持哪些I/O抽屉，各有什么特点


什么是EXP 12S磁盘柜（fc#5886）？可以用什么主机卡来连接它？是否有冗余电源和风扇？12S支持什么硬盘

什么是EXP 12S磁盘柜(fc#5886)? 可以用什么主机卡来连接它？ 是否有冗余电源和风扇? 12S支持什么硬盘

解答:

EXP 12S磁盘柜是19英寸标准机柜宽、2U高，内部可插入12块3.5英寸SAS热插拔磁盘的磁盘柜。

POWER6/POWER7/P5服务器通过SAS卡连接到EXP 12S来使用。EXP 12S可以在POWER6/POWER7服务器里定购，也可以在P5服务器升级的时候订购。产品号为fc#5886。在POWER6/POWER7服务器中配置fc#5912/fc#5901 SAS卡，fc#5805的SAS RAID卡，或者fc#5904/fc#5908/fc#5906 1.5GB缓存的SAS RAID卡来连接EXP 12S磁盘柜；在P5的服务器中，可以通过fc#5912的SAS卡，或者fc#5902的SAS RAID卡进行连接。

一个fc#5912/fc#5901最多可以连接4个EXP 12S磁盘柜。fc#5805需成对配置，一对fc#5805 SAS RAID卡最多可以连接4个EXP 12S磁盘柜。fc#5904/fc#5906/fc#5908 SAS RAID卡最多可连接5个EXP 12S磁盘柜。

Power 520如果配1个CPU（fc#5633），则不能连fc#5886 SAS磁盘柜；
Power 520最多可连接24个fc#5886 SAS磁盘柜；
Power 550最多可连接48个fc#5886 SAS磁盘柜；
Power 560最多可连接110个fc#5886 SAS磁盘柜；
Power 570最多可连接110个fc#5886 SAS磁盘柜；
Power 595最多可连接185个fc#5886 SAS磁盘柜。

Power 710/720如果配置4个CPU(fc#8350),则不能连fc#5886 SAS磁盘柜；
Power 710/730最多可连接8个fc#5886 SAS磁盘柜；
Power 720/740最多可连接28个fc#5886 SAS磁盘柜；
Power 750最多可连接48个fc#5886 SAS磁盘柜；
Power 755最多可连接13个fc#5886 SAS磁盘柜；
Power 770最多可连接110个fc#5886 SAS磁盘柜；
Power 780最多可连接110个fc#5886 SAS磁盘柜。

EXP 12S磁盘柜基本配置中已经含有冗余电源和风扇了。EXP 12S支持目前POWER6/POWER7服务器的3.5英寸内部SAS硬盘。

目前，Power 520/550/560/570/595/710/720/730/740/750/755/770/780上可配的硬盘有：

fc#3647(146GB) 15000转SAS硬盘。

fc#3648(300GB) 15000转SAS硬盘。

fc#3649(450GB) 15000转SAS硬盘。

fc#3586(69GB)SAS SSD硬盘，最大支持8块SSD硬盘。

突出价值点：fc#5886为POWER6/POWER7服务器提供3.5英寸SAS硬盘扩展的硬盘抽屉；目前，P5的SCSI硬盘都已经停产，如果客户需要对P5服务器的硬盘升级，可以通过配置fc#5886来实现SAS硬盘的扩容。


SFF Storage I/O drawer fc#5887介绍

解答:

fc#5887是一个2U高的SAS硬盘扩展柜，可支持24块SAS SFF硬盘，没有PCIe槽位。该扩展柜支持POWER6/POWER7服务器。
单个fc#5887可以支持1/2/4个分区。

1）做一个分区的情形：24块盘全属同一个分区：

2）做两个分区的情形：每个分区各12块盘：

3）做四个分区的情形：每个分区各6块盘：

突出价值点：
1）IBM发布的fc#5887，填补了专门放SFF小盘的硬盘扩展柜方面产品的空白。
2）fc#5887支持多个分区，对客户很有意义。


fc#5887支持的分区数量？是否可以手动修改其分区的磁盘模式

解答:

fc#5887 EXP24S可以支持1(mode 1)、2(mode 2)、4(mode 4)个硬盘通道，即支持最大四个AIX或Linux的分区，此时需要fc#5887扩展柜配置订购成Mode 4模式。

注意：截止到此FAQ撰写时（2011年4月），此fc#5887扩展柜与fc#5802或fc#5803这样的I/O扩展柜并不相同，EXP24S的磁盘模式是不能在现场手动更改的。扩展柜的磁盘模式是在制造过程中设置，没有选项可以在现场调整。因此，请仔细规划后再下单订货。请注意，多分区选项并不支持IBM System i。

突出价值点：新的硬盘扩展柜支持分区的配置，更加灵活，但请仔细规划后订购。


Power服务器I/O Drawer硬件特性及介绍

解答：

在09年新推出来的四种IO抽屉：fc#5802，fc#5877，fc#5803,fc#5873均可以支持POWER6和POWER7的服务器。下面将对这几种IO抽屉进行介绍：

fc#5802 PCIe 12X I/O Drawer：

硬件特性：

fc#5802为4U 高，19英寸宽的包含10个PCIe槽位和18个SFF SAS硬盘的I/O抽屉。
fc#5802 的宽度为17.5英寸宽（444.5mm），高度为7英寸（177.8），深度为28英寸深（711.2mm）。是可以放在19英寸标准机柜里面的。
下图为fc#5802的前视图和后视图:

槽位信息：

10个PCIe 槽位，其速度是：2.5 GB/sec
18个硬盘槽位，支持热插拔，可以支持一个、两个或四个分区。
如果是一个分区，需配置一个PCIe SAS 硬盘控制器；
如果是两个分区，每个分区放置9块硬盘；此时需要配置两个PCIe SAS 硬盘控制器；
如果是四个分区，各个分区的硬盘数分别是：5 / 4 / 4 / 5 块；此时需要配置四个PCIe SAS 硬盘控制器；

fc#5802的硬件要求和软件要求：

硬件要求：Power 520/550/560/570/720/740/750/770/780
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7

配置fc#5802的注意事项:

fc#5802 的最小配置是：2根12X DDR 线缆，2根直流电电源线和2根SPCN（为了保证适当的冗余）线缆。fc#5802和主机系统柜的连接，还需要在系统柜的GX槽位上安装12X 适配器，以及连接所用的12X线缆：1.5米（fc#1862），3.0米（fc#1865），或者8米（fc#1864）。不支持 12X SDR 线缆。
一个12X 的环路里可以做多配置两个fc#5802。
不支持fc#5802和fc#5796/7314-G30混合在一个环路里。

和fc#5796 的比较：

fc#5802提供了约为fc#5796两倍的带宽；
fc#5802的PCIe槽位的速度约为fc#5796的PCI-X槽位的速度的两倍；
一个fc#5802比一个fc#5796多提供了四个PCI槽位;
每个环路最多放置两个fc#5802，每个环路最多放置四个fc#5796；
fc#5802还提供了十八块硬盘槽位，而fc#5796没有；(且不同于以前的fc#5886，fc#5802可以支持多个分区)
fc#5802放置更新技术的SAS SFF硬盘

fc#5877 PCIe 12X I/O Drawer：

硬件特性：

fc#5877为4U 高，19英寸宽的包含10个PCIe槽位的I/O抽屉。无硬盘槽位。是可以放在19英寸标准机柜里面的。如下图所示：

如果客户只想扩展PCIe插槽，而不想扩展SFF硬盘槽位，那么fc#5877是很好的选择。相比fc#5802, fc#5877的价格和维护费更低。

fc#5877的硬件要求和软件要求：

硬件要求：Power 520/550/560/570/720/740/750/770/780
软件要求：操作系统为AIX 5.3及以上，IBM i 6.1.1及以上，Linux SLES10/RHEL4.6及以上

配置fc#5877的注意事项:

fc#5877的配置注意事项与fc#5802相同。
fc#5877与fc#5802可以混在一个12X的loop中。

fc#5803 12X I/O Drawer：

硬件特性：

fc#5803为4U 高，24英寸宽的包含20个PCIe槽位和26个SFF SAS硬盘的I/O抽屉。

槽位信息：

20个PCIe 槽位，其速度是：2.5 GB/sec
26个硬盘槽位，支持热插拔，可以支持一个、两个或四个分区。
如果是一个分区，需配置一个PCIe SAS 硬盘控制器；
如果是两个分区，每个分区放置13块硬盘；此时需要配置两个PCIe SAS 硬盘控制器；
如果是四个分区，各个分区的硬盘数分别是：7 / 6/ 6 / 7 块；此时需要配置四个PCIe SAS 硬盘控制器；

fc#5803的硬件要求和软件要求：

硬件要求：Power 575/595
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7

配置fc#5803的注意事项:

一个环路最多配置一个fc#5803

和fc#5797/5798 的比较：

fc#5803提供了大约为fc#5797/5798两倍的带宽；
fc#5803的20个PCIe槽位中，有6个槽位的速度约比fc#5797/5798的PCI-X 的速度快两倍到四倍；有14个槽位的速度比fc#5797/5798的PCI-X 的速度快将近两倍
和fc#5797/5798的PCI 槽位数量一致，但是需要为fc#5803配置硬盘控制器，则需要占槽位
可以配置8Gb 的光纤存储卡（在NPIV的技术下）
更快的SFF硬盘槽位；
更新技术的SAS硬盘；
每个环路放置一个抽屉，这点和fc#5797/5798一样；
有不配置硬盘的选项；
fc#5803还提供了十八块硬盘槽位，而fc#5796没有；(且不同于以前的fc#5886，fc#5803可以支持多个分区)
fc#5803放置更新技术的SAS SFF硬盘

fc#5873 12X I/O Drawer：

fc#5873为4U 高，24英寸宽的包含20个PCIe槽位的I/O抽屉，是fc#5803的no disk 选项。
每个环路只能放置一个fc#5873抽屉；
硬件要求：Power 575/595；
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7。

突出价值点：这些新增的部件为Power系列服务器提供了灵活的I/O扩展能力，方便用户根据需求进行配置并提供灵活的分区支持能力。

Top


Power 595支持哪些I/O抽屉，各有什么特点

解答：

Power 595支持如下的I/O抽屉：fc#5791, fc#5794, fc#5797, fc#5798, fc#5803, fc#5873

(1)fc#5791 集成20个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要RIO的卡进行连接，最大可以配置12个.

(2)fc#5794 集成20个PCI-X槽位，8个SCSI硬盘的槽位，2个硬盘控制器,可以支持2个分区,需要RIO的卡进行连接，最大可以配置12个.

(3)fc#5797 集成14个PCI-X DDR槽位和6个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要12X的卡进行连接，带有转发器，最大可以配置30个.

(4)fc#5798 集成14个PCI-X DDR槽位和6个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要12X的卡进行连接，不带转发器，最大可以配置3个.

(5)fc#5803 集成20个PCIe槽位，26块SFF硬盘槽位，没有集成硬盘控制器,需要另外配置SAS卡来访问硬盘,最多可支持4个分区,需要12X的卡进行连接，最大可以配置32个.

(6)fc#5873 集成20个PCIe槽位，不带有硬盘槽位，需要12X的卡进行连接，最大可以配置31个.

Top


外设

P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号 (最近更新)

目前支持的几款HMC介绍及配置注意事项

在没有HMC的情况下，如何远程管理Power服务器 (最近更新)

哪些服务器可通过7042-CR6/7042-C08管理 (新增)

IBM Systems Director Management Console (SDMC)介绍 (新增)

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备?

7216-1U2介绍

7216-1U2磁带机、DVD一体机，是否支持订购两个磁带机，连接到两台Power服务器上面来使用 (新增)

USB移动硬盘设备介绍，以及与磁带驱动器的比较

Power服务器能否在USB移动硬盘中安装操作系统并启动? (新增)


P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

解答：

P系列服务器的切换器及相关线缆图如下。此切换器可以在显示套件7316-TF3中定购，产品编号为fc#4283。

fc#4283切换器可以连接一套鼠标、键盘、显示器做为本地的Console使用，鼠标、键盘可以是PS/2或者USB接口，如下图一所示。右边的8个ARI端口可以用来连接服务器，用于连接服务器的各种线缆如下图所示。

图一 切换器，fc#4283

目前，在e-config工具中，可以配置的线缆为fc#4268和fc#4269；这两种线缆可用于环形连接， 订购一个fc#4268或fc#4269包含四根线缆，可以连接4台服务器。1个ARI端口最多支持4组fc#4268或fc#4269线缆串联，支持16台服务器。一个fc#4283最多可以连接128台服务器。

图二 PS/2型的串联线缆(KCO)，fc#4268

图三 USB型的串联线缆(UCO)，fc#4269

下图显示了线缆之间采用串接的方式，每两根线缆之间用双绞线连接，双绞线的长度最长支持10米。如果服务器和7316-TF3之间的距离较远的话，可以根据实际情况制作合适长度的双绞线。

突出价值点：7316-TF3，为用户提供安装在19英寸机柜里的一套鼠标，键盘和液晶显示器；fc#4283为一个切换器，一台fc#4283的切换器支持最大连接128台服务器，即128台服务器可以共享一套液晶套件，为客户大大节省了空间和成本。

Top


什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号

解答：

IBM硬件管理控制台(Hardware Management Console)提供了标准的用户接口来配置和管理Power Systems系列服务器以及服务器上的分区。系统管理员通过HMC对Power Systems服务器上的分区进行配置和日常管理。

HMC的功能包括：
.创建分区，维护分区
.显示每个分区上虚拟的操作系统会话终端
.显示每个分区的虚拟操作面板
.监控，记录以及汇报硬件的更换
.服务器开/关机
.作为Service Focal Point设备提供远程管理和Service Agent Call-Home功能
.激活服务器上的CUoD部件

当前的POWER6/POWER7服务器中，Power 560/570/575/595/770/780必须依靠HMC管理。

HMC和服务器的兼容列表如下：

HMC 版本 | 所支持的服务器
Version 7, 及以上版本 | POWER5, POWER6 and POWER7(V7 R710及其以上)
Version 4, 5, 6及以上版本 | POWER5
Version 3, 及以上版本 | POWER4

7042-CR4，7042-CR5,7042-CR6, 7042-C07，7042-C08适用于POWER5，POWER5+,POWER6的服务器；
7310-CR4，7310-C06适用于POWER5和POWER5+的服务器；
如果为7310-CR4，7310-C06 需要将微码升级到Hardware Management Console Licensed Machine Code v7，才能适用于POWER6的服务器。

POWER7服务器对HMC的版本要求如下：
1）HMC V7 R710及其以上；
2）7042-CR3及其以上，或者7310-C05及其以上；
3）如果使用IBM Systems Director来管理HMC，或者HMC管理的分区数超过了254个，则HMC应该是7042-CR3及其以上或者7310-C06及其以上，并且该HMC至少应有3GB的内存。

Power服务器与HMC具体的版本兼容性，可以通过如下的网站查询：
https://www14.software.ibm.com/webapp/set2/flrt/home

当前，HMC支持的服务器数量如下：
1.最大48台非590或者595的服务器；
2.对于POWER7服务器，最大支持48台Power 710/720/730/740/750/755/770/780；
3.最大支持32台590或者595服务器；
4.支持最大1024个LPAR；
5.在HMC管理的架构中，最大支持2台HMC同时管理一台服务器。

突出价值点: 一台HMC既可以同时管理几十台POWER服务器,几百个分区。每台服务器也可以同时连接2台HMC来达到管理方面更高的可用性。

Top


目前支持的几款HMC介绍及配置注意事项

解答：

目前可以配置的HMC有7042-CR5，7042-CR6，7042-C08这三款。其中，CR5和CR6是机架式的，C08是桌边式的。7042-CR5将于2011年1月停产，将由7042-CR6取而代之。

7042-CR5默认的微码版本为V7R350。CR5具有：
1)四核2.4GHz的Intel处理器，8MB缓存；
2)4GB DDR3 内存；
3)300GB的硬盘；
4)4个1Gb的以太网口；
5)1 PCIe & 1 PCI-X slot；
6)4个USB端口（two front, two rear）；
7)DVD-RAM。

在e-config中配置7042-CR5时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

7042-CR6默认的微码版本为V7R720。CR6具有：
1)四核2.53GHz的Intel处理器，12MB L2 cache；
2)4GB DDR3 内存；
3)500GB的硬盘；
4)4个1Gb的以太网口;
5)1 PCIe & 1 PCI-X slot；
6)4个USB端口（two front, two rear）；
7)DVD-RAM。

在e-config中配置7042-CR6时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

7042-C08默认的微码版本为V7。C08具有：
1)四核2.53GHz的Intel处理器，8MB L2 cache；
2)4GB DDR3 内存；
3)250GB的硬盘；
4)集成2个1Gb的以太网口，可以再添加2个1Gb的以太网口；
5)3 PCIe & 2 PCI-X slot；
6)7个USB端口（two front, four rear, one internal）；
7) DVD-RAM。

在e-config中配置7042-C08时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

突出价值点：客户可以根据实际需要来选择桌边式或者机架式HMC。

Top


在没有HMC的情况下，如何远程管理Power服务器

解答：

在没有HMC的情况下，如何对Power服务器建立远程控制。

远程控制，包括在没有HMC的情况下通过高级系统管理接口(ASMI)控制电源的开/关。ASMI端口（HMC1）的IP地址需要更改为可路由的地址。然后，您可以通过Web浏览器指向该地址来访问系统ASMI。

这里有两种方法来实现：

1.通过串行RS232连接。

注意：这个方法只适用于系统电源线已插上，但未开机的状态(即Standby模式)

-需要DB9的连接线连接Power服务器的串行端口并连接到ASCII终端。或使用串行到USB的转接线连接到笔记本电脑(见下图)并使用Windows超级终端中的终端仿真器。
端口设置为：
– 19200 bits per second
– 8 data bits
– No parity
– 1 stop bit
– Xon/Xoff flow control

需要USB到DB9母头串行线缆。需要如下图连接得到这种线缆。

默认用户名/密码是admin/admin:

选(5)Network Services，然后选(1)Network Configuration，然后选Configure Interface，最后选(9)Static Enter IP Settings and then Save Settings设置IP地址:

2.通过ASMI

通过以太网线缆连接笔记本电脑到HMC的端口，将笔记本电脑的IP地址设置在与HMC IP同一子网下。

高级系统管理界面支持的浏览器，到目前为止有，Microsoft Internet Explorer 6.0, Netscape 7.1, Mozilla Firefox, or Opera 7.23，您可以通过运行于PC机或笔记本电脑的上述浏览器连接到服务处理器。

使用默认的IP地址。Web Browse to ASMI https://ip_addr
Power 5 HMC1 192.168.2.146 Mask 255.255.255.0
HMC2 192.168.3.147 Mask 255.255.255.0
Power 6 HMC1 169.254.2.147 Mask 255.255.255.0
HMC2 169.254.3.147 Mask 255.255.255.0

UserID: admin , Password admin

Network Services
-Network Configuration
IP配置为可路由的IP地址

一旦HMC的端口有一个可路由的IP，您可以用支持的浏览器连接到ASMI。

Point Web Browser to ASMI https://ip_addr
Then after logging on as admin, you can turn power on to system via
Power/Restart Control
Power On/Off System

参考文档：
Redbook: Hardware Management Console V7 Handbook: SG24-7491
RedPaper: Integrated Virtualization Manager on IBM System p5 : redp4061
RedPaper: IBM Power 520 Technical Overview ; redp4403

突出价值点：高端服务器需要由HMC来管理，对于低端服务器，可以有更多的方式来远程控制服务器。

Top


哪些服务器可通过7042-CR6/7042-C08管理

解答:

7042-CR6软件最低版本为V7R720，7042-C08最低版本为V7RV11。

CR6/C08支持POWER5、POWER6、POWER7服务器；

CR6/C08不支持POWER4及更早的设备。

CR6/C08 Manage POWER4 Service Agent实现的功能：

CR6/C08可以通过Electronic Service Agent连接到POWER4的HMC，来用来管理POWER4机器的一些系统和服务的日志信息，可实现call home功能，而并不是对POWER4的机器进行管理。


IBM Systems Director Management Console (SDMC)介绍

解答:

IBM Systems Director Management Console (SDMC)是POWER服务器新一代的管理控制台, 将在接下来的几年内逐步取代HMC。跟7042-CR6一样，SDMC在机柜里占用1U的空间。

与HMC相比，SDMC具有如下优势：

简化虚拟化的管理；

可以管理刀片；

支持刀片上的动态分区迁移；

支持刀片的双VIOS；

支持刀片的Active Memory Expansion；

对Power服务器的硬件、服务和虚拟化管理的外观风格是统一的。

突出价值点：SDMC为客户提供了丰富的管理功能。


System P系列服务器的外置磁带和光驱存储设备（7214-1U2）可支持多少个媒体设备？

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备

解答：

7214-1U2有两个媒体槽位，最大支持3个媒体设备。其左边槽位支持1个磁带驱动器，右边槽位可支持1个磁带驱动器或者2个DVD光驱。如图一所示，7214-1U2包含1个磁带驱动器和2个DVD光驱。

7214-1U2不支持总线分离的配置。所有驱动器设备都必须连接到一个SAS Controller上。

7214-1U2只能通过一块SAS卡(fc#5912或者fc#5901)连接到P服务器上，且7214-1U2的所有设备(磁带机或者光驱)只能属于一个LPAR。

图一

注意：在AIX或Linux操作系统下，每个Power 520或Power 550服务器最多只允许配置两个7214-1U2设备。

突出价值点：7214-1U2为一个外置的磁带和光驱的存储设备，通过SAS卡与服务器相连；如果一台POWER6服务器实现多个分区的时候，只需配置一套外置的磁带和光驱设备，就可以在多个分区之间进行动态的偏移，而不用为每个分区配置一套磁带机和光驱设备，能为客户节省成本，提高硬件设备的利用率。


7216-1U2介绍

解答：

7216-1U2，为最新推出的一款媒体抽屉。可以通过USB端口或者通过SAS卡连接到POWER6/POWER7的服务器上。

7216有2个槽位，可以为POWER6/POWER7服务器提供外置的磁带机，DVD或者移动硬盘设备。

如果是连接POWER7的服务器，目前7216-1U2上支持的设备如下：

DAT320 160 GB SAS Tape Drive (fc#1402)
DAT320 160 GB USB Tape Drive (fc#5673)
Half-high LTO Ultrium 5 1.5 TB SAS Tape Drive (fc#8247)
DVD-RAM - 9.4 GB SAS Slim Optical Drive (fc#1420 and fc#1422)
RDX Removable Disk Drive Docking Station(fc#1103)

如果是连接POWER6的服务器，目前7216-1U2上支持的设备如下：

DAT320 160 GB SAS Tape Drive (fc#1402)
DVD-RAM - 9.4 GB SAS Slim Optical Drive (fc#1420 and fc#1422)
RDX Removable Disk Drive Docking Station(fc#1103)

服务器与7216-1U2连接的线和卡的选择：

7216-1U2支持USB端口或者SAS卡连接到POWER6/POWER7的服务器上。

可以通过集成的USB端口或者USB卡，通过USB线，连接USB的驱动器；

可以通过SAS卡：fc#5901/fc#5912/fc#5278(LP) 的SAS卡，通过SAS线，连接SAS的驱动器；但是不支持用服务器上集成的SAS端口连接7216-1U2。

如果通过SAS卡（fc#5901/fc#5912/fc#5278(LP))连接7216-1U2，可以在1U2里配置SAS的磁带机和DVD设备，在驱动器中，包含了外部的SAS线，不需要单独配置SAS线。

如果通过USB口连接7216-1U2，可以在1U2中配置USB接口的磁带机和USB的移动硬盘，在驱动器中，包含了USB的连接线，不需要单独配置USB线缆。

每个驱动器（磁带机，DVD或者移动硬盘）可通过自带的线缆，连接到一台服务器相应类型（USB或者SAS）的一个控制器上。

7216-1U2的两个槽位，支持如下的驱动器设备的组合：

1.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），另一个槽位剩余。
2.连接两个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一）。
3.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），一个或者两个DVD-RAM。
4.连接四个DVD-RAM。
5.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），一个移动硬盘（RDX Removable HDD Docking Station）。
6.连接一个移动硬盘（RDX Removable HDD Docking Station），一个或者两个DVD-RAM。
7.连接两个移动硬盘（RDX Removable HDD Docking Station）。

注意：在7216-1U2上，适用于POWER6服务器的驱动器位：DAT320 SAS Tape Drive，DVD-RAM，RDX Removable Disk Drive Docking Station。

7216-1U2支持AIX，IBM i，Linux的操作系统，但是，移动硬盘（RDX Removable HDD Docking Station）和USB的磁带机（DAT320 USB Tape Drive）不支持IBM i的操作系统。

突出价值点：7216-1U2为一个外置的磁带，光驱或者移动硬盘的存储设备，通过SAS卡或者USB接口与POWER7服务器相连；该设备的每个驱动器，都已经配置了相应的对外连接控制器的线缆，不需要单独配置连接线。当要在服务器中实现多个分区时，只需配置一套外置的磁带，光驱或者移动硬盘设备，就可以在多个分区之间进行动态的偏移，而不用为每个分区配置一套磁带机，光驱或者移动硬盘设备，能为客户节省成本，提高硬件设备的利用率。

Top


7216-1U2磁带机、DVD一体机，是否支持订购两个磁带机，连接到两台Power服务器上面来使用

解答:

7216-1U2里面的每个设备，都拥有自己独立的SAS或USB连线，可以连接到任何一台支持的服务器上的SAS或USB卡上面。

所以，完全可以在1U2里面订购两台磁带机，分别连接到两台不同的服务器上面。


USB移动硬盘设备介绍，以及与磁带驱动器的比较

解答：

2009年4Q发布的USB移动硬盘设备有4种Feature Code - fc#1104，fc#1103，fc#1106和fc#1107。

其中：fc#1104为外置硬盘驱动器，fc#1103为内置硬盘驱动器。支持的硬盘为 160G(fc#1106)和 500G(fc#1107)两种。

目前只USB移动硬盘支持AIX和Linux，不支持VIOS和IBM i。具体支持的版本情况如下：

AIX 5.3 with the 5300-11 Technology Level, 及以上版本。
AIX 6.1 with the 6100-04 Technology Level, 及以上版本。
SUSE Linux Enterprise Server 10 Service Pack 2, 及以上版本。
SUSE Linux Enterprise Server 11, 及以上版本。
Red Hat Enterprise Linux version 4.7, 及以上版本。
Red Hat Enterprise Linux 5.3, 及以上版本。

 | USB移动硬盘设备 | 磁带驱动器
驱动器的价格 | 低 | 高
驱动器的维护费用 | 无 | 有
磁带的价格 | 高 | 低
速度 | 比入门级磁带驱动器高 | 入门级驱动器速度相对较低
压缩 | 由应用完成该功能 | 大部分驱动器有内置的压缩功能
自动加载器 | 没有 | 有(低端的除外)
磁带的最大容量 | 500GB的非压缩容量, (比入门级磁带驱动器的容量大) | 入门级磁带驱动器的相对较小
稳定/可靠性 | 高 | 低
随机存取 | 可以 (with UDF 文件系统) | 不可以
健壮性 | 高 | 相对较低
加密 | 由应用完成 | 有驱动器完成(低端的除外)
清洗带 | 不需要 | 需要
备份/恢复时间 | 比入门级磁带驱动器快 | 入门级驱动器相对较慢
外部连接能力 | USB 连接 | 通过SAS PCI卡连接

突出价值点：可以根据客户的需要选择内置或者外置的硬盘驱动器，目前支持两种容量的硬盘(500G和160G)。USB移动硬盘设备在速度、可靠性和拥有成本方面都具有优势。


Power服务器能否在USB移动硬盘中安装操作系统并启动

解答:

不能！ USB移动硬盘设备不能用来安装操作系统。

P6、P7小型机中提供的#110X USB移动硬盘采用USB 2.0连接方式，传输速度约为20MB/s，提供了内置磁带机之外的另一种备份恢复方式，相比磁带，它能提供更快的数据访问速度。USB移动硬盘只是一种备份/恢复设备，并不能做为系统磁盘来安装操作系统。

在AIX中，使用USB移动硬盘进行数据备份恢复和使用磁带机备份恢复的命令基本一致，大多为管理员所熟悉的标准的命令，不会增加备份和恢复的复杂程度。

AIX中常用的一些命令，都可以对USB移动硬盘进行备份，例如：

。mksysb
。backup 和 restore
。tar
。dd
。cpio

在Linux中， 使用USB移动硬盘被视为标准的磁盘设备，可使用标准的Linux命令来进行数据的复制、备份以及恢复。


PowerVM

动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

System P服务器分区技术中的Physical Shared Processor Pool,Multiple Shared Processor Pool, Shared Dedicated Capacity 介绍

PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

表格列举不同Power服务器的型号所能够支持的PowerVM的features

什么是PowerVM? (最近更新)

PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用 (最近更新)

动态分区迁移(Live Partition Mobility)介绍 (新增)

要实现动态分区迁移所具备的前提条件 (新增)

IVE介绍及特性

刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？ (最近更新)

PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？ (最近更新)

Power服务器支持分区的最大数量是多少？ (最近更新)

目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况

用VIOS实现分区双机时，需要几个VIOS，以及串口心跳卡/网卡/HBA卡的数量应如何考虑 (新增)

Power服务器上使用NPIV的技术，是否需要额外的License

VMControl 版本及功能介绍 (新增)


动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

解答:

每一个LPAR相当于一台完全独立的物理机器，HMC只能管理与之相连接的硬件环境，没有直接连接的硬件环境HMC是没有办法管理的，所以要在每个分区中配置单独的网卡与HMC连接。

突出价值点：提供灵活的动态功能，可以在不影响应用的情况下，在各分区间动态调整资源。

参考书目以及下载地址：
Redbook 书号：SG24-7231-00 Page 8
参考书目名称：《LPAR Simplification Tools Handbook》
下载地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247231.pdf


System p服务器分区技术中的Physical Shared-Processor Pool, Multiple Shared-Processor Pool, Shared Dedicated Capacity介绍

解答:

1.物理共享处理器池 (Physical Shared Processor Pool)

POWER5服务器与上一代POWER4服务器在对CPU资源的划分上使用了新技术－即微分区技术。在POWER4服务器上划分分区时(LPAR/DLPAR)每个分区至少要分配1路物理CPU资源，而在POWER5服务器上使用微分区(Micro-Partition)功能后，对CPU的划分粒度更细了，1路物理CPU可以划分成10个Entitle Unit，每个分区最少可以分配1/10个Entitle Unit，一个Entitle Unit可以看成是1/10个物理CPU资源。使用微分区技术后对CPU资源的划分更加灵活，提高了CPU资源的利用率。

在POWER4服务器上划分分区的时候，物理CPU都被以1路、2路、3路……的整数方式划分的，分区中的CPU数量与物理CPU的数量能够直接对应。而在POWER5服务器的微分区技术中以前这种分区中的CPU数量与物理CPU的数量直接对应关系没有了，取而代之的是物理共享处理器池(Physical Shared Processor Pool)，物理共享处理器池是先将物理CPU放置于一个共享的处理器池中统一的被分配到分区之中使用。如图一所示。

图一

p2至p7 六个物理CPU被放置于物理共享处理器池中，通过Power Hypervisor将池子里的物理CPU调度到微分区之中。在微分区中看到的CPU叫做虚拟处理器(Virtual Processor),即下图微分区中的vp0,vp1……。可见虚拟处理器的总数与物理共享处理器池中的物理处理器的总数是不相等的。在微分区中虚拟处理器与物理处理器之间是没有固定关系的。Power Hypervisor会调度物理共享处理器池中的物理处理器最终被分配到哪个微分区中被使用，默认情况是Power Hypervisor会将一个物理处理器上的资源划分给微分区使用。如图二所示

图二

2. 多个共享处理器池（Multiple Shared Processor Pool）

多个共享处理器池Multiple Shared Processor Pools (MSPPs)是POWER6服务器上的新功能。这个功能允许管理员同时创建多个微分区的集合（Set of Micro-Partition），一个集合内包含一个或多个微分区。这个功能的好处在于可以由管理员人为地控制一个微分区集合所要消耗的物理共享处理器池中的物理处理器的量。如图三所示

图三

图三中的服务器被划分了六个微分区，三个微分区为一个微分区的集合，每个集合对应一个共享处理器池(Shared Processor Pool)。管理员可以人为地从物理共享处理器池(Physical Shared Processor Pool)调度物理处理器，为每个微分区集合中的共享处理器池分配物理处理器的量。该功能比以前一代POWER5服务器中只能存在一个共享处理器池(Shared Processor Pool)相比在物理处理器的划分上更加灵活和有针对性了。

3. Shared Dedicated Capacity

Shared Dedicated Capacity也是POWER6服务器上的新功能。我们将以前那种物理处理器数量与分区中的处理器数量有对应关系的处理器化分方式叫做Dedicated方式，而把目前微分区中的处理器划分方式叫做Shared方式。在POWER5服务器上能够同时做到既有使用Dedicated方式划分的分区又有使用Shared方式划分的分区。但是使用这两种方式划分的分区之中所使用的物理处理器是完全分开的。如果一个物理处理器被分配给了使用Shared方式划分的分区，这个处理器就不能在分配给使用Dedicated方式划分的分区使用。反之也是一样。
在POWER6服务器中新的Shared Dedicated Capacity功能打破了以前的限制。在Dedicated方式划分的分区中，如果分区中的物理处理器上存在没有被使用的处理器时钟周期，那么这些没有被使用的时钟周期将会分配到物理共享处理器池(Physical Shared Processor Pool)中供Shared方式划分的分区所使用。提高处理器的利用效率。

突出价值点：功能强大的CPU调度机制。1/10内核即可支持1个分区，增量颗粒度小至0.01个内核。灵活的调度策略。根据预先设定的调度策略和当前负载情况，自动在各微分区间调整处理器资源。Multiple Shared Processor Pool同时对软件的授权使用提供了更高性价比的解决方案。

参考书目以及下载地址:
Redbook 书号：SG24-7940-04 Page 42
参考书目名称：《PowerVM Virtualization on IBM System p》
下载地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247940.pdf

Top


PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

解答：

Feature | Licensed by | Processor support | Operating System supporta
LPARb | All Editions (limited on Express) | POWER4,5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER (not POWER4) RHEL 4, 5 for POWER (not POWER4
Capacity Upgrade on Demand | All Editions (specific models) | POWER4, 5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER RHEL 4, 5 for POWER (5.1 for POWER6)
Micro-Partitioning | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER RHEL 4, 5 for POWER
Shared Dedicated Capacity | All Editions | POWER6 | AIX 5.3 and 6.1 SLES 10 update 1 for POWER RHEL 5.1 for POWER
Multiple Shared Processor Pools | PowerVM SE and EE | POWER6 with HMC | AIX 5.3 and 6.1 SLES 10 for POWER6 RHEL 5.1 for POWER6
Virtual I/O Server | All Editions | POWER5 and 6 | Virtual I/O Server
IVM | PowerVM Express, SE and EE | POWER5 and 6 | Integrated Virtualization Manager
Virtual SCSI | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 10 for POWER RHEL 4, 5, 5.1 for POWER
Virtual Ethernet | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 9 for POWER (10 for POWER6) RHEL 4, 5 for POWER (5.1 for POWER6)
Live Partition Mobility | PowerVM Enterprise Edition | POWER6 | AIX 5.3 and 6.1 SLES 10 update 1 for POWER RHEL 5.1 for POWER

a. Contact your sales representative for specific technology level or service pack requirements.
b. Including DLPAR operations, except dynamic memory removal for all Linux versions.

Top


表格列举不同Power服务器的型号所能够支持的PowerVM的features

解答：

不同Power服务器的型号所能够支持的PowerVM的features如下表:

 | JS Blades | PS Blades | 520 | 520 | 520 | 550 | 550 | 560 | 570 | 570 | 595 | 710 | 720 | 730 | 740 | 750 | 770 | 780
 |  |  | 8203- E4A | 9407- M15 | 9408- M25 | 8204- E8A | 9409- M50 | 8234- EMA | 9117- MMA | 9406- MMA | 9119- FHA | 8231- E2B | 8202- E4B | 8231- E2B | 8205- E6B | 8233- E8B | 9117- MMB | 9179- MHB
Express Edition | 支持 | 支持 | 支持 |  |  | 支持 |  |  |  |  |  | 支持 | 支持 | 支持 | 支持 | 支持 |  |
Standard Edition | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Enterprise Edition | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Micro- partitioning | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
VIOS | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
IVM | 支持 | 支持 | 支持 |  |  | 支持 |  |  |  |  |  | 支持 | 支持 | 支持 | 支持 | 支持 |  |
PowerVM Lx86 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
NPIV | 支持 | 支持 | 支持 |  |  | 支持 |  | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Live Partition Mobility | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Shared Processor Pools |  |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
HMC |  |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持

参考如下链接：http://www-03.ibm.com/systems/power/software/virtualization/editions/features.html

突出价值点：详细、图形化的列举了不同Power服务器的型号所能够支持的PowerVM的3个版本及各个详细功能，方便客户统一查阅、参考。


什么是PowerVM?

解答:

PowerVM是在基于IBM POWER处理器的硬件平台上提供的具有行业领先水平的虚拟化技术家族。它是IBM Power System虚拟化技术全新和统一的品牌(逻辑分区，微分区，Hypervisor，虚拟I/O服务器，APV，PowerVM Lx86，Live Partition Mobility)。PowerVM有三个版本，分别是PowerVM Express Edition，PowerVM Standard Edition，PowerVM Enterprise Edition。

1. PowerVM Express Edition

PowerVM Express Edition只能在IBM Power 520，Power 550，PS700，PS701，PS702，PS703,PS704,Power 710，Power 720，Power 730，Power 740，Power 750，这几种服务器上购买。它们的主要功能包括：最多可以创建三个分区，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，不支持Multiple Shared Processor Pools,Live Partition Mobility和Active Memory Sharing功能，分区创建和管理使用IVM工具。

2. PowerVM Standard Edition

PowerVM Standard Edition可以在全部的IBM Power服务器上购买。它们的主要功能包括：对分区数量没有限制，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，支持Multiple Shared Processor Pools功能。不支持Live Partition Mobility和Active Memory Sharing功能。分区创建和管理可以使用IVM或者HMC工具。

3. PowerVM Enterprise Edition

PowerVM Enterprise Edition可以在全部的IBM Power服务器上购买。它们的主要功能包括：对分区数量没有限制，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，支持Multiple Shared Processor Pools功能,Live Partition Mobility功能和和Active Memory Sharing功能。分区创建和管理可以使用IVM或者HMC工具。

注释：“Shared Dedicated Capacity”，“Multiple Shared Processor Pools”，“Live Partition Mobility”，“Active Memory Sharing”功能只有在基于IBM POWER6/POWER7处理器的服务器上才可以实现。

突出价值点：PowerVM有三种版本，灵活、全面的虚拟化功能。为用户低、中、高的虚拟化和整合需求提供了灵活多样的解决方案。对于数据中心空间和节能管理提供了技术上的支持。


PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

解答：

PowerVM中的Processor Affinity功能介绍:

在Power服务器上使用微分区功能创建分区时，处理器资源采用了共享的方式，物理处理器(Physical Processor)被放到共享处理器池中(Physical Shared Processor Pool)，服务器的物理处理器和操作系统所使用的虚拟处理器(Virtual Processor)之间没有了一一对应的关系。Power Hypervisor负责调度物理处理器的处理资源(Entitled Capacity)给操作系统中的虚拟处理器使用。由于物理和虚拟处理器之间没有绑定的关系，可能会导致虚拟处理器在不同的时钟周期得到来自不同物理处理器的处理资源，也就是说虚拟处理器上执行的程序在不同的时钟周期会在不同的物理处理器上执行，在这种情况下会造成对Cache，Memory的资源占用和Context switching。为了优化对Cache，Memory的使用和减少Context switching，Power Hypervisor将尝试调度以前虚拟处理器一直使用的物理处理器给该虚拟处理器使用。如果以前虚拟处理器一直使用的物理处理器不可用，Power Hypervisor将扩大寻找物理处理器的范围，具体寻找物理处理器的顺序为：

1. Chip: the other processor core on the POWER5 or POWER6 chip
2. Chip module: a processor core within the same chip module
3. Processor card/book (dependant on system type): a processor within the same processor card/book

PowerVM中的Virtual Processor Folding功能介绍:

从AIX5.3 ML3开始，为了让Uncapped Micro-Partition能够更有效的利用Physical Shared-Processor Pool中未被使用的Processor Capacity，PowerVM增加了Virtual Processor Folding功能。Virtual Processor Folding将未被使用的Virtual Processor置为休眠状态，以避免消耗系统资源。这个功能的好处在于提高Processor Affinity，减少POWER Hypervisor的负载，增加Virtual Processor在Physical Processor上的平均执行时间。

突出价值点：Processor Affinity功能使Power Hypervisor在微分区环境下优化Processor Capacity的调度；
Virtual Processor Folding将暂时没有被使用的Virtual Processor置于休眠状态，可以减少不必要的系统开销。


什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用

解答:

PowerVM Lx86是在基于IBM POWER处理器的服务器上产生一个虚拟的x86 Linux应用运行环境。大部分的32位x86 Linux上的应用可以不重新编译就可以运行在IBM Power System服务器上。

IBM PowerVM Lx86 version 1.2 支持以下的Linux操作系统:

1. Red Hat Enterprise Linux 4 (RHEL 4) for POWER version 4.4, 4.5 and 4.6. Also, x86 Linux applications running on RHEL 4.3 are supported.

2. SUSE Linux Enterprise Server 9 (SLES 9) for POWER Service Pack 3 and 4

3. SUSE Linux Enterprise Server 10 (SLES 10) for POWER Service Pack 1

IBM PowerVM Lx86 version 1.2即可以安装在IBM Power 520/550/560/570/575/595/710/720/730/740/750/770/780，又可以安装在IBM BladeCenter JS23/JS43/JS21/ JS22/JS12/PS700/PS701/PS702/PS703/PS704上。及可用于POWER5,POWER5+,POWER6,POWER7的服务器。

注意：如下应用不支持在PowerVM Lx86上运行：
1.直接访问硬件设备的应用（e.g.3D graphics adapters）。
2. 要求非标准的内核模块或不使用Linux for Power操作系统提供的内核模块的应用。
3. 不仅仅使用到1997年Intel架构软件开发者手册中定义的Intel IA-32指令集架构的应用，包括基本架构(Order Number 243190)，指令集参考手册(Order Number 243191)，系统编程手册(Order Number 243192)。
4. 不能在Red Hat Enterprise Linux 4 version 4.3或Novell SUSE Linux Enterprise Server (SLES) 9 version SP3 or Novell SLES 10操作系统上正常运行的应用。
5. 在x86 Linux上特殊的系统管理和配置工具。

突出价值点：大部分的32位x86 Linux上的应用可以不重新编译就可以运行在IBM Power System服务器上。为用户原有系统移植到Power平台上提供了方便的途径。


动态分区迁移(Live Partition Mobility)介绍

解答:

动态分区迁移就是在机器不宕机的情况下把操作系统（AIX或Linux）和其托管的应用程序从一个物理服务器转移到另外一台物理服务器。整个迁移过程在保证系统完整的情况下几秒钟内完成。整个系统环境都会迁移，包括处理器的状态、内存、附带的虚拟设备和连接的用户。

IBM Power服务器提供行业最高标准的独立可靠性。为了满足新的IT需求，企业可能会改变其IT架构。将生产环境的应用从一台物理的服务器迁移到另一台物理服务器上，在迁移的过程中，动态分区迁移能实现不间断的维护。而以前要是进行应用或者分区的迁移，通常需要宕机操作。

当今，甚至小型的IBM Power服务器都承载着许多逻辑分区。随着分区的数量的增加，找到一个可以被所有分区接纳的可视管理窗口变得越来越困难。动态分区迁移支持分区的迁移，可以在方便的时候处理服务器上存在的一些故障，从而避免了对使用者造成的不便。

动态分区迁移功能可以满足日益严格的服务级别协议（SLAs），因为它可以让您主动将运行的分区和应用程序从一个物理服务器迁移到另一个物理服务器。

将运行的分区从一个物理服务器迁移到另一个服务器，可以平衡服务器的工作负载和资源。假如对于一个关键应用程序的资源需求达到不可预知的峰值,此时可以将这个应用程序的分区移动到具有更大处理能力的服务器上，或者将不太重要的应用分区迁移到其他服务器上，通过释放相关资源达到满足应用程序需求的最佳状态。

动态分区迁移也可以作为企业服务器的整合途径，因为它提供了把应用程序从一台独立的服务器迁移到整合多个应用的服务器上的一个便捷的途径。假如某些工作负载分区对资源的需求波动比较大（例如：在每月的月底或者季度末会遇到工作负载的最高峰），你可以在工作负载未达到峰值时，使用动态分区迁移技术将其整合到一台服务器上，,在工作负载达到峰值之前，将应用迁移到满足其峰值运行的服务器上。

这种方式可以减少机器运行期间耗电量和在非高峰期间冷却设备的耗电量，起到了节能的效果。

动态分区迁移技术能够自动的被纳入到系统管理工具和脚本。能实现快速释放系统资源，以支持多并发迁移。对于单一分区的实时迁移，HMC和IVM的提供了一个便捷的迁移方式。动态分区迁移提供了连续可靠性，表现如下：

1)通过从一个服务器到另一个服务器动态的迁移应用程序减少了计划停机时间。
2)通过将工作负载从高负载的服务器迁移到空闲的服务器上，这样可应对实时变化的工作负载需要和业务需要。
3)通过便捷的整合工作负载和关闭不需要的服务器，减少了能源的消耗。

动态分区迁移技术是IBM PowerVM的延续。通过和其他的虚拟化技术结合，例如逻辑分区，工作负载分区，SAN Volume Controller(SVC)等，对当今数据中心灵活的系统和架构提供了的虚拟的计算平台。


要实现动态分区迁移所具备的前提条件

解答:

动态分区迁移是建立在已有的其它技术基础之上的。熟悉这些技术是对利用动态分区迁移有帮助的。这本书假设您已经对下面的内容有了一定的了解：

-PowerVM（虚拟化）
-VIOS（虚拟IO服务器）
-Virtual SCSI（虚拟SCSI）
-Virtual and shared Ethernet（虚拟共享以太网）
（参考《PowerVM Virtualization on IBM System p: Introduction and Configuration Fourth Edition》，SG24-7940）
-Hardware Management Console（HMC）
-SAN，（动态分区迁移需要配置共享存储）
-Dlpar（动态逻辑分区）
-AIX or Linux

动态分区迁移的前提条件

动态分区迁移的主要要求有：

1、HMC要求：
-对active和inactive的分区迁移都需要Version 7 Release 3.2.0（需要补丁MH01062）以上的版本.如果HMC版本达不到这个级别，请先升级HMC
-型号要在7310-CR2以上，或者7310-C03

2、源和目标系统要求：
-源和目标系统必须是基于IBM Power6或者Power7技术的机型
-源和目标系统必须安装有激活的PowerVM企业版
-源和目标系统的微码必须在01Ex320或以上.不同的机型，x代表不同的字母：S代表刀片服务器，L代表入门级服务器（如520、550、560），M代表中级服务器（如570），H代表企业级服务器（如595）如果需要升级微码，请参考网址:
http://publib.boulder.ibm.com/infocenter/systems/scope/hw/index.jsp?topic=/ipha5/fix_serv_firm_kick.htm

3、源和目标VIOS的要求：
-在每个源和目标系统上，都必须至少要有一个VIOS，其版本要在1.5.1或以上
-现在有一个新的分区属性，叫mover service partition（MSP）.迁移时需要选择MSP.它指明了，VIOS是否具有mover能力.默认情况下，所有VIOS分区都把这个属性设置成false.
-除了要把mover service partition设置成true，源和目标的MSP要通过网络互相通讯。在源和目标服务器上，Virtual Asynchronous Services Interface (VASI)设备提供了MSP与POWER Hypervisor的通讯。

4、操作系统要求
要迁移的分区的操作系统必须是AIX或者Linux。VIOS分区或者运行IBM i系统的分区是不能被迁移的。操作系统必须满足下面的版本要求：
-AIX 5L 5.3 TL7 或者以上（要求级别是5300-07-01）
-AIX 6.1或以上（要求级别是6100-00-01）
-Red Hat Enterprise Linux Version 5 (RHEL5) Update 1或以上（需要kernel security最新）
-SUSE Linux Enterprise Server 10 (SLES 10) Service Pack 1或以上（需要kernel security最新）

5、存储要求
查看VIOS所支持的磁盘和光纤设备列表
http://www14.software.ibm.com/webapp/set2/sas/f/vios/documentation/datasheet.html

6、网络要求
如果要迁移的分区是通过VLAN进行网络访问的，那么这个VLAN必须通过VIOS分区中的shared Ethernet adapter(SEA)桥接到物理网络（如果有多个VLAN，也都需要桥接）。LAN必须被配置，以保证在迁移完成之后，分区还能够继续与其他的client和server进行通讯。

Top


IVE介绍及特性

解答：

一. IVE的介绍

IVE 是Integrated Virtual Ethernet Adapter 的缩写,目前主要用于Power 520, Power 550, Power 560, Power 570, Power 710, Power 720, Power 730, Power 740, Power 750, Power 755, Power 770, Power 780上, 主要有三种类型的IVE adapter:

2个1Gbps 物理端口,1个Port Group,16个逻辑端口

4个1Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

2个10Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

其中Power 750/755主要有两种类型的IVE卡（与Power 520/550/560/570的后两种卡相同）：

4个1Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

2个10Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

如图一,显示了相应IVE adapter对应的物理端口,Port Group,和逻辑端口:

图一

其中1Gbps 的物理端口为RJ-45 Ethernet Connections,10Gbps的物理端口为光纤接口,其接口如图二:

图二

其中Power 770/780主要有三种类型的IVE卡：

Four 1 Gbps Ethernet ports

Two 10 Gbps SFP+ optical (SR only) Ethernet ports and two 1 Gbps copper Ethernet ports

Two 10 Gbps SFP+ copper twinax ports and two 1 Gbps Ethernet ports

对应的图片：Four 1 Gbps Ethernet ports

Two 10 Gbps SFP+ optical (SR only) Ethernet ports and two 1 Gbps copper Ethernet ports

Two 10 Gbps SFP+ copper twinax ports and two 1 Gbps Ethernet ports

其中Power 710/720/730/740主要有如下三种类型的IVE卡：

Quad-port 1 Gb HEA Daughter Card(每块IVE卡支持32个逻辑端口，每个物理端口支持最大8个逻辑端口)；

Dual-port 10 Gb HEA Daughter Card (Fiber)(每块IVE卡支持32个逻辑端口，每个物理端口支持最大16个逻辑端口)；

Dual-port 10 Gb HEA Daughter Card (Copper)(每块IVE卡支持32个逻辑端口，每个物理端口支持最大16个逻辑端口)。

二.IVE的特性:

(1) IVE直接连接到GX+ bus 上,不占用PCIe, PCI-X槽位；

(2) 每个物理端口有一个Layer 2 Switches;每个逻辑端口只能属于一个物理端口;属于同一个物理端口的LPAR之间可直接通信；

(3) 每个逻辑端口有一个唯一的MAC地址,可以将逻辑端口指派给任何一个LPAR；

(4) 指派给同一个LPAR的多个逻辑端口,均不属于同一个物理端口(注: 1个LPAR最多对应的逻辑端口,依赖于IVE的物理端口数)；

(5) IVE通过HMC或者IVM进行管理；

(6) 通过HMC或者IVM,将某个物理端口设定为Promiscuous模式,则这个物理端口只能分配给一个LPAR,其他LPAR不能共享这个物理端口；

(7) 通过HMC或者IVM设定MCS(Multiple Core Scaling)参数,以此来改变每个Port Group的逻辑端口数。例如:当MCS=1时,一个Port Group支持16个逻 辑端口,当MCS=8时,一个Port Group支持2个逻辑端口；

(8) IVE支持的操作系统:AIX(IBM AIX 5L version 5.2,5.3,6.1,7.1),Linux(Red Hat RHEL 4.5 or later; SuSE SLES 10 SP1 or later),IBM i(i 6.1, 7.1)。

突出价值点：天生具有虚拟化功能，不需配置VIO Server，即可使用对外的网络虚拟功能。

参考文档:《Integrated Virtual Ethernet Adapter Technical Overview and Introduction》

下载地址: http://www.redbooks.ibm.com/redpapers/pdfs/redp4340.pdf

Top


刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？

解答:

到目前为止，JS12,JS22,JS23,JS24，PS700，PS701，PS702，PS703，PS704都在在Sales Manual中都声明了对NPIV的支持，并对不同操作系统有不同的硬件要求。其中刀片上，目前只支持8GB的HBA扩展卡(CFFh, CIOv)和10GbE FcoE扩展卡(CFFh)。

下表是对AIX Client LPAR的硬件兼通性要求：

NPIV Compatibilty Matrix | Qlogic 8Gb CIOv #8242 Requires firmware version 5.02.01 or later | Qlogic 8Gb CFFh #8271 Requires firmware version 5.02.01 or later | Emulex 8Gb CIOv #8240 Will Require firmware update; check Emulex site | Qlogic 10GbE CFFh #8275
QLogic 8Gb Switch Modules #3284 Requires firmware version 7.10.1.04 or later | Yes | Yes | No | NA
Brocade 8Gb Switch Modules #5045, 5869 | Yes | Yes | Yes | NA
Cisco 4Gb Switch Module #3242 | Yes | Yes | Yes | NA
10GbE Passthru Module #5412 | NA | NA | NA | Yes

注：上表已略去已停产feature，若要查看更完整和最新信息，请查看相应刀片的Sales Manual和刀片的兼容列表：

JS21：http://www.ibm.com/common/ssi/rep_sm/2/872/ENUS7998-_h02
JS22: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS7998-_h01
JS23/43: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS7778-_h01
PS700: http://www.ibm.com/common/ssi/rep_sm/2/872/ENUS8406-_h02
PS701/702: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS8406-_h01
PS703: http://www-01.ibm.com/common/ssi/rep_sm/2/872/ENUS7891-_h02
PS704: http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS7891-_h01
刀片兼容性列表: http://www-947.ibm.com/support/entry/portal/docdisplay?brand=5000020&lndocid=MIGR-5073016


PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？

解答：

共享内存概述

共享内存是分配给共享内存池的物理内存，在多个逻辑分区之间共享该内存。共享内存池是已定义的一组物理内存块，它们由系统管理程序作为单个内存池进行管理。配置为使用共享内存的逻辑分区（以后称为共享内存分区）与其他共享内存分区共享池中的内存。

例如，创建具有16GB物理内存的共享内存池。然后创建三个逻辑分区，将它们配置为使用共享内存，并激活共享内存分区。每个共享内存分区可使用共享内存池中的16GB。

分配给共享内存分区的内存量可大于共享内存池中的内存量。例如，可向共享内存分区1分配12GB，向共享内存分区2分配8GB，并向共享内存分区3分配4GB。这些共享内存分区总共使用24GB内存，但共享内存池只有16GB内存。在此情况下，内存配置被视为过量使用。

系统管理程序在共享内存分区的工作负载需求驱动下，通过不断执行下列任务来管理过量使用的内存配置：

* 根据需要，将来自共享内存池中的物理内存部分分配给共享内存分区；
* 根据需要，请求虚拟 I/O 服务器（VIOS）逻辑分区在共享内存池与调页空间设备之间读写数据。

在多个逻辑分区之间共享内存的能力称为PowerVM Active Memory（活动内存）共享技术。PowerVM Active Memory（活动内存）共享技术是随 PowerVM 企业版提供的，您必须获取并输入 PowerVM 版激活码才能使用。

实现Active Memory Sharing的必要条件：

就像Live Partition Mobility一样，Active Memory Sharing功能只能在POWER6/POWER7服务器中配置，同样Active Memory Sharing只能在PowerVM企业版中获得。如果客户目前使用的PowerVM易捷版或PowerVM标准版，那么首先需要升级到PowerVM企业版，以便使用Active Memory Sharing功能。使用Active Memory Sharing功能的分区要求所有设备都是虚拟化的（通过VIOS获得），并定义此分区使用Shared Processor模式。

突出价值点：为内存根据应用需要在各分区间动态地、自动地切换提供了可能。

Top


Power服务器支持分区的最大数量是多少？

解答：

Power全系列服务器（POWER5，POWER6和POWER7）均支持微分区技术。通过微分区技术，可以0.1颗CPU为单位来创建分区，那么我们可以得到以下结论：

* 每个激活的处理器最多支持10个分区。
* 对于POWER5和POWER6单台服务器分区数量的上限为254。
* 需要注意的是，4-Core 4.2GHz封装的Power 570服务器支持最大32颗处理器，但是所支持的分区最大数量为160。
* 2011年，对POWER7服务器支持的最大分区数量如下表：

POWER7 Model | Max Cores | Original Max LPAR | May 2011 Max LPARs
PS700 |  |  |
PS701 | 8 | 80 | 80
PS702/703 | 16 | 160 | 160
PS704 | 32 | n/a | 320
710/720 | 8 | 80 | 80
730/740 | 16 | 160 | 160
750 | 32 | 160 | 320
755 | 32 | 32 | 32
770/780 | 64 | 256 | 640

突出价值点: 非常细的颗粒度,为灵活的虚拟化方案提供了支持。

Top


目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况

解答：

目前，AIX和VIOS的版本与各型号POWER7服务器间的兼容情况见表：

突出价值点：方便查询AIX和VIOS的版本与各型号POWER7服务器间的兼容情况，有利于更好地预先确认应用实施条件。


用VIOS实现分区双机时，需要几个VIOS，以及串口心跳卡/网卡/HBA卡的数量应如何考虑

解答：

1. VIOS本身就是一个定制的AIX系统，只运行几个物理和虚拟device driver管理程序，本身非常稳定。所以，对于普通应用要求,一个物理服务器配置一个VIOS即可, 但对于需要如下需求,建议配置2个VIOS。

(1)AIX client / cluster node分区希望在VIOS升级或更改配置时继续可用。

(2)AIX client / cluster node分区希望使用到SEA Failover等双VIOS提供的冗余和自动fail-over功能。

2. 关于心跳方式的选择,在IP心跳之外要有非IP心跳:专用串口心跳或共享磁盘心跳。当选择串口心跳时,因为串口卡不能通过VIOS做虚拟化，因此每一个分区都需要配置一块专用的串口卡。

3. 网卡和HBA卡都可以通过VIOS做虚拟化，为了保证冗余, 每个VIOS需要至少两块网卡和两块HBA卡。也就是说，当配置一个VIOS时，一个物理服务器需要至少两块网卡和两块HBA卡；当配置两个VIOS时，一个物理服务器需要至少4块网卡和4块HBA卡。

Top


Power服务器上使用NPIV的技术，是否需要额外的License

解答：

N_Port ID Virtualization (NPIV) 是业界通行的一个工业标准，主要目的是通过虚拟化光纤通道接口来简化 SAN 网络的架构 , 让虚拟环境下的服务器与 SAN 环境连接更加弹性和安全。

NPIV技术包含在PowerVM易捷版，标准版和企业版中，支持POWER6/POWER7服务器(包括刀片服务器)上的AIX V5.3,AIX V6.1,IBM i 6.1.1 and SUSE Linux Enterprise Server 11的分区。

因此，PowerVM的软件支持NPIV的技术，如果在Power服务器上使用NPIV的技术，不需要额外的License。

注意：要实现NPIV的技术，需要满足如下的要求：

1.POWER6/POWER7服务器；
2.至少一块8GB的双口HBA卡(fc#5735/fc#5273)；
3.支持NPIV的SAN交换机；
4.HMC V7.3.4 or later；
5.VIOS 2.1。


VMControl 版本及功能介绍

解答:

IBM System Director VMControl是IBM Systems Director的一个插件，用来简化IT环境中的工作负载管理。这个插件有三个版本：

_ IBM Systems Director VMControl Express Edition
_ IBM Systems Director VMControl Standard Edition
_ IBM Systems Director VMControl Enterprise Edition

每个版本提供了相应工具来管理虚拟服务器，虚拟应用程序，工作负载和跨多硬件平台和虚拟环境的系统池。

管理访问是通过统一的Web界面或者命令行界面(CLI)的方式来启动和控制配置任务。

VMControl的版本

VMControl一共有三个版本，介绍如下：

_ VMControl易捷版(Express Edition)

这个版本提供了虚拟服务器的管理和重新部署，与Hardware Management Console (HMC)或Integrated Virtualization Manager (IVM)提供的功能类似。

_ VMControl标准版(Standard Edition)

这个版本增加了导入，部署，捕获和维护客户化定制的虚拟服务器映像，并将这些映像存入映像存储库的功能。标准版也能够进行工作负载的创建和管理。在60天的试用期结束以后，它需要订购一个有效的license。

_VMControl企业版(Enterprise Edition)

这个版本增加了创建和管理系统池，可以管理系统池里的工作负载和虚拟服务器。它增加了SAN的自动配置以及基于事件的服务器的自动重新部署，增强了环境的可靠性。在60天的试用期结束以后，它需要订购一个有效的license。

下表中显示出了每个版本的功能，其中VMControl易捷版是可以免费下载的。

下表显示了VMControl所列出的功能：

Express edition | Standard edition | Enterprise edition
创建虚拟服务器 | 发现映像存储库 | 创建系统池
编辑虚拟服务器 | 导入基于标准的映像 | 将虚拟应用程序部署到系统池
管理虚拟服务器 | 捕获一个正在运行的虚拟服务器 | 管理系统池
重新部署虚拟服务器 | 导入虚拟化应用程序包 |
 | 部署虚拟应用程序 |
 | 编辑工作负载区 |
 | 移除工作负载区 |
 | 监视工作负载区 |

Top


PowerHA

System P服务器AIX与HACMP版本兼容性的问题; 另外，实施HACMP时，最常用的方法及所需要的基本硬件资源

Power 710/730与PowerHA SystemMirror for AIX的兼容性

Power 720/740与PowerHA SystemMirror for AIX的兼容性

Power 750与PowerHA SystemMirror的兼容性

Power 770/780与PowerHA SystemMirror for AIX的兼容性

POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性 (最近更新)

FCoE与PowerHA SystemMirror for AIX 的兼容性 (新增)

SVC 6.1与PowerHA SystemMirror for AIX的兼容性 (新增)

IBM System Storage Storwize V7000与PowerHA SystemMirror for AIX的兼容性 (新增)

什么是PowerHA SystemMirror

PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术

PowerHA 7.1可以安装到AIX 哪些版本中？是否支持通过VIOS访问共享存储 (新增)

PowerHA 7.1还支持RS232串口心跳和磁盘心跳吗？其拓扑支持的心跳有何变化 (新增)

PowerHA 7.1 可以通过 System Director 集中管理吗 (新增)

什么是DB2 PureScale,它的主要功能以及特点介绍

什么是GPFS？以及其基本架构介绍

GPFS基本创建过程以及常见注意事项

GPFS中的Manager主要有哪几种,及区别


System P 服务器 AIX与HACMP 版本兼容性的问题;另外，实施HACMP时，最常用的方法及所需要的基本硬件资源

解答:

常用的实施HACMP需要有相应的网卡,光纤卡与异步卡与心跳线.
网卡用于配置IP网络,包括Service ip 、Standby ip 和Boot ip。
光纤卡用于连接存储设备。
异步卡与心跳线用于组成串行网络。

System P Server AIX 与 HACMP 版本兼容性的问题

 | AIX 4.3.3 | AIX 5.1 | AIX 5.1(64-bit) | AIX 5.2 | AIX 5.3 | AIX 6.1 | AIX 7.1
HACMP 4.5 | No | Yes | No | Yes | No | No | No
HACMP/ES 4.5 | No | Yes | Yes | Yes | No | No | No
HACMP/ES 5.1 | No | Yes | Yes | Yes | Yes | No | No
HACMP/ES 5.2 | No | Yes | Yes | Yes | Yes | No | No
HACMP/ES 5.3 | No | No | No | Yes | Yes | Yes | No
HACMP/ES 5.4.0 | No | No | No | TL8+ RSCT 2.3.9+ | TL4+ RSCT 2.4.5+ | No | No
HACMP/ES 5.4.1 | No | No | No | TL8+ RSCT 2.3.9+ | TL4+ RSCT 2.4.5+ | Yes | Yes
PowerHA 5.5 | No | No | No | No | TL9+ RSCT 2.4.10.0 | TL2,SP1+ RSCT 2.5.2.0 | Yes
PowerHA 6.1 | No | No | No | No | TL9+ RSCT 2.4.12.0 | TL2,SP1+ RSCT 2.5.4.0 | Yes
PowerHA 7.1 | No | No | No | No | No | TL6+ RSCT 3.1.0.0 | Yes

参考链接：http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD101347

突出价值点：这个表格列出了目前常见的HACMP版本与操作系统AIX的兼容性，便于客户安装准备，并且提供了实施所需的基本硬件资源，便于客户规划管理。

Top


Power 710/730与PowerHA SystemMirror for AIX的兼容性

解答:

Power 710/730上运行不同的PowerHA与AIX版本时,各种版本之间的兼容性见下表:

Power 710/730 (8231-E2B) | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX 5.3 TL11 SP1, RSCT 2.4.13.0 | AIX V6.1 TL04 SP02, RSCT 2.5.4.2 | HACMP V5.4.1 APAR IZ84442, AIX V7.1, RSCT V3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V5.5 APAR IZ84440, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V6.1 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V6.1 SP3, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V7.1 | Not Supported | AIX V6.1 TL06, RSCT V3.1.0.0 | AIX V7.1, RSCT V3.1.0.0


Power 720/740与PowerHA SystemMirror for AIX的兼容性

解答:

Power 720/740上运行不同的PowerHA与AIX版本时,各种版本之间的兼容性见下表:

Power 720/740 (8205-E4B/E6B) | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX 5.3 TL11 SP1, RSCT 2.4.13.0 | AIX V6.1 TL04 SP02, RSCT 2.5.4.2 | HACMP V5.4.1 APAR IZ84442, AIX V7.1, RSCT V3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V5.5 APAR IZ84440, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V6.1 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V6.1 SP3, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V7.1 | Not Supported | AIX V6.1 TL06, RSCT V3.1.0.0 | AIX V7.1, RSCT V3.1.0.0


Power 750与PowerHA SystemMirror的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.5, 6.1 和7.1添加了对Power 750的支持。具体细节信息如下：

IBM Poewr 750 (8233-E8B) | AIX 5.3 | AIX 6.1 | AIX 7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 5.5 SP7 AIX V7.1, RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3 TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX V7.1, RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL06 RSCT 3.1.0.0 | AIX V7.1, RSCT 3.1.0.0

注意：POWER7服务器上集成的串口不能用于PowerHA的心跳，可以通过配置单独的串口卡或者用磁盘做心跳；PowerHA可以使用POWER7服务器上集成的网卡。

参考链接:http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10705

突出价值点：表格列举了PowerHA的2个版本与Power 750服务器及AIX操作系统的兼容性，便于客户查阅。


Power 770/780与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.4.1, V5.5, V6.1 和V7.1的版本可以支持IBM POWER7 770/780 (9117-MMB/9179-MHB)。

具体操作系统和补丁版本请参考下表:

IBM POWER7 770/780 (9117-MMB/9179-MHB) | AIX V5.3 | AIX V6.1 | AIX V7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 5.5 SP5 AIX V7.1, RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX V7.1, RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL6 RSCT 3.1.0.0 | AIX V7.1, RSCT 3.1.0.0

注：

(1)POWER7服务器上的集成串口不支持PowerHA；

(2)POWER7服务器的集成以太网卡支持PowerHA；

(3)IBM强烈建议在同时使用了DLPAR和微分区技术的分区建立双机环境时,在PowerHA 6.1中安装APAR IZ72927。

参考链接：http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10708


POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.4.1, V5.5, V6.1 和V7.1的版本可以支持BladeCenter PS700 (8406-70Y) and PS701/702 (model 8406-71Y)。具体细节信息如下：

BladeCenter PS701/702 | AIX V5.3 | AIX V6.1 | AIX V7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12 RSCT 2.4.13.0 | AIX V6.1, TL05 RSCT 2.5.5.0 | PowerHA 5.5 SP7 AIX 7.1 RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3 TL12 RSCT 2.4.13.0 | AIX V6.1, TL05 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX 7.1 RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL06 RSCT 3.1.0.0 | AIX 7.1 RSCT 3.1.0.0

(1)支持如下的卡：

fc#8240 Emulex 8Gb FC Expansion Card (CIOv);
fc#8241 QLogic 4Gb FC Expansion Card (CIOv);
fc#8242 QLogic 8Gb FC Expansion Card (CIOv);
fc#8243 Broadcom 2-port Gb Ethernet Expansion Card (CIOv);
fc#8246 SAS Connectivity Card (CIOv);
fc#8251 Emulex 4Gb FC Expansion Card (CFFv);
fc#8252 QLogic Ethernet/4Gb FC Expansion Card (CFFh);
fc#8271 QLogic Ethernet/8Gb FC Expansion Card (CFFh);
fc#8291 Broadcom 4-port 1 Gigabit Ethernet Expansion Card (CFFh/PCI-E).

(2)PowerHA支持集成的以太网卡，包括集成虚拟网卡(IVE)；

(3)支持IVM Integrated Virtualization Manager。

参考链接：http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10713


FCoE与PowerHA SystemMirror for AIX 的兼容性

解答:

PowerHA SystemMirror for AIX v5.4.1,V5.5,V6.1,V7.1添加了对IBM Converged Switch B32(3758-B32)的兼容性，具体的兼容性见下表：

IBM Converged Switch B32 | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.4.1 SP10 PowerHA APAR IZ96232 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.5 SP7 PowerHA APAR IZ96233 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V6.1 | AIX V5.3 TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 6.1 SP3 AIX V7.1 TL0 SP02 PowerHA APAR IZ96235 RSCT 3.1.0.3
PowerHA V7.1 | N/A | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | AIX V7.1 TL0 SP02 PowerHA APAR IZ96236 RSCT 3.1.0.3

参考链接：http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10745


SVC 6.1与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX v5.4.1, v5.5, v6.1, v7.1添加了对IBM SVC V6.1版本的兼容性。具体的兼容性信息见下表：

IBM System Storage SVC v6.1 | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.4.1 SP10 PowerHA APAR IZ96232 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.5 SP7 PowerHA APAR IZ96233 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V6.1 | AIX V5.3 TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 6.1 SP3 AIX V7.1 TL0 SP02 PowerHA APAR IZ96235 RSCT 3.1.0.3
PowerHA V7.1 | N/A | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | AIX V7.1 TL0 SP02 PowerHA APAR IZ96236 RSCT 3.1.0.3

参考链接：http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10742


IBM System Storage Storwize V7000与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX v5.4.1, v5.5, v6.1 and v7.1配合AIX v5.3, v6.1 and v7.1支持IBM System Storage Storwize V7000。具体的兼容性信息见下表：

IBM System Storage Storwize V7000 v6.1 | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.4.1 SP10 PowerHA APAR IZ96232 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 5.5 SP7 PowerHA APAR IZ96233 AIX V7.1 TL0 SP02 RSCT 3.1.0.3
PowerHA V6.1 | AIX V5.3 TL11, SP01 RSCT 2.4.13.0 | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | PowerHA 6.1 SP3 AIX V7.1 TL0 SP02 PowerHA APAR IZ96235 RSCT 3.1.0.3
PowerHA V7.1 | N/A | AIX V6.1 TL06 SP03 RSCT 3.1.0.3 | AIX V7.1 TL0 SP02 PowerHA APAR IZ96236 RSCT 3.1.0.3

PowerHA的更新可从以下链接获得：
http://www14.software.ibm.com/webapp/set2/sas/f/hacmp/home.html

参考链接：http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10743


什么是PowerHA SystemMirror

解答：

PowerHA SystemMirror for AIX V6.1是PowerHA V5.5之后的新版本HACMP软件。

PowerHA SystemMirror分标准版和企业版两种：

标准版(5765-H23)针对数据中心内的高可用方案；

企业版(5765-H24)包括标准版的功能和双站点的远程高可用方案(XD)。

PowerHA SystemMirror 6.1标准版能够实现：
– 监控、检测事件并对事件做出反应
– 在系统之间建立心跳
– 使系统可以自动切换

PowerHA SystemMirror 6.1企业版支持如下的技术：
IBM DS8000 Metro Mirror, SVC Metro Mirror & Global Mirror, EMC SRDF
以及SP3版本新添加对Hitachi Truecopy and IBM DS8700 Global Mirror技术的支持。

在PowerHA SystemMirror标准版(5765-H23)和企业版(5765-H24)中，默认包含了Smart Assist的功能，不再需要单独购买。

PowerHA SystemMirror V6.1支持的AIX操作版本:

AIX 5.3 Technology Level 9，RSCT V2.4.12，及以上版本；

AIX 6.1 Technology Level 2，RSCT V2.5.4，及以上版本。

PowerHA SystemMirror V6.1 SP3 支持 AIX V7.1,RSCT V3.1.0.0，及以上版本。

突出价值点：PowerHA SystemMirror for AIX V6.1是新发布的一款高可用集群软件，它分为两个版本 - 标准版和企业版。其中，标准版用于数据中心内的高可用方案，企业版用于双站点的远程高可用方案，企业版既包含了标准版的功能，又包含了两站点的容灾功能。新的PowerHA版本里面默认包含了Smart Assist的功能、可以支持EMC SRDF的存储复制技术、支持GLVM配置向导以及支持DLPAR的功能等。


PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

解答:

下面是PowerHA V6.1 Standard Edition 和 Enterprise Edition 的特性对比表：

 | Stanard Edition | Enterprise Edition
Centralized management C-SPOC | Y | Y
Cluster resource management | Y | Y
Shared storage management | Y | Y
Cluster verification framework | Y | Y
Integrated heart beating | Y | Y
SMIT management interfaces | Y | Y
AIX event/error management | Y | Y
Disk heart beating | Y | Y
PowerHA Dynamic LPAR high availability management | Y | Y
Smart assists | Y | Y
Multi Site HA management |  | Y
PowerHA GLVM |  | Y
GLVM deployment wizard |  | Y
IBM Metro Mirror support |  | Y
IBM Global Mirror support |  | Y
EMC SRDF/S SRDF/A |  | Y


PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术

解答：

PowerHA SystemMirror for AIX 6.1企业版包含了PowerHA SystemMirror for AIX 6.1标准版的功能和两个站点的集群管理功能。PowerHA企业版可以在远端站点实现自动的资源切换，并管理相关的复制对等功能。

在PowerHA SystemMirror for AIX 6.1企业版上，支持的数据复制技术如下：

1.支持DS8700的同步和异步复制技术；
2.支持SVC的同步和异步复制技术；
3.支持Hitachi TrueCopy；
4.支持EMC SRDF；
5.支持GLVM 同步和异步复制技术。

可以参考下表:

 | Sync mode | Async mode | Active Active | Consistency groups
GLVM | Yes | Yes | Yes | Yes
SVC | Metro Mirror | Global Mirror | yes | yes
DS8700 | Metro Mirror | Global Mirror | yes | yes
EMC | SRDF | SRDF | yes | yes
Hitachi | Truecopy | Truecopy | yes | yes

注意：

同步复制模式，两个站点之间最大支持300KM的距离；
异步复制模式，两个站点之间理论上没有距离的限制。

突出价值点：PowerHA SystemMirror for AIX 6.1企业版，可以支持多种存储的复制技术，不仅支持IBM的存储复制技术，还支持EMC和Hitachi的存储复制技术，可以满足客户不同存储设备的需求。


PowerHA 7.1可以安装到AIX 哪些版本中？是否支持通过VIOS访问共享存储

解答:

PowerHA 7.1需要CAA（Cluster Aware AIX）支持。CAA是AIX V7.1的新特性，原有的AIX V6.1升级到TL06以上也有CAA功能。所以，AIX V7.1和V6.1-TL06支持PowerHA 7.1。

PowerHA 7.1支持通过VIOS访问共享存储，详细功能有如下限制：

通过VIOS来使用SAN心跳时，无论是通过VSCSI 还是NPIV，都要求软件版本升级到VIOS 2.2.0.11-FP24 SP01。

Cluster Repository（共享存储池）支持通过NPIV来访问。

Cluster Repository（共享存储池）支持通过VSCSI来访问，但需要AIX 6.1 TL6 SP2或 AIX 7.1 SP2来支持。

突出价值点：拓扑管理内置入操作系统内核中，更加可靠、更加快速。


PowerHA 7.1还支持RS232串口心跳和磁盘心跳吗？其拓扑支持的心跳有何变化

解答:

PowerHA 7.1不再支持RS232串口心跳和磁盘心跳（包括多节点磁盘心跳）。同时不再支持的拓扑特性有：

。TMSCSI, TMSSA

。替换方式的IP切换

。专为心跳设置的别名网络（Heartbeat over alias）

。第二个站点（2 site），包括跨站点LVM镜像(Cross-site LVM mirroring) （暂时）

。IPV6 （暂时）

新增支持的拓扑特性有：

。SAN 心跳

。TMSAS 心跳

。IP心跳多点传送技术（multicast IP addressing for heartbeating）

突出价值点：拓扑管理内置入操作系统内核中，更加可靠、更加快速。


PowerHA 7.1 可以通过 System Director 集中管理吗

解答:

PowerHA 7.1新增了Director插件，与System Director高度集成，统一界面方便管理。可以方便地创建、校验、同步集群，以及向集群内添加节点。原来的WebSMIT管理方式不再支持。PowerHA 7.1 Director agent随安装介质提供，与软件一同安装。Director管理插件可以在网上方便下载，与System Director一同安装到Director服务器上。

突出价值点：与System Director高度集成，统一界面方便管理。可以方便地创建、校验、同步集群，以及向集群内添加节点。


什么是DB2 PureScale,它的主要功能以及特点介绍

解答:

DB2 PureScale是一种新的DB2可选组件，通过提供无限的容量、持续的可用性和应用程序透明性。DB2 PureScale降低了业务增长的风险和成本。DB2 PureScale on IBM Power Systems融合了PowerHA PureScale技术，在UNIX或x86系统上交付了无与伦比的数据库可伸缩性和可用性水平。它补充了现有的DB2 for z/OS和System z，是整体系统在可用性、可扩展性、安全性和可靠性方面当之无愧的领袖。

在IBM Power Systems上部署的DB2 PureScale结合PowerHA PureScale技术,可以提供DB2数据库的高可扩展性和高可用性，DB2 PureScale的主要功能用一句话来说就是在不牺牲性能的前提下扩展DB2集群。

DB2 PureScale产品特点如下：

1、无限的容量: DB2 PureScale为所有事务性工作负载提供了几乎无限的容量。要扩展您的系统，只需连接新节点并发出两条简单命令。DB2 PureScale基于集群的共享磁盘架构通过有效使用系统资源降低了成本。

2、应用程序透明性: 使用DB2 PureScale，您无需更改应用程序代码即可在多个节点上有效运行。借助成熟、可扩展的架构，您可以扩展应用程序来满足最严苛的业务需求。而且，只需少量改动或者甚至无需改动，就可以运行为其他数据库软件编写的应用程序。DB2提供了对常用语法和PL/SQL过程的本机支持，这使从Oracle数据库迁移到DB2变得比以往更加轻松。

3、持续的可用性: DB2 PureScale通过使用基于IBM Power Systems且高度可靠的PowerHA PureScale技术，以及一个冗余平台，提供了持续的可用性。该系统几乎可在出现节点故障的同时进行恢复，立刻将工作负载重新分配到健康的节点上。

突出价值点: DB2 PureScale提供无限的容量、持续的可用性和应用程序透明性，降低了业务增长的风险和成本。


什么是GPFS？以及其基本架构介绍

解答：

1.什么是GPFS

GPFS(General Parallel File System)是IBM公司开发的通用集群文件系统，支持AIX/Linux/Windows操作系统。

在集群的环境中，GPFS文件系统允许集群中所有的节点访问同一文件的数据，并提供统一的文件存储空间。应用可以使用标准的UNIX文件系统接口访问文件的内容, 大多数应用不需要修改或重新编译就可运行在GPFS文件系统上。UNIX文件系统上的实用程序也为GPFS所支持，也就是用户可以继续使用他们所熟悉的UNIX命令来进行常规的文件操作，但是用户需要使用GPFS文件系统的特有的管理命令来管理GPFS文件系统。GPFS支持32位和64位的应用，可以动态的增加或减少文件系统的容量。

GPFS文件系统区别于其他的集群文件系统的特点是，在多个节点中，为应用提供并发的、高速的文件访问，提供突出的性能，尤其是大数据量的顺序操作，尽管典型的GPFS应用适用于多个节点，但对单个节点也能提供有益的性能。GPFS特别适合于集中对数据的访问超过了分布式文件服务器的处理能力的应用环境。它不适用于以热备份为主应用环境或数据很容易按照节点划分区的应用环境。

2.GPFS的基本结构

GPFS是一种定义在多个节点上的集群文件系统。运行GPFS的全部节点集称之为GPFS群集。在GPFS群集中，所有节点又被分成多个GPFS节点集，在同一个节点集的节点可共享其所属的GPFS文件系统，而其他节点集中的节点是无法访问它的。GPFS支持lc、rpd、hacmp和sp等多种群集类型。

GPFS群集中的每一节点，都由以下几方面构成：（1）GPFS管理命令 （2）扩展核心 （3）多线程的后台监控程序

2.1 GPFS的扩展核心

GPFS的扩展核心为操作系统的vnode提供了一个接口，为增加文件系统提供了虚拟文件系统接口。在结构上，应用程序向操作系统发出一文件系统调用请求，操作系统会将此请求转给GPFS文件系统扩展核心。从应用的角度，GPFS只是一个文件系统。GPFS的扩展核心将完成这些请求 -- 通过使用系统中已有的资源或发送消息给GPFS后台监控程序来完成此请求。

2.2 GPFS后台监控程序

GPFS后台监控程序为GPFS完成所有的I/O操作和缓存的管理。 这包括预读（read-ahead）和延迟写(write-behind)。 所有的I/O操作是由令牌（token）来控制的，这确保了建立在多节点上的文件系统中数据的一致性。后台监控程序是一多线程的进程，有些线程只处理某些特定的功能。忙于日常事务的线程只进行日常事务处理，有专用的线程来响应服务请求。后台监控进程也与运行在其他节点上运行GPFS的实例进行通信，来协调配置的改变、文件系统的恢复和并行修改相同的数据结构。这些具体的功能包括：

.为新文件和新扩大的文件分配空间，这通过与文件系统管理器（file system manager）协商完成；
.目录的管理，包括创建新目录、插入和删除目录中的条目、因I/O的请求而检索相关的目录；
.为保证数据和元数据的完整性分配适当的锁。涉及到会从多个节点访问的数据；
.磁盘的I/O 是由后台进程中的线程发起的；
.文件系统的安全与配额管理也是由进程协同文件系统管理器共同管理的。


GPFS基本创建过程以及常见注意事项

解答：

(注: 以下命令中的具体参数仅供参考,实际操作中请结合环境使用正确的参数)。

1 环境准备

1.1 在全部节点准备两个文件/etc/hosts和/.rhosts，内容示例如下：

/etc/hosts (用来支持节点之间的访问)
192.168.1.13 techline13
192.168.1.14 techline14
192.168.1.15 techline15
注意事项:需要将全部节点的主机名和IP都列出来。

/.rhosts (用来支持节点之间访问时的权限)
techline13 root
techline14 root
techline15 root
注意事项:需要将全部节点都列出来。

1.2 在操作配置节点准备两个文件/tmp/mmfs/nodefile和/tmp/mmfs/nsdfile, 内容示例如下：

/tmp/mmfs/nodefile (创建节点时用到)
techline13:manager-quorum
techline15:manager-quorum
techline14:client-nonquorum

/tmp/mmfs/nsdfile (创建NSD盘时用到)
hdisk1:techline13::dataAndMetadata::
hdisk2:techline13::dataAndMetadata::

1.3 export PATH=$PATH:/usr/lpp/mmfs/bin:. (在所有节点设置环境变量)

2.在全部节点安装GPFS3.4(以V3.4为例)软件：

安装文件gpfs.base, gpfs.docs.data, gpfs.msg.en_US三个文件, 然后安装升级包3.4.0.2
注意事项: 如果不安装升级包3.4.0.2,则执行命令mmstartup时会报错。

3.创建GPFS集群：

mmcrcluster -N /usr/lpp/mmfs/nodefile -p techline13 -s techline15 -C gpfscluster01 -A

4.设定license：

mmchlicense server/client –accept
注意事项:此为V3.3版本以后才有的要求。

5.创建NSD：

mmcrnsd -F /usr/lpp/mmfs/nsdfile -v no
mmlsnsd

6.创建文件系统：

mmstartup -a
mmcrfs /gpfs01 gpfs01 -F /usr/lpp/mmfs/nsdfile -A yes -B 256K

7.在所有节点挂载文件系统：

mmmount /gpfs01
注意事项: 此步也可以用操作系统的命令mount /gpfs01来实现。

Top


GPFS中的Manager主要有哪几种,及区别

解答：

GPFS中主要有三种Manager角色:Cluster configuration Server / Cluster Manager / File system Manager.

Cluster configuration Server主要用来管理集群的配置信息,修改集群配置信息的命令在执行时都要求访问Cluster configuration Server,而且各节点的GPFS daemon进程在启动时都需要访问Cluster configuration Server, 因此在配置集群时建议设定primary和secondary两个manager,以保证至少有一个是available的,从而保证集群的正常工作。

Cluster Manager的主要功能有:

1 管理并选定File system Manager；
2 管理集群quorum；
3 将集群变化通知其它集群；
4 监控硬盘的使用；
5 处理remote cluster 的UID mapping请求。

Cluster Manager的选定原则是:存活最久的节点将会被选为Cluster Manager, 当然我们可以通过命令强制指定某节点为Cluster Manager。

File system Manager的主要功能有：

1 管理本文件系统的配置信息；
2 管理磁盘空间的分配；
3 文件访问的令牌管理；
4 quota管理。

Top


性能与物理参数

服务器性能参数

System P系列服务器的CPU, Memory, I/O的带宽 (最近更新)

业界常见的服务器性能指标有哪些及简要介绍 (新增)

一个根据业务需求估算TPC-C值的实例 (新增)

物理环境参数

System P系列服务器的尺寸、环境要求、功率和重量


System P系列服务器的CPU, Memory, I/O的带宽

解答:

答案、解释及解决问题的步骤：

CPU
处理器型号
可选Core数量
主频
Memory
RAM(内存)
一级缓存
二级缓存
三级缓存 		I/O带宽(峰值)
处理器到内存带宽
二级到三级高速缓存的带宽
GX I/O 子系统带宽
Power 520
8203-E4A

64-bit IBM POWER6 & POWER6+
1 (4.2 GHz only), 2 or 4
POWER6: 4.2 GHz
POWER6+: 4.7 GHz

 2-16 GB (1-core);4-32 GB (2-core);4 - 64 GB (4-core)
L1: 64 KB - 64 KB
L2: Up to 16 MB (8 MB per dual core chip)
L3: 4.2 GHz: 0 4.7 GHz: Up to 64 MB (32MB per dual-core chip) 		32.0GBps
75.2GBps
28.2GBps
Power 550
8204-E8A 		64-bit POWER6 & POWER6+
2, 4,6 or 8 core
POWER6: 3.5 GHz, 4.2 GHz
POWER6+: 5.0GHz 		3.5 GHz: 4–128 GB;4.2, 5.0 GHz: 4 GB - 256 GB(8 DIMM slots per processor card)
L1: 64 KB - 64 KB
L2: Up to 32 MB (8 MB per dual core chip)
L3: Up to 128 MB (32 MB per dual-core chip) 		128GBps(8-core)
160GBps(8-core)
23.3GBps
Power 560
8234-EMA 		64-bit IBM POWER6
4,8 or 16 core
3.6 GHz 		8 GB - 384 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		128.0GBps
230.0GBps
24.0GBps
Power 570
9117-MMA 		64-bit POWER6
2, 4, 8, 12 or 16 core
3.5GHz, 4.2GHz, 4.4GHz，4.7GHz，5.0GHz 		2 GB - 768 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		256GBps
300.8GBps
66.7GBps
Power 570
9117-MMA 		64-bit POWER6+
4, 8, 16，24 or 32 core
4.2GHz 		2 GB - 768 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		256GBps
300.8GBps
66.7GBps
Power 595
9119-FHA 		64-bit POWER6
8 - 64
4.2 GHz; 5.0 GHz 		16 GB - 4 TB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		1376.0GBps
2560.0GBps
640.0GBps
BladeCenter JS22
7998-61X 		64-bit POWER6
4-core
4.0 GHz 		4GB – 32GB
L1: 64 KB - 64 KB
L2: 4 MB
L3: - 		21.3GBps
-
5.8GBps
BladeCenter JS12
7998-60X 		64-bit POWER6
2-core
3.8 GHz 		2 GB - 64 GB
L1: 64 KB - 64 KB
L2: 4 MB
L3: - 		21.3GBps
-
5.8GBps
BladeCenter JS23
7778-23X 		64-bit IBM POWER6+
4-core
4.2GHz 		4 GB – 64 GB
L1: 64 KB - 64 KB per core
L2: 16MB (8 MB per dual core chip)
L3: 64MB (32MB per dual-core chip) 		21.3GBps
67.2GBps
8.4GBps
BladeCenter JS43
7778-23X plus fc#8446 		64-bit POWER6+
8-core
4.2GHz 		8 GB - 128 GB
L1: 64 KB - 64 KB per core
L2: 32 MB (8 MB per dual core chip)
L3: 128 MB (32MB per dual-core chip) 		42.68GBps
134GBps
16.8GBps
Power 710
8231-E2B 		64-bit POWER7
4 core at 3.0 GHz
6 core at 3.7 GHz
8 core at 3.55 GHz 		8 - 64 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

68.22 GBps per socket

L1 Cache: 144 GB/s(3.0GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L2 Cache:144 GB/s(3.0GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L3 Cache: 96 GB/s(3.0GHz); 113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

30GBps
Power 720
8202-E4B 		64-bit POWER7
4, 6, 8 core at 3.0 GHz 		4 core
8 – 64 GB (1066 MHz DDR3)
6 or 8 core
8 – 128 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

68.22 GBps per socket

L1 Cache: 144 GB/s(3.0GHz);
L2 Cache:144 GB/s(3.0GHz);
L3 Cache: 96 GB/s(3.0GHz).

30GBps
Power 730
8231-E2B 		64-bit POWER7
8 core at 3.0 GHz
8 core at 3.7 GHz
12 core at 3.7 GHz
16 core at 3.55 GHz 		8 - 128 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

136.44GBps

L1 Cache: 144 GB/s(3.0GHz);170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L2 Cache:144 GB/s(3.0GHz);170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L3 Cache: 96 GB/s(3.0GHz);113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

50GBps
Power 740
8205-E6B 		64-bit POWER7
4, 8 core at 3.3 GHz
4, 8 core at 3.7 GHz
6, 12 core at 3.7 GHz
16 core at 3.55 GHz 		8 - 256 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

136.44GBps(68.22 GBps per socket)

L1 Cache: 158.4 GB/s(3.3GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz)
L2 Cache:158.4 GB/s(3.3GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz)
L3 Cache:105.6 GB/s(3.3GHz); 113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

50GBps
Power 750
8233-E8B 		64-bit POWER7
8, 16, 24, 32 Core at 3.0GHz,3.2GHz,3.3GHz,3.55GHz,3.6GHz
6,12,18,24 Core at 3.7GHz 		8 GB – 512 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

272.9GBps(68.22 GBps per socket)

L1 Cache:144 GB/s(3.0GHz);158.4 GB/s(3.3GHz);170.4 GB/s(3.55GHz);
L2 Cache:144 GB/s(3.0GHz);158.4 GB/s(3.3GHz);170.4 GB/s(3.55GHz);
L3 Cache: 96 GB/s(3.0GHz); 105.6 GBps (3.3 GHz);113.6 GB/s(3.55GHz).

30GBps
Power 755
8236-E8C 		64-bit POWER7
32-core
3.3 GHz or 3.6GHz 		128 GB – 256 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

272.9GBps(68.22 GBps per socket)

L1 Cache:158.4 GB/s(3.55GHz);
L2 Cache:158.8 GB/s(3.55GHz);
L3 Cache:105.6 GB/s(3.55GHz).

25GBps
Power 770
9117-MMB 		64-bit POWER7
12, 24, 36, 48 core at 3.5 GHz 		32 GB – 1024 GB (1066 MHz DDR3)
128 GB – 2 TB
(1066 MHz DDR3)2010年11月19日可订购

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

1091.6GBps(68.22 GBps per socket)

L1 Cache:148.8 GB/s(3.1GHz);
L2 Cache:148.8 GB/s(3.1GHz);
L3 Cache:99.2 GB/s(3.1GHz).

236.5GBps
Power 780
9179-MHB 		64-bit POWER7
16, 32, 48, 64 core at 3.8 GHz (Standard mode)
8, 16, 24, 32 core at 4.1 GHz(TurboCore mode) 		32 GB – 1024 GB (1066 MHz DDR3)
128 GB – 2 TB
(1066 MHz DDR3)2010年11月19日可订购

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

1091.6GBps(68.22 GBps per socket)

L1 Cache:185.28 GB/s(3.86GHz);
L2 Cache:185.28 GB/s(3.86GHz);
L3 Cache:123.52 GB/s(3.86GHz).

236.5GBps
IBM BladeCenter PS700
8406-70Y 		64-bit POWER7
4 core
3.0 GHz 		8 GB - 64 GB (1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		34.1GBps
-
-
BladeCenter PS701
8406-71Y 		64-bit POWER7
8-core
3.0GHz 		16 GB – 128 GB (1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		68.2GBps
-
-
BladeCenter PS702
8406-71Y plus + fc#8358 		64-bit POWER7
16-core
3.0GHz 		32GB - 256 GB(1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		136.4GBps
-
-

BladeCenter PS703
7891-73X

64-bit POWER7
16-core
2.4 GHz

16 GB - 128 GB
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core)

136.4GBps
-
-

BladeCenter PS704
7891-74X

64-bit POWER7
32-core
2.4 GHz

32 GB - 256 GB
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core)

272.9GBps(68.22 GBps per socket)
-
-

突出价值点：表格列举了System P系列服务器的CPU,Memory,I/O的带宽，便于客户查阅。

所需资源和渠道的详情：
网址:http://www-03.ibm.com/systems/power/hardware/reports/factsfeatures.html

Top


业界常见的服务器性能指标有哪些及简要介绍

解答:

当前业界常见的服务器性能指标有:
TPC-C
SPECjbb2005
SPECjAppServer2004
SPECint2006 及 SPECint_rate_2006
SPECfp2006 及 SPECfp_rate_2006
SAP SD 2-Tier
LINPACK

一、TPC (Transaction Processing Performance Council) 即联机交易处理性能协会, 成立于1988年的非盈利组织,各主要软硬件供应商均参与,成立目标: 为业界提供可信的数据库及交易处理基准测试结果,当前发 布主要基准测试为:

TPC-C : 数据库在线查询(OLTP)交易性能
TPC-E : 数据库在线查询(OLTP)交易性能
TPC-H : 商业智能 / 数据仓库 / 在线分析(OLAP)交易性能

1.TPC-C测试内容 ：数据库事务处理测试, 模拟一个批发商的订单管理系统。实际衡量服务器及数据库软件处理在线查询交易处理（OLTP）的性能表现. 正规 TPC-C 测试结果发布必须提供 tpmC值, 即每分钟完成多少笔 TPC-C 数据库交易 (TPC-C Transaction Per Minute), 同时要提供性价比$/tpmC。如果把 TPC-C 测试结果写成为 tpm, TPM, TPMC, TPCC 均不属正规。

二、SPEC (Standard Performance Evaluation Council) 即标准性能评估协会,成立于1988年的非盈利组织，最初由多家工作站厂家建立及后发展到各主要软硬件供应商均参与，成立目标 : 为业界提供现实而标准化之性能测试，为市场提供公平和各种有用的量度标准，并在发挥厂家优势及严格遵守法则之间取得平衡。SPEC发布各种不同种类的基准测试, 包括 :

SPECjbb2005: 作为 JAVA 应用服务器之性能
SPECjAppServer2004: 服务器执行 J2EE 应用之性能
SPEC CPU 2006: 处理器单核或多核在处理整点及浮点计算性能

2.SPECjbb2005 (Java Business Benchmark)基准测试模拟一个三层架构环境来进行 JAVA应用服务器测试，目的是衡量应用服务器端 JAVA 应用 (Server-side Java Application) 之性能。正规SPECjbb2005 测试结果发布必须提供 bops 值, 即每秒钟完成多少笔JAVA 业务操作 (Business Operation Per Second), 同时要求提供完整的测试环境资料，包括：服务器名称，处理器内核数量，线程数量，JVM名称，JVM数量，bops/JVM性能等。

3.SPECjAppServer2004基准测试衡量采用J2EE (Java 2 Enterprise Edition) 技术之应用服务器性能。正规 SPECjAppServer2004 测试结果发布必须提供 JOPS 值, 即每秒钟完成多少笔JAVA操作 (Java Operation Per Second), 同时要求提供完整的测试环境资料，包括：服务器名称，处理器内核数量，JAVA 应用服务器名称，J2EE服务器数量，J2EE实例数量等。

4.SPECint2006 及 SPECint_rate_2006 基准测试之目的,分别是衡量单处理器(吞吐量)及多处理器(整机)的整点计算能力和编译器的优化能力.测试结果为相对性能值,主要反映处理器整点计算、吞吐量、缓存性能及编译器之优化能力, SPEC整点计算能力提供共4类型测试结果,分别如下:

 | SPEC标准选项来编译测试应用 | 厂家最优化选项来编译测试应用
单处理器(吞吐量)整点计算能力 | SPECint_base2006 | SPECint2006
多处理器(整机)整点计算能力 | SPECint_rate_base2006 | SPECint_rate_2006

5.SPECfp2006 及 SPECfp_rate_2006 基准测试之目的,分别是衡量单处理器(吞吐量)及多处理器(整机)的浮点计算能力和编译器的优化能力. 测试结果为相对性能值, 主要反映处理器浮点计算、缓存性能及编译器之优化能力. SPEC浮点计算能力提供共4类型测试结果,分别如下

 | SPEC标准选项来编译测试应用 | 厂家最优化选项来编译测试应用
单处理器(吞吐量)浮点计算能力 | SPECfp_base2006 | SPECfp2006
多处理器(整机)浮点计算能力 | SPECfp_rate_base2006 | SPECfp_rate_2006

三、SAP基准测试组织由SAP及其技术合作伙伴代表组成，包括各主要软硬件供应商支持，设立目标 : 提供一个专门为 SAP ERP 企业资源管理应用设计的基准测试工具, 所有厂家必须通过SAP测试性能作为SAP服务器配置(Sizing)的标准指标。SAP基准测试组织发布各种不同种类的基准测试, 包括 :

SAP SD (2-Tier / 3-Tier) Standard Application Benchmark : SAP Sales & Distribution Module
SAP BW Standard Application Benchmark : SAP Business Information Warehouse Module
SAP TRBK Standard Application Benchmark : SAP Banking Account & Deposite Management
SAP Enterprise Portal-ESS Standard Application Benchmark : SAP NetWeaver Portal

6.SAP SD 2-Tier 基准测试内容 ：衡量不同硬件厂家加上数据库后执行SAP企业资源管理应用销售及分销 (SD 即Sales & Distribution) 模块时的性能表现。SAP SD 两层结构基准测试将应用服务器及数据库服务器安装在同一台物理服务器上。测试结果会被标准化成 SAP SD 应用模块的 SAPS 应用标准性能值（SAP Application Performance Standard）。SAPS 为一个独立于硬件的性能指标。100 SAPS 值在 SAP SD 应用定义里等同于每小时2000笔商业处理定单项目 (fully business processed order line items per hour)。每一笔商业处理定单项目包含新定单产生、发货单产生、定单显示、改变发货内容、货品录入、列出定单及产生发票；从技术角度来说，等同于每小时2400笔SAP交易或每小时6000笔对话 (控制台改变) 加上每小时2000笔录入操作。

四、Linpack是业界应用最广的的用于测试高性能计算机系统浮点性能的benchmark, 在目标集群中运行Linpack测试程序,测试结果以浮点运算每秒（Flops）给出。

Top


一个根据业务需求估算TPC-C值的实例

解答:

某公安局数据中心主机处理能力需求分析

某市局信息中心业务处理平台是支撑今后某市公安系统所有业务系统的统一应用平台和数据交换平台。对中心主机的处理能力要求较高。由于新的应用系统是陆续开发上线，目前很难计算出所需的处理能力。因此，下面仅以人口信息系统为参照，估算该部分应用所需的主机处理能力。在系统规划时，应该以此为基础，考虑短期内会投产的其它应用系统，作为中心主机当前配置必须满足的基本性能要求。同时，还应考虑未来多个公安应用系统的处理需求，来确定中心主机应该具备的可扩充性能要求。 在人口信息方面，由于制证等工作会由制证中心的人口信息系统（二代）进行处理，所以需要信息中心系统处理的内容主要涉及对人口信息的查询以及和相关业务系统的数据交换等方面。下面以某市现有人口数量3300万来进行粗略估算。

1.当前处理能力需求
公安行业中多个应用系统，都涉及对人口信息的互连操作。因此，在一年中可能存在多个业务高峰时期，需要使用到这个人口信息数据库。假设在业务繁忙时期每天需要处理5%的人口信息，则以每天工作8小时计，平均每小时处理的人口信息为:
3300万 x 5% ÷ 8 = 20.625万；

在每天的峰值时间（例如早上的10点左右和下午5点左右），对于处理能力的要求应该达到平均时间的3倍，则在峰值期间每分钟处理的人口信息业务量为:
( 20.625 ÷ 60 ) x 3 = 10312.5；

根据目前其他省市建设情况与当前人口信息系统应用软件的事情情况，处理每条人口信息时，数据库服务器的性能开销大约相当于4个tpmc处理能力，则当前在峰值期间对于人口信息系统需要的处理能力约为:
10312.5 x 4 = 41250 tpmC；

除人口信息数据处理外，信息中心还会包含其它多个业务系统。原则上考虑其他所有业务系统的应用需求基本等同于人口信息系统，则所有业务系统目前需要的处理能力约为:
41250 x 2 = 82500 tpmC

由于系统建设需要一定建设周期，一般为半年到两年的时间。到投产运行时，业务量已经超过目前的数量。按9个月的投产周期考虑，若业务量的年增长率为30%，则投产时业务量与目前相比增加比例约为20%。这样，投产时所需的处理能力约为：
82500 x ( 1 + 20% ) = 99000 tpmC

为保证系统稳定运行，系统资源利用应保持1/3的空闲比例，即平均资源利用率不超过65%，因此，投产时主机系统所需的处理能力应为:
93000 ÷ 65% = 152308 tpmC

按照三层次的结构设计，中心系统由数据库服务器和应用服务器组成。一般来讲，业务处理压力经服务器层次分担后，数据库服务器和应用服务器的压力比例约为4:1。据此，当前系统处理能力需求为： 当前数据库服务器处理能力需求为
152308 x 80% = 121846 tpmC

当前应用服务器处理能力需求为
152308 x 20% = 30462 tpmC

在系统设计时，为了保证中心系统的可靠性和安全性，主机系统通常采用双机热备方式进行配置。在具体实现上，主要有两种模式。

模式一: 是为数据库服务器和应用服务器分别配置专门的热备份主机。这种方式下，主机处理能力按照上述需求值配置即可。即，两台数据库服务器处理能力大于121846tpmC，两台应用服务器处理能力大于30462 tpmC。

模式二: 为了节约投资，不配置专门的热备份主机，而采用数据库服务器和应用服务器组成集群，互相备份的模式。当采用这种模式时，由于故障状况发生后会由一台主机同时承担全部功能，所以考虑当前主机处理能力时，单台主机的处理能力应等于数据库服务器和应用服务器处理能力需求之和，即152308tpmC。从节约投资的角度出发，故障状况发生后，一般只要求功能的接管，响应速度方面则允许有所降低。如果可以容忍响应速度的适度降低，那么在计算单台主机的处理能力时，另一种常见的做法是取数据库服务器和应用服务器两者处理能力需求的大者。即，两台服务器的处理能力都大于121846tpmC。在本方案设计中，为了节约投资，建议采用后一种方式，即当前主机处理能力都按照121846tpmC考虑。

2.扩充处理能力需求

系统投产后，除已投产系统自身的业务量增加外，还会有多个新的应用系统陆续投入使用。综合考虑这两类因素，按照系统使用三年，每年30%的业务量增长估算，主机系统所需的处理能力应为：
152308 x ( 1 + 30% ) x ( 1 + 30% ) = 257401 tpmC

同理，所需数据库服务器处理能力需求为
257401 x 80% = 205920 tpmC

所需应用服务器处理能力需求为
257401 x 20% = 51481 tpmC
和前面的论述相似，为了节约投资，对系统扩充能力的要求，也按照后一种方式考虑，即主机扩充处理能力为205920tpmC。

一点说明：此实例只是为了说明解决类似问题过程中的分析思路和分析方法，实例中所提到的具体数据只是假设值，并不表示这些计算细节在实际案例中可以直接使用，比如上面所提到的"数据库服务器的性能开销大约相当于4个tpmc处理能力"只是一个假定,而实际案例中对于tpmc值的转换请根据实际情况做相应处理。

Top


System P系列服务器的尺寸、环境要求、功率和重量

解答:

 | 高度(英寸/毫米) | 宽度(英寸/毫米) | 深度(英寸/毫米) | 操作温度(°C) | 操作湿度 | 最高纬度(米) | 最大功率(KVA) | 重量(kg)
Power 520(机架式） | 4U-6.8/173 | 17.3/440 | 21.2/538 | 5-35 | 8%-80% | 3048 | 0.876 | 34
Power 520(桌边式） | 21.3/540 | 7.2-12.9/182-329 | 24.7/628 | 5-35 | 8%-80% | 3048 | 0.876 | 37.6-40.8
Power 550(机架式） | 4U-6.8/173 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.443 | 48.7
Power 550(桌边式） | 21.3/540 | 7.2-12.9/182-329 | 30.6/778 | 5-35 | 8%-80% | 3048 | 1.443 | 53.2-57.2
Power 560(一个系统柜） | 4U-6.85/174 | 19/483 | 32.4/824 | 5-35 | 8%-80% | 3048 | 1.224 | 63.6
Power 570(一个系统柜） | 4U-6.85/174 | 19/483 | 32.4/824 | 5-35 | 8%-80% | 3048 | 1.428 | 63.6
Power 575 | 42U-79.3/2014 | 29.5/756 | 60.0/1524 | 10-28 | 20%-80% | 3048 | N/A | 1656
Power 595 | 42U-79.3/2014 | 30.5/775 | 58.5-71.1/1486-1806 | 10-28 | 20%-80% | 3048 | 27.7 | 1531-1552
Power 710 | 2U-3.5/89 | 19/440 | 27.8/706 | 5-35 | 8%-80% | 3050 | 0.663 | 28.2
Power 720(机架式） | 4U-6.8/173 | 17.3/440 | 24/610 | 10-40 | 10% to 80% | 3048 | 0.765 | 48.7
Power 720(桌边式） | 21.3/541 | 7.2-12.9/183-328.5 | 27.1/688 | 10-40 | 10% to 80% | 3048 | 0.765 | 53.7-57.2
Power 730 | 2U-3.5/89 | 19/440 | 27.8/706 | 5-35 | 8%-80% | 3050 | 1.122 | 29.5
Power 740(机架式） | 4U-6.8/173 | 17.3/440 | 24/610 | 10-40 | 10% to 80% | 3048 | 1.428 | 48.7
Power 740(桌边式） | 21.3/541 | 7.2-12.9/183-328.5 | 27.1/688 | 10-40 | 10% to 80% | 3048 | 1.428 | 53.7-57.2
Power 750 | 4U-6.8/172 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.95 | 48.7
Power 755 | 4U-6.8/172 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.95 | 48.7
Power 770(一个系统柜） | 4U-6.8/172 | 19/483 | 32/863 | 5-35 | 8%-80% | 3048 | 1.6 | 70.3
Power 780(一个系统柜） | 4U-6.8/172 | 19/483 | 32/863 | 5-35 | 8%-80% | 3048 | 1.6 | 70.3

参见以下红皮书:《IBM Power Systems facts and features》；《IBM POWER7 systems facts and features》

网址: http://www-03.ibm.com/systems/p/hardware/reports/factsfeatures.html

Top


其他

P系列服务器显卡介绍

Power System上Infiniband 产品的支持列表

什么是Power服务器的Storage Key?

什么是CAA（Cluster Aware AIX） (新增)

POWER服务器处理器能否升级，以及升级后支持的数量 (最近更新)

POWER6 产品支持的操作系统

POWER7 产品支持的操作系统 (最近更新)

AIX V6.1支持的硬件环境

AIX V7.1支持的硬件环境 (最近更新)

AIX EE 6.1版本包含哪些软件

什么是AIX Express Edition? 该版本有何要求？

AIX V 7.1支持的几个新功能

IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

AIX V7.1 标准版，企业版，易捷版的区别

AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？

简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

什么是NIM？它的应用场景以及基本概念介绍

什么是ASMI及简要介绍 (新增)

NIM中常见的资源类型以及各自的特点介绍

一个典型的NIM安装过程介绍

POWER服务器的电源和耗电量计算方法

Power系列机型上共有多少种SAS连接线, 它们有什么不同? (最近更新)

FCoE支持的操作系统

为什么选择FCoE/FCoEE?

什么是IBM Systems Director Active Energy Manager?

IBM Systems Director 系统软件各个版本包含哪些软件

IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

被管理服务器所监控和管理的服务器是否均需购买Systems Director软件 (新增)


P系列服务器显卡介绍

解答:

p系列服务器目前可配置两种显卡，分别为：fc#5748和fc#5269。具体介绍如下：

fc#5748 POWER GXT145 PCI Express Graphics Accelerator

POWER GXT145是一种多功能，低价格的2D图形加速器。它可以配置成8位或24位彩色模式。这个适配器同时支持模拟和数字显示器。该适配器需要一个PCI Express插槽。如果连接的设备需要一个15针D-Shell的接口的VGA连接（例如，当图形适配器的输出是直接连接到一个7316-TF3显示套件或间接通过一个KVM切换器），订购一个VGA到DVI接口转接器，fc#4276 去连接相应的设备。

硬件描述:

128位图形处理器
8-bit indexed， 8位真彩色，或24位真彩色
32兆SDRAM内存
1个PCI Express接口
2个DVI-I（模拟/数字视频）连接接口
它所支持的功能多达大约1670万颜色
Rectangular clipping
1个模拟监视器输出高达2048 x 1536分辨率
1个数字监视器输出高达1280 x 1024分辨率
第2个显示器支持对第二个连接高达1600 x 1200的模拟接口分辨率或1280 x 1024数字接口分辨率
第2个显示器，仅支持在Aix的克隆模式下，配一个模拟连接
APIs Supported
X-Windows and Motif

在任何一个分区不能超过4个图形适配器。
属性提供： 2D图形适配器
属性要求： 1个PCI Express插槽

配置要求：如果连接VGA的显示器(如7316-TF3),则需要加配：fc#4276 ( VGA to DVI Connection Converter )VGA到DVI转换器来转换成VGA接口。

操作系统要求：
AIX Version 5.3 supported
AIX Version 6.1 supported
AIX Version 7.1 supported
SUSE Linux supported
Red Hat Linux supported
Refer to Software Requirements for specific O/S levels supported

fc#5269 PCIe LP POWER GXT145 Graphics Accelerator

该卡为Low Profile的显卡，其功能与fc#5748类似。POWER GXT145是一种多功能，低价格的2D图形加速器。它可以配置成8位或24位彩色模式。这个适配器同时支持模拟和数字显示器。该适配器需要一个PCI Express插槽。如果连接的设备需要一个15针D-Shell接口的VGA连接（例如，当图形适配器的输出是直接连接到一个7316-TF3显示套件或间接通过一个KVM切换器），订购一个VGA到DVI接口转接器，fc#4276 去连接相应的设备。

硬件描述:
128位图形处理器
8-bit indexed， 8位真彩色，或24位真彩色
32兆SDRAM内存
1个PCI Express接口
2个DVI-I（模拟/数字视频）连接接口
它所支持的功能
多达大约1670万颜色
Rectangular clipping
1个模拟监视器输出高达2048 x 1536分辨率
1个数字监视器输出高达1280 x 1024分辨率
第2个显示器支持对第二个连接高达1600 x 1200的模拟接口分辨率或1280 x 1024数字接口分辨率
第2个显示器，仅支持在Aix的克隆模式下，配一个模拟连接
APIs Supported
X-Windows and Motif

在任何一个分区不能超过4个图形适配器。
属性提供： 2D图形适配器
属性要求： 1个Low Profile(LP) Slot

配置要求：如果连接VGA的显示器(如7316-TF3),则需要加配：fc#4276 ( VGA to DVI Connection Converter )VGA到DVI转换器来转换成VGA接口。

操作系统要求：
AIX Version 5.3 supported
AIX Version 6.1 supported
AIX Version 7.1 supported
SUSE Linux supported
Red Hat Linux supported
Refer to Software Requirements for specific O/S levels supported

突出价值点：分别详细介绍了P系列服务器中的两款显卡的产品特性和技术参数。

请参考销售手册中相应的feature code说明:

Power 产品销售手册查询

Top


Power Systems 上Infiniband 产品的支持列表

解答：

Infiniband 是一项互连技术，它通过将传统的共享总线体系结构转换到交换光纤体系结构来打破 PCI 总线的带宽和扇出限制。这是一项将服务器、存储设备和网络设备捆绑在一起的交换光纤 I/O 技术。与 PCI 发送数据所采用的并联方式不同，Infiniband 以串联方式发送数据，并且通过多路复用信号可以同时承载多个通道。

Infiniband Adapter介绍：

F/C 或者 P/N | 描述 | 编号 | 可订购时间 | 停产时间
26K6457 | 1x IB HCA Expansion Card for BladeCenter | N/A | Dec 10, 2004May 26, 2006 | 31-Jan-07
1466(P/N 32R1760) | Cisco IB 4x HCA Expansion Card (StFF) | N/A | 15-Aug-06 | Oct 31. 2008
1802 | GX Dual-port 12x Channel Attach | Roosa 12x | 6-Nov-07 |
1808 | GX++ 12X DDR Adapter, Dual-port |  | 16-Mar-10 |
1809 | GX Dual-port 4x IBM HCA | Roosa 4x w/Chato | 18-Nov-05 |
1810 | GX Dual-port 4x IBM HCA | Roosa 4x | 18-Nov-05 |
1811 | GX Dual-port 4x IBM HCA | Telesto 4x | 14-Oct-05 |
1812 | GX Dual-port 4x IBM HCA | Lambda 4x | 14-Oct-05 |
1820 | PCI-X Dual-port 4x IB HCA | Taylor | 26-May-06 | 23-Jun-06
5266 | GX++ Dual-port 4x Channel Attach |  | 17-Sep-10 |
5608 | Dual Port 12x IB GX Adapter (DDR) | Guardian | 7-Oct-08 | 29-May-09
5609 | GX Dual-port 12x-DDR Channel Attach | Guardian+ | 22-May-09 |
5612 | Dual 2-Port 4X IB HCA | Monk | 8-Apr-08 |
5615 | GX++ Dual-port 12x Channel Attach |  | 17-Sep-10 |
5616 | Dual Port 12X IB GX Adapter (SDR) | Valery | January 29, 2008(same) |
7820 | GX Dual-port 12x IBM HCA | Callisto 12x | 9-Dec-05 |
8256(p/n 32R1760) | 4X Infiniband HCA Expansion Card (StFF) | CISCO | 30-Nov-07 | 11-Jul-08
8258 | 4X Infiniband DDR Expansion Card (CFFh) | Mellanox | 30-Nov-07 |
8297 | Cisco 4X Infiniband DDR Expansion Card (CFFh)Provides FC 8258 + Cisco software key | Mellanox | 30-Nov-07 | 30-May-08
8298 | Voltaire 4X Infiniband DDR Expansion Card (CFFh)Provides FC 8258 + Voltaire software key | Mellanox | 30-Nov-07 |

所支持的服务器列表及支持的Infiniband卡的数量

System |  | Feature Code
 |  | 1808 | 5266 | 5609 | 5615 | 5616
POWER7 | 8231-E2B(710) | n | 1 | n | n | n
 | 8202-E4B(720) | n | n | n | 1 | n
 | 8231-E2B(730) | n | 2 | n | n | n
 | 8205-E6B(740) | n | n | n | 2 | n
 | 8233-E8B(750) | n | n | 1 | n | 1
 | 8236-E8C(755) | n | n | 1 | n | n
 | 9117-MMB(770) | 8 | n | n | n | n
 | 9179-MHB(780) | 8 | n | n | n | n

System |  | Feature Code
 |  | 1802 | 5608 | 5609 | 5612 | 5616 | 8256 | 8258 | 8297 | 8298
POWER6 | 9125 (575) | n | n | n | 2 | n | n | n | n | n
 | 9117 (570) | 82 | n | n | n | n | n | n | n | n
 | 8234 (560) | 33 | n | n | n | n | n | n | n | n
 | 8204 (550) | n | 1w | 1 | n | 2 | n | n | n | n
 | 8203 (520) | n | 1w | 1 | n | 2 | n | n | n | n
 | 7988 (JS22) | n | n | n | n | n | 1w | 1 | 1w | 1
 | 7998 (JS12) | n | n | n | n | n | 1w | 1 | n | 1

System |  | P/N | Feature Code
 |  | 26K6457 | 1466 | 1809 | 1810 | 1811 | 1812 | 1820 | 7820 | 8256
POWER5 | 7988 (JS21) | n | n | n | n | n | n | n | n | 1w
 | 8844 (JS21) | 1w | 1w | n | n | n | n | n | n | n
 | 9115 (505) | n | n | n | n | n | n | 1w | n | n
 | 9110 (510,510Q)
 | 9111 (520) | n | n | n | n | n | n | 2w | n | n
 | 9123 (710)
 | 9131 (52A,520Q) | n | n | n | n | n | 1 | 2w | n | n
 | 9113 (550) | n | n | 1 | n | n | n | 4w | n | n
 | 9133 (55A) | n | n | 1 | n | n | n | 2w | n | n
 | 9124 (720)
 | 9116 (560Q) | n | n | n | 1 | n | n | n | n | n
 | 9117 (570)
 | 9118 (575) | n | n | n | n | 1 | n | n | n | n
 | 9119 (590/595) | n | n | n | n | n | n | n | 4 | n

System |  | Feature Code
 |  | 1820
POWER4 | 7028 (p630) | 1w
 | 7038 (p650) | 1w
 | 7039 (p655) | 1w
 | 7040 (61D) | 1w
 | 7311 (D10/D11/D20) | 1w

注:W. 表示目前为止，这块Infiniband的卡已经停产了
2.Two GX adapters per CEC enclosure
3. One GX adapter per CEC enclosure

Infiniband 交换机

MTM | Description | Announce | Withdrawn | Replacement
7874-024 | 1U, 24-port 4x DDR IB Edge Switch (QLogic 9024CU) | 2008-11-11 |  |
7874-040 | 4U, 48-port 4x DDR IB Director Switch (QLogic 9040) | 2008-11-11 |  |
7874-120 | 7U, 120-port 4x DDR IB Director Switch (QLogic 9120) | 2008-11-11 |  |
7874-240 | 14U, 240-port 4x DDR IB Director Switch (QLogic 9240) | 2008-11-11 |  |
p/n 26K6454 | Topspin IB Switch Module for BladeCenter | 2004-12-10 |  |
p/n 43W4419 | 4X InfiniBand Pass-thru Module | 2007-10-27 |  |
p/n 32R1756 | Cisco Systems 4X InfiniBand Switch Module | 2006-08-11 |  |
7048-120 | 1U, 24-port 4x | 2005-10-14 | 2006-6-23 | Cisco SFS 7000P
7048-270 | 6U, 32-port 12x or 96-port 4x | 2005-10-14 | 2006-6-23 | Cisco SFS 7008P

突出价值点：IBM早在2004年1月就开始把Infiniband技术应用于其解决方案，是最早应用该技术的厂商之一。与早期PCI 总线和其它各厂商专有的交换网络及I/O 解决方案相比，Infiniband 更具有提供RAS （可靠性、可用性、可服务性）的能力。

Top


什么是Power服务器的Storage Key

解答：

Storage key是 POWER6 和POWER7处理器增加的一项内存保护功能，系统内存可以按照区域分配不同的 Key，通过硬件提供支持来保证只有持有正确的 Key 的代码可以修改其内容。该技术可以应用在 AIX 内核或者用户应用程序代码中，防止由于代码的错误行为（无论是有意还是无意）而可以任意破坏其它内存区域，因此可以进一步提高系统的稳定性。

POWER6有8个Storage Key，其中2个是用户/应用级的，6个是内核级的；POWER7有32个Storage Key，其中8个是用户/应用级的，24个是内核级的。相比POWER6的Storage Key，POWER7 Storage Key的数据隔离颗粒度更细。

突出价值点：Storage Key提升了系统的稳定性。相比POWER6的Storage Key，POWER7 Storage Key的数据隔离颗粒度更细。

Top


什么是CAA（Cluster Aware AIX）

解答:

CAA是Cluster Aware AIX的简称，是AIX V7.1的新特性，原有的AIX V6.1升级到TL06以上也有CAA功能。

使用CAA功能，可以创建、管理多个AIX节点组成集群，从而在1个数据中心内，为创建高可用和理想架构的解决方案提供操作系统层面的支持。RSCT和PowerHA都直接使用CAA服务。采用CAA的AIX与以前版本的主要区别是将集群的拓扑管理内置入操作系统内核中。对事件的监测和消息的管理更加可靠、更加快速。CAA负责cluster的底层功能，PowerHA使用其功能对应用提供高可用性。CAA在AIX标准版/企业版中可以独立使用（用户使用API进行开发，或使用第三方软件），在AIX易捷版中必须配置PowerHA才可以使用。另外，需要注意的是，CAA的集群必须有共享存储。

突出价值点：拓扑管理内置入操作系统内核中，更加可靠、更加快速。


POWER服务器处理器能否升级，以及升级后支持的数量

解答：

POWER6服务器的处理器升级情况如下：

 | JS12 | JS22 | JS23 | JS43 | Power 520 | Power 550 | Power 560 | Power 570 | Power 575 | Power 595
处理器可否升级 | 不可以 | 不可以 | 可以** | 不可以 | 不可以 | 可以 | 可以 | 可以 | 不可以 | 可以
最大Core数 | 2 | 4 | 4 | 8 | 4 | 8 | 16 | 16/32* | 32 | 64
处理器可否混插 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以

* 16-Core配置使用2-Core/Processor Card 处理器板，32-Core配置使用4-Core/Processor Card处理器板。
**JS23的处理器也是固化在主板上的，但可以通过增加一个fc#8446(1-Wide Add-on SMP Chassis)来升级为JS43，从而处理器由4路变为8路。

POWER7服务器的处理器升级情况如下：

 | PS700 | PS701 | PS702 | PS703 | PS704 | Power 710 | Power 720 | Power 730 | Power 740 | Power 750 | Power 755 | Power 770 | Power 780
处理器可否升级 | 不可以 | 可以* | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 可以*** | 可以 | 不可以 | 可以 | 可以
最大Core数 | 4 | 8 | 16 | 16 | 32 | 8 | 8 | 16 | 16 | 32 | 32 | 64** | 64
处理器可否混插 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以

* PS701通过添加#8358 1-Wide Add-on SMP Chassis后，即升级为PS702，CPU扩展到16Core，但会同时占用两个刀片槽位。
**Power 770最大可支持到64Core（4*16Core），但16Core CPU板在中国不销售，在中国最大支持48 Core（4*12Core）。
***Power 740可以支持处理器的升级，但是在做MES的时候，不可以修改处理器的主频，只能添加处理器板的数量。

突出价值点：通过处理器的升级，如果初始配置的处理器不为满配，可以通过MES的方式，升级处理器数量，以满足客户需求，提高系统的处理能力。


POWER6 产品支持的操作系统

解答：

AIX

IBM i

Linux

JS12

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 SP4, or later
AIX V5.3 TL08, or later
AIX V6.1 TL01, or later (Available 6/10/08)
AIX V6.1 TL00 SP5, or later

IBM i 6.1 (formerly known as i5/OS V6R1), or later

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux V4.6 for POWER, or later
Red Hat Linux V5.1 for POWER, or later

JS22

AIX V5.3 TL06 SP4, or later
AIX V5.3 TL07, or later
AIX V6.1 TL00, or later

IBM i 6.1, or later

SUSE Linux 10 for POWER SP1 Update 1, or later
Red Hat Linux for POWER, V4.6, or later
Red Hat Linux for POWER, V5.1, or later

JS23
JS43

AIX V5.3 TL07 SP9, or later
AIX V5.3 TL08 SP7, or later
AIX V5.3 TL09 SP4, or later
AIX V5.3 TL10, or later
AIX V6.1 TL03, or later
AIX V6.1 TL02 SP4, or later
AIX V6.1 TL01 SP5, or later
AIX V6.1 TL00 SP9, or later

同上

SUSE Linux 10 SP2 for POWER Systems, or later
SUSE Linux 11 for POWER Systems, or later
Red Hat Linux 4.6 for POWER
Red Hat Linux 4.7 for POWER, or later
Red Hat Linux 5.1 for POWER
Red Hat Linux 5.2 for POWER
Red Hat Linux 5.3 for POWER, or later

Power 520

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 or later
AIX V6.1, or later

IBM i 5.4 with V5R4M5 machine code, or later
IBM i 6.1, or later

SUSE Linux 10 SP1 for POWER Systems, or later
Red Hat Linux 4.5 for POWER, or later
Red Hat Linux 5.1 for POWER, or later

Power 550

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 or later
AIX V5.3 TL06 SP4, or later
AIX V6.1, or later

同上

同上

Power 560

AIX V5.3 TL06 SP10, or later
AIX V5.3 TL07 SP7, or later
AIX V5.3 TL08 SP5, or later
AIX V5.3 TL09, or later
AIX V6.1 TL00 SP7, or later
AIX V6.1 TL01 SP3, or later
AIX V6.1 TL02 or later

IBM i 6.1, or later

同上

Power 570

For configurations with POWER6 processors (#5620, 5621, 5622, 7380):
AIX V5.2 TL10, or later
AIX V5.3 with TL06, or later
AIX V6.1, or later

For configurations with POWER6 processors (#7387, 7388, 7540):
AIX V5.3 TL06 SP10, or later
AIX V5.3 TL07 SP7, or later
AIX V5.3 TL08 SP5, or later
AIX V5.3 TL09 or later
AIX V6.1 TL00 SP7, or later
AIX V6.1 TL01 SP3, or later
AIX V6.1 TL02 or later

IBM i 5.4.5, or later
IBM i 6.1, or later

同上

Power 575

AIX V5.3 TL08, or later
AIX V6.1 TL02 SP1, or later

不支持

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux 4.6 for POWER, or later
Red Hat Linux 5.2 for POWER, or later

Power 595

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 SP4, or later
AIX V5.3 TL08, or later
AIX V6.1 TL00 SP5, or later
AIX V6.1 TL01, or later

IBM i 5.4 (formerly known as i5/OS V5R4), or later
IBM i 6.1 (formerly known as i5/OS V6R1), or later

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux 4.7 for POWER, or later
Red Hat Linux 5.2 for POWER, or later

注：具体到每个机型，对每个操作系统的版本的小版本要求，请参见该机型的Sales Manual的Technical Description下面的Software Requirements部分。

Power 产品销售手册查询

Top


POWER7 产品支持的操作系统

解答：

POWER7 | AIX | IBM i | Linux | VIOS
PS700/PS701/PS702 | AIX V5.3 TL12, or later AIX V5.3 TL10 SP5 AIX V5.3 TL11 SP5 AIX V6.1 TL06 , or later, AIX V6.1 TL05 SP3, or later AIX V6.1 TL04 SP7, or later AIX V6.1 TL03 SP7, or later AIX V7.1 | IIBM i 6.1 with i 6.1.1 machine code, or later IBM i 7.1, or later. | SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.3.0, or later.
PS703/704 | AIX V5.3 TL12 SP4 AIX V5.3 TL11 SP7 AIX V6.1 TL06 SP5 AIX V6.1 TL05 SP6 AIX V6.1 TL04 SP10 AIX V7.1 SP3 | IBM i 6.1 machine code, or later IBM i 7.1, or later | SUSE Linux Enterprise Server 11 SP1, or later； Red Hat Enterprise Linux Version 5.6 for POWER, or later Red Hat Enterprise Linux Version 6.0 for POWER, or later | VIOS 2.2.0.12-FP24 SP02, or later
Power 710/720/730/740 | AIX V7.1, or later AIX V6.1 TL06, or later AIX V6.1 TL05 SP 3, or later AIX V6.1 TL04 SP 7, or later AIX V6.1 TL03 SP 7, or later AIX V5.3 TL12 SP 1, or later AIX V5.3 TL11 SP 5, or later AIX V5.3 TL10 SP 5, or later | IBM i 6.1 with i 6.1.1 machine code, or later IBM i 7.1, or later. | SUSE Linux Enterprise Server 11 SP1, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.2. or later.
Power 750 | AIX V7.1, or later AIX V6.1 TL04 SP2, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | IBM i 6.1 with i 6.1.1 machine code, or later. | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.11 with Fix Pack 22.1 and SP1, or later.
Power 755 | AIX V7.1, or later AIX V6.1 TL04 SP2, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | - | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.11 with Fix Pack 22.1 and SP1, or later.
Power 770/780 | AIX V7.1, or later AIX V6.1 TL04 SP3, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | IBM i 6.1, or later. | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.12 with Fix Pack 22.1 and SP2, or later.

注：具体到每个机型，对每个操作系统的版本的小版本要求，请参见该机型的Sales Manual的Technical Description下面的Software Requirements部分。

Power 产品销售手册查询

Top


AIX V6.1支持的硬件环境

解答：

AIX V6.1 支持如下系统：

1.运行在POWER4, Power PC970, POWER5, POWER6 或者POWER7 处理器上的IBM Power系统，包括IBM System p, System p5, IBM eServer p5, System i, 和system i5 servers with POWER5 or POWER6/POWER7 processors

2.基于POWER4 和POWER5处理器的IBM eServer pSeries服务器产品线

3.IBM 刀片JS2x Blades 和IntelliStation power 工作站

AIX V6.1 只支持64位的内核。32位和64位的应用在AIX V6.1上可以不用更改，但是32位的设备驱动和内核的延伸在AIX V6.1 上是不支持的。

突出价值点：相比AIX 5.3及其以前版本，AIX V6.1支持工作负载分区(Workload Partition, WPar)。通过 WPAR 可以实现新一级别的 AIX 虚拟化功能，它补充现有的虚拟化功能的不足，实现了应用程序对于资源的更好的使用。


AIX V7.1支持的硬件环境

解答：

AIX V7.1 支持如下的系统：

.基于POWER4，PPC970, POWER5, POWER6, or POWER7的系统上运行，包括IBM System p, System p5, eServer p5, System i, and System i5 servers的服务器。

.基于POWER4和POWER5处理器的eServer pSeries产品线的服务器上运行。

.IBM BladeCenter JS2x刀片服务器和IntelliStation POWER 工作站。

注意：AIX V7.1只支持64-bit内核。AIX V7.1上可以运行32-bit和64-bit的应用，但是，不支持32-bit的设备驱动和内核扩展。

突出价值点：AIX 7既可以运行在POWER7服务器上，也可运行在以前的PPC970、POWER4、POWER5、POWER6服务器上，这有利于保护客户的投资。


AIX EE 6.1版本包含哪些软件

解答：

AIX 6.1EE(AIX Enterprise Edition V6.1.1)是企业版，包含如下几种软件：

*AIX Standard Edition Version 6 TL4
*PowerVM Workload Partitions Manager V2.1
*Systems Director Enterprise Edition

其中关于System Director Enterprise Edition所包含的软件，可以查看:《IBM Systems Director系统软件各个版本包含哪些软件》

突出价值点：AIX 6.1 EE中增加了System Director Enterprise Edition，不但为客户提供管理的便利性，还方便了用户订购，节约了软件成本。


什么是AIX Express Edition? 该版本有何要求？

解答：

AIX Express Edition（易捷版）为较小的工作负载提供了一种更低价的AIX License和SWMA选择。其目标用户为低端Power服务器和刀片Power服务器。在一台大的企业级Power服务器上整合很多的小工作负载的场景，这也是个很好的选择。

AIX 6 以及更高版本提供AIX Express Edition。AIX 5.3以及更早版不提供这个版本。

该版本要求运行其的Power服务器上的每LPAR不能超过4核(core)，并且，每核最多8 GB内存。


AIX V7.1支持的几个新功能

解答：

AIX 7扩展了AIX操作系统的功能，将AIX的垂直可扩展性增强为带256个处理器内核和1024个线程的分区,以便处理最大型的工作负载。

AIX 7支持新的TB级段，能为大型工作负载提供更高的性能，可以充分利用旨在提高内存性能的POWER7处理器的内存管理功能。

AIX 7支持新的虚拟化功能，可以简化先前的AIX V5.2 环境的整合。此新功能需要采购“AIX 5.2 Workload Partitions for AIX 7”产品，旨在允许管理员简便地备份运行 AIX 5.2 的现有 LPAR，并将其还原至 AIX 7 工作负载分区。

AIX 7支持新的称为Cluster Aware AIX的内置群集功能。此新技术在 AIX 基础操作系统中构建了群集技术。此内置群集支持提供了命令和编程 API 来通过 AIX 实例组创建群集，另外还提供了基于内核的检测信号、监控和事件基础架构。此新基础架构支持群集内的存储设备通用设备命名。虽然Cluster Aware AIX功能主要用于为 PowerHA SystemMirror 和 PowerVM等产品提供可靠而又可扩展的群集基础架构，客户也可以直接使用Cluster Aware AIX功能来促进横向扩展计算环境的管理。

AIX 7支持新的可以改善和简化安全性管理的安全性功能。例如，基于角色的访问控制中的新的域支持是对基于角色的访问控制 （RBAC） 的增强，允许制定安全策略来限制对特定类似资源集合（如可用网络适配器的子集）的管理访问。可以使用域来控制对卷组、文件系统、文件和设备的访问。

AIX 7支持AIX Profile Manager等新的易管理性增强特性。AIX Profile Manager 可以通过 XML 配置文件管理 AIX 的配置。此功能基于 AIX 6.1 TL4 引入的 Runtime Expert 功能而构建。这一新的管理功能可以通过IBM Systems Director 界面进行管理和操作。

突出价值点：最新版本 AIX 7.1在虚拟化、安全特性、可用性和管理性方面提供重要的新功能。


IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

解答：

AIX 5.2 Workload Partitions for AIX 7，旨在允许管理员简便地备份运行 AIX 5.2 的现有 LPAR，并将其还原至 AIX 7 工作负载分区。

该功能支持的硬件平台：

POWER7的服务器。

该功能支持的软件平台：

支持的操作系统为：AIX V7.1及以上的版本；

支持的AIX5.2 的具体版本要求：AIX 5200-10 SP8.只有这一个版本支持该功能。

突出价值点：AIX 5.2 Workload Partitions for AIX 7 是在 AIX 7.1 for POWER7 服务器上支持的一个新产品。AIX 7 允许创建一种特殊的 WPAR，为 WPAR 中运行的工作负载提供 AIX V5.2 TL10 SP8 运行时环境。可以把在老式硬件上运行的 AIX V5.2 工作负载简便地迁移到 POWER7 硬件上。


AIX V7.1 标准版，企业版，易捷版的区别

解答：

AIX 7.1支持的3个版本的区别如下：

AIX 7.1 易捷版：每个分区支持最大4C，每C支持最大8GB内存。

AIX 7.1 标准版：支持最大256C，1024线程。

AIX 7.1 企业版：包括AIX 7.1标准版的功能；增加了企业级的管理功能：Systems Director Enterprise Edition和PowerVM Workload Partitions Manager。


AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？

解答：

这三个版本的AIX光盘是完全相同的。

版本的设定可以通过下列方式来设定：

- 安装阶段 (光盘安装时会提示，NIM安装可以在bosinst.data中指定)；
- 安装后可以随时通过chedition。

详见AIX Releases Notes :
http://publib.boulder.ibm.com/infocenter/aix/v6r1/topic/com.ibm.aix.ntl/RELNOTES/SC23-6629-07_pdf.pdf


简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

解答：

现在AIX已经自带GLVM功能，不需要单独购买，GLVM可通过标准的TCP/IP网络实现跨站点的实时数据镜像功能。它提供了与HACMP/XD中GLVM相同的跨站点数据镜像功能，只是没有PowerHA提供的自动监测和恢复的功能。 GLVM可以帮助用户实现跨站点的数据实时镜像，但并不要求像PowerHA一样实现对灾难的自动检测，并自动迁移关键应用到灾备站点的功能。

如需GLVM更详细的技术资料请参考GLVM白皮书：

http://www-03.ibm.com/systems/resources/systems_p_os_aix_whitepapers_pdf_aix_glvm.pdf

突出价值点：用户可以在不增加任何成本的基础上，通过GLVM实现远程数据镜像的功能。


什么是NIM？它的应用场景以及基本概念介绍

解答：

Network Installation Management (NIM)，就是通过网络进行操作系统和软件安装的管理方法。

随着机房内的服务器逐渐增多，分区服务器越来越多的使用， 如何在各服务器或分区上快速安装操作系统和系统软件，使机房内的服务器保持特定版本的操作系统，显得越来越重要。使用NIM不仅能安装和维护AIX操作系统，还能维护和安装其他的软件、补丁。NIM也允许在安装过程中和安装完成后客户化的配置服务器。使用NIM环境可以减少对物理介质的使用，如磁带和光盘，在NIM中这些设备是服务器的资源。也可以使用NIM对服务器进行系统备份，并将其存在NIM环境中的服务器上。在需要时，再使用NIM将备份恢复到同一台服务器上(分区)或其他服务器上(分区)。

NIM环境是由NIM服务器和NIM客户端构成，NIM服务器提供资源(如用于安装的文件和程序)，接受服务器提供资源的称为NIM客户端。 在NIM中，客户端的操作需要使用NIM资源，这些资源实体是由文件和目录构成的。AIX中NIM客户端是通过NFS来访问资源。


NIM中常见的资源类型以及各自的特点介绍

解答：

NIM中常用的resources类型有lpp_source、SPOT和mksysb。

一. lpp_source:

1.指向一个目录, 其内容等同于AIX 的系统光盘或应用程序的安装光盘。
2.包含了需要进行安装的lpp文件, 可以是bff格式 ,也可是rpm格式。

二. SPOT(Shared Product Object Tree):

1.指向一个目录, 其中存放了安装系统的命令(用于将LPP_source中的安装映像安装到服务器上)和用于引导NIM客户机所必需的系统引导映像。(与 /usr 文件系统的内容相同)。
2.包含: 设备驱动程序, BOS的安装程序, 其它与安装相关的代码。

三. mksysb:

1.指向一个文件. rootvg的备份文件, 用于恢复或克隆系统。


一个典型的NIM安装过程介绍

解答：

下面以客户机上没有操作系统为例，简要介绍一下怎样通过NIM安装基本操作系统。(请确认master上已经安装了bos.sysmgt.nim.master和bos.sysmgt.nim.spot)。

在master机器上执行以下步骤:

1.配置NIM master
#smitty nim --> Configure the NIM Environment --> Advanced Configuration --> Initialize the NIM Master Only

在此窗口中为该NIM 网络起个名字, 并且给出相应网络接口名。

2.定义lpp_source
Smitty nim --> Perform NIM Administration Tasks --> Manage Resources --> Define a Resource --> lpp_source

给lpp_source 资源一个名字, 该资源存放在哪台服务器上, 存放到哪个目录下, 如果有安装介质,则指明路径。

3.定义SPOT资源 (使用刚才定义的lpp_source 资源来生成 SPOT 资源)
Smitty nim --> Perform NIM Administration Tasks --> Manage Resources --> Define a Resource --> spot

给出SPOT资源的名字, 存放服务器的名字,SPOT 资源存放的目录名, 在 Source of Install images 中给出所要使用的lpp_source 名字, 给出相关信息后, 回车, SPOT就会从lpp_source中读取所需的内容, 并将结果存放到指定的目录中, 其过程与为系统安装软件类似(会有一段时间)。

4.在master上定义NIM client
Smitty nim --> Perform NIM Administration Tasks --> Manage Machince --> Define a Machine

给出NIM client 的名字, 为 communication protocol used by client 选择 nimsh 然后回车, NIM client 的设置就完成了。

5.为 nim client 系统安装做准备
Smitty nim --> Perform NIM Software Installation and Maintenance Tasks --> install and update software --> Install the Base Operating System on Stankalone Clients --> 选择client --> rte --> 选择前面定义过的 lpp_source 和 SPOT 资源 名称。

将 initiate reboot 设为 no, 回车, NIM master 为nim client 就做好了安装准备。

在client机器上执行以下步骤:

6.引导 NIM Client
开启nim client 服务器或分区, 进入 SMS 菜单, 选择 Setup Remote IPL。

7.选择与NIM master 通讯的网卡。

8.设置NIM master 和 NIM client 的IP 地址,网关和子网掩码, 回上层菜单，做与NIM master连通测试。

9.通过网络引导系统
SMS --> boot option --> Select Install/Boot Device --> network --> Normal Mode Boot

系统就会从NIM master 上获得 bootp 映像, 接下来就进入BOS的安装过程。

Top


什么是ASMI及简要介绍

解答:

高级系统管理界面（Advanced System Management Interface 简称ASMI）是由IBM Power服务器的服务处理器（Service Processor）所提供的管理界面，系统管理员能够通过它设置服务器的参数，比如自动启动到诊断模式、设置服务处理器和控制系统是否加电，或者是查看系统信息，比如查看错误日志和VPD。

系统管理员可以使用装有互联网浏览器的PC，通过以太网来访问高级系统管理界面,也可以通过连接在服务器串口上的终端或硬件管理终端(HMC)来访问高级系统管理界面。

使用高级系统管理界面，系统管理员能够完成以下工作：

1、设置高级系统管理界面的登录配置文件。系统管理员可以修改访问高级系统管理界面的口令，查看登录审核记录，以及修改默认的高级系统管理界面语言。
2、查看系统信息。系统管理员可以查看系统电源控制网络（SPCN）的跟踪数据，进度指示器历史和VPD。
3、控制系统电源。系统管理员可以控制系统加电和启动的方式。
4、修改系统设置。系统管理员可以在高级系统管理界面中定制服务器的工作方式，比如打开/关闭PCI错误注入策略和修改内存配置。
5、修改高级系统管理界面的网络设置。系统管理员可以为高级系统管理界面配置网络界面参数，并对虚拟的TTY设备进行调试。
6、使用随需应变的工具。系统管理员可以在不重新启动服务器的情况下激活处理器和内存。
7、使用并发管理工具。系统管理员可以在不重新启动服务器的情况下替换某些设备。
8、使用Service Aid工具对服务器进行诊断。系统管理员可以查看错误信息或者启动服务处理器的DUMP。


Power服务器的电源和耗电量计算方法

解答：

POWER6, POWER7和P5服务器的电源计算是通过不同的方法进行计算的：

POWER6, POWER7服务器的计算方式参考如下的网页：
http://www-912.ibm.com/see/EnergyEstimator

注意，在每次进入计算工具之前，需要接受一个使用该计算工具的许可，您可以在看完该许可以后，点击“I accept”即可。

然后选择国家(Country/Region),语言(Language),数字格式(Number Formatting)，用户类型(User Type)；点击继续(Continue);选择需要计算的产品型号，相应的产品的处理器主频和对应的处理器数量的范围，进入以后，在详细设定处理器数量，内存，硬盘，PCI槽位，扩展等机型的具体信息，进行计算。

也可以导入e-config导出的XML文件或者SPT工具导出的sysplan文件。然后选择“restore”，可以还原导入文件的配置，并计算出相应配置的服务器的功率和散热量。该功能为Energy Estimate工具2010年9月更新的新功能。

P5服务器的计算方式参考如下的网页：
http://publib.boulder.ibm.com/infocenter/systems/scope/hw/topic/iphdl_p5/powerloadcalc.htm

选择需要计算功率的机型，在每次进入计算工具之前，需要接受一个使用该计算工具的许可，您可以在看完该许可以后，点击“I Accept”即可，然后和POWER6的计算方法类似，需要选择处理器数量和主频，内存，硬盘，PCI卡，DVD，磁带机等信息，进行计算。

参考网页：
http://publib.boulder.ibm.com/infocenter/systems/scope/hw/index.jsp?topic=/iphdl_p5/systemcalculators.htm&resulto f=%22%73%79%73%74%65%6d%22%20%22%63%61%6c%63%75%6c%61%74%6f%72%22%20&searchQuery=%73%79%73%74%65%6d%20%63%61%6c%63%75 %6c%61%74%6f%72&searchRank=%30&pageDepth=%30

突出价值点：Sales Manual给出的是最大功率。您可以使用以上所述工具估算实际配置下的功率，同时还可以通过导入e-config工具和SPT工具导出的相关格式的文件，直接计算出服务器的具体功耗等信息。
基于IBM POWER6,POWER7处理器的服务器内置了EnergyScale能源管理技术，该技术提供了一系列的功能来监视以及节省基于IBM POWER6,POWER7处理器的服务器的能源消耗。


Power系列机型上共有多少种SAS连接线, 它们有什么不同

解答：

Power系列机型上共有11种SAS连接线,我们来分别介绍它们的功用:

(1)Power 520/550/750上连接磁盘背板到后机箱的SAS连接线, Power 520上是fc#3674,Power 550/750上是fc#3668, 当磁盘背板的外部SAS接口用来连接外置的磁盘柜fc#5886时要用到这种SAS线.

(2)Power 520/550/750上磁盘背板分离时连接背板到后机箱的SAS连接线,以提供对另外三块磁盘的访问,520上是fc#3670, 550/750上是fc#3669.

(3)AI线, Feature Code是fc#3679,用在Power 520/550/750上时,连接SAS卡到机箱接口,与fc#3669(Power 550/750)或fc#3670(Power 520)一起使用以提供对磁盘背板的分离功能;用在Power 560/570上时,可以与fc#5909/fc#5911一起使用以提供对CEC上磁盘背板的分离功能,也可以与fc#3650/fc#3651一起使用,提供对CEC上磁盘背板的分离功能，用在Power770/780上时，可以与fc#1815和fc#5901一起使用，以提供对CEC上磁盘三分离背板的功能.

(4)AE线,用来连接SAS卡和Media扩展柜(如7214-1U2).

(5)AT线,用在PCIe 12X的I/O扩展柜上以连接SAS卡和扩展柜上的磁盘.

(6)EE线,用来连接两个磁盘扩展柜(fc#5886)的堆叠,注意,最多只能堆叠一层.

(7)YO线,连接SAS卡和磁盘扩展柜(fc#5886).

(8)YI线,用在Power 520/550/750上,用于磁盘背板的外部SAS接口与磁盘扩展柜(fc#5886)的连接,需要与fc#3674(Power 520)或fc#3668(Power 550/750)一起使用.

(9)X线, 连接一对SAS RAID卡与磁盘扩展柜(fc#5886)以提供磁盘RAID功能.

(10)YR线,用在Power 560/570上,连接一对SAS RAID卡与CEC上的磁盘以提供RAID功能,需要与Cable Card(fc#3651)一起使用.

(11)AA线，Adapter to Adapter SAS Cable,当用两块5904/5906/5908做RAID 5或RAID 6时，用于连接该两块SAS卡.

突出价值点：IBM产品成功实现了从SCSI到SAS的转变。SAS连接线有不同种类和长度，客户可以根据不同需求进行相应选择。

Top


FCoE支持的操作系统

解答：

目前，有如下几个编号的FCoE卡：fc#8275，fc#5708,fc#5270。

对于POWER6 服务器上所使用的FCoE卡：fc#8275，fc#5708，其支持的操作系统如下:

VIOS V2.1.2.0;
AIX 5.3 with the 5300-11 Technology Level, 及以上版本;
AIX 6.1 with the 6100-04 Technology Level, 及以上版本;
SUSE Linux Enterprise Server 10 Service Pack 3, 及以上版本;
Red Hat Enterprise Linux 5.4, 及以上版本;
IBM i 6.1 for NIC through VIOS (not directly supported).

对于POWER7服务器上FCoE卡（fc#8275，fc#5708,fc#5270）所支持的操作系统，可以直接参考POWER7服务器所支持的的操作系统的兼容信息。
http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=1611200J08000

突出价值点：目前Power 520/550/560/570/575/595/750/755/770/780上支持的FCoE卡是fc#5708；JS和PS刀片上支持的FCoE卡是fc#8275；Power 710/730上支持的FCoE卡是fc#5270（Low-Profile PCIe）；Power720/740上支持的FCoE卡是fc#5708和fc#5270。


为什么选择FCoE/FCoEE

解答：

选择FCoE/FCoEE的理由如下：

1.可以节省PCI插槽，一个FCoE卡可以替代一个以太网卡加一个光纤卡。

2.相应节省插槽，可以减少 I/O 抽屉的使用。

3.由于FCoE交换机替代了光纤交换机和以太网交换机，而且 I/O 抽屉减少，因此节省了机柜的使用空间。

4.由于更少的卡和 I/O 抽屉的使用，因此节省了电力和制冷的消耗。

5.使用以太网线替代了原有光纤加以太网线，因此配线更简单。

6.很好的适应性，可以随着时间的推移，在现有硬件的基础上很容易地调整到符合客户的需求。

突出价值点：FCoE能减少数据中心的接口卡、电缆和网络设备，从而使数据中心变得比较简单、绿色环保。在一些大公司，如果能减少电缆数量，将会对空气流动产生积极作用，并减少降温成本。


什么是IBM Systems Director Active Energy Manager

解答：

IBM Systems Director Active Energy Manager目前版本为V4.2, 是IBM Systems Director软件中的插件，是能耗监测管理工具。

对于支持AEM的Power服务器，它既可以对当前能耗和散热情况进行检测，也可以记录和分析能耗和散热历史数据。

对于其他服务器和设备，可以通过智能PDU来监测。

与基于POWER6处理器的EnergyScale技术相结合,可以实现能耗限制和自动降低能耗等控制功能。

其监测功能的使用授权是免费的。

IBM Systems Director Active Energy Manager 可以在IT架构中，通过支持的Power服务器提供平台监控和能耗使用报告。Systems Director Active Energy Manager 通过数据中心控制支持的Power服务器的能耗来提高能量的使用效率，对我们的客户来说，可以真正的节省和降低花费。此解决方案是IBM智慧的地球之动态架构的能源解决方案的组成部分。

IBM Systems Director Active Energy Manager 可以帮助客户通过数据中心更好地了解能耗的使用情况:

*确定能耗的使用；
*精确地测定散热的成本；
*监控IT花费；
*由部门和/或用户进行管理。

突出价值点：IBM POWER6 EnergyScale技术与IBM Systems Director能源管理器(Active Energy Manager, 以下简称AEM)是IBM绿色创新计划的重要基础。基于IBM POWER6处理器的服务器内置了EnergyScale能源管理技术来监控以及节省能源消耗，而AEM作为一个集成的能源管理平台，能够处理和显示EnergyScale收集的数据，调用EnergyScale的相关能源管理功能。


IBM Systems Director 系统软件各个版本包含哪些软件

解答:

IBM新推出的Systems Director系统软件包含三个版本，Systems Director Enterprise Edition，Systems Director Standard Edition和Systems Director Express Edition。下面单独列出了每个版本所包含的相关软件：

Systems Director Enterprise Edition 包括：
* Systems Director Standard Edition 所有功能
* Systems Director VMControl(TM) Enterprise Edition for Power, V2.2
* Tivoli Monitoring (ITM)
* Tivoli Monitoring for Energy Management
* Tivoli Application Discovery and Dependency Manager (TADDM)
* Systems Director Enterprise Edition Installation Launchpad

Systems Director Standard Edition 包括：
* Systems Director Express Edition 所有功能
* Systems Director Active Energy Manager V4.2
* Systems Director VMControl(TM) Standard Edition for Power, V2.2
* Systems Director Network Control V1.1

Systems Director Express Edition 包括：
* Systems Director V6.1
* Systems Director VMControl(TM) Express Edition for Power, V2.2
* Systems Director Service and Support Manager V6.1.2
* Systems Director Transition Manager for HP Systems Insight Manager V6.1


IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

解答:

Systems Director是一套系统管理软件，包括Express, Standard, Enterprise三个版本，下面是三个版本的功能列表。

Systems Director Express版本，包括了一套管理工具，通过提供清晰的IT系统组件的关系图和运行状态，从而降低系统操作复杂度。

其功能包括：

* 提供对物理服务器、虚拟服务器以及存储资源的自动发现和拓扑视图；
* 对运行于Power服务器之上的AIX, IBM i, 和Linux提供虚拟化管理；
* 简化部署、安装和更新步骤；
* 对所监控的系统提供自动报告硬件故障，收集系统服务信息的功能；
* 提供符合行业标准的，对AIX和IBM i的单一系统、平台级别管理功能；
* 通过Launch-in-context功能与HMC集成；
* 通过向导、教程和帮助功能，简单易学。

Systems Director Standard 版本，能够降低部署工作负载时间，从而提高效率，并且还能优化电量的使用。

其功能包括：

* System Director Express版本的所有功能；
* 抓取、导入，创建、删除标准的虚拟镜像；
* 部署标准虚拟镜像；
* 在中心库里面维护虚拟镜像；
* 监控电量的使用，分析电力和散热的趋势；
* 通过支持的工具设备，例如UPS、PDU，感应器，以及机房空调设备单元提供的监控应用等，来实现对旧有系统设备的监控；
* 提供对服务器的电力使用限制(cap)功能；
* 节能模式，会根据处理器的使用率和数据中心设备的海拔高度来进一步优化；
* 对网络设备的发现和状态监控功能。

Systems Director Enterprise 版本，提供高级的性能和可用性管理，为Dynamic Infrastructure提供自动的资源平衡机制。

其功能包括：

* System Director Standard 版本的所有功能；
* 创建、删除系统池，对系统池内的一个服务器上的资源进行管理；
* 在系统池内添加、删除物理服务器；
* Workload Partition (WPAR)的创建和管理；
* LPAR对服务器，对应用的关系的虚拟化；
* 对虚拟环境进行实时的、乃至预告式的监控；
* 对性能管理和容量评估进行预告。

突出价值点：Systems Director为数据中心不同的服务器和存储设备提供了一个统一的、集成的管理界面，大大简化了系统管理，提高系统管理效率，并为云计算提供了切实可行的管理工具。

Top


被管理服务器所监控和管理的服务器是否均需购买Systems Director软件？

解答:

是的，无论是管理节点还是被管理的服务器均需要在每台服务器上安装Systems Director软件。Systems Director软件根据服务器上所激活的处理器核数授权。每台服务器上每一个激活的处理器均需购买相应的license。不同的受管服务器可以使用不同版本的Systems Director软件，但管理节点必须为最高版本的Systems Director软件。

AIX企业版包括Systems Director企业版，所以Systems Director软件不再需要作为一个单独的产品报价。

通过下图，以确定哪个版本的Systems Director软件符合客户的要求：

突出价值点：不同版本的Systems Director软件可以提供不同级别的功能，供客户灵活选择。


目录 产品配置常见问题汇总

目录

IBM Power Systems 常见配置问题汇总

刀片服务器

BladeCenter H机箱中10个I/O插槽的配置规则 (最近更新)

7989-BCH机箱怎样配置冗余的电源以及电源线？

BladeCenter S电源配置问题 (最近更新)

BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项

当配置Power刀片的刀片中心BladeCenter H 时,都有哪些SFP(光纤连接模块)可以用在该刀片中心？

怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card?

如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？ (最近更新)

BCH和BCS上有多种以太网交换机模块，如何为客户选择

刀片中心的fc#5045、fc#5869 Brocade SAN交换模块是否需要配置full-fabric的级联license (新增)

如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块

JS43，PS702和PS704是否集成了两个SASController？ (最近更新)

刀片做HACMP推荐方案 (最近更新)

POWER6

Power 520/550

在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

如何在Power 520/550 服务器上创建RAID 5? (最近更新)

如何实现Power 520和550的2个LPAR的RAID功能?

如何配置Power 520服务器内置磁盘分区的功能 (最近更新)

如何配置Power 550服务器内置磁盘分区的功能 (最近更新)

如何配置Power 520 和550 三个及以上分区

配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜

能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘?

Power 560/570

Power 570的Processor Power Regulator是什么？

如何在Power 570上创建RAID 5? (最近更新)

Power 570在一个CEC中，如何配置2个分区

Power 570在多个分区的情况下，如何实现光驱在分区之间的切换?

如何实现Power 560和570内置硬盘之外增加LPAR

Power 595

Power 595内存的配置规则

用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜?

怎样在Power 595上配置内置光驱和磁带机?

其他

Power 520/550/560/570/595 CPU, MEM, Disk的配置规则?

POWER7

Power 710/730

对Power 710/730，请问如何配置适配卡来支持HA

Power 710/730服务器的内置磁盘不支持分离背板的功能

Power 710/730的内存配置及规则

在e-config中，Power710/730可以配置的内置磁带机和磁带介绍 (新增)

Power 720/740

Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

Power 720/740的内存配置及规则

如何在Power720/740上配置3个以上分区 (新增)

在e-config中，Power 720/740 可以配置的内置磁带机和磁带介绍 (新增)

哪些配置情况下会使Power 720/740的噪音增加 (新增)

Power 750/755

如何在Power 750上实现硬盘背板的分离

如何配置Power 750三个及以上分区

如何实现Power 750的RAID功能

Power 750/755的内存配置规则

Power 770/780

如何在Power 770/780上实现硬盘背板的分离

如何实现Power 770/780的RAID功能

在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗

Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置

其他

POWER7服务器 CPU，MEM，DISK的配置规则 (最近更新)

POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项

POWER7服务器如何配置3.5英寸的磁盘

POWER7全线产品家族分离背板总结 (最近更新)

其他

System P 服务器如何选配置电源线? (最近更新)

介绍Power服务器上fc#6577的电源线

如何在e-config中选择7316-TF3?

POWER服务器上的几种 10 Gigabit的以太网卡有什么不同?

配置FCoE卡时的注意事项

用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？ (最近更新)

新发布的SFF硬盘和SSD 硬盘的特性是什么? 如何配置?

为什么必须要配置一对fc#5805的RAID卡？

fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？

Power中异步卡和串口线的选择

在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？ (最近更新)

fc#5802/5803如何配合主机实现分区功能

Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

Power服务器常用I/O抽屉配置方法 (最近更新)

System P服务器都支持哪一些类型的I/O Drawer? (最近更新)

怎样配置fc#5796和fc#5802的IO抽屉

7014-T00/T42/B42机柜PDU和电源线的配置介绍

为什么现在在配置中介质会出现ESD，如何避免？ (新增)

如何通过e-config工具，配置C/C++, fortran, Cobol等开发环境 (新增)


配置 刀片服务器

刀片服务器

BladeCenter H机箱中10个I/O插槽的配置规则 (最近更新)

7989-BCH机箱怎样配置冗余的电源以及电源线？

BladeCenter S电源配置问题 (最近更新)

BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项

当配置Power刀片的刀片中心BladeCenter H 时,都有哪些SFP(光纤连接模块)可以用在该刀片中心？

怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card?

如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？ (最近更新)

BCH和BCS上有多种以太网交换机模块，如何为客户选择

刀片中心的fc#5045、fc#5869 Brocade SAN交换模块是否需要配置full-fabric的级联license (新增)

如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块

JS43，PS702和PS704是否集成了两个SASController？ (最近更新)

刀片做HACMP推荐方案 (最近更新)


BladeCenter H机箱中10个I/O插槽的配置规则

解答:

10个I/O插槽分为三种,其中Bay 1-4为普通模块插槽,Bay 5-6为桥接模块插槽,Bay 7-10为高速模块插槽。Bay 1-2必须放置以太网的交换模块或以太直通模块.

可以放在Bay 1-4上的模块有:
BNT 1/10 Gb Uplink Ethernet Switch Module (fc#1590)
Cisco 3110X Catalyst Switch (fc#3171)
Cisco 3110G Catalyst Switch (fc#3173)
Cisco 3012 Catalyst Switch (fc#3174)
BNT Layer 2/3 Copper Gigabit Ethernet Switch Modules for BladeCenter (fc#3212)
Server Connectivity Module for BladeCenter (fc#3220)
Intelligent Copper Pass-thru Module (fc#5452)

Nortel 10 GB Uplink Ethernet Switch Module (fc#3210)(已停产)
BNT Layer 2-7 GbE Switch Module for BladeCenter (fc#3211)(已停产)
Nortel Networks L2/L3 Fiber Gigabit Ethernet Switch Module (#3213)(已停产)
Cisco Systems Fiber Intelligent Gigabit Ethernet Switch Module (fc#3214)(已停产)
Cisco Systems Intelligent Gigabit Ethernet Switch Module (fc#3215)(已停产)
Optical Pass-thru Module (fc#3218)(已停产)
Copper Pass-thru Module (fc#3219)(已停产)

可以放在Bay 3-4上的模块有:
Cisco Systems 4Gb 20-port Fibre Channel Switch Module (fc#3242)
IBM BladeCenter SAS Connectivity Module(fc#3267)
Brocade 10-port 8 Gb SAN Switch Module for IBM BladeCenter (fc#5045)
Brocade 20-port 8 Gb SAN Switch Module for IBM BladeCenter (fc#5869)

QLogic 4Gb 20-port Fibre Channel Switch Module (fc#3202)(已停产)
QLogic 4Gb 10-port Fibre Channel Switch Module (fc#3203)(已停产)
Brocade 20-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3206) (已停产)
Brocade 10-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3207)(已停产)
McDATA 4Gb 20-port Fibre Channel Switch Module (fc#3208)(已停产)
McDATA 4Gb 10-port Fibre Channel Switch Module (fc#3209)(已停产)
Cisco Systems 4Gb 10-port Fibre Channel Switch Module (fc#3241)(已停产)
QLogic 10-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3243)(已停产)
QLogic 20-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3244)(已停产)
QLogic 4 Gb Intelligent Pass-Thru Module for IBM BladeCenter (fc#3245)(已停产)
Optical Pass-thru Module (fc#3218)(已停产)
Copper Pass-thru Module (fc#3219)(已停产)
QLogic 20-port 8 Gb SAN Switch Module (fc#3284)
QLogic 8 Gb Intelligent Pass-thru Module (fc#5449)

不可以在Bay 3 和Bay 4 之间混插以太网连接模块（包括铜口Pass-thru Module）和SAN连接模块，而混插光口的Pass-thru Module和以太网连接模块（或SAN连接模块）是允许的。Bay 5-6上的Bridge modules提供到Bay 7-10的连接，它们不直接与刀片连接。Bay 7-10支持高速的协议比如4X InfiniBand。

可以放在Bay 7或 Bay 9上的模块有:

Cisco Nexus 4001I Switch Module for IBM BladeCenter H(fc#2241)
Voltaire 40 Gb Infiniband Switch Module for IBM BladeCenter(fc#3204)
4X InfiniBand Pass-Thru Module for IBM BladeCenter (fc#3216)
Multi-Switch Interconnect Module (fc#3239)
1个(fc#3239)将两个高速模块插槽转换为两个普通插槽，可以放置在Bay 1-4上的模块都可以放置在转换后的普通插槽上。
BNT 10-port 10 Gb Ethernet Switch Module for IBM BladeCenter(fc#3248)
10 Gb Ethernet Pass-Thru Module(#5412)

4X InfiniBand Pass-Thru Module for IBM BladeCenter (fc#3216)(已停产)
Cisco Systems 4X InfiniBand Switch (fc#3217)(已停产)

请参考销售手册中的Description备注

BladeCenter　H 销售手册

突出价值点：BCH支持14个刀片服务器，拥有10个I/O插槽，目前有20多种可选的交换或者直通模块，可根据客户的需求，在BCH上合理选择相应的模块。

Top


7989-BCH机箱怎样配置冗余的电源以及电源线？

解答:

IBM刀片中心(BladeCenter)是放置刀片服务器(BladeServer)的机箱。目前有五种机箱可以选择。型号分别是BC-E,BC-H,BC-T,BC-HT,BC-S。其中BC-E是一款入门级机箱，7U高度，可以放置14片刀片服务器。BC-H是一款高性能机箱，9U高度，可以放置14片刀片服务器。BC-T和BC-HT是符合电信标准的机箱。BC-S机箱内部可以放置12块磁盘，6片刀片服务器。

现将BC-H机箱电源与电源线配置的注意事项做详细的介绍。

从上图中可以看到BC-H中的电源模块放置在机箱的上下两端。上端可以放置两个电源模块，下端可以放置两个电源模块。BC-H机箱最多可以放置四个电源模块（每个电源模块提供2980W功率）。每个电源模块的位置都被编号。具体编号如上图所示。电源模块的配置要遵守以下几条规则：

电源模块要成对配置。

第一、二号位置上放置的电源模块叫标准电源模块，在定购机箱时这两个位置上的模块是必须要购买的，其Feature Code为：fc#9058，这两个电源模块是负责给一至七号刀片服务器和一 至四，七至十号I/O模块供电的。第三、四号位置上放置的电源模块叫可选电源模块，其Feature Code为：fc#3205，这两个模块是负责给八至十四号刀片服务器和五到十号I/O模块供电的。

注意：fc#3200 2900W的电源已经于2010年10月29日停产。替代的电源为2980W的电源模块，默认的电源模块编号为：fc#9058，可选电源模块编号为：fc#3205。

在BC-H电源线配置方面，BC-H机箱在购买时默认不带电源线，电源线需要随机箱单独购买。在中国购买BC-H机箱时要购买编号为fc#6673的电源线，下图为电源线示意图，圆形的插头是连接到BC-H机箱上，另外三个方形的插头连接到机柜的PDU上。三个方形插头其中有两个是为BC-H机箱的电源模块供电的，另一个插头是为风扇供电的。

如果要把购买的BC-H机箱放置到机柜中，目前只有一款7014-B42的机柜可以放置BC-H机箱。7014-T00/42都不能用来放置BC-H机箱。

请参阅IBM红皮书: SG247523

下载地址: http://www.redbooks.ibm.com/redbooks/pdfs/sg247523.pdf

突出价值点：为系统提供冗余的电源保护，增强系统的可用性。

Top


BladeCenter S电源配置问题

解答：

在e-config中，目前BladeCenter S只支持一种电源：

fc#4505 IBM BladeCenter S 950W/1450W Auto-Sensing PS (C14)

该电源可配置如下的电源线：
BladeCenter S to PDU:
fc#6458 Power Cable - Drawer to IBM PDU, 14-foot, 250V/10A

BladeCenter S to WALL:
fc#6493 Power Cord (9-foot), To Wall/OEM PDU, (250V, 10A), Plug Type #62

什么时候需要添加第二对电源模块？

BladeCenter S的所有电源模块都在同一个电源域(Power Domain)中，为每个刀片、模块供电。当需要在BladeCenter S上配置多于2个刀片或者加第二个DSM(Disk Storage Module)，或者在bay 2和bay 4装模块的时候，必须配置第二对电源模块。

突出价值点：可以将BladeCenter S放到IBM 19英寸的机柜里，将fc#6458电源线连接到C13标准的PDU(fc#7188/9188)上，目前可以放置的机柜为：7014-T42、7014-T00以及7014-B42；也可以将其放到OEM的19英寸机柜里，此时需要配置fc#6493的电源线来进行连接。

Top


BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项

解答：

NSSM(fc#3267):IBM 刀片中心SAS普通连接模块(IBM BladeCenter SAS Connectivity Module)。

.支持BladeCenter S 和 BladeCenter H刀片中心；
.不支持RAID功能；
.支持 TS2240 磁带机；
.支持 DS3200 盘阵；
.配置可以1个,推荐2个；
.要求刀片内配置SAS子卡。

RSSM(fc#3734):IBM 刀片中心SAS RAID控制交换模块（SAS RAID Controller Switch Module）。

.仅支持在BladeCenter S刀片中心,用于对BladeCenter S内部的磁盘提供RAID功能的支持；
.支持RAID 0, 1, 5, & 10；
.支持 TS2240 磁带机；
.不支持 DS3200 盘阵；
.配置必须要求2个；
.要求刀片内配置SAS子卡。

注意：fc#3734 RSSM不支持和fc#3267 NSSM同时存在于BladeCenter S中。

fc#3267和fc#3734支持：
JS12/22刀片中的fc#8250 CFFv SAS 卡
JS23/43/PS700/PS701/PS702刀片中的fc#8246 CIOv SAS 卡

关于 SAS RAID Controller Switch Module的兼容列表，参考如下链接：

IBM BladeCenter S SAS RAID Module Interoperability Matrix
ftp://ftp.software.ibm.com/systems/support/system_x_pdf/ibm_fw_bcsw_s0cl-interoperability_1.30.pdf

突出价值点：使用SAS Connective Module(fc#3267)连接的BCS里的硬盘，目前只能分配给指定的刀片，供某个刀片独立使用，不能实现刀片之间的存储共享；而SAS RAID Module(fc#3734)可以实现存储共享。

Top


当配置Power刀片的刀片中心BladeCenter H时，都有哪些SFP(光纤连接模块)可以用在该刀片中心？

解答：

主要有短波和长波两种属性的模块可以用在刀片中心BladeCenter H上。每一个FC(feature code)代表着一个SFP模块。

在配置Switch以及SFP时候，我们一定还要考虑冗余路径的问题，所以Switch和SFP数量上都不能少。在为刀片中心BladeCenter H配置交换机的时候，大家要注意所有20口的交换机会有6个对外的接口，e-config工具只会默认配置一个SFP，所以其余的5个端口大家如果想要使用，必需手动的选择SFP数量；而对于所有10口的交换机，会有3个对外的接口，e-config工具也只会默认配置一个SFP给交换机，其余的2个端口大家如果想要使用，必需手动的选择数量。

以下是几种常用的SFP模块:

fc#3261 Cisco SYSTEMS 4 GB SHORT-WAVE LENGTH SFP MODULES (Cisco 4GB 短波光纤模块 一个)
主要用在fc#3241 Cisco 4 Gb 20 port的光纤交换机或者fc#3242 Cisco 4 Gb 10 port的光纤交换机使用。

fc#3238 IBM SHORT WAVE SFP MODULE, 4 GB (IBM 4GB 短波光纤模块 一个)
主要用在fc#3206 Brocade 20-port 4 Gb 光纤交换模块上或者用在fc#3207 Brocade 10-port 4 Gb 光纤交换模块上。

fc#3286 8Gb SFP+ Short Ware optic transceiver (QLOGIC 8 Gb 短波光纤模块 一个)
主要用在 fc#3284 QLOGIC 8 Gb 20 port的光纤交换机。

fc#3282 IBM 10 Gb Ethernet 850 nm Fiber SFP+ Transceiver (IBM 10 Gb ethernet 850nm 光纤收发模块 一个)
主要用在 fc#1590 BNT 1/10 Gb Uplink Ethernet 交换机上。

fc#5358 Brocade 8 Gb SFP+ Short-wave Optic Transceiver(Brocade 8Gb短波光纤模块 一个)
主要用在fc#5045 Brocade 8 Gb 10-port 和 fc#5869 Brocade 8 Gb 20-port光纤交换模块上 。

fc#3236 IBM SHORT WAVE SFP MODULE (IBM 短波光纤模块 一个)(已停产)
IBM Short Wave SFP Module for connecting switches to Storage Area Networks
主要用在fc#3213 Nortel 20 port 光纤网络交换机或者fc#3214 Cisco 20 port 的智能光纤网络交换机上使用。

fc#3237 IBM LONG WAVE SFP MODULE （IBM 长波光纤模块 一个）(已停产)
IBM Long Wave SFP Module for connecting switches to Storage Area Networks

fc#3262 Cisco SYSTEMS 4 GB LONG-WAVE LENGTH SFP MODULES (Cisco 4GB 长波光纤模块 一个)(已停产)
主要用在fc#3241 Cisco 4 Gb 20 port的光纤交换机或者fc#3242 Cisco 4 Gb 10 port的光纤交换机使用。

突出价值点：目前，BCH上可以配置5种SFP模块，这5种SFP模块可以用在Cisco 4Gb的光纤交换模块,Brocade 4Gb/8Gb的光纤交换模块,Qlogic 8Gb的光纤交换模块以及BNT 1/10Gb Uplink ethernet交换模块上。

Top


怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card

解答：

fc#8252同时拥有两个4Gb光纤接口和两个1Gb的以太网口，会占用刀片服务器的一个PCI-E插槽，fc#8252在对外连接使用之前，首先必须先在刀片机箱（BladeCenter H）上配置一个多路转换模块MSIM:fc#3239-Multi-Switch Interconnect Module，这个fc#3239将会把刀片机箱（BladeCenter H）上四个上下结构的高速交换槽位转换成左右结构的标准交换槽位，分别是bay 7，8，9，10；其中左侧的两个位置是负责fc#8252的两个以太网口通信的，右侧的两个位置是负责fc#8252的两个4Gb光纤接口对外通信的。如图下图所示：

突出价值点：fc#8252同时拥有两个4Gb光纤接口和两个1Gb的以太网口，相当于一块双口1Gb以太网卡和一块双口4Gb光纤卡，但#8252只占用刀片服务器的一个PCI-E插槽，从而节省了PCI槽位。

Top


如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？

解答：

 |  | Pass-Thru Feature | External Port | Cable | 对应关系
BladeCenter H | 支持以太网协议 | fc#5452-Intelligent Copper Pass-thru Module | 14个RJ-45 | 普通网线 | 1-1
 | 支持以太网、FC和FCoE协议 | fc#5412-10Gb Ethernet Pass-Thru Module | 14个 | fc#3282-IBM 10 Gb Ethernet 850 nm Fiber SFP+ Transceiver | one to one mapping
BladeCenter S | 支持以太网协议 | fc#5452-Intelligent Copper Pass-thru Module | 14个 | 普通网线 | 1-1连接

Top


BCH和BCS上有多种以太网交换机模块，如何为客户选择

解答：

在为客户选择以太网交换机时，需要考虑以下几个方面：

1)价格；

2)厂商(客户是否偏好某一厂商)；

3)交换机本身的相关参数：
(a) 支持以太网协议的层次：L2，L2/L3，还是支持到L7；
(b) 未来客户需求的变化。比如目前1G就够用，但在不久的将来也许就变成10G才够用，如果是这样，可以现在就考虑为客户配置10G的交换机；
(c) 可管理性(管理工具、CLI命令接口，管理软件)；
(d) 上行/下行速率(1Gb还是10Gb)；
(e) 性能(带宽、时延)；
(f) 耗电量(单个交换机也许影响不大，但是当数据中心里有很多台设备，差异就体现出来了)。

需要说明的是，有的客户可能倾向于思科的网络交换机，但是，其实客户也可以考虑选择BNT的网络交换机。因为，BNT的网络交换机与思科的有相似的CLI，能操作思科网络交换机的工程师，对BNT网络交换机的操作也易于上手。

突出价值点：IBM为客户提供了多种以太网交换模块。客户可以根据实际需求来灵活选择。


刀片中心的fc#5045、fc#5869 Brocade SAN交换模块是否需要配置full-fabric的级联license

解答:

不需要！
fc#5045、fc#5869默认状态下已经包括了full-fabric的许可。


如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块

解答：

BCH中支持FCoE功能的交换模块有：
fc#2241 Cisco Nexus 4001I Switch Module for IBM BladeCenter H
fc#3248 BNT 10-port 10Gb Ethernet Switch Module for BladeCenter

但需注意：fc#2241 Cisco Nexus 4001I Switch Module for IBM BladeCenter H交换模块需要额外购买fc#2242 Software Upgrade License for Cisco Nexus 4001I软件升级许可，来启用FCoE功能。

在POWER7刀片服务器中，可以配置fc#8725 QLogic 2-port 10 Gb Converged Network Adapter (CFFh)子卡，来连接BCH上的FCoE交换模块。

突出价值点：通过FCoE技术，不但减少服务器内部子卡的数量和刀片中心交换模块数量，更大大减少了连接线缆数量，从而提高散热能力，降低能耗需求。


JS43，PS702和PS704是否集成了两个SASController？

解答：

JS43,PS702和PS704只集成了一个SAS Controller。

通常大家会觉得，JS43为2个JS23的叠加，PS702为2个PS701的叠加，并且所有的部件都是重复的，其实并非如此。JS43为一个JS23外加了一个扩展单元（fc#8446),PS702为一个PS701外加了一个扩展单元（fc#8358）。

在扩展单元中，并不包含JS23或者PS701的所有部件，比如集成的SAS Controller等一些部件并不在扩展单元中。

PS704支持2个SAS槽位，但是只有一个SAS controller。

如果JS43/PS702/PS704要实现分区，可以通过IVM实现分区的管理。将SAS Controller的所有硬盘分配给分区VIOS，并由VIOS将硬盘指派给其他的分区使用。

需要注意，目前，IVM不支持每台服务器大于1个逻辑分区，且JS43/PS702/PS704不支持HMC，所以JS43/PS702不支持双VIOS的配置。

另外，JS43/PS702/PS704最大支持2个双口的光纤通道卡和双口网卡+双口光纤通道卡(fc#8252)，所以可以给2个LPARs配置冗余的磁盘IO。JS43/PS702/PS704共有4个集成的以太网端口，其中包含IVE卡，该卡是可以不通过VIOS就将网络端口分给多个分区使用。


刀片做HACMP推荐方案

解答：

一个推荐的配置：

PS701：

两个集成的以太网端口和一个以太网和FC混合卡(fc#8252，提供2个以太网端口和2个FC端口)

BladeCenter H：

2个以太网交换模块(用于刀片集成的以太网端口，占用BCH的I/O bay 1和bay 2)
2个以太网交换模块(安装在MSIM上)
2个FC交换模块(安装在MSIM上)
2个Multi Switch Interconnect Module(fc#3239)

外部共享硬盘：

HACMP 心跳：通过共享硬盘来实现心跳功能

如下是MSIM的介绍：

突出价值点：刀片相对其他Power服务器成本低，加入HACMP之后，适合于对小型应用进行双机或集群的热备容灾方案。

Top


配置-POWER6

POWER6

Power 520/550

Power 560/570

Power 595

其他


配置 Power 520/550

Power 520/550

在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

如何在Power 520/550 服务器上创建RAID 5? (最近更新)

如何实现Power 520和550的2个LPAR的RAID功能?

如何配置Power 520服务器内置磁盘分区的功能 (最近更新)

如何配置Power 550服务器内置磁盘分区的功能 (最近更新)

如何配置Power 520 和550 三个及以上分区

配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜

能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘?


在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

解答：

目前，Power550上可以配置三种磁带机：
fc#5619 80/160GB DAT160 SAS Tape Drive;
fc#5661 DAT320 160/320 GB Tape Drive;
fc#5746 Half High 800GB/1.6TB LTO4 SAS Tape Drive;

fc#5619,fc#5661和fc#5746默认包含一个的磁带机，一个清洗带和测试带。

磁带机fc#5619和fc#5746所使用的磁带可以直接在e-config工具中配置：
fc#5689 DAT160 Data Cartridge 为5盒一包的数据磁带；
fc#5747 IBM LTO Ultrium 4 800 GB Data Cartridge 为5盒一包的数据磁带。

fc#5661磁带机所使用的磁带目前还不可以直接通过e-config工具配置，需要单独从市面上购买。

突出价值点：在Power 520和550上有单独的空间放置内置磁带机，与配置外置的磁带机相比，不需要单独的空间来放置外置磁带机，且也不用单独配置PCI卡来连接外置磁带机，相对更节省成本。


如何在Power 520/550服务器上创建RAID 5？

解答:

对Power 520/550服务器内置磁盘创建RAID 5需要选择以下组件：

Power 520服务器：

1. 需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且需要配置fc#8310或者fc#8340的硬盘背板，实现内置硬盘的RAID功能。
2. fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。
3. fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉（fc#5886）和IO抽屉（fc#5802）上SAS硬盘的RAID功能。

Power 550服务器：

1. 需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且需要配置fc#8310或者fc#8340的硬盘背板，实现内置硬盘的RAID功能。
2. fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。
3. fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉（fc#5886）和IO抽屉（fc#5802）上SAS硬盘的RAID功能。

其中Power 520/550的方案1，配置fc#5679(SAS RAID Enablement)的RAID子卡和支持RAID子卡的硬盘背板 fc#8310/fc#8340,可以实现内置硬盘的RAID功能。fc#5679这块卡，它不会占用主板的PCI槽位，可以为客户节省PCI槽位。

突出价值点：多种RAID卡的选择，更灵活的配置，确保系统的高可用性。


如何实现Power 520和550 的2个LPAR的RAID功能

解答：

Power 520/550支持多种内部硬盘结构,具体请参见《Power 520六种硬盘背板的介绍》和《Power 550六种硬盘背板的介绍》。

如果要实现Power 520/550 2个LPAR，每个LPAR 3块硬盘(3.5"或者2.5"的SAS硬盘)的RAID功能，可通过如下方法完成：

1.第一个LPAR通过内部的SAS卡连接内部的硬盘背板(fc#8310/fc#8340)，集成SAS卡可以连接RAID子卡fc#5679，实现RAID功能，支持RAID 0,1,5,6和10，RAID子卡fc#5679还支持175MB的cache。

2.第二个LPAR通过外接SAS卡fc#5904 + SAS线fc#3679 + SAS线fc#3669(550)或fc#3670(520)来实现RAID功能.

如果要实现Power 520/550 2个LPAR，每个LPAR 4 块硬盘(3.5"或者2.5"的SAS硬盘)的RAID功能，可通过如下方法完成：

如果配置3.5"的SAS硬盘：

1.第一个LPAR通过内部的SAS卡连接内部的硬盘背板(fc#8310)，集成SAS卡可以连接RAID子卡fc#5679，实现RAID功能，支持RAID 0,1,5,6和10，RAID子卡fc#5679还支持175MB的Cache。

2.第二个LPAR通过SAS卡连接fc#5886的扩展柜。扩展柜可通过2个fc#5805的SAS RAID卡连接（fc#5805是成对配置的）。fc#5805可以实现写Cache数据和RAID校验的映射。适配卡支持SAS的冗余链路，在一条SAS链路出问题的时候，自动进行链路切换，支持RAID 0,1,5,6和10，可通过fc#3661，3662，3663的SAS线连接fc#5886的扩展柜；或者配置fc#5904的SAS RAID卡连接fc#5886的扩展柜来实现RAID功能。

如果配置2.5"的SAS硬盘：

通过fc#8340(8个槽位)的硬盘背板实现，第一个分区通过集成的SAS卡 + RAID子卡(fc#5679)实现RAID,第二个分区通过外接SAS卡fc#5904 + SAS线fc#3679 + SAS线fc#3669(550)或fc#3670(520)来实现RAID功能。

突出价值点：不同RAID卡的组合使用，确保系统的高可用性。


如何配置Power 520 服务器内置磁盘分区的功能？

解答:

环境:Power 520(产品,平台,机型,软件版本,等)

配置内置磁盘分区功能需要满足以下要求:

1. 配置磁盘背板为fc#8310(使用3.5"SAS磁盘)或fc#8340(使用2.5"SAS磁盘)。

2. 选择一种下面所列SAS卡，配置1个:
.fc#5912 PCI-X SAS卡
.或fc#5901 PCIe SAS卡
.或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3670内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3670，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 520的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3670分离背板的线和fc#3679的线控制。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 550 服务器内置磁盘分区的功能？

解答:

环境:Power 550(产品,平台,机型,软件版本,等)

配置内置磁盘分区功能需要满足以下要求:

1. 配置磁盘背板为fc#8310(使用3.5"SAS磁盘)或fc#8340(使用2.5"SAS磁盘)。

2. 选择一种下面所列SAS卡，配置1个:
fc#5912 PCI-X SAS卡
或fc#5901 PCIe SAS卡
或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3669内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3669，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 550的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 520和550 三个及以上分区

解答：

由于在Power 520/550中，内置硬盘能实现2个分区的配置，要实现3个及以上分区的配置，需要通过I/O扩展实现：

有两种配置方式：1.是通过添加SAS的卡和fc#5886的SAS扩展柜；2.是通过添加fc#5802的IO抽屉实现；

1.前两个分区，正如在如何配置Power 520 服务器内置磁盘分区的功能？和如何配置Power 550 服务器内置磁盘分区的功能?中介绍的，需要配置fc#8340/fc#8310的硬盘背板，fc#3669和fc#3679的SAS线，以及fc#5912/fc#5901的SAS卡；

2.第三个分区主要的配置如下：

(1) 通过SAS卡和fc#5886的SAS硬盘扩展柜：

fc#5912/fc#5901的SAS卡，fc#5886的SAS扩展柜，以及相应的YO的SAS的线，在e-config中，可以配置如下的YO线：

fc#3691 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 1.5 M
fc#3692 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 3 M
fc#3693 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 6 M
fc#3694 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 15 M

一般，e-config工具，将自动添加fc#3692 YO的SAS线。

(2) 通过添加fc#5802的IO抽屉实现：

fc#5802支持最大18块SFF SAS硬盘，每个fc#5802支持1,2或者4个硬盘通道(可通过fc#5802上的Switch进行通道数量的选择)，当为1个分区时，最大的硬盘数为18块 SFF SAS硬盘；当为2个分区时，每个通道支持的最大9块SFF SAS硬盘；当为4个分区时，每个通道支持最大的SFF SAS 硬盘数分别为：5，4，4，5；每个分区的硬盘通道都需要配置fc#5901的SAS卡以及相应数量的fc#3688 SAS 的线(AT)。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜

解答:

最新的e-config配置Power 520, 550时，缺省硬盘背板为fc#8340, 缺省硬盘为fc#3647。

fc#8340是支持SFF 2.5"硬盘的背板，但fc#3647为3.5"的硬盘，只能放在fc#8308, 或者fc#8310背板，或者fc#5886硬盘扩展柜中。这样e-config就会为这块硬盘自动加一个fc#5886。

解决办法：
手工把硬盘背板更改为fc#8310或者fc#8308即可。


能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘?

解答：

在Power 550的硬盘背板上，最大支持配置6块fc#3647 146GB SAS硬盘，具体的硬盘背板的信息如下：

fc#8308 = 6 x 3.5" DASD Backplane with no external SAS port
fc#8310 = 6 x 3.5" DASD backplane with an external SAS port

以上两种硬盘背板都可以支持fc#3647的硬盘，但是最大只能放置6块3.5英寸的硬盘。如果要配置8块fc#3647的3.5英寸SAS硬盘，需要将其中的6块硬盘放置到硬盘背板上，另外2块硬盘放置到fc#5886的EXP 12S硬盘扩展柜里。

针对在Power 550上配置8块fc#3647 3.5英寸SAS硬盘的情况，需要进行如下的配置：

1.fc#8310 具有对外SAS端口的硬盘背板；

2.fc#3668 为一根从硬盘背板到系统后挡板的SAS线缆，该SAS线缆用于将硬盘背板的外对SAS端口连接到系统的后挡板，可以支持通过YI的SAS线缆连接到fc#5886上；

3.fc#3687 SAS Cable (YI) System to SAS Enclosure, Single Controller/Dual Path 3M，该SAS线缆主要用于通过fc#3668的SAS线缆，将一台fc#5886的硬盘扩展柜连接到主机集成的SAS端口上；

4.fc#5886 EXP 12S硬盘扩展柜。

注意：通过以上的配置，fc#5886上的硬盘是由fc#8310上集成的SAS控制器管理，如果在fc#8310上配置了fc#5679的RAID子卡，此时，fc#5679的RAID子卡，可以实现fc#8310和fc#5886上硬盘的RAID功能。


配置Power 560/570

Power 560/670

Power 570的Processor Power Regulator是什么？

如何在Power 570上创建RAID 5? (最近更新)

Power 570在一个CEC中，如何配置2个分区

Power 570在多个分区的情况下，如何实现光驱在分区之间的切换?

如何实现Power 560和570内置硬盘之外增加LPAR


Power 570的Processor Power Regulator是什么？

解答：

Power 570的Processor Power Regulator是处理器稳压器，这个部件提供处理器运行时所需的电压调节。

每个系统抽屉都有三个处理器稳压器，第三个处理器稳压器可以为处理器提供冗余的电源保护，增强系统的可用性。只要系统抽屉中至少有两个工作的稳压器，那么处理器将持续运行。出错的（即第三个）稳压器可热拔插更换，但必须留在系统中直至备件替换。

如果一个系统抽屉中只有两个处理器稳压器，就不能为处理器提供任何冗余的稳压功能。当且仅当只有一个系统抽屉的情况下，配置一个或两个fc#5620处理器卡(3.5GHz主频)时，才可以仅配置两个处理器稳压器。这种情况下，处理器稳压器不能给处理器提供冗余电源保护。需要注意的是，这种两个稳压器的配置是e-config工具在只有一个或两个fc#5620时的默认配置。所有其他的配置，每个系统抽屉均必须配置三个稳压器。

突出价值点：为处理器提供冗余的电源保护，增强系统的可用性。


如何在Power 570上创建RAID 5

解答:

RAID卡fc#5805/fc#5908可以给Power 570的内置磁盘创建RAID 5，在硬件配置方面有三种情况。

第一种情况：给一个CEC单元内的6块磁盘创建RAID 5。

当给一个CEC单元内的6块磁盘创建RAID 5时，有两种配置方式：
1.1x fc#5908,1x fc#3651,1xfc#3679(AI SAS Cable)的配置方式；
2.2x fc#5805(fc#5805卡在e-config配置工具中必须成对配置),1x fc#3651,1x fc#3667 (YR Cable), 每个fc#5805卡上的一个接口通过fc#3667线缆连接到fc#3651上保证冗余。具体连接方式见下图。

第二种情况：给两个CEC单元内的12块磁盘创建RAID 5。

当给两个CEC单元内的12块磁盘创建RAID 5时，有两种配置方式：
1.1x fc#5908，2x fc#3651(每个CEC单元一个)，2xfc#3679(AI SAS Cable)的配置方式；
2.2x fc#5805(fc#5805卡在e-config配置工具中必须成对配置),2x fc#3651 (每个CEC单元一个), 2x fc#3667 (YR Cable), 每个fc#5805卡上的两个接口通过fc#3667线缆连接到fc#3651上保证冗余。具体连接方式见下图。

第三种情况：给三个CEC单元的18块硬盘创建RAID 5。

当给三个CEC单元内的18块磁盘创建RAID 5 时，在硬件配置方面需要满足：

1x fc#5908，3x fc#3651(每个CEC单元一个)，3xfc#3679(AI SAS Cable)的配置方式。具体的连接方式，见下图：

注意：在Power 570上，fc#5805的SAS RAID卡只能通过MES的方式进行订购。

突出价值点：为客户数据保护提供多种选择。Power 570在做RAID5的时候，有两种RAID卡可以选择：fc#5805，fc#5908.其中fc#5805必须成对的配置才能实现RAID5，fc#5805为PCIe的卡，其缓存为380MB；fc#5908为占用两个PCI-X的槽位的RAID卡，其缓存为1.5Gb。fc#5805的RAID卡为双口的，最多支持2个系统抽屉的12块硬盘做RAID；fc#5908RAID卡为三端口，最多支持3个系统抽屉的18块硬盘做RAID，客户可以根据需要进行选择相应的RAID卡。

Top


Power 570 在一个CEC中，如何配置2个分区

解答：

Power 570每个系统柜有6个磁盘槽位，具有分离背板(Split Backplane)功能的选件能够将6个磁盘槽位分成2组(每组3块磁盘)，并且AIX或Linux可以分别使用这两个磁盘组。两个磁盘组分别使用不同的磁盘控制器(一个板载集成的，一个PCI的)， 增加的一个组对于一些数量较少的分区和磁盘控制器镜像是非常有意义的。

可以通过如下两种配置方案实现9117-MMA每个CEC划分两个分区：

第一种配置方式：可以使用fc#3650 + fc#5912/fc#5901 + fc#3679,那么它们连接的3块SAS盘(第4，5，6号盘)将分配给一个分区;而主板上的6 Pack中的另外3块盘和光驱将会分配给另一个分区使用。这时的光驱是不能够浮动的,也即无法提供DLPAR使用。此种配置方法需要占用两个PCI槽位，fc#5912要使用一个PCI-X槽位或者fc#5911要使用一个PCIe槽位，fc#3650要占用一个PCIe槽位。

第二种配置方式：可以使用fc#5909/fc#5911＋fc#3679，那么它们连接的3块SAS盘(第4，5，6号盘)将分配给一个分区;而主板上的6 Pack中的另外3块盘和光驱将会分配给另一个分区使用。这时的光驱是不能够浮动的,也即无法提供DLPAR使用。采用这种方法只需为fc#5909/fc#5911提供一个PCIe槽位，无需再选择fc#3650，可以节省一个PCIe槽位。

注：fc#5909已于2009年6月26日停产，fc#5911为其替代产品。

fc#5911的SAS卡有三个接口,分离磁盘背板功能会占用其中两个,剩下的一个接口可以用来连接fc#5886的磁盘扩展柜或外置的Media扩展柜,也就是说,可以连接SAS Disk或Tape。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。

Top


Power 570在多个分区的情况下，如何实现光驱在分区之间的切换

解答：

目前，在默认的情况下，Power 570 的光驱不能在分区之间进行切换，可以通过配置外置的光驱设备，实现分区的切换；

也可通过如下的方式实现：在9117-MMA CEC单元中配置fc#3651 + fc#5912/fc#5901 + fc#3679，这样CEC单元中的6块内置磁盘全部连接到fc#5912/fc#5901上，光驱仍然连接到内置的SAS控制器上。光驱和内置磁盘完全分离，光驱可以在不同分区之间切换。以8路处理器的9117-MMA为例，如果客户要求划分两个分区，就可以按照上述方法在一个CEC单元上配置fc#3651 + fc#5912/fc#5901 + fc#3679和光驱，而另一个单元上按照默认配置，这样一个CEC单元上的光驱就可以在两个分区之间切换了。依此类推，12路和16路处理器时也可以按照该方法实施。

注：此方法适合多个CEC做分区的情况。

突出价值点：利用光驱的DLPAR，可以减少硬件的成本，使用还非常方便，是多分区服务器的很好的一个选择。


如何实现Power 560和570内置硬盘之外增加LPAR

解答：

要实现Power 560和570的内置硬盘之外增加LPAR，可以通过两种方式实现：1.是通过添加SAS卡和外置的SAS硬盘扩展柜fc#5886实现；2.是通过添加fc#5802的IO抽屉实现。

主要的配置如下：

1.通过SAS卡和fc#5886的SAS硬盘扩展柜：

fc#5912/fc#5901的SAS卡，fc#5886的SAS扩展柜，以及相应的YO的SAS的线，在e-config中，可以配置如下的YO线：

fc#3691 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 1.5 M
fc#3692 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 3 M
fc#3693 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 6 M
fc#3694 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 15 M

2.通过添加fc#5802的IO抽屉：

fc#5802支持最大18块SFF SAS硬盘，每个fc#5802支持1，2，4个硬盘通道(可通过fc#5802上的switch进行通道数量的选择)，当为一个分区时，最大的硬盘数为18块 SFF SAS硬盘，当为两个分区时，每个通道支持的最大9块SFF SAS硬盘，当为四个分区时，每个通道支持最大的SFF SAS 硬盘数分别为：5，4，4，5；每个分区的硬盘通道都需要配置fc#5901的SAS卡以及相应数量的fc#3688 SAS的线(AT)。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


配置 Power 595

Power 595

Power 595内存的配置规则

用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜?

怎样在Power 595上配置内置光驱和磁带机?


Power 595内存的配置规则

解答：

1) 对 Processor Book 的规则：
每个Processor Book至少激活16GB。

2) 对内存 Feature 的规则：
对 0/8, 0/16, 0/32GB 的内存，最少要激活50%；
对 0/4, 0/64GB，还有 fc#820x 的套装内存，必须全部激活。

详情见下表：

Feature Code | 内存大小 | 最小激活大小
#5693 | 0/4 GB | 4 GB
#5694 | 0/8 GB | 4 GB
#5695 | 0/16 GB | 8 GB
#5696 | 0/32 GB | 16 GB
#5697 @ | 0/64 GB | 64 GB
#8201 | 32 x #5694 | 256 GB
#8202 | 16 x #5695 | 256 GB
#8203 | 32 x #5695 | 512 GB
#8204 | 16 x #5696 | 512 GB
#8205 @ | 32 x #5697 | 2 TB

注意：内存激活是和服务器的序列号绑定的，如果一组内存移到另外一台服务器上，相应的激活仍然保留在原来的服务器上。


用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜

解答：

这个是因为在用e-config配置Power 595(9119-FHA)时，选择了SAS硬盘或者SAS固态盘。

Power 595目前可以配置的硬盘有3种：

1) SAS SFF(2.5")硬盘：安装在新推出的fc#5803扩展柜(24"宽)里面；
2) SAS硬盘：安装在fc#5886 EXP 12S扩展柜(19"宽)里面；
3) SAS固态硬盘：安装在fc#5886 EXP 12S扩展柜(19"宽)里面；

注：fc#3279的146.8 GB SCSI硬盘已于2009年11月27日停产了。

如果您为Power 595配置了3.5"的SAS硬盘或者SAS固态硬盘，e-config会自动按照硬盘的数量配置fc#5886。fc#5886无法安装在Power 595的24"的机柜里面，而必须安装在19"的机柜里面。所以，e-config就会自动配置19"机柜(fc#0553, 即7014-T42)。

目前可以选择使用SAS SFF硬盘来避免配置19"机柜，SAS SFF的容量为：73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive。

SAS SFF(2.5")硬盘是放到fc#5803的IO抽屉中，每个I/O抽屉可配26块硬盘。每个I/O抽屉里有4个硬盘背板，每个硬盘背板内分别有7/6/7/6个可热插拔硬盘槽位。每个硬盘背板有独立的SAS链路，可通过档位开关设置支持1/2/4个LPAR分区。需要注意的是，每个分区需要加配1个fc#5901 SAS卡或2个fc#5903 SAS RAID卡来管理。如果使用fc#5903，只支持最大2个LPAR设置。

配置了SAS硬盘的Power 595机柜形式如下图所示：

突出价值点：Power 595支持不同容量和不同尺寸的SAS硬盘，根据不同的硬盘选择相应的IO抽屉。在满足客户硬盘容量需求的情况下，建议选择2.5"的SAS SFF硬盘，其可以直接放到Power 595的24"IO抽屉(fc#5803)中，不用单独配置19"机柜，可以为客户节省成本和空间。

Top


怎样在Power 595上配置内置光驱和磁带机

解答：

在Power 595上配置内置的光驱和磁带机时，首先需要配置介质抽屉fc#5720 (DVD/Tape SAS External Storage Unit), 同时需要配置一块SAS卡与fc#5720连接, fc#5720默认放置在机柜里34U的位置，如果要放到12U的位置可以配置fc#8449(Media Drawer Placement Indicator - U12)。

fc#5720提供一个磁带机槽位和两个光驱槽位,最多可以配置一个磁带机和两个光驱。当在Power 595上配置了fc#5720时,至少要配置一个光驱。

如果Power 595在做分区配置时, 选配了fc#5803的I/O扩展柜,fc#5720必须连接到一个专用的SAS卡上，可以实现在不同分区之间的浮动,现在e-config工具里默认会配置fc#5901的SAS卡来连接fc#5720，当做多个分区时,一定要配置一块单独的一块SAS卡来连接fc#5720。

突出价值点：在Power 595上配置光驱和磁带机，客户可以根据需要选择fc#5720介质抽屉在机柜中的位置。fc#5720里配置的光驱和磁带机通过一块SAS卡连接，就可以在多个分区之间进行动态的漂移，能为客户节省成本，提高硬件设备的利用率。


配置 其他

其他

System P 服务器如何选配置电源线? (最近更新)

介绍Power服务器上fc#6577的电源线

如何在e-config中选择7316-TF3?

Power服务器上的几种 10 Gigabit的以太网卡有什么不同?

配置FCoE卡时的注意事项

用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？ (最近更新)

新发布的SFF硬盘和SSD 硬盘的特性是什么? 如何配置?

为什么必须要配置一对fc#5805的RAID卡？

fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？

Power中异步卡和串口线的选择

在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？ (最近更新)

fc#5802/5803如何配合主机实现分区功能

Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

Power服务器常用I/O抽屉配置方法 (最近更新)

System P服务器都支持哪一些类型的I/O Drawer? (最近更新)

怎样配置fc#5796和fc#5802的IO抽屉

7014-T00/T42/B42机柜PDU和电源线的配置介绍

为什么现在在配置中介质会出现ESD，如何避免？ (新增)

如何通过e-config工具，配置C/C++, fortran, Cobol等开发环境 (新增)


Power 520/550/560/570/595 CPU,MEM,DISK 的配置规则?

解答:

Power 520
CPU：1(4.2GHz Only),2,or 4 cores @ 4.2 & 4.7GHz

最大内存容量：16GB(1 core)、32GB(2 cores)、64GB(4 cores)

硬盘：6个3.5-inch SAS DASD bays，最大支持2.7TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

Power 550
CPU：2,4,6,or 8 cores @ 3.5 & 4.2 & 5.0 GHz

最大内存容量：64GB(2 core)、128GB(4 cores)、192GB(6 cores)、256GB(8 cores)

硬盘：6个3.5-inch SAS DASD bays，最大支持2.7TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

Power 560
CPU：4,8,or 16 cores @ 3.6 GHz

最大内存容量：96GB(4 core)、192GB(8 cores)、384GB(16 cores)

硬盘：每个enclosure 6个3.5-inch SAS DASD bays，最大支持5.4TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

Power 570
CPU：2,4,8,12 or 16 cores @ 3.5,4.2,4.4,4.7,5.0GHz；4,8,16,24 or 32 cores @ 4.2GHz

最大内存容量：96GB(2 core)、192GB(4 cores)、384GB(8 cores)、576GB(12 cores)、768GB(16 cores)

硬盘：每个enclosure 6个3.5-inch SAS DASD bays(系统最大24个)最大支持10.8TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

Power 595
CPU：8-64 cores @ 4.2 & 5.0 GHz

最大内存容量：256GB(1 book)、512GB(2 books)、768GB(3 books)、1024GB(4 books)、1280GB(5 books)、1536GB(6 books)、1792GB(7 books)、2TB(8 books)@4.2GHz

512GB(1 book)、1TB(2 books)、1.5TB(3 books)、2TB(4 books)、2.5TB(5 books)、3TB(6 books)、3.5TB(7 books)、4TB(8 books)@5.0GHz

硬盘：每个fc#5803IO抽屉支持26 hot-swap SFF SAS disk bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

查询相关产品销售手册：

Power 520 销售手册

Power 550 销售手册

Power 560 销售手册

Power 570 销售手册

Power 595 销售手册

Top


配置_POWER7

POWER7

Power 710/730

Power 720/740

Power 750/755

Power 770/780

其他


配置 Power 710/730

Power 710/730

对Power 710/730，请问如何配置适配卡来支持HA

Power 710/730服务器的内置磁盘不支持分离背板的功能

Power 710/730的内存配置及规则

在e-config中，Power710/730可以配置的内置磁带机和磁带介绍 (新增)


对Power 710/730，请问如何配置适配卡来支持HA?

解答：

Power 710/730不支持PCI槽位扩展，并且内置只有4个PCIe LP槽位。为了满足PowerHA的各关键配件都要冗余的要求，目前推荐配置如下：

1) 网卡 X 2， HBA X 2，用共享磁盘做心跳；

2) 若可用IVE网口来冗余，可只配置一块网卡，但注意：IVE网口和网卡接口要相同，并且IVE不支持热插拔。

配置如下：

网卡 X 1，HBA X 2，剩下的槽位加串口卡 X 1，心跳走串口线心跳。


Power 710/730服务器的内置磁盘不支持分离背板的功能

解答：

Power 710/730服务器的内置磁盘不支持分离背板的功能。

突出价值点：如果客户在入门级服务器需要分离背板的功能，可以选择Power 720/740服务器；Power 710/730服务器并不支持分离背板的功能，但通过选择fc#5268的磁盘背板可以支持内置磁盘的RAID功能。


Power 710/730的内存配置及规则

解答：

Power 710支持的内存配置及规则如下：

Power 710支持DDR3，1066MHz的内存。

一台Power 710最大支持2个Memory riser card，每个Memory riser card支持4个内存槽位。其中系统默认带一个Memory riser card，另一个Memory riser card需单独配置，其编号为：fc#5265。

Power 710 最大支持8个内存槽位，4组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：2GB，4GB或者8GB；

最小配置1组内存，及最小4GB的内存；

最大内存为64GB；

每个Memory riser card上的内存，必须为相同的内存，不同Memory riser card上的内存可以不同；

Power 710支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)。

Power 730支持的内存配置及规则如下：

Power 730支持DDR3，1066MHz的内存。

一台Power 730最大支持4个Memory riser card,每个Memory riser card支持4个内存槽位。其中系统默认带一个Memory riser card，可需单独选配3个Memory riser card，其编号为：fc#5265。

Power 730 最大支持16个内存槽位，8组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：2GB，4GB或者8GB；

最小内存容量为：8GB；

最大内存为128GB；

每个Memory riser card上的内存，必须为相同的内存，不同Memory riser card上的内存可以不同；

Power 730支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)。

注意：至少需要配置2组（4 DIMMs）单条2GB的内存。


在e-config中，Power710/730可以配置的内置磁带机和磁带介绍

解答:

fc#1124

fc#1124是一个3.25英尺的内部半高磁带机，它具有存储，还原和存档的功能。作为一个DDS第五代标准磁带机，fc#1124使用了全新的大容量可压缩的IBM DAT160技术和4MM数据带，如果使用2比1的压缩比，它的最大容量可以达到160GB。比起先前的36/72GB 4MM磁带机，明显的提高了数据容量。当订购了fc#1124，会附带提供一个测试带，一个清洗带。

注：fc#1124磁带机要求fc#5263背板支持。

fc#1106 和 fc#1107

fc#1106是一个包含了扩展坞的可移动的USB磁盘驱动器，它同样支持可移动磁盘。这个磁盘驱动器是一个备份还原设备，它对于磁带机则是二选一的。这个可移动式的磁盘驱动器和常规的磁盘驱动器是不可以互相替换的，同样它也不可以作为磁盘阵列的一部分。它的正常的数据容量为160GB，采用压缩技术后可以达到320GB。

注：压缩技术是由操作系统提供的，而不是驱动器自身提供的。

当在Power 710和730配置fc#1106和fc#1107的时候，同样需要配置一个fc#1123。

fc#1106和fc#1107基本相同，只是fc#1107的容量更大。在不采用压缩技术的情况下fc#1106可以到达500G，采用后可以达到1000G。


配置 Power 720/740

Power 720/740

Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

Power 720/740的内存配置及规则

如何在Power720/740上配置3个以上分区 (新增)

在e-config中，Power 720/740 可以配置的内置磁带机和磁带介绍 (新增)

哪些配置情况下会使Power 720/740的噪音增加 (新增)


Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

解答：

Power 720/740服务器实现内置硬盘分离时，不需要添加额外的线缆。

服务器对内部磁盘进行分离背板的功能，必须包含以下内容：

fc#5618 硬盘背板 -- 支持6个SFF磁盘槽位/SATA DVD/半高磁带机；
fc#5631 磁盘背板分离功能组件。

fc#5631是一个额外的SAS控制器芯片，它可以将#5618磁盘背板上的6个磁盘分割成2组各包含3个磁盘驱动器，并且属于fc#5631 SAS控制器下的3个磁盘支持RAID-10的能力，集成SAS控制器所控制的3个磁盘没有此能力。fc#5631 SAS控制器不占用PCI插槽，不能与磁盘背板fc#5630一起订购，不提供RAID-5/6的能力。

突出价值点：Power 720/740具备磁盘背板分离或者实现RAID功能的Feature，便于客户灵活选择合适的功能。


Power 720/740的内存配置及规则

解答：

Power 720的内存配置及规则如下：

Power 720支持DDR3，1066MHz的内存。

一台Power 720最大支持2个Memory riser card,每个Memory riser card支持8个内存槽位。其中系统默认带一个Memory riser card，可需单独选配1个Memory riser card，其编号为：fc#5604。

Power 720 最大支持16个内存槽位，8组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：4GB(4C)，4GB或者8GB(6C or 8C)；

最小配置1组内存，及最小8GB的内存；

最大内存：64GB(4C); 128GB(6C or 8C)；

可以在每个Memory riser card上配置不同的内存；

Power 720支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)；

如果配置单条8GB的内存(fc#4529)，最少支持2组内存(4 DIMMs)。

Power 740的内存配置及规则如下：

Power 740支持DDR3，1066MHz的内存。

一台Power 740最大支持4个Memory riser card,每个Memory riser card支持8个内存槽位。其中系统默认带一个Memory riser card，可需单独选配3个Memory riser card，其编号为：fc#5604。

Power 740 最大支持32个内存槽位，16组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：4GB或者8GB；

最小配置1组内存，及最小8GB的内存；

最大内存：256GB；

可以在每个Memory riser card上配置不同的内存；

Power 740支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)，10组内存(20 DIMMs)，12组内存(24 DIMMs)，14组内存(28 DIMMs)，16组内存(32 DIMMs)；

如果配置单条8GB的内存(fc#4529)，最少支持2组内存(4 DIMMs)。

注意：如果Power 740只配置了一个处理器板卡，此时，最大只支持2个Memory Riser Card，可以单独再选配一个Memory Riser Card。
如果Power 740配置了两个处理器板卡，此时，最大支持4个Memory Riser Card，可以单独再选配三个Memory Riser Card。


如何在Power720/740上配置3个以上分区

解答:

在Power 720/740中,内置硬盘能实现2个分区,要实现3个及以上分区,需要通过IO扩展实现。

1.前两个分区,需要配置支持分离的硬盘背板的编号为：fc#5618，同时还需要配置fc#5631的分离背板的选件，该选件为第二个分区提供了SAS Controller，且不占用PCI槽位，可以支持背板的分离，实现两个分区。每个分区支持3块SFF的SAS硬盘。其中，由fc#5631管理的分区支持RAID10。

2.第三个及以上分区主要的配置，有如下两种方法:

a) 通过SAS卡和fc#5886的SAS硬盘扩展柜实现。

fc#5912/fc#5901的SAS卡，fc#5886的SAS扩展柜，以及相应的YO的SAS的线，在e-config中，可以配置如下的YO线：
fc#3691 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 1.5 M
fc#3692 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 3 M
fc#3693 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 6 M
fc#3694 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 15 M

一般来说，e-config工具将自动添加fc#3692 YO的SAS线。另外，放到fc#5886中的硬盘为3.5英寸的硬盘，与背板fc#5618上支持的硬盘不同，需要单独选择。

b) 通过添加fc#5802的IO抽屉实现。

fc#5802支持最多18块SFF SAS硬盘，每个fc#5802支持1,2或者4个硬盘通道(可通过fc#5802上的Switch进行通道数量的选择)。当为1个分区时，最大的硬盘数为18块 SFF SAS硬盘；当为2个分区时，每个通道支持的最大9块SFF SAS硬盘；当为4个分区时，每个通道支持最大的SFF SAS 硬盘数分别为：5，4，4，5。每个分区的硬盘通道都需要配置fc#5901的SAS卡以及相应数量的fc#3688 SAS 的线(AT)。

注意：
4-Core 的Power 720不支持IO抽屉的扩展，因此，4-Core的Power 720，最大只支持2个逻辑分区。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


在e-config中，Power720/740可以配置的内置磁带机和磁带介绍

解答:

Power 720/740上fc#5618和fc#5630的硬盘背板均支持内置磁带机。

在Power 720/740上支持的内置磁带机为：

fc#5619 80/160GB DAT160 SAS Tape Drive，该feature提供了一个半高的磁带机，测试磁带盒一个清洗带。
fc#5638 1.5TB/3.0TB LTO-5 SAS Tape Drive，该feature提供了一个半高的LTO5的SAS磁带机，一个LTO5的测试带和一个LTO5的清洗带。
fc#5661 DAT320 160/320 GB Tape Drive，该feature提供了一个DAT320 160/320GB的磁带机
fc#5673 DAT320 160 GB USB Tape Drive，该feature提供了一个DAT320 160/320GB的磁带机
fc#5746 Half High 800GB/1.6TB LTO4 SAS Tape Drive，该feature提供了一个半高的LTO4的SAS磁带机，一个LTO4的清洗带和LTO4的测试带。

目前在Power 720/740上可以直接为fc#5746 LTO4的磁带机配置数据磁带，其编号为：

fc#5747 IBM LTO Ultrium 4 800 GB Data Cartridge，该feature提供了5盘数据磁带。

注意：fc#5619/fc#5638/fc#5661/fc#5673磁带机所使用的磁带目前还不可以直接通过e-config工具配置，需要单独从市面上购买。

参考资料：

Power 720销售手册链接


哪些配置情况下会使Power 720/740的噪音增加

解答:

相比Power 520/550，Power 720/740在隔音降噪方面有很大进步。

但是，如下两种配置情况下会明显增加Power 720/740的噪音：

1）仅配置了一个电源在系统的SAS bay上配置了69GB的固态硬盘（SSD）；

2）配置了PCIe Riser Card (fc#5610或者fc#5685)。


配置 Power 750/755

Power 750/755

如何在Power 750上实现硬盘背板的分离

如何配置Power 750三个及以上分区

如何实现Power 750的RAID功能

Power 750/755的内存配置规则


如何实现Power 750的RAID功能

解答:

对于Power750，可以通过如下的方式实现硬盘的RAID功能：

(1)需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且配置fc#8340的硬盘背板，实现内置硬盘的RAID功能。

(2)fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)和IO抽屉(fc#5802)上SAS硬盘的RAID功能。

(3)fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。

突出价值点：多种RAID卡的选择，更灵活的配置，确保系统的高可用性。


如何在Power 750上实现硬盘背板的分离

解答:

Power 750的硬盘背板分离的配置方式与Power 550的背板分离方式相似。

配置内置磁盘分区功能需要满足以下要求:
1. 配置fc#8340的硬盘背板。
2. 选择一种下面所列SAS卡，配置1个:
fc#5912 PCI-X SAS卡
或fc#5901 PCIe SAS卡
或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3669内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3669，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 750的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。

注意：Power 755不支持硬盘背板分离；Power 750 IBM i不支持硬盘背板分离。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 750三个及以上分区

解答:

因为分区数较多，所以我们建议通过fc#5802扩展柜来放CEC之外的分区硬盘。DLPAR的DVD光驱和磁带机选用外置设备7214-1U2/7216-1U2。

下面按3分区为例说明。

配置分析：虽然Power 750的CEC有分离硬盘背板，支持两组硬盘，但在fc#5802扩展柜里面分组硬盘更加简单方便。所以我们选择在CEC里面放一组硬盘，在fc#5802里面放两组硬盘来实现共3分区的方法。

详细配置步骤：

1) 计算所有分区的PCI卡的数量，确定fc#5802的数量。
一个fc#5802扩展柜可以放10张PCIe的卡，最多放18块2.5"(SFF)硬盘，最多分作4分区；

在e-config的Expansions页面上设置fc#5802扩展柜的数量。

注意：对于fc#5802，每个12X环路里面最多有2个扩展柜，Power 750 最多能有2个环路。
对于1个处理器板(8-core)的Power 750，最多有1个12X环路。
对于2个或以上处理器板的Power 750，最多有2个12X环路。

对于那些目前和将来客户都不会在里面放置硬盘的fc#5802，可以更换为fc#5877扩展柜。fc#5877除了不能放置硬盘之外，其他特性与fc#5802完全相同。

2) 配置硬盘3分区*2块＝6块。例如我们选用146GB硬盘 fc#1886 = 6

3) 配置SAS卡，fc#5901 * 3, 其中2块用来在fc#5802里面做2个分区，第3块用来链接外置7214-1U2/7216-1U2。
配置SAS线，fc#3688 * 2, 用来在fc#5802中连接fc#5901到每组硬盘。
这样在fc#5802里面就有支持2分区的两组硬盘。

4) 按照所有分区的卡的需求，在Adapters页面上配置卡。在SOSWOS页面上配置7214-1U2/7216-1U2，注意配置磁带机和DVD光驱。

这样，一台支持3分区的Power 750基本配置完成。

对于更多分区要求，都可以按上述流程来配置，注意要点如下：
1) 每个fc#5802最多支持4分区，注意当前Power 750配置支持的最大分区数。
2) 一般为每分区配置2块硬盘，Power 750上应该选用 fc#188x 的 SFF硬盘。
3) 对SAS卡fc#5901，一般为在fc#5802里面的分区数 + 1, 多余的一个来连接7214-1U2/7216-1U2，来实现DLPAR。
4) 对SAS线fc#3688，一般为在fc#5802里面的分区数。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


Power 750/755的内存配置规则

解答:

Power 750/755的内置配置规则如下：

1.支持DDR3的内存；

2.内存是按照一对内存进行配置的，每个Feature Code为2根内存；

3.每个处理器板卡上支持1,2,4对内存，及支持2,4或者8根内存；不支持3对内存；

4.每个处理器板卡上的内存必须一致（不能混合不同容量和不同频率的内存）；

5.最小的内存容量为8GB（2 X 4GB DIMMs）；

最大的内存容量为：

Power 750：512GB（Power 750支持4个处理器板卡，每个处理器板卡上支持8个内存，单条内存最大容量为16GB）；
Power 755：256GB（Power 755支持4个处理器板卡，每个处理器板卡上支持8个内存，单条内存最大容量为8GB）。


配置 Power 770/780

Power 770/780

如何在Power 770/780上实现硬盘背板的分离

如何实现Power 770/780的RAID功能

在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗

Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置


如何在Power 770/780上实现硬盘背板的分离

解答:

Power 770和780服务器的每个CEC单元默认即支持磁盘背板分离的功能。每个CEC单元集成有2个SAS磁盘控制器，每个控制器管理三块磁盘，除此之外还有一个独立的媒体控制器，可以独立地控制光驱，使其能够在分区之间浮动。

还有一个选项，可以提供磁盘背板3分区的功能。此时每个CEC单元的两个集成的磁盘控制器各自控制两块磁盘，配合单独配置的一个PCI插槽的控制卡控制剩余的两个磁盘。该3分区的磁盘背板的功能需要如下配件：

Feature Code | 描述
fc#1815 | 内部SAS线，提供三分磁盘背板的功能
fc#3679 | 外部SAS线，连接SAS控制器到机箱背部接口
fc#5901 | SAS控制器

这种磁盘背板3分区的选项fc#1815可以配置到任意一个CEC单元，但不能与内部RAID选项fc#5662在同一CEC混用。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。同时，Power 770/780的内置DVD支持在多个分区之间浮动。


如何实现Power 770/780的RAID功能

解答:

在Power 770/780中，新添加了内置的RAID子卡fc#5662。该RAID子卡为一块175MB Cache RAID - Dual IOA Enablement Card，支持RAID 0,1,5,6和10。可以实现内置硬盘的RAID功能，也可以实现内置硬盘和一个fc#5886硬盘抽屉中硬盘的RAID功能。

如果需要实现CEC抽屉6块硬盘的RAID功能，需要添加fc#5662，此时，CEC抽屉的6块硬盘不支持背板分离；如下图：

如果需要实现CEC抽屉6块硬盘和一个fc#5886硬盘抽屉12块硬盘的RAID功能，需要添加fc#5662的RAID子卡，fc#1819 SAS线，fc#3686/fc#3687 SAS线，以及fc#5886的12S硬盘抽屉。其中，fc#1819的SAS线主要连接硬盘背板后方的SAS端口；fc#3686/fc#3687为YI的SAS 线，用于连接fc#5886的硬盘抽屉。如下图：

突出价值点：在Power 770/780上，直接可以通过RAID子卡实现内置硬盘和外置硬盘的RAID功能，继承了Power 520/550内置RAID子卡对硬盘做RAID的优势。该RAID子卡不占用PCI槽位，方便了用户的配置和使用。


在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗

解答：

不可以。

因为在实现了三分区的背板(triple split DASD backplane)上，有两个硬盘槽位由一个不具有写缓存的PCIe SAS控制器控制。而SSD硬盘需要控制器具有写缓存。


Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置

解答：

在TurboCore模式下，每颗处理器上会有一半的内核会关闭，这部分内核的L3 cache会供给剩下的内核使用，从而对剩余的内核的性能有一个很大的提升。一般来讲，TurboCore状态下的可使用的内核数，等于处理器内核的激活数，但最多不能超过安装的物理处理器内核的一半。所以在订购一个运行在TurboCore模式下的服务器的时候，要至少多订购一倍的物理处理器内核，但激活不需要多订购。

注意，在e-Config中允许订购一台标示为TurboCore模式，处理器激活数量超过物理处理器内核数一半的服务器。多余出来的处理器激活在TurboCore模式下不会用到，但切换到MaxCore模式下会用到。


配置 p7其他

其他

POWER7服务器 CPU，MEM，DISK的配置规则 (最近更新)

POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项

POWER7服务器如何配置3.5英寸的磁盘

POWER7全线产品家族分离背板总结 (最近更新)


POWER7服务器 CPU，MEM，DISK的配置规则

解答:

Power 710
CPU：4 at 3.0GHz; 6 at 3.7 GHz ; 8 at 3.55GHz
最大内存容量：64 GB(4,6,8 Core)
内置硬盘：3或者6个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 720
CPU：4, 6, 8 at 3.0 GHz
最大内存容量：64 GB(4 Core)、128 GB(6,8 Core)
内置硬盘：6或者8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 730
CPU：8 at 3.0GHz or 3.7GHz; 12 at 3.7GHz; 16 at 3.55GHz
最大内存容量：128 GB(8，12，16 Core)
内置硬盘：3或者6个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 740
CPU：4, 8 at 3.3GHz or 3.7GHz; 6,12 at 3.7GHz; 8,16 at 3.55GHz;
最大内存容量：128 GB(4,6 Core)、256 GB(8,12,16 Core)
内置硬盘：6或者8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 750
CPU：8, 16, 24, 32 Core at 3.0GHz,3.2GHz,3.3GHz,3.55GHz,3.6GHz
6,12,18,24 Core at 3.7GHz
最大内存容量：128 GB(8 Core)、256 GB(16 Core)、384 GB(24 Core)、512 GB(32 Core)
内置硬盘：8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和1300GB 10KRPM SAS SFF Disk Drive.

Power 755
CPU：32 at 3.3 GHz or 3.6GHz
最大内存容量：256GB(32 cores)
内置硬盘：8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 770
CPU：12, 24, 36, 48 at 3.5 GHz
最大内存容量：目前支持1066 MHz DDR3的内存：512 GB(12 Core)、1TB(24 Core)、1.5TB(36 Core)、2TB(48 Core)
内置硬盘：每个enclosure 6个2.5-inch SAS SFF DASD bays，支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 780
CPU：16, 32, 48, 64 at 3.8 GHz
8, 16, 24, 32 at 4.1 GHz(TurboCore mode)
最大内存容量：目前支持1066 MHz DDR3的内存：512 GB(12 Core)、1TB(24 Core)、1.5TB(36 Core)、2TB(48 Core)
内置硬盘：每个enclosure 6个2.5-inch SAS SFF DASD bays，支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.


POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项

解答：

冗余热插拔冷却风扇是所有新的入门级服务器的标准配置。

冗余热插拔电源，对于Power 710和720服务器是可选配置，对于Power 730和740是标准配置。

突出价值点：冗余风扇即使在入门级服务器也是标准配置，冗余电源针对不同的服务器也有更多的选择。


POWER7服务器如何配置3.5英寸的磁盘

解答：

目前所有POWER7系列服务器CEC自身都没有3.5硬盘槽位，客户如需配置3.5英寸硬盘，可以通过添加fc#5886 EXP12S SAS Disk Drawer来实现。

在添加fc#5886 EXP12S SAS Disk Drawer时，既可以通过CEC自身的外部SAS端口来连接，也可以通过额外添加的SAS控制器或RAID控制器来连接。

针对于具体的POWER7服务器，连接fc#5886的方式如下：

Power 710/730:

可以通过fc#5268硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5278和一根YO的SAS线(fc#3691/3692/3693/3694)来连接。

注意：当为4C的Power 710不支持fc#5886的扩展。

Power 720/740:

可以通过fc#5630硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5278/fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接。

注意：当为4C的Power 720不支持fc#5886的扩展。

Power 750/755:

可以通过fc#8340硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接，或者一对SAS RAID控制器fc#5903和一根X的SAS线(fc#3661/3662/3663)来连接。

Power 770/780:

需要通过额外添加的SAS控制器fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接，或者一对SAS RAID控制器fc#5903和一根X的SAS线(fc#3661/3662/3663)来连接。

突出价值点：通过添加fc#5886 EXP12S SAS Disk Drawer，提高POWER7系列服务器的灵活性和可扩展性。


POWER7全线产品家族分离背板总结

解答：

不同型号的POWER7服务器，分离背板的方法有差异。具体情况如下：

Power 770/780：

每个背板具有两个SAS控制器，不需添加任何部件，背板已经默认被分成了两部分。如果想把背板分离成三部分，需添加如下三种部件（每种部件各一个）：
fc#1815 - Internal SAS cable providing the triple split
fc#3679 - External SAS cable connecting the SAS controller to a bulkhead port
fc#5901 - SAS controller。
另外，内置光驱可以在多个分区间浮动。

Power 750：

跟Power 550一样，需要添加两根线（fc#3669和fc#3679各一根）和一块卡（fc#5912或fc#5901）。注意： 内置的DVD-RAM无法在多个分区间进行漂移。建议客户在外置的1U2上配置光驱，以使光驱在多分区间浮动。

Power 755：

背板不具有分离的功能。

Power 720/740：

在选择fc#5618背板的基础上，再选择fc#5631，以进行背板分离。fc#5631为内置硬盘提供了第二个SAS控制器，但它不占用PCI槽位。注意： 内置的DVD-RAM由fc#5618上的SAS控制器进行控制，因此无法在多个分区间进行漂移。建议客户在外置的1U2上配置光驱，以使光驱在多分区间浮动。

Power710/730：

背板不具有分离的功能。

Blades PS700/701/702/703/704：

背板不具有分离的功能。包括PS702/PS704在内，这五款刀片都仅有一个集成的SAS控制器。

突出价值点：POWER7服务器的大部分背板都支持分离功能，以满足客户支持多分区的需求。

Top


System P 服务器如何配置电源线

解答:

机器型号 | Rack（R）/ Deskside（D） | 直流（DC）/ 交流（AC） | 电源线 feature code | 备注
System POWER6
8203-E4A | R | AC | 6671/6458 | 不包括 OEM Rack Option
 | D | AC | 6493 |
8204-E8A | R | AC | 6671/6458 | 不包括 OEM Rack Option
 | D | AC | 6493 |
8234-EMA | R | AC | 6671/6458 |
9117-MMA | R | AC | 6671/6458 |
9125-F2A | R | AC | 8696 |
9119-FHA | R | AC | 8694 |
System POWER7
8231-E2B | R | AC | 6671/6458 | 不包括Oem rack option
8202-E4B | R | AC | 6671/6458 | 不包括Oem rack option
 | D | AC | 6493 |
8205-E6B | R | AC | 6671/6458 | 不包括Oem rack option
 | D | AC | 6493 |
8233-E8B | R | AC | 6671/6458 |
8236-E8C | R | AC | 6671/6458 |
9117-MMB | R | AC | 6671/6458 |
9179-MHB | R | AC | 6671/6458 |
I/O Drawer
7314-G30 | R | AC | 6458 |
HMC
7042-CR6 | R | AC | 6671/6458 |
7042-C08 | D | AC | 6493 |
Rack
7014-T00 | N/C | AC | 6491 |
 | N/C | DC |  | 客户自备
7014-B42 | N/C | AC | 6491 |
7014-T42 | N/C | AC | 6491 |

Top


介绍Power服务器上fc#6577的电源线

解答:

fc#6577是一根新的电源线选择，与原来指定电源线不同，此feature的意思是让工厂来为服务器选择到机柜PDU的合适长度的电源线。

如果服务器和T00,T42机柜在一个订单内，并且服务器指示安装到机柜，则这个feature是必选项。

但订购这个feature会造成服务器安装在机柜内，从工厂运输到客户现场。一般不建议这样运输。

所以建议不使用fc#6577这个电源线。

避免的办法有两个：

1. 若服务器和机柜在一个订单内：

把所有机柜的 Codes->Rack Indicator 更改为 fc#9002(Field Integration Indicator, Ship Empty Rack)，把所有自动配置为fc#6577电源线的服务器的 Codes->Rack Indicator 更改为 fc#4650(Rack Indicator-Not Factory Integrated)。
然后做一下Final Validation，e-config会自动按不使用fc#6577的情况来配置电源线。

2. 把服务器和机柜分在两个订单内配置。


如何在e-config中选择7316-TF3

解答：

在e-config中，有两种选择7316-TF3的方式：1、是单独选择7316-TF3；2、是通过服务器的外设选择7316-TF3，具体的如何选择7316-TF3的方式介绍如下

1.单独选择7316-TF3：

首先在Global setting中选择“Allow Standalone Peripherals”，

其次点击“OK”，回到e-config的主页面，选择“3.Peripherals”，然后双击“Displays-Coax InfoWindow/Flat Panel”

在Available Products 列表中，即可选择7316-TF3,并进行配置

2.在服务器的外设进行配置7316-TF3：

以Power 570服务器为例：
Power 570的硬件配置“SOSWOS”页面，在Available Products列表中，选择7316-TF3，双击后即可进行配置。

具体配置图示参见网站：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=1511239B27000

突出价值点：7316-TF3液晶折叠套件可以放置在机柜中，配置了KVM切换器和相应的连线，可以最多连接128台主机，节省大量空间。

Top


Power服务器上的几种 10 Gigabit的以太网卡有什么不同

解答：

在Power 520/550/560/570/595/720/740/750/755/770/780的配置中，支持四种类型的10Gigabit以太网卡，他们分别是：fc#5769，fc#5772，fc#5721，fc#5732。

下面分别做一个简单的介绍：

fc#5769 10 Gigabit的以太网卡，一个高性能，PCIe的网卡，支持LC标准的接头，支持850nm的多模光纤线(MMF)，支持的距离为300m，该网卡支持IEEE 802.3ae 10GBASE-SR标准。

fc#5721 10 Gb，PCI-X 2.0 DDR的以太网卡，支持多模光纤线(MMF)，62.5um的光纤线支持长度为33m，50um的光纤线长度为300m。光纤线为LC标准的接头，该以太网卡支持IEEE 802.3ae标准。

fc#5772 10 Gigabit PCIe的以太网卡，提供高性能的光纤网卡，支持1310nm的单模光纤线(SMF)，支持距离能长达10千米。支持IEEE 802.3ae标准。

fc#5732 10 Gigabit PCIe的高性能以太网卡。通过铜线缆进行连接，支持的距离为15m，支持IEEE 802.3ae 10GBASE-CX4标准。

在Power710/730的配置中，支持两种类型的10 Gigabit 以太网卡，分别是：fc#5272和fc#5275；
在Power720/740的配置中，支持四种类型的10 Gigabit 以太网卡，分别是：fc#5272，fc#5275，fc#5284，fc#5286。

fc#5272，fc#5275的以太网卡均为PCIe Low-Profile(LP)类型的卡，可以用于Power710/730的PCIe Low-Profile槽位，及Power720/740的fc#5610(PCIe Riser Card Gen1) 或者fc#5685（PCIe Riser Card Gen2）的PCI扩展卡上。

fc#5284，fc#5286的以太网卡均为PCIe2 Low-Profile（LP）类型的卡，可以用于Power720/740的PCIe2 Low-Profile槽位，及Power720/740的fc#5685（PCIe Riser Card (Gen2)）的PCI扩展卡上。

下面将对fc#5272，fc#5275，fc#5284，fc#5286这四种10 Gigabit 以太网卡做一个简单的介绍：

fc#5272：PCIe LP 10GbE CX4 1-port Adapter，该卡与fc#5732 PCIe的网卡功能类似，可参考fc#5732的介绍；
fc#5275：PCIe LP 10GbE SR 1-port Adapter，该卡与fc#5769 PCIe的网卡功能类似，可参考fc#5769的介绍；
fc#5284：PCIe2 LP 2-port 10GbE SR Adapter，该卡为双端口，PCIe Gen2的Low Profile 10GbE网卡，其提供2个 10Gb以太网SFP+ SR端口，支持最远300m的光纤线连接。
fc#5286：PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter，该卡为双端口，PCIe Gen2的Low Profile 10GbE网卡, 其提供2个10Gb以太网SFP+ copper twinax端口，支持最远5m的线缆连接。

突出价值点：多种10 Gigabit 以太网卡，提供了不同模式，不同接口，不同距离的选择，在配置上更灵活，适用于各种不同的需求。


配置FCoE卡时的注意事项

解答：

一般注意事项同10GB 以太网卡或者8GB HBA卡。

此外还要考虑：
a) 要确保带宽能够满足以太网+光纤通道的峰值流量之和；
b) 要考虑单端口的最大的以太网负载性能(吞吐量和延迟)；
c) 对操作系统的需求和限制，尤其是IBM i；
d) 确保环境提供FCoE交换机(除非只有直连方式)。

突出价值点：FCoE能减少数据中心的接口卡、电缆和网络设备，从而使数据中心变得比较简单、绿色环保。在一些大公司，如果能减少电缆数量，将会对空气流动产生积极作用，并减少降温成本。


用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？

解答：

有5种不同的Features，根据服务器的差别配置是有区别的：

Feature Code | Power server 服务器
fc#8273 | JS23/43 刀片
fc#8207 | PS703/PS704 刀片
fc#1890 or fc#1909(i)SFF | Power 520/550/710/720/730/740/750/755/770/780 CEC抽屉（fc#8346/fc#8340）
fc#1995 or fc#1996(i) | Power 710/720/730/740/750/770/780
fc#3586 or fc#3587(i) | Power 560/570 CEC抽屉 或者 fc#5886扩展抽屉
fc#1995 or fc#1996 (i) | fc#2053/2055的 PCIe RAID & SAS Adapter

配置时我们要注意以下几点：
1) SSD 是不兼容fc#5900和fc#5901和fc#5912卡的；
2) fc#1890 和 fc#1909 是可以配置在Power 520/550/710/720/730/740/750/755/770/780的CEC抽屉以及fc#5802和fc#5803的IO抽屉里；
3) fc#3586和fc#3587是不可以配置在Power 520和Power 550CEC里；
4) fc#5886的扩展抽屉最多支持8块SSD盘，在fc#5886里也不可以混SSD和HDD；包含着SSD的fc#5886不可以再串接其他的fc#5886，也不可以连接到Power 520/550 CEC上的外置接口；
5) SSD和HDD不可以混合在同一个RAID array中；
6) 当Power 520或者Power 550配置分离的硬盘底板时, SSD和HDD是可以被分别安放在左右两边不同的底板域中，但是不可以混合在同一边的底板域里；
7) 当Power 520或者Power 550配置没有分离功能的硬盘底板时, SSD和HDD是可以被混合安放在一个底板里；
8) SSD和HDD的盘是不可以混合在一起做镜像的；
9) 当将SSD放到fc#5802和fc#5803的IO抽屉中，一个抽屉最大支持9块SSD硬盘，且必须通过一对fc#5903/5805的SAS RAID卡连接；
10)fc#1995/fc#1996主要放置到fc#2053/2055的 PCIe RAID & SAS Adapter上。每块卡支持1,2 or 4块fc#1995/fc#1996的SSD硬盘。

突出价值点：固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。

Top


新发布的SFF硬盘和SSD 硬盘的特性是什么？如何配置

解答：

（1）SFF硬盘

Small Form Factor ，2.5英寸硬盘，比HDD硬盘更加节能。

支持的配置环境：
Power 520/550 CEC,Power 710/720/730/740/750/755/770/780 , fc#5802和fc#5803 PCIe 12X I/O Drawer。

现在可以配置的SFF 硬盘容量：
for AIX
-fc#1882 146GB 10K rpm；
-fc#1885 300GB 10K rpm；
-fc#1883 73GB 15K rpm；
-fc#1886 146GB 15K rpm；
for i
-fc#1884 69GB 15K rpm；
-fc#1888 139GB 15K rpm。

（2） SSD硬盘

Solid State Drive (SSD)，固态硬盘。固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。
容量：69GB(fc#1890 or fc#1909(i)SFF/fc#3586 or fc#3587(i))/177GB(fc#1995 or fc#19969(i))

支持的环境：
69GB的SSD硬盘支持的硬件环境：Power 520/550/560/570/575/595/710/720/730/740/750/755/770/780/EXP 12S SAS Drawer/fc#5802/fc#5803；
177GB的SSD硬盘支持的硬件环境：Power 710/720/730/740/750/755/770/780,需要放置到fc#2053/2054/2055的 PCIe RAID & SAS Adapter上。

支持的RAID 配置：RAID 0和5。

配置规则：
internal controller：支持SAS和SSD的混合配置；
internal RAID:不支持SAS和SSD的混合配置；
分离背板：不支持SAS 和SSD 混合配置在一组内；
EXP 12S SAS Drawer：支持8块SSD 硬盘，4个槽位空闲；不支持混合设备；
fc#5802/fc#5803:每对fc#5903的卡，最大8块SSD硬盘；
每块fc#2053/2054/2055的 PCIe RAID & SAS Adapter，支持1,2 or 4块fc#1995/fc#1996的SSD硬盘。

突出价值点：SFF硬盘比HDD硬盘更加节能。固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。

Top


为什么必须要配置一对fc#5805的RAID卡？？

为什么必须要配置一对fc#805的RAID卡？

解答：

只有存在两个fc#5805 Controller 时，fc#5805 的RAID Cache才能激活。

如果任何一个fc#5805 Controller 的微码检测不到另一个fc#5805 RAID 卡，那么不能激活fc#5805的RAID Cache。

当配置了两个fc#5805 Controller，就可以在两个fc#5805 Controller中都记录写Cache数据和RAID校验的信息，因此，当一个Controller出问题时，RAID Cache能进行数据恢复。

注意：fc#5902和fc#5903的SAS RAID卡也必须成对的配置，但是这两块卡已经停产，目前由fc#5805的SAS RAID 替代。


fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？

解答：

尽管fc#5805与fc#5903的有着相同的CCIN号(574E)和功能，但两者还是有区别的：

由于fc#5805上的电池比fc#5903上的更薄，fc#5805整块卡的厚度比fc#5903要小。

注意：

1. Power 720/740上的PCIe插槽比其它机器型号的PCIe插槽要紧，所以Power 720/740上只能使用fc#5805，不能使用fc#5903。但是，在能使用fc#5903的地方，都可以使用fc#5805。

2.fc#5903已于2011年1月7日停产。


Power中异步卡和串口线的选择

解答：

目前，在e-config中，可以配置的异步卡为fc#5785，fc#5277：

fc#5785: 4 Port Async EIA-232 PCIe Adapter,它是一个4口，EIA-232标准的异步卡，EIA-232为一个9针的接口。

fc#5277: PCIe LP 4-Port Async EIA-232 Adapter, 它是一个4口，EIA-232标准的异步卡，EIA-232为一个9针的接口，其功能与fc#5785类似，但是为PCIe LP的接口，只能用于Power 710/720/730/740上的PCIe LP 槽位。

异步卡的串口线有如下种类：

fc#3124: Serial-to-Serial Port Cable for Drawer/Drawer,3.7米的串口线，该线的两端分别提供了一个25针的连接器；

fc#3125：Serial-to-Serial Port Cable for Rack/Rack，8米的串口线，该线的两端分别提供了一个25针的连接器；

fc#3927：Serial Port Null Modem Cable, 9-pin to 9-pin, 3.7M，3.7米的串口线，该线两端分别提供了一个9针的连接器；

fc#3928：Serial Port Null Modem Cable, 9-pin to 9-pin, 10M，10米的串口线，该线两端分别提供了一个9针的连接器。

通常，两台设备在做PowerHA时，除了选择异步卡还会选择相应的串口线。

对于fc#5785/fc#5277的4口异步卡，有两种类型的串口线可以选择：

1.fc#3124或者fc#3125 的串口线，此时，需要配一个9针到25针的转换头：

fc#3925：Serial Port Converter Cable, 9-Pin to 25-Pin，9针到25针的转换头，通过这个转换头，可以将fc#3124或者fc#3125的串口线连接到异步卡fc#5785/fc#5277上。

2.fc#3927或者fc#3928的串口线。

查询：Sales Manual

Power 产品销售手册查询

突出价值点：在做PowerHA的时候，强烈推荐配置一个非IP网络的心跳的方式，其中串口心跳是最常见的方式之一。心跳机制用来监控集群中节点的状态，进行节点间信息通信，故障判断，事件触发等等重要作用。新推出的fc#5785/fc#5277的4口PCIe异步卡，能够提供更高的性能，并可以用于多款PCIe的IO抽屉中。

Top


在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？

解答:

打开相应Power机型，在分区(CSP/LPAR)子项中找到PowerVM各版本（Feature Code参见下面的列表），它的数量与被激活处理器的数量必须一致.

POWER6 | Express (3 Micro-partitions, VIOS/IVM, Lx86) | Standard (Full Micro-partitioning) | Enterprise (Live Partition Mobility for AIX & Linux)
9119 FHA | NA | #7943 | #8002
9125 F2A | NA | #7949 | #8024
9117 MMA | NA | #7942 | #7995
8234 EMA | NA | #7942 | #7995
8204 E8A | #7983 | #7982 | #7986
8203 E4A | #7983 | #8506 | #8507
8231 E2B | #5225 | #5227 | #5228
8202 E4B | #5225 | #5227 | #5228
8205 E6B | #5225 | #5227 | #5228
8233 E8B | #7793 | #7794 | #7795
8236 E8C | NA | NA | NA
9117 MMB | NA | #7942 | #7995
9179 MHB | NA | #7942 | #7995
7998 61X | NA | #5409 | #5649
7998 60X | NA | #5406 | #5606
7778 23X | NA | #5429 | #5607
8406 70Y | #5225 | #5227 | #5228
8406 71Y | #5225 | #5227 | #5228
7891 73X | #5225 | #5227 | #5228
7891 74X | #5225 | #5227 | #5228


fc#5802/5803如何配合主机实现分区功能

解答：

fc#5802

IO抽屉fc#5802有4个磁盘的背板，其中两个为4块硬盘一个通道，两个为5块硬盘一个通道；

fc#5802可以支持1个磁盘通道， 18块硬盘；2个磁盘通道，每个通道9块硬盘；4个磁盘通道，其中2个通道4块硬盘，2个通道5块硬盘；通道数量是通过IO抽屉上有个Mode Switch进行选择的。

注意一点，fc#5802的硬盘通道需要添加SAS Adapter。

4个通道的配置情况：

需要4个SAS PCIe卡+4根fc#3688的AT线。

2个通道的配置情况：

需要2个SAS PCIe卡+2根fc#3688的AT线。

1个通道的配置情况：

需要1个SAS PCIe卡+1根fc#3688的AT线。

在e-config中，默认只会选择1根fc#3688的AT线，当大于1个通道的时候，需要添加相应数量的AT线来实现多个硬盘通道。

fc#5803

IO抽屉fc#5803是适用于Power 595，它和fc#5802的功能类似，但是它支持的通道的硬盘数和fc#5802不同；fc#5803的4个磁盘背板，其中两个为7块硬盘一个通道，两个为6块硬盘一个通道。

fc#5803可以支持一个磁盘通道，26块硬盘；2个磁盘通道，每个通道13块硬盘；4个磁盘通道，其中2个通道7块硬盘，2个通道6块硬盘；通道数量是通过IO抽屉上的Mode Switch进行选择的。fc#5803的磁盘通道需要添加SAS Adapter实现，其配置方式和fc#5802相似。

fc#5802/fc#5803支持的硬盘均为2.5英寸的SFF SAS硬盘。

突出价值点：fc#5802/5803 使用2.5"硬盘，带有PCIe插槽，支持4组硬盘。是目前性能最好的I/O drawer. 具有硬盘槽位多，PCIe槽位多，支持的分区多的优点。

Top


Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

解答:

Power 520/550/750 目前支持两种GX 12X接口卡：fc#5609和fc#5616,可用来提供GX 12X接口以连接12X的I/O扩展柜。

其中fc#5616是SDR的，fc#5609是DDR的，DDR的数据传输速度是SDR的两倍；

fc#5616和fc#5609均支持fc#5796,fc#5802和fc#5877的IO抽屉。

在配置时要注意：

1-core的Power 520是不能配置GX卡的；
2-core的Power 520/550，8-core的Power750只能配置fc#5616，及当配置一块处理器卡时，只能配置fc#5616；
只有4-core及以上的Power 520/550,16-core及以上的Power 750才可以配置/fc#5609，及当Power 550/750配置两块及以上处理器卡时，可以配置fc#5609。

突出价值点：fc#5609 12X Adapter提供更高的带宽，其数据传输速度是fc#5616 12X Adapter的两倍。


POWER服务器常用I/O抽屉配置方法

解答：

 | 外观 | 容量 | 主机接口卡 | 数据连线 | MAX / Loop(Adapter)
fc#5886 | 2U 19" | 12块SAS硬盘 | fc#5912/fc#5901/fc#5278( PCIe LP) fc#5902/fc#5903 fc#5904/fc#5908 | SAS(YO)线 SAS(EE)线 | 4 (fc#5904/fc#5908为5)
fc#5887 | 2U 19" | 24块Gen2 SFF SAS硬盘 | fc#5901/fc#5278( PCIe LP) fc#5903/fc#5805 fc#5904/fc#5906/fc#5908 CEC SAS Port | SAS(YO)线 SAS(X)线 | 2(每块SAS卡，最多连接2个fc#5887)
fc#5796 | 4U 19"半宽 | 6个266MHz PCI-X插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 4
fc#5802 | 4U 19" | 18个SAS SFF硬盘+10个PCIe插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 2
fc#5877 | 4U 19" | 10个PCIe插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 2
7311-D20 | 4U 19" | 12块SCSI硬盘+7个133MHz PCI-X插槽 | fc#5614(Power 520, 550) fc#1800(Power 560, 570) | N+1根RIO-2线 SPCN线 | 6

注意:

1. N为I/O抽屉个数
2. SPCN线的数量是服务器内所有有SPCN接口的I/O抽屉(e.g. fc#5796, fc#5802, 7311-D20)的数量+1
3. fc#5609卡仅支持4-core及以上的power 520, 550,750，并且一台服务器最多一块；
4. fc#5615卡仅支持6-core及以上的Power 720，并且Power 720最大支持一块fc#5615；
5. 一块fc#5912/fc#5901最多可接4台fc#5886，需2根SAS(YO)线，4根SAS(EE)线；连线如图1所示；
6. 若要求每个fc#5886支持一个LPAR，则需要每个fc#5886配置1个fc#5912/fc#5901/fc#5278(LP PCIe)+1根SAS Cable(YO), 连线如图2所示；
7. 如果要求fc#5886中的硬盘做RAID，需要把fc#5912/fc#5901改为成对的fc#5902/fc5903，相应连线会变为SAS Cable(X)，fc#5902/fc#5903支持RAID 0, 5, 6, 10，连线如图3所示；
8. 12X抽屉和RIO-2抽屉不能混在一个IO环路中, fc#5796和fc#5802不能混在一个IO环路中；
9. fc#5802和fc#5877可以在一个环路中；
10. 每个fc#5796需要配置一块fc#6446或者fc#6457；如果主机和抽屉在3米，抽屉和抽屉在1.5米之内，选用fc#6446即可；如果超过这个距离，需要选配fc#6457(带有中继器)；
11. fc#5887的IO抽屉，可以支持1/2/4个分区，每块SAS卡最多连接2个fc#5887。

图1: 1块fc#5912/fc#5901连接4台fc#5886

图2: 1块fc#5912/fc#5901连接1台fc#5886

图3: 2块fc#5902/fc#5903连接1台fc#5886实现RAID

Top


System P系列服务器都支持哪一些类型的I/O Drawer

解答:

Server I/O Drawers/Towers

Drawer | Server Loop Attachment | PCI Slots per Drawer | Disk Bays per Drawer | POWER6 Availability | Max Drawers per Loop | Footprint
#5802 | 12X DDR 6 | 10 PCIe | 18 SFF SAS | Y | 2 | 19" rack
#5877 | 12X DDR 6 | 10 PCIe | 0 | Y | 2 | 19" rack
#5803 | 12X DDR 6 | 20 PCIe | 26 SFF SAS | Y | 1 4 | 24" rack
#5873 | 12X DDR 6 | 20 PCIe | 0 | Y | 1 4 | 24" rack
7311-D20 | RIO-2 | 7 PCI-X | 12 SCSI | limited, mig | 6 | 19" rack 4U
#0595 | RIO-2 1 | 7 PCI-X | 12 SCSI | w/d, mig | 6 | 19" rack 5U
#5095 | RIO-2 1 | 7 PCI-X | 12 SCSI | w/d, mig | 6 | Tower
7314-G30 | 12X SDR | 6 PCI-X DDR | 0 | w/d, mig | 4 | 19" rack 1/2 4U
#5796 | 12X SDR | 6 PCI-X DDR | 0 | Y | 4 | 19" rack 1/2 4U
7311-D11 | RIO-2 | 6 PCI-X | 0 | w/d, mig | 4 | 19" rack 1/2 4U
#5790 | RIO-2 1 | 6 PCI-X | 0 | Y 7 | 6 | 19" rack 1/2 4U
#5094 | RIO-2 1 | 14 PCI-X | 15/45 SCSI | w/d, mig | 6 | Tower
#5294 | RIO-2 1 | 28 PCI-X | 90 SCSI | w/d, mig | 3 2 | 19" rack 36U
#5096 | RIO-2 1 | 14 PCI-X | 0 | w/d, mig | 6 | Tower
#5296 | RIO-2 1 | 28 PCI-X | 0 | w/d, mig | 3 2 | 19" rack 36U
#0588 | RIO-2 1 | 14 PCI-X | 0 | w/d, mig | 6 | 19" rack 8U
#5088 | RIO-2 1 | 14 PC-X | 0 | w/d, mig | 3 5 | Tower
EXP24 7031-D24 | n/a | 0 | 24 SCSI | w/d, mig | n/a | 19" rack 4U
EXP24 #5786 | n/a | 0 | 24 SCSI | Y 10 | n/a | 19" rack 4U
EXP 12S #5886 | n/a | 0 | 12 SAS | Y | n/a | 19" rack 2U
EXP 24S #5887 | n/a | 0 | 24 Gen-2 SFF SAS | Y | n/a | 19" rack 2U
7040-61D 9 | RIO-2 | 20 PCI-X | 16 SCSI | w/d, mig | 1 4 | 24" rack
#5791 9 | RIO-2 | 20 PCI-X | 16 SCSI | w/d, mig | 1 4 | 24" rack
#5794 9 | RIO-2 | 20 PCI-X | 8 SCSI | w/d, mig | 1 4 | 24" rack
#5797 3 9 | 12X | 14 PCI-X DDR, 6 PCI-X | 16 SCSI | Y | 1 4 | 24" rack
#5798 3 9 | 12X | 14 PCI-X DDR, 6 PCI-X | 16 SCSI | Y | 1 4 | 24" rack

1 System i servers used the term “HSL” instead of “RIO”. The terms are interchangeable.
2 Requires two positions on the loop. Physically is two I/O towers in a 19” 36U rack
3 #5797 and #5798 same drawer except #5797 supports longer 12X cables and can be located in an expansion rack. #5798 can not be in expansion rack, only the CEC frame.
4 Logically two drawers in one 4-U foot print. Can be configured with two loops per drawer or one loop per drawer
5 5088 bolted to top of 5094 tower. Thus combination of 5094 + 5088 require 2 positions on loop
6 Runs at DDR speed assuming CEC GX adapter and 12X cable are also DDR. Otherwise runs at SDR.
7 Withdrawn for new orders on Power 595 (9119-FHA), but can be ordered as RPQ 8Q4004
8 Announced withdrawal for Feb 2010. Already withdrawn on Power 595 (9119-FHA), but can use RPQ 8Q4004 8 Withdrawn from marketing effective November 2009
9 Disk bays used by drives formatted for AIX/Linux, not IBM i formatted drives
10 Drawer avaible for existing SCSI disk migration. New SCSI disk withdrawn from marketing
w/d Withdrawn from marketing, not orderable from IBM Manufacturing
Limited 7311-D20 redefined for new orders to always require specific telephony adapters and to require an RPQ. Thus this drawer effectively withdrawn except for special telephony configurations
nan Not Available New – can’t/shouldn’t be ordered with a Power System. Use either equivalent feature code I/O drawer or use newer technology drawer (12X or SAS)
mig Migrate Attachment of existing I/O units supported
Y New I/O drawers orderable from IBM Manufacturing
n/a Not applicable

Server I/O Drawer Attachment

Server Drawer | 520 1-core (0 Loops) | 520 2-,4-core (0-2 Loops) | 550 0-2 Loops | 560 (0-3 Loops) | 570 0-8 Loops | 575 0-1 Loops | 595 1 1-32 Loops
Max 2 all RIO | 0 | 12 | 12 | 18 | 48 | 0 | 95 (IBM i), 12 (AIX)
Max 2 all 12X | 0 | 8 | 8 | 12 | 32 | 1 | 32
#5802 | 0 | Max 4 | Max 4 | Max 6 | Max 16 | 0 | 0
#5877 | 0 | Max 4 | Max 4 | Max 6 | Max 16 | 0 | 0
#5803 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 32
#5873 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 31
7311-D20 | 0 | Max 12 | Max 12 | Max 18 | Max 48 | 0 | 0
#0595 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5095 | 0 | Max 12 | Max 12 | 0 | 0 | 0 | 0
7314-G30 | 0 | Max 8 | Max 8 | Max 12 | Max 32 | 0 | 0
#5796 | 0 | Max 8 | Max 8 | Max 12 | Max 32 | 0 | 0
7311-D11 | 0 | 0 | 0 | 0 | Max 20 | 0 | 0
#5790 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5094 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5294 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
#5096 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5296 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
#0588 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5088 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
EXP24 7031-D24 | 0 | Max 12 | Max 24 | Max 26 | Max 60 | 0 | 0
EXP24 #5786 | 0 | Max 12 | Max 24 | Max 26 | Max 60 | 0 | Max 110
EXP 12S #5886 | 0 | Max 24 | Max 48 | Max 110 | Max 110 | Max 98 per node | Max 185
7040-61D | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5791 | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5794 | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5797 | 0 | 0 | 0 | 0 | 0 | 0 | Max 30
#5798 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 30

1 At least one I/O drawer with PCI slots is required. After May 2009 the #5803/5873 is highly recommended as that initial drawer. Between Nov 2008 and May 2009, the 12X #5797/5798 was highly recommended for that initial drawer. Prior to Nov 2008, at least one #5791 (AIX/Linux) or #5790 (IBM i) was required
2 Though you can mix RIO and 12X I/O drawers on systems with two or more loops, within a loop it must be all RIO drawers or all 12X drawers. Thus if you add 12X loops, you lower the maximum number of RIO drawers, and vice versa. Note this maximum does not include I/O drawers with no PCI slots such as disk-only drawers or removable media drawers.
12X I/O drawers with PCIe slots can not be mixed on the SAME loop as 12X I/O drawers without PCIe slots.

Server Drawer 1 | Power 710 / 730 Express 0 Loops | Power 720 Express 0-1 Loops | Power 740 Express 0-2 Loops | Power 750 Express 0-2 Loops | Power 755 0 Loops | Power 770 0-8 Loops | Power 780 0-8 Loops
#5802 | 0 | Max 24 | Max 4 | Max 4 | 0 | Max 16 | Max 16
#5877 | 0 | Max 24 | Max 4 | Max 4 | 0 | Max 16 | Max 16
7314-G30 | 0 | Max 44 | Max 8 | Max 8 | 0 | Max 32 | Max 32
#5796 | 0 | Max 44 | Max 8 | Max 8 | 0 | Max 32 | Max 32
EXP24 7031-D24 | 0 | Max 124 | Max 24 | Max 24 | 0 | Max 60 | Max 60
EXP24 #57862 | 0 | Max 124 | Max 24 | Max 24 | 0 | Max 60 | Max 60
EXP 12S #5886 | 83 | Max 284 | Max 28 | Max 48 | 13 | Max 110 | Max 110
EXP 24S #5887 | 0 | Max 144 | Max 14 | Max 24 | 7 | Max 56 | Max 56

1 Though you can mix 12X PCI-X DDR I/O drawers with 12X PCIe I/O drawers on a system with two or more loops, within a loop it must be all PCIe or all PCI-X DDR I/O drawers.
2 In addition to the #5786, the EXP24 #5787 Disk Tower is supported, but not orderable, on the Power 750.
3 Disk-only I/O drawers are not supported on 4-core Power 710 Express configurations.
4 12X I/O drawers or disk-only drawers are not supported on 4-core Power 720 Express configurations.

参考链接：http://www-03.ibm.com/systems/power/hardware/reports/factsfeatures.html

Top


怎样配置fc#5796和fc#5802的IO抽屉

解答：

一．对于服务器配置fc#5802/fc#5877的IO抽屉：

在Power 520，550，560，570，720，740，750, 770,780上均可以配置fc#5802/fc#5877的IO抽屉,fc#5802的IO抽屉可以放置18块SFF SAS硬盘和10个PCIe的槽位；fc#5877的IO抽屉可以放置10个PCIe的槽位，下面将详细介绍在不同产品上配置fc#5802/fc#5877的配置方式：

Power 520/550/750: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#5616/5609) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5802/fc#5877数量+1)。
Power 560/570: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#1802) + 2根12X DDR cable + 2根SPCN cable(每个环路的12X DDR cable和SPCN cable的数量为fc#5802/fc#5877数量+1)。
Power 720/740: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#5615) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5802/fc#5877数量+1)。
Power 770/780:配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#1808) + 2根12X DDR cable + 2根SPCN cable(每个环路的12X DDR cable和SPCN cable的数量为fc#5802/fc#5877数量+1)。

每个GX Loop Adapter的一个环路支持最大2个fc#5802/fc#5877。

二. 对于服务器配置fc#5796的IO抽屉：

在Power 520，550，560，570, 720, 740, 750, 770,780上均可以配置fc#5796的IO抽屉,该IO抽屉可以放置6个PCI-X的槽位。下面将详细介绍在不同产品上配置fc#5796的配置方式：

Power 520/550/750: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#5616/5609) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 560/570: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#1802) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 720/740: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#5615) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 770/780: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#1808) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。

每个GX Loop Adapter的一个环路支持最大4个fc#5796。

注意：

1C的Power 520不支持IO抽屉的扩展；
4C的Power 720不支持IO抽屉的扩展；
4C的Power 520，或者4C及以上的Power 550/750才可以配置fc#5609的12X GX的卡；
Power 720最大支持一个IO 环路。

另外：用于I/O抽屉fc#5796上两种12X Channel Attach卡（fc#6446和fc#6457），主要是用在I/O柜上以提供12X接口的，其区别如下：

fc#6446没有转发器(Repeater)而fc#6457有转发器(Repeater)。

在使用时要注意,fc#6446只能用在单个机柜之内的I/O柜的连接，主机和I/O柜之间不能超过3米,I/O柜之间互连时,如果两个I/O柜上都用fc#6446,则它们之间距离不能超过1.5米,如果只有一个I/O柜用fc#6446(另一个用fc#6457)则距离不能超过3米。fc#6457可以用于放置在两个不同的机柜之间的I/O柜的互连,当I/O柜上都用fc#6457时,主机与I/O柜或两个I/O柜之间允许的最大连接距离是8米。

突出价值点：对于POWER6/POWER7的服务器，提供了PCI-X和PCIe槽位的IO抽屉，可以根据客户的不同需求，进行PCI槽位的扩展，提高了POWER6/POWER7服务器的扩展能力。


7014-T00/T42/B42机柜PDU和电源线的配置介绍

解答：

7014-T00/T42中，有两种PDU可以选择，均为C13的标准：

fc#7188/9188:提供12个接口，机柜默认会配置一个fc#9188的PDU，需要手动配置fc#7188；

fc#5889/7109:提供12个接口，为智能的PDU，可以监测PDU的耗电情况。

所配置的电源线为默认的fc#6491，建议使用冗余的PDU，且PDU数量与电源线数量相同。

7014-B42机柜，有两种标准的PDU，C13和C19的标准。该机柜能同时装入刀片机箱和小型机，放置不同的设备，需要配置不同的PDU。

能放入B42机柜的小型机主要有：POWER5机型: p5 505/505Q、p5 510/510Q、p5 520/520Q、p5 550/550Q、p5 560Q、p5 570；POWER6机型：Power 520、 Power 550、Power 560、Power 570；POWER7机型：Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780。

当放置小型机或者刀片机箱BCS(电源插头为C14标准的fc#4505)时，需要在B42机柜里配置fc#7188/fc#7109的PDU(C13)和fc#6491的电源线；
当放置刀片机箱BCH或者BCS(电源插头为C20标准的fc#4548)时，需要在B42机柜里配置fc#7189的PDU(C19)和fc#6491的电源线。

建议使用冗余的PDU，且PDU的数量和电源线的数量相等。

突出价值点：目前可以配置三种19英寸的IBM机柜，根据不同插头标准，选择不同类型的PDU。T42机柜里，能够配置智能PDU(iPDU)，Active Energy Manager与智能PDU(iPDU)或EnergyScale配合使用，提供最广泛的电源管理。

Top


为什么现在在配置中介质会出现ESD，如何避免

解答:

ESD(Electronic Software Delivery)是IBM的软件的一种新发布方式，用户购买了相关软件之后，可以到IBM指定的网页上下载相关软件，自行刻录使用。如需传统发布方式: DVD/CD-ROM方式，请参考以下方法修改。

e-config的现在的缺省方式是ESD，改为DVD介质的方法如下：

1. 如果是一个全新的配置，在做任何配置之前，在Global Settings → Software Default Options - p5/AIX Default Options → Media设置为DVD/CD-ROM即可。要注意这个设置只对之后的软件配置起作用。

2. 如果是一个已经做好的配置，则需要：

进入每台服务器的Software Products → Shared Preferences 页面，点击每行 Delivery SIPO, 把Preference的Media页改为DVD/CD-ROM。

注意的是，如果订购了C/C++等目前还只有CD-ROM介质的软件，还需要到这个软件配置画面里，在Prodcut Preference里面把Media改为CD-ROM才可以。

注意是每台服务器都需要修改。


如何通过e-config工具，配置C/C++, fortran, Cobol等开发环境

解答:

在配置完硬件后，通过点击“configure”回到e-config主界面， 选择“Software Products”，在弹出一个新界面，在“Product Categories”页面选中 “Programming Languages”， 然后再到“Product Selections”页面，根据客户需要选择相应的C/C++, fortran, Cobol等开发环境的软件。

例如目前在e-config中，可配置的C/C++, fortran, Cobol等开发软件如下:

5724-X13 IBM XL C/C++ FOR AIX, V11.1

5724-X15 IBM XL Fortran for AIX V13.1

5724-Z87 IBM COBOL for AIX V4.1


附录 Power

附录

Power 服务器售前常用工具

1. IBM Power Systems Competitive Sales Tool Version 20.1 (May 4, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/B48EB3335EFE53390025730900271CD0?Opendocument?OpenDocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件

2. TCO/ROI估算工具

一个非常好的TCO/ROI评估工具 - Alinean SCON, 该工具通过数字、图表的方式，直观地展现使用IBM的服务器整合方案可以为客户带来怎样的成本降低和高的投资回报率。Alinean作为第三方工具，不隶属任何厂商，因而更中立，合作伙伴、最终客户都可自行注册使用。

下面列出了工具最近更新的部分信息：

1. 在Questionnaire 页面，添加了更多的信息：
System Group扩展到10个；
Workload Group输入信息进行了更新；
Additional Enterprise Software部分添加了新的软件：
（1）Data Management
（2）Application Serving
（3）Virtualization (includes Systems Software)
（4）Systems Management
（5）Threat Mitigation
（6）Email Applications
2. 在Solution页面，添加了高可用性的选项；在System Management选项里，添加了VMControl子项；
3. 在TCO Analysis页面，Server Hardware Costs worksheet也进行了更新；
4. 添加了对输出报告的翻译工具，可将针对存储和服务器的IBM Systems Consolidation Evaluation Tool的输出报告翻译成简体中文的版本。

工具链接：https://roianalyst.alinean.com/stg/

工具的介绍，可以参考网络课堂《您可以使用的TCO/ROI估算工具 》。

3.在线Power系列服务器产品支持，热点包括：

(1) IBM Power System 常见问题汇总：IBM工程师常遇到的问题汇总

(2) IBM Power System 产品配置常见问题汇总

(3) 网络课堂：以Flash动画的方式对当前热门技术进行介绍，甚至包括用e-Config一步一步的教您如何配置一台服务器.

还有很多其他有用的链接:
http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=1

4.IBM Power服务器参数和特性报告

IBM Power System facts and features，当前Power服务器的各项物理、电气参数，性能指标等的一个汇总报告。
http://www-03.ibm.com/systems/p/hardware/reports/factsfeatures.html

5.IBM 性能报告

System performance report， 所有的IBM Power服务器的性能参数汇总，包括SPEC、TPC、rPerf等参数，是查看Power服务器性能的权威资料。
http://www-304.ibm.com/jct03004c/systems/p/hardware/reports/system_perf.html

6.IBM AIX, VIOS and HMC Facts & Features

IBM AIX, VIOS and HMC Facts & Features，列出了AIX、VIOS和HMC相关的版本以及相应功能的汇总报告。
http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD103130

7.刀片产品（System X和Power刀片）的兼容性文档列表

刀片产品（System X和Power刀片）的兼容性文档列表
http://www-03.ibm.com/servers/eserver/serverproven/compat/us/eserver.html

8.PowerHA兼容性手册

PowerHA兼容性手册中，包含了HACMP v5.4.1、PowerHA v5.5、PowerHA v6.1、PowerHA v7.1与Power服务器、IBM Storage、Adapters、AIX版本的兼容性信息。
http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD105638

9.销售手册

IBM硬件和软件的销售手册
http://www-01.ibm.com/common/ssi/index.wss

10.红皮书网站

全面的IBM技术参考资料网站。
http://www.redbooks.ibm.com

例如：

用“Technical Overview and Introduction”来查询，能够查询到各款IBM Power服务器的技术特点介绍红皮书；
用“PowerVM”来查询，能够查询到现在IBM Power服务器上虚拟技术相关的红皮书。

11.IBM Power产品和友商产品的参数对比

IBM Power产品和友商产品的参数对比链接：
http://www-03.ibm.com/systems/migratetoibm/systems/power/performance.html

12.IBM Power产品白皮书链接

(1) IBM Power产品白皮书

(2) AIX 6.1 信息中心:
http://publib.boulder.ibm.com/infocenter/systems/scope/aix/index.jsp

(3) AIX 5.3 信息中心:
http://publib.boulder.ibm.com/infocenter/pseries/v5r3/index.jsp?topic=/com.ibm.aix.doc/doc/base/aixinformation.htm

(4) AIX 5.2 信息中心:
http://publib16.boulder.ibm.com/pseries/en_US/infocenter/base/aix52.htm

13.IBM Cluster Information Center链接

IBM Cluster Information Center


IBM POWER6家族便捷指南

December 2009

 | BladeCenter JS12 Express | BladeCenter JS22 Express | BladeCenter JS23 / JS43 Express | Power 520 Express | Power 550 Express | Power 560 Express | Power 570 | Power 595
Machine type-model | 7998-60X | 7998-61X | JS23: 7778-23X JS43 = JS23 + FC 8446 | 8203-E4A | 8204-E8A | 8234-EMA | 9117-MMA | 9119-FHA
System package | Blade Server/ BladeCenter | Blade Server/ BladeCenter | Blade Server BladeCenter | 4U, 19" rack or tower | 4U, 19" rack or tower | 4U / node, 19" rack | 4U / node, 19" rack | 42U, 24" CEC frame
# of cores (GHz & processor) | 2 (3.8 GHz POWER6TM) | 4 (4.0 GHz POWER6) | JS23: 4 (4.2 GHz POWER6+) JS43: 8 (4.2 GHz POWER6+) | 1, 2, 4 (4.2 GHz POWER6) 2, 4 (4.7 GHz POWER6+) | 2, 4, 6, 8 (3.5,/4.2 GHz POWER6) 2, 4, 6, 8 5.0 GHZ POWER6+) | 4, 8, 16 (3.6 GHz POWER6+) | 2 to 16 (3.5/4.4 GHz POWER6, 5.0 GHz POWER6+)1 4 to 32 (4.2 GHz POWER6+) | 8 to 64 (4.2 GHz POWER6) 16 to 64 (5.0 GHz POWER6)
Min2 - max. memory | 42 – 64 GB | 4 – 32 GB | JS23: 4–64GB JS43: 8-128GB | 2 2 – 64 GB (max 16 per core) | 4 2 – 256 GB (max 64 per proc card) | 8 – 384 GB (max 96 per proc card) | 2 – 768 GB (max 96 per proc card) | 16 – 4096 GB (max 512 per proc book)
Max CEC disk bays / TB storage | 2 / 0.29 | 1 / 0.14 | JS23: 1 / 0.14 JS43: 2 / 0.29 | 83 / 2.7 | 83 / 2.7 | 12 / 5.4 (6 / 2.7 per drawer) | 24 / 10.8 (6 / 2.7 per drawer) | 26 / 3.8 per PCIe I/O drawer
Max CEC PCI slots | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 23/43: 2/4 PCIe | 3 PCIe + 2 PCI-X DDR | 3 PCIe + 2 PCI-X DDR | 8 PCIe + 4 PCI-X DDR | 16 PCIe + 8 PCI-X DDR | 20 slots per 24" I/O drawer
Max I/O loops (RIO and/or 12X) | 0 | 0 | 0 | 1-core = 0 2-core = 1 4-core = 2 | 2-core = 1, 4->8-core= 2 | 4-core = 1, 8-core = 2, 16-core = 3 | 8 (1 per proc. card) | 32 (4 per proc. book)
Max 12X I/O drawers 4 | 0 | 0 | 0 | 8 or 4 | 8 or 4 | 12 or 6 | 32 or 16 | 30 or 32
Max RIO I/O drawers 4 | 0 | 0 | 0 | 12 | 12 | 18(AIX) 0(IBM i) | 48 | 12 (AIX) 96 (IBM i)
Max disk bays with I/O drawers5 | 2 +12 bays if BladeCenter S | 1 +12 bays if BladeCenter S | 1/2 +12 bays if BladeCenter S | 1-core = 8 2/4-core = 296 | 584 | 1332 | 1344 | 832 (AIX) 2200 (IBM i)
Max PCI slots w/ 12X PCI-X I/O drawers | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 1 | 2 PCIe + 50 PCI-X DDR | 1 PCIe + 50 PCI-X DDR | 7 PCIe + 76 PCI-X DDR | 12 PCIe + 200 PCI-X DDR | 180 PCI-X + 420 PCI-X DDR
Max PCI slots w/ 12X PCIe I/O drawers | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 42 PCIe + 2 PCI-X DDR | 41 PCIe + 2 PCI-X DDR | 67 PCIe + 4 PCI-X DDR | 172 PCIe + 8 PCI-X DDR | 640 PCIe
AIX rPerf (Ranges shown for 520 to 595) | 14.71 | 30.26 | JS23: 36.28 JS43: 68.20 | 4.2 GHz: 8.39 - 31.48 4.7 GHz: 20.13 - 39.73 | 3.5GHz: 15.85 - 58.80 4.2GHz: 18.38 - 68.2 5GHz: 21.1 - 78.6 | 3.6GHz: 31.3 - 100.3 | 3.5GHz: 15.85 - 105.75 5.0GHz: 21.16 - 141.21 4.2GHz(4-32): 35.5 - 193.25 | 4.2GHz: 75.58 - 479.89 5.0GHz: 164.67 - 553.01
IBM i CPW (Ranges shown for 520 to 595) | 7100 | 13800 | JS23: 14400 JS43: 24050 | 4.2 GHz: 4300 - 15600 4.7 GHz: 9500 - 18300 | 3.5GHz: 7750–27600 4.2GHz: 9200-32650 5GHz: 10600-37950 | 3.6GHz: 14100-48500 | 3.5GHz: 8150-57600 5.0GHz 11000-77600 4.2GHz (4-32): 16200-104800 | 4.2GHz: 35500-256200 5.0GHz 41000-294700
CoD options | N/A | N/A | N/A | N/A9 | N/A9 | N/A | CUoD, On/Off Utility, Trial | CUoD, On/Off, Utility, Trial
Max partitions AIX+IBM i + Linux | 20 | 40 | 40 (23) 80 (43) | 40 | 80 | 160 | 160 | 254
IBM i level & tier | 6.1 P05 | 6.1 P10 | 6.1 P10 | 5.4 6, 6.1 P05 / P10 | 5.4 6, 6.1 P20 | 6.1 P20 | 5.4, 6.1 P30 | 5.4, 6.1 P50
AIX level & group | 5.3, 6.1 C5 | 5.3, 6.1 C5 | 5.3, 6.1 C5 | 5.3, 6.1 D5 | 5.3, 6.1 E5 | 5.3, 6.1 E5 | 5.27, 5.3, 6.1 F5 | 5.3, 6.1 H5
Linux support | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.6 RHEL 5.2 SLES 10 SP2 SLES 11
PowerVMExpress | N/A | N/A | N/A | Optional | Optional | N/A | N/A | N/A
PowerVM Standard | Standard | Standard | Standard | Optional 8 | Optional 8 | Optional | Optional | Optional
PowerVM Enterprise | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional

A Power 575 column is not shown due to space constraints in this document.The Power 575 is a high performance cluster built on POWER6 technology and is designed for HPC and other compute intensive workloads.See the detailed Facts/Features document for Power 575 information.
Not all numbers apply to all operating systems.

1 Power 570 2 – 16 core 4.2 GHz and 4.7 GHz withdrawn from marketing 2009
2 JS12 BladeCenter, Power 520, Power 550 DIMM options changed 1H09 for newly shipped servers increasing minimum.Values shown are the new minimums.
3 Power 520 and 550 can have either eight disk SAS SFF disk slots or six 3.5-inch SAS disk slots
4 Assuming maximum number of I/O loops, second number indicates number of PCIe 12X I/O drawers
5 Ignoring SAN drives, using the maximum whether SAS or SCSI, ignoring IBM i disk controller implications
6 The Power 520 4.7 GHz and Power 550 5.0 GHz require IBM i 6.1 at a minimum
7 AIX 5.3 or higher needed for the 4.2, 4.4 and 5.0 GHz Power 570 processors announced October 2008
8 IBM i edition may require PowerVM Standard or higher as a minimum
9 Power 520 (9408-M25) and Power 550 (9409- M50) do provide CoD options

参考链接：ftp://public.dhe.ibm.com/common/ssi/sa/st/n/poy03001usen/POY03001USEN.PDF

注：本POWER6产品参数查阅指南适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。

Top


IBM POWER7家族便捷指南

April 2011

 | BladeCenter PS700 Express | BladeCenter PS701 Express | BladeCenter PS702 Express | BladeCenter PS703 Express | BladeCenter PS704 Express | Power 710 Express | Power 720 Express | Power 730 Express | Power 740 Express | Power 750 Express | Power 755 | Power 770 | Power 780
Machine type-model | 8406-70Y | 8406-71Y | 8406-71Y | 7891-73X | 7891-74X | 8231-E2B | 8202-E4B | 8231-E2B | 8205-E6B | 8233-E8B | 8236-E8C | 9117-MMB | 9179-MHB
System package | Blade Server / BladeCenter | Blade Server / BladeCenter | Blade Server / BladeCenter | Blade Server / BladeCenter | Blade Server / BladeCenter | 2U, 19" rack | 4U, 19" rack or tower | 2U, 19" rack | 4U, 19" rack or tower | 4U, 19" rack | 4U, 19" rack | 4U / node, 19" rack | 4U / node, 19" rack
# of cores (GHz & processor) | 3.0 GHz(4-core) 4 | 3.0 GHz(8-core) 8 | 3.0 GHz(8-core) 16 | 2.4 GHz (8-core) 16 | 2.4 GHz (8-core) 32 | 3.0 GHz(4-core) 4 3.7 GHz(6-core) 6 3.55 GHz(8-core) 8 | 3.0 GHz (4-core) 4 3.0 GHz (6-core) 6 3.0 GHz (8-core) 8 | 3.0 GHz(4-core) 8 3.7 GHz(4-core) 8 3.7 GHz(6-core) 12 3.55 GHz(8-core) 16 | 3.3 GHz(4-core) 4, 8 3.7 GHz(4-core) 4, 8 3.7 GHz(6-core) 6, 12 3.55 GHz(8-core) 8,16 | 3.0/3.2/3.3/3.55/3.6GHz(8-core): 8,16,24,32 3.7GHz(6-core): 6,12,18,24 | 3.3/3.6 GHz(8-core) 32 | 3.5 GHz(6-core) 4 - 48 | 3.86 GHz (8-core) 4 - 64 4.14 GHz (4-core)3 4 - 32
# of sockets | 1 | 1 | 2 | 2 | 4 | 1 | 1 | 2 | 1 or 2 | 1, 2, 3, 4 | 4 | 2, 4, 6, 8 | 2, 4, 6, 8
Min - max memory | 8 - 64 GB (1066) | 16 - 128 GB(1066) | 32 - 256 GB (1066) | 16 - 128 GB (1066) | 32 - 256 GB (1066) | 4 - 64 GB (1066) | 4 core 8 – 64 GB (1066) 6 or 8 core 8 – 128 GB (1066) | 8 - 128 GB (1066) | 8 - 256 GB (1066) | 8 – 512 GB(1066) (max 128 per proc card) | 128 – 256 GB(1066) (max 64 per proc card) | 32 GB – 2 TB(1066) (max 512 GB per node) | 32 GB – 2 TB(1066) (max 512 GB per node)
Max CEC disk bays / TB storage | 2 / 1.2 TB | 1 / 600 GB | 2 / 1.2 TB | 1 / 600 GB | 2 / 1.2 TB | 6 / 1.8 TB | 8 / 2.4 TB | 6 / 1.8 TB | 8 / 2.4 TB | 8 / 2.4 TB | 8 / 2.4 TB | 6 per node / 1.8 TB Max per sys 24 / 7.2 TB | 6 per node / 1.8 TB Max per sys 24 / 7.2 TB
Max CEC PCI slots | Expansion Cards 1 PCIe CIOv 1 PCIe CFFh | Expansion Cards 1 PCIe CIOv 1 PCIe CFFh | Expansion Cards 2 PCIe CIOv 2 PCIe CFFh | Expansion Cards 1 PCIe CIOv 1 PCIe CFFh | Expansion Cards 2 PCIe CIOv 2 PCIe CFFh | 4 PCIe LP | 4 PCIe + 4 PCIe LP (opt.) | 4 PCIe LP | 4 PCIe + 4 PCIe LP (opt.) | 3 PCIe and 2 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 6 PCIe per node 24 per system | 6 PCIe per node 24 per system
Max GX adapter slots | N/A | N/A | N/A | N/A | N/A | 1 GX++ | 1 GX++ 1 (6- or 8-core systems only) | 2 GX++ | 2 GX++ 1 | 1 socket 1 GX+ 2 or more sockets 1 GX++ and 1 GX+ | 1 GX++ | 2 GX++ per node Max per system = 8 | 2 GX++ per node Max per system = 8
Max 12X I/O PCIe drwrs | N/A | N/A | N/A | N/A | N/A | N/A | 22 | N/A | 4 | 4 | 0 | 16 | 16
Max 12X I/O PCI-X drwrs | N/A | N/A | N/A | N/A | N/A | N/A | 42 | N/A | 8 | 8 | 0 | 32 | 32
Max disk bays w/ I/O drawers | 2 + 12 bays if BladeCenter S | 1 + 12 bays if BladeCenter S | 2 + 12 bays if BladeCenter S | 1 + 12 bays if BladeCenter S | 2 + 12 bays if BladeCenter S | 102 | 380 | 102 | 416 | 586 | 164 | 1320 | 1320
Max PCI slots w/ 12X PCI-X I/O drawers | N/A | N/A | N/A | N/A | N/A | N/A | 4 PCIe and 24 PCI-X DDR | N/A | 4 PCIe and 48 PCI-X DDR | 1 PCIe and 50 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 24 PCIe and 192 PCI-X DDR | 24 PCIe and 192 PCI-X DDR
Max PCI slots w/ 12X PCIe I/O drawers | N/A | N/A | N/A | N/A | N/A | N/A | 24 PCIe | N/A | 44 PCIe | 41 PCIe and 2 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 184 PCIe | 184 PCIe
AIX rPerf Ranges | 45.13 | 81.24 | 154.36 | 251.45 | 154.36 | 45.13 – 91.96 | 45.13 – 81.24 | 86.66 – 176.57 | 48.33 – 176.57 | 81.24 – 331.06 | N/A | 140.75 – 579.39 | 115.86 – 685.09
IBM i CPW Ranges | 21,100 | 42,100 | 76,300 | 64,000 | 110,000 | 23,800 – 51,800 | 23,800 – 46,300 | 44,600 – 97,700 | 25,500 – 97,700 | 44,600 – 181,000 | N/A | 73,100 – 292,700 | 57,450 – 343,050
Capacity on Demand options | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | CUoD, On/Off, Utility, Trial | CUoD, On/Off, Utility, Trial
Max partitions (10/core) | 40 | 80 | 160 | 160 | 320 | 80 | 80 | 160 | 160 | 320 | 32 (DLPAR Only) | 480 | 640
IBM i level & tier | 6.1.1, 7.1 Small – P05 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small -P05 (4-core) P10 (6- or 8-core) | 6.1.1, 7.1 Small -P05 (4-core) P10 (6- or 8-core) | 6.1.1, 7.1 Small – P20 | 6.1.1, 7.1 Small – P20 | 6.1.1, 7.1 Small - P20 | N/A | 6.1.1, 7.1 Medium - P30 | 6.1.1, 7.1 Large - P50
AIX level & group | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Medium | 5.3, 6.1, 7.1 Large
Linux support | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 11 SP1 RHEL 6.0 | SLES 11 SP1 RHEL 6.0 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5
PowerVM Express | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | N/A | N/A
PowerVM Standard | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | Optional | Optional
PowerVM Enterprise | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | Optional | Optional
Systems Director (w/VMControl) | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional

1 The GX++ slot on the Power 720 Express server and the second GX++ slot on the Power 740 Express server are not available if the optional four PCIe low profile slots are used.
2 Not supported on 4-core Power 720 Express configurations.
3 Each Power 780 3.86 GHz processor card has two sockets, with each socket having eight POWER7 processor cores. If run in optional TurboCore mode at 4.14 GHz, only half the cores in each socket are available.

参考链接：http://public.dhe.ibm.com/common/ssi/ecm/en/poy03032usen/POY03032USEN.PDF

注：本POWER7产品参数查阅指南适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。

Top


Power家族服务器一览表

注：本Power家族服务器一览表适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。


Power服务器TPC-C估算器

TPC-C是比较不同硬件和软件配置的OLTP(On-line Transaction Processing)性能的一个指标。

IBM的P系列服务器，每个型号的产品都有几款机型会通过TPC组织的测试来公布TPC-C值。对于那些没有公布TPC-C的机型配置，可以通过这个TPC-C估算器来粗略估算其TPC-C值，以方便用户选择机型。

该估算器的估算方式是通过已发布TPC-C的机型配置的机器为基准，用IBM官方发布的该款机型配置的rPerf与基准机型的rPerf做对比得出的。

注：此TPC-C估算器是为方便用户了解IBM P系列服务器的TPC-C值所开发的小工具，并非官方发布的数据，所估算出的TPC-C值仅供参考。

下载工具


Power产品配置文件中英文翻译工具

通过Power产品配置文件翻译工具，可以将.CSV的英文配置文件翻译成中文的配置文件，方便查看配置信息。

首先打开翻译工具，选择“启用宏”，点击“选择文件”按钮，选择需要进行翻译的.CSV配置文件，然后点击“开始翻译”按钮，将产生一个中文的.xls配置文件，并可对其进行保存操作。

注：此翻译工具为方便用户了解配置文件所开发的Beta版非正式工具，中文的翻译仅供参考，如果您对此工具有任何意见和建议，请及时联系我们(techline@cn.ibm.com)。

下载配置文件中英文翻译工具


Power服务器销售手册快速查询通道

通过下面的列表，找到相关产品，点击"->" 可查到该产品的信息. 或者

输入产品类型号 MTM(Machine 产品号):

例如：Power 550, 可输入 "8204-E8A"

(注意:如果是首次进行查询，需要对所在国家和语言进行设置，确定搜索范围和返回文档的语言，如下所示：

Home Country and Site Language://选择所在国家和语言 | China(English)
Narrow searches to://选择搜索范围 | China
Return documents in English and://选择返回文档的语言 | English
Return a maximum of://选择返回文档的最大值 | 200

点击 continue, 进行重新查询.)

Blade Center

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 适合的应用 | 链接
BladeCenter PS700 | 8406-70Y | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2010/04/13 | - | - | ->
BladeCenter PS701 | 8406-71Y | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2010/04/13 | - | - | ->
BladeCenter PS702 | 8406-71Y | 宽度:59 mm 深度:445 mm 高度:245 mm 重量:8.7 kg | 700(watts) | 2010/04/13 | - | - | ->
BladeCenter PS703 | 7891-73X | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 399(watts) | 2011/04/12 | - | - | ->
BladeCenter PS704 | 7891-74X | 宽度:59 mm 深度:445 mm 高度:245 mm 重量:8.7 kg | 492(watts) | 2011/04/12 | - | - | ->
BladeCenter JS12 | 7998-60X | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 350(watts) | 2008/04/02 | - | 适用于小型数据库和应用程序服务器。 | ->
BladeCenter JS22 | 7998-61X | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 350(watts) | 2007/11/06 | 2011/01/07 | 用于业务绩效应用程序，例如较小的数据库、OLTP和商业智能； 用于 HPC 工作负载，例如天气预报、地震处理、分子力学和计算流体力学。 | ->
BladeCenter JS23 | 7778-23X | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2009/04/28 | 2011/04/29 | - | ->
BladeCenter JS43 | 7778-23X | 宽度:59 mm 深度:445 mm 高度:245 mm 重量:8.7 kg | 700(watts) | 2009/04/28 | 2011/04/29 | - | ->
BladeCenter JS21 | 7988-J21 | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 376(watts) | 2007/06/05 | 2009/01/02 | - | ->
BladeCenter H Chassis | 7989-BCH | 高度:400 mm 宽度:442 mm 深度:711 mm 重量:40.82 - 158.8 kg | 45(watts) | 2007/06/05 | - | - | ->
BladeCenter S Chassis | 7779-BCS | 宽度:444 mm 深度:733.4 mm 高度:306.3 mm 重量:40.82 - 108.86 kg | 45(watts) | 2008/04/02 | - | - | ->

Top

POWER7 Systems

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 适合的应用 | 链接
Power 710 | 8231-E2B | Rack-Mount: 宽度:440 mm 深度:706 mm 高度:89 mm(2U) 重量:28.3 kg | 650(watts) | 2010/08/17 | 紧凑2U封装内可靠而又安全的高性能、高能效基础架构和应用程序服务器。凭借 POWER7 工作负载优化技术，Power 710 服务器使用 AIX、IBM i 和 Linux 操作系统可以实现极其快速的事务处理； 这是一款易于购买、安装和管理的服务器，可以无缝地集成至您的现有基础架构，从而缩短部署和实现价值所需的时间。 | ->
Power 720 | 8202-E4B | Rack-Mount: 宽度:440 mm 深度:610 mm 高度:173 mm(4U) 重量:48.7 kg Deskside/Desktop: 宽度:328.5mm with tip plate/183 mm without tip plate 深度:688 mm 高度:541 mm 重量:53.7 kg without tip plate / 57.2 kg with tip plate | 750(watts) | 2010/08/17 | 用于 UNIX、IBM i 和 Linux 工作负载的可靠而又安全的分布式应用程序服务器或整合服务器； IBM i 提供了高度可扩展的防病毒架构，该架构带有稳定的数据库和中间件基础，可以实现高效的业务处理应用程序部署。 | ->
Power 730 | 8231-E2B | Rack-Mount: 宽度:440 mm 深度:706 mm 高度:89 mm(2U) 重量:29.5 kg | 1100(watts) | 2010/08/17 | 高性能、高密度、高能效的服务器，是在虚拟化环境中运行多个应用程序和基础架构工作负载的理想选择； 整合 UNIX 和 x86 Linux 工作负载。 | ->
Power 740 | 8205-E6B | Rack-Mount: 宽度:440 mm 深度:610 mm 高度:173 mm(4U) 重量:48.7 kg Deskside/Desktop: 宽度:328.5mm with tip plate/183 mm without tip plate 深度:688 mm 高度:541 mm 重量:53.7 kg without tip plate / 57.2 kg with tip plate | 1400(watts) | 2010/08/17 | 用于中小型数据库服务器； 用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器。 | ->
Power 750 | 8233-E8B | Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1950(watts) | 2010/02/09 | 用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器； 用于中到大型数据库服务器。 | ->
Power 755 | 8236-E8C | Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1950(watts) | 2010/02/09 | 针对运行高度并行的计算密集型工作负载和算法而优化，例如天气与气候建模、计算化学、物理和石油储量建模等。 | ->
Power 770 | 9117-MMB | 一个系统抽屉: 宽度: 483 mm 深度: 863 mm 高度: 174 mm(4U) 重量: 70.3 kg | 1600(watts)/blk | 2010/02/09 | 用于整合UNIX、IBM i 和x86 Linux工作负载； 适用于中到大型数据库服务器； 适用于中到大型事务处理应用程序，例如ERP 和 CRM； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->
Power 780 | 9179-MHB | 一个系统抽屉: 宽度: 483 mm 深度: 863 mm 高度: 174 mm(4U) 重量: 70.3 kg | 1600(watts)/blk | 2010/02/09 | 适用于大型跨UNIX、IBM i和Linux工作负载的服务器整合； 适用于大型数据库服务器； 适用于大型事务处理应用程序，例如ERP 和 CRM； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->

Top

POWER6 Systems

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 适合的应用 | 链接
Power 520 | 8203-E4A | Deskside/Desktop: 宽度:328.5mm with tip foot/182.3 mm without tip foot 深度:628 mm 高度:540 mm Rack-Mount: 宽度:440 mm 深度:538 mm 高度:173 mm(4U) 重量: Rack-mount:31.75 kg Deskside: 40.8 kg | 850(watts) | 2008/01/29 | 2011/05/27 | 用于分布式 UNIX、IBM i和 LinuxERP/CRM 应用程序服务器； 用于小型数据库服务器； 用于UNIX、IBM i 和Linux工作负载的小规模整合服务器； 用于带有集成数据库和应用程序服务器的完整业务系统。 | ->
Power 550 | 8204-E8A | Deskside/Desktop: 宽度:282.5 mm with tip foot/182.5 mm without tip foot 深度:778 mm 高度:540 mm 重量:57.2 kg with tip foot/53.7 kg without tip foot Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1500(watts) | 2008/01/29 | 2011/05/27 | 适用于UNIX、IBM i和 Linux ERP/CRM应用程序服务器； 用于中型数据库服务器； 用于整合UNIX、IBM i和x86 Linux 工作负载； 用于运行IBM i操作系统的中到大型企业。 | ->
Power 560 | 8234-EMA | 一个系统抽屉: 宽度: 483 mm 深度: 824 mm 高度: 174 mm(4U) 重量: 63.6 kg | 1200(watts)/blk | 2008/10/07 | 2011/01/07 | 用于整合UNIX、IBM i 和x86 Linux工作负载； 适用于中到大型数据库服务器； 用于UNIX、IBM i和Linux ERP/CRM 应用程序服务器。 | ->
Power 570 | 9117-MMA | 一个系统抽屉: 宽度: 483 mm 深度: 824 mm 高度: 174 mm(4U) 重量: 63.6 kg | 1400(watts)/blk | 2007/05/22 | 2011/01/07 | 适用于中到大型事务处理应用程序，例如ERP 和 CRM； 适用于中到大型数据库服务器； 适用于跨UNIX、IBM i和Linux工作负载的服务器整合； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->
Power 575 | 9125-F2A | 系统机架尺寸: 宽度:750 mm 深度:1524 mm 高度:2013 mm 重量:1656 kg 一个节点为2U高度 |  | 2008/04/08 | 2010/07/30 | 针对运行大型、高度并行的计算密集型工作负载和算法而优化； 针对天气和气候建模、计算化学、物理、计算机辅助工程、计算流体力学和石油探测的应用亲和性。 | ->
Power 595 | 9119-FHA | 宽度:775 mm 深度:1486-1806 mm 高度:2014 mm 重量:1531-1552 kg | 27500(watts)/CEC+3IO | 2008/04/08 | 2011/07/29 | 用于支持大规模事务处理和数据库应用程序的数据中心； 用于大规模服务器整合，可增加灵活性，降低运营和能耗成本； 用于要求其关键业务型应用程序具有最高级别的RAS的企业。 | ->

Top

p5 Server

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
P5 505 505Q | 9115-505 | 1U | 400(watts) | 2005/10/04 | 2009/05/29 | ->
P5 510 510Q | 9110-51A | 2U | 625(watts) | 2006/02/14 | 2010/07/30 | ->
P5 520, 520Q | 9131-52A | 4U | 600(watts) | 2005/10/04 | 2008/12/12 | ->
P5 550, 550Q | 9133-55A | 4U | 1100(watts) | 2005/10/04 | 2008/12/12 | ->
p5-560Q | 9116-561 | 4U | 1300(watts)/blk | 2006/02/14 | 2009/01/02 | ->
P5-570 | 9117-570 | 4U | 1300(watts)/blk | 2004/07/13 | 2008/08/29 | ->
P5-575 | 9118-575 | 2U 24" | 41,600(watts) | 2005/02/08 | 2008/08/29 | ->
P5-590 | 9119-590 | 24" frame | 16,700(watts) | 2004/10/15 | 2008/08/29 | ->
P5-595 | 9119-595 | 24"frame | 22,710(watts) | 2004/10/14 | 2009/05/29 | ->

Top

pSeries Server

产品线 |  | 产品号 | 发布时间 | 停产时间 | 链接
p610-6C1 |  | 7028-6C1 | 2001/10/04 | 2004/03/09 | ->
p610-6E1 |  | 7028-6E1 | 2001/10/04 | 2004/03/09 | ->
p615-6C3 |  | 7029-6C3 | 2003/05/27 | 2005/12/13 | ->
p615-6E3 |  | 7029-6E3 | 2003/05/27 | 2005/12/13 | ->
p620-6F1 | F85 | 7025-6F1 | 2001/04/17 | 2003/09/12 | ->
p630-6C4 |  | 7028-6C4 | 2002/06/25 | 2005/12/13 | ->
p630-6E4 |  | 7028-6E4 | 2002/06/25 | 2005/12/13 | ->
p640 | B80 | 7026-B80 | 2000/10/03 | 2003/12/12 | ->
p650 |  | 7038-6M2 | 2002/11/12 | 2005/06/21 | ->
p655 |  | 7039-651 | 2002/11/12 | 2005/10/07 | ->
p660-6H1 | H85 | 7026-6H1 | 2001/04/17 | 2003/09/12 | ->
p660-6M1 | M85 | 7026-6M1 | 2001/09/04 | 2003/09/12 | ->
p670 |  | 7040-671 7040-61D 7040-61R | 2002/04/09 | 2005/11/18 |
p680 | S85 | 7017-S85 | 2000/10/03 | 2003/03/28 | ->
p690 | S90 | 7040-681 7040-61D 7040-61R | 2001/10/04 | 2005/11/18 |

Top

RS/6000 Server

产品线 | 产品号 | 发布时间 | 停产时间 | 链接
B50 | 7046-B50 | 1999/09/13 | 2003/09/12 | ->
150 | 7043-150 | 1998/10/05 | 2003/12/12 | ->
260 | 7043-260 | 1998/10/05 | 2000/12/01 | ->
170 | 7044-170 | 2000/02/07 | 2003/12/12 | ->
270 | 7044-270 | 2000/02/07 | 2003/09/12 | ->
F50 | 7025-F50 | 1997/04/15 | 2001/07/17 | ->
H50 | 7026-H50 | 1998/02/09 | 2000/12/01 | ->
H70 | 7026-H70 | 1999/04/06 | 2001/07/17 | ->
F80 | 7025-F80 | 2000/05/09 | 2001/07/13 | ->
H80 | 7026-H80 | 2000/05/09 | 2001/07/13 | ->
M80 | 7026-M80 | 2000/05/09 | 2002/01/31 | ->
S70 | 7017-S70 | 1997/10/06 | 1999/12/13 | ->
S7A | 7017-S7A | 1998/10/05 | 2000/12/01 | ->
S80 | 7017-S80 | 1999/09/13 | 2001/08/31 | ->

Top

Rack

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
RS/6000 Rack | 7014-T00 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1147 mm with front and rear doors; 1042 mm with rear door only. 高度: 1804 mm with standard AC power; (36U) 1926 mm with -48 volt DC power. 空机柜重量: 244 kg | 2000/05/09 | ->
RS/6000 Rack | 7014-T42 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1147 mm with front and rear doors; 1042 mm with rear door only . 高度: 2015 mm with standard AC power (42U) 空机柜重量: 261 kg |  | ->
Rack | 7014-B42 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1042 mm with rear door only; 1409 mm with acoustic doors. 高度: 2015 mm with standard AC power(42U) 空机柜重量: 261 kg | 2007/06/05 | ->

Top

I/O Draws

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
Rack-Mounted High-Density Expansion Drawer | 7311-D20 | 宽度:482 mm 深度:610 mm 高度:178 mm(4U) 重量:45.9 kg | 340(watts) | 2002/11/12 | 2010/08/27 | ->
PCI-X I/O Drawer | 7314-G30 | 宽度:224 mm 深度:800 mm 高度:172 mm(4U) 重量:20 kg | 250(watts) | 2007/05/22 | 2009/08/28 | ->

Top

HMC

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
Hardware Management Console | 7042-CR4 | 宽度:440 mm 深度:711.4 mm 高度:43 mm 重量:15.6 kg | 500(watts) | 2007/06/08 | 2009/12/31 | ->
Hardware Management Console | 7042-CR5 | 宽度:440 mm 深度:711 mm 高度:43 mm 重量:15.6 kg | 780(watts) | 2009/10/20 | 2011/01/07 | ->
Hardware Management Console | 7042-CR6 | 宽度:440 mm 深度:711 mm 高度:43 mm 重量:15.9 kg | 194-675(watts) | 2010/08/17 | - | ->
Deskside Hardware Management Console | 7042-C07 | 宽度:216 mm 深度:540 mm 高度:438 mm 重量:16.3 kg | 550(watts) | 2008/04/08 | 2010/09/17 | ->
Deskside Hardware Management Console | 7042-C08 | 宽度:216 mm 深度:540 mm 高度:438 mm 重量:18 kg | 550(watts) | 2010/04/13 | - | ->

Top

Consoles

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
Rack-Mounted Flat Panel Console Kit | 7316-TF3 | 宽度:485 mm 深度:635 mm to 730mm 高度:43.0 mm(1U) 高度(opened):410 mm 重量:12.8 kg Switch fc#4283 高度:1U | 2004/04/27 | ->

Top

Storage Device Enclosure

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
Tape/Optical Storage Device Enclosure | 7214-1U2 | 宽度:446 mm 深度:736 mm 高度:44 mm(1U) 重量:11 kg | 2007/11/30 | ->
Tape/Optical Storage Device Enclosure | 7216-1U2 | 宽度:480 mm 深度:454 mm 高度:43 mm(1U) 重量:5.1-7.1kg | 2010/08/17 | ->

Top


What's New Storage

What's New

1.更新了存储产品配置文件中英文翻译工具：

本期更新了存储产品配置文件中英文翻译工具，在该工具中，新增了DS8800，SVC CG8的中英文翻译。

存储产品配置文件中英文翻译工具

2.更新了存储产品竞争工具链接

本期在存储产品速查手册的附录中，更新了最新版本的存储产品竞争工具链接。

Storage产品速查手册附录

3.更新了存储销售手册快速查询通道

本期更新了存储销售手册快速查询通道，在该工具中， 更新了TS2900、SSPC、SVC、V7000、SAN384B等的销售手册信息。

Storage销售手册快速查询通道

4.更新了存储家族产品一览表

本期更新了存储家族产品一览表，展现了目前在产的产品。

存储家族产品一览表

5.新增的网络课堂：(新增)

(1) Storwize V7000 Implementation

(2) Storage Cloud and SONAS

(3) 2011 IBM System Storage Configuration Guide and FAQ

6.增加了25个新的热点问题： (新增)

(1) DS5020 接口类型、数量及相关问题

(2) IBM TPC for Disk Midrange Edition 产品介绍

(3) XIV 数据迁移的步骤

(4) SVC SAN及Zone规划

(5) SVC 基本术语

(6) V7000与HBA卡，操作系统以及后端磁盘阵列等的兼容性

(7) V7000 存储虚拟化价值表现

(8) V7000 虚拟化以及数据迁移方式

(9) V7000 自动分层存储（EasyTier）应用方式

(10) V7000 高级复制功能介绍

(11) V7000是否可以通过iSCSI端口进行远程镜像

(12) LTO5代驱动器，半高和全高的比较

(13) LTO5 驱动器新功能Linear Tape File System(LTFS)介绍

(14) N6210与N6240型号区别

(15) 2498-E32产品简介

(16) DS5020 e-config中Adapters选项配置

(17) DS5020 e-config中Features选项配置

(18) DS8000中Flash Copy (PTC）和Flash Copy SE配置是否有冲突

(19) XIV 电源与电源线的配置注意事项

(20) V7000 License说明以及订购方法

(21) V7000 软件在e-config中的配置方法

(22) TS3100 TS3200 TS3310 TS3500 e-config中feature选项的配置注意事项

(23) TS7650 TS7650G e-config中console选项的配置注意事项

(24) TS7650G 软件的配置

(25) 2498-R06端口配置

7.更新的FAQ：(最近更新)

(1) DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？

(2) DS4700,DS4800,DS5000,EXP 默认带多少个SFP?

(3) DS4000/DS5000电池保护原理与时间

(4) DS5020主机接口数量、类型及组合方式

(5) DS5020 firmware 7.70 密码设置规则

(6) DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法

(7) DS5020的常用软件和文档下载网址

(8) DS5000支持的扩展柜介绍

(9) DS8000中磁盘相关基本概念

(10) DS8700 微码实现的功能介绍

(11) IBM DS8800 存储产品介绍

(12) XIV磁盘存储的硬件特征

(13) IBM SVC解决方案有哪些特点和优势

(14) SVC 5.1和6.1软件新增功能

(15) SVC新一代引擎2145-CF8简介

(16) IBM Storwize V7000产品介绍

(17) IBM磁带库备份容量评估

(18) TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型?

(19) IBM 3580和3592磁带机的介绍

(20) TS7610，TS7650与TS7650G的区别

(21) N series 产品的基本技术概念

(22) N series产品的尺寸、重量与功率

(23) N series支持的最大硬盘、扩展柜的数量

(24) N series CPU、缓存信息

(25) N3000系列的接口类型、功能与数量

(26) 2231-IA3 IBM Information Archive Model IA3简介

(27) DS5000硬盘配置注意事项

(28) DS5000 SFP与线缆配置方法

(29) DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？

(30) DS8700硬盘选择及配置

(31) Storwize V7000 硬件的SFP配置

(32) e-config中磁带的配置介绍

(33) 3584-L53配置注意事项

(34) 2498-R06 配置注意事项

(35) 768B econfig配置注意事项

(36) 384B econfig配置注意事项

(37) 存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置

8.删除的FAQ：

(1) 什么是Storage Partition？以及如何计算耗费的Storage Partition数量？

(2) IBM System Storage DS5100/DS5300规格一览表

(3) DS5000常用文档下载

(4) DS4000/DS5000 SN Number、PN Number、配件或整机保修信息查询

(5) DS5020与DS4700的参数对比

(6) DS5020缓存是否可以升级

(7) DS8800 体系架构说明

(8) IBM XIV Storage System Software V10.2新功能

(9) 利用SVC Flashcopy功能实现数据拷贝的速度

(10) SVC的Easy Tier功能介绍

(11) Storwize V7000 缺省支持那些高级功能

(12) DS5000/DS8000的功率和尺寸查询

(13) LTO 磁带是否要配标签，标签的格式是什么样的？

(14) 带库驱动器接口的数量与线缆的选择

(15) 磁带机与磁带库的区别

(16) 带库中I/O槽位的作用

(17) TS1120与TS1130的区别

(18) TS2900/TS3100/TS3200/TS3310/TS3500的功率和尺寸查询

(19) TS3100/TS3200/TS3310光纤驱动器与主机HBA卡连接过程中需要注意什么？

(20) 3580系列磁带机接口类型描述

(21) N系列网关与N系列文件存储的区别

(22) N series产品NAS和SAN功能的区别与配置方法

(23) N series产品兼容性的查询方法

(24) N3400的接口类型、功能与数量

(25) N3600的接口类型、功能与数量

(26) 3758-B32 FCoE与CEE协议应用介绍

(27) IBM System Storage DR550 产品简介

(28) DR550配置中，可以选择的Key Application包含哪些

(29) DS5100/DS5300磁盘配置注意事项

(30) DS5000 e-config配置中TPC软件的选择

(31) EXP5060中SFP模块及线缆的配置及注意事项

(32) EXP5060中磁盘的配置及注意事项

(33) DS5000 Expansion Unit中SFP模块及线缆的配置及注意事项

(34) DS5000 Expansion Unit中磁盘的配置及注意事项

(35) DS8700 function Auth 中各license的配置

(36) DS8700软件的选择

(37) DS8700的磁盘配置注意事项

(38) DS8700 OEL value unit计算及配置方法

(39) DS8800 e-Config中HA/Cables的配置

(40) SVC(2145-8A4) 硬件的Features和Cables配置

(41) IBM Storwize V7000 线缆及模块的配置

(42) TS3100/TS3200/TS3310/TS3500要实现LTO加密功能所需的配置

(43) TS7650G 硬件中Storage Link和Attach的配置

(44) N Series Port/Loop indicator在e-config中的配置方法

(45) 2005-R04 SFP与线缆的选择与配置

(46) 2005-R04 许可（License）的选择与说明

(47) 2498-R06 许可（License）的选择与说明

(48) 768B 许可(License)的选择与说明

(49) 384B 许可(License)的选择与说明

(注：本手册删除的FAQ，仍可通过如下链接查询：http://www-900.ibm.com/cn/support/viewdoc/knowledgebase)


IBM Storage 常见问题汇总

目录

IBM Storage 常见问题汇总

Disk Storage

DS4000

DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？ (最近更新)

DS4700,DS4800,DS5000,EXP 默认带多少个SFP? (最近更新)

DS5000

DS5100/DS5300扩展柜的连接方式，及模块使用的计算

DS4000/DS5000电池保护原理与时间(最近更新)

DS5020主机接口数量、类型及组合方式 (最近更新)

DS5020 firmware 7.70 密码设置规则(最近更新)

DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法(最近更新)

DS5020的常用软件和文档下载网址(最近更新)

DS5000支持的扩展柜介绍(最近更新)

DS5020 接口类型、数量及相关问题(新增)

IBM TPC for Disk Midrange Edition 产品介绍(新增)

DS8000

DS8000 Copy Service特性

DS8000中磁盘相关基本概念 (最近更新)

DS8700新产品特性阐述

DS8700 微码实现的功能介绍(最近更新)

IBM DS8800 存储产品介绍(最近更新)

DS8700与DS8800 物理指标与电气特性

XIV

XIV磁盘存储的功率、尺寸与工作环境

XIV磁盘存储的技术特征与产品优势

XIV磁盘存储的硬件特征 (最近更新)

XIV 数据迁移的步骤(新增)

SVC

IBM SVC解决方案有哪些特点和优势 (最近更新)

SVC 5.1和6.1软件新增功能 (最近更新)

SVC新一代引擎2145-CF8简介(最近更新)

SVC SAN及Zone规划(新增)

SVC 基本术语(新增)

Storwize V7000

IBM Storwize V7000产品介绍(最近更新)

Storwize V7000 物理组成

V7000与HBA卡，操作系统以及后端磁盘阵列等的兼容性(新增)

V7000 存储虚拟化价值表现(新增)

V7000 虚拟化以及数据迁移方式(新增)

V7000 自动分层存储（EasyTier）应用方式(新增)

V7000 高级复制功能介绍(新增)

V7000是否可以通过iSCSI端口进行远程镜像(新增)

Tape Library

IBM磁带机/磁带库与备份服务器的连接方式

IBM磁带库备份容量评估(最近更新)

IBM磁带机/磁带库与HBA卡，操作系统等兼容性

TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型? (最近更新)

LTO X 产品的单盘磁带容量, LTO 3/4/5传输速率, 及其读写兼容性

IBM 3580和3592磁带机的介绍(最近更新)

带库中 Path Failover的功能介绍, 是必选的吗

TS7610产品介绍

IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

TS7610，TS7650与TS7650G的区别 (最近更新)

LTO5代驱动器，半高和全高的比较 (新增)

LTO5 驱动器新功能Linear Tape File System(LTFS)介绍 (新增)

N series

N series 产品的基本技术概念 (最近更新)

SONAS产品简介

N series常用软件功能的介绍

N series产品的尺寸、重量与功率 (最近更新)

N series支持的最大硬盘、扩展柜的数量 (最近更新)

N3400与N3300,N3600参数对比

N series CPU、缓存信息 (最近更新)

N3000系列的接口类型、功能与数量 (最近更新)

N6040/N6060/N6070三种型号的区别

N6210与N6240型号区别 (新增)

SAN/Ethernet Switch

B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

B-Type SAN交换机NPIV功能介绍

B24/B40/B80配置中所有License包含的功能

B24、B40、B80三款SAN交换机SFP模块与光纤线的选择

IBM Converged Switch L32 (3758)交换机介绍

2498-E32产品简介 (新增)

IBM DCN 交换机性能参数

Data Retention Solution

2231-IA3 IBM Information Archive Model IA3简介(最近更新)


Disk Storage

DS4000

DS5000

DS8000

XIV

SVC

Storwize V7000


DS4000

DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？ (最近更新)

DS4700,DS4800,DS5000,EXP 默认带多少个SFP (最近更新)


DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？

解答:

1. 请查看兼容性网站 System Storage Interoperation Center (SSIC)

登陆SSIC网址：http://www-03.ibm.com/systems/support/storage/config/ssic/displayesssearchwithoutjs.wss?start_over=yes

第一步：“Product Family”中选择“IBM System Storage Midrange Disk”；

第二步：“Product Model”中选择DS4000的具体型号，如：DS4700；

第三步：“Product Version”中选择产品的微码信息；

第四步：“Host Platform”选择设备连接的服务器平台类型；

第五步：“Operating System”选择操作系统平台；

第六步：“Connection Protocol”选择连接协议（连接方式）；

第七步：“Server Model”选择服务器的型号；

第八步：“Adapter Vendor(HBA,CNA,etc)”选择主机上HBA（FC、SAS、SCSI适配卡）或CNA适配卡的提供商；

第九步：“Adapter Model(HBA,CNA,etc)”选择主机上HBA（FC、SAS、SCSI适配卡）或CNA适配卡的型号；

第十步：“SAN or Networking Vendor”选择SAN交换机或以太网交换机的提供商；

第十一步：“SAN or Networking Model”选择SAN交换机以太网交换机的型号；

第十二步：“Clustering”选择支持的集群软件；

第十三步：“Multipathing”选择支持的多路径软件。

以上13步并非全部都要选择，我们可以根据实际情况，按需选择，得到符合条件的兼容性信息。

2. 请查看DS4000兼容性列表文档：

参考资料：
《IBM System Storage DS4000 Interoperability Matrix》
下载地址：http://www-03.ibm.com/systems/storage/disk/ds4000/pdf/interop-matrix.pdf

参考资料：
《IBM System Storage DS5000 Interoperability Matrix》
下载地址：http://www-03.ibm.com/systems/resources/systems_storage_disk_ds5000_interop-matrix.pdf

Top


DS4700,DS4800,DS5000,EXP 默认带多少个SFP

解答:

DS4700/DS4800/EXP810/EXP420默认均带有一半的SFP，详情如下：

 | DS4200 | DS4700 | DS4800 | EXP810 | EXP420
默认SFP数量 | 4个 | 70A：4个 72A：6个 | 8个 | 2个 | 2个
最大SFP数量 | 8个 | 70A：8个 72A：12个 | 16个 | 4个 | 4个

另外，fc#2410选件包括一对，即两个SFP模块。

DS5020/DS5100/DS5300 机头主机接口都标配了SFP模块，他们的扩展柜默认均带有一半的SFP，具体参考以下信息：

DS5020机头标配带有所有端口的SFP模块，即前端主机端口默认4个，后端扩展柜端口4个，额外配置的主机端口卡（Host Port Card）默认带有SFP模块。
EXP520 默认SFP数量为2个，最大SFP数量4个。

DS5100/DS5300主机端口卡（Host Port Card）默认包含所有主机端口的SFP模块，扩展柜端口（Drive Port）需要选配SFP模块，只能选择4对或8对，即8个或16个。
EXP5000 默认SFP数量为2个，最大SFP数量4个；
EXP5060 默认SFP数量为4个，最大SFP数量8个。


DS5000

DS5100/DS5300扩展柜的连接方式，及模块使用的计算

DS4000/DS5000电池保护原理与时间 (最近更新)

DS5020主机接口数量、类型及组合方式 (最近更新)

DS5020 firmware 7.70 密码设置规则 (最近更新)

DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法(最近更新)

DS5020的常用软件和文档下载网址(最近更新)

DS5000支持的扩展柜介绍(最近更新)

DS5020 接口类型、数量及相关问题(新增)

IBM TPC for Disk Midrange Edition 产品介绍(新增)


DS5100/DS5300扩展柜的连接方式，及模块使用的计算

解答：

DS5100 DS5300连接扩展柜时：

1、在无EXP5060中继连接的情况下，小于等于8个扩展柜时，每个扩展柜一个单独的环路对(Loop-pair)；当大于8个扩展柜时，再在环路里添加第二个扩展柜。在DS5100 DS5300机头的SFP模块配置中，小于等于4个扩展柜时选4个fc#2412，大于4个扩展柜时选8个fc#2412.在DS5100 DS5300扩展柜的SFP模块配置中，8个以内的扩展柜都不需要额外添加SFP模块（标配带一对SFP模块），8个以上的扩展柜，每个扩展柜添加一对模块。

2、在有EXP5060中继连接的情况下，一个EXP5060占用2个扩展环路，即把一个中继连接的EXP5060当成两个普通扩展柜时的连接，计算模块和线缆。

1-4台扩展柜连接示意图（DS5100/DS5300需要4个fc#2412，扩展柜不需要额外配置SFP模块）

5-8台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，扩展柜不需要额外配置SFP模块）

9-16台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，8台扩展柜不需要额外配置SFP模块，剩下每个扩展柜需要额外配置1个fc#2412）

17-28台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，8台扩展柜不需要额外配置SFP模块，剩下每个扩展柜需要额外配置1个fc#2412）

EXP5060中继连接时，一个环路占用普通两个环路的端口数量：

Top


DS4000/DS5000电池保护原理与时间

解答:

DS4000系列存储Cache电池保护时间标称为72小时。由于DS4000的Cache是一种易失性存储介质，需要持续供电才能存储数据，一旦失去供电Cache中的数据将丢失。如果DS4000打开Cache功能（尤其是write Cache），应用端数据写到Cache中就会返回写成功，但此时数据并没有写到磁盘中（一般需要一定条件触发从Cache写到磁盘，如：10秒以后或Cache容量达到80%等，该过程称作flush），若意外掉电，电池就会保护Cache中的数据，该电池为充电电池，可以保护72小时。

出于数据安全性的考虑，一旦电池失效，DS4000会自动禁用Cache功能，可能导致性能下降，需要尽快维修或更换电池解决。

DS5000系列存储Cache电池保护机制与DS4000不再相同，DS5000的控制器中增加了一个USB闪存，当意外掉电时，DS5000将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。

参考资料：
书名:《IBM System Storage DS4000 and Storage Manager V10.30》
参考链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg247010.pdf

书名:《IBM Midrange System Storage Hardware Guide》
参考链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg247676.pdf

突出价值点：DS5000拥有和Cache同样大小的USB闪存，当意外掉电时，所有数据均可以通过电池保护复制到非易失性闪存中，进行永久保存。这样的设计保证了DS5000产品处理数据的零丢失，保证用户数据安全，提高用户整体系统在意外事故中数据的安全可靠与零风险。


DS5020 主机接口数量、类型及组合方式

解答：

DS5020有两种类型的主机端口：

1)8Gbps FC主机接口用于连接主机HBA卡或者光纤交换机，实现FC SAN功能；
2)1Gbps iSCSI主机接口用于连接以太网卡、iSCSI卡或者以太网交换机，实现IP SAN功能。

DS5020最少配置4个FC主机端口(每个控制器2个FC主机端口)，也可以再增加4个FC主机端口或者4个iSCSI主机端口。

在e-config中可以配置出三种数量和类型主机接口的DS5020：

1) 既不选择fc#2080，也不选择fc#2081，则DS5020共有4个8Gbps FC主机端口(每个控制器2个FC主机端口)；
2) 选择fc#2080，则DS5020共有8个8Gbps FC主机端口(每个控制器4个FC主机端口)；
3) 选择fc#2081，则DS5020共有4个8Gbps FC主机端口和4个1Gbps iSCSI主机端口(每个控制器2个FC主机端口，2个iSCSI主机端口)。

其中FC主机端口均随机自带SFP模块，此外，到目前为止，以上三种配置的DS5020不能更改或升级主机端口的配置。

突出价值点：支持最新的8Gbps的FC SAN传输速率，能够向下兼容4Gbps，2Gbps方式，具有竞争力的性能以及投资保护特性；支持多种主机端口，满足不同级别客户的不同需求，其中iSCSI接口，能够使客户使用更具性价比的传输方式，完成非关键业务的工作。


DS5020 firmware 7.70 密码设置规则

解答:

如果DS5020 firmware 为7.70， 当首次用Storage Manager添加作管理时，要求必须设置密码，密码的设置规则是：8到30个字符，且必须包含至少一个数字，一个小写字母，一个大写字母，和一个不规则字符（如：<> ! @ + # 等），且不允许有空格。另外，该密码是大小写敏感的。

下图是DS5000 Storage Manager 10.70的设置密码窗口截图:

如果密码窗口中只要求输入一个密码，那么说明之前密码已经被配置了。由于DS5020出厂时没有设置初始密码，如果不知道密码，请联系初次配置DS5020的相关人员。


DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法

解答:

当DS5020的host port是8 Gbps 的host端口，当和IBM 2498-B24/B40/B80的8 Gbps 端口连接时，且2498-B24/B40/B80的微码版本是6.2.0e 或以上时，将会出现无法连通的情况。

解决方法：

对于6.2.x版本，使用下列命令来把2498-B24/B40/B80上和DS520连接的端口设置成IDLE 模式，在2498-B24/B40/B80的命令行窗口下输入下列命令：
#portcfgfillword x 0 (其中x 是交换机的端口号)
 当把2498-B24/B40/B80上和DS520连接的端口设置成IDLE 模式后，DS5020将会自动和2498-B24/B40/B80建立起 8 Gbps 的连接。

对于6.3.x或以上版本，使用下列命令来把2498-B24/B40/B80上和DS520连接的端口设置成自适应模式，在2498-B24/B40/B80的命令行窗口下输入下列命令：
#portcfgfillword x 3 (其中x 是交换机的端口号)
 当把2498-B24/B40/B80上和DS520连接的端口设置成自适应模式后，DS5020将会自动和2498-B24/B40/B80建立起 8 Gbps 的连接。

参考文档
H196488: DS3500/DS3950/DS5000 systems not working with Brocade on 8 Gbps host ports
链接：http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5083089


DS5020的常用软件和文档下载网址

解答:

DS5000 常用软件下载网址:

DS5000 Storage Manger V10.70 32bit (x86) 和 64bit(x64) for Windows2003 和 Windows2008：
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=All&platform=All&function=fixId&fixids=Disk-SM-Windows_x86-Dec-2010-version-10.70.x5.25,Disk-SM-Windows_x64-Dec-2010-version-10.70.x5.25&includeRequisites=1&downloadMethod=http&source=fc

IBM DS Controller firmware version 7.70.38.00 :
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=DS_fw_v7.70.38.00&platform=All&function=fixId&fixids=Disk-CntlFW-Dec-2010-version-7.70.38.00&includeRequisites=1&downloadMethod=http&source=fc

IBM DS ESM/HDD firmare package version 1.72:
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=DS_HDDESM_v1.72&platform=All&function=fixId&fixids=Disk-HDDESM-Jan-2011-version-1.72&includeRequisites=1&downloadMethod=http&source=fc

上述3个链接需要输入IBM网站的id和password, 如果没有id可以先注册，再登陆下载。

Linux RDAC Driver Package for IBM DS4000/DS5000 Storage Subsystems:
http://www.lsi.com/rdac/ds4000.html

DS5020文档
 Installation, User's, and Maintenance Guide - IBM System Storage DS5020 Storage Subsystem
ftp://ftp.software.ibm.com/systems/support/system_x_pdf/81y1085_simplified_chinese.pdf

Installation, User's and Maintenance Guide - IBM System Storage DS5020 EXP520 Storage Expansion Enclosure
ftp://ftp.software.ibm.com/systems/support/system_x_pdf/81y1089_simplified_chinese.pdf

Command Line Interface and Script Commands Programming Guide - IBM System Storage DS3000, DS4000, and DS5000
https://www-947.ibm.com/support/entry/myportal/docdisplay?lndocid=MIGR-5076792

DS5000 Redbooks 下载网址:
IBM Midrange System Storage Hardware Guide:
http://publib-b.boulder.ibm.com/abstracts/sg247676.html?Open

IBM Midrange System Storage Implementation and Best Practices Guide:
http://www.redbooks.ibm.com/Redbooks.nsf/RedbookAbstracts/sg246363.html?OpenDocument

IBM Midrange System Storage Copy Services Guide:
http://www.redbooks.ibm.com/abstracts/sg247822.html?Open


DS5000支持的扩展柜介绍

解答:

1.EXP5060（1818-G1A）
EXP5060是DS5100/DS5300专用的高密度扩展柜，能在一个4U高的柜子里放60块SATA硬盘。EXP5060中包含6个硬盘抽屉，每个抽屉10块硬盘。有效节约客户的空间成本，并且在DS5100/DS5300没有EXP5000扩展柜的前提下，能扩展到480块硬盘。

EXP5060于2010年3月开始支持2TB的SATA硬盘，因此，DS5100/DS5300连接EXP5060后，支持的最大容量由原来的480TB增加至960TB。

EXP5060可以与EXP5000的扩展柜共同接入DS5100或DS5300中，但是两者必须要接入不同的环路内，而不能在同一环路内进行混接，若是DS5100或DS5300后端既有EXP5060又有EXP5000，那DS5100或者DS5300最大支持的硬盘数量为448块。

2.EXP5000（1818-D1A）
EXP5000是DS5100/DS5300的专用扩展柜，16个硬盘槽位。支持SATA硬盘，FC硬盘，加密硬盘和SSD硬盘。

3.EXP520(1814-52A)
EXP520是DS5020的专用扩展柜，16个硬盘槽位。支持SATA硬盘，FC硬盘，加密硬盘。

4.EXP810(1814-81A)
DS5000系列整体可以用EXP810的扩展柜，以作投资保护。DS5020加EXP810的扩展柜，需要加fc#7414的许可。DS5100/DS5300需要加EXP810则需要走产品部RPQ特殊流程。

突出价值点：EXP5060提供了高可用的SATA盘，这种扩展柜采用了热插拔和冗余双环路的技术，为存储系统提供了连续，可靠的服务。高密度的扩展柜节约了空间成本，从而有效降低了客户的总体拥有成本（TCO）。


DS5020 接口类型、数量及相关问题

解答:

1. 主机通道端口（Host Channel Port）:

DS5020有两种类型的主机端口，8Gbps FC主机接口用于连接主机HBA卡或者光纤交换机，实现FC SAN功能；1Gbps iSCSI主机接口用于连接以太网卡、iSCSI卡或者以太网交换机，实现IP SAN功能。DS5020最少配置4个FC主机端口（每个控制器2个FC主机端口），也可以再增加4个FC主机端口或者4个iSCSI主机端口。在e-config中可以配置出三种数量和类型主机接口的DS5020：

1) 既不选择fc#2080，也不选择fc#2081，则DS5020共有4个8Gbps FC主机端口（每个控制器2个FC主机端口）；
2) 选择fc#2080，则DS5020共有8个8Gbps FC主机端口（每个控制器4个FC主机端口）；
3) 选择fc#2081，则DS5020共有4个8Gbps FC主机端口和4个1Gbps iSCSI主机端口（每个控制器2个FC主机端口，2个iSCSI主机端口）；其中FC主机端口均随机自带SFP模块，此外到目前为止，以上三种配置的DS5020不能更改或升级主机端口的配置。

2. 扩展磁盘通道端口（Drive Channel Port）

DS5020一共有4个扩展磁盘通道端口，每个控制器2个，并且随机自带SFP模块。该端口用于连接后端的扩展柜，如：EXP520或EXP810。每两个端口（每个控制器一个）形成一组冗余扩展磁盘通道对（Redundant drive channel pair），每个通道组最多可以连接3台扩展柜。由端口数可知，DS5020可以形成2组通道对，最多连接6台扩展柜。

3. 其他端口

1) 以太网管理端口（RJ45）：DS5020一共有4个以太网管理端口，每个控制器2个。一般配合DS Storage Manager软件实现带外（out-of-band）配置与管理DS5020。
2）串行管理口（PS/2）：DS5020一共有2个以太网管理端口，每个控制器1个。用于IBM服务人员对DS5020进行诊断操作。


IBM TPC for Disk Midrange Edition 产品介绍

解答:

IBM Tivoli Storage Productivity Center for Disk Midrange Edition（简称TPC for DME），可以帮助我们的客户简化对IBM System Storage DS3000、DS4000、DS5000 和 V7000 设备的管理。

IBM TPC for DME可以帮助系统管理员从单一控制台对整个存储平台进行配置、管理并对其性能进行监督。系统管理员对这些存储系统的性能统计数据进行监督和分析的时间间隔可以缩短至每五分钟进行一次。性能数据可以在布局查看器中实时查看，也可以经过存储用来生成历史报告，或者通过对各种设备参数的性能阈值进行监督来及时生成报警。

IBM TPC for DME独立于 IBM Tivoli Storage Productivity Center for Disk，原因在于TPC for DME主要用于支持IBM入门级和中端存储磁盘产品，如DS3000、DS4000、DS5000 和 V7000。另外可以根据每个存储设备加以许可，例如磁盘控制器以及它们各自的扩展单元。

IBM TPC for DME主要的优点在于：
1. 通过实时监督和故障识别来实现持续、主动的性能分析，以此提高SAN的可用性。
2. 通过保持SAN可靠运行，帮助您潜在提高存储的投资回报
 3. 通过简化复杂的SAN的管理来降低存储管理成本


DS8000

DS8000 Copy Service特性

DS8000中磁盘相关基本概念 (最近更新)

DS8700新产品特性阐述

DS8700 微码实现的功能介绍 (最近更新)

IBM DS8800 存储产品介绍(最近更新)

DS8700与DS8800 物理指标与电气特性


DS8000 Copy Service特性

解答:

DS8000 提供非常强大的Copy Service 功能。

FlashCopy可以在你需要的任何时间迅速完成拷贝，它提供逻辑卷的快速时间点（Point-in-Time）快照，产生一份源数据卷在某一时刻的一模一样的镜像，并且目标数据卷立即可用。

FlashCopy SE的全称是FlashCopy space efficient.跟标准的DS8000 FlashCopy不同，FlashCopy SE不需要占据FlashCopy源卷那么大的物理空间。也就是说FlashCopy的目标卷是space efficient volume（一个虚拟卷，并没有占据实际的物理空间）。现在，当你需要FlashCopy功能时，你可以有更多的选择，FlashCopy 标准版（配置的物理容量必须两倍于客户的逻辑容量），FlashCopy SE近似FlashCopy 标准版功能，节省更多的物理空间。在FlashCopy SE中，改变量会被存储到repository卷，针对于每一个extent pool你只可以定义一个repository卷。这个extent pool中的FlashCopy SE 目标卷将会共享这一个repository卷。

一般的来说，FlashCopy SE方案最好适用于改变量不大的FlashCopy（源与目标卷）关系中。例如： 那些FlashCopy target卷只需要存在一个相对较短的时间。

DS8000 提供三种典型的数据灾难复制方案。Metro Mirror，Global Mirror, Metro Global Mirror等。

Metro Mirror 是同步数据复制方案，始终保持本地数据和异地数据是一致的。每一次IO都需要在异地的DS8000 上先完成，本地的IO才能完成。这种数据复制功能对本地DS8000的IO性能有影响，根据距离的增加影响会越来越大。理论上，最大支持300 公里的Metro Mirror方案。

Global Mirror 是异步复制方案，本地数据和异地数据不是实时同步的，本地IO的完成跟异地IO没有关系。一般的情况下，异地数据总是和本地数据有着一定的差别（异地的数据没有本地的数据新，差着时间点）。基本上，Global Mirror 对本地DS8000 的IO 性能没有影响。理论上，Global Mirror 不受距离限制。

Metro Global Mirror 是一个三点数据灾备方案，典型的是，同城做一个Metro Mirror的方案，然后在异地配置一个Global Mirror的方案。小范围内的灾难，在同城进行恢复（恢复速度快，数据几乎没有丢失），如果是大范围的灾难，在异地进行恢复（恢复速度慢，丢失一部分的数据）。这是一个完全的数据灾难方案，适用于多种灾难情况，而且能根据具体的情况，三点数据灾难方案可以做相应的调整。

Remote pair Flashcopy 是为了避免当Metro Mirror primary volume成为一个Flashcopy的 target volume时，从Metro Mirror primary volume到Metro Mirror secondary volume发生数据物理移动。在本地DS8000上，只须传送一个inband FlashCopy 命令来触发远程DS8000上的一个Flashcopy操作，而不是从本地DS8000到远程DS8000通过Metro Mirror来mirror数据。这样可以减少对本地DS8000和远程DS8000之间带宽的占用。

当本地DS8000上执行一个Flashcopy命令，开始从Local A 到 Local B的flashcopy。同时，也会有一条相似的inband flashcopy命令通过FC link从本地DS8000传给远程DS8000，开始从Remote A到 Remote B的flashcopy。

目前，本地和远程都只有一份数据，现在想在本地和远程再都增加一份数据，不想占用本地和远程之间的带宽，采用Remote pair Flashcopy方法。

创建Remote Pair FlashCopy的前提条件是：
1．Local A / Remote A 和 Local B / Remote B 必须已经是2对Metro Mirror pairs，且这2对Metro Mirror pairs必须是处于full duplex 状态。
2．Remote A 和Remote B 必须位于同一台DS8000中的同一个Storage Facility Image (SFI)上。

参考资料
书名：《IBM System Storage DS8000 Series Copy Services in Open Environments》
书号：SG24-6788-03
参考章节：Part4，Part6，Part7
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246788.pdf

Top


DS8000中磁盘相关基本概念

解答:

DDM:

一个磁盘驱动器模块(Disk Drive Module (DDM)是一个可替换的单元，包含一块单独的磁盘和它相应的包装。 DDMs 订购是以16块盘为一组，又叫做一个a drive set. 一个 drive set 是跨两个disk enclosures, 8 DDMs 在前面的(front) disk enclosure ，8 DDMs 在后面的(rear) disk enclosure. 当订购disk enclosures 时，它们是成对出现的，每个可以插16块硬盘 。如果任何一个 disk enclosure 没有插满 DDMs, 则空的槽位必须被哑盘(dummy carriers )来填充，又叫做disk enclosure fillers. Disk enclosure fillers 可以以16为一组来订购。

Array sites:

Array site 是用于定义arrays的building blocks。一个 array site 是一组硬盘，由8块相同转速和容量的硬盘组成，这8块硬盘会从位于不同环路里的2个disk enclosures 里选择，例如：4块硬盘来自环路1，另外4块硬盘来自环路2。通常都是4块磁盘来自一个后面的(rear)disk enclosure ，4块磁盘来自前面的(front) disk enclosure 。

Arrays:
一个 array 是在一个array site里创建,创建一个array意味着首先要定义一个特定的RAID 类型，DS8000支持的RAID 类型是RAID-5 和RAID-10 . 对于每一个array site ，你可以选择一个RAID 类型，为一个array选择RAID类型的过程也叫做定义一个 array。
对于DS8000 热备盘的算法（sparing algorithm）,一个array site可以定义0到2个热备盘。 一个array 是定义在一个array site里，当这个array 能被一个device adapter pair 里的每个adapter 访问, 它由一个device adapter来管理. 由哪个adapter 和哪个server 来管理这个 array 会在后来configuration path时作定义。

DS8000有下列6种 RAID 配置可供选择:
- 3+3 RAID 10 配置，Array 包含6块数据盘，其中3块是做镜像的数据盘。该Array Site另外剩下的2块盘作为热备盘。（6+2S）
- 4+4 RAID 10 配置，Array 包含8块数据盘，其中4块是做镜像的数据盘。
- 6+P RAID 5 配置，Array 包含6块数据盘和1块奇偶校验盘。该Array Site另外剩下的1块盘作为热备盘。(6+P+S)
- 7+P RAID 5 配置， Array 包含7块数据盘和1块奇偶校验盘。(7+P)
- 5+P+Q+S RAID 6 配置，Array 包含5块数据盘和2块奇偶校验盘。该Array Site另外剩下的1块盘作为热备盘。
- 6+P+Q RAID 6 配置，Array 包含6块数据盘和2块奇偶校验盘。

以下是RAID级别支持的磁盘类型：
- RAID 10：支持 FC 和 SATA 硬盘
- RAID 5： 支持 FC 和 SSD 硬盘
- RAID 6： 支持 FC 和 SATA 硬盘

Rank:
当定义一个新的rank, 它的名字由DS Storage Manager来选择, 例如：R1, R2, 或 R3, 等等。你必须添加一个array 到一个rank里。目前，一个rank里只能包含一个array，但将来会允许一个rank里有一个或多个arrays。每一个rank里可用的空间将会被划分成extents。extents 是逻辑卷的building blocks。一个 extent 是跨一个array的所有磁盘的条带。创建一个rank 的同时需要会做两件事：
- 这个Array被格式化成或者是 FB (open systems) 或是 CKD (zSeries) 数据。
- 这个Array的容量被分成相同大小的partitions, 叫做 extents. 这个extent 大小取决于extent 类型， FB 或 CKD。一个FB rank 拥有一个extent 的大小是 1 GB。

参考资料：
书名：《IBM System Storage DS8000 Series Copy Services in Open Environments》
书号：SG24-6788-03
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246788.pdf

书名：《IBM System Storage DS8000 Architecture and Implementation》
书号：SG24-6786-07
地址：http://www.redbooks.ibm.com/abstracts/sg246786.html?Open


DS8700新产品特性阐述

解答：

IBM System Storage DS8700相比前一代DS8000产品,为客户提供了更高的性能、更优的可靠性和弹性，及更高的能效。DS8700采用了基于IBM POWER6处理器的控制器、全新内部PCIE光纤连接方式、全新的微码、以及增强的设备适配器，与之前最强大的机型DS8300相比其性能提高了150%，这使得DS8700能够更好地满足更为苛刻的业务应用和业务分析需求。

System Storage DS8700能够支持客户在不中断运行的前提下从基础型号升级到最高级的型号，从而帮助企业可以根据需求扩容，而无需购买全新系统。除具有灵活性和可扩展性外，DS8700还能使客户从上一代产品的投资中获益。比如DS8700支持与上一代型号的硬盘、硬盘盒、工具、脚本和拷贝服务之间的全面兼容。此外，新的System Storage DS8700更具能效，IOPS/watt(每秒读写操作次数)比之前的DS8300提高了50%以上。

DS8700与DS8100/DS8300硬件参数对比：

 | DS8100 | DS8300 | DS8700
DDMs(min-max) | 16-384 | 16-1024 | 16-1024
DDM Interface | FC-AL | FC-AL | FC-AL
FC DDM Types | 146, 300, 450 GB | 146, 300, 450 GB | 300, 450，600GB
SATA DDM Types | 1 TB（停产） | 1 TB（停产） | 2 TB
SSD DDM Types | 73, 146 GB | 73, 146 GB | 73, 146 GB
RAID Types | RAID 5, 6, 10 | RAID 5, 6, 10 | RAID 5, 6, 10
Max Capacity w/146GB DDM | 56 TB | 239.2 TB | 239.2 TB
Max Capacity w/450GB DDM | 173 TB | 717.6 TB | 717.6 TB
Max Number of LUNs / CKD volumes | 64K total | 64K total | 64K total
Max N-Port Logins/Port | 510 | 510 | 510
Max Process Logins | 2K | 2K | 2K
Max Logical Paths / CU | 512 | 512 | 512
Max LUN Size | 2 TB | 2 TB | 2 TB
Dynamic Provisioning | Add / Del | Add / Del | Add / Del
Cache / NVS | 16-128GB/1-4GB | 32-284GB/1-8GB | 32-384GB/1-12GB
Processor | P5 2.2GHz 2-way | P5 2.2GHz 4-way | P6 4.7GHz 2 or 4-way
Host Adapters | ESCON x 2 ports 4 Gb FC x 4 ports | ESCON x 2 ports 4 Gb FC x 4 ports | 4 Gb FC x 4 ports
Host Adapter Slots | 16 | 32 | 32
Max Host Adapter Ports | 64 | 128 | 128
PPRC Fabric | FCP | FCP | FCP
DA Slots | 8 | 16 | 16

更多DS8000存储产品信息请参考：
http://www-900.ibm.com/storage/cn/disk/ds8000/index.shtml

DS8700动态架构高可用性方案介绍：
https://www-900.ibm.com/systems/cn/dihub/products_innovation/storage_advantage/09q4_ds87/index.shtml

DS8700产品架构以及使用红皮书：
http://www.redbooks.ibm.com/redpieces/pdfs/sg248786.pdf

Top


DS8700 微码实现的功能介绍

解答:

IBM System Storage DS8700 的最新微码为5.1版本，提供了如下新功能：

.提供IBM System Storage Easy Tier 功能；

.提供73GB、146GB 与600GB容量固态盘8磁盘组配置； （73GB和146GB固态盘已停产）

.提供600 GB 15,000 rpm Fibre Channel 磁盘；

.提供2 TB 7,200 rpm SATA 磁盘；

.提供Quick initialization与Thin Provisioning for open volumes 功能；

.提供Remote Pair FlashCopy功能；

.提供Concurrent code load improvements功能；

.提供Prevent deletion of CKD and FB volumes in use功能；

.提供Disable recovery key功能；

.提供Rekey data keys of an encryption group功能；

.提供z/HPF extended distance。

Top


IBM DS8800 存储产品介绍

解答：

随着数据的爆炸式增长，许多企业都在竭力管理、保护和维护飞速增长的信息资产并极力减轻风险。在控制服务级别和增长速率的同时降低企业风险并优化存储管理成本，这就需要一个可靠的信息基础架构。IBM DS8800 是IBM新分布的最新一代企业级磁盘存储产品，为客户提供了高性能，高容量，高扩展性与高可靠性的存储产品。

IBM全新的企业级的存储产品DS8800，应用了强大而又久经市场考验的Power6+的控制器，主频由DS8700 的4.7GHz 提升到5GHz，特别使DS8800较之先前产品在顺序读写性能上有了效大提升。

IBM DS8800由于使用了全新的存储磁盘柜的设计，使得整个机器的存储密度增加了。全新存储磁盘柜为2U高，支持24块2.5英寸6Gb SAS或固态盘，从DA卡到它的连接依然通过光纤线。

IBM DS8800包括一个主柜与最多配置两个扩展柜，最大支持1056块磁盘。在双两路的配置下，只能配置一个主柜最多支持240块磁盘。在双四路配置下，最多可以增加2个扩展柜，最多支持1056块磁盘，达到以更小占用空间内集聚更多数据的目的，实现前所未有的性能水平。以便更好的节省机房的空间，降低运营成本。

IBM DS8800最新支持16块4端口或8端口8Gb 长波或短波 Fibre Channel/FICON主机接口卡，并自适应8Gb、4Gb与2Gb的链路速率，最多支持128个主机接口。DS8800另一个重要的提升在于后端设备接口卡升级到了8Gb，极大提升IOPS性能，吞吐率与可扩展性。

IBM DS8800采用前进风，后出风的散热方式，满足用户数据中心的整体规划，以达到节省能源的目的。在内部数据分配方式上，IBM DS880在默认情况下自动将卷组的数据分布在一个extent pool上的所有rank上，以便有效消除热点数据，提升性能与减少管理复杂度。

IBM的设计思路是将服务器和大型主机领域的领先技术应用到存储上。DS8800将存储的处理能力分布在前端、控制层、后端3个层次，使得存储的IO响应时间非常快。IBM DS8800采用了全新的IBM POWER6+ 5.0 GHz处理器架构作为其核心的控制器，最大支持384GB缓存并且采用业界独有的各种缓存专利技术，ARP算法成倍提高缓存命中率，AMP算法成倍提高RAID5顺序访问速度，而IWC算法极大提高数据随机写性能。

IBM DS8800内部IO抽屉与控制器之间依然采用了PCI-E点对点光纤连接方式，两台控制器之间保留的RIO-G环路用于处理器之间的通信。

IBM DS8800内部IO抽屉中安装两种两型的适配卡，即主机适配卡与设备适配卡。其中主机设备卡用于连接前端的主机接口或者SAN网络接口，设备适配卡用于连扫后端的磁盘组并且用于管理、监控与重建RAID。在DS8800中，采用了全新的设备适配卡设计并支持8Gb/s的传输速率。。每个设备适配卡并且必须成对安装以冗余的方式连接后端的磁盘组。

IBM DS8800最新支持16块4端口或8端口8Gb 长波或短波 Fibre Channel/FICON主机接口卡，并自适应8Gb、4Gb与2Gb的链路速率，最多支持128个主机接口。

DS8800 系统架构示意图：

Top


DS8700与DS8800 物理指标与电气特性

解答:

DS8700与DS8800物理指标如下：

DS8700与DS8800电气特性如下：

Top


XIV

XIV磁盘存储的功率、尺寸与工作环境

XIV磁盘存储的技术特征与产品优势

XIV磁盘存储的硬件特征 (最近更新)

XIV 数据迁移的步骤 (新增)


XIV磁盘存储的功率、尺寸与工作环境

解答：

型号：2810-A14/2812-A14

宽：600mm

深：1092mm

高：1991mm

最大重量：869kg

最大功率：8.4kw

噪声：8.4bels

散热量：26K Btu/hour

温度：10-35摄氏度

相对湿度：25%-80%

由于XIV是由interface module（接口模块）和data module(数据模块)组成，因此不同容量配置的XIV其功率是不一致的，主要区别如下：

Modules | Disks | Power usage 1TB/2TB
 |  | KVA(peak) | KVA(IdIe) | KBTU
6 | 72 | 3.4/3.1 | 2.9/2.8 | 11.0
9 | 108 | 5.0/5.4 | 4.2/4.0 | 16.4
10 | 120 | 5.5/4.9 | 4.7/4.4 | 17.8
11 | 132 | 6.1/5.4 | 5.2/4.7 | 19.3
12 | 144 | 6.7/5.8 | 5.7/5.1 | 20.7
13 | 156 | 7.2/6.2 | 6.2/5.5 | 22.2
14 | 168 | 7.8/6.6 | 6.7/5.9 | 23.6
15 | 180 | 8.4/7.1 | 7.2/6.2 | 25.1

参考资料：

XIV销售手册（Sales Manual）

XIV数据手册（Data Sheet）

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


XIV磁盘存储的技术特征与产品优势

解答：

技术特征：

1.先进的系统架构--分布式算法：数据被“切割”为"分区"，分布式算法自动地将分区跨所有的磁盘,无存储热点；

2.支持1TB或2TB的磁盘；

3.快照(SnapShot)：

差异快照(Differential SnapShot): 只复制更改的数据；

全复制(Full Copy): 后台全复制(克隆)；

多重关系快照(Multiple Snapshot): 可写的快照卷。

4.Thin Provisioning功能:提供硬(物理)和软(虚拟)容量设置,存储空间分配更加灵活方便；

5.同步与异步镜像：可通过以太网、iSCSI及光纤实现；

6.数据迁移：XIV系统可作为主机和旧存储的代理。

产品优势：

1.较低的总体拥有成本(TCO)：

易于管理，节约人力成本；

更加省电，节约空间；

使用SATA硬盘实现FC硬盘的性能；

没有附加软件功能费用。

2.高可靠性：

自愈(self-healing)功能；

30分钟内重建1TB的SATA硬盘。

3.高性能：

先进的分布式算法：使所有硬盘平均负载I/O，避免热点盘和I/O瓶颈；

平均分配的缓存(Cache)，使用先进的缓存算法和高速磁盘与缓存带宽；

通过分布保护机制，磁盘重建(Rebuild)时，不影响系统性能。

4.先进的快照(SnapShot)技术：

支持最多16,000个快照；

先进的ROW快照技术，快照时对生产数据的性能不会产生负面影响。

丰富的存储复制功能集合

1.每卷支持多达16,000 份快照；

2.卷快照，卷拷贝，从快照恢复卷均为瞬时操作。完成时间小于秒级；

3.快照可以更改为可写模，但仍然保持差分(仅占用变化的数据空间)；

4.支持所有快照功能，包括差分快照和物理全拷贝；

5.支持一致组Consistent Group，多个卷可以在同一时间点完成快照，保障数据一致性；

6.部署灵活，可灵活的将快照映射到主机，拷贝快照到卷，复制快照等等；

7.高性能快照：XIV 存储系统将其创新的复制算法和其大规模 CPU 处理能力及 Cache 缓存能力结合，保障快照对性能的影响最小化；

8.传统的 Copy-On-Write 技术为更高效的Redirect-On-Write 技术取代。消除了不必要的内部拷贝动作；

9.Redirect-on-write 操作总是在同一模块内部完成。磁盘之间的数据拷贝通过高速 PCI-X 总线完成。这相对于传统的在模块或控制器之间的拷贝而言极大的提升了性能；

10.快照的写操作开销不依赖于快照的数量和卷的大小；

11.对快照和卷的读操作零开销 。

可靠性方面的优势

XIV 存储系统通过其网格架构及独特的RAID-X 保护机制提供了前所未有的系统可靠性。

这些特性使得系统几乎不受任何单点故障的影响，并大大降低了双重故障的风险。

1.真正的无单点故障
XIV 系统中的冗余架构保障任何单点故障对主机 I/O 均无影响。所有的磁盘，数据模块，交换机或UPS 均为冗余方式配置，并通过 Active-Active 的 N+1 方式提供保护。每一组件均可热插拔，这意味着整个系统无须停机便可实现更替。

2.30分钟重建1TB磁盘驱动器
XIV 系统的设计目标之一便是要最小化双重磁盘故障风险。利用其创新的RAID-X 设计，每一磁盘均会分成很多小的条带，每一条带又会镜像到不同的磁盘之上。这一架构的优越之处在于当磁盘出现故障时，系统中所有的磁盘均会参与重建。在系统利用率达到近 100%的情形下(充满数据)，当一块 1TB 的磁盘驱动器故障时，系统暴露于双重磁盘故障的风险仅为 30 分钟的重建时间。如此短的重建时间极大(成数量级的)的降低了可能因双重故障而带来的数据丢失风险，特别是在同传统存储系统对比时这一优点更加明显。

3.仅重建实际数据
标准的存储系统是在块级完成磁盘重建，无论是否有有效数据完全重建整个磁盘。XIV 存储系统仅重建分配给卷的空间，甚至即使在一个卷的内部也仅重建真正写入的数据部分。因此，单个驱动器故障时的重建时间实际上可能大大小于30分钟，因为并非所有的空间都会分配出去并有数据写入。

4.模块故障时自恢复
XIV 存储系统拥有自恢复机制。在数据模块发生故障时，系统会启动重建机制重建冗余状态。故障的模块可以在系统恢复冗余状态后予以更换，保护系统免受维护人员操作错误的风险。

参考资料：
1.查阅IBM销售手册: XIV销售手册
2.《IBM XIV Storage System- Concepts, Architecture, and Usage》

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


XIV磁盘存储的硬件特征

解答：

型号：2810-A14/2812-A14

支持24 x 4Gb FC及6 x 1Gb iSCSI

高性能：提供GRID存储能力，无数据热点

高可靠性：基于GRID的重建技术

最大180块SATA磁盘，使用1TB/2TB SATA硬盘，提供约79TB/161TB的可用容量

9个数据模块，使用Single Low-Voltage CPU

6个接口模块，使用Dual Low-Voltage CPU

每个模块12块1TB/2TB SATA磁盘

3个UPS

1TB 模块最大支持120GB系统缓存（每个模块8GB），2TB模块最大支持240GB系统缓存（每个模块16GB） 注意：1TB模块通过RPQ申请也可以支持最大240GB系统缓存（每个模块16GB）

支持120GB系统缓存（每个模块8GB）

支持同步远程镜像、自动精简配置(thin provisioning)、数据迁移及快照技术

目前XIV支持以下几种配置方式

模块总数 | 6 | 9 | 10 | 11 | 12 | 13 | 14 | 15
可用容量 | 27/55 | 43/87 | 50/102 | 54/111 | 61/125 | 66/134 | 73/149 | 79/161
接口模块 | 3 | 6 | 6 | 6 | 6 | 6 | 6 | 6
数据模块 | 3 | 3 | 4 | 5 | 6 | 7 | 8 | 9
硬盘数量 | 72 | 108 | 120 | 132 | 144 | 156 | 168 | 180
FC接口 | 8 | 16 | 16 | 20 | 20 | 24 | 24 | 24
iSCSI接口 | 0 | 4 | 4 | 6 | 6 | 6 | 6 | 6
内存(GB) | 48/96 | 72/144 | 80/160 | 88/176 | 96/192 | 104/208 | 112/224 | 120/240

参考资料：

查阅IBM销售手册:Storage System 销售手册查询

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


XIV 数据迁移的步骤

解答:

XIV支持将数据从其它厂商迁移到XIV存储上，迁移过程如下：

1. 停止主机上面的应用
2. 在SAN交换机上更改原有存储产品与XIV和host之间的zoning
3. 在XIV上面定义迁移的Target
4. 向Target增加用于数据迁移的端口
5. 定义XIV的端口与数据迁移端口之间的连接，并将XIV定义为Linux主机
6. 在原有存储产品上修改mapping，将需要数据迁移的LUN映射到XIV上
7. 在XIV上面定义数据迁移关系
8. 测试并激活数据迁移关系
9. 将XIV的LUN映射到主机上
10. 在主机上面识别XIV的LUN，并安装XIV的驱动程序
11. 导入卷组，并启动应用
12. 数据迁移完成后，在XIV上面删除数据迁移关系
13. 在SAN交换机上面删除XIV与原有存储产品的数据迁移zoning


SVC

IBM SVC解决方案有哪些特点和优势 (最近更新)

SVC 5.1和6.1软件新增功能 (最近更新)

SVC新一代引擎2145-CF8简介(最近更新)

SVC SAN及Zone规划(新增)

SVC 基本术语(新增)


IBM SVC解决方案有哪些特点和优势

解答：

IBM SVC解决方案特点如下：

1.SAN虚拟存储控制器具备灵活的磁盘管理功能，极大的提高了存储管理的效率，例如可动态创建和扩展逻辑卷等。 而且，SVC为各种不同的存储设备提供了一个统一的数据复制平台， 例如瞬间复制 FlashCopy和远程复制 Remote Mirroring。 这些复制功能都允许源磁盘卷和目标磁盘卷可以存在于不同品牌的磁盘阵列上。

2.透明的数据迁移：当SVC被加入到一个现有的SAN 环境中时，不需要做数据迁移， SVC 把现有的磁盘配置原封不动的继承下来（这是SVC的Image mode）， 这样对服务器上的应用是完全透明的。当SVC完全配置好以后， 它又可以将原先磁盘上的卷及数据透明的迁移到其他真正的虚拟卷中。 所有的迁移过程对服务器透明，因此不需要中止应用。

3.IBM SVC是一个软硬件集成化的产品，专业的虚拟存储软件运行在集群式的硬件引擎上。 它使用了定制的IBM System x 服务器，运行的存储操作系统是基于 Linux kernel的。 与SAN网络接口是工业标准的HBA卡。由于SVC是为一个完全开放的存储环境设计的， 兼容各种不同的存储设备。用户可以将各种存储方案融合其中，而不用担心SVC会有什么封闭性。 SAN Volume Controller 天生具备灵活的扩展能力，可以使用户在存储性能和存储容量方面平滑无缝的升级。
例如，扩展控制器个数可以增加性能，而往存储池中增加磁盘则可以增加容量， 这两方面的扩张都可以在线完成，不需要中止应用。SVC的主控台提供了自动向IBM服务中心报警和远程支持的能力。

4.灵活开放的体系结构:
易于实施；
易于在性能和容量双向发展。

5.企业级的高可靠性和稳定性。

6.提供SSD固态盘和Easy Tier的支持
对固态设备 （SSD） 的创新紧密集成支持 专为关键应用程序数据提供超高的性能 SVC 架构可将 SSD 的性能和容量扩展至高达 2.4 TB 和每秒 800,000 次读 I/O，却只需极小的入门级配置，这有助于使 SSD 更加经济实惠 将数据移入/移出 SSD，而不造成中断；在硬盘驱动器上创建固态驱动器数据的副本
注意：目前内置的SSD仅支持 SVC 5.1 版本，暂时不支持SVC 6.1
SVC产品从6.1版本开始，增加了Easy Tier 分层存储技术。Easy Tier是一种针对SSD固态盘的性能优化技术，它先统计出频繁访问的热点数据所在的数据块(Extents)，然后将这些数据块(Extents)从传统磁盘的Mdisk移动到SSD固态盘的Mdisk，从而有效地优化和提高访问速度和性能。

IBM SVC解决方案优势如下：

虚拟化是IBM早在40多年前就推出的一项技术，如今在许多新的领域又重新恢复了它的生机：从虚拟服务器到虚拟存储， 优化的网络，虚拟环境中的工作站，以及应用虚拟化。虚拟化技术为企业带来的潜在收益是巨大的， 不仅可以提高存储设备的利用率和业务灵活性，而且还可降低处理的总成本并提高可靠性。

根据所实施的虚拟化的起点、类型和范围不同，客户可以快速获得这些收益。 SVC目前已经发展到了6.1的版本，目前SVC已经有多于2000个实际安装用户， 支持至少50多个存储设备。同时SVC在存储性能理事会测试标准SPC-1和SPC-2的指标都获得最高性能得分， 彰显了IBM在存储领域的领导地位。

-IBM拥有40年的虚拟化技术；
-全球已经销售出13000多台SVC引擎，建立了4000个基于SVC系统；
-全球有超过130个客户参考案例；
-在性能测试中， SVC表现出了及高的性能和扩展能力；
-SVC具有最快的SPC-1基准测试值 (SVC 4.2: 272,500 IOPS)；
-SVC具有最快的SPC-2 基准测试值 (SVC4.2: 7080)；
-SVC可以支持包括IBM和非IBM在内的120多中磁盘存储系统（IBM, EMC, HP, HDS, Sun, Dell, NetApp, Fujitsu, NEC, Bull)；
-IBM从产品，到咨询，到实施，提供一整套服务。

突出价值点:
SVC解决方案实现了存储空间的统一管理和虚拟化。
SVC 解决方案提供了异构存储设备之间的数据迁移，和实现了异构存储设备之间远程镜像功能。

Top


SVC 5.1和6.1软件新增功能

解答:

SVC 6.1 新增功能：

1. Completely redesigned user interface
和new Storwize V7000 GUI用户界面很相似，CLI用户界面没有变化。

2. Easy Tier
SVC产品从6.1版本开始，增加了Easy Tier 分层存储技术。Easy Tier是一种针对SSD固态盘的性能优化技术，它先统计出频繁访问的热点数据所在的数据块（extents），然后将这些数据块（extents）从传统磁盘的Mdisk移动到SSD固态盘的Mdisk，从而有效地优化和提高访问速度和性能。
SVC 的 Easy Tier 具有以下一些特点：
1) Easy Tier 是 SVC 6.1版本的原生（Native）功能，不需要额外费用，只要将软件版本升级到6.1版本，SVC就具备了Easy Tier功能
2) 完整的 Easy Tier 功能包括两种模式：统计评估模式（measuring或evaluation）和 迁移优化模式（migration或Auto Data Placement）
a.没有SSD固态盘也可以使用统计评估模式，通常用于评估现有环境配置，以决定需要添加的SSD固态盘数量，以及哪些卷（volume）更有益于使用迁移优化模式
b.应用迁移优化模式必须要有SSD固态盘，并且同一个存储池（Storage Pool）中，需要配置两种级别（Tier）的Mdisk，即传统磁盘组成的Mdisk和SSD固态盘组成的Mdisk
3) 目前，由于2145-CF8升级到SVC 6.1后暂时不支持内置的SSD固态盘，因此，如果2145-CF8使用Easy Tier功能只能使用外置存储的SSD固态盘
4) SVC使用Easy Tier的迁移颗粒度由extent的大小决定，默认值为256MB，最小支持16MB，最大支持8GB

3. Scalability
最大 extent size 增加到原来的4倍，达到8GB；
最大 volume size 增加到256TB；
最大 WWNNs 的数目增加到原来的4倍，达到256。

4. Interoperability
支持新的server software：
VMware vSphere 4.1；
支持新的disk system：
IBM Storwize V7000
IBM System Storage DS8800
EMC Symmetrix VMAX
Compellent Series 20 Storage Controller
Fujitsu Eternus Models DX60, DX80, DX90, DX410, DX8100, DX8300, DX9700。

5. SVC for XIV
针对XIV,采用特殊的license配置。

SVC 5.1 新增功能：

1. Multi Cluster Mirroring
支持四个Cluster之间的MM/GM复制伙伴关系。

2. 8129 relationship support
支持 8192 Metro Mirror and/Global Mirror relationship，之前的版本只支持1024个。

3. Space Efficient VDisks – zero detect
支持将 非SE的VDisk 中没有使用过的容量(zeros)回收到SVC MDG里，把VDisk变为SEV,为客户腾出更多的存储空间，更有效的利用存储。

4. Dual Ethernet port support and iSCSI
SVC 使用集成的两个以太网口来做 iSCSI 访问。

5. Reverse FlashCopy
支持把FlashCopy 的某一个目标VDisk 恢复到源VDisk上，并且不需要停止原有的 FlashCopy关系，并且不需要等原有的FlashCopy关系结束。

6. 256 TB VDisk support
VDisks 最大支持 256 TB。

7. Remote authentication via Tivoli Integrated Portal
SVC 5.1 不仅支持本地认证，也支持远程用户认证。

8. Syslog support
专对当前SVC email and SNMP trap 功能新增的日志。

9. Auto-recovery of node metadata
提高客户的可用性。

10.SVC Console (GUI) Changes
支持Windows 2008。

参考文档:
书名：Implementing the IBM System Storage SAN Volume Controller V6.1
书号：SG24-7933
链接：http://www.redbooks.ibm.com/redpieces/abstracts/sg247933.html?Open

突出价值点：SAN虚拟存储控制器具备灵活的磁盘管理功能，极大的提高了存储管理的效率，例如可动态创建和扩展逻辑卷等。
而且，SVC为各种不同的存储设备提供了一个统一的数据复制平台，例如瞬间复制 FlashCopy和远程复制 Remote Mirroring。
这些复制功能都允许源磁盘卷和目标磁盘卷可以存在于不同品牌的磁盘阵列上。

Top


SVC新一代引擎2145-CF8简介

解答:

1.新的SVC节点类型，使用 IBM System x3550M2 server：
Intel Core Xeon 5500 Series quad-core 处理器
24GB 缓存
4个 8Gbps FC 端口
支持 IBM Systems Director Active Energy Manager
双电源
19英寸标准，1U 高

2.总线带宽是 8G4的两倍, IOPS最大可以达到8G4的两倍；

3.支持 Solid State Drives (最多每个SVC节点 四个SSD)；
注意：SVC 6.1版本暂时不支持SSD固态盘

4.在一个 SVC clusters，不同的IO group可以是不同的节点类型；

5.在对原有环境进行替换升级的时候，可以允许不同的节点在一个IO group里；
注：4F2不能升级到5.1 code，所以也不能与CF8共存。

6.SVC 2145-CF8是针对2145-8G4的替换产品。

7.SVC 2145-CF8软件5639-VC5的配置中新增IBM Tivoli Storage FlashCopy Manager的组件，该软件的主要功能是执行近乎即时的应用程序感知快照备份，而对DB2、Oracle、SAP、Microsoft SQL Sever和Microsoft Exchange性能的影响是最低的；提供对Microsoft Exchange数据的高级、精细还原；支持群集应用程序环境（Windows上的MSCS或VCS以及AIX上的HACMP）以及Microsoft Exchange 2007持续复制配置（LCR、CCR和SCR）。

8.SVC5.1以上可以支持iSCSI接口，避免了服务器中光纤通道主机总线适配器（HBA）的成本，同时减少了对光纤通道交换机的需求。

突出价值点：
IBM拥有40年的虚拟化技术；
全球已经销售出13000多台SVC引擎，建立了4000个基于SVC系统；
全球有超过130个客户参考案例；
在性能测试中， SVC表现出了及高的性能和扩展能力；
SVC具有最快的SPC-1基准测试值 (SVC 4.2: 272,500 IOPS)；
SVC具有最快的SPC-2 基准测试值 (SVC4.2: 7080)；
SVC可以支持包括IBM和非IBM在内的120多中磁盘存储系统（IBM, EMC, HP, HDS, Sun, Dell, NetApp, Fujitsu, NEC, Bull)。

Top


SVC SAN及Zone规划

解答:

SVC 需要规划出三个Zone，分别是：

1．主机Zone:每个主机的HBA卡建议看到SVC的两到四个端口

2．存储Zone:一个存储要通过相同端口让SVC的所有节点看到，简单的说可以做一个Zone把所有存储端口和所有SVC端口放在一起。

3．SVC Cluster内Zone: 组成一个SVC Cluster的所有节点的所有口要放在一个Zone 里。

如果SVC需要实施远程容灾，还需要划出MM/GM容灾Zone。SVC每个节点至少拿出一个端口和另外一个Cluster的每个节点至少一个端口做Zone，推荐两个以便冗余。


SVC 基本术语

解答:

MDisk：Managed Disk，是从SVC的子存储分配过来的LUN

MDG： Managed Disk Group，在SVC上把MDisk集合起来的存储池。在SVC 6.1版本之后，MDG更名为Storage pool。

VDisk：Virtual Disk，是从SVC上建立的虚拟磁盘，是SVC分配个主机的LUN。在SVC 6.1版本之后，VDisk更名为volume。

SEV：Space-Efficient VDisk，是‘瘦供给’或称‘节省空间的’VDisk。在SVC 6.1版本之后，SEV更名为thin provisioning。

VDM：VDisk Mirroring，是SVC的将一个VDisk创建多份拷贝存放到不同的存储池上的技术，是高可用的功能(Storage HA)

MM：MetroMirror，同步镜像，是灾备的功能(DR)，零数据丢失

GM：GlobalMirror，异步镜像，是灾备的功能(DR)，RPO>0

FC：FlashCopy，快照，对逻辑错误进行防护的功能，基于时间点

IO group：两个节点构成的类似AB控制器的一对，VDisk在同一个IO group的两个节点之间fail over实现fail back

SVC逻技示意图:


Storwize V7000

IBM Storwize V7000产品介绍 (最近更新)

Storwize V7000 物理组成

V7000与HBA卡，操作系统以及后端磁盘阵列等的兼容性 (新增)

V7000 存储虚拟化价值表现 (新增)

V7000 虚拟化以及数据迁移方式 (新增)

V7000 自动分层存储（EasyTier）应用方式 (新增)

V7000 高级复制功能介绍 (新增)

V7000是否可以通过iSCSI端口进行远程镜像 (新增)


IBM Storwize V7000产品介绍

解答：

IBM Storwize V7000是IBM最新发布的中端磁盘存储系统，提供了无与伦比的性能、可用性、高级功能和高级扩容能力。

IBM Storwize V7000是功能强大的中级磁盘系统，支持轻松使用和快速部署，无需添加资源。IBM Storwize V7000提供固有的IBM存储资源虚拟化、SSD优化和“精简调配”技术，能够提高存储资源利用率，并且允许您重新配置系统来快速轻松地满足不断变化的需求。此外，IBM Storwize V7000的高级功能还允许用户在不中断系统运行的情况下，将数据迁出现有存储设备，从而简化实施流程并且最大限度地避免用户服务中断。IBM Storwize V7000还允许用户使用虚拟化功能和复用现有磁盘系统，从而进一步提高投资回报率(ROI)。

硬件参数：
标准2U机箱
支持24块2.5英寸磁盘驱动器（2076-124/224）或12块3.5英寸磁盘驱动器（2076-112/212）
冗余双活控制器与电源
16GB 缓存
主机接口：8个8Gb FC端口和 4个1Gb iSCSI端口
扩展柜接口：4个6Gb SAS端口
最多支持9个扩展柜
最大支持240TB物理容量
在一个机器内支持同规格磁盘混插，在一个系统中混合使用12盘位或24盘位的扩展柜

支持的磁盘驱动器：
IBM Storwize V7000 Control Enclosure（2076-112）与IBM Storwize V7000 Expansion Enclosure(2076-212)支持12块3.5英寸磁盘驱动器，有如下选择：
2 TB 3.5" 7.2k Nearline（近线）SAS磁盘

IBM Storwize V7000 Control Enclosure（2076-124）与IBM Storwize V7000 Expansion Enclosure(2076-224)支持24块2.5英寸磁盘驱动器，有如下选择：
- 300 GB 2.5" 10k SAS磁盘
- 450 GB 2.5" 10k SAS磁盘
- 600 GB 2.5" 10k SAS磁盘
- 300 GB 2.5" E-MLC (企业级多级单元) SSD

IBM Storwize V7000先进的软件功能:
全新的用户使用界面，基于web方便使用；
支持RAID 0, 1, 5, 6, 10；
Easy Tier自动分层技术 (动态硬盘 /固态硬盘的管理）；
单卷256个Flashcopy；
支持异构存储虚拟化；
透明数据迁移；
远程/本地数据镜像；
自动精简配置；
RAS 服务与自诊断；
良好的主机、存储及软件兼容性和互操作性；
可与IBM System Director集成；
与TPC, FCM 以及 TSM 的结合以增强管理能力。

基于V7000的虚拟化应用优势
- 高扩展性
IBM V7000可扩展至240块盘，充分满足客户未来存储容量的需求；
- 高开放性，支持所有主流的存储和主机
V7000支持广泛的主机、存储的硬件平台与操作系统，具体信息请参考：http://www-1.ibm.com/support/docview.wss?rs=591&uid=ssg1S1002864
- 独立性，位于中间层，不占用主机的 CPU 和存储资源
- 高性能， IBM V7000 目前具有业界较高的 SPC-1 测试性能,具有单独的处理器和 CACHE 帮助存储分担压力
- 出色的功能， V7000 具有统一的容灾和虚拟存储的功能等，使不同存储具有相同功能
在虚拟化SAN中，由于V7000是为一个完全开放的存储环境 设计的，兼容各种不同的存储设备。用户可以将各种存储方案融合其中，而不用担心V7000会有什么封闭性。用户可以按照应用不断变化的需求来分配存储，而不再受制于存储子系统设备在功能和性能上的限制。V7000又是一个SAN网络的中心管理控制点，而且它对服务器的操作系统和存储子系统透明。V7000允许用户横跨不同供应商的多个存储子系统使用 一组单一的高级拷贝服务，如FlashCopy和对等远程拷贝MetroMirror/GlobalMirror。该软件可通过扩展支持实现当前所有非IBM 磁盘存储系统的虚拟并对这些系统进行管理，帮助用户通过中央视图简化异构存储环境管理。
- 集中管理，为用户提供统一的存储管理接口，不同存储平台可以统一管理
IBM V7000借助虚拟存储将复杂的存储环境简单化，消除异构平台所造成的信息传递壁垒，实现了随需应变的存储体系，让存储真正实现按需分配是最好的解决办法。基于此，IBM的V7000是整个SAN网络的控制器，整合不同存储系统的容量，提供通用的复制功能并在不中断服务器的情况下实现数据移动。充分利用存储资源并按 需分配存储空间、性能和功能。实现从一个地方对各种存储集中进行管理。

Top


Storwize V7000 物理组成

解答:

1. SAS 作为盘柜之间的连接方式，支持的硬盘类型：SSD, 10K SAS 和Nearline SAS：
最多240 disk drives 使用 2.5"drives；
最多 120 disk drives使用3.5"drives；
最多加到 9个扩展柜。
2.5-inch (SFF)
.300GB 10K RPM SAS
.450GB 10K RPM SAS
.600GB 10K RPM SAS
3.5-inch (LFF)
.2TB 7,200 RPM NL-SAS
Solid-State (SFF)
. 300GB SAS

2. 双活动, 热插拔控制器；

3. 2种主机连接方式：
Fibre Channel
iSCSI

4. 支持不同类型/磁盘容量的硬盘混插；

5. 每对控制器上有8个 8Gbps FC Ports ，4个 1Gbps iSCSI Ports ，和16GB Cache；

6. 每个控制器或扩展柜模块的高度是2U。


V7000与HBA卡，操作系统以及后端磁盘阵列等的兼容性

解答:

1.V7000不仅能当做普通的磁盘阵列，还可以用作外部存储虚拟化，整合其他磁盘阵列，甚至第三方的磁盘阵列，但是后端所接的磁盘阵列必须满足兼容性。

注意：V7000后端不能接SVC，但是SVC后端可以接V7000

2.参考资料：

名称：兼容性列表
链接：http://www-01.ibm.com/support/docview.wss?uid=ssg1S1003703
SSIC网址：http://www-03.ibm.com/systems/support/storage/ssic/interoperability.wss


V7000 存储虚拟化价值表现

解答:

1. V7000帮助客户实现应用的不间断运行

目前情况，为了移植数据或更改存储基础设施，企业必须经常让存储设备离线。这些行为会中 断正在访问企业数据的应用程序，从而延长应用程序故障时间。分析家们估计，这一故障时间成本高达是高昂的。此外，例如，为了将数据从一家厂商的存储阵列移植到另一家厂商的存储阵列，您可能需要获得专业化服务而这些服务的需要额外的费用。

V7000设计帮助客户避免让存储设备离线。V7000的数据移植功能支持在移植数据和更 改存储基础设施的同时连续存取数据。为应用程序提供的数据的连续可用性可以帮助您避免故障时间成本以及造成的影响。此外， V7000可以与IBM TotalStorage Productivity Center合作，帮助自动向应用程序分配更多的容量，从而实现业务的不间断运行。

2. V7000帮助降低成本、简化存储环境

V7000可以帮助客户充分利用中端存储设备的成本节约，同时实现企业级存储设备的优势，如果大缓存和高级复制功能。 中端存储设备的成本比企业级存储设备的成本最高低50%，这是一笔很大的投资。另外V7000允许您创建分级的存储类别，为您正在存储的数据类型提供最有效的存储设备。 V7000在整个虚拟化环境中提供企业级存储设备的强大属性。

在许多用户环境中，企业部署了不同类型的存储设备，如EMC、Hitachi或IBM ESS。这些存储设备提供不同的功能，企业不得不采用不同的方法对它们进行分别管理。

为了管理这些不同的系统，企业技术人员需要开发多种技能。此外，企业可能基于其中一种功能来实现自动化。如果它们这样做，它们可能不能在系统之间实现数据移动。因为使用这些数据的应用程序与一台设备的功能密切相关。这将减少企业厂商的可选择性和降低使用存储系统的灵活性。

V7000提供一个位置来管理多个、不同类型的磁盘系统。它还提供一组通用的功能。这些功能以相同的方式工作，与磁盘系统的类型无关。这样，V7000有助于避免固定于一家供应商和简化管理。这两种功能都可以帮助您降低存储成本。

3. V7000帮助企业提高员工生产力

V7000创建一个虚拟化的异构存储环境库。通过对整个存储库进行集中存储管理，V7000可以帮助存储管理员提高生产力。他们只需学习一个界面，而且需要执行的工作更少。这是因为可以在虚拟化存储库中执行工作。这些功能都有助于降低运营成本。

4. V7000帮助企业更有效地利用存储设备

许多企业仅使用25%到50%的存储设备。通过将多个磁盘阵列的存储 容量整合到一个存储设备，V7000旨在帮助企业显著提高存储设备的利用率。存储管理员可以对这台存储设备集中进行管理。无需为每台服务器提供备用存储容量。 更确切的说，多个磁盘阵列拥有在所有服务器中共享的存储容量库。因此，存储容量库可以比较小。


V7000 虚拟化以及数据迁移方式

解答:

V7000加入SAN环境后，用户的SAN就转移到虚拟存储网络中了。所有的磁盘存储设备从各自为政变成由V7000统一分配和管理，V7000可以看成是SAN的一部分。在设备管理上，通过V7000的虚拟卷管理功能，首先将所有的磁盘卷交给V7000管理。管理员根据设备的特性，定义了高性能组设备和低成本设备，并根据服务器的需要创建和分配存储。例如当某个服务器对存储空间的需求发生变化时，V7000可以动态的在多个存储设备直接调配存储空间。如果某台服务器的I/O要求突然提高了，可以动态更换虚拟盘Vdisk所对应的物理设备。例如，某服务器上的Vdisk所原来使用的是“低成本组”的磁盘设备，如果发现性能不够时，可以在不停应用的情况下，透明的将数据转移到“高性能组”。 所有的迁移过程对服务器透明，因此不需要中止应用。按照V7000的功能，将数据整合分为以下几种类型：

1．虚拟化现有的数据

当V7000 完全配置好以后，它又可以将原先磁盘上的卷及数据透明的迁移到其他真正的虚拟卷中，如下图所示：

如图所示，原先磁盘的数据通过V7000的迁移功能可以透明地条带化到真正的虚拟卷中。

2．在同一存储设备中移植数据

当现有存储设备的配置发生变化或需要对其需要整合时，比如磁盘阵列扩容，需要把数据从146G的磁盘移植到建立在300G磁盘上的Vdisk上时，该功能就可以对现有阵列的扩容的同时而不影响应用。

3.替换现有阵列

V7000对用户的SAN虚拟化后，可以根据需要将数据在不同的存储之间进行透明地移植，如将某一组应用的数据从低性能磁盘移植到新购的高性能阵列而不影响应用和生产，如下图所示：

4.V7000虚拟化与非虚拟化共存

在某些情况下，客户希望某些应用的数据不通过V7000虚拟化，直接由原有的SAN提供给主机，V7000可以支持非虚拟化的卷和虚拟化的卷共存。如下图所示：

5．调整存储空间的利用率

如上描述，V7000在支持对虚拟卷进行在线的移植，扩容。同时V7000还支持对虚拟化卷的缩小，如下图所示（但此功能需要主机操作系统卷管理软件的支持。）

通过IBM V7000加入用户系统后，通过上述介绍的V7000数据整合功能，用户可以轻松地根据系统和业务的需要，在新旧存储空间进行数据移植，I/O性能的调配。主要的实施步骤如下：

·现有存储空间的调查，明确目前系统需求。
·新旧存储设备整体规划，数据迁移计划。
·在新旧存储设备之间/不同的存储设备之间/同一存储设备内部进行在线数据移植。

在IBM V7000实施阶段，可以根据用户的具体需求进行数据移植和整合，以及异构存储的远程复制。但数据整合与迁移是一个长期、动态的过程，可以随企业环境、需求的变化而调整。这正是IBM V7000对用户系统虚拟化后给用户带来的优势。

Top


V7000 自动分层存储（EasyTier）应用方式

解答:

Easy Tier能够将常被访问的数据自动迁移到高性能的固态驱动器中，从而提高利用效率。Easy Tier功能运行在细粒度的“子LUN”环境中，能够基于IO模式和驱动器特征将数据片段自动转移到适当级别的驱动器上，无需管理员的进一步互动。Easy Tier还允许您在不中断系统运行的情况下手动调整整个逻辑卷的位置，从而进一步提高灵活性和控制力，允许企业根据应用需求来更加有效地调节系统性能。

Easy Tier允许您轻松省钱地部署SSD。Easy Tier允许您创建混合型存储资源池并且在托管磁盘组群中将存储资源分割成两层，通常是SSD和HDD。此外，Easy Tier也支持其他的分层方法和定义。

找出最繁忙的子LUN数据单元并且将它们自动转移到高性能SSD中。

剩下的数据单元可利用容量更大的低价位驱动器来创造最佳客户价值。

系统可自动监控和管理SSD或HDD托管磁盘组群中的卷，您也可以通过将热点数据块转移到SSD并且将冷点数据块转移到HDD来自动处理它们。


V7000 高级复制功能介绍

解答:

IBM V7000 实现对客户的SAN的虚拟化后，所有的磁盘存储设备从各自为政变成由V7000统一分配和管理，V7000可以看成是SAN的一部分，允许跨来自众多不同供应商的存储系统应用高级复制服务。复制服务是V7000实现异构环境容灾的基础，通过光纤通道，以逻辑卷为基本单位，将本地存储上的数据以统一的形式同步镜像到远端存储设备上，提供一组单一的高级复制服务以帮助进一步简化操作。保证数据的即时性、完整性和系统性能之间的平衡。
IBM V7000目前提供MetroMirror和GlobalMirror两种高级复制功能。异步（Global Mirror）功能的设计目的在于针对业务连续性和灾难恢复提供几乎不受距离限制的长距离异步远程复制能力。在 V7000 中，同步(MetroMirror)和异步可以作为同一项功能实现，以便灵活地实现镜像（远程复制）功能，而且对现有的同步复制用户不再收取任何许可证费用，以帮助降低总成本。

1. MetroMirror/同步复制

来自服务器的更新被写往本地连接的V7000缓存，该系统将数据转发给远地点连接的V7000的缓存。只有当两个V7000集群的缓存都拥有数据的拷贝以后本地系统才会向处理器返回一个I/O完成指示。同步远程拷贝能够在远地点提供最新程度的数据当前值，但应用程序会因等待写I/O操作的完成而被延迟。

MetroMirror/同步复制示意图

2. GlobalMirror/异步复制

在GlobalMirror复制中，来自服务器的更新被写往本地V7000的缓存，该系统立即向服务器返回一个I/O完成指示。更新在很短的一段时间以后被送往一个远程V7000缓存。异步远程拷贝对应用程序性能的影响最小，但远程磁盘系统在数据最新性方面与本地系统相比会有一个延迟。

GlobalMirror/异步复制示意图


V7000是否可以通过iSCSI端口进行远程镜像

解答:

V7000的iSCSI端口不支持远程镜像的功能。

iSCSI在V7000的连接中，只支持到主机端的连接，任何存储间的连接（包含远程镜像及外接存储）只能通过FC端口。


Tape Library

IBM磁带机/磁带库与备份服务器的连接方式

IBM磁带库备份容量评估 (最近更新)

IBM磁带机/磁带库与HBA卡，操作系统等兼容性

TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型? (最近更新)

LTO X 产品的单盘磁带容量, LTO3/4/5传输速率, 及其读写兼容性

IBM 3580和3592磁带机的介绍 (最近更新)

带库中 Path Failover的功能介绍,是必选的吗

TS7610产品介绍

IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

TS7610，TS7650与TS7650G的区别 (最近更新)

LTO5代驱动器，半高和全高的比较 (新增)

LTO5 驱动器新功能Linear Tape File System(LTFS)介绍 (新增)


IBM磁带机/磁带库与备份服务器的连接方式

解答:

磁带机/磁带库与备份服务器的连接取决于磁带机/磁带库的驱动器类型：

1.配置SAS或者SCSI驱动器的磁带机或者磁带库一般与备份服务器直连，并且备份服务器需要配置满足兼容性的SAS卡或者SCSI卡。每个LTO3/LTO4的SAS，SCSI驱动器只能有一个端口与服务器连接，但是每个LTO5的全高SAS驱动器可以有两个端口与服务器，实现冗余(LTO5半高驱动器只有一个端口)；

2.配置光纤驱动器的磁带库则既可与备份服务器直连也可以通过光纤交换机相连，备份服务器需要配置满足兼容性的光纤HBA卡。每个LTO3/LTO4的光纤驱动器只能有一个端口与服务器或者光纤交换机连接，但是LTO5的全高FC驱动器可以有两个端口与服务器或者交换机连接，实现冗余(LTO5半高驱动器只有一个端口)。

参考资料
名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


IBM磁带库备份容量评估

解答:

1.目前TS2900是IBM最低端的磁带库，它共有10个槽位，其中包含一个用来进出磁带的I/O槽位和一个清洗带槽位，剩余的八个槽位是数据带槽位:

a)3572-S3H支持LTO3的驱动器，所能读写的最大磁带容量是LTO3的磁带，LTO3的磁带未压缩容量为400GB，按照2:1压缩比压缩后的容量为800GB，因此理论上3572-S3H所能支持的最大未压缩容量为3.2TB，压缩后的容量为6.4TB，该产品已停产；
b)3572-S4H支持LTO4的驱动器，所能读写的最大磁带容量是LTO4的磁带，LTO4的磁带未压缩容量为800GB，按照2:1压缩比压缩后的容量为1.6TB，因此理论上3572-S4H所能支持的最大未压缩容量为6.4TB，压缩后的容量为12.8TB。
c)3572-S5H支持LTO5的驱动器，所能读写的最大磁带容量是LTO5的磁带，LTO5的磁带未压缩容量为1.5TB，按照2:1压缩比压缩后的容量为3.0TB，因此理论上3572-S5H所能支持的最大未压缩容量为12TB，压缩后的容量为24TB

2.TS3100支持一个全高的驱动器或者两个半高的驱动器，驱动器类型有：LTO3:半高SAS；LTO4:FC/SAS/SCSI；LTO5:FC/SAS，TS3100最大可以支持24个磁带槽位，不能够扩展，其中包括1个I/O槽位，一个清洗带槽位，22个数据带槽位：

驱动器类型 | 最大数据带槽位数 | 最大未压缩容量 | 最大压缩容量 (2:1压缩)
LTO3 | 22 | 8.8TB | 17.6TB
LTO4 | 22 | 17.6TB | 35.2TB
LTO5 | 22 | 33TB | 66 TB

3.TS3200支持两个全高的驱动器或者四个半高的驱动器，驱动器类型有：LTO3:半高SAS；LTO4:FC/SAS/SCSI；LTO5:FC/SAS，TS3200最大可以支持48个磁带槽位，不能够扩展，其中包括3个I/O槽位，一个清洗带槽位，44个数据带槽位：

驱动器类型 | 最大数据带槽位数 | 最大未压缩容量 | 最大压缩容量(2:1压缩)
LTO3 | 44 | 17.6TB | 35.2TB
LTO4 | 44 | 35.2TB | 70.4TB
LTO5 | 44 | 66TB | 132TB

4.TS3310使用LTO3/LTO4/LTO5光纤磁带驱动器，是一个可以扩展的磁带库，其最大可以支持四个E9U扩展柜，最大可支持18个驱动器，409个磁带槽位，6-54个I/O槽位，其最大备份容量可概括如下：

数据带槽位 (L5B+4E9U) | I/O槽位 | 最大未压缩容量 | 最大压缩容量 2:1压缩比
403 | 6 | 604.5TB (LTO5) 322.4TB (LTO4) 161.2TB (LTO3) | 1209 TB (LTO5) 644.8TB (LTO4) 322.4TB (LTO3)
397 | 12 | 595.5TB (LTO5) 317.6TB (LTO4) 158.8TB (LTO3) | 1191 TB (LTO5) 635.2TB (LTO4) 317.6TB (LTO3)
391 | 18 | 586.5TB(LTO5) 312.8TB (LTO4) 156.4TB (LTO3) | 1173 TB (LTO5) 625.6TB (LTO4) 312.8TB (LTO3)
385 | 24 | 577.5TB(LTO5) 308TB (LTO4) 154TB (LTO3) | 1155TB(LTO5) 616TB (LTO4) 308TB (LTO3)
379 | 30 | 568.5TB(LTO5) 303.2TB (LTO4) 151.6TB (LTO3) | 1137TB(LTO5) 606.4TB (LTO4) 303.2TB (LTO3)
373 | 36 | 559.5TB(LTO5) 298.4TB (LTO4) 149.2TB (LTO3) | 1119TB(LTO5) 596.8TB (LTO4) 298.4TB (LTO3)
367 | 42 | 550.5TB(LTO5) 293.6TB (LTO4) 146.8TB (LTO3) | 1101TB (LTO5) 587.2TB (LTO4) 293.6TB (LTO3)
361 | 48 | 541.5TB(LTO5) 288.8TB (LTO4) 144.4TB (LTO3) | 1083TB (LTO5) 577.6TB (LTO4) 288.8TB (LTO3)
355 | 54 | 532.5TB(LTO5) 284TB (LTO4) 142TB (LTO3) | 1065TB(LTO5) 568TB(LTO4) 284TB(LTO3)

5.TS3500使用LTO和IBM 3592的磁带驱动器，支持高度可扩展的自动数据保留，可显著提高地面空间的利用率并降低成本，为大型机和开放系统提供了高度可扩展的自动化磁带库，可用于中端环境到企业级环境中进行备份和归档，其最大备份容量如下：

型号 | 驱动器类型 | 最大槽位数 | 最大未压缩容量 | 最大压缩容量
L53+D53 | LTO | 6887(L53+15×D53) | 10330TB(LTO5) 5509TB (LTO4) 2754TB (LTO3) | 20660TB(LTO5) 11018TB(LTO4) 5509TB (LTO3)
L23+D23 | 3592 | 6260(L23+15×D23) | 6260TB(TS1130) 4382TB(TS1120) | 18780TB(TS1130) 13146TB(TS1120)
L23+S24 | 3592 | 15110 | 15110TB(TS1130) 10577TB(TS1120) | 45330TB(TS1130) 31731TB(TS1120)
L53+S54 | LTO | 19889 | 29833TB(LTO5) 15911TB(LTO4) 7955TB (LTO3) | 59666TB(LTO5) 31822TB(LTO4) 15910TB(LTO3)

参考资料
名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


IBM磁带机/磁带库与HBA卡，操作系统等兼容性

解答:

1.与磁带机或磁带库相连的服务器上必须配置满足兼容性的SAS卡或SCSI卡或者光纤HBA卡。

2.参考资料：
名称：兼容性列表
链接：ftp://public.dhe.ibm.com/storage/tape/lto_isv_matrix.pdf
SSIC网址：http://www-03.ibm.com/systems/support/storage/config/ssic/displayesssearchwithoutjs.wss?start_over=yes

Top


TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型

解答:

TS2900/TS3100/TS3200/TS3310信息：

磁带库型号
 槽位数 支持的驱动器类型
3572-S3H TS2900（已停产） 最大9
一个IO槽位

Ultrium 3 HH：3 Gbps SAS
3572-S4H TS2900 最大9
一个IO槽位 		Ultrium 4 HH：3 Gbps SAS
3572-S5H TS2900 最大9
一个IO槽位

Ultrium 5 HH：6 Gbps SAS
3573-L2U TS3100 最大24
一个IO槽位

Ultrium 3 LVD SCSI Drive（已停产）
Ultrium 3 Fibre Drive(4Gb)（已停产）
Ultrium 3 Half-high LVD SCSI Tape Drive（已停产）
Ultrium 3 Half-high SAS Tape Drive

Ultrium 4 LVD SCSI Drive
Ultrium 4 Fibre Channel Drive
Ultrium 4 SAS Drive
Ultrium 4 Half-high SAS Drive

Ultrium 5 Fibre Channel Drive(8Gb)
Ultrium 5 Half-high Fibre Channel Drive
Ultrium 5 SAS Drive
Ultrium 5 Half-high SAS Tape Drive
3573-L4U TS3200 最大48
三个IO槽位

Ultrium 3 LVD SCSI Drive（已停产）
Ultrium 3 Fibre Drive(4Gb)（已停产）
Ultrium 3 Half-high LVD SCSI Tape Drive（已停产）
Ultrium 3 Half-high SAS Tape Drive

Ultrium 4 LVD SCSI Tape Drive
Ultrium 4 Fibre Channel Tape Drive
Ultrium 4 SAS Tape Drive
Ultrium 4 Half-high SAS Tape Drive

Ultrium 5 Fibre Channel Drive(8Gb)
Ultrium 5 Half-high Fibre Channel Drive
Ultrium 5 SAS Drive
Ultrium 5 Half-high SAS Tape Drive
3576-L5B 与3576-E9U
TS3310

41到409

6到54个IO槽位(具体信息参看下表)

Ultrium 3 LVD SCSI Drive
Ultrium 3 Fibre Drive(4Gb)

Ultrium 4 SAS Drive
Ultrium 4 Fibre Channel Drive

Ultrium 5 Fibre Channel Drive(8Gb)

TS3310 详细信息：

磁带库配置 | I/O站数量 | 数据带槽位 | 总槽位数量 | 扩展许可数量
5U（L5B） | 6 | 35 | 41 | 没有许可
14U（L5B+E9U） | 6/12/18 | 76/70/64 | 82 | 没有许可
 | 6/12/18 | 127/121/115 | 133 | 一个许可
23U（L5B+2*E9U） | 6/12/18/24/30 | 168/162/156/150/144 | 174 | 一个许可
 | 6/12/18/24/30 | 219/213/207/201/195 | 225 | 两个许可
32U(L5B+3*E9U) | 6/12/18/24/30/36/42 | 258/252/246/240/234/228/222 | 264 | 两个许可
 | 6/12/18/24/30/36/42 | 311/305/299/293/287/281/275 | 317 | 三个许可
41U(L5B+4*E9U) | 6/12/18/24/30/36/42/48/54 | 350/344/338/332/326/320/314/308/302 | 356 | 三个许可
 | 6/12/18/24/30/36/42/48/54 | 403/397/391/385/379/373/367/361/355 | 409 | 四个许可

对于上述磁带库中SAS接口的驱动器，其接口类型都是SFF-8088。目前，SAS 接口类型主要分两种：SFF-8088（MiniSAS）和SFF-8470(SAS)。

通常，在e-config配置中，SAS磁带驱动器对应的线缆选有两种：

一种是MiniSAS/MiniSAS（图1），另一种是SAS/MiniSAS（图2）。

(图一) [image] (图二)

由于在磁带设备端需要用MiniSAS的接头，所以线缆类型的选择取决于主机端SAS HBA卡的接口类型。

目前，在IBM X服务器上常用的SAS卡25R8060是SFF-8088的接口类型，SAS3800X是SFF-8470的接口类型。

参考资料：
书名：《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-05
TS3100 信息：121
TS3200 信息：143
TS3310 信息：169-171
网址: http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


LTO X 产品的单盘磁带容量,LTO3/4/5传输速率,及其读写兼容性.

解答:

LTO 3： (已停产)
容量：400GB(800GB 使用2:1压缩比) 传输速率：80MB/s
LTO 4：
容量：800GB(1600GB 使用2:1压缩比) 传输速率：120MB/s
LTO 5：
容量：1.5TB(3TB 使用2:1压缩比) 传输速率：140MB/s

读写兼容性:
LTO 5代驱动器读写LTO 4代的磁带，传输速率为120MB/s；只读LTO 3代磁带，传输速率为80MB/s；不支持LTO 2代磁带。
LTO 4代驱动器读写LTO 3代的磁带，传输速率为80MB/s；只读LTO 2代磁带，传输速率为35MB/s；不支持LTO 1代磁带。
LTO 3代驱动器读写LTO 2代的磁带，传输速率为35MB/s；只读LTO 1代磁带，传输速率为20MB/s；不支持LTO 4/5代磁带。

参考资料：
书名：《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-05
网址:http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


IBM 3580和3592磁带机的介绍

解答:

目前IBM用于开放平台的外置磁带机主要有两种3580磁带机和3592磁带机，其中3580磁带机采用的是LTO的技术，其可支持的磁带类型有LTO3的400GB（压缩后可达800GB），LTO4的磁带800GB（压缩后可达1.6TB），最大可以支持LTO5 1.5TB 数据磁带，存储容量可高达3TB，其传输速率可分别为80MBps/120MBps/140MBps；3592磁带机则是采用IBM专有的技术与普通的LTO磁带机并不兼容，主要体现在高容量，高性能以及存储关键数据的高可用性方面，其磁带的规格以及驱动器的传输速率与LTO的规格也不同。

1.3580磁带机根据驱动器类型以及高度不同，目前主要有以下几个型号：

a)3580-H3V(TS2230)V2：这款磁带机使用的是LTO 3的半高SAS驱动器 （采用的是6Gbps的双端口SAS驱动器），最大传输速率为80MB/s；

b)3580-H4V(TS2240)V2：这款磁带机使用的是LTO 4的全高SAS驱动器 （采用的是6Gbps的双端口SAS驱动器），最大传输速率为120MB/s；

c)3580-H5S(TS2250)：这款磁带机使用的是LTO 5的半高SAS驱动器（采用的是6Gbps的双端口SAS驱动器），最大传输速率为140MB/s；

d)3580-L43(TS2340)：这款磁带机使用的是LTO 4的SCSI全高驱动器(SCSI接口速率为3Gbps)，最大传输速率为120MB/s；

e)3580-S53(TS2350): 这款磁带机使用的是LTO 5的SAS全高驱动器（采用的是6Gbps的双端口SAS驱动器），最大传输速率为140MB/s。

2.3592的磁带机有两种型号3592-E05(TS1120)和3592-E06(TS1130)：

a)TS1120(3592-E05)是IBM推出的第二代3592磁带机,TS1120可支持单盘磁带容量300GB,500GB或700GB（采用3:1压缩比可达300GB,1.5TB或2.1TB的容量），采用4Gbps的光纤端口连接，传输速率可达100MB/s；

b)TS1130(3592-E06)是第三代的3592磁带机，可支持128GB,640GB或1TB（采用3:1压缩比可达384GB,1.9TB或3TB的容量）的单盘磁带容量，同样采用4Gbps的光纤端口连接，传输速率可达160MB/s。

参考资料：
a)名称：3580 销售手册 （Sales Manual）
b)名称：3592 销售手册 （Sales Manual）

Top


带库中 Path Failover的功能介绍,是必选的吗

解答：

Path Failover提供控制链路和数据链路的冗余。

控制链路的冗余是指，当主机中HBA卡或者带库中磁带驱动器发生故障时，在不中断当前业务的同时自动切换到另一条链路。

数据链路的冗余是指，在SAN环境中，配置多个环节的冗余设置，当通路故障时，切换当前应用至冗余通路，并提供对故障的校验及恢复。

Path Failover，只有在TS3100以上的磁带库中有，非必选选项，根据客户需要定购，在配置大于两个驱动器，或者多条链路的情况下，推荐配置fc#1682。

参考资料：
书名:《IBM System Storage TS3310 Tape Library Setup and Operator Guide》
书号：GA32-0477
链接：http://publibfp.dhe.ibm.com/epubs/pdf/a3204778.pdf

书名:《IBM System Storage TS3100/TS3200 Tape Library Setup and Operator Guide》
书号：GA32-0545
链接：http://publibfp.boulder.ibm.com/epubs/pdf/15103625.pdf

书名:《IBM Tape Device Drivers Installation and User’s Guide》 (文档较大，请下载完以后阅读)
书号：GC27-2130
链接：ftp://ftp.software.ibm.com/storage/devdrvr/Doc/IBM_Tape_Driver_IUG.pdf

书名:《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-06
链接：http://www.redbooks.ibm.com/abstracts/sg245946.html

突出价值点：控制路径的切换功能不需要停止现有的操作进程，光纤和SAS接口的全高驱动器在AIX, Linux, Solaris, HP-UX, 和 Windows操作平台上都支持这个功能，如果使用IBM的磁带驱动器，例如：TS1120，TS1130，那么都支持这个功能。
数据路径的切换功能支持使用IBM的光纤LTO3或LTO4的驱动器的带库，支持平台有AIX, Linux, Solaris, HP-UX, 和 Windows，这个功能使得客户能够灵活的配置SAN架构，同时提供了高可用性和有效的管理。


TS7610产品介绍

解答:

1.TS7610是IBM最新推出的一款低端的虚拟带库，针对中型企业需要用于数据保护的更全面方案而设计，TS7610充分利用独特的重复数据删除技术提高了容量需求，以及可靠性和可用性。

2.TS7610可以选择两种容量配置4.4TB（4TiB）和5.9TB（5.4TiB），其硬件组成主要是一个四核2.33GHz的Intel Xeon处理器，24GB的缓存，12块1TB的SATA硬盘，一块双端口的4Gbps光纤HBA卡。虚拟能力：TS7610能虚拟4个TS3500磁带库，64个LTO3虚拟驱动器，8192个虚拟磁带槽位。

3.TS7610支持重复数据删除功能，其重复数据删除比率可达25:1，能实现的备份速率为85MB/s，TS7610适用于每周数据备份少于3TB。

4.2010年11月IBM TS7610推出了一个新功能-OST(OpenStorage)的功能，此功能将IBM TS7610与赛门铁克的NetBackup有效结合，将数据直接备份到磁盘，而不需要TS7610做磁带库虚拟仿真，可以让用于有效的在站点之间将备份数据备份到磁盘上，同时结合了TS7610的重复数据删除的功能，将磁盘利用最大化，此外也可以利用TS7610的远程复制功能实现最多12站点之间的复制，从而降低了带宽提高了性能。但是TS7610中虚拟磁带库(VTL)与OST只能配置一种，不可同时存在。

参考资料：

Data Sheet 链接：ftp://public.dhe.ibm.com/common/ssi/ecm/en/tsd03107usen/TSD03107USEN.PDF

Sales Manual链接：TS7610销售手册链接

红皮书链接：http://www.redbooks.ibm.com/redpieces/pdfs/sg247652.pdf


IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

解答：

作为重复数据删除解决方案方面的佼佼者，IBM TS7650 一直受到财富500强企业数据中心的青睐，如今全球已经有多家公司部署了该解决方案，其具体的优势为：

1.超级基于磁盘的数据保护
更高的扩展能力——能够为每个存储系统提供多达1PB的存储容量，即可以提供超过25PB的存储能力；
更有效的性价比——可减少高达25倍的存储需求。

2.高性能的持续重复数据删除
每节点 450MB/s 的在线处理能力，双节点集群高达900 MB/s 的在线处理能力。

3.强大的连续性
在线重复数据删除减少了对操作的影响降低了宕机的风险；
方案很好地集成了现有的备份环境和存储架构。

4.确保了数据完整性
通过逐位数据比对，彻底消除了由于“哈希冲突”等原因所造成的数据误删除。

5.出色的远程复制优势
有效地减少了 WAN 中的带宽；
能够使用“跨数据中心” 的存储并减少磁带的运输；
为灾难恢复提供了一种更快更高效的方式。

重复数据删除解决方案给客户带来的价值：

1.提高服务
TS7650 产品解决方案可以高速、高效地满足企业现有的业务应用、策略和法规的需求，保证了企业的业务连续性。

2.管理风险
IBM TS7650 采用在线重复数据删除方法，进行实时地重复数据删除，这样，当数据写入磁盘时已经进行了重复数据删除操作，从而降低了宕机的风险保证了业务的连续性；
IBM TS7650 解决方案将能够为每个存储系统提供多达 1PB 的存储容量，即可以保存超过 25PB 的用户数据，从而有效地避免了孤岛存储空间的出现；
IBM TS7650 选择了一种模式识别的算法来查找和处理数据冗余，从而降低了大型环境中数据丢失的风险，保证了数据的完整性。

3.降低成本
通过 IBM TS7650 重复数据删除解决方案，您可以减少多达25倍的存储容量需求，并提高存储的利用率，从而有效地帮助您控制IT方面的预算；
通过减少操作中的磁盘容量，您亦有效地降低了企业的IT能源能耗。

突出价值点：
能够在大幅降低基础架构成本的同时，满足企业数据中心基于磁盘的数据保护需求。
该解决方案提供了行业领先的联机重复数据删除性能和每个系统高达 1PB 物理存储容量的可扩展性，可提供高达 25PB 的存储容量。
再结合 IBM 存储，ProtecTIER Gateway 解决方案可提供强大的基于磁盘的存储库，从而改善备份与归档数据的保留和可用性。
TS7650G 结合了虚拟磁带库解决方案与 IBM 获得专利的 HyperFactor 技术所实现的联机重复数据删除功能。 该技术可以在磁盘需求和成本方面实现大幅节省。

Top


TS7610,TS7650 TS7650G的区别

TS7610，TS7650与TS7650G的区别

解答:

TS7610是一款入门级虚拟带库，而TS7650和TS7650G则是IBM的高端虚拟带库。

TS7610（3959-SM1）是IBM新推出的一款入门级虚拟带库，它主要针对中小型企业的快速备份需求，TS7610的基本单元是由一个四核2.33GHZ主频的Intel Xeon处理器，24GB缓存,12块1TB的SATA硬盘和一块双端口的4Gbps的光纤HBA卡组成。TS7610可以提供两种容量配置4.4TB（4TiB）和5.9TB（5.4TiB），可以虚拟4个TS3500磁带库，64个LTO3虚拟驱动器，8192个虚拟磁带槽位,最大可支持25:1的重复数据删除比率。

TS7650（3958-AP1）基本单元是一台 x3850 M2 服务器，16核处理器，2.27GHz主频，32GB内存，其后端默认配置的是DS4700的盘阵内置450GB的光纤硬盘。TS7650根据后端存储控制器和扩展柜的不同组合方式会有三种容量选择，分别是7TB,18TB,36TB,36TB（cluster），这三种容量都是做完RAID之后的可用容量。TS7650所支持的备份速率每节点可达500MB/s，最大可支持25:1的重复数据删除比率，最大可支持12个虚拟带库，256个虚拟驱动器，128,000个虚拟槽位。

TS7650G（3958-DD4）这是一款网关产品，基本单元是一台x3850 X5的服务器，32核处理器，2.27Ghz主频，64GB内存。其后端可接从低端到高端以及第三方的满足产品兼容性的磁盘存储，最大支持的容量可达到1PB，所支持的备份速率每节点可达500MB/s（双节点cluster配置可达1000MB/s），最大可支持25:1的重复数据删除比率，最大可支持16个虚拟带库，256个虚拟驱动器，512,000个虚拟槽位。

参考资料：

TS7610 销售手册链接

TS7650 销售手册链接

TS7650G 销售手册链接


LTO5代驱动器，半高和全高的比较

解答:

1.LTO5代驱动器的传输速度为140MB/sec，包括全高驱动器（FH）和半高驱动器（HH）

2.性能参数：

最大磁带速度 (查询)(m/s:米/秒) 10 FH / 6.4 HH
最大磁带速度 (倒带)(m/s：米/秒) 10 FH / 6.4 HH
磁带转动速度 (m/s2：米/二次方秒) 10 FH / 5.0 HH
平均文件存取 (s：秒) 49 FH / 72.0 HH
缓冲 (MB) 512 FH / 256 HH


LTO5 驱动器新功能Linear Tape File System(LTFS)介绍

解答:

1.LTO5引入了分区的概念。LTO-5支持两个磁带介质分区，确切地说，一盘磁带内的介质可以分成一个索引分区（Index Partition）和一个数据分区（Data Partition），从而实现线性磁带文件系统（Linear Tape File System，LTFS），提供从磁带直接管理文件的功能，LTFS能够直接将文件写入到磁带介质中，而不需要专门的应用。两个分区能够独立访问，索引分区的容量很小，用来保存文件的索引和目录结构，文件本身保存在数据分区上。配备LTO5驱动器的磁带库或者磁带机，只需安装一个类似驱动程序的软件，就可以直接看到采用LTFS的LTO5磁带上的文件和目录。LTFS现在可以用在Linux或者Mac系统上。由于LTFS支持文件和目录浏览，捕捉系统或编辑系统也可直接在LTO5磁带上做简单的编辑，而不一定要把数据转移到硬盘上或者读取整个磁带，Linear Tape File System (LTFS)规范能够实现更好的文件控制和空间管理。LTFS主要是一项软件功能，但是要以介质分区这项硬件功能作为基础。LTO-4无法“升级”支持LTFS功能

目前LTFS支持的操作系统只有Linux和Mac

2.参考资料

红皮书：http://www.redbooks.ibm.com/redpieces/pdfs/sg245946.pdf
章节 ：第四章
页数 ：P137


N series 常见问题

N series

N series 产品的基本技术概念 (最近更新)

SONAS产品简介

N series常用软件功能的介绍

N series产品的尺寸、重量与功率 (最近更新)

N series支持的最大硬盘、扩展柜的数量 (最近更新)

N3400与N3300,N3600参数对比

N series CPU、缓存信息 (最近更新)

N3000系列的接口类型、功能与数量 (最近更新)

N6040/N6060/N6070三种型号的区别

N6210与N6240型号区别 (新增)


N series 产品的基本技术概念

解答:

N series中的RAID概念

N series支持RAID 4 和 RAID DP两个RAID 级别。

RAID 4和RAID DP之间最大的区别为: RAID 4在同一RAID组中使用单数据校验盘,而RAID DP在同一RAID组中使用双奇偶校验RAID技术，可防止RAID组中任意两块硬盘故障失效，性能几乎毫无影响。

这两种RAID方式的校验数据都是存放在某块（些）盘上的，由于每次的写操作都涉及校验数据的更新，于是校验盘很容易成为整个磁盘系统的瓶颈，但是N系列产品将WAFL文件系统和RAID4或者RAID-DP结合起来解决了这个问题。

这里以RAID4为例：传统的文件系统：由于数据需要写到已经预先分配好的空间去，并没有进行任何的优化，导致数据可能是写到不同盘片的不同轨道。采用了WAFL的RAID4：由于数据没有预先分配位置，而是通过一定的算法进行优化，将数据写到最近的可用的空余磁道，于是使得我们的数据尽可能写在不同盘片的同一个轨道上，这样磁头就不需要在多个轨道之间移动，大大提高了校验盘的写的性能。

N series中的RAID group size

RAID group size是指一个RAID组中支持物理硬盘的最大数量。

RAID 4 group size的要求如下：

对于FC或SAS硬盘，最少2块盘，缺省8块盘，最大14块盘。
对于SATA硬盘，最少2块盘，缺省7块盘，最大7块盘。

RAID-DP group size的要求如下：

对于FC或SAS硬盘，最少3块盘，缺省16块盘，最大28块盘。
对于SATA硬盘，最少3块盘，缺省14块盘，最大16块盘。

N series中的Aggregates 和 Volumes（注意：以下限制仅适用于Data ONTAP 7.3版本）

由一个或多个RAID组（RAID group）组成的Aggregate可以划分为一个或多个Volume。

对于一个N series系统：
最多支持400个RAID group；
最多支持aggregate数目:100；
最大支持aggregate size: 16TB；
最小支持aggregate size：10GB；
一个aggregate中支持最大的RAID Group数目：150；
最小支持FlexVolume size是20MB；
最大支持FlexVolume size是16TB；
最多支持volume数目是200。

N series在Data ONTAP操作系统中 完成 local file system writes, 分为以下6步：

1. Data ONTAP接收到一个 来自host的write 请求，类型可以是 NFS 或 Common Internet File System (CIFS),或FCP 或 iSCSI。
2. 把该请求的data write到non-volatile memory (NVRAM), NVRAM 有电池保护。同时在Cache memory中也会write一份data。Cache memory写的速度会快于NVRAM。
3. 把write成功的反馈给host，host马上继续下一个I/O操作。
4. 稍后，当NVRAM的空间占用超过1/2，或最近一次 consistency point (CP)完成后的时间超过10秒，新的一次的CP会被触发。
5. 从Cache memory中write data到RAID Software。
6. RAID software writes data 到disk上，当write完成，则本次CP即告完成。

N series Gateway（网关）与 N series Filer（文件存储）的区别

N系列N6000以上有两种产品：网关(NAS gateway)与文件存储(NAS Filer)。
从配置上看对于N系列网关，其后端既能接满足产品兼容性的存储盘阵，又可以接其自身扩展柜，而N系列文件存储的后端接的是其自身的扩展柜，不能接其他存储
从功能上看N系列网关是一种基于网络的统一存储整合解决方案，旨在为连接有多种类型存储阵列的SAN提供互联网协议（IP）和光纤通道（FC）协议访问方法，N系列网关提供了创新式的数据管理功能，实现了数据共享访问，数据保护和企业级用户关键数据的恢复，以及能够与企业级SAN架构的无缝隙融合。N 系列网关产品支持连接到IBM Enterprise Storage Server（ESS） 系列、IBM XIV Storage System、IBM System Storage DS8000和 DS4000系列；以及各种 EMC、Hitachi、Fujitsu、3PAR 和 HP 存储子系统。
N系列文件存储后端可以按照客户不同的容量需求接不容类型及数量的扩展柜，既能作为普通SAN盘阵实现块级数据访问又能作为文件存储实现网络共享访问。

N series产品NAS和SAN功能的区别与配置方法

首先，NAS指的是Network Attached Storage，即网络附属存储，而SAN指的是Storage Area Network，即存储区域网络。严格来讲，一个是存储，一个是网络，它们是两种不同的概念，所以这里我们指的是N series产品采用NAS相关的CIFS、NFS协议存取数据与采用SAN相关的FCP、iSCSI协议存取数据的区别

存储方式 | SAN |  | NAS
全称 | Storage Area Network |  | Network Attached Storage
支持协议 | FCP | iSCSI | CIFS | NFS
与主机连接方式 | FC SAN | IP网络 | IP网络 | IP网络
数据存储方式 | 块级别 |  | 文件级别
文件系统 | 本身不包含文件系统， 需要由使用的操作系统创建 |  | 包含文件系统
共享访问 | 协议本身不支持，需要主机端 使用集群或并行文件系统软件 |  | 协议本身支持共享访问
支持的操作系统 | 支持大部分主流企业级操作系统 |  | Windows和支持 CIFS协议的操作系统 | Unix/Linux以及 支持NFS协议的操作系统

参考资料：
书名:《IBM System Storage N series》
书号：SG24-7129-00
页码：84-90
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247129.pdf

Top


SONAS产品简介

解答:

SONAS是IBM新推出的云存储，支持NAS文件共享协议CIFS，NFS，HTTPs，FTP等。SONAS包含管理节点（Managment Node)，存储节点(Storage Node)，接口节点(Interface Node)，每个节点上安装了GPFS文件系统的软件。SONAS最大支持30个接口节点和60个存储节点，实现最大容量为14.4PB。

IBM SONAS 提供以下特性来满足数据扩展、数据可用性和灵活性需求：

1. 通过使用 15 个磁盘存储扩展机架，可以扩展至高达 14.4 PB 的容量。

2. 允许在单一全局命名空间下轻松、灵活的数据访问，从而能通过单一驱动器盘符（如：Z盘）向所有用户提供单一的文件逻辑视图。

3. 分层存储用于高度可用的重要数据，辅助存储用于较少访问的数据。

4. 支持行业标准协议：CIFS、NFS、HTTP、FTP 和 SCP。

5. 通过冗余的热插拔组件和故障转移实现高度可用性。

IBM SONAS 利用高性能引擎高速扫描极大规模的文件系统。SONAS的先进架构能将您的文件空间虚拟化并整合为单一的、涵盖整个企业的文件系统，从而降低您的总体拥有成本。通过采用 SONAS来整合和管理企业数据，能够避免管理大量分散存储系统时经常出现的问题。SONAS高度可扩展，可以帮助节省空间，从而降低您的资本支出并提高您的运营效率。

图示：SONAS的先进架构将文件空间虚拟化并整合为单一的、涵盖整个企业的文件系统

集中管理、集中部署


N series常用软件功能的介绍

解答:

以下软件许可一般随N series产品自动配置

1.Data ONTAP：N series的操作系统，是必选选件。

2.CFO：即Cluster Failover，在双节点的N series中实现两个节点的故障切换，对于双节点的N series是必选选件，单节点N series无法配置。

3.NearStore：实现近线存储功能，是实现重复数据删除功能（Deduplication）的前提条件，非必选选件，但一般会随e-config自动配置出来。

4.Deduplication：实现重复数据删除功能，需要配合NearStore使用。

以下软件许可需要根据需要进行配置：

1.如果NAS的客户端使用Windows系统,则网络共享许可为CIFS。
如果客户端使用Linux/Unix系统,则网络共享许可为NFS。
如果客户端既有使用Windows系统的又有使用Linux / Unix系统,则网络共享许可需要同时配置CIFS 和NFS。

2.如果使用光纤通道协议(FCP)与主机连接,即该存储与主机以光纤SAN方式连接 则需要配置FCP等相关协议。

3.如果使用iSCSI协议与主机连接,即该存储与主机以IP SAN方式连接 则需要配置iSCSI等相关协议。

4.SnapMirror 可通过FC和IP传输方式实现同步，半同步和异步的异地数据同步。通过在LAN或WAN上高速复制数据，可实现远程容灾和数据分布，为关键应用程序提供最高的数据可用性和最快的恢复速度。

5.SnapRestore 可从SnapShot中在几秒内恢复任意容量的单卷数据，也可恢复单独的文件和目录。

6.SnapShot 秒级瞬间文件系统在线只读的零拷贝模式快照技术，不占用额外空间除非原始数据被更改或删除。每个卷可有255份快照以防止逻辑人为错误，用户可自行访问任意时间点快照进行恢复而不需系统管理员协助。该功能是免费提供的。

7.FlexClone 由于SnapShot创建的快照卷本身是只读的，如果对其进行写操作，我们可以通过FlexClone基于一个SnapShot卷创建一个Clone卷，然后再对Clone卷进行测试或开发等操作，甚至当需要完整保留该卷时，可以将FlexClone卷与源卷分离。

8.SnapLock 以磁盘为基础的高性能WORM（一次写入，多次读出）存储解决方案，在介质上数据仅能被写入一次，永不能被覆盖或改写。SnapLock不同配置能使数据在严格受控或灵活受控环境下应用，如法规遵从，数据可永久或在指定时期以不可擦除，不可重写的状态保存。

参考资料：
书名:《IBM System Storage N series Software Guide》
书号：SG24-7129
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg247129.pdf

Top


N series产品的尺寸、重量与功率

解答：

N series 型号 | 高(mm) | 宽(mm) | 深(mm) | 最大重量(Kg) |  |  | 最大功率(Watts)
 |  |  |  | Model A10 | Model A20 | 每个SAS硬盘
N3300 | 87.5 mm (3.45 in) | 446 mm (17.6 in) | 569 mm (22.4 in) | 19.5 kg (43.0 lb) | 21.5kg (47.4 lb) | 0.8kg (1.8 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3400 | 88.5 mm (3.5 in) | 446 mm (17.6 in) | 569 mm (22.4 in) | 19.5 kg (43.0 lb)-Model A11 | 21.5 kg (47.4 lb)-Model A21 | 每个SAS硬盘 0.8 kg (1.8 lb) 每个SATA硬盘 0.65 kg (1.4 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3600 | 175 mm (6.89 in) | 446 mm (17.6 in) | 582 mm (23 in) | 32.6 kg (71.9 lb) | 35.3 kg (77.8 lb) | 0.8 kg (1.8 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3700 | 133 mm (5.25 in) | 447 mm (17.6 in) | 508 mm (20.0 in) | 35.8 kg (78.8 lb) |  |  | 72GB 10K FC硬盘 | 72GB 15K FC硬盘 | 144GB 10K FC硬盘 | 144GB 15K FC硬盘 | 300GB 10K FC硬盘 | 300GB 15K FC硬盘
 |  |  |  |  |  |  | 389 watts | 371 watts | 389 watts | 394 watts | 389 watts | 389 watts
N5200 | 130 mm (5.13 in) | 449 mm (17.7 in) | 618 mm (24.3 in) | 34.0 kg (75.0 lb) | 68.0 kg (150.0 lb) | - | 329 watts
N5300 | 130 mm (5.12 in) | 449 mm (17.7 in) | 762 mm (30 in)/含线缆管理托 610 mm (24 in) 不含线缆管理托架 | 34 kg (75 lb) |  |  | 358 watts
N5500 | 130 mm (5.13 in) | 449 mm (17.7 in) | 518 mm (24.3 in) | 34.0 kg (75.0 lb) | 68.0 kg (150.0 lb) | - | 384 watts
N5600 | 130 mm (5.12 in) | 449 mm (17.7 in) | 762 mm (30 in)/含线缆管理托 610 mm (24 in) 不含线缆管理托架 | 34 kg (75 lb) |  |  | 387watts
N6040 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.4 kg (97.8 lb) - Model A10 | 52.2 kg (115 lb) - Model A20 | - | 385 watts （200 to 240V） - Model A10 712 watts （200 to 240V） - Model A20
N6060 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.8 kg (98.8 lb) - Model A12 | 53.1 kg (117 lb) - Model A22 | - | 460 watts （200 to 240V） - Model A12 860 watts （200 to 240V） - Model A22
N6070 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.9 kg (99 lb) - Model A11 | 53.2 kg (117.3 lb) - Model A21 | - | 493 watts （200 to 240V） - Model A11 930 watts （200 to 240V） - Model A21
N6210 | 130 mm (5.12 in) | 447 mm (17.6 in) | 713 mm (28.1 in.) 含线缆管理托架 655 mm (25.8 in.) 不含线缆管理托架 | 29.7 kg (65.4 lb) - Model C10 34.6 kg (76.2 lb) - Model C20 |  |  | 411 watts （200 to 240V） - Model C10 610 watts （200 to 240V） - Model C20
N6240 | 130 mm (5.12 in) - C21 E11 260 mm (10.24 in) - E21 | 447 mm (17.6 in) | 713 mm (28.1 in) 含线缆管理托架 655 mm (25.8 in) 不含线缆管理托架 | 34.6 kg (76.2 lb) - Model C21 32.9 kg (72.6 lb) - Model E11 65.9 kg (145.2 lb) - Model E21 |  |  | 618 watts （200 to 240V） - Model C21 487 watts （200 to 240V） - Model E11 974 watts （200 to 240V） - Model E21
N7600 | 263 mm (10.4 in) | 446 mm (17.6 in) | 782 mm (30.8 in) 含线缆管理托 695 mm (27.4 in) 不含线缆管理托架 | 54.8 kg (121 lb) |  |  | 935 watts
N7800 | 263 mm (10.4 in) | 446 mm (17.6 in) | 782 mm (30.8 in)/含线缆管理托 695 mm (27.4 in) 不含线缆管理托架 | 54.8 kg (121 lb) |  |  | 935 watts

参考资料
查阅IBM销售手册：Storage System 销售手册查询

IBM System Storage N5200, N5300, N5500, and N5600 Series Hardware and Service Guide
http：//publibfp.boulder.ibm.com/epubs/pdf/c2677855.pdf

IBM System Storage N7600 and N7800 Hardware and Service Guide
http：//publibfp.boulder.ibm.com/epubs/pdf/c2679530.pdf

IBM System Storage N6000 Series Hardware and Service Guide
http：//www-01.ibm.com/support/docview.wss?uid=ssg1S7002553


N series 支持的最大硬盘、扩展柜的数量

解答：

型号 | 最大硬盘 | 最大物理容量 | 扩展柜的数量 | 扩展柜类型 | 硬盘类型
N3300 | 68 | 136TB | 4 | EXN1000 EXN4000 | SAS SATA FC
N3400 | 136 | 272TB | 6 | EXN1000 EXN3000 EXN4000 | SAS SATA FC
N3600 | 104 | 188TB | 6 |  | SAS SATA FC
N6040 | 420 | 840TB | 30 |  | SAS SATA FC
N6060 | 672 | 1344TB | 48 |  | SAS SATA FC
N6070 | 840 | 1680TB | 60 |  | SAS SATA FC
N6210 | 240 | 480TB | 20 |  | SAS SATA FC
N6240 | 600 | 1200TB | 42 |  | SAS SATA FC
N7900 | 1176 | 2352TB | 84 |  | SAS SATA FC

注意：所有最大容量详细信息，请参考销售手册。

突出价值点：N系列产品目前支持的扩展柜有 EXN1000,EXN3000,EXN4000 通过支持SATA、SAS、FC盘，客户可以根据性能和价格需求合理选择。

Top


N3400与N3300,N3600参数对比

解答:

N3400是IBM新一代N series产品，支持更多的CPU,内存，性能较之N3600提高了2倍，并且具有30％容量提升。N3400集成的SAS端口可以连接EXN3000磁盘扩展柜。所有最大容量详细信息，请参考销售手册。

N3400与N3300,N3600参数对比如下：

 | N3300 | N3400 | N3600
处理器类型 | 2X32-bit Single Core | 2X32-bit Dual Core | 2X32-bit Single Core
处理器核数 | 2 | 4 | 2
缓存 | 2GB | 8GB | 4GB
扩展槽位数 | - | - | 2
板载端口数量和类型 | 4FC 4GbE | 4FC 8GbE 2SAS | 4FC 4GbE
管理端口 | BMC Console | SAS ACP BMC Console | BMC Console
最大硬盘数 | 68 | 136 | 104
最大裸容量 | 136TB | 272TB | 188TB
Data ONTAP 支持最高版本 | 7.3.4 | 8.0 | 7.3.4

注意：以上参数是双节点N3000的配置

参考文档
销售手册（Sales Manaual）
1. N3300：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS2859-_h01/index.html
2. N3400：http://www-01.ibm.com/common/ssi/rep_sm/2/872/ENUS2859-_h02/index.html
3. N3600：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS2862-_h01/index.html

Top


N series CPU、缓存信息

解答:

1.N3300、N3400和N3600是N series中入门级产品，它们的CPU和缓存信息如下：

N series 型号 |  | 单/双节点 | CPU型号 | 处理器个数 | 缓存容量 | NVRAM
N3300 | 2859-A10 | 单节点 | Intel 2.2 GHz Celeron | 1 | 1 GB | 128 MB
 | 2859-A20 | 双节点 |  | 2 | 2 GB | 256 MB
N3400 | 2859-A11 | 单节点 | Intel 1.6GHz Dual Core Xeon LV | 2 | 8 GB | 512 MB
 | 2859-A21 | 双节点 |  | 4 | 16 GB | 1 GB
N3600 | 2862-A20 | 双节点 | Intel 2.2 GHz Celeron | 2 | 4 GB | 512 MB

2.N6040、N6060、N6070、N6210、N6240和N7900是N series的中高端产品，它们的CPU和缓存信息如下：

N series 型号 |  | 单/双节点 | CPU型号 | 处理器个数 | 缓存容量 | NVRAM
N6040 | 2858-A10 | 单节点 | AMD 2.4GHz 64bit Dual Core Opteron | 1 | 4 GB | 512 MB
 | 2858-A20 | 双节点 |  | 2 | 8 GB | 1 GB
N6060 | 2858-A22 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 2 | 16 GB | 4 GB
N6070 | 2858-A21 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 4 | 32 GB | 4 GB
N6210 | 2858-C10 | 单节点 | 2.3 GHz Dual core | 1 | 4 GB | 2 GB
 | 2858-C20 | 双节点 |  | 2 | 8 GB | 4 GB
N6240 | 2858-C21 | 双节点 | 2.3 GHz Quad core | 2 | 16 GB | 4 GB
 | 2858-E11 | 单节点 |  | 1 | 8 GB | 2 GB
 | 2858-E21 | 双节点 |  | 2 | 16 GB | 4 GB
N7900 | 2867-A21 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 8 | 64 GB | 4 GB

参考资料：
书名：《IBM System Storage N series Hardware Reference》
书号：REDP-4658
链接：http://www.redbooks.ibm.com/redpapers/pdfs/redp4658.pdf


N3000系列的接口类型、功能与数量

解答:

N3300的接口类型、功能与数量

上图是N3300-A20双节点型号的后视图，总共两个控制器，包括：
1. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：2个，用于本地管理和维护。

N3300-A10是单节点型号，相比N3300-A20少一个控制器，包括：
1. FC光纤端口：2个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：2个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：1个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：1个，用于本地管理和维护。

N3400的接口类型、功能与数量

上图是N3400-A21双节点型号的后视图，总共两个控制器，包括：
1. SAS端口(QSFP)：2个，用于连接EXN3000系列扩展柜；
2. ACP端口(RJ45)：2个，通过以太网实现对EXN3000扩展柜的管理功能；
3. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
4. 千兆以太网端口(RJ45)：8个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
5. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
6. 串行管理端口(RJ45)：2个，用于本地管理和维护。

N3400-A11是单节点型号，相比N3400-A21少一个控制器，包括：
1. SAS端口(QSFP)：1个，用于连接EXN3000系列扩展柜；
2. ACP端口(RJ45)：1个，通过以太网实现对EXN3000扩展柜的管理功能；
3. FC光纤端口：2个，用于FCP主机访问服务或连接扩展柜；
4. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
5. 远程LAN管理端口(RJ45)：1个，用于远程监控、管理和维护；
6. 串行管理端口(RJ45)：1个，用于本地管理和维护。

N3600的接口类型、功能与数量

上图是N3600-A20双节点型号的后视图，总共两个控制器，包括：
1. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：2个，用于本地管理和维护；
5. PCIe扩展插槽：2个，用于扩展端口，包括，千兆、万兆以太网、FC、SAS，FCoE端口等。

Top


N6040/N6060/N6070三种型号的区别

解答：

以下指标为双节点模式下, 最大端口数为主机集成端口与IO扩展卡所包括端口数之和。

 | N6070 | N6060 | N6040
最大裸容量 | 1680TB | 1344TB | 840TB
最大磁盘数量 | 840 | 672 | 420
缓存 | 32GB | 16GB | 8GB
最大缓存 | 160GB | 80GB | 72GB
最大千兆网络端口 | 36 | 36 | 36
万兆网络支持 | Yes | Yes | Yes
最大4Gbps 光纤端口 | 40 | 40 | 40
8Gb光纤端口 | Yes | Yes | Yes
扩展PCI槽位 | 8 | 8 | 8
尺寸 | 6U | 6U | 6U

注意：以上为双节点模式下指标, 最大端口数为主机集成端口与IO扩展卡所包括端口数之和。

Top


N6210与N6240型号区别

解答:

注意：E21是两台E11的组合。

参考文档：
1.N6210与N6240销售手册：http://w3-01.ibm.com/sales/ssi/rep_sm/3/872/ENUS2858-_h03/index.html
2.N6000系列data sheet：http://public.dhe.ibm.com/common/ssi/ecm/en/tsd03062usen/TSD03062USEN.PDF


SAN/Ethernet Switch

B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

B-Type SAN交换机NPIV功能介绍

B24/B40/B80配置中所有License包含的功能

B24、B40、B80三款SAN交换机SFP模块与光纤线的选择

IBM Converged Switch L32 (3758)交换机介绍

2498-E32产品简介 （新增）

IBM DCN 交换机性能参数


B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

解答:

1.2498-B24/B40/B80分别是24/40/80端口的光纤存储交换机。这些交换机上的SFP模块都需要花钱购买，如果购买的SFP模块超过了交换机默认激活的端口数量，就需要购买端口激活的许可。

2.2498-B24默认激活8个端口，端口激活许可是fc#7200，一个fc#7200激活8个端口，最多购买两个fc#7200。默认支持级联。

3.2498-B40默认激活24个端口，端口激活许可是fc#7400，一个fc#7400激活8个端口，最多购买两个fc#7400。默认支持级联。注：e-config中会有一个feature #8S1022,此feature可用在端口全激活的时候，此时只购买一个fc#7400,再选一个fc#8S1022就可以免费激活第二组8端口，但是fc#8S1022这个feature需要过IBM内部RPQ的流程方可配置，若要配置此feature请联系IBM相关销售人员。

4.2498-B80默认激活48个端口，端口激活许可是fc#7800，一个fc#7800激活16个端口，最多购买两个fc#7800。默认支持级联。

以下产品停产或即将停产：

1.2005-B16/B5K/B64分别是16/32/64端口的光纤存储交换机。这些交换机上的SFP模块都需要花钱购买，如果购买的SFP模块超过了交换机总端口数的一半，就需要购买端口激活的许可。

2.2005-B16默认激活8个端口，端口激活许可是fc#7515，一个fc#7515激活4个端口，最多购买两个fc#7515。默认不支持级联，即E_Ports，需要fc#7450 Full Fabric的激活许可，一个Fabric里最多支持10台。

3.2005-B5K默认激活16个端口，端口激活许可是fc#7514，一个fc#7514激活8个端口，最多购买两个fc#7514。默认即支持级联。

4.2005-B64默认激活32个端口，端口激活许可是fc#7520，一个fc#7520激活16个端口，最多购买两个fc#7520。默认即支持级联。

参考资料：

书名：《IBM System Storage SAN24B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002303

书名：《IBM System Storage SAN40B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002302

书名：《IBM System Storage SAN80B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002301

书名：《IBM System Storage SAN16B-2 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001367

书名：《IBM System Storage SAN32B-3 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001748

书名：《IBM System Storage SAN64B-2 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001462

书名：《Implementing an IBM/Brocade SAN with 8 Gbps Directors and Switches》
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246116.pdf

Top


B-Type SAN交换机NPIV功能介绍

解答:

N_Port ID Virtualization (NPIV) 将单个光纤端口虚拟成多个独立的端口，为每个连接到该物理端口的不同类型操作系统提供独立的端口标识（对每个操作系统看起来就像有自己独立的物理端口一样）。NPIV分配一个独立的virtual port ID给每个光纤通道协议设备。它允许你去分配虚拟地址而不影响现有连接和设备。虚拟端口有与N_port相同的属性，因此能够提供Fabric相关的所有服务。

每个NPIV设备有独立的 Device PID, Port WWN, 和 Node WWN，执行同Fabric中其他端口相同的功能。也就是说，NPIV虚拟出的多个virtual devices与连接在非NPIV端口的普通设备无异，zone配置对于NPIV端口和非NPIV端口也没有区别，能够根据domain和port符号，或WWN，或两者兼有的方式划分。对于完全由virtual N_Port ID构成的Zone，必须使用WWN_Zone。

B-tyoe SAN交换机端口的NPIV配置方法如下：

在命令行下使用portCfgNPIVPort 打开和关闭port的NPIV功能。
例如：打开port 10的NPIV功能:
switch:admin>portCfgNPIVPort 10,1


B24/B40/B80配置中所有License包含的功能

B24、B40、B80配置中所有License包含的功能

解答：

B24：

fc#7201 B24 Enterprise Package：包含fc#7202、fc#7204、fc#7205、fc#7206、2×fc#7200
fc#7202 Fabric Watch：交换机运行中状态、性能、安全等监控管理；
fc#7203 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7204 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况
fc#7205 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7206 Adaptive Networking：自动优化网络服务以配合应用数据流，可以通过优先级设定对带宽的使用量；
fc#7200 8-Port Activation：8端口激活许可，B24默认只激活8个端口，通过该许可能够将端口激活到16个或24个。此外激活端口的数量需要和SFP模块的数量相同。

B40：

fc#7401 包含了除fc#7403,fc#7407和fc#7409以外的所有License；
fc#7403 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7404 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；
fc#7405 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7406 Adaptive Networking：自动优化网络服务以配合应用数据流，可以通过优先级设定对带宽的使用量；
fc#7407 Integrated Routing：EX_port激活的License，支持 FC-router功能
fc#7409 FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7400 8端口激活的License。B40默认只激活24个端口，通过该许可能够将端口激活到32个或40个。此外激活端口的数量需要和SFP模块的数量相同。

B80：

fc#7801 包含了除fc#7803,fc#7807和fc#7809以外的所有License；
fc#7803 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7804 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；
fc#7805 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7806 Adaptive Networking：自动优化网络服务以配合应用数据流；
fc#7807 Integrated Routing：EX_port激活的License，支持 FC-router功能；
fc#7809 FICON w/CUP Activation：FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7800 16端口激活的License。B80默认只激活48个端口，通过该许可能够将端口激活到64个或80个。此外激活端口的数量需要和SFP模块的数量相同。

此外，这三款交换机默认支持Fabric级联（ISL）、Advanced Zoning以及NPIV功能，无需购买许可。

突出价值点：IBM SAN Switch B-Type，光纤交换机附带很多功能License以及管理软件，对用户而言，搭载功能License以及管理软件的交换机，可以达到节省成本、简化管理及保护投资等效益功能，可以有效保证用户SAN网络环境的功能性、安全性、易管理性，并可藉此达到整合存储管理工具、提高服务器及存储系统使用效能等功能。

Top


B24、B40、B80三款SAN交换机SFP模块与光纤线的选择

解答:

打开三款交换机的e-Config配置中的Connet页面，可以看到SFP模块和光纤线，其中:

4Gbps/8Gbps：SFP接口速率为4Gb或8Gb；

SW/Short Wave：短波SFP模块，配合多模光纤线，用于短距离内数据传输；

LW/Long Wave：长波SFP模块，配合单模光纤线，用于远距离距离数据传输；

ELW：增强型长波SFP模块，配合单模光纤线，用于10km以上的远距离数据传输；

8-Pack：SFP模块8个一包，可以按包选择；

Fibre Cable multimode：多模光纤，配合SW短波SFP使用；

Fibre Cable siglemode：单模光纤，配合LW长波SFP使用；

OM3 Cable：第三代多模光纤，增加了多模光纤的传输距离，配合SW短波SFP使用；

另外，SFP的数量必须等于默认端口数与激活端口数之和。例如一台B40，默认激活24端口，然后再激活8个端口，那么我们需要订购32个SFP模块。光纤线缆可以根据需要选配，但最多不能超过交换机的端口总数。

以下是B-type各种SFP模块的波长，其中：

4GB 短波SPF：发射波长830-860nm；接收波长770-860nm；

4GB 长波 4KM SFP：发射波长1280-1345nm；接收波长1260-1600nm；

4GB 长波 10KM SFP：发射波长1285-1345nm；接收波长1260-1600nm；

4GB 长波 30KM SFP：发射波长1285-1345nm；接收波长1260-1600nm；

8GB 短波SPF：发射/接收波长840-860nm；

8GB 长波 10KM SFP：发射/接收波长1260-1360nm；

8GB 长波 25KM SFP：发射/接收波长1260-1360nm；

10GB 短波 SFP：发射波长840-860nm；接收波长840-860nm；

10GB 长波 SFP：发射波长1260-1355nm；接收波长1260-1355nm。


IBM Converged Switch L32 (3758)交换机介绍

解答:

3758-L32是一种架顶式FCoE交换机，带有24个用于连接LAN的万兆以太网端口和8个用于连接光纤通道SAN的光纤通道端口（最高速度达8 Gbps）。这种可靠的高性能交换机可提供先进的光纤通道服务并支持CEE功能，由DCFM管理软件进行管理。

3758-L32是一种采用1U机型设计的架顶式FCoE交换机。它带有8个8GB 的光纤通道端口和24个支持万兆以太网功能的Converged Enhanced Ethernet（CEE）端口。CEE端口既可以传输存储流量，又可以传输LAN流量，因此不需要独立的SAN和LAN适配器及线缆。

3758-L32通过融合网络适配器（CNA）连接到服务器。经过整合的SAN和LAN服务器端口及相应的线缆可以简化服务器机柜中的配置和布线，从而降低设备采购成本。这种设计可以帮助减少杂乱的线缆，降低与功耗和冷却相关的运营成本。

由于FCoE可以继续使用光纤通道结构和服务，因此3758-L32可以无缝地集成到现有的光纤通道环境中，帮助企业利用一个统一的管理框架管理与FCoE相连的设备。企业还可以利用Brocade DCFM等功能强大的Fabric管理应用。

光纤通道端口
8个光纤通道通用（E、F、M和FL）端口，速率为1、2、4和8 Gbps
24个万兆以太网端口 (CEE端口)

FcoE特性
完整的T11 FCoE实体和FCoE桥接
硬件引擎中内置的FCoE转换实体可提供：
光纤通道封装的检测和FCoE Fabric架构登录帧的重定向
FCoE以太网数据包中光纤通道帧的封装（FC > FCoE）
光纤通道目的地虚拟Fabric架构和目的地FC_ID到以太网虚拟LAN及目的地MAC地址的映射
Fabric架构提供的MAC地址（FPMA）支持通过Fabric架构分配的FC_ID创建新的以太网MAC地址

CEE特性
数据中心桥接eXchange（DCBX）
基于优先级的流控制（PFC）- IEEE 802.1Qbb
增强传输选择（ETS）– IEEE 802.1Qaz

性能
光纤通道：1、2、4和8 Gbps线速，全双工
CEE：10 Gbps线速

介质类型
光纤通道介质类型：行业标准的小型可热插拔（SFP）和SFP+，LC连接器；短波激光（SWL）和长波激光（LWL）；最大距离取决于光缆和端口速率；支持SFP+（2、4和8 Gbps）及SFP（1、2和4 Gbps）光收发器
CEE介质类型：可热插拔的万兆以太网SFP+可支持短距离（SR）和长距离（LR）光收发器的任何组合；1、3或5米的Twinax铜缆

尺寸
宽：42.9厘米（16.9英寸）
高：4.3厘米（1.7英寸）
深：63.4厘米（25.0英寸）

系统重量
13.0公斤（28.6磅），双电源FRU，无收发器

电源
最大功耗：350瓦
一般功耗：306瓦
输入电压：85 到 264 VAC ，常规
输入线频率：47到63 Hz
冲击电流：最大60安培
最大电流：12V DC时29安培

更多信息请参考：《IBM汇聚交换机B32 安装、服务和用户指南》

Top


3758-B32 FCoE与CEE协议应用介绍

解答:

FCoE并不是要代替传统的光纤通道技术，而是在不同连接传输层上对光纤通道进行拓展。FCoE的价值在于在同样的网络基础体系上用户有权利选择是将整个逻辑网络全部当成传输存储数据与信号的专用局域网，或是作为混合存储数据、信息传送及其它数据传输的共用网络。FCoE是在继续保持用户对光纤通道SAN所期望的高性能和功能性的前提下，将存储传输融入以太网架构。

FCoE的核心在于，能够在为在以太网（CEE）上传输FC的封装协议(Lossless Ethernet: CEE)，因此，FCoE的一个数据帧的组合就显得尤为重要，因此，其至少具有三个特点和需求：

- Fibre Channel数据帧依旧: FC没有任何改变, 使用相同的名称
- Ethernet需要更大的数据帧(Jumbo Frames): 大于1500 bytes
- Ethernet必须变成无丢失的，保证传输完整的存储数据

在FCoE标准应用中，CEE增强型以太网是其中最重要的关联部分。由于FCoE协议需要基于一个网络承载，而显然FCoE的使命，在以太网上传输FC的数据，因此，需要一个拥有FC特性的以太网来服务于FCoE。因此，CEE，增强型以太网是其中最重要的相关部分，传输FCoE存储数据、数据中心应用系统和集群，CEE是一种Lossless的以太网，即无丢失以太网，其能够无损的传输FCoE的数据——FC与以太网的设计在连接上最大的不同：FC一旦连接便肯定100%可用，而以太网只是保证你的连接，而无法保证可用性，也就说，数据无法正常传输，或速率极低，是可以被允许的。在CEE中，改变了这些以太网的弊端。

FCoE所能够带来的显著好处：

- 减少服务器和交换机端口数
- 减少线缆和电力消耗
- 增加链路使用效率
- 使用10Gb CEE，传输速度高
- 增加存储网络连接2/3层应用和虚拟机的数量
- 网络将来降低成本, 更多链接选择


2498-E32产品简介

解答:

1.IBM SAN32B-E4加密交换机是一台32端口的高性能的独立式设备，旨在保护任务关键型环境中的静态数据。该交换机能够提供基于网络的加密服务，可以有选择性的或者全面的保护数据资产，该8Gbps的SAN32B-E4光纤通道加密交换机能够不中断的进行扩展，可提供48至高达96Gbps的加密处理能力，从而以灵活、按需的性能满足最苛刻环境的要求，此外它还能为磁带存储系统提供速度高达48Gbps的压缩服务，它与行业领先的企业级密钥管理系统之一IBM Tivoli Key Lifecycle Manager(TKLM)紧密集成，该系统能够跨分布式环境支持密钥生命周期服务。

2. 参考资料

a)销售手册：http://www-01.ibm.com/common/ssi/rep_sm/3/872/ENUS2498-_h03/index.html
b)红皮书：http://www.redbooks.ibm.com/redbooks/pdfs/sg247922.pdf


IBM DCN 交换机性能参数

解答:

以下列表分别描述了IBM DCN M系列、R系列、S系列、C系列以及G系列5类交换机的性能参数:

IBM M 系列
型号 | IBM Ethernet Router B04M | IBM Ethernet Router B08M | IBM Ethernet Router B16M
背板交换容量 | 960Gbps | 1.92Tbps | 3.84Tbps
数据交换容量 | 400Gbps | 800Gbps | 1.6Tbps
数据包转发能力 | 240Mpps | 480Mpps | 1Bpps
交换矩阵冗余 | 2+1 | 2+1 | 3+1
管理引擎冗余 | 1+1 | 1+1 | 1+1
电源冗余 | M+N | M+N | M+N
I/O用户板卡插槽 | 4 | 8 | 16
最大10GE端口密度(XFP) | 16 | 32 | 64
最大1GE端口密度(RJ45/SFP) | 80 | 160 | 320
最大OC 192/STM 64 POS端口密度 | 8 | 16 | 32
最大OC 48/STM 16 POS端口密度 | 32 | 64 | 128
最大MAC地址数量 | 1M | 1M | 1M
最大VLAN数量 | 4.096 | 4.096 | 4.096
IP v4 硬件路由 | 512K | 512K | 512K
IP v6 硬件路由 | 112K | 112K | 112K
每Trunk支持的最大端口数 | 32 | 32 | 32

IBM R 系列
型号 | IBM Ethernet Switch B04R | IBM Ethernet Switch B08R | IBM Ethernet Switch B16R
背板交换容量 | 960Gbps | 1.92Tbps | 3.84Tbps
数据交换容量 | 400Gbps | 800Gbps | 1.6Tbps
数据包转发能力 | 286Mpps | 571Mpps | 1.142Bpps
交换矩阵冗余 | 2+1 | 2+1 | 3+1
管理引擎冗余 | 1+1 | 1+1 | 1+1
电源冗余 | M+N | M+N | M+N
I/O用户板卡插槽 | 4 | 8 | 16
最大非线速10GE端口密度(XFP) | 64 | 128 | 256
最大线速10GE端口密度(XFP) | 16 | 32 | 64
最大1GE端口密度(RJ45/SFP) | 192 | 384 | 768
最大OC 192/STM 64 POS端口密度 | 无 | 无 | 无
最大OC 48/STM 16 POS端口密度 | 无 | 无 | 无
最大VLAN数量 | 4.096 | 4.096 | 4.096
IP v4 硬件路由 | 512K | 512K | 512K
IP v6 硬件路由 | 64K | 64K | 64K
每Trunk支持的最大端口数 | 32 | 32 | 32

IBM S 系列
型号 | IBM Ethernet Switch B08S | IBM Ethernet Switch B16S
背板交换容量 | 600Gbps | 1.08Tbps
数据交换容量 | 464Gbps | 848Gbps
数据包转发能力 | 304Mpps | 636Mpps
交换矩阵冗余 | 1+1 | 1+1
管理引擎冗余 | 1+1 | 1+1
电源冗余 | N+1 | N+1
I/O用户板卡插槽 | 8 | 16
最大非线速10GE端口密度(XFP) | 20 | 36
最大1GE端口密度(RJ45/SFP) | 192 | 384
最大1GE POE端口密度(RJ45/SFP) | 192 | 384
现场升级到PoE能力 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096

IBM C 系列
型号 | IBM Ethernet Switch B24C(C or F) | IBM Ethernet Switch B48C(C or F) | IBM Ethernet Switch B50C(C or F)
交换性能 | 88Gbps | 96Gbps | 136Gbps
转发性能 | 65Mpps | 71Mpps | 101Mpps
100/1000Mbps端口密度（RJ-45 or SFP） | 24 | 48 | 48
100/1000Mbps端口密度（RJ-45/SFP组合端口） | 4 | 4(F没有) | 没有
10G端口 | 2 | 2 | 2
缓存 | 128 | 128 | 192
冗余电源 | 支持内置冗余 | 支持内置冗余 | 支持内置冗余
AC/DC支持 | 支持 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096 | 4,096

IBM G 系列
型号 | IBM Ethernet Switch B48G(C or F) | IBM Ethernet Switch B50G
交换性能 | 136Gbps | 136Gbps
转发性能 | 101Mpps | 101Mpps
100/1000Mbps端口密度（RJ-45 or SFP） | 48 | 48
100/1000Mbps端口密度（RJ-45/SFP组合端口） | 4 | 4
10G端口 | 2 | 2
冗余电源 | 支持内置冗余 | 支持内置冗余
AC/DC支持 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096
堆叠支持 | 不支持 | 8
堆叠带宽 | 没有 | 40

下表是IBM DCN交换机与Brocade交换机的型号对照表:

IBM DCN 交换机与 Brocade 交换机型号对照表
IBM Name | IBM Model | Brocade Name
IBM m-series Ethernet routers
IBM Ethernet Router B04M | 4003-M04 | NetIron MLX-4
IBM Ethernet Router B08M | 4003-M08 | NetIron MLX-8
IBM Ethernet Router B16M | 4003-M16 | NetIron MLX-16
IBM r-series Ethernet switches
IBM Ethernet Switch B04R | 4003-R04 | BigIron RX-4
IBM Ethernet Switch B08R | 4003-R08 | BigIron RX-8
IBM Ethernet Switch B16R | 4003-R16 | BigIron RX-16
IBM c-series Ethernet switches
IBM Ethernet Switch B24C (C) | 4002AC2 | NetIron CES 2024C
IBM Ethernet Switch B24C (F) | 4002BC2 | NetIron CES 2024F
IBM Ethernet Switch B48C (C) | 4002-C4A / 4002AC4 | NetIron CES 2048C
IBM Ethernet Switch B48C (F) | 4002-C4B / 4002BC4 | NetIron CES 2048F
IBM Ethernet Switch B50C (C) | 4002-C5A / 4002AC5 | NetIron CES 2048CX
IBM Ethernet Switch B50C (F) | 4002-C5B / 4002BC5 | NetIron CES 2048FX
IBM s-series Ethernet switches
IBM Ethernet Switch B08S | 4003-S08 | FastIron SX 800
IBM Ethernet Switch B16S | 4003-S16 | FastIron SX 1600
IBM g-series Ethernet switches
IBM Ethernet Switch B48G | 4002-G4A / 4002AG4 | FastIron GS 648P
IBM Ethernet Switch B50G | 4002-G5A / 4002AG5 | FastIron GS 648P-STK
IBM Converged Switches
IBM Converged Switch B32 | 3758-L32 | Brocade 8000

HPC(高性能计算)与IBM DCN 交换机的解决方案概述及优势分析

1. 以太网技术 —— 高性能计算互联技术的趋势:

- 以太网时延逐渐接近于其他连接方式：IBM 具有业界领先的低时延；

- 成本低：和Infiniband等互联技术相比，具有较低的成本，大量使用使得千兆和万兆以太网价格快速下降，大部分服务器内置千兆网卡，使得服务器方面的成本较低；

- 普遍应用，基于标准：
. 基于 IEEE 802.3 标准；
. 企业 LAN 中广泛应用；

- 可扩展到数千个节点：随着数据处理量的加大，需要数千个节点计算单元，完成越来越大的、庞大的数据量计算；

- 基础网络需要频繁重新配置时尤其适用： 随着计算模型的频繁变化，需要频繁的变化高性能计算的连接方式，以太网能够很好的对其适应；

- 易于管理：以太网具有“即插即用、维护简单”等特点，能够和高性能计算系统很好的结合，使高性能计算系统的使用成本大大降低。

2. 用户需求分析

- 服务器间的时延最小化常常是一个关键因素；

- 端口密度最大化：
. 具有高密度GE和10GE的大型交换机；
. 在大规模集群中，不得不考虑空间的利用；

- 性能最高化：
. 无阻塞或尽可能的低阻塞；

- 成本最低化

- 网络可视化

- 大规模集群中，需要考虑电源功耗

- 大规模集群中，需要考虑散热系统

3. IBM公司交换机在高性能计算行业的特点和优势：

- 高性能：全系列、全线速性能，业界单机性能最强大的二、三层交换机家族，单机箱实现2Bpps的IPv4/IPv6包处理能力；

- 高可靠：高可靠冗余交换引擎、电源和管理模块，并支持无中断冗余切换，为业界平均水平的3倍；

- 低时延：在各种负载下呈现稳定的时延，64B字节帧10ec,9KB巨帧35ec （业界同等产品通常为30-70ec）；

- 可扩展性：业界领先的无阻塞128个10GE接口或1536个1GE接口的提供能力，满足大型HDC网络需要和未来发展的扩展空间；

- 投资保护：提供线速100GE未来扩展能力和IPv6的线速转发和路由；同系列内所有接口板卡通用，电源模块通用，管理界面相同；

- 低成本和绿色环保：
. 电源消耗较竞争对手低30-50％ ；
. 空调需求较竞争对手低40-50％；
. UPS需求约为竞争对手50% ；
. 空间占用约为竞争对手70%；
. 全系列提供内置冗余交流电源，节省成本增加可靠性。

- 网络应用可见：硬件实现基于sFlow的应用流量统计，以帮助网络性能的深入分析和优化。

4. IBM交换机部分HPC客户一览表：

国内
客户名称 | 节点数
中石油东方地球物理公司 | 3000
大庆油田研究院 | 624
大庆油田物探院 | 624
中石油北京研究院 | 624
中石化北京研究院 | 256
中石化南京物研所 | 256
中石化中原油田 | 256
长庆油田研究院 | 500
中海油塘沽研究院 | 100+
中海油湛江研究院 | 100+
公安部网安中心 | 2000
中科院计算所 | 1000+
香港邵氏影城 |
北京化工大学 |
青岛海洋大学 |
北京航空航天大学 |
北京师范大学 |
中国传媒大学 |
西安交通大学 |
中山大学 |
国外
客户名称 | 国家
Atralian Center for Adv Computing & Comms | Atralia
Weta Digital | New Zealand
Amerada Hess | US
Ascent Media | US
Caltech | US
Dreamworks | US
Indtrial Light and Magic | US
Los Alamos National Laboratory | US
Lucas | US
Prediction Company | US
Sandia National Laboratory | US
SGI | US
Sony Imageworks | US
UC Irvine Department of Physics and Astronomy | US
University of Arizona | US
C-Information Sciences Institute | US
Verisign | US
Vanderbilt University | US

5. IBM HPC应用领域：

- 石油勘探；

- 科学计算；

- 电影动画制作；

- 气象预报与分析；

- 大容量的数据处理；

- 军事科学；

- 地震灾难预测。

Top


DR550

Data Retention Solution

2231-IA3 IBM Information Archive Model IA3简介(最近更新)


2231-IA3 IBM Information Archive Model IA3简介

解答:

要点

· 提供统一的存储池，存储所有类型数据，包括结构化和非结构化、合规性或非合规性；
· 通过支持多种信息采集方式以及信息保护级别提供灵活性；
· 通过多种访问方式存储信息；
· 可扩展至高达 608TB（原始容量）；
· 在保留策略允许删除之前，保持信息完整性，并通过增强的篡改保护功能提高信息安全性；
· 利用重复数据删除及压缩功能优化存储；
· 允许使用混合介质（磁盘、磁带和虚拟磁带），从而提供极低的总拥有成本 （TCO）。

在满足您的信息保留需求时：无论是长期保留高价值的内容，满足行业保留法规，还是遵守公司管理要求，您都需要一个安全、可扩展而又经济高效的归档解决方案。IBM 信息归档是新一代的信息保留解决方案， 可作为所有类型数据（结构化或非结构化）的归档库，从而帮助任何规模的企业满足业务、法律或法规等全方面的信息保留需求。

IBM 信息归档可通过以下方式帮助您降低成本、提高运营效率并管理风险：

降低成本

· 借助内置的重复数据删除、压缩及分层存储管理功能降低磁盘容量需求。
· 避免了为结构化和非结构化的信息保留两种单独平台的需要。
· 通过将信息移动到较低成本的存储层（包括磁带）降低对主存储的需求。
· 单一管理点有助于减少管理归档信息所需的人力。
· 能够使用单一归档平台管理多个业务范围 （LOB） 的归档信息，从而可减少占地空间并降低能源成本。

提高运营效率

· 支持行业标准接口和协议可最大限度地减少对信息保留的投资
· 安装和配置轻松，可在更短时间内实现价值
· 其单一用户界面和 RAS 特性可简化对归档信息的管理
· 提供了在一个 IBM 信息归档中配置多达三个单独信息库（集合）的灵活性

管理风险

· 旨在帮助您的企业满足最严格的信息保留要求。
· 提供合规的存储库：不可擦除、不可重写的 （NENR） 和单写多读 （WORM） 保护。
· 通过正在申请专利的最新增强型篡改保护功能增强保护能力。

常见特性

· 可扩展至 608TB（原始容量）
· 提供受保护的存储以确保数据完整性和真实性
· 不可擦除、不可重写 （NENR） 数据保留
· 单写多读 （WORM） 数据保护
· 每个信息归档提供三个可配置的信息集合
· 提供多种保护级别
· 通过多种访问方法存储信息：
o System Storage Archive Manager （SSAM） 接口
o 行业标准接口 （NFS）
· 重复数据删除
· 压缩
· 分层存储库
· 正在申请专利的增强篡改保护

硬件概要

· 最高 608TB 存储量（主机架“2231-IA3”中 224TB 原始容量，扩展机架“2231-IS32”中 2 X 192TB 原始容量）
· 1台 Remote Support Manager 服务器（必需）
· 1个 KVM（必需）
· 1台管理服务器（必需）
· 2台 SMC 交换机（必需）
· 1个 FC 10/100/1G（必需）
· 2台 24端口 Brocade（可选）
· FC 交换机（可选，但成对提供）
· 1台 Ingest/Retrieve（S2M 服务器） - （必需）
· 2台 2231-S2M 服务器（可选用以提高性能）
· 1个 2231-D1A 磁盘控制器（必需）
· 2个 2231-D1A 磁盘控制器（可选 － 对于更多的集合，每个集合 1个控制器）
对于第 1个磁盘控制器，多达 6个 2231-D1B 磁盘扩展抽屉；对于第 2个和第 3个磁盘控制器多达 5个 2231-D1B

Top


IBM Storage 常见配置问题汇总

目录

IBM Storage 常见配置问题汇总

Disk System

DS5000

DS5000硬盘配置注意事项 (最近更新)

DS5000系列 CPU、缓存信息与配置

DS5100/DS5300 e-config配置注意事项

DS5000 SFP与线缆配置方法 (最近更新)

DS5100/DS5300 主机接口卡的配置方法

DS5020 e-config中Adapters选项配置(新增)

DS5020 e-config中Features选项配置(新增)

DS8000

DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？ (最近更新)

DS8700的CPU、缓存的选择及配置

DS8700硬盘选择及配置(最近更新)

IBM DS8800硬盘选择及配置

DS8000中Flash Copy (PTC）和Flash Copy SE配置是否有冲突(新增)

XIV

IBM XIV 硬盘选择及配置

XIV 电源与电源线的配置注意事项 (新增)

SVC

SVC(2145-CF8) 硬件的Features和Cables配置

SSPC 硬件的Features和Power Cords配置

Storwize V7000

Storwize V7000 硬件的SFP配置(最近更新)

Storwize V7000 硬件的HDDs配置

V7000 License说明以及订购方法(新增)

V7000 软件在e-config中的配置方法(新增)

Tape System

e-config中磁带的配置介绍 (最近更新)

3584-L53配置注意事项 (最近更新)

TS3100/TS3200/TS3310/TS3500 e-config中feature选项的配置注意事项 (新增)

TS7610 软、硬件配置及注意事项

TS7650 硬件中Features和cables的配置

TS7650/TS7650G e-config中console选项的配置注意事项(新增)

TS7650G 软件的配置(新增)

N series

N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

N3300/N3400/N3600硬盘配置与容量问题

SAN/Ethernet Switch

3758-L32 SFP与线缆的选择与配置

2498-R06 配置注意事项 (最近更新)

2498-R06端口配置 (新增)

768B econfig配置注意事项 (最近更新)

384B econfig配置注意事项(最近更新)

其他

存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置 (最近更新)


Disk System_配置

Disk System

Disk System

DS5000

DS5000硬盘配置注意事项 (最近更新)

DS5000系列 CPU、缓存信息与配置

DS5100/DS5300 e-config配置注意事项

DS5000 SFP与线缆配置方法 (最近更新)

DS5100/DS5300 主机接口卡的配置方法

DS5020 e-config中Adapters选项配置(新增)

DS5020 e-config中Features选项配置(新增)

DS8000

DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？ (最近更新)

DS8700的CPU、缓存的选择及配置

DS8700硬盘选择及配置(最近更新)

IBM DS8800硬盘选择及配置

DS8000中Flash Copy (PTC）和Flash Copy SE配置是否有冲突(新增)

XIV

IBM XIV 硬盘选择及配置

XIV 电源与电源线的配置注意事项 (新增)

SVC

SVC(2145-CF8) 硬件的Features和Cables配置

SSPC 硬件的Features和Power Cords配置

Storwize V7000

Storwize V7000 硬件的SFP配置(最近更新)

Storwize V7000 硬件的HDDs配置

V7000 License说明以及订购方法(新增)

V7000 软件在e-config中的配置方法(新增)


DS5020硬盘配置注意事项

DS5000硬盘配置注意事项

解答：

DS5020

目前，DS5020有四类可选的硬盘：

1. 7200转的SATA硬盘，容量大小为：1TB和2TB；

2. 15000转的FC硬盘，容量大小为：300GB，450GB，600GB；

3. 15000转的加密FC硬盘，容量大小和普通FC硬盘一致；

4. 固态硬盘（SSD），容量大小为：73GB，300GB。

在DS5020中，如果配置加密硬盘，必须配置相应的加密许可fc#7410。在配置33-64个硬盘时，需要加fc#7393的硬盘容量许可，在配置65-112个硬盘时，需要加fc#7394的硬盘容量许可。此外，DS5020可以支持磁盘混插，不需要任何license。

DS5100/DS5300

1. DS5100和DS5300主柜中不能放置硬盘，硬盘必须配置在1818-D1A扩展柜或1818-G1A中。

2. 1818-D1A即EXP5000目前支持750GB,1000GB和2000GB的7.2K SATA硬盘；支持146GB、300GB、450GB和600GB的4Gbps 15K FC硬盘；以及146GB、300GB、450GB和600GB的4Gbps 15K FC加密硬盘，同时D1A中还支持73GB的固态盘，为了提高性能，推荐每个扩展柜中配置一块固态盘，固态盘最多可配20块；订购加密硬盘同时还需要在DS5100或DS5300主柜中选择fc#7358加密硬盘激活许可。1818-D1A e-Config硬盘配置中16-Pak为16块硬盘一包，配置硬盘时可以单盘配置，也可以选择16盘一包配置。目前，DS5100和DS5300最大支持28个1818-D1A扩展柜即448块硬盘，但是当DS5100中1818-D1A数量大于16个，即硬盘数量大于256时，需要购买fc#7371。

3. 1818-G1A 也称EXP5060，它是高密度扩展柜，每个扩展柜支持最小2个、最大6个硬盘包，目前每个盘包包括10块1000GB或2000GB 7.2K SATA硬盘，DS5100和DS5300最大支持8个EXP5060扩展柜即480块硬盘。EXP5060数量为8个即满配时，DS5100需要购买fc#7371和fc#7372，而DS5300只需要购买fc#7372。

4. EXP5060可以和EXP5000可以混和使用在DS5000不同环路上，混合模式下最大支持448块硬盘。

产品优势：

1. DS5100和DS5300若满配SATA盘，最大容量可达到960TB（使用2TB的SATA盘），若是满配FC盘，最大容量可达268.8TB（使用600GB 15K 4Gbps FC盘），在满足一定的微码版本的情况下DS5100和DS5300支持FC，SATA，FDE,SSD的混插，满足不同应用对磁盘的要求，更好的节约客户成本，实现价值最大化。

2. DS5100和DS5300支持加密硬盘，加密盘是在硬件的级别上对硬盘实现加密，能在不增加客户成本和不牺牲性能的前提条件下更好的保护客户数据；支持固态硬盘，更快的数据存取和吞吐量，更好的可靠性以及较低的电源功率消耗，DS5100和DS5300后端8个环路，可让驱动器在多环路有效传递，避免后端过度饱和，实现更高的性能和更高效的利用。

3.DS5020支持加密硬盘，能在不增加客户成本和不牺牲性能的前提条件下更好的保护客户数据；支持不同容量、转速的的磁盘的混插，满足不同应用对磁盘的要求，更好的节约客户成本，实现价值最大化。

Top


DS5000系列 CPU、缓存信息与配置

解答：

1.DS5100和DS5300 CPU、缓存信息与配置：

DS5100和DS5300每控制器含一个Intel Xeon 2.8 GHz处理器。

DS5100和DS5300目前支持8GB(每控制器4GB)、16GB(每控制器8GB)、32GB(每控制器16GB)以及64GB(每控制器32GB)的数据缓存，e-config中分别对应fc#2030、fc#2031、fc#2033和fc#2034；此外，DS5100和DS5300还拥有4GB(每控制器2GB)的专用控制器缓存。目前，DS5100和DS5300采用PCI-Express作为内部总线，从而提高了DS5100和DS5300的整体性能。

此外，DS5100和DS5300的控制器中增加了一个USB闪存，当意外掉电时，DS5100和DS5300将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。

网络课堂:http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000

2.DS5020 CPU、缓存信息与配置：

DS5020每控制器含一个Intel xScale 1.2 GHz处理器。

DS5020目前支持2GB(每控制器1GB)或 4GB(每控制器2GB)缓存，e-Config中默认是2GB缓存配置，配置4GB缓存机型需要增加fc#2070选件，目前，DS5020不能从2GB缓存MES升级到4GB；DS5020采用PCI-Express作为内部总线，从而提高了DS5020的整体性能。

此外，DS5020的控制器中增加了一个USB闪存，当意外掉电时，DS5020将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。


DS5100/DS5300 e-config配置注意事项

解答:

1．DS5100/DS5300的e-config配置中，有Adapters的选项，这个卡区别于DS4000配置中用在主机端的HBA卡。在DS5000的机头上，本身是没有主机接口的，需要配置这种Adapter来配置主机端口。如下图，每个fc#2050(4G)或fc#2052(8G)包含2块4端口的卡(即8端口)，在DS5100/DS5300中可以选择8个或16个FC端口；

fc#2060包含2块双端口的1GbE iSCSI卡(即4端口)，在DS5100/DS5300中可以选择4个或8个iSCSI端口。

2．接口卡上不用另配模块，那么在SFP的选择中，所选的SFP模块都是接在扩展端口，连接扩展柜用的。DS5000共有16个扩展端口，可以配置8或者16个模块(即4个fc#2412或8 fc#2412)

3．DS5100/DS5300是8/16/32/64GB Cache可选。
在DS5100/DS5300中，FC和SATA硬盘的混插是不需要License的，在e-config配置中，没有这个选项。
在DS5300中，如果连接8台EXP5060，需要fc#7373。
在DS5100中，如果连接8台EXP5060，需要fc#7371和fc7372；如果连接16台以上1818-D1A(EXP5000)需要fc#7371。
注：EXP5060是一款可容纳60块1TB SATA硬盘的扩展柜。

Top


DS5100/DS5300 SFP与线缆配置方法

DS5000 SFP与线缆配置方法

解答:

SFP是Small Form-factor Pluggable的缩写，它是电信号与光信号进行转换的接口器件。SFP模块一般分为用于近距离传输的Short Wave短波模块，以及用于远距离传输的Long Wave长波模块，其中短波模块一般配合Multimode多模光纤线缆使用，长波模块一般配合Singlemode单模光纤线缆使用。此外，光纤接口设备还有LC和SC的接口规格，一般较早设备采用SC标准，较新的设备采用LC标准。

DS5020：

在DS5020中使用的SFP模块为Short Wave短波模块，光纤线缆为多模光纤，接口规格为LC。此外，新一代的OM3线缆也属于多模LC-LC光纤，但是OM3光纤线缆比传统多模光纤，在相同速率下支持更远的距离。DS5020有两个控制器，每个控制器上有两种类型的FC接口需要使用SFP模块，它们分别是用于连接前端主机或SAN交换机的HostPort，以及用于连接后端扩展柜的Drive Channel Port

DS5020根据FC端口的配置数量，自带相应数量的SFP模块，不需要单独订购SFP模块（注意：DS5020扩展柜EXP520上的SFP模块需要根据需要选配）。

DS5020根据主机接口卡的不同配置，最少支持4个、最大支持8个8Gbps Host Port；以及4个Drive Channel Port。在e-config中最多可以订8条光纤线缆，光纤线缆包括1米、5米、25米LC-LC的普通多模光纤，以及新一代OM3 10米LC-LC多模光纤，OM3多模光纤线缆除以根为单位订购外，还能以4根为一包订购。此外，光纤线缆还可以在SAN交换机和EXP520扩展柜的e-config中订购，光纤线缆的数量需要根据实际需求和配置来选择。

DS5100/DS5300：

DS5100/DS5300可以配置两块或者四块4端口FC主机接口卡，e-config中每个fc#2050或fc#2052代表两块4端口4Gbps或8Gbps FC主机接口卡，并且每块配置的主机接口卡均满配相应端口数量的SFP模块； DS5100/DS5300还可以配置iSCSI主机接口卡，但是iSCSI主机接口卡不需要SFP模块。

DS5100/DS5300默认拥有16个扩展柜连接端口，默认没有自带SFP模块，可以选择配置4对或8对SFP模块。e-config中每个fc#2412表示两个SFP模块，当扩展柜数量小于等于4时，建议选择4个fc#2412，当扩展柜数量大于4时，建议选择8个fc#2412。

线缆可以选择fc#5601，fc#5605和fc#5625，分别对应1米，5米和25米FC多模 LC-LC线缆，以及fc#5810 OM3 FC多模 LC-LC线缆，fc#5818是4个一包的OM3 FC多模 LC-LC线缆，OM3线缆在相同速率下可以支持更远的传输距离；连接主机端口的线缆需要根据主机或FC交换机数量以及连接方式决定；用于连接扩展柜端口的线缆建议在配置扩展柜时进行选择，每个扩展柜选择两根即可。

网络课堂：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000


DS5100/DS5300 主机接口卡的配置方法

解答:

DS5100/DS5300 e-config配置中，FC主机接口卡是安装在DS5100/DS5300上，用于连接主机HBA卡或者光纤交换机，iSCSI主机接口卡是安装在DS5100/DS5300上，用于直连或通过以太网交换机连接网卡、iSCSI卡。

目前有三种类型的主机接口卡可供配置，它们分别是：

1. fc#2050代表2块4口（Quad）4Gbps FC主机接口卡；
2. fc#2052代表2块4口（Quad）8Gbps FC主机接口卡；
3. fc#2060代表2块2口（Dual）1GbE iSCSI主机接口卡。

其中FC主机接口卡均随卡满配相应端口数量的SFP模块，DS5100/DS5300中可以配置2块或者4块主机接口卡，也就是说可以从fc#2050、fc#2052和fc#2060中选择1组或2组，最多支持16个FC主机接口或者8个iSCSI主机接口。


DS5020 e-config中Adapters选项配置

解答:

1.目前DS5020机头的配置中，有两种主机接口卡的配置：
a)2个双端口的8 GB光纤主机接口卡；
b)2个双端口的1 GB iSCSI主机接口卡。

2.配置注意事项：
a)DS5020默认带有4个8 GB光纤主机接口；
b)当在e-config配置中选择2080时，该DS5020即有8个8 GB光纤主机接口；
c)当在e-config配置中选择2081时，改DS5020即有4个8 GB光纤主机接口和4个1 GB iSCSI主机接口；
d)fc#2080和fc#2081选项只能在初始配置时定制，后期不可扩展；
e)所有主机接口都自带有SFP模块，不需要额外配置。

参考资料：DS5020销售手册（Sale Manual）


DS5020 e-config中Features选项配置

解答:

配置注意事项：

a)DS5020默认2GB缓存，即每个控制器1GB，当添加fc#2070时，就变成4GB缓存，即每控制器2GB。该缓存扩展模块只能在出厂前设定，后期不可升级；

b)DS5202当添加到33-64块硬盘时，需要添加fc#7393的磁盘数量许可（license）；

c)DS5202当添加到65-112块硬盘时，需要添加fc#7394的磁盘数量许可（license）；

d)fc#7401为DS5020快照(Flash Copy)功能的激活，该功能激活后，对同一个逻辑卷（LUN）只可保留4个时间点的快照数据。一般客户没有特殊数说明，配置该激活即可；

e)当客户需要对同一个逻辑卷（LUN）保留4个以上时间点的快照数据时，则需要添加fc#7402。把对同一个逻辑卷（LUN）的快照个数扩展到8个时间点；

f)fc#7403为卷拷贝(Volume Copy)的功能激活许可；

g)fc#7404快照(Flash Copy)和卷拷贝(Volume Copy)功能的打包许可，包含了fc#7401和fc#7403；

h)fc#7405为DS5020远程镜像（Enhanced Remote Mirror）功能的激活，该功能激活后，可实现32组逻辑卷（LUN）之间实现镜像。一般客户没有特殊数说明，配置该激活即可；

i)当客户需要对大于32组逻辑卷（LUN）进行镜像的时候，则需要添加fc#7406。把远程镜像的镜像对从32组扩展到64组；

j)当客户需要配置加密硬盘的时候，必须添加fc#7410加密激活许可（license）；

k)目前，DS5020支持两种扩展柜，EXP520及EXP810。当需要连接EXP810扩展柜时，需要添加fc#7414许可，确保EXP810的正常连接。另，在DS5020的配置界面中并没有EXP810的配置界面，需要单独配置；

l)fc#8S1106是一个只有内部sales可以订购的特殊许可，需要走产品部的RPQ流程。该许可为并行访问的功能。

参考资料：DS5020销售手册（Sale Manual）


DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求

解答:

DS8000配置中，主要有以下许可(License)功能:

1. OEL:

是按照客户订购的DS8000的裸容量来购买的许可（license）,许可（license）的容量不得少于物理容量。如：DS8000一共订购了10TB容量的硬盘，则需要客户订购至少10TB的OEL许可（license）.该许可（license）是必须的。

除此之外DS8700新增加了OEL value unit 许可，此许可是根据磁盘的性能，容量，转速等特性来收费。OEL value unit也是必配的许可，配置时容量不少于econfig中指示的point值。

2. PTC:

是按照客户订购的DS8000的裸容量来购买PTC(point time copy)即Flashcopy的许可（license），许可（license）的容量不得少于物理容量。该许可（license）是可选的。

它包含：PTC,PTC add,SE,SE add 4个选项。

a.PTC:
是标准的FlashCopy许可(License)。

b.SE:
是FlashCopy SE的许可(License)。

c.SE add:
是如果客户在已经订购了PTC的基础上，加订Flashcopy SE的许可(License)。

d.PTC add:
是如果客户在已经订购了SE的基础上，加订标准FlashCopy的许可(License)。

3. RMC：

是按照客户订购的DS8000的裸容量来购买RMC(remote mirror copy)即Remote mirror的许可（license），该许可（license）的容量不得少于物理容量。该许可（license）是可选的。

它包含：MGM,MM,GM,GM add,MM add。

a.MM(Metro Mirror)：
是按照客户订购的DS8000的裸容量来购买Metro Mirror的许可(License)。
MM(Metro Mirror)的原理是：本地DS8000和远程DS8000的逻辑卷之间实现实时同步镜像,两个DS8000的距离最大可达300公里。

b.GM(Global Mirror)：
是按照客户订购的DS8000的裸容量来购买Global Mirror的许可(License)。
GM(Global Mirror)的原理是：本地DS8000和远程DS8000的逻辑卷之间实现异步镜像,两个DS8000的距离可以更远。

c.MGM(Metro/Global Mirror):
是按照客户订购的DS8000的裸容量来购买3 site Metro/Global Mirror的许可(License)。
MGM(Metro/Global Mirror)的原理是：先是本地DS8000和远程第一个DS8000的逻辑卷之间实现实时同步镜像,远程第一个DS8000再和远程第二个DS8000逻辑卷之间实现异步镜像。

d.GM add: 是如果客户在已经订购了MM(Metro Mirror)的基础上，加订GM(Global Mirror)的许可(License)。

e.MM add: 是如果客户在已经订购了GM(Metro Mirror)的基础上，加订MM(Global Mirror)的许可(License)。

注意：在DS8700与DS8800配置中，没有GM add与MM add许可，需要订购标准的GM与MM许可。

4. RMZ：

是按照客户订购的DS8000的裸容量来购买RMZ(Remote Mirror for Z/OS)即Remote Mirror的许可(License).

客户的应用环境是Z/OS的情况下，要想实现DS8000的Remote Mirror功能需要购买的许可(License)，许可(License)的容量不得少于物理容量。该许可(License)是可选的。

5. PAV:

是按照客户订购的DS8000的裸容量来购买Parallel Access Volumes (PAV)的许可(License)。

该license是客户的应用环境是Z/OS的情况下，能够实现单个Z系列的服务器来并发处理针对同一个逻辑卷的多个I/O操作,从而可以大大减少设备的排队延时时间。license的容量不得少于物理容量。该license是可选的。

6. OEL Value Unit:

在DS8700/DS8800 Function Auth中新增加了OEL Value Unit 许可，此许可是根据磁盘的性能、容量、转速等特性来收费。OEL Value Unit是必配的许可，配置时容量不少于e-config中指示的point值。OEL的容量的license在DS8700中是免费的，配置时不少于物理容量。

7. Easy Tier:

如果客户要求在DS8700上使用 Easy tier 功能，需要增加IBM System Storage Easy Tier许可（fc#7083）,这个许可是免费的。Easy tier实现在SSD磁盘与FC/SATA混合的环境下，自动将热点数据迁移到SSD磁盘上,其他的数据放在普通的磁盘上以提升性能同时实现分级存储。Easy tier还可以实现整卷迁移到不同类型的磁盘上。Easy tier是IBM DS8000 5.1版本微码的新功能。

参考资料：
查阅IBM销售手册:Storage System 销售手册查询

Top


DS8700的CPU、缓存的选择及配置

解答:

DS8700中有两种CPU卡：2-way processor card和4-way processor card。

在选择2路CPU时，缓存有32/64/128GB的三种选择。在选择4路CPU时，缓存有32/64/128/256/384GB的5种选择。

在选择2路CPU的时候，DS8700最大支持128块硬盘，即不支持扩展柜。当选择4路CPU的时候，DS8700支持最大1024块硬盘，即4个扩展柜。

突出价值点：全新 DS8700 的 POWER6 处理器采用的是主频为 4.7Ghz 的处理器。每个处理器有两块处理器卡，每块处理器卡中可以容纳 2 个处理器。这样每个处理器最多就能容纳 4 个 POWER6的处理器。除此之外，相比于现有 DS8000 系列产品中每块处理器卡拥有 8 个DIMM 插槽，在DS8700 中增加到 12 个。这样，DS8700 将整个系统所能够容纳的内存数量从现有 DS8000 的256GB 提升到了 384GB。

采用新的硬件之后，DS8700 中的所有系统部件都可以同步更换，甚至从 2 路处理器到更强大的 4 路处理器的升级都不会对客户的应用造成影响。IBM DS8700 进一步简化系统管理的复杂度，使得用户可以更方便地使用存储设备的各项功能。在能源消耗受到高度重视的全球大环境下，DS8700 在保证海量数据处理性能和高可用性的前提下，可以用更少的能耗来达到所需的性能指标。

DS8700 延续了 DS8000 系列产品的良好传统；更为关键的是，在对高端存储设备的硬件进行升级的时候，用户的应用不会被中断。此外，与 DS8300 相同的硬盘和硬盘仓，以及和 DS8300 完全兼容的镜像服务，还可以全面保护客户现有的 DS8000 系列产品投资。


DS8700硬盘选择及配置

解答:

IBM DS8700 在4路CPU（4-way CPU)的配置时，最多可以支持4个磁盘扩展柜，最多支持1024块硬盘。在2路CPU（2-way CPU)的配置时，只包含一个主柜，最多支持128块硬盘。

IBM DS8700支持FC磁盘、可加密FC磁盘，SATA盘与固态盘四种类型。其中可加密FC磁盘不能与其它类型磁盘在DS8700中混用。

固态盘除了支持标准的磁盘组配置外,还支持半组(half Driver Set)的配置,即个磁盘组里8块磁盘。需要特别注意，每台DS8700里，只能订一个半组的固态盘磁盘组，而DS8700最大支持256块固态盘。

DS8700同样支持CoD类型的磁盘。

通过下表，用户可以了解IBM DS8700具体支持的磁盘信息与Value Unit许可数量，它是根据磁盘的性能，容量，转速等特性来收费。

Feature Number | Size | Drive type | Drive speed | Encryption drive | Non-encryption drive | Value Units Required
6014 | 73 GB | SSD half set | N/A | No | Yes | 6
6114 | 146 GB | SSD half set | N/A | No | Yes | 9
6214 | 600 GB | SSD half set | N/A | No | Yes | 25
6016 | 73 GB | SSD | N/A | No | Yes | 12
6116 | 146 GB | SSD | N/A | No | Yes | 18
6216 | 600 GB | SSD | N/A | No | Yes | 50
2416 | 300 GB | FC | 15K rpm | No | Yes | 6.8
2616 | 450 GB | FC | 15K rpm | No | Yes | 9
2716 | 600 GB | FC | 15K rpm | No | Yes | 11.5
5116 | 300 GB | FC | 15K rpm | Yes | No | 6.8
5216 | 450 GB | FC | 15K rpm | Yes | No | 9
2916 | 2 TB | SATA | 7.2K rpm | No | Yes | 20

以下是配置DS8700的注意事项：

1.DS8700硬盘配置以磁盘组（Drive Set）为单位，每个磁盘组（Drive Set）包括16块硬盘，并且最少配置一个磁盘组（Drive Set）。

2.DS8700 2-way CPU型号最大支持128块硬盘，不支持连接2421-94E扩展柜，最大支持8个Drive Set，即128块硬盘。

3.DS8700 4-way CPU型号最大支持1024块硬盘，最多支持4个2421-94E扩展柜，其中机头最大支持8个Drive Set，即128块硬盘，前三个2421-94E扩展柜最大支持3*16个Drive Set，即768块硬盘，第四个2421-94E扩展柜最大支持8个Drive Set，即128块硬盘。

4.目前DS8700支持300GB,450GB，600GB 15000转的FC盘，600GB 标准SSD固态盘包和半包配置，2TB SATA盘，300GB,450GB 15000转的FDE加密盘。另外还支持FC，SATA或者FDE的CoD随需激活的硬盘。DS8700默认的微码为R5.1，支持上述硬盘。

5.DS8700中最多支持256块SSD固态盘，固态盘支持RAID 5；2TB SATA盘支持RAID 6和RAID 10。

6.DS8700中，如果配置FDE全加密盘，需要配置Tivoli Key Lifecycle Manager (TKLM) V2.0 软件fc#5608-A99；此外，全加密盘不能与其他类型的硬盘混插。


IBM DS8800硬盘选择及配置

解答：

IBM DS8800 是IBM新分布的最新一代企业级磁盘存储产品，为客户提供了高性能，高容量，高扩展性与高可靠性的产品。

IBM DS8800包括一个主柜与最多配置两个扩展柜，最大支持1056块磁盘。在e-Config工具中，DS8800的磁盘配置方法与DS8000其它型号一致，都以磁盘组(Driver Set)的方式来订购，每个磁盘组包含16块磁盘。

在e-Config工具中，IBM DS8800当选择“2-Way Processor Card”(fc#4301)时，只能配置一个主柜，不能增加扩展柜。如果选择fc#1250 Business Class连接的光纤线缆,主柜中最多支持15个磁盘组，共240块磁盘。如果选择fc#1246标准连接的光纤线缆,主柜中最多只支持9个磁盘组，共144块磁盘。

当选择“4-Way Processor Card”(fc#4302)时，如果选择fc#1250 Business Class连接的光纤线缆,最多配置一个扩展柜，此时主柜最多支持15个磁盘组，共240块磁盘。扩展柜里最多支持21个磁盘组，共336块磁盘。所以Business Class连接的光纤线缆最多只支持576块磁盘。如果选择#1246标准连接的光纤线缆，最多可以配置两个扩展柜。此时主柜最多支持15个磁盘组，共240块磁盘，第1个扩展柜最多支持21个磁盘组，共336块磁盘。第2个扩展柜最多支持30个磁盘组，共480块磁盘。所以标准连接的光纤线缆使得DS8800最多可以支持1056块磁盘。

IBM DS8800支持SAS盘，可加密SAS盘与固态盘三种类型。其中可加密SAS盘不能与SAS盘在DS8800混用。SSD只支持RAID 5，而SAS盘支持RAID 5，6，10。DS8800同样支持CoD类型的磁盘。

DS8800支持的磁盘具体型号如下：
300 GB SSD drive
146 GB 15,000 rpm SAS
450 GB 10,000 rpm SAS
600 GB 10,000 rpm SAS

450 GB 10,000 rpm FDE SAS
600 GB 10,000 rpm FDE SAS

146 GB 15,000 rpm CoD SAS
450 GB 10,000 rpm CoD SAS
600 GB 10,000 rpm CoD SAS
450 GB 10,000 rpm FDE CoD SAS
600 GB 10,000 rpm FDE CoD SAS

Top


DS8000中Flash Copy (PTC）和Flash Copy SE配置是否有冲突

解答:

DS8000中Flash Copy（PTC）功能和Flash Copy SE（SE）功能是相互独立的两个功能，可以同时存在。

PTC实现时，需要快照的原卷和目的卷的容量必须相同。SE实现时，引入了存储池的概念，当数据发生改变时，数据的改变量写入单独的存储池，因此快照的目的卷可以小于原卷，节省空间。


IBM XIV 硬盘选择及配置

解答：

在IBM XIV存储系统中，可以配置1TB或者2TB的SATA磁盘。但是这两种磁盘不能在一套XIV系统中混合使用。

在e-config工具中，当选择“2TB DCPU”标识时，就可以在下面的网格单元选择中，选择单盘容量为2TB的接口（fc#1102）与数据（fc#1107）网格单元。

如果选择“Dual-CPU”标识，那么在下面的网格单元选择中，选择单盘容量为1TB的接口（fc#1101）与数据（fc#1106）网格单元。

在IBM XIV系统中，不论在网格单元中选择1TB还是2TB的磁盘，都还可以选择配置“Capacity on Demand(CoD)”类型的网络单元，即先购买全部网格硬件与现阶段所需要的网格单元数量激活许可，然后再根据需求在未来12个月内补订余下的网格单元激活许可。

如果选择“2TB DCPU Capacity on Demand(CoD)”标识，那么就必须订购含2TB磁盘的6个接口网格单元（fc#1112）与9个数据网格单元（fc#1117）总共15个单元。最少订4个网格单元的许可(fc#1121)，最大可订15个许可即激活全部单元。“CoD Standard order”（fc#0301）是一个仅用于管理目的的标识，当订满15个激活许可时，这个feature将会自动消失。

如果选择“Dual-CPU Capacity on Demand(CoD)”标识，那么就必须订购含1TB磁盘的6个接口网格单元（fc#1111）与3个数据网格单元（fc#1116）总共9个单元。最少订4个网格单元的许可(fc#1120)，最大可订9个许可即激活全部单元。同样，“CoD Standard order”（fc#0301）是一个仅用于管理目的的标识，当订满15个激活许可时，这个feature将会自动消失。

在IBM XIV系统中，最多可以配置6个接口网格单元与9个数据网格单元，每个网格单元都具有CPU、内存与磁盘。两种类型的网格单元区别只在于接口单元具有连接前端主机或交换机的FC或iSCSI接口。

通过下表用户可以查询不同数量的网络单元对应的磁盘容量，接口数量、功耗、内部还宽，CPU数量与内存等信息。

Top


XIV 电源与电源线的配置注意事项

解答:

首先要强调一点，针对于XIV电源与电源线的问题，一定要与客户或者客户的涉电工程师来确认。XIV提供的三种电源与电源线都可以按客户的需求所应用。

XIV为客户提供了三种选择：
1．如果电源为单相（Single phase）220V, 60A(#9890)类型，电源线选择fc#9813
2．如果电源为三相（Three phrase）Wye 220V, 30A(#9892)类型，电源线选择fc#9822
3．如果电源为三相（Three phrase）delta 220V, 30A(#9894)类型，电源线选择fc#9824


SVC(2145-CF8) 硬件的Features和Cables配置

解答：

(fc#5305) 5 m Fiber Optic Cable LC-LC
该feature提供一根 5-meter，2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#5325) 25 m Fiber Opt Cable LC-LC
该feature提供一根 25-meter，2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#5608) 8 Gbps LW SFP
SVC V5.1支持split a SVC I/O group 跨长距离。 8 Gpbs LW SFP feature code fc#5608 是目前支持用于该配置的唯一硬件。该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#0010) Storage Engine Preload
该feature 提供由IBM 工厂在SVC Storage Engine上预安装required SVC Storage Software，该feature缺省就是选中的。

Top


SSPC 硬件的Features和Power Cords配置

解答：

(fc#00xx) Preload Features
该feature 是订货方式的选择，中国大陆地区这里要选0018 TotalStorage Productivity Center Basic Edition will be ordered in AAS/e-config。

(fc#1810) Dual Power Supply Option
该feature 提供一个另外的 redundant 670 Watt Power Supply 且带有一根 Y-cable来增强电源的冗余可用性。一般都建议订购该feature。

(fc#9100) Console Keyboard/Display/Drawer
该feature 提供一个Console Keyboard/Display/Drawer。

(fc#117x - fc#118x) Power Cords
该feature是电源线，中国大陆地区这里要选 # 1183 Power Cord，Group 13 China (250V，10A)。该feature是必须选的，最大的数量是3，最小的数量是1。如果选了双电源，该featue的数量要选2。

Top


Storwize V7000 硬件的SFP配置

解答:

Storwize V7000 硬件的SFP配置：

Storwize V7000的控制器盘柜一共有8个8 Gbps FC host ports, (每个RAID controller 有4个 8 Gbps FC ports ) 且缺省每个8 Gbps FC host port都已经插有短波(SW)的SFP transceivers。一般情况下，不需在该页面选择，即#5608的数量为0。如果客户有特殊的长波SFP transceivers连接需求，此页面中可以选择另外订购最多8个#5608 8Gbps长波(LW)的SFP transceivers。


Storwize V7000 硬件的HDDs配置

解答:

上面是窗口是2076-124的硬盘配置窗口，2076-224同上。
选择V7000控制器盘柜中的硬盘的数量，最多可以配置24块硬盘。
有4种硬盘的类型可以选择，分别是:

fc#3203 300GB 2.5in 10k HDD；
fc#3204 450GB 2.5in 10k HDD；
fc#3206 600GB 2.5in 10k HDD；
fc#3504 300GB 2.5in SDD。

其中fc#3203，fc#3204，fc#3206是SAS硬盘；fc#3504是SSD硬盘。

V7000控制器盘柜支持SAS 硬盘, Nearline SAS 硬盘, 和SSD硬盘在一个IBM Storwize V7000 Control Enclosures 和 IBM Storwize V7000 Expansion Enclosures盘柜里混插。

上面是窗口是2076-112的硬盘配置窗口，2076-212同上。

选择V7000控制器盘柜中的硬盘的数量，最多可以配置12块硬盘。

有1种硬盘的类型可以选择，#3302 2TB 3.5in 7.2k HDD 是 Nearline SAS 硬盘。

Top


V7000 License说明以及订购方法

解答:

5639-VM1 V7000基础软件，按照V7000配置磁盘笼数量订购，econfig自动生成数量

5639-EV1 V7000外挂存储虚拟化许可，按照外挂存储阵列中拥有磁盘的笼子数量订购

5639-RM1 V7000远程镜像许可，按照V7000本地磁盘笼以及外挂存储阵列中拥有磁盘的笼子的总数订购


V7000 软件在e-config中的配置方法

解答:

1．在配置完成了V7000的硬件后，双击e-config窗口中中间栏的software Products

2．在下列窗口中，不做任何修改，直接点击next按钮

3. 在下列窗口中，确保Disk Virtualization选项打上了钩，然后点击next按钮

4．在下列窗口中，有3个选项可以选择，其中
5639-VM1 IBM Storwize V7000 Software V6.1 是必须配置的软件，包含：ThinProvisioning，FlashCopy，Easy Tier等基本功能。
5639-EV1 IBM Storwize V7000 External Virtualization Software V6.1是可选的软件，允许V7000连接外置光纤盘阵,并且提供虚拟化软件的全部功能.
5639-RM1 IBM Storwize V7000 Remote Mirroring Software V6.1是可选的软件，允许在V7000之间实现同步/异步远程镜像功能。
做完选择后，直接点击next按钮。

5．在下列窗口选择上面所选的软件（5639-EV1）的warranty时间，缺省是1或3年，也可以选择其他年限

6．在下列窗口定义上面所选的软件（5639-EV1）的数量license，该license的数量必须是使用V7000虚拟化功能的外置盘柜的个数。
V7000虚拟化功能的外置盘柜必须符合下列条件：
是一个外置的控制器盘柜或扩展柜。
该外置的控制器盘柜或扩展柜必须至少包含一块硬盘（包括SSD硬盘）。
该license缺省数量是1，须根据客户的实际应用环境选择。

7．在下列窗口选择上面所选的软件（5639-RM1）的warranty时间，缺省是1或3年，也可以选择其他年限。

8．在下列窗口定义上面所选的软件（5639-RM1）的数量license，该license的数量必须是按照V7000所管理的盘柜的个数来收费的，V7000所管理的盘柜除了包括V7000本身的控制器盘柜和V7000的扩展柜，还包括使用V7000虚拟化功能的外置盘柜的个数。
V7000虚拟化功能的外置盘柜必须符合下列条件：
是一个外置的控制器盘柜或扩展柜。
该外置的控制器盘柜或扩展柜必须至少包含一块硬盘（包括SSD硬盘）。
该license缺省数量是1，须根据客户的实际应用环境选择。

9．在下列窗口选择上面所选的软件（5639-VM1）的warranty时间，缺省是1或3年，也可以选择其他年限。
5639-VM1没有数量的个数可选,因为(5639-VM1) IBM Storwize V7000 Base Software license是按照V7000的盘柜个数来收费的。每添加一个V7000的控制器盘柜或V7000的扩展柜，都会自动在硬件的基础上生成一份5639-VM1的软件。

10．下列软件配置完成的窗口，直接点击configure按钮完成软件配置


Tape System

e-config中磁带的配置介绍 (最近更新)

3584-L53配置注意事项 (最近更新)

TS3100 TS3200 TS3310 TS3500 e-config中feature选项的配置注意事项 (新增)

TS7610 软、硬件配置及注意事项

TS7650 硬件中Features和cables的配置

TS7650 TS7650G e-config中console选项的配置注意事项(新增)

TS7650G 软件的配置(新增)


e-config中磁带的配置介绍

解答:

1.在磁带库的e-config配置中，TS2900、TS3100以及TS3200的硬件e-config配置中会自动配置feature号为#8305，#8405，#8505的磁带，这种磁带是五盘一包，但是这种磁带并不带标签，一般不建议客户配置这种磁带。建议客户到e-config的Storage Media中配置相应的带标签的磁带。

2.Storage Media中的磁带分类主要常用的有，3589-004（清洗带），3589-010（LTO4带标签的数据带），3589-011（LTO4不带标签的数据带），3589-014（LTO5带标签的数据带），3589-015（LTO5不带标签的数据带），以上几种磁带配置中清洗带为五盘一包，数据带为20盘一包，这几种磁带主要用于3580磁带机或者支持LTO驱动器的磁带库中。

3.由于e-config的Storage Media配置中磁带标签的编码为乱码，因此需要客户在配置磁带的时候手动修改为正确的编码。

4.TS2900/TS3100/TS3200/TS3310/TS3500 对磁带标签的要求是必须的(Required)

5.Ultrium Tape Drive/Library 的标签格式如下：
Ultrium 5 Data Cartridge 的标签格式是：xxxxx0L5
Ultrium 5 WORM Cartridge的标签格式是： xxxxx0LV
Ultrium 4 Data Cartridge 的标签格式是：xxxxx0L4
Ultrium 4 WORM Cartridge的标签格式是：xxxxx0LU
Ultrium 3 Data Cartridge的标签格式是：xxxxx0L3 （注意：e-config中对应的型号 3589-008 已停产）
Ultrium 3 WORM Cartridge的标签格式是：xxxxx0LT （注意：e-config中对应的型号 3589-028 已停产）
Ultrium 2 Data Cartridge的标签格式是：xxxxx0L2 （注意：e-config中对应的型号 3589-006 已停产）
Ultrium 1 Data Cartridge (READ ONLY)的标签格式是：xxxxx0L1
IBM LTO Ultrium Cleaning Cartridge的标签格式是：CLNxxxLx


3584-L53配置注意事项

解答：

3584-L53目前支持3种驱动器，3588-F3B、3588-F4A和3588-F5A。fc#1514为驱动器上架套件，必须大于等于驱动器个数，fc#9681/fc#9682/fc#9679为驱动器的安装方式标示，数量必须等于驱动器个数。

在配置TS3500机头槽位时，有几种选择，如果不选任何选项，那么3584-L53默认激活了64个槽位，选中fc#1643，则槽位升级到一半即129个，再选中fc#1644，槽位全部激活，有261-287个槽位（4个以上驱动器，槽位跟驱动器数量有冲突）。

3584-L53有两种支持的扩展柜，3584-S54和3584-D53。D53是普通扩展柜，能加12个驱动器，最大支持440个磁带槽位。S54是高密度扩展柜，不能加驱动器，只能增加槽位。在S54中，有一个fc#1646的槽位激活选项，不选这个选项，S54是660个槽位，选上这个选项之后能扩展至单个柜子1320个磁带槽位。S54扩展柜适合于客户机房空间不足，而对容量要求又很高的情况。另外，在配置S54的时候，需要在L53机头上配置fc#9050和fc#9205的license。

3584-L53双机械臂的配置注意事项：1）3584-L53中至少有一个3584-D53的扩展柜； 2）必须保证有一个无驱动器的D53，将其放在最右边，同时在D53中，选择fc#1440 service bay B，并去掉额外的电源模块fc#1451 ；3）在L53中，选择fc#9040 High Availability Library选件，并在最左边添加一个3584-HA1作为控制机柜。

3584-L53驱动器与槽位的关系表：

按需扩展的feature类型 | 驱动器的数量 | I/O槽位数 | 槽位的总数量
默认 | 0-12 | 16 | 64
Intermediate(半数激活) | 0-12 | 16 | 129
Full (全激活) | 0-4 | 16 | 287
Full (全激活) | 5-8 | 16 | 273
Full (全激活) | 9-12 | 16 | 261
Full (全激活) | 0-4 | 32 | 245
Full (全激活) | 5-8 | 32 | 231
Full (全激活) | 9-12 | 32 | 219

突出价值点：企业级的磁带库产品，按需扩展容量。磁带槽位、驱动器的灵活配置能更好的满足不同用户的不同需求。支持动态逻辑带库划分，动态槽位扩展等虚拟化管理。双机械臂的配置为企业级带库用户在多磁带槽位的情况下寻找抓取最优路径，提高了带库效率。

Top


TS3100/TS3200/TS3310/TS3500 e-config中feature选项的配置注意事项

解答:

1.TS3100 e-config配置中features选项的配置注意事项
a)fc#5900是加密激活的许可(license)只有LTO4或LTO5的驱动器才支持硬件加密功能，LTO3的驱动器并不支持此功能。
b)fc#7703是不带IBM 标识(logo)的许可
c)fc#1682是路径冗余的功能激活许可(license)。这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的
d)fc#7002是上架套件，fc#9848是PDU电源线，若需要将TS3100放置在机柜中，这两个许可是必选的，而且必须同时选择
e)fc#8106,fc#8109都是额外的磁带仓，用于批量更换磁带，一般不需要订购，TS3100缺省已经配有2个可移动的magzine，提供24个槽位，其中包括1个I/O槽位
f)fc#8002是清洗带，fc#8305,#8405,#8505分别为LTO3,LTO4,LTO5的数据磁带，均为5盘一包，不带标签（一般不建议客户配置这种不带标签的数据带）

2.TS3200 e-config配置中features选项的配置注意事项
a)fc#5900是加密激活的许可(license)只有LTO4或LTO5的驱动器才支持硬件加密功能，LTO3的驱动器并不支持此功能。
b)fc#7703是不带IBM 标识(logo)的许可
c)fc#1682是路径冗余的功能激活许可(license)。这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的
d)fc#1901是冗余电源，fc#7002是上架套件，fc#9848是PDU电源线，若需要将TS3200放置在机柜中，这两个许可是必选的，而且必须同时选择
e)fc#8107,fc#8108都是额外的磁带仓，用于批量更换磁带，一般不需要订购，TS3200缺省已经配有4个可移动的magzine，提供48个槽位，其中包括3个I/O槽位
f)fc#8002是清洗带，fc#8305,#8405,#8505分别为LTO3,LTO4,LTO5的数据磁带，均为5盘一包，不带标签（一般不建议客户配置这种不带标签的数据带）

3.TS3310 e-config配置中features选项的配置注意事项
a)fc#7003是上架套件，fc#9848是PDU电源线，若需要将TS3310放置在机柜中，这两个许可是必选的，而且必须同时选择
b)fc#1640是扩展柜槽位激活的许可，#1640的数量与扩展柜E9U的数量相同，若不激活#1640,扩展柜只有半数46个槽位激活，反之则是全部92个槽位激活
c)fc#1650是高级报告功能，它主要提供了介质完整的分析报告和驱动器资源利用率的功能，这也给用户分析数据提供了图形化显示并以此来帮助用户评估磁带库性能和驱动器利用率
d)fc#1682是路径冗余的功能激活许可(license)。这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的
e)fc#5900是加密激活的许可(license)只有LTO4或LTO5的驱动器才支持硬件加密功能，LTO3的驱动器并不支持此功能。
f)fc#9900是加密出版物，该许可免费
g)fc#8002是清洗带
h)fc#9210,#9211,#9212,#9215分别为连接各类型操作系统的许可

4. 3584-L53：在e-config配置中features的配置注意事项
a)fc#1643表示半数槽位激活，对于L53主机柜默认只有64个槽位激活可用，激活#1643后可用槽位变为129个
b)fc#1644表示全部槽位激活，在驱动器数量不超过4个的配置情况下，L53主柜最大可激活287个槽位，随着驱动器数量增加，其可用槽位数量有所减少
c)fc#1658是额外16个使用LTO驱动器的带库I/O槽位，#1659是额外16个使用3592驱动器的I/O槽位
d)fc#1682是多路径切换功能，这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的
e)fc#1690/1692分别为高级/入门级带库管理系统，这个feature主要提供了磁带，槽位，驱动器和逻辑带库的动态管理，通过Web界面可以将驱动器指定给任意一个逻辑带库，它允许在线添加，删除或者改变逻辑带库，而不中断主机应用
f)fc#9040高可用扩展柜标识，通常在配置高可用扩展柜的时候需要配置#9040；fc#9050高密度扩展柜标识，通常在配置高密度扩展柜的时候需要配置#9050
g)fc#9205是增强的机械爪和钳子，通常与高密扩展柜同时配置
h)fc#9316是8-16扩展柜的承重线缆，若客户配置的扩展柜数量超过8个，需要配置这个feature
i)fc#9900是加密出版物，#1604是LTO加密激活许可(license)，只有LTO4或LTO5的驱动器才支持加密功能，并且需要配置5608-A99 TKLM(Tivoli Key Lifecycle Manager)软件用来做密钥管理

5.3584-L23: 在e-config配置中features的配置注意事项
a)fc#1643表示半数槽位激活，对于L23主机柜默认只有58个槽位激活可用，激活#1643后可用槽位变为117个
b)fc#1644表示全部槽位激活，在驱动器数量不超过4个的配置情况下，L23主柜最大可激活260个槽位，随着驱动器数量增加，其可用槽位数量有所减少
c)fc#4871/#4872/#4873分别表示连接TS7700的连接组件

6.参考资料
a)名称：销售手册（sales manual）
链接：TS3500：http://www-01.ibm.com/common/ssi/rep_sm/2/872/ENUS3584-_h12/index.html
http://www-01.ibm.com/common/ssi/rep_sm/0/872/ENUS3584-_h10/index.html
TS3310：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS3576-_h01/index.html
TS3200：http://www-01.ibm.com/common/ssi/rep_sm/3/872/ENUS3573-_h03/index.html
TS3100：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS3573-_h01/index.html

b)名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
章节：第八章，第九章，第十章，第十二章
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


TS7610 软、硬件配置及注意事项

解答：

1. 硬件配置注意事项：

TS7610虚拟带库支持2个4Gbps 光纤主机端口，在e-config配置中，默认会有一块双端口的HBA卡(fc#3459)。

TS7610支持两种容量，4.4TB(fc#9313)和5.9TB(fc#9314)，在配置中可以选择。容量的变更是通过软件的方式来实现的，并非增加硬盘等的硬件方式，没有费用产生。

2. 软件配置注意事项：

TS7610中5639-TAA软件是必配的的选项，他是TS7610实现虚拟带库功能的基础。

在5639-TAA软件的配置中包含Base和Replication两个选项，Base选项包含了重复数据删除的功能，是必选的。Replication选项能够支持数据在TS7610、TS7650和TS7650G之间复制的功能，根据客户要求选配。

参考文档
销售手册(Sales Manaual)
http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS3959-_h01/index.html


TS7650 硬件中Features和cables的配置

解答：

TS7650G(3958-DD4)Features和Cables的配置:

(fc#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(fc#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(fc#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2.

(fc#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(fc#3447) Cluster Connection Kit
这个产品号提供一个network power control switch, 2 个ethernet switches, 及相关的线缆和上架硬件，用来创建一个 clustered 配置在两个 TS7650 Servers之间.#3447（The Cluster Connection Kit）必须和 两个 TS7650 Servers放在同一个机柜中。如果有两个 TS7650 Servers做cluster，则#3447是必须的，否则，不需要订，两个做 cluster的TS7650 Servers只需在其中的一个上订购一个fc#3447。缺省的数量是0，最大数量是1。

(fc#9306) ProtecTIER EE V2 load
表示在TS7650 server上配置的软件版本是ProtecTIER Enterprise Edition V2 (PID 5639-XXB) . 是必须要订的，缺省的数量是1，最大/最小数量都是1。

(fc#9340) Rack Mount DD1
表示TS7650G Server 需要放入客户提供的工业标准的 19英寸机柜. 是必须要订的，缺省的数量是1，最大/最小数量都是1。

(fc#6025) 25 Meter LC/LC Fibre Channel Cable
该feature提供一根 25 meter (82 ft.) 50.0/125 micrometer 的短波多模光纤线缆，在光纤线缆两端有LC duplex 接口. 可以用来连接TS7600 server和switch，或host，或者是后端的disk subsystem。不是必须要订的，缺省的数量是4，最大数量都是8. 最小数量都是0。

(fc#9700) No Factory Cables
当订购新机器时，不需要从工厂订购任何光纤线缆时，选择该feature。不是必须要选的，缺省的数量是0，最大数量都是1. 最小数量都是0。

TS7650(3958-AP1)Features和Cables的配置

(fc#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(fc#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(fc#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(fc#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(fc#3170) 16 2.27 GHz Processor Cores
表示提供一个 x3850 X2 processor。 是必须要选的，最大数量都是2， 最小数量都是1。

(fc#3707) 4.8 TB FC Disk Expansion
表示是DS5020 expansion drawer，带有 16 块FC 硬盘. 是必须要选的，最大数量都是6, 最小数量都是1。

(fc#3708) 4.8 TB FC Disk Controller
表示是DS5020 controller ，带有 16 块FC 硬盘. 是必须要选的，最大数量都是2，最小数量都是1。

(fc#08XX) Initial Configuration Indicators
表示是初始配置容量的标示符。

以下分别是是VTL和OST支持的4种配置方案：

(fc#6025) 25 Meter LC/LC Fibre Channel Cable
该feature提供一根 25 meter (82 ft.) 50.0/125 micrometer 的短波多模光纤线缆，在光纤线缆两端有LC duplex 接口。可以用来连接TS7600 server和switch，或host，或者是后端的disk subsystem。不是必须要订的，缺省的数量是4，最大数量都是8。最小数量都是0。

(fc#9700) No Factory Cables
当订购新机器时，不需要从工厂订购任何光纤线缆时，选择该feature。不是必须要选的，缺省的数量是0，最大数量都是1。最小数量都是0。

Top


TS7650/TS7650G e-config中console选项的配置注意事项

解答:

1.TS7650 e-config中console选项的配置
a)fc#2714 Console Expansion
该选件提供一根线缆来连接 TS3000 System Console (TSSC)，和一个 Ethernet hub 来扩展连接到 TSSC的单元数量。该选件最多可提供 14 个来自fc#2715 或另一个 fc#2714的连接。
b)fc#2715 Console Attachment
该选件提供一根线缆来连接到 TS3000 System Console的Ethernet hub，一个TS3000 System Console最多可以连接40个fc#2715 这样的连接。
c)fc#5513 KVM adjacent frame connection
该选件提供一根线缆将1-2台TS7650连接到KVM Switch
d)fc#5514 2nd server in adjacent frame
该选件表示这是第二台连接到KVM Switch的TS7650
e)关于 System Console配置， 一般建议在第一台TS7650上配置System Console，选择fc#2722 (TS3000 System Console)，TS3000主要提供了日志收集和远程支持的功能，它可以远程监控设备，在设备出现硬件报错时提供了call home的功能。如果还有其他的TS7650在同一地点运行,可以选择在其他的TS7650G配置 fc#2714 或 fc#2715。

2.TS7650G e-config中console选项的配置
a)fc#2722 TS3000 System Console
该选件提供一个TS3000 System Console。选件fc#2722包括一个 1U高的服务器（Server），键盘（keyboard），显示器（display），鼠标（mouse）和 以太网交换机（Ethernet switch）。该选件还必须配置fc#2733，fc#5510和fc#5512
b)fc#2733 Internal Modem
该选件提供一个内置调制解调器（Internal Modem）安装在 1U 服务器上。
c)fc#5510 Install KVM Switch
该选件提供KVM Switch，线缆和上架套件
d)fc#5512 KVM Display, Keyboard, Mouse
该选件提供KVM显示器，键盘，鼠标和上架套件

参考资料

1.TS7650/TS7650G销售手册链接：
TS7650：http://www-01.ibm.com/common/ssi/rep_sm/3/872/ENUS3958-_h03/index.html
TS7650G：http://www-01.ibm.com/common/ssi/rep_sm/5/872/ENUS3958-_h05/index.html

2.红皮书链接：http://www.redbooks.ibm.com/redpieces/pdfs/sg247652.pdf

Top


TS7650G 软件的配置

解答:

1．在配置完成了TS7650G的硬件后，双击e-config窗口中中间栏的software Products（software Platform）

2．在下列窗口中，不做任何修改，直接点击next按钮.

3. 在下列窗口中，不做任何修改，直接点击next按钮

4. 在下列窗口中，不做任何修改，直接点击next按钮

5. 在下列窗口选择软件的warranty时间，缺省是1年，也可以选择3年等其他年限。

6．在下列窗口中可以选择软件功能的license，其中5639-XXB ProtecTier VTL Per Server缺省选中，不需修改，Capacity support表示是重复数据删除功能的license，cluster support表示是cluster 功能的license，replication support表示是远程复制功能的license。

7．在下列窗口中，不做任何修改，直接点击next按钮.

8．接下来的窗口依次分别是前面选择的Capacity support/cluster support/replication support 的容量的定义窗口

9．下列软件配置完成的窗口，直接点击configure按钮完成软件配置

Top


N series 配置

N series

N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

N3300/N3400/N3600硬盘配置与容量问题


N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

解答：

N series有三种扩展柜可以连接,一种支持SATA硬盘,一种支持FC硬盘，另一种支持SAS/SATA硬盘。

1. 连接EXN1000扩展柜：

当配置EXN1000的SATA扩展柜时，要先在e-config工具里"Ports/Loops Indicator"选项下配置fc#9559 SATA环路数(每个环路最多能接6个EXN扩展柜)。

然后在e-config工具里"Disk Expansions"选项下添加EXN1000的扩展柜，在配置EXN1000时要注意"Cable"里面选择是第一个直连到系统柜的，还是要连接到其他扩展柜的。

其中，EXN1000的"Disks"项根据需求选择磁盘大小和数量，最小5块，最大14块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

2. 连接EXN4000扩展柜：

当配置EXN4000的FC扩展柜时，要先在e-config工具里"Ports/Loops Indicator"选项下配置fc#9558 FC环路数(每个环路最多能接6个EXN扩展柜)。

然后去e-config工具里"Disk Expansions"选项下添加EXN4000的扩展柜，在配置EXN4000时要注意"cable"里面选择是第一个直连到系统柜的，还是要连接到其他扩展柜的。

其中，EXN4000的"Disks"项根据需求选择磁盘大小数量，最小5块，最大14块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

3. 连接EXN3000扩展柜：

当配置EXN3000的SAS/SATA扩展柜时，首先要在e-config工具中“Adapters/Cables”下选择SAS接口的PCIe卡(N3400板载有SAS接口，不用配)，单控制器中SAS卡的数量为奇数，双控制器SAS卡的数量为偶数，不需要在e-config工具里"Ports/Loops Indicator"选项下配置fc#9558 或 fc#9559。然后在e-config工具里"Disk Expansions"选项下添加EXN3000的扩展柜，在配置EXN3000时要注意"Cable"里面选择是在stack的最底部，还是非底部。

其中，EXN3000的"Disks"项根据需求选择磁盘大小数量，最小5块，最大24块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

IBM于2009年10月20日推出一种新的N系列扩展柜EXN3000，这是一款4U高的扩展柜，可以配置24块SAS或者SATA硬盘。

EXN3000提供了廉价高可用性的SAS口连接方式，它通过N系列的板载或者PCIe SAS卡连接，因此可以支持它的N系列存储有N3400，N3600，N6040，N6060，N6070，N7900。

参考资料：
查阅IBM销售手册：Storage System 销售手册查询


N3300/N3400/N3600硬盘配置与容量问题

解答:

N3300配置方法如下：
N3300主柜支持12块 SAS或SATA硬盘。目前，N3300支持以下容量、类型的硬盘：
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3300支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
最大支持连接4台EXN1000或EXN4000。

N3300主柜最大支持12块硬盘、4台扩展柜最大支持56块，总共最大支持68块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3300最大支持68TB物理容量。

N3300配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3300配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数。

由于N3300上FC端口数量的限制，如果配置了扩展柜，对于N3300-A10，由于无法配置fc#9557，即没有FC端口用于连接前端主机，将不能使用FCP协议；
对于N3300-A20，可以支持FCP，但是fc#9557和fc#9560（冗余连接扩展柜）不能并存。

N3400配置方法如下：
N3400主柜支持12块 SAS或SATA硬盘。目前，N3400支持以下容量、类型的硬盘:
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3400支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
- EXN3000，支持SAS和SATA硬盘，每个扩展柜支持最少5块、最大24块SAS或SATA硬盘
最大支持连接6台EXN1000或EXN4000，或者4台EXN3000。

N3400初始订单最大支持108块硬盘、升级订单最大支持136块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN3000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs SAS硬盘
- 450GB 15K转 4Gpbs SAS硬盘
- 600GB 15K转 4Gpbs SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3400最大支持136TB物理容量。

N3400配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3400配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数；
N3400配置EXN3000扩展柜时，由于其板载集成了SAS端口，因此不需要增加接口选件。

由于N3400上FC端口数量的限制，如果配置了扩展柜，对于N3400-A11，由于无法配置fc#9557，即没有FC端口用于连接前端主机，将不能使用FCP协议；
对于N3400-A21，可以支持FCP，但是fc#9557和fc#9560（冗余连接扩展柜）不能并存。

N3600配置方法如下：
N3600主柜支持20块 SAS或SATA硬盘。目前，N3600支持以下容量、类型的硬盘:
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3600支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN3000，支持SAS或SATA硬盘，每个扩展柜支持最少5块、最大24块FC硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
最大支持连接6台EXN1000、EXN3000或EXN4000。

N3600主柜最大支持20块硬盘、6台扩展柜最大支持84块（尽管EXN3000物理上支持更多的硬盘槽位，但是目前最大也只支持84块硬盘），总共最大支持104块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN3000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs SAS硬盘
- 450GB 15K转 4Gpbs SAS硬盘
- 600GB 15K转 4Gpbs SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3600最大支持104TB物理容量。

N3600配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3600配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数；
N3600配置EXN3000扩展柜时，还需要在e-config中选择fc#1060 SAS卡。

Top


SAN/Ethernet Switch

3758-L32 SFP与线缆的选择与配置

2498-R06 配置注意事项(最近更新)

2498-R06端口配置(新增)

768B econfig配置注意事项(最近更新)

384B econfig配置注意事项(最近更新)


3758-L32 SFP与线缆的选择与配置

解答:

3758-L32是一种机架式FCoE交换机，带有24个用于连接LAN的万兆以太网端口和8个用于连接光纤通道SAN的光纤通道端口(最高速度达8 Gbps)。这种可靠的高性能交换机可提供先进的光纤通道服务并支持CEE功能，由DCFM管理软件进行管理。

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于3758-L32中的24个CEE端口中，配合OM3 Cable(线缆)使用。

SR：短波(Short Reach)模式。

LR：长波(Long Reach)模式。

Twinax：双绞线(铜缆)，自带转接模块，可以直接插在3758-L32的24个CEE端口中，有1米、3米、5米三种长度的线缆，支持10Gbps传输速率，支持热插拔。

8Gbps SW SFP：速率8Gbps的短波SFP模块，只用于3758-L32的8个FC端口中，配合multimode(多模光纤)使用。

8Gbps 10KM LW SFP：速率8Gbps的长波SFP模块，最长传输距离10KM，只用于3758-L32的8个FC端口中，配合siglemode(单模光纤)使用。

8-Pack：8个一包，可以按包选择，等同于选择8个独立的模块或线缆。

线缆参数描述：

fc#5605 5m Fibre Cable LC/LC multimode 50u: 5米长度，LC到LC接口多模光纤，配合短波模块(SW SFP)使用；

fc#5625 25m Fibre Cable LC/LC multimode 50u: 25米长度，LC到LC接口多模光纤，配合短波(SW SFP)模块使用；

fc#5721 31m Fibre Cable LC/LC multimode 9u: 31米长度，LC到LC接口单模光纤，配合长波(LW SFP)模块使用；

fc#5810 10m OM3 Cable LC/LC: 10米长度，LC到LC接口，配合10Gbps SFP+模块使用。


2498-R06 配置注意事项

解答:

SFP参数描述：

4Gbps/8Gbps：SFP接口速率为4Gbps/8Gbps；

SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；

LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；

ELW(Enhance Long Wave):超长波SFP模块，配合单模光纤线，用于超长距离数据传输；

1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；

8-Pack：SFP模块8个一包，可以按包选择；

4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用，其中配置10KM/25KM/30KM的长波SFP模块，必须配置fc#7742 Extended Fabric许可(license)。

线缆参数描述：

fc#5605 5m Fibre Cable LC/LC multimode 50μ: 5米长度，LC到LC接口多模光纤，配合短波模块(SW SFP)使用；

fc#5625 25m Fibre Cable LC/LC multimode 50μ: 25米长度，LC到LC接口多模光纤，配合短波(SW SFP)模块使用；

fc#5721 31m Fibre Cable LC/LC multimode 9μ: 31米长度，LC到LC接口单模光纤，配合长波(LW SFP)模块使用；

fc#5810 10m OM3 Cable LC/LC: 10米长度，LC到LC接口，配合10Gbps SFP+模块使用。

注意：
2498-R06中，默认激活4个FC端口以及2个以太网端口，要激活全部22个端口(16个FC端口以及6个以太网端口)，必须添加fc#7732许可(License)，SFP收发模块可以配置的数量最小配置4个最大配置44个(44个，实际端口数量的2倍，R06实际拥有22个端口)。

许可参数描述：

fc#7731 R06 Enterprise Bundle:许可（License）包，其中包含fc#7734 Performance Monitor、fc#7735 Trunking Activation、fc#7736 Adaptive Networking以及fc#7740 Fabric Watch

fc#7732 R06 Port Activation 12 FC,4 IP :激活全部端口可用，2498-R06默认激活4个FC端口以及2个以太网端口，要使用全部22个端口（16个FC端口以及6个以太网端口），必须添加fc#7732许可（License）

fc#7733 R06 8 Gbps Advanced Extension :激活两个功能：FCIP Trunking，可以把R06中的以太网端口绑定（最多4个端口），以达到增加带宽和链路冗余的效果；Adaptive Rate limiting(ARL),在带宽压力比较大的时候，ARL可以限制其它TCP连接速率，以保证R06的以太网传输带宽。

fc#7734 R06 Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；

fc#7735 R06 Trunking Activation : 激活两台交换机之间的多FC端口Trunking绑定；

fc#7736 R06 Adaptive Networking :可以设定某一链路的基本带宽，可以在压力大的带宽中保证该链路的基本带宽以及性能；

fc#7737 R06 FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；

fc#7739 R06 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由（FCR）功能；

fc#7740 R06 Fabric Watch:为交换机提供关于状态、性能以及安全性方面的前期诊断和预警，可以把故障排除在发生之前；

fc#7742 R06 Extended Fabric:支持超过10KM以上的远距离连接，根据产品不同，调整交换机内部buffer，最远可以达到3000KM，配合LW（长波）模块或者ELW（超长波）模块以及单模光纤线使用。

Top


2498-R06端口配置

解答:

2498-R06是一款FC转IP的路由交换机。最小6端口（2个IP口，4个FC口），最大22端口（6个IP口，16个FC口）

1.最小配置所需选件：
2* fc#2551 IP SFP端口模块
4* fc24xx/fc#28xx FC SFP端口模块

2.最大配置所需选件：
6* fc#2551 IP SFP端口模块
16* fc24xx/fc#28xx FC SFP端口模块
1* fc#7732（最小配置基础上，额外的12个FC端口，4个IP端口激活）


768B 交换刀片与SFP的解释以及配置注意事项

768B econfig配置注意事项

解答:

交换刀片和SFP参数描述：

768B e-Config中Connection选项中主要配置各种不同类型端口的刀片(Blade)，以及适应不同类型端口的SFP模块。一台768B最少配置1片刀片(Blade)最多配置8片刀片(Blade)，除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块。

1．768B 交换刀片(Blade)解释说明:

fc#3816：16个8Gb光纤端口交换刀片(Blade)；
fc#3832：32个8Gb光纤端口交换刀片(Blade)；
fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，比如使用光纤环路(Loop)协议的磁带机以及磁带库等设备；
fc#3864：64个8Gb光纤端口交换刀片(Blade)，自带64个8Gbps 短波光纤转接模块(SFP)；
fc#3850：光纤路由交换刀片(Blade)，提供16个光纤端口以及两个以太网口，提供FC协议到IP协议的转换功能；
fc#3870：6个10Gb光纤端口交换刀片(Blade)；
fc#3880：24个10Gb CEE端口交换刀片(Blade)，配合10Gbps fc#2117、fc#2118、fc#2151、fc#2158 SFP+转接模块使用；
fc#3890：12个8Gbps端口扩展刀片(Blade)，可以支持2个10Gbps以太网端口或者10个1Gbps以太网端口，配置组合为10个1Gbps以太网端口，或者2个10Gbps以太网端口，或者10个1Gbps以太网端口以及1个10Gbps以太网端口，要使用10Gbps以太网端口，必须配置fc#7892 10GbE Activation。

2. 768B SFP模块解释说明：

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于fc#3880 FCoE 10GbE 24-port Blade中的24个CEE端口中，配合OM3 Cable(线缆)使用；
SR：短波(Short Reach)模式；
LR：长波(Long Reach)模式；
4Gbps/8Gbps:SFP接口速率为4Gb或8Gb；
SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；
LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；
ELW(Extend Long Wave):远距离传输长波SFP模块，配合单模光纤线使用；
XFP：10Gb光纤模块；
8-Pack：SFP模块8个一包，可以按包选择；
1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；
4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用。

3. 配置注意事项：

a)768B中交换刀片(Blade)根据需求至少配置1片，最多配置8片，每类型交换刀片(Blade)所提供的端口数量以及端口类型都是不一样的，在配置时需要注意，按照实际需求选择正确的交换刀片(Blade)。除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块；
b) 8-Pack SFP模块包，等同于配置8个独立的SFP模块；
c) fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，无法连接磁带机以及磁带库等必须使用光纤环路(Loop)协议的设备。

许可和线缆参数描述：

768B e-config中License/Cables选项中主要配置光纤交换机中高级管理和高级功能的许可（license）以及应用于连接不用端口类型的线缆配置，可以根据具体的需求进行选择

1．许可解释：

fc#870 Inter-Chassis Cable Kit：提供必需的线缆使一台768B背板串联到另外一台768B交换机，以形成一台更大的交换机，配合fc#885或fc#882订购
fc#880 SAN768B Pair of Upgrade Power Supplies：再添加额外的两个电源支持，768B默认带有两个电源，选上这个功能后，总共4个电源支持
fc#885 Inter-Chassis License：激活一台768B的背板互联功能，以形成一台更大的交换机
fc#886 SAN768B FICON w/CUP Activation: 激活连接Z/OS FICON接口时，可以使用带内管理用的License
fc#887 FCIP/FC High-Performance Extension：激活FC到IP的路由转换功能，前提为768B 必须配置FC3850：光纤路由交换刀片（blade）
fc#888 FICON Accelerator: 提供FICON端口到Z/OS的连通性，并且提供Z/OS使用FCIP协议实现远程镜像（Global Mirror）的复制链路的加速功能
fc#889 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由（FCR）功能
fc#9010 SAN768B Server Application Optimization，Initial：激活下单流程的优化
fc#882 Inter-Chassis License，Half：激活一半768B交换机啊背板互联功能，使一半768B背板串联到另外一台768B交换机的一半或者背板串联到另外一台384B交换机

2. 线缆参数说明：

a) Fibre Cable multimode：多模光纤，配合SW(短波)SFP使用
b) Fibre Cable siglemode：单模光纤，配合LW(长波)SFP使用
c) OM3 Cable：第三代多模光纤，适合运行10 Gbps链路
d) 4-Pack: 4根线缆一包，可以按包选购

3. 注意事项：

a) 所有的高级许可（license）都有特定的应用功能以及应用上的必要条件，在配置选择时，需要根据用户准确需求进行配置。
b) 光纤线缆的选择需要根据所配置的交换刀片（blade）以及SFP类型进行选择

Top


384B 交换刀片与SFP的解释以及配置注意事项

384B econfig配置注意事项

解答:

交换刀片和SFP参数描述：

384B e-config中Connection选项中主要配置各种不同类型端口的刀片(Blade)，以及适应不同类型端口的SFP模块。一台384B最少配置1片刀片(Blade)最多配置4片刀片(Blade)，除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块。

1．384B 交换刀片(Blade)解释说明:

fc#3816：16个8Gb光纤端口交换刀片(Blade)；
fc#3832：32个8Gb光纤端口交换刀片(Blade)；
fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，比如使用光纤环路(Loop)协议的磁带机以及磁带库等设备；
fc#3864：64个8Gb光纤端口交换刀片(Blade)，自带64个8Gbps 短波光纤转接模块(SFP)；
fc#3850：光纤路由交换刀片(Blade)，提供16个光纤端口以及两个以太网口，提供FC协议到IP协议的转换功能；
fc#3870：6个10Gb光纤端口交换刀片(Blade)；
fc#3880：24个10Gb CEE端口交换刀片(Blade)，配合10Gbps fc#2117、fc#2118、fc#2151、fc#2158 SFP+转接模块使用；
fc#3890：12个8Gbps端口扩展刀片(Blade)，可以支持2个10Gbps以太网端口或者10个1Gbps以太网端口，配置组合为10个1Gbps以太网端口，或者2个10Gbps以太网端口，或者10个1Gbps以太网端口以及1个10Gbps以太网端口，要使用10Gbps以太网端口，必须配置fc#7892 10GbE Activation。

2. 384B SFP模块解释说明：

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于fc#3880 FCoE 10GbE 24-port Blade中的24个CEE端口中，配合OM3 Cable(线缆)使用；
SR：短波(Short Reach)模式；
LR：长波(Long Reach)模式；
4Gbps/8Gbps:SFP接口速率为4Gb或8Gb；
SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；
LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；
ELW(Extend Long Wave):远距离传输长波SFP模块，配合单模光纤线使用；
XFP：10Gb光纤模块；
8-Pack：SFP模块8个一包，可以按包选择；
1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；
4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用，其中配置10KM/25KM/30KM的长波SFP模块，必须配置fc#7803 Extended Fabric Activation许可(License)。

3. 配置注意事项：

a)384B中交换刀片(Blade)根据需求至少配置1片，最多配置4片，每类型交换刀片(Blade)所提供的端口数量以及端口类型都是不一样的，在配置时需要注意，按照实际需求选择正确的交换刀片(Blade)。除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块；
b) 8-Pack SFP模块包，等同于配置8个独立的SFP模块；
c) 选择10KM、25KM、30KM 长波SFP模块，需要配置 fc#7803 Extended Fabric Activation许可(License)；
d) fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，无法连接磁带机以及磁带库等必须使用光纤环路(Loop)协议的设备。

许可和线缆参数描述：

384B e-config中License/Cables选项中主要配置光纤交换机中高级管理和高级功能的许可（license）以及应用于连接不用端口类型的线缆配置，可以根据具体的需求进行选择

1．许可解释：

fc#803 384B Extended Fabric Activation：支持超过10KM到80KM的远距离传输缓存调整
fc#870 SAN384B Inter-Chassis Cable Kit：提供必需的线缆使一台384B背板串联到另外一台384B或者背板串联到另外一台768B交换机，以形成一台更大的交换机
fc#884 SAN384B FICON w/CUP Activation: 激活连接Z/OS FICON接口时，可以使用带内管理用的License
fc#887 FCIP/FC High-Performance Extension：激活FC到IP的路由转换功能，前提为384B 必须配置FC3850：光纤路由交换刀片（blade）
fc#888 FICON Accelerator: 提供FICON端口到Z/OS的连通性，并且提供Z/OS使用FCIP协议实现远程镜像（Global Mirror）的复制链路的加速功能
fc#890 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由（FCR）功能
fc#9020 SAN384B Server Application Optimization，Initial：激活下单流程的优化

fc#712 2499-192 Firmware Update 1 year：1年微码升级服务，2499-192默认带有1年微码更新服务，可以通过订购fc#712许可（License）再增加1年升级服务，用以保证新功能的更新
fc#713 2499-192 Firmware Update 2 years：2年微码升级服务，2499-192默认带有1年微码更新服务，可以通过订购fc#713许可（License）再增加2年升级服务，用以保证新功能的更新

2. 线缆参数说明：

a) Fibre Cable multimode：多模光纤，配合SW(短波)SFP使用
b) Fibre Cable siglemode：单模光纤，配合LW(长波)SFP使用
c) OM3 Cable：第三代多模光纤，适合运行10 Gbps链路
d) 4-Pack: 4根线缆一包，可以按包选购

3. 注意事项：

a) 所有的高级许可（license）都有特定的应用功能以及应用上的必要条件，在配置选择时，需要根据用户准确需求进行配置。
b) 光纤线缆的选择需要根据所配置的交换刀片（blade）以及SFP类型进行选择

Top


Disk System_配置

其他

存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置 (最近更新)


存储设备(Disk/Tape/SAN/NAS/SVC)的电源线如何配置

解答:

1. Disk:
a.DS4000/DS5000及EXP810/EXP520/EXP5000/EXP5060扩展柜：选择fc#9840“Peoples Republic of China”。
b.DS6000及其扩展柜：选择fc#9890 “Peoples Republic of China”。
c.DS8100/DS8300及其扩展柜：选择fc#9091 AV Voltage: 380-480, 电源线选择fc#1090 line cord。
d.DS8700/DS8800：通常选择fc#1090 line cord
e.Storwize V7000：选择fc#9730 PDU电源线 或 fc#9726 中国地区墙插电源线。

2. Tape:
a.TS2900：桌边型电源线选择fc#9840“Peoples Republic of China”；机架型电源线选择fc#7006 “Rack Mount Kit with Device to PDU Line Cord”。
b.TS3100/TS3200/TS3310：桌边型电源线选择fc#9840“Peoples Republic of China”；机架型电源线选择fc#9848 “Rack to PDU Line Cord”。

3. SAN:
a.IBM SAN-B系列(2005-BXX)：桌边型电源线选择fc#9840“Peoples Republic of China”。
b.2106-C36机柜：“Optional PDU pair”选择fc#9766 “Korea”；“Power cords”选择fc#9835 “Single phase(Korea)”。

4. NAS:
所有产品均选择fc#9008 “Power Cord, China”。

5. SVC:
选择fc#9726 “Power Cord, China”。

参考资料:
查阅IBM销售手册:Storage System 销售手册查询


附录 Storage

附录

Storage System售前常用工具

1.IBM System Storage Competitive Sales Tool Version 11.2 (April 22, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/4F68C0CF2311C10D002573720020B21B?Opendocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件

2.TCO Comparison Tool for Disk Storage Systems

软件简介：
TCOnow! for Disk可以帮助我们比较现有磁盘存储与新购方案中的磁盘存储的成本。在新方案中，我们也可以通过TCOnow! for Disk对IBM与其他厂商（如EMC、HP和日立）的磁盘成本进行比较。此外，还可以对磁盘存储潜在的高级功能与软件进行比较，提高了成本计算与比较的准确性。
TCOnow! for Disk还具有以下便捷功能：
1.快速便捷的TCO计算与分析；
2.个性化的价格报告；
3.快速生成直观的图形化建议方案书。

https://www-304.ibm.com/partnerworld/wps/servlet/mem/ContentHandler/tstotcocomptool113005

访问方法：
第一步：点击TCOnow！工具的链接；
第二步：进入“PartnerWorld: sign in”界面，在IBM ID和Password文本框中输入用户名和密码；
第三步：进入工具安装页面，根据链接和安装步骤进行下载和安装即可；或参考附件的视频教程进行安装（点击页面最下面的“tconowfordiskdemov04.exe”，下载执行即可观看）。

系统要求：
Windows 2000 (Service Pack 4) 或 Windows XP；
Internet Explorer v6.x 或 以上；
需要连接到Internet。

安装步骤：
首先，登陆 link 注册您的公司信息，详细信息请登录查询（注意：只有IBM Business Partners可以使用）；

第一步：安装CIOview Player软件：
1. 下载“CIOview Player setup.exe”本地硬盘，双击该文件（CIOview Player软件 下载链接）；
2. 安装开始，完成后，点击“Finish”；
注意：CIOview Player需要Microsoft’s .NET Framework。如果没有安装.NET Framework，安装程序会自动通过Internet安装该软件，安装时的文件名为“dotnetfx.exe”，软件提供商为InstallShield Software Corp.安装完成后可能会重启计算机。

第二步：注册 CIOview Player：
1. 打开“开始 -> 程序 -> CIOview Player -> CIOviewPlayer V4”；
2a.第一次运行时，工具自动显示未注册的对话框，填写注册表格，点击“Register”；
2b.如果没有自动显示注册表格，点击“Help -> Register”，然后填写注册表格，点击“Register”；
(注意：填写邮件地址域名须为授权代理公司的邮件域名，否则可能收不到许可文件。)
3. 关闭CIOview Player。

第三步：激活CIOview Player许可，打开一个 TCOnow! for Disk 工程：
1. 检查您关于CIOview的email信息，邮件内包括CIOview的个人唯一许可，以下两种方法可以激活；
a）点击email中的链接，打开CIOview Player目录，拖拽许可文件到打开的目录；
b）复制粘贴许可文件（player.license.txt）到“CIOview Player V4”的安装目录；
2. 打开“开始 -> 程序 -> CIOview Player -> CIOviewPlayer V4”；
3. 打开“Content -> Browse for Additional Content Modules”；
4. 在列表中找到并选中"TCOnow! for Disk"，点击Install；
5. 安装完成后，打开“File -> New -> TCOnow! for Diks”，创建一个 TCOnow! for Disk 工程。

3.TCO/ROI估算工具

一个非常好的TCO/ROI评估工具 - Alinean SCON, 该工具通过数字、图表的方式，直观地展现使用IBM的服务器整合方案可以为客户带来怎样的成本降低和高的投资回报率。Alinean作为第三方工具，不隶属任何厂商，因而更中立，合作伙伴、最终客户都可自行注册使用。

工具链接：https://roianalyst.alinean.com/stgz/

工具的介绍，可以参考网络课堂《您可以使用的TCO/ROI估算工具 》。

4.在线存储产品支持，热点包括：

(1) IBM 存储产品常见问题汇总：IBM工程师常遇到的问题汇总

(2) IBM 存储产品配置常见问题汇总

(3) 网络课堂：以Flash动画的方式对当前热门技术进行介绍，甚至包括用e-config一步一步的教您如何配置一台服务器.

还有很多其他有用的链接:
http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=4

5.IBM System Storage and TotalStorage products（英文）存储产品资料查询

IBM System Storage and TotalStorage products，包括IBM全线的存储产品，根据存储产品的字母顺序，可以方便查询相关信息
http://www-03.ibm.com/systems/storage/product

6.IBM System Storage Interoperability Matrices 存储产品兼容性文档列表

IBM System Storage Interoperability Matrices 包括最新的Disk、Tape、SAN和NAS等存储产品的兼容性文档
http://www-03.ibm.com/systems/storage/product/interop.html

7.IBM System Storage Interoperation Center在线存储产品兼容性查询

IBM System Storage Interoperation Center，可以根据存储产品的型号，查询兼容的微码版本、应用主机、系统平台、SAN交换机以及HBA卡等信息。
http://www-03.ibm.com/systems/support/storage/config/ssic

8.FC HBA Search Tool 存储产品光纤通道卡兼容性查询工具

FC HBA Search Tool， 可以根据产品类型和系统平台，查询所有的System Storage 产品的光纤通道卡（HBA）兼容性信息
http://www-03.ibm.com/systems/support/storage/config/hba/index.wss

9.销售手册

IBM硬件和软件的销售手册
http://www-01.ibm.com/common/ssi/index.wss

10.红皮书网站

全面的IBM技术参考资料网站。
http://www.redbooks.ibm.com

例如：

用“Technical Overview and Introduction”来查询，能够查询到各款IBM Power服务器的技术特点介绍红皮书
用“N series”来查询，能够查询到现在Nseries存储产品相关的红皮书。

11.IBM Publications Center，可以查询IBM所有相关产品文档，其中包括中文资料

http://www.elink.ibmlink.ibm.com/publications/servlet/pbi.wss

12.IBM 存储产品白皮书链接：

http://www-03.ibm.com/support/techdocs/atsmastr.nsf/Web/WhitePapers

存储白皮书查询列表


存储家族产品一览表

存储家族产品一览表中，展现了目前存储的主要产品，下面的文档中列出了存储产品的参数信息。

注意：本存储家族服务器一览表适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。


存储产品配置文件中英文翻译工具

通过存储产品配置文件翻译工具，可以将.CSV的英文配置文件翻译成中文的配置文件，目前我们的工具支持对DS4700, DS4800, DS5020, DS5100, DS5300, DS8100, DS8300, DS8700, DS8800, B24, B40, B80, SVC CF8/CG8, XIV, TS3100, TS3200, TS3500, TS3310, TS2900产品的硬件Feature codes进行自动翻译。

首先打开翻译工具，选择“启用宏”，点击“选择文件”按钮，选择需要进行翻译的.CSV配置文件，然后点击“开始翻译”按钮，将产生一个中文的.xls配置文件，并可对其进行保存操作。

注：此翻译工具为方便用户了解配置文件所开发的Beta版非正式工具，中文的翻译仅供参考，如果您对此工具有任何意见和建议，请及时联系我们(techline@cn.ibm.com)。

下载配置文件中英文翻译工具


存储销售手册快速查询通道

通过下面的列表，找到相关产品，点击"->" 可查到该产品的信息. 或者

输入产品类型号 MTM(Machine 产品号):

例如：DS4200, 可输入 "1814-7VA"

(注意:如果是首次进行查询，需要对所在国家和语言进行设置，确定搜索范围和返回文档的语言，如下所示：

Home Country and Site Language://选择所在国家和语言 | China(English)
Narrow searches to://选择搜索范围 | China
Return documents in English and://选择返回文档的语言 | English
Return a maximum of://选择返回文档的最大值 | 200

点击 continue, 进行重新查询.)

Storage System

Disk System

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
XIV | 2810-A14 | 宽度: 600 mm 深度: 1,092 mm 高度: 1,991 mm 重量: 876 kg | 8.4 KW | 2008/08/12 | - | ->
 | 2812-A14 | 宽度: 600 mm 深度: 1,142 mm 高度: 1,991 mm 重量: 884 kg | 8.5 KVA | 2009/07/14 | - | ->
Storwize V7000 | 2076-112 | 宽度: 483 mm 深度: 630 mm 高度: 87.5 mm 重量: Drive-ready (without drive modules installed): 17.7kg Fully configured (12 drive modules installed): 27.2 kg | 380(watts) | 2010/10/07 | - | ->
 | 2076-212 |  | 175(watts)
 | 2076-124 | 宽度: 483 mm 深度: 630 mm 高度: 87.5 mm 重量: Drive-ready (without drive modules installed): 17.7kg Fully configured (12 drive modules installed): 25.2 kg | 530(watts)
 | 2076-224 |  | 205(watts)
 | 2076-312 | 宽度: 483 mm 深度: 630 mm 高度: 87.5 mm 重量: Drive-ready (without drive modules installed): 17.7kg Fully configured (12 drive modules installed): 25.2 kg Fully configured (24 drive modules installed): 25.2 kg (55.4 lb) | 764(watts) | 2011/05/09 | - | ->
 | 2076-324
DS4200 | 1814-7VA | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2006/08/08 | 2009/06/30 | ->
DS4700-70A | 1814-70A | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2006/05/09 | 2009/12/11 | ->
DS4700-72A | 1814-72A
DS4800-80A | 1815-80A | 宽度: 481.75 mm 深度: 634.92 mm 高度: 174.5 mm 重量: 36.38 kg | 540(watts) | 2006/05/23 | 2009/12/31 | ->
DS4800-82A | 1815-82A |  |  | 2005/05/10 | 2009/12/31 | ->
DS4800-84A | 1815-84A |  |  | 2005/05/10 | 2009/03/31
DS4800-88A | 1815-88A |  |  | 2005/08/30 | 2009/03/31 | ->
DS5000 | 1818-51A | 宽度: 481.75 mm 深度: 634.92 mm 高度: 174.5 mm 重量: 40.90 kg | 580(watts) | 2008/08/26 | - | ->
 | 1818-53A
DS5020 | 1814-20A | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2009/08/25 | - | ->
DS6800 | 1750-522/EX2 | 宽度: 478 mm 深度: 610 mm 高度: 134 mm 重量: 56.4 kg | 550(watts) | 2006/08/22 | 2010/06/11 | ->
DS8100-1Year | 2421-931 | 宽度 847 mm 深度 1183 mm 高度 1930 mm Model 921/931 1189kg Model922/932 1248kg Model 9A2/9B2 1248kg Model 92E 9AE 1089kg Model 921/931 1189kg Model 922/932/9A2/9B2 1248kg Model 92E/9AE 1089kg | 5000 + N * 6000(watts) | 2006/10/31 | 2010/09/30 | ->
DS8300-1Year | 2421-932 |  | 7000 + N * 6000(watts)
DS8700-1Year | 2421-941 | 宽度 847 mm 深度 1183 mm 高度 1930 mm Model 941 1209kg Model 94E 1109kg | 6.7 KW（2-way） 7.3 KW（4-way） | 2009/10/20 | - | ->
DS8800-1Year | 2421-951 | 宽度 845 mm 深度 1226 mm 高度 1933 mm Model 951 1324kg Model 95E 1307kg | 6.7 KW（2-way） 7.5 KW（4-way） | 2010/10/07 | - | ->

Top

EXP

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
EXP5000 | 1818-D1A | 宽度: 482.60 mm 深度: 558.80 mm 高度: 132.10 mm 重量: 38.56 kg | 580(watts) | 2008/08/26 | - | ->
EXP5060 | 1818-G1A | 宽度: 482.60 mm 深度: 866.10 mm 高度: 176.0 mm 重量: 102.1 kg | 1428(watts) | 2009/10/20 | -
EXP520 | 1814-52A | 宽度: 482.6 mm 深度: 571.5 mm 高度:129.5 mm 重量: 38.56 kg | 600(watts) | 2009/08/25 | - | ->
EXP810 | 1812-81A | 宽度: 482.6 mm 深度: 558.8 mm 高度: 132.1 mm 重量: 38.56 kg | 448.5(watts) | 2006/02/28 | - | ->
EXP420 | 1812-8VA | 宽度: 482.6 mm 深度: 558.8 mm 高度: 129.5 mm 重量: 38.56 kg | 600(watts) | 2006/08/08 | 2009/12/11 | ->

Top

Tape System

Tape Library

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
TS2900 | 3572-S3H 3572-S4H 3572-S5H | 宽度: 445 mm 深度: 847 mm 高度:43.6 mm 重量:18 kg | 2008/08/26 | 3572-S3H 2011/04/15 | ->
TS3100 | 3573-L2U | 宽度: 447.5 mm 深度: 810 mm 高度: 97.6 mm 重量: 15 kg | 2006/04/11 | - | ->
TS3200 | 3573-L4U | 宽度: 447.5 mm 深度: 810 mm 高度: 185.2 mm 重量: 21.3 kg | 2006/05/09 | - | ->
TS3310 | 3576-L5B + E9U | L5B: 宽度: 443.2 mm 深度: 801.4 mm 高度: 219.7 mm 重量: 38.6 kg E9U: 宽度: 443.2 mm 深度: 801.4 mm 高度: 401.1 mm 重量: 49.9 kg | 2005/10/11 | - | ->
TS3400 | 3577-L5U | 宽度: 437 mm 深度: 895 mm 高度: 221 mm 重量: 36.9 kg | 2007/02/13 | 2010/09/24 | ->
TS3500 | 3584-L23 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 354 kg (with 0 drives and 0 cartridges) 490 kg (with 12 drives and 238 cartridges) | 2006/05/09 | - | ->
 | 3584-D23 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 271 kg (with 0 drives and 0 cartridges) 451 kg (with 12 drives and 360 cartridges) | 2006/05/09 | - | ->
 | 3584-L53 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 356 kg (with 0 drives and 0 cartridges) 481 kg (with 12 drives and 262 cartridges) | 2006/05/09 | - | ->
 | 3584-D53 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 274 kg(with 0 drives and 0 cartridges) 440 kg (with 12 drives and 396 cartridges) | 2006/05/09 | - | ->
 | 3584-S24 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: S24:285.7 kg (with 0 cartridges) 526.2 kg (with 1,000 cartridges) S54:290.3 kg (with 0 cartridges) 562.5 kg (with 1,320 cartridges) | 2008/08/26 | - | ->
 | 3584-S54
 | 3584-HA1 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 261 kg | 2005/02/15 | - | ->
TS7500/TS7700 | 3952-F05 | 宽度: 644 mm 深度: 1098 mm 高度: 1804 mm 重量: Minimum:261 kg Maximum:659 kg | 2005/10/11 | - | ->
TS7530 | 3954-CV7 | 宽度: 483 mm 深度: 711 mm 高度: 178 mm 重量: Minimum: 29.5 kg Maximum: 43.2 kg | 2008/05/13 | 2009/08/28 | ->
TS7610 | 3959-SM1 | 宽度: 449 mm 深度: 707 mm 高度: 88 mm 重量: 30 kg | 2010/07/20 | - | ->
TS7650 | 3958-AP1 | 宽度: 644 mm 深度: 1098 mm 高度: 1804 mm 重量: 728.0 kg | 2009/02/10 | - | ->
TS7650G | 3958-DD1 | 宽度: 443.6 mm 深度: 720.2 mm 高度: 172.8 mm 重量: 43.2 kg | 2008/08/29 | 2009/03/28 | ->
TS7650G | 3958-DD3 | 宽度: 443.6 mm 深度: 720.2 mm 高度: 172.8 mm 重量: 43.2 kg | 2009/02/10 | 2010/12/03 | ->
TS7650G | 3958-DD4 | 宽度: 443.6 mm 深度: 712.1 mm 高度: 172.8 mm 重量: 43.2 kg | 2010/10/26 | - | ->

Top

Tape

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
TS1040(Ultrium 4) | 3588-F4A | 宽度: 186 mm 深度: 455 mm 高度: 89 mm 重量: 5.07 kg | 2007/04/24 | - | ->
TS1130 | 3592-E06 | 宽度: 195 mm 高度: 95 mm Length, front of bezel to rear of closed retention latch: 467 mm 重量: 5.7 Kg | 2008/07/15 | - | ->
TS1120 | 3592-E05 | 宽度: 194.5 mm 深度: 467 mm 高度: 95 mm 重量: 5.7 kg | 2005/10/11 | - | ->
TS2230 | 3580-H3L | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 6.45 kg | 2006/10/31 | 2010/11/26 | ->
TS2230(LTO3 SAS) | 3580-H3S | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 4.5 kg | 2007/07/10 | 2010/12/03 | ->
TS2230 | 3580-H3V | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/11/09 | - | ->
TS2240(LTO4 SAS) | 3580-H4S | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 4.5 kg | 2007/10/23 | 2010/12/03 | ->
TS2240 | 3580-H4V | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/11/09 | - | ->
TS2250 | 3580-H5S | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/04/12 | - | ->
TS2340(LTO SCSI) | 3580-L43 | 宽度: 250.20 mm 深度: 292.10 mm 高度: 120.6 mm 重量: 6.45 kg | 2007/04/24 | - | ->
TS2340(LTO SAS) | 3980-S43 |  |  | 2010/11/26

Top

SVC

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
SVC EE | 2145-8A4 | SVC Storage Engine 宽度: 440 mm 深度: 559 mm 高度: 43 mm 重量: 10.1 kg | 2008/10/28 | 2010/11/05 | ->
SVC | 2145-8G4 | SVC Storage Engine 宽度: 440 mm 深度: 740mm 高度: 43 mm 重量: 13.0 kg | 2007/05/22 | 2009/12/12 | ->
SSPC | 2805-MC5 | 宽度: 440 mm 深度: 711 mm 高度: 43 mm Single pack 重量: 18.44 kg Pallet load 重量: 204.12 kg | 2010/11/23 | - | ->
SVC | 2145-CF8 | 宽度: 440 mm 深度: 737 mm 高度: 43 mm 重量: 14.0 kg | 2009/10/20 | 2011/07/01 | ->
SVC | 2145-CG8 | 宽度: 440 mm 深度: 737 mm 高度: 43 mm 重量: 14.0 kg | 2011/05/09 | - | ->

Top

Nseries

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
N3300 | 2859-A10, A20 | 宽度:446 mm 深度:569 mm 高度:87.5 mm 重量:19.5 kg - Model A10 重量:21.5 kg - Model A20 重量:Add 0.8 kg for each SAS drive | 2007/08/28 | - | ->
N3400 | 2859-A11, A21 | 宽度:446 mm 深度:569 mm 高度:88.5 mm 重量:19.5 kg - Model A11 重量:21.5 kg - Model A21 重量:Add 0.8 kg for each SAS drive Add 0.65 kg for each SATA drive | 2010/02/09 | - | ->
N3600 | 2862-A10, A20 | 宽度: 446 mm 深度: 582 mm 高度: 175 mm 重量: 32.6 kg- Model A10 重量: 35.3 kg- Model A20 重量: Add 0.8 kg for each SAS drive | 2007/08/28 | A10:2009/11/30 A20:2011/04/22 | ->
N3700 | 2863-A10, A20 | 宽度: 447 mm 深度: 508 mm 高度: 133 mm 重量: 35.8 kg | 2005/07/28 | 2008/10/31 | ->
N5200 | 2864-A10, A20 | 宽度: 449 mm 深度: 518 mm 高度: 130 mm 重量: 34.0 kg - Model A10 重量: 68.0 kg - Model A20 | 2005/11/08 | 2009/02/27 | ->
N5300 | 2869-A10, A20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N5600 | 2868-A10, A20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2006/11/14 |  | ->
N5300 Gateway | 2869-G10, G20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N5600 Gateway | 2868-G10, G20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N6040, N6070 | 2858-A10, A20, A11, A21 | 宽度: 447 mm 深度: 616.6 mm 高度: 258.7 mm 重量: Model A10: 44.4 kg Model A20: 52.2 kg Model A11: 44.9 kg Model A21: 53.2 kg | 2008/08/26 | A10：2011/04/22 A11：2009/11/30 A20：2011/04/22 A21：- | ->
N6060 | 2858-A12,A22 | 宽度: 447 mm 深度: 616.6 mm 高度: 258.7 mm 重量: Model A12: 44.8 kg Model A22: 53.1 kg | 2009/02/10 | A12：2009/11/30 | ->
N6210 | 2858-C10,C20 | 宽度: 447 mm 深度: 713 mm with cable management arms； 655 mm without cable 高度: 130 mm 重量: Model C10：29.7 kg Model C20：34.6 kg | 2011/01/25 | - | ->
N6240 | 2858-C21,E11,E21 | 宽度: 447 mm 深度: 713 mm with cable management arms 655 mm without cable management arms 高度: Model C21/E11：130 mm Model E21：260 mm 重量: Model C21：34.6 kg Model E11：32.9 kg Model E21：65.9 kg | 2011/01/28 | - | ->

Top

SAN

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
B16 | 2005-B16 | 宽度: 428.5 cm 深度: 307.3 cm 高度: 42.9 cm 重量: 3.99 kg without media | 66(watts) | 2005/07/26 | 2008/11/29 | ->
B32 | 2005-B5K | 宽度: 42.87 cm 深度: 26.4 cm 高度: 4.35 cm 重量: 4.9 kg, dual power supplies, no SFPs | 60(watts) | 2007/04/24 |  | ->
B64 | 2005-B64 | 宽度: 428 mm 深度: 610 mm 高度: 86 mm 重量: 13.7 kg without media | 245(watts) | 2006/05/09 |  | ->
B24-4 8Gb | 2498-B24 | 宽度: 428.8 mm 深度:306 mm 高度:42.9 mm 重量:4.35 kg | 57(watts) | 2008/05/13 | - | ->
B40-4 8Gb | 2498-B40 | 宽度: 428.8 mm 深度:610 mm 高度:42.9 mm 重量:9.34 kg | 91(watts)
B80-4 8Gb | 2498-B80 | 宽度: 428.8 mm 深度:610 mm 高度:86 mm 重量:15.6 kg | 91(watts)
SAN384B | 2499-192 | 宽度: 437.4 mm 深度: 732 mm 高度: 350 mm 重量: 25.76 kg empty chassis 68.04 kg fully populated | 841(watts) | 2009/07/14 | - | ->
SAN768B | 2499-384 | 宽度: 437.4 mm 深度: 732 mm 高度: 612.4 mm 重量: 103.50 kg |  | 2008/02/12 | - | ->
SAN04B-R | 2005-R04 | 宽度:635 mm 深度:429 mm 高度:424.4 mm 重量:12.43 kg |  | 2008/05/13 | 2010/11/27 | ->
SAN06B-R | 2498-R06 | 宽度:431.8 mm 深度:641.4 mm 高度:44.5 mm 重量:10.9 kg |  | 2009/11/10 | - | ->
SAN32B-E4 | 2498-E32 | 宽度: 429 mm 深度: 648 mm 高度: 87 mm 重量: 22.4 kg |  | 2010/11/09 | - | ->

Top


灾备，刻不容缓！环境复杂，谁能确保业务连续性

下面是一组来自企业第一线的真实数据：

  • 93%经历了重大数据丢失的公司在五年之内其商业都不能恢复正常运作；
  • 76%的公司都声称经历过灾难或者经受过重大的信息毁损；
  • 32%的公司，仅仅 4小时的宕机时间就会对业务产生严重的影响；
  • 8%的公司估计，一天的商业停运将造成至少 500，000美金的收入损失；
  • 超过 40%经历灾难的公司没能再重新经营，超过 25%的用户在重新经营两年之内还是面临关闭；
  • ……

我们处在一个变化的环境中，各种灾难或突发状况伏击在企业周围，威胁着企业赖以生存的信息系统：断电、火灾、宕机、网络瘫痪、黑客攻击……当自然灾害骤临或人员误操作时，都将对 IT 系统产生重大的影响。企业的重要数据一旦被毁坏，业务将遭受致命的打击，进而给企业造成经济和声誉的巨大损失。一旦出现情况，您的IT有把握确保业务连续性吗？！

不怕一万，就怕万一，保障业务连续性，刻不容缓！

  • 从企业外部看，不仅是自然灾害、流量峰值和意外宕机，更包括市场变幻、政策调整、企业并构、法规遵从等意想不到的业务挑战！如果不能对风险采取有效治理，一旦造成业务中断，企业为此蒙受的信誉和经济损失将无可估量，甚至承担法律风险。
  • 从企业内部看，业务运营越来越依赖于 IT 系统的稳定高效运行，不断变化的市场需求需要高可用的业务和 IT 运行, 需要不断增加全球和地区的网络支持，需要适应不断增长的数据维护要求。对 IT 软硬件可靠性、关键业务运作数据的依赖都在不断增长。企业正面临由此带来的快速增长的压力，当出现一个意料之外的重大事件或突发的市场变化，运作必须在保证对商业有限的影响下持续进行。

“打造坚强的 IT 系统，让业务在风险面前岿然不倒”，确保业务连续性再也不是可有可无的选择项，而已成为企业的当务之急！这是一个涉及极广，需要周密规划的过程，必须由一个有能力对全局负责的厂商来完成。您选择的，应该是一个具有深刻业务洞察、丰富行业经验，能帮助您从规划到实施，保护数据、管理风险并恢复业务的战略合作伙伴！

应需而生，立意高远，IBM 业务连续性解决方案，帮您搭建稳固的系统环境，从容应对风险！

—— IBM 帮助企业能清楚地识别并有效地降低业务运营的风险，自动调整，快速反应，缩短恢复时间，减少破坏性事件的影响，即使灾难从未发生！

五大服务

  • 灾难恢复咨询实施服务
    • 评估与整体规划：包括风险评估，业务冲击分析，应用影响分析，环境分析，业务连续性与灾难恢复整体实施规划策略与设计等
    • 设计：包括灾难恢复整体技术架构设计，高可用性架构设计
    • 实施：包括业务连续性、灾难恢复系统实施，高可用性架构实施
    • 灾难恢复计划：灾难恢复计划的制定，演练管理，业务连续性与灾难恢复日常运维管理

  • 灾难恢复外包服务：
    IBM 灾难恢复外包服务是指客户将自己的灾备系统托管在 IBM 已经建成的高品质灾备中心，由 IBM 为客户提供灾备数据中心运维管理，在发生灾难时，IBM 为客户提供专业的灾难恢复服务，使客户的业务得以持续运营。IBM 能够为您提供从独占式热备份到共享式冷备份高质量、多层次的灾难恢复运维服务，并可在此基础上结合业务连续性计划服务，形成端到端的完整解决方案。

  • 磁盘镜像数据复制规划和实施：
    是以存储为基础，实时的、同步/异步、与应用无关的数据远程镜像功能。基于 IBM 高端企业存储阵列，通过数据通道，以逻辑卷为基本单位，将本地存储阵列上的数据同步镜像到远端存储阵列上。

  • 信息保护服务：
    信息据保护服务是一站式托管的数据备份和恢复服务，可提供自动、安全的数据备份和恢复服务，可保护的数据包括服务器数据（文件、数据库、电子邮件等）和数据中心数据。信息保护服务可以更快更容易地保护您的关键数据，为您提供更加智慧的数据保护，确保您的业务连续性和有效的灾难恢复，费用按“现用现付”方式计算。该“现用现付”服务企业无需进行 IT 资源投入，只需按所保护的数据量收费。

  • 工作场所恢复服务：
    工作场所恢复服务为企业业务持续提供备用的工作环境， 包括专属坐席，共享坐席以及相应的办公设施。该项服务保证客户的业务单位在发生灾难的时候，可以继续从事业务。

六大优势

  • 优势一：服务标杆，业界翘楚，业务连续和灾难恢复服务的领导者
    作为全球最大的 IT 服务提供商、最大的业务连续性和灾备服务提供商，与业务连续和灾难恢复服务的领导者，IBM 为全球多个行业的客户提供稳定可靠的服务。从企业的业务需求出发，遵循业界领先的系统方法论，深刻理解行业运作，并从企业的业务需求出发，总结出了一整套业务连续性开发模式，为客户提供先进的基础设施和高效流程的支持，保障客户的业务连续性。
  • 优势二：实力超群，全球公认，无与伦比的全球支持体系
    IBM 在全球 55个国家和地区，拥有 154个灾备中心；分布于 164国家或地区的 130,000 专业人员，随时整装等发，具备支持同时多家发生灾害的能力。IBM 拥有绝对实力，为企业提供无与伦比的全球网络体系支持，可以满足极端苛刻条件下的风险牵制需求。
  • 优势三：按需设计，量身定制，六级灾备方案响应您的需求
    根据国家质监总局颁布的《信息系统灾难恢复规范》定义的灾难恢复的六个等级，IBM 运用业务连续及灾备规划设计的先进理念和实施方法，可以协助各行业客户量身制定出切实可行、投资合理并且可靠的业务连续性计划和灾难恢复技术方案，帮助不同规模和需求的企业定制最适合的业务连续性方案（包括数据备份，灾难恢复和业务连续性等），将业务停顿的风险和损失降到最低。
  • 优势四：服务全面，提前预警，帮助您真正实现业务永续！
    IBM 提供真正端到端的解决方案，以资深专家顾问准确的分析业务中断所造成的损失和影响，并据此确定业务的关键程度；以成熟可靠的项目流程，有效控制项目周期; 以行业法规为标准，并映射为有效的解决方案；以科学的项目管理统一企业对多家厂商和集成商的接口，最大限度降低项目的沟通成本和复杂程度；根据最新的技术、客户的需求及时进行服务升级及补充，以确保企业的连续运转，实现您企业的灾难恢复能力的螺旋形上升，使业务连续性计划与外界环境变更同步发展。
  • 优势五：身经百战，攻无不克，具有丰富演练及实践经验的团队为您服务
    IBM 作为业界满意度最高的服务提供商拥有丰富的实战经验。自从 1989年开始正式提供该商业服务，成功帮助超过 450个客户从灾难中恢复；拥有超过 15000份的合约， 每年超过40000次的演练。
    经典案例：利用业界先进的远程备份技术 GDPS/XRC，IBM 帮助中国农业银行设计并提供的灾难恢复系统（BCRS），成功将全国 36个省和直辖市的核心业务，从北京迁移到了上海新建的数据中心，仅停业几个小时就完成了这一历史壮举。同时，位于北京的灾备系统启动，实现了上海－北京异地的灾难备份系统运行模式。中国农业银行软件开发中心，对此给予了高度肯定。
  • 优势六：整合规划，性能卓越，IBM 全线产品为您保驾护航！
    IBM 以丰富的产品线，超强整合能力，结合深层行业洞察，通过资深 IT 咨询人才，与经验丰富的技术人才，为您企业的业务连续性保驾护航！IBM System Storage DS8000 Turbo 系列产品以其高可用性架构、国际级高性能、线性可扩展性、业界领先的新功能，以及 IBM 40年成熟丰富的容灾实践经验，能够帮助企业从容逾越风险，实现业务连续性，并极大降低总体拥有成本。

参考链接：http://www-900.ibm.com/cn/promotion/esg/storage/business_resiliency/index.shtml

Top


业务连续与灾难恢复

业务连续与灾难恢复服务

业务连续性服务

业务连续性规划

IBM业务弹性方案介绍

高可用性服务

高性能解决方案

信息高可用

数据连续性服务

灾难恢复服务

灾难恢复演练

IT 恢复

工作区恢复

灾难恢复方案规划，设计，实施

容灾解决方案

成长型企业全面灾备解决方案

容灾灾备

灾难恢复

安全高可用的优势

信息保护

法规遵从

实施 IT 架构高可用性，服务器和存储一个也不能差！

下一代数据中心高可用性解决方案

同城灾备解决方案

山东移动建设三中心灾备系统 确保业务高连续性目

远程数据灾备方案（基于DS4000的DR） 某市财政局DR项目


业务连续与灾难恢复服务

概述

业务连续性对企业成功来说至关重要。在当前的互连世界里，公司运作的每个方面几乎都容易受到业务中断的影响。因此，连续性成为企业远远超越 IT 的一个担忧。随着业务威胁的不断增多，保证业务连续性的最坏情形"保单"方法已经不足以解决问题。

然而，您是如何确定业务的连续性和恢复要求的？您如何确定关键的业务和 IT 重点并将其整合到一个综合的连续性计划中去？从哪儿开始？

IBM 业务连续和灾难恢复服务可以为您提供帮助，从计划和设计直到实施和管理。

来自 IBM 的综合服务

我们的服务远远超越传统的减灾服务。我们通过对各种威胁的潜在影响进行预测，帮助公司提高各个业务层次的弹性。IBM 的业务连续性专家已经确定了连续性计划中必须解决的三个威胁领域。我们全面的产品家族能够解决所有三个领域的问题：业务驱动、数据驱动和事件驱动。

业务驱动的服务

帮助您制定业务连续性计划的服务，与您的风险控制系统保持一致并加速满足您的业务需求

IBM 业务连续性服务

数据驱动的服务

帮助您对自己的关键数据进行优化并确保当前基础设施可用性的服务

IBM 高可用性服务

IBM 数据连续性服务

事件驱动的服务

帮助您解决灾难恢复计划中通常存在的差距的服务，以便您可以保证员工、流程和系统能够快速恢复

IBM 灾难恢复服务

我们能够提供

业务连续性服务

发现并弥补当前连续性战略与可靠的连续性计划之间的差距，与业务需求、预算和最佳实践保持一致

容灾解决方案

了解IBM针对不同IT环境提供的容灾解决方案。

成长型企业全面灾备解决方案

成长型企业全面灾备解决方案

数据连续性服务

按照法规要求和业务需求确定关键数据的重要次序并实施数据保留和检索计划，以便随时随地访问信息

灾难恢复服务

弥补灾难计划上存在的常见差距，目的是更有效地对事系统中断故做出响应，在最大限度上降低与恢复相关的成本和时间

高可用性服务

通过计划、建立并运行可以实现对企业流程、IT 环境和网络持续访问的基础架构，避免故障停机和由此引发的恢复成本

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/business-continuity-and-recovery.html

Top


业务连续性服务

概述

保持企业健康运营

保持企业正常运作意味着在面临决定企业命运的流程时，保持企业稳健运营，不要出局。企业业绩下滑或者放缓可能会严重影响您的营业收入，甚至企业的长期生存。IBM 业务连续性服务产品组合可以帮助您制定可靠的业务连续性计划，这样，企业就能面对需求中断或者激增的时候以正常状态运营。

我们提供的产品和服务

IBM 提供一整套服务产品，旨在帮助您的企业在任何情况下都能保持连续经营：

  • 业务连续性评估
    • 识别整体风险和企业中存在的弱点
    • 对连续性计划的方案、流程、过程、角色和职责进行评估
    • 将 IT 与您的关键业务流程建立对应关系
  • 业务连续性规划与设计
    • 制定业务连续性实施计划
    • 制定业务连续性计划方案，包括流程在内
  • 业务连续性确认与测试
    • 通过讨论会的方式对您对特殊情形的反应能力进行评估
  • 业务连续性计划管理
    • 对您的弹性计划进行管理，包括报告在内

我们将帮助您解决业务连续性计划各个层次的问题，从战略和愿景到人和流程，再到应用、数据、技术和设备。

切实保证您的业务连续性

您的企业是否做好应对严重数据中断的准备？如果意外事故，无论是人为事故还是自然灾难，影响了您的业务运作，您的员工能否继续工作？他们的工作效率能有多高？如果您的企业在这方面尚未准备好，或者说您不确定自己的连续性流程在遇到灾难时会如何表现，IBM 可以帮助您。

凭借我们在全球业务连续性方面 40多年的经验和专业知识，我们完全有能力帮助您解决当前业务连续性战略中存在的差距问题。

我们可以与您共同合作，根据您特殊的业务需求制定相应的计划并对计划进行管理，利用行业最佳实践来建立一个可靠而且工作效率更高的业务环境。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/bcrs_business-continuity.html

Top


业务连续性规划

目标

评估、设计、实施和管理

有效的企业级 IT 与基础架构风险及业务弹性规划，这应该是您企业的核心工作。保持运营稳定性意味着，您能够始终向着您组织设定的业务目标前进。中断或拖慢都会严重影响您的收入，甚至是您组织的长期生存。IBM 与您合作，理解您的目标，并提供IT与基础架构风险管理及业务弹性领域的专业知识，以评估一系列 IT 资源与资产风险，为您的业务流程提供坚实的后盾。

优势

可用、端到端的弹性计划，让您步步领先

使用行业最佳实践和我们的弹性企业蓝图方式，我们可以与您合作，开发并管理一个计划，满足您特定的业务需求，创造出一个可靠、生产力更高的业务环境。通过降低无法满足合同、行业标准、法规及内部控制要求方面的风险，我们能够帮助您将业务规划、IT 与业务弹性联系起来。这样，您将获得符合您不断发展的业务需求和风险容忍水平的整合计划。

IBM 提供全生命周期服务：

. 评估和规划
- 识别您环境中的总体风险和弱点
- 针对连续性计划评估计划、流程、程序、角色和责任
- 将 IT 与您的关键业务流程映射起来
- 创建计划，降低来自一系列已识别威胁的风险

. 设计
- 创建一个设计，实现更具弹性的 IT 与物理基础架构

. 实施
- 协助您实施您的计划
- 计划验证与周期性测试
- 根据业务条件的变化更新计划（收购、合并、扩张）

. 计划管理
- 针对您的风险与弹性计划提供管理，包括报表

收益

经过验证的连续性与弹性计划

在某些方面，您现在正在制定的业务运营连续性保持计划将很可能被放入测试之中。凭借业务流程方面的专业知识和超过40年的业务连续性全球经验，我们能够帮助您找到并弥合您当前业务连续性策略的缺陷，指导您满足复杂的标准、实践和法规需求，消除其对您业务连续新计划的影响。

Top


IBM业务弹性方案介绍

IT 基础架构是确保所有业务在信息化平台上运营的基石，是动态基础架构远景规划的核心。IBM为您提供具有经过验证的业务弹性功能的 IT 平台。

IBM业务弹性方案及产品介绍

IBM提供了全面的服务器、存储设备、软件和服务产品，帮您打造坚实的 IT 系统，从而保证业务的弹性：

    IBM服务器与存储高可用性解决方案，从数据存储、主机应用和服务器多方面提高您IT基础架构的整体可用性，进而保证您的业务运营的可持续性。IBM 服务器与存储高可用性方案主要包括：应用级别System z主机高可用解决方案，基于IBM Power系列UNIX服务器的应用高可用性方案， 基于PC服务器的高可用性方案以及数据存储的高可用性方案。

    IBM 灾难备份恢复解决方案，根据客户对数据及业务应用恢复时间的不同需求，从服务器、存储、软件和应用、网络和物理环境、服务和管理五个方面为客户设计灾难备份方案，充分保护客户企业核心业务数据的安全性及业务应用可恢复性，能够在数据意外丢失时，迅速恢复业务的运营，从而保证系统应用与业务运营的可持续性，降低风险。

    IBM在业务持续服务方面有完整的实施方法论，它包括分析、设计和实施三个阶段的咨询和技术服务，IBM又将该三个阶段工作划分为七个步骤，即“风险分析”、“业务影响分析”、“可恢复性评估”、“恢复策略制定”、“灾难恢复方案设计”、“业务持续计划设计”和“业务持续计划演练和维护”。

    以下分平台介绍IBM业务弹性解决方案：

    System z大型机服务器系列适用于业务弹性方案，没有一个计算机平台能像 System z 服务器一样，能那么长久而彻底地通过体系结构来集成或增强弹性的功能部件。也没有一个平台能比 System z 服务器更好地将可用性技术融入 IT 基础架构。IBM System z 服务器业务弹性解决方案能帮助您：

     . z/OS 操作系统的创新硬件功能部件和恢复能力，确保一流的可用性。
     . 减少宕机时间（从以小时计减到以秒计）。
     . 动态和自动地重新分配资源以满足应用的需求。
     . 使用运行于 z/VM 操作系统的 Linux，在几分钟内提供新的虚拟服务器以处理负载的转移。
     . 使用保持应用程序和数据可用的动态磁盘交换能力，使员工、合作伙伴和客户几乎意识不到发生了系统故障。

    当您选择 IBM System z 服务器产品作为高端应用和重要数据的平台时，可以保证您将企业的目标瞄准在随需应变市场中的世界级业务弹性。

    解决方案技术特色：

    Parallel Sysplex - Parallel Sysplex 集群允许多个应用跨服务器通信 － 它甚至还可以支持一个大型应用在多个服务器上运行，从而为该应用程序提供最佳的可用性。Parallel Sysplex 不需要对数据库分区，从而可以防止应用程序被中断，并能使宕机时间减到最小。

    GDPS - GDPS 是多站点或单站点应用程序可用性解决方案，能够管理远程拷贝配置和存储子系统（包括IBM DS8000存储服务器）、自动化并行系统综合运行任务以及从单一控制点执行故障恢复。

    上述技术为 z 系列服务器上运行关键业务的应用和数据提供了连续可用性、有效的负载管理、资源管理和快速数据恢复能力。

    我们通过 IBM Power 系列服务器和IBM System Storage 存储产品及专业的服务，帮助您构建信息高可用方案。从而保证您的业务运营的可持续性，帮助您提高业务服务水平，提升客户满意度。
具体有以下三种方案：

    磁盘设备间数据镜像方式：通过AIX操作系统的 LVM（逻辑卷管理）技术，在两套磁盘存储设备间（DS8000/DS5000/DS4000）建立数据镜像从而实现高可用性。任何一个存储的突然宕机也不会对业务造成任何影响。

    磁盘设备间数据复制方式：基于智能存储之间的数据同步功能，通过 Metro Mirror(同步的镜像模式)和 Global Mirror (异步的镜像模式)等磁盘数据复制技术，在两套同一系列的磁盘存储设备间（DS8000/DS5000/DS4000）建立数据复制关系从而实现高可用性。方案不消耗主机系统的资源，保证相关主机上的应用高效运行。

    虚拟存储数据镜像方式：通过SVC(虚拟存储控制器)的 Virtual Mirror（虚拟镜像）技术，在多套磁盘存储设备间建立数据镜像或数据复制从而实现高可用性。

    IBM Power 服务器平台业务弹性解决方案能帮助您：

     . 通过简单易用的方法对业务关键性数据进行镜像复制及同步
     . 可以对 AIX 逻辑卷做数据复制及同步，且不限物理距离
     . 灾难系统自动恢复
     . 应用环境数据的自动切换，恢复，以及应用数据与生产环境的同步
     . 简单易用的用户界面

    解决方案技术特色：

    HACMP - HACMP 是 High Availability Cluster Multi-Processing 的缩写，是 IBM 公司在 Power 系列 AIX 操作系统上的高可靠集群软件，配置冗余，消除单点故障，保证整个系统连续可用性和安全可靠性。HACMP是利用网络来侦测主机及网卡的状况，搭配AIX所提供的硬盘镜像等功能，在主机、网卡、硬盘控制卡、硬盘或网络发生故障时，自动切换到另一套备用元件上重新工作；若是主机故障还可切换至备份机上继续应用系统的运行。

    PowerVM - PowerVM 的动态分区实时迁移(Live Partition Mobility，LPM)为UNIX市场上POWER6独有功能，功能实现了将一台POWER6服务器上的分区实时地迁移到另外一台POWER6服务器上。它允许您将正在运行的AIX和Linux分区，以及它们所承载的应用程序从一个物理服务器迁移到另一个物理服务器，而不会对基础服务产生任何影响。这项迁移操作只需要花费几秒钟的时间即可完成，可以维护整个系统事务的完整性。这项迁移操作将传输整个系统环境，包括处理器的状态、内存、附加的虚拟设备，以及连接的用户， 从而有助于实现连续、高可用性目标。

    通过 IBM System x服务器或刀片服务器、存储系统及VMware 软件所部署的虚拟化平台帮助企业整合服务器、操作系统、应用平台，将所有服务器整体资源进行统一管理，按需分配资源，实现具有资源动态调整、虚拟HA、虚拟机动态部署迁移、虚拟备份功能的全方位虚拟化解决方案。从而帮助您实现IT基础架构的快速响应、高可靠、高可用和灾难恢复。

    同时基于存储系统的镜像功能均可以在x86平台上实现，从而构建信息高可用方案：

    磁盘设备间数据复制方式：基于智能存储之间的数据同步功能，通过 Metro Mirror(同步的镜像模式)和 Global Mirror (异步的镜像模式)等磁盘数据复制技术，在两套同一系列的磁盘存储设备间（DS8000/DS5000/DS4000）建立数据复制关系从而实现高可用性。
    虚拟存储数据镜像方式：通过SVC(虚拟存储控制器)的 Virtual Mirror（虚拟镜像）技术，在多套磁盘存储设备间建立数据镜像或数据复制从而实现高可用性。

     IBM业务弹性方案的优势

     IBM的领先优势

     . 40年提供弹性可用性和恢复解决方案的历史。
     . 在全球部署了数千个成功的IBM弹性解决方案。
     . 在55个国家构建了154个全球弹性中心，在全球派驻了数千名合格的IBM和合作伙伴顾问。
     . 旨在实现业务连续性和RAS的IBM硬件和存储器。
     . 100%恢复遭受灾难事件的客户系统。
     . 超过3,400个信息保护客户，管理的数据量超过24拍比特。

     IBM业务连续性服务优势

    IBM 作为全球最大的业务连续性和灾难恢复服务提供商，在该领域拥有数十年的实践经验，一直保持业界的领导地位。与 IBM 合作，您不仅可以拥有先进的灾难恢复解决方案，而且还将获得来自 IBM 的专业技术和管理支持。

    全球共享的技术和资源：我们在全球 55 个国家共设置了 154 个灾难恢复中心，其中包括北京、上海、广州。它们根据统一标准架构，可以进行互相备份与经验交流，最大程度地减少了组织、流程与工具的疏漏，同时有力地降低了成本。您还有机会与众多领域（包括商业情报、分析和 IT）的 IBM 专家直接交流，并可访问 IBM 设在世界各地的数据中心和恢复站点。

    丰富的项目管理经验：IBM 是一个以管理著称的公司。在业务连续和灾难恢复服务领域，IBM 凭借丰富的项目管理经验，能够为您设计、管理和执行全面的业务连续性计划，使您的团队把精力集中在增长和成功上。

    整合的 IBM 职能支持：我们的专业团队背后有 IBM 整合业务的强大支持，更有全世界 IBM 业务合作伙伴网络协助，职能涵盖行业和 IT 咨询、应用管理、企业改革、实施服务和全面承包各方面，为您提供端到端的全面解决方案。 依靠雄厚的技术实力和完善的服务体系，IBM 业已成为业界满意度最高的服务提供商。

Top


高可用性服务

通过计划、建立并运行可以实现对企业流程、IT 环境和网络持续访问的基础架构，避免故障停机和由此引发的恢复成本

概述

通过可用性创造业务价值

IBM 高可用性服务能够帮助您避免代价高昂的故障停机和恢复工作。我们可以帮助您对基础架构进行评估、计划、设计、建造、实施和管理，支持您当前的业务可用性和服务水平目标。IBM 高可用性服务旨在帮助您对自己的关键业务流程、IT 系统和操作环境以及网络实现一致的管理。

通过这些服务帮助您减少故障停机时间，降低基础架构的复杂性，改善您对 IT 资源的利用方式，这样，您就可以满足甚至超过 IT 可用性和服务水平要求，为企业创造价值。您还可以为进入新的市场领域做好充分的准备，对需求高峰进行管理并且对最新收购的公司进行快速整合。

我们提供的产品和服务

IBM 高可用性服务能够帮助您在企业的各个层次上保持正常、健康的运行。具体的服务产品如下：

  • 高可用性评估
    • 对 IT 可用性计划、流程、过程、角色、职责、报告、控制和服务水平实现情况进行分析
    • 通过事后分析、故障成本或组件故障影响分析技术，对可能发生的故障进行分析
  • 高可用性规划与设计
    • 对高可用性进行规划，包括计划、计划管理、报告和服务水平管理
    • 高可用性流程和过程设计，包括角色和职责
    • IBM System z, IBM System i, IBM System p, IBM System x 和多供应商服务器以及存储和网络高可用性技术结构设计
  • 高可用性实施
    • IBM 服务器优化与整合服务规划、设计和实施 － IBM 针对地理分散的开放式集群产品、IBM Geographically Dispersed Parallel Sysplex（GDPS）技术、IBM AIX 操作系统和 Microsoft Windows 操作系统提供的实施服务
  • 高可用性容量服务
    • 针对 System z, System i, System p 和多供应商服务器，IBM 和非 IBM 存储设备以及网络的预定容量服务
    • 数据中心和工作场所连续性托管

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/bcrs_high-availability.html

Top


高性能解决方案

业务运营越来越依赖于 IT 系统稳定高效地持续运行，如何降低更新、检修和维护等引发的计划内停机要求，保持业务持续不间断；如何经受住无法预知的断电、自然灾害、网络攻击、误操作等的考验，减少宕机的影响……为企业构建一个更持续稳定、更高可用的基础设施是 IT 建设的当务之急！

今天，服务器的高可用性（High Availability，简称 HA）对很多企业并不陌生，但系统的整体可用性是由服务器可用性、存储可用性和应用可用性共同决定的（乘数效应），往往取决于最薄弱的环节，应用又是构建在服务器和存储环境之上，因此服务器和存储两部分的独立可用性就尤其需要做到最好，才能保证系统的整体高可用性。特别是随着 IT 系统在业务运作中扮演的角色越来越重要，数据海量扩充，信息成为企业最宝贵的资产之一，IT 系统就向存储的可用性发起更高挑战。全新的系统高可用性概念提出：IT 架构高可用性，服务器和存储一个也不能差！

IBM系统高可用性解决方案，通过 IBM Power Systems 服务器和 IBM Storage 存储无缝的、默契的组合，为系统高可用提供强有力的保障，提高您 IT 基础架构的整体可用性，进而保证您的业务运营的持续性：

无缝配合+独有 LVM 技术，确保系统稳定、可靠、零宕机！

利用内置于 AIX 的 LVM 管理技术，在主机上实现对两台存储设备的同时操作，实现最高境界的高可用性。

  • 磁盘镜像方式——在两套 System Storage 磁盘设备间，建立镜像关系，更高可靠、更高可用！

    通过 Power 服务器独有的内置于 AIX 操作系统的 LVM（逻辑卷管理）技术，在两套 IBM System Storage 磁盘设备间（DS8000/DS5000/DS4000），建立数据镜像关系。两套存储设备同时处于活动状态。生产主机在写数据时，会同时写入两套磁盘设备中。在双主机和双存储的环境中，即使有一半的主机系统和一半的存储系统发生故障从而导致不能正常工作，则由于另外一半设备是独立工作，整个系统也不会发生瘫痪，同时还可以接管故障系统的服务，确保业务系统继续运行，实现了最高境界的高可用性——零宕机、零中断、自动切换，充分满足客户对高可靠性和连续可用性的要求。

    采用 LVM 方案，用户不必改变现有环境，也不存在数据集中迁移的问题，而且业务系统保持同时在线；不存在系统接管、应用重新启动等问题，可以实现系统的平滑过渡。实施 LVM 方案，既可以在相同型号的 IBM 存储产品之间进行，也可以在不同型号的 IBM 存储产品之间进行。

    除了 LVM，IBM 还可以提供更多的存储高可用性解决方案。

强大的 System Storage 高可用方案，为全系统安全提供可靠保障！

  • 利用存储复制技术实现高可用性 （磁盘复制方式）

    避免由于存储介质损坏导致的业务中断，通过专用 Metro Mirror 实现存储数据复制，满足主机多应用、异构的存储高可用性需求；可平滑升级为同城异地同步或异步数据复制，初步实现数据级 DR，最终实现存储系统的高可用性。该数据同步复制方案无数据丢失，IBM存储设备间数据同步网络带宽占用最小，通过 Metro Mirror 或 Global Mirror 灵活实现数据复制。适用的 IBM 存储设备包括 DS8000/5000/4000、XIV、SVC、N series 等。

  • 利用 DS8300 LPAR 分区技术实现高可用性

    通过创建虚拟存储系统使扩展性与高性能完美结合，相对单一的存储设备降低了 TCO（总体拥有成本）；支持异构工作负载，并基于系统（硬件）实施，支持数据一致性，通过灵活调配与性能优化，降低人工干预，从而以存储虚拟化分区技术实现存储高可用。该方案在同一物理存储系统中实现了存储分区，灵活合理地分配物理资源，通过 LPAR 实现数据级 HA。该方案为 DS8300所特有。

  • 利用 SVC 虚拟化存储系统技术实现异构环境的高可用性

    通过 SVC 虚拟化存储系统技术实现数据级高可用，应用 Flashcopy 和 Metro Mirror/Global Mirror，支持简便可行的全局数据异地复制，显著提高在线存储空间利用率，实现快速便捷、不影响应用运行的数据迁移能力；具备单点管理、统一的管理界面，简化管理；借助SVC将多个磁盘系统的容量整合为一个单一的“容量池”，节省空间和能源，通过 SVC 虚拟磁盘技术将数据同时写入到两份或多份虚拟磁盘中，实现存储数据的高可用。该方案采用虚拟化存储管理，大大提高存储资源利用率；实现集中的存储管理；安全地实现存储数据HA；真正的跨设备平台的虚拟存储系统。

  • 更高级别的两地三中心容灾解决方案实现高可用性

    避免单点故障，搭建全 RAID 所有磁盘驱动器、永远配置热备盘和双活动服务器，并支持可选的基于主机 I/O 路径故障切换与恢复，可在线微码升级，在线管理控制，支持冗余管理平台。采用极为可靠稳定的操作系统，支持闪存拷贝（Flash Copy）、同城镜像（Metro Mirror）、全局镜像（Global Mirror）、三点级连镜像拷贝（MGM）等多种先进功能。该方案实现数据 0丢失和本地存储 HA，远程异步数据复制，配合 IBM 主机系统的无缝灾备切换。

IBM 系统高可用性解决方案，优势无可比拟！

  • IBM Power Sysmtes 服务器采用大型机可用性设计的高 RAS 系统硬件，配备消除计划内停机的动态分区实时迁移（Live Partition Mobility）功能；

  • IBM Power Sysmtes 服务器具有极高可靠性的 AIX 操作系统，配备消除计划内应用停顿的动态应用程序迁移（Live Application Mobility）功能；

  • IBM Power Sysmtes 服务器提供包括实现本地高可用集群以及远程容灾功能的 PowerHA 高可用性软件；

  • IBM 高可用性解决方案与远程灾备系统相辅相成；

  • IBM 提供从存储设备个体到存储层整体的高可用性支持，如高可用产品 DS8000、DS5000、DS4000，再加上磁盘镜像方式、磁盘复制方式、DS8300 虚拟化分区、SVC 等满足不同需求的高可用性方案，让数据更加安全；

  • IBM作为全球最大的业务连续性和灾备服务提供商，超过 2,500个专职人员，成功实施案例超过 15,000个；

  • IBM 服务器和存储组合由统一服务团队整合管理，效率和完整性更高，服务承诺更长远，总体维护成本低。

参考链接：http://www-31.ibm.com/systems/cn/bluehome/hotoffer/highavailability/index.shtml?

Top


信息高可用

目标

对于提高可用性水平的需求不断增加

面对全球竞争和在多个时区的客户，各企业需要将他们 IT 服务 24x7 的可用性作为求得生存的前提条件。但是，很多公司对于“可用性”有着不同的理解。它不仅仅是指服务器硬件有效运行，还有一个定义，即公司内部客户、外部客户（例如顾客）和企业对企业交易可以成功完成，并且效果良好。这需要网络、服务器、应用和数据层不仅可用，还要妥善运行——应用及时完成，生成所需的会计统计，并满足所有法规需求。

客户希望合并基础架构及其管理，以降低成本，提高效率和灵敏性。但是，当部署更少的系统和解决方案时，要保持这些系统和解决方案高度可用就变得前所未有的重要了。要将这些服务蛋装入更少的篮子中——那么，每个篮子必须格外结实。

优势

不只应对可用性问题

IBM 能够施以援手。我们提供始终具有最高可靠性、可用性和可服务性特性的硬件。通过虚拟化功能、可靠的软件和自动化管理工具，IBM 解决方案是动态基础架构的一个重要元素。所有这些都能够确保组织内外的最终用户能够不断访问您整个 IT 基础架构中的服务，且不会中断业务。

IBM Business Resilience 解决方案和服务是客户保持业务运营所需的基础，由此可以允许 IT 专家将更多的时间用于创新——创新可以产生竞争优势。

收益

每个 IBM 平台中内建的业务连续性、弹性和可用性特性使您能够减少计划内和计划外业务中断，并在灾难恢复过程中为您提供帮助。全球各行各业上千家客户都在依靠 IBM Resiliency 解决方案和服务保持他们业务始终在线并可用。了解有关以下平台如何能够帮助您的业务更加灵活的更多信息。

Top


数据连续性服务

按照法规要求和业务需求确定关键数据的重要次序并实施数据保留和检索计划，以便随时随地访问信息。

概述

更快地实现灾难恢复

没有任何一家企业能够承受得起关键数据丢失所带来的损失。然而您该分配多少资源用于数据保护呢？问题的关键在于在数据可用性问题和更大的安全和隐私担心之间寻找一个平衡点。

IBM 数据连续性服务旨在帮助您根据自己的规范要求和业务需求对自己的关键数据进行评估并确定优先保护顺序。我们可以与您共同合作，根据您对数据保留和检索的优先顺序制定并实施数据可用性计划。

通过设在全球 155个以上的备份与恢复中心，我们可以帮助您随时随地实现对数据的访问。我们几乎能够在任何层次上为您提供服务，满足您的需求。

我们提供的产品和服务

IBM 数据连续性服务可以帮助您简化对关键业务数据的备份和检索，满足对数据的访问、一致性和性能要求。具体来说，包括以下服务：

  • 数据连续性评估
    • 对数据连续性计划、流程、过程、角色、职责、报告和控制以及 e-mail、数据和数据库服务水平的实现情况进行分析
  • 数据连续性规划与设计
    • 为数据连续性（包括 e-mail、数据和数据库）提供 IT 流程和过程设计
  • E-mail 和数据存档
    • 通过有管理的托管服务对具有更高安全性的地点特定时间段内的 e-mail、数据库和各种数据类型进行存档。
  • E-mail 和数据连续性
    • 管理的数据连续性服务，旨在为存储块、文件或应用层次的数据提供连续的数据备份和快速恢复
    • 旨在对实时复制以及时点和在线数据备份进行管理的电子服务
    • 当主 e-mail 系统瘫痪时，热备份 e-mail 系统启动
    • 为分布式系统实现在线电子数据备份

做到有备无患

您要保护的数据价值有多大？数据丢失造成的影响将是什么？我们可以帮助您建立一个优化的数据连续性计划。最后，对自己的数据加以保护可以为您节省成本，提高员工生产力，并且为客户带去更高的价值。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/bcrs_data-continuity.html

Top


灾难恢复服务

弥补灾难计划上存在的常见差距，目的是更有效地对事系统中断做出响应，在最大限度上降低与恢复相关的成本和时间

概述

如果灾难降临，您是否已经做好准备？

IBM 灾难恢复服务能够让您将损失控制在最低限度。可以让您在自己规定的时间和恢复点快速实现数据恢复。因此，您不会受到任何损失。

我们的服务主要是帮助您保证数据安全，保持您的关键员工在线，保证您的关键业务流程能够正常运行，然后，一旦主系统恢复，就将临时数据迁移回去。

灾难规划需要全球资源。IBM 广泛的资源网络和功能证明了IBM 的实力。我们在全球提供针对特殊行业的专业知识。我们在全球 55个国家设有 154个灾难恢复中心。我们在全球签署的灾难恢复合同多达 15,000份，我们拥有足够的专业知识，无论灾难发生在哪里，都能帮助您快速实现恢复。

我们提供的产品和服务

IBM 灾难恢复服务可以帮助您在发生灾难时对业务进行保护。具体来说，IBM 提供下列服务产品：

  • 灾难恢复评估
    • 对您灾难恢复计划的方案、流程、过程、角色和职责进行评估，包括 IBM System i服务器备份和恢复分析
  • 灾难恢复规划与设计
    • 帮助对灾难恢复进行规划，包括计划管理、报告和服务水平管理
    • 对结构进行设计，帮助提高诸如 IBM System z，System i，System p，System x和多供应商服务器、存储及网络技术的恢复能力
  • 灾难恢复演练
  • 数据中心恢复
    • 提供对全球 IBM 恢复中心的访问
    • 利用存储在 IBM 地点的数据快速恢复客户端环境
    • 在多个客户端地点提供灾难恢复
    • 送出 System i 和 System p 备用服务器
  • 网络恢复
    • 对客户端网络进行灾难恢复
  • 工作场所恢复
    • 为固定地点或虚拟工作场所提供客户端工作场所灾难恢复
    • 为固定地点提供呼叫中心灾难恢复
    • 通过移动恢复中心提供灾难恢复
  • 灾难恢复确认与测试
    • 帮助您对灾难恢复计划进行测试，包括 System i 恢复测试
    • 协助您对灾难恢复计划进行测试
    • 召开讨论会，帮助对您的灾难恢复计划进行测试

我们能够提供

IT 恢复

帮助企业对突发事件的快速恢复做好准备

工作区恢复

提供现场、虚拟和/或移动环境，帮助企业和员工在发生灾难或系统中断期间继续工作

灾难恢复方案规划，设计，实施

IBM 的咨询顾问在对您的企业进行全面分析评估的基础上，根据您的业务需求和灾难恢复指标，为您制订灾难恢复策略，设计和实施不同层次的灾难恢复解决方案，并确认不同方案的财务影响。

灾难恢复演练

IBM为已有灾备系统的客户提供专业的灾难恢复演练服务，通过灾难恢复演练来验证客户灾备系统的可靠性，增强客户业务系统的抗灾能力，使业务连续性得以保障。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/bcrs_disaster-recovery.html

Top


灾难恢复演练

IBM为已有灾备系统的客户提供专业的灾难恢复演练服务，通过灾难恢复演练来验证客户灾备系统的可靠性，增强客户业务系统的抗灾能力，使业务连续性得以保障。

服务详述

“你的灾备系统还好吗？”
“上次演练距今已经多久了？”
“时过境迁，你的恢复手段还能用吗？”
“你的IT系统更新了一次又一次，你的灾难恢复计划更新了吗？”
“负责灾难恢复的伙计们是否已经记不起灾难恢复的流程了？”
……

IBM为已有灾备系统的客户提供专业的灾难恢复演练服务，通过灾难恢复演练来验证客户灾备系统的可靠性，增强客户业务系统的抗灾能力，使业务连续性得以保障。

服务目标:

灾难恢复演练可以帮助客户确保灾难备份系统和灾难恢复计划的持续有效性。通过灾难恢复演练客户可以实现以下目的：

  • 检验灾难恢复计划可以满足客户灾难恢复的要求；
  • 验证灾难恢复系统的高可用性、高可靠性和高响应度；
  • 确认灾难恢复水平满足客户灾难恢复目标（RTO、RPO、NRO）的要求；
  • 确认灾难备份系统的处理能力符合客户的要求；
  • 提高恢复团队的恢复技能。

任务描述:

  • 协助客户制定演练策略，确定演练的目标和范围；
  • 协助客户建立首次演练组织机构；
  • 协助客户确定演练的范围、演练参与部门等；
  • 协助客户制定演练实施方案和演练工作计划；
  • 对客户演练参与人员进行灾难恢复计划和灾难演练的培训；
  • 协助客户制定演练记录模板和演练测试用例；
  • 负责准备演练环境，如IT系统环境、工作与生活环境等；
  • 协助客户组织并实施演练；
  • 负责提供为首次演练提供技术支持；
  • 协助客户记录演练过程中的各项工作；
  • 协助客户进行灾难演练的总结与评估；
  • 协助客户对灾难恢复计划进行更新。

工作成果:

  • 《灾难恢复系统总体演练方案》
  • 《灾难恢复系统演练计划》
  • 《灾难恢复系统演练总结》
  • 《灾难恢复系统测试和验收结果》

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/recoverability-assessment.html

Top


IT 恢复

帮助企业对突发事件的快速恢复做好准备

概述

意外突发事件会造成严重后果。业务中断。收入损失。客户不满。事实上，许多经历过突发事件造成数据丢失的企业都无法恢复。您的企业有应对这种意想不到情况的预案吗?

IBM 灾难恢复服务– IT 恢复提供成套 IT 恢复方案，帮助您在突发事件之后快速恢复，将损失降低到最小程度。从简单的硬件更换到重建高度复杂的映射环境，我们的 IT 恢复服务可进行定制，专门满足您的需求。我们的服务包括：

  • 数据中心恢复—IBM 业务恢复服务中心提供重新复元服务
  • 易捷恢复—中小企业数据中心恢复
  • 易捷保护—恢复恢复快速发送至任何地点

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/it-recovery.html

Top


工作区恢复

提供现场、虚拟和/或移动环境，帮助企业和员工在发生灾难或系统中断期间继续工作

概述

突发事件多种多样，从最普通的建筑物跑水、断电和公交罢工到各种悲剧的发生，如特大暴雨、暴风雪和恐怖主义袭击等。这些事件严重程度不同，但都会导致员工无法继续工作。

IBM 灾难恢复 – 工作区恢复解决方案可帮助企业保持生产状态，进而保证业务正常运营：

  • 专用工作台
  • 共享工作区
  • 虚拟连续工作区
  • 移动工作区

这一解决方案利用 IBM 业务弹性中心-配有通信功能、多供应商 IT 设备和牢固数据中心的安全保障设施。每种工作区恢复方案都可以保证技术和环境质量、功能性、价格竞争力以及保持运营不中断运行所需的灵活性。

各种方案既可单独使用，也可以相互组合，并且可与 IBM 丰富的业务连续性和弹性服务相结合。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/work-area-recovery.html

Top


灾难恢复方案规划，设计，实施

IBM 的咨询顾问在对您的企业进行全面分析评估的基础上，根据您的业务需求和灾难恢复指标，为您制订灾难恢复策略，设计和实施不同层次的灾难恢复解决方案，并确认不同方案的财务影响。

服务详述

灾难恢复解决方案设计

建立适合您的灾难恢复体系架构

或许您已经意识到，在变幻莫测的企业环境中，为企业建立一套灾难防范和恢复体系，保障企业的业务连续性至关重要。然而，在高额的投资成本面前，您是否开始犹豫？ 您可以做一下计算，如果因为关键业务中断，所造成的损失远远大于一套灾难恢复体系的建设和维护成本，那么您就有必要做此投资了。

IBM咨询顾问能够在对您的企业进行全面分析评估的基础上，根据您的业务需求和灾难恢复指标，为您制订灾难恢复策略，设计和实施不同层次的灾难恢复解决方案，并确认不同方案的财务影响，例如企业可承受的财务损失范围、中断运营的时间以及可能造成的成本负担等。

在保障业务连续性的目标下，我们会为您设计合适的灾难恢复体系架构，最大限度降低您的总体拥有成本，提高您的投资效率。

与 IBM 合作，您将用更少的成本获得更加专业的业务连续性及灾难恢复服务。更重要的是，您可以节约出内部资源来执行核心业务，从而提高企业的核心竞争力。

灾难恢复集成服务

保障您的灾难恢复项目成功地实施

要建立一套高效的灾难恢复体系，仅有完善的解决方案还是远远不够的，您还需要一支经验丰富的专家队伍，协助您完成整个项目的实施。

多年以来，IBM在全球积累了大量的灾难恢复项目集成实施经验，既有为跨国企业建立全球灾难恢复网络的经验，也有为中小客户提供灵活解决方案的经验。我们拥有一套完整的恢复程序和控制设施，能够提供多种等级的灾难恢复服务，协助您搭建灾难备份设施及网络架构，以保障数据的高度安全。

我们不仅可以为您集成IBM的多种平台产品，也可以集成其他厂商的产品和解决方案。同时，我们将凭借IBM为人称道的项目管理经验，保证您的灾难恢复项目有效、高质量地实施，保证项目质量，降低风险，并协助您控制成本。

在建立起支持业务连续性流程的灾难恢复环境之后，IBM的咨询顾问和技术专家还会对您的员工进行灾难恢复技能的培训，使其能够真正掌握业务连续性计划的实施要领，将灾难恢复项目进一步落实。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/disaster-recovery.html

Top


容灾解决方案

了解IBM针对不同IT环境提供的容灾解决方案。

服务详述

解决方案

方案描述

适用环境

基于 IBM z系列
主机的容灾方案
（GDPS+PPRC/XRC）

该技术为 z 系列服务器上运行关键业务的应用和数据提供了连续可用性、有效的负载管理、资源管理和快速数据恢复能力。

IBM z系列服务器平台和 IBM 高端存储

基于 IBM 存储的容灾方案
（PPRC,Global Mirror）

IBM 的高端存储服务器 的 PPRC，全称为 Peer to Peer Remote Copy，能够自动将源卷上的数据同步到目标卷，利用这个特性，可以实现以存储为基础的、实时的、与应用无关的数据远程镜像功能，可根据需要选择同步或异步方式。

IBM 高端存储

基于 IBM p系列主机的方案
（HACMP/XD+ LVM/GLVM）

HACMP/XD（Extended Distance）Geographic Logical Volume Manager（GLVM）提供了增强型业务连续性解决方

  • 通过简单易用的方法对业务关键性数据进行镜像复制及同步
  • 不限距离的实时镜像AIX 5L支持的逻辑卷数据
  • 灾难系统自动恢复
  • 应用环境数据的自动切换，恢复，以及应用数据与生产环境的同步
  • 简单易用的用户界面
  • 替换了 HACMP/XD 以前支持的通过 IP 镜像数据的功能

IBM p系列服务器平台

基于虚拟化存储的容灾方案

IBM SVC 可以实现虚拟存储层（Virtualization Layer）的功能，将存储智能加入到 SAN 的网络中。SVC 为各种不同的存储设备提供了一个统一的数据复制平台，例如瞬间复制 FlashCopy 和远程复制 Metro Mirror。这些复制功能都允许源磁盘卷和目标磁盘卷可以存在于不同品牌的磁盘阵列上。SVC 对当前所有的主流存储系统都支持，包括 IBM、HP、EMC、HITACH、SUN 等。

异构存储环境

基于数据库的容灾方案

IBM 可以根据客户需求，提供基于数据库的容灾方案，可以跨越不同的操作系统平台和不同的存储系统平台

数据库系统环境

基于 IBM i系列主机的容灾方案
（Mimix/OMS）

Base on iSeries OS

IBM i系列服务器平台

业务连续性咨询服务方案

IBM 为客户提供业务连续性评估，计划与设计服务，利用 IBM 业务流程专业技术识别客户环境中的所有风险和缺陷，为业务连续性体系评估计划、流程、人员角色和责任，为关键业务流程绘制蓝图。

需要保护的关键业务系统环境

灾备外包服务方案

灾备外包服务是指客户将自己的容灾系统托管在 IBM 已经建成的灾备中心，充分利用 IBM 强大的技术资源、丰富的灾备项目经验和严谨的运维管理流程来实现客户的灾备目的。
目前，IBM 已经在北京、天津、上海和深圳建有高品质的灾备中心，可以为客户提供全方位的灾备服务。

希望托管自己的容灾中心，借助成熟经验和科学管理体系实现灾备需求的客户

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/disater-solution.html

Top


成长型企业全面灾备解决方案

成长型企业全面灾备解决方案

概述

针对不同企业的 IT 系统灾备需求，以及 IT 系统状况，IBM 提供了多样的灾备解决方案。

数据级的灾备解决方案---远程数据保护，可以帮助企业自动备份和保护关键业务数据。

基于存储的高效快速灾备解决方案 (Enhanced Remote Mirroring) ，可在数十公里范围内实现生产点与容灾点的数据无丢失，保证关键业务系统及时可用，是建立同城灾备的首选解决方案。

基于 Softek 的低成本数据级灾备解决方案，可以提供较低成本的针对异构环境的系统灾备解决方案。

参考链接：http://www-935.ibm.com/services/cn/zh/it-services/enterprise_disaster_preparedness_solutions.html

Top


容灾/灾备

容灾（灾备）的重要性

企业业务的连续运营依赖于 IT 系统的容灾（灾备）能力，然而作为信息化平台基石的 IT 基础架构却面临着各种各样的风险和挑战：无法预知的 IT 硬件设备损坏、自然灾害及系统人员误操作等，或将造成数据丢失或业务的突然中断；手段频多的黑客攻击、病毒入侵、垃圾邮件、系统与网络的漏洞，更给系统及 网络带来了巨大的安全隐患；此外，用户需要实时访问机密、关键数据，而行业与政府的监管标准法规不断出台，企业在服务挑战和成本压力之间艰难平衡。

作为全球最大的业务连续性和容灾服务提供商，IBM 在该领域拥有超过 40年的实践经验，并已在 55个国家构建了 154个全球弹性中心。依靠全球派驻的数千名资深顾问，IBM 可为客户提供先进的灾难恢复方案及专业技术和管理支持，帮助企业预测潜在崩溃，实施计划来保持业务系统和资源的可用性，并在灾难和不可预知事件发生后，快 速恢复关键业务数据，保障业务运营的连续性。

IBM 业务弹性解决方案从数据存储、主机应用和服务器等多方面提高了 IT 基础架构的整体可用性，进而保证业务运营的可持续性，为您打造了坚实的 IT 系统。具体方案包括：

Power 服务器业务连续性解决方案

如今的企业业务系统正运行在一个充满风险的环境里：自然灾害无法预知、人为误操作难以避免、安全漏洞此消彼长，而业务对 IT 系统的依赖却越来越高，基础架构需要提供不间断的应用服务，消除计划内停机影响，最小化计划外停机影响。IBM Power 服务器业务连续性解决方案将基于可靠性极高的 AIX 操作系统，提供 RAS 备受赞誉的 Power Systems、利用 PowerHA 等创新技术为客户提供业界最全面最强大的集群及容灾功能，强化企业对于灾难的防御能力。

存储高可用性解决方案

企业 IT 架构的根基——信息架构正面临各种风险和挑战：无法预知的 IT 硬件设备损坏及人员误操作或将造成数据丢失进而引发业务中断；用户需要实时访问机密、关键数据向信息架构的服务提出更高要求；加强的行业与政府法规，进一步增加了企业的信息合规性压力。作为全球最大的业务连续性和灾备服务供应商，IBM 存储高可用性解决方案可以合理的成本满足企业从单一存储设备到信息架构整体的高可用性需求，并提供集成了系统规划、设备提供到实施服务的整套灾备方案，实现高附加值的存储投资。

Top


灾难恢复

灾难恢复的目标

抱最好的希望，做最坏的打算

客户需要尽可能降低无法预见的事件带来的影响，无论这些事件是微不足道的细枝末节，还是摧毁一切的悲惨灾难，他们的目标都是，更有效地对中断做出反应，并以尽可能低的成本和尽可能短的时间完成灾难恢复。在出现中断状况时保护数据和 IT 基础架构，这一方向近年来已经变得越来越重要、越来越清晰。

IBM 提供多种 IT 灾难恢复选项，其解决方案覆盖广泛，从内部恢复技术到高度复杂的恢复环境，从工作区恢复到在中断期间保持员工生产力。与 IBM 合作，您可以更好地从事件中恢复，避免它们更严重地损害您的运营状况和品牌声誉。

优势

有效地响应意外

要全面掌握多种不同的、可能发生的灾难，是非常难以实现的。因此，需要按照业务影响将它们排列优先级，并设计一种全局策略，对它们做出响应。此外，策略应该具有充分的灵活性，使之既可以适应意料之外的条件，又可以随时间不断改变，确保在最坏的情况下，组织仍可获得最佳的可靠性。所有这些都显示，您需要一个具有深入知识、单刀直入的解决方案与服务的、可信赖的顾问。

IBM 特别提供：

. IT 恢复
- 提供全面、灵活的恢复选项，为您量身定制，满足您特定的技术与业务需求。
- 提供广泛的解决方案，从简单的硬件替换到高度复杂的恢复环境。
- 利用 IBM 在 55个国家中的 154个业务弹性中心，帮助恢复客户环境。

. 工作区恢复
- 在中断期间保持员工生产力。
- 提供员工需要的技术、技术设施和环境质量服务，在恢复期间保持运营。
- 帮助限制收入损失，并解决和支持法规监管达标需求。

. 危机管理与响应
- 在出现危机时，提供员工辅助、危机通信、基础架构修复与替换等方面的支持。

收益

强有力的灾难恢复计划

制定灾难应对计划同时需要全球性的资源和特定行业的专业知识。IBM 广大的网络、能力和 40年的经验不言自明。我们提供：

. 分布于 55个国家的 154个弹性中心，用于测试、灾难声明和工作区恢复。
. 为超过 12,000家客户提供灾难恢复服务。
. 成熟的跟踪记录，在我们的客户声明出现灾难时，100%得到了恢复。

IBM 强大的灾难恢复计划能够帮助您的企业应对几乎任何中断事件并实现恢复，避免其影响您的劳动力、流程、基础架构、应用或数据。

Top


安全高可用的优势

企业成长，IT 系统是否安全至关重要，尤其在当前经济环境下，您需要的更应该是持久稳定信得过的伙伴，能给您的 IT 系统带来更安心的保障，让业务稳定运行！
当前，在您企业的 IT 运营中是否也正面临以下困扰？

  • 承担企业核心应用的服务器发展路线不清晰，IT 系统无法与时俱进
  • 系统平台正面临迁移的风险，但缺乏迁移的技术保障
  • IT 预算有限，需要长期的投资保护
  • 系统性能不强，无法保障业务安全稳定的运行

别担心，IBM Power 服务器能够助您解决这些难题！

不同于某厂商，IBM Power 服务器是业界最成熟稳定的系统平台，以及 IBM UNIX 服务器 20多年清晰稳定的产品路线，能保证您的 IT 系统持续安全运行。

产品路线更清晰，远离投资风险

  • IBM Power 服务器连续 9年在中国 UNIX 市场排名第一，目前市场占有率超过 50%，领先其他厂商 15%。
  • IBM 20多年稳定的产品路线，让您没有系统升级的后顾之忧。不像某厂商抛弃原有系统平台之后，导致新旧系统无法平滑迁移，数据安全风险陡增。
  • 您的技术更新因为某些厂商系统平台的变更而推迟？IBM 技术发展始终连贯如一，保护您的长期 IT 投资。

RAS 创新功能，为稳定运行提供坚实基础

  • 集出色的可靠性、可用性、可服务性于一体，大大提升系统稳定性。
  • 采用世界上最快的 POWER6 处理器，主频突破 5.00GHz，CPU 的出错几率减少 30%。
  • 断点程序技术、核心模块的自动隔离技术、计算校验防护技术等多项先进技术，有效保证准确运算，避免宕机。

操作平台最稳定，让业务永续运行

  • 根据 2008年 Yankee 集团研究报告，Power 服务器采用的 AIX 操作系统是世界上最稳定的操作系统，系统平均每年宕机时间仅为 36分钟，助您避免系统中断带来的损失。
  • 操作平台成熟可靠，令您安全使用，提升 IT 管理效率。

高可用解决方案，使企业关键应用更安全

  • IBM Power HA 高可用性解决方案提供可靠的监控、故障检测与自动恢复，能将计划外宕机几率减少到最低，保障业务的连续性。

无论过去、现在、还是将来，IBM 始终致力于为您打造稳定的 IT 基础架构，只有稳定才能带来真安全！

参考链接：http://www-31.ibm.com/cn/express/migratetoibm/power/safe/index.shtml

Top


信息保护

目标

为您的数据提供可靠的、工业级的保护

IBM 信息保护服务能够帮助您根据您的备份、保持和检索优先级实施计划，使您能够在几乎任何时间、任何地点访问企业内外的信息。

优势

最高达 40% 的节约和一套服务，满足所有需求

凭借按使用付费的定价和最高达 40%的成本节约，这套服务能够帮助您满足最苛刻的数据保护、业务与系统连续性、灾难恢复及法规合规标准。

收益

信息保护应成为任何全面的业务弹性计划的一部分

我们正在申请专利的自动管理引擎能够减少运营恢复中的人为错误，您还可以受益于24x7x365的监控与支持。您的内部IT部门将得以释放并投入到更具战略意义的业务活动中。最重要的是，您数据备份与恢复的效率和成功率都将得到改善。

Top


法规遵从

目标

法规越来越详细地制定各组织必须如何严格限制对于敏感信息的访问、监控和归档，特别是对于信用卡号或健康记录的客户数据，以及更具一般意义的组织信息。而且，仅仅满足法规遵从需求是不够的。各组织还必须能够证明自己能够在审计时快速、全面地满足法规遵从需求。

各组织都了解法规遵从需求，但是，并不能始终清楚其能够涉及到的很多方面，或者如何通过技术基础设施或业务流程应对它们。他们需要了解哪些法规最直接应用于他们，哪些解决方案/服务最适用于他们，可以帮助他们满足法规遵从需求，以及若他们实际面对审计，如何证明他们能够满足法规遵从需求。在很多情况下，他们会希望向一个值得信赖的合作伙伴外购对于这些功能的部分或者全部责任。

优势

IBM 风险和法规遵从解决方案将先进的硬件和软件产品与 IBM Global Services 的专业能力相结合，可以帮助您确定满足您的法规遵从目标所需要采取的行动。IBM 可以帮助您实施系统和流程，将原始数据快速转变为有用信息，帮助您：

. 分析您的市场、参考和衍生数据需求，建立一个战略数据管理计划。
. 优化供应和需求管理。
. 部署最有效的分布式架构。
. 实现来自相关数据来源的数据净化、验证和集成。
. 预测客户需求和市场趋势。
. 通过整个组织的总体数据视图，降低风险和总体拥有成本。
. 满足国内和国际法规和法律要求。

收益

IBM 风险管理和法规遵从解决方案旨在通过以下措施优化股东价值：

. 保持级别和声誉。
. 降低资金成本。
. 减少负担，降低法规遵从成本。
. 改进决策和定价。
. 增强总体效率。

我们的解决方案能够帮助您直观地感知并响应变化和威胁。

Top


实施 IT 架构高可用性，服务器和存储一个也不能差！

业务运营越来越依赖于 IT 系统稳定高效地持续运行，如何降低更新、检修和维护等引发的计划内停机要求，保持业务持续不间断；如何经受住无法预知的断电、自然灾害、网络攻击、误操作等的考验，减少宕机的影响……为企业构建一个更持续稳定、更高可用的基础设施是 IT 建设的当务之急！

今天，服务器的高可用性（High Availability，简称 HA）对很多企业并不陌生，但系统的整体可用性是由服务器可用性、存储可用性和应用可用性共同决定的（乘数效应），往往取决于最薄弱的环节，应用又是构建在服务器和存储环境之上，因此服务器和存储两部分的独立可用性就尤其需要做到最好，才能保证系统的整体高可用性。特别是随着 IT 系统在业务运作中扮演的角色越来越重要，数据海量扩充，信息成为企业最宝贵的资产之一，IT 系统就向存储的可用性发起更高挑战。全新的系统高可用性概念提出：IT 架构高可用性，服务器和存储一个也不能差！

IBM系统高可用性解决方案，通过 IBM Power Systems 服务器和 IBM Storage 存储无缝的、默契的组合，为系统高可用提供强有力的保障，提高您 IT 基础架构的整体可用性，进而保证您的业务运营的持续性：

无缝配合+独有 LVM 技术，确保系统稳定、可靠、零宕机！

利用内置于 AIX 的 LVM 管理技术，在主机上实现对两台存储设备的同时操作，实现最高境界的高可用性。

  • 磁盘镜像方式——在两套 System Storage 磁盘设备间，建立镜像关系，更高可靠、更高可用！

    通过 Power 服务器独有的内置于 AIX 操作系统的 LVM（逻辑卷管理）技术，在两套 IBM System Storage 磁盘设备间（DS8000/DS5000/DS4000），建立数据镜像关系。两套存储设备同时处于活动状态。生产主机在写数据时，会同时写入两套磁盘设备中。在双主机和双存储的环境中，即使有一半的主机系统和一半的存储系统发生故障从而导致不能正常工作，则由于另外一半设备是独立工作，整个系统也不会发生瘫痪，同时还可以接管故障系统的服务，确保业务系统继续运行，实现了最高境界的高可用性——零宕机、零中断、自动切换，充分满足客户对高可靠性和连续可用性的要求。

    采用 LVM 方案，用户不必改变现有环境，也不存在数据集中迁移的问题，而且业务系统保持同时在线；不存在系统接管、应用重新启动等问题，可以实现系统的平滑过渡。实施 LVM 方案，既可以在相同型号的 IBM 存储产品之间进行，也可以在不同型号的 IBM 存储产品之间进行。

    除了 LVM，IBM 还可以提供更多的存储高可用性解决方案。

强大的 System Storage 高可用方案，为全系统安全提供可靠保障！

  • 利用存储复制技术实现高可用性 （磁盘复制方式）

    避免由于存储介质损坏导致的业务中断，通过专用 Metro Mirror 实现存储数据复制，满足主机多应用、异构的存储高可用性需求；可平滑升级为同城异地同步或异步数据复制，初步实现数据级 DR，最终实现存储系统的高可用性。该数据同步复制方案无数据丢失，IBM存储设备间数据同步网络带宽占用最小，通过 Metro Mirror 或 Global Mirror 灵活实现数据复制。适用的 IBM 存储设备包括 DS8000/5000/4000、XIV、SVC、N series 等。

  • 利用 DS8300 LPAR 分区技术实现高可用性

    通过创建虚拟存储系统使扩展性与高性能完美结合，相对单一的存储设备降低了 TCO（总体拥有成本）；支持异构工作负载，并基于系统（硬件）实施，支持数据一致性，通过灵活调配与性能优化，降低人工干预，从而以存储虚拟化分区技术实现存储高可用。该方案在同一物理存储系统中实现了存储分区，灵活合理地分配物理资源，通过 LPAR 实现数据级 HA。该方案为 DS8300所特有。

  • 利用 SVC 虚拟化存储系统技术实现异构环境的高可用性

    通过 SVC 虚拟化存储系统技术实现数据级高可用，应用 Flashcopy 和 Metro Mirror/Global Mirror，支持简便可行的全局数据异地复制，显著提高在线存储空间利用率，实现快速便捷、不影响应用运行的数据迁移能力；具备单点管理、统一的管理界面，简化管理；借助SVC将多个磁盘系统的容量整合为一个单一的“容量池”，节省空间和能源，通过 SVC 虚拟磁盘技术将数据同时写入到两份或多份虚拟磁盘中，实现存储数据的高可用。该方案采用虚拟化存储管理，大大提高存储资源利用率；实现集中的存储管理；安全地实现存储数据HA；真正的跨设备平台的虚拟存储系统。

  • 更高级别的两地三中心容灾解决方案实现高可用性

    避免单点故障，搭建全 RAID 所有磁盘驱动器、永远配置热备盘和双活动服务器，并支持可选的基于主机 I/O 路径故障切换与恢复，可在线微码升级，在线管理控制，支持冗余管理平台。采用极为可靠稳定的操作系统，支持闪存拷贝（Flash Copy）、同城镜像（Metro Mirror）、全局镜像（Global Mirror）、三点级连镜像拷贝（MGM）等多种先进功能。该方案实现数据 0丢失和本地存储 HA，远程异步数据复制，配合 IBM 主机系统的无缝灾备切换。

IBM 系统高可用性解决方案，优势无可比拟！

  • IBM Power Sysmtes 服务器采用大型机可用性设计的高 RAS 系统硬件，配备消除计划内停机的动态分区实时迁移（Live Partition Mobility）功能；

  • IBM Power Sysmtes 服务器具有极高可靠性的 AIX 操作系统，配备消除计划内应用停顿的动态应用程序迁移（Live Application Mobility）功能；

  • IBM Power Sysmtes 服务器提供包括实现本地高可用集群以及远程容灾功能的 PowerHA 高可用性软件；

  • IBM 高可用性解决方案与远程灾备系统相辅相成；

  • IBM 提供从存储设备个体到存储层整体的高可用性支持，如高可用产品 DS8000、DS5000、DS4000，再加上磁盘镜像方式、磁盘复制方式、DS8300 虚拟化分区、SVC 等满足不同需求的高可用性方案，让数据更加安全；

  • IBM作为全球最大的业务连续性和灾备服务提供商，超过 2,500个专职人员，成功实施案例超过 15,000个；

  • IBM 服务器和存储组合由统一服务团队整合管理，效率和完整性更高，服务承诺更长远，总体维护成本低。

参考链接：http://www-31.ibm.com/systems/cn/bluehome/hotoffer/highavailability/index.shtml#max

Top


下一代数据中心高可用性解决方案

IBM 提供 业务不间断的高可用解决方案

Power 550/520 + DS5020/4700 + PowerHA + LVM/StorageHA 网络可选用 IBM S 系列或 G系列交换机。

Power 550/520 + DS5020/4700 + PowerHA + LVM/StorageHA 网络可选用IBM S系列或G系列交换机 示意图

客户目标

  • 改善业务服务质量；
  • 确保数据的连续访问。

方案价值

  • 通过冗余的硬件与软件，实现系统的高可靠与高可用特性，从而实现业务的不间断服务；
  • 完整的、自动的本地数据保护；
  • 满足数据长期保存的需求；
  • 面向灾备的解决方案。

方案优势

  • 高性能服务器+存储+网络配合；
  • 网络也采用双机双链路配置；
  • 高可靠性硬件配置，24X7 的应用保障；
  • 高性能的数据存储实现完整数据备份、恢复；
  • 单一厂家集成，从系统规划、设备提供到实施服务；
  • 是业务连续性和灾备的基础级方案。

基于存储镜像的同城灾备解决方案

Power 550/Power 520 + DS5020 + PowerHA+ERM 网络可选用 IBM S 系列或 G 系列交换机。

Power 550/Power 520 + DS5020 + PowerHA+ERM 网络可选用IBM S系列或G系列交换机示意图

客户目标

  • 同城灾难备份恢复能力；
  • 确保业务连续性。

方案价值

  • 通过磁盘镜像功能，实现跨站点的数据镜像备份，确保灾难发生时，数据的完整性；
  • 自动的数据镜像复制功能，无需干预；
  • 满足数据异地存储的；
  • 面向灾备的解决方案。

方案优势

  • 高性能服务器+存储+网络配合；
  • 高可靠性硬件配置，24X7 的应用保障；
  • 基于存储的镜像复制，与主机无关；
  • 单一厂家集成，从系统规划、设备提供到实施服务；
  • 是业务连续性和灾备的中级解决方案。

数据快速备份及恢复解决方案

Power 520(TSM备份服务器） + DS4700 + T3200 + TSM + S 系列或 G 系列交换机。

Power 520(TSM备份服务器） + DS4700 + T3200 + TSM + S系列或G系列交换机示意图

客户目标

  • 减低数据损失风险；
  • 减少管理成本。

方案价值

  • 缩短备份和恢复时间、最大化应用可用性，从而改善业务连续性；
  • 运用重复数据删除和存储分层功能，提高效率并节省资源；
  • 借助创新性访问和加密特性,增强数据安全性。

方案优势

  • 高性能服务器+存储+网络交换机配合；
  • Tivoli 高级数据恢复管理技术可使数据免受损失风险，帮助降低复杂性，减少管理成本并遵从数据保持和可用性要求；
  • 单一厂家集成，从系统规划、设备提供到实施服务。

参考链接：http://www-31.ibm.com/cn/express/migratetoibm/ngdc/solution.shtml#high_useable

Top


同城灾备解决方案

本方案可以帮您实现：

  1. 通过磁盘镜像功能，实现跨站点的数据镜像备份，确保灾难发生时数据的完整性。
  2. 自动的数据镜像复制功能，无需人工干预，实现数据异地存储。
  3. 提高系统可用性，增加业务的可持续性，关键业务应用程序免受故障影响。
  4. 预测潜在崩溃，并实施计划来保持业务系统和资源的可用性。
  5. 在灾难和不可预知事件发生后，最快恢复关键业务数据，保障业务运营持续性。
  6. 加强风险管理，提高市场竞争力。
  7. 提高业务服务水平，提升客户满意度。

本方案的解决之道：

  • Power 550/Power 520 + DS5020 + PowerHA+ERM
  • 网络可选用IBM S系列或G系列交换机；
  • 高性能服务器+存储+网络配合；
  • 生产机房服务器的高可用：通过IBM Power系列服务器上的高可靠集群软件PowerHA，进行冗余配置，消除单点故障，当任一服务器系统发生故障时，自动切换到另一套备用系统上重新工作，保证整个系统的连续可用性和安全可靠性；
  • 存储高可用：通过Metro Mirror（同步的镜像模式），和Global Mirror（异步的镜像模式） 远程磁盘镜像复制技术，在两套IBM System Storage DS5020磁盘设备间（生产机房及灾备机房各一套），建立磁盘镜像复制关系从而实现存储高可用性，从而建立完善的灾难备份中心，保证关键数据的可恢复性与业务应用的可持续性；
  • 高可靠性硬件配置，24x7小时的应用保障；
  • 基于存储的镜像复制，与主机无关；
  • 统一服务，贯穿系统规则、设备提供、部署实施，单一厂家集成。

参考链接：http://www-31.ibm.com/smb/cn/business/infrastructure/security/drbc.shtml

Top


山东移动建设三中心灾备系统 确保业务高连续性

中国移动山东公司(以下简称“山东移动”)为保障业务连续性、提高用户体验，在 2009年完成了三中心的容灾系统建设。日前，记者采访了中国移动山东公司账务中心崔可升副主任，在给记者介绍山东移动的三中心灾备系统的过程中，崔主任给出的这样一组数据给记者留下了深刻的印象：

山东移动目前拥有用户 5000多万;
系统的规模、逻辑主机数量已经接近 500台;
系统的数据量 4PB;
在每年 1-2亿的 IT 投入中，有 2/3 的投入是用于保证数据安全性和业务连续性的。

确保“三无产品”万无一失

如此大的用户规模和数据量，如何保证 BOSS 系统的业务连续性万无一失，成为了山东移动面临的首要挑战。崔主任说：“山东移动的领导曾经将 BOSS 系统的重要性形象的总结为‘三无产品’，三无是指：无可替代、无与伦比、无以复加。一句话，移动公司 BOSS 系统介于网络侧和用户侧，BOSS 系统的计费数据来源于网络侧，用户通过 BOSS 系统进行产品订购等业务办理，并查询服务使用情况。，所以它处的环节是非常非常重要的。比如你的电话无意中被停机了，或者充了值迟迟不能打出电话，用户满意度会大大降低。”BOSS 系统的安全性关系到山东 5000多万用户的用户体验，也是企业的重中之重，为了降低风险，确保 BOSS 系统有备无患，万无一失，山东移动在业务连续性方面的建设也一直在不断的进步。

2005年山东移动的主备级容灾系统上线了。建设主备级备份系统的契机是山东移动建设了一个新中心。新中心建成后，山东移动把所有的业务迁到新的中心里面去;然后把原有的老的系统进行了一个改造，做成一个主备级的容灾系统。但是，主备级容灾系统也存在着一些问题，首先是对于现有系统在出现容灾的情况下，到底能不能完成任务?因为主备中心间的系统设备容量和能力不同，所以对于容灾的安全性存在着一定的疑问。另外一方面，在主备级容灾的过程中，新建的机房，需要人员值守等等一些成本，一年、两年，可能几年计算机设备更新比较快，4、5年一个周期设备就折旧差不多了，这样大量的设备不能得到应用，对于山东移动来说也是一个很大的浪费。反观生产中心，可能在有需要业务高峰期的时候有限资源分配不够，另外一个中心却有资源限制，主备中心间的资源无法平衡，也就带来了一个矛盾的问题。

07年开始，在原来主备级容灾的基础上，山东移动实行了双中心容灾方式，双中心容灾方式解决了备用中心容灾达不到充分发挥的问题。当然用双中心的容灾方式，对管理来说是更加增加了复杂度，技术实现方面也提出了很多很高的要求。

目前，山东移动用户量越来越多，而两个中心每个中心承载的业务也是非常大，考虑降低风险的方式，于是山东移动建立了第三个物理中心。原则上每一个中心承载的用户数不超过一定数量(如 2000万户)，这样的话相当于把风险分散在多个中心，这是山东移动设计三中心系统的核心思想。新建中心在空间、电影等配套环境等比较充足，山东移动现在基本上 1 对 2 的关系——一个中心承担了全省 1/2 的量，另外两个中心各承担 1/4 的量，这是从生产角度来看。与此同时，三中心还互相之间还承担了备份的任务。目前三个中心的业务已经完全上线了，运行非常好。这三个中心就任何一个中心出问题，其他两个中心都能把业务接过来，这样整个服务质量、整个客户的满意度大大提升了。

高性能与 ROI 的平衡

在移动行业内，有一个衡量信息化成本的有效指标，就是根据发展一位新的用户，移动所需的费用的多少。在山东移动，发展一个新用户所需的 BOSS 系统投资费用不到其他省份的二分之一，如何实现如此高的 ROI，崔主任为我们介绍了山东移动的高效之道：

首先，信赖高端产品。山东移动现在所有的主机全是高端的 IBM Power 595，存储实际上也是虚拟的，当然是从我们规划来看。我们存储目前 IBM 现在也是占了绝大部分，采用 IBM 也是最高端的 DS8300，这款产品非常不错，包括我们的 BOSS 系统、经营分析系统，都采用大量的 IBM 存储系统。选择高端的机器是因为它的安全性提高了，我们就是用 IBM 最高端的机器，它的性能很好，安全性很好，这是一个方面。

另外，山东把 IBM 的虚拟技术发挥的淋漓尽致，我们全部买的都是大的设备，然后就像切蛋糕一样，切成一小块一小块的，因为这个切都是动态的切，根据业务发展情况可以动态调整，IBM 虚拟技术发挥了非常重要的作用。这就是 IBM 所提倡的动态架构，这也是为什么山东移动在 ROI 方面比兄弟省份有如此大的优势之所在。实际上，山东移动的依托于 IBM 虚拟技术的动态资源调整架构，是目前概念比较热的“云计算”落地的典型案例。

最后，是选择合作伙伴，我觉得 IBM 的技术给我们提供了很好的平台，没有好的技术，可能很多思想就实现不了。系统架构的设计以及它的控制，包括对开发管理，以及对架构的拆分等等，我觉得这个方面也是需要我们有一些技术或者需要一些经验来做。这方面有两方面：一是IBM有很好的技术给我们提供平台，另外一方面我们积累了很好的经验，这两者也是缺一不可的。

一切从客户的角度出发

山东移动的容灾系统的建设不是一蹴而就的，而是在技术不断的摸索中，不断的进步的。从最初的应急系统到目前的三中心动态备份系统，山东移动在业务连续性方面的建设历程也具有广泛的借鉴意义。

崔主任总结到：“业务连续性是一个系统工程，不单纯只是容灾的项目，怎么样保证 BOSS 系统长时间稳定运行，涉及方方面面的事情，实际上我们在 05年与 IBM 开展合作的时候，除容灾方面的建设咨询外，IBM 还承担我们的机房设计、机房装修工作。我们和 IBM 合作，我觉得最主要的是看到了 IBM 在这个行业内的经验，对于我们可以提供一些借鉴意义，少走一些弯路。”

对于容灾系统来说，除了项目的搭建以外，演练也是非常重要的。山东移动对于灾备演练也是非常的重视，比如首先进行一些桌面演练，一次不行两次演练。保证在流程方面是畅通的，然后进行真实的演练，在演练中发现存在的问题，每一次演练都给山东移动带来了很多的收获。目前，山东移动每年都要进行灾备演练。

山东移动三中心系统的建设也离不开公司领导的高瞻远瞩，崔主任这样说：“作为公司领导层，始终站在客户角度来考虑，就是要求提供运行安全使用方便的 BOSS 系统，提高客户满意度。公司领导在投资、人员等方面给予了大力支持。至于你内部采用什么样的容灾备份、容灾机制等等，那是技术细节方面的事情，是我们建设维护部门需要也应该做好的，当然压力也很大。”一切从客户体验出发，一切为了业务连续性，唯有如此，才是山东移动长远发展之道。

参考链接：http://www-31.ibm.com/systems/cn/dihub/business_resiliency/casestudies/sdmobile.shtml

Top


远程数据灾备方案（基于DS4000的DR） 某市财政局DR项目

解决方案描述:

基于DS4000系列的远程灾难数据备份，利用remote mirror来对统一城市内不同地点的两台存储进行远程的数据备份，并且要求手工切换。

解决方案详细描述

由于财务系统在任何公司都是很关键的系统，因此对于财务数据的可靠性要求就显得非常的高，此项目的产生就是基于财务系统的远程数据备份，在同一个城市距离50公里的地方进行远程存储数据的远距离备份，这属于同城异地数据备份项目，是在灾备中一个比较典型的数据备份实施项目。

该项目基于Power5服务器，并且在主站提供hacmp的单点故障解决方案，通过连接光纤交换机和DS4800来完成本地的高可用性，由于本地的数据一点因为自然因素等不可抗拒力量造成损坏，那么数据将会全部丢失，因此考虑到财务系统的安全可靠性，用户希望在距离本地50公里的地方进行数据的备份，因此整个环境的中间网络传输是基于IP的专用网络，通过分析每天用户和数据的变化量，结合IP带宽统一考虑后，觉得该项目可以执行，并在执行过程中基本顺利，最后通过远程地点DS4800的数据备份，达到了数据可靠性的保证。并且在响应时间和备份时间上基本达到了用户的要求。

虽然只完整灾备项目的一部分，但是涉及到的概念和思想均是DR的相关联信息，为进一步推动用户制定完整的灾备方案以及更完善的数据可靠性的实施带来了机会。

功能描述

  • 主站点的磁盘阵列收到主机的写请求
  • 控制器将主机的写操作请求纪录到Mirror Repository Logical Driver （信息实际是记录在一个队列上）
  • 主站点磁盘阵列将主机的写数据写入本地磁盘上。
  • 主站点磁盘阵列的控制器发送写操作完成给主机系统。
  • 主站点磁盘阵列的控制器将一致组的（Consistency Group）数据传输到备份站点的控制器上。
  • 备份站点的磁盘阵列控制器将数据写入备份站点的磁盘上。
  • 备份站点的磁盘阵列控制器将数据写完的确认发给主站点磁盘阵列的控制器。
  • 主站点磁盘阵列的控制器将Mirror Repository Logical Driver的关于此次写操作的相关信息删除。

说明：Mirror Repository Logical Driver 是磁盘阵列在启用Enhance Remote Mirror后在本地磁盘上创建的2个125MB的存储空间。Mirror Repository Logical Driver 上存放的只是和Enhance Remote Mirror有关的状态信息和控制信息。根据财政核心应用系统的运行模式对数据的实时性要求不高及灾备网络使用的是党政专线带宽有限的实际情况，建议采用异步方式（Global Mirror）进行数据灾备。

竞争优势

基于DS4000的解决方案是利用DS4000强大的控制器缓存空间，将实时传送的IO请求传送给远端的DS4000存储设备，通过缓存中预先指定好的空间保证业务不会因为实时的数据远端传送而影响业务的运行，因此DS4000提供了很好的硬件支持。

remote mirror功能能够保证数据第一次完整备份后，实时的将数据传送给远端的存储设备，不管中间因为网络问题，还是存储控制器缓存的问题，在瓶颈解决以后，都可以实现数据的续传功能，免去了用户对于数据传输时的瓶颈的担心。

通过remote mirror的恢复功能，当本地设备故障后，异地设备自动变为主模式，从而可以通过预先制定好的脚本将远端的存储空间，通过光纤以及IP网络快速的让本地的主机识别到，即可以最小化的减少应用的down机时间，又可以有助于快速的恢复业务。

业务问题

解决了用户在DS4000上的数据安全性隐患，即便因为非人为原因造成的设备损失，也不会影响数据的完整性。

也解决了用户一直担心的财务数据不可靠的风险，通过远程数据的copy，把现有的数据实时的传送给远端的DS4000存储，通过remote mirror来实现实时的copy，一旦因为网络问题出现实时数据无法传送，通过该功能的自动续传功能，还是可以保证数据的安全性，由于用户的数据量不大，所以DS4000的性能也不会受到任何的影响，保证了实时数据能够按照用户预想的时间传送到远端的DS4000存储设备上，彻底解决了用户的数据可靠性隐患。

商机

在数据日益重要的现在，如何能够快速有效的保证关键业务关键数据的完整性和可靠性成为了很多企业很重视的问题，成功的灾备方案不但要做到硬件级别的灾备，还需要做到应用级别的灾备，一个完整的灾难备份能够提供给客户一套更加可靠可行的灾难回复保证计划，包括结合hacmp，quest，remote mirror等多方协作才能构建出一套真正的DR解决方案，因此可以看出DR带来的商机还是很多的。

本次实施方案主要涉及到存储级别硬件的灾难备份，为了保证硬件级别的故障引起的数据丢失风险，基于DS4000的平台是因为目前很多

客户还是在购买DS4000的产品，对与这些用户来讲，也有很大一部分的业务存在潜在的硬件故障风险，那么如何去保证这些用户群在硬件故障或者不可抗力作用下的数据丢失风险呢，我个人认为，基于DS4000的remote mirror是一个非常有效的保证方法，因为DS4000的成本想对DS8000比较低，而且需要DS4000DR方案的客户通常会选择同城的备份方式，这样实施的风险和实施的难度都会有很大的下降，因此带来的成本也会相应的比高端的配置要低，这样在我们推广的过程中反而是一个很有利的因素。真是由于DS4000客户群的广泛，而且业务的重要性依然存在，才让我们有更多的机会能够将成熟的方案带到客户中去，从而实现中低端用户实现DR的这种可能！

投资收益率

DR，顾名思义，灾难恢复，因此基本上都是用在用户的关键业务当中，所以不管是基于DS4000，还是基于DS5000，或者DS8000的业务，都是用户认为比较重要的业务数据才会进行DR的考虑，所以一旦进行了DR的实施方案提供和涉及，给客户带来的投资收益主要是在数据的可靠性和完整性上，再加上目前基于应用的灾难备份，共同构成了一套可靠性完整性极高的用户数据保障体系。

基于硬件的DR其另一个主要好处就是当本地因为不可抗力影响造成设备损坏的时候，所有用用停止，设备损坏，应用将失去回复能力，这样基于硬件的DR就会变得很重要，因为硬件是一切的基础，此解决方案就可以满足在这样的条件下，用户及时的将数据进行远端的备份，带主要场所恢复生产以后，可以将数据完整的copy过来。类似于这次的汶川大地震，如果构建一套基于存储的DR方案，并且成功的实施，那么很多损失将会被避免，特别是银行，政府，财务等重要部门的数据和记录。

参考链接：http://www-304.ibm.com/partnerworld/gsd/solutiondetails.do?solution=38280&lc=zh&stateCd=P&page=1

Top


PowerHA

PowerHA 简介

什么是 PowerHA for AIX？它与 HACMP 有什么区别？

Power安全高可用的优势

HACMP 认证学习系列，第 1 部分：入门

HACMP 认证学习系列，第 2 部分：计划与设计

HACMP 认证学习系列，第 3 部分：安装和配置（1）

HACMP 认证学习系列，第 3 部分：安装和配置（2）

HACMP 认证学习系列，第 3 部分：安装和配置（3）

HACMP 认证学习系列，第 4 部分：集群的验证和测试

HACMP 5.x 完全手册，第 1 部分：设计和安装

HACMP 5.x 完全手册，第 2 部分：测试和维护

HACMP 5.x 完全手册，第 3 部分：脚本设计和经验共享

使用 HACMPXD + GLVM 实现高可用性集群

浅谈 HACMP 心跳

关于在虚拟 IO 环境中实现 PowerHA 的提示


PowerHA 简介

简介

随着业务需求日益增加，关键的应用程序必须一直可用，系统必须对故障有容忍能力。但是，这些有容错能力的系统的成本很高。因此，需要通过应用程序提供这些能力，同时这个应用程序还应该是经济有效的。

高可用性解决方案可以确保解决方案的任何组件的故障都不会导致用户无法使用应用程序及其数据。实现这一目标的方法是通过消除单一故障点消除或掩盖计划内和计划外停机。另外，保持应用程序高可用性并不需要特殊的硬件。PowerHA 不执行备份等管理任务、时间同步和任何与应用程序相关的配置。

图 1 是故障转移功能的示意图。当一个服务器停机时，另一个服务器接管。

图 1. 故障转移功能

PowerHA 的概述

PowerHA 和 HACMP 这两个词可以互换使用。正如前面提到的，它会消除单一故障点 (SPOF)。下表列出可能存在的 SPOF：

集群对象 | 消除 SPOF 的方法
节点 | 使用多个节点
电源 | 使用多条电路或不间断电源
网络适配器 | 使用冗余的网络适配器
网络 | 使用多个网络连接节点
TCP/IP 子系统 | 使用非 IP 网络连接相邻节点和客户机
磁盘适配器 | 使用冗余的磁盘适配器或多路径硬件
磁盘 | 使用多个磁盘以及镜像或 raid
应用程序 | 添加用于接管的节点；配置应用程序监视器
VIO 服务器 | 实现双 VIO 服务器
站点 | 添加额外站点

主要目标是，当两个服务器中的一个发生故障时，让另一个服务器接管。 PowerHA 集群技术通过提供冗余实现故障转移保护，同时通过并发/并行访问支持水平扩展。

PowerHA 术语

PowerHA 使用许多术语。它们可以分为拓扑组件和资源组件两类。

拓扑组件基本上是物理组件。它们包括：

  • 节点：System p 服务器可以是单独的分区或 VIOS 客户机
  • 网络：IP 网络和非 IP 网络
  • 通信接口：令牌环网或以太网适配器
  • 通信设备：RS232 或磁盘的心跳机制

资源组件是需要保持高可用性的逻辑实体。它们包括：

  • 应用服务器：它涉及应用程序的启动/停止脚本。
  • 服务 IP 地址：最终用户一般通过 IP 地址连接应用程序。这个 IP 地址映射到实际运行应用程序的节点。因为 IP 地址需要保持高可用性，所以它属于资源组。
  • 文件系统：许多应用程序需要挂载文件系统。
  • 卷组：许多应用程序需要高可用的卷组。

所有资源一起组成资源组实体。PowerHA 把资源组当作单一单元处理。它会保持资源组高可用性。资源组有与其相关联的策略。这些策略包括：

  1. 启动策略：这决定资源组应该激活哪个节点。
  2. 故障转移策略：当发生故障时，这决定故障转移目标节点。
  3. 故障恢复策略：这决定资源组是否执行故障恢复。

当发生故障时，PowerHA 寻找这些策略并执行相应的操作。

PowerHA 的子系统

图 2. PowerHA 的子系统

上图说明 PowerHA 由许多软件组件组成：

  • 集群管理器 clstrmgr 是核心进程，它监视集群成员关系。集群管理器包含管理拓扑组件的拓扑管理器、管理资源组的资源管理器、通过 RMC 设施起作用的事件管理器和事件脚本以及对故障做出反应的 RSCT。
  • clinfo 进程提供用于在集群管理器和应用程序之间进行通信的 API。clinfo 还提供远程监视功能，可以在集群状态发生变化时运行脚本。
  • 在 PowerHA 5 中，clcomdES 使集群管理器能够以安全的方式进行通信，不需要使用 rsh 和 /.rhost 文件。

配置两节点集群

开始研究配置之前，先讨论一下 PowerHA 的连网和存储考虑事项。

连网

PowerHA 使用网络探测和诊断故障以及为客户机提供高可用性的应用程序访问能力。

节点之间的通信也要通过网络。PowerHA 直接探测三类故障：网络、NIC 和节点故障。它通过使用 RSCT 守护进程执行探测和诊断。RSCT 实际上探测跨所有网络发送的心跳数据包是否丢失并判断准确的丢失（网络、NIC 或节点故障）。

图 3 说明所有 NIC 传输并接收心跳数据包，这有助于判断故障。

图 3. 根据心跳数据包形成的集群
根据心跳数据包形成的网络集群的示意图

如果心跳数据包的传输停止了，那么两个节点都会认为对方停机了，因此都尝试让资源组上线。这会导致大规模的数据破坏。
为了避免此问题，PowerHA 使用两种网络：

  1. IP 网络：例如以太网、Ether channel 等
  2. 非 IP 网络：例如 RS232（为了确保即使在发生网络故障的情况下 PowerHA 也能够区分网络故障和节点故障，需要非 IP 网络）

IP 地址接管 (IPAT)

大多数应用程序都要求 IP 是高度可用的。为了确保这一点，我们把服务 IP 地址包含在资源组中。把服务 IP 地址从一个 NIC 转移到另一个上的过程称为 IP 地址接管。有两种实现 IPAT 的方法：

  1. 通过别名实现 IPAT：PowerHA 使用 AIX IP 别名特性把服务 IP 地址添加到 NIC 中
  2. 通过替换实现 IPAT：PowerHA 把接口 IP 地址替换为服务 IP

存储

存储设备大致分为两类：

  1. 私有的存储：只由一个节点拥有
  2. 共享的存储：由集群中的多个节点拥有

所有应用程序的数据驻留在共享的存储设备中。为了避免数据不一致，可以按以下方式进行共享存储保护：

  1. 基于保留/释放的共享存储保护：用于标准的卷组
  2. 基于 RSCT 的共享存储保护：用于增强型并发卷组

HACMP 5.x 支持基于 RSCT 的共享存储保护，当以非并发模式使用增强型并发卷组时，这种保护方式依靠 AIXs RSCT 组件控制共享存储的所有权。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-powerhaintro/

Top


什么是 PowerHA for AIX？它与 HACMP 有什么区别？

什么是 PowerHA for AIX？它与 HACMP 有什么区别？

IBM PowerHA 是以前的 IBM High Availability Cluster Multiprocessing (HACMP) 产品的新名称。改名是为了让 HACMP 与新的 IBM Power Systems Software 计划保持一致。PowerHA for AIX V5.5 是 HACMP 5.4 的后续版本。

PowerHA 支持哪些硬件和软件？

由于支持列表过长，在这里不一一列出，请您访问下面的网址来查询 PowerHA 所支持的硬件和软件。

http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?infotype=dd&amp;subtype=sm&amp;appname=pseries&amp;htmlfid=897/ENUS5765-F62#SHeader_9

PowerHA 能够在不同的操作系统上工作吗？

可以。PowerHA与 AIX 操作系统和 System p 服务器紧密地集成，可以提供在其他操作系统和硬件组合上不可用的许多特性。PowerHA V5 支持 Power 服务器上的 Linux 操作系统。PowerHA for Linux 只支持在 AIX 上可用的一部分特性，但是这种多平台支持为整个企业提供一个通用的可用性基础结构，有助于保护您的投资并提供增长路径。Sales Manual 中列出了 PowerHA on Linux支持的所有硬件和软件。

在新的 System POWER6 处理器上支持 PowerHA 吗？

在 System POWER6 服务器上支持 PowerHA。PowerHA for AIX 嵌入了对 POWER6 系统上的动态 LPAR 的支持，但是需要安装额外的 APAR。

在哪些 AIX 级别上支持 PowerHA？

PowerHA 需要以下 AIX 级别之一：

  • AIX V5.2
  • AIX V5.3
  • AIX V6.1

PowerHA 将支持以后的 AIX 版本。PowerHA 和 AIX 可用的最新补丁请参见 TechSupport 网站。

哪些应用程序可以使用 PowerHA？

所有流行的应用程序都可以使用 PowerHA，包括 DB2、Oracle、SAP、WebSphere 等等。PowerHA 提供 Smart Assist 代理，让用户能够快速轻松为特定的应用程序配置 PowerHA。PowerHA 包含灵活的配置参数，可以针对任何应用程序轻松地设置。

PowerHA 是否支持动态 LPAR、CUoD、On/Off CoD 或 CBU？

PowerHA 支持动态 Logical Partitioning、Capacity Upgrade on Demand、On/Off Capacity on Demand 和 Capacity Backup Upgrade。请参见公告 204-298 和 105-056。

为什么常常在硬件或软件发布之后才提供PowerHA 支持？

在宣布支持之前，要在 PowerHA 环境中测试所有新的硬件和软件。这是因为 PowerHA 以独特的高强度方式测试特性和接口，因此问题在 PowerHA 环境之外可能不会暴露出来。不能简单地假定新的硬件或软件能够正常工作，必须在实验室中安装并通过资格测试运行它们。有时候会发现问题，需要花时间解决问题，因此 PowerHA 无法在硬件发布的同时宣布支持。

PowerHA for Linux 支持可选特性 PowerHA/XD 和 PowerHA Smart Assist 吗？

目前还不支持。

如果已经安装了 PowerHA，现在怎么办？

在 PowerHA 能够管理您的应用程序并保持其高可用性之前，需要把您的集群和应用程序的相关信息告诉 PowerHA。这需要四个步骤：
步骤 1) 定义保持应用程序高可用性所用的节点。

假定本地节点（配置 PowerHA 的节点）是集群节点之一，必须把组成集群的其他节点的名称告诉 PowerHA。只需输入每个节点的主机名或 IP 地址。

步骤 2) 定义希望保持高可用性的应用程序

需要告诉 PowerHA 关于应用程序的三项信息：

  • 名称 — 提供一个名称
  • 启动脚本 — 指定 PowerHA 用来启动此应用程序的脚本
  • 停止脚本 — 指定 PowerHA 用来停止此应用程序的脚本

步骤 3) 检查和同步集群

PowerHA 会发现连接到节点的所有网络和磁盘。检查步骤会确认集群配置能够保持应用程序的高可用性。如果成功，将把配置复制到集群中的其他节点。

步骤 4) 管理应用程序

在启动 PowerHA 时，它会开始管理应用程序并保持其高可用性。还可以使用 PowerHA 提供的维护设施在节点之间转移应用程序，从而进行维护。

配置 PowerHA 的具体方法请参见 Installation Guide 的第 11 章 Using the SMIT Assistant。请查看 PowerHA 的在线文档。PowerHA for Linux 不包含 AIX 上可用的高级发现和检查特性。在配置 PowerHA for Linux 时，必须手工地定义集群、网络和网络接口。对配置的任何修改都需要在所有节点上重新启动 PowerHA for Linux。

对于 IP 地址接管，PowerHA 为什么需要那么多子网？

PowerHA（使用 RSCT）通过特定的网络接口发送检测信号，从而判断适配器状态；只要能够通过接口发送检测信号，就认为此接口是正常的。在 AIX V5 之前，AIX 不允许多个接口拥有子网路由，但是在 AIX V5.1 中多个接口可以有到同一子网的路由。这有时候称为多路径路由或路由分条；当出现这种情况时，AIX 将把以某一子网为目的地的出站数据包通过具有到此子网的路由的所有接口发送出去。具有 RSCT 功能的接口能够可靠地把检测信号发送到特定的接口。因此，这些地址的安排不会产生重复的子网路由，这是由引导、服务和持久化标签的子网规则决定的。

PowerHA V5 包含一个新特性，可以将 PowerHA 配置为对检测信号使用不同的 IP 别名地址集，从而避免一些子网需求。这个特性提供一个基地址（即启始地址），PowerHA 会计算出正确的子网中的一组地址 —— 当集群服务启用时，PowerHA 把这些地址作为 IP 别名地址添加到接口中，然后只使用这些别名地址发送检测信号。然后，可以在任何子网中分配 “常规的” 引导、服务和持久化标签，但是要小心：尽管这个特性可以避免检测信号使用多路径路由，但是多路径路由可能会严重影响您的应用程序。Concepts and Facilities Guide 的第 2 章和 Administration and Troubleshooting Guide 的第 3 章中讨论了通过 IP 别名发送检测信号。请查看 PowerHA 的在线文档。

如何避免名称服务器成为单一故障点？

1) 通过输入以下条目创建一个 /etc/netsvc.conf 文件，让节点先检查 /etc/hosts，再查询名称服务器（DNS）：
hosts=local,bind
其中的 local 让节点先检查 /etc/hosts，再查询名称服务器
2) 删除 /etc/resolv.conf（或用别的名称保存它，供以后使用），这样就会先用 /etc/hosts 进行名称解析。
关于更新 /etc/hosts 文件和名称服务器配置的更多信息，请参见 Installation Guide。请查看 PowerHA 的在线文档。

什么是 config_too_long 事件？

config_too_long 事件是当集群事件的运行时间比预先设置的时间长时 PowerHA 发出的信息性事件。在发生以下情况时会出现此事件：

  • 一个 AIX 命令（例如 fsck）长时间运行或已经挂起了
  • 遇到了不可恢复的错误 —— 在这种情况下，hacmp.out 中会出现“EVENT FAILED”标志

如果遇到 config_too_long 事件，应该检查 hacmp.out 文件，判断原因并决定是否需要手工干预。关于出现事件失败之后的恢复的更多信息，请参见 Administration and Troubleshooting Guide 的第 18 章 Recover from PowerHA Script Failure。

所有节点是否需要使用 PowerHA 和 AIX 操作系统的相同版本？

不。但是，在运行混合型集群时有一些限制。

集群节点上 AIX 的级别不一致不会给 PowerHA 造成问题，只要 AIX 的级别足以支持节点上运行的 PowerHA 的级别即可。在这种环境中支持所有集群操作。PowerHA 的安装和更新包将强制执行每个系统上所需的最低级别的 AIX。

同样，对于 Linux on POWER，只要安装了支持的最低级别，操作系统级别不一致应该不会造成问题。不支持在同一集群中混合使用不同的平台，比如 AIX、RedHat 和 SUSE。从实用性的角度来说，建议所有节点尽可能使用相同级别的操作系统和 PowerHA。保持所有节点上的操作系统、PowerHA 和应用程序处于相同级别可以简化集群的管理，减少发生错误的可能性，这会大大减少管理员遇到的麻烦。Planning Guide 对有效地管理不同的安装和迁移场景给出了建议。

为什么需要非 IP 检测网络？

非 IP 检测链路的用途常常被误解。需要非 IP 检测网络是因为 IP 网络上的 PowerHA 检测作为 UDP 数据报发送。这意味着，如果一个节点或网络很拥挤，检测可能被丢弃。如果只有 IP 网络，那么在发生长时间拥挤时，就会认为此节点出现了故障，PowerHA 会启动接管操作。因为此节点实际上仍然是活跃的，PowerHA 接管会造成两个节点具有相同的 IP 地址，还会造成这两个节点同时试图拥有和访问共享磁盘。这种情况有时候被称为“分裂的集群”。在这种情况下，数据损坏是不可避免的。

因此，PowerHA 强烈建议节点通过至少一个非 IP 网络连接到至少一个其他节点。对于超过两个节点的集群，最可靠的配置是在每个节点上包含两个非 IP 网络。非 IP 链路（尤其是 RS-232）上的距离限制常常使这个需求很难得到满足。对于这种集群，应该考虑使用 PowerHA 磁盘检测。磁盘检测能够简便地建立多个非 IP 网络，而不需要额外的硬件或软件。

在同一集群中可以使用不同类型的处理器、通信适配器或磁盘子系统吗？

一般来说可以，只要 PowerHA 支持各个组件即可。注意，某些组合可能是不合理的，或是应该避免的。例如，如果在同一网络上使用运行速度不同的两个以太网适配器，一般会迫使网络上的所有适配器以低速适配器的速度运行。同样，如果以低档处理器作为高档处理器的备用，PowerHA 可能不得不在低档处理器上运行应用程序，这会导致不可接受的性能。只要 AIX 和硬件支持互连，PowerHA 也会支持它们。

可以用现有的 Enhanced Concurrent Mode 卷组实现磁盘检测吗？还是需要定义新的卷组？

为了在各种故障场景中实现最高的可用性水平，最好的做法是为每个物理磁盘单元（或 LUN）配置一个磁盘检测连接。

检测操作本身要对共享磁盘的非数据区域读写消息。尽管检测信号使用的空间不会减少应用程序可用的空间（它在磁盘的保留区域中），但是磁盘会在保留区域和应用程序数据区域之间来回搜索，这会造成一些开销。

如果让磁盘检测路径使用与应用程序相同的磁盘和卷组，最好的做法是选择包含不会频繁访问或对性能要求不高的应用程序的磁盘：尽管磁盘检测开销很小（每秒 2-4 次寻道），但是它可能影响应用程序性能，过多的应用程序访问也会使磁盘连接看起来时断时续。为检测选用哪个磁盘和卷组取决于共享磁盘环境和管理过程。例如，使用一个单独的卷组实现检测可以把检测与应用程序数据隔离开，但是会增加一个必须维护（升级、修改等）的卷组并占用一个 LUN。如果决定用一个单独的卷组实现检测，并不需要把它包含在 PowerHA 资源组中，但是 CSPOC 实用程序使用一个资源组节点列表作为要执行操作的节点集：把这个卷组包含在一个资源组中，这个资源组只包含与此磁盘连接的节点集，这样就能够使用 CSPOC 功能。也可以定义和使用不属于任何卷组的磁盘，但是这种设置必须手工地配置和维护。

参考链接：http://www.ibm.com/developerworks/cn/aix/aixfaq/4.html

Top


Power安全高可用的优势

企业成长，IT 系统是否安全至关重要，尤其在当前经济环境下，您需要的更应该是持久稳定信得过的伙伴，能给您的 IT 系统带来更安心的保障，让业务稳定运行！

当前，在您企业的 IT 运营中是否也正面临以下困扰？

  • 承担企业核心应用的服务器发展路线不清晰，IT 系统无法与时俱进
  • 系统平台正面临迁移的风险，但缺乏迁移的技术保障
  • IT 预算有限，需要长期的投资保护
  • 系统性能不强，无法保障业务安全稳定的运行

别担心，IBM Power 服务器能够助您解决这些难题！

不同于某厂商，IBM Power 服务器是业界最成熟稳定的系统平台，以及 IBM UNIX 服务器 20多年清晰稳定的产品路线，能保证您的 IT 系统持续安全运行。

产品路线更清晰，远离投资风险

  • IBM Power 服务器连续 9年在中国 UNIX 市场排名第一，目前市场占有率超过 50%，领先其他厂商 15%。
  • IBM 20多年稳定的产品路线，让您没有系统升级的后顾之忧。不像某厂商抛弃原有系统平台之后，导致新旧系统无法平滑迁移，数据安全风险陡增。
  • 您的技术更新因为某些厂商系统平台的变更而推迟？IBM 技术发展始终连贯如一，保护您的长期 IT 投资。

RAS 创新功能，为稳定运行提供坚实基础

  • 集出色的可靠性、可用性、可服务性于一体，大大提升系统稳定性。
  • 采用世界上最快的 POWER6 处理器，主频突破 5.00GHz，CPU 的出错几率减少 30%。
  • 断点程序技术、核心模块的自动隔离技术、计算校验防护技术等多项先进技术，有效保证准确运算，避免宕机。

操作平台最稳定，让业务永续运行

  • 根据 2008年 Yankee 集团研究报告，Power 服务器采用的 AIX 操作系统是世界上最稳定的操作系统，系统平均每年宕机时间仅为 36分钟，助您避免系统中断带来的损失。
  • 操作平台成熟可靠，令您安全使用，提升 IT 管理效率。

高可用解决方案，使企业关键应用更安全

  • IBM Power HA 高可用性解决方案提供可靠的监控、故障检测与自动恢复，能将计划外宕机几率减少到最低，保障业务的连续性。

参考链接：http://www-31.ibm.com/cn/express/migratetoibm/power/safe/index.shtml?ca=eainnovationzone

Top


HACMP 认证学习系列，第 1 部分：入门

什么是 HACMP？

在解释什么是 HACMP 之前，我们必须定义高可用性的概念。

高可用性

在当今的复杂环境中，为应用程序提供连续的服务是成功的 IT 实现的重要组成部分。高可用性屏蔽或消除计划内和计划外的系统和应用程序停机时间，是帮助为应用程序客户端提供连续服务的组件之一。这是通过消除硬件和软件单点故障（single points of failure，SPOF）来实现的。

高可用性解决方案将确保任何解决方案组件（无论是硬件、软件还是系统管理）的故障不会导致应用程序及其数据对用户不可用。
高可用性解决方案应该通过适当的设计、规划、硬件选择、软件配置和精心控制的变更管理规程来消除单点故障 (SPOF)。

停机时间

停机时间是应用程序不能为其客户端提供服务的时间范围。可以将停机时间划分为：

  • 计划内停机：
  • 硬件升级
  • 维修
  • 软件更新/升级
  • 备份（离线备份）
  • 测试（需要定期测试以实现集群验证。）
  • 开发
  • 计划外停机：
  • 管理员错误
  • 应用程序故障
  • 硬件故障
  • 环境灾难

用于 AIX 的 IBM 高可用性解决方案 High Availability Cluster Multi Processing 基于久经考验的 IBM 集群技术，并包括两个组件：

  • 高可用性：通过使用重复和/或共享资源来确保应用程序可供使用的过程。
  • 集群多处理：运行在相同节点上并具有共享或并发数据访问的多个应用程序。

基于 HACMP 的高可用性解决方案提供了自动化的故障检测、诊断、应用程序恢复和节点重新集成。使用适当的应用程序，HACMP 还可以为并行处理应用程序提供并发数据访问，从而提供卓越的水平可伸缩性。

图 1 显示了一个典型的 HACMP 环境。

图 1 HACMP 集群

历史和发展

IBM High Availability Cluster Multi-Processing 可追溯到 20 世纪 90 年代初。
HACMP 的开发始于 1990 年，目的是为运行在 RS/6000 服务器上的应用程序提供高可用性解决方案。
我们不提供有关每个早期版本的信息，因为那些版本在本书编写之际已不再被支持或不再使用，我们仅提供有关最近版本的重点介绍。

HACMP V4.2.2

与 HACMP Classic (HAS) 一起，此版本引入了增强的可伸缩性版本（enhanced scalability version，ES），ES 是基于并行系统支持计划（Parallel Systems Support Program，PSSP）所产生的可靠的可伸缩集群技术（Reliable Scalable Clustering Technology，RST）拓扑、组和事件管理服务。

HACMP V4.3.X

除了其它方面以外，此版本还引入了对 HACMP/ES 的 32 节点支持、C-SPOC 增强功能、ATM 网络支持、HACMP 任务指南（用于简化集群配置的 GUI）、多个事件前和事件后脚本、FDDI MAC 地址接管、监视和管理支持增强功能、逐个节点的迁移，以及 AIX 快速连接支持。

HACMP V4.4.X

此版本中的新项目包括与 Tivoli的集成、应用程序监视、无退回的级联 (cascading with out fallback)、C-SPOC 增强功能、改进的迁移支持、HA-NFS 功能集成，以及软拷贝文档（HTML 和 PDF）。

HACMP V4.5

在此版本中，AIX 5L 是必需的，并且存在自动化的配置发现功能、每个网络适配器上的多个服务标签（通过使用 IP 别名）、持久 IP 地址支持、64 位功能的 API，以及监视和从卷组定额丧失中恢复。

HACMP V5.1

这是引入了重大变更的版本，涵盖从配置简化和性能增强到更改 HACMP 术语的范围。
HACMP V5.1 中的部分重要新功能包括：

  • SMIT “标准”和“扩展”配置路径（过程）
  • 自动化的配置发现
  • 自定义资源组
  • 基于通过磁盘的心跳检测的非 IP 网络
  • 快速磁盘接管
  • 卷组的强制启用（varyon）
  • 通过 IP 别名的心跳检测
  • HACMP Classic (HAS) 已被丢弃；现在仅存在基于 IBM 可靠的可伸缩集群技术的 HACMP/ES
  • 改进的安全性，通过使用集群通信守护进程（消除了对使用标准 AIX“r”命令的需要，从而消除了对 /.rhosts 文件的需要）来实现
  • 改进的集群自定义和同步性能
  • HACMP 术语的规范化
  • 配置和维护的简化
  • 在线规划工作表增强功能
  • 卷组的强制启用
  • 自定义资源组
  • 接管节点上的服务 IP 地址/标签的心跳信号监视
  • 通过 IP 别名的心跳检测
  • 通过磁盘的心跳检测
  • 各种 C-SPOC 增强功能
  • GPFS 集成
  • 集群验证增强功能
  • 改进的资源组管理

HACMP V5.2

从 2004 年 7 月开始，新的 HACMP V5.2 添加了管理、配置简化、自动化和性能方面的更多改进功能。
下面是 HACMP V5.2 中的改进功能摘要：

  • 两节点配置助手，同时带有 SMIT 菜单和 Java 接口

（另外还有 SMIT“标准”和“扩展”配置路径）。

  • 文件收集。
  • 用户密码管理。
  • 不再使用传统资源组，自定义资源组已将其取代。
  • 自动化的测试过程。
  • 自动集群验证。
  • 改进的在线规划工作表（Online Planning Worksheets，OLPW）现在可以从现有的 HACMP 集群导入配置。
  • 事件管理（Event management，EM）已由资源监视和控制（resource monitoring and a control，RMC）子系统（AIX 中的标准组件）所取代。
  • 增强的安全性。
  • 资源组依赖性。
  • 自我修复的集群。

高可用性概念

什么对象需要受到保护？最终，关键环境中的任何 IT 解决方案的目标都是提供连续的服务和数据保护。

高可用性只是实现连续操作目标的一个构件。高可用性基于硬件、软件（操作系统及其组件）、应用程序和网络组件的可用性。
若要实现高可用性解决方案，您需要：

  • 冗余服务器
  • 冗余网络
  • 冗余网络适配器
  • 监视
  • 故障检测
  • 故障诊断
  • 自动化的故障转移
  • 自动化的重新集成

HACMP 的主要目标是消除单点故障 (SPOF)。
表 1 单点故障

集群对象 | 消除单点故障的方法
节点（服务器） | 多个节点
电源 | 多个电路和/或电源
网络适配器 | 冗余网络适配器
网络 | 用于连接节点的多个网络
TCP/IP 子系统 | 非 IP 网络以便为 TCP/IP 提供后备
磁盘适配器 | 冗余磁盘适配器
磁盘 | 冗余硬件和磁盘镜像或 RAID 技术
应用程序 | 配置应用程序监视和备份节点，以获取应用程序引擎和数据

表 1 中的“集群对象”列中列出的每个项目是一个物理或逻辑组件，如果该组件发生故障，则会导致应用程序无法为客户端提供服务。

高可用性与容错的对比

可以将用于硬件和软件故障检测及处理的系统定义为两个组：

  • 容错系统
  • 高可用性系统

容错系统

提供容错功能的系统旨在几乎无中断地操作，而不管可能发生的故障如何（也许由于自然灾害导致的完全站点故障除外）。在此类系统中，至少为所有的软件或硬件组件配置了重复组件。

因而，CPU、内存和磁盘具有特殊的设计，即使在一个子组件发生故障时也可以提供连续的服务。

此类系统非常昂贵，并且极其专门化。实现容错解决方案需要大量的精力和所有系统组件的高度自定义。

在不能接受任何停机时间的场合（生命保障等等），容错设备和解决方案是必需的。

高可用性系统

为高可用性而配置的系统是以如下方式配置的硬件和软件组件的组合：即确保在发生故障时，能够使用最短的可接受停机时间实现自动化的恢复。

在此类系统中，相关软件将检测环境中的问题，然后将应用程序传输到另一台计算机，从而接管原始计算机（节点）的身份。

因而，消除环境中的所有单点故障 (SPOF) 是非常重要的。例如，如果计算机只有一个网络连接，则应该在同一个节点中提供第二个网络接口，以便在提供服务的主适配器发生故障时接管工作。

另一个重要问题是镜像数据，并将数据放在可从集群中的任何一台计算机访问的共享磁盘区域，从而保护数据。

高可用性集群多处理（High Availability Cluster Multi-Processing，HACMP）软件提供了用于在高度可用的系统中集成应用程序的框架和一组工具。

要在 HACMP 集群中集成的应用程序需要相当多的自定义，此自定义不是在应用程序级别进行，而是在 HACMP 和 AIX 平台级别进行。

HACMP 是一个灵活的平台，允许运行在 AIX 平台上的通用应用程序实现集成，从而以合理的成本提供高度可用的系统。

高可用性解决方案

与其他解决方案相比较，高可用性 (HA) 解决方案可以提供许多优点。表 2 描述了一些 HA 解决方案及其特征。
表 2 HA 解决方案的类型

解决方案 | 独立系统 | 增强的 独立系统 | 高可用性集群 | 容错系统
停机时间 | 两天 | 两小时 | 视情况而定（通常三分钟） | 永不停机
数据可用性 | 上次的完全备份 | 上一个事务 | 上一个事务 | 无数据损失

高可用性解决方案提供了以下优点：

  • 标准的组件
  • 可与现有的硬件一起使用
  • 适用于几乎任何应用程序
  • 可使用广泛的磁盘和网络类型
  • 以合理成本实现卓越的可用性

针对 IBM Eserver pSeries 的 IBM 高可用性解决方案提供了一些独特的优点。此类优点包括：

  • 经证实的解决方案（超过 14 年的产品开发历史）
  • 灵活性（在独立 AIX 系统上运行的几乎任何应用程序都可以使用 HACMP 来保护）
  • 使用“现成的”硬件组件
  • 经证实的客户支持承诺

提供高可用性解决方案的注意事项包括：

  • 全面的设计和详细的规划
  • 消除单点故障
  • 选择适当的硬件
  • 正确的实现（不要走“捷径”）
  • 训练有素的系统管理实践
  • 有文档记录的操作过程
  • 详尽的测试

HACMP 概念

HACMP 的基本概念可按如下方式进行分类：

  • 集群拓扑

包含基本集群成员节点、网络、通信接口、通信设备和通信适配器。

  • 集群资源

将要使其高度可用的实体（例如，文件系统、原始设备、服务 IP 标签和应用程序）。资源在资源组（resource group，RG）中分组在一起，HACMP 将资源组作为单个实体来保持其高度可用。

资源组可从单个节点使用，或在并发应用程序的情况下，可以同时从多个节点使用。

  • 故障转移

表示资源组响应活动节点上的故障而从该活动节点转移到另一个节点（备份节点）。

  • 退回

表示资源组在先前的节点变得可用时从备份节点转移到先前的节点。此转移通常是为了响应先前发生故障的节点的重新集成。

HACMP 术语

要理解 HACMP 的正确功能和用途，必须知道一些重要的术语：

  • 集群 (Cluster)

独立系统（节点）或 LPAR 的松散耦合的集合，组织到一个网络中以便共享资源和彼此通信。
HACMP 定义了操作系统之间的关系，其中当某个集群节点无法提供服务时，对等的集群节点将提供该节点所提供的服务。
在任何集群组件发生故障的情况下，这些单独的节点共同维持一个或多个应用程序的功能。

  • 节点 (Node)

运行 AIX 和 HACMP 的 IBM Eserver pSeries 计算机（或 LPAR），被定义为集群的一部分。每个节点都有一个资源集合（磁盘、文件系统、IP 地址和应用程序），在节点发生故障的情况下，可以将该资源集合转移到集群中的另一个节点。

  • 资源 (Resource)

资源是集群配置的逻辑组件，可从一个节点移动到另一个节点。提供高度可用的应用程序或服务所必需的所有逻辑资源在资源组 (RG) 中分组在一起。
在节点发生故障的情况下，资源组中的组件一起从一个节点移动到另一个节点。集群可能具有多个资源组，从而允许高效地使用集群节点（从而实现 HACMP 中的“多处理”）。

  • 接管 (Takeover)

接管是指在集群内的节点之间转移资源的操作。
如果一个节点由于硬件问题或 AIX 崩溃而发生故障，其资源应用程序将移动到另一个节点。

  • 客户端 (Client)

客户端是能够通过局域网访问运行在集群节点上的应用程序的系统。客户端运行客户端应用程序，连接到运行应用程序的服务器（节点）。

HACMP/XD（扩展距离）

High Availability Cluster Multi-Processing for AIX (HACMP) 基本软件产品处理部分连续操作问题。它处理单个站点的计算联合体中的计算机、适配器或局域网的故障恢复。

图 2 显示了典型的 HACMP/XD 高可用性地理集群（High Availability Geographic Cluster，HAGEO）。

图 2 典型的 HACMP/XD HAGEO 配置

若要在发生重大灾难（站点故障）的情况下保护应用程序，将需要附加的软件。HAGEO 提供了：

  • 配置具有地理分离站点的集群的能力。

HAGEO 将 HACMP 扩展到包括两个地理位置上的远程数据中心或站点。此扩展可以防止个别站点成为集群中的单点故障。
地理镜像过程为每个站点提供了基本数据的更新副本。
任一个站点都可以运行关键应用程序，从而确保在故障或灾难导致一个站点失效的情况下，任务关键型计算资源在地理上分离的另一个站点上连续可用。

  • 自动的故障检测和通知。

HAGEO 与 HACMP 合作提供了站点或地理网络故障的自动检测。它启动恢复过程，并将有关检测到的所有故障及其所执行的响应操作的信息通知系统管理员。

  • 自动化故障转移

HAGEO 包括事件脚本，以处理站点或地理网络故障的恢复。这些脚本与标准 HACMP 事件脚本集成在一起。
可以通过添加事件前或事件后脚本来自定义配置的行为，就像对 HACMP 所做的那样。

  • 快速的灾难恢复。

HAGEO 还在可操作的站点提供了数据和应用程序的快速恢复。地理镜像过程确保在灾难降临时，数据已经在第二个站点可用。
恢复时间通常要花几分钟，其中不包括应用程序恢复时间。

  • 站点恢复期间的自动数据重新同步

HAGEO 作为站点恢复过程不可或缺的一部分处理每个站点上的镜像的重新同步。重新加入的站点上的节点将自动使用在该站点发生故障时接收的数据进行更新。

  • 可靠的数据完整性和一致性。

HAGEO 的地理镜像和地理消息组件确保在站点发生故障时，幸存站点的数据与故障站点的数据保持一致。
当故障站点重新集成到集群中时，HAGEO 使用来自可操作站点的最新数据来更新该站点，从而再次确保数据一致性。

  • 灵活、可伸缩的配置。

HAGEO 软件支持广泛的配置，允许您按自己的需要配置独特的灾难恢复解决方案。
HAGEO 集群中最多可以有八个节点，每个站点的节点数量各不相同。
HAGEO 与文件系统和数据库无关，因为地理镜像设备的行为与它所支持的磁盘设备的行为相同。由于镜像是透明的，配置为使用地理镜像的应用程序不必进行任何方式的修改。

HACMP/XD：HAGEO 组件

该软件具有三个重要功能：

  • GeoMirror：

包括一个逻辑设备和在第二个站点上执行镜像的伪设备驱动程序；数据在一个站点输入。TCP/IP 用作镜像数据的传输协议。
GeoMirror 可以在异步或同步模式下使用，具体取决于站点之间的通信带宽，以及应用程序事务量（将决定更改的数据量）。

  • GeoMessage：

在两个站点的 GeoMirror 设备之间提供可靠的数据和消息传输。

  • 地理拓扑：

提供用于将地理镜像功能与 HACMP 功能集成的逻辑，以提供自动的故障检测和从影响整个站点的事件中恢复。

  • 从灾难中恢复

当灾难导致站点故障时，幸存站点的节点上的集群管理器将快速检测情况，并采取操作以保持地理镜像的应用程序可用。
同样，如果集群由于全局地理网络故障而被分割，则配置为非主控 (non-dominant) 的站点上的集群管理器将关闭自身，以便避免数据偏差。

HACMP/XD：HAGEO 基本配置

可以按照 HACMP 基本软件所支持的任何一种配置来配置 HAGEO 集群。这些配置包括备用（standby）、单边接管（one-sided takeover）、相互接管（mutual takeover）和并发访问（concurrent access）配置。

  • 备用配置

备用配置是一种传统冗余硬件配置，其中集群中的一个或多个节点保持空闲，直到某个服务器节点发生故障。
在 HAGEO 中，这转变为使用一个空闲站点。该站点并非完全空闲，因为它还参与了地理镜像过程。但是该站点的节点不执行应用程序工作。

  • 接管配置

在接管配置中，所有节点都在执行处理；不存在空闲节点。
配置包括：

    • 站点内（本地）接管
    • 远程单边接管
    • 远程相互接管
  • 并发配置

在并发访问配置中，一个站点的所有节点可以同时访问并发卷组，并拥有相同的磁盘资源。
另一个站点以相同的方式进行设置。
如果某个节点离开站点，资源的可用性不会受到影响，因为其他节点已启用并发卷组。
如果某个站点发生故障，另一个站点可以提供该站点上的节点所提供的并发访问。并发应用程序可由集群中的所有节点访问。
HACMP Cluster Lock Manager 必须在集群中的所有节点上运行。并非所有数据库都可用于涉及到跨地理位置的节点的并发访问。

HACMP/XD PPRC 集成功能

在两个站点都使用了 IBM Enterprise Storage Server 并且对等远程复制（Peer to Peer Remote Copy，PPRC）功能提供了存储卷镜像的环境中，同时在 HACMP V4.5 PTF5 和 HACMP V5.1中引入的此功能可以提供自动化的站点故障转移和应用程序数据的远程副本激活。

在主站点发生故障的情况下，数据应该在辅助站点可供使用（通过 PPRC 进行复制）。必须激活辅助站点中的数据副本才能将其用于处理。

HACMP/XD PPRC 集成功能在主站点发生故障时提供自动化的副本拆分，在主站点变得可用时提供自动化的重新集成。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-1/

Top


HACMP 认证学习系列，第 2 部分：计划与设计

了解应用程序在故障情况下的行为，对于控制集群在此类情况下应当如何反应是非常重要的。

规划和实现集群所必需的信息应该涵盖应用程序、环境、硬件、网络、存储，同时还要涵盖支持和变更过程。

本章将介绍以下 HACMP 集群主题：

  • 节点规模调整注意事项
  • 集群硬件规划
  • 软件规划
  • 存储规划
  • 灾难恢复规划

注意：规划是成功的实现的一半，但是就 HACMP 而言，如何强调正确规划的重要性都不为过。如果规划不当，您可能会在以后某个时候发现自己陷入种种限制之中，而要摆脱这些限制可能是非常痛苦的经历。因此，请保持镇定从容，并使用产品附带的规划工作表；这些工作表对于任何迁移或问题确定情形或者对于规划的文档记录都是非常有价值的。

规划注意事项

在规划高可用性集群时，您应该考虑节点、存储、网络等方面的规模调整，以便即使是在接管情况下，也能够提供应用程序正确运行所必需的资源。

规模调整：选择集群中的节点

在开始集群的实现之前，您应该了解需要多少个节点，以及应该使用什么节点类型。就应用程序所需要的资源而言，将要使用的节点类型是非常重要的。

节点的规模调整应该涵盖以下方面：

  • CPU（CPU 的数量和速度）
  • 每个节点中的随机访问存储器 (RAM) 容量
  • 磁盘存储（内部）
  • 每个节点中的通信和磁盘适配器数量
  • 节点可靠性

集群中的节点数量取决于要实现高可用性的应用程序的数量，同时还取决于所需的可用性程度。在集群中为每个应用程序准备多个备用节点可以提高应用程序的总体可用性。

注意：HACMP V5.1 集群中的最大节点数量是 32。

HACMP V5.1 支持各种各样的节点，涵盖从桌面系统到高端服务器的范围。SP 节点和逻辑分区（Logical Partition，LPAR）也受支持。有关进一步的信息，请参阅红皮书《HACMP for AIX 5L V5.1 Planning and Installation Guide》（SC23-4861-02）。

集群资源的共享基于应用程序的需求。有些节点执行的任务与要实现高可用性的应用程序并不直接相关，并且不需要与应用程序节点共享资源，应该将此类节点配置在单独的集群中以简化实现和管理。

所有的节点都应该提供足够的资源（CPU、内存和适配器），以维持所有指定的应用程序在故障转移（接管故障节点中的资源）情况下的执行。

如果可能，应该在集群中包括附加的节点，以提高集群的可用性；这还可以在执行节点故障转移、重新集成和维护操作时提供更大的灵活性。

建议使用具有相似硬件配置的集群节点，在实现具有相互接管（mutual takeover）或并发配置的应用程序的集群时尤其是如此。这样使得分发资源和执行管理操作（软件维护等等）变得更加容易。

规模调整：存储注意事项

在最常用的配置中，要实现高可用性的应用程序需要一个共享存储空间来存储应用程序数据。该共享存储空间或者用于并发访问，或者用于使数据对接管节点上的应用程序可用（在 fail-over 情况下）。

要在集群中使用的存储应该允许每个应用程序从所有的指定节点进行共享访问。当前支持的 HACMP 共享存储技术包括 SCSI、SSA 和光纤通道（Fibre Channel.）。

根据应用程序的需求，应该将存储配置定义为非共享（“私有”）或共享存储。私有存储可以保留在内部磁盘上，并且不参与任何接管活动。

考虑到以下原因，共享存储应该提供访问控制机制：

  • 放在共享存储中的数据必须能够从可能在某个时间点运行应用程序的任何一个节点进行访问。在某些情况下，应用程序一次仅在一个节点上运行（非并发），但是在另一些情况下，必须提供对数据的并发访问。
  • 在非并发环境中，如果共享数据被错误的节点更新，这可能会导致数据破坏。
  • 在并发环境中，应用程序应该提供自己的数据访问机制，因为平台并发软件 (AIX/HACMP) 会绕过由存储控制的访问机制。

网络注意事项

在规划 HACMP 集群时，应该考虑以下方面：

  • IP 网络拓扑（路由、交换机等等）
  • IP 网络性能（速度/带宽、延迟和冗余）
  • ATM 和/或 X.25 网络配置

IP 网络用于使客户端访问运行在集群中的节点上的应用程序，以及用于在集群节点之间交换心跳信号消息。在 HACMP 集群中，心跳信号消息是通过 IP 网络和点对点（非 IP）网络进行交换的。

HACMP 旨在通过基于 TCP/IP 的网络、X.25 和 ATM 网络提供客户端的访问。

HACMP 集群规划

集群规划也许是实现成功的配置过程中最重要的步骤。HACMP 规划应该包括以下方面：

  • 硬件规划
    • 节点
    • 网络
    • 存储
  • 软件规划
    • 操作系统版本
    • HACMP 版本
    • 应用程序兼容性
  • 测试和维护规划
    • 测试过程
    • 变更管理
    • 管理操作

硬件规划
实现高可用性配置的目标是通过消除单点故障（硬件、软件和网络），以及通过屏蔽服务中断（无论是计划内还是计划外的中断），从而提供高度可用的服务。

节点规划的决策因素包括：

  • 支持的节点：计算机类型、功能、支持的适配器、电源（AC、DC、双电源与单电源等等）。
  • 连接和电缆：电缆类型、长度、接头、型号、导线管布线、电缆槽容量需求，以及可用性。

节点配置

HACMP V5.1 支持在一个集群中使用 IBM Eserver pSeries（独立和 LPAR 模式）、IBM SP 节点以及现有的 RS/6000 服务器的任何节点组合。节点必须满足内部内存、内部磁盘、可用 I/O 插槽数量和操作系统兼容性（AIX 版本）的最低要求。

要考虑的项包括：

  • 内部磁盘（磁盘数量、容量以及是否使用 LVM 镜像）
  • 共享磁盘容量和存储数据保护方法（RAID 和 LVM 镜像）
  • I/O 插槽限制及其对导致单点故障 (SPOF) 的影响
  • 对集群的客户端访问（网络适配器）
  • 其他 LAN 设备（交换机、路由器和网桥）
  • I/O 适配器和子系统冗余
  • 电源冗余

网络配置

规划群集网络时的主要目标是评估所需的冗余程度，以消除网络组件成为单点故障的可能性。应该考虑以下方面：

  • 网络：连接到多个物理网络的节点
  • 对于 TCP/IP 子系统故障：使用非 IP 网络以帮助决策过程
  • 网络接口：每个网络上的冗余网络适配器（以防止在单个网络接口发生故障情况下的资源组故障转移）

在规划集群网络配置时，必须为节点连接选择正确的组合：

  • 集群网络拓扑（交换机、路由器等等）。
  • 连接集群节点的 IP 和非 IP（点到点）网络组合和每个节点到所有网络的连接数量。

用于提供高可用性服务 IP 地址的方法：

  • 通过 IP 别名的 IP 地址接管（IP address takeover，IPAT）
  • 通过 IP 替换的 IPAT。

有关 HACMP 配置中支持的节点和适配器的完整列表，请参阅红皮书《HACMP for AIX 5L V5.1 Planning and Installation Guide》（SC23-4861-02）；另请访问位于以下地址的 IBM 支持网站： http://www-1.ibm.com/servers/eserver/pseries/ha/

HACMP 网络术语

从 HACMP V5.1 开始，用于描述 HACMP 配置和操作的术语已发生了很大的变化。做出此更改是为了简化 HACMP 的总体使用和维护，同时也是为了使术语与 IBM 产品系列保持一致。

例如，在早期的 HACMP 版本中，取决于上下文，术语“适配器”可以具有不同的含义，从而使配置变得非常令人混淆和困难。

IP 标签 (IP label)

术语“IP 标签”表示与特定 IP 地址相关联的名称，此名称是在集群节点上使用的名称解析方法（DNS 或静态 - /etc/hosts）中定义的。此术语取代“主机名称”(host name)，后者可能与 hostname 命令的输出产生混淆，并且可能没有与任何 IP 地址相关联。

在 HACMP V5.1 中，术语“适配器”(Adapter) 已替换如下：

  • 服务 IP 标签/地址 (Service IP Label / Address)：通过其提供服务的 IP 标签/地址。此 IP 标签/地址可能与单个节点绑定，也可能由多个节点共享，并且 HACMP 保持其高度可用。
  • 通信接口 (Communication Interface)：支持 TCP/IP 协议并由其基本 IP 地址表示的物理接口。
  • 通信设备 (Communication Device)：表示点到点非 IP 网络连接的一端的物理设备，例如 /dev/tty1、/dev/tmssa1、/dev/tmscsi1 和 /dev/hdisk1。
  • 通信适配器 (Communication Adapter)：用于提供高度可用的通信链路的 X.25 适配器。

服务 IP 地址/标签 (Service IP address/label)

服务 IP 地址是用于客户端访问的 IP 地址。此 IP 地址（及其关联的标签）由 HACMP 监视，并且是资源组的一部分。

存在两种类型的服务 IP 地址（标签）：

  • 共享服务 IP 地址（标签）：可以配置在多个节点上的 IP 地址，并且是一次只能在一个节点上处于活动状态的资源组的一部分。
  • 与节点绑定的服务 IP 地址（标签）：只能配置在一个节点上（不由多个节点共享）的 IP 地址。通常，此类服务 IP 地址与并发资源组相关联。

服务 IP 地址在 HACMP 已启动并且关联的资源组处于在线状态时变得可用。

HACMP 通信接口 (HACMP communication interface)

HACMP 中的通信接口定义是以下内容的逻辑分组：

  • 逻辑网络接口一个名称，AIX 将某个物理网络适配器端口（例如，en0）解析为此名称。
  • 服务 IP 地址是一个 IP 地址，将通过该 IP 地址提供诸如应用程序等服务，并且客户端节点将通过该 IP 地址进行通信。
  • 服务 IP 标签是映射到服务 IP 地址的标签。

通信接口指的是基于 IP 的网络和网络适配器。

连接到公共物理网络的网络适配器组合为 HACMP 所使用的逻辑网络。

每个网络适配器能够承载多个 TCP/IP 地址。在配置集群时，您要定义 HACMP 将监视的 IP 地址（基本或启动 IP 地址）和 HACMP 将保持其对 HACMP 高度可用的 IP 地址（服务 IP 地址）。

HACMP 中的心跳信号通过通信接口进行传递。HACMP 使用 RSCT 子系统的心跳检测功能（通过 UDP）来监视其网络接口和 IP 地址。每当 HACMP 服务在该节点上启动，HACMP 就将 ODM 中定义和存储的网络拓扑传递给 RSCT，并且 RSCT 将向 HACMP 提供故障通知。

HACMP 通信设备 (HACMP communication device)

HACMP 还提供点对点非 IP 网络的监视。点对点网络的两端都是 AIX 设备（在 /dev 目录中定义）。这些设备是通信设备，并包括串行 RS232 连接、目标模式 SCSI、目标模式 SSA 和磁盘检测信号连接。

点对点网络也由 RSCT 监视，并且 HACMP 使用它们的状态来区分节点故障和 IP 网络故障。

例如，通过磁盘的心跳检测使用磁盘设备名称（例如，/dev/hdisk2）作为在连接的每一端配置到 HACMP 的设备。

建议此类网络至少要在集群中的任何两个节点之间配置一个非 IP 网络。

在磁盘心跳检测的情况下，建议使用一个点对点网络，此网络由每个物理机箱的每个节点对的一个磁盘组成。不能将一个物理磁盘用于两个点对点网络。

通信适配器和链路 (Communication adapter and link)

可以将以下通信链路定义为 HACMP 中的资源：

  • LAN 网络适配器 (ent*) 上配置的 SNA
  • X.25 适配器上配置的 SNA
  • 本机 X.25 链路

HACMP 将这些链路作为资源组的一部分进行管理，从而确保高可用性通信链路。在物理网络接口故障、X.25 链路故障或节点故障的情况下，高度可用的通信链路（连同相同资源组中的所有资源一起）将被迁移到同一个节点或接管节点上的另一个可用的适配器。

IP 别名

IP 别名是通信（网络）接口上配置的除基本 IP 地址以外的 IP 地址。IP 别名是受 HACMP 支持的一个 AIX 功能。AIX 支持在每个通信接口上使用多个 IP 别名。适配器上的每个 IP 别名可以在单独的子网上。

AIX 还允许为接口配置具有不同子网掩码的 IP 别名；HACMP 尚不支持此功能。

IP 别名在 HACMP 中同时用作用于 IP 地址接管的服务和非服务地址，以及用于心跳配置。

网络接口功能 (Network interface function)

对于 IP 网络，建议您在每个节点上为每个网络配置多个通信接口。那些通信接口将分别具有特定的作用，具体取决于 HACMP 集群的状态。

  • 服务接口 (Service Interface)

服务接口是配置了一个或多个服务 IP 地址（标签）的通信接口。取决于为每个网络定义的 IP 地址接管 (IPAT) 方法，将在基本 IP 地址之外添加服务 IP 地址（通过别名的 IPAT），或者服务 IP 地址将取代通信接口的基本（启动）IP 地址。此接口用于提供对运行在该节点上的应用程序的访问。服务 IP 地址由 HACMP 通过 RSCT 心跳信号进行监视。

  • 启动接口 (Boot Interface)

这是由在 AIX 配置中定义的基本（启动）IP 地址表示的通信接口。如果使用了通过 IP 别名进行的心跳检测，则 HACMP 将不监视此 IP 地址，而是通过 HACMP 在启动时分配的 IP 别名来监视通信接口。

启动接口不传输任何客户端流量；然而，如果服务接口失败，HACMP 将把服务 IP 地址转移到非服务接口上。如果某个节点发生故障，接管节点上的另一个接口将在执行资源组故障转移时配置服务 IP 地址。

注意：对于每个网络，一个节点可以具有零到七个非服务接口。在同一个网络上使用多个非服务接口可以消除通信接口的单点故障。

  • 持久节点 IP 标签 (Persistent Node IP Label)

持久节点 IP 标签是一个 IP 别名，可以将其分配给集群网络上的某个特定节点。持久节点 IP 标签：

    • 与节点绑定（始终保持在同一个节点上）。
    • 能够在已经定义了某个服务或非服务 IP 标签的网络适配器上共存。
    • 具有不需要在该节点上安装附加物理网络适配器的优点。
    • 不属于任何资源组。

分配持久节点 IP 标签可以提供一个与节点绑定的 IP 地址，并且对于管理目的来说非常有用，因为到持久节点 IP 标签的连接始终会确定该特定的集群节点，即使 HACMP 服务没有在该节点上启动时也是如此。

注意：可以在每个节点上为每个网络配置一个持久节点 IP 标签（地址）。例如，如果有一个连接到 HACMP 中定义的两个网络的节点，可以通过两个分别用于每个网络的持久 IP 标签（地址）来确定该节点。

持久 IP 标签是在 HACMP 配置中定义的，并在 HACMP 第一次在每个节点上启动时变得可用。一经配置，持久 IP 标签（地址）将在配置它们的适配器上保持可用，即使 HACMP 已在节点上停止或节点已重新启动时也是如此。

可以在以下类型的基于 IP 的网络上创建持久节点 IP 标签：

    • 以太网
    • 令牌环网
    • FDDI 网
    • ATM 局域网模拟器

限制：不能在 SP 交换机、ATM 传统 IP 或非 IP 网络上配置持久节点 IP 标签。

持久 IP 标签的行为如下：

    • 如果某个配置了服务 IP 标签的网络适配器发生故障，并且该网络适配器上还定义了一个持久标签，则会将持久 IP 标签（地址）连同服务 IP 标签（地址）一起转移到同一个非服务接口上。
    • 如果指定节点上用于集群网络的所有网络适配器均发生故障，则持久节点 IP 标签将变得不可用。持久节点 IP 标签始终保持在同一个网络上，并保持在同一个节点上；它不会在集群中的节点之间移动。

用于心跳检测的 IP 别名 (IP aliases used for heartbeat)

这些 IP 地址是从专用的不可路由地址池中分配的，并用于监视通信接口，而不需要更改通信接口的基本（启动）IP 地址。

这在某些情况下是非常有用的，例如，当更改每个节点上的网络适配器的基本 IP 地址不适宜（因为它们是在 AIX 中定义的），并且那些地址不符合 HACMP 要求（它们在同一个子网中，因此不能监视网络适配器）的时候。

为此目的，HACMP 提供了通过 IP 别名的进行心跳检测的方法。

网络类型

在 HACMP 中，“网络”这个术语用于定义一个逻辑实体，此逻辑实体将用于集群中的节点间通信和用于客户端访问的通信接口和设备分组在一起。可以将 HACMP 中的网络定义为 IP 网络和非 IP 网络。

IP 网络和非 IP 网络均用于在节点之间交换心跳信号（“Keep Alive”）消息。通过这种方式，HACMP 维护有关集群节点及其各自的通信接口和设备状态的信息。

HACMP V5.1 中支持的 IP 网络类型包括：

  • 以太网 (ether)
  • 令牌环网 (token)
  • FDDI 网 (fddi)
  • SP Switch 和 SP Switch2 网 (hps)
  • ATM 网 (atm)

下列 IP 网络类型不受支持：

  • 串行光纤通道转换器网 (SOCC)
  • 串行线路 IP 网 (SLIP)
  • 光纤通道交换网 (FCS)
  • 802.3
  • IBM 高性能交换网 (HPS)

非 IP 网络是两个集群节点之间的点对点连接，HACMP 将其用于控制消息和心跳信号。在 IP 网络（或节点上的 TCP/IP 子系统）发生故障的情况下，这些网络可以为 HACMP 提供附加级别的保护。

HACMP 中的非 IP（基于设备）网络支持下列设备：

  • 目标模式 SCSI (tmscsi)
  • 目标模式 SSA (tmssa)
  • 磁盘心跳信号 (diskhb)
  • 串行 RS232

注意：在 AIX 5L V5.1 和 AIX 5L V5.2 中，HACMP 现在还支持将以太网聚合 (Etherchannel) 通信接口用于 IP 地址接管。不支持将 Etherchannel 用于：

  • 硬件地址接管
  • PCI 热插拔

此外，在当前版本中，HACMP 不支持 AIX 虚拟 IP 功能 (VIPA) 和 IPV6。

选择 IP 地址接管 (IPAT) 方法

在实现集群时要做出的关键决策之一是资源组和与之关联的服务 IP 地址的行为。

由于 HACMP 在大多数时间都用于保护独立的非并发应用程序，因此必须选择将要用于提供高度可用的服务 IP 地址的方法。

在启动应用程序或将其连同关联的资源组一起移动到另一个节点时，可以通过两种方式配置服务 IP 地址：

  • 通过替换通信接口的基本（启动时）IP 地址；

此方法称为“通过 IP 替换的 IP 地址接管 (IPAT)”。

  • 通过为通信接口配置一个除现有 IP 地址之外的附加 IP 地址；此方法称为“通过 IP 别名的 IP 地址接管”。

HACMP V5.1 中的缺省 IPAT 方法是通过别名（通过别名的 IPAT）。要更改此缺省行为，必须使用 HACMP 扩展配置菜单来更改网络属性。

IP 地址接管

IP 地址接管是一种恢复 IP 地址标签的机制，其方法是在初始物理网络适配器发生故障时，将服务 IP 标签转移到另一个节点上的另一个物理网络适配器。IPAT 确保用于向客户端节点提供服务的 IP 地址（标签）保持可用。

IPAT 和服务 IP 标签

可以将两种 IPAT 方法和这些方法控制服务 IP 标签的方式作如下解释：

  • 通过 IP 别名的 IP 地址接管

将服务 IP 地址/标签用作某个现有通信接口的别名，而不更改（替换）该接口的基本地址。
HACMP 使用 ifconfig 命令来执行此操作。

注意：在此配置中，节点上定义的所有基本（启动）IP 地址/标签必须配置在不同的子网上，并且还要与服务 IP 地址（标签）不同。此方法还可以节省硬件，但是需要额外的子网。图 1。

图 1 通过 IP 别名的 IPAT

HACMP 使用 AIX 的 IP 别名网络功能来支持不同类型的网络上的 IP 地址接管。通过 IP 别名的 IPAT 可以在某些类型的网络上使用无故 ARP (gratuitous ARP) 功能。

通过 IP 别名的 IPAT 使单个网络适配器可以支持多个服务 IP 地址（标签）。因此，同一个节点可以同时承载多个资源组，而不会将资源组的数量限制为可用的通信接口的数量。

相对于通过 IP 替换的 IPAT，通过别名的 IPAT 提供了以下优点：

    • 通过 IP 别名的 IP 地址接管比通过 IP 替换的 IPAT 速度更快，因为与在同一个接口上添加一个 IP 别名相比，替换 IP 地址要花显著更长的时间。
    • IP 别名允许多个服务标签在同一个网络接口上共存，因此可以在集群中使用更少的物理网络接口卡。

注意：在 HACMP V5.1 中，通过 IP 别名的 IPAT 是用于保持服务 IP 标签高度可用的缺省机制。

  • 通过 IP 替换的 IP 地址接管

服务 IP 地址替换网络接口上的现有（启动/基本）IP 地址。

使用此方法，同一网络接口上一次仅配置有一个 IP 地址/标签。

注意：在此配置中，服务 IP 地址必须与其中一个节点的通信接口启动地址在同一个子网上，而备用通信接口的基本 IP 地址必须在一个不同的子网上。此方法还可以节省子网，但是需要额外的硬件。

图 2 通过 IP 替换的 IPAT

如果包含服务 IP 地址的通信接口发生故障，在使用通过 IP 替换的 IPAT 时，HACMP 将把服务 IP 地址转移到在同一个节点并在同一网络上的另一个可用接口；在此情况下，关联的资源组不受影响。

如果同一个节点上没有可用的接口，则将资源组连同服务 IP 标签一起转移到另一个具有可用通信接口的节点上。

在使用通过 IP 替换的 IPAT（也称为“传统 IPAT”）时，还可以配置硬件地址接管 (HWAT)。硬件地址接管的实现方式是使用本地管理地址（locally administered address，LAA）来屏蔽通信接口的本机 MAC 地址，从而确保客户端上的 ARP 缓存中的映射保持不变。

网络安全规划

规划网络安全性对于避免集群节点上未经授权的访问也是非常重要的。

从 HACMP V5.1 开始，通过为节点之间所有与 HACMP 配置相关的通信提供公共通信基础设施（守护进程），从而引入了一种新的安全机制。

新的集群通信守护进程 (clcomdES) 的引入在 HACMP 集群中提供了增强的安全性，同时还加快了与配置相关的操作速度。

存在三个级别的通信安全性：

  • 标准级别
    • 缺省安全级别。
    • 直接由集群通信守护进程 (clcomdES) 实现。
    • 使用 HACMP ODM 类别和 /usr/es/sbin/cluster/rhosts 文件来确定合法伙伴。
  • 增强级别
    • 在 SP 集群中使用。
    • 利用基于 Kerberos 提供的第三方身份验证方法的增强身份验证方法。
  • 虚拟专用网（Virtual Private Network，VPN）
    • VPN 是在 AIX 中配置的。
    • 然后将 HACMP 配置为使用 VPN 来进行所有与节点间配置相关的通信操作。

通过使用集群安全通信子系统，HACMP 消除了对每个集群节点上的 /.rhosts 文件或 Kerberos 配置的需要。

但是，可能仍然需要 /.rhosts 来支持需要这种远程通信机制的应用程序的操作。

注意：并非所有集群通信都通过 clcomdES 进行保护；其他守护进程具有自己的通信机制（不是基于“r”命令）。

  • 集群管理器 (clstrmgrES)
  • 集群锁守护进程 (cllockdES)
  • 集群多对等扩展通信守护进程 (clsmuxpdES)

clcomdES 用于集群配置操作，例如集群同步、集群管理 (C-SPOC) 和动态重新配置 (DARE) 操作。

通过使用“最低权限”原则，集群通信守护进程 clcomdES 提供安全的远程命令执行和 HACMP ODM 配置文件更新。

因而，只有存在于 /usr/es/sbin/cluster/ 中的程序才以 root 身份运行；其他所有程序都以“nobody”用户身份运行。除了 clcomdES 以外，还使用了以下程序：

  • cl_rsh 是集群远程 Shell 执行程序。
  • clrexec 用于以 root 身份运行特定的危险命令，例如修改 /etc 目录中的文件。
  • cl_rcp 用于复制 AIX 配置文件。

这些命令硬编码在 clcomdES 中，不支持由用户运行。

集群通信守护进程 (clcomdES) 具有以下特征：

  • 由于集群通信不需要标准 AIX“r”命令，因此可以消除对 /.rhosts 文件的依赖性。因而，即使在“标准”安全模式下，集群安全性也得到了增强。
  • 为其他节点在本地节点（从中执行配置变更和同步的节点）上的 ODM 副本提供可靠的缓存机制。
  • 限制可在远程节点上作为 root 身份执行的命令（只有 /usr/es/sbin/cluster 中的命令才以 root 身份运行）。
  • clcomdES 从 /etc/inittab 启动，并由系统资源控制器（system resource controller，SRC）子系统进行管理。
  • 提供自己的心跳检测机制，并发现活动的集群节点（即使是在集群管理器或 RSCT 未运行的情况下）。

注意：ClcomdES 为诸如 clverify、godm、rsh 和 rexec 等各种 HACMP 服务提供了传输机制。

针对传入连接的 clcomdES 身份验证过程的基础是对照以下文件检查节点的身份：

  • HACMPadapter ODM 类别（此类别中定义的 IP 标签）
  • HACMPnode ODM（用作集群中节点的通信路径的 IP 地址/标签）
  • /usr/sbin/cluster/etc/rhosts 文件

如果 /usr/sbin/cluster/etc/rhosts 文件丢失，或者未包含针对远程发起节点的条目（IP 地址或可解析的 IP 标签），则不允许进入的连接。

如果 HACMPnode、HACMPadapter ODM 类别和 /usr/sbin/cluster/etc/rhosts 文件为空，则 clcomdES 假设集群正在进行配置，并接受传入的连接，然后在初始配置完成后，将对等节点的 IP 标签（地址）添加到 /usr/sbin/cluster/etc/rhosts 文件。

如果请求连接的 IP 地址与上述位置（HACMPadapter、HACMPnode 和 /usr/es/sbin/cluster/etc/rhosts）中的某个标签匹配，则 clcomdES 将反过来连接到请求节点，并要求提供 IP 标签（主机名称）；如果返回的 IP 标签（主机名称）与请求 IP 地址匹配，则身份验证成功完成。

注意：如果 /usr/es/sbin/cluster/etc/rhosts 文件中存在不可解析的标签，则拒绝所有自远程节点的 clcomdES 连接。
HACMP 心跳检测

与在许多其他类型的集群中一样，心跳检测用于监视网络接口、通信设备和 IP 标签（服务、非服务和持久 IP 标签）的可用性，从而监视节点的可用性。

从 HACMP V5.1 开始，心跳检测完全基于 RSCT 拓扑服务（因而 HACMP V5.1 只是“Enhanced Scalability”版本；使用直接由集群管理器守护进程监视的传统网络接口模块 (NIM) 的心跳检测已不再使用）。

执行心跳检测的方法是通过每个通信接口或设备在集群中的节点之间交换消息（Keep Alive 数据包）。

每个集群节点以特定间隔向其他集群节点发送心跳信号消息，并预期以特定间隔接收来自对应节点的心跳信号消息。如果消息接收停止，则 RSCT 将此情况视为故障，并告诉 HACMP，后者将采取适当的恢复操作。

心跳信号消息可通过以下网络发送：

  • TCP/IP 网络
  • 点对点非 IP 网络

为了防止集群分割（split brain），HACMP 必须能够区分节点故障和 TCP/IP 网络故障。TCP/IP 网络故障可能由有故障的网络元素（交换机、集线器和电缆）导致；在这种情况下，集群中的节点不能通过 IP 发送和接收检测信号消息（Keep Alive，KA），因此每个节点认为对等节点发生了故障，并尝试获取资源。这具有潜在的数据破坏风险，在使用并发资源时尤其是如此。

非 IP 网络是节点之间的直接连接（点对点），并且不使用 IP 来进行检测信号消息交换，因此不太容易受到 IP 网络元素故障的影响。如果使用了这些网络类型，则在 IP 网络发生故障的情况下，节点仍然能够交换消息，因此得出的判断是网络故障，从而不执行任何资源组活动。

为了避免 HACMP 中发生分割，我们建议：

  • 配置冗余网络（IP 和非 IP）
  • 同时使用 IP 和非 IP 网络。

若要了解一个建议的两节点集群配置，图 3。

图 3 HACMP 集群中的信号检测

通过磁盘的信号检测

通过磁盘的心跳检测 (diskhb) 是 HACMP V5.1 中引入的新功能，旨在提供预防集群分割的附加保护和简化的非 IP 网络配置，尤其是用于太难或无法实现 RS232、目标模式 SSA 或目标模式 SCSI 连接的环境。

此类网络可以使用任何类型的共享磁盘存储（光纤通道、SCSI 或 SSA），只要用于交换 KA 消息的磁盘是 AIX 增强并发卷组的一部分。用于信号检测网络的磁盘并不专门用于此目的；可以将它们用于存储应用程序共享数据（有关更多信息，请参见图 3）。

客户提出了使用目标模式的光纤通道连接请求，但是由于异构（非标准发起设备和目标功能）的 FC 环境（适配器、存储子系统、SAN 交换机和集线器），此方法很难实现和支持。

通过使用共享磁盘来交换消息，非 IP 网络的实现更加可靠，并且不依赖所使用的硬件类型。

此外，在 SAN 环境中，当使用光纤来连接设备时，这种非 IP 连接的长度具有与 SAN 相同的距离限制， 因而允许实现超长的点对点网络。

通过将某个磁盘定义为增强的并发卷组的一部分，该磁盘的一部分（扇区）将不用于任何 LVM 操作，此磁盘部分将用于在两个节点之间交换消息。

使用通过磁盘的信号检测的规范如下：

  • 一个磁盘可用于两个节点之间的一个网络。同时在两个节点上使用 LVM 分配的物理卷 ID（physical volume ID，PVID）来标识要使用的磁盘。
  • 用于磁盘信号检测网络的建议配置是在每个存储机箱中将一个磁盘用于一对节点。
  • 要求将要使用的磁盘是某个增强并发卷组的一部分，虽然该卷组不一定要是活动的或者是某个资源组（并发或非并发）的一部分。唯一的限制在于，必须同时在两个节点上定义该卷组（volume group，VG）。

注意：增强并发卷组的集群锁机制不使用保留磁盘空间来进行通信（“传统”版本的 clvmd 要使用保留磁盘空间）；它改为使用 RSCT 组服务。

通过 IP 别名的心跳检测

对于 IP 网络，现在引入了一个新的心跳检测功能：通过 IP 别名的信号检测。此功能是为不能或不适宜更改通信接口的基本 IP 地址的集群而提供的。

用于信号检测的 IP 别名是在 HACMP 服务启动时在现有 IP 地址之外配置的。用于此目的的 IP 地址必须与现有的 IP 地址在完全不同的子网中，并且不应该定义用于任何名称解析（/etc/hosts、BIND 等等）。此配置不需要任何附加的可路由子网。

与使用基本/启动 IP 地址来交换心跳信号消息不同，RSCT 使用 HACMP 定义的 IP 别名来为每个通信接口建立通信组（检测信号环）。

注意：在使用通过 IP 别名的心跳检测时，通信接口的基本/启动 IP 地址由不由RSCT 拓扑服务（从而由 HACMP）进行监视。通信接口将通过所分配的 IP 别名接受监视。

即使使用此技术，HACMP 仍然要求网络上的所有接口（所有节点中的接口）能够彼此通信（能够彼此看到对方的 MAC 地址）。

用于 IP 别名的子网掩码与用于服务 IP 地址的子网掩码相同。在定义用于信号检测的 IP 地址时，必须指定要用于信号检测的起始地址，并且必须确保有足够多与网络上使用的现有子网不发生冲突的子网可用（节点中的每个物理通信接口对应一个子网）。

例如，在一个三节点的集群中，所有节点都有三个定义在同一网络上的通信接口，则需要三个不可路由的子网。

假设所有节点都有三个以太网适配器（en0、en1 和 en2），子网掩码属于 C 类，并且要用于通过 IP 别名的信号检测的起始 IP 地址为 172.16.100.1，则为每个以太网适配器（通信接口）分配的别名将如表 1 所示。另请参见图 4 和图 5。

表 1 用于信号检测的 IP 别名

适配器/节点 | 节点 1 | 节点 2 | 节点 3
en0 | 172.16.100.1 | 172.16.100.2 | 172.16.100.3
en1 | 172.16.101.1 | 172.16.101.2 | 172.16.101.3
en2 | 172.16.102.1 | 172.16.102.2 | 172.16.102.3

用于通过 IP 别名的心跳检测的地址在集群同步过程中存储在 HACMPadapter ODM 类中。

图 4 信号检测别名地址分配

在 HACMP V5.1 中，可以配置通过 IP 别名的心跳检测，以便为使用任一种类型的 IPAT（通过 IP 别名或通过 IP 替换）的网络建立基于 IP 的检测信号环。所配置的 IPAT 类型将决定 HACMP 处理服务 IP 地址（标签）的方式：

  • 对于通过 IP 替换的 IPAT，服务标签将替换通信接口的基本（启动）地址，而不是替换心跳检测别名。
  • 对于通过 IP 别名的 IPAT，服务标签将用作通信接口以及基本 IP 地址的别名以及心跳检测别名。

通过 IP 别名的信号检测被定义为一个网络 (HACMP) 特征，并且是 HACMP 拓扑定义的组成部分。要启用此功能，用户必须在 HACMP 网络定义中指定起始地址。

要设置此特征，必须使用扩展 SMIT 菜单（针对集群拓扑）。可以在定义网络时定义此特征，或者可以在以后更改。

图 5 IP 别名管理

有关此主题的更多信息，请参阅红皮书《HACMP for AIX 5L V5.1 Planning and Installation Guide,》（SC23-4861-02） 中的第 3 章“Planning Cluster Network Connectivity”。

共享存储配置

大多数 HACMP 配置都需要共享存储。支持从多个主机进行访问的 IBM 磁盘子系统包括 SCSI、SSA、ESS 和 FAST。

还可以使用第三方 (OEM) 的存储设备和子系统，尽管其中大多数都没有直接经过 IBM 的 HACMP 使用认证。

有关这些设备的信息，请访问制造商各自的网站。

表 2 列出了可在 HACMP 集群用于共享访问的部分 IBM 存储设备（最常用的）。

表 2 外部存储子系统（此处列出的一些型号已经过时或者改变，请在正式设计时在 IBM 网站上进行查询或者咨询相关的技术支持）

IBM 7133 SSA 磁盘子系统，型号 D40 和 T40（支持最大 72.8 GB 的磁盘模块，每个 SSA 环中最多包括八个节点）。

IBM Enterprise Storage Server (ESS)，型号 E10、E20、F10 和 F20（通过 IBM FC/FICON 使用 SCSI 和光纤通道接口最多可以支持八个节点，功能代码：3021、3022 和 3023）

IBM 2105-800 (ESS) Total Storage Enterprise Storage Server（FS 和 SCSI）IBM 7133 SSA 磁盘子系统，型号 D40 和 T40（支持最大72.8 GB 的磁盘模块，每个 SSA 环最多可包括八个节点）。

IBM Total Storage FAStT，型号 200、500、600、700 和 900。

HACMP 还支持共享磁带驱动器（SCSI 或 FC）。共享磁带可通过 SCSI 或 FC 进行连接。不支持并发模式的磁带访问。
有关部分受支持的磁带子系统，请参见表 3。
表 3 磁带驱动器支持

IBM 3583 Ultrium 可伸缩磁带库，型号 L18、L32 和 L72

IBM 3584 Ultra 可伸缩磁带库，型号 L32 和 D32

IBM Total Storage Enterprise 3590 磁带驱动器，型号 H11

IBM Magstar 3590 磁带驱动器，型号 E11 和 B11

IBM 3581 Ultrium Tape Autoloader，型号 H17 和 L17

IBM 3580 Ultrium 磁带驱动器，型号 H11 和 L11

有关受支持的存储和磁带驱动器的更新列表，请访问 IBM 网站。

还可以为 HACMP 配置非 IBM 共享存储子系统（磁盘和磁带子系统）。有关非 IBM 存储的列表，请参见各制造商的网站。

共享 LVM 要求

HACMP 集群的共享 LVM 规划取决于共享磁盘访问方法和共享磁盘设备的类型。应该为共享 LVM 考虑的元素包括：

  • 数据保护方法
  • 存储访问方法
  • 存储硬件冗余

注意：HACMP 本身不提供存储保护。存储保护是通过以下途径提供的：

  • AIX（LVM 镜像）
  • 硬件 RAID

在本部分中，我们将提供有关存储级别的数据保护方法的信息，同时还将讨论 LVM 共享磁盘访问模式。

  • 非并发
  • “传统”并发（HACMP 并发逻辑卷管理器 – clvm）
  • 增强并发模式 (ECM)，AIX 5L V5.1 及更高版本中的一个新选项

非并发、增强并发和并发

在非并发访问配置中，一次仅有一个集群节点可以访问共享数据。如果包含共享磁盘空间的资源组移动到另一个节点，则新节点将激活磁盘，并检查卷组、逻辑卷和文件系统的当前状态。

在非并发配置中，磁盘可共享为：

  • 原始物理卷
  • 原始逻辑卷
  • 文件系统

在并发访问配置中，磁盘上的数据并发地对所有节点可用。此模式不支持文件系统（JFS 或 JFS2）。

快速磁盘接管

HACMP V5.1 利用了新的 AIX 增强并发 LVM。在 AIX 5L V5.2 中，必须以增强并发模式创建任何新的并发卷组。

只有在 AIX 5L V5.2 中，增强并发卷组还可以用于文件系统（共享或非共享）。在故障转移情况下，快速磁盘接管选项利用此功能来加速接管共享文件系统的过程。

增强的并发卷组在资源组中的所有节点上启用，数据访问由 HACMP 进行协调。只有资源组在其上处于活动状态的节点才会以“并发主动”(concurrent active) 模式启用该卷组；

其他节点将以“被动”(passive) 模式启用该卷组。在“被动”模式下，不允许对该卷组执行高级操作。

注意：在将资源组用于快速磁盘接管选项时，拥有冗余网络和非 IP 网络是极其重要的。这将避免在“split brain”情况下发生数据破坏（毕竟，卷组处于并发模式）。

RAID 和 SSA 并发模式

RAID 并发模式卷组在功能上已过时，但是由于增强的并发模式提供了附加的功能，RAID 并发 VG 将在一段时间内继续受支持。RAID 和 SSA 并发模式卷组均受 HACMP V5.1 的支持，但是具有一些重要的限制：

  • 如果并发资源组包括运行 64 位内核的节点，则要求所有卷组都处于增强并发模式。
  • SSA 并发模式在 64 位内核上不受支持。
  • 带有 32 位内核的 SSA 磁盘仍然使用 SSA 并发模式。
  • 不能将 C-SPOC 实用程序用于 RAID 并发卷组。必须将这些卷组转换为增强并发模式（否则，AIX 将它们视为非并发的）。
  • 在 AIX 5L V5.1 中，仍然可以创建 SSA 并发 VG（使用 32 位内核），但是在 AIX 5L V5.2 中，不能创建新的 HACMP 并发 VG；必须以增强并发模式创建所有的新 VG。

LVM 需求
复制，并且可以跨越多个物理磁盘和机箱。
主要的 LVM 组件包括：

  • 物理卷

一个物理卷（physical volume，PV）表示 AIX 所看到的单个物理磁盘 (hdisk*)。物理卷划分为物理分区（physical partition，PP），后者表示 LVM 使用的物理分配单元。

  • 卷组

卷组（volume group，VG）是一组物理卷，AIX 将其视为一个连续的可寻址磁盘区域。在 HACMP 中，卷组及其所有逻辑卷可以属于某个共享资源组。一个卷组不能属于多个资源组（resource group，RG）。

  • 物理分区

物理分区 (PP) 是 VG 中的分配单元。PV 划分为 PP（在将 PV 添加到 VG 时），并且 PP 用于 LV（每个逻辑分区 (LP) 分配一个、两个或三个 PP）。

  • 卷组描述符区域（Volume Group Descriptor Area，VGDA）

VGDA 是磁盘上的一个区域，其中包含有关该卷组中的存储分配的信息。

对于单磁盘卷组，存在两个 VGDA 副本。对于双磁盘 VG，存在三个 VGDA 副本：一个磁盘上有两个 VGDA，另一个磁盘上有一个 VGDA。对于由三个或更多 PV 组成的 VG，卷组中的每个磁盘上存在一个 VGDA。

  • 定额（Quorum）

要使某个活动的 VG 维持活动状态，必须有一个 VGDA“定额”(50% + 1) 可用。此外，如果某个 VG 将定额选项设置为“off”，当一个 VGDA 副本丢失时，则无法将其激活（无“force”选项）。如果关闭了定额，系统管理员必须知道该 VG 的映射，以确保数据完整性。

  • 逻辑卷

统的存储。在 HACMP 中，属于某个 VG 的逻辑卷已经属于某个资源组，并且不能属于另外一个资源组。

  • 逻辑分区

逻辑分区（logical partition，LP）是逻辑卷的空间分配单元，并且是物理分区的逻辑视图。使用 AIX LVM，可以将逻辑分区映射到一个、两个或三个物理分区，以实现 LV 镜像。

注意：虽然可以将 LVM 镜像用于任何类型的磁盘，但是在使用 IBM 2105 Enterprise Storage Servers 或 FAStT 存储服务器时，您可以忽略此选项。这些存储子系统（以及某些非 IBM 存储子系统）通过使用各种级别的 RAID 来提供自己的数据冗余机制。

  • 文件系统

文件系统（file system，FS）实际上是用于存储文件和目录的简单数据库。

AIX 中的文件系统存储在单个逻辑卷上。文件系统（JFS 或 JFS2）的主要组件是包含数据、文件系统日志和文件系统设备驱动程序的逻 辑卷。HACMP 同时支持使用 JFS 和 JFS2 作为共享文件系统，不过要注意，日志必须在一个单独的逻辑卷上（JFS2 可能还有内联日志，但这在 HACMP 中不受支持）。

卷组的强制启用

HACMP V5.1 提供了一个新功能，即在节点上强制启用某个卷组的选项。在接管过程中，如果正常启用命令在该卷组上失败（缺乏定额），则在接管节点上启用该卷组之前，HACMP 将确保该 VG 中每个逻辑卷的每个逻辑分区至少有一个有效副本可用。

只要存在一个有效的数据副本可用，强制启用某个卷组使您可以将卷组置于在线并保持在线（作为资源组的一部分）。应该仅对具有镜像逻辑卷的卷组使用强制启用选项，并慎用此功能以避免创建分割的集群。

注意：对于卷组中用于强制启用选项的逻辑卷，应该指定非常严格的分配策略。这样，LVM 将确保逻辑卷的副本始终在单独的磁盘上，并提高强制启用操作一个或多个磁盘发生故障后的成功机会。

在属于资源组的 VG 失去一个或多个磁盘 (VGDA) 情况下的接管中，此选项非常有用。如果不使用此选项，资源组将不会在接管节点上激活，从而使应用程序不可用。

当在接管情况下使用卷组的强制启用选项时，HACMP 首先尝试正常的 varyonvg 命令。如果此尝试由于缺乏定额而失败，则在尝试强制将卷置于在线之前，HACMP 将检查数据的完整性，以确保卷组中所有的数据至少存在一个可用的副本。如存在，则运行 varyonvg –f 命令；如不存在，该卷组保持离线，并且资源组将处于错误状态。

注意：用户仍然可以使用打破定额 (quorum buster) 的磁盘或自定义脚本来强制启用某个卷组，但是 HACMP 中新的强制启用属性将自动化此操作，客户实施的过程现在可以变得轻松了。
有关更多信息，请参见《HACMP for AIX 5L V5.1 Planning and Installation Guide》SC23-4861-02 中的第 5 章“Planning Shared LVM Components”。

软件规划

在规划 HACMP 集群的过程中，最重要的步骤之一是选择将在集群节点上运行的软件级别。

节点软件规划中的决策因素包括：

  • 操作系统需求：AIX 版本和建议的级别。
  • 应用程序兼容性：确保在集群环境中满足并支持所有应用程序需求。
  • 资源：可以使用的资源类型（IP 地址、存储配置、是否需要 NFS 等等）。

下列 AIX 可选基本操作系统（base operating system，BOS）组件是 HACMP 的必备条件：

  • bos.adt.lib
  • bos.adt.libm
  • bos.adt.syscalls
  • bos.net.tcp.client
  • bos.net.tcp.server
  • bos.rte.SRC
  • bos.rte.libc
  • bos.rte.libcfg
  • bos.rte.libcur
  • bos.rte.libpthreads
  • bos.rte.odm
  • bos.data

在使用（增强的）并发资源管理器访问时，还需要以下组件。

  • bos.rte.lvm.5.1.0.25 或更高版本（用于 AIX 5L V5.1）
  • bos.clvm.enh

应用程序兼容性

运行在某个独立 AIX 服务器上的几乎任何应用程序都可以通过使用 HACMP 集群得到保护，从这个意义上讲，HACMP 是一个灵活的高可用性解决方案。

在开始集群应用程序规划时，应该考虑以下方面：

  • 与所使用的 AIX 版本的应用程序兼容性。
  • 与要实现用于高可用性的存储方法的应用程序兼容性。
  • 还必须知道应用程序和平台之间的所有相互依赖性，也就是所有应用程序文件的所有存储位置（持久数据、临时文件、套接字，以及管道——如适用的话）。
  • 还应该能够提供无人参与的应用程序启动/停止方法（脚本），并且应用程序必须能够在重新启动时从错误（例如，在运行应用程序的节点崩溃的情况下）中恢复。

重要：如果应用程序无法在独立节点上正常运行，或者不能确定所有的应用程序依赖性，请不要继续进行 HACMP 实现！！！

  • 如果计划使用应用程序监视，则还应该提供应用程序监视工具（方法、行为和脚本）。
  • 应用程序客户端依赖性（服务器重新启动时的客户端行为）。
  • 应用程序网络依赖性（套接字、路由等等）
  • 许可证授权问题，也就是说，如果应用程序依赖 CPU ID，则应该考虑为能够承载应用程序的每个节点购买备用许可证。此外，如果应用程序基于处理器数量授予许可证，则在故障转移情况下，要确保不会违背许可证授权。

应用程序服务器

根据 HACMP 定义，应用程序服务器由一个脚本集合来表示，HACMP 使用这些脚本在激活资源组时启动应用程序，或在将资源组置于离线时停止同一个应用程序。

在应用程序已启动之后，HACMP 还可以监视该应用程序，并在应用程序不能正常运行时采取相应措施。应用程序监视可以在进程级别执行，还可以使用自定义方法来执行（例如，对于诸如数据库引擎等多进程应用程序）。

注意：HACMP/ES V4.4 中已经引入了基于 RSCT 的事件管理功能 (EM) 的应用程序监视。从 HACMP V5.2 开始，事件管理已被取代为资源监视和控制（Resource Monitoring and Control，RMC），后者在功能上是等效的，但是提供了更多的灵活性。从 HACMP V5.2 开始，还可以监视应用程序启动。

HACMP 还提供了应用程序可用性分析工具，此工具对于审核总体应用程序可用性和用于评估集群环境非常有用。

规划 NFS 配置

HACMP 的典型应用之一是为客户端计算机和应用程序提供高可用性网络文件系统 (HA-NFS)。这对于使用交叉挂载的网络文件系统实现相互接管来说是非常有用的，在运行应用程序的集群中尤其是如此。

从 HACMP V4.4 开始，HA-NFS 功能已集成到 HACMP 中，因此不再存在单独的产品。

使用 NFS 时的一些注意事项：

  • 对于将要通过 NFS 导出的共享卷组，卷组主编号（ Major Number ）在能够提供该 VG 中的文件系统的所有集群节点上都是相同的。
  • 在 AIX 中，当您导出文件和目录时，将使用 mknfsexp 命令，因此将创建/更新 /etc/exports 文件。另一方面，在 HACMP 中，必须在资源组配置中指定要导出和进行 NFS 装入的文件系统和目录。
  • 如果需要这些文件系统的任何可选配置，则应该创建 /usr/es/sbin/cluster/etc/exports 文件。
  • 对于具有要导出的文件系统的所有资源组，必须将“File systems Mounted before IP Address Configured”属性设置为“true”。
  • HACMP 脚本包含缺省 NFS 行为。您可能需要修改这些脚本以处理特定的配置。
  • 在 HACMP V5.1 中，除了级联资源组外，还可以在循环或自定义资源组中配置高可用性 NFS。

注意：NFS 锁功能仅限于两节点的集群。此功能提供了可靠的 NFS 服务器能力，允许备份处理器在主 NFS 服务器发生故障时恢复当前 NFS 活动，从而将锁保留在 NFS 文件系统和副本缓存 (dupcache) 上。

有关更多信息，请参见 HACMP for AIX 5L V5.1 Planning and Installation Guide，SC23-4861-02。

许可证授权

大多数软件供应商都要求，对于每台物理计算机或多处理器 (SMP) 计算机中的每个处理器，每个应用程序应该使用一个唯一的许可证。通常，许可证激活代码是在安装时输入的。

但是在 HACMP 环境中，在接管情况下，如果应用程序在不同的节点上重新启动，您必须确保拥有用于新计算机的必需激活代码（许可证）；否则应用程序可能无法正常启动。

应用程序还可能需要与节点绑定的唯一许可证（每个节点上的一个单独许可证文件）。

有些应用程序还具有关于可在集群中用于该应用程序的浮动许可证数量的限制。为避免此问题，请确保您拥有用于每台集群节点计算机的足够许可证，以便应用程序能够同时在多个节点上运行（对于并发应用程序尤其是如此）。

客户端连接

在资源组接管期间，应用程序在另一个节点上启动，因此客户端必须知道该操作。在某些情况下，应用程序客户端使用客户端计算机上的 ARP 缓存来重新连接到服务器。在此情况下，存在两种可能的情形：

  • 包含该应用程序的服务 IP 的网络将通过 IP 替换的 IPAT 用于本地管理的 MAC 地址接管（因而不必更新客户端计算机 ARP 缓存）。
  • 每当发生网络或节点事件，HACMP 就使用 clinfo 程序，此程序将调用 /usr/es/sbin/cluster/etc/clinfo.rc 脚本。缺省情况下，此操作将更新系统的 ARP 缓存和指定的客户端 ARP 缓存，以反映对网络地址的更改。如果需要进一步的操作，可以自定义此脚本。

运行 clinfo 守护进程的客户端将能够在发生集群事件后快速重新连接到集群。

注意：如果使用通过 IP 别名的 IPAT，请确保所有客户端都支持 TCP/IP 无故 ARP 功能。

如果 HACMP 节点和客户端在同一个子网上，并且客户端没有运行 clinfo 守护进程，您可能必须通过从集群节点 ping 该客户端，从而间接更新本地 ARP 缓存。

为实现此目的，可以在集群节点上将您希望通知的客户端主机的 IP 标签或 IP 地址添加到 clinfo.rc 脚本中的 PING_CLIENT_LIST 变量。每当发生集群事件，clinfo.rc 脚本就对 PING_CLIENT_LIST 中指定的每个主机执行以下命令：

# ping -c1 $host

在客户端位于不同子网上的情况下，应确保在发生 IPAT 时更新路由器 ARP 缓存；否则，客户端预期将会在重新连接时发生延迟。

操作系统空间需求

在 HACMP V5.1 中，集群验证程序 (clverify) 和新的集群通信守护进程 (clcomdES) 都需要使用 /var 文件系统中的附加空间。

由于详细的消息和附加的调试信息，集群中的每个节点上的 /var 文件系统必须满足以下空闲空间需求：

  • 20 MB，其中：
    • /var/hacmp/clcomd/clcomd.log 需要 2 MB。
    • /var/hacmp/clcomd/clcomddiag.log 需要 18 MB。
  • 用于 /var/hacmp/odmcache 目录中存储的文件的附加（1 MB x 集群中的节点数量）空间。
  • 每个集群节点用于集群验证数据的 4 MB。
  • 用于集群验证日志 (clverify.log[0-9]) 的 2 MB。

例如，对于一个四节点的集群，建议 /var 文件系统中至少有 42 MB 的空闲空间。

  • 应该有 2 MB 的空闲空间用于写入 clverify.log[0-9] 文件。
  • 应该有 16 MB（每个节点 4 MB）的空闲空间用于写入来自节点的验证数据。
  • 应该有 20 MB 的空闲空间用于写入 clcomd 日志信息。
  • 应该有 4 MB（每个节点 1 MB）的空闲空间用于写入 ODM 缓存数据。

对于集群中的每个节点，clverify 实用程序最多需要 /var 文件系统中的 4 MB 空闲空间。clverify 一次最多可以保存某个节点的验证数据的四个副本（在发起该验证的节点上）。

  • /var/hacmp/clverify/current/<nodename>/* 包含当前的 clverify 执行所产生的日志。
  • /var/hacmp/clverify/pass/<nodename>/* 包含上次通过的验证所产生的日志。
  • /var/hacmp/clverify/pass.prev/<nodename>/* 包含倒数第二次通过的验证所产生的日志。
  • /var/hacmp/clverify/fail/<nodename>/* 包含有关上次失败的验证的信息。

此外，/var/hacmp/clverify/clverify.log 及其副本 [0-9] 通常消耗 1-2 MB 的磁盘空间。

资源组规划

资源组是一个逻辑实体，其中包含 HACMP 要使其高度可用的资源。资源可以是：

  • 存储空间（应用程序代码和数据）
    • 文件系统
    • 网络文件系统
    • 原始逻辑卷
    • 原始物理磁盘
  • 服务 IP 地址/标签（由客户端用于访问应用程序数据）
  • 应用程序服务器
    • 应用程序启动脚本
    • 应用程序停止脚本

要让 HACMP 使资源高度可用，必须将每个资源包括在资源组中。

每当发生集群事件和集群中的条件发生改变，HACMP 就将资源组从一个节点移动到另一个节点，从而确保集群资源的可用性。

HACMP 控制资源组在以下情况下的行为：

  • 集群启动
  • 节点故障
  • 节点重新集成
  • 集群关闭

在这其中的每个集群阶段，HACMP 中的资源组行为由以下条件确定：

  • 哪个或哪些节点在集群启动时获取该资源组。
  • 哪个节点在所有者节点发生故障时接管该资源组。
  • 资源组是要退回刚从先前发生的故障中恢复的节点，还是保留在当前拥有它的节点上。

集群节点之间的优先级关系决定了哪个集群节点最初控制某个资源组，以及原始节点在发生故障后重新加入集群时，哪个节点将接管该资源组的控制权。

资源组接管关系可定义为：

  • 级联（Cascading）
  • 循环（Rotating）
  • 并发（Concurrent）
  • 自定义（Custom）

级联、循环和并发资源组是 HACMP V5.1 以前的“传统”类型。由于这些类型的定义可能难于理解，HACMP V5.1 中引入了新的“自定义”类型的资源组。

这只是规范化 HACMP 术语并使得 HACMP 概念更容易理解的第一步。从 HACMP V5.2 开始，“传统”资源组类型已被唯一的自定义资源组所取代。

级联资源组

级联资源组定义了可控制该资源组的所有节点的列表，以及每个节点在接管该资源组方面的优先级。

级联资源组的行为如下：

  • 在集群启动时，在缺省情况下，级联资源组在其主节点（在该节点组中具有最高优先级的节点）上激活。

此外，可以使用另一个名为“Inactive Takeover”的属性，以指定在具有最高优先级的节点（也称为主节点）在集群启动时不可用的情况下，可以在较低优先级的节点上激活该资源组。

  • 在节点发生故障时，级联资源组故障转移到 RG 节点优先级列表中具有下一个优先级的可用节点。

此外，通过为资源组指定“Dynamic Node Priority”策略，故障转移过程将基于某些动态参数（例如，具有最多 CPU 空闲时间的节点）来确定将接管该资源组的节点。

  • 在节点重新集成到集群中时，在缺省情况下，级联资源组将退回其主节点。

此外，通过为资源组指定“Cascading without Fallback”属性，当较高优先级的节点变得可用时，资源组将保留在接管节点上。

总而言之，级联资源组具有以下属性：

  • Inactive Takeover (IT) 是允许微调主节点不可用时的资源组启动（初始获取）的属性。
  • 在当前拥有此类资源组之一的节点发生故障时，该资源组将故障转移到节点优先级列表中的下一个可用节点。可以通过两种方式之一来配置故障转移优先级：使用缺省的节点优先级列表（这是配置 RG 时列出节点的顺序），或者通过设置 Dynamic Node Priority (DNP) 策略。
  • Cascading without Fallback (CWOF) 是一个修改退回行为的属性。通过使用 CWOF 属性，每当具有较高优先级的节点变得可用时，您可以避免不必要的 RG 退回（从而避免不必要的客户端中断）。在此模式下，可以在某个方便的时候手动将 RG 移动到主节点，而不必中断客户端。

循环资源组

对于循环资源组，节点优先级列表仅确定哪个节点将在所有者节点发生故障时接管该资源组。

在集群启动时，节点优先级列表中的第一个可用节点将激活该资源组。

如果资源组在接管节点上，它决不会在某个较高优先级的节点变得可用时退回该节点。

循环 RG 不存在动态节点优先级（Dynamic Node Priority，DNP）计算。

当在同一组节点上配置多个循环 RG 以便控制循环资源组的首选位置时，应该从参与节点列表中为每个组分配一个不同的最高优先级节点。

当集群启动时，每个节点将尝试获取自己拥有其最高优先级的循环资源组。

如果所有循环资源组都已激活，加入集群的新节点将仅作为这些资源组的备份节点来加入。如果所有循环组都未激活，加入集群的节点一般仅获取这些非活动资源组中的一个。其余资源组仍然保持非活动状态。

但是，如果存在多个可在其上移动资源组的网络，一个节点可以获取多个循环组，每个网络一个。
并发资源组

顾名思义，并发 RG 可以同时在多个节点上处于活动状态。在集群启动时，RG 将在列表中的所有节点上激活，并且没有首选的启动顺序。

对于并发资源组，节点之间不存在优先级；它们全都是平等的所有者节点。如果一个节点发生故障，其他节点将继续提供服务；资源组不移动。

可能需要附加的并发软件来管理对应用程序数据的并发访问。

HACMP V5.1 中引入了这种新的 RG 类型，以简化资源组管理和便于理解。资源组名称（级联、循环和并发）对新用户来说可能令人混淆，因为：

  • 它们没有清楚指示基本的 RG 行为。
  • 附加的 RG 参数会使 RG 定义进一步复杂化：

Cascading without Fallback 和 Inactive Takeover。
此外，在某些情况下，用户需要标准 RG 定义所没有提供的行为组合。

  • HACMP V5.1 引入了自定义资源组。
    • 用户必须显式指定所需的启动、故障转移和退回行为。
    • RG 启动和退回可以通过使用 Settling Timer 和 Fallback Timer 来进行控制。
    • 还可以通过使用 Dynamic Node Priority (DNP) 来影响 RG 故障转移。
  • 限制（仅针对 HACMP V5.1）：
    • 自定义 RG 仅支持通过服务 IP 地址/标签别名的 IPAT。
    • 不存在站点或复制的资源支持（对于 HACMP-XD）。

启动首选项

  • Online On Home Node Only：在节点启动时，RG 将仅在具有最高优先级的节点上置于在线。此行为等效于级联 RG 行为。
  • Online On First Available Node：在节点启动时，RG 将第一个激活的节点上置于在线。此行为等效于循环 RG 或使用非活动接管的级联 RG 的行为。如果配置了停留 (settling) 时间，则该时间将影响 RG 的启动行为。
  • Online On All Available Nodes：RG 应该在 RG 中的所有节点上在线。此行为等效于并发 RG 行为。此启动首选项将覆盖某些故障转移和退回首选项。

故障转移首选项

  • Fallover To Next Priority Node In The List：RG 将故障转移到节点列表中的下一个可用节点。此行为等效于级联和循环 RG 的行为。
  • Fallover Using Dynamic Node Priority：RG 将基于 DNP 计算来执行故障转移。资源组必须指定 DNP 策略。
  • Bring Offline (On Error Node Only)：RG 将不在发生错误时进行故障转移；而是简单地将其置于离线。此行为最适合于并发式的 RG。

退回首选项

  • Fallback To Higher Priority Node：RG 将在某个具有较高优先级的节点变得可用时退回该节点。此行为等效于级联 RG 行为。退回计时器将影响此行为。
  • Never Fallback：即使某个较高优先级的节点变得在线，资源组也将保持在原位置。此行为等效于循环 RG 的行为。

应用程序监视
除了资源组管理以外，HACMP 还可以通过以下两种方法之一监视应用程序：

  • 应用程序进程监视：使用 RSCT 事件管理功能检测进程是否终止。
  • 应用程序自定义监视：基于您定义的监视方法（程序或脚本）来监视应用程序的运行状况。

注意：不能将应用程序进程监视用于监视通过 Shell 脚本启动的应用程序，或那些监视进程无法确定应用程序运行状况的应用程序。

对于监视 Shell 脚本应用程序，必须使用自定义监视方法（例如，Apache Web 服务器）。

当应用程序监视处于活动状态时，HACMP 的行为如下：

  • 对于应用程序进程监视，一个内核 hook 将通知 HACMP 集群管理器所监视的进程已终止，HACMP 将启动应用程序恢复过程。

要使恢复操作能够进行，必须提供某种方法来清理和重新启动应用程序（可以使用为应用程序服务器定义提供的应用程序启动/停止脚本）。
HACMP 尝试重新启动应用程序，并等待应用程序稳定指定的时间，然后发送通知消息和/或实际将整个 RG 移动到另一个节点（节点优先级列表中的下一个节点）。

  • 对于自定义应用程序监视（自定义方法），除了应用程序清理和重新启动方法以外，还必须提供用于执行定期应用程序测试的程序/脚本。

要规划进程监视器的配置，请检查以下事项：

  • 验证该应用程序是否可以使用某个进程监视器进行监视。
  • 检查要监视的进程的名称。必须使用准确的进程名称来配置应用程序监视器。
  • 指定拥有进程的用户名，例如 root。请注意，该进程拥有者必须拥有要监视的所有进程。
  • 指定要监视的应用程序的实例数量（进程数量）。缺省为一个实例。
  • 指定在开始监视前的等待时间（以秒为单位）。

注意：在大多数情况下，此值不应该为零。例如，对于数据库应用程序，您可能希望将监视延迟到启动脚本和初始数据库搜索已完成之后。

  • 重新启动数值，表示在采取任何其他操作之前尝试重新启动应用程序的次数。
  • 在重置重新启动数值前应用程序必须保持稳定的间隔（以秒为单位）。
  • 要在应用程序无法在重新启动数值内重新启动时采取的操作。缺省选择是通知，即运行一个事件来向集群通知故障情况。还可以指定故障转移，在此情况下，包含故障应用程序的资源组将移动到对该资源组拥有下一个最高优先级的集群节点。
  • 重新启动方法（如果希望的话）。（如果“Restart Count”不为零，则这是必需的。）

如果计划建立自定义监视方法，则还要检查：

  • 是否已指定了要用于检查指定应用程序的程序/脚本。
  • 关于运行该监视方法的频度的轮询间隔（以秒为单位）。如果监视器在此间隔内没有响应，则认为应用程序出错，并启动恢复过程。
  • 在用户定义的监视方法未在轮询间隔内返回时用于终止该监视器方法的信号。缺省信号为 SIGKILL。
  • 开始监视前的等待时间（以秒为单位）。例如，对于数据库应用程序，建议将监视延迟到启动脚本和初始数据库搜索已完成之后（否则，可能会认为应用程序出错并启动恢复过程）。
  • 重新启动数值，即在采取任何其他操作之前尝试重新启动应用程序的次数。
  • 在重置重新启动数值前应用程序必须保持稳定的间隔（以秒为单位）。
  • 在应用程序无法在重新启动数值内重新启动时采取的操作。

有关更多信息，请参见《HACMP for AIX 5L V5.1 Planning and Installation Guide》SC23-4861-02。

灾难恢复计划

从 HACMP V5.1 开始，HAGEO 和 GeoRM 已作为 IBM HACMP/XD（扩展距离）功能集成到 HACMP 中。

HAGEO 软件产品提供了一个用于构建容灾计算环境的灵活、可靠的平台。HAGEO 组件可以通过 TCP/IP 点对点网络在无限距离的地理站点之间镜像数据。

HAGEO 与 HACMP 协作提供整个地理站点的自动故障检测、通知和恢复。

本红皮书描述的灾难恢复策略使用两个站点：原始和恢复或备份站点。数据恢复策略必须处理以下问题：

  • 数据准备情况级别。
    • 第 0 级：无。不提供灾难恢复。
    • 第 1 级：定期备份。恢复到给定日期所必需的数据将被备份，并将其发送到另一个位置。
    • 第 2 级：为前滚做好准备。除了定期备份外，还将数据更新日志发送到另一个位置。传输可以是手动的或电子的。恢复将截止到恢复站点存储的最后一个日志数据集。
    • 第 3 级：前滚或向前恢复 (forward recover)。在恢复站点的磁盘上维护数据的副本。接收数据更新日志，并使用恢复实用程序定期将其应用于副本。
    • 第 4 级：实时前滚。与前滚一样，只不过是在原始站点中记录更新的同时传输并应用更新。日志数据的这种实时传输和应用不会影响原始站点的事务响应时间。
    • 第 5 级：实时远程更新。在发送事务响应或完成任务前同时更新数据的原始和恢复副本。
  • 站点互连选项。
    • 第 0 级：无。站点之间不存在互连或数据传输。
    • 第 1 级：手动传输。不存在互连。对于站点之间的数据传输，将手动管理数据的发送、跟踪和接收。
    • 第 2 级：远程磁带。以电子方式将数据传输到远程磁带。

发送和接收是自动的。跟踪可以是自动或手动的。

    • 第 3 级：远程磁盘。以电子方式将数据传输到远程磁盘。

发送、接收和跟踪全都是自动的。

  • 恢复站点准备情况。
    • 冷站点（Cold）：冷站点通常是具有适当基础设施的环境，但是只有很少或没有数据处理设备。必须将安装此设备作为数据恢复过程中的第一步。

当灾难发生时，“定期备份”和“为前滚做好准备”的数据都可以从存储位置传输到此站点。

    • 暖站点（Warm）：暖站点安装有可操作的数据处理设备。在灾难发生前，此设备用于其它数据处理任务。可以将数据处理资源用于存储数据，例如日志。恢复过程在关闭和备份站点的定期工作之后开始。

“定期备份”和“为前滚做好准备”的数据都可以存储在此站点以加速灾难恢复。

    • 热站点（Hot）：热站点安装有可操作的数据处理设备，并且可以连续或定期存储数据以缩短恢复时间。

可以实现从“前滚”到“实时远程更新”的所有级别。
HAGEO 软件提供了最高级别的灾难恢复：

  • 第 5 级：HAGEO 通过在发送事务响应或完成任务前同时更新数据的原始和恢复副本，从而提供了“实时远程更新”的数据准备情况。
  • 第 3 级：HAGEO 还通过以电子方式将数据传输到地理上的远程站点，并且该站点的磁盘更新和所有簿记都是自动的，从而提供了远程磁盘站点互连。
  • HAGEO 提供了热站点准备情况。由于恢复站点包含可操作的数据处理设备以及最新数据，这将使恢复时间保持最短。

此外，使用 HAGEO，恢复站点可活动地处理数据并执行有用的工作。事实上，每个站点都可以是另一个站点的备份，从而最小化为每个原始生产站点建立恢复站点的成本。

HACMP 对灾难恢复的贡献

HACMP 基本软件奠定了松散耦合的集群技术的基础，以防止诸如处理器、网络和网络适配器等各个系统组件成为集群中的单点故障。此软件可以确保站点中的计算环境保持高度可用。

您只需根据 HACMP 集群组件定义站点中的系统组件，HACMP 基本软件功能将帮助保持系统组件在该站点中高度可用。

有关更多信息，请参见 High Availability Clusters Multi-Processing XD (Extended Distance) for HAGEO Technology: Planning and Administration Guide, SA22-7956。

图 6 显示了带有远程镜像 (GeoRM) 选项的地理集群关系图。

图 6 HAGEO 组件

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-2/index.html

Top


HACMP 认证学习系列，第 3 部分：安装和配置（1）

HACMP 软件安装

HACMP 软件提供了一系列可用于使应用程序高度可用的功能。务必记住，并非所有的系统或应用程序组件都受到 HACMP 的保护。

例如，如果某个关键应用程序的所有数据都驻留在单个磁盘上，并且该磁盘发生了故障，则该磁盘就成了整个集群的单点故障，并且未受到 HACMP 的保护。在此情况下，必须使用 AIX 逻辑卷管理器或存储子系统保护功能。HACMP 仅在备份节点上提供磁盘接管，以使数据可继续使用。

这就是 HACMP 规划是如此重要的原因，因为整个规划过程中的主要目标是消除单点故障。当关键集群功能由单个组件提供时，就存在单点故障。如果该组件发生故障，集群没有提供该功能的其他途径，依赖该组件的应用程序或服务就会变得不可用。

还要记住，规划良好的集群非常容易安装，可提供更高的应用程序可用性，能够按预期执行，并且比规划不当的集群需要更少的维护。
检查先决条件

在完成规划工作表以后，请验证您的系统是否满足 HACMP 所必需的要求；执行这项额外的工作可以消除许多潜在的错误。

HACMP V5.1 需要下列操作系统组件之一：

  • 带 RSCT V2.2.1.30 或更高版本的 AIX 5L V5.1 ML5。
  • 带 RSCT V2.3.1.0 或更高版本（建议使用 2.3.1.1）的 AIX 5L V5.2 ML2。
  • C-SPOC vpath 支持（需要 SDD 1.3.1.3 或更高版本）。

有关先决条件和 APAR 的最新信息，请参考产品附带的自述文件和以下 IBM 网站：
http://www14.software.ibm.com/webapp/set2/sas/f/cluster/home.html

全新安装

HACMP 支持网络安装管理（Network Installation Management，NIM）程序，包括“备选磁盘迁移”(Alternate Disk Migration) 选项。您必须在每个集群节点上安装 HACMP 文件集。可以通过使用 NIM 或从本地软件存储库安装 HACMP 文件集。

通过 NIM 服务器进行安装

建议使用 NIM，原因只是由于它允许您从服务器而不是从其他媒体将 HACMP 软件加载到其他节点上。

此外，这是一种分发、更新和管理节点的灵活方法。它允许您并行安装多个节点，并提供一个用于维护软件更新的环境。这在大型环境中是非常有用的，是一种节省时间的方法；对于较小的环境，本地存储库可能就足够了。

如果选择 NIM，则需要将所有 HACMP 文件集复制到 NIM 服务器上，并在继续安装前定义一个 lpp_source 资源。

从 CD-ROM 或硬盘进行安装

如果您的环境只有少数节点，或者感觉使用 NIM 有点大材小用，您可以使用简单的 CD-ROM 安装，或者通过将 HACMP 文件集复制到本地来创建本地存储库，然后使用 exportfs 命令；这允许其他节点使用 NFS 来访问数据。

安装 HACMP

在安装 HACMP 之前，请确保阅读 /usr/es/lpp/cluster/doc 目录中的 HACMP V5.1 发布说明，以了解有关需求或已知问题的最新信息。

要在服务器节点上安装 HACMP 软件，可以执行以下步骤：

1. 如果直接从诸如 CD-ROM 等安装媒体或从本地存储库进行安装，请输入 smitty install_all 快速路径。SMIT 将显示 Install and Update from ALL Available Software 屏幕。
2. 在 INPUT device/directory for software 字段中输入安装媒体的设备名称或安装目录，然后按 Enter 键。
3. 输入对应的字段值。

要选择希望安装的软件，请按 F4 以获得软件清单，或输入 all 以安装所有服务器和客户端映像。根据您的集群配置选择希望安装的软件包。有些软件包可能需要在您的环境中不可用的软件集（例如，Tivoli Monitoring）。

cluster.es 和 cluster.cspoc 映像（其中包含 HACMP 运行时可执行文件）是必需的，必须安装在所有服务器上。

注意：如果要安装并发资源管理器 (Concurrent Resource Manager) 功能，则必须安装 cluster.es.clvm LPP，而且，如果选择 cluster.es 和 cluster.cspoc，则还必须选择关联的消息软件包。

确保在 Accept new license agreements 字段中选择 Yes。必须对此项选择 Yes 才能继续进行安装。如果选择 No，安装可能会停止，并显示一条关于一个或更多个文件集需要软件许可协议的警告。您只需对每个节点接受一次许可协议。

4. 按 Enter 键开始安装过程。

安装后的操作

要在安装 HACMP 软件之后完成安装，可以执行以下步骤：

1. 通过使用 AIX 命令 lppchk 验证该软件安装，并检查安装目录以确定预期的文件是否存在。

2. 运行命令 lppchk -v 和 lppchk -c cluster*。如果该安装正常，则两个命令都会顺利运行完成；如果不是这样，请使用适当的问题确定技术以修复任何问题。

3. 尽管不是必需的，但还是建议重新启动 HACMP 环境中的每个集群节点。

如果不希望重新启动，请确保使用以下命令在所有集群节点上启动集群通信守护进程 (clcomdES)。
# startsrc -s clcomdES

迁移路线和选项

如果您正在进行升级或转换 HACMP 集群的过程，可以使用以下选项：逐个节点的迁移和快照转换。

如果需要在迁移过程期间使应用程序保持可用，则使用逐个节点的迁移路线。逐个节点的迁移的步骤如下：

1. 停止一个集群节点上的集群服务。
2. 升级 HACMP 软件。
3. 将该节点重新集成到集群中。
此过程也称为“滚动迁移”（“rolling migration”）。此迁移选项具有某些限制；有关更多详细信息，请参见后文的“逐个节点的迁移”。

如果可以接受应用程序的维护时间，则迁移步骤如下：
1. 停止所有集群节点上的集群服务。
2. 升级每个节点上的 HACMP 软件。
3. 一次启动一个节点上的集群服务。

快照迁移

还可以通过使用一个集群快照功能，从而将整个集群转换到 HACMP V5.1。但是，集群将在整个过程中不可用，并且在重新激活集群之前，必须升级所有的节点。

有关更多详细信息，请参见下面的“转换集群快照”。

转换集群快照

此迁移方法是为必须同时升级/迁移 AIX 和 HACMP 的情况而提供的（例如，将 AIX V4.3.3 和 HACMP V4.4.1 迁移到 AIX 5L V5.1 和 HACMP V5.1）。

重要：不要使集群长期处于混合版本状态是非常重要的，因为这样无法保证高可用性。

如果要从早期受支持的 HACMP (HAS) 版本迁移到 HACMP V5.x，您可以迁移集群而不创建快照。如果希望通过与以前安装中相同的方式配置 HACMP，您可以保存来自当前配置的规划工作表和配置文件，以便将来参考。卸载 HACMP 软件组件，使用最新的 HACMP 版本重新安装它们，并根据保存的规划和配置文件对新版本进行配置。

注意：应该注意，在迁移或升级以后，没有任何一个新的 HACMP V5.x 功能是活动的。要激活新功能（增强功能），您需要配置选项并同步集群。

要从受支持的 HAS 版本转换到 HACMP，可以执行以下步骤：

1. 确保当前软件已提交（不是处于应用状态）。
2. 在快照中保存 HAS 集群配置，并保存您希望保留的任何自定义事件脚本。
3. 删除集群中所有节点上的 HAS 软件。
4. 安装 HACMP V5.1 软件。
5. 验证所安装的软件。
6. 转换并应用保存的快照。

集群快照实用程序允许您通过执行以下步骤将集群配置保存到某个文件：

1. 根据需要重新安装任何保存的自定义事件脚本。
2. 重新启动每个节点。
3. 同步并验证 HACMP V5.1 配置。

下面几部分将解释其中每个步骤。

检查以前的 HACMP 版本

要确定系统上是否存在 HACMP Classic (HAS) 软件，可以输入以下命令：

# lslpp -h “cluster*”

如果 lslpp 命令的输出表明 HACMP 已安装，但是版本低于 V4.5，您必须将其至少升级到 V4.5，然后才能继续运行快照转换实用程序。有关更多信息，请参考 HACMP for AIX 5L V5.1 Administration and Troubleshooting Guide, SC23-4862-02。

保存集群配置和自定义事件脚本

要保存 HACMP (HAS)（V4.5 或更高版本）集群配置，请在 HACMP (HAS) 中创建一个快照。如果您有自定义的事件脚本，则还必须保存这些脚本。

注意：请不要在 /usr/sbin/cluster、/usr/es/sbin/cluster 或 /usr/lpp/cluster 中的任何目录路径中保存集群配置或自定义事件脚本。这些目录将在安装新的 HACMP 软件包的过程中被删除并重新创建。

如何删除 HACMP (HAS) 软件

要删除 HACMP 软件和集群节点及客户端上的集群配置，可以执行以下步骤：

1. 输入 smitty install_remove 快速路径。您应该看到示例 1 所示的屏幕。
示例 1 删除已安装的软件

Remove Installed Software
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* SOFTWARE name [cluster*] +
PREVIEW only?(remove operation will NOT occur) yes +
REMOVE dependent software? no +
EXTEND file systems if space needed? no +
DETAILED output? no +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

安装 HACMP V5.1

按照“安装 HACMP”中的说明来安装 HACMP 软件。

注意：在转换并应用保存的快照之前，请不要重新启动。

验证所安装的软件

在安装 HACMP 以后，使用 lppchk 验证预期的文件是否存在。

转换并应用保存的快照

在集群节点上安装 HACMP V5.1 以后，需要转换并应用从以前的配置中保存的快照。

重要：必须在重新启动集群节点之前转换快照。

要转换并应用保存的快照，可以执行以下操作：
1. 使用 clconvert_snapshot 实用程序，并指定 HACMP (HAS) 版本号和要转换的快照文件名。-C 标志将 HACMP (HAS) 快照转换为 HACMP V5.1 快照格式：
clconvert_snapshot -C -v version -s <filename>
2. 应用该快照。

重新安装保存的自定义事件脚本

重新安装从以前的配置中保存的任何自定义事件脚本。

注意：早期版本中使用的某些事件前和事件后脚本可能在 HACMP V5.1 中无法使用，在使用并行处理的资源组中尤其是如此。

重新启动集群节点
重新启动集群节点是激活新的集群通信守护进程 (clcomdES) 所必需的。

验证并同步集群配置
在应用 HACMP 软件并重新启动每个节点以后，必须验证并同步集群拓扑。验证过程可以提供错误和/或警告，以确保集群定义在所有节点上都是相同的。在下面的部分中，我们将简要介绍集群验证过程。
运行 smitty hacmp 并选择 Extended Configuration → Extended Verification and Synchronization，选择 Verify changes only，然后按 Enter 键（请参见示例 2）。
示例 2 HACMP 验证和同步

HACMP Verification and Synchronization (Active Cluster on a Local Node)
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Emulate or Actual [Actual] +
Force synchronization if verification fails?[No] +
* Verify changes only?[No] +
* Logging [Standard] +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

重要：不能在混合版本的集群中同步配置。在升级时，不应该使集群长期处于混合 HACMP 版本状态。仅当所有节点都已升级并且已经同步了集群时，V5.1 提供的新功能才可用。

3.1.6 逐个节点的迁移
必须考虑以下事项以便执行逐个节点（“滚动”）的迁移：

  • 集群中的所有节点都必须已经安装了 HACMP V4.5，并处于提交状态。
  • 逐个节点的迁移仅适用于从 HACMP (HAS) V4.5 到 HACMP V5.1 的迁移。
  • 集群中的所有节点都必须正常启动并运行 HAS V4.5 软件。
  • 集群必须处于稳定状态。
  • 必须有足够的磁盘空间在迁移过程中保存 HAS 和 HACMP 软件：
    • /usr 目录中大约需要 120 MB
    • /（根）目录中大约需要 1.2 MB
  • 当迁移完成时，空间需求将降至 HACMP V5.1 本身所需的正常容量。
  • 节点必须有足够的内存来同时运行 HACMP (HAS) 和 HACMP 守护进程。此内存需求至少为 64 MB 的 RAM。建议使用 128 MB 的 RAM。
  • 检查您不具有在 HACMP 中不受支持的网络类型。一旦迁移开始，就不能再做出配置更改。必须预先删除或更改不受支持的类型。有关详细信息，请参阅 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02 的第 3 章“Planning Cluster Network Connectivity”。

重要：与在任何迁移中一样，一旦开始了迁移过程，就不要尝试对集群拓扑或资源做出任何更改。

  • 如果集群中的任何节点当前设置为在重新启动时自动启动集群服务，则应该在开始迁移过程之前更改此设置。下面的过程描述了如何关闭集群的自动启动。
  • 使用 C-SPOC 来禁用集群服务在系统重新启动时的自动启动。
  • 使用 SMIT 快速路径 smitty clstop，并选择如示例 3 所示的选项。

示例 3 停止集群服务

Stop Cluster Services
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Stop now, on system restart or both on system restart +
Stop Cluster Services on these nodes [p630n01] +
BROADCAST cluster shutdown? true +
* Shutdown mode graceful +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

如果不使用 C-SPOC，则必须单独地更改每个集群节点上的设置。

如何执行逐个节点的迁移
要执行从 HACMP V4.5 到 HACMP V5.1 的逐个节点的迁移，可以执行以下步骤：

1. 在快照中保存当前配置（作为预防措施）。
将快照放在安全的目录中（不会受安装过程影响的目录）。请不要使用 /usr/sbin/cluster。
2. 使用 graceful with takeover 方法停止其中一个运行 HAS V4.5 的节点上的集群服务。要从命令行停止集群服务，可以运行以下命令：
# /usr/es/sbin/cluster/utilities/clstop -gr
3. 在继续之前，验证该节点上的集群服务已停止，并且其集群资源已转移到接管节点。
4. 在该节点上安装 HACMP V5.1。有关说明请参见“HACMP 软件安装”。
5. 使用 AIX 命令 lppchk 检查所安装的软件。请参见上的“安装后步骤”。
6. 重新启动该节点。
7. 重新启动 HACMP 软件：
a. 输入快速路径 smitty hacmp。
b. 转到 System Management (C-SPOC)。
c. 选择 Manage HACMP Services。
d. 选择 Start Cluster Services。
在重新启动集群服务时：

  • 还会启动 HACMP 软件。
  • HACMP 集群服务将在该节点上运行，并且该节点将重新加入集群。
  • 该节点将重新获取自己所属主节点的级联资源（取决于您的 Inactive Takeover 设置）。

旧的和新的 HACMP 版本（即 HACMP V4.5 和 Enhanced Scalability HACMP V5.1）现在都在该节点上运行，但是只有 HACMP Classic (HAS) 控制集群事件和资源。如果列出由系统资源控制器 (SRC) 控制的守护进程，您将看到此混合节点上列出了下列守护进程（请参见表 1）。
表 1 HACMP 使用的守护进程列表

HACMP | HACMP/ES | RSCT
clstmgr | clstmgrES | grpsvcs
clockd (optional) | clockdES (optional) | topsvcs
clsmuxpd | clsmuxpES | emsvcs
clinfo (optional) | clinfoES (optional) | grpglsm
 | clcomdES | emaixos

8. 对集群中的所有其他节点重复步骤 2 至 6。
注意：启动最后一个节点上的集群服务以后就没有回头路可走了。
一旦重新启动最后一个节点上的 HACMP（将同时重新启动 HACMP 的两个版本），并且迁移已开始，您就无法逆转迁移了。
如果在经过此点以后希望恢复 HACMP 配置，则必须重新安装 HACMP 软件并应用保存的快照。截止到此时，您可以取消 HACMP 的安装并恢复先前运行的 HACMP 集群。如果需要这样做，请参见“撤消过程”。
在安装和迁移过程期间，当您重新启动每个节点时，节点将同时运行两个产品，但是 HACMP clstrmgr 将控制集群事件的处理，而 clstrmgrES 则处于被动模式。
在最后一个节点上启动集群服务以后，到 HACMP 的迁移将自动进行。集群的完全控制权限自动移交给 HACMP V5.1 守护进程。
迁移过程文档的消息将记录到 /tmp/hacmp.out 文件以及 /tmp/cm.log 和 /tmp/clstrmgr.debug 日志文件。
当迁移完成，并且所有集群节点都已启动并正常运行 HACMP V5.1 时，卸载 HACMP (HAS) 软件。
9. 在升级并重新启动所有节点，并且集群处于稳定状态以后，同步并验证该配置。
还应该在任何迁移之后测试集群的正确故障转移和恢复行为。
注意：在逐个节点地从 HAS 4.5 迁移到 HACMP V5.1 的过程中，您将看到下列警告：
sysck:3001-036 WARNING:File /etc/cluster/lunreset.lst is also owned by files cluster.base.server.events.
sysck:3001-036 WARNING:File /etc/cluster/disktype.lst is also owned by fileset cluster.base.server.events.
可以安全地忽略这些警告并继续进行安装。
config_too_long 消息
当迁移过程已完成并在卸载 HACMP 文件集时，您可能会看到一条 config_too_long 消息。
当集群管理器检测到某个事件的处理时间超出了指定的时间时，就会出现此消息。config_too_long 消息将不断被追加到 hacmp.out 日志，直到该事件完成。如果观察到这些消息，您应该定期检查该事件是否实际仍在运行并且没有失败。
可以通过增加 HACMP 在调用 config_too_long 事件之前的等待时间来避免这些消息（使用 SMIT）。要更改为某个事件分配的处理间隔，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Event Configuration。
4. 选择 Change/Show Time Until Warning。

必须在每个节点上执行此过程。更改将在重新启动集群服务以后生效。

逐个节点的迁移过程是如何工作的

在所有节点上安装 HACMP 以后（现在所有节点都处于混合版本状态），在最后一个集群节点上启动集群服务会自动触发到 HACMP V5.1 的控制权移交，如下所示：
1. 安装 HACMP V5.1 将在集群节点上的某个固定目录中安装一个名为 firstboot 的恢复文件，并创建一个要在迁移过程中用作标志的迁移文件 (.mig)。
2. HACMP 恢复驱动程序将向 HACMP 集群管理器发送一条消息，告诉它运行 waiting 和 waiting_complete 事件。

  • HACMP 使用 RSCT 组服务来验证集群稳定性和成员资格。
  • 将每个集群节点上的 firstboot 文件移动到一个活动目录 (/etc)。
  • 在所有节点上，将安装期间创建的迁移标志（.mig 文件）从 HACMP V5.1 目录转移到 HACMP V4.5 目录。

在将 firstboot 文件移动到活动目录并在所有节点上完成 .mig 文件转移之后，到 HACMP 的控制权移交将继续触发 HACMP 迁移事件。
3. HACMP 恢复驱动程序发出迁移事件。

  • HACMP V5.1 使用 forced 选项停止 HACMP V4.5 守护进程。
  • 全部激活 HACMP V5.1 clinfoES 和 clsmuxpdES 守护进程，并重用那些守护进程的 HACMP V4.5 版本以前所使用的端口。

4. HACMP V5.1 恢复驱动程序将运行 migrate_complete 事件。

  • 卸载 HACMP V4.5。两个产品共有的配置文件保持不变。
  • 重新链接基本目录。
  • 删除 /etc/firstboot 文件。
  • 删除 HACMP /usr/sbin/cluster 目录中的迁移标志（.mig 文件）。

5. 迁移工作到此结束。

迁移期间保存的集群快照
预先存在的 HACMP 快照保存在 /usr/es/sbin/cluster/snapshots 目录中。

处理迁移过程中的节点故障
在将节点的 firstboot 文件移动到某个活动目录以后，如果节点在迁移期间发生故障，则会在节点重新启动期间完成迁移过程。但是，故障节点在重新集成到集群中时，可能有不同步的 HACMP ODM。在此情况下，应该在将故障节点重新集成到集群中之前同步集群拓扑和资源。

撤消过程
如果由于某种原因而决定不完成迁移过程，您可以在启动最后一个节点上的 HACMP 之前的任何时候，在已安装 HACMP V5.1 软件的节点上卸载 HACMP V5.1。

注意：仅在本地节点上卸载 HACMP 软件。在迁移期间，请不要选择用于卸载多个节点中的软件的选项。

要卸载 HACMP 软件，可以执行以下操作：
1. 在每个节点上，逐个地停止集群服务。
要停止集群服务，请参见示例3。
在继续之前，检查该节点上的集群服务已停止，并且其集群资源已转移到接管节点。
2. 当您确信节点上的资源已正确转移到接管节点时，删除 HACMP V5.1 软件。请参见 “如何删除 HACMP (HAS) 软件”。
3. 在该节点上启动 HACMP。当您确信资源已正确转移回该节点（若需要的话）时，在下一个节点上重复这些步骤。
4. 继续此过程，直到从集群中的所有节点删除 HACMP。

处理逐个节点的迁移过程中的同步故障
如果尝试在迁移未完成时对集群拓扑或资源做出更改，同步过程将会失败。您将接收到以下消息：
cldare:Migration from HACMP V4.5 to HACMP V5.1 Detected. cldare cannot be run until migration has completed.
要撤消更改，必须恢复活动的 ODM。请执行以下步骤：
1. 输入 smitty hacmp。
2. 转到 Problem Determination Tools。
3. 选择 Restore HACMP Configuration Database from Active Configuration。

下面将讨论 HACMP 升级。
受支持的 HACMP V5.1 升级
HACMP 转换实用程序提供了从下面列出的版本升级到 V5.1 的简单升级路线：

  • HACMP/ES V4.4.1 到 HACMP V5.1
  • HACMP/ES V4.5 到 HACMP V5.1

如果希望从比上面列出的版本更早的版本转换到 HACMP V5.1，则必须首先升级到上述受支持的版本之一。然后您将能够转换到 HACMP V5.1。例如，要从 HACMP/ES 4.2.2 转换到 HACMP V5.1，必须首先执行到 HACMP/ES 4.4.1 或更高版本的安装升级，然后再执行到 HACMP V5.1 的升级。

要升级到 HACMP V5.1，可以执行以下步骤：
1. 根据需要升级到 HACMP V5.1 维护级别 5 或更高级别。
2. 根据需要检查并验证 AIX 安装。
3. 在所有节点上提交当前的 HACMP 软件。
4. 使用 clstop 命令停止一个节点上的 HACMP/ES。
5. 在资源从已停止的节点成功转移到接管节点以后，安装新的 HACMP 软件。

有关安装 HACMP V5.1 软件的说明，请参阅“HACMP 软件安装”。
通过使用 AIX 命令 lppchk 验证该软件安装，并检查安装目录以确定预期的文件是否存在：
lppchk -v 或 lppchk -c “cluster.*”
如果该安装正常，则两个命令都应该会顺利运行完成。
6. 重新启动第一个节点。
7. 使用 smitty clstart 启动第一个节点上的 HACMP 软件，并验证第一个节点成功加入了集群。
8. 一次一个节点地在其余集群节点上重复上述步骤。
9. 检查 tty 设备是否已配置为串行网络。
并重新配置它们。
11. 在完成所有节点的升级以后，按照 “验证升级后的集群定义”中的描述，将节点配置和集群拓扑从节点 A 同步到所有节点。请不要跳过同步期间的验证。
重要：在升级时，当某个还未升级的节点仍在混合版本的集群中时，切勿从某个已升级的节点同步集群定义。cl_convert 实用程序分配跨集群中的所有节点保持一致的节点 ID。这些新 ID 可能与已经存在的 ID 发生冲突。
12. 恢复 HACMP 事件 ODM 对象类，以保存已经为集群配置的任何事件前和事件后脚本。
13. 根据需要对集群做出附加更改。
14. 在投入生产应用前对集群完成一个测试阶段。
验证升级后的集群定义
此部分内容会在后面的文章中详细讲解。
cl_convert 和 clconvert_snapshot
HACMP 转换实用程序是 cl_convert 和 clconvert_snapshot。
将 HACMP/ES 软件升级到最新版本的 HACMP 涉及到将 ODM 从早期版本转换到最新版本的 ODM。在安装 HACMP 时，将会自动运行 cl_convert。但是，如果安装失败，则必须从命令行运行 cl_convert。
在转换失败的情况下，请使用 –F 标志运行 cl_convert。例如，要从 HACMP/ES V4.5 转换到 HACMP V5.1，可以按如下方式使用 -F 和 –v（版本）标志（请注意为 V4.5 添加的“0”）：

# /usr/es/sbin/cluster/conversion/cl_convert -F -v 4.5.0

运行转换实用程序将需要：

  • Root 用户权限
  • 要转换的源 HACMP 版本

cl_convert 实用程序将转换进度记录到 /tmp/clconvert.log 文件，以便您能判断转换是否成功。此日志在每次执行 cl_convert 或 clconvert_snapshot 时生成（被改写）。
clconvert_snapshot 实用程序不会在安装期间自动运行，而是必须从命令行运行。按照 “cl_convert 和 clconvert_snapshot”中的描述，在从 HACMP (HAS) 迁移到 HACMP 时运行 clconvert_snapshot 以升级集群快照。

升级并发资源管理器
要在集群节点上安装并发访问功能，请使用“HACMP 软件安装”中列出的过程来安装并发资源管理器（Concurrent Resource Manager，CRM）。
AIX 5L V5.1 支持增强并发模式 (ECM)。如果要安装带并发资源管理器功能的 HACMP，请参阅 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02 中的第 2 章“Initial Cluster Planning”。
有关增强并发模式和受支持的 IBM 共享磁盘设备的信息，请参阅 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02 中的第 5 章“Planning Shared LVM Components”。此外，如果希望使用来自其他制造商的磁盘，请参阅 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02 中的附录 D“OEM Disk Accommodation”。

安装期间的问题
如果在安装期间遇到问题，安装程序会自动执行一个清理过程。如果由于某种原因，在失败的安装之后没有执行清理，可以执行以下步骤：
1. 输入 smitty install。
2. 选择 Software Maintenance and Utilities。
3. 选择 Clean Up After a Interrupted Installation。
4. 检查 SMIT 输出（或检查 /smit.log 文件）以确定中断原因。
5. 通过使用 AIX 问题确定技术来修复任何问题，并重复安装过程。

网络配置
集群节点通过通信网络进行彼此通信。如果某个节点上用于某个网络的其中一个物理网络接口卡 (NIC) 发生故障，则 HACMP 通过将流量转移到同一节点上的另一个物理网络接口卡，从而保持到该节点的通信。如果到该节点的“连接”失败，则 HACMP 将把资源转移到另一个可用节点。
此外，HACMP（通过 RSCT 拓扑服务）使用节点之间的心跳信号消息（通过集群网络），定期检查集群节点和通信接口的可用性。如果 HACMP 没有检测到来自某个节点的心跳信号，则认为该节点已发生故障，其资源将自动转移到另一个节点。
强烈建议在集群节点之间配置多条通信路线。拥有多个网络可以防止集群分割（“裂脑”（(“split brain”））。分割集群中的危险之处在于，每个分区中的节点可能不协调地同时访问相同数据，从而导致数据破坏。

网络类型
下面将讨论网络的类型。
物理和逻辑网络
物理网络连接两个或更多个物理网络接口。存在许多类型的物理网络，HACMP 大致将它们分类为基于 IP 的网络和非 IP 网络：

  • 基于 TCP/IP 的网络，例如以太网或令牌环网
  • 基于设备的网络，例如 RS-232 或目标模式 SSA (tmssa) 网络

在 HACMP 中，所有能够直接彼此通信的网络接口都分组到一个逻辑网络中。HACMP 为每个 HACMP 逻辑网络分配一个名称（例如，net_ether_01）。HACMP 中的逻辑网络可以包含一个或多个 IP 子网。RSCT 管理每个逻辑子网中的心跳信号数据包。

全局网络
全局网络是多个 HACMP 网络的组合。HACMP 网络可以由物理上不同的网络和/或不同的逻辑网络（子网）的任何组合组成，只要它们共享相同的“冲突域”(collision domain)，例如 Ethernet。HACMP 将组合的全局网络视为单个网络。RSCT 处理全局网络中定义的网络之间的路由。

TCP/IP 网络
HACMP 支持的基于 IP 的网络包括：

  • ether（以太网）
  • atm（异步传输模式，ATM）
  • fddi（光纤分布式数据接口，FDDI）
  • hps（SP 交换）
  • token（令牌环）

通过 IP 别名的心跳检测
在 HACMP V5.1 中，可以配置通过 IP 别名的信号检测。在以前版本的 HACMP 中，检测信号是通过服务和非服务 IP 地址/标签（基本或启动 IP 地址/标签）进行交换的。
使用此配置，通信接口的 IP 启动地址可以驻留在同一个子网或不同的子网上。RSCT 使用自动分配并分组到不同子网中的 IP 别名，为每个通信接口组建立单独的心跳信号环。可以将非可路由的子网用于检测信号环，并将其它子网保留用于可路由的（客户端）流量。
有关通过基于 IP 的网络的检测信号配置的更多信息，请参阅后文的“定义通信接口”。

持久 IP 地址/标签
持久节点 IP 标签是一个 IP 别名，可以将其分配给网络上的某个特定节点。持久节点 IP 标签是具有以下特征的标签：

  • 始终保持在同一个节点上（与节点绑定）
  • 与同一个接口上存在的其他 IP 标签共存
  • 不需要在该节点上安装附加的物理接口
  • 不属于任何资源组

在节点上分配用于某个网络的持久节点 IP 标签使您可以在集群网络上拥有与节点绑定的地址，此地址可以访问集群中的特定节点来进行管理。有关更多信息，请参后文的“定义持久 IP 标签”。

非 IP 网络
HACMP 中的非 IP 网络用作在集群节点之间交换消息的独立路径。在 IP 子系统发生故障的情况下，当存在某个独立路径可用并且有效时，HACMP 仍然可以区分网络故障和节点故障。下面是对四种当前可用的非 IP 网络类型及其特征的简略描述。尽管可以配置没有非 IP 网络的 HACMP 集群，但是强烈建议在集群节点之间至少使用一个非 IP 连接。
HACMP 目前支持将下列类型的网络用于集群节点之间的非 TCP/IP 心跳信号交换：

  • 串行网络 (RS232)
  • 磁盘检测信号网络 (diskhb)
  • 目标模式 SSA 网络 (tmssa)
  • 目标模式 SCSI 网络 (tmscsi)

串行网络 (RS232)
串行 (RS232) 网络至少需要每个集群节点有一个可用的串行端口。在由两个以上的节点组成的集群的情况下，将通过串行连接建立一个节点环，从而要求每个节点有两个串行端口。
在本机串行端口数量与 HACMP 集群配置需要不匹配的情况下，可以通过添加八端口的异步适配器来扩充串行端口。有关更多信息，请参见后文的“定义通信设备”。

磁盘心跳信号网络
在某些情况下，RS232、tmssa 和 tmscsi 连接可能成本太昂贵，或者设置起来太复杂。通过磁盘的信号检测 (diskhb) 可以为用户提供：

  • 非常易于配置的点对点网络类型。
  • 预防集群分割的附加保护。
  • 可使用任何磁盘类型来形成数据路径的点对点网络类型。
  • 不需要附加硬件的设置；可以使用同时还用于数据并包括在资源组中的磁盘。

为了支持 SSA 并发 VG，每个磁盘上有一小部分保留空间用于 clvmd 通信。增强并发 VG 不使用该保留空间来通信；相反，它们使用 RSCT 组服务。
磁盘心跳信号使用一个保留扇区（保留用于 SSA 并发模式 VG 的扇区），节点可将其用作交换 Keep Alive 消息的区域。
属于增强并发 VG 的任何磁盘都可用于 diskhb 网络，包括用于数据存储的磁盘。此外，包含用于 diskhb 网络的磁盘的 VG 不必启用。
可以将任何磁盘类型配置为增强并发 VG 的一部分，从而使得这种类型的网络极其灵活。有关配置磁盘检测信号网络的更多信息，请参见 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02 中的第 3 章“Planning Cluster Network Connectivity”。

目标模式 SSA
如果使用共享 SSA 设备，可以将目标模式 SSA 用于 HACMP 中的非 IP 通信。这依赖 SSA 适配器的内置功能（使用 SCSI 通信协议）。SSA 环路（磁盘和适配器）中的 SSA 设备使用“发起者”和“目标”之间的通信；SSA 磁盘是“目标”，但是 SSA 适配器同时具有两个功能（“发起者”和“目标”）；因而，tmssa 连接使用这些功能在 HACMP 节点之间建立串行式的链路。这是一个点对点的通信网络，只能在两个节点之间通信。
要在集群节点之间配置 tmssa 网络，该节点中的 SSA 适配器（一个或多个）必须是包含共享磁盘的 SSA 环路的一部分。在此情况下，必须为每个节点分配一个唯一的 SSA 路由器设备 (ssar) 节点编号。
要更改系统的 SSA 节点编号，可以执行以下步骤：
1. 运行 smitty ssa 快速路径。
2. 选择 Change/Show SSA Node Number of this System。
3. 将节点编号更改为集群环境中的唯一编号。
注意：在使用并发磁盘访问的集群中，SSA 路由器编号必须与 HACMP 节点编号匹配（与之相同）；
否则，您将无法以并发模式 Varyon 共享卷组。

目标模式 SCSI
另一种可能的非 IP 网络是目标模式 SCSI 连接。
每当使用共享 SCSI 设备的时候，您还可以使用 SCSI 总线来交换心跳信号。只有 SCSI-2 Differential 或 SCSI-2 Differential Fast/Wide 设备才支持目标模式 SCSI (tmscsi)。SCSI-1 Single-Ended 和 SCSI-2 Single-Ended 不支持 HACMP 集群中的串行网络。
建议不要在今后的任何配置中使用此类网络（因为磁盘心跳信号网络要与受支持的任何类型的共享 SCSI 磁盘一起工作）。

存储配置
存储配置是必须在开始 HACMP 集群配置之前执行的最重要任务之一。可以将存储配置视为 HACMP 配置的一部分。
根据应用程序的需要和存储的类型，您必须决定集群中有多少个节点将拥有共享存储访问，以及哪些资源组将使用哪些磁盘。
HACMP 支持大多数 IBM 存储子系统。要了解有关存储服务器支持的更多信息，请参见 HACMP for AIX 5L V5.1 Planning and Installation Guide，SC23-4861-02。
最常用的共享存储子系统包括：

  • 光纤连接存储服务器 (FAStT)
  • 企业存储服务器 (ESS/Shark)
  • 串行体系结构存储 (SSA)

存储保护（数据或其他方面）独立于 HACMP；对于高可用性存储，必须使用具有适当冗余和容错级别的存储。HACMP 不具有对存储可用性的任何控制。
对于数据保护，可以使用 RAID 技术（在存储或适配器级别）或 AIX LVM 镜像。
独立磁盘冗余阵列（Redundant Array of Independent Disk，RAID）
磁盘阵列是磁盘驱动器组，这些驱动器协同工作以实现高于单个（独立）驱动器的数据传输速率。阵列还可以提供数据冗余，以便在阵列中的一个驱动器（物理磁盘）发生故障时，数据不会丢失。取决于 RAID 级别，数据将实现镜像或条带化，或者同时实现这两者。
有关一些广泛使用的 RAID 级别的特征，请参见表 2。
RAID 0
RAID 0 也称为数据条带化 (data striping)。传统上，文件按顺序写入到单个磁盘。使用条带化，信息将划分为字节块（固定容量的数据，通常称为“块”），并将这些块并行写到一系列磁盘（或从一系列磁盘并行读取这些块）。这种方法具有两个性能优点：

  • 由于多个 I/O 流同时进行，数据传输速率比顺序操作更高。
  • 由于数据的分布性消除了访问模式偏差，随机访问吞吐量得到了提高。这意味着，对于跨许多磁盘均匀分布的数据，随机访问很可能会发现所需的信息跨多个磁盘分布，从而得益于比单个磁盘更高的吞吐量。

RAID 0 的唯一目的是提高性能。不存在冗余，因此任何磁盘故障都需要从备份中重新加载数据。
RAID 1
RAID 1 也称为数据镜像。在这种实现中，每个数据块的相同副本保存在单独的磁盘上，或在更常见的情况下，每个磁盘具有包含信息的准确副本（或镜像映像）的“孪生磁盘”。如果阵列中的任何磁盘发生故障，则镜像磁盘将维持数据可用性。读取性能可以增强，因为始终使用其动臂机构（磁头）最靠近所需数据的磁盘，从而最小化寻道时间。
写入操作的响应时间会比单个磁盘稍慢一点，具体取决于写入策略；写入操作可以并行（为了实现更快的响应）或顺序（为了实现安全性）执行。
RAID Level 1 具有数据冗余，但是应该定期保存数据（备份）。这是在文件或目录被意外破坏或删除时用于恢复数据的唯一途径。
RAID 2 和 RAID 3
固定容量的数据），每个块被写到单独的磁盘上的相同物理位置（并行）。在进行读取时，可以同时向每个磁盘发送数据请求。这种体系结构要求为每个数据条带写入奇偶校验信息；RAID 2 和 RAID 3 之间的区别在于，RAID 2 可以利用多个磁盘驱动器实现奇偶校验，而 RAID 3 只能利用一个磁盘驱动器。如果某个驱动器发生故障，系统可以在奇偶校验信息和其余驱动器的基础上重新构造丢失的数据。针对大容量数据的性能非常优异，但是小容量数据请求的性能非常糟糕，因为始终要涉及到每个驱动器，并且不能存在重叠或独立的操作。
RAID 4
RAID 4 通过使用更大的数据块，并跨所有驱动器（保留用于奇偶校验的驱动器除外）对数据进行条带化，从而解决了 RAID 3 的某些缺点。使用磁盘条带化意味着 I/O 请求只需涉及到所需数据实际所在的驱动器。这意味着可以实现同时以及独立的读取。但是，写入请求需要一个读取/修改/更新周期，从而在单个奇偶校验驱动器上导致瓶颈。
必须读取每个条带，插入新数据，然后在将条带写回磁盘之前计算新的奇偶校验信息。然后再使用新的奇偶校验信息更新奇偶校验磁盘，但是在完成此操作之前，不能将该磁盘用于其他写入操作。这个瓶颈意味着，RAID 4 使用得不如 RAID 5 那么多，后者实现了相同的过程，但是没有瓶颈。
RAID 5
RAID 5 非常类似于 RAID 4。区别在于，奇偶校验信息也跨用于数据的相同磁盘分布，从而消除了该瓶颈。奇偶校验数据决不会与它所保护的数据块存储在相同的驱动器上。这意味着，现在可以执行并发读取和写入操作，并且由于可以使用一个额外的磁盘（以前用于奇偶校验信息的磁盘），性能也提高了。还存在其他可能的增强，以进一步提高数据传输速率，例如缓存从磁盘进行的同时读取，并在读取接下来的块时传输该信息。这可以实现接近适配器速度的数据传输速率。
与 RAID 3 一样，在磁盘发生故障的情况下，可以在其余驱动器的基础上重新构建信息。RAID 5 阵列也使用奇偶校验信息，虽然创建阵列中的数据的定期备份仍然非常重要。RAID 5 阵列一次一个段（一个段可以包含多个块）地跨阵列中的所有驱动器对数据进行条带化。在具有 n 个驱动器的阵列中，一个条带包括写到其中“n-1”个驱动器的数据段和一个写到“第 n 个”驱动器的奇偶校验段。这种机制还意味着，并非所有磁盘空间都可用于存储数据。例如，在具有五个 72 GB 磁盘的阵列中，尽管总存储空间为 360 GB，但是只有 288 GB 可用于存储数据。
RAID 0+1 (RAID 10)
RAID 0+1 也称为 IBM RAID-1 Enhanced 或 RAID 10，是 RAID 0（数据条带化）和 RAID 1（数据镜像）的组合。RAID 10 提供了 RAID 0 的性能优点，同时保持了 RAID 1 的数据可用性。在 RAID 10 配置中，数据及其镜像都跨阵列中的所有磁盘进行条带化。第一个条带是数据条带，第二个条带是镜像，镜像与数据放在不同的物理驱动器上。RAID 10 实现可以提供优异的写入性能，因为它们不必计算或写入奇偶校验数据。RAID 10 可以通过软件 (AIX LVM)、硬件（存储子系统级别）或通过硬件和软件的组合来实现。具体的实现解决方案取决于总体需求。RAID 10 的成本特征与 RAID 1 相同。
表 2 列出了当今的 IT 实现中使用的最常见 RAID 级别。
表 2 广泛使用的 RAID 级别的特征

RAID 级别 | 可用磁盘容量 | 读取/写入操作性能 | 成本 | 数据保护
RAID 0 | 100% | 读取/写入性能都非常高 | 低 | 否
RAID 1 | 50% | 中/高读取性能，中等写入性能 | 高 | 是
RAID 5 | 80% | 高读取性能 中等写入性能 | 中 | 是
RAID 10 | 50% | 读取/写入性能都非常高 | 高 | 是

光纤连接存储服务器 (FAStT)
存在不同型号的 FAStT 存储可用并在 HACMP 中受支持。
介绍所有型号的 FAStT 超出了本红皮书的范围。为了解如何配置 FAStT 存储，我们将提供 FAStT900 存储服务器的示例。
FAStT900 存储服务器
FAStT900 存储服务器最多支持四个主机的直接连接（每个主机包含两个主机适配器），并旨在提供最大限度的主机端和驱动器端冗余。通过将外部光纤通道交换机与 FAStT900 存储服务器结合使用，最多可以将 64 个主机（每个主机都具有两个主机总线适配器）连接到一个 FAStT900 存储服务器。
在配置 FAStT 存储之前，必须确保按照所需的配置完成所有硬件和电缆连接。有关 FAStT 电缆连接的更多信息，请参见 IBM TotalStorage FAStT900 Fibre Channel Storage Server Installation Guide, GC26-7530。
FAStT Storage Manager 软件
配置 FAStT 存储的唯一途径是使用 FAStT Storage Manager 软件。大多数流行的操作系统都提供了 FAStT Storage Manager 软件，例如 AIX、Linux 和 Windows? XP/2000。使用 FAStT Storage Manager，您可以配置受支持的 RAID 级别、逻辑驱动器和分区。受支持的 RAID 级别为 RAID 0、RAID 1、RAID 5 和 RAID 0+1。
FAStT Storage Manager 中不存在配置 RAID 10 的选项。选择带多个磁盘的 RAID 1，FAStT Manager 将负责处理数据的条带化和镜像。
它允许用户根据操作系统的需要格式化逻辑驱动器。存在不同的 Storage Manager 版本。Storage Manager V8.4 是 FAStT900 支持的 Storage Manager 版本，相比于早期版本，此版本具有一些较新的功能。
带 Storage Manager V8.4 的 FAStT900 支持的一些新功能包括：

  • FlashCopy。

FlashCopy 逻辑驱动器是存储子系统中的另一个逻辑驱动器（称为基本逻辑驱动器）的时间点映像。FlashCopy 是完整的物理副本的逻辑等效副本，但是可以更快地创建，并且只需较少的磁盘空间（原始逻辑驱动器的 20%）。

  • 远程镜像选项

远程镜像选项用于实现存储子系统之间远距离的在线、实时复制。

  • Volumecopy

volumecopy 选项是一种基于固件的机制，用于复制存储阵列中的逻辑驱动器数据。用户通过指定两个兼容驱动器来提交 volumecopy 请求。一个驱动器指定为源，另一个指定为目标。volumecopy 请求是持久性的，以便能够将该复制过程的任何相关结果传达给用户。

  • 存储分区

存储分区允许用户通过将存储卷映射到某个 LUN 编号，每个分区提供 0-255 的 LUN，从而通过多个不同的分区将所有存储卷提供给 SAN。这种卷或 LUN 映射仅适用于已配置为访问该 LUN 的主机端口。此功能还允许将使用不同操作系统及其各自的唯一磁盘存储子系统设置的主机同时连接到同一个 FAStT 存储服务器。
有关 Storage Manager V8.4 安装和配置的更多信息，请参阅 IBM TotalStorage FAStT Storage Manager 8.4 Installation and Support Guide for Intel-based Operating Environments, GC26-7589。

企业存储服务器 (ESS/Shark)
IBM 企业存储服务器 (ESS) 是一种第二代 Seascape 磁盘存储系统，并提供了领先的可用性、性能、可管理性和可伸缩性。ESS 中的 RAID 级别在某些配置中是预定义的，只有非常有限的修改余地。可用的 RAID 级别是 RAID 1、RAID 5 和 RAID 0+1。
IBM 企业存储服务器 (ESS) 不仅仅是实现跨企业平台的共享存储；它还可以通过各种各样的强大功能，从而提高了企业范围的存储资源的性能、可用性、可伸缩性和可管理性。其中部分功能在名称上与 FAStT 存储中可用的功能的名称相同，但是其技术概念在很大程度上是不同的。其中部分功能包括：

  • FlashCopy

FlashCopy 提供快速的数据复制功能。此选项帮助消除对长时间停止应用程序以执行备份和还原的需要。

  • 点对点远程复制

此功能在远程位置维护数据的同步副本（始终保持与主副本一样的最新状态）此数据备份副本可用于从主系统的故障中快速恢复而不丢失任何事务；这是一个可选功能，完全可以保持电子商务应用程序的正常运行。

  • 扩展远程副本 (XRC)

此功能在远程位置（可使用电信线路从无限距离的位置连接到该位置）提供一个数据副本，在主存储系统发生故障的情况下将使用该副本。ESS 通过对计划外停机的完全支持来增强了 XRC。在电信链路发生故障的情况下，这个可选功能允许快速重新同步辅助远程副本，而不需要从主位置复制所有数据来实现灾难恢复保护。

  • 自定义卷

自定义卷允许为高端服务器定义各种大小的卷，从而使管理员可以配置系统以实现最佳性能。

  • 存储分区

存储分区通过为每个服务器提供对自己的存储容量池的访问，从而更高效地利用存储设备。存储池可以在多个服务器之间共享。
有关企业存储服务器配置的更多信息，请参阅 IBM TotalStorage Enterprise Storage Server Service Guide 2105 Model 750/800 and Expansion Enclosure, Volume 1, SY27-7635。
串行存储体系结构（Serial Storage Architecture，SSA）
串行存储体系结构是一种行业标准接口，用于提供 I/O 存储设备的高性能容错连接。在 SSA 子系统中，到多个目的地的传输是多路的；各个链路的空间重用进一步增加了有效带宽。命令沿着环路从一个设备自动转发到另一个设备，直到到达目标设备。多个命令可以同时绕着环路传输。
SSA 支持 RAID 0、RAID 1、RAID 5 和 RAID 0+1。要使用任何 RAID 设置，必须遵循 SSA 机箱的回路连接说明。
需要在整个磁盘中进行特定的环路连接才能创建 RAID。有关 IBM SSA RAID 配置的更多信息，请参阅 IBM Advanced SerialRAID Adapters Installation Guide, SA33-3287。

共享 LVM
对于 HACMP 集群，关键要素是高度可用的应用程序所使用的数据。此数据存储在 AIX 逻辑卷管理器（Logical Volume Manager，LVM）实体上。
HACMP 集群使用 LVM 的功能来使多个节点可访问该数据。AIX 逻辑卷管理器提供从多个节点进行的共享数据访问。共享逻辑卷管理器的部分组件包括：

  • 共享卷组是完全驻留在由集群节点共享的外部磁盘上的卷组。
  • 共享物理卷是驻留在共享卷组中的磁盘。
  • 共享逻辑卷是完全驻留在共享卷组中的逻辑卷。
  • 共享文件系统是完全驻留在共享逻辑卷中的文件系统。

如果您是某个 HACMP 集群的系统管理员，可能会要求您执行下面许多与 LVM 相关的任务：

  • 创建新的共享卷组。
  • 扩展、缩小、更改或删除现有的卷组。
  • 创建新的共享逻辑卷。
  • 扩展、缩小、更改或删除现有的逻辑卷。
  • 创建新的共享文件系统。
  • 扩展、更改或删除现有的文件系统。
  • 添加和删除物理卷。

在共享 LVM 组件上执行任何维护任务时，应确保在导出然后重新导入卷组时重置所有权和权限。
在导出和导入后，卷组由 root 拥有，并且可由系统组访问。
注意：如果更改了原始逻辑卷设备的所有权，使用原始逻辑卷的应用程序可能会受到此更改的影响，例如某些数据库服务器。必须在此操作序列之后将所有权和权限恢复为所需的所有权和权限。
可以通过以下任何数据访问模式使共享逻辑卷访问变得可用：
非并发访问模式
并发访问模式
增强并发访问模式

非并发访问模式
非并发访问环境中的 HACMP 通常使用日记记录文件系统来管理数据，尽管有些数据库应用程序可能绕过日记记录文件系统并直接访问逻辑卷。
LVM 的非并发访问同时支持镜像和非镜像配置。有关创建镜像和非镜像逻辑卷的更多信息，请参阅 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02。
要在节点上创建非并发共享卷组，可以执行以下步骤：
1. 使用快速路径 smitty mkvg。
2. 除非站点有其他特定要求，否则请使用缺省字段值。

  • VOLUME GROUP name

共享卷组的名称应该在集群中是唯一的。

  • Activate volume group AUTOMATICALLY at system restart?

设置为 No，以便由集群事件脚本根据情况激活该卷组。

  • ACTIVATE volume group after it is created?

设置为 Yes。

  • Volume Group MAJOR NUMBER

确保在所有节点上使用相同的主编号。在每个节点上使用 lvlstmajor 命令来确定所有节点共有的未使用主编号。
要在节点上创建非并发共享文件系统，可以执行以下步骤：

AIX 为其创建的每个逻辑卷分配一个逻辑卷名称。
逻辑卷名称的示例为 /dev/lv00 和 /dev/lv01。在 HACMP 集群中，任何共享逻辑卷的名称必须是唯一的。此外，日记记录文件系统日志 (jfslog) 也是需要在集群中具有唯一名称的逻辑卷。
3. 检查以下字段的设置：

  • Mount automatically at system restart?

确保将此字段设置为 No。

  • Start Disk Accounting

除非希望进行磁盘记帐，否则请将此字段设置为 No。
4. 通过挂载和卸载新创建的文件系统来对其进行测试。

将卷组导入故障转移节点
在导入卷组之前，请确保从主节点 Varyoff 该卷组。然后可以运行 HACMP 的发现过程（discovery process），此过程将收集有关跨所有节点可用的所有卷组的信息。
将卷组导入故障转移节点将会同步该卷组在每个所导入节点上的 ODM 定义。
在将卷组添加到资源组时，可以选择手动将卷组导入故障转移节点，或者可以选择自动将其导入资源组中的所有故障转移节点。

注意：在故障转移节点上导入卷组以后，必须更改卷组的启动状态。根据 HACMP 的要求，使用以下命令来更改卷组状态：
# chvg -an -Qn <vgname>
此命令将禁用系统重新启动时的自动 Varyon，同时还禁用该卷组的定额。

并发访问模式
将并发访问与 HACMP 一起使用需要安装附加的文件集。有关更多信息，请参见系列的第 2 部分“规划和设计”。
文件系统不支持并发访问模式；相反，您必须使用原始逻辑卷或物理磁盘。

创建并发访问卷组
1. 物理卷 (hdisk*) 应该已安装、配置并且可用。
可以使用以下命令验证磁盘的状态：

# lsdev -Cc disk

2. 要使用并发访问卷组，必须将其创建为支持并发的卷组。支持并发的卷组可以在非并发模式或并发访问模式下激活（启用）。
要创建并发访问卷组，可以执行以下步骤：
a. 输入 smit cl_convg。
b. 选择 Create a Concurrent Volume Group。
c. 根据需要输入字段值。
d. 按 Enter 键。

导入支持并发的卷组
通过运行以下命令来导入支持并发的卷组：

# importvg -C -y vg_name physical_volume_name

将卷组中的任何磁盘的名称指定为 importvg 命令的参数。缺省情况下，AIX 在导入非支持并发的卷组时自动 Varyon 这些卷组。AIX 在导入支持并发的卷组时不自动 Varyon 这些卷组。

以非并发模式 Varyon 支持并发的 VG
必须以非并发模式 Varyon 支持并发的卷组才能创建逻辑卷。使用 varyonvg 命令以非并发模式激活卷组：

# varyonvg <vgname>

在支持并发的卷组上创建逻辑卷
可以在卷组上创建逻辑卷，并指定逻辑卷镜像以提供数据冗余。
要在源节点上在支持并发的卷组上创建逻辑卷，可以执行以下步骤：
1. 使用 SMIT 快速路径 smit cl_conlv。
2. 以逻辑分区数量的形式指定逻辑卷大小。
3. 为其他可用选项指定所需的值。
4. 按 Enter 键。

Varyoff 卷组
在创建逻辑卷以后，使用 varyoffvg 来 Varyoff 该卷组，以便 HACMP 脚本能够启用该卷组。输入：

# varyoffvg <vgname>

在 HACMP 资源组中定义一个并发卷组
要在所有节点上同时启动该并发卷组，可以在 HACMP 的启动脚本中指定卷组名称。
在集群启动时，可以发现该并发卷组在所有已配置的节点上被激活。

增强并发模式 (ECM) VG
使用 HACMP V5.1，现在能够创建和使用增强并发 VG。这些卷组可同时用于并发和非并发访问。还可以使用 C-SPOC 将现有的并发（传统）卷组转换为增强并发模式。
对于在非并发环境中使用的增强并发卷组，与使用 SCSI 保留机制不同，HACMP V5.1 使用快速磁盘接管机制来确保快速接管和数据完整性。
注意：HACMP V5.1 中的快速磁盘接管仅在 AIX 5L V5.2 中可用。
ECM 卷组在集群中属于该资源组的所有节点上 Varyon 。但是，只有已激活该资源组（在线）的节点才被授权进行用于修改数据的访问。

增强并发卷组能够以两种模式在节点上变为活动或 Varyon 状态：主动或被动。
主动 Varyon
在主动状态下，允许进行所有高级操作。当在节点上以主动状态启用某个增强并发卷组时，该卷组允许执行以下操作：

  • 文件系统操作，例如文件系统挂载
  • 应用程序操作
  • 逻辑卷操作，例如创建逻辑卷
  • 同步卷组

被动 Varyon
当以被动状态启用某个增强并发卷组时，LVM 在 LVM 级别为该卷组提供等效的 Fencing。
以被动模式启用该 VG 的节点只允许在该卷组上执行有限数量的只读操作。

  • 对该卷组的特殊文件的 LVM 只读访问
  • 对该卷组拥有的所有逻辑卷的前 4KB 的 LVM 只读访问

当以被动模式启用某个卷组时，不允许执行下列操作：

  • 文件系统操作，例如装入
  • 逻辑卷上的任何打开或写入操作
  • 同步卷组

创建增强并发访问卷组
1. 在 AIX 5L 5.1 及更高版本上创建并发卷组时，将会自动以增强并发模式创建这些卷组。
2. 要从 AIX 命令行创建支持并发的卷组，可以使用 mkvg 命令。例如：

# mkvg -n -s 32 -C -y myvg hdisk11 hdisk12

将在 hdisk11 和 hdisk12 上创建一个增强并发 VG。其中的标志指定以下特征：
-n 不要在启动时启用该 VG。
-s 32 指定 32 MB 的分区大小。
-C 创建一个增强并发 VG。
-y 指定 VG 名称。

快速磁盘接管
这是 HACMP V5.1 的一个新功能，并具有下列主要用途：

  • 减少应用程序停机时间，实现更快的资源组故障转移（和移动）
  • 对卷组的并发访问（保护数据完整性）
  • 使用 AIX 增强并发 VG (ECM)
  • 使用 RSCT 进行通信

增强并发卷组支持主动和被动模式的 Varyon，并且可以包括在非并发资源组中。
快速磁盘接管由 HACMP 软件自动进行设置。对于以增强并发模式创建并包含文件系统的所有共享卷组，HACMP 将激活快速磁盘接管功能。当 HACMP 启动时，资源组中共享同一个增强并发卷组的所有节点将以被动模式 Varyon 该卷组。当将该资源组置于在线时，获取资源的节点将以主动模式 Varyon 该卷组。
其他节点将维持该卷组的被动模式启用状态。在此情况下，对该卷组的所有更改都将自动传播到该卷组中的所有节点。在集群启动、资源组激活和故障转移以及在故障节点重新加入集群时，从主动到被动模式的改变以及反向改变由 HACMP 进行协调。
此功能的先决条件包括：

  • HACMP V5.1
  • AIX 5L 5.2 或更高版本
  • bos.clvm.5.2.0.11 或更高版本
  • APAR IY44237
有关快速磁盘接管的更多信息，请参见 HACMP for AIX 5L V5.1 Planning and Installation Guide, SC23-4861-02。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-3/1.html

Top


HACMP 认证学习系列，第 3 部分：安装和配置（2）

HACMP V5.x 标准和扩展配置
HACMP V5.1 引入了标准和扩展 SMIT 配置路径。
标准配置路径
标准路径允许用户容易地配置最常见的选项，例如：

  • 通过别名的 IPAT 网络
  • 共享的服务 IP 标签
  • 卷组和文件系统
  • 应用程序服务器

在使用 Initialization and Standard Configuration SMIT 菜单下的选项时，可以通过几个步骤将集群的基本组件添加到 HACMP 配置。HACMP 配置是自动发现的，并用于为集群定义最常见的选项（请参见示例 1 和示例 2）。
示例 1 HACMP for AIX

HACMP for AIX
Move cursor to desired item and press Enter.

Initialization and Standard Configuration
Extended Configuration
System Management (C-SPOC)
Problem Determination Tools

F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=Exit Enter=Do

示例 2 Initialization and Standard Configuration

Initialization and Standard Configuration
Move cursor to desired item and press Enter.
Add Nodes to an HACMP Cluster
Configure Resources to Make Highly Available
Configure HACMP Resource Groups
Verify and Synchronize HACMP Configuration
Display HACMP Configuration

F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=Exit Enter=Do

使用标准路径的先决任务
要使用标准配置路径，必须在所有节点上安装 HACMP V5.1，并且执行配置的节点与将要包括在集群中的所有其他节点之间必须存在连接。
必须物理（VLAN 和交换机）和逻辑地（子网）在每个节点上至少配置一个网络接口，以便您能从一个节点成功地与其它每个节点通信。
一旦完成对所有磁盘、通信设备、串行网络的配置和启动了它们，并在 AIX 中配置了到其他节点的通信路径，HACMP 就会自动收集有关物理和逻辑配置的信息，并在对应的 SMIT 选择列表中显示该信息，以帮助您完成 HACMP 配置过程。
建立连接路径以后，HACMP 就可以发现集群信息，并且您能够访问所有的所需节点，以执行任何必要的 AIX 管理任务。您不需要打开附加的窗口，或者物理地移动到其他节点的控制台并手动地登录每个节点。到远程节点上的相关 HACMP 和/或 AIX SMIT 屏幕的 SMIT 快速路径在 HACMP SMIT 屏幕中都是可用的。

标准路径的假设和缺省设置
该软件做出一些关于环境的假设，例如假设某个物理网络上的所有网络接口都属于同一个 HACMP 网络。已提供或自动配置了智能和/或缺省参数。这有助于最小化配置集群所需要的步骤数量。
基本假设包括：

  • 将主机名称（由 hostname 命令的输出结果确定）用作节点名称。自动在 HACMP 中配置能够彼此看到对方的 MAC 地址的所有网络接口。不通过路由器即可彼此 ping 到对方的网络接口放在同一个逻辑网络上。HACMP 对每个逻辑网络进行命名。
  • IP 别名用作向网络接口分配服务 IP 标签/地址的缺省机制。
  • 为能够作为别名接管某个服务 IP 标签的任何逻辑网络配置了通过 IP 别名的 IP 地址接管。

注意：要配置通过 IP 替换的 IP 地址接管机制，必须使用扩展配置路径来更改 HACMP 网络属性（关闭 IP 别名）。

  • 可以为资源组配置基本的预定义管理策略（故障转移和退回首选项：级联、循环或并发）或新的自定义资源组。

添加、更改或删除串行（非 IP）网络和设备是通过扩展路径完成的，因为您必须手动为每个点对点网络定义所需的通信设备（端点）。
有关进一步的配置，或者要向集群配置添加更多详细信息或自定义，可以使用 HACMP 扩展配置 SMIT 路径。有关进一步的参考信息，请参见“扩展配置路径”。
注意：在使用标准 HACMP 配置 SMIT 路径时，如果配置所需的任何信息驻留在远程节点上，则会自动执行集群信息的发现操作。

使用标准路径来配置集群的步骤
1. 配置集群拓扑
确定集群节点，并使用 Configure Nodes to an HACMP Cluster 菜单选项建立节点之间的通信路径。您将在这里命名集群，并按名称或按 IP 地址选择节点（在 /etc/hosts 中列出）。这将为 HACMP 提供与参与该集群的节点通信所需要的基本信息。
在正确确定每个节点并存在通信路径之后，HACMP 自动运行发现操作，此操作将确定集群中的基本组件。
所发现的主机名称将用作节点名称，并添加到 HACMP 节点 ODM。与集群中的两个或更多个节点共享物理连接的网络（以及关联的接口）自动被添加到 HACMP 网络和 HACMP 适配器 ODM。发现的其他共享资源信息包括 PVID，以及卷组（请参见示例 3）。
示例 3 配置集群中的节点（标准）

Configure Nodes to an HACMP Cluster (standard)
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Cluster Name [cluster5x]
New Nodes (via selected communication paths) [] +
Currently Configured Node(s) p630n01 p630n02 p630n>

F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
9=Shell F10=Exit Enter=Do

2. 配置集群资源。
配置要使其高度可用的资源。使用 Configure Resources to make Highly Available 菜单来配置要在集群中的节点之间共享的资源（请参见示例 4）。
可以配置下列资源：

  • IP 地址/标签
  • 应用程序服务器
  • 卷组（共享和并发）
  • 逻辑卷
  • 文件系统

示例 4 配置要实现高可用性的资源

Configure Resources to Make Highly Available
Move cursor to desired item and press Enter.
Configure Service IP Labels/Addresses
Configure Application Servers
Configure Volume Groups, Logical Volumes and Filesystems
Configure Concurrent Volume Groups and Logical Volumes
F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=Exit Enter=Do

3. 配置资源组。
使用 Configure HACMP Resource Groups 菜单来创建为每个相关或依赖资源集计划的资源组。
可以选择配置级联、循环、并发或自定义资源组（请注意，不能在标准菜单中为自定义资源组指定退回计时器策略）（请参见示例 5）。
示例 5 配置 HACMP 资源组（标准）

Configure HACMP Resource Groups
Move cursor to desired item and press Enter.
Add a Resource Group
Change/Show a Resource Group
Remove a Resource Group
Change/Show Resources for a Resource Group (standard)
F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=Exit Enter=Do

4. 将要管理的资源一起分组到前面定义的资源组中。
选择 Configure HACMP Resource Groups → Change/Show Resources for a Resource Group 以将资源分配到每个资源组（请参见示例 6）。
示例 6 更改/显示级联资源组的资源（标准）

Change/Show Resources for a Cascading Resource Group
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Resource Group Name rg01
Participating Node Names (Default Node Priority) p630n01 p630n02 p630n>
* Service IP Labels/Addresses [n01a1] +
Volume Groups [] +
Filesystems (empty is ALL for VGs specified) [] +
Application Servers [] +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

5. 调整日志查看和管理（可选）。
（可选）调整日志查看和管理（针对每个节点的调试级别和 hacmp.out 日志文件格式选项的设置）。
6. 验证和同步集群配置。
使用 Verify and Synchronize HACMP Configuration 菜单来保证所需的配置在给定的物理连接和设备下切实可行，并确保集群中的所有节点具有相同的配置视图（请参见示例 7）。
示例 7 集群的验证和同步

Command:running stdout:yes stderr:no
Before command completion, additional instructions may appear below.
Verification to be performed on the following:
Cluster Topology
Cluster Resources
Retreiving data from available cluster nodes.This could take a few minutes...
Verifying Cluster Topology...

7. 显示集群配置（可选）。请参见示例 8。检查集群拓扑和资源配置。
示例 8 显示 HACMP 信息

Command:OK stdout:yes stderr:no
Before command completion, additional instructions may appear below.
Cluster Description of Cluster:cluster5x
Cluster Security Level:Standard
There are 6 node(s) and 2 network(s) defined
NODE p630n01:
Network net_ether_01
gp01 10.1.1.1
Network net_ether_02
n06a1 192.168.11.136
n05a1 192.168.11.135
n04a1 192.168.11.134
n02a1 192.168.11.132
n01a1 192.168.11.131
F1=Help F2=Refresh F3=Cancel F6=Command
F8=Image F9=Shell F10=Exit /=Find
n=Find Next

8. 对集群配置进行进一步的添加或调整（可选）。
您可能希望使用 HACMP 扩展配置路径上可用的一些选项。此类添加或调整包括（举例而言）：

  • 添加用于心跳检测的非 IP 网络
  • 添加其他资源，例如 SNA 通信接口和链路或磁带资源
  • 配置资源组运行时策略，包括工作负载管理器 (Workload Manager)
  • 添加自定义资源组定时器
  • 配置集群安全性
  • 自定义集群事件
  • 配置站点策略

扩展配置路径
扩展配置路径允许用户对配置进行精细控制：

  • 配置发现是可选的。
  • 节点名称不需要与主机名称匹配。
  • 可以根据特定用户的环境配置 IP 网络拓扑。

使用 Extended Configuration 菜单下面的选项，您可以将集群的基本组件添加到 HACMP 配置数据库 (ODM)，以及添加所有其他类型的资源。
使用扩展路径来配置集群的步骤
1. 运行发现操作（可选）
如果已经配置了部分或全部集群组件，则运行发现操作。运行发现操作将从所有集群节点检索当前的 AIX 配置信息。此信息显示在选择列表中，以帮助您精确选择现有的组件。所发现的组件突出显示为预定义组件，并且可供选择（请参见示例 9）。
示例 9 发现其他节点中的信息（扩展）

Command:OK stdout:yes stderr:no
Before command completion, additional instructions may appear below.

[TOP]
Discovering IP Network Connectivity

Retreiving data from available cluster nodes.This could take a few minutes...
Discovered [24] interfaces
IP Network Discovery completed normally
Discovering Volume Group Configuration clharvest_vg:Initializing....
Gathering cluster information, which may take a few minutes...
clharvest_vg:Processing...
Storing the following information in file
/usr/es/sbin/cluster/etc/config/clvg_config

p630n01:

Hdisk:hdisk0
PVID: 0006856f612dab6e
VGname: rootvg
VGmajor: active
[MORE...1761]
F1=Help F2=Refresh F3=Cancel F6=Command
F8=Image F9=Shell F10=Exit /=Find
n=Find Next

2. 配置、更改或自定义集群拓扑。
在 Extended Topology Configuration 菜单下，您可以：
确定节点，并使用 Configure Nodes to an HACMP Cluster 菜单建立节点之间的通信路径。在此情况下，您将命名集群，并按名称或按 IP 地址选择节点（在 /etc/hosts 中列出）。这将为 HACMP 提供所需的信息以便与参与该集群的节点通信。
您还可以：
– 选择 PVID 和现有的卷组。
– 配置、更改或显示站点（可选）。
– 配置、更改或显示预定义或发现的基于 IP 的网络，以及预定义或发现的串行设备。
– 配置、更改、显示并使用 AIX 设置来更新 HACMP 通信接口和设备。
– 配置以前定义的或以前发现的通信接口和设备。
– 配置、更改和显示持久节点 IP 标签。
有关更多详细信息，请参见示例 10。
示例 10 扩展拓扑配置

Extended Topology Configuration
Move cursor to desired item and press Enter.
Configure an HACMP Cluster
Configure HACMP Nodes
Configure HACMP Sites
Configure HACMP Networks
Configure HACMP Communication Interfaces/Devices
Configure HACMP Persistent Node IP Label/Addresses
Configure HACMP Global Networks
Configure HACMP Network Modules
Configure Topology Services and Group Services
Show HACMP Topology
F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=ExitEnter=Do

3. 配置或自定义要使其高度可用的资源。
使用 Configure Resources to Make Highly Available 菜单来配置要在集群中的节点之间共享的资源，以便在一个组件发生故障的情况下，另一个组件将自动取代其位置（请参见示例 11）。您可以配置下列资源：

  • 服务 IP 地址/标签
  • 应用程序服务器
  • 卷组
  • 并发卷组
  • 逻辑卷
  • 文件系统
  • 应用程序监视
  • 磁带资源
  • 操作系统的通信适配器和链路
  • HACMP 通信接口和链路
  • 自定义磁盘方法

示例 11 扩展资源配置

Extended Resource Configuration
Move cursor to desired item and press Enter.
HACMP Extended Resources Configuration
Configure Resource Group Run-Time Policies
HACMP Extended Resource Group Configuration
F1=Help F2=Refresh F3=Cancel F8=Image
F9=Shell F10=Exit Enter=Do

4. 配置资源组。
可以选择配置自定义、级联、并发或循环资源组。使用“扩展”路径，您还可以配置资源组运行时策略，自定义级联资源组的故障转移/退回行为，以及定义自定义资源组策略和参数。
5. 分配将要与资源组一起进行管理的资源。
将相关或相依赖的资源放到资源组中。
6. 对集群配置做出任何进一步的添加或调整。
– 配置集群安全性。
– 自定义集群事件。
– 配置性能优化。
– 更改节点、通信接口和设备、网络、资源或资源组的属性。
7. 验证和同步集群配置。
使用 Verify and Synchronize HACMP Configuration 菜单来保证所需的配置在给定的物理连接和设备下切实可行，并确保集群中的所有节点具有相同的配置视图。
8. 显示集群配置（可选）。
查看集群拓扑和资源配置。

定义集群拓扑
下面将定义集群拓扑。
标准拓扑配置
完成以下过程来定义集群拓扑。您只需在一个节点上执行这些步骤。在验证和同步集群拓扑时，其定义将被复制到所有其他节点。
1. 输入 smitty hacmp。
2. 选择 Initialization and Standard Configuration → Configure Nodes to an HACMP Cluster 并按 Enter 键。
3. 在 Configure Nodes to an HACMP Cluster 屏幕中，按如下方式输入值：
– Cluster name
输入标识该集群的 ASCII 文本字符串。集群名称可以包括字母和数字字符以及下划线，但是不能具有前导的数字。请使用不超过 31 个字符长度的名称。集群名称可以与主机名称不同。请不要使用保留名称。
– New nodes via selected communication paths
为集群中的每个新节点输入或添加可解析的 IP 标签（可以是主机名称）、IP 地址或全域名（Fully Qualified Domain Name），各项值之间用空格分隔。将采用此路径来发起与该节点的通信。请按 F4 可以查看 /etc/hosts 中还未在 HACMP 中配置的主机名称和/或地址的挑选列表屏幕（请参见图 1）。

图 1 将节点配置到 HACMP 集群（标准）

Currently configured node(s)

如果已经配置了节点，则会将它们显示在此处。您可以按任何顺序添加节点名称或 IP 地址。
4. 按 Enter 键。HACMP 软件将使用此信息来为 ODM 创建集群通信路径。一旦建立了通信路径，HACMP 就运行发现操作并将结果打印到 SMIT 屏幕。

5. 验证结果对您的集群是否适当。

扩展拓扑配置
在开始通过扩展拓扑配置进行 HACMP 配置之前，建议通过 Discover HACMP Related information from Configured Nodes 菜单收集 HACMP 信息（请参见示例 9）。
完成以下过程来定义集群拓扑。您只需在一个节点上执行这些步骤。在验证和同步集群拓扑时，其定义将被复制到其他节点。
扩展拓扑配置屏幕包括：

  • 配置 HACMP 集群
  • 配置 HACMP 节点
  • 配置 HACMP 站点
  • 配置 HACMP 网络
  • 配置通信接口
  • 配置通信设备
  • 配置 HACMP 持久 IP 标签
  • 配置 HACMP 网络模块

配置 HACMP 集群
配置集群所需的唯一步骤是分配集群名称。
请执行以下步骤：
1. 输入 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure an HACMP Cluster。
5. 选择 Add/Change/Show an HACMP Cluster 并按 Enter 键。
6. 输入下面的值：
– Cluster name
输入标识该集群的 ASCII 文本字符串。集群名称可以包括字母和数字字符以及下划线，但是不能具有前导的数字。请使用不超过 31 个字符长度的名称。
节点名称可以与主机名称不同。请不要使用保留名称。有关保留名称的列表，请参见位于 HACMP for AIX 5L V5.1 Administration and Troubleshooting Guide, SC24862-00 的第 6 章“Verifying and Synchronizing a Cluster Configuration”中的“HACMP List of Reserved Words”。
7. 按 Enter 键。
8. 按 F3，直到返回到 Extended Topology SMIT 屏幕。

定义节点
使用标准路径来定义节点不是一个可用的选项。HACMP 自动使用所发现的 IP 网络的主机名称作为节点名称。
如果希望手动定义节点，则需要使用 HACMP 的扩展 SMIT 路径。
要使用扩展路径定义集群节点，请执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Nodes。
5. 选择 Add a Node to the HACMP Cluster 并按 Enter 键。
6. 按如下方式输入字段值：

  • Node name

为集群中的每个新节点输入（或添加）一个最多 31 个字符的可解析 IP 标签（可以是主机名称）、IP 地址或全域名（Fully Qualified Domain Name），各项值之间用空格分隔。将采用此路径来发起与该节点的通信。请按 F4 可以查看 /etc/hosts 中还不是 HACMP 配置的 IP 标签/地址的内容的挑选列表屏幕。

  • Communication path to node

如果已经配置了节点，则会将它们显示在此处。
HACMP 软件使用此信息来为 ODM 创建集群通信路径。在建立通信路径以后，HACMP 将更新集群通信守护进程的身份验证信息。

定义站点
站点定义是可选的。提供站点定义是为了更容易与 HAGEO 产品集成。如果定义要在 HAGEO 之外使用的站点，则必须提供适当的方法或自定义来处理站点操作。如果定义了站点，站点事件将在 node_up 和 node_down 事件期间运行。
要向 HACMP 集群添加站点定义，可以执行下列步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Sites。
5. 选择 Cluster Configuration。
6. 选择 Cluster Topology。
7. 选择 Configure Sites。
8. 选择 Add Site Definition 并按 Enter 键。
9. 按如下方式输入字段值：

  • Site name

使用不超过 32 个的字母数字字符和下划线输入该节点的名称。

  • Site nodes

输入属于该站点的集群节点的名称。名称之间保留一个空格。一个节点只能属于一个站点。

  • Dominance

（如果安装了 HAGEO 的话。）选择 Yes 或 No 以指示当前站点是否为主控站点。

  • Backup communications

（如果安装了 HAGEO 的话。）选择 HAGEO 集群的备份通信类型（电话线为 DBFS，Geo_Secondary 网络为 SGN）。还可以选择 None。

    • 按 Enter 键将站点定义添加到 ODM。
    • 重复上述步骤以添加第二个站点。

定义网络
集群应该具有多个网络，以避免单点故障。
通常，集群同时具有基于 IP 和非 IP 的网络，以便使用不同的心跳方式。
使用 Add a Network to the HACMP Cluster SMIT 屏幕来定义 HACMP IP 和非 IP 网络。要加速该过程，建议在进行网络配置前运行发现操作。运行发现操作还可能会显示站点上的任何“陌生”网络配置。
可以将以下任何或所有方法用于心跳配置：

  • 串行网络
  • 基于 IP 的网络，包括使用 IP 别名的信号检测
  • 通过磁盘的信号检测

基于 IP 的网络
要配置基于 IP 的网络，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Networks。
5. 选择 Add a Network to the HACMP Cluster 并按 Enter 键。
6. 选择要配置的网络类型并按 Enter 键。
7. 按如下方式输入信息：

  • Network name

如果不输入名称，HACMP 将为该网络提供缺省网络名称，此名称由网络类型追加一个编号构成（例如，ether1）。如果要更改此网络的名称，请使用不超过 31 个的字母数字字符和下划线。

  • Network type

此字段根据所选的网络类型进行填充。

  • Netmask

网络掩码，例如 255.255.0.0。

  • Enable IP takeover via IP aliases

缺省值为 True。如果网络不支持 IP 别名，则会使用 IP 替换。IP 替换机制是从某个接口删除一个 IP 地址，并将另一个 IP 地址添加到该接口。如果希望在不支持别名的网络上使用 IP 替换，请将缺省值更改为 False。

  • IP address offset for heartbeating over IP aliases

输入心跳信号地址的专用地址范围的基地址，例如 10.10.10.1。HACMP 将使用此地址来为配置中的每个启动接口自动生成用于心跳信号的 IP 地址。此地址范围必须唯一，并且一定不能与网络上的任何其他子网发生冲突。
8. 按 Enter 键以配置该网络。
9. 按 F3 返回以配置更多网络。

配置通过 IP 替换的 IPAT
如果没有可在 HACMP 集群中使用的额外子网，您可能需要配置通过 IP 替换的 IPAT。在 HACMP V5.1 中，通过 IP 别名的 IPAT 是将 IP 标签绑定到网络接口的缺省方法，并用于确保 IP 标签的恢复。通过 IP 别名的 IPAT 可以节省硬件，但是需要多个子网。
用于配置通过 IP 替换的 IPAT 的步骤如下：
1. 在 Add a Service IP Label/Address SMIT 屏幕中，将您作为资源添加到资源组的 IP 标签指定为 Configurable on Multiple Nodes。
2. 在同一个屏幕中，通过指定 Alternate Hardware Address to Accompany IP Label/Address 来配置硬件地址接管（hardware address takeover，HWAT）。
3. 在 Add a Network to the HACMP Cluster 屏幕中，在 Enable IP Takeover via IP Aliases SMIT 字段中指定 False。

将串行网络配置到 HACMP
执行下列步骤来配置串行网络：
1. 输入 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Networks。
5. 选择 Add a Network to the HACMP Cluster 并按 Enter 键。SMIT 将显示网络类型选择。
6. 选择要配置的网络类型并按 Enter 键。
7. 按如下方式填充 Add a non IP-based Network 屏幕上的字段：

  • Network name

为网络命名，并使用不超过 31 个的字母数字字符和下划线；网络名称不要以数字开头。请不要使用保留名称来命名网络。

  • Network type

有效类型为 RS232、tmssa、tmscsi 和 diskhb
8. 按 Enter 键以配置该网络。
9. 按 F3 返回以配置更多网络。
定义通信接口
通信接口已经配置到 AIX，您将运行 HACMP 发现程序来将它们添加到 HACMP 选择列表，以便在 HACMP 配置过程中提供帮助。

将发现的通信接口添加到 HACMP 集群
1. 在 SMIT 中，转到 Extended Configuration。
2. 选择 Extended Topology Configuration。
3. 选择 Configure HACMP Communication Interfaces/Devices。
4. 选择所发现的选项。SMIT 将为发现的通信类型显示一个选择器屏幕。
5. 请选择 Communication Interfaces 并按 Enter 键。
6. 选择要添加的一个或多个发现的通信接口，然后按 Enter 键。
如果前面没有明确定义值，HACMP 或者使用 HACMP ODM 缺省值，或者自动生成值。例如，通过组合字符串“Net”与网络类型（例如，ether）加上下一个可用的整数，从而自动生成物理网络名称，例如 net_ether_03（请参见示例 12）。

示例 12 配置 HACMP 通信接口

将预定义的通信接口添加到 HACMP 集群
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Communication Interfaces/Devices 并按 Enter 键。
5. 选择预定义的选项。SMIT 将为预定义的通信类型显示一个选择器屏幕。
6. 请选择 Communication Interfaces 并按 Enter 键。随即出现 Add a Communication Interface 屏幕。
7. 按如下方式填充字段：

  • Node name

该网络接口物理地存在于其上的节点的名称。

  • –Network name

该逻辑网络的唯一名称。

  • Network interface

输入与该通信接口关联的网络接口（例如，en0）。

  • IP label/Address

与该通信接口关联的 IP 标签/地址，在节点启动时将在网络接口上配置此 IP 标签/地址。选择列表筛选掉了已经配置到 HACMP 的 IP 标签/地址。

  • Network type

网络媒体/协议的类型（例如，以太网、令牌环网、FDDI 网等等），请从预定义网络类型列表中选择类型。
注意：所添加的网络接口缺省情况下具有基本或服务功能。您没有像在 HACMP V5.1 以前的版本中那样指定网络接口的功能，但是进一步的配置将定义接口的功能。

定义通信设备
通信设备已经配置到 AIX 中，并且您已经运行 HACMP 发现程序来将它们添加到了 HACMP 选择列表，以便在 HACMP 配置过程提供帮助。
为集群配置发现的串行设备
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Communication Interfaces/Devices 并按 Enter 键。
5. 选择发现的选项并按 Enter 键。
6. 从选择器屏幕中选择通信设备类型。
随即将出现 Select Point-to-Point Pair of Discovered Communication Devices to Add 屏幕。此屏幕显示一个选择列表，其中包含多个通信设备，当您选择其中一个或多个设备时，这些设备将被添加到 HACMPadapter ODM 类。已经添加到集群的设备已从选择列表中筛选掉（请参见示例 13）。

示例 13 配置 HACMP 通信设备

7. 请在此屏幕中仅选择两个设备。假设这些设备已经物理地连接，您要负责确保此情况属实。
8. 根据需要继续定义设备。
为集群配置预定义通信设备
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Topology Configuration。
4. 选择 Configure HACMP Communication Interfaces/Devices 并按 Enter 键。
5. 选择预定义的选项并按 Enter 键。
6. 从选择器屏幕中选择通信设备类型并按 Enter 键。SMIT 将显示 Add a Communications Device 屏幕。
7. 选择希望将设备添加到其中的非 IP 网络，然后按 Enter 键。
8. 按如下方式输入字段值：

  • Node name

串行设备的节点名称。

  • Device name

设备文件名称。RS232 串行设备必须具有设备文件名 /dev/ttyn。目标模式的 SCSI 串行设备必须具有设备文件名 /dev/tmscsin。目标模式的 SSA 设备必须具有设备文件名 /dev/tmssan。磁盘信号检测串行设备的名称为 /dev/hdiskn，其中 n 是在每个设备文件名中分配的编号。

  • Device path

例如，对于 RS232，此字段值为 /dev/tty0。

  • Network type

此字段在您输入设备名称时由系统自动填充（RS232、tmssa、tmscsi 或 diskhb）。

  • Network name

此字段由系统自动填充。
9. 在填充所有必填子段后按 Enter 键。现在 HACMP 将检查设备配置的有效性。如果某个节点不可达，您可能会接收到警告。
10. 重复上述步骤，直到每个节点都已完成所有适当的通信设备的定义。

启动 IP 标签
集群中的每个节点在每个可用的适配器上配置了一个 IP 地址。这些 IP 地址称为 HACMP 配置的启动 IP 标签。集群监视此 IP 标签以了解适配器的活动状态。如果在节点上配置了通过 IP 别名的心跳检测，则会通过心跳检测 IP 标签监视适配器的可用性。
要查看节点上的启动 IP 标签，可以运行以下命令：
# netstat -in

定义持久 IP 标签
持久节点 IP 标签是一个 IP 别名，可以将其分配给网络上的某个特定节点。
持久节点 IP 标签是具有以下特征的标签：

  • 始终保持在同一个节点上（与节点绑定）
  • 与接口上存在的其他 IP 标签共存
  • 不需要在该节点上安装附加的物理接口
  • 不属于任何资源组。

在节点上分配用于某个网络的持久节点 IP 标签使您可以在集群网络上拥有与节点绑定的地址，此地址可用于管理目的以访问集群中的特定节点。
使用持久 IP 标签的先决条件包括：

  • 只能在每个节点上为每个网络定义一个持久 IP 标签。
  • 持久 IP 标签在节点启动时变得可用。
  • 在不使用别名的网络上，可以将持久标签定义在与服务标签相同的子网上，或者可以将其定义在完全不同的子网上。但是，必须将持久标签定义在与网络上的所有非服务 IP 标签不同的子网上。
  • 在使用别名的网络上，可以将持久标签定义在与别名服务标签相同的子网上，或者可以将其配置在完全不同的子网上。但是，必须将其定义在与网络上的所有启动 IP 标签不同的子网上。
  • 一旦在特定节点上为特定网络上的某个网络接口配置了持久 IP 标签，此标签即在操作系统启动时在该节点上的一个启动接口上变得可用，并当 HACMP 在该节点上关闭时保持配置在该网络上。
  • 可以使用 Delete a Persistent Node IP Label/Address SMIT 屏幕从集群配置中删除某个持久 IP 标签。但是，在从集群配置中删除持久 IP 标签以后，不会自动将该持久 IP 标签从其别名所在的接口上删除。为了完全从节点中删除持久 IP 标签，应该使用 ifconfig delete 命令手动删除该别名，或者重新启动集群节点。
  • 必须单独地定义持久节点 IP 标签，而不是使用发现过程。请执行以下步骤：

a. 输入快速路径 smitty hacmp。
b. 转到 Extended Configuration。
c. 选择 Extended Topology Configuration。
d. 选择 Configure HACMP Persistent Node IP Labels/Addresses。
e. 选择 Add a Persistent Node IP Label 并按 Enter 键。
f. 按如下方式输入字段值：

  • Node name

IP 标签/地址将绑定到的节点的名称。

  • Network name

IP 标签/地址将绑定到的网络的名称。

  • Node IP label/Address

与指定节点保持绑定的 IP 标签/地址。
g. 按 Enter 键。

定义 HACMP 网络模块
正如前面所阐述的，HACMP 预定义了具有特定值的网络。
在为集群配置不同类型的网络时，您必须在某个时间点更改网络模块的预定义值。如果希望查看和更改网络模块值，HACMP V5.x 的 SMIT 菜单可以直接进入网络模块菜单。
如果希望查看网络模块的当前值，可以使用以下过程：
1. 输入 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Configure HACMP Network Modules。
4. 选择 Change a Network Module 并按 Enter 键。SMIT 将显示已定义的网络模块的列表（请参见示例 14）。
5. 选择您希望查看其当前设置的网络模块的名称，然后按 Enter 键。

示例 14 更改使用预定义值的网络模块

在该命令完成后，将出现一个屏幕，其中显示指定网络模块的当前设置。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-3/2.html

Top


HACMP 认证学习系列，第 3 部分：安装和配置（3）

HACMP 提供了下列类型的资源组：

  • 级联资源组
  • 循环资源组
  • 并发访问资源组
  • 自定义访问组

级联资源组
级联资源组定义能够控制该资源组的所有节点的列表，然后通过为每个节点分配接管优先级，从而指定集群节点控制该资源组的优先权。当故障转移发生时，具有最高优先级的活动节点将获取该资源组。如果该节点不可用，则具有下一个最高优先级的节点将获取该资源组，以此类推（请参见图 1、2 和 3）。

图 1 初始配置中的级联资源组

图 2 故障转移条件下的级联资源组

图 3 退回条件下的级联资源组

参与节点的列表建立了该资源组的资源链。当某个拥有该资源组的较高优先级的节点加入或重新集成到集群中时，该节点将取得资源组的控制权，资源组将从具有较低优先级的节点退回到较高优先级的节点。

特殊的级联资源组属性
级联资源组支持下列属性：

  • Cascading without Fallback
  • Inactive Takeover
  • Dynamic Node Priority

Cascading without fallback (CWOF) 是一个允许微调退回行为的级联资源组属性。当将 Cascading Without Fallback 标志设置为 False 时，则表示执行传统的级联资源组行为：当某个节点加入或重新集成到集群中时，如果其优先级比资源组当前所在的节点高，并且有接口可用，则资源组将退回到较高优先级的节点。当将此标志设置为 True 时，资源组不会退回到任何加入或重新集成到集群中的节点，即使该节点是较高优先级的节点。配置了 CWOF 的资源组不需要 IP 地址接管。
Inactive Takeover 是允许微调节点对资源组的初始获取的级联资源组属性。如果 Inactive Takeover 为 True，则资源组中要加入集群的第一个节点将获取资源组，而不管为该节点指定的优先级如何。如果 Inactive Takeover 为 False，则要加入集群的每个节点仅获取被指定为其最高优先级节点的资源组。缺省值为 False。
Dynamic Node Priority 允许使用事件发生时的集群状态来确定接管节点列表的顺序。

循环资源组
与级联资源组一样，循环资源组定义了能够接管某个资源组控制权的节点的列表，并使用优先级来确定其他节点接管资源控制权的顺序。
与 CWOF 设置为 True 时的级联资源组一样，当具有最高优先级的节点重新集成到集群中时，资源组控制权不会自动归还该节点。为了避免退回所导致的服务中断，或者在资源保持跨多个节点分布变得非常重要时，可以使用循环资源组（请参见图 4 和 图 5 和 6）。

图 4 初始配置中的循环资源组

图 5 故障转移条件下的循环资源组

图 6 故障节点重新集成后的循环资源组

对于循环资源组，除非设置了 Dynamic Node Priority，否则具有某个资源组的最高优先级和可用连接（网络、网络接口和地址）的节点将从故障节点获取该资源组。HACMP 软件假设拥有循环资源组的关联服务地址的节点控制该资源组。
循环资源组与 Cascading without Fallback 资源组具有一些相似性。
然而，还是有一些重要的不同之处。与级联资源组不同，循环资源组彼此之间进行交互。
由于循环资源组需要使用 IP 地址接管，资源链中的所有节点必须共享到该资源组的同一个网络连接。如果多个循环资源组共享一个网络，任何时候只有其中一个资源组能够在给定的节点上激活。因而，循环资源组本身是分布放置的。然而，设置了 Cascading without Fallback 的级联资源组可能聚集在一起——也就是说，多个组最终将驻留在同一个节点上。CWOF 不要求将某个 IP 地址与组相关联。

并发访问资源组
并发访问资源组可以同时由多个节点共享。并发访问某个资源组的所有节点在加入集群时获取该资源组。节点之间不存在优先级。
支持并发访问资源组的集群的节点数不能超过 32 个。请注意，集群中的所有节点都必须是某个并发资源组的成员。
并发资源组中包括的资源仅仅是是带有原始逻辑卷、原始磁盘和使用那些磁盘的应用程序服务器的卷组。
定义这些逻辑存储实体的设备必须支持并发访问。

自定义资源组
在 HACMP V5.1 中，除了级联、循环和并发资源组以外，还可以配置自定义资源组。自定义资源组的参数允许您精确描述资源组在启动、故障转移和退回时的行为。
普通的级联、循环和并发资源组具有预定义的启动、故障转移和退回行为。自定义资源组的策略要比 CWOF 或 Inactive Takeover (IT) 属性更容易理解。这些策略没有被限制到普通资源组的预定义策略，并且可以根据需要进行定制。
表 1 显示了“传统”资源组（HACMP 5.1 以前的版本）和自定义资源组之间的资源组行为对比关系。

表 1 自定义资源组行为

自定义资源组属性
可以配置特定于自定义资源组的参数，这些参数定义资源组在启动、故障转移和退回时的行为方式。自定义资源组的配置包括：

  • 缺省节点优先级列表

可承载某个特定资源组的节点列表，这些节点在资源组的“Participating Node Names”中进行定义。

  • 主节点

任何非并发资源组（包括其行为类似于非并发资源组的自定义资源组）的缺省节点列表中列出的第一个节点。
自定义资源组参数

  • Settling time

Settling time 是将当前离线的资源组置于在线所需要的时间。当未配置 settling time 时，资源组将在加入集群的第一个可用的较高优先级节点上启动。可以通过指定 settling time 来配置自定义资源组的启动行为。
Settling Time 用于确保在具有较高优先级的节点被置于在线时，资源组不会在节点之间不断移动。此属性还允许 HACMP 在激活资源组前等待给定的时间长度，然后在可用的最高优先级节点上激活该资源组。
在设置了 Settling Time 的情况下，如果该资源组的最高优先级节点在线，则 HAMP 会立即将该资源组置于在线；
否则，HACMP 会在 Settling Time 间隔期间等待，然后再决定要放置该资源组的节点。

  • Dynamic node priority (DNP)

还可以使用 Dynamic Node Priority来自定义资源组的故障转移行为。
注意：还可以为普通级联和循环资源组配置 Dynamic Node Priority。

  • Delayed Fallback Timer

通过指定并分配一个延迟退回计时器 (Delayed Fallback Timer)，可以配置自定义资源组的退回行为，使得退回操作在其中一个预定义的重复间隔中进行：每天、每周、每月和每年，或者按特定的日期和时间。
Delayed Fallback Timer 允许自定义资源组在您指定的时间退回到较高优先级的节点。配置了 Delayed Fllback Timer 并且当前驻留在非主节点上的资源组将在指定的时间退回到较高优先级的节点。

  • Inactive takeover (IT)

可以配置自定义资源组的一种启动行为：如果 RG 处于“离线”状态的情况下，并且某个属于该 RG 节点优先级列表的节点启动 HACMP 服务，则此节点能够获取该资源组。

使用标准路径配置 HACMP 资源组
使用标准路径，您可以配置使用基本管理策略的资源组。这些策略基于三种预定义类型的启动、故障转移和退回策略：级联、循环或并发。
配置资源组涉及到两个阶段：

  • 配置资源组名称、管理策略和能够拥有该资源组的节点。
  • 向资源组添加资源和附加属性。

使用标准路径创建 HACMP 资源组
要创建资源组，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 在 HACMP 菜单上，选择 Initialization and Standard Configuration。
3. 选择 Configure HACMP Resource Groups。
4. 选择 Add a Standard Resource Group 并按 Enter 键。
5. 系统将提示您选择资源组管理策略。请选择 Cascading、Rotating、Concurrent 或 Custom，然后按 Enter 键。
取决于前面的选择，您将看到一个标题为 Add a Cascading/Rotating/Concurrent/Custom Resource Group 的屏幕。该屏幕仅显示与所选的资源组类型相关的选项。
注意：如果是配置自定义资源组，请参阅 “自定义资源组”。
6. 按如下方式输入字段值（此屏幕用于级联、循环和并发资源组）：

  • Resource group name

输入所需的名称。使用不超过 31 个的字母数字字符或下划线；请不要使用前导数字。

  • Participating node names

输入能够拥有或接管该资源组的节点的名称。首先输入具有最高所有权优先级的节点，然后以所需顺序输入具有较低优先级的节点（请参见示例 1）。
示例 1 使用标准路径的资源组配置

Add a Resource Group with a Cascading Management Policy (standard)
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Resource Group Name [rg1]
* Participating Node Names (Default Node Priority) [p630n01 p630n02]
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

7. 按 Enter 键。
8. 按 F3 返回到 Add a Standard Resource Group 屏幕，以继续添加为 HACMP 集群计划的所有标准资源组。
将资源分配到资源组
要为资源组分配资源，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Initialization and Standard Configuration。
3. 选择 Configure HACMP Resource Groups。
4. 选择 Change/Show Resources for a Standard Resource Group 并按 Enter 键，以显示已定义的资源组的列表。
5. 选择您希望配置的资源组，然后按 Enter 键。SMIT 将返回与所选的资源组类型匹配的屏幕，并填充 Resource Group Name 和 Participating Node Names (Default Node Priority) 字段（请参见示例 2）。
示例 2 将资源分配到资源组

Change/Show Resources for a Cascading Resource Group
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Resource Group Name rg01
Participating Node Names (Default Node Priority) p630n01 p630n02 p630n>

* Service IP Labels/Addresses [n01a1] +
Volume Groups [] +
Filesystems (empty is ALL for VGs specified) [] +
Application Servers [] +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

6. 按如下方式输入字段值：

  • Service IP label/IP address

列出要在该资源组被接管时接管的服务 IP 标签。按 F4 可以查看有效 IP 标签的列表。其中包括循环或可被接管的地址。

  • Filesystems (empty is for all specified VGs)

如果将 Filesystems 字段保留为空，并在下面的 Volume Groups 字段中指定共享卷组，则将在该卷组中挂载所有的文件系统。如果将 Filesystems 字段保留为空，并且不在下面的字段中指定卷组，则不会安装任何文件系统。还可以选择要包括在资源组中的各个文件系统。按 F4 可以查看文件系统的列表。在此情况下，在将该资源组置于在线时，将仅挂载指定的文件系统。
只有对于非并发资源组，Filesystems 才是一个有效的选项。

  • Volume groups

确定应该在获取或接管该资源组时启用的共享卷组。从选择列表中选择卷组，或者在此字段中输入所需的卷组名称。
按 F4 将显示该资源组中的所有共享卷组和当前可用于导入到资源组节点上的卷组的列表。

注意：仅当您是在添加非并发或自定义的非并发式资源组时，才应该使用 Service IP Label/IP Addresses、Filesystems 和 Volume group 选项。

  • Concurrent volume groups

确定可由多个节点同时访问的共享卷组。从选择列表中选择卷组，或者在此字段中输入所需的卷组名称。如果您先前已请求 HACMP 收集有关适当卷组的信息，则按 F4 将显示该资源组中当前可用并支持并发的所有现有卷组和可用于导入到该资源组中的节点上并支持并发的卷组的列表。
缺省情况下，Disk Fencing 功能是启用的。

  • Application servers

指示要包括在该资源组中的应用程序服务器。按 F4 可以查看应用程序服务器的列表。
7. 按 Enter 键以将这些值添加到 HACMP ODM。
8. 按 F3，直到返回到 Change/Show Resources for a Standard Resource Group 菜单，或者按 F10 退出 SMIT。

使用扩展路径配置 HACMP 资源组
要使用扩展路径创建资源组，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Resource Configuration。
4. 选择 HACMP Resource Group Configuration。
5. 选择 Add a Resource Group 并按 Enter 键。
6. 在下一个屏幕上，选择资源组管理策略（Cascading、Rotating、Concurrent 或 Custom）并按 Enter 键。
取决于前面的选择，您将看到一个标题为 Add a Cascading/Rotating/Concurrent/Custom Resource Group 的屏幕。该屏幕仅显示与所选的资源组类型相关的选项。
注意：如果是配置自定义资源组，请参阅“配置自定义资源组”。
7. 按如下方式输入字段值（此屏幕用于级联、循环和并发资源组）：

  • Resource group name

输入所需的名称。使用不超过 31 个的字母数字字符或下划线；请不要以数字开头。

  • Inter-site management policy

选择下列选项之一：

    • 除非定义了站点，否则应该使用 Ignore（缺省）。如果要定义站点，则必须提供适当的方法或自定义来处理站点操作。设置为除 Ignore 以外的任何内容的站点策略会自动将资源组添加到一个自定义的串行处理列表。
    • 可以分配将由多个站点按优先顺序接管的 Cascading 资源。当站点发生故障时，具有最高优先级的活动站点将获取该资源。当故障站点重新加入时，具有最高优先级的站点将获取该资源。
    • Rotating 资源可由其资源链中的任何站点获取。

当站点发生故障时，该资源将由最高优先级的备用站点获取。当故障站点重新加入时，该资源仍然属于其新的所有者。

    • Concurrent 资源可从任何站点进行访问。如果站点关系是并发的，则管理策略不能是 Rotating。

– Participating node names
输入能够拥有或接管该资源组的节点的名称。首先输入具有最高所有权优先级的节点，然后以所需顺序输入具有较低优先级的节点。
8. 按 Enter 键。
9. 按 F3 返回到 Add a Standard Resource Group 屏幕，以继续添加为 HACMP 集群计划的所有标准资源组（请参见示例 3）。
示例 3 使用扩展路径的资源组配置

Add a Cascading Resource Group (extended)
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Resource Group Name [rg1]
* Inter-Site Management Policy [ignore] +
* Participating Node Names (Default Node Priority) [p630n01 p630n02] +
F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

通过扩展路径向资源组分配资源和属性
要为资源组配置资源和属性，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Resource Configuration。
4. 选择 Extended Resource Group Configuration。
5. 选择 Change/Show Resources and Attributes for a Resource Group 并按 Enter 键。SMIT 将显示已定义的资源组的列表。
6. 选择您希望配置的资源组，然后按 Enter 键。SMIT 将返回与所选的资源组类型匹配的屏幕，并填充了 Resource Group Name、 Inter-site Management Policy 和 Participating Node Names (Default Node Priority) 字段。
如果参与节点已启动，可以按 F4 列出共享资源。如果还未定义资源组/节点关系，或者如果某个节点未启动，则按 F4 将显示相应的警告（请参见示例 4）。

示例 4 使用扩展路径向资源组分配资源和属性

7. 填写下列字段：

  • Dynamic node priority (Overrides default)

选择动态节点优先级策略。缺省为空（有序的节点列表）。将列出所有已定义的动态节点优先级策略，包括预先配置的策略。

  • Service IP label/IP addresses

此选项与标准配置路径中使用的选项相同。

  • Filesystems (为空的话将为特定 VG 的所有文件系统)

此选项与标准配置路径中使用的选项相同。

  • Volume groups

此选项与标准配置路径中使用的选项相同。

  • Application servers

此选项与标准配置路径中使用的选项相同。

  • Use forced varyon of volume groups, if necessary

缺省值为 False。如果此标志设置为 True，则在该卷组由于缺乏定额而使正常的 Varyon 失败的情况下，并且 HACMP 发现该卷组的每个逻辑卷中的每个逻辑分区至少有一个完整副本可用时，则 HACMP 将使用强制 Varyon 来将属于该资源组的每个卷组置于在线。
此选项应该仅用于其中的每个逻辑卷都实现了镜像的卷组。建议使用非常严格的分配策略；对于其他逻辑卷配置选择，强制 Varyon 不太可能会成功。

  • Filesystems consistency check

确定用于检查文件系统一致性的方法：fsck（缺省）或 logredo（用于快速恢复）。

  • Filesystems recovery method

确定文件系统恢复方法：parallel（并行）（用于快速恢复）或 sequential（串行）（缺省）。如果您有共享的嵌套文件系统，请不要将此字段设置为 parallel。这些文件系统必须按串行方式进行恢复。
注意：集群验证实用程序 clverify 不会报告文件系统和快速恢复的不一致性。
– File systems mounted before IP configured
指定在接管时，HACMP 是在接管故障节点的 IP 地址之前还是之后接管卷组并装入故障节点的文件系统。缺省设置为 False，意味着首先接管 IP 地址。类似地，当某个节点重新集成时，将首选获取 IP 地址，然后才装入文件系统。如果资源组包含要导出的文件系统，则应该将此字段设置为 True。这样设置是为了在服务地址上接收到 NFS 请求时，文件系统将可用。
– Filesystems/Directories to export
确定要进行 NFS 导出的文件系统或目录。这些文件系统应该是上面的 Filesystems 字段中列出的文件系统的子集。目录应该包含在上面列出的其中一个文件系统中。按 F4 可以查看列表。
– Filesystems/Directories to NFS mount
确定要进行 NFS 挂载的文件系统或目录。当所有者节点在集群中处于活动状态时，资源链中的所有节点都将尝试对这些文件系统或目录进行 NFS 挂载。
– Network for NFS mount (Optional)
选择您希望在其中对文件系统进行 NFS 装入的以前定义的 IP 网络。按 F4 可以列出有效的网络。仅当已经填写了 Filesystems/Directories to NFS Mount 字段时，此字段才有意义。Service IP Labels/IP Addresses 字段应该包含一个在所选网络上的服务标签。
– Raw disk PVIDs
按 F4 可以获得 PVID 和关联的 hdisk 设备名称的清单。如果在使用直接访问原始磁盘的应用程序，则应在此处列出那些原始磁盘。
– Tape resources
输入希望在该资源组上启动的磁带资源。
按 F4 可以从以前在 Define Tape Resources 屏幕中定义的资源列表中做出选择。
– Fast connect services
按 F4 可以从该资源组中的所有节点共有的 Fast Connect 资源列表中做出选择，这些资源是在 Fast Connect 的初始配置过程中指定的。如果是在添加 Fast Connect 文件共享，请确保您已在资源组中定义了它们的文件系统。
– Communication links
输入要由 HACMP 启动的通信链路（这是以前在 Configure Communication Adapters and Links SMIT 屏幕中定义的）。按 F4 可以查看已定义的通信链路的列表。如果添加 SNA-over-LAN 链路，请确保同时向该资源组添加了一个服务 IP 标签。
– Miscellaneous
指定您希望放到该拓扑中的文本以及资源组信息。该信息可由脚本访问，例如 Database1。

  • Primary workload manager class

按 F4 并从与指定的 HACMP WLM 配置相关联的工作负载管理器 (Workload Manager) 类选择列表中做出选择。对于级联资源组，如果没有指定辅助 WLM 类，则所有节点都使用主 WLM 类。如果指定了辅助类，则只有主节点才使用主 WLM 类。对于循环和并发资源组，资源组中的所有节点都配置为使用主 WLM 类。

  • Secondary workload manager class

（可选）按 F4 并从与该资源组相关联的工作负载管理器类选择列表中做出选择。只有级联资源组才允许使用辅助 WLM 类。如果没有指定辅助 WLM 类，则该资源组中的所有节点都使用主 WLM 类。如果在这里指定了辅助类，则主节点将使用主 WLM 类，所有其他节点将使用辅助 WLM 类。

  • Automatically import volume groups

指定 HACMP 是否应该自动导入在 Volume Groups 或 Concurrent Volume Groups 字段中定义的卷组。缺省情况下，Automatically Import Volume Groups 标志设置为 False。如果将 Automatically Import Volume Groups 设置为 False，则不会自动导入所选的卷组。在此情况下，当您向该资源组添加卷组时，请确保已经使用 importvg 命令或 C-SPOC 将所选的卷组导入每个节点。如果将 Automatically Import Volume Groups 设置为 True，则在按 Enter 键时，HACMP 将确定是否需要将您在 Volume Groups 或 Concurrent Volume Groups 字段中输入或选择的卷组导入该资源组中的任何节点，并在需要时自动导入卷组。

  • Inactive takeover applied

设置此变量以控制级联资源组的初始获取。此变量不适用于循环或并发资源组。如果 Inactive Takeover 为 True，则资源组中要加入集群的第一个节点将获取资源组，而不管为该节点指定的优先级如何。如果 Inactive Takeover 为 False，则要加入集群的每个节点仅获被指定为其最高优先级节点的资源组。缺省值为 False。
– Cascading without fallback enabled
设置此变量以确定级联资源组的退回行为。当 CWOF 变量为 False 时，级联资源组将在具有较高优先级的节点加入或重新集成到集群中时退回。当 CWOF 为 True 时，级联资源组不会在具有较高优先级的节点加入或重新集成到集群中时退回。仅当所有者节点发生故障时，级联资源组才从其所有者节点迁移。当所有者节点重新集成到集群中时，级联资源组不会退回到该所有者节点。CWOF 的缺省设置为 False。
– Fallback timer policy (为空的话表示立即执行)
仅当这是一个自定义资源组，并且您前面在列表中选择了 Fallback to Higher Priority Node 作为退回策略时，此字段才会显示出来。缺省为空（资源组在较高优先级的节点加入时立即退回）。选择列表中列出了所有已配置的退回计时器策略。
8. 按 Enter 键以将这些值添加到 HACMP ODM。
9. 返回到 Extended Configuration 菜单顶部并同步集群。

配置自定义资源组
除了基于基本管理策略（级联、循环和并发）的资源组以外，还可以配置自定义资源组。
在使用 Extended Configuration 路径时，您可以指定参数，这些参数精确描述自定义资源组在启动、故障转移和退回时的行为，其中包括延迟退回计时器（这些属性在 Standard Configuration 路径上不可用）。有关自定义 RG 行为，请参见表 1。
请确保您始终能够通过选择与特定预定义资源组的行为相同的策略，从而配置一个其行为与预定义的级联、循环或并发资源组完全相同的自定义资源组。
要配置自定义资源组，必须执行以下步骤：

  • 配置运行时策略。
  • 配置动态节点优先级策略。
  • 配置延迟退回计时器。
  • 配置停留时间 (settling time)。
  • 定义启动行为。
  • 定义故障转移行为。
  • 定义退回行为。
  • 向自定义资源组添加资源。

配置自定义资源组
请执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Resource Configuration。
4. 选择 HACMP Resource Group Configuration → Add a Resource Group 并按 Enter 键。一个选择列表将显示您可以配置的所有类型的资源组：Cascading、Rotating、Concurrent 或 Custom。
5. 请从选择列表中选择 Custom 并按 Enter 键。随即出现 Add a Resource Group 屏幕。按如下方式填充字段：

  • Resource group name

输入所需的名称。使用不超过 31 个的字母数字字符或下划线；请不要以数字开头。

  • Inter-site management policy

缺省值为 Ignore。这是用于自定义资源组的唯一有效选项。

  • Participating node names

输入能够拥有或接管该资源组的节点的名称。首先输入具有最高所有权优先级的节点，然后以所需顺序输入具有较低优先级的节点。

  • Startup policy

从定义自定义资源组的启动策略的列表中选择一个值：

    • Online on home node only

该自定义资源组在资源组启动期间应该仅在其主（最高优先级）节点上置于在线。这要求最高优先级的节点可用。

    • Online on first available node

该自定义资源组将在变得可用的第一个参与节点上激活。如果为自定义资源组配置了停留时间，在使用此启动策略选项的情况下，该停留时间仅用于此资源组。

    • Online on all available nodes

该自定义资源组将在所有节点上置于在线。如果对该资源组选择此选项，请确保该组中的资源能够同时在多个节点上置于在线。
– Fallover policy
从定义自定义资源组的故障转移策略的列表中选择一个值：

  • Fallover to next priority node in the list

在故障转移情况下，一次仅在一个节点上在线的资源组遵守该资源组的节点列表中指定的缺省节点优先级顺序。

  • . Fallover using dynamic node priority

在选择此选项之前，应配置一个希望使用的动态优先级策略。或者可以选择三种预定义的动态优先级策略之一。

  • . Bring offline (On error node only)

选择此选项以在错误状态过程中将资源组在某个节点上置于离线。当某个特定的节点发生故障时，如果您希望资源组仅在该节点上置于离线，但是在其他节点上保持在线，则此选项是最合适的。当启动首选项不是 Online On All Available Nodes 时，选择此选项作为故障转移首选项可能会使资源在错误状态过程中变得不可用。如果做此设置，HACMP 将发出警告。
– Fallback policy
从定义自定义资源组的退回策略的列表中选择一个值：

  • Fallback to higher priority node in the list

资源组将在较高优先级的节点加入集群时退回。如果选择此选项，您可以使用前面在 Configure Resource Group Run-time Policies SMIT 菜单中指定的延迟退回计时器。如果不配置延迟退回策略，则资源组将在较高优先级的节点加入集群时立即退回。

  • Never fallback

资源组不会在较高优先级的节点加入集群时退回。
6. 按 Enter 键以将资源组信息添加到 HACMP ODM。
7. 在命令完成后按 F3，直到返回到 Extended Resource configuration 屏幕，或按 F10 退出 SMIT。

配置自定义资源组的停留时间
停留时间指定 HACMP 在等待某个较高优先级节点（加入集群）多长时间以后，才激活某个当前在该节点上处于离线状态的自定义资源组。如果设置了停留时间，则 HACMP 将在该停留时间间隔期间等待，以确定是否有某个更高优先级的节点可能加入集群，而不是简单地在重新集成到集群中的第一个可能节点上激活该资源组。
要配置自定义资源组的停留时间，可以执行以下步骤：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Resource Configuration。
4. 选择 Configure Resource Group Run-Time Policies。
5. 选择 Configure Settling Time for Resource Group 并按 Enter 键。随即出现 Configure Settling Time 屏幕。
6. 按如下方式输入字段值：
– Settling time (in seconds)
在此字段中输入任何正整数。缺省值为零。在此情况下，该资源组尝试在某个正在加入集群的较高优先级节点上启动之前，将不做等待。在设置了停留时间的情况下，如果重新集成到集群中的当前可用节点不是最高优先级的节点，则资源组将在停留时间间隔过程中等待。
当停留时间结束时，资源组将在停留时间间隔过程中加入集群的节点列表中具有最高优先级的节点上激活。如果该间隔期间没有节点加入集群，则资源组将保持离线。停留时间仅对具有 Online on First Available Node 启动策略的自定义资源组有效。
7. 按 Enter 键提交更改并同步集群。此停留时间将分配给具有 Online on First Available Node 启动策略的所有自定义资源组。
定义延迟退回计时器
延迟退回计时器允许自定义资源组在指定的时间退回到较高优先级的节点。这允许您为与该资源组相关联的维护停机时间做好计划。
您可以指定计划该自定义资源组发生退回的重复时间，或者指定希望计划该自定义资源组发生退回的特定时间和日期。
可以为自定义资源组指定下列类型的延迟退回计时器：

  • Daily
  • Weekly
  • Monthly
  • Yearly
  • On a specific date

配置延迟退回计时器
要配置延迟退回计时器，可以执行以下步骤：
1. 输入 smit hacmp。
2. 选择 Extended Configuration → Extended Resource Configuration → Configure Resource Group Run-Time Policies → Configure Delayed Fallback Timer Policies → Add a Delayed Fallback Timer Policy，然后按 Enter 键。随即将显示一个选择列表 Recurrence for Fallback Timer。其中列出了 Daily、Weekly、Monthly、Yearly 和 Specific Date 策略。
3. 请从选择列表中选择计时器策略并按 Enter 键。取决于所选择的选项，将会显示一个对应的 SMIT 屏幕，该屏幕允许您配置该类型的退回策略。
将延迟退回策略分配给自定义资源组
必须首先定义延迟退回策略，然后才能将它们作为属性分配给自定义资源组。

1. 创建一个自定义资源组，或者选择某个现有的自定义资源组。
2. 转到 Extended Configuration → Change/Show Resource and Attributes for a Resource Group 并按 Enter 键。SMIT 将显示一个资源组列表。
3. 选择您希望为其分配延迟退回策略的资源组。（为该资源组显示的所有有效选项基于您为该自定义资源组指定的启动、故障转移和退回首选项。）
4. 按如下方式输入字段值：

  • Resource Group Name

所选资源组的名称显示在此字段中。

  • Inter-site Management Policy

对自定义资源组使用 Ignore (default)。

  • Participating Node Names (缺省节点优先级)

能够拥有或接管该资源组的节点的名称。
最先列出具有最高优先级的节点，然后紧跟具有较低优先级的节点。

  • Dynamic Node Priority (覆盖缺省值)

缺省为空（有序的节点列表）。将列出所有已定义的动态节点优先级策略，包括预先配置的策略。请注意，仅当您在前面选择了 Fallover Using Dynamic Node Priority 作为该资源组的故障转移行为时，才会显示此 SMIT 选项。

  • Fallback Timer Policy

缺省为空（资源组在较高优先级的节点加入时立即退回）。选择列表中列出了所有已配置的退回计时器策略。请注意，仅当您在前面选择了 Fallback to Higher Priority Node in the List 作为该资源组的退回策略时，才会显示此 SMIT 选项。
5. 按 F4 查看 Fallback Timer Policy 字段中的选择列表，并选择您希望用于该资源组的退回计时器策略。
6. 按 Enter 键提交更改。在填充 ODM 前，将会对配置进行检查。可以将相同的退回计时器策略分配给其他自定义资源组。
7. 向其他资源组分配退回计时器策略，并在完成时同步集群。

验证和同步 HACMP
在配置、重新配置或更新集群之后，应该在一个节点上运行集群验证过程，以检查是否所有节点都已就集群拓扑、网络配置以及 HACMP 资源的所有权和接管达成一致。如果验证成功，则对配置进行同步。
在活动的集群上，同步将会立即生效。
集群验证由针对各种 HACMP 配置执行的一系列检查组成。每个检查尝试检测集群一致性问题或错误。clverify 实用程序的消息输出尽可能遵循了常用的标准格式，并指出了发生错误的节点、设备、命令等等。该实用程序使用详细日志记录将输出写入 /var/hacmp/clverify/clverify.log。
在对集群做出更改之后，可以验证集群配置，或仅验证自从上次成功运行验证以来对集群所做的更改。clverify 实用程序在运行之后，还会在每个节点的 ODM 中存储详细的信息记录。每个节点的子目录包含上次成功验证、倒数第二次成功验证和上次不成功验证的信息。
在运行该实用程序的节点上，/var/hacmp/clverify/pass | pass.prev | fail /nodename/clver_response.xml 文件包含从所有节点接收到的信息。您可以在该文件中看到有关所收集到的数据和所执行的检查的详细信息。您（或服务技术人员）可以查看不成功的验证日志的详细信息，以准确确定错误发生在何处。
注意：/var/hacmp/clverify/clverify.log 文件 (0-9) 通常消耗 1-2 MB 的磁盘空间。例如，对于一个四节点的集群，建议 /var 文件系统至少有 18 MB 的空闲空间。
验证和同步集群配置
取决于您在使用哪一个 SMIT 路径，此过程稍微有所不同。如果是在使用 Initialization and Standard Configuration 路径，当您选择选项 Verify and Synchronize HACMP Configuration 时，该命令将立即执行。检查配置时的消息将发送到控制台。
如果是在使用 Extended Configuration 路径，可以在运行该命令之前设置命令参数。取决于集群是否为活动的，参数稍微有所不同。
请完成以下步骤来验证并同步集群拓扑和资源配置：
1. 输入快速路径 smitty hacmp。
2. 转到 Extended Configuration。
3. 选择 Extended Verification and Synchronization 并按 Enter 键。
该软件将检查集群服务是否正在任何集群节点上运行。如果集群是活动的，则可以选择运行模拟或实际的验证过程。对于活动的集群，Extended Cluster Verification and Synchronization SMIT 屏幕包括下列选项：
– Emulate or Actual
缺省为 Actual。
– Force synchronization if verification fails?
缺省为 No。如果选择 Yes，则集群验证将会运行，但是会忽略验证错误并对集群进行同步。
– Verify changes only?
缺省为 No。（对资源和拓扑配置运行完全检查。）Yes 将指定仅验证自从上次验证集群以来已更改过的资源和拓扑配置。
– Logging
缺省为 Standard。选择 Verbose 将把通常仅记录到 clverify.log 中的输出发送到控制台。当 clverify 从远程节点收集数据时，详细日志记录始终是启用的。
对于非活动的集群，该 SMIT 屏幕包括下列选项：
– Verify, Synchronize, or Both?
缺省为 Both。还可以选择仅验证或仅同步。
– Force synchronization if verification failed?
缺省为 No。如果选择 Yes，则集群验证将会运行，但是会忽略验证错误并对集群进行同步。
– Verify only changed parameters?
缺省为 No。（对资源和拓扑配置运行完全检查。）Yes 将指定仅验证自从上次验证集群以来已更改过的资源和拓扑配置。
– Logging
缺省为 Standard。选择 Verbose 会将通常仅记录到 clverify.log 中的输出发送到控制台。当 clverify 从远程节点收集数据时，详细日志记录始终是启用的。
4. 选择要使用的验证模式：
对所有字段选择缺省值，以运行适用于当前集群配置的所有验证检查。只有在不存在错误的情况下，才会对集群进行同步。
如果希望忽略验证错误并对集群进行同步，请选择 Force。
选择 Verify Changes Only 将仅运行与您更改（并同步）过的 HACMP 配置部分相关的检查。此模式对非活动的集群不起作用。
注意：Verify Changes Only 选项仅与 HACMP 集群 ODMS 相关。如果对集群节点上的 AIX 配置做出了更改，则不应该选择此选项。仅当您没有对 AIX 配置做出任何更改时才应选择此选项。
5. 按 Enter 键。SMIT 将运行 clverify 实用程序。验证产生的输出将显示在 SMIT Command Status 窗口中。
6. 如果接收到错误消息，请做出必要的更改并再次运行验证过程。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-3/3.html

Top


HACMP 认证学习系列，第 4 部分：集群的验证和测试

验证和测试是可靠的配置的精髓，并且是成功实现的基础之一。大多数系统管理员都记得他们的上一个 HACMP 实现，其原因要么是该实现的压力极大，要么是因为一切都按预期顺利进行。

HACMP 集群的优劣由您对其所做的设计、实现和测试工作决定。
尽管 HACMP 是一个功能强大的组件，如果没有正确的测试，在实现后也会成为一场灾难。未经计划的接管、不完善的脚本、莫名中止的节点以及一般的停机时间都可能是未经测试的集群配置的副作用。尽量列出尽可能多的故障场景，创建测试计划，验证所有故障情况下的集群行为，然后仔细检查集群规划，并确保消除了任何单点故障。
在本章中，我们将详细介绍一些基本的测试过程。
务必记住，高可用性不仅包括 HACMP 软件，而且还包括适当的硬件、可靠的软件、具有详细文档记录的设计、高级的自定义、管理和变更管理。

它有效吗？
设计和安装 HACMP 是一回事，让它按您的预期工作完全是另外一回事。只有一种方法可以确定 HACMP 是否按预期工作：测试、检验和验证。务必记住，一旦集群已经运行，生产环境的变更就更难实现（如果可能的话）。
测试和验证可能随所选择的集群解决方案而异；
然而，我们必须一再强调的是，测试可能是整个实现中最重要的组成部分，因为测试做得越多，结果就越好。
尽量模拟能够想象的每种事故；配置的优劣将由您对其所做的测试决定。
我们已不胜其烦地强调了我们认为对于检验和验证配置来说非常重要的一些要点；然而，由于每个配置都是不同的，应该将这些要点用作一般指导原则。

硬件和许可证先决条件
请考虑以下要点：

  • 验证您有冗余的电源、排风机、控制器等等。
  • 验证 sysplanar、适配器、磁盘等的微码级别是最新的。
  • 验证所使用的每个网络接口与实际交换机端口所报告的速度匹配。
  • 验证您有足够的软件许可证。有些软件许可证基于处理器 ID 和处理器数量。如果一个节点发生故障，另一个节点应该能够接管。

操作系统设置
请考虑以下要点：

  • 验证操作系统，并确保您已安装操作系统或应用程序所需的最新 PTF。
  • 验证用户数量、每用户允许的最大进程数量、最大文件数量、单个文件的最大大小、堆栈大小等等。
  • 验证 High Water Mark 和 Low Water Mark。在开始测试时，您可以分别为这两个属性分配值 33 和 24。最佳设置取决于系统配置、应用程序需求、I/O 操作量等等。您将必须监视系统性能一段时间，然后相应地调整这些参数
  • Syncd frequency.缺省值是 60。应该将其更改为 10，并开始监视集群性能，然后尝试确定能达到满意集群性能的最小值。
  • 验证您有足够的分页空间。
  • 验证转存（Dump）设备已正确设置。
  • 对于频繁使用的文件系统，可能需要单独的 jfslog。确保其名称对所有逻辑卷、文件系统和 jfslog 来说是唯一的。如果对 jfslog 使用系统自动命名，您应该小心。
  • 验证 /etc/filesystem 中的每个节 (stanza ) 已正确定义。
  • 验证 /、/var 和 /tmp 中有足够的空间。
  • 验证 /etc/services 文件。
  • 确保时钟设置在所有节点上完全相同（日期、时区和 NTP 设置——如果使用的话）。
  • 如果使用 DNS，请确保正确定义 DNS 服务器，并拥有在 DNS 变得可用时的退回计划。

集群环境
请考虑以下要点：

  • 验证 PVID 在所有节点上保持一致。
  • 验证每个卷组的 quorum 和 auto-varyon 参数已正确设置。
  • 确保名称对整个集群中的所有逻辑卷、文件系统和 jfslog 来说是唯一的。如果对 jfslog 使用系统自动命名，您应该小心。
  • 验证所有本地文件系统已装入。
  • 验证应用程序所有者的 User ID 和 Group ID 在所有节点上完全相同。
  • 确保应用程序使用的变量和用户配置文件在所有集群节点上保持一致。
  • 验证 crontab 以及您是否拥有与某个资源组或应用程序相关并且需要与该资源组或应用程序一起进行故障转移的脚本。有关更多信息，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02。
  • 验证您的应用程序仅由 HACMP 启动。对 /etc/inittab 的检查始终是有用的。
  • 测试您的应用程序启动/停止和监视脚本（用于自定义监视器），并确保它们能够在无人参与的情况下运行并提供有用的日志记录信息。
  • 对每个资源组执行手动接管，并记下有关 CPU 和磁盘使用、接管时间等的任何恰当信息。

在自定义应用程序监视和资源组行为时可以进一步使用此信息。

集群启动
在验证系统组件之后，就可以启动集群了。下面几个部分将详细介绍几个有关如何验证启动的示例。

验证集群服务
在启动集群服务之前，应该验证 clcomd 守护进程已添加到 /etc/inittab 并且已由 init 在集群中的所有节点上启动。
可以使用 SMIT 快速路径 smitty clstart 来启动集群服务。
然后，您可以选择希望在其上启动集群服务的节点。
可以选择是否希望启动集群锁服务或集群信息守护进程。
取决于集群配置，您还可能需要启动集群锁服务（用于并发 RG）。
示例 1 演示了如何启动集群服务。
示例 1 启动集群服务 (smitty clstart)

Start Cluster Services
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Start now, on system restart or both now +
Start Cluster Services on these nodes [p630n01] +
BROADCAST message at startup? false +
Startup Cluster Lock Services? false +
Startup Cluster Information Daemon? true +
Reacquire resources after forced down ? false +

F1=Help F2=Refresh F3=Cancel F4=List
F5=Reset F6=Command F7=Edit F8=Image
F9=Shell F10=Exit Enter=Do

可以使用命令 lssrc -g cluster 来验证集群服务的状态。取决于集群配置，启动的服务数量可能有所不同；但是，集群管理守护进程 (clstrmgrES)、Cluster SMUX Peer 守护进程 (clsmuxpd) 和集群拓扑服务守护进程 (topsvcsd) 应该在运行。
可以使用诸如 lssrc -g topsvcs 和 lssrc -g emsvcs 等命令来列出不同集群子系统的当前状态。
还可以定义别名来简化验证过程；在我们的场景中，我们使用以下命令创建了一个名为 lsha 的别名：
alias lsha='lssrc -a|egrep "svcs|ES"，
然后使用 lsha 来列出所有与集群相关的子系统的状态。
示例 2 演示了如何验证与集群相关的服务的状态。
示例 2 验证集群服务的状态

[p630n02][/]> lssrc -g cluster
Subsystem Group PID Status
clstrmgrES cluster 49830 active
clsmuxpdES cluster 54738 active
clinfoES cluster 45002 active
[p630n02][/]> lssrc -g topsvcs
Subsystem Group PID Status
topsvcs topsvcs 53870 active
[p630n02][/]> lssrc -g emsvcs
Subsystem Group PID Status
emsvcs emsvcs 53638 active
emaixos emsvcs 53042 active
[p630n02][/]> lsha
clcomdES clcomdES 11404 active
topsvcs topsvcs 53870 active
grpsvcs grpsvcs 49074 active
emsvcs emsvcs 53638 active
emaixos emsvcs 53042 active
clstrmgrES cluster 49830 active
clsmuxpdES cluster 54738 active
clinfoES cluster 45002 active
grpglsm grpsvcs inoperative

IP 验证
要验证 IP 地址，可以执行以下操作：

  • 使用命令 netstat –in 来验证所有 IP 地址都已配置完毕。
  • 使用命令 netstat –rn 来验证路由表。
  • 如果使用 NFS，则使用命令 lssrc -g nfs 来验证 NFS 服务已启动。

资源验证
要验证资源，可以执行以下操作：

  • 使用命令 lsvg –o 来验证卷组已启用。
  • 使用命令 lsvg -l your_volume_group 来验证逻辑卷已打开和同步。
  • 使用命令 mount 来验证文件系统已装入。
  • 如果有要导出的文件系统，可以使用命令 showmount –e 来验证它们。

应用程序验证
要验证应用程序，可以执行以下操作：

  • 使用命令 ps -ef|grep application_process 来验证应用程序在正常运行。
  • 验证客户端能够连接。

在 /tmp/hacmp.out log 文件中，查找 node_up 和 node_up_complete 事件。
示例 3 显示了一个示例 node_up 事件。
示例 3 Node_up 事件

:node_up[455] exit 0
Jun 30 15:07:19 EVENT COMPLETED:node_up p630n01
HACMP Event Summary
Event:node_up p630n01
Start time:Wed Jun 30 15:07:07 2004
End time:Wed Jun 30 15:07:21 2004
Action:Resource:Script Name:
Acquiring resource group:rg01 process_resources
Search on:Wed.Jun.30.15:07:10.EDT.2004.process_resources.rg01.ref
Acquiring resource:All_service_addrs acquire_service_addr
Search on:Wed.Jun.30.15:07:12.EDT.2004.acquire_service_addr.All_service_addrs.rg01.ref
Resource online:All_nonerror_service_addrs acquire_service_addr
Search on:
Wed.Jun.30.15:07:16.EDT.2004.acquire_service_addr.All_nonerror_service_addrs.rg01.ref

示例 4 显示了一个示例 node_up_complete 事件。
示例 4 Node_up_complete 事件

:node_up_complete[314] exit 0
Jun 30 15:07:24 EVENT COMPLETED:node_up_complete p630n01
HACMP Event Summary
Event:node_up_complete p630n01
Start time:Wed Jun 30 15:07:21 2004
End time:Wed Jun 30 15:07:25 2004
Action:Resource:Script Name:
Resource group online:rg01 process_resources
Search on:Wed.Jun.30.15:07:22:00.EDT.2004.process_resources.rg01.ref

如果遇到任何与集群服务启动相关的问题，或者希望全面了解集群启动和所涉及到的进程，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02 中的第 7 章“Starting and Stopping Cluster Services”。
监视集群状态
应该始终监视集群状态，无论是监视集群的整体状态（启动、停止或不稳定），还是监视单独的节点状态（启动、停止、加入、离开或重新配置）。

使用 clstat
可以使用命令 /usr/sbin/cluster/clstat 来获得有关集群的各个信息片段，包括集群状态、节点数量、节点的名称和状态、资源组的名称和状态，以及接口的名称和状态。要使用此命令，您应该已经启动了 clinfo 守护进程。示例 5 显示了此命令的输出。
示例 5 示例 clstat 输出

clstat - HACMP Cluster Status Monitor
Cluster:bubu (1088583415)
Wed Jun 30 15:21:25 EDT 2004
State:UP Nodes: 6
SubState:STABLE
Node:p630n01 State:UP
Interface:gp01 (0) Address: 10.1.1.1
State:UP
Interface:n01bt1 (1) Address: 172.16.100.31
State:UP
Interface:p630n01 (1) Address: 192.168.100.31
State:UP
Interface:n01a1 (1) Address: 192.168.11.131
State:UP
Resource Group:rg01 State:On line
Node:p630n02 State:UP
Interface:gp02 (0) Address: 10.1.1.2
State:UP
Interface:n01bt2 (1) Address: 172.16.100.32
State:UP
Interface:p630n02 (1) Address: 192.168.100.32
State:UP
Interface:n02a1 (1) Address: 192.168.11.132
State:UP
Resource Group:rg02 State:On line
Node:p630n03 State:UP
Interface:gp03 (0) Address: 10.1.1.3
State:UP
Interface:n01bt3 (1) Address: 172.16.100.33
State:UP
Interface:p630n03 (1) Address: 192.168.100.33
State:UP
********************** f/forward, b/back, r/refresh, q/quit ***********************

如果集群节点具有图形功能，可以使用 /usr/sbin/cluster/clstat 来显示一个描述集群和节点状态的图形窗口。在执行此操作之前，请确保将 DISPLAY 变量导出到 X 服务器地址并允许 X 客户端访问。
该命令的结果应该与图 1 所示的结果类似。

图 1 clstat 的图形显示

使用 snmpinfo
如果打算使用基于 SNMP 的监视，务必记住 HACMP 使用 V1 代理。AIX 5L 5.2 缺省使用 V3，因此您必须使用命令/usr/sbin/snmpv3_ssw -1 来更改版本。
使用 Tivoli
若要将集群与 Tivoli Monitoring 集成，您需要安装 Tivoli Monitoring 组件。有关操作原理和更多信息，请参阅红皮书 Exploiting HACMP V4.4: Enhancing the Capabilities of Cluster Multi-Processing, SG25979。
集群停止
可以使用 smitty clstop 来停止集群服务。可以选择您希望在其上停止集群服务的所有节点，以及停止类型：graceful、takeover 或 forced。
示例 6 演示了如何停止集群服务。

示例 6 停止集群服务 (smitty clstop)

在一个节点上成功关闭集群服务以后，命令 lssrc -g cluster 的输出应该不包含任何内容。
还可以使用别名命令 lsha 来验证所有与集群相关的进程的状态。
示例 7 演示了如何验证与集群相关的服务的状态。
示例 7 验证集群停止

[p630n01][/]> lssrc -g cluster
Subsystem Group PID Status
[p630n01][/]> lssrc -g topsvcs

Subsystem Group PID Status
topsvcs topsvcs inoperative
[p630n01][/]> lssrc -g emsvcs
Subsystem Group PID Status
emsvcs emsvcs inoperative
emaixos emsvcs inoperative
[p630n01][/]> lsha
clcomdES clcomdES 14896 active
topsvcs topsvcs inoperative
grpsvcs grpsvcs inoperative
grpglsm grpsvcs inoperative
emsvcs emsvcs inoperative
emaixos emsvcs inoperative

请注意，clcomd 守护进程在集群服务停止以后仍在运行。
一个节点上的关闭类型将决定该节点在成功停止集群服务以后获取的资源组将来的行为。
在文件 /tmp/hacmp.out 中，查找 node_down 和 node_down_complete 事件。
示例 8 显示了一个示例 node_down 事件。
示例 8 Node_down 事件

:node_down[306] exit 0
Jun 30 16:14:40 EVENT COMPLETED:node_down p630n01 graceful
HACMP Event Summary
Event:node_down p630n01 graceful
Start time:Wed Jun 30 16:14:28 2004
End time:Wed Jun 30 16:14:43 2004
Action:Resource:Script Name:
Releasing resource group:rg01 process_resources
Search on:Wed.Jun.30.16:14:30.EDT.2004.process_resources.rg01.ref
Releasing resource:All_service_addrs release_service_addr
Search on:Wed.Jun.30.16:14:32.EDT.2004.release_service_addr.All_service_addrs.rg01.ref
Resource offline:All_nonerror_service_addrs release_service_addr
Search on:
Wed.Jun.30.16:14:35.EDT.2004.release_service_addr.All_nonerror_service_addrs.rg01.ref
Resource group offline:rg01 process_resources
Search on:Wed.Jun.30.16:14:37.EDT.2004.process_resources.rg01.ref

示例 9 显示了一个示例 node_down_complete 事件。
示例 9 Node_down_complete 事件

:node_down_complete[352] exit 0
Jun 30 16:14:48 EVENT COMPLETED:node_down_complete p630n01 graceful
HACMP Event Summary
Event:node_down_complete p630n01 graceful
Start time:Wed Jun 30 16:14:43 2004
End time:Wed Jun 30 16:14:48 2004
Action:Resource:Script Name:
Resource group offline:rg01 process_resources
Search on:Wed.Jun.30.16:14:45.EDT.2004.process_resources.rg01.ref

应该尽可能避免使用 kill -9 命令来停止集群管理器守护进程。在这样的情况下，SRC 将检测到 clstrmgr 守护进程异常退出，并将调用 /usr/es/sbin/cluster/utilities/clexit.rc。这样会中止系统，并且可能破坏位于共享存储上的数据。其余节点将根据资源组策略启动接管。
如果遇到任何与集群服务停止相关的问题，或者希望全面了解集群停止进程，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02 中的第 7 章“Starting and Stopping Cluster Services”。
Graceful
当您指定了此参数时，节点拥有的资源组将被释放，但是不会由其他节点获取。
Graceful with takeover
当您指定了此参数时，该节点拥有的资源组将被释放，并根据资源组类型由其他节点获取。
Forced
当您指定了此参数时，集群服务将停止，但是资源组不会被释放。
注意：建议不要一次在多个节点上强制关闭集群服务。
若要更好地了解这些选项，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02 中的第 7 章“Starting and Stopping Cluster Services”。
应用程序监视
在启动集群服务以后，请确保应用程序已启动并正在运行，该应用程序提供的所有服务应该可用，并且客户端能够连接。
验证应用程序进程已启动并正在运行，并且该应用程序需要的所有资源（卷组、文件系统、逻辑卷和 IP 地址）都可用。
强烈建议您测试已定义的每个应用程序服务器的启动和停止脚本。取决于运行这些脚本的节点，可能需要对其做出一些修改。必须小心编写启动脚本，以使应用程序能够从任何以前的异常终止中恢复。停止脚本必须使应用程序能够正确关闭，使数据保持同步，并释放所有资源。
验证应用程序状态
可以使用应用程序进程监视或自定义应用程序监视来监视应用程序的状态。

应用程序进程监视
此类监视使用 RSCT 功能在应用程序进程级别工作，并且非常易于配置。用于监视的值高度依赖于应用程序的特征。建议使用以下指导原则：

  • 确保已定义了一个应用程序服务器。
  • 确保使用命令 ps –el 的输出来指定要监视的进程名称。
  • 确保指定了正确的进程所有者。
  • 确保指定了正确的实例数量。
  • 应该选择足够长的稳定间隔，以使应用程序能够从任何以前的异常关闭中恢复。
  • 确保正确设置了重新启动计数。您不会希望尝试无限期地重新启动某个永远不会在一个节点上启动的应用程序；相反，您应该尝试启动故障转移。
  • 确保正确设置了重新启动间隔。如果此间隔非常短，则重新启动计数器将会重置，并且故障转移或通知操作可能在应该发生的时候没有发生。
  • 如果需要在应用程序发生故障的情况下采取任何特殊措施，可以将这些措施包括在在用于清理方法的脚本中。

自定义应用程序监视：
您必须编写自己的脚本来监视与您的应用程序相关的所有参数。应该在无法使用应用程序进程监视的时候使用此方法。如果应用程序工作正常，确保您的脚本返回退出代码 0。
验证资源组状态
在监视集群时，您可能希望查看资源组和拓扑的状态。资源组可以处于以下状态中的某一种状态：在线、离线、获取、释放、错误、临时错误或未知。
可以使用命令 /usr/es/sbin/cluster/utilities/clfindres 或 clRGinfo 来确定资源组的状态。两种方法的结果应该完全相同，因为 /usr/es/sbin/cluster/utilities/clfindres 调用 clRGinfo。
此命令的最常用标志包括：
-t 如果希望显示某个自定义资源组的停留时间和延迟退回计时器设置，则使用此标志。
-p 如果希望显示某个资源组的优先级覆盖位置 (priority override location)，则使用此标志。
有关这些标志的进一步详细信息，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02 中的第 7 章“Starting and Stopping Cluster Services”。
示例 10 显示了此命令在带 –p 标志运行时的输出。

示例 10 示例 clRGinfo -p 输出

始终可以使用命令 /usr/es/sbin/cluster/utilities/cltopinfo 来检查集群拓扑，如示例 11 所示。
示例 11 Cltopinfo 示例输出

Cluster Description of Cluster:bubu
Cluster Security Level:Standard
There are 6 node(s) and 7 network(s) defined
NODE p630n01:
Network net_diskhb_01
Network net_diskhb_02
p630n01_hdisk30_01 /dev/hdisk30
Network net_ether_01
gp01 10.1.1.1
Network net_ether_02
n02a1 192.168.11.132
n04a1 192.168.11.134
n03a1 192.168.11.133
n06a1 192.168.11.136
n05a1 192.168.11.135
n01a1 192.168.11.131
p630n01 192.168.100.31
n01bt1 172.16.100.31
Network net_rs232_01
Network net_rs232_02
Network net_rs232_03
NODE p630n02:
Network net_diskhb_01

可以使用不同的标志来对输出进行格式设置。请参见此命令的手册页面。
有关可用于集群状态监视的工具的详细描述，请参阅 HACMP for AIX 5L V5.1 Adminstration and Troubleshooting Guide, SC23-4862-02 的第 8 章“Monitoring an HACMP Cluster”。

验证 NFS 功能
注意：在开始使用 NFS 之前，应该注意恢复功能和锁还原功能（在 NFS 服务器故障的情况下）仅对两节点的集群可用。
在使用 HACMP 时，您应该注意，在 NFS 的实现方式方面存在一些限制。如果使用通过 IP 别名或替换的 IPAT，则 NFS 行为会有所不同。请记下您的文件系统属于哪一种资源组类型（级联、循环或自定义），以及可用的服务数量、启动接口和路由表中的路由。
可以在两种不同类型的 NFS 装入之间做出选择：硬挂载和软挂载。

  • 如果尝试对某个文件系统进行软装入，并且导出 NFS 服务器不可用，您将会接收到一个错误。
  • 当导出 NFS 服务器不可用时，尝试对某个文件系统进行硬装入的客户端将会一直尝试，直到该服务器变得可用，这种情况可能不适合于您的应用程序。

注意：缺省选择是硬装入。
确保每个节点的主机名称与服务标签匹配是推荐的普遍做法，因为有些应用程序使用主机名称。
在我们测试 NFS 的例子中，我们将使用一个包含两个节点、两个级联资源组和两个通过服务地址导出的文件系统的集群。
我们使用了以下步骤来测试 NFS 功能：
1. 定义两个卷组 vg01 和 vg02。确保每个卷组的主编号在两个节点上完全相同。
2. 在每个卷组中定义一个逻辑卷和一个将导出的文件系统，并将它们命名为 /ap1_fs 和 /app2_fs。确保逻辑卷名称和 jfslog 名称在两个节点上保持一致。
3. 可以使用 C-SPOC 执行前面的任务，并且不应该担心卷组主编号、逻辑卷名称或 jfslog 名称在整个集群中的唯一性。
4. 定义两个级联资源组，名字为：rg01 和 rg02。
5. 对于 rg01，将参与节点定义为 node 1 和 node 2。
6. 对于 rg02，将参与节点定义为 node 2 和 node 1。
7. 创建两个将用于挂载文件系统的目录：
/mount_point1 和 /mount_point2。
8. 运行 smitty hacmp 并转到 Change/Show All Resources and Attributes for a Cascading Resource Group 菜单。
9. 对于 rg01m：

  • 在 Filesystems 字段中输入 /app1_fs
  • 在 Filesystem mounted before IP Configured 字段中选择 True
  • 在 Filesystems/Directories to Export 字段中输入 /app1_fs
  • 在 Filesystems/Directories to NFS mount 字段中输入 /mount_point1;/app1_fs
  • 在 Network For NFS Mount 字段中选择服务网络

10. 对于 rg02：

  • 在 Filesystems 字段中输入 /app2_fs
  • 在 Filesystem mounted before IP Configured 字段中选择 True
  • 在 Filesystems/Directories to Export 字段中输入 /app2_fs
  • 在 Filesystems/Directories to NFS mount 字段中输入 /mount_point2;/app2_fs
  • 在 Network For NFS Mount 字段中选择服务网络

11. 如果计划使用特定的 NFS 导出选项，则必须编辑文件 /usr/es/sbin/cluster/etc/exports。该文件的格式与 /etc/exports 文件的格式相同。
12. 同步集群资源。
13. 在两个节点上启动集群服务。
14. 通过分别运行命令 lssrc -g cluster 和 lssrc -g nfs 来验证集群和 NFS 服务已成功启动。
15. 验证 vg01 已在 node 1 上启用。/filesystem1 应该已在本地挂载，/filesystem2 应该已经实现 NFS 挂载。使用命令 showmount –e 来验证 node 1 已对 /filesystem1 进行了 NFS 导出。
16. 验证 vg02 已在 node 2 上启用。/filesystem2 应该已在本地挂载，/filesystem1 应该已经实现 NFS 挂载。使用命令 showmount –e 来验证 node 2 已对 /filesystem2 进行了 NFS 导出。
17. 使用 takeover 选项停止 node 1 上的集群服务。
18. 验证 vg01 已在 node 2 上启用。/filesystem1 和 /filesystem2 应该同时实现了本地和 NFS 装入。它们还应该实现了 NFS 导出。
19. 重新启动 node 1 上的集群服务。/filesystem1 应该再次同时实现了本地和 NFS 装入。node 2 应该能够对 /filesystem1 进行 NFS 装入。

节点故障转移时的集群行为
通过在预计要发生故障的节点上关闭电源或者运行命令 cp /dev/zero /dev/kmem 或 halt –q 来模拟节点崩溃。
验证故障节点获取的资源组将按预期的方式迁移，并且集群仍然向其客户端提供服务。
测试 IP 网络
在测试发生 IP 故障时的集群行为之前，您必须确保正确设置将运行集群的网络环境：

  • 如果网络使用 VLAN，则要确保所有物理接口连接到同一个 VLAN。
  • 如果集群使用 MAC 地址接管，则要确保交换机端口未绑定到特定的 MAC 地址。
  • 将接口速度设置为特定的值，并在可能的情况下使用双工通信。确保为接口设置的速度与交换机接口的速度匹配。验证您在故障转移情况下将拥有相同的设置。
  • 验证与 ARP 相关的网络环境设置。启用代理 ARP 的路由器可能会干扰集群接管。验证您的网络支持免费 ARP 和 UDP 广播。
  • 应该避免使用活动网络设备（路由器、第 3 层交换机、防火墙等等）来连接到集群节点，因为这些类型的设备可能阻止用于集群节点之间通信的 UDP 广播和其他类型的消息。
  • 验证任何网络接口的故障不会导致集群分割。

通信适配器故障
我们添加了一些步骤，以模拟包含不确定数量接口的节点上的网络接口故障：
1. 从该适配器中拔出电缆。
2. 如果该适配器配置了服务 IP 地址，则：

  • 在 /tmp/hacmp.out 中验证发生了事件“swap_adapter”。
  • 使用命令 netstat –in 验证服务 IP 地址已经转移。
    • 如果在使用通过 IP 别名的 IPAT，则服务 IP 地址应该已经化名到其中一个可用的启动接口上。
    • 如果在使用通过 IP 替换的 IPAT，则服务 IP 地址应该已经转移到其中一个可用的备用接口。
  • 验证持久地址（如有的话）已转移到另一个可用的接口。
  • 将电缆插入该网络适配器。
    • 如果使用通过别名的 IPAT，则启动 IP 地址应该变得可用。
    • 如果使用通过替换的 IPAT，则备用 IP 地址应该可用。

3. 如果该适配器未配置服务 IP 地址，则会从集群中删除其 IP 地址。该接口上配置的任何持久地址应该化名到另一个可用的接口上。
4. 一次一个地拔出和插入所有接口的电缆。

网络故障
为了避免单点故障，您应该使用多个交换机将集群连接到外部环境，并确保客户端能够使用其中任何一个交换机连接到集群。
可以使用以下步骤来测试集群针对交换机故障的恢复能力：关闭交换机电源，并使用命令 netstat –in 来验证集群 IP 服务地址已迁移（无论是通过别名还是通过替换）到连接到其余交换机的接口。

验证持久 IP 标签
1. 确保未在任何资源组中定义该持久节点 IP 标签。
2. 使支持该 IP 服务标签的网络接口发生故障。该持久节点 IP 标签应该转移到服务接口所迁移到的同一个启动接口上。
3. 一次一个地使其他网络接口发生故障，并等待集群稳定。
该持久 IP 标签应该迁移到下一个可用的启动接口。
4. 当您使所有的网络接口发生故障时，该 IP 持久标签应该不可用。
5. 重新启用所有网络接口。
6. 停止集群服务。IP 持久标签应该仍然可用。
7. 重新启动该节点。该 IP 持久标签应该仍然可用。
测试非 IP 网络
本部分的目的是描述一些用于测试集群节点之间的非 IP 连接的方法。
串行网络
可以在集群的任何两个节点之间实现 RS232 心跳检测网络。
要测试两个节点之间的串行连接，可以执行以下步骤：
1. 在两个节点上运行命令 lsdev -Cc tty，以验证预期要使用的 tty 设备可用。下面假设您在串行连接的两端都使用 tty1。
2. 确保将 baud rate 设置为 38400，将 parity 设置为 none，将 bits per character 设置为 8，将 number of stop bits 设置为 1，将 enable login 设置为 disable。
3. 确保使用串口线（null-modem cable）电缆。
4. 确保集群服务未运行。
5. 在 node 1 上，运行命令 cat < /dev/tty1。
6. 在 node 2 上，运行命令 cat /etc/hosts > /dev/tty1。您应该能够在 node 1 的控制台上看到 /etc/hosts。
7. 以相反方向重复此测试。

SCSI 网络
可以在集群的任何两个节点之间实现 SCSI 心跳检测网络。要测试 SCSI 心跳信号网络，建议执行以下步骤：
1. 验证两个节点上都已安装文件集 devices.scsi.tm.rte。
2. 确保两个节点都正确连接到 SCSI 存储。
3. 确保连接到共享总线的所有设备的 SCSI ID 保持唯一。不要使用编号 7，因为此值在每次配置新添加的适配器或在以服务模式启动系统时由 AIX 分配。
4. 启用每个 SCSI 适配器的目标模式（target mode）。验证 tmscsi 设备处于可用状态。
5. 确保集群服务未运行。
6. 在 node 1 上，运行命令 cat < /dev/tmscsi#.tm，其中 # 是目标设备的 ID。
7. 在 node 2 上，运行命令 cat /etc/hosts > /dev/tmscsi#.in，其中 # 是发起者设备的 ID。您应该能够在 node 1 的控制台上看到 /etc/hosts 文件。
8. 以相反方向重复此测试。
SSA 网络
可以在集群的任何两个节点之间实现 SSA 心跳检测网络。要测试 SSA 心跳信号网络，建议执行以下步骤：
1. 验证两个节点上都已安装文件集 devices.ssa.tm.rte。
2. 确保使用命令 chdev -l ssar -a node_number=x 来正确设置 SSA 路由器 ID，其中 x 是一个唯一的非零数字。必须使用集群节点的节点 ID 值。
3. 确保两个节点都已正确连接到 SSA 存储。
4. 确保集群服务未运行。
5. 在 node 1 上，运行命令 cat < /dev/tmssa#.tm。
6. 在 node 2 上，运行命令 cat /etc/hosts > /dev/tmssa#.in。您应该能够在 node 1 的控制台上看到 /etc/hosts 文件。
7. 以相反方向重复此测试。

通过磁盘的心跳信号网络
要测试磁盘心跳信号网络，可以执行以下步骤：
1. 确保磁盘的 PVID 在连接的两个节点上完全相同。
2. 确保同时将磁盘定义为两个集群节点上的某个增强并发卷组的成员。
3. 验证您已安装正确版本的 bos.clvm.enh 和 RSCT 文件集。
4. 运行命令 /usr/es/sbin/cluster/utilities/clrsctinfo -cp cllsif|grep diskhb 并验证节点的同步取得成功。我们使用 hdisk30 来定义集群节点 1 和 2 之间的磁盘检测信号网络，如示例 12 所示。
示例 12 Clrsctinfo 输出示例

[p630n02][/]> /usr/es/sbin/cluster/utilities/clrsctinfo -cp cllsif|grep diskhb
p630n01_hdisk30_01:service:net_diskhb_02:diskhb:serial:p630n01:/dev/rhdisk30::hdisk30::
p630n02_hdisk30_01:service:net_diskhb_02:diskhb:serial:p630n02:/dev/rhdisk30::hdisk30::

5. 在 node 1 上，运行命令 /usr/sbin/rsct/bin/dhb_read –p /dev/hdisk30 –r。您的结果应该与示例 13 所示的结果类似。
示例 13 磁盘检测信号接收

[p630n02][/]> /usr/sbin/rsct/bin/dhb_read -p /dev/hdisk30 -r
Receive Mode:
Waiting for response . . .
Link operating normally

6. 在 node 2 上，运行命令 /usr/sbin/rsct/bin/dhb_read –p /dev/hdisk30 -t。
7. 您的结果应该与示例 14 所示的结果类似。
示例 14 磁盘检测信号传输

[p630n01][/]> /usr/sbin/rsct/bin/dhb_read -p /dev/hdisk30 -t
Transmit Mode:
Detected remote utility in receive mode.Waiting for response . . .
Link operating normally

8. 以相反方向重复此测试。
9. 转到目录 /var/ha/log。
10. 如果集群名为 certification，并且您使用磁盘 27，则运行命令

tail -f nim.topsvcs.rhdisk27.certification

11. 命令的输出应该与示例 15 所示的输出类似。
示例 15 通过磁盘的检测信号的示例日志

[p630n02][/]> tail -f /var/ha/log/nim.topsvcs.rhdisk30.certification
06/30 19:24:21.296: Received a SEND MSG command.Dst: .
06/30 19:25:01.798: Received a SEND MSG command.Dst: .
06/30 19:25:42.636: Received a SEND MSG command.Dst: .
06/30 19:26:23.318: Received a SEND MSG command.Dst: .
06/30 19:27:03.836: Received a SEND MSG command.Dst: .
06/30 19:27:44.836: Received a SEND MSG command.Dst: .
06/30 19:28:26.318: Received a SEND MSG command.Dst: .
06/30 19:29:07.376: Received a SEND MSG command.Dst: .
06/30 19:29:48.378: Received a SEND MSG command.Dst: .
06/30 19:30:29.310: Received a SEND MSG command.Dst: .

发生其他故障时的集群行为
HACMP 处理由集群基础设施（拓扑和组服务）确定的故障，但是还可以对并不直接与 HACMP 组件相关的故障作出反应。
硬件组件故障
应该验证您在下列场景中仍然能够访问存储在外部磁盘上的数据：

  • 一个将节点连接到存储的适配器发生故障。
  • 同一个节点中将该节点连接到存储的多个适配器发生故障。
  • 一个节点中的一个适配器和另外一个节点中的另一个适配器发生故障。
  • 电缆故障。
  • 整个节点发生故障。
  • 如果使用多个存储机箱，则验证一个机箱的故障。

如果在使用 SSA 技术，应小心检查前面提到的所有场景中的环路连续性和跳线卡 (bypass card) 行为，并验证集群和应用程序仍在正常工作。
如果使用 ESS 或 FAStT 存储，则应该小心验证 LUN 屏蔽和分区。
Rootvg 镜像和内部磁盘故障
至少使用两个磁盘的镜像 rootvg 可以帮助您避免 rootvg 崩溃。
要测试此场景，建议按照以下步骤操作：
1. 使用命令 lsvg -p rootvg 来验证 rootvg 至少包含两个内部磁盘。
2. 使用命令 lsvg -l rootvg 来验证逻辑卷已同步，并且不存在任何过时分区。
3. 使用命令 bootlist -m normal –o 来验证所有磁盘都已包括在启动列表中。
4. 断开一个磁盘的电源，在热插磁盘的情况下，从磁盘盒中取出磁盘。
5. 验证系统在正常工作。
6. 重新启动系统。
7. 连接断开的磁盘。
8. 同步 rootvg。
AIX 和 LVM 级别的错误
HACMP 只能检测三种类型的故障：

  • 网络接口卡故障
  • 节点故障
  • 网络故障

集群行为还会受到其它事件的影响，例如卷组定额确失或应用程序故障，但是它不会直接对这些事件作出反应。
VG 的强制 Varyon
要全面了解此功能，必须充分了解 AIX LVM。
启用定额
当启用了定额时，必须有一半以上的 VGDA 和 VGSA 副本可进行读访问并且内容完全相同，varyonvg 命令才能成功。如果对某个磁盘的写操作发生故障，则会更新其他物理卷上的 VGSA 以指示该故障。只要所有 VGDA 和 VGSA 中有一半以上能够写入，定额就会得以维持，卷组将保持启用。然而，丢失物理卷上的数据将不可用，除非该数据的镜像副本位于另一个可用的物理卷上。
仍然可以使丢失数据的所有副本和该卷组可访问并启用，因为其他磁盘中的大部分 VGDA 和 VGSA 副本仍然可访问。
建议不要在 HACMP 配置中使用定额。
禁用定额
当禁用了定额时，所有的 VGDA 和 VGSA 副本都必须可进行读访问并且内容完全相同，varyonvg 命令才能成功。如果对某个磁盘的写操作发生故障，则会更新其他物理卷上的 VGSA 以指示该故障。只要至少有一个 VGDA 和 VGSA 副本可写，卷组就将保持启用，但是不再保证数据完整性。
强制 Varyon
HACMP V5.1 的这个新功能允许在正常 varyonvg 操作失败的情况下强制执行 varyonvg。
可以通过执行以下步骤来测试强制 Varyon 功能：
1. 定义一个至少包含两个物理卷的卷组。一个卷组应该至少包括一个逻辑卷，该逻辑卷至少应该具有两个位于不同磁盘上的数据副本。至少应该可以从集群的两个节点访问一个卷组。使用 C-SPOC 可以容易地执行此任务。
2. 将前面定义的卷组包括在一个资源组中。该资源组的参与节点应该至少包括两个节点，例如，假设我们定义了一个具有参与节点 node1 和 node2 的级联资源组。
3. 对于该资源，在 Extended Resource Group Configuration 面板中将参数 Use forced varyon of volume groups, if necessary 设置为 True。
4. 同步集群资源。
5. 启动 node 1 和 node 2 上的集群服务。
6. 验证该卷组已在 node 1 上启用。
7. 验证逻辑卷已打开，并且文件系统已装入。
8. 在其中一个文件系统上创建一个测试文件。
9. 使该卷组中足够多的磁盘发生故障，以便仅有一个 VGDA 和 VGSA 副本可用。
10. 在我们的测试中，我们定义了一个包含两个磁盘的卷组，并使用命令 dd if=/dev/zero of=/dev/hdisk5 bs=128 删除了包含两个 VGDA 的磁盘中的 PVID。
此操作将使该磁盘不可用于 Varyon 过程。上述命令的结果如示例 16 所示。
示例 16 从磁盘删除 PVID

[p630n02][/]> dd if=/dev/zero of=/dev/hdisk36 bs=128
[p630n02][/]> lquerypv -h /dev/hdisk36
00000000 00000000 00000000 00000000 00000000 |................|
00000010 00000000 00000000 00000000 00000000 |................|
00000020 00000000 00000000 00000000 00000000 |................|
00000030 00000000 00000000 00000000 00000000 |................|
00000040 00000000 00000000 00000000 00000000 |................|
00000050 00000000 00000000 00000000 00000000 |................|
00000060 00000000 00000000 00000000 00000000 |................|
00000070 00000000 00000000 00000000 00000000 |................|
00000080 00000000 00000000 00000000 00000000 |................|
00000090 00000000 00000000 00000000 00000000 |................|
000000A0 00000000 00000000 00000000 00000000 |................|
000000B0 00000000 00000000 00000000 00000000 |................|
000000C0 00000000 00000000 00000000 00000000 |................|
000000D0 00000000 00000000 00000000 00000000 |................|
000000E0 00000000 00000000 00000000 00000000 |................|
000000F0 00000000 00000000 00000000 00000000 |................|

11. 在 node 1 上，使用 takeover 选项停止集群服务。
12. 验证该卷组已在 node 2 上启用。
13. 验证文件系统已装入，并且可以访问测试文件。
RSCT 验证
可以使用以下命令进行测试，以确定 RSCT 是否在正常工作：

lssrc -ls topsvcs

此命令的输出如示例 17 所示。

示例 17 lssrc -ls topsvcs 的示例输出

要检查 RSCT 组服务，请参考示例 18。
示例 18 lssrc -ls grpsvcs 的示例输出

Subsystem Group PID Status
grpsvcs grpsvcs 42784 active
2 locally-connected clients.Their PIDs:
32142(haemd) 21124(clstrmgr)
HA Group Services domain information:
Domain established by node 2
Number of groups known locally: 3
Number of Number of local
Group name providers providers/subscribers
ha_em_peers 6 1 0
CLRESMGRD_1088583415 6 1 0
CLSTRMGR_1088583415 6 1 0

可以使用 /var/ha/run/topsvcs.your_cluster_name 中的日志文件 cllsif.log 来密切监视通过所有已定义的网络的检测信号。在示例 19 中可以看到该日志文件的一个示例。
示例 19 示例 cllsinfo.log

p630n01_hdisk30_01:service:net_diskhb_02:diskhb:serial:p630n01:/dev/rhdisk30::hdisk30::
gp01:boot:net_ether_01:ether:public:p630n01:10.1.1.1::en1::255.255.255.0
p630n01:boot:net_ether_02:ether:public:p630n01:192.168.100.31::en0::255.255.255.0
n01bt1:boot:net_ether_02:ether:public:p630n01:172.16.100.31::en2::255.255.255.0
n06a1:service:net_ether_02:ether:public:p630n01:192.168.11.136::::255.255.255.0
n05a1:service:net_ether_02:ether:public:p630n01:192.168.11.135::::255.255.255.0
n02a1:service:net_ether_02:ether:public:p630n01:192.168.11.132::::255.255.255.0
n04a1:service:net_ether_02:ether:public:p630n01:192.168.11.134::::255.255.255.0
n03a1:service:net_ether_02:ether:public:p630n01:192.168.11.133::::255.255.255.0
n01a1:service:net_ether_02:ether:public:p630n01:192.168.11.131::::255.255.255.0
p630n02_hdisk30_01:service:net_diskhb_02:diskhb:serial:p630n02:/dev/rhdisk30::hdisk30::
gp02:boot:net_ether_01:ether:public:p630n02:10.1.1.2::en1::255.255.255.0
n01bt2:boot:net_ether_02:ether:public:p630n02:172.16.100.32::en2::255.255.255.0
p630n02:boot:net_ether_02:ether:public:p630n02:192.168.100.32::en0::255.255.255.0
n06a1:service:net_ether_02:ether:public:p630n02:192.168.11.136::::255.255.255.0
n05a1:service:net_ether_02:ether:public:p630n02:192.168.11.135::::255.255.255.0
n02a1:service:net_ether_02:ether:public:p630n02:192.168.11.132::::255.255.255.0
n04a1:service:net_ether_02:ether:public:p630n02:192.168.11.134::::255.255.255.0
n03a1:service:net_ether_02:ether:public:p630n02:192.168.11.133::::255.255.255.0
n01a1:service:net_ether_02:ether:public:p630n02:192.168.11.131::::255.255.255.0
gp03:boot:net_ether_01:ether:public:p630n03:10.1.1.3::en1::255.255.255.0
p630n03:boot:net_ether_02:ether:public:p630n03:192.168.100.33::en0::255.255.255.0
n01bt3:boot:net_ether_02:ether:public:p630n03:172.16.100.33::en2::255.255.255.0
n06a1:service:net_ether_02:ether:public:p630n03:192.168.11.136::::255.255.255.0
n05a1:service:net_ether_02:ether:public:p630n03:192.168.11.135::::255.255.255.0
n02a1:service:net_ether_02:ether:public:p630n03:192.168.11.132::::255.255.255.0
n04a1:service:net_ether_02:ether:public:p630n03:192.168.11.134::::255.255.255.0
n03a1:service:net_ether_02:ether:public:p630n03:192.168.11.133::::255.255.255.0
n01a1:service:net_ether_02:ether:public:p630n03:192.168.11.131::::255.255.255.0
p630n03_tty0_01:service:net_rs232_02:rs232:serial:p630n03:/dev/tty0::tty0::
gp04:boot:net_ether_01:ether:public:p630n04:10.1.1.4::en1::255.255.255.0
n01bt4:boot:net_ether_02:ether:public:p630n04:172.16.100.34::en2::255.255.255.0
p630n04:boot:net_ether_02:ether:public:p630n04:192.168.100.34::en0::255.255.255.0
n06a1:service:net_ether_02:ether:public:p630n04:192.168.11.136::::255.255.255.0
n05a1:service:net_ether_02:ether:public:p630n04:192.168.11.135::::255.255.255.0
n02a1:service:net_ether_02:ether:public:p630n04:192.168.11.132::::255.255.255.0
n04a1:service:net_ether_02:ether:public:p630n04:192.168.11.134::::255.255.255.0
n03a1:service:net_ether_02:ether:public:p630n04:192.168.11.133::::255.255.255.0
n01a1:service:net_ether_02:ether:public:p630n04:192.168.11.131::::255.255.255.0
p630n04_tty0_01:service:net_rs232_02:rs232:serial:p630n04:/dev/tty0::tty0::
gp05:boot:net_ether_01:ether:public:p630n05:10.1.1.5::en1::255.255.255.0

目录 /var/ha/run/topsvcs.your_cluster_name 中的文件 machines.your_cluster_id.lst 包含有关集群的至关重要的信息。
示例 20 显示了该文件的一个示例。
示例 20 示例 machines.cluster_id.lst

*InstanceNumber=166
*configId=1407358441
*!TS_realm=HACMP
*!TS_EnableIPAT
*!TS_PinText
*!TS_PinData
*!TS_HACMP_version=6
TS_Frequency=1
TS_Sensitivity=4
TS_FixedPriority=38
TS_LogLength=5000
Network Name net_ether_01_0
Network Type ether
*!NIM_pathname=/usr/sbin/rsct/bin/hats_nim
*!NIM_Src_Routing=1
*!TS_Frequency=1
*!TS_Sensitivity=5
*
*Node Type Address
1 en1 10.1.1.1
2 en1 10.1.1.2
3 en1 10.1.1.3
4 en1 10.1.1.4
5 en1 10.1.1.5
6 en1 10.1.1.6
Network Name net_ether_02_0
Network Type ether
*!NIM_pathname=/usr/sbin/rsct/bin/hats_nim
*!NIM_Src_Routing=1
*!TS_Frequency=1
*!TS_Sensitivity=5
*
*Node Type Address
1 en0 192.168.100.31
2 en0 192.168.100.32
3 en0 192.168.100.33
4 en0 192.168.100.34
5 en0 192.168.100.35
6 en0 192.168.100.36
Network Name net_ether_02_1
Network Type ether
*!NIM_pathname=/usr/sbin/rsct/bin/hats_nim
*!NIM_Src_Routing=1
*!TS_Frequency=1
*!TS_Sensitivity=5

*
*Node Type Address
1 en2 172.16.100.31
2 en2 172.16.100.32
3 en2 172.16.100.33
4 en2 172.16.100.34
5 en2 172.16.100.35
6 en2 172.16.100.36
Network Name rs232_0
Network Type rs232
*!NIM_pathname=/usr/sbin/rsct/bin/hats_rs232_nim
*!NIM_Src_Routing=0
*!TS_Frequency=2
*!TS_Sensitivity=5
*
*Node Type Address
3 tty0 255.255.0.0 /dev/tty0
4 tty0 255.255.0.1 /dev/tty0
Network Name diskhb_0
Network Type diskhb
*!NIM_pathname=/usr/sbin/rsct/bin/hats_diskhb_nim
*!NIM_Src_Routing=0
*!TS_Frequency=2
*!TS_Sensitivity=4
*
*Node Type Address
2 rhdisk30 255.255.10.1 /dev/rhdisk30
1 rhdisk30 255.255.10.0 /dev/rhdisk30

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/HACMP-4/

Top


HACMP 5.x 完全手册，第 1 部分：设计和安装

前言

为什么需要 HACMP

各厂商现有的 UNIX 服务器一般都拥有很高的可靠性，在这一点上 IBM 的 P 系列服务器表现尤为突出。但所有 UNIX 服务器均无法达到如 IBM 大型主机 S/390 那样的可靠性级别，这是开放平台服务器的体系结构和应用环境所决定的。使用 IBM 高可用性集群软件 --HACMP，可以更好的保护关键业务应用不受故障影响。

HACMP 工作原理

HACMP 是 High Availability Cluster Multi-Processing 的缩写。HACMP 是 IBM 公司在 P 系列 AIX 操作系统上的高可靠集群软件，配置冗余，消除单点故障，保证整个系统连续可用性和安全可靠性。HACMP 是利用网络来侦测主机及网卡的状况，搭配 AIX 所提供的硬盘镜像等功能，在主机、网卡、硬盘控制卡、硬盘或网络发生故障时，自动切换到另一套备用元件上重新工作 ; 若是主机故障还切换至备份机上继续应用系统的运行。

作为双机系统的两台服务器同时运行 HACMP 软件：

  • 两台服务器的备份方式有二种 :
    • 一台服务器运行应用，另外一台服务器做为备份
    • 两台服务器除正常运行本机的应用外，同时又作为对方的备份主机 ;
  • 两台主机系统在整个运行过程中，通过 " 心跳线 " 相互监测对方的运行情况 ( 包括系统的软硬件运行、网络通讯和应用运行情况等 );
  • 一旦发现对方主机的运行不正常 ( 出故障 ) 时，故障机上的应用就会立即停止运行，本机 ( 故障机的备份机 ) 就会立即在自己的机器上启动故障机上的应用，把故障机的应用及其资源 ( 包括用到的 IP 地址和磁盘空间等 ) 接管过来，使故障机上的应用在本机继续运行 ;
  • 应用和资源的接管过程由 HACMP 软件自动完成，无需人工干预 ;
  • 当两台主机正常工作时，也可以根据需要将其中一台机上的应用人为切换到另一台机 ( 备份机 ) 上运行。

实验环境说明：

本文的实验环境以双机互备中比较复杂的多 service 多网络的情况为例，其它类似设置可适当简化。

  • 机器一览表
节点机器名 | 操作系统 | 应用软件 | HA 版本
host2 | AIX5305-CSP | ORACLE 10g | HA5208
host1 | AIX5305-CSP | Tuxedo8.1 | HA5208
  • 磁盘和 VG 规划表
节点机器名 | 磁盘 | VG | VG MajorNumber
host1 | hdisk2 | host1vg | 101
host2 | hdisk3 | host2vg | 201
  • 用户和组规划表
用户 | USERID | 组 | 组 ID | 使用节点
orarrunc | 210 | dba | 201 | host1
tuxrun | 301 | bea | 301 | host1
bsx1 | 302 | bea | 301 | host1
xcom | 401 | dba | 201 | host1
orarun | 209 | dba | 201 | host2
  • 逻辑卷和文件系统规划表

PP size:128M

节点机器名 | 逻辑卷 | 文件系统 | 大小(pp) | 所有者 | 用途
host1 | ora10runclv | /ora10runc | 40 | orarunc | ORACLE 客户端软件
host1 | tux81runlv | /tux81run | 30 | tuxedo | Tuxedo 软件
host1 | bsx1lv | /bsx1 | 30 | bsx1 | 宝信 MES 应用程序
host1 | xcomlv | /xcom | 30 | xcom | 宝信 xcom 通信软件
host2 | ora10runlv | /ora10run | 60 | orarun | ORACLE 数据库软件
host2 | oradatalv | /oradata | 100 | orarun | 数据库
  • 路由规划表
节点名 | 目的 | 路由
host1 | default | 10.2.200.254
host2 | default | 10.2.200.254
  • HACMP 结构表

集群名 : test_cluster

适配器名 | 功能 | 网络名 | 网络类型 | 属性 | 节点名 | IP 地址
host1_tty0 | heartbeat | host1_net_rs232 | rs232 | serial | host1 |
host1_l2_boot1 | boot1 | host2_net_ether_2 | ether | public | host1 | 10.2.2.1
host1_l1_boot1 | boot1 | host2_net_ether_1 | ether | public | host1 | 10.2.1.1
host1_l2_svc | Service | host1_net_ether_2 | ether | public | host1 | 10.2.200.1
host1_l1_svc1 | Service | host1_net_ether_1 | ether | public | host1 | 10.2.100.1
host1_l1_svc2 | Service | host1_net_ether_1 | ether | public | host1 | 10.2.101.1
host1_l2_boot2 | boot2 | host1_net_ether_2 | ether | public | host1 | 10.2.12.1
host1_l1_boot2 | boot2 | host1_net_ether_1 | ether | public | host1 | 10.2.11.1
host2_tty0 | heartbeat | host2_net_rs232 | rs232 | serial | host2 |
host2_l2_boot1 | boot1 | host2_net_ether_2 | ether | public | host2 | 10.2.2.2
host2_l1_boot1 | boot1 | host2_net_ether_1 | ether | public | host2 | 10.2.1.2
host2_l2_svc | service | host2_net_ether_2 | ether | public | host2 | 10.2.200.2
host2_l1_svc1 | service | host2_net_ether_1 | ether | public | host2 | 10.2.100.2
host2_l1_svc2 | service | host2_net_ether_1 | ether | public | host2 | 10.2.101.2
host2_l2_boot2 | boot2 | host2_net_ether_2 | ether | public | host2 | 10.2.12.2
host2_l1_boot2 | boot2 | host2_net_ether_1 | ether | public | host2 | 10.2.11.2

图 1 HACMP 示意图

图 2 实验环境示意图

应用脚本起停设计

  • start_host1:

添加网关
运行 start_host1_app

  • stop_host1:

运行 stop_host1_app
清理 vg 进程

  • start_host2:

添加网关
运行 start_host2_app

  • stop_host2:

运行 stop_host1_app
清理 vg 进程

  • start_host1_app:

确认 host2 已启动
整理路由
启动主应用程序
启动通信程序

  • stop_host1_app:

停通信程序
停应用主程序
清理路由

  • start_host2_app:

如在 host1 机器上执行 stop_host1_app
启动 Oracle 数据库及监听程序
如在 host1 机器上执行 start_host1

  • stop_host2_app:

停数据库及监听程序

安装篇

规划

万事开头难，对于一个有经验的 HACMP 工程师来说，会深知规划的重要性，一个错误或混乱的规划将直接导致实施的失败和不可维护性。

HACMP 实施的根本目的不是安装测试通过，而是在今后运行的某个时刻突然故障中，能顺利的发生自动切换或处理，使得服务只是短暂中断即可自动恢复，使高可用性成为现实。

规划前的需求调研

在做规划之前，或者说一个准备实施 HACMP 来保证高可用性的系统初步设计之前，至少需要调查了解系统的以下相关情况，这些都可能影响到 HACMP 的配置。

  • 应用特点
    1. 对负荷的需求，如 CPU、内存、网络等特别是 I/O 的负载的侧重。
    2. 对起停的要求，如数据库重起可能需要应用重起等等。
    3. 对于自动化的限制，如重起需要人工判断或得到命令，需要在控制台执行。
  • 网络状况和规划

包括网段的划分、路由、网络设备的冗余等等在系统上线前的状况和可提供条件，以及实施运行过程中可能出现的变更。

  • 操作系统情况

目前 IBM 的 HACMP 除了 AIX，还支持 Linux。

目前新装机器都是 AIX5.3，即使安装 HA5.4 也没有问题。但如果安装可能是在老机器上进行升级，需要仔细了解操作系统版本及补丁情况。

  • 主机设计
    1. 可能实施的机器网卡的数量 , 网卡是否只能是双口或更多。
    2. 是否有槽位增加异步卡
    3. 主机之间的距离，这影响到串口线的长度。
    4. 预计实施高可用性的情况
  • 希望实施 HACMP 的机器数量

希望方式，如一备一，双机互备，一备多，环形互备等等。

HACMP 版本确定

IBM HACMP 自从出了 5.2 版本后，到了 5.205 后比较稳定，并经过我们自己充分的测试（见测试篇）和实践证明（已有多个系统成功自动切换）。目前考虑到 HA 5.3 的过渡性，HACMP V5.4 的补丁还不够，推荐版本为 HACMP V5.209。

IP 地址设计

IP 地址切换 (IPAT) 方式 有 3 种方式 :

图 3，4和 5 中描述了三个主要的 IPAT 配置场景。

  • 第一个拓扑模式 :IPAT via Replacement

在分开的子网中包含 boot 和 standby 网卡。当集群服务启动的时候 boot 地址被换成 service 地址。尽管这种方式有效性强，但是在需要实现多服务 IP 地址的环境下这种方式是不可取的。集群的管理员不得不利用 pre- 和 post-events 定制其环境建立额外的别名， 并且需要确认这些别名在下一次接管发生前被删除。

图 3 IPAT via Replacement

第二个拓扑模式：IPAT via Aliasing

HACMP 4.5 开始引入了 IPAT via Aliasing 作为缺省的拓扑模式。在这种新的模式中，standby 网卡的功能被另外一个 boot 网卡替换。子网需求的不同点是还需要一个另外的子网，每一个 boot 网卡需要它自己的子网，并且任何 service 或 persistent 的 IP 将在其本身的子网上操作，所以一共三个子网。当集群服务启动并且需要 service IP 的时候，boot IP 并不消失。这个设计和第一种是不同的，在同一个 HACMP 网络中有多个 service IP 存在并且通过别名来控制。

图 4 IPAT via Aliasing

第三种模式 :EthernetChannel（EC）

这种模式把底层的以太网卡藏到一个单一的“ent”接口之后。 该模式不是对前述任何一种方式的替换，而是可以和前述的任一种模式共同存在 。因为在每一个节点 EC 都被配置成冗余方式，可以在 HACMP 中使用 IP 别名定义它们每一个作为单一网卡网络。因为在每个节点只有一个网卡被定义，所以只有两个子网，一个是用作 boot（每个节点的基本 IP 地址），另一个是用于提供高可用服务。

图 5 IPAT via EthernetChannel

本文讨论 实际工作中使用最多的为第 2 种 : 别名方式 (IPAT via Aliasing)，逐步推荐第 3 种 。

这样设计时就需要注意以下事项：

  • 网段设计：
    一个服务地址需要 3 个网段对应，boot 地址网段不能和服务地址一致。避免网络变更造成的系统不可用，boot 地址的网段不要和实际其它系统的网段一致。在网段比较紧张的地方，建议设计时询问网络管理员。

举例来说，下面的地址将会由于网络变更后打通合一后 可能造成冲突 ：

设计人 | 机器名 | 服务地址 | boot1 地址 | boot2 地址
张三 | app1_db | 10.66.1.1 | 10.10.1.1 | 10.10.1.1
张三 | app1_app | 10.66.1.2 | 10.10.2.2 | 10.10.2.2
李四 | app2_db | 10.66.2.1 | 10.66.3.1 | 10.66.1.1
李四 | app2_app | 10.66.2.2 | 10.66.3.2 | 10.10.1.2
王五 | app3_db | 10.66.3.1 | 10.66.1.1 | 10.66.2.1
王五 | app3_app | 10.66.3.2 | 10.66.1.2 | 10.10.2.2
  • boot 地址的设计：
    不要和实际其它同网段机器的 boot 地址冲突，最好不同网段。即这个规划不能只考虑系统本身，还需要从同网段的高度考虑。

举例来说，下面的地址由于 2 个系统分开设计，同时开启将直接导致 2 个系统不可用。
boot 地址的设计表 1

设计人 | 机器名 | 服务地址 | boot1 地址 | boot2 地址
张三 | app1_db | 10.66.3.1 | 10.10.1.1 | 10.10.1.1
张三 | app1_app | 10.66.3.2 | 10.10.1.2 | 10.10.1.2
李四 | app2_db | 10.66.3.11 | 10.10.1.1 | 10.10.1.1
李四 | app2_app | 10.66.3.12 | 10.10.1.2 | 10.10.1.2

所以在设计时，我们建议 boot 地址的 IP 地址最后一段参照服务地址，这样虽然可记忆性不是很好，但即使设计在同一网段，也可以避免上述错误发生。更改设计如下：

boot 地址的设计表 2

设计人 | 机器名 | 服务地址 | boot1 地址 | boot2 地址
张三 | app1_db | 10.66.3.1 | 10.10.1.1 | 10.10.1.1
张三 | app1_app | 10.66.3.2 | 10.10.1.2 | 10.10.1.2
李四 | app2_db | 10.66.3.11 | 10.10.1.11 | 10.10.1.11
李四 | app2_app | 10.66.3.12 | 10.10.1.12 | 10.10.1.12

此外，如果是每个网卡多个网口，记得设计时必须注意同一网络的 boot 地址要分开到 2 块网卡，以保证真正的冗余。
心跳设计

配置 HACMP 的过程中，除了 TCP/IP 网络之外，您也可以在其它形式的网络上，如串行网络和磁盘总线上配置心跳网络。

  • TCP/IP 网络

优点：要求低，不需要任何额外硬件或软件，即可实现。
缺点：占用 IP 地址，不能避免由于 TCP/IP 的软件问题导致 HACMP 崩溃，系统不可用。

  • 串口网络

优点：真正实现高可用性，不占用 IP 地址。
缺点：需要硬件支持，对于 p5 机器，需要新增异步卡，而中低端的机器的插槽有限。

  • 磁盘心跳

优点 : 不占用插槽，磁盘总线上的心跳网络能够在 TCP/IP 网络资源有限的情况下提供额外的 HACMP 节点间的通信手段，并且能够防止 HACMP 节点之间由于 TCP/IP 软件出现问题而无法相互通信。
缺点：需要操作系统和存储支持，如使用增强型卷组，此外对于 I/O 读写负荷高的应用，也需要慎用。
正如 IBM 红皮书所说，条件许可的情况下，强烈推荐使用串口网络，其次是磁盘心跳。

资源组设计

对于 HACMP 来讲，服务 IP 地址和磁盘 VG、文件系统、应用服务器都是资源，如何规划需要根据实际情况来，包括以下内容：

资源组的数量即资源 ：一般情况下每台机器只要建立一个资源组即可，包括服务 IP 地址、应用服务器及 VG。但对于 2 节点的 oracle RAC 来讲，就需要 3 个，2 个 IP 和应用资源组，1 个并发 VG 资源组。

现在不推荐具体确定 VG 里的文件系统，这是因为确定后，有可能造成有些新增文件系统不在 HACMP 的控制范围，结果是 HACMP 切换时由于这些文件系统没有 unmount 掉而导致切换失败。

资源组的策略 : 分 failover( 故障切换 ) 和 fallbak（回切）。一般选缺省，当然你可以根据具体情况修正，如 oracle RAC 的并发 VG 资源组的选择就不一样。

磁盘及 VG 设计

虽然实际上 HACMP 是靠 PVID 来认磁盘的，但集群的机器上磁盘顺序不一，磁盘对应不一致会造成某种混乱。以致于安装配置和维护时很容易产生各种人为错误，所以我们强烈建议机器上看到的磁盘和 VG 名称都一一对应，此外 VG 的 MajorNumber 也需要预先设计规划，以免不一致。

用户及组设计

HA 要求所有切换需要用到的用户必须所有节点对应，ID 完全相同，用户运行的环境变量完全相同，即当系统切换时，对使用该用户的程序用户即组设置没有区别的。

如 host2 上 oracle 用户为 orarun，host1 上的 orarun 必须为切换保留，ID 均为 209，host1 上平时用的 oracle 用户就设为 orarunc。

逻辑卷和文件系统设计

HACMP 要求切换相关的文件系统和 lv 不能重名，如 host2 上 oracle 软件目录为 /ora10run，host1 上的 /ora10run 必须为切换保留，改为 /ora10runc。

此外，集群下相关的文件系统和 lv，在各个节点主机的定义也需要一致 , 如 /etc/filesystems 里是一致的，这个通过 importvg 或 HACMP 的 C-SPOC 来保证。

路由设计

对于有通信需求的主机，很可能对路由有一定要求，如本次实验环境，就有 2 个网段走的不是缺省路由，需要设计清楚，最后在起停脚本实现。

应用脚本设计

我们这里说的应用，是包括数据库在内除 OS 和 HACMP 之外的所有程序，对于应用程序的起停顺序和各种要求，都需要预先和应用人员加以沟通，并预先设计伪码，最终编写脚本实现。

准备

安装前提

  • 操作系统版本要求：

实验要求为 AIX5203 以上，实际 HA5.4 要求 AIX5301 和 AIX5206，具体安装时可查看以下安装版本的《High Availability Cluster Multi-Processing for AIX 5L Installation Guide》Prerequisites 一节。

  • 系统参数要求

作为集群的各个节点机，我们建议各个参数最好完全一致，需要注意的参数有：

    • 异步 I/O 服务进程配置（Asynchronous I/O servers）
    • 用户最大进程数
    • 系统时间
    • 用户缺省的 limits 参数
    • 其它可能影响应用的参数
  • 环境要求

此时，没有建立任何 HACMP 占用设计 ID 相关的用户和组，同样也没有建立 VG 和文件系统，包括名称冲突文件系统、lv 和 Major numver 冲突的 VG。

  • 用户和组确认

[host1][root][/]>lsuser -a id ALL
root id=0
daemon id=1
bin id=2
sys id=3
adm id=4
uucp id=5
……
[host2][root][/]>lsuser -a id ALL
root id=0
daemon id=1
……
  • 文件系统确认

[host1][root][/]>df -k
Filesystem 1024-blocks Free %Used Iused %Iused Mounted on
/dev/hd4 524288 487820 7% 3276 3% /
/dev/hd2 7077888 1868516 74% 91290 18% /usr
/dev/hd9var 524288 458364 13% 991 1% /var
/dev/hd3 917504 826700 10% 120 1% /tmp
/dev/hd1 655360 524856 20% 291 1% /home
/proc - - - - - /proc
/dev/hd10opt 1179648 589072 51% 11370 8% /opt
[host2][root][/]>df -k
…
  • 安装包要求：

RSCT 2.3.6.0 或更高版本。
使用以下命令进行确认：
lslpp –l|grep rsct
以下的包也是必须要安装的：

rsct.*
bos.adt.lib
bos.adt.libm
bos.adt.syscalls
bos.net.tcp.client
bos.net.tcp.server
bos.rte.SRC
bos.rte.libc
bos.rte.libcfg
bos.rte.libcur
bos.rte.libpthreads
bos.rte.odm

显示确认结果：

[host1][root][/]>lslpp -l rsct.*
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
rsct.basic.HACMP 2.4.4.0 COMMITTED RSCT Basic Function (HACMP/ES
Support)
rsct.basic.rte 2.4.4.0 COMMITTED RSCT Basic Function
rsct.basic.sp 2.4.4.0 COMMITTED RSCT Basic Function (PSSP
Support)
……
[host2][root][/]>lslpp -l rsct.*
……

如果您要安装并行的资源组（如 oracle RAC ），还要安装下面的包：
bos.rte.lvm.rte (5.2.0.25 or higher)
bos.rte.lvm.rte
bos.clvm.enh

软件安装

安装 HACMP5.2 ( 需要在所有节点上安装）
如果是光盘，请插入光盘 , 执行 smitty install_latest

Install Software
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* INPUT device / directory for software /dev/cd0
* SOFTWARE to install [_all_latest]
…..
ACCEPT new license agreements? yes
Preview new LICENSE agreements? no

如果是安装盘拷贝，请进入 cd installp/ppc 目录，smitty install_latest

Install Software
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* INPUT device / directory for software? .
* SOFTWARE to install [_all_latest]
…..
ACCEPT new license agreements? yes?
Preview new LICENSE agreements? No

安装结束后，会报 failed，检查除以下包没装上外，其它都已安装上
clluster.hativoli
clusterhaview
netwiew

打补丁

注意，请不要忽略给 HACMP 打补丁这一步骤。其实对 HACMP 来说，补丁是十分重要的。很多发现的缺陷都已经在补丁中被解决了。当严格的按照正确步骤安装和配置完 HACMP 的软件后，发现 takeover 有问题，IP 接管有问题，机器自动宕机等等千奇百怪的问题，其实大都与补丁有关。所以一定要注意打补丁这个环节。如 HACMP 为 5205 或补丁 IY73937。

使用 smitty install_latest 命令来安装：

IY53044 - Latest HACMP for AIX R510 Fixes as of January 2004
[host1][root][/soft_ins/ha52/patch]>ls
.toc cluster.es.cspoc.dsh.5.2.0.21.bff
cluster.adt.es.client.include.5.2.0.3.bff ……

安装结束后，仍会报 failed，检查除以下包没装上外，其它都已安装上：
cluster.doc.en_US.pprc
cluster.doc.en_US.websphere
cluster.es.ercmf
cluster.es.pprc
cluster.es.svcpprc
cluster.es.websphere
cluster.xd.glvm
补丁可在 IBM 网站下载 :
http://www-933.ibm.com/eserver/support/fixes/

图 6 补丁下载示意图

重启机器
记住一定要重起机器 , 否则安装将无法正常继续。

安装确认

1）确认 inittab：

#egrep "HA|clcomd" /etc/inittab
harc:2:wait:/usr/es/sbin/cluster/etc/harc.net # HACMP for AIX network startup
clcomdES:2:once:startsrc -s clcomdES >/dev/console 2>&1
clinit:a:wait:/bin/touch /usr/es/sbin/cluster/.telinit
# HACMP for AIX These must be the last entries of run level a in inittab!
pst_clinit:a:wait:/bin/echo Created /usr/es/sbin/cluster/.telinit > /dev/console
# HACMP for AIX These must be the last entries of run level a in inittab!

在 HACMP 5.1 以后的版本中 为了安全起见，不再使用 /.rhosts 文件来控制两台机器之间的命令和数据交换，而是引进的一个新的进程 clcomd 。如果你查看 /etc/inittab 文件就会发现安装完 HACMP 后，添加了一行：

clcomdES:2:once:startsrc -s clcomdES >/dev/console 2>&1 。

2）确认安装和补丁包：（着重确认 cluster.es.server.rte）

lslpp -l cluster.*
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
…..
cluster.es.server.rte 5.2.0.9 COMMITTED ES Base Server Runtime
……

3）确认进程

ps -ef |grep clcomd
root 115694 65676 0 Jun 07 - 2:09 /usr/es/sbin/cluster/clcomd -d

总结

本部分主要对 HACMP 的规划和设计进行了详尽的描述，对于 HACMP 的实施，实际是相当重要和具有实用价值的。同时，还对准备和安装部分进行了论述，也是实际 HACMP 实施的整理和总结，相信对大家有所帮助。后面将对 HACMP 的配置进行专门论述，从而形成完整的实施步骤。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/0804_xinmin_hacmp/1.html

Top


HACMP 5.x 完全手册，第 2 部分：测试和维护

测试部分
虽然 HACMP 提供了自动化测试工具 test tool，使用起来也较为简单。但个人认为由于 HACMP 的完整测试是一个比较复杂的事情，工具还不能说非常成熟，也无法模拟交换机等故障，所以只能提供协助，不能完全依靠，结果仅供参考。
测试方法说明：

  1. ping 测试：从 client 同时发起，每次 1024 个字节，延续 10 分钟。
  2. ping 长测试：每次 1024 个字节，延续 24 小时。
  3. 应用测试：利用自动化测试工具持续从 client 连接应用服务使用查询。
  4. 应用长测试 :48 小时内，进行应用测试使用。
  5. telnet 测试：telnet 连接后根据情况确认。

标准测试
这个测试为必须完成的测试，每个网段都要做一次，阶段一般为初始配置阶段，运维定修阶段。

标准测试表

序号 | 测试步骤 | 系统结果 | 应用结果
1 | 拔掉 host1 的服务 IP 的网线 | 地址漂移到另一个网卡 | 中断 30s 左右可继续使用
2 | 拔掉 host1 剩下的一根网线 | 发生切换 | 中断 5 分钟左右可继续使用
3 | 拔掉 host2 的服务 IP 网线 | 所有服务地址漂到另一个网卡 | 中断 30s 左右可继续使用
4 | 恢复所有网线 | 地址 join，clstat 可看到所有节点均 恢复原始状态。 | 无影响
5 | 在 host2 上执行 ha1t -q | host2 机宕机，切换到 host1 机 | 中断 5 分钟左右可继续使用
 | 启动 host2 恢复原始状态 |  |
1 | 拔掉 host2 的服务 IP 网线 | 地址漂另一个网卡 | 中断 30s 左右可继续使用
2 | 拔掉 host2 的剩下一根的网线 | 发生切换 | 中断 5 分钟左右可继续使用
3 | 拔掉 host1 的服务 IP 网线 | 所有服务地址漂到另一网卡 | 中断 30s 左右可继续使用
4 | 恢复所有网线 | 地址 join，clstat 可看到均 up | 无影响
5 | 在 host1 上执行 halt -q | host1 机宕机，切换到 host2 机 | 中断 5 分钟左右可继续使用

完全测试
完全测试在有充分测试时间和测试条件（如交换机可参与测试）下进行，阶段一般为系统上线前一周。
注意：考虑到下表的通用性，有 2 种情况没有细化，需要注意。

  1. 同一网络有 2 个服务 IP 地址，考虑到负载均衡， 将自动分别落在 boot1、boot2 上 ，这样不论那个网卡有问题，都会发生地址漂移。
  2. 应用中断没有加入应用的重新连接时间，如 oracleDB 发生漂移，实际 tuxedo 需要重新启动才可继续连接，这个需要起停脚本来实现。

完全测试表

序号 | 测试场景 | 系统结果 | 应用结果 | 参考时长
 | 功能测试 |  |  |
1 | host2 起 HA | host2 服务 IP 地址生效，vg、文件系统生效 | host2 app(db) 启动 OK | 120s
2 | host2 停 HA | host2 服务 IP 地址、vg 释放 | host2 app 停止 | 15s
3 | host1 起 HA | host1 服务 IP 地址生效，vg、文件系统生效 | host1 app 启动 OK | 120s
4 | host1 停 HA | host1 网卡、vg 释放 | host2 app 停止 | 15s
5 | host2 takeover 到 host1 | host2 服务地址切换到 host1 的 boot2 和 vg 切换到 host1 | host2 app 短暂中断 | 30s
 | host2 clstart | 恢复原状 | host2 app 短暂中断 | 120s
6 | host1 takeover 到 host2 | host1 服务地址切换到 host2 的 boot2 和 vg 等切换到 host2 | host1 app 短暂中断 | 30s
 | host1 clstart | 恢复原状 | host1 app 短暂中断 | 120s
 | 网卡异常测试 |  |  |
1 | host2 断开 boot1 网线 | host2 的服务 IP 从 boot1 漂移至 boot2 | host2 app 短暂中断 | 30s
 | host2 恢复 boot1 网线连接 | host2 boot1 join | 无影响 | 40s
2 | host2 断开 boot2 网线 | host2 的服务 IP 从 boot2 漂移至 boot1 | host2 app 短暂中断 | 30s
 | host2 恢复 boot2 网线连接 | host2 boot1 join | 无影响 | 40s
3 | host2 断开 boot1、boot2 网线 | host2 服务地址切换到 host1 的 boot2 上，vg 等切换到 host1 | host2 app 短暂中断 | 210s
 | host1 再断开 boot2 网线， | host2 的服务 IP 漂移到 host1 的 boot1 | host2 app 短暂中断 | 30s
 | host2 恢复 boot1、boot2 网线连接 | host2 boot1，boot 2join | 无影响 | 30s
 | host2 clstart | 恢复原状 | host2 app 短暂中断开 | 120s
4 | host1 断开 boot1、boot2 网线 | host1 服务地址切换到 host2 的 boot2 上，vg 等切换到 host2 | host1 app 短暂中断 | 210s
 | host2 再断开 boot2 网线， | host1 的服务 IP 漂移到 host2 的 boot1 | host1 app 短暂中断 | 30s
 | host1 恢复 boot1、boot2 网线链接 | host1 boot1，boot 2join | 无影响 | 30s
 | host2 clstart | 恢复原状 | host2 app 短暂中断 | 120s
5 | host2 force clstop | cluster 服务停止，IP、vg 资源无反应 | 无影响 | 20s
 | host2 clstart | 恢复原状 | 无影响 | 20s
6 | host1 force clstop | cluster 服务停止，IP、vg 资源无反应 | 无影响 | 20s
 | host1 clstart | 恢复原状 | 无影响 | 20s
7 | host2,host1 boot2 网线同时断开 30mins | boot2 failed | 无影响 | 20s
 | host2,host1 boot2 网线恢复 | boot2 均 join | 无影响 | 20s
8 | host2,host1 boot1 网线同时断开 30mins | 服务 IP 地址均漂移到 boot2 上。 | host1,host2 app 短暂中断 | 30s
 | host2,host1 boot1 网线恢复 | boot1 均 join | 无影响 | 20s
 | 主机宕机测试 |  |  |
1 | host2 突然宕机 halt -q | host2 服务地址切换到 host1 的 boot2 和 vg 等切换到 host1 | host2 app 短暂中断 | 30s
 | host2 clstart | 恢复原状 | host2 app 短暂中断 | 120s
2 | host1 突然宕机 halt -q | host1 服务地址切换到 host2 的 boot2 和 vg 等切换到 host2 | host1 app 短暂中断 | 30s
 | host1 clstart | 恢复原状 | host1 app 短暂中断 | 120s
 | 交换机异常测试 |  |  |
1 | SwitchA 断电 | 服务 IP 地址均漂移到 boot2 上 | host1、host2 app 短暂中断 | 50s
 | SwitchA 恢复 | boot1 join | 无影响 | 40s
 | SwitchB 断电 | 服务 IP 地址均漂移回 boot1 上 | host1、host2 app 短暂中断 | 50s
 | SwitchB 恢复 | boot2 join | 无影响 | 40s
2 | SwitchB 断电 | boot2 failed | 无影响 | 50s
 | SwitchB 恢复 | boot2 join | 无影响 | 40s
 | SwitchA 断电 | 服务 IP 地址均漂移到 boot2 上。 | host1、host2 app 短暂中断 | 50s
 | SwitchA 恢复 | boot1 join | 无影响 | 40s
3 | SwitchA，B 同时断电 10mins | network 报 down，其他一切不动。 | host1、host2 app 中断 | 10min
 | SwitchA，B 恢复 | boot1，boot2 join | 服务自动恢复 | 50s
4 | SwitchA 断电 | 服务 IP 地址均漂移到 boot2 上 | host1、host2 app 短暂中断 | 50s
 | 30s 后 B 也断电 | 不动 | host1、host2 app 中断 | 50s
 | SwitchA，B 恢复 | boot1 join | 自动恢复 | 40s
5 | SwitchB 断电 | boot2 failed | 无影响 | 50s
 | 30s 后 A 也断电 | network 报 down，其他一切不动。 | host1、host2 app 中断 | 50s
 | SwitchA，B 恢复 | boot1 join | 自动恢复 | 40s
6 | SwitchA 异常（对接网线触发广播风暴） | 机器本身正常，但网络不通 | host1、host2 app 中断 | 20s
 | SwitchA 恢复 | 恢复后一切正常 | 自动恢复 |
7 | SwitchB 异常（对接网线触广播风暴） | 机器本身正常，但网络不通 恢复后一切正常 | host1、host2 app 中断 | 20s
 | SwitchB 恢复 |  | 自动恢复 |
8 | SwitchA，B 同时异常（对接网线触广播风暴） | 机器本身正常，但网络丢包严重， | host1、host2 app 中断 | 10s
 | SwitchA，B 恢复 | 恢复后一切正常 | 自动恢复 | 20s
 | 稳定性测试 |  |  |
1 | host2， host1 各起 HA |  | 正常服务 |
2 | host2 takeover 切换 host1 |  | 正常服务 |
3 | host1 takeover 到 host2 |  | 正常服务 |

运维切换测试：
运维切换测试是为了在运维过程中，保证高可靠性加以实施。建议每年实施一次。因为这样的测试实际是一种演练，能够及时发现各方面的问题，为故障期间切换成功提供有效保证。

运维切换测试表

场景 |  | 建议时长 | 切换方式
主备（run->dev） | 主切换到备机 | >10 天 | 备机开发测试停用或临时修改 HA 配置
互备（app <->db,app<->app,db<->db） | 互相切换 | >30 天 | 手工互相交叉启动资源组

主机切换到备机：
有 2 种方式：

  • 可用 takeover 方式 , 但由于负荷和防止误操作的原因，备机的开发测试环境一般需要停用。
  • 也可通过修改 HA 的配置，将备机资源组的节点数增加运行节点。这样可以在切换测试期间继续使用开发测试环境。但这样不光要对 HA 有所改动。还要预先配置时就要保证备机开发测试环境也不是放在本地盘上，需要放在共享 vg 里，此外还要同步开发测试的环境到运行机。建议最好在设计时就有这样的考虑。

手工互相切换：
停掉资源组：
smitty hacmp->System Management (C-SPOC)
-> HACMP Resource Group and Application Management
->Bring a Resource Group Offline 选择 host2_RG,host2

Bring a Resource Group Offline
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Resource Group to Bring Offline host2_RG
Node On Which to Bring Resource Group Offline host2
Persist Across Cluster Reboot? false

同样停掉 host1_RG
互换资源组：
smitty hacmp->System Management (C-SPOC)
-> HACMP Resource Group and Application Management
->Bring a Resource Group Online 选择 host2_RG,host1

Resource Group to Bring Online host2_RG
Node on Which to Bring Resource Group Online host1

Persist Across Cluster Reboot 回答 No。
即在 host1 上启动 host2 的资源组，同样方法在 host2 上启动 host1 资源组。这样 2 台机器就实现了互换。
注意： 由于互切需要人工干预，恢复原状也要人工干预，所以切换期间需要密切监控运行状况，如方便出现有异常时，能立刻人工处理。
互换 crontab 及相关后台脚本：
由于备份作业等 crontab 里的后台作业会有所不同，所以需要进行互换，按我们的做法只需拷贝相应 crontab 的配置文件即可。
[host1][root][/]>cp /home/scripts/host2/crontab_host2 /var/spool/cron/crontabs/root
修改文件属性：
[host1][root][/]>chown root:cron /var/spool/cron/crontabs/root
[host1][root][/]>chmod 600 /var/spool/cron/crontabs/root
重起 crontab:
[host1][root][/]> ps -ef|grep cron
root 278688 1 0 Dec 19 - 0:02 /usr/sbin/cron
[host1][root][/]>kill -9 278688
如果不采用我们脚本的做法，除需要拷贝对方的 crontab 外，还要记得同步相应脚本。
互换备份策略：
由于备份方式不同，可能所作的调整也不一样，需要具体系统具体对待。实验环境中的备份采用后台作业方式，无须进一步处理。实际环境中可能采用备份软件，由于主机互换了，备份策略是否有效需要确认，如无效，需要做相应修正。
维护部分
作为高可用性的保证，通过了配置和测试之后，系统可以成功上线了，但不要忘记，HACMP 也需要精心维护才能在最关键的时刻发生作用，否则不光是多余的摆设，维护人员会由于“已经安装好 HA 了，关键时刻自然会发生作用”的想法反而高枕无忧，麻痹大意。
我们统计了以往遇到的切换不成功或误切换的场景，编制了测试成功切换却失败的原因及对策，如下表：

HACMP 切换问题表

故障现象 | 原因 | 根本原因 | 对策
无法切换 1 | 测试一段时间后两边 HA 不同步 | 没通过 HA 的功能（含 C-SPOC）进行用户、文件系统等系统变更。 | 制定和遵守规范，定期检查，定修及时处理
无法切换 2 | 应用停不下来，导致超时，文件系统不能 umount | 停止脚本问题 | 规范化增加 kill_vg_user 脚本
切换成功但应用不好用 | 应用启动异常 | 应用有变动，停止脚本异常停止或启动脚本不正确 | 规范化和及时更新起停脚本
切换成功但应用不好用 | 备机配置不符合运行要求 | 各类系统和软件参数不合适 | 制定检查规范初稿，通过运维切换测试检查确认。
切换成功但通信不好用 1 | 网络路由不通 | 网络配置原因 | 修正测试路由，通过运维切换测试检查确认。
切换成功但通信不好用 2 | 通信软件配置问题 | 由于一台主机同时漂移同一网段的 2 个服务地址，通信电文从另一个 IP 地址通信，导致错误 | 修正配置，绑定指定服务 IP。
误切换 | DMS 问题 | 系统负荷持续过高 | 参见《脚本和经验》部分。

注意：请记住，对于客户来说，不管什么原因，“应用中断超过了 5-10 分钟，就是 HACMP 切换不成功”，也意味着前面所有的工作都白费了，所以维护工作的重要性也是不言而谕的。
强制方式停掉 HACMP:
HACMP 的停止分为 3 种，graceful（正常），takeover（手工切换），force（强制）。
下面的维护工作，很多时候需要强制停掉 HACMP 来进行，此时资源组不会释放，这样做的好处是，由于 IP 地址、文件系统等等没有任何影响，只是停掉 HACMP 本身，所以应用服务可以继续提供，实现了在线检查和变更 HACMP 的目的。

[host1][root][/]>smitty clstop
Stop Cluster Services
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
* Stop now, on system restart or both now
Stop Cluster Services on these nodes [host1]
BROADCAST cluster shutdown? true
* Shutdown mode forced

一般所有节点都要进行这样操作。
强制停掉后的 HACMP 启动 :
在修改 HACMP 的配置后，大多数情况下需要重新申请资源启动，这样才能使 HACMP 的配置重新生效。

[host1][root][/]>smitty clstart
Start Cluster Services
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Start now, on system restart or both now
Start Cluster Services on these nodes [bgbcb04]
BROADCAST message at startup? true
Startup Cluster Information Daemon? false
Reacquire resources after forced down ? true

日常检查及处理
为了更好地维护 HACMP，平时的检查和处理是必不可少的。下面提供的检查和处理方法除非特别说明，均是不用停机，而只需停止应用即可进行，不影响用户使用。不过具体实施前需要仔细检查状态，再予以实施。
当然，最有说服力的检查和验证是通过”运维切换测试“。
clverify 检查
这个检查可以对包括 LVM 的绝大多数 HACMP 的配置同步状态，是 HACMP 检查是否同步的主要方式。
smitty clverify -> Verify HACMP Configuration

Verify Cluster
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Base HACMP Verification Methods both
(Cluster topology, resources, both, none)
Custom Defined Verification Methods []
Error Count []
Log File to store output []
Verify changes only? [No]
Logging [Standard]

回车即可
经过检查，结果应是 OK。如果发现不一致，需要区别对待。对于非 LVM 的报错，大多数情况下不用停止应用，可以用以下步骤解决：

  1. 先利用强制方式停止 HACMP 服务。

同样停止 host2 的 HACMP 服务。

  1. 只检查出的问题进行修正和同步 ：

smitty hacmp -> Extended Configuration-> Extended Verification and Synchronization
这时由于已停止 HACMP 服务，可以包括”自动修正和强制同步 “。
对于 LVM 的报错，一般是由于未使用 HACMP 的 C-SPOC 功能，单边修改文件系统、lv、VG 造成的，会造成 VG 的 timestamp 不一致。这种情况即使手工在另一边修正（通常由于应用在使用，也不能这样做），如何选取自动修正的同步，也仍然会报 failed。此时只能停掉应用，通过整理 VG 来解决。
cldump 检查：
cldump 的监测为将当前 HACMP 的状态快照，确认显示为 UP，STABLE。

[host1][root][/]>/usr/sbin/cluster/utilities/cldump
____________________________________________________________________________
Cluster Name: test_cluster
Cluster State: UP
Cluster Substate: STABLE
_____________________________________________________________________________

Node Name: host1 State: UP
Network Name: net_ether_01 State: UP
Address: 10.2.100.1 Label: host1_l1_svc1 State: UP
Address: 10.2.101.1 Label: host1_l1_svc2 State: UP
Address: 10.2.1.1 Label: host1_l1_boot1 State: UP
Address: 10.2.11.1 Label: host1_l1_boot2 State: UP
Network Name: net_ether_02 State: UP
Address: 10.2.200.1 Label: host1_l2_svc State: UP
Address: 10.2.2.1 Label: host1_l2_boot1 State: UP
Address: 10.2.12.1 Label: host1_l2_boot2 State: UP

Node Name: host2 State: UP
Network Name: net_ether_01 State: UP
Address: 10.2.100.2 Label: host2_l1_svc1 State: UP
Address: 10.2.101.2 Label: host2_l1_svc2 State: UP
Address: 10.2.1.2 Label: host2_l1_boot1 State: UP
Address: 10.2.11.2 Label: host2_l1_boot2 State: UP
Network Name: net_ether_02 State: UP
Address: 10.2.200.2 Label: host2_l2_svc State: UP
Address: 10.2.2.2 Label: host2_l2_boot1 State: UP
Address: 10.2.12.2 Label: host2_l2_boot2 State: UP

Cluster Name: test_cluster

Resource Group Name: host1_RG
Startup Policy: Online On Home Node Only
Fallover Policy: Fallover To Next Priority Node In The List
Fallback Policy: Fallback To Higher Priority Node In The List
Site Policy: ignore
Node State
--------------- ---------------
host1 ONLINE
host2 OFFLINE

Resource Group Name: host2_RG
Startup Policy: Online On Home Node Only
Fallover Policy: Fallover To Next Priority Node In The List
Fallback Policy: Fallback To Higher Priority Node In The List
Site Policy: ignore
Node State
--------------- ---------------
host2 ONLINE
host1 OFFLINE

clstat 检查
clstat 可以实时监控 HACMP 的状态，及时确认显示为 UP，STABLE

[host1][root][/]>/usr/sbin/cluster/clstat
注：如果没有反应，运行 clinfo

clstat - HACMP Cluster Status Monitor
-------------------------------------
Cluster: test_cluster (1145945461)
Sun Jul 2 16:54:16 BEIST 2006
State: UP Nodes: 2
SubState: STABLE

Node: host1 State: UP
Interface: host1_l2_boot1 (1) Address: 10.2.2.1
State: UP
Interface: host1_l1_boot1 (1) Address: 10.2.1.1
State: UP
Interface: host1_l1_boot2 (2) Address: 10.2.11.1
State: UP
Interface: host1_l2_boot2 (2) Address: 10.2.12.1
State: UP
Interface: host1_tty0_01(0) Address: 0.0.0.0
State: UP
Interface: host1_l1_svc1 (2) Address: 10.2.100.1
State: UP
Interface: host1_l1_svc2(2) Address: 10.2.101.1
State: UP
Interface: host1_l2_svc (2) Address: 10.2.200.1
State: UP
Resource Group: host1_RG State: On line

Node: host2 State: UP
Interface: host2_l2_boot1 (1) Address: 10.2.2.2
State: UP
Interface: host2_l1_boot1 (1) Address: 10.2.1.2
State: UP
Interface: host2_l1_boot2 (2) Address: 10.2.11.2
State: UP
Interface: host2_l2_boot2 (2) Address: 10.2.12.2
State: UP
Interface: host2_tty0_01(0) Address: 0.0.0.0
State: UP
Interface: host2_l1_svc1 (2) Address: 10.2.100.2
State: UP
Interface: host2_l1_svc2(2) Address: 10.2.101.2
State: UP
Interface: host2_l2_svc (2) Address: 10.2.200.2
State: UP
Resource Group: host2_RG State: On line

/etc/hosts 环境检查
正常情况下，2 台互备的 /etc/hosts 应该是一致的，当然如果是主备机方式，可能备机会多些 IP 地址和主机名。通过对比 2 个文件的不同，可以确认是否存在问题。

[host1][root][/]>rsh host2:/etc/hosts >/tmp/host2_hosts
[host1][root][/]>diff /etc/hosts /tmp/host2_hosts

脚本检查
需要注意以下事项：

      1. 应用的变更需要及时修正脚本，两边的脚本需要及时同步，并及时申请时间测试。
      2. 上一点需要维护人员充分与应用人员沟通，运行环境的任何变更必须通过维护人员实施。
      3. 维护人员启停应用要养成使用这些脚本启停的习惯，尽量避免手工启停。

[host1][root][/home/scripts]>rsh host2
"cd /home/scripts;ls -l host1 host2 comm" >/tmp/host2_scripts
[host1][root][/home/scripts]> ls -l host1 host2 comm" >/tmp/host1_scripts
[host1][root][/]>diff /tmp/host1_scripts /tmp/host2_scripts

用户检查
正常情况下，2 台互备的 HA 使用到的用户情况应该是一致的，当然如果是主备机方式，可能备机会多些用户。通过对比 2 节点的不同，可以确认是否存在问题。

[host1][root][/]>rsh host2 lsuser -f orarun,orarunc,tuxrun,bsx1,\
xcom >/tmp/host2_users
[host1][root][/]> lsuser -f orarun,orarunc,tuxrun,bsx1,\
xcom >/tmp/host1_users >/tmp/host1_users
[host1][root][/]>diff /tmp/host1_user /tmp/host2_user

注：两边的必然有些不同，如上次登录时间等等，只要主要部分相同就可以了。
还有两边 .profile 的对比，用户环境的对比。

[host1][root][/]>rsh host2 su - orarun -c set >/tmp/b
[host1][root][/]> su - orarun -c set >/tmp/a
[host1][root][/]>diff /tmp/a /tmp/b

tty 心跳检查
由于心跳在 HACMP 启动后一直由 HACMP 在使用，所以需要强制停掉 HACMP 进行检查。

  • 察看 tty 速率

确认速率不超过 9600

[host1][root][/]>stty -a </dev/tty0
[host2][root][/]>cat /etc/hosts >/dev/tty0
host1 上显示
speed 9600 baud; 0 rows; 0 columns;
eucw 1:1:0:0, scrw 1:1:0:0:
…
  • 检查连接和配置

[host1][root][/]>host1: cat /etc/hosts>/dev/tty0
[host2][root][/]>host2:cat</dev/tty0

在 host2 可看到 host1 上 /etc/hosts 的内容。

同样反向检测一下。

errpt 的检查
虽然有了以上许多检查，但我们最常看的 errpt 不要忽略，因为有些报错，需要大家引起注意，由于 crontab 里 HACMP 会增加这样一行：

0 0 * * * /usr/es/sbin/cluster/utilities/clcycle 1>/dev/null 2>/dev/null
# HACMP for AIX Logfile rotation

即实际上每天零点，系统会自动执行 HACMP 的检查，如果发现问题，会在 errpt 看到。
除了 HACMP 检查会报错，其他运行过程中也有可能报错，大都是由于心跳连接问题或负载过高导致 HACMP 进程无法处理，需要引起注意，具体分析解决。

变更及实现
由于维护的过程出现的情况远比集成实施阶段要复杂，即使红皮书也不能覆盖所有情况。这里只就大家常见的情况加以说明，对于更为复杂或者更为少见的情况，还是请大家翻阅红皮书，实在不行计划停机重新配置也许也是一个快速解决问题的笨方法。
这里的变更原则上是不希望停机，但实际上 HACMP 的变更，虽然说部分支持 DARE（dynamic reconfiguration），绝大部分操作支持 Force stop 完成， 我们还是希望有条件的话停机完成。
对于 DARE，我不是非常赞成使用，因为使用不当会造成集群不可控，危险性更大。我一般喜欢使用先强制停止 HACMP，再进行以下操作 , 结束同步确认后再 start HACMP。
卷组变更 - 增加磁盘到使用的 VG 里 :
注意，pvid 一定要先认出来，否则盘会没有或不正常。

  1. 集群的各个节点机器运行 cfgmgr，设置 pvid

[host1][root][/]>cfgmgr
[host1][root][/]>lspv
….
hdisk2 00c1eedf6ddb9f5e host1vg
hdisk3 00c1eedffa577b0e host2vg
hdisk4 none none
[host1][root][/]>chdev -l hdisk2 -a pv=yes
[host1][root][/]>lspv
….
hdisk4 00c1eedffc677bfe none

在 host2 上也要做同样操作。

  1. 运行 C-SPOC 增加盘到 host2vg:

smitty hacmp->System Management (C-SPOC)-> HACMP Logical Volume Management
->Shared Volume Groups-> Set Characteristics of a Shared Volume Group
->Add a Volume to a Shared Volume Group 选择节点 VG 和磁盘增加即可

Resouce Group Name host2_RG
VOLUME GROUP name hostvg
Reference node host2
VOLUME names hdisk4

完成后两边都可看到
hdisk3 00c1eedffa577b0e host2vg
hdisk4 00c1eedffc677bfe host2vg

lv 变更
lv 的变更不多，可以变更的部分如下：
smitty hacmp->System Management (C-SPOC)-> HACMP Logical Volume Management
->Show Characteristics of a Shared Logical Volume-> Shared Logical Volumes
->Change a Shared Logical Volume 选择 lv

* Resource Group Name host2_RG

MAXIMUM NUMBER of PHYSICAL VOLUMES [8]
[/ora10runc]
MAXIMUM NUMBER of LOGICAL PARTITIONS [512]

裸设备增加空间：
smitty hacmp->System Management (C-SPOC)-> HACMP Logical Volume Management
-> Shared Logical Volumes->Set Characteristics of a Shared Logical Volume
-> Increase the Size of a Shared Logical Volume

[Entry Fields]
Resource Group Name rac2_RG
LOGICAL VOLUME name XWFTPlv
Reference node rac2
* Number of ADDITIONAL logical partitions [100]
PHYSICAL VOLUME names hdisk3
POSITION on physical volume outer_middle
RANGE of physical volumes minimum
MAXIMUM NUMBER of PHYSICAL VOLUMES []
to use for allocation
Allocate each logical partition copy superstrict
on a SEPARATE physical volume?
File containing ALLOCATION MAP []

文件系统变更
smitty hacmp->System Management (C-SPOC)-> HACMP Logical Volume Management
->Shared File Systems->Enhanced Journaled File Systems
->Change / Show Characteristics of a Shared Enhanced Journaled File System

Resource Group Name bg595b02_RG
File system name /cube
NEW mount point [/cube]
SIZE of file system [6291456]
Mount GROUP []
PERMISSIONS read/write
Mount OPTIONS []
Start Disk Accounting? no
Block Size (bytes) 4096
Inline Log? no
Inline Log size (MBytes) 0

服务 IP 地址变更
增加服务 IP 地址

  1. 修改 /etc/hosts, 增加以下行

10.66.201.1 host1_l2_svc2
10.66.201.2 host2_l2_svc2
HACMP 新增服务 IP
smitty hacmp-> Extended Configuration-> HACMP Extended Resources Configuration
-> Configure HACMP Service IP Labels/Addresses
-> Add a Service IP Label/Address-> Configurable on Multiple Nodes 选择网络

Add a Service IP Label/Address configurable on Multiple Nodes (extended)

Type or select values in entry fields.
Press Enter AFTER making all desired changes.
* IP Label/Address host1_svc2
* Network Name net_ether_01
Alternate HW Address to accompany IP Label/Address []
同样增加 host2_svc2
  1. 修正资源组

smitty hacmp->Extended Configuration->Extended Resource Configuration
->HACMP Extended Resource Group Configuration
->Change/Show Resources and Attributes for a Resource Group

Type or select values in entry fields.
Press Enter AFTER making all desired changes.

[Entry Fields]
Resource Group Name eai1d0_RG
Participating Nodes (Default Node Priority) bgbcb11 bgbcb04

Startup Policy Online On Home Node Only
Fallover Policy Fallover To Next Priority
Node In The List
Fallback Policy Fallback To Higher Priority
Node In The List
Fallback Timer Policy (empty is immediate) []
Service IP Labels/Addresses [host1_svc host1_svc2]
  1. HACMP 同步

需要同步，参见第 2 部分的“检查和同步 HACMP 配置”一节。

  1. HACMP 启动

注意修改启动参数使得启动时重新申请资源，触发新增服务 IP 生效。
这时 netstat -in，可以看到地址生效了。
修改服务 IP 地址
如果要修改应用服务使用的 IP 地址，自然是需要停止应用来进行的。比如要将原地址 10.2.200.x 改为 10.2.201.x，路由改为 10.2.201.254 步骤如下：

  1. 正常停止 HACMP

smitty clstop ->graceful

  1. 所有节点修改 /etc/hosts 将服务地址修改为需要的地址

10.2.201.1 host1_l2_svc host1
10.2.201.2 host2_l2_svc host2

  1. 修改启动脚本的路由部分（如果需要）

GATEWAY=10.2.201.254

  1. 在一个节点修改 HACMP 的配置

smitty hacmp->Extended Configuration-> HACMP Extended Resources Configuration
->Configure HACMP Service IP Labels/Addresses
->Change/Show a Service IP Label/Address 选择 host1_l2_svc
不做修改 ，直接回车即可，同样修改 host2 璤 l2_svc。
smitty hacmp->Extended Configuration->Extended Resource Configuration
->HACMP Extended Resource Group Configuration
->Change/Show Resources and Attributes for a Resource Group
->Change/Show All Resources and Attributes for a Resource Group 选择 host1_RG
不做修改 ，直接回车即可，同样修改 host2 璤 RG

  1. 同步 HACMP。
  1. 重新启动 HACMP 并确认。

注意修改启动参数使得启动时重新申请资源，触发新服务 IP 地址生效。
注意： 如果修改的不是应用服务要用的地址，或者修改期间对该地址的服务可以暂停，则可以将步骤 1 改为强制停止，增加第 7 步。整个过程可以不停应用服务。
7. 去除原有服务 IP 地址
netstat -in 找到该服务 IP 地址所在网卡 en2。然后执行：
ifconfig en2 alias delete 10.2.200.1
boot 地址变更

  1. smitty tcpip 修改网卡的地址
  2. 修改 /etc/hosts 的 boot 地址
  3. 修改 HACMP 配置

smitty hacmp ->Extended Configuration-> Extended Topology Configuration
-> Extended Topology Configuration

Change/Show a Communication Interface
Node Name [bgbcb04]
Network Interface en1
IP Label/Address bgbcb04_boot1
Network Type ether
* Network Name [net_ether_01]

不做修改 ，直接回车即可，同样修改其他 boot 地址。

  1. 同步 HACMP
  2. 重新启动 HACMP 确认

注意：修改启动参数使得启动时重新申请资源，触发新 boot IP 地址生效，否则 clstat 看到的 boot 地址将是 down。
用户变更
修改用户口令
由于安全策略的原因，系统可能需要更改口令，利用 HACMP 会方便不少，也避免切换过去后因时隔太久，想不起口令需要强制修改的烦恼。
唯一设计不合理的是，必须 root 才能使用这个功能。
smitty hacmp ->Extended Configuration-> Security and Users Configuration
-> Passwords in an HACMP cluster
-> Change a User's Password in the Cluster

Selection nodes by resource group host2_RG
*** No selection means all nodes! ***
* User NAME [orarun]
User must change password on first login? false

此时需要你输入新口令更改：

COMMAND STATUS

Command: running stdout: no stderr: no
Before command completion, additional instructions may appear below.
orarun's New password:
Enter the new password again:
OK 即成功

修改用户属性
以下步骤可变更用户属性，值得注意的是，虽然可以直接修改用户的 UID，但实际上和在单独的操作系统一样， 不会自动修改该用户原有的文件和目录的属性，必须事后自己修改 ，所以建议 UID 在规划阶段就早做合理规划。
smitty hacmp ->Extended Configuration-> Security and Users Configuration
->Users in an HACMP cluster
-> Change / Show Characteristics of a User in the Cluster
选择资源组和用户
除开头 1 行，其他使用均等同于独立操作系统。

Change User Attributes on the Cluster
Resource group eai1d0_RG
* User NAME test
User ID [301]
ADMINISTRATIVE USER? false

….
小结
本部分主要对 HACMP 的测试和日常维护进行了较为详尽的描述，基本上是我们的实际工作总结，相信读者可以从中得到启发，对日常 HACMP 的维护相信很有帮助。后面一部分将论述富有特色的脚本管理和特殊情况下的经验总结，这部分几乎没有看到在以往资料中提及，相信大家也会感兴趣。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/0804_xinmin_hacmp/3.html

Top


HACMP 5.x 完全手册，第 3 部分：脚本设计和经验共享

脚本部分
HACMP 的作用在于关键时刻能根据发生的情况自动通过预先制定好的策略进行相应的操作，如切换。使得用户经过短暂的中断即可继续使用服务。而对于用户来说，“服务可用”才是 HACMP 切换成功的标志，而这一点不光是 HACMP 配置本身，还大大倚赖于启停脚本的可用性。
自 IBM 的 HACMP5205 以后，趋于稳定，BUG 很少。这使得 HACMP 切换不成功的主要原因集中在启停脚本的问题上。而很多时候，脚本的问题是非常隐蔽和难以测试的，所以在编写启停脚本时需要考虑周全，系统上线后要仔细维护。
通过多年的实践，我们形成了自己的一套脚本编制方式，共享出来，供大家参考。
脚本规划
启停方式
对于启动脚本，完全放在后台，不影响 HACMP 的切换。
对于停止脚本，通过后台启动，前台检查的方式进行，并使用清理 VG 的进程，确保停止成功。
由于启停是由启停各个部件启动组成的，如 host1 的启停就是启停 tuxedo 和 xom 软件组成，host2 的启停就是有启动 DB 和 listener 组成。我们把主机的启动分割为多个部分，这样综合写出共性的公用脚本程序，这样虽然第一次编写测试这些公用程序会花费大量的时间和精力，但最终将大大减轻管理员的重复工作，简化了脚本的编写，保证了脚本的质量。
文件存放目录表

目录 | 用途 | 举例
/usr/sbin/cluster/app | 存放 HA 启停脚本 |
/usr/sbin/cluster/app/log | 存放启停应用的详细 log |
/home/scripts/`hostname` | 存放应用启停脚本 | /home/scripts/host1
/tmp | 存放启停应用的 log | /tmp/ha_app.out

文件命名表：
以主机名为特征进行命名，这样比较方便使用和区分。

脚本 | 命名规则 | 举例
HA 启动脚本 | start_`hostname` | start_host1
应用启动脚本 | start_`hostname`_app | start_host1_app
HA 停止脚本 | stop_`hostname` | stop_host2
应用停止脚本 | stop_`hostname`_app | stop_host2_app
启停应用 log | /tmp/ha_app.out |
启动应用详细 log | start_`hostname`_app`yyyymmddHHMM`log | start_host1_app200712241722.log
停止应用详细 log | stop_`hostname`_app`yyyymmddHHMM`log | stop_host1_app200712241722.log

启停跟踪
为了便于跟踪和阅读，应用的启停 log 不写入 /tmp/hacmp.out，而是另行输出到单独的 log。一般情况下，管理员只需跟踪 /tmp/ha_app.out 即可，一直等不到结束，再查看 /usr/sbin/cluster/app/log 下详细 log。

[host2][root][/]>tail -f /tmp/ha_app.out
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Starting--- host2 at Tue Dec 18 11:17:51 BEIST 2007
Waiting------- DB testdb --------- start,Press any key to cancel..
DB testdb is started!
Waiting------- listener testdb --------- start,Press any key to cancel..
testdb -- LISTENER is started!
Waiting------- listener testdb port 1521--------- start,Press any key to cancel..
LISTENER testdb port 1521 is listening!
start eai1d1 successful! at Tue Dec 18 11:20:43 BEIST 2007
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[host2][root][/]>cd /usr/sbin/cluster/app
[host2][root][/]>more start_host2_app200712181117.log
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Starting--- eai1d1 at Mon Dec 24 16:06:35 BEIST 2007
Mon Dec 24 16:06:35 BEIST 2007
Waiting------- DB eaiz1dev --------- start,Press any key to cancel..
SQL*Plus: Release 10.2.0.2.0 - Production on Mon Dec 24 16:06:35 2007

Copyright (c) 1982, 2005, Oracle. All Rights Reserved.

Connected to an idle instance.

SQL> ORACLE instance started.

Total System Global Area 1543503872 bytes
Fixed Size 2071488 bytes
Variable Size 369099840 bytes
Database Buffers 1157627904 bytes
Redo Buffers 14704640 bytes
....Database mounted.
.Database opened.
SQL> Disconnected from Oracle Database 10g Enterprise
Edition Release 10.2.0.2.0 - 64bit Production
……

编写注意事项：
值得注意的是，经过测试和实际使用发现，由 HA 启动脚本时， 如有嵌套，相对目录执行程序将不能生效，必须写成绝对路径 。如下面的情况将导致错误：

start_host1: nohup /home/scripts/host1/start_host1_app &
start_host1_app: /home/scripts/comm/start_db.sh orarun testdb 1521
start_db.sh: cd /home/scripts/comm
check_db_main.sh testdb
check_db_main.sh not found

需要改写为

start_db.sh: /home/scripts/comm/check_db_main.sh testdb

启动脚本
由于 HACMP 的启动和应用的启动可以分开，为避免应用脚本的启动不正常导致 HACMP 的报错，建议将 HACMP 的启动脚本简化，将启动应用的部分放在另一个应用启动脚本里。
基于规划，start_host2_app 的启动脚本使用了公用程序 start_db.sh 和 wait_db_start.sh，源代码如下，供大家参考：
start_db.sh 代码：

#start_db.sh oracle_sid listener_name
ORACLE_SID=$1
sqlplus " / as sysdba"<< EOF
startup
EOF
lsnrctl start $2

wait_db_start.sh 代码：

wait_db.sh oracle_user oracle_sid listner_port
#return code: 1---press key canceled
waitout ()
{
printf "Waiting------- ${1} ${2} ${3}--------- start,Press any key to cancel."
}
#main
CURRENT_PATH=`pwd`
SCRIPTS_PATH=`dirname ${0}`
cd $SCRIPTS_PATH
waitout DB $2
i=1
while [ $i -gt 0 ]
do
waitkey
$SCRIPTS_PATH/check_db_main.sh $1 $2
i=$?
done
waitout listener $2
i=1
while [ $i -gt 0 ]
do
waitkey
$SCRIPTS_PATH/check_db_listener.sh $1 $2 $4
i=$?
done
waitout listener $2 "port $3"
i=1
while [ $i -gt 0 ]
do
waitkey
$SCRIPTS_PATH/check_port.sh $3
i=$?
done
echo "\nLISTENER $2 port $3 is listening!"
cd $CURRENT_PATH
exit 0

实际使用 start_host1 代码如下：

#start_host1
MACHINE=host1
GATEWAY=10.2.200.254
HA_LOG=log/start_"$MACHINE"_app`date +%C%y%m%d%H%M`.log
SCRIPTS_PATH=`dirname ${0}`
if [ "$SCRIPTS_PATH" = "." ];then
SCRIPTS_PATH=`pwd`
fi
if [ `hostname` = "$MACHINE" ]; then
route delete 0
route add 0 $GATEWAY
fi
> $SCRIPTS_PATH/$HA_LOG
nohup /home/scripts/comm/tail_log.sh start_app $SCRIPTS_PATH/$HA_LOG "!!!!!!!!!!!!|
started!|Waiting---|listening!|starting---|successful!" "successful!" >>/tmp/ha_app.out &
sleep 1
nohup /home/scripts/$MACHINE/start_"$MACHINE"_app ha >$HA_LOG &
exit 0

停止脚本
由于必须保证应用正常停止，才切换过去，所以停止脚本的正常结束才是 HACMP 停止应用服务器成功的标志。
停止脚本需要设定一个等待时间的阀值，超过这个阀值，将进行异常中止脚本的运行。
此外，为了防止停止时出现停不下来的现象，导致 HACMP 超时报 too long 广播，需要注意以下停止脚本的编写：

  1. 停止数据库脚本

停止数据库之前，必须记得先清理掉远程连接的用户，这样才能保证数据库能在可预测的时间内正常停止。
如 oracle 数据库停止之前，建议增加以下代码：

ps -ef|grep ora|grep $ORACLE_SID|grep "LOCAL=NO"|awk '{print "kill -9 "$2}'|sh

如果数据库超过一段时间仍停不下来，必须启动异常停止脚本。

  2. 最后加上清理文件系统的脚本

这一点很容易被忽略，因为有时即使应用正常停止，以下原因都可能导致导致 HACMP 不能 umount 这个文件系统 :

    • 有用户登录在该文件系统下；
    • 有其他程序使用了该文件系统下的库文件；
    • 该文件系统与应用无关，但正在被使用。

结果均会最终导致 HACMP 停止不了该节点，切换失败。
基于这个原因，我们编写了 kill_vg_user.sh, 使用起来非常方便有效，都放在 /home/scripts/comm 下。现提供源代码，供大家使用和指正。
kill_vg_user.sh 代码 :

#kill_vg_user.sh vg_name
#kill_vg_user.sh erpapp_vg
if [ $# -le 0 ] ;then
echo "no para, example:kill_vg_user.sh erpapp_vg "
exit
fi
#main
SCRIPTS_PATH=`dirname ${0}`
df -k|awk '{print $7 }'|grep -v Mounted >/tmp/fs_mounted.txt
for i in `lsvg -l $1 |grep -vE "N/A|vg|MOUNT"|awk '{print $7}'`
do
if [ `grep -c $i /tmp/fs_mounted.txt` -ge 1 ] ; then
echo kill_fs_user.sh $i
$SCRIPTS_PATH/kill_fs_user.sh $i
fi
done

调用的 kill_fs_user.sh 代码 :

#kill_fs.sh fs_name
#kill_fs.sh /oracle
if
[ ` df -k|grep $1|grep -v grep|awk '{print $7}'|grep -v [0-9a-zA-Z]$1
|grep -v $1[0-9a-zA-Z_-]|wc -l` -eq 1 ] ;
then
fuser -kcux $1
fi

实际使用 stop_host1 代码：

MACHINE=host1
VGNAME=host1vg
HA_LOG=log/stop_"$MACHINE"_app`date +%C%y%m%d%H%M`.log
SCRIPTS_PATH=`dirname ${0}`
if [ "$SCRIPTS_PATH" = "." ];then
SCRIPTS_PATH=`pwd`
fi
cd $SCRIPTS_PATH
>$HA_LOG
/home/scripts/comm/tail_log.sh stop_app $SCRIPTS_PATH/$HA_LOG "!!!!!!!!!!!!!!!!!!|
stopped!|Waiting---|stopping---|successful!" "successful!" >>/tmp/ha_app.out &
sleep 1
/home/scripts/$MACHINE/stop_"$MACHINE"_app ha >$HA_LOG 2 >&1#stop_host1
/home/scripts/comm/kill_vg_user.sh $VGNAME
exit 0

同步 HA 的脚本
由于 HA 切换后，切换的时间有可能超过一天，而切换时很可能另一台机器已无法开启，不能拿到最新的 crontab 和后台相关脚本，所以 crontab 和脚本最好能每天自动同步。
编写 sync_HA.sh
在 host1 上编写

  • sync_HA.sh 的代码：

OMACHINE=host2
rsh $OMACHINE "cd /home/scripts;tar -cvf ${OMACHINE}_scripts.tar $OMACHINE"
rcp $OMACHINE:/home/scripts/${OMACHINE}_scripts.tar /home/scripts
cd /home/scripts
rm -rf $OMACHINE
tar -xvf ${OMACHINE}_scripts.tar
rcp $OMACHINE:/var/spool/cron/crontabs/root /home/scripts/$OMACHINE/crontab_${OMACHINE}

  • 修改 Crontab 生效

###sync crontab
0 0 * * * /home/script/sync_HA.sh >/tmp/sync_HA.log 2>&1

同样在 host2 上编写，但注意 OMACHINE 修改为 host1。
异常情况的人工干预
本文没有详细描述 HACMP 异常情况的处理，这是因为每个系统每次异常可能情况都不一样，而且一般来说，安装 HACMP 的系统都是核心系统，给你留的时间会非常短，快速处理的要求更严格。
所以，我们试图找到一个办法，来应对 HACMP 本身异常 99% 的异常情况，而对于脚本和系统参数的不匹配，只能通过找出问题所在来处理。
场景 1：host1 出现问题，但 HACMP 没有切换成功，处于僵死状态

  1. 快速强制停止 host1 机器运行

host1:halt -q
  2. 确保应用服务继续

在 host2 上使用手工启动 host1_RG，
smitty hacmp->System Management (C-SPOC)-> HACMP Resource Group and Application Management ->Bring a Resource Group Online 选择 host1_RG,host2

Bring a Resource Group Online
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
Resource Group to Bring Online host1_RG

Node on Which to Bring Resource Group Online host2 即在 host2 上启动 host1 的资源组。

  3. 检查和确认应用已可以访问。
    如发现仍然不正常，请参考场景 2 的第 3 步。
  4. 检查和修正问题。
    • host2: 强制停止 HACMP；
    • 重新启动 host1，确认无硬件问题；
    • 检查 HACMP 的环境，阅读 /tmp/hacmp.out 等 log，看看能否找出问题所在；
    • 修正 HACMP 或其它部分
    • 确认无误申请短暂停机时间，重起 HACMP 回原。

场景 2：host1 出现问题，HACMP 切换过来，但处于僵死状态
由于此场景的起因有很多，3，4 点只能根据具体系统来细化，但还是强烈建议每个系统编制一份手工切换手册，详细列明 HACMP 不可用的情况下如何手工启动应用，以备紧急情况使用。

  1. 停止 host1 机器运行

host1:halt -q
  2. host2 强制停止 HACMP
  3. 检查和修正目前状况

HACMP 异常情况修正表

序号 | 目前状况 | 目前状况 | 修正 | 备注
1 | 服务 IP 地址 | 无 | smitty tcpip 手工添加 |
2 | vg 状况 | 未 varyon | varyonvg 手工执行 | 如果锁住加 varyonvg -bu
3 | fs 状况 | 未 mount | mount 手工执行 | 如损坏，执行 fsck -y
4 | 应用程序状况 | 执行异常 | 强制停止，重起 | 确认 1-3 ok 再做
  4. 手工修正目前状况
  5. 检查和修正问题
    1. 重新启动 host1，确认无硬件问题；
    2. 检查 HACMP 的环境，阅读 /tmp/hacmp.out 等 log，看看能否找出问题所在；
    3. 修正 HACMP 或其它部分；
    4. 确认无误申请短暂停机时间，重起 HACMP 回原。

其它有用的经验
HACMP 自动启动的实现
有的系统，希望开机就把 HACMP 自动启动，也就不需要人工干预就启动了应用，这需要 clstart 时指明 :

[host1][root][/]>smitty clstart
Start Cluster Services
* Start now, on system restart or both restart
Start Cluster Services on these nodes [host1]
BROADCAST message at startup? true
Startup Cluster Information Daemon? false
Reacquire resources after forced down ? false

这样，HACMP 会自动才 /etc/initab 里增加以下一行

hacmp6000:2:wait:/usr/es/sbin/cluster/etc/rc.cluster -boot -b # Bring up Cluster
Stop Cluster Services

这样就实现了自动启动 HACMP 和应用。
如果希望取消这种设定，需要运行 clstop:

[host1][root][/]>smitty clstop
Stop Cluster Services
* Stop now, on system restart or both restart
Stop Cluster Services on these nodes [bgbcb04]
BROADCAST cluster shutdown? true
* Shutdown mode graceful

可以看到 /etc/initab 里这一行消失了。

HACMP 的 too long 报警广播的修正
在有些系统运行很长时间的情况下，有可能停止的时间会超出我们预期，如 oracle 数据库的某些资源被交换到 Pagespace 里。缺省如果超过 180s，就会广播报警，直至 HACMP 异常。这时你可以修正这个参数，以避免广播出现。
smitty hacmp->Extended Configuration ->Extended Event Configuration ->Change/Show Time Until Warning

Max. Event-only Duration (in seconds) [360]
Max. Resource Group Processing Time (in seconds) [360]
Total time to process a Resource Group event 12 minutes and 0 seconds
before a warning is displayed
NOTE: Changes made to this panel must be
propagated to the other nodes by
Verifying and Synchronizing the cluster

同样，修改后需要 HACMP 同步。

HACMP 的 DMS 问题的修正
DMS（deadman switch) 是用来描述系统 kernel extension 用的，它可以在系统崩溃前关闭系统，并产生 dump 文件，以供日后检查使用。
DMS 存在的目的是为了保护共享外置硬盘及数据，当系统挂起时间长过一定限制时间时，DMS 会自动关闭该系统，由 HACMP 的备份节点接管系统，以保护数据和业务的正常进行，避免潜在的问题，特别是外置磁盘阵列。
errpt 确认 DMS 的发生：

LABEL: KERNEL_PANIC
IDENTIFIER: 225E3B63
Date/Time: Thu Apr 25 21:26:16
Sequence Number: 609
Machine Id: 0040613A4C00
Node Id: localhost
Class: S
Type: TEMP
Resource Name: PANIC
Descrīption
SOFTWARE PROGRAM ABNORMALLY TERMINATED
Recommended Actions
PERFORM PROBLEM DETERMINATION PROCEDURES

Detail Data
ASSERT STRING

PANIC STRING

DMS 起作用的原因主要有以下几点：

  • 某种应用程序的优先级大于 clstrmgr deamon , 导致 clstrmgr 无法正常重置 DMS 计数器；
  • 在系统上存在大量 I/O 操作，导致 CPU 没有时间相应 clstrmgr deamon；
  • 内存泄漏或溢出问题；
  • 大量的系统错误日志活动。

换句话说，当以上情况出现时，HACMP 认为系统崩溃，会自动切换到另一台节点机上去，这是我们想要的结果吗？
一般情况下，原有的缺省设置无需更改。但由于系统运行了较长时间后，负荷可突破原有设计（平均小于 45%），而且某些情况下会持续 100%，我们就不希望发生切换。如果发生了 DMS 造成的切换，我们先延长 HACMP 的确认的时间，即调整心跳线的 诊断频率 ：
smitty hacmp->Extended Topology Configuration ->Configure HACMP Network Modules -> Change a Network Module using Predefined Values 选择 r232

* Network Module Name rs232
Description RS232 Serial Protocol
Failure Detection Rate Slow
NOTE: Changes made to this panel must be
propagated to the other nodes by
Verifying and Synchronizing the cluster

同样，记得同步 HACMP。
如果还是发生 DMS 导致的 HACMP 切换，排除异常后，只好禁用 DMS 了， 这点 IBM 不推荐，因为有可能造成切换时数据丢失或损坏。
修改 rc.cluster 文件增加 -D 参数：

[host1][root][/]> vi /usr/es/sbin/cluster/etc/rc.cluster
if [ "$VERBOSE_LOGGING" = "high" ]
then
clstart -D -smG $CLINFOD $BCAST
else
clstart -D -smG $CLINFOD $BCAST 2>/dev/console
fi

重起 HACMP 生效。
SNMP 的调整（AIX5.3 不需要）
在 AIX 5.2 下要对 SNMP 做一些调整才可以看到真正的 HACMP 的状态。
具体来说， AIX 5.2 的 SNMP 默认是 version 3 :

[host1][root][/]>ls -l |grep snmp
lrwxrwxrwx 1 root system 8 Apr 08 17:55 clsnmp -> clsnmpne
-rwxr-x--- 1 root system 83150 Mar 12 2003 clsnmpne
-rwxr-x--- 1 root system 55110 Mar 12 2003 pppsnmpd
lrwxrwxrwx 1 root system 9 Apr 08 17:55 snmpd -> snmpdv3ne

而 HACMP 只支持 SNMP version 1 . 所以我们要做一下调整：

stopsrc -s snmpd
/usr/sbin/snmpv3_ssw -1
startsrc -s snmpd
[host1][root][/usr/sbin]>ls -l |grep snmp
lrwxrwxrwx 1 root system 18 Apr 21 13:40 clsnmp -> /usr/sbin/clsnmpne
-rwxr-x--- 1 root system 83150 Mar 12 2003 clsnmpne
-rwxr-x--- 1 root system 55110 Mar 12 2003 pppsnmpd
lrwxrwxrwx 1 root system 17 Apr 21 13:40 snmpd -> /usr/sbin/snmpdv1

小结
本部分论述了富有特色的 HACMP 脚本编著，也就特殊情况下的一些 HACMP 场景的处理做了详尽的描述，相信对希望进一步深入掌握 HACMP 的读者会有所帮助，对现实工作具有较强的参考意义。总的来说，本文采用类似教程的方式，一步一步由浅入深，细致完整的描述了 IBM HACMP 实施的各个方面，是不可多得的 HACMP 的使用手册。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/0804_xinmin_hacmp/4.html

Top


使用 HACMP/XD + GLVM 实现高可用性集群

HACMP/XD GLVM 是一种基于软件的通过 TCP/IP 网络实现关键业务数据镜像的新技术。HACMP/XD GLVM 通过支持 AIX 5L 逻辑卷来保证业务连续性的运行，提供了较为简单易用的配置和使用方法，适用于 p 系列服务器的应用负载环境。 HACMP/XD GLVM 通过实时镜像数据及自动接管 / 恢复的功能来保证企业的业务连续性，即瞬时接管 / 恢复数据并保证关键应用的可靠性。

HACMP/XD GLVM 提供的数据复制是基于 AIX 5L Logical Volume Manager (LVM) 进行的 , 可以对 AIX 逻辑卷做数据复制及同步，且不限物理距离。HACMP/XD GLVM 与 AIX 5L 的 LVM 集成在一起，使用 HACMP/XD GLVM 的用户只需要配置一个 AIX 远程伪设备驱动程序来定义远程物理卷， HACMP/XD GLVM 的用户需要将远程磁盘配置为“远程物理卷”，并将这些远程物理卷与本地物理卷组合在一个卷组中以便完成镜像，这个卷组由 AIX 5L 的 LVM 象本地卷组一样进行管理。熟悉 AIX 5L LVM 的用户一定会非常容易地掌握 HACMP/XD GLVM 的使用。

使用 HACMP/XD GLVM，用户可以通过两或三份镜像的数据管理位于两地的生产和备份中心（不限距离），达到异地自动接管且不丢数据的目的。
其系统架构如下：

HACMP/XD GLVM 架构
HACMP/XD GLVM 架构

参考链接：http://www.ibm.com/developerworks/cn/education/aix/hacmpglvm/index.html

Top


浅谈 HACMP 心跳

初识 HACMP 心跳
HACMP 软件主要监控 4 种故障：节点，网卡，网络，应用。其中前三种都是通过心跳来监控并产生事件响应的，我们可以看出使用 HACMP 集群，可谓玩的就是心跳。如果不了解心跳的过程和基本原理，使用 HACMP 搭建起来的高可用的平台就可能是高不可用。

其实 HACMP 的心跳并不复杂高深，像所有的 HA 软件一样，心跳包是用来传递节点的状态信息，HACMP 的心跳包从最高的 IP 地址依次单向流动到最低 IP 地址，然后再返回到 IP 地址最高的节点形成一个单向循环的环路。每一个物理子网都会有一个心跳环路，包括串口心跳和磁盘心跳这些点对点的心跳，在广义上也是各自独立的心跳环路。每个环路我们称之为一个心跳网络。其心跳过程我们可以参看下图，Node3 有最高的 IP 地址 192.168.1.3，它是该心跳环路的 Group Leader。 Node3 产生的心跳包发送给 Node2，Node2 产生的心跳包发送给 Node1，Node1 则发送给 Node3 形成一个环路。

对于 HACMP 集群来说，至少需要 2 个心跳网络来保证心跳网络的冗余，而且更进一步，至少需要 2 种不同类型的心跳网络保证更高的可靠性，比如，一个 IP 网络心跳，一个磁盘心跳。之所以对心跳网络可靠性有如此高的要求，除了我们之前描述的心跳网络的重要作用以外，还有更重要的原因：如果 2 个节点间心跳通信完全中断后，他们都会认为对方已经宕机，然后都在本地启动应用，并同时去争抢磁盘资源，有可能导致数据出现风险，即所谓的 split-brain 事件。所以 HACMP 包括其他的 HA 的集群应用都有一个很重要的前提，就是要求在任何时刻至少存在一个可用的心跳网络在节点间传递信息。

再看 HACMP 心跳

从 HACMP5.1 版本以后，HACMP 的心跳已经交由 RSCT（Reliable Scalable Cluster Technology）这一套中间层软件来实现。RSCT 相当于是一个集群应用与集群管理的中间通讯平台，它提供了丰富的集群功能简化了集群应用开发的复杂性。在其他的一些软件，比如 IBM CSM 集群管理软件和 HMC 上的部分管理功能都是通过 RSCT 的组件来实现的。

再细分来看，负责心跳的是 RSCT 中的 Topology Services 模块。我们下面先了解一下 Topology Services 的初始化过程。Topology Services 的核心进程是 /usr/sbin/rsct/bin/hatsd 。hatsd 启动后就开始广播本节点信息同时侦听其他节点的信息，经过自举、推举、还有一段时间等待（其过程有点类似于以太网交换机通过 spanning-tree 协议选举 root 节点），最后在该子网中找出所有节点里一个 IP 地址最高的，将它定义为 group leader。 Group leader 作为一个权威节点负责该子网中节点状态信息的收集，管理，更新和发布。至此，心跳网络就完成了其初始化过程开始正常心跳。另外，为防止 Group Leader 宕机，还定义了 IP 地址第二高的节点作为 Group Leader 的监控节点称之为 Group Leader Successor，它负责监控 Group Leader 状态，在必要时可以弹劾并成为 Group Leader。

在心跳网络建立以后，网络状态的监控被分为两部分，一是网卡物理状态的监控；一是逻辑上的网络链路状态监控。网卡物理状态的监控是通过为每一块网块创建一个监控进程（NIM）来实现的，当网卡状态改变会立刻通知 RSCT，比如网卡 Link down 的信息就会被 NIM 立刻发现并产生 Network adaptor failure 的事件。

另一方面，hacmp 心跳故障判断还能从逻辑上分析判断网络状态。我们以下图为例。假设在运行过程中，Node3 到 Node2 之间的网络发生意外中断，但是 Node3 网卡的链路状态仍然为 UP，此时物理的网卡监控不会做出反应。然而心跳包会开始丢包，Node2 会发现无法收到 Node3 的心跳包，但此时并不能确定到底是 Node2 还是 Node3 网络出现故障。为了进一步确定故障，Node3 会通过 RSCT 走别的心跳网络发命令给第三个节点（node1），让第三个节点（Node1）分别去 ping Node2 和 Node3。如果故障点在 Node3 上面，那么显然 ping Node3 会失败，于是确定故障位置在 Node3 上面，最后产生一个的 Network adaptor failure 的事件通知给 HACMP。

2 个节点的 HACMP 集群

我们从上文可以发现，准确判断网络故障点的位置需要“第三个节点”做仲裁。只有 2 个节点的 HA 集群如何实现正确判断？从一般的逻辑判断上来说，2 个节点之间出问题一定是公说公有理，婆说婆有理，必须要有第三方来做仲裁。

在只有 2 个节点的 HA 集群中，为了解决这个问题，HACMP 需要配置一个文件来设置一些第三方的一个仲裁 IP 地址。当心跳故障发生时，2 个节点都会去试图从本机去 ping 这些仲裁 IP 地址。能正确的 ping 通则表明本节点的网络正常，从而判断出故障点需要注意的是，仅仅是在网络心跳发生问题时，RSCT 才会调用网络诊断的进程去使用这些仲裁 IP，在正常状态下，这些仲裁 IP 不会参与到心跳过程。

这些仲裁 IP 的选择可以是子网的网关，也可以是子网中其他的某一节点 IP 地址。如果有多个子网，需要为每个子网挑选一个仲裁 IP 地址，把他们写成一个 list 保存到一个配置文件（netmon.cf）中。该配置文件的存放位置在 /usr/es/sbin/cluster/netmon.cf。在两个节点的 HA 群里同步配置的过程中，如果没有配置 netmon.cf 可能会弹出一个 warning 的信息提示该文件需要配置。

在配置 netmon.cf 后，RSCT 的进程启动后，会逐条把其中的 IP 读取进来，作为仲裁 IP 使用。我们可以在 nmDiag.nim.topsvcs.xxx 这个日志文件中看到这样的信息。

06/18 19:01:55.387: read_ping_configuration:Entered for adapter en0
06/18 19:01:55.387: read_ping_configuration:File /usr/es/sbin/cluster/netmon.cf opened
06/18 19:01:55.387: read_ping_configuration:Read [192.168.21.130 ] from file.
06/18 19:01:55.387: read_ping_configuration:gethostbyname (192.168.21.130) was successful.
06/18 19:01:55.387: read_ping_configuration:Read [172.32.16.3] from file.
06/18 19:01:55.387: read_ping_configuration:gethostbyname (172.32.16.3) was successful.
06/18 19:01:55.387: read_ping_configuration:Read 2 ping addresses.

其他一些细节

RSCT/HACMP 日志文件

关于 HACMP 心跳的日志存放在 /var/ha/log 目录下。其主要可供分析的有：

  • nim.topsvcs.enX (enX 为网络端口名 ) 该文件对应的记录了网卡 enX 的网络监控进程的启动，心跳和退出的详细日志。
  • nmDiag.nim.topsvcs.enX 该文件记录了在心跳出现丢失后，RSCT 对网络拓扑的逻辑分析判断的过程。
  • Topsvcs.<pid 进程号 >.<cluster name> 该文件是 topsvcs 的主进程日志文件，记录 topsvcs 进程的启动过程，以及心跳网络拓扑改变等重要的事件信息。

心跳网络状态查询命令

我们一般都知道 hacmp 的状态可以通过 /usr/sbin/cluster/clstat 来查看，还有一个命令可以更详细的查看当前集群心跳状态。 lssrc –ls topsvcs 如下图：

# lssrc -ls topsvcs | more
Subsystem Group PID Status
topsvcs topsvcs 315610 active
Network Name Indx Defd Mbrs St Adapter ID Group ID
net_ether_01_0 [ 0] 2 1 S 192.168.21.150 192.168.21.150
net_ether_01_0 [ 0] en0 0x808820f2 0x808820fc
HB Interval = 1.000 secs. Sensitivity = 10 missed beats
Missed HBs: Total: 0 Current group: 0
Packets sent : 1078 ICMP 0 Errors: 0 No mbuf: 0
Packets received: 866 ICMP 0 Dropped: 0
NIM's PID: 307250
net_ether_01_1 [ 1] 2 1 S 172.16.21.1 172.16.21.1
net_ether_01_1 [ 1] en1 0x808820f3 0x808820fc
HB Interval = 1.000 secs. Sensitivity = 10 missed beats
Missed HBs: Total: 0 Current group: 0
Packets sent : 1078 ICMP 0 Errors: 0 No mbuf: 0
Packets received: 434 ICMP 0 Dropped: 0

通过分析心跳包的丢包数量和频率可以判断网络的可靠性和负载情况，一方面可以用来分析和解释异常的 HA 备机切换动作，另一方面可以用来分析系统问题并通过调整系统参数来均衡负载。建议在设计 HA 集群的时候不要使用负载过大的 TCP/IP 网络或者 IO 负载很大的磁盘来做心跳。

小结

HACMP 集群的各种网络故障的分析和判断都是由 RSCT 心跳来实现的，网络故障的判断正确与否也直接影响了 HACMP 对应用的切换和还原，所以了解心跳的过程与原理对于设计与配置 HACMP 高可用集群具有重要的意义。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/0811_wangrong_hacmp/

Top


关于在虚拟 I/O 环境中实现 PowerHA 的提示

简介
在本文中，将提出对在虚拟 I/O (VIO) 环境中构建 PowerHA 集群的一些建议。将简要介绍一个简单的两节点 PowerHA 集群的 LPAR 和 VIO server (VIOS) 设计和布局。但是，并不讨论具体的 PowerHA 配置，因为这个主题太大了，无法在这里详细讨论。深入的信息请参考官方 IBM PowerHA 文档。本文还假设您有使用 AIX、VIO 和 PowerHA 的经验。

概况
本文讨论的示例环境由两台 POWER6 595 服务器组成。为了实现冗余，每台 595 配置两个 VIO 服务器，跨两个物理 frame 构建了一个两节点集群，即每台 Power 595 服务器上有一个 PowerHA 节点。LPAR 运行 AIX 5.3 TL7 SP5 和 PowerHA 5.4.1.3。跨虚拟 I/O 环境用 1.5.2.1-FP11.1 版构建每个 VIOS。图 1 给出这个配置。

图 1. PowerHA 集群概况
显示两台 595 服务器以及 vios、RAM 和 LPAR 信息

在下面几节中，简要讨论集群节点的虚拟网络和虚拟（共享）存储配置。主要讨论以下方面：

  • PowerHA 引导与服务网络和地址
  • PowerHA 网络的 Shared Ethernet Adapter (SEA) 配置
  • 共享卷组的考虑事项

虚拟网络
虚拟网络配置是 PowerHA 配置的重要方面。图 2 说明如何配置 VIOS 网络；在这个示例中，在一台 595 frame 上进行配置，然后在另一台 frame 上复制 VIOS 网络配置。

图 2. VIOS 网络概况
595-1 VIOS 网络

如图 2 所示，同一 VIOS 对的客户机包括 PowerHA 和非 HA LPAR。您还会注意到有多个 SEA，即每个 VLAN 和使用类型有一个：PUBLIC、BACKUP 和 PowerHA。每个 VLAN 有惟一的 IP 范围：PUBLIC 10.2.2、BACKUP 10.3.3 和 PowerHA 10.1.1。在 10.4.4 网络上，每个 LPAR 上还有一个接口，这个网络用于 LPAR 之间通过 POWER Hypervisor 虚拟网络进行内部（私有）通信。

HA 节点通过 VLAN40 (PVID40/41)（这是 PowerHA 网络）与外部通信。非 HA LPAR 通过 VLAN10 (PVID10) 和 PUBLIC 网络通信。每个 VIOS 在 VLAN20 上还有另一个 SEA，这是用于网络备份的复制 VLAN，因此这个网络名为 BACKUP。

为 PUBLIC 和 BACKUP 网络配置了 Shared Ethernet Adapter Fail Over (SEA FO)。PowerHA 网络没有 SEA FO。如果 VIOS 上用于 PowerHA 网络的 SEA 发生故障，那么服务 IP 会转移到由冗余 VIOS 提供的另一个引导适配器。

对于任何 SEA 都没有使用 VLAN 标签。因为这个网络中只有几个 VLAN，所以不需要 VLAN 标签。但是，您的需求可能不一样。
用 cltopinfo 命令查看 PowerHA 集群网络，可以看到每个节点的网络定义如下：

清单 1. 网络定义

# cltopinfo
Cluster Name: CLUSTER-A
Cluster Connection Authentication Mode: Standard
Cluster Message Authentication Mode: None
Cluster Message Encryption: None
Use Persistent Labels for Communication: No
There are 2 node(s) and 3 network(s) defined

NODE aix01adm:
Network net_diskhb_01
aix01adm_hdisk1_01 /dev/hdisk1
Network net_ether_01
aix01adm 10.2.2.8
Network net_ether_02
aix01 10.1.1.12
aix01b2v1 10.1.1.76
aix01b1v2 10.1.1.140

NODE aix02adm:
Network net_diskhb_01
aix02adm_hdisk1_01 /dev/hdisk1
Network net_ether_01
aix02adm 10.2.2.15
Network net_ether_02
aix01 10.1.1.12
aix02b1v3 10.1.1.77
aix02b2v4 10.1.1.141

Resource Group HARG1
Startup Policy Online On Home Node Only
Fallover Policy Fallover To Next Priority Node In The List
Fallback Policy Never Fallback
Participating Nodes aix01adm aix02adm
Service P Label aix01

可以看到服务和引导适配器都在同一个子网化（分段）IP 网络中，其中的 b1v1 定义与第一个 VIOS (v1) 相关联的第一个引导适配器 (b1)，以此类推。服务地址是 hostname，后面不附加 adm。

清单 2. 服务和引导适配器

Service address:aix01 10.1.1.12
Netmask 255.255.255.192
IP range 10.1.1.1 - 62

boot1 address: aix01b1v1 10.1.1.76
Netmask 255.255.255.192
IP range 10.1.1.65 - 126

boot2 address: aix01b2v2 10.1.1.140
Netmask 255.255.255.192
IP range 10.1.1.129 - 190

boot1 address: aix02b1v3 10.1.1.77
Netmask 255.255.255.192
IP range 10.1.1.65 - 126

boot2 address: aix02b2v4 10.1.1.141
Netmask 255.255.255.192
IP range 10.1.1.129 - 190

通常，在 VIOS 上配置 SEA 时，会部署 SEA Fail Over 以便在发生 VIOS 故障时保护网络连接。但是，在这个 PowerHA 环境中，采用的方法不同。PowerHA 网络不使用 SEA FO。这样，由 PowerHA 感知网络故障并控制故障转移。在这个环境中，在每个 VIOS 上有一个用于 PowerHA 网络的 SEA。如果一个 VIOS 发生故障，服务地址会转移到由冗余 VIOS 提供的引导适配器。

采用这种方式主要是由于 PowerHA 集群在虚拟网络环境中的通信方式。如果配置 SEA FO 并发生了故障，HA 就无法探测到故障。同样，如果物理层的所有通信中断了，HA 仍然会认为网络是正常的，因为它仍然能够通过 Hypervisor 上的虚拟 LAN 路由通信流。

由于这个原因，在集群中的所有节点上配置 netmon.cf 文件是很重要的。

这个文件告诉 HA 如何判断它与网络或其伙伴 HA 节点的连接是否中断了。如果没有适当地配置这个文件，PowerHA 就无法探测到网络故障。

netmon.cf 文件和 VIO
在 VIO 环境中配置 netmon.cf 文件时，建议参考两个 APAR。您很快就会理解这个文件为什么很重要以及什么时候应该实现它。
APAR IZ01331 描述在 PowerHA 集群中使用 VIO 的场景以及在探测网络故障方面面对的困难。例如，如果 “从网络上拔掉整个 CEC，frame 上的 PowerHA 节点不会探测到本地适配器关闭事件，因为从 LPAR 的 OS 的角度来看，（同一 frame 上）VIO 客户机之间的通信流与正常的外部通信流一样。”

为了解决这个问题，客户可以使用 netmon.cf 文件声明：指定的适配器只有在能够 ping 通一组指定目标的情况下才认为是打开的。

如果 VIOS 有同一网络上的多个物理接口，或者有两个或更多 PowerHA 节点使用同一 frame 中的一个或更多 VIOS，PowerHA 就不会收到物理接口故障的通知（因此不会做出反应）。

如果出现由 VIO Server 管理的所有物理接口都发生故障的极端情况，VIOS 会继续在同一 frame 中的 LPAR 之间路由通信流，PowerHA 使用的虚拟以太网接口不会报告故障，PowerHA 不会做出反应。

集群中的每个节点有一个定制的 netmon.cf 文件，其中列出一些 IP 地址，为了判断一个接口是打开的 还是关闭的，它必须能够 ping 通这些地址。例如，aix01adm 驻留在 Frame 1 (595-1) 上，aix02adm 驻留在 Frame 2 (595-2) 上。如果 595-1 上所有 VIOS 的所有物理接口的所有网络连接都中断了，那么 aix01adm 仍然会继续工作，因为它仍然能够通过虚拟网络路由数据包。要想让这个节点（和其他节点）探测到问题，应该在 netmon.cf 文件中指定在特定接口上它应该能够到达的地址。如果它 ping 不通这些地址，就把这些接口标为关闭的，PowerHA 能够做出相应的反应。

APAR IZ01874 解释如何为 netmon.cf 文件选择 IP 地址。这个文件应该包含这样的远程 IP 地址和主机名：它们不包含在集群配置中，但可以通过 PowerHA 网络接口访问。这些地址前面必须加上 !REQD。

比较合适的目标包括名称服务器（DNS 服务器）和网关（路由器），或者会响应 ping 操作的可靠的外部 IP 地址（比如 NTP 服务器）。可以使用下面的 ping 命令检查 ping 在特定的接口上是否会得到响应：

# ping -S <Boot IP address> <IP addr in netmon.cf>

其中的 <Boot IP address> 是在引导接口上配置的 IP 地址。例如：

清单 4. 特定的接口上 ping 命令的响应

# ping -c5 -S aix01b1v1 aix02b1v3
PING bxaix04b1v1: (10.1.1.77): 56 data bytes
64 bytes from 10.1.1.77: icmp_seq=0 ttl=255 time=0 ms
64 bytes from 10.1.1.77: icmp_seq=1 ttl=255 time=0 ms
64 bytes from 10.1.1.77: icmp_seq=2 ttl=255 time=0 ms
64 bytes from 10.1.1.77: icmp_seq=3 ttl=255 time=0 ms
64 bytes from 10.1.1.77: icmp_seq=4 ttl=255 time=0 ms

----aix02b1v3 PING Statistics----
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0/0/0 ms

清单 5 给出来自两个物理 frame 上两个节点的 netmon.cf 示例。

清单 5. netmon.cf 示例

HOST: aix01adm 595-1
--------------------
# Care is required when modifying this file!
# The nature of the VIO/PowerHA environment means the contents
# of netmon.cf on each cluster node is different.
# IP labels/addresses on virtual interfaces in any VIO client LPAR
# within this server frame, must be excluded from this file!
!REQD aix01b1v1 10.2.2.1
!REQD aix01b2v2 10.2.2.1
!REQD aix01b1v1 10.1.1.1
!REQD aix01b2v2 10.1.1.1
!REQD aix01b1v2 10.1.1.77
!REQD aix01b2v2 10.1.1.141
!REQD aix01b1v1 aix02b1v3
!REQD aix01b2v2 aix02b2v4
!REQD aix01b1v1 10.1.9.2
!REQD aix01b2v2 10.1.9.3
10.2.2.1
10.1.9.2
10.1.9.3
ntp-srvr
ntp-srvr

HOST: aix02adm 595-2
--------------------
# Care is required when modifying this file!
# The nature of the VIO/PowerHA environment means the contents
# of netmon.cf on each cluster node is different.
# IP labels/addresses on virtual interfaces in any VIO client LPAR
# within this server frame, must be excluded from this file!
!REQD aix02b1v3 10.2.2.1
!REQD aix02b2v4 10.2.2.1
!REQD aix02b1v3 10.1.1.1
!REQD aix02b2v4 10.1.1.1
!REQD aix02b1v3 10.1.1.76
!REQD aix02b2v4 10.1.1.140
!REQD aix02b1v3 aix01b1v1
!REQD aix02b2v4 aix01b2v2
!REQD aix02b1v3 10.1.9.2
!REQD aix02b2v4 10.1.9.3
10.2.2.1
10.1.9.2
10.1.9.3
ntp-srvr
ntp-srvr

以下面这行为例

!REQD aix01b1v1 aix02b1v3

!REQD 标记指出，只有在可以 ping 通目标 (aix02b1v3) 的情况下，才认为这个适配器 (aix01b1v1) 是打开的。aix01b1v1 指定测试使用哪个接口，aix01b1v1 解析为 10.1.1.76，这是 en2 接口上的地址。如果可以 ping 通目标 aix02b1v3，就认为这个接口是打开的。

清单 6. 判断适配器主机名

# host aix01b1v1
aix01b1v1 is 10.1.1.76

# ifconfig en2
en2: flags=1e080863,480<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST,
GROUPRT,64BIT,CHECKSUM_OFFLOAD(ACTIVE),CHAIN>
inet 10.1.1.76 netmask 0xffffffc0 broadcast 10.1.1.127
inet 10.1.1.12 netmask 0xffffffc0 broadcast 10.1.1.63
tcp_sendspace 262144 tcp_recvspace 262144 rfc1323 1

使用 en2 连接 aix02b1v3，这是 595-2 上它的伙伴节点上的接口。如果无法通信，接口 en2 (aix01b1v1) 就被标为关闭的。不要在这个文件中包含同一 frame 上的任何节点。所有条目都应该针对驻留在这个物理 frame 之外的系统，以便探测外边的物理网络（而不是虚拟网络）上真正的物理网络故障。

注意，在 netmon.cf 文件中不要指定接口名，比如：

!REQD en2 10.1.1.10

在 VIO 环境中包含接口名是无效的。我上次检查时，有一个 Design Change Request (DCR) 请求 HA 开发团队解决这个问题。一些客户遇到了接管过程缓慢的问题，这是由 RSCT (netmon) 判断 netmon.cf 中的第二个字段是 IP/主机名还是接口名的方式造成的。在某些情况下，netmon 会尝试解析主机名的 IP 地址，例如 $ host en2，这时解析会失败。IBM 开发人员正在开发一种新算法，以避免把接口名当作主机名对待，尤其是对于 enX 等明显的格式。目前，最好不要在 netmon.cf 文件中使用接口名，例如 enX。

如果 netmon.cf 方法在您的 VIO 环境中是合适的，建议只使用这种方法。通过使用这种方法，判断所谓的 “好适配器” 的标准不再是 “是否能够接收到任何网络通信流？”，而是 “是否可以成功地 ping 通某些地址？（无论可以看到的通信流有多大）”。

这可能导致适配器被误以为关闭了。如果必须使用这个新功能，建议为需要监视的每个接口指定尽可能多的目标。

虚拟（共享）存储

关于 PowerHA 和 Virtual SCSI (VSCSI) 的 IBM 技术文档明确地定义了在 VIO 环境中支持的存储配置。共享的卷组 (VG) 必须定义为 “Enhanced Concurrent Mode”。在一般情况下，对于 PowerHA 集群中的共享卷组，推荐使用 Enhanced Concurrent Mode 模式。在这种模式下，多个 PowerHA 节点都可以访问共享卷组，这会加快发生节点故障时的故障转移（磁盘接管）。对这些共享磁盘的所有卷组管理操作都应该通过 PowerHA 节点执行，而不应该通过 VIOS。
在示例环境中，在主节点上运行 lspv 以确认共享卷组处于并发模式。

清单 7. 在主节点上运行 lspv

root@aix01adm / # lspv
hdisk0 00c79a70a6858137 rootvg
hdisk1 00c79a70a20c321c sapvg concurrent

图 3 显示每个节点上有两个卷组。每个节点有自己的（非共享）根卷组 (rootvg)。

图 3. VIOS VSCSI 概况
显示两个服务器，每个节点上有两个卷组

主节点在启动并处于活跃状态时拥有共享卷组。通过在主节点上运行 lsvg 命令并观察它的一些属性可以确认这一点。VG STATE 是 active，VG Mode 是 Concurrent，Concurrent 设置为 Enhanced-Capable，VG PERMISSION 是 read/write。共享卷组中的逻辑卷是打开的。

清单 8. 在主节点上运行 lsvg

root@aix01adm / # lsvg sapvg
VOLUME GROUP:sapvg VG IDENTIFIER:00c79a6000004c0000000123a2278720
VG STATE:active PP SIZE:64 megabyte(s)
VG PERMISSION:read/write TOTAL PPs:6398 (409472 megabytes)
MAX LVs:256 FREE PPs:1596 (102144 megabytes)
LVs:13 USED PPs:4802 (307328 megabytes)
OPEN LVs:13 QUORUM:2 (Enabled)
TOTAL PVs:1 VG DESCRIPTORS:2
STALE PVs:0 STALE PPs:0
ACTIVE PVs:1 AUTO ON:no
Concurrent:Enhanced-Capable Auto-Concurrent: Disabled
VG Mode:Concurrent
Node ID:2 Active Nodes:1
MAX PPs per VG:32512
MAX PPs per PV:4064 MAX PVs:8
LTG size (Dynamic):256 kilobyte(s) AUTO SYNC:no
HOT SPARE:no BB POLICY:relocatable

root@aix01adm / # lsvg -l sapvg
sapvg:
LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT
oraclelv jfs2 192 192 1 open/syncd /oracle
sapmnt_CG1lv jfs2 144 144 1 open/syncd /sapmnt
usrsap_CG1lv jfs2 144 144 1 open/syncd /usr/sap
oraclestagelv jfs2 128 128 1 open/syncd /oracle/stage
sapreorg_CG1lv jfs2 64 64 1 open/syncd /oracle/CG1/sapreorg
sapbackup_CG1lv jfs2 16 16 1 open/syncd /oracle/CG1/sapbackup
mirrlogA_CG1lv jfs2 8 8 1 open/syncd /oracle/CG1/mirrlogA
mirrlogB_CG1lv jfs2 8 8 1 open/syncd /oracle/CG1/mirrlogB
origlogA_CG1lv jfs2 8 8 1 open/syncd /oracle/CG1/origlogA
origlogB_CG1lv jfs2 8 8 1 open/syncd /oracle/CG1/origlogB
sapdata1_CG1lv jfs2 1600 1600 1 open/syncd /oracle/CG1/sapdata1
oraarch_CG1lv jfs2 80 80 1 open/syncd /oracle/CG1/oraarch
loglv01 jfs2log 1 1 1 open/syncd N/A

在执行故障转移之前，备用节点上的文件系统没有挂载，所以不可能意外地使用备用节点上的数据。在备用节点上，可以访问共享的增强型并发卷组，但是只能采用被动只读模式。VG PERMISSION 设置为 passive-only。共享卷组中的逻辑卷是关闭的。

清单 9. 备用节点

root@aix02adm / # lsvg sapvg
VOLUME GROUP:sapvg VG IDENTIFIER:00c79a6000004c0000000123a2278720
VG STATE:active PP SIZE:64 megabyte(s)
VG PERMISSION:passive-only TOTAL PPs:6398(409472 megabytes)
MAX LVs:256 FREE PPs:1596(102144 megabytes)
LVs:13 USED PPs:4802 (307328 megabytes)
OPEN LVs:0 QUORUM:2 (Enabled)
TOTAL PVs:1 VG DESCRIPTORS: 2
STALE PVs:0 STALE PPs:0
ACTIVE PVs:1 AUTO ON:no
Concurrent:Enhanced-Capable Auto-Concurrent: Disabled
VG Mode:Concurrent
Node ID:1 Active Nodes:2
MAX PPs per VG:32512
MAX PPs per PV:4064 MAX PVs: 8
LTG size (Dynamic):256 kilobyte(s) AUTO SYNC:no
HOT SPARE:no BB POLICY:relocatable

root@aix02adm / # lsvg -l sapvg
sapvg:
LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT
oraclelv jfs2 192 192 1 closed/syncd /oracle
sapmnt_CG1lv jfs2 144 144 1 closed/syncd /sapmnt
usrsap_CG1lv jfs2 144 144 1 closed/syncd /usr/sap
oraclestagelv jfs2 128 128 1 closed/syncd /oracle/stage
sapreorg_CG1lv jfs2 64 64 1 closed/syncd /oracle/CG1/sapreorg
sapbackup_CG1lv jfs2 16 16 1 closed/syncd /oracle/CG1/sapbackup
mirrlogA_CG1lv jfs2 8 8 1 closed/syncd /oracle/CG1/mirrlogA
mirrlogB_CG1lv jfs2 8 8 1 closed/syncd /oracle/CG1/mirrlogB
origlogA_CG1lv jfs2 8 8 1 closed/syncd /oracle/CG1/origlogA
origlogB_CG1lv jfs2 8 8 1 closed/syncd /oracle/CG1/origlogB
sapdata1_CG1lv jfs2 1600 1600 1 closed/syncd /oracle/CG1/sapdata1
oraarch_CG1lv jfs2 80 80 1 closed/syncd /oracle/CG1/oraarch
loglv01 jfs2log 1 1 1 closed/syncd N/A

为了支持增强型并发卷组，必须（在集群中的所有节点上）安装 bos.clvm.enh 文件集。增强型并发卷组引入了一个新的子系统 (gsclvmd)。可以通过查询这个子系统查明活跃的增强型并发卷组。

清单 10. 查询 gsclvmd 子系统

# lssrc -s gsclvmd
Subsystem Group PID Status
gsclvmd 327756 active

# ps -fp 462906
UID PID PPID C STIME TTY TIME CMD
root 462906 327756 0 Nov 04 - 0:02 /usr/sbin/gsclvmd -r 30 -i 300 -t 300 -c
00c79a6000004c0000000123a2278720 -v 0

# lssrc -ls gsclvmd
Subsystem Group PID Status
gsclvmd gsclvmd 327756 active

Active VGs # 1
vgid pid
00c79a6000004c0000000123a2278720 462906

可以使用 CSPOC 为共享卷组启用增强型并发模式（Fast Disk Takeover）。

清单 11. 启用增强型并发模式

# smit cl_vg
Shared Volume Groups

Move cursor to desired item and press Enter.

List All Shared Volume Groups
Create a Shared Volume Group
Create a Shared Volume Group with Data Path Devices
Enable a Shared Volume Group for Fast Disk Takeover
Set Characteristics of a Shared Volume Group
Import a Shared Volume Group
Mirror a Shared Volume Group
Unmirror a Shared Volume Group

关于 PowerHA 和虚拟存储支持的更多信息，请参见 IBM 技术文档和 PowerHA 文档。

结束语

这只是实现这种配置的方法之一。我希望这些简短的提示有助于您了解如何在 VIO 环境中实现 PowerHA。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-powerha/

Top


业务弹性相关链接

方案建议书：

1.存储高可用解决方案建议书

2.IBM存储容灾解决方案建议书

3.企业级存储 DS8000 容灾方案建议书

4.IBM SVC 异构存储容灾方案建议书

5.连续数据保护解决方案建议书(DS3000/DS4000 + TSM FastBack)

6.企业数据保护及备份方案建议书(DS4700/DS5000+TS2900/TS3100)

7.企业业务连续性解决方案建议书(System x3850M2+DS4700/DS5000)

8.企业业务连续性方案建议书(Power550/520 + DS4700/DS5000)

9.IBM 存储整合方案建议书 —— IBM SVC + DS5000/DS4700

10.IBM 存储融合解决方案建议书 ——IBM DS5000 + Gateway

11.IBM企业业务连续性方案建议书 ——Power 550/520 + DS4700/DS5000

12.同城灾备解决方案 建议书

13.业务连续和灾备基本概念和规划方法论介绍

14.IBM Power 高可用性解决方案 (1.95 MB)

15.智慧地球--动态架构之业务弹性方案建议书

16.数据存储及备份解决方案

17.软件业务连续性解决方案

18.IBM 动态架构 - Power 服务器业务连续性方案建议书

19.业务连续和灾难恢复服务

20.IBM Power 服务器高可用性方案建议书

21.业务不间断的高可用解决方案建议书

红皮书：

1.《IBM PowerHA SystemMirror 7.1 for AIX》

2.《IBM eServer pSeries HACMP V5.x Certification Study Guide Update》

3.《PowerHA for AIX Cookbook》

4.《Exploiting IBM PowerHA SystemMirror Enterprise Edition》

5.《Implementing the IBM System Storage SAN Volume Controller V6.1》

6.《IBM SAN Volume Controller and Brocade Disaster Recovery Solutions for VMware》

7.《Implementing the IBM Storwize V7000》

8.《IBM Storage Infrastructure for Business Continuity》

9.《IBM System Storage Business Continuity Solutions Overview》

10.《IBM XIV Storage System: Copy Services and Migration》

11.《IBM System Storage DS Storage Manager Copy Services Guide》

12.《IBM System Storage DS8000: Copy Services in Open Environments》

13.《IBM System Storage N series with VMware ESX Server》

相关链接：

IBM HAMCP 官方网站

HACMP 在线信息中心

IBM HACMP 资源中心

全面的存储解决方案

Top


IBM专家热门推荐书籍

本期，《速查手册》更新了推荐热门书籍栏目。由IBM资深专家为我们推荐了与产品和技术相关的热门书籍，便于我们对IBM产品和技术的学习。

热门白皮书推荐

热门红皮书推荐


热门白皮书推荐

Power

1.《IBM Storwize V7000 with IBM PowerHA SystemMirror》（英文）

简介：本文对相关概念和解决方案的论证，旨在说明IBM Storwize V7000配合AIX系统下的IBM PowerHA SystemMirror，可以帮助您满足苛刻的企业级高可用性（HA）要求。PowerHA SystemMirror可以自动发现服务器资源的失效，并将应用从失效服务器移动到群集中正常工作的Power服务器上，Storwize V7000可以提供共享并发卷功能，系统管理员通过使用这些强大的功能可以避免或尽量减少计划内和计划外的停机。

Storage

1.《Disaster recovery using Veritas Storage Foundation Enterprise HA with IBM Storwize V7000 Metro Mirror and Global Mirror》（英文）

简介：本文描述了Symantec的Veritas Storage Foundation和IBM Storwize V7000的安装、配置，以及基于Oracle数据库的高可用（HA）与容灾（DR）方案的配置方法。

2.《Performance benefits of IBM Storwize V7000 with Easy Tier for Oracle 11g workload》（英文）

简介：本文通过Oracle的ORION和Vdbench测试工具模拟联机事务处理(OLTP)环境和工作负载，描述了Oracle 11g数据库应用IBM Storwize V7000的Easy Tier功能后的性能优势。

Top


热门红皮书推荐

Power

1.《IBM PowerHA SystemMirror 7.1 for AIX》（英文）

简介：IBM公司AIX操作系统下的 PowerHA SystemMirror 7.1，是IBM Power服务器高在可用性领域的主要产品。此版本与IBM高可用性解决方案和AIX操作系统有着更紧密的结合。IBM Systems Director通过与PowerHA SystemMirror 7.1的集成，可以支持SAP Smart Assist and cache support功能、IBM系统存储DS8000的Global Mirror功能以及日立存储。

这本IBM红皮书包括了AIX版IBM PowerHA SystemMirror 7.1的相关知识。本书的出版非常必要，它介绍了PowerHA基本原理的改变，特别是和以前版本PowerHA的不同之处。

这本红皮书出归纳了PowerHA SystemMirror 7.1版本的最新功能，并且阐述了如何规划、安装和配置PowerHA与Cluster Aware AIX（CAA）集群组件，并且介绍了PowerHA SystemMirror Smart Assist for DB2的功能。本书将指导您如何从以前版本PowerHA升级到7.1版本，并且演示如何对PowerHA 7.1版本进行监控，测试以及故障排除。此外，本书还演示了如何使用IBM Systems Director for PowerHA 7.1，如何安装IBM Systems Director Server和PowerHA SystemMirror插件。本书还介绍了如何使用 IBM DS8700的Global Mirror功能和日立TrueCopy与Universal Replicator功能实施灾难恢复。

本书的读者是所有为企业规划和实施高可用解决方案的技术人员，包括IT咨询师，IT架构师，技术支持人员和IT专家。

2.《IBM BladeCenter PS703 and PS704 Technical Overview and Introduction》（英文）

简介：IBM BladeCenter PS703和PS704是64位应用程序的首选刀片服务器。它们被设计用来最大限度减少复杂性，提高效率，流程自动化，减少能源消耗和易衡量。PS703和PS704刀片服务器使用IBM POWER7，支持AIX，IBM i 和Linux操作系统。

PS703和PS704和其他IBM刀片服务器使用相同的刀片中心，可快速交付使用，提高了投资回报率。

这本IBM红皮书是一个涵盖了PS703和PS704刀片服务器的全面的指南，详细介绍了产品的突出特性和功能。

3.《IBM Systems Director VMControl Implementation Guide on IBM Power Systems》（英文）

简介：IBM Redbooks的发布可以帮助您安装和配置基于IBM Systems Director VMControl的解决方案，因此您可以超越简单的虚拟化管理使用，通过虚拟化的使用，您可以更好的管理您的IT基础设施。本书描述了怎样基于IBM System Director 和 VMControl 来减少设备的购置成本，管理成本通，增强设备的使用率和改进系统架构性能，以达到您的商业目标

本书对于怎样使用VMControl 简单的管理虚拟化环境通过多样的虚拟化技术和硬件平台，传递给您企业范围内的技术可见性和可控性提供了一个广泛的理解。一个主导型的多平台虚拟化管理解决方案。VMControl现已可使用三个版本，易捷版，标准版和企业版，可以最好的匹配您的虚拟化环

此外，这本书也描述了VMControl企业版本嵌入到IBM Systems Director，通过使用工作量优化的方法来减少IT基础设施的费用，提高服务水平。通过使用VMControl企业版， 您可以通过一个单一的系统简单的集中管理多个系统，为云计算和动态基础设施提供了一个必要的能力。

Storage

1.《IBM XIV Storage System: Copy Services and Migration》（英文）

简介：本文重点介绍了XIV存储系统的复制与迁移功能。XIV存储系统拥有丰富的复制功能，可以实现数据保护，增强客户的业务连续性、数据迁移的能力以及在线备份功能。这些复制功能包括，时间点拷贝，即快照和完整卷拷贝；包含同步和异步模式的远程复制。这些复制功能包含在XIV的软件中，不需要额外的费用。

2.《IBM System Storage DS Storage Manager Copy Services Guide》（英文）

简介：本文为客户提供了IBM DS3000、DS4000和DS5000系列存储复制功能的指南和推荐配置。本文中的DS系列存储使用v7.70版本的微码，以及v10.70版本的IBM System Storage DS Storage Manager。

IBM中端系列存储提供了以下三种复制服务的功能，包括：
IBM FlashCopy
VolumeCopy
Enhanced Remote Mirroring (ERM)

Top


虚拟租赁计划(VLP)

该虚拟租赁计划(VLP)提供免费远程访问IBM的硬件，包括在IBM AIX、IBM i和Linux操作系统中运行的基于IBM POWER6和 IBM POWER5处理器的服务器。

全自动的 IBM Virtual Loaner Program (VLP) 是使用 IBM 平台开发和演示软件解决方案的灵活而经济高效的方法。VLP 可供全球 IBM PartnerWorld 成员免费使用，具备以下关键优势：

.基于 Web 的预约、系统管理和用户支持；

.多语言支持，包括简体中文、马来语、日语、西班牙语、葡萄牙语、法语和韩语；

.高度安全地按需访问 IBM Power Systems 平台，其中包括 IBM AIX, IBM i、Linux SLES 和 RHEL；

.保存和恢复系统映像以供将来使用；

.通过 IBM 软件访问目录免费访问 IBM 中间件；

.能够测试最新的 Power Systems 虚拟化技术；

.实时 Web 对话和基于电子邮件的用户支持；

.制作 VLP 预约教程：ibm.com/partnerworld/wps/static/flash/flamovie/vlp_reservation072507.swf

VLP 特性：

.IBM Power Systems：POWER7、POWER6、POWER5；

.IBM Power 570 和 IBM BladeCenter POWER 服务器；

.IBM AIX 5.3 和 AIX 6.1；

.IBM i 5.4 和 IBM i 6.1；

.Red Hat：RHEL4 和 RHEL5; SUSE：SLES9、SLES10 和 SLES11；

.IBM 软件（从 IBM 软件访问目录 (SAC) 提供）；

.IBM PowerVM Lx86、Dynamic LPAR、Live Partion Mobility、Live Application Mobility、Workload Partitions 和 Micropartitions。

VLP 拥有优良的记录。自 2004 年以来，VLP 已为超过 2000 个 IBM 业务合作伙伴的 14000 多个系统预约提供支持。

VLP连接 的用户指南(中文)

VLP连接 的用户指南(英文)

详细了解 VLP 或请求租赁，请访问：VLP网站。

Top


竞争分析工具

本期更新了Power和存储产品的竞争分析工具及链接，便于大家快速查询与友商相应产品之间的竞争分析信息。

1. IBM Power Systems Competitive Sales Tool

Version 20.1 (May 4, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/B48EB3335EFE53390025730900271CD0?Opendocument?OpenDocument

2.IBM System Storage Competitive Sales Tool

Version 11.2 (April 22, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/4F68C0CF2311C10D002573720020B21B?Opendocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件


2011年第1季度热门问题排行榜

本期热门问题排行榜, 由高到低列出了第1季度客户最常问的20个问题，便于大家查看和学习。

2011年第1季度热门问题排行榜 - Power

2011年第1季度热门问题排行榜 - Storage


Power和Storage产品技术支持信息周报

Power&Storage产品技术支持信息周报

为了帮助IBM合作伙伴更方便、更及时地获得IBM最新的产品和技术信息，IBM中国技术支持中心推出“技术周报”的免费支持服务，每周以手机短信、电子邮件和发布在IBM技术支持网站的方式，提供最近一周"常见的五至十个技术问题和答案"，内容主要针对System Power与存储产品，服务对象是和IBM签约的合作伙伴。如果您需要免费订阅或退订此服务，请联系IBM 业务合作伙伴专线 800-810-1166 分机 5060。

Power and Storage技术周报

Power and Storage技术周报

2010-06, 第一期，Power&存储 产品技术支持信息周报

2010-05, 第四期，Power&存储 产品技术支持信息周报

2010-05, 第三期，Power&存储 产品技术支持信息周报

2010-05, 第二期，Power&存储 产品技术支持信息周报

2011-05, 第一期，Power&存储 产品技术支持信息周报

2011-04, 第三期，Power&存储 产品技术支持信息周报

2011-04, 第二期，Power&存储 产品技术支持信息周报

2011-04, 第一期，Power&存储 产品技术支持信息周报

2011-03, 第五期，Power&存储 产品技术支持信息周报

2011-03, 第四期，Power&存储 产品技术支持信息周报

2011-03, 第三期，Power&存储 产品技术支持信息周报

2011-03, 第二期，Power&存储 产品技术支持信息周报

2011-03, 第一期，Power&存储 产品技术支持信息周报

2011-02, 第二期，Power&存储 产品技术支持信息周报

2011-02, 第一期，Power&存储 产品技术支持信息周报

2011-01, 第三期，Power&存储 产品技术支持信息周报

2011-01, 第二期，Power&存储 产品技术支持信息周报

2011-01, 第一期，Power&存储 产品技术支持信息周报

2010-12, 第五期，Power&存储 产品技术支持信息周报

2010-12, 第四期，Power&存储 产品技术支持信息周报

2010-12, 第三期，Power&存储 产品技术支持信息周报

2010-12, 第二期，Power&存储 产品技术支持信息周报

2010-12, 第一期，Power&存储 产品技术支持信息周报

2010-11, 第四期，Power&存储 产品技术支持信息周报

2010-11, 第三期，Power&存储 产品技术支持信息周报

2010-11, 第二期，Power&存储 产品技术支持信息周报

2010-11, 第一期，Power&存储 产品技术支持信息周报

2010-10, 第三期，Power&存储 产品技术支持信息周报

2010-10, 第二期，Power&存储 产品技术支持信息周报

2010-10, 第一期，Power&存储 产品技术支持信息周报

2010-09, 第四期，Power&存储 产品技术支持信息周报

2010-09, 第三期，Power&存储 产品技术支持信息周报

2010-09, 第二期，Power&存储 产品技术支持信息周报

2010-09, 第一期，Power&存储 产品技术支持信息周报

2010-08, 第四期，Power&存储 产品技术支持信息周报

2010-08, 第三期，Power&存储 产品技术支持信息周报

2010-08, 第二期，Power&存储 产品技术支持信息周报

2010-08, 第一期，Power&存储 产品技术支持信息周报

2010-07, 第四期，Power&存储 产品技术支持信息周报

2010-07, 第三期，Power&存储 产品技术支持信息周报

2010-07, 第二期，Power&存储 产品技术支持信息周报

2010-07, 第一期，Power&存储 产品技术支持信息周报

2010-06, 第四期，Power&存储 产品技术支持信息周报

2010-06, 第三期，Power&存储 产品技术支持信息周报

2010-06, 第二期，Power&存储 产品技术支持信息周报

2010-06, 第一期，Power&存储 产品技术支持信息周报

2010-05, 第四期，Power&存储 产品技术支持信息周报

2010-05, 第三期，Power&存储 产品技术支持信息周报

2010-05, 第二期，Power&存储 产品技术支持信息周报

2010-05, 第一期，Power&存储 产品技术支持信息周报

2010-04, 第四期，Power&存储 产品技术支持信息周报

2010-04, 第三期，Power&存储 产品技术支持信息周报

2010-04, 第二期，Power&存储 产品技术支持信息周报

2010-04, 第一期，Power&存储 产品技术支持信息周报

2010-03, 第五期，Power&存储 产品技术支持信息周报

2010-03, 第四期，Power&存储 产品技术支持信息周报

2010-03, 第三期，Power&存储 产品技术支持信息周报

2010-03, 第二期，Power&存储 产品技术支持信息周报

2010-03, 第一期，Power&存储 产品技术支持信息周报

2010-02, 第三期，Power&存储 产品技术支持信息周报

2010-02, 第二期，Power&存储 产品技术支持信息周报

2010-02, 第一期，Power&存储 产品技术支持信息周报

2010-01, 第四期，Power&存储 产品技术支持信息周报

2010-01, 第三期，Power&存储 产品技术支持信息周报

2010-01, 第二期，Power&存储 产品技术支持信息周报

2010-01, 第一期，Power&存储 产品技术支持信息周报

2009-12, 第五期，Power&存储 产品技术支持信息周报

2009-12, 第四期，Power&存储 产品技术支持信息周报

2009-12, 第三期，Power&存储 产品技术支持信息周报

2009-12, 第二期，Power&存储 产品技术支持信息周报

2009-12, 第一期，Power&存储 产品技术支持信息周报

2009-11, 第四期，Power&存储 产品技术支持信息周报

2009-11, 第三期，Power&存储 产品技术支持信息周报

2009-11, 第二期，Power&存储 产品技术支持信息周报

2009-11, 第一期，Power&存储 产品技术支持信息周报

2009-10, 第三期，Power&存储 产品技术支持信息周报

2009-10, 第二期，Power&存储 产品技术支持信息周报

2009-10, 第一期，Power&存储 产品技术支持信息周报

2009-09, 第五期，Power&存储 产品技术支持信息周报

2009-09, 第四期，Power&存储 产品技术支持信息周报

2009-09, 第三期，Power&存储 产品技术支持信息周报

2009-09, 第二期，Power&存储 产品技术支持信息周报

2009-09, 第一期，Power&存储 产品技术支持信息周报

2009-08, 第四期，Power&存储 产品技术支持信息周报

2009-08, 第三期，Power&存储 产品技术支持信息周报

2009-08, 第二期，Power&存储 产品技术支持信息周报

2009-08, 第一期，Power&存储 产品技术支持信息周报

2009-07, 第五期，Power&存储 产品技术支持信息周报

2009-07, 第四期，Power&存储 产品技术支持信息周报

2009-07, 第三期，Power&存储 产品技术支持信息周报

2009-07, 第二期，Power&存储 产品技术支持信息周报

2009-07, 第一期，Power&存储 产品技术支持信息周报

Top


《IBM Power和Storage售前技术火线速查手册》调查反馈

《IBM Power&Storage售前技术火线速查手册》调查表

注： 为必填选项

1.姓名：

2.公司(非IBM BP请详细填写公司名称,IBM客户请填写客户)：

3.请选择您在销售过程中，经常用到的IBM售前配置工具：

IBM Power&Storage售前技术火线速查手册
e-Config配置工具（Power和存储）
TPCC计算小工具
POWER6/POWER7产品e-Config配置输出文件转中文小工具
存储产品e-Config配置输出文件转中文小工具
电源计算工具
销售手册快速查询通道
其它

4.《IBM Power&Storage售前技术火线速查手册》的推出是否对您有所帮助：

5.请具体指出本手册在下列哪些方面为您提供了帮助：

提高现有技术水平
了解新的技术知识
发现新的商机
其它

6.请选择您对《IBM Power&Storage售前技术火线速查手册》2011年第2期的满意度：

(10为满意度最高，1为满意度最低)

7.您认为本手册每周能帮助您节省多少工作时间：

小于3小时
3-6小时
6-9小时
9小时以上

8.《IBM Power&Storage售前技术火线速查手册》在内容方面您比较满意哪些方面：

售前常见问题汇总
售前常见配置问题汇总
携手IBM，开启业务弹性之旅
IBM专家推荐热门书籍
竞争分析工具
2011年1季度最热门问题
Power&Storage产品技术支持信息周报
其它

9.您希望我们今后在哪些技术领域及解决方案方面给您提供更多的技术支持（包括其他改进意见）：


如何获取《IBM Power和Storage售前技术火线速查手册》新版本

如何获取《IBM Power&Storage售前技术火线速查手册》新版本

关于《IBM Power&Storage售前技术火线速查手册》下载的信息：

下载网址： http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=7&docordown=7

下载方式：具体方式如下图，通过选择“Cross Platform”，然后点击“Go”，可以查询到最新版的《IBM Power&Storage售前技术火线速查手册》，然后进行登录和下载。

手册使用介绍：

课程名称：《IBM Power&Storage售前技术火线速查手册》使用介绍
课程介绍：教您如何使用《IBM Power&Storage售前技术火线速查手册》及IBM技术支持工程师日常使用的查询工具
课程回放：https://sas.elluminate.com/dr.jnlp?suid=D.C79E79573E026A4A43AD0A52D5AB94&sid=2008517

如何开通下载权限和注册方式?

. 如果您已有个人售前技术咨询专号(Service ID)，并为IBM技术支持网的注册用户，可以直接下载最新版的《IBM Power&Storage售前技术火线速查手册》；

. 如果您已有个人售前技术咨询专号(Service ID)，但还未成为IBM技术支持网的注册用户，请从如下链接去注册您的个人用户名。请注意，在注册中“联系方式”一项，需要填写与Service ID所对应的手机号，否则将有可能无法下载此手册；

注册网址：https://www-900.ibm.com/cn/support/register.jsp

. 如果您已是IBM技术支持网的注册用户，但未申请个人售前技术咨询专号(Service ID)，请致电 800-810-1166 或 010-82456688，分机5060申请开通下载此手册的权限。

请您阅读并遵守此手册的使用条款，下载完此手册后请勿网站上载及传播。如果您对此手册的下载有任何疑问，请致电业务合作伙伴专线800-810-1166 或010-82456688，分机5060。

如果您有任何意见和建议，请您在此手册的调查反馈表中，直接填写并提交，我们期待您的任何反馈。感谢您的合作与支持！


联系我们

如果您有任何意见和建议，欢迎与我们联系。

E-mail： techline@cn.ibm.com

Tel：8008101166-5060 / (010)82456688-5060

IBM中国技术支持中心 编制


使用条款

《IBM Power&Storage售前技术火线速查手册》（下面简称为“速查手册”）,非IBM正式电子出版物,仅供IBM内部销售人员和IBM核心合作伙伴参考使用。使用此“速查手册”，您即承认您已阅读、理解并同意受这些条款的约束，并遵守所有适用的法律和法规。如果您不同意这些条款，请不要使用此“速查手册”。

IBM 可随时通过更新“速查手册”来修改这些“使用条款”以及此“速查手册”中包含的任何其他信息，而无需通知您。IBM 还可以随时对此“速查手册”中描述的产品、服务或程序进行改进或更改，而无需另行通知。

此“速查手册”包含所有权声明和版权信息，您必须遵守并服从所有相关的条款。未经 IBM 事先的书面同意，不得在其他网站上载、张贴、传播、分发或使用此“速查手册”及其中的所有内容创作演绎作品，除非 IBM 授予您一份非专属的、不可转让的且有限的许可，允许您仅在您的计算机上为了您个人使用而非商业性使用此“速查手册”的目的访问和显示此“速查手册”内的内容。此许可权的条件是：您不修改此“速查手册”的内容，完整地保留所有的版权、商标和其他专有权声明并且您接受该内容随附的任何条款、条件和声明，及此“速查手册”中的所有其他规定。

如果您未遵守此“速查手册”上的条款、条件和声明，则授予您的任何权利将自动终止，而无需事先通知，并且您必须立即销毁您所拥有或掌握的所有已下载资料副本。除了前一段中的有限许可权，IBM不授予您关于任何专利、商标、版权或其他专有权或知识产权的任何明示的或暗含的权利或许可。您不得在另一个 Web 站点或任何其他介质中设置此“速查手册”任何内容的镜像。

特定免责条款

此“速查手册”的信息不附带任何有关正确性、最新性及完整性的承诺和保证，并且此“速查手册”可能包含有技术方面不够准确的地方或排字错误。IBM 不承担以下责任（且明确声明免除以下责任）：更新此“速查手册”使信息保持最新或者确保任何已张贴信息的准确性或完整性。因此，关于此“速查手册”中描述的任何服务、产品或其他事项作出任何决策之前，您应该确认所有已张贴信息的准确性和完整性。

IBM 不保证任何被告知／报告的问题将由 IBM 解决，即使 IBM 选择为了解决某个问题提供信息，也是如此。

业务关系

此“速查手册”可能提供非 IBM Web 站点和资源的链接或引用。IBM 对于任何非 IBM Web 站点或第三方资源（包括任何 Lenovo Web 站点）不作任何声明、保证或其他承诺，即使这些 Web 站点或第三方资源可能引用了任何 IBM 站点，或者可从任何 IBM 站点访问或链接到任何 IBM 站点。到某个非 IBM Web 站点的链接并不意味着 IBM 认可此类 Web 站点的内容或使用或其所有者。此外，IBM 不是您可能与任何第三方签署协议的任何交易的一方也不对任何交易负责，即使您从某个 IBM 站点了解到此类第三方（或使用到此类第三方的链接），也是如此。因此，您承认并同意，IBM 不对此类外部站点或资源的可用性负责，也不对可从那些站点或资源上获得的任何内容、服务、产品或其他资料承担任何责任或义务。

当您访问某个非 IBM Web 站点（即使该站点可能包含 IBM 徽标），请理解该 Web 站点与 IBM 无关并且 IBM 不控制该 Web 站点上的内容。您须谨慎从事，避免遭受病毒、蠕虫病毒、特洛伊木马和其他可能的破坏性程序入侵并采取您认为适当的方式保护您的信息。

翻译

此“速查手册”中某些文本提供有英语以外的其他语言。文本可能由人员翻译或者仅由计算机软件翻译，而没有人的参与或审核。这些翻译版是为了您的方便起见提供的，关于 翻译（无论机器翻译的或人翻译的）的准确性或完整性，IBM 不作任何声明或承诺。请参阅下面的“不保证声明”以了解更多的条款和条件。

不保证声明

使用此“速查手册”所带来的风险由您自行承担。所有资料、信息、产品、软件、程序和服务均“按现状”提供，不附有任何形式的保证或担保。在法律许可的最大范围内，IBM 明确声明免除所有明示的、暗含的、法定的和其他保证、担保、声明或承诺，包括但不限于有关适销、适用于某种特定用途以及有关所有权和知识产权的非侵权的保证。在不受任何限制的情况下，IBM 不保证，此“速查手册”将不中断、及时、安全或无错误。

您理解并同意，如果您下载或以其他方式获得此“速查手册”，则您自行决定执行上述操作，且风险由您自行承担，并且您须自行负责可能产生的任何损害赔偿，包括数据的丢失或对您的计算机系统的损害。

某些司法区域的强制性法律不允许对保证有所排除，在此情况下则上述排除可能不适用于您。

责任限制

任何情况下，对于此“速查手册”导致的或由于使用此“速查手册”或由于使用链接到、引用此“速查手册”或通过此“速查手册”访问的任何站点或资源，或者由于使用、下载或访问任何资料、信息、产品或服务而导致的或与之相关的任何直接的、间接的、附带的、特别的、惩戒性的或任何种类的后果性的损害赔偿，包括但不限于任何利润的损失、商业中断、可节省金额的损失或者程序或其他数据的丢失，IBM 均不对任何一方负责，即使 IBM 已被明确告知可能有此类损害赔偿时，也是如此。这种关于责任的排除和放弃适用于所有诉因，无论是基于合同、保证、民事侵权行为还是任何其他法律理论。

附加的或不同的条款、条件和声明可能适用于通过此“速查手册”提供的特定资料、信息、产品、软件和服务。如有任何冲突，此类附加的或不同的条款、条件和声明将优先适用于这些“使用条款”。请参阅相应的协议或声明。

Top


2011年第1季度热门问题排行榜 - Power

(1) Power 720/740 硬盘背板介绍

(2) 如何配置Power 550服务器内置磁盘分区的功能

(3) System P 系列 Server 的 CPU, Memory, IO 的带宽

(4) Power 720/740支持的PCI槽位信息

(5) 如何配置Power 520和550 3个及以上分区

(6) Power 550六种硬盘背板的介绍

(7) 如何配置Power 750三个及以上分区

(8) 如何在Power750上实现硬盘背板的分离

(9) Power720/740的内存配置及规则

(10) Power710/730 硬盘背板介绍

(11) 在e-config中，Power 720/740 可以配置的内置磁带机和磁带介绍

(12) 怎样配置fc#5796和fc#5802的IO抽屉

(13) 刀片做HACMP推荐方案

(14) System P Server 的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备

(15) 如何在Power770/780上实现硬盘背板的分离

(16) Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆

(17) Power 570 在一个CEC中，如何配置2个分区

(18) 7014-T00/T42/B42机柜PDU和电源线的配置

(19) 什么是PowerVM

(20) 在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

Top


2011年第1季度热门问题排行榜 - Storage

(1) V7000 软件在e-config中的配置方法

(2) DS5020 e-config中Adapters选项配置

(3) DS5020 e-config中Features选项配置

(4) B24/B40/B80三款SAN交换机SFP模块与光纤线的选择

(5) DS5020 接口类型、数量及相关问题

(6) TS7650G 软件的配置方法

(7) DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？

(8) B24/B40/B80配置中所有License包含的功能

(9) Storwize V7000 硬件的HDDs配置

(10) DS5100/DS5300 主机接口卡的配置方式

(11) DS8700硬盘选择及配置

(12) DS8700 e-Config中HA/Cables的配置

(13) TS7650(3958-AP1)硬件中Features的配置

(14) TS7650G(3958-DD4)硬件中features的配置

(15) TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型

(16) TS3100 TS3200 TS3310 TS3500 e-config中feature选项的配置注意事项

(17) TS7650 TS7650G e-config中console选项的配置注意事项

(18) DS8700 e-Config中Opt/Admin的配置

(19) DS5100 License配置(Host kit、Storage Partition、FlashCopy、VolumeCopy、ERM等)

(20) Storwize V7000 硬件的SFP配置


DS5100 License配置(Host kit、Storage Partition、FlashCopy、VolumeCopy、ERM等)

解答:

fc#77xx Host kit是必选项（至少选择一项），可以根据连接DS5100服务器的操作系统，选择相应的Host kit；

fc#89xx Storage Partition是必选项，根据客户需求选择相应数量，最少8个Partition, 最多512个Partition。关于Partition更多信息可参考以下链接：
http://www-900.ibm.com/cn/downloadfiles/tsc/faq/2694056L12000.doc

fc#203x Cache Memory是必选项，DS5100支持8、16、32和64GB缓存，可以根据性能需求选择；

Flash/VolumeCopy，Enhanced Remote Mirror，Disk Encryption Activation是可选项，实现快照/卷拷贝，远程拷贝与加密功能。

fc#7350是Flash/VolumeCopy，包括快照功能和卷拷贝功能选件。快照功能可以很快完成数据卷的拷贝，对于测试、备份等应用有很大帮助。VolumeCopy是数据从源卷到目标卷的完全复制，是数据的物理拷贝。通常VolumeCopy与Flashcopy结合使用。它利用了FlashCopy能够生成一份数据时间点快照的功能，保证了在卷拷贝数据复制过程中源卷的可用性和目标卷数据的一致性。Flash/VolumeCopy是在同一个DS5100内实现的功能。

fc#7353是Enhanced Remote Mirror增强型远程镜像选件，可以把本地DS5000上的数据通过光纤同步或者异步复制到远端的DS5000上，从而可以实现DS5000数据的容灾。fc#7356可以将镜像对数量从64个提高到128个。Enhanced Remote Mirror是在两台DS5100之间实现的功能。

fc#7358是磁盘加密选件，需要配合扩展柜中的fc#552x和fc#554x加密硬盘使用。全盘加密（FDE）磁盘驱动器能够显著减少所存储数据存在的安全漏洞。遵从“受信任存储器组（Trusted Storage Group，TCG）”企业安全子系统分类规范的 FDE 磁盘驱动器获得国家安全局（National Security Agency）的资格认证，提供了具有政府级别加密功能的安全性。

此外，DS5100默认支持SATA和FC硬盘混插，如果一个DS5100存储子系统包括FC和SATA硬盘，不需要购买许可，默认即可支持。

fc#7371是扩展柜许可选件，DS5100默认最大支持16个1818-D1A，如果1818-D1A大于16个，需要选择该选件；fc#7371，最大支持28个1818-D1A扩展柜。

fc#7372是扩展柜许可选件，DS5100默认最大支持7个EXP5060高密度扩展柜，如果配置8个EXP5060，需要该选件fc#7372和fc#7371，最大支持8个EXP5060扩展柜。

网络课堂：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000


DS8700 e-Config中HA/Cables的配置

解答：

在"Host/Adapter"中，可以配置用于连接前端主机或SAN交换机的主机接口卡，每一块卡提供四个主机接口。每台DS8700至少要配置2块主机接口卡，如果选择#4302 4核心的处理器卡的时候，可以增加扩展柜，实现最多32块主机接口卡。

共有五种类型可以选择：
(#3143) 4Gb SW FCP/FICON Adapter PCIE
(#3243) 4Gb LW FCP/FICON Adapter PCIE
(#3245) 4Gb 10km LW FCP/FICON Adapter PCIE
(#3153) 8Gb 4 port SW FCP/FICON Adapter PCIE
(#3253) 8Gb 4 port LW FCP/FICON Adapter PCIE

在"Cable"中,可以配置 50微米多模或9微米单模，31米长，LC或LC/SC接口类型的光纤线。
(#1410) 50 μm Fibre Cable(LC)
(#1411) 50 μm Fibre Cable(LC/SC)
(#1412) 50 μm Fibre Cable(Jumper)
(#1420) 9 μm Fibre Cable(LC)
(#1421) 9 μm Fibre Cable(LC/SC)
(#1422) 9 μm Fibre Cable(Jumper)

通常情况下，如果选择短波的主机接口卡，则配置50微米的多模光纤线；如是选择了长波的主机接口卡，则配置9微米长波的光纤线。

现在大部分主机HBA卡接口与SAN交换机接口均为LC类型，所以我们选择LC类型的光纤线，即#1410和#1420。如果客户的主机HBA卡或交换机接口为SC类型，由于DS8700主机接口为LC类型，所以此时需要选择LC/SC类型的光纤张，即#1411和#1421。

Top


DS8700 e-Config中Opt/Admin的配置

解答：

在"Processor Memory"中，可以选择DS8700缓存的大小。当选#4301 2核心的处理器卡的时候，最大缓存为128GB；如果选择#4302 4核心的处理器卡的时候，最大缓存为384GB。

在"Optional Features"中，有很多feature可以选择，它们的功能如下：
(#0200) Shipping weight reduction
保证在DS8700在出厂运输过程中，机器最大重量不超过909公斤。

(#1000) Remote power control
激活远程电源控制功能。

(#1055) Extended PLD
此功能可以保证在意外掉电的情况下，DS8700还可以有最多50秒的电力供应。些选项适合没有UPS的环境。

(#1712) Release 5.1 Bundle Family
订购DS8700 5.1 版本微码

(#1722) DS8000 Licensed Machine Code R6.1
订购DS8700 6.1 版本微码

(#1980) Performance accelerator
允许DS8700每个磁盘环路对中最少只有32块磁盘，提高性能。

(#4301) 2-Way Processor Card
为DS8700中的每台Power 6 服务器提供2核心的处理器卡。DS8700中共有两台Power 6 服务器做为它的核心控制器。

(#4302) 4-Way Processor Card
为DS8700中的每台Power 6 服务器提供4核心的处理器卡。DS8700中共有两台Power 6 服务器做为它的核心控制器。

在"Administrative Indicators"中，可以选DS8700要连接主机系统类型。这些Indicators只用于管理目的，不影响机器的实际使用。

Top


TS7650(3958-AP1)硬件中Features的配置

解答:

TS7650(3958-AP1)Features配置如下：

(#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(#3170) 16 2.27 GHz Processor Cores
表示提供一个 x3850 X2 processor，是必须要选的，最大数量都是2，最小数量都是1。

(#3707) 4.8 TB FC Disk Expansion
表示是DS5020 expansion drawer，带有 16 块FC硬盘，是必须要选的，最大数量都是6，最小数量都是1。

(#3708) 4.8 TB FC Disk Controller
表示是DS5020 controller，带有 16 块FC硬盘，是必须要选的，最大数量都是2，最小数量都是1。

(#08XX) Initial Configuration Indicators
表示是初始配置容量的标示符。

以下分别是VTL和OST支持的4种配置方案：

Top


TS7650G(3958-DD4)硬件中features的配置

解答:

TS7650G(3958-DD4)Features的配置如下:

(#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(#3447) Cluster Connection Kit
这个产品号提供一个network power control switch, 2 个ethernet switches, 及相关的线缆和上架硬件，用来创建一个 clustered 配置在两个 TS7650 Servers之间.#3447（The Cluster Connection Kit）必须和 两个 TS7650 Servers放在同一个机柜中。如果有两个 TS7650 Servers做cluster，则#3447是必须的，否则，不需要订，两个做 cluster的TS7650 Servers只需在其中的一个上订购一个#3447。缺省的数量是0，最大数量是1。

(#9306) ProtecTIER EE V2 load
表示在TS7650 server上配置的软件版本是ProtecTIER Enterprise Edition V2 (PID 5639-XXB)，是必须要订的，缺省的数量是1，最大/最小数量都是1。

(#9340) Rack Mount DD1
表示TS7650G Server 需要放入客户提供的工业标准的 19英寸机柜，是必须要订的，缺省的数量是1，最大/最小数量都是1。

Top


配置POWER6-其他

其他

Power 520/550/560/570/595 CPU MEM Disk的配置规则?


机柜

后门热交换器技术