导言

《IBM售前技术火线速查手册》旨在帮助IBM和合作伙伴销售技术人员提升技术水平，及快速解决日常工作问题。本手册集成了IBM Power服务器和存储产品的常见售前问题；产品介绍、售前常用工具、文档及相关网站的链接；同时，提供最新制作的网络课程、网络课堂学习规划图给大家，帮助大家系统地学习IBM产品和技术。

本期常见问题的更新率达到了55%以上，更多特色亮点如下：

- 新增“携手 IBM，开启虚拟化之旅”栏目：介绍了与虚拟化相关的概念、技术、优势、相关产品；并为您提供了相应的白皮书、红皮书、案例以及虚拟化实战案例的链接等资料；

- 新增“2010年第4季度热门问题排行榜”：通过该排行榜，您可以快速查看第4季度的热门问题和答案；

- 更新“IBM专家推荐热门书籍”栏目，由IBM资深专家推荐给大家一些与产品、技术相关的热门书籍，帮助大家提高自身技术水平；

- 更新“竞争分析工具”：及时更新了Power,存储和System x的竞争分析工具。Power竞争分析工具的版本为：Version 19.1 (January 19, 2011)；存储竞争分析工具的版本为：Version 10.15（December 21, 2010）；System x竞争分析工具的版本为：Version 6.6 (January 26, 2011)；

- 更新“存储产品配置文件中英文翻译工具”：在存储产品中英文翻译工具中，添加了新推出的Feature Code的翻译；

- 更新“Power 和 存储 产品销售手册快速查询通道”：在Power产品销售手册快速查询通道中，添加了Power 520/550/595/JS23/JS43的计划停产时间；在Storage产品销售手册快速查询通道中，添加了TS7650G、 TS2230、TS2240、TS2250、N6210、N6240、SAN32B-E4的销售手册链接、产品物理参数，便于大家快速查询新发布产品的信息；

- 更新“Power 和 存储 产品家族一览表”：在Power和存储产品家族一览表中，更新了当前的相关产品，便于大家查看目前在产的产品信息；

- 更新“IBM POWER7家族便捷指南”：可以直接查看Power服务器(BladeCenter PS700/PS701/PS702, Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780)的产品参数信息。

下面是各产品本期更新情况的链接：

Power System - What's New

Storage System - What's New

注：本期FAQ的内容适用于当前的情况，如有更新，请关注后续的更新版本。另外，如果手册中涉及到了产品的维保信息，请以产品部提供的实时信息为准。


What's New Power

What's New

1.更新了Power服务器销售手册快速查询通道

本期更新了Power服务器销售手册快速查询通道，在该工具中，更新了Power 520/550/595/JS23/Js43的计划停产时间。

Power服务器销售手册快速查询通道

2.更新了Power家族服务器一览表

本期更新了Power家族服务器一览表，展现了目前在产的产品。

Power家族服务器一览表

3.更新了IBM POWER7家族便捷指南

本期更新了IBM POWER7家族便捷指南，可以直接查看Power服务器(BladeCenter PS700/PS701/PS702、Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780)的产品参数信息。

IBM POWER7家族便捷指南

4.更新了Power产品竞争工具链接

本期在Power产品速查手册的附录中，更新了最新版本的Power产品竞争工具链接。

Power产品速查手册附录

5.新增的网络课堂：(新增)

(1) AIX7简介

(2) DB2 pureScale on POWER

(3) GPFS解决方案介绍

(4) 通过VIOS实现双机的一些讨论

(5) AIX Security Feature -- ICE & EFS

(6) Power 710/730 and 720/740 配置详解

6.增加了24个新的热点问题：(新增)

(1) 能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘?

(2) Power 710/720/730/740/750/755/770/780支持的PCI槽位信息

(3) POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)

(4) POWER7入门级服务器Power 710/720/730/740中fc#2319 Factory Deconfiguration of 1-core的含义是什么？

(5) POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项

(6) Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置

(7) 在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗？

(8) POWER7全线产品家族分离背板总结

(9) BCH和BCS上有多种以太网交换机模块，如何为客户选择

(10) 如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块

(11) POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？

(12) AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？

(13) 没有硬盘槽位的fc#5873 I/O抽屉是否可以升级为带硬盘槽位的fc#5803？

(14) 主要有哪些POWER6上的adapter、硬盘等设备是POWER7不支持的？

(15) fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？

(16) 目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况

(17) Power服务器上使用NPIV的技术，是否需要额外的License

(18) PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术

(19) 什么是GPFS？以及其基本架构介绍

(20) GPFS基本创建过程以及常见注意事项

(21) GPFS中的Manager主要有哪几种,及区别

(22) 什么是NIM？它的应用场景以及基本概念介绍

(23) NIM中常见的资源类型以及各自的特点介绍

(24) 一个典型的NIM安装过程介绍

7.更新的FAQ：(最近更新)

(1) 刀片JS12/JS22与JS23/JS43的参数对比

(2) JS23/43和PS700/701/702 中CIOv/CFFh属性的卡都有哪些Features?都支持哪些操作系统？

(3) Power 520六种硬盘背板的介绍

(4) Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？

(5) Power 550六种硬盘背板的介绍

(6) Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？

(7) Power 720/740支持的PCI槽位信息

(8) Power 750(8233-E8B)硬盘背板的介绍

(9) Power 750(8233-E8B)的硬件特性

(10) Power 770/780硬盘背板介绍

(11) Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡

(12) POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug

(13) 什么是EXP 12S磁盘柜(产品号fc#5886)?可以用什么主机卡来连接它?是否有冗余电源和风扇?12S支持什么硬盘?

(14) 什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号

(15) System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备?

(16) System P服务器AIX与HACMP版本兼容性的问题; 另外，实施HACMP时，最常用的方法及所需要的基本硬件资源

(17) Power 750与PowerHA SystemMirror的兼容性

(18) 7216-1U2介绍

(19) 什么是PowerHA SystemMirror?

(20) 在一些Power机型中，支持内置RAID卡。在AIX 操作系统中，也可以使用LVM的mirror功能提供磁盘冗余保护。这两种磁盘冗余保护方式在性能和可用性上有何区别？

(21) BladeCenter H机箱中10个I/O插槽的配置规则

(22) 7989-BCH机箱怎样配置冗余的电源以及电源线？

(23) 如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？

(24) BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项

(25) 用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？

(26) POWER7 产品支持的操作系统

(27) 如何在Power 520/550 服务器上创建RAID 5?

(28) 如何实现Power 520和550的2个LPAR的RAID功能?

(29) 配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜

(30) 如何在Power 570上创建RAID 5?

(31) Power 710/730的内存配置及规则

(32) Power 720/740的内存配置及规则

(33) 如何实现Power 750的RAID功能

(34) POWER7服务器 CPU，MEM，DISK的配置规则

(35) System P 服务器配置中如何选配置电源线?

(36) 为什么必须要配置一对fc#5805的RAID卡？

(37) Power中异步卡和串口线的选择

(38) POWER服务器处理器能否升级，以及升级后支持的数量

(39) 在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

8.删除的FAQ：

(1) 什么是GPFS? 以及GPFS在HACMP中的运用？

(2) Power 560(8234-E4A)硬件特性

(3) 从外形和processor socket数量角度来看，POWER7服务器如何与原来的服务器对应？

(4) IBM PowerHA 是否支持DS5100/5300？是否支持DS4700/4800的MPIO

(5) IBM PowerHA SystemMirror v6.1 是否支持存储SVC 5.1

(6) 如何在Power 560上创建RAID5

(7) Power 560 在一个CEC中，如何配置2个分区

(8) fc#5903的RAID卡用什么SAS线连接SSD硬盘

(9) HBA卡fc#5759和fc#5774有何区别，为什么不推荐配fc#5759

(注：本手册删除的FAQ，仍可通过如下链接查询：http://www-900.ibm.com/cn/support/viewdoc/knowledgebase)


目录 常见问题汇总

目录

IBM Power Systems 常见问题汇总

刀片服务器

刀片JS12/JS22与JS23/JS43的参数对比 (最近更新)

刀片PS700/701/702的参数对比

PS700/701/702，JS12/22/23/43与刀片中心(BladeCenter)的兼容性

JS23/43和PS700/701/702 中CIOv/CFFh属性的卡都有哪些Features?都支持哪些操作系统？ (最近更新)

Power刀片服务器上可选择哪些8Gb的光纤卡

刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？ (新增)

POWER6

Power 520(8203-E4A)

Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？ (最近更新)

Power 520六种硬盘背板的介绍 (最近更新)

Power 550(8204-E8A)

Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？ (最近更新)

Power 550六种硬盘背板的介绍 (最近更新)

Power 595(9119-FHA)

Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同?是否可以混插?

Power 595服务器是否支持热节点添加的功能？

POWER7

Power 710/730(8231-E2B)

Power 710/730硬盘背板介绍

Power 720(8202-E4B)/Power 740(8205-E6B)

Power 720/740支持的PCI槽位信息 (最近更新)

Power 720/740硬盘背板介绍

Power 750(8233-E8B)

Power 750(8233-E8B)硬盘背板的介绍 (最近更新)

Power 750/755的区别

Power 750(8233-E8B)的硬件特性 (最近更新)

Power 755(8236-E8C)

Power 755(8236-E8C)的产品定位与硬件特性

Power 770(9117-MMB)

Power 770/780的区别

Power 770/780硬盘背板介绍 (最近更新)

Power 770(9117-MMB)的硬件特性

将Power 770/780放到T42机柜里，有哪些限制？

Power 780(9179-MHB)

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780(9179-MHB)的硬件特性

其他

哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因

POWER7的主要技术特点？

POWER7服务器与POWER6的主要区别有哪些

IBM eDRAM技术的特别之处是什么

介绍POEWR7处理器的缓存信息

什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

请简要介绍一下POWER7处理器的主要创新技术

POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡 (最近更新)

Power 710/720/730/740/750/755/770/780支持的PCI槽位信息 (新增)

Power 710/730/720/740硬件参数对比

POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)? (新增)

POWER7入门级服务器Power 710/720/730/740中fc#2319 Factory Deconfiguration of 1-core的含义是什么？ (新增)

POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug(最近更新)

I/O Drawer

什么是EXP 12S磁盘柜(产品号fc#5886)?可以用什么主机卡来连接它?是否有冗余电源和风扇?12S支持什么硬盘? (最近更新)

Power服务器I/O Drawer硬件特性及介绍

Power 595支持哪些I/O抽屉，各有什么特点？

没有硬盘槽位的fc#5873 I/O抽屉是否可以升级为带硬盘槽位的fc#5803？ (新增)

外设

P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号 (最近更新)

目前支持的几款HMC介绍及配置注意事项

在没有HMC的情况下，如何远程管理Power服务器

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备? (最近更新)

7216-1U2介绍 (最近更新)

USB移动硬盘设备介绍，以及与磁带驱动器的比较

虚拟化技术 (PowerVM)

动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

System P服务器分区技术中的Physical Shared Processor Pool,Multiple Shared Processor Pool, Shared Dedicated Capacity 介绍

PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

表格列举不同Power服务器的型号所能够支持的PowerVM的features

什么是PowerVM？

PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用

IVE介绍及特性

Power服务器的内置光驱是否可以进行DLPAR

刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？

PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？

Power服务器支持分区的最大数量是多少？

将VIOS client AIX分区用于HA集群中的node时，要求配置双VIOS吗？以及原因

将VIOS client AIX分区用于HA集群中的node时，如果采用VIOS级别上的网络冗余功能，AIX操作系统和HA软件需要再对网络进行冗余设置吗? 如果不需要,HA支持单网卡配置吗

目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况 (新增)

Power服务器上使用NPIV的技术，是否需要额外的License (新增)

PowerHA

System P服务器AIX与HACMP版本兼容性的问题; 另外，实施HACMP时，最常用的方法及所需要的基本硬件资源 (最近更新)

Power 710/730与PowerHA SystemMirror for AIX的兼容性

Power 720/740与PowerHA SystemMirror for AIX的兼容性

Power 750与PowerHA SystemMirror的兼容性 (最近更新)

Power 770/780与PowerHA SystemMirror for AIX的兼容性

POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性

什么是PowerHA SystemMirror? (最近更新)

PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术 (新增)

Linux on Power的高可用方案介绍

IP地址接管(IP Address Takeover IPAT)机制

做HA配置时，为了传输心跳信号，有哪些方案可以选择

什么是DB2 PureScale,它的主要功能以及特点介绍

什么是GPFS？以及其基本架构介绍 (新增)

GPFS基本创建过程以及常见注意事项 (新增)

GPFS中的Manager主要有哪几种,及区别 (新增)

性能与物理参数

服务器性能参数

System P系列服务器的CPU, Memory, I/O的带宽

物理环境参数

System P系列服务器的尺寸、环境要求、功率和重量

其它

P系列服务器显卡介绍

主要有哪些POWER6上的adapter、硬盘等设备是POWER7不支持的？ (新增)

常见SAS RAID Controller Adapter 介绍

Power System上Infiniband 产品的支持列表

什么是Power服务器的Storage Key?

POWER服务器处理器能否升级，以及升级后支持的数量 (最近更新)

POWER6 产品支持的操作系统

POWER7 产品支持的操作系统 (最近更新)

AIX V6.1支持的硬件环境

AIX V7.1支持的硬件环境

AIX EE 6.1版本包含哪些软件

什么是AIX Express Edition? 该版本有何要求？

AIX V7.1支持的几个新功能

IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

AIX V7.1 标准版，企业版，易捷版的区别

AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？ (新增)

简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

什么是NIM？它的应用场景以及基本概念介绍 (新增)

NIM中常见的资源类型以及各自的特点介绍 (新增)

一个典型的NIM安装过程介绍 (新增)

在一些Power机型中，支持内置RAID卡。在AIX 操作系统中，也可以使用LVM的mirror功能提供磁盘冗余保护。这两种磁盘冗余保护方式在性能和可用性上有何区别？ (最近更新)

POWER服务器的电源和耗电量计算方法

Power系列机型上共有多少种SAS连接线, 它们有什么不同?

FCoE支持的操作系统

为什么选择FCoE/FCoEE?

什么是IBM Systems Director Active Energy Manager?

IBM Systems Director 系统软件各个版本包含哪些软件

IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

5765-SEP IBM Systems Director Standard Edition for Power Systems软件和5765-DRP IBM(R) Systems Director for Power Systems的区别是什么

5765-AME软件的功能，以及其相应的替代产品


刀片服务器

刀片JS12/JS22与JS23/JS43的参数对比 (最近更新)

刀片PS700/701/702的参数对比

PS700/701/702，JS12/22/23/43与刀片中心(BladeCenter)的兼容性

JS23/43和PS700/701/702 中CIOv/CFFh属性的卡都有哪些Features?都支持哪些操作系统？ (最近更新)

Power刀片服务器上可选择哪些8Gb的光纤卡

刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？ (新增)


刀片JS12/JS22与JS23/JS43的参数对比

解答：

 | BladeCenter JS12 Express | BladeCenter JS22 Express | BladeCenter JS23 Express | BladeCenter JS43 Express
Architecture | 3.8 GHz POWER6 SCM 2-core (1 Socket) Single Wide | 4.0 GHz POWER6 SCM 4-core (2 Sockets) Single Wide | 4.2GHz POWER6+ DCM 4 core (2 Sockets) Single Wide | 4.2GHz POWER6+ DCM 8-core (4 Sockets) Double Wide
Memory | 2GB to 64 GB DDR2 (Chipkill) | 2GB to 32 GB DDR2 (Chipkill) | 4GB to 64GB DDR2 (Chipkill) | 4GB to 128GB DDR2 (Chipkill)
DASD / Bays | 0-2 SAS disk (146 or 300 or 600 GB) | 0-1 SAS disk (146 or 300 GB) | 0-1SAS disk (146 or 300 or 600 GB) SSD (69 GB) | 0- 2SAS disk (146 or 300 or 600 GB) SSD (69 GB)
Daughter Cards | Legacy, SFF or High speed DC | Legacy, SFF, or High speed DC | Legacy, SFF, or High speed DC | Legacy,SFF, or High speed DC
Integrated Features | KVM Dual Port 1Gb Ethernet SAS Controller USB | KVM Dual Port 1Gb Ethernet SAS Controller USB | KVM Dual Port 1Gb Ethernet SAS Controller USB | KVM Dual Port 1Gb Ethernet SAS Controller USB
Expansion Card Slot | One PCI-X CFFv One PCIe CFFh | One PCI-X CFFv One PCIe CFFh | One PCIe CIOv One PCIe CFFh | Two PCIe CIOv Two PCIe CFFh
Fiber Support | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter)
Redundant Power & Cooling | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter)
Service Processor | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL)
Virtualization | PowerVM Std Edition built-in | PowerVM Std Edition built-in | PowerVM Std Edition built-in | PowerVM Std Edition built-in
Systems Management | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology | IBM Director and CSM IBM EnergyScale Technology
OS Support | AIX, i,Linux | AIX, i,Linux | AIX, i,Linux | AIX, i,Linux
rPerf | 14.37 | 30.26 | 4W = 36.28 | 8W = 68.20
CPW | 7100 | 13800 | 14,100 | 26,590
BladeCenter Chassis Support | BCE, BCH, BCHT, BCT, BCS | BCH, BCHT, BCS | BCH, BCHT, BCS | BCH, BCHT, BCS

突出价值点：该参数表列出了目前Power家族的刀片服务器。刀片服务器与机架式服务器比较，其主要优势在于：更加节能和节省空间。 JS12/JS23/JS43拥有了IBM Active Energy Manger 和EnergySCale的技术，能帮助监控和控制供电和制冷。

Top


刀片PS700/701/702的参数对比

解答:

 | BladeCenter PS700 | BladeCenter PS701 | BladeCenter PS702
Architecture | POWER7 4-Core (1Socket x 4 Cores) Single Wide | POWER7 8-core (1 Socket x 8 Cores ) Single Wide | POWER7 16-core (1 Socket x 8 Cores per blade) Double Wide
Memory | 8 GB – 64 GB (1066 MHz ) | 16 GB – 128 GB ( 1066 MHz ) | 32 GB – 256 GB ( 1066 MHz
DASD / Bays | 0-2 SAS disk (300 or 600GB) | 0-1 SAS disk (300 or 600GB) | 0-2 SAS disk (300 or 600GB)
Daughter Cards | 1 PCIe CIOv Expansion Card 1 PCIe CFFh Expansion Card | 1 PCIe CIOv Expansion Card 1 PCIe CFFh Expansion Card | 2 PCIe CIOv Expansion Card 2 PCIe CFFh Expansion Card
Integrated Features | Dual Port 1Gb Ethernet SAS Controller USB | Dual Port 1Gb Ethernet SAS Controller USB | Quad Port 1Gb Ethernet SAS Controller USB
Scalability Support | No | Yes – Factory or Customer Upgrade | Yes – Factory or Customer Upgrade
Fibre Support | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter)
Redundant Power | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter)
Redundant Cooling | Yes (via BladeCenter) | Yes (via BladeCenter) | Yes (via BladeCenter)
Service Processor | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL) | FSP1 (IPMI, SOL)
Virtualization | IBM PowerVM | IBM PowerVM | IBM PowerVM
Systems Management | IBM Director , CSM, xCAT,IBM EnergyScale Technology | IBM Director , CSM, xCAT,IBM EnergyScale Technology | IBM Director , CSM, xCAT,IBM EnergyScale Technology
OS Support | AIX, i, Linux | AIX, i, Linux | AIX, i, Linux
rPerf | 45 | 81 | 154
CPW | 21,100 | 42,100 | 76,300
BladeCenter Chassis Support | BCE, BCH*, BCHT, BCS* | BCH*, BCHT, BCS* | BCH,* BCHT, BCS*

* In Power Systems Channel

突出价值点：该参数表列出了目前Power家族新推出的POWER7的刀片服务器。刀片服务器与机架式服务器比较，其主要优势在于：更加节能和节省空间。 PS700/PS701/PS702拥有了IBM Active Energy Manger 和EnergySCale的技术，能帮助监控和控制供电和制冷;还可以支持开源的集群管理软件：xCAT；与JS的刀片服务器相比，具有更高的rPerf值。


PS700/701/702，JS12/22/23/43与刀片中心(BladeCenter)的兼容性

解答：

PS700/701/702，JS12/22/23/43与刀片中心(BladeCenter)的兼容性如下（划√的表示兼容）：

 | PS700 | PS701 | PS702 | JS12 | JS22 | JS23 | JS43
BCE | √ |  |  | √ |  |  |
BCT |  |  |  | √ |  |  |
BCH | √ | √ | √ | √ | √ | √ | √
BCHT | √ | √ | √ | √ | √ | √ | √
BCS | √ | √ | √ | √ | √ | √ | √

突出价值点：每款刀片均被多款刀片中心所支持。这便于客户进行整合。


JS23/43和PS700/701/702中CIOv/CFFh属性的卡都有哪些Features?都支持哪些操作系统？

解答：

Card Name | Form Factor | Feature Code | Supported OS
 |  |  | JS23/43 | PS700/701/702
Emulex 8GB Fibre Channel | CIOv | 8240 | AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL02 SP4 AIX 6.1 TL03 IBM i 6.1 VIOS 2.1.1 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.7,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 4Gb Fibre Channel | CIOv | 8241 | AIX 5.3 TL07 SP9 AIX 5.3 TL08 SP7 AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL00 SP9 AIX 6.1 TL01 SP5 AIX 6.1 TL02 SP4 AIX 6.1 TL03 IBM i 6.1 VIOS 2.1.1 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.6,4.7,5.1,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 8GB Fibre Channel | CIOv | 8242 | AIX 5.3 TL07 SP9 AIX 5.3 TL08 SP7 AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL00 SP9 AIX 6.1 TL01 SP5 AIX 6.1 TL02 SP4 AIX 6.1 TL03 IBM i 6.1 VIOS 2.1.1 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.7,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
3Gb SAS Pass-through | CIOv | 8246 | AIX 5.3 TL07 SP9 AIX 5.3 TL08 SP7 AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL00 SP9 AIX 6.1 TL01 SP5 AIX 6.1 TL02 SP4 AIX 6.1 TL03 IBM i 6.1 VIOS 2.1.1 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.7,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 4Gb Fibre Channel and Broadcom 1 GB Ethernet Combo | CFFh | 8252 | AIX 5.3 TL07 SP9 AIX 5.3 TL08 SP7 AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL00 SP9 AIX 6.1 TL01 SP5 AIX 6.1 TL02 SP4 AIX 6.1 TL03 IBM i 6.1 VIOS 2.1.1 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.6,4.7,5.1,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
Mellanox 4X InfiniBand Dual Port | CFFh | 8258 | AIX 5.3 TL07 SP9 AIX 5.3 TL08 SP7 AIX 5.3 TL09 SP4 AIX 5.3 TL10 AIX 6.1 TL00 SP9 AIX 6.1 TL01 SP5 AIX 6.1 TL02 SP4 AIX 6.1 TL03 Not supported under IBM i Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.6,4.7,5.1,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i not supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 8Gb Fibre Channel | CFFh | 8271 | AIX 5.3 TL08 SP8 AIX 5.3 TL09 SP5 AIX 5.3 TL10 SP2 AIX 5.3 TL11 AIX 6.1 TL01 SP7 AIX 6.1 TL02 SP6 AIX 6.1 TL03 SP3 AIX 6.1 TL04 IBM i 6.1 VIOS 2.1.2.0 Novell SUSE Linux 10 SP2 Novell SUSE Linux 11 Red Hat 4.7,5.2,5.3 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported
QLogic 2-port 10Gb Converged Network Adapter | CFFh | 8275 | AIX 5.3 TL11 AIX 6.1 TL04 IBM i 6.1 Novell SUSE Linux 10 SP3 Red Hat 5.4 | AIX Version 5.3 supported AIX Version 6.1 supported IBM i 6.1 supported IBM i 7.1 supported SUSE Linux supported Red Hat Linux supported Refer to Software Requirements for specific O/S levels supported

Top


Power刀片服务器上可选择哪些8Gb的光纤卡

解答：

在JS12和JS22上,可以选择的8Gb光纤卡为:

fc#8271 QLogic 8 Gb Fibre Channel Expansion Card (CFFh)

在JS23，JS43，PS700，PS701，PS702上,可以选择的8Gb光纤卡为:

fc#8240 Emulex 8Gb Fibre Channel Expansion Card (CIOv) for IBM BladeCenter

fc#8242 QLogic 8Gb Fibre Channel Expansion Card (CIOv) for IBM BladeCenter

fc#8271 QLogic 8 Gb Fibre Channel Expansion Card (CFFh)

在JS12, JS22, JS23, PS700, PS701上,最多可以选配一块8Gb光纤卡,在JS43和PS702上可以选配两块8Gb光纤卡。

突出价值点：JS12, JS22, JS23，JS43，PS700，PS701，PS702刀片服务器能够支持8Gb光纤卡，使得数据传输更快，有效降低系统因为数据通道而产生的时延，提高用户体验。

Top


刀片上CIOv/CFFv和CFFh的卡有什么区别？如何与刀箱上的交换/直通模块相连

解答:

CIOv/CFFv是标准、横插的PCI槽位，CFFh是高速、竖插的PCI槽位。其中CFFv是PCI-X的，CIOv/CFFh是PCIe的. 当选择BCH刀箱时，CIOv/CFFv的卡与刀箱上bay1/2/3/4上的标准交换/直通模块相连, CFFh的卡与刀箱上bay7/8/9/10上的高速交换/直通模块相连。请参考如下示意图：


POWER7系列刀片有无显卡？如何实现对POWER7刀片服务的管理？

解答：

POWER7系列刀片主板没有集成显卡，也不支持HMC管理，如需对POWER7刀片进行管理，可以通过以下途径：

1.刀片中心上的高级管理模块，适合对刀片服务器硬件进行管理，如远程开关机、查看日志等。

2.通过SOL模式，适合对新装刀片进行管理，如安装操作系统等。

3.通过SSH模式，适合对已有系统的刀片进行管理，如安装软件、服务等。

突出价值点：可通过多种方式对POWER7系列刀片进行管理，提高灵活度。


POWER6

Power 520(8203-E4A)

Power 550(8204-E8A)

Power 595(9119-FHA)


Power 520(8203-E4A)

Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？ (最近更新)

Power 520六种硬盘背板的介绍 (最近更新)


Power 520(8203-E4A)支持哪些RAID卡以及其RAID功能？

解答:

Power 520(8203-E4A)支持两种类型的RAID卡，一种为内置RAID子卡，一种为外插RAID卡。具体介绍如下：

1. 内置RAID子卡：

内置RAID可以使用RAID子卡fc#5679，这个卡支持RAID 0,5,6和10，它不会占用主板的PCI槽位；使用RAID子卡fc#5679做RAID时必须配置DASD背板fc#8345,fc#8346,fc#8340或者fc#8310，它支持硬件RAID 0,5,6和10。支持双路径，假如一个SAS端口出现问题，那么RAID控制器将会自动切换路径到第二个端口去连接磁盘，另外RAID控制器还提供缓存保护功能，不会造成因缓存失效而带来数据的丢失；fc#5679 RAID子卡支持创建热备盘，支持从Array中的磁盘启动。

2. 外插RAID卡：

PCI-X DDR Dual-X4 3GB SAS RAID卡（fc#5902）适用于高性能的应用，使用两个fc#5902通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5902)必须成对配置，其写缓存为175MB。主要可用于连接(fc#5886)EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10；

PCI-X DDR Dual X4 SAS卡fc#5912用于连接POWER6的外部SAS磁盘扩展柜以及I/O抽屉，使用两个fc#5912可以支持连接到SAS磁盘的冗余路径，提供高的系统可用性。主要与fc#5886 EXP12S SAS磁盘扩展抽屉一起使用，支持RAID 0和10。

PCIe Dual-x4 SAS卡（fc#5901）用于连接SAS磁盘扩展柜fc#5886，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF硬盘。支持RAID0 和 RAID 10；

PCIe 380MB Cache Dual - x4 3Gb SAS RAID卡（fc#5903/fc#5805）适用于高性能的应用，使用两个fc#5903/fc#5805通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5903/fc#5805)必须成对配置，其写缓存为380MB。主要可用于连接(fc#5886) EXP12S SAS硬盘扩展柜，或者fc#5802 - PCIe 12X IO抽屉中的SAS SFF硬盘，它支持RAID 0,5,6和10；

PCI-X DDR 1.5GB Cache SAS RAID Adapter(fc#5904),适用于高性能的应用，支持1.5GB的写缓存和1.6GB的读缓存，需要占用两个PCI-X槽位，可用于连接Power 520内置硬盘或者(fc#5886) EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10。

注意：fc#5902和fc#5903的RAID卡已经停产了。由fc#5805替代原有的fc#5903的RAID卡。

突出价值点：Power 520支持多种RAID卡，方便根据需求做适合的选择，增加的RAID功能有效提高了数据的可靠性和访问性能。


Power 520六种硬盘背板的介绍

解答：

Power 520的e-config工具支持六种硬盘背板，分别为:fc#8308，fc#8310，fc#8341，fc#8345，fc#8340和fc#8346。默认的硬盘背板为fc#8340。

下面介绍一下这几种硬盘背板：

fc#8308与fc#8341的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，没有对外的SAS端口，一个5.25英寸的半高的磁带机，fc#8308支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8341是支持IDE的DVD-ROM或者DVD-RAM。

fc#8310与fc#8345的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，一个对外的SAS端口，该端口可以连接一个fc#5886的SAS硬盘笼子（通过fc#3668连接）;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10，通过fc#3670的线支持硬盘背板的分离，一个5.25英寸的半高的磁带机，fc#8310支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8345是支持IDE的DVD-ROM或者DVD-RAM。

fc#8340与fc#8346的硬盘背板相似，支持8块2.5英寸的硬盘（SFF Small Form Factor），一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10;通过fc#3670的线支持硬盘背板的分离，每个通道支持4块硬盘，支持连接SATA的DVD-ROM或者DVD-RAM以及一个5.25英寸的半高的磁带机。

fc#8310,fc#8345,fc#8340或者fc#8346支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3670分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

注意：fc#8341，fc#8345和fc#8346的硬盘背板已经停产，如果要配置3.5英寸的硬盘，需要配置fc#8310或者fc#8308的硬盘背板；如果要配置2.5英寸的硬盘，需要配置fc#8340的硬盘背板。

突出价值点：多种硬盘背板可供选择，更加方便灵活地根据需求做出配置，同时提供了RAID功能的支持。


Power 550(8204-E8A)

Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？ (最近更新)

Power 550六种硬盘背板的介绍 (最近更新)


Power 550(8204-E8A)服务器支持哪些RAID卡，可以实现什么功能？是否支持SCSI RAID功能？

解答:

1. Power 550支持两种类型的RAID卡，一种为内置RAID子卡，一种为外插RAID卡。具体介绍如下：

(1) 内置RAID子卡：

内置RAID可以使用RAID子卡fc#5679，这个卡支持RAID 0,5,6和10，它不会占用主板的PCI槽位；使用RAID子卡fc#5679做RAID时必须配置DASD背板fc#8345,fc#8346,fc#8340或者fc#8310，它支持硬件RAID 0,5,6和10。支持双路径，假如一个SAS端口出现问题，那么RAID控制器将会自动切换路径到第二个端口去连接磁盘，另外RAID控制器还提供缓存保护功能，不会造成因缓存失效而带来数据的丢失；fc#5679 RAID子卡支持创建热备盘，支持从Array中的磁盘启动。

(2) 外插RAID卡

PCI-X DDR Dual X4 3GB SAS RAID卡fc#5902适用于高性能的应用，使用两个fc#5902通过正确的连接到SAS硬盘，可以支持冗余的路径保护，fc#5902必须成对配置。主要可用于连接fc#5886 EXP12S SAS硬盘扩展柜，它支持RAID 0,5,6和10；

PCI-X DDR Dual X4 SAS卡fc#5912用于连接POWER6的外部SAS磁盘扩展柜以及I/O抽屉，使用两个卡fc#5912可以支持连接到SAS磁盘的冗余路径，提供高的系统可用性。主要与fc#5886 EXP12S SAS磁盘扩展抽屉一起使用，支持RAID 0和10；

PCIe Dual-x4 SAS卡（fc#5901）用于连接SAS磁盘扩展柜fc#5886，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF硬盘。支持RAID0 和 RAID 10；

PCIe 380MB Cache Dual - x4 3Gb SAS RAID卡（fc#5903/fc#5805）适用于高性能的应用，使用两个fc#5903/fc#5805通过正确的连接到SAS硬盘，可以支持冗余的路径保护，(fc#5903/fc#5805)必须成对配置，其写缓存为380MB。主要可用于连接(fc#5886) EXP12S SAS硬盘扩展柜，或者fc#5802 PCIe 12X IO抽屉中的SAS SFF 硬盘，它支持RAID 0,5,6和10；

PCI-X DDR 1.5GB Cache SAS RAID Adapter(fc#5904)可以支持RAID 0,5,6和10，使用fc#8310或者fc#8346的背板，通过连接SAS线fc#3679 + SAS线fc#3669来实现第二个LPAR的RAID功能，或者通过SAS y型连接线(fc#3692、fc#3693、fc#3694)连接fc#5886 EXP 12S硬盘扩展柜，实现RAID功能。

2. Power 550不支持内部的SCSI驱动器，也就是不支持内部的SCSI RAID功能；另外，也不支持外部的SCSI RAID功能。

注意：fc#5902和fc#5903的RAID卡已经停产了。由fc#5805替代原有的fc#5903的RAID卡。

突出价值点：Power550支持内置的RAID卡，它不占用PCI槽位，节省了外接I/O的成本。

Top


Power 550六种硬盘背板的介绍

解答：

Power 550的e-config工具支持六种硬盘背板，分别为:fc#8308，fc#8310，fc#8341，fc#8345，fc#8340和fc#8346。默认的硬盘背板为fc#8340。

下面介绍一下这几种硬盘背板：

fc#8308与fc#8341的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，没有对外的SAS端口，一个5.25英寸的半高的磁带机，fc#8308支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8341是支持IDE的DVD-ROM 或者DVD-RAM。

fc#8310与fc#8345的硬盘背板相似，支持6个3.5"硬盘的硬盘背板，一个对外的SAS端口，该端口可以连接一个fc#5886的SAS硬盘笼子（通过fc#3668连接）;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10，通过fc#3669的线支持硬盘背板的分离，一个5.25英寸的半高的磁带机，fc#8310支持连接SATA的DVD-ROM或者DVD-RAM;而fc#8345是支持IDE的DVD-ROM 或者DVD-RAM。

fc#8340与fc#8346的硬盘背板相似，支持8块2.5英寸的硬盘（SFF Small Form Factor），一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子;配合fc#5679，可以提供内部RAID功能，包括RAID 0,5,6和10;通过fc#3669的线支持硬盘背板的分离，每个通道支持4块硬盘，支持连接SATA的DVD-ROM或者DVD-RAM以及一个5.25英寸的半高的磁带机。。

fc#8310,fc#8345,fc#8340或者fc#8346支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

注意：fc#8341，fc#8345和fc#8346的硬盘背板已经停产，如果要配置3.5英寸的硬盘，需要配置fc#8310或者fc#8308的硬盘背板；如果要配置2.5英寸的硬盘，需要配置fc#8340的硬盘背板。

突出价值点：多种硬盘背板可供选择，更加方便灵活地根据需求做出配置，同时提供了RAID功能的支持。


Power 595(9119-FHA)

Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同？是否可以混插

Power 595服务器是否支持热节点添加的功能？


Power 595的fc#4695和fc#4705都是5.0GHz 8核Processor Book,有何不同？是否可以混插

解答：

Power 595的fc#4695(0/8-core POWER6 5.0GHz CoD , 0-core Active Processor Book)和fc#4705(0/8-core, 64GB Enabled POWER6 5.0GHz CoD , 0-core Active Processor Book)都是5.0GHz 8核的Processor Book，它们之间的区别主要是Processor Book 中的DCA(Distributed Converter Assembly)的区别。(DCA主要用与为Processor Book提供配电和直流转换器的功能)。

fc#4705能提供更强大的DCA功能，因此它能支持fc#5697 - 0/64GB DDR2 Memory(4X16GB) DIMMS, 400 MHz, POWER6 CoD Memory的内存，而fc#4695不能支持fc#5697 64GB的内存。

如果要选择fc#5697 64GB的内存，需要选择fc#4705。

注意：不允许在新购订单(Initial Order)中混用fc#4695和fc#4705两种处理器。

但是可以在升级订单(MES)中混用的，有一个前提条件：系统中不允许有fc#5697或fc#8205(0/64 GB DDR2 Memory)的内存。

客户可以免费将已有的处理器单元fc#4695升级到fc#4705，在升级的同时，也可以新订购fc#4705处理器单元。

突出价值点：Power 595的Processor Book中的DCA提供强大的配电和直流转换功能，使得595最大可以支持4TB的内存，从而为系统提供强大的内存支持。


Power 595服务器是否支持热节点添加的功能？

解答：

是的，Power 595服务器支持热节点添加功能。

IBM Power 595服务器通过新的可靠性、可用性和可维护性功能，增强了客户对支持大型应用程序和大型数据库的能力，其中就包括热节点添加和热节点修复的功能。Power 595服务器现在支持在线增加新的处理器节点到CEC主柜中而整个系统不需要断电（热节点添加）。新增加的处理器节点及其中的内存和GX板卡将在业务运行的同时升级和安装到这个系统中。新增加的资源如处理器等，可以根据需求分配到现有应用中或创建新的分区。Power 595服务器中失败的一个处理器节点现在可以在线地将其移除、修复而整个系统不需要断电（热节点修复）。这种修复是通过使该处理器节点失效并移除。当修复完成后，这个节点可以在线添加回来，并且它的资源可立即用于分配给新的或现有的应用环境。热节点修复的另一个设计理念也是旨在用此方法，可以在线的添加处理器节点内的内存，可以在不断电的情况下，增加内存容量。

需要注意的是，这些功能需要微码版本的支持，对于现有的595服务器，需要系统升级后的固件级别是eFW 3.4.0或更高的版本。

突出价值点：这些功能为Power 595保证了极具竞争优势的可靠性、可用性和可维护性。

Top


POWER7

Power 710/730(8231-E2B)

Power 720/740(8202-E4B/8205-E6B)

Power 750(8233-E8B)

Power 755(8236-E8C)

Power 770(9117-MMB)

Power 780(9179-MHB)

其他


Power 710/730(8231-E2B)

Power 710/730硬盘背板介绍


Power 710/730 硬盘背板介绍

解答：

Power 710/730有三种硬盘背板，它们是fc#5267, fc#5263, fc#5268。其区别如下：

 | fc#5267 | fc#5263 | fc#5268
硬盘槽位数 | 6 | 3 | 6
是否支持DVD | 支持 | 支持 | 支持
是否支持磁带机 | 不支持 | 支持 | 不支持
AIX / Linux support | 支持 | 支持 | 支持
JBOD / RAID 0 | 支持 | 支持 | 支持
RAID 5/6/10 | 不支持 | 不支持 | 支持
背板分离 | 不支持 | 不支持 | 不支持

另外，fc#5268有一个SAS Port，可用来连接fc#5886扩展柜。但是，4-core的Power 710不支持SAS Port。

突出价值点：三种硬盘背板为客户提供了选择的多样性。客户可以根据不同的功能需求来选择相应的硬盘背板。


Power 720/740 (8202-E4B)/(8205-E6B)

Power 720/740支持的PCI槽位信息 (最近更新)

Power 720/740硬盘背板介绍


Power 720/740支持的PCI槽位信息

解答：

Power 720/740默认支持4个PCIe的槽位，可以支持普通的PCIe的卡。

可以通过内置的PCI扩展柜：fc#5610(PCIe Riser Card (Gen1))/fc#5685(PCIe Riser Card (Gen2))，扩展4个Low-Profile的PCIe槽位。支持Low-Profile的卡；扩展时，只能选择一种类型的PCI扩展柜，这两种类型的PCI扩展柜均占用的是GX++ Slot1的槽位。

如果要扩展PCI-X的卡，需要配置PCI-X的扩展抽屉-fc#5796。一个fc#5796支持6个PCI-X的槽位。

如果要扩展PCIe的卡，需要配置PCIe的扩展抽屉-fc#5802或者fc#5877。一个fc#5802/fc#5877支持10个PCIe槽位。

其中fc#5610为第一代的PCIe Riser Card，fc#5685为第二代的PCIe Riser Card。
与fc#5610上PCIe LP槽位相比，fc#5685的PCIe LP槽位提供了更高的带宽，具体细节如下：
PCIe Gen1: 2.5 GHz (~ 2 GB/sec )
PCIe Gen2: 5.0 GHz (~ 4 GB/sec )
另外，fc#5284 PCIe2 LP 2-Port 10GbE SR Adapter和fc#5286 PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter只能用于fc#5685的PCIe Riser Card上。

注意：

如果是4C的Power 720，只支持配置一个fc#5610/fc#5685，扩展4个PCIe Low-Profile槽位，不支持扩展外置的IO抽屉。
如果是6C或者8C的Power 720，只有一个GX+的槽位可用，此时，要么配置fc#5610/fc#5685，要么配置外置的扩展柜。
如果是4C或者6C的Power 740(一个处理器板的时候)，只有一个GX+的槽位可用，此时，要么配置fc#5610/fc#5685，要么配置外置的扩展柜。

突出价值点：Power 720/740支持PCI-X，PCIe，PCIe Low-Profile这几种类型的PCI槽位，可以根据客户的不同需求，进行PCI槽位的扩展，提高了Power 720/740服务器的扩展能力。


Power 720/740 硬盘背板介绍

解答：

Power 720/740有三种硬盘背板方案，它们是fc#5618, fc#5618+fc#5631, fc#5630。其区别如下：

 | #5618 | #5618+5631 | #5630
硬盘槽位数 | 6 | 3+3 | 8
是否支持DVD | 支持 | 支持 | 支持
是否支持磁带机 | 支持 | 支持 | 支持
AIX / Linux support | 支持 | 支持 | 支持
JBOD / RAID 0 | 支持 | 支持 | 支持
RAID 10 | 不支持 | 部分支持注 | 支持
RAID 5/6 | 不支持 | 不支持 | 支持
背板分离 | 不支持 | 支持 | 不支持

注：RAID 10 only on the 3 drives associated with fc#5631。

另外，fc#5630有一个SAS Port，可用来连接fc#5886扩展柜。

突出价值点：三种硬盘背板方案为客户提供了选择的多样性。客户可以根据不同的功能需求来选择相应的硬盘背板方案。


Power 750(8233-E8B)

Power 750(8233-E8B)硬盘背板的介绍 (最近更新)

Power 750/755的区别

Power 750(8233-E8B)的硬件特性 (最近更新)


Power 750(8233-E8B)硬盘背板的介绍

解答:

Power 750，只支持一种类型的硬盘背板：fc#8340。

该硬盘背板fc#8340与Power 520和Power 550上的fc#8346硬盘背板相似。

支持8块2.5英寸的硬盘(SFF Small Form Factor)；

一个对外的SAS端口，可以连接一个fc#5886的SAS硬盘笼子；

配合fc#5679的内置RAID子卡，可以提供内部硬盘的RAID功能，支持RAID 0,5,6和10；

通过fc#3669和fc#3679的SAS线支持硬盘背板的分离，每个通道支持4块硬盘；

支持连接SATA的DVD-RAM以及一个5.25英寸的半高的磁带机。

fc#8340支持硬盘背板的分离；第一个硬盘通道被集成的控制器控制；第二个硬盘通道由SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。这样可以将内置的SAS硬盘分为两个部分，可以实现两个LPAR。

突出价值点：该硬盘背板为POWER7产品发布时新推出的硬盘背板，可以实现内置硬盘的背板分离和内置硬盘的RAID功能。


Power 750/755的区别

Power 750和Power 755的区别

解答:

Power 750和Power 755的区别如下表：

Feature | Power 755 | Power 750
OS | AIX, Linux | AIX, IBM i, Linux
Processors | 32-core @ 3.3 GHz 4 Sockets | 8, 16, 24, 32 Core at 3.0 GHz or 3.3 GHz 32 Core at 3.55 GHz 1-4 Sockets
Memory | 128 – 256 GB 4GB & 8GB DIMMS | 8 – 512 GB 4GB, 8GB, 16GB DIMMS
GX slot support | Yes 1 GX++ for IB clustering only | Yes, 1 GX+ & 1 GX++ for IB clustering or for I/O drawer expansion
175 MB Cache RAID | No | Yes
Split Backplane | No | Yes
Integrated Ethernet | Quad GbE or Dual 10GbE | Quad GbE or Dual 10GbE
Virtualization | No PowerVM support | PowerVM Express, Standard and Enterprise
DASD / Bays | 8 SFF SAS HDD /10k and 15K SFF drives SDD | 8 SFF SAS HDD / SDD 10k and 15K SFF drives
Internal Tape | No | Yes
Performance Metric | TFLOPS | rPerf, CPW
Active Memory Expansion | No | Yes
Target Workloads | HPC:Weather/Climate modeling, computational chemistry, physics, prtroleum reservoir modeling | Commercial:DB, Virtualized app servers and consol of comp UNIX and Linux apps

突出价值点：Power 750和755均为POWER7的服务器，这两款产品分别支持不同的运用环境。其中：Power 755比较适合于中小型，高强度的并行运算工作和算法，效率高，操作性强，其主要针对运行高度并行的计算密集型工作负载和算法而优化，例如天气与气候建模、计算化学、物理和石油储量建模等。而Power 750主要适用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器；用于中到大型数据库服务器。


Power 750(8233-E8B)的硬件特性

解答:

下面是Power750(8233-E8B)的硬件特性表：

处理器 | POWER7处理器 3.0 GHZ 8/16/24/32 Core 3.3 GHZ 8/16/24/32 Core 3.5 GHZ 8/16/24/32 Core
内存 | 最多512 GB的DDR3内存
SAS硬盘槽位 | 8个2.5寸的SFF硬盘槽位 (Opt: cache & RAID-5/6)
PCI内存插槽 | PCIe x8: 3个 PCI-X DDR: 2个
GX插槽 | 最多2个（与PCIe共享槽位）
集成的SAS/SATA控制器 | 是
系统集成端口 | 3个USB口, 2个Serial口, 2个HMC口
集成的虚拟以太网(IVE)卡 | 两种可选的IVE卡： 4端口的千兆以太网卡 双端口的万兆以太网卡
内置媒体槽位 | 1个DVD槽位 1个磁带机槽位
IO抽屉数量 | PCIe I/O抽屉：最多4个 PCI-x I/O抽屉：最多8个
级联 | 12X SDR/DDR (InfiniBand技术)
冗余电源 | 是

突出价值点：Power 750采用POWER7技术，在性能和能耗方面有着突出的表现，是数据库服务器和应用服务器的理想选择。


Power 755(8236-E8C)

Power 755(8236-E8C)的产品定位与硬件特性


Power 755(8236-E8C)的产品定位与硬件特性

解答:

Power 755面向中小型的集群环境，最多支持64个节点的集群。（而Power 575面向大型和超大型的集群环境）

Power 755的硬件特性如下表所示：

处理器 | POWER7处理器 3.3 GHZ 32 Core
内存 | 最多256 GB的DDR3内存
SAS硬盘槽位 | 8个2.5寸的SFF硬盘槽位
PCI内存插槽 | PCIe x8:3个 PCI-X DDR:2个
GX插槽 | 1个（与PCIe共享槽位）
系统集成端口 | 3个USB口, 2个Serial口, 2个HMC口
集成的虚拟以太网(IVE)卡 | 两种可选的IVE卡： 4端口的千兆以太网卡 双端口的万兆以太网卡
内置媒体槽位 | 1个DVD槽位 （没有内置的磁带机槽位）
集群 | 多达64个节点 （通过Ethernet 或InfiniBand进行集群）
冗余电源 | 是
性能 | 0.84 TFlops

突出价值点：与Power 575一样，Power 755每个节点为32处理器核心。但相比Power 575节点，Power 755节点的性能高40%，耗电量降低2/3，占地面积减少37%。


Power 770(9117-MMB)

Power 770/780的区别

Power 770/780硬盘背板介绍 (最近更新)

Power 770(9117-MMB)的硬件特性

将Power 770/780放到T42机柜里，有哪些限制？


Power 770/780的区别

解答:

Power 770和Power 780服务器的主要区别如下：

1) 处理器：

Power 770提供了一个单一处理器的选择：6 Core 3.5GHz；
Power 780提供了一个单一处理器的选择，但可以运行在的MaxCore模式或TurboCore模式，每个处理器板支持：
MaxCore模式 - 8 Core 3.86GHz
TurboCore模式 - 4 Core 4.14GHz

2) 软件授权级别：

Power 770 - Medium
Power 780 - Large

此外，Power 780服务器为客户提供了一个免费的PowerCare服务。

突出价值点：Power 770优化各种类型的商业工作负载；Power 780新一代的高端服务器，具有先进模块化设计和 POWER7 TurboCore 模式。


Power 770/780硬盘背板介绍

解答:

Power 770/780硬盘背板信息介绍如下：

1)Power 770/780每个CEC单元的硬盘背板支持6块2.5寸的SFF硬盘。每个硬盘背板有两个SAS控制器，每个控制器各控制3块硬盘，支持RAID 10。因此，Power 770/780每个CEC单元的6块内置磁盘默认支持两个分区(LPAR)，每个分区3块硬盘。如下图所示：

2)Power 770/780的硬盘背板也支持增加第三个SAS控制器(需要添加fc#5901和fc#1815)。在这种情况下，每个控制器控制2块硬盘，支持RAID 10。此时Power 770/780每个CEC单元的6块内置磁盘支持三个分区(LPAR)，每个分区2块硬盘。如下图所示：

3) Power 770/780的硬盘背板也支持不被分离，SAS控制器同时控制六块硬盘。通过添加fc#5662，给这六块盘做RAID 5和RAID 6。如下图所示：

4) 当Power 770/780的硬盘背板不被分离时，可以通过集成的SAS Port连接一个fc#5886扩展柜。此时需要添加fc#5662和fc#1819。如下图所示：

注意：在一个CEC抽屉内，如果硬盘背板设置为2分（没加内置RAID卡时的缺省状态）或者3分磁盘链路，在不同磁盘链路上可以分别配置SSD和HDD硬盘。但是在同一磁盘链路里不可以混配。

突出价值点：Power 770/780每个CEC单元的硬盘背板使用起来很方便，可以根据客户的不同需求进行相应的配置。

Top


Power 770(9117-MMB)的硬件特性

解答:

Power 770是POWER7家族最新推出的一款中高端服务器，是中高端数据库服务器和应用服务器的极佳选择。

下面是Power 770的硬件特性表：

Power 770
Processor Technology | 6 Cores@3.5 GHz
L3 Cache | On Chip
Redundant Power&Cooling | Yes
Redundant Server Processor | Yes/Two Enclosure minimum
Redundant Clock | Yes/Two Enclosure minimum
Concurrent Add Support | Yes
Concurrent Service | Yes
System Unit | Single Enclosure | 4 Enclosures
Processors | Up to 2 Sockets | 8 Sockets
DDR3 Memory (Buffered) | Up to 512 GB | Up to 2 TB
SAS/SSD SFF Bays | 6 | 24
DVD-RAM Media Bays | 1 Slim-line | 4 Slim-line
SAS / SATA Controller | 2/1 | 8/4
PCIe bays | 6 PCIe | 24 PCIe
GX++ Slots (12X DDR) | 2 | 8
Integrated Ethernet | Std: Quad 1Gb Opt: Dual 10Gb + Dual 1 Gb | Std: Four Quad 1Gb Opt: Four x Dual 10Gb + Dual 1 Gb
USB | 3 | 12
12X I/O Drawers w/ PCI slots | Max: 4 PCIe, 8 PCI-X | Max: 16 PCIe, 32 PCI-X

突出价值点：Power 770采用POWER7技术，它集中高端服务器和POWER7家族的优点于一身，是数据库服务器和应用服务器的理想选择。


将Power 770/780放到T42机柜里，有哪些限制？

解答：

将Power 770/780放到机柜里时，因为7014-T42/B42, 或 fc#0553机柜在EIA 37(第37U)的底部有一处凸起，为了不跟前面板或前边弯曲的连接线冲突，一台Power 770或780不能同时占据EIA 36(第36U)和EIA 37(第37U)的位置。


Power 780(9179-MHB)

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780(9179-MHB)的硬件特性


Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么,它们有什么区别, 各有什么特点

Power 780服务器上的 MaxCore Mode与TurboCore Mode是什么，它们有什么区别， 各有什么特点

解答:

MaxCore Mode与TurboCore Mode是Power 780服务器的一个技术亮点，它们是指POWER7处理器的两种不同的工作模式，其中TurboCore模式能够选择优化系统的频率和高速缓存利用率，从而为数据库和事务工作负载提供每内核最高性能。

在MaxCore Mode下，处理器主频为3.86GHz，所有的处理器都是激活的，L3级缓存平分给所有的处理器，即4MB每处理器；在TurboCore Mode下，服务器自动优化系统的频率和高速缓存利用率，此时处理器主频为4.14GHz，处理器有一半是激活的，L3级缓存平分给所有激活的处理器，即8MB每处理器，这使得单个处理器获得的L3级缓存是MaxCore Mode下的两倍，并结合处理器主频的提升从而使得单个处理器的运算能力相当于POWER6处理器的1.5倍，并降低了机器的耗电量。请注意，目前在POWER7的其它机型上还不支持TurboCore Mode。

突出价值点:TurboCore模式能够选择优化系统的频率和高速缓存利用率，从而为数据库和事务工作负载提供每内核最高性能。


Power 780(9179-MHB)的硬件特性

解答:

Power 780是POWER7家族最新推出的一款中高端服务器，是中高端数据库服务器和应用服务器的极佳选择。T42机柜可以配置fc#6250带有Power 780标示的机柜。

下面是Power 780的硬件特性表：

Power 780
Processor Technology | 4 Cores@4.14 GHz TurboCore 8 Cores@3.86 GHz
L3 Cache | On Chip
Redundant Power & Cooling | Yes
Redundant Server Processor | Yes/Two Enclosure minimum
Redundant Clock | Yes/Two Enclosure minimum
Concurrent Add Support | Yes
Concurrent Service | Yes
System Unit | Single Enclosure | 4 Enclosures
Processors | 2 Sockets | 8 Sockets
DDR3 Memory (Buffered) | Up to 512 GB | Up to 2 TB
SAS/SSD SFF Bays(CEC) | 6 | 24
DVD-RAM Media Bays | 1 Slim-line | 4 Slim-line
SAS / SATA Controller | 2/1 | 8/4
PCIe (CEC) | 6 PCIe | 24 PCIe
GX++ Slots (12X DDR) | 2 | 8
Integrated Ethernet | Std: Quad 1Gb Opt: Dual 10Gb + Dual 1 Gb | Std: Four Quad 1Gb Opt: Four x Dual 10Gb + Dual 1 Gb
USB | 3 | 12
12X I/O Drawers w/ PCI slots | Max: 4 PCIe, 8 PCI-X | Max: 16 PCIe, 32 PCI-X

突出价值点：Power 780采用POWER7技术，它集中高端服务器和POWER7家族的优点于一身，是数据库服务器和应用服务器的理想选择。


POWER7-其他

其他

哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因

POWER7的主要技术特点？

POWER7服务器与POWER6的主要区别有哪些

IBM eDRAM技术的特别之处是什么

介绍POEWR7处理器的缓存信息

什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

请简要介绍一下POWER7处理器的主要创新技术

POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡 (最近更新)

Power 710/720/730/740/750/755/770/780支持的PCI槽位信息 (新增)

Power 710/730/720/740硬件参数对比

POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager) (新增)

POWER7入门级服务器Power 710/720/730/740中fc#2319 Factory Deconfiguration of 1-core的含义是什么？ (新增)

POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug(最近更新)


哪些服务器支持Active Memory Expansion功能，如果要使用该功能，需要配置PowerVM功能吗？以及原因

解答:

所有POWER7机器（刀片除外）皆可支持Active Memory Expansion。需要在购买服务器时选购该Feature Code。

具体信息如下：
Power 710/730：fc#4795;
Power 720：fc#4793；
Power 740：fc#4794；
Power 750：fc#4792；
Power 770/780：fc#4791。

使用该功能，不需要配置PowerVM功能。因为该功能是在分区内部运行过程中对内存进行部分压缩、优化管理，来提高可用内存的，本身并不涉及分区间的资源动态分配。

另外，我们知道，POWER7 server可以运行在 POWER6模式或POWER7 模式下。需要注意，如果要使用Active Memory Expansion，POWER7 server需要运行在 POWER7 模式下。

其对操作系统和硬件的最低要求为：
1. HMC: V7R7.1.0.0
2. eFW: 7.1
3. AIX: 6.1 TL4 SP2

所以，如果定购server时只选定了AIX v5.3，则在system-->memory下，Active Memory Expansion 的Feature Code会自动隐藏，而无法选购。


POWER7的主要技术特点？

解答:

POWER7的主要特性如下：

* 芯片面积567mm2: 45nm 硅绝缘、铜互联制造工艺, eDRAM

* 相当于27亿个晶体管的处理能力

* 实际使用12亿个晶体管

* eDRAM技术使能耗使用效率提高

NOTE: Nahalem使用了23亿个晶体管

* 8个处理器内核

* 每核12个执行单元

* 每核4路SMT

* 每芯片32个线程

* 每核256KB二级缓存

* 片内32MB共享的eDRAM三级缓存

* 双DDR3内存控制器

* 每芯片100GB/s内存带宽

* 可扩展到32个芯片互联

* 每芯片360GB/s SMP带宽

* 可以同时维持20000个缓存一致性操作

* 硬件指令和数据预取

* 与POWER6二进制兼容

* 第四代的SMP总线构架

* 第三代多线程技术-SMT4

突出价值点：这是一款“划时代”的产品，专为“智慧地球”打造，重新定义业界对性能的观点，POWER7处理器的诞生为小型机开启了新纪元。


POWER7服务器与POWER6的主要区别有哪些

解答:

POWER7和POWER6服务器的基本设计没有根本性的不同，但也有以下的区别：

*POWER6每芯片封装2个处理器，POWER7每芯片封装8个处理器；

*为满足CPU的吞吐量，内存带宽及内存容量都随之增加；

*更多的IO处理来满足数据到内存的请求 - POWER7将利用当前最新的IO抽屉，计划每台服务器支持更多的IO抽屉。

突出价值点：在性能、新技术、绿色节能上POWER7完全超越了现在的POWER6，成为RISC处理器新的王者。


IBM eDRAM技术的特别之处是什么

解答:

IBM eDRAM技术的特点如下：

*优点：大密度，更低的功耗要求，更少的软错误，以及更好的性能；

*提高了处理器芯片内内存的性能，与传统的SRAM（静态随机存取内存）相比，只需约三分之一的空间和五分之一的功耗；

*更少的晶体管，更低的功耗需求；

*全新的、处理器芯片内的SOI内存技术/提供了有史以来最快的访问速度；

*对于较大的缓存容量，与目前处理器芯片内的SRAM相比，eDRAM提供了更好的性能。

突出价值点："IBM is effectively doubling microprocessor performance beyond what classical scaling alone can achieve,” said Dr. Subramanian Iyer, DE (Distinguished Engineer).


介绍POEWR7处理器的缓存信息

解答:

一级缓存：32KB的指令缓存，32KB的数据缓存；

二级缓存：256KB/处理器核心，即2MB/处理器芯片；

三级缓存：8个处理器核心共享32MB的三级缓存。

与POWER6处理器不同，POWER7处理器把三级缓存从芯片外移动到了芯片内部，采用片上的eDRAM(嵌入式的动态随机存储器)技术。

突出价值点：1)相比POWER6处理器的二级缓存，POWER7处理器的二级缓存与处理器核心结合得更紧密，因此，POWER7二级缓存几乎能达到一级缓存的速度。
2)由于采用了片上的eDRAM作为三级缓存，POWER7处理器的三级缓存几乎能达到POWER6二级缓存的速度，而且比POWER6三级缓存的软错误率更低。
3)由于采用了更好的设计理念和技术，POWER7的缓存能为客户带来更高的价值(速度更快/带宽更大/软错误率更低)。


什么是Thermal Power Management Device(TPMD), 它可以实现哪些功能

解答:

Thermal Power Management Device(TPMD)是服务器内的一个硬件模块,由一个微处理器和数据收集模块组成, 通过它使用能源管理软件可以收集服务器的功耗和温度状态，从而调节机器的处理器主频和内存使用率,进而降低服务器的功耗和温度。

POWER6和POWER7服务器都有TPMD模块。

当服务器的功耗和温度超过上限值时,TPMD会降低处理器的电压和主频或是强制释放部分内存,从而降低服务器的能量消耗和温度；当功耗和温度低于上限时,TPMD会允许处理器根据应用的需要而超频运行。

突出价值点:TPMD动态调节服务器的处理器主频和内存使用率,从而降低服务器的功耗和温度。


请简要介绍一下POWER7处理器的主要创新技术

解答:

POWER7处理器的主要有四种创新技术：

1、IBM独有eDRAM 技术：

.只需要传统SRAM 1/3的空间，1/5的电力，同时降低250倍的错误几率，减少1.5B晶体管；
.实现POWER7 on-chip 32MB L3缓存，较片外缓存延迟只有1/6，带宽提升2倍，实现POWER7高性能。

2、SMT4智能并发多线程：

.根据不同模式，智能支持SMT1, SMT2, SMT4，最大限度利用处理器资源；
.当负载能够受益于多线程时，SMT2模式较SMT1提升50%，SMT4模式较SMT1提升80%。

3、TurboCore Mode：

.每核处理器的L3缓存增加一倍，带宽增加一倍，主频提升至4.1GHz，性能较POWER6每核提升50%以上；
.为数据库应用获得每核处理器最大性能，降低license成本。

4、Active Memory Expansion：
.在POWER7系统上，可以有效扩展达100%的物理内存；
.使POWER7系统具有更强大的整合能力，为SAP等应用提供更多的内存。


POWER6/6+模式与POWER7模式的区别，同一台POWER7服务器内的不同LPAR可以运行在不同模式下吗？

解答：

基于 POWER7 的系统针对分区提供 2 种模式：P6/P6+模式和P7模式。其区别如下表所示：

P6 / P6+ MODE | P7 MODE | Customer Value
2-Thread SMT | 4-Thread SMT | 吞吐能力、CPU 利用率
8 Storage Keys | 32 Storage Keys | RAS、数据隔离的颗粒度、提升应用键的使用
VMX (Vector Multimedia Extension / AltiVec) 支持单精度浮点运算，不支持双精度浮点运算 | VSX (Vector Scalar Extension) 支持双精度浮点运算 | 高性能计算
Affinity OFF by Default | 3-tier Memory, MicroPartition Affinity | 提升系统性能
64-core/128-thread Scaling | 32-core / 128-thread Scaling 64-core / 256-thread Scaling 256-core / 1024-thread Scaling | 高可扩展、服务器整合
EnergyScale CPU Idle | EnergyScale CPU Idle and Folding with NAP and SLEEP | 提升能源效率
N/A | Active Memory Expansion | 扩展内存容量

同一台POWER7服务器内的不同LPAR可以运行在不同模式下。

突出价值点：POWER7服务器针对分区提供P6/P6+和P7两种模式，而且同一台POWER7服务器内的不同LPAR可以运行在不同模式下。这给了用户很大的灵活性。

Top


Power 710/720/730/740服务器上的LP适配卡是种什么卡，同普通适配卡有什么区别？哪些卡为LP卡

解答：

LP是Low profile的缩写，LP适配卡是比原来POWER服务器常见的普通PCI卡的高度要矮。LP卡只能插在LP插槽上使用。目前只有Power 710/730上，和选配了LP插槽的Power 720/740上能够使用LP适配卡。

目前有13款LP卡发布，每块LP卡都有对应的完全相同电器特性的普通卡对应，区别仅仅是卡的挡板高度。如下：

fc#2053 PCIe LP RAID & SSD SAS Adapter 3Gb (fc#2054/2055)
fc#5269 PCIe LP POWER GXT145 Graphics Accelerator (fc#5748)
fc#5270 PCIe LP 10Gb FCoE 2-port Adapter (fc#5708)
fc#5271 PCIe LP 4-Port 10/100/1000 Base-TX Ethernet Adapter (fc#5717)
fc#5272 PCIe LP 10GbE CX4 1-port Adapter (fc#5732)
fc#5273 PCIe LP 8Gb 2-Port Fibre Channel Adapter (fc#5735)
fc#5274 PCIe LP 2-Port 1GbE SX Adapter (fc#5768)
fc#5275 PCIe LP 10GbE SR 1-port Adapter (fc#5769)
fc#5276 PCIe LP 4Gb 2-Port Fibre Channel Adapter (fc#5774)
fc#5277 PCIe LP 4-Port Async EIA-232 Adapter (fc#5785)
fc#5278 PCIe LP 2-x4-port SAS Adapter 3Gb (fc#5901)
fc#5284 PCIe2 LP 2-port 10GbE SR Adapter
fc#5286 PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter

其中fc#5284和fc#5286只能用于fc#5685的PCIe Riser Card上，其他的PCIe LP卡既可用于fc#5610，又可用于fc#5685。


Power 710/720/730/740/750/755/770/780支持的PCI槽位信息

解答：

机型 | 710/730 | 720 | 740 | 750 | 755 | 770/780
系统抽屉内PCI槽位 | 4 PCIe LP** | 4 PCIe + 4 PCIe LP(通过PCIe Riser Card,可选) | 4 PCIe + 4 PCIe LP(通过PCIe Riser Card,可选) | 2 PCI-X + 3 PCIe | 2 PCI-X + 3 PCIe | 6 PCIe/CEC Max 24 PCIe
是否支持PCIe Riser Card * | No | Yes | Yes | No | No | No
是否支持I/O扩展柜 | No | Yes | Yes | Yes | No | Yes
最大PCI槽位(用PCI-X 12X扩展柜) | 4 PCIe LP | 24 PCI-X+ 4 PCIe | 48 PCI-X + 4 PCIe | 50 PCI-X + 1 PCIe | 2 PCI-X + 3 PCIe | 24 PCIe + 192 PCI-X
最大PCI槽位(用PCIe 12X 扩展柜) | 4 PCIe LP | 24 PCIe | 44 PCIe | 2 PCI-X + 41 PCIe | 2 PCI-X + 3 PCIe | 184 PCIe

* PCIe Riser Card会占用掉一个GX++槽位。
** LP: Low Profile。


Power 710/730/720/740硬件参数对比

解答：

 | Power 710 | Power 720 | Power 730 | Power 740
Footprint, packaging | 2U rack | 4U rack, tower | 2U rack | 4U rack, tower
Number of processor sockets | 1 | 1 | 2 | 1 or 2
Number of cores | 4, 6, 8 | 4, 6, 8 | 8, 12, 16 | 4, 6, 8, 12, 16
GHz clock | 3.0, 3.7, 3.55 | 3.0 | 3.0, 3.7, 3.55 | 3.3, 3.7, 3.55
Max GB memory | 64GB | 64 (4-core) 128 (6/8-core) | 128 | 256
Max disk storage in system unit | 1.8TB | 2.4TB | 1.8TB | 2.4TB
PCI slots in system unit | PCIe: 4 | PCIe: 4+4LP | PCIe: 4 | PCIe: 4+4LP
LPARs | 80 | 80 | 160 | 160
12X I/O Drawers | No | 4-core No 6/8-core Yes | No | Yes
Disk-only I/O drawers (#5886) | 4-core No 6/8-core Yes | 4-core No 6/8-core Yes | Yes | Yes
Power requirements | 100-240VAC | 100-240VAC | 200-240VAC | 200-240VAC


POWER7入门级服务器Power 710/720/730/740是否支持IVM (Integrated Virtualization Manager)

解答：

Power710/720/730/740支持IVM的管理。

管理PowerVM的分区可以使用PowerVM内置的IVM软件或通过一个硬件管理控制台(HMC)。 IVM易于使用，有助于减少管理虚拟设备、处理器和分区所需的时间和精力。 HMC对于低端服务器并不是个必选的设备，但HMC可以支持更多的虚拟分区和更高的整体系统管理和控制水平。

突出价值点：低端服务器可以通过PowerVM集成的IVM实现一定的虚拟化功能，帮助客户节省成本。


POWER7入门级服务器Power 710/720/730/740中fc#2319 Factory Deconfiguration of 1-core的含义是什么？

解答：

这个fc#2319 适用于以下POWER7的服务器：Power 710，Power 730，Power 720和Power 740。

fc#2319 - Factory Deconfiguration of 1-core，是工厂deconfiguration 1核的处理器来优化的软件授权，注意：仅限于降低软件成本，并仅适用于4-Core，6-Core或8-Core的配置。fc#2319的最大数量是所购买服务器的物理处理器数量减一，例如：对于4-Core的系统，fc#2319最大为3；对于6-Core的系统，fc#2319最大为5；对于8-Core的系统，fc#2319最大为7；此时只需购买1-Core的软件授权，比如AIX的授权，便于客户降低初期软件成本。

突出价值点：使得入门级客户以更低的软件成本，选择更适合的服务器。


POWER7 Server中，非刀片式Server上的PCI Slot是否支持Hotplug

解答:

POWER7 Server中，目前已发布并可下单的非刀片式Server主要有Power 710/720/730/740/750/755/770/780。

其中，Power 750/755/770/780上所有的PCI Slot都是支持Hotplug的。12X I/O扩展抽屉上的PCI Slot也支持Hotplug。但是需要注意，IVE、集成SAS RAID子卡和GX++ Slot是不支持Hotplug的。

关于Power 710/720/730/740，系统抽屉内的PCI Slot目前不支持Hotplug。Power 720/740 系统抽屉内可以选配的附加4个PCIe Low Profile Slot也不支持Hotplug。但是，Power 720/740可以通过GX++卡来扩展12X I/O抽屉，12X I/O扩展抽屉上的PCI Slot支持Hotplug。


IO Drawer

什么是EXP 12S磁盘柜（产品号fc#5886）？可以用什么主机卡来连接它？是否有冗余电源和风扇？12S支持什么硬盘 (最近更新)

Power服务器I/O Drawer硬件特性及介绍

Power 595支持哪些I/O抽屉，各有什么特点

没有硬盘槽位的fc#5873 I/O抽屉是否可以升级为带硬盘槽位的fc#5803？ (新增)


什么是EXP 12S磁盘柜（fc#5886）？可以用什么主机卡来连接它？是否有冗余电源和风扇？12S支持什么硬盘

什么是EXP 12S磁盘柜(fc#5886)? 可以用什么主机卡来连接它？ 是否有冗余电源和风扇? 12S支持什么硬盘

解答:

EXP 12S磁盘柜是19英寸标准机柜宽、2U高，内部可插入12块3.5英寸SAS热插拔磁盘的磁盘柜。

POWER6/POWER7/P5服务器通过SAS卡连接到EXP 12S来使用。EXP 12S可以在POWER6/POWER7服务器里定购，也可以在P5服务器升级的时候订购。产品号为fc#5886。在POWER6/POWER7服务器中配置fc#5912/fc#5901 SAS卡，fc#5805的SAS RAID卡，或者fc#5904/fc#5908/fc#5906 1.5GB缓存的SAS RAID卡来连接EXP 12S磁盘柜；在P5的服务器中，可以通过fc#5912的SAS卡，或者fc#5902的SAS RAID卡进行连接。

一个fc#5912/fc#5901最多可以连接4个EXP 12S磁盘柜。fc#5805需成对配置，一对fc#5805 SAS RAID卡最多可以连接4个EXP 12S磁盘柜。fc#5904/fc#5906/fc#5908 SAS RAID卡最多可连接5个EXP 12S磁盘柜。

Power 520如果配1个CPU（fc#5633），则不能连fc#5886 SAS磁盘柜；
Power 520最多可连接24个fc#5886 SAS磁盘柜；
Power 550最多可连接48个fc#5886 SAS磁盘柜；
Power 560最多可连接110个fc#5886 SAS磁盘柜；
Power 570最多可连接110个fc#5886 SAS磁盘柜；
Power 595最多可连接185个fc#5886 SAS磁盘柜。

Power 710/720如果配置4个CPU(fc#8350),则不能连fc#5886 SAS磁盘柜；
Power 710/730最多可连接8个fc#5886 SAS磁盘柜；
Power 720/740最多可连接28个fc#5886 SAS磁盘柜；
Power 750最多可连接48个fc#5886 SAS磁盘柜；
Power 755最多可连接13个fc#5886 SAS磁盘柜；
Power 770最多可连接110个fc#5886 SAS磁盘柜；
Power 780最多可连接110个fc#5886 SAS磁盘柜。

EXP 12S磁盘柜基本配置中已经含有冗余电源和风扇了。EXP 12S支持目前POWER6/POWER7服务器的3.5英寸内部SAS硬盘。

目前，Power 520/550/560/570/595/710/720/730/740/750/755/770/780上可配的硬盘有：

fc#3647(146GB) 15000转SAS硬盘。

fc#3648(300GB) 15000转SAS硬盘。

fc#3649(450GB) 15000转SAS硬盘。

fc#3586(69GB)SAS SSD硬盘，最大支持8块SSD硬盘。

突出价值点：fc#5886为POWER6/POWER7服务器提供3.5英寸SAS硬盘扩展的硬盘抽屉；目前，P5的SCSI硬盘都已经停产，如果客户需要对P5服务器的硬盘升级，可以通过配置fc#5886来实现SAS硬盘的扩容。


Power服务器I/O Drawer硬件特性及介绍

解答：

在09年新推出来的四种IO抽屉：fc#5802，fc#5877，fc#5803,fc#5873均可以支持POWER6和POWER7的服务器。下面将对这几种IO抽屉进行介绍：

fc#5802 PCIe 12X I/O Drawer：

硬件特性：

fc#5802为4U 高，19英寸宽的包含10个PCIe槽位和18个SFF SAS硬盘的I/O抽屉。
fc#5802 的宽度为17.5英寸宽（444.5mm），高度为7英寸（177.8），深度为28英寸深（711.2mm）。是可以放在19英寸标准机柜里面的。
下图为fc#5802的前视图和后视图:

槽位信息：

10个PCIe 槽位，其速度是：2.5 GB/sec
18个硬盘槽位，支持热插拔，可以支持一个、两个或四个分区。
如果是一个分区，需配置一个PCIe SAS 硬盘控制器；
如果是两个分区，每个分区放置9块硬盘；此时需要配置两个PCIe SAS 硬盘控制器；
如果是四个分区，各个分区的硬盘数分别是：5 / 4 / 4 / 5 块；此时需要配置四个PCIe SAS 硬盘控制器；

fc#5802的硬件要求和软件要求：

硬件要求：Power 520/550/560/570/720/740/750/770/780
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7

配置fc#5802的注意事项:

fc#5802 的最小配置是：2根12X DDR 线缆，2根直流电电源线和2根SPCN（为了保证适当的冗余）线缆。fc#5802和主机系统柜的连接，还需要在系统柜的GX槽位上安装12X 适配器，以及连接所用的12X线缆：1.5米（fc#1862），3.0米（fc#1865），或者8米（fc#1864）。不支持 12X SDR 线缆。
一个12X 的环路里可以做多配置两个fc#5802。
不支持fc#5802和fc#5796/7314-G30混合在一个环路里。

和fc#5796 的比较：

fc#5802提供了约为fc#5796两倍的带宽；
fc#5802的PCIe槽位的速度约为fc#5796的PCI-X槽位的速度的两倍；
一个fc#5802比一个fc#5796多提供了四个PCI槽位;
每个环路最多放置两个fc#5802，每个环路最多放置四个fc#5796；
fc#5802还提供了十八块硬盘槽位，而fc#5796没有；(且不同于以前的fc#5886，fc#5802可以支持多个分区)
fc#5802放置更新技术的SAS SFF硬盘

fc#5877 PCIe 12X I/O Drawer：

硬件特性：

fc#5877为4U 高，19英寸宽的包含10个PCIe槽位的I/O抽屉。无硬盘槽位。是可以放在19英寸标准机柜里面的。如下图所示：

如果客户只想扩展PCIe插槽，而不想扩展SFF硬盘槽位，那么fc#5877是很好的选择。相比fc#5802, fc#5877的价格和维护费更低。

fc#5877的硬件要求和软件要求：

硬件要求：Power 520/550/560/570/720/740/750/770/780
软件要求：操作系统为AIX 5.3及以上，IBM i 6.1.1及以上，Linux SLES10/RHEL4.6及以上

配置fc#5877的注意事项:

fc#5877的配置注意事项与fc#5802相同。
fc#5877与fc#5802可以混在一个12X的loop中。

fc#5803 12X I/O Drawer：

硬件特性：

fc#5803为4U 高，24英寸宽的包含20个PCIe槽位和26个SFF SAS硬盘的I/O抽屉。

槽位信息：

20个PCIe 槽位，其速度是：2.5 GB/sec
26个硬盘槽位，支持热插拔，可以支持一个、两个或四个分区。
如果是一个分区，需配置一个PCIe SAS 硬盘控制器；
如果是两个分区，每个分区放置13块硬盘；此时需要配置两个PCIe SAS 硬盘控制器；
如果是四个分区，各个分区的硬盘数分别是：7 / 6/ 6 / 7 块；此时需要配置四个PCIe SAS 硬盘控制器；

fc#5803的硬件要求和软件要求：

硬件要求：Power 575/595
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7

配置fc#5803的注意事项:

一个环路最多配置一个fc#5803

和fc#5797/5798 的比较：

fc#5803提供了大约为fc#5797/5798两倍的带宽；
fc#5803的20个PCIe槽位中，有6个槽位的速度约比fc#5797/5798的PCI-X 的速度快两倍到四倍；有14个槽位的速度比fc#5797/5798的PCI-X 的速度快将近两倍
和fc#5797/5798的PCI 槽位数量一致，但是需要为fc#5803配置硬盘控制器，则需要占槽位
可以配置8Gb 的光纤存储卡（在NPIV的技术下）
更快的SFF硬盘槽位；
更新技术的SAS硬盘；
每个环路放置一个抽屉，这点和fc#5797/5798一样；
有不配置硬盘的选项；
fc#5803还提供了十八块硬盘槽位，而fc#5796没有；(且不同于以前的fc#5886，fc#5803可以支持多个分区)
fc#5803放置更新技术的SAS SFF硬盘

fc#5873 12X I/O Drawer：

fc#5873为4U 高，24英寸宽的包含20个PCIe槽位的I/O抽屉，是fc#5803的no disk 选项。
每个环路只能放置一个fc#5873抽屉；
硬件要求：Power 575/595；
软件要求：操作系统为AIX 5.3以上，IBM i 6.1，Linux SLES10/RHEL4.7。

突出价值点：这些新增的部件为Power系列服务器提供了灵活的I/O扩展能力，方便用户根据需求进行配置并提供灵活的分区支持能力。

Top


Power 595支持哪些I/O抽屉，各有什么特点

解答：

Power 595支持如下的I/O抽屉：fc#5791, fc#5794, fc#5797, fc#5798, fc#5803, fc#5873

(1)fc#5791 集成20个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要RIO的卡进行连接，最大可以配置12个.

(2)fc#5794 集成20个PCI-X槽位，8个SCSI硬盘的槽位，2个硬盘控制器,可以支持2个分区,需要RIO的卡进行连接，最大可以配置12个.

(3)fc#5797 集成14个PCI-X DDR槽位和6个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要12X的卡进行连接，带有转发器，最大可以配置30个.

(4)fc#5798 集成14个PCI-X DDR槽位和6个PCI-X槽位，16个SCSI硬盘的槽位，4个硬盘控制器,可以支持4个分区,需要12X的卡进行连接，不带转发器，最大可以配置3个.

(5)fc#5803 集成20个PCIe槽位，26块SFF硬盘槽位，没有集成硬盘控制器,需要另外配置SAS卡来访问硬盘,最多可支持4个分区,需要12X的卡进行连接，最大可以配置32个.

(6)fc#5873 集成20个PCIe槽位，不带有硬盘槽位，需要12X的卡进行连接，最大可以配置31个.

Top


没有硬盘槽位的fc#5873 I/O抽屉是否可以升级为带硬盘槽位的fc#5803？

解答：

不可以。

无磁盘、12X PCIe的I/O抽屉fc#5873是没法升级为带磁盘、12X PCIe的I/O抽屉fc#5803的。您可以选择去掉fc#5873，添加fc#5803来替换。

突出价值点：无磁盘的fc#5873可以帮助客户降低初期投资，但也要根据未来发展趋势选择更加合适的I/O抽屉。


外设

P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号 (最近更新)

目前支持的几款HMC介绍及配置注意事项

在没有HMC的情况下，如何远程管理Power服务器

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备? (最近更新)

7216-1U2介绍 (最近更新)

USB移动硬盘设备介绍，以及与磁带驱动器的比较


P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

解答：

P系列服务器的切换器及相关线缆图如下。此切换器可以在显示套件7316-TF3中定购，产品编号为fc#4283。

fc#4283切换器可以连接一套鼠标、键盘、显示器做为本地的Console使用，鼠标、键盘可以是PS/2或者USB接口，如下图一所示。右边的8个ARI端口可以用来连接服务器，用于连接服务器的各种线缆如下图所示。

图一 切换器，fc#4283

目前，在e-config工具中，可以配置的线缆为fc#4268和fc#4269；这两种线缆可用于环形连接， 订购一个fc#4268或fc#4269包含四根线缆，可以连接4台服务器。1个ARI端口最多支持4组fc#4268或fc#4269线缆串联，支持16台服务器。一个fc#4283最多可以连接128台服务器。

图二 PS/2型的串联线缆(KCO)，fc#4268

图三 USB型的串联线缆(UCO)，fc#4269

下图显示了线缆之间采用串接的方式，每两根线缆之间用双绞线连接，双绞线的长度最长支持10米。如果服务器和7316-TF3之间的距离较远的话，可以根据实际情况制作合适长度的双绞线。

突出价值点：7316-TF3，为用户提供安装在19英寸机柜里的一套鼠标，键盘和液晶显示器；fc#4283为一个切换器，一台fc#4283的切换器支持最大连接128台服务器，即128台服务器可以共享一套液晶套件，为客户大大节省了空间和成本。

Top


什么是HMC，HMC支持管理服务器数量，哪些服务器必须通过HMC管理，以及适合POWER6/POWER7服务器的HMC型号

解答：

IBM硬件管理控制台(Hardware Management Console)提供了标准的用户接口来配置和管理Power Systems系列服务器以及服务器上的分区。系统管理员通过HMC对Power Systems服务器上的分区进行配置和日常管理。

HMC的功能包括：
.创建分区，维护分区
.显示每个分区上虚拟的操作系统会话终端
.显示每个分区的虚拟操作面板
.监控，记录以及汇报硬件的更换
.服务器开/关机
.作为Service Focal Point设备提供远程管理和Service Agent Call-Home功能
.激活服务器上的CUoD部件

当前的POWER6/POWER7服务器中，Power 560/570/575/595/770/780必须依靠HMC管理。

HMC和服务器的兼容列表如下：

HMC 版本 | 所支持的服务器
Version 7, 及以上版本 | POWER5, POWER6 and POWER7(V7 R710及其以上)
Version 4, 5, 6及以上版本 | POWER5
Version 3, 及以上版本 | POWER4

7042-CR4，7042-CR5,7042-CR6, 7042-C07，7042-C08适用于POWER5，POWER5+,POWER6的服务器；
7310-CR4，7310-C06适用于POWER5和POWER5+的服务器；
如果为7310-CR4，7310-C06 需要将微码升级到Hardware Management Console Licensed Machine Code v7，才能适用于POWER6的服务器。

POWER7服务器对HMC的版本要求如下：
1）HMC V7 R710及其以上；
2）7042-CR3及其以上，或者7310-C05及其以上；
3）如果使用IBM Systems Director来管理HMC，或者HMC管理的分区数超过了254个，则HMC应该是7042-CR3及其以上或者7310-C06及其以上，并且该HMC至少应有3GB的内存。

当前，HMC支持的服务器数量如下：
1.最大48台非590或者595的服务器；
2.对于POWER7服务器，最大支持48台Power 710/720/730/740/750/755/770/780；
3.最大支持32台590或者595服务器；
4.支持最大1024个LPAR；
5.在HMC管理的架构中，最大支持2台HMC同时管理一台服务器。

突出价值点: 一台HMC既可以同时管理几十台POWER服务器,几百个分区。每台服务器也可以同时连接2台HMC来达到管理方面更高的可用性。

Top


目前支持的几款HMC介绍及配置注意事项

解答：

目前可以配置的HMC有7042-CR5，7042-CR6，7042-C08这三款。其中，CR5和CR6是机架式的，C08是桌边式的。7042-CR5将于2011年1月停产，将由7042-CR6取而代之。

7042-CR5默认的微码版本为V7R350。CR5具有：
1)四核2.4GHz的Intel处理器，8MB缓存；
2)4GB DDR3 内存；
3)300GB的硬盘；
4)4个1Gb的以太网口；
5)1 PCIe & 1 PCI-X slot；
6)4个USB端口（two front, two rear）；
7)DVD-RAM。

在e-config中配置7042-CR5时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

7042-CR6默认的微码版本为V7R720。CR6具有：
1)四核2.53GHz的Intel处理器，12MB L2 cache；
2)4GB DDR3 内存；
3)500GB的硬盘；
4)4个1Gb的以太网口;
5)1 PCIe & 1 PCI-X slot；
6)4个USB端口（two front, two rear）；
7)DVD-RAM。

在e-config中配置7042-CR6时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

7042-C08默认的微码版本为V7。C08具有：
1)四核2.53GHz的Intel处理器，8MB L2 cache；
2)4GB DDR3 内存；
3)250GB的硬盘；
4)集成2个1Gb的以太网口，可以再添加2个1Gb的以太网口；
5)3 PCIe & 2 PCI-X slot；
6)7个USB端口（two front, four rear, one internal）；
7) DVD-RAM。

在e-config中配置7042-C08时，如果需要配置键盘,请选择fc#5951；如果需要鼠标，请选择8845。

突出价值点：客户可以根据实际需要来选择桌边式或者机架式HMC。

Top


在没有HMC的情况下，如何远程管理Power服务器

解答：

在没有HMC的情况下，如何对Power服务器建立远程控制。

远程控制，包括在没有HMC的情况下通过高级系统管理接口(ASMI)控制电源的开/关。ASMI端口（HMC1）的IP地址需要更改为可路由的地址。然后，您可以通过Web浏览器指向该地址来访问系统ASMI。

这里有两种方法来实现：

1.通过串行RS232连接。

注意：这个方法只适用于系统电源线已插上，但未开机的状态(即Standby模式)

-需要DB9的连接线连接Power服务器的串行端口并连接到ASCII终端。或使用串行到USB的转接线连接到笔记本电脑(见下图)并使用Windows超级终端中的终端仿真器。
端口设置为：
– 19200 bits per second
– 8 data bits
– No parity
– 1 stop bit
– Xon/Xoff flow control

需要USB到DB9母头串行线缆。需要如下图连接得到这种线缆。

默认用户名/密码是admin/admin:

选(5)Network Services，然后选(1)Network Configuration，然后选Configure Interface，最后选(9)Static Enter IP Settings and then Save Settings设置IP地址:

2.通过ASMI

通过以太网线缆连接笔记本电脑到HMC的端口，将笔记本电脑的IP地址设置在与HMC IP同一子网下。

高级系统管理界面支持的浏览器，到目前为止有，Microsoft Internet Explorer 6.0, Netscape 7.1, Mozilla Firefox, or Opera 7.23，您可以通过运行于PC机或笔记本电脑的上述浏览器连接到服务处理器。

使用默认的IP地址。Web Browse to ASMI https://ip_addr
Power 5 HMC1 192.168.2.146 Mask 255.255.255.0
HMC2 192.168.3.147 Mask 255.255.255.0
Power 6 HMC1 169.254.2.147 Mask 255.255.255.0
HMC2 169.254.3.147 Mask 255.255.255.0

UserID: admin , Password admin

Network Services
-Network Configuration
IP配置为可路由的IP地址

一旦HMC的端口有一个可路由的IP，您可以用支持的浏览器连接到AMSI。

Point Web Browser to ASMI https://ip_addr
Then after logging on as admin, you can turn power on to system via
Power/Restart Control
Power On/Off System

参考文档：
Redbook: Hardware Management Console V7 Handbook: SG24-7491
RedPaper: Integrated Virtualization Manager on IBM System p5 : redp4061
RedPaper: IBM Power 520 Technical Overview ; redp4403

突出价值点：高端服务器需要由HMC来管理，对于低端服务器，可以有更多的方式来远程控制服务器。

Top


System P系列服务器的外置磁带和光驱存储设备（7214-1U2）可支持多少个媒体设备？

System P系列服务器的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备

解答：

7214-1U2有两个媒体槽位，最大支持3个媒体设备。其左边槽位支持1个磁带驱动器，右边槽位可支持1个磁带驱动器或者2个DVD光驱。如图一所示，7214-1U2包含1个磁带驱动器和2个DVD光驱。

7214-1U2不支持总线分离的配置。所有驱动器设备都必须连接到一个SAS Controller上。

7214-1U2只能通过一块SAS卡(fc#5912或者fc#5901)连接到P服务器上，且7214-1U2的所有设备(磁带机或者光驱)只能属于一个LPAR。

图一

注意：在AIX或Linux操作系统下，每个Power 520或Power 550服务器最多只允许配置两个7214-1U2设备。

突出价值点：7214-1U2为一个外置的磁带和光驱的存储设备，通过SAS卡与服务器相连；如果一台POWER6服务器实现多个分区的时候，只需配置一套外置的磁带和光驱设备，就可以在多个分区之间进行动态的偏移，而不用为每个分区配置一套磁带机和光驱设备，能为客户节省成本，提高硬件设备的利用率。


7216-1U2介绍

解答：

7216-1U2，为最新推出的一款媒体抽屉。可以通过USB端口或者通过SAS卡连接到POWER6/POWER7的服务器上。

7216有2个槽位，可以为POWER6/POWER7服务器提供外置的磁带机，DVD或者移动硬盘设备。

如果是连接POWER7的服务器，目前7216-1U2上支持的设备如下：

DAT320 160 GB SAS Tape Drive (fc#1402)
DAT320 160 GB USB Tape Drive (fc#5673)
Half-high LTO Ultrium 5 1.5 TB SAS Tape Drive (fc#8247)
DVD-RAM - 9.4 GB SAS Slim Optical Drive (fc#1420 and fc#1422)
RDX Removable Disk Drive Docking Station(fc#1103)

如果是连接POWER6的服务器，目前7216-1U2上支持的设备如下：

DAT320 160 GB SAS Tape Drive (fc#1402)
DVD-RAM - 9.4 GB SAS Slim Optical Drive (fc#1420 and fc#1422)
RDX Removable Disk Drive Docking Station(fc#1103)

服务器与7216-1U2连接的线和卡的选择：

7216-1U2支持USB端口或者SAS卡连接到POWER6/POWER7的服务器上。

可以通过集成的USB端口或者USB卡，通过USB线，连接USB的驱动器；

可以通过SAS卡：fc#5901/fc#5912/fc#5278(LP) 的SAS卡，通过SAS线，连接SAS的驱动器；但是不支持用服务器上集成的SAS端口连接7216-1U2。

如果通过SAS卡（fc#5901/fc#5912/fc#5278(LP))连接7216-1U2，可以在1U2里配置SAS的磁带机和DVD设备，在驱动器中，包含了外部的SAS线，不需要单独配置SAS线。

如果通过USB口连接7216-1U2，可以在1U2中配置USB接口的磁带机和USB的移动硬盘，在驱动器中，包含了USB的连接线，不需要单独配置USB线缆。

每个驱动器（磁带机，DVD或者移动硬盘）可通过自带的线缆，连接到一台服务器相应类型（USB或者SAS）的一个控制器上。

7216-1U2的两个槽位，支持如下的驱动器设备的组合：

1.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），另一个槽位剩余。
2.连接两个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一）。
3.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），一个或者两个DVD-RAM。
4.连接四个DVD-RAM。
5.连接一个磁带机（DAT320 SAS, DAT320 USB, or Half-high LTO Ultrium 5选其一），一个移动硬盘（RDX Removable HDD Docking Station）。
6.连接一个移动硬盘（RDX Removable HDD Docking Station），一个或者两个DVD-RAM。
7.连接两个移动硬盘（RDX Removable HDD Docking Station）。

注意：在7216-1U2上，适用于POWER6服务器的驱动器位：DAT320 SAS Tape Drive，DVD-RAM，RDX Removable Disk Drive Docking Station。

7216-1U2支持AIX，IBM i，Linux的操作系统，但是，移动硬盘（RDX Removable HDD Docking Station）和USB的磁带机（DAT320 USB Tape Drive）不支持IBM i的操作系统。

突出价值点：7216-1U2为一个外置的磁带，光驱或者移动硬盘的存储设备，通过SAS卡或者USB接口与POWER7服务器相连；该设备的每个驱动器，都已经配置了相应的对外连接控制器的线缆，不需要单独配置连接线。当要在服务器中实现多个分区时，只需配置一套外置的磁带，光驱或者移动硬盘设备，就可以在多个分区之间进行动态的偏移，而不用为每个分区配置一套磁带机，光驱或者移动硬盘设备，能为客户节省成本，提高硬件设备的利用率。

Top


USB移动硬盘设备介绍，以及与磁带驱动器的比较

解答：

2009年4Q发布的USB移动硬盘设备有4种Feature Code - fc#1104，fc#1103，fc#1106和fc#1107。

其中：fc#1104为外置硬盘驱动器，fc#1103为内置硬盘驱动器。支持的硬盘为 160G(fc#1106)和 500G(fc#1107)两种。

目前只USB移动硬盘支持AIX和Linux，不支持VIOS和IBM i。具体支持的版本情况如下：

AIX 5.3 with the 5300-11 Technology Level, 及以上版本。
AIX 6.1 with the 6100-04 Technology Level, 及以上版本。
SUSE Linux Enterprise Server 10 Service Pack 2, 及以上版本。
SUSE Linux Enterprise Server 11, 及以上版本。
Red Hat Enterprise Linux version 4.7, 及以上版本。
Red Hat Enterprise Linux 5.3, 及以上版本。

 | USB移动硬盘设备 | 磁带驱动器
驱动器的价格 | 低 | 高
驱动器的维护费用 | 无 | 有
磁带的价格 | 高 | 低
速度 | 比入门级磁带驱动器高 | 入门级驱动器速度相对较低
压缩 | 由应用完成该功能 | 大部分驱动器有内置的压缩功能
自动加载器 | 没有 | 有(低端的除外)
磁带的最大容量 | 500GB的非压缩容量, (比入门级磁带驱动器的容量大) | 入门级磁带驱动器的相对较小
稳定/可靠性 | 高 | 低
随机存取 | 可以 (with UDF 文件系统) | 不可以
健壮性 | 高 | 相对较低
加密 | 由应用完成 | 有驱动器完成(低端的除外)
清洗带 | 不需要 | 需要
备份/恢复时间 | 比入门级磁带驱动器快 | 入门级驱动器相对较慢
外部连接能力 | USB 连接 | 通过SAS PCI卡连接

突出价值点：可以根据客户的需要选择内置或者外置的硬盘驱动器，目前支持两种容量的硬盘(500G和160G)。USB移动硬盘设备在速度、可靠性和拥有成本方面都具有优势。


PowerVM

动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

System P服务器分区技术中的Physical Shared Processor Pool,Multiple Shared Processor Pool, Shared Dedicated Capacity 介绍

PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

表格列举不同Power服务器的型号所能够支持的PowerVM的features

什么是PowerVM?

PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用

IVE介绍及特性

Power服务器的内置光驱是否可以进行DLPAR

刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？

PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？

Power服务器支持分区的最大数量是多少？

将VIOS client AIX分区用于HA集群中的node时，要求配置双VIOS吗？以及原因

将VIOS client AIX分区用于HA集群中的node时，如果采用VIOS级别上的网络冗余功能，AIX操作系统和HA软件需要再对网络进行冗余设置吗? 如果不需要,HA支持单网卡配置吗

目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况 (新增)

Power服务器上使用NPIV的技术，是否需要额外的License (新增)


动态LPAR时为什么要在每个分区中配置单独的网卡与HMC连接？

解答:

每一个LPAR相当于一台完全独立的物理机器，HMC只能管理与之相连接的硬件环境，没有直接连接的硬件环境HMC是没有办法管理的，所以要在每个分区中配置单独的网卡与HMC连接。

突出价值点：提供灵活的动态功能，可以在不影响应用的情况下，在各分区间动态调整资源。

参考书目以及下载地址：
Redbook 书号：SG24-7231-00 Page 8
参考书目名称：《LPAR Simplification Tools Handbook》
下载地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247231.pdf


System p服务器分区技术中的Physical Shared-Processor Pool, Multiple Shared-Processor Pool, Shared Dedicated Capacity介绍

解答:

1.物理共享处理器池 (Physical Shared Processor Pool)

POWER5服务器与上一代POWER4服务器在对CPU资源的划分上使用了新技术－即微分区技术。在POWER4服务器上划分分区时(LPAR/DLPAR)每个分区至少要分配1路物理CPU资源，而在POWER5服务器上使用微分区(Micro-Partition)功能后，对CPU的划分粒度更细了，1路物理CPU可以划分成10个Entitle Unit，每个分区最少可以分配1/10个Entitle Unit，一个Entitle Unit可以看成是1/10个物理CPU资源。使用微分区技术后对CPU资源的划分更加灵活，提高了CPU资源的利用率。

在POWER4服务器上划分分区的时候，物理CPU都被以1路、2路、3路……的整数方式划分的，分区中的CPU数量与物理CPU的数量能够直接对应。而在POWER5服务器的微分区技术中以前这种分区中的CPU数量与物理CPU的数量直接对应关系没有了，取而代之的是物理共享处理器池(Physical Shared Processor Pool)，物理共享处理器池是先将物理CPU放置于一个共享的处理器池中统一的被分配到分区之中使用。如图一所示。

图一

p2至p7 六个物理CPU被放置于物理共享处理器池中，通过Power Hypervisor将池子里的物理CPU调度到微分区之中。在微分区中看到的CPU叫做虚拟处理器(Virtual Processor),即下图微分区中的vp0,vp1……。可见虚拟处理器的总数与物理共享处理器池中的物理处理器的总数是不相等的。在微分区中虚拟处理器与物理处理器之间是没有固定关系的。Power Hypervisor会调度物理共享处理器池中的物理处理器最终被分配到哪个微分区中被使用，默认情况是Power Hypervisor会将一个物理处理器上的资源划分给微分区使用。如图二所示

图二

2. 多个共享处理器池（Multiple Shared Processor Pool）

多个共享处理器池Multiple Shared Processor Pools (MSPPs)是POWER6服务器上的新功能。这个功能允许管理员同时创建多个微分区的集合（Set of Micro-Partition），一个集合内包含一个或多个微分区。这个功能的好处在于可以由管理员人为地控制一个微分区集合所要消耗的物理共享处理器池中的物理处理器的量。如图三所示

图三

图三中的服务器被划分了六个微分区，三个微分区为一个微分区的集合，每个集合对应一个共享处理器池(Shared Processor Pool)。管理员可以人为地从物理共享处理器池(Physical Shared Processor Pool)调度物理处理器，为每个微分区集合中的共享处理器池分配物理处理器的量。该功能比以前一代POWER5服务器中只能存在一个共享处理器池(Shared Processor Pool)相比在物理处理器的划分上更加灵活和有针对性了。

3. Shared Dedicated Capacity

Shared Dedicated Capacity也是POWER6服务器上的新功能。我们将以前那种物理处理器数量与分区中的处理器数量有对应关系的处理器化分方式叫做Dedicated方式，而把目前微分区中的处理器划分方式叫做Shared方式。在POWER5服务器上能够同时做到既有使用Dedicated方式划分的分区又有使用Shared方式划分的分区。但是使用这两种方式划分的分区之中所使用的物理处理器是完全分开的。如果一个物理处理器被分配给了使用Shared方式划分的分区，这个处理器就不能在分配给使用Dedicated方式划分的分区使用。反之也是一样。
在POWER6服务器中新的Shared Dedicated Capacity功能打破了以前的限制。在Dedicated方式划分的分区中，如果分区中的物理处理器上存在没有被使用的处理器时钟周期，那么这些没有被使用的时钟周期将会分配到物理共享处理器池(Physical Shared Processor Pool)中供Shared方式划分的分区所使用。提高处理器的利用效率。

突出价值点：功能强大的CPU调度机制。1/10内核即可支持1个分区，增量颗粒度小至0.01个内核。灵活的调度策略。根据预先设定的调度策略和当前负载情况，自动在各微分区间调整处理器资源。Multiple Shared Processor Pool同时对软件的授权使用提供了更高性价比的解决方案。

参考书目以及下载地址:
Redbook 书号：SG24-7940-04 Page 42
参考书目名称：《PowerVM Virtualization on IBM System p》
下载地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247940.pdf

Top


PowerVM的功能与PowerVM版本，处理器以及操作系统的兼容性

解答：

Feature | Licensed by | Processor support | Operating System supporta
LPARb | All Editions (limited on Express) | POWER4,5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER (not POWER4) RHEL 4, 5 for POWER (not POWER4
Capacity Upgrade on Demand | All Editions (specific models) | POWER4, 5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER RHEL 4, 5 for POWER (5.1 for POWER6)
Micro-Partitioning | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 9, 10 for POWER RHEL 4, 5 for POWER
Shared Dedicated Capacity | All Editions | POWER6 | AIX 5.3 and 6.1 SLES 10 update 1 for POWER RHEL 5.1 for POWER
Multiple Shared Processor Pools | PowerVM SE and EE | POWER6 with HMC | AIX 5.3 and 6.1 SLES 10 for POWER6 RHEL 5.1 for POWER6
Virtual I/O Server | All Editions | POWER5 and 6 | Virtual I/O Server
IVM | PowerVM Express, SE and EE | POWER5 and 6 | Integrated Virtualization Manager
Virtual SCSI | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 10 for POWER RHEL 4, 5, 5.1 for POWER
Virtual Ethernet | All Editions | POWER5 and 6 | AIX 5.3 and 6.1 SLES 9 for POWER (10 for POWER6) RHEL 4, 5 for POWER (5.1 for POWER6)
Live Partition Mobility | PowerVM Enterprise Edition | POWER6 | AIX 5.3 and 6.1 SLES 10 update 1 for POWER RHEL 5.1 for POWER

a. Contact your sales representative for specific technology level or service pack requirements.
b. Including DLPAR operations, except dynamic memory removal for all Linux versions.

Top


表格列举不同Power服务器的型号所能够支持的PowerVM的features

解答：

不同Power服务器的型号所能够支持的PowerVM的features如下表:

 | JS Blades | PS Blades | 520 | 520 | 520 | 550 | 550 | 560 | 570 | 570 | 595 | 710 | 720 | 730 | 740 | 750 | 770 | 780
 |  |  | 8203- E4A | 9407- M15 | 9408- M25 | 8204- E8A | 9409- M50 | 8234- EMA | 9117- MMA | 9406- MMA | 9119- FHA | 8231- E2B | 8202- E4B | 8231- E2B | 8205- E6B | 8233- E8B | 9117- MMB | 9179- MHB
Express Edition | 支持 | 支持 | 支持 |  |  | 支持 |  |  |  |  |  | 支持 | 支持 | 支持 | 支持 | 支持 |  |
Standard Edition | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Enterprise Edition | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Micro- partitioning | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
VIOS | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
IVM | 支持 | 支持 | 支持 |  |  | 支持 |  |  |  |  |  | 支持 | 支持 | 支持 | 支持 | 支持 |  |
PowerVM Lx86 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
NPIV | 支持 | 支持 | 支持 |  |  | 支持 |  | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Live Partition Mobility | 支持 | 支持 | 支持 |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
Shared Processor Pools |  |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持
HMC |  |  | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持 | 支持

参考如下链接：http://www-03.ibm.com/systems/power/software/virtualization/editions/features.html

突出价值点：详细、图形化的列举了不同Power服务器的型号所能够支持的PowerVM的3个版本及各个详细功能，方便客户统一查阅、参考。


什么是PowerVM?

解答:

PowerVM是在基于IBM POWER处理器的硬件平台上提供的具有行业领先水平的虚拟化技术家族。它是IBM Power System虚拟化技术全新和统一的品牌(逻辑分区，微分区，Hypervisor，虚拟I/O服务器，APV，PowerVM Lx86，Live Partition Mobility)。PowerVM有三个版本，分别是PowerVM Express Edition，PowerVM Standard Edition，PowerVM Enterprise Edition。

1. PowerVM Express Edition

PowerVM Express Edition只能在IBM Power 520，Power 550，PS700，PS701，PS702， Power 710，Power 720，Power 730，Power 740，Power 750，这几种服务器上购买。它们的主要功能包括：最多可以创建三个分区，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，不支持Multiple Shared Processor Pools和Live Partition Mobility功能，分区创建和管理使用IVM工具。

2. PowerVM Standard Edition

PowerVM Standard Edition可以在全部的IBM Power服务器上购买。它们的主要功能包括：对分区数量没有限制，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，支持Multiple Shared Processor Pools功能。不支持Live Partition Mobility功能。分区创建和管理可以使用IVM或者HMC工具。

3. PowerVM Enterprise Edition

PowerVM Enterprise Edition可以在全部的IBM Power服务器上购买。它们的主要功能包括：对分区数量没有限制，支持微分区虚拟化功能，支持Shared Dedicated Capacity，支持PowerVM Lx86功能，支持Multiple Shared Processor Pools功能和Live Partition Mobility功能。分区创建和管理可以使用IVM或者HMC工具。

注释：“Shared Dedicated Capacity”，“Multiple Shared Processor Pools”，“Live Partition Mobility”功能只有在基于IBM POWER6/POWER7处理器的服务器上才可以实现。

突出价值点：PowerVM有三种版本，灵活、全面的虚拟化功能。为用户低、中、高的虚拟化和整合需求提供了灵活多样的解决方案。对于数据中心空间和节能管理提供了技术上的支持。


PowerVM中的Processor Affinity和Virtual Processor Folding功能介绍

解答：

PowerVM中的Processor Affinity功能介绍:

在Power服务器上使用微分区功能创建分区时，处理器资源采用了共享的方式，物理处理器(Physical Processor)被放到共享处理器池中(Physical Shared Processor Pool)，服务器的物理处理器和操作系统所使用的虚拟处理器(Virtual Processor)之间没有了一一对应的关系。Power Hypervisor负责调度物理处理器的处理资源(Entitled Capacity)给操作系统中的虚拟处理器使用。由于物理和虚拟处理器之间没有绑定的关系，可能会导致虚拟处理器在不同的时钟周期得到来自不同物理处理器的处理资源，也就是说虚拟处理器上执行的程序在不同的时钟周期会在不同的物理处理器上执行，在这种情况下会造成对Cache，Memory的资源占用和Context switching。为了优化对Cache，Memory的使用和减少Context switching，Power Hypervisor将尝试调度以前虚拟处理器一直使用的物理处理器给该虚拟处理器使用。如果以前虚拟处理器一直使用的物理处理器不可用，Power Hypervisor将扩大寻找物理处理器的范围，具体寻找物理处理器的顺序为：

1. Chip: the other processor core on the POWER5 or POWER6 chip
2. Chip module: a processor core within the same chip module
3. Processor card/book (dependant on system type): a processor within the same processor card/book

PowerVM中的Virtual Processor Folding功能介绍:

从AIX5.3 ML3开始，为了让Uncapped Micro-Partition能够更有效的利用Physical Shared-Processor Pool中未被使用的Processor Capacity，PowerVM增加了Virtual Processor Folding功能。Virtual Processor Folding将未被使用的Virtual Processor置为休眠状态，以避免消耗系统资源。这个功能的好处在于提高Processor Affinity，减少POWER Hypervisor的负载，增加Virtual Processor在Physical Processor上的平均执行时间。

突出价值点：Processor Affinity功能使Power Hypervisor在微分区环境下优化Processor Capacity的调度；
Virtual Processor Folding将暂时没有被使用的Virtual Processor置于休眠状态，可以减少不必要的系统开销。


什么是PowerVM Lx86，Lx86支持的操作系统，以及不支持Lx86的应用

解答:

PowerVM Lx86是在基于IBM POWER处理器的服务器上产生一个虚拟的x86 Linux应用运行环境。大部分的32位x86 Linux上的应用可以不重新编译就可以运行在IBM Power System服务器上。

IBM PowerVM Lx86 version 1.2 支持以下的Linux操作系统:

1. Red Hat Enterprise Linux 4 (RHEL 4) for POWER version 4.4, 4.5 and 4.6. Also, x86 Linux applications running on RHEL 4.3 are supported.

2. SUSE Linux Enterprise Server 9 (SLES 9) for POWER Service Pack 3 and 4

3. SUSE Linux Enterprise Server 10 (SLES 10) for POWER Service Pack 1

IBM PowerVM Lx86 version 1.2即可以安装在IBM Power 520/550/560/570/575/595/710/720/730/740/750/770/780，又可以安装在IBM BladeCenter JS23/JS43/JS21/ JS22/JS12/PS700/PS701/PS702上。及可用于POWER5,POWER5+,POWER6,POWER7的服务器。

注意：如下应用不支持在PowerVM Lx86上运行：
1.直接访问硬件设备的应用（e.g.3D graphics adapters）。
2. 要求非标准的内核模块或不使用Linux for Power操作系统提供的内核模块的应用。
3. 不仅仅使用到1997年Intel架构软件开发者手册中定义的Intel IA-32指令集架构的应用，包括基本架构(Order Number 243190)，指令集参考手册(Order Number 243191)，系统编程手册(Order Number 243192)。
4. 不能在Red Hat Enterprise Linux 4 version 4.3或Novell SUSE Linux Enterprise Server (SLES) 9 version SP3 or Novell SLES 10操作系统上正常运行的应用。
5. 在x86 Linux上特殊的系统管理和配置工具。

突出价值点：大部分的32位x86 Linux上的应用可以不重新编译就可以运行在IBM Power System服务器上。为用户原有系统移植到Power平台上提供了方便的途径。


IVE介绍及特性

解答：

一. IVE的介绍

IVE 是Integrated Virtual Ethernet Adapter 的缩写,目前主要用于Power 520, Power 550, Power 560, Power 570, Power 710, Power 720, Power 730, Power 740, Power 750, Power 755, Power 770, Power 780上, 主要有三种类型的IVE adapter:

2个1Gbps 物理端口,1个Port Group,16个逻辑端口

4个1Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

2个10Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

其中Power 750/755主要有两种类型的IVE卡（与Power 520/550/560/570的后两种卡相同）：

4个1Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

2个10Gbps 物理端口,2个Port Group,32个逻辑端口(每个Port Group 16个逻辑端口)

如图一,显示了相应IVE adapter对应的物理端口,Port Group,和逻辑端口:

图一

其中1Gbps 的物理端口为RJ-45 Ethernet Connections,10Gbps的物理端口为光纤接口,其接口如图二:

图二

其中Power 770/780主要有三种类型的IVE卡：

Four 1 Gbps Ethernet ports

Two 10 Gbps SFP+ optical (SR only) Ethernet ports and two 1 Gbps copper Ethernet ports

Two 10 Gbps SFP+ copper twinax ports and two 1 Gbps Ethernet ports

对应的图片：Four 1 Gbps Ethernet ports

Two 10 Gbps SFP+ optical (SR only) Ethernet ports and two 1 Gbps copper Ethernet ports

Two 10 Gbps SFP+ copper twinax ports and two 1 Gbps Ethernet ports

其中Power 710/720/730/740主要有如下三种类型的IVE卡：

Quad-port 1 Gb HEA Daughter Card(每块IVE卡支持32个逻辑端口，每个物理端口支持最大8个逻辑端口)；

Dual-port 10 Gb HEA Daughter Card (Fiber)(每块IVE卡支持32个逻辑端口，每个物理端口支持最大16个逻辑端口)；

Dual-port 10 Gb HEA Daughter Card (Copper)(每块IVE卡支持32个逻辑端口，每个物理端口支持最大16个逻辑端口)。

二.IVE的特性:

(1) IVE直接连接到GX+ bus 上,不占用PCIe, PCI-X槽位；

(2) 每个物理端口有一个Layer 2 Switches;每个逻辑端口只能属于一个物理端口;属于同一个物理端口的LPAR之间可直接通信；

(3) 每个逻辑端口有一个唯一的MAC地址,可以将逻辑端口指派给任何一个LPAR；

(4) 指派给同一个LPAR的多个逻辑端口,均不属于同一个物理端口(注: 1个LPAR最多对应的逻辑端口,依赖于IVE的物理端口数)；

(5) IVE通过HMC或者IVM进行管理；

(6) 通过HMC或者IVM,将某个物理端口设定为Promiscuous模式,则这个物理端口只能分配给一个LPAR,其他LPAR不能共享这个物理端口；

(7) 通过HMC或者IVM设定MCS(Multiple Core Scaling)参数,以此来改变每个Port Group的逻辑端口数。例如:当MCS=1时,一个Port Group支持16个逻 辑端口,当MCS=8时,一个Port Group支持2个逻辑端口；

(8) IVE支持的操作系统:AIX(IBM AIX 5L version 5.2,5.3,6.1,7.1),Linux(Red Hat RHEL 4.5 or later; SuSE SLES 10 SP1 or later),IBM i(i 6.1, 7.1)。

突出价值点：天生具有虚拟化功能，不需配置VIO Server，即可使用对外的网络虚拟功能。

参考文档:《Integrated Virtual Ethernet Adapter Technical Overview and Introduction》

下载地址: http://www.redbooks.ibm.com/redpapers/pdfs/redp4340.pdf

Top


Power服务器的内置光驱是否可以进行DLPAR

解答：

在P5中，内置光驱是可以进行DLPAR的，在多个LPAR之间可进行动态切换；在POWER6中，内置光驱不能进行DLPAR，在多个LPAR之间不可进行动态切换；在POWER7中，Power 770和780每个CEC抽屉中的内置光驱是可以在多个LPAR之间进行动态切换的。

P5 52A，55A，561，570和Power 770，780中，内置光驱是被单独的控制器控制的，所以可以在多个LPAR之间进行动态切换。

Power 520，550，560，570；Power 720, 740中，内置光驱是被内置的SAS Controller控制的，所以不可以在多个LPAR之间进行切换。要实现光驱在多个LPAR之间进行动态切换，可以通过SAS卡连接外置光驱的方案来实现。对于POWER6服务器，目前可供选择的外置光驱为7214-1U2；对于POWER7服务器，目前可供选择的外置光驱为：7214-1U2和7216-1U2。

Power 750默认情况下，DVD不能在多个分区之间漂移。但是，如果将fc#8340的硬盘背板分离（每个通道4块硬盘），其中一个SAS通道是由集成的SAS控制器控制，另一个SAS通道是由一块SAS卡实现。内置的媒体设备与集成的SAS控制器绑定在一起，如果集成的SAS控制器上不放置硬盘，只配置了DVD和磁带机，此时内置媒体设备是可以实现在多个分区之间动态切换的。

突出价值点：不同的产品有不同的特性，用户可以根据需求进行相应配置。


刀片服务器上的VIOS是否支持NPIV？对硬件有何要求？

解答:

到目前为止，JS12,JS22,JS23,JS24，PS700，PS701，PS702都在在Sales Manual中都声明了对NPIV的支持，并对不同操作系统有不同的硬件要求。其中刀片上，目前只支持8GB的HBA扩展卡(CFFh, CIOv)和10GbE FcoE扩展卡(CFFh)。

下表是对AIX Client LPAR的硬件兼通性要求：

NPIV Compatibilty Matrix | Qlogic 8Gb CIOv #8242 | Qlogic 8Gb CFFh #8271 | Emulex 8Gb CIOv #8240 | Qlogic 10GbE CFFh #8275
QLogic 8Gb Switch Modules fc#3284 | Yes | Yes | No | NA
Brocade 8Gb Switch Modules fc#5045, 5869 | Yes | Yes | Yes | NA
10GbE Passthru Module fc#5412 | NA | NA | NA | Yes

注：上表已略去已停产feature，若要查看更完整和最新信息，请查看相应刀片的Sales Manual：

JS21：http://www.ibm.com/common/ssi/rep_sm/2/872/ENUS7998-_h02
JS22: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS7998-_h01
JS23/43: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS7778-_h01
PS700: http://www.ibm.com/common/ssi/rep_sm/2/872/ENUS8406-_h02
PS701/702: http://www.ibm.com/common/ssi/rep_sm/1/872/ENUS8406-_h01


PowerVM新特性AMS(Active Memory Sharing)介绍，以及实现Active Memory Sharing的必要条件是什么？

解答：

共享内存概述

共享内存是分配给共享内存池的物理内存，在多个逻辑分区之间共享该内存。共享内存池是已定义的一组物理内存块，它们由系统管理程序作为单个内存池进行管理。配置为使用共享内存的逻辑分区（以后称为共享内存分区）与其他共享内存分区共享池中的内存。

例如，创建具有16GB物理内存的共享内存池。然后创建三个逻辑分区，将它们配置为使用共享内存，并激活共享内存分区。每个共享内存分区可使用共享内存池中的16GB。

分配给共享内存分区的内存量可大于共享内存池中的内存量。例如，可向共享内存分区1分配12GB，向共享内存分区2分配8GB，并向共享内存分区3分配4GB。这些共享内存分区总共使用24GB内存，但共享内存池只有16GB内存。在此情况下，内存配置被视为过量使用。

系统管理程序在共享内存分区的工作负载需求驱动下，通过不断执行下列任务来管理过量使用的内存配置：

* 根据需要，将来自共享内存池中的物理内存部分分配给共享内存分区；
* 根据需要，请求虚拟 I/O 服务器（VIOS）逻辑分区在共享内存池与调页空间设备之间读写数据。

在多个逻辑分区之间共享内存的能力称为PowerVM Active Memory（活动内存）共享技术。PowerVM Active Memory（活动内存）共享技术是随 PowerVM 企业版提供的，您必须获取并输入 PowerVM 版激活码才能使用。

实现Active Memory Sharing的必要条件：

就像Live Partition Mobility一样，Active Memory Sharing功能只能在POWER6服务器中配置，同样Active Memory Sharing只能在PowerVM企业版中获得。如果客户目前使用的PowerVM易捷版或PowerVM标准版，那么首先需要升级到PowerVM企业版，以便使用Active Memory Sharing功能。使用Active Memory Sharing功能的分区要求所有设备都是虚拟化的（通过VIOS获得），并定义此分区使用Shared Processor模式。

突出价值点：为内存根据应用需要在各分区间动态地、自动地切换提供了可能。

Top


Power服务器支持分区的最大数量是多少？

解答：

Power全系列服务器（POWER5，POWER6和POWER7）均支持微分区技术。通过微分区技术，可以0.1颗CPU为单位来创建分区，那么我们可以得到以下结论：

* 每个激活的处理器最多支持10个分区。
* 对于POWER5和POWER6单台服务器分区数量的上限为254。
* 目前，对于POWER7(Power 750/770/780)单台服务器分区数量的上限为160。

*需要注意的是，4-Core 4.2GHz封装的Power 570服务器支持最大32颗处理器，但是所支持的分区最大数量为160。

突出价值点: 非常细的颗粒度,为灵活的虚拟化方案提供了支持。

Top


将VIOS client AIX分区用于HA集群中的node时，要求配置双VIOS吗？以及原因

解答:

VIOS本身就是一个定制的AIX系统，只运行几个物理和虚拟device driver管理程序，本身非常稳定。所以，对于普通应用要求,一个VIOS即可, 但对于需要如下需求,建议配置2个VIOS。

1〉AIX client / cluster node分区希望在VIOS升级或更改配置时继续可用。

2〉AIX client / cluster node分区希望使用到SEA Failover等双VIOS提供的冗余和自动fail-over功能。

详细介绍请参考:《IBM System p Advanced POWER Virtualization Best Practices》


将VIOS client AIX分区用于HA集群中的node时，如果采用VIOS级别上的网络冗余功能，AIX操作系统和HA软件需要再对网络进行冗余设置吗? 如果不需要,HA支持单网卡配置吗

解答:

将VIOS client AIX分区用于HA集群中的node时，如果采用VIOS级别上的网络冗余功能，例如下图所示:双VIOS SEA failover已经对网络进行冗余设置。此时，AIX操作系统和HACMP都不会受到单网卡故障的影响，此时网络的单点故障对AIX操作系统和HACMP是透明的，由VIOS层面来处理。所以，此时一般对HACMP不再进行单节点上的网络冗余设置。HACMP支持这种单网卡配置。


目前AIX和VIOS的版本与各型号POWER7服务器间的兼容情况

解答：

目前，AIX和VIOS的版本与各型号POWER7服务器间的兼容情况见表：

突出价值点：方便查询AIX和VIOS的版本与各型号POWER7服务器间的兼容情况，有利于更好地预先确认应用实施条件。


Power服务器上使用NPIV的技术，是否需要额外的License

解答：

N_Port ID Virtualization (NPIV) 是业界通行的一个工业标准，主要目的是通过虚拟化光纤通道接口来简化 SAN 网络的架构 , 让虚拟环境下的服务器与 SAN 环境连接更加弹性和安全。

NPIV技术包含在PowerVM易捷版，标准版和企业版中，支持POWER6/POWER7服务器(包括刀片服务器)上的AIX V5.3,AIX V6.1,IBM i 6.1.1 and SUSE Linux Enterprise Server 11的分区。

因此，PowerVM的软件支持NPIV的技术，如果在Power服务器上使用NPIV的技术，不需要额外的License。

注意：要实现NPIV的技术，需要满足如下的要求：

1.POWER6/POWER7服务器；
2.至少一块8GB的双口HBA卡(fc#5735/fc#5273)；
3.支持NPIV的SAN交换机；
4.HMC V7.3.4 or later；
5.VIOS 2.1。


PowerHA

System P服务器AIX与HACMP版本兼容性的问题; 另外，实施HACMP时，最常用的方法及所需要的基本硬件资源 (最近更新)

Power 710/730与PowerHA SystemMirror for AIX的兼容性

Power 720/740与PowerHA SystemMirror for AIX的兼容性

Power 750与PowerHA SystemMirror的兼容性 (最近更新)

Power 770/780与PowerHA SystemMirror for AIX的兼容性

POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性

什么是PowerHA SystemMirror (最近更新)

PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术 (新增)

Linux on Power的高可用方案介绍

IP地址接管(IP Address Takeover IPAT)机制

做HA配置时，为了传输心跳信号，有哪些方案可以选择

什么是DB2 PureScale,它的主要功能以及特点介绍

什么是GPFS？以及其基本架构介绍 (新增)

GPFS基本创建过程以及常见注意事项 (新增)

GPFS中的Manager主要有哪几种,及区别 (新增)


System P 服务器 AIX与HACMP 版本兼容性的问题;另外，实施HACMP时，最常用的方法及所需要的基本硬件资源

解答:

常用的实施HACMP需要有相应的网卡,光纤卡与异步卡与心跳线.
网卡用于配置IP网络,包括Service ip 、Standby ip 和Boot ip。
光纤卡用于连接存储设备。
异步卡与心跳线用于组成串行网络。

System P Server AIX 与 HACMP 版本兼容性的问题

 | AIX 4.3.3 | AIX 5.1 | AIX 5.1(64-bit) | AIX 5.2 | AIX 5.3 | AIX 6.1 | AIX 7.1
HACMP 4.5 | No | Yes | No | Yes | No | No | No
HACMP/ES 4.5 | No | Yes | Yes | Yes | No | No | No
HACMP/ES 5.1 | No | Yes | Yes | Yes | Yes | No | No
HACMP/ES 5.2 | No | Yes | Yes | Yes | Yes | No | No
HACMP/ES 5.3 | No | No | No | Yes | Yes | Yes | No
HACMP/ES 5.4.0 | No | No | No | TL8+ RSCT 2.3.9+ | TL4+ RSCT 2.4.5+ | No | No
HACMP/ES 5.4.1 | No | No | No | TL8+ RSCT 2.3.9+ | TL4+ RSCT 2.4.5+ | Yes | Yes
PowerHA 5.5 | No | No | No | No | TL9+ RSCT 2.4.10.0 | TL2,SP1+ RSCT 2.5.2.0 | Yes
PowerHA 6.1 | No | No | No | No | TL9+ RSCT 2.4.12.0 | TL2,SP1+ RSCT 2.5.4.0 | Yes
PowerHA 7.1 | No | No | No | No | No | TL6+ RSCT 3.1.0.0 | Yes

参考链接：http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD101347

突出价值点：这个表格列出了目前常见的HACMP版本与操作系统AIX的兼容性，便于客户安装准备，并且提供了实施所需的基本硬件资源，便于客户规划管理。

Top


Power 710/730与PowerHA SystemMirror for AIX的兼容性

解答:

Power 710/730上运行不同的PowerHA与AIX版本时,各种版本之间的兼容性见下表:

Power 710/730 (8231-E2B) | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX 5.3 TL11 SP1, RSCT 2.4.13.0 | AIX V6.1 TL04 SP02, RSCT 2.5.4.2 | HACMP V5.4.1 APAR IZ84442, AIX V7.1, RSCT V3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V5.5 APAR IZ84440, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V6.1 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V6.1 SP3, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V7.1 | Not Supported | AIX V6.1 TL06, RSCT V3.1.0.0 | AIX V7.1, RSCT V3.1.0.0


Power 720/740与PowerHA SystemMirror for AIX的兼容性

解答:

Power 720/740上运行不同的PowerHA与AIX版本时,各种版本之间的兼容性见下表:

Power 720/740 (8205-E4B/E6B) | AIX V5.3 | AIX V6.1 | AIX V7.1
HACMP V5.4.1 | AIX 5.3 TL11 SP1, RSCT 2.4.13.0 | AIX V6.1 TL04 SP02, RSCT 2.5.4.2 | HACMP V5.4.1 APAR IZ84442, AIX V7.1, RSCT V3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V5.5 APAR IZ84440, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V6.1 | AIX V5.3 TL12, RSCT 2.4.13.0 | AIX V6.1 TL05, RSCT 2.5.5.0 | PowerHA V6.1 SP3, AIX V7.1, RSCT V3.1.0.0
PowerHA SystemMirror V7.1 | Not Supported | AIX V6.1 TL06, RSCT V3.1.0.0 | AIX V7.1, RSCT V3.1.0.0


Power 750与PowerHA SystemMirror的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.5, 6.1 和7.1添加了对Power 750的支持。具体细节信息如下：

IBM Poewr 750 (8233-E8B) | AIX 5.3 | AIX 6.1 | AIX 7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 5.5 SP7 AIX V7.1, RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3 TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX V7.1, RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL06 RSCT 3.1.0.0 | AIX V7.1, RSCT 3.1.0.0

注意：POWER7服务器上集成的串口不能用于PowerHA的心跳，可以通过配置单独的串口卡或者用磁盘做心跳；PowerHA可以使用POWER7服务器上集成的网卡。

参考链接:http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10705

突出价值点：表格列举了PowerHA的2个版本与Power 750服务器及AIX操作系统的兼容性，便于客户查阅。


Power 770/780与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.4.1, V5.5, V6.1 和V7.1的版本可以支持IBM POWER7 770/780 (9117-MMB/9179-MHB)。

具体操作系统和补丁版本请参考下表:

IBM POWER7 770/780 (9117-MMB/9179-MHB) | AIX V5.3 | AIX V6.1 | AIX V7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 5.5 SP5 AIX V7.1, RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP03 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX V7.1, RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL6 RSCT 3.1.0.0 | AIX V7.1, RSCT 3.1.0.0

注：

(1)POWER7服务器上的集成串口不支持PowerHA；

(2)POWER7服务器的集成以太网卡支持PowerHA；

(3)IBM强烈建议在同时使用了DLPAR和微分区技术的分区建立双机环境时,在PowerHA 6.1中安装APAR IZ72927。

参考链接：http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10708


POWER7刀片服务器与PowerHA SystemMirror for AIX的兼容性

解答:

IBM PowerHA SystemMirror for AIX V5.4.1, V5.5, V6.1 和V7.1的版本可以支持BladeCenter PS700 (8406-70Y) and PS701/702 (model 8406-71Y)。具体细节信息如下：

BladeCenter PS701/702 | AIX V5.3 | AIX V6.1 | AIX V7.1
PowerHA V5.4.1 | AIX V5.3, TL11, SP01 RSCT 2.4.13.0 | AIX V6.1, TL04, SP02 RSCT 2.5.4.2 | PowerHA 5.4.1 SP10 AIX V7.1, RSCT 3.1.0.0
PowerHA V5.5 | AIX V5.3 TL12 RSCT 2.4.13.0 | AIX V6.1, TL05 RSCT 2.5.5.0 | PowerHA 5.5 SP7 AIX 7.1 RSCT 3.1.0.0
PowerHA V6.1 | AIX V5.3 TL12 RSCT 2.4.13.0 | AIX V6.1, TL05 RSCT 2.5.5.0 | PowerHA 6.1 SP3 AIX 7.1 RSCT 3.1.0.0
PowerHA V7.1 | N/A | AIX V6.1, TL06 RSCT 3.1.0.0 | AIX 7.1 RSCT 3.1.0.0

(1)支持如下的卡：

fc#8240 Emulex 8Gb FC Expansion Card (CIOv);
fc#8241 QLogic 4Gb FC Expansion Card (CIOv);
fc#8242 QLogic 8Gb FC Expansion Card (CIOv);
fc#8246 SAS Connectivity Card (CIOv);
fc#8251 Emulex 4Gb FC Expansion Card (CFFv);
fc#8252 QLogic Ethernet/4Gb FC Expansion Card (CFFh);
fc#8271 QLogic Ethernet/8Gb FC Expansion Card (CFFh).

(2)PowerHA支持集成的以太网卡，包括集成虚拟网卡(IVE)；

(3)支持IVM Integrated Virtualization Manager。

参考链接：http://www.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/FLASH10713


什么是PowerHA SystemMirror

解答：

PowerHA SystemMirror for AIX V6.1是PowerHA V5.5之后的新版本HACMP软件。

PowerHA SystemMirror分标准版和企业版两种：

标准版(5765-H23)针对数据中心内的高可用方案；

企业版(5765-H24)包括标准版的功能和双站点的远程高可用方案(XD)。

PowerHA SystemMirror 6.1标准版能够实现：
– 监控、检测事件并对事件做出反应
– 在系统之间建立心跳
– 使系统可以自动切换

PowerHA SystemMirror 6.1企业版支持如下的技术：
IBM DS8000 Metro Mirror, SVC Metro Mirror & Global Mirror, EMC SRDF
以及SP3版本新添加对Hitachi Truecopy and IBM DS8700 Global Mirror技术的支持。

在PowerHA SystemMirror标准版(5765-H23)和企业版(5765-H24)中，默认包含了Smart Assist的功能，不再需要单独购买。

PowerHA SystemMirror V6.1支持的AIX操作版本:

AIX 5.3 Technology Level 9，RSCT V2.4.12，及以上版本；

AIX 6.1 Technology Level 2，RSCT V2.5.4，及以上版本。

PowerHA SystemMirror V6.1 SP3 支持 AIX V7.1,RSCT V3.1.0.0，及以上版本。

突出价值点：PowerHA SystemMirror for AIX V6.1是新发布的一款高可用集群软件，它分为两个版本 - 标准版和企业版。其中，标准版用于数据中心内的高可用方案，企业版用于双站点的远程高可用方案，企业版既包含了标准版的功能，又包含了两站点的容灾功能。新的PowerHA版本里面默认包含了Smart Assist的功能、可以支持EMC SRDF的存储复制技术、支持GLVM配置向导以及支持DLPAR的功能等。


PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

解答:

下面是PowerHA V6.1 Standard Edition 和 Enterprise Edition 的特性对比表：

 | Stanard Edition | Enterprise Edition
Centralized management C-SPOC | Y | Y
Cluster resource management | Y | Y
Shared storage management | Y | Y
Cluster verification framework | Y | Y
Integrated heart beating | Y | Y
SMIT management interfaces | Y | Y
AIX event/error management | Y | Y
Disk heart beating | Y | Y
PowerHA Dynamic LPAR high availability management | Y | Y
Smart assists | Y | Y
Multi Site HA management |  | Y
PowerHA GLVM |  | Y
GLVM deployment wizard |  | Y
IBM Metro Mirror support |  | Y
IBM Global Mirror support |  | Y
EMC SRDF/S SRDF/A |  | Y


PowerHA SystemMirror for AIX6.1企业版 支持的数据复制技术

解答：

PowerHA SystemMirror for AIX 6.1企业版包含了PowerHA SystemMirror for AIX 6.1标准版的功能和两个站点的集群管理功能。PowerHA企业版可以在远端站点实现自动的资源切换，并管理相关的复制对等功能。

在PowerHA SystemMirror for AIX 6.1企业版上，支持的数据复制技术如下：

1.支持DS8700的同步和异步复制技术；
2.支持SVC的同步和异步复制技术；
3.支持Hitachi TrueCopy；
4.支持EMC SRDF；
5.支持GLVM 同步和异步复制技术。

可以参考下表:

 | Sync mode | Async mode | Active Active | Consistency groups
GLVM | Yes | Yes | Yes | Yes
SVC | Metro Mirror | Global Mirror | yes | yes
DS8700 | Metro Mirror | Global Mirror | yes | yes
EMC | SRDF | SRDF | yes | yes
Hitachi | Truecopy | Truecopy | yes | yes

注意：

同步复制模式，两个站点之间最大支持300KM的距离；
异步复制模式，两个站点之间理论上没有距离的限制。

突出价值点：PowerHA SystemMirror for AIX 6.1企业版，可以支持多种存储的复制技术，不仅支持IBM的存储复制技术，还支持EMC和Hitachi的存储复制技术，可以满足客户不同存储设备的需求。


Linux on Power的高可用方案介绍

解答：

PowerHA不再支持Linux on Power，针对Linux on Power可以为客户提供以下两种高可用解决方案：

突出价值点：虽然PowerHA不再支持Linux，但在Power平台上的Linux还是可以得到多种高可用方案的保护，来保证客户关键应用的稳定运行。

Top


IP地址接管(IP Address Takeover IPAT)机制

解答：

IP 地址接管是一种恢复IP地址标签的机制，其方法是在初始物理网络适配器发生故障时，将服务IP标签转移到备份的物理网络适配器或者转移到备份节点的物理网络适配器上。IPAT 确保用于向客户端节点提供服务的IP地址（标签）保持可用。
目前有两种IPAT的方式：
- IP替换的IP地址接管 (IPAT via replacement )
- IP别名的IP地址接管（IPAT via alias），这是目前PowerHA默认的方式。

可以将两种IPAT方法和这些方法控制服务IP标签的方式作如下解释：

- IP替换的IP地址接管

服务IP地址替换网络接口上的现有(启动/基本)IP地址。使用此方法，同一网络接口上一次仅配置有一个IP地址/标签。

注意：在此配置中，服务IP地址必须与一个节点的通信接口启动地址在同一个子网上，而备用通信接口的基本IP地址必须在一个不同的子网上。此方法还可以节省子网，但是需要额外的硬件。参考下图：

如果包含服务IP地址的通信接口发生故障，在使用通过IP替换的IPAT时，PowerHA将把服务IP地址转移到在同一个节点并在同一网络上的另一个可用接口；在此情况下，关联的资源组不受影响。

如果同一个节点上没有可用的接口，则将资源组连同服务IP标签一起转移到另一个具有可用通信接口的节点上。

在使用IP替换的IPAT(也称为“传统IPAT”)时，还可以配置硬件地址接管(HWAT)。硬件地址接管的实现方式是使用本地管理地址（locally administered address，LAA）来屏蔽通信接口的本机MAC地址，从而确保客户端上的ARP缓存中的映射保持不变。

- IP别名的IP地址接管

将服务IP地址/标签用作某个现有通信接口的别名，而不更改（替换）该接口的基本地址。使用ifconfig命令来执行此操作。

注意：在此配置中，节点上定义的所有基本（启动）IP地址/标签必须配置在不同的子网上，并且还要与服务IP地址（标签）不同。此方法还可以节省硬件，但是需要额外的子网。参见下图:

PowerHA使用AIX的IP别名网络功能来支持不同类型的网络上的IP地址接管。通过IP别名的IPAT可以在某些类型的网络上使用无故ARP (gratuitous ARP) 功能。

IP别名的IPAT使单个网络适配器可以支持多个服务IP地址（标签）。因此，同一个节点可以同时承载多个资源组，而不会将资源组的数量限制为可用的通信接口的数量。

相对于通过IP替换的IPAT，通过别名的IPAT提供了以下优点：

- IP别名的IP地址接管比通过IP替换的IPAT速度更快，因为与在同一个接口上添加一个IP别名相比，替换IP地址要花显著更长的时间;

- IP别名允许多个服务标签在同一个网络接口上共存，因此可以在集群中使用更少的物理网络接口卡。

突出价值点：介绍了PowerHA中IP地址的接管机制，分别对替换和别名的两种方式进行阐述，描述了两种接管机制各自的优点和特性。

参考资料：《PowerHA for AIX Cookbook》
书号：SG24-6375-01 页码：第78页

Top


做HA配置时，为了传输心跳信号，有哪些方案可以选择

解答：

心跳(heartbeat)是在群集中节点间传递的通讯包,用于监测群集中的节点、网络和网络接口的工作状态，防止节点的孤立，以保证群集的正常运作。在HA系统中心跳信息可以有三种方案来传递:

(1) TCP/IP网络

(2) 串口心跳(RS232)

(3) 共享磁盘

其中方案(2)(3)为非IP心跳，在HA配置心跳的时候，除了IP心跳外，我们强烈建议集群系统中至少再加配一个非IP心跳(方案2或3)。

突出价值点：使用非IP网络除了为群集提供传递心跳信息的途径外，也是IP网的备份 -- 可以避免由于TCP/IP软件自身故障而导致的系统节点孤立等异常情况的发生。


什么是DB2 PureScale,它的主要功能以及特点介绍

解答:

DB2 PureScale是一种新的DB2可选组件，通过提供无限的容量、持续的可用性和应用程序透明性。DB2 PureScale降低了业务增长的风险和成本。DB2 PureScale on IBM Power Systems融合了PowerHA PureScale技术，在UNIX或x86系统上交付了无与伦比的数据库可伸缩性和可用性水平。它补充了现有的DB2 for z/OS和System z，是整体系统在可用性、可扩展性、安全性和可靠性方面当之无愧的领袖。

在IBM Power Systems上部署的DB2 PureScale结合PowerHA PureScale技术,可以提供DB2数据库的高可扩展性和高可用性，DB2 PureScale的主要功能用一句话来说就是在不牺牲性能的前提下扩展DB2集群。

DB2 PureScale产品特点如下：

1、无限的容量: DB2 PureScale为所有事务性工作负载提供了几乎无限的容量。要扩展您的系统，只需连接新节点并发出两条简单命令。DB2 PureScale基于集群的共享磁盘架构通过有效使用系统资源降低了成本。

2、应用程序透明性: 使用DB2 PureScale，您无需更改应用程序代码即可在多个节点上有效运行。借助成熟、可扩展的架构，您可以扩展应用程序来满足最严苛的业务需求。而且，只需少量改动或者甚至无需改动，就可以运行为其他数据库软件编写的应用程序。DB2提供了对常用语法和PL/SQL过程的本机支持，这使从Oracle数据库迁移到DB2变得比以往更加轻松。

3、持续的可用性: DB2 PureScale通过使用基于IBM Power Systems且高度可靠的PowerHA PureScale技术，以及一个冗余平台，提供了持续的可用性。该系统几乎可在出现节点故障的同时进行恢复，立刻将工作负载重新分配到健康的节点上。

突出价值点: DB2 PureScale提供无限的容量、持续的可用性和应用程序透明性，降低了业务增长的风险和成本。


什么是GPFS？以及其基本架构介绍

解答：

1.什么是GPFS

GPFS(General Parallel File System)是IBM公司开发的通用集群文件系统，支持AIX/Linux/Windows操作系统。

在集群的环境中，GPFS文件系统允许集群中所有的节点访问同一文件的数据，并提供统一的文件存储空间。应用可以使用标准的UNIX文件系统接口访问文件的内容, 大多数应用不需要修改或重新编译就可运行在GPFS文件系统上。UNIX文件系统上的实用程序也为GPFS所支持，也就是用户可以继续使用他们所熟悉的UNIX命令来进行常规的文件操作，但是用户需要使用GPFS文件系统的特有的管理命令来管理GPFS文件系统。GPFS支持32位和64位的应用，可以动态的增加或减少文件系统的容量。

GPFS文件系统区别于其他的集群文件系统的特点是，在多个节点中，为应用提供并发的、高速的文件访问，提供突出的性能，尤其是大数据量的顺序操作，尽管典型的GPFS应用适用于多个节点，但对单个节点也能提供有益的性能。GPFS特别适合于集中对数据的访问超过了分布式文件服务器的处理能力的应用环境。它不适用于以热备份为主应用环境或数据很容易按照节点划分区的应用环境。

2.GPFS的基本结构

GPFS是一种定义在多个节点上的集群文件系统。运行GPFS的全部节点集称之为GPFS群集。在GPFS群集中，所有节点又被分成多个GPFS节点集，在同一个节点集的节点可共享其所属的GPFS文件系统，而其他节点集中的节点是无法访问它的。GPFS支持lc、rpd、hacmp和sp等多种群集类型。

GPFS群集中的每一节点，都由以下几方面构成：（1）GPFS管理命令 （2）扩展核心 （3）多线程的后台监控程序

2.1 GPFS的扩展核心

GPFS的扩展核心为操作系统的vnode提供了一个接口，为增加文件系统提供了虚拟文件系统接口。在结构上，应用程序向操作系统发出一文件系统调用请求，操作系统会将此请求转给GPFS文件系统扩展核心。从应用的角度，GPFS只是一个文件系统。GPFS的扩展核心将完成这些请求 -- 通过使用系统中已有的资源或发送消息给GPFS后台监控程序来完成此请求。

2.2 GPFS后台监控程序

GPFS后台监控程序为GPFS完成所有的I/O操作和缓存的管理。 这包括预读（read-ahead）和延迟写(write-behind)。 所有的I/O操作是由令牌（token）来控制的，这确保了建立在多节点上的文件系统中数据的一致性。后台监控程序是一多线程的进程，有些线程只处理某些特定的功能。忙于日常事务的线程只进行日常事务处理，有专用的线程来响应服务请求。后台监控进程也与运行在其他节点上运行GPFS的实例进行通信，来协调配置的改变、文件系统的恢复和并行修改相同的数据结构。这些具体的功能包括：

.为新文件和新扩大的文件分配空间，这通过与文件系统管理器（file system manager）协商完成；
.目录的管理，包括创建新目录、插入和删除目录中的条目、因I/O的请求而检索相关的目录；
.为保证数据和元数据的完整性分配适当的锁。涉及到会从多个节点访问的数据；
.磁盘的I/O 是由后台进程中的线程发起的；
.文件系统的安全与配额管理也是由进程协同文件系统管理器共同管理的。


GPFS基本创建过程以及常见注意事项

解答：

(注: 以下命令中的具体参数仅供参考,实际操作中请结合环境使用正确的参数)。

1 环境准备

1.1 在全部节点准备两个文件/etc/hosts和/.rhosts，内容示例如下：

/etc/hosts (用来支持节点之间的访问)
192.168.1.13 techline13
192.168.1.14 techline14
192.168.1.15 techline15
注意事项:需要将全部节点的主机名和IP都列出来。

/.rhosts (用来支持节点之间访问时的权限)
techline13 root
techline14 root
techline15 root
注意事项:需要将全部节点都列出来。

1.2 在操作配置节点准备两个文件/tmp/mmfs/nodefile和/tmp/mmfs/nsdfile, 内容示例如下：

/tmp/mmfs/nodefile (创建节点时用到)
techline13:manager-quorum
techline15:manager-quorum
techline14:client-nonquorum

/tmp/mmfs/nsdfile (创建NSD盘时用到)
hdisk1:techline13::dataAndMetadata::
hdisk2:techline13::dataAndMetadata::

1.3 export PATH=$PATH:/usr/lpp/mmfs/bin:. (在所有节点设置环境变量)

2.在全部节点安装GPFS3.4(以V3.4为例)软件：

安装文件gpfs.base, gpfs.docs.data, gpfs.msg.en_US三个文件, 然后安装升级包3.4.0.2
注意事项: 如果不安装升级包3.4.0.2,则执行命令mmstartup时会报错。

3.创建GPFS集群：

mmcrcluster -N /usr/lpp/mmfs/nodefile -p techline13 -s techline15 -C gpfscluster01 -A

4.设定license：

mmchlicense server/client –accept
注意事项:此为V3.3版本以后才有的要求。

5.创建NSD：

mmcrnsd -F /usr/lpp/mmfs/nsdfile -v no
mmlsnsd

6.创建文件系统：

mmstartup -a
mmcrfs /gpfs01 gpfs01 -F /usr/lpp/mmfs/nsdfile -A yes -B 256K

7.在所有节点挂载文件系统：

mmmount /gpfs01
注意事项: 此步也可以用操作系统的命令mount /gpfs01来实现。

Top


GPFS中的Manager主要有哪几种,及区别

解答：

GPFS中主要有三种Manager角色:Cluster configuration Server / Cluster Manager / File system Manager.

Cluster configuration Server主要用来管理集群的配置信息,修改集群配置信息的命令在执行时都要求访问Cluster configuration Server,而且各节点的GPFS daemon进程在启动时都需要访问Cluster configuration Server, 因此在配置集群时建议设定primary和secondary两个manager,以保证至少有一个是available的,从而保证集群的正常工作。

Cluster Manager的主要功能有:

1 管理并选定File system Manager；
2 管理集群quorum；
3 将集群变化通知其它集群；
4 监控硬盘的使用；
5 处理remote cluster 的UID mapping请求。

Cluster Manager的选定原则是:存活最久的节点将会被选为Cluster Manager, 当然我们可以通过命令强制指定某节点为Cluster Manager。

File system Manager的主要功能有：

1 管理本文件系统的配置信息；
2 管理磁盘空间的分配；
3 文件访问的令牌管理；
4 quota管理。

Top


性能与物理参数

服务器性能参数

System P系列服务器的CPU, Memory, I/O的带宽

物理环境参数

System P系列服务器的尺寸、环境要求、功率和重量


System P系列服务器的CPU, Memory, I/O的带宽

解答:

答案、解释及解决问题的步骤：

CPU
处理器型号
可选Core数量
主频
Memory
RAM(内存)
一级缓存
二级缓存
三级缓存 		I/O带宽(峰值)
处理器到内存带宽
二级到三级高速缓存的带宽
GX I/O 子系统带宽
Power 520
8203-E4A

64-bit IBM POWER6 & POWER6+
1 (4.2 GHz only), 2 or 4
POWER6: 4.2 GHz
POWER6+: 4.7 GHz

 2-16 GB (1-core);4-32 GB (2-core);4 - 64 GB (4-core)
L1: 64 KB - 64 KB
L2: Up to 16 MB (8 MB per dual core chip)
L3: 4.2 GHz: 0 4.7 GHz: Up to 64 MB (32MB per dual-core chip) 		32.0GBps
75.2GBps
28.2GBps
Power 550
8204-E8A 		64-bit POWER6 & POWER6+
2, 4,6 or 8 core
POWER6: 3.5 GHz, 4.2 GHz
POWER6+: 5.0GHz 		3.5 GHz: 4–128 GB;4.2, 5.0 GHz: 4 GB - 256 GB(8 DIMM slots per processor card)
L1: 64 KB - 64 KB
L2: Up to 32 MB (8 MB per dual core chip)
L3: Up to 128 MB (32 MB per dual-core chip) 		128GBps(8-core)
160GBps(8-core)
23.3GBps
Power 560
8234-EMA 		64-bit IBM POWER6
4,8 or 16 core
3.6 GHz 		8 GB - 384 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		128.0GBps
230.0GBps
24.0GBps
Power 570
9117-MMA 		64-bit POWER6
2, 4, 8, 12 or 16 core
3.5GHz, 4.2GHz, 4.4GHz，4.7GHz，5.0GHz 		2 GB - 768 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		256GBps
300.8GBps
66.7GBps
Power 570
9117-MMA 		64-bit POWER6+
4, 8, 16，24 or 32 core
4.2GHz 		2 GB - 768 GB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		256GBps
300.8GBps
66.7GBps
Power 595
9119-FHA 		64-bit POWER6
8 - 64
4.2 GHz; 5.0 GHz 		16 GB - 4 TB
L1: 64 KB - 64 KB
L2: 8 MB
L3: 32 MB 		1376.0GBps
2560.0GBps
640.0GBps
BladeCenter JS22
7998-61X 		64-bit POWER6
4-core
4.0 GHz 		4GB – 32GB
L1: 64 KB - 64 KB
L2: 4 MB
L3: - 		21.3GBps
-
5.8GBps
BladeCenter JS12
7998-60X 		64-bit POWER6
2-core
3.8 GHz 		2 GB - 64 GB
L1: 64 KB - 64 KB
L2: 4 MB
L3: - 		21.3GBps
-
5.8GBps
BladeCenter JS23
7778-23X 		64-bit IBM POWER6+
4-core
4.2GHz 		4 GB – 64 GB
L1: 64 KB - 64 KB per core
L2: 16MB (8 MB per dual core chip)
L3: 64MB (32MB per dual-core chip) 		21.3GBps
67.2GBps
8.4GBps
BladeCenter JS43
7778-23X plus fc#8446 		64-bit POWER6+
8-core
4.2GHz 		8 GB - 128 GB
L1: 64 KB - 64 KB per core
L2: 32 MB (8 MB per dual core chip)
L3: 128 MB (32MB per dual-core chip) 		42.68GBps
134GBps
16.8GBps
Power 710
8231-E2B 		64-bit POWER7
4 core at 3.0 GHz
6 core at 3.7 GHz
8 core at 3.55 GHz 		8 - 64 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

68.22 GBps per socket

L1 Cache: 144 GB/s(3.0GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L2 Cache:144 GB/s(3.0GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L3 Cache: 96 GB/s(3.0GHz); 113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

30GBps
Power 720
8202-E4B 		64-bit POWER7
4, 6, 8 core at 3.0 GHz 		4 core
8 – 64 GB (1066 MHz DDR3)
6 or 8 core
8 – 128 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

68.22 GBps per socket

L1 Cache: 144 GB/s(3.0GHz);
L2 Cache:144 GB/s(3.0GHz);
L3 Cache: 96 GB/s(3.0GHz).

30GBps
Power 730
8231-E2B 		64-bit POWER7
8 core at 3.0 GHz
8 core at 3.7 GHz
12 core at 3.7 GHz
16 core at 3.55 GHz 		8 - 128 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

136.44GBps

L1 Cache: 144 GB/s(3.0GHz);170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L2 Cache:144 GB/s(3.0GHz);170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz);
L3 Cache: 96 GB/s(3.0GHz);113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

50GBps
Power 740
8205-E6B 		64-bit POWER7
4, 8 core at 3.3 GHz
4, 8 core at 3.7 GHz
6, 12 core at 3.7 GHz
16 core at 3.55 GHz 		8 - 256 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

136.44GBps(68.22 GBps per socket)

L1 Cache: 158.4 GB/s(3.3GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz)
L2 Cache:158.4 GB/s(3.3GHz); 170.4 GB/s(3.55GHz);178.56 GB/s(3.7 GHz)
L3 Cache:105.6 GB/s(3.3GHz); 113.6 GB/s(3.55GHz); 119.04 GB/s(3.7 GHz).

50GBps
Power 750
8233-E8B 		64-bit POWER7
8, 16, 24, 32 core at 3.0 GHz or 3.3 GHz
32-core at 3.55 GHz 		8 GB – 512 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

272.9GBps(68.22 GBps per socket)

L1 Cache:144 GB/s(3.0GHz);158.4 GB/s(3.3GHz);170.4 GB/s(3.55GHz);
L2 Cache:144 GB/s(3.0GHz);158.4 GB/s(3.3GHz);170.4 GB/s(3.55GHz);
L3 Cache: 96 GB/s(3.0GHz); 105.6 GBps (3.3 GHz);113.6 GB/s(3.55GHz).

30GBps
Power 755
8236-E8C 		64-bit POWER7
32-core
3.3 GHz 		128 GB – 256 GB (1066 MHz DDR3)

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

272.9GBps(68.22 GBps per socket)

L1 Cache:158.4 GB/s(3.55GHz);
L2 Cache:158.8 GB/s(3.55GHz);
L3 Cache:105.6 GB/s(3.55GHz).

25GBps
Power 770
9117-MMB 		64-bit POWER7
12, 24, 36, 48 core at 3.5 GHz 		32 GB – 1024 GB (1066 MHz DDR3)
128 GB – 2 TB
(1066 MHz DDR3)2010年11月19日可订购

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

1091.6GBps(68.22 GBps per socket)

L1 Cache:148.8 GB/s(3.1GHz);
L2 Cache:148.8 GB/s(3.1GHz);
L3 Cache:99.2 GB/s(3.1GHz).

236.5GBps
Power 780
9179-MHB 		64-bit POWER7
16, 32, 48, 64 core at 3.8 GHz (Standard mode)
8, 16, 24, 32 core at 4.1 GHz(TurboCore mode) 		32 GB – 1024 GB (1066 MHz DDR3)
128 GB – 2 TB
(1066 MHz DDR3)2010年11月19日可订购

L2: 256 KB(Per-Core)
L3: 4 MB (Per-Core)

1091.6GBps(68.22 GBps per socket)

L1 Cache:185.28 GB/s(3.86GHz);
L2 Cache:185.28 GB/s(3.86GHz);
L3 Cache:123.52 GB/s(3.86GHz).

236.5GBps
IBM BladeCenter PS700
8406-70Y 		64-bit POWER7
4 core
3.0 GHz 		8 GB - 64 GB (1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		34.1GBps
-
-
BladeCenter PS701
8406-71Y 		64-bit POWER7
8-core
3.0GHz 		16 GB – 128 GB (1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		68.2GBps
-
-
BladeCenter PS702
8406-71Y plus + fc#8358 		64-bit POWER7
16-core
3.0GHz 		32GB - 256 GB(1066 MHz DDR3)
L2: 256 KB(Per-Core)
L3:4 MB (Per-Core) 		136.4GBps
-
-

突出价值点：表格列举了System P系列服务器的CPU,Memory,I/O的带宽，便于客户查阅。

所需资源和渠道的详情：
网址:http://www-03.ibm.com/systems/power/hardware/reports/factsfeatures.html

Top


System P系列服务器的尺寸、环境要求、功率和重量

解答:

 | 高度(英寸/毫米) | 宽度(英寸/毫米) | 深度(英寸/毫米) | 操作温度(°C) | 操作湿度 | 最高纬度(米) | 最大功率(KVA) | 重量(kg)
Power 520(机架式） | 4U-6.8/173 | 17.3/440 | 21.2/538 | 5-35 | 8%-80% | 3048 | 0.876 | 34
Power 520(桌边式） | 21.3/540 | 7.2-12.9/182-329 | 24.7/628 | 5-35 | 8%-80% | 3048 | 0.876 | 37.6-40.8
Power 550(机架式） | 4U-6.8/173 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.443 | 48.7
Power 550(桌边式） | 21.3/540 | 7.2-12.9/182-329 | 30.6/778 | 5-35 | 8%-80% | 3048 | 1.443 | 53.2-57.2
Power 560(一个系统柜） | 4U-6.85/174 | 19/483 | 32.4/824 | 5-35 | 8%-80% | 3048 | 1.224 | 63.6
Power 570(一个系统柜） | 4U-6.85/174 | 19/483 | 32.4/824 | 5-35 | 8%-80% | 3048 | 1.428 | 63.6
Power 575 | 42U-79.3/2014 | 29.5/756 | 60.0/1524 | 10-28 | 20%-80% | 3048 | N/A | 1656
Power 595 | 42U-79.3/2014 | 30.5/775 | 58.5-71.1/1486-1806 | 10-28 | 20%-80% | 3048 | 27.7 | 1531-1552
Power 710 | 2U-3.5/89 | 19/440 | 27.8/706 | 5-35 | 8%-80% | 3050 | 0.663 | 28.2
Power 720(机架式） | 4U-6.8/173 | 17.3/440 | 24/610 | 10-40 | 10% to 80% | 3048 | 0.765 | 48.7
Power 720(桌边式） | 21.3/541 | 7.2-12.9/183-328.5 | 27.1/688 | 10-40 | 10% to 80% | 3048 | 0.765 | 53.7-57.2
Power 730 | 2U-3.5/89 | 19/440 | 27.8/706 | 5-35 | 8%-80% | 3050 | 1.122 | 29.5
Power 740(机架式） | 4U-6.8/173 | 17.3/440 | 24/610 | 10-40 | 10% to 80% | 3048 | 1.428 | 48.7
Power 740(桌边式） | 21.3/541 | 7.2-12.9/183-328.5 | 27.1/688 | 10-40 | 10% to 80% | 3048 | 1.428 | 53.7-57.2
Power 750 | 4U-6.8/172 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.95 | 48.7
Power 755 | 4U-6.8/172 | 17.3/440 | 28.7/730 | 5-35 | 8%-80% | 3048 | 1.95 | 48.7
Power 770(一个系统柜） | 4U-6.8/172 | 19/483 | 32/863 | 5-35 | 8%-80% | 3048 | 1.6 | 70.3
Power 780(一个系统柜） | 4U-6.8/172 | 19/483 | 32/863 | 5-35 | 8%-80% | 3048 | 1.6 | 70.3

参见以下红皮书:《IBM Power Systems facts and features》；《IBM POWER7 systems facts and features》

网址: http://www-03.ibm.com/systems/p/hardware/reports/factsfeatures.html

Top


其他

P系列服务器显卡介绍

主要有哪些POWER6上的adapter、硬盘等设备是POWER7不支持的？ (新增)

常见SAS RAID Controller Adapter 介绍

Power System上Infiniband 产品的支持列表

什么是Power服务器的Storage Key?

POWER服务器处理器能否升级，以及升级后支持的数量 (最近更新)

POWER6 产品支持的操作系统

POWER7 产品支持的操作系统 (最近更新)

AIX V6.1支持的硬件环境

AIX V7.1支持的硬件环境

AIX EE 6.1版本包含哪些软件

什么是AIX Express Edition? 该版本有何要求？

AIX V 7.1支持的几个新功能

IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

AIX V7.1 标准版，企业版，易捷版的区别

AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？ (新增)

简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

什么是NIM？它的应用场景以及基本概念介绍 (新增)

NIM中常见的资源类型以及各自的特点介绍 (新增)

一个典型的NIM安装过程介绍 (新增)

在一些Power机型中，支持内置RAID卡。在AIX 操作系统中，也可以使用LVM的mirror功能提供磁盘冗余保护。这两种磁盘冗余保护方式在性能和可用性上有何区别？ (最近更新)

POWER服务器的电源和耗电量计算方法

Power系列机型上共有多少种SAS连接线, 它们有什么不同?

FCoE支持的操作系统

为什么选择FCoE/FCoEE?

什么是IBM Systems Director Active Energy Manager?

IBM Systems Director 系统软件各个版本包含哪些软件

IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

5765-SEP IBM Systems Director Standard Edition for Power Systems软件和5765-DRP IBM(R) Systems Director for Power Systems的区别是什么

5765-AME软件的功能，以及其相应的替代产品


P系列服务器显卡介绍

解答:

p系列服务器目前可配置两种显卡，分别为：fc#5748和fc#5269。具体介绍如下：

fc#5748 POWER GXT145 PCI Express Graphics Accelerator

POWER GXT145是一种多功能，低价格的2D图形加速器。它可以配置成8位或24位彩色模式。这个适配器同时支持模拟和数字显示器。该适配器需要一个PCI Express插槽。如果连接的设备需要一个15针D-Shell的接口的VGA连接（例如，当图形适配器的输出是直接连接到一个7316-TF3显示套件或间接通过一个KVM切换器），订购一个VGA到DVI接口转接器，fc#4276 去连接相应的设备。

硬件描述:

128位图形处理器
8-bit indexed， 8位真彩色，或24位真彩色
32兆SDRAM内存
1个PCI Express接口
2个DVI-I（模拟/数字视频）连接接口
它所支持的功能多达大约1670万颜色
Rectangular clipping
1个模拟监视器输出高达2048 x 1536分辨率
1个数字监视器输出高达1280 x 1024分辨率
第2个显示器支持对第二个连接高达1600 x 1200的模拟接口分辨率或1280 x 1024数字接口分辨率
第2个显示器，仅支持在Aix的克隆模式下，配一个模拟连接
APIs Supported
X-Windows and Motif

在任何一个分区不能超过4个图形适配器。
属性提供： 2D图形适配器
属性要求： 1个PCI Express插槽

配置要求：如果连接VGA的显示器(如7316-TF3),则需要加配：fc#4276 ( VGA to DVI Connection Converter )VGA到DVI转换器来转换成VGA接口。

操作系统要求：
AIX Version 5.3 supported
AIX Version 6.1 supported
AIX Version 7.1 supported
SUSE Linux supported
Red Hat Linux supported
Refer to Software Requirements for specific O/S levels supported

fc#5269 PCIe LP POWER GXT145 Graphics Accelerator

该卡为Low Profile的显卡，其功能与fc#5748类似。POWER GXT145是一种多功能，低价格的2D图形加速器。它可以配置成8位或24位彩色模式。这个适配器同时支持模拟和数字显示器。该适配器需要一个PCI Express插槽。如果连接的设备需要一个15针D-Shell接口的VGA连接（例如，当图形适配器的输出是直接连接到一个7316-TF3显示套件或间接通过一个KVM切换器），订购一个VGA到DVI接口转接器，fc#4276 去连接相应的设备。

硬件描述:
128位图形处理器
8-bit indexed， 8位真彩色，或24位真彩色
32兆SDRAM内存
1个PCI Express接口
2个DVI-I（模拟/数字视频）连接接口
它所支持的功能
多达大约1670万颜色
Rectangular clipping
1个模拟监视器输出高达2048 x 1536分辨率
1个数字监视器输出高达1280 x 1024分辨率
第2个显示器支持对第二个连接高达1600 x 1200的模拟接口分辨率或1280 x 1024数字接口分辨率
第2个显示器，仅支持在Aix的克隆模式下，配一个模拟连接
APIs Supported
X-Windows and Motif

在任何一个分区不能超过4个图形适配器。
属性提供： 2D图形适配器
属性要求： 1个Low Profile(LP) Slot

配置要求：如果连接VGA的显示器(如7316-TF3),则需要加配：fc#4276 ( VGA to DVI Connection Converter )VGA到DVI转换器来转换成VGA接口。

操作系统要求：
AIX Version 5.3 supported
AIX Version 6.1 supported
AIX Version 7.1 supported
SUSE Linux supported
Red Hat Linux supported
Refer to Software Requirements for specific O/S levels supported

突出价值点：分别详细介绍了P系列服务器中的两款显卡的产品特性和技术参数。

请参考销售手册中相应的feature code说明:

Power 产品销售手册查询

Top


主要有哪些POWER6上的adapter、硬盘等设备是POWER7不支持的？

解答：

POWER7 servers 不支持的POWER6 板卡
Feature | Description | CCIN | Replacement feature
 | Storage |  |
2749 | PCI Ultra Magnetic Media Controller HVD SCSI | 2749 | SCSI 5736 (LVD)
2757 | PCI-X Ultra RAID Disk Controller SCSI | 2757 | SCSI 5782 or move to SAS or FC/FCoE
2780 | PCI-X Ultra4 RAID Disk Controller SCSI | 2780 | SCSI 5782 or move to SAS or FC/FCoE
5580 | 2780 Controller with auxiliary Write Cache SCSI | 2780 / 5708 | SCSI 5782 or move to SAS or FC/FCoE
5581 | 2757 Controller with auxiliary Write Cache SCSI | 2757 / 5708 | SCSI 5782 or move to SAS or FC/FCoE
5583 | 5777 Controller with auxiliary Write Cache SCSI | 571E / 574F | SCSI 5782 or move to SAS or FC/FCoE
5590 | 2780 Controller with auxiliary Write Cache SCSI | 2780 / 574F | SCSI 5782 or move to SAS or FC/FCoE
5591 | 2757 Controller with auxiliary Write Cache SCSI | 2757 / 574F | SCSI 5782 or move to SAS or FC/FCoE
5702 | PCI-X Ultra Tape Controller SCSI | 5702 | SCSI 5736 or move to SAS or FC/FCoE
5712 | PCI-X Dual Channel Ultra320 Adapter SCSI | 5702 | SCSI 5736 or move to SAS or FC/FCoE
5776 | PCI-X Disk Controller 90 MB SCSI | 571B | SCSI 5782 or move to SAS or FC/FCoE
5777 | PCI-X Disk Controller 1.5 GB SCSI | 571E | SCSI 5782 or move to SAS or FC/FCoE
5778 | PCI-X EXP24 Controller 1.5 GB SCSI (note – adapter supported, can move it, but then is #5780/5782 feat code) | 571F | SCSI 5782 or move to SAS or FC/FCoE
5806 | PCI-X Dual Channel Ultra320 SCSI Adapter SCSI (note – adapter supported without an IOP – then is #5736 feat code) | 571A | SCSI 5736
5911 | SAS adapter for 570 internal Split DASD option | 57BA | Not applicable
 | Fibre Channel |  |
2787 | PCI-X Fibre Channel Disk Controller | 2787 | PCI-X 5749/5759 / PCIe 5774/5735 / FCoE
5704 | PCI-X Fibre Channel Tape Controller | 5704 | PCI-X 5749/5759 / PCIe 5774/5735 / FCoE
5760 | PCI-X Fibre Channel Disk Controller | 280E | PCI-X 5749/5759 / PCIe 5774/5735 / FCoE
5761 | PCI-X Fibre Channel Tape Controller | 280D | PCI-X 5749/5759 / PCIe 5774/5735 / FCoE
 | Ethernet |  |
1981, 5718 | 10 GB Ethernet-SR PCI-X Adapter | 1981 / 5718 | PCI-X 5721, PCIe 5769
1982, 5719 | 10 GB Ethernet-LR PCI-X Adapter | 1982 / 5719 | PCI-X 5722, PCIe 5772
1984, 5707 | 2-Port GB Ethernet-SX PCI-X Adapter | 1984 / 5707 | PCIe 5768
3709 | PCI 100/10 Mbps Ethernet IOA (note System i heritage ordered as 940x feat 2849 instead of 3709) | 2849 | None, use 1Gb adapters
 | Integrated xSeries Servers (IXS) |  |
4812 | PCI Integrated xSeries Server | 4812-001 | iSCSI attach 5713
4813 | PCI Integrated xSeries Server | 4812-001 | iSCSI attach 5713
 | I/O Processors (IOPs) |  |
2844 | PCI IOP | 2844 | None
2847 | PCI IOP for SAN Load Source | 2847 | None
3705 | PCI IOP (System i 2843) | 2843 | None
 | DTTA |  |
6312 | Quad Digital Trunk Telephony PCI Adapter | 6312 | None
 | Cryptographic |  |
4801 | PCI Cryptographic Coprocessor | 4758-023 | PCI-X 4764
4805 | PCI Cryptographic Accelerator | 2058-001 | PCI-X 4764
 | Twinax |  |
4746 | PCI Twinaxial Workstation IOA | 2746 | None. if really need, OEM protocol converter

POWER7 servers 不支持的POWER6 设备
Feature | Description | CCIN | Replacement feature
 | HDD (Disk drives) |  |
3273 | 36.4 GB 10k rpm SCSI Disk Drive | 1967 | SAS: SFF 1882/1883, 3.5-in 3647
4319, 4326 | 35.16GB 10k rpm Disk Unit | 4326 | SAS: SFF 1884, 3.5-in 3677
3277 | 36.4 GB 15k rpm SCSI Disk Drive | 1970 | SAS: SFF 1883, 3.5-in 3647
1968, 3274 | 73.4 GB 10k rpm SCSI Disk Drive | 1968 | SAS: SFF 1882/1883, 3.5-in 3647
1969, 3275 | 146.8 GB 10k rpm SCSI Disk Drive | 1969 | SAS: SFF 1882, 3.5-in 3647
1973, 3578 | 300 GB 10k rpm SCSI Disk Drive | 3578 | SAS: SFF 1885, 3.5-in 3648
 | Internal Optical drives |  |
3706 | DVD-ROM (note System i heritage ordered for 940x as feat 4631 instead of 3706) | 6336 | DVD RAM 5762
4430, 4630 | DVD-RAM | 6330-002 | DVD RAM 5762
4633 | DVD-RAM | 6333 | DVD RAM 5762
5756 | IDE Slimline DVD-ROM Drive | 6337-002/003 | DVD RAM 5762
5757 | IBM 4.7 GB IDE Slimline DVD-RAM Drive | 6331-002 | DVD RAM 5762
 | Internal HH tape drives |  |
3707 | 30 GB 1/4 in. Cartridge Tape (note System i heritage ordered for 940x as feat 4684 instead of 3707) |  | DAT 5907, 5619 or LTO 5746
3708, 4487 | 50 GB 1/4 in. Cartridge Tape (note System i heritage ordered for 940x as feat 4687) | 63A0 | DAT 5907, 5619 or LTO 5746
5907 | 36/72 GB 4 mm DAT72 SAS Tape Drive | N/A | DAT 5907, 5619
 | Diskette Drive |  |
2591 | External USB 1.44 MB Diskette Drive | N/A | None
 | Display / Monitor |  |
3636 | L200P Flat Panel Monitor | N/A | 22 in. wide screen 3632

突出价值点：可以方便查询adapter,硬盘等设备的兼容性。


常见SAS RAID Controller Adapter 介绍

解答：

CCIN (Custom Card Identification Number) | 572A | 572B | 57B8 | 57BA | 57B3 | 574E
Feature Code (FC) | fc#5912 | fc#5902 | fc#5679 | fc#5911 | fc#5901 | fc#5903
Description | PCI-X266 Ext Dual-x4 3Gb SAS Adapter | PCI-X266 Ext Dual-x4 3Gb SAS RAID Adapter | PCI-X266 Planar 3Gb SAS RAID Adapter | PCIe x8 Ext Dual-x4 3 Gb SAS Adapter and Cable Card | PCIe x8 Ext Dual-x4 3 Gb SAS Adapter | PCIe x8 Ext Dual-x4 3 Gb SAS RAID Adapter
Form factor | Low Profile 64-bit PCI-X | Long 64-bit PCI-X | Planar RAID Enablement | Combination PCIe x8 and Cable Card | PCIe x8 | PCIe x8
Adapter failing function code LED value | 2515 | 2516 | 2505 | 2D0B | 2516 | 2518
Physical links | 8 (two mini SAS 4x connectors) | 8 (two mini SAS 4x connectors) | 81 | 8 (two mini SAS 4x connectors, one required to connect by an external AI cable to the top mini-SAS 4x Cable Card connector) | 8 (two mini SAS 4x connectors) | 8 (two mini SAS 4x connectors)
RAID levels supported | RAID 0,5,6和10 | RAID 0,5,6和10 | RAID 0,5,6和10 | RAID 0, 54, 64, 10 | RAID 0, 54, 64, 10 | RAID 0, 5, 6, 10
Write cache size | No | 175 MB | 175 MB | No | No | 380 MB
Cache battery pack technology | No | LiIon | Not applicable2 | No | No | LiIon
Cache battery pack FFC | No | 2D03 | Not applicable2 | No | No | 2D0E
Cache battery concurrent maintenance | No | No | Not applicable2 | No | No | Yes
Removable cache card | No | Yes | No | No | No | Yes
Auxiliary write cache (AWC) support | No | No | Yes | No | No | No
High availability (HA) two system RAID | Yes3 | Yes | No | No | Yes | Yes
HA two system JBOD | Yes3 | No | No | No | Yes | No
HA single system RAID | Yes3 | Yes | No | No | Yes | Yes
Requires HA RAID configuration | No | Yes | No | No | No | Yes
Minimum Required AIX version | One of the following: .AIX Version 6.1 with Technology Level 0(6100-00 .AIX 5L Version 5.3 with Technology Level 7(5300-07), or later .AIX 5L Version 5.3 with Technology Level 6 and Service Pack4 (5300-06- 04),or later | One of the following: .AIX Version 6.1 with Technology Level 1(6100-01) .AIX 5L Version 5.3 with Technology Level 8(5300- 08),or later | One of the following: .AIX Version 6.1 with Technology Level 0 (6100-00) .AIX 5L Version 5.3 with Technology Level 7(5300-07),or later .AIX 5L Version 5.3 with Technology Level 6 and Service Pack 7(5300-06- 07),or later | One of the following: AIX 5.3 with the 5300-07 Technology Level and Service Pack 9, or later AIX 5.3 with the 5300-08 Technology Level and Service Pack 7, or later AIX 5.3 with the 5300-09 Technology Level and Service Pack 4, or later AIX 5.3 with the 5300-10 Technology Level, or later AIX 6.1 with the 6100-00 Technology Level and Service Pack 9, or later AIX 6.1 with the 6100-01 Technology Level and Service Pack 5, or later AIX 6.1 with the 6100-02 Technology Level and Service Pack 4, or later AIX 6.1 with the 6100-03 Technology Level, or later | One of the following: AIX 5.3 with the 5300-07 Technology Level and Service Pack 9, or later AIX 5.3 with the 5300-08 Technology Level and Service Pack 7, or later AIX 5.3 with the 5300-09 Technology Level and Service Pack 4, or later AIX 5.3 with the 5300-10 Technology Level, or later. AIX 6.1 with the 6100-00 Technology Level and Service Pack 9, or later AIX 6.1 with the 6100-01 Technology Level and Service Pack 5, or later AIX 6.1 with the 6100-02 Technology Level and Service Pack 4, or later AIX 6.1 with the 6100-03 Technology Level, or later | One of the following: AIX 5.3 with the 5300-07 Technology Level and Service Pack 9, or later AIX 5.3 with the 5300-08 Technology Level and Service Pack 7, or later AIX 5.3 with the 5300-09 Technology Level and Service Pack 4, or later AIX 5.3 with the 5300-10 Technology Level, or later AIX 6.1 with the 6100-00 Technology Level and Service Pack 9, or later AIX 6.1 with the 6100-01 Technology Level and Service Pack 5, or later AIX 6.1 with the 6100-02 Technology Level and Service Pack 4, or later AIX 6.1 with the 6100-03 Technology Level, or later

注：

1 一些系统提供了一个从背板集成控制器引出的外部 min SAS 4X连接器。
2 该控制器包含带电池保护的缓存(cache)，但该电池是由57B8控制器通过背板连接来供电。
3 除了part number为44V4266和44V4404（fc # 5900）外，CCIN 572A卡支持Multi-initiator和高可用性(HA)。
4 使用没提供写缓存的SAS RAID控制器来做RAID 5和RAID 6，性能相对不好。建议使用具有写缓存的SAS RAID控制器来做RAID 5和RAID 6。

突出价值点：表格列举了常见的SAS控制卡及SAS RAID控制卡的产品特性，包含Feature code、Physical links、RAID levels supported、Write cache size、Minimum Required AIX version等重要技术指标。

参考资料：

《Power Systems SAS RAID controllers for AIX》

下载地址:

http://publib.boulder.ibm.com/infocenter/powersys/v3r1m5/topic/arebj/arebj.pdf

Top


Power Systems 上Infiniband 产品的支持列表

解答：

Infiniband 是一项互连技术，它通过将传统的共享总线体系结构转换到交换光纤体系结构来打破 PCI 总线的带宽和扇出限制。这是一项将服务器、存储设备和网络设备捆绑在一起的交换光纤 I/O 技术。与 PCI 发送数据所采用的并联方式不同，Infiniband 以串联方式发送数据，并且通过多路复用信号可以同时承载多个通道。

Infiniband Adapter介绍：

F/C 或者 P/N | 描述 | 编号 | 可订购时间 | 停产时间
26K6457 | 1x IB HCA Expansion Card for BladeCenter | N/A | Dec 10, 2004May 26, 2006 | 31-Jan-07
1466(P/N 32R1760) | Cisco IB 4x HCA Expansion Card (StFF) | N/A | 15-Aug-06 | Oct 31. 2008
1802 | GX Dual-port 12x Channel Attach | Roosa 12x | 6-Nov-07 |
1808 | GX++ 12X DDR Adapter, Dual-port |  | 16-Mar-10 |
1809 | GX Dual-port 4x IBM HCA | Roosa 4x w/Chato | 18-Nov-05 |
1810 | GX Dual-port 4x IBM HCA | Roosa 4x | 18-Nov-05 |
1811 | GX Dual-port 4x IBM HCA | Telesto 4x | 14-Oct-05 |
1812 | GX Dual-port 4x IBM HCA | Lambda 4x | 14-Oct-05 |
1820 | PCI-X Dual-port 4x IB HCA | Taylor | 26-May-06 | 23-Jun-06
5266 | GX++ Dual-port 4x Channel Attach |  | 17-Sep-10 |
5608 | Dual Port 12x IB GX Adapter (DDR) | Guardian | 7-Oct-08 | 29-May-09
5609 | GX Dual-port 12x-DDR Channel Attach | Guardian+ | 22-May-09 |
5612 | Dual 2-Port 4X IB HCA | Monk | 8-Apr-08 |
5615 | GX++ Dual-port 12x Channel Attach |  | 17-Sep-10 |
5616 | Dual Port 12X IB GX Adapter (SDR) | Valery | January 29, 2008(same) |
7820 | GX Dual-port 12x IBM HCA | Callisto 12x | 9-Dec-05 |
8256(p/n 32R1760) | 4X Infiniband HCA Expansion Card (StFF) | CISCO | 30-Nov-07 | 11-Jul-08
8258 | 4X Infiniband DDR Expansion Card (CFFh) | Mellanox | 30-Nov-07 |
8297 | Cisco 4X Infiniband DDR Expansion Card (CFFh)Provides FC 8258 + Cisco software key | Mellanox | 30-Nov-07 | 30-May-08
8298 | Voltaire 4X Infiniband DDR Expansion Card (CFFh)Provides FC 8258 + Voltaire software key | Mellanox | 30-Nov-07 |

所支持的服务器列表及支持的Infiniband卡的数量

System |  | Feature Code
 |  | 1808 | 5266 | 5609 | 5615 | 5616
POWER7 | 8231-E2B(710) | n | 1 | n | n | n
 | 8202-E4B(720) | n | n | n | 1 | n
 | 8231-E2B(730) | n | 2 | n | n | n
 | 8205-E6B(740) | n | n | n | 2 | n
 | 8233-E8B(750) | n | n | 1 | n | 1
 | 8236-E8C(755) | n | n | 1 | n | n
 | 9117-MMB(770) | 8 | n | n | n | n
 | 9179-MHB(780) | 8 | n | n | n | n

System |  | Feature Code
 |  | 1802 | 5608 | 5609 | 5612 | 5616 | 8256 | 8258 | 8297 | 8298
POWER6 | 9125 (575) | n | n | n | 2 | n | n | n | n | n
 | 9117 (570) | 82 | n | n | n | n | n | n | n | n
 | 8234 (560) | 33 | n | n | n | n | n | n | n | n
 | 8204 (550) | n | 1w | 1 | n | 2 | n | n | n | n
 | 8203 (520) | n | 1w | 1 | n | 2 | n | n | n | n
 | 7988 (JS22) | n | n | n | n | n | 1w | 1 | 1w | 1
 | 7998 (JS12) | n | n | n | n | n | 1w | 1 | n | 1

System |  | P/N | Feature Code
 |  | 26K6457 | 1466 | 1809 | 1810 | 1811 | 1812 | 1820 | 7820 | 8256
POWER5 | 7988 (JS21) | n | n | n | n | n | n | n | n | 1w
 | 8844 (JS21) | 1w | 1w | n | n | n | n | n | n | n
 | 9115 (505) | n | n | n | n | n | n | 1w | n | n
 | 9110 (510,510Q)
 | 9111 (520) | n | n | n | n | n | n | 2w | n | n
 | 9123 (710)
 | 9131 (52A,520Q) | n | n | n | n | n | 1 | 2w | n | n
 | 9113 (550) | n | n | 1 | n | n | n | 4w | n | n
 | 9133 (55A) | n | n | 1 | n | n | n | 2w | n | n
 | 9124 (720)
 | 9116 (560Q) | n | n | n | 1 | n | n | n | n | n
 | 9117 (570)
 | 9118 (575) | n | n | n | n | 1 | n | n | n | n
 | 9119 (590/595) | n | n | n | n | n | n | n | 4 | n

System |  | Feature Code
 |  | 1820
POWER4 | 7028 (p630) | 1w
 | 7038 (p650) | 1w
 | 7039 (p655) | 1w
 | 7040 (61D) | 1w
 | 7311 (D10/D11/D20) | 1w

注:W. 表示目前为止，这块Infiniband的卡已经停产了
2.Two GX adapters per CEC enclosure
3. One GX adapter per CEC enclosure

Infiniband 交换机

MTM | Description | Announce | Withdrawn | Replacement
7874-024 | 1U, 24-port 4x DDR IB Edge Switch (QLogic 9024CU) | 2008-11-11 |  |
7874-040 | 4U, 48-port 4x DDR IB Director Switch (QLogic 9040) | 2008-11-11 |  |
7874-120 | 7U, 120-port 4x DDR IB Director Switch (QLogic 9120) | 2008-11-11 |  |
7874-240 | 14U, 240-port 4x DDR IB Director Switch (QLogic 9240) | 2008-11-11 |  |
p/n 26K6454 | Topspin IB Switch Module for BladeCenter | 2004-12-10 |  |
p/n 43W4419 | 4X InfiniBand Pass-thru Module | 2007-10-27 |  |
p/n 32R1756 | Cisco Systems 4X InfiniBand Switch Module | 2006-08-11 |  |
7048-120 | 1U, 24-port 4x | 2005-10-14 | 2006-6-23 | Cisco SFS 7000P
7048-270 | 6U, 32-port 12x or 96-port 4x | 2005-10-14 | 2006-6-23 | Cisco SFS 7008P

突出价值点：IBM早在2004年1月就开始把Infiniband技术应用于其解决方案，是最早应用该技术的厂商之一。与早期PCI 总线和其它各厂商专有的交换网络及I/O 解决方案相比，Infiniband 更具有提供RAS （可靠性、可用性、可服务性）的能力。

Top


什么是Power服务器的Storage Key

解答：

Storage key是 POWER6 和POWER7处理器增加的一项内存保护功能，系统内存可以按照区域分配不同的 Key，通过硬件提供支持来保证只有持有正确的 Key 的代码可以修改其内容。该技术可以应用在 AIX 内核或者用户应用程序代码中，防止由于代码的错误行为（无论是有意还是无意）而可以任意破坏其它内存区域，因此可以进一步提高系统的稳定性。

POWER6有8个Storage Key，其中2个是用户/应用级的，6个是内核级的；POWER7有32个Storage Key，其中8个是用户/应用级的，24个是内核级的。相比POWER6的Storage Key，POWER7 Storage Key的数据隔离颗粒度更细。

突出价值点：Storage Key提升了系统的稳定性。相比POWER6的Storage Key，POWER7 Storage Key的数据隔离颗粒度更细。

Top


POWER服务器处理器能否升级，以及升级后支持的数量

解答：

POWER6服务器的处理器升级情况如下：

 | JS12 | JS22 | JS23 | JS43 | Power 520 | Power 550 | Power 560 | Power 570 | Power 575 | Power 595
处理器可否升级 | 不可以 | 不可以 | 可以** | 不可以 | 不可以 | 可以 | 可以 | 可以 | 不可以 | 可以
最大Core数 | 2 | 4 | 4 | 8 | 4 | 8 | 16 | 16/32* | 32 | 64
处理器可否混插 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以

* 16-Core配置使用2-Core/Processor Card 处理器板，32-Core配置使用4-Core/Processor Card处理器板。
**JS23的处理器也是固化在主板上的，但可以通过增加一个fc#8446(1-Wide Add-on SMP Chassis)来升级为JS43，从而处理器由4路变为8路。

POWER7服务器的处理器升级情况如下：

 | PS700 | PS701 | PS702 | Power 710 | Power 720 | Power 730 | Power 740 | Power 750 | Power 755 | Power 770 | Power 780
处理器可否升级 | 不可以 | 可以* | 不可以 | 不可以 | 不可以 | 不可以 | 可以*** | 可以 | 不可以 | 可以 | 可以
最大Core数 | 4 | 8 | 16 | 8 | 8 | 16 | 16 | 32 | 32 | 64** | 64
处理器可否混插 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以 | 不可以

* PS701通过添加#8358 1-Wide Add-on SMP Chassis后，即升级为PS702，CPU扩展到16Core，但会同时占用两个刀片槽位。
**Power 770最大可支持到64Core（4*16Core），但16Core CPU板在中国不销售，在中国最大支持48 Core（4*12Core）。
***Power 740可以支持处理器的升级，但是在做MES的时候，不可以修改处理器的主频，只能添加处理器板的数量。

突出价值点：通过处理器的升级，如果初始配置的处理器不为满配，可以通过MES的方式，升级处理器数量，以满足客户需求，提高系统的处理能力。


POWER6 产品支持的操作系统

解答：

AIX

IBM i

Linux

JS12

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 SP4, or later
AIX V5.3 TL08, or later
AIX V6.1 TL01, or later (Available 6/10/08)
AIX V6.1 TL00 SP5, or later

IBM i 6.1 (formerly known as i5/OS V6R1), or later

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux V4.6 for POWER, or later
Red Hat Linux V5.1 for POWER, or later

JS22

AIX V5.3 TL06 SP4, or later
AIX V5.3 TL07, or later
AIX V6.1 TL00, or later

IBM i 6.1, or later

SUSE Linux 10 for POWER SP1 Update 1, or later
Red Hat Linux for POWER, V4.6, or later
Red Hat Linux for POWER, V5.1, or later

JS23
JS43

AIX V5.3 TL07 SP9, or later
AIX V5.3 TL08 SP7, or later
AIX V5.3 TL09 SP4, or later
AIX V5.3 TL10, or later
AIX V6.1 TL03, or later
AIX V6.1 TL02 SP4, or later
AIX V6.1 TL01 SP5, or later
AIX V6.1 TL00 SP9, or later

同上

SUSE Linux 10 SP2 for POWER Systems, or later
SUSE Linux 11 for POWER Systems, or later
Red Hat Linux 4.6 for POWER
Red Hat Linux 4.7 for POWER, or later
Red Hat Linux 5.1 for POWER
Red Hat Linux 5.2 for POWER
Red Hat Linux 5.3 for POWER, or later

Power 520

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 or later
AIX V6.1, or later

IBM i 5.4 with V5R4M5 machine code, or later
IBM i 6.1, or later

SUSE Linux 10 SP1 for POWER Systems, or later
Red Hat Linux 4.5 for POWER, or later
Red Hat Linux 5.1 for POWER, or later

Power 550

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 or later
AIX V5.3 TL06 SP4, or later
AIX V6.1, or later

同上

同上

Power 560

AIX V5.3 TL06 SP10, or later
AIX V5.3 TL07 SP7, or later
AIX V5.3 TL08 SP5, or later
AIX V5.3 TL09, or later
AIX V6.1 TL00 SP7, or later
AIX V6.1 TL01 SP3, or later
AIX V6.1 TL02 or later

IBM i 6.1, or later

同上

Power 570

For configurations with POWER6 processors (#5620, 5621, 5622, 7380):
AIX V5.2 TL10, or later
AIX V5.3 with TL06, or later
AIX V6.1, or later

For configurations with POWER6 processors (#7387, 7388, 7540):
AIX V5.3 TL06 SP10, or later
AIX V5.3 TL07 SP7, or later
AIX V5.3 TL08 SP5, or later
AIX V5.3 TL09 or later
AIX V6.1 TL00 SP7, or later
AIX V6.1 TL01 SP3, or later
AIX V6.1 TL02 or later

IBM i 5.4.5, or later
IBM i 6.1, or later

同上

Power 575

AIX V5.3 TL08, or later
AIX V6.1 TL02 SP1, or later

不支持

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux 4.6 for POWER, or later
Red Hat Linux 5.2 for POWER, or later

Power 595

AIX V5.3 TL06 SP7, or later
AIX V5.3 TL07 SP4, or later
AIX V5.3 TL08, or later
AIX V6.1 TL00 SP5, or later
AIX V6.1 TL01, or later

IBM i 5.4 (formerly known as i5/OS V5R4), or later
IBM i 6.1 (formerly known as i5/OS V6R1), or later

SUSE Linux 10 SP2 for POWER, or later
Red Hat Linux 4.7 for POWER, or later
Red Hat Linux 5.2 for POWER, or later

注：具体到每个机型，对每个操作系统的版本的小版本要求，请参见该机型的Sales Manual的Technical Description下面的Software Requirements部分。

Power 产品销售手册查询

Top


POWER7 产品支持的操作系统

解答：

POWER7 | AIX | IBM i | Linux | VIOS
PS700/PS701/PS702 | AIX V5.3 TL12, or later AIX V5.3 TL10 SP5 AIX V5.3 TL11 SP5 AIX V6.1 TL06 , or later, AIX V6.1 TL05 SP3, or later AIX V6.1 TL04 SP7, or later AIX V6.1 TL03 SP7, or later AIX V7.1 | IIBM i 6.1 with i 6.1.1 machine code, or later IBM i 7.1, or later. | SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.3.0, or later.
Power 710/720/730/740 | AIX V7.1, or later AIX V6.1 TL06, or later AIX V6.1 TL05 SP 3, or later AIX V6.1 TL04 SP 7, or later AIX V6.1 TL03 SP 7, or later AIX V5.3 TL12 SP 1, or later AIX V5.3 TL11 SP 5, or later AIX V5.3 TL10 SP 5, or later | IBM i 6.1 with i 6.1.1 machine code, or later IBM i 7.1, or later. | SUSE Linux Enterprise Server 11 SP1, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.2. or later.
Power 750 | AIX V6.1 TL04 SP2, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | IBM i 6.1 with i 6.1.1 machine code, or later. | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.11 with Fix Pack 22.1 and SP1, or later.
Power 755 | AIX V6.1 TL04 SP2, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | - | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.11 with Fix Pack 22.1 and SP1, or later.
Power 770/780 | AIX V6.1 TL04 SP3, or later； AIX V6.1 TL03 SP5, or later； AIX V6.1 TL02 SP8, or later； AIX V5.3 TL11 SP2, or later； AIX V5.3 TL10 SP4, or later； AIX V5.3 TL09 SP7, or later. | IBM i 6.1, or later. | SUSE Linux Enterprise Server 11, or later； SUSE Linux Enterprise Server 10 SP3, or later； Red Hat Enterprise Linux Version 5.5 for POWER, or later. | VIOS 2.1.2.12 with Fix Pack 22.1 and SP2, or later.

注：具体到每个机型，对每个操作系统的版本的小版本要求，请参见该机型的Sales Manual的Technical Description下面的Software Requirements部分。

Power 产品销售手册查询

Top


AIX V6.1支持的硬件环境

解答：

AIX V6.1 支持如下系统：

1.运行在POWER4, Power PC970, POWER5, POWER6 或者POWER7 处理器上的IBM Power系统，包括IBM System p, System p5, IBM eServer p5, System i, 和system i5 servers with POWER5 or POWER6/POWER7 processors

2.基于POWER4 和POWER5处理器的IBM eServer pSeries服务器产品线

3.IBM 刀片JS2x Blades 和IntelliStation power 工作站

AIX V6.1 只支持64位的内核。32位和64位的应用在AIX V6.1上可以不用更改，但是32位的设备驱动和内核的延伸在AIX V6.1 上是不支持的。

突出价值点：相比AIX 5.3及其以前版本，AIX V6.1支持工作负载分区(Workload Partition, WPar)。通过 WPAR 可以实现新一级别的 AIX 虚拟化功能，它补充现有的虚拟化功能的不足，实现了应用程序对于资源的更好的使用。


AIX V7.1支持的硬件环境

解答：

AIX 7 可以在基于PPC970、POWER4、POWER5、POWER6和新一代POWER7的系统上运行。

AIX 7 的大多数新特性都可在基于早期 POWER 处理器的平台上使用，但是在基于 POWER6 和 POWER7 处理器构建的系统上才能实现最高的性能。

突出价值点：AIX 7既可以运行在POWER7服务器上，也可运行在以前的PPC970、POWER4、POWER5、POWER6服务器上，这有利于保护客户的投资。


AIX EE 6.1版本包含哪些软件

解答：

AIX 6.1EE(AIX Enterprise Edition V6.1.1)是企业版，包含如下几种软件：

*AIX Standard Edition Version 6 TL4
*PowerVM Workload Partitions Manager V2.1
*Systems Director Enterprise Edition

其中关于System Director Enterprise Edition所包含的软件，可以查看:《IBM Systems Director系统软件各个版本包含哪些软件》

突出价值点：AIX 6.1 EE中增加了System Director Enterprise Edition，不但为客户提供管理的便利性，还方便了用户订购，节约了软件成本。


什么是AIX Express Edition? 该版本有何要求？

解答：

AIX Express Edition（易捷版）为较小的工作负载提供了一种更低价的AIX License和SWMA选择。其目标用户为低端Power服务器和刀片Power服务器。在一台大的企业级Power服务器上整合很多的小工作负载的场景，这也是个很好的选择。

AIX 6 以及更高版本提供AIX Express Edition。AIX 5.3以及更早版不提供这个版本。

该版本要求运行其的Power服务器上的每LPAR不能超过4核(core)，并且，每核最多8 GB内存。


AIX V7.1支持的几个新功能

解答：

AIX 7扩展了AIX操作系统的功能，将AIX的垂直可扩展性增强为带256个处理器内核和1024个线程的分区,以便处理最大型的工作负载。

AIX 7支持新的TB级段，能为大型工作负载提供更高的性能，可以充分利用旨在提高内存性能的POWER7处理器的内存管理功能。

AIX 7支持新的虚拟化功能，可以简化先前的AIX V5.2 环境的整合。此新功能需要采购“AIX 5.2 Workload Partitions for AIX 7”产品，旨在允许管理员简便地备份运行 AIX 5.2 的现有 LPAR，并将其还原至 AIX 7 工作负载分区。

AIX 7支持新的称为Cluster Aware AIX的内置群集功能。此新技术在 AIX 基础操作系统中构建了群集技术。此内置群集支持提供了命令和编程 API 来通过 AIX 实例组创建群集，另外还提供了基于内核的检测信号、监控和事件基础架构。此新基础架构支持群集内的存储设备通用设备命名。虽然Cluster Aware AIX功能主要用于为 PowerHA SystemMirror 和 PowerVM等产品提供可靠而又可扩展的群集基础架构，客户也可以直接使用Cluster Aware AIX功能来促进横向扩展计算环境的管理。

AIX 7支持新的可以改善和简化安全性管理的安全性功能。例如，基于角色的访问控制中的新的域支持是对基于角色的访问控制 （RBAC） 的增强，允许制定安全策略来限制对特定类似资源集合（如可用网络适配器的子集）的管理访问。可以使用域来控制对卷组、文件系统、文件和设备的访问。

AIX 7支持AIX Profile Manager等新的易管理性增强特性。AIX Profile Manager 可以通过 XML 配置文件管理 AIX 的配置。此功能基于 AIX 6.1 TL4 引入的 Runtime Expert 功能而构建。这一新的管理功能可以通过IBM Systems Director 界面进行管理和操作。

突出价值点：最新版本 AIX 7.1在虚拟化、安全特性、可用性和管理性方面提供重要的新功能。


IBM AIX 5.2 Workload Partitions for AIX 7支持的环境

解答：

AIX 5.2 Workload Partitions for AIX 7，旨在允许管理员简便地备份运行 AIX 5.2 的现有 LPAR，并将其还原至 AIX 7 工作负载分区。

该功能支持的硬件平台：

POWER7的服务器。

该功能支持的软件平台：

支持的操作系统为：AIX V7.1及以上的版本；

支持的AIX5.2 的具体版本要求：AIX 5200-10 SP8.只有这一个版本支持该功能。

突出价值点：AIX 5.2 Workload Partitions for AIX 7 是在 AIX 7.1 for POWER7 服务器上支持的一个新产品。AIX 7 允许创建一种特殊的 WPAR，为 WPAR 中运行的工作负载提供 AIX V5.2 TL10 SP8 运行时环境。可以把在老式硬件上运行的 AIX V5.2 工作负载简便地迁移到 POWER7 硬件上。


AIX V7.1 标准版，企业版，易捷版的区别

解答：

AIX 7.1支持的3个版本的区别如下：

AIX 7.1 易捷版：每个分区支持最大4C，每C支持最大8GB内存。

AIX 7.1 标准版：支持最大256C，1024线程。

AIX 7.1 企业版：包括AIX 7.1标准版的功能；增加了企业级的管理功能：Systems Director Enterprise Edition和PowerVM Workload Partitions Manager。


AIX 分为 Express, Standard, Enterprice版本，请问这三个版本拿到的光盘是否相同？如果不同，有什么区别？

解答：

这三个版本的AIX光盘是完全相同的。

版本的设定可以通过下列方式来设定：

- 安装阶段 (光盘安装时会提示，NIM安装可以在bosinst.data中指定)；
- 安装后可以随时通过chedition。

详见AIX Releases Notes :
http://publib.boulder.ibm.com/infocenter/aix/v6r1/topic/com.ibm.aix.ntl/RELNOTES/SC23-6629-07_pdf.pdf


简单介绍GLVM功能；GLVM是否可以通过TCPIP实现远程数据复制功能？是否需要单独购买

解答：

现在AIX已经自带GLVM功能，不需要单独购买，GLVM可通过标准的TCP/IP网络实现跨站点的实时数据镜像功能。它提供了与HACMP/XD中GLVM相同的跨站点数据镜像功能，只是没有PowerHA提供的自动监测和恢复的功能。 GLVM可以帮助用户实现跨站点的数据实时镜像，但并不要求像PowerHA一样实现对灾难的自动检测，并自动迁移关键应用到灾备站点的功能。

如需GLVM更详细的技术资料请参考GLVM白皮书：

http://www-03.ibm.com/systems/resources/systems_p_os_aix_whitepapers_pdf_aix_glvm.pdf

突出价值点：用户可以在不增加任何成本的基础上，通过GLVM实现远程数据镜像的功能。


什么是NIM？它的应用场景以及基本概念介绍

解答：

Network Installation Management (NIM)，就是通过网络进行操作系统和软件安装的管理方法。

随着机房内的服务器逐渐增多，分区服务器越来越多的使用， 如何在各服务器或分区上快速安装操作系统和系统软件，使机房内的服务器保持特定版本的操作系统，显得越来越重要。使用NIM不仅能安装和维护AIX操作系统，还能维护和安装其他的软件、补丁。NIM也允许在安装过程中和安装完成后客户化的配置服务器。使用NIM环境可以减少对物理介质的使用，如磁带和光盘，在NIM中这些设备是服务器的资源。也可以使用NIM对服务器进行系统备份，并将其存在NIM环境中的服务器上。在需要时，再使用NIM将备份恢复到同一台服务器上(分区)或其他服务器上(分区)。

NIM环境是由NIM服务器和NIM客户端构成，NIM服务器提供资源(如用于安装的文件和程序)，接受服务器提供资源的称为NIM客户端。 在NIM中，客户端的操作需要使用NIM资源，这些资源实体是由文件和目录构成的。AIX中NIM客户端是通过NFS来访问资源。


NIM中常见的资源类型以及各自的特点介绍

解答：

NIM中常用的resources类型有lpp_source、SPOT和mksysb。

一. lpp_source:

1.指向一个目录, 其内容等同于AIX 的系统光盘或应用程序的安装光盘。
2.包含了需要进行安装的lpp文件, 可以是bff格式 ,也可是rpm格式。

二. SPOT(Shared Product Object Tree):

1.指向一个目录, 其中存放了安装系统的命令(用于将LPP_source中的安装映像安装到服务器上)和用于引导NIM客户机所必需的系统引导映像。(与 /usr 文件系统的内容相同)。
2.包含: 设备驱动程序, BOS的安装程序, 其它与安装相关的代码。

三. mksysb:

1.指向一个文件. rootvg的备份文件, 用于恢复或克隆系统。


一个典型的NIM安装过程介绍

解答：

下面以客户机上没有操作系统为例，简要介绍一下怎样通过NIM安装基本操作系统。(请确认master上已经安装了bos.sysmgt.nim.master和bos.sysmgt.nim.spot)。

在master机器上执行以下步骤:

1.配置NIM master
#smitty nim --> Configure the NIM Environment --> Advanced Configuration --> Initialize the NIM Master Only

在此窗口中为该NIM 网络起个名字, 并且给出相应网络接口名。

2.定义lpp_source
Smitty nim --> Perform NIM Administration Tasks --> Manage Resources --> Define a Resource --> lpp_source

给lpp_source 资源一个名字, 该资源存放在哪台服务器上, 存放到哪个目录下, 如果有安装介质,则指明路径。

3.定义SPOT资源 (使用刚才定义的lpp_source 资源来生成 SPOT 资源)
Smitty nim --> Perform NIM Administration Tasks --> Manage Resources --> Define a Resource --> spot

给出SPOT资源的名字, 存放服务器的名字,SPOT 资源存放的目录名, 在 Source of Install images 中给出所要使用的lpp_source 名字, 给出相关信息后, 回车, SPOT就会从lpp_source中读取所需的内容, 并将结果存放到指定的目录中, 其过程与为系统安装软件类似(会有一段时间)。

4.在master上定义NIM client
Smitty nim --> Perform NIM Administration Tasks --> Manage Machince --> Define a Machine

给出NIM client 的名字, 为 communication protocol used by client 选择 nimsh 然后回车, NIM client 的设置就完成了。

5.为 nim client 系统安装做准备
Smitty nim --> Perform NIM Software Installation and Maintenance Tasks --> install and update software --> Install the Base Operating System on Stankalone Clients --> 选择client --> rte --> 选择前面定义过的 lpp_source 和 SPOT 资源 名称。

将 initiate reboot 设为 no, 回车, NIM master 为nim client 就做好了安装准备。

在client机器上执行以下步骤:

6.引导 NIM Client
开启nim client 服务器或分区, 进入 SMS 菜单, 选择 Setup Remote IPL。

7.选择与NIM master 通讯的网卡。

8.设置NIM master 和 NIM client 的IP 地址,网关和子网掩码, 回上层菜单，做与NIM master连通测试。

9.通过网络引导系统
SMS --> boot option --> Select Install/Boot Device --> network --> Normal Mode Boot

系统就会从NIM master 上获得 bootp 映像, 接下来就进入BOS的安装过程。

Top


在一些Power机型中，支持内置RAID卡。在AIX 操作系统中，也可以使用LVM的mirror功能提供磁盘冗余保护。这两种磁盘冗余保护方式在性能和可用性上有何区别？

解答：

Power 550/520/750等机型都可以配置内置RAID卡，如fc#5679。使用这些RAID卡可以实现RAID 0/5/6/10。好处是不依赖于CPU，内存等系统资源。同时，通过其上的175MB 写Cache，对I/O性能有所增强。缺点是所有RAID成员盘都需要连接到相同的RAID卡上，RAID卡容易成为单点。解决该单点故障的办法是使用fc#5903/5902/5805这样成对使用的双卡。但是fc#5903/5902/5805不支持Power 550/520/750 CEC内的磁盘，支持Power 560/570 CEC/5886/5802/5803等扩展抽屉内的磁盘。

使用LVM的mirror和stripe功能也可以实现软的RAID 0/1/10。好处是不依赖于硬件RAID卡。而且可以通过将pv分布在不同磁盘链路上来消除单点故障。缺点是需要消耗CPU和内存的一些资源来支持。

性能方面，硬件RAID卡的Cache大小和磁盘数量对I/O都有较大影响。 普通RAID卡Cache 不大，容易成为I/O瓶颈，这也是外置SAN存储大量被采用的原因之一。对于内置RAID有高性能要求的情况，建议配fc#5908/5904有1.5GB写Cache和1.6GB读Cache。

如果使用LVM实现mirror, 一般可以满足操作系统的I/O访问需求。对于I/O要求较高的数据访问，如果采用LVM stripe+mirror，一般需要更多的磁盘链路和磁盘来优化I/O性能。

突出价值点：多种可选的数据冗余和性能优化方案，供用户的各种应用环境提供不同选择。

Top


Power服务器的电源和耗电量计算方法

解答：

POWER6, POWER7和P5服务器的电源计算是通过不同的方法进行计算的：

POWER6, POWER7服务器的计算方式参考如下的网页：
http://www-912.ibm.com/see/EnergyEstimator

注意，在每次进入计算工具之前，需要接受一个使用该计算工具的许可，您可以在看完该许可以后，点击“I accept”即可。

然后选择国家(Country/Region),语言(Language),数字格式(Number Formatting)，用户类型(User Type)；点击继续(Continue);选择需要计算的产品型号，相应的产品的处理器主频和对应的处理器数量的范围，进入以后，在详细设定处理器数量，内存，硬盘，PCI槽位，扩展等机型的具体信息，进行计算。

也可以导入e-config导出的XML文件或者SPT工具导出的sysplan文件。然后选择“restore”，可以还原导入文件的配置，并计算出相应配置的服务器的功率和散热量。该功能为Energy Estimate工具2010年9月更新的新功能。

P5服务器的计算方式参考如下的网页：
http://publib.boulder.ibm.com/infocenter/systems/scope/hw/topic/iphdl_p5/powerloadcalc.htm

选择需要计算功率的机型，在每次进入计算工具之前，需要接受一个使用该计算工具的许可，您可以在看完该许可以后，点击“I Accept”即可，然后和POWER6的计算方法类似，需要选择处理器数量和主频，内存，硬盘，PCI卡，DVD，磁带机等信息，进行计算。

参考网页：
http://publib.boulder.ibm.com/infocenter/systems/scope/hw/index.jsp?topic=/iphdl_p5/systemcalculators.htm&resulto f=%22%73%79%73%74%65%6d%22%20%22%63%61%6c%63%75%6c%61%74%6f%72%22%20&searchQuery=%73%79%73%74%65%6d%20%63%61%6c%63%75 %6c%61%74%6f%72&searchRank=%30&pageDepth=%30

突出价值点：Sales Manual给出的是最大功率。您可以使用以上所述工具估算实际配置下的功率，同时还可以通过导入e-config工具和SPT工具导出的相关格式的文件，直接计算出服务器的具体功耗等信息。
基于IBM POWER6,POWER7处理器的服务器内置了EnergyScale能源管理技术，该技术提供了一系列的功能来监视以及节省基于IBM POWER6,POWER7处理器的服务器的能源消耗。


Power系列机型上共有多少种SAS连接线, 它们有什么不同

解答：

Power系列机型上共有11种SAS连接线,我们来分别介绍它们的功用:

(1)Power 520/550上连接磁盘背板到后机箱的SAS连接线, Power 520上是fc#3674,Power 550上是fc#3668, 当磁盘背板的外部SAS接口用来连接外置的磁盘柜fc#5886时要用到这种SAS线.

(2)Power 520/550上磁盘背板分离时连接背板到后机箱的SAS连接线,以提供对另外三块磁盘的访问,520上是fc#3670, 550上是fc#3669.

(3)AI线, Feature Code是fc#3679,用在Power 520/550上时,连接SAS卡到机箱接口,与fc#3669(Power 550)或fc#3670(Power 520)一起使用以提供对磁盘背板的分离功能;用在Power 560/570上时,可以与fc#5909/fc#5911一起使用以提供对CEC上磁盘背板的分离功能,也可以与fc#3650/fc#3651一起使用,提供对CEC上磁盘背板的分离功能.

(4)AE线,用来连接SAS卡和Media扩展柜(如7214-1U2).

(5)AT线,用在PCIe 12X的I/O扩展柜上以连接SAS卡和扩展柜上的磁盘.

(6)EE线,用来连接两个磁盘扩展柜(fc#5886)的堆叠,注意,最多只能堆叠一层.

(7)YO线,连接SAS卡和磁盘扩展柜(fc#5886).

(8)YI线,用在Power 520/550上,用于磁盘背板的外部SAS接口与磁盘扩展柜(fc#5886)的连接,需要与fc#3674(Power 520)或fc#3668(Power 550)一起使用.

(9)X线, 连接一对SAS RAID卡与磁盘扩展柜(fc#5886)以提供磁盘RAID功能.

(10)YR线,用在Power 560/570上,连接一对SAS RAID卡与CEC上的磁盘以提供RAID功能,需要与Cable Card(fc#3651)一起使用.

(11)AA线，Adapter to Adapter SAS Cable,当用两块5904/5906/5908做RAID 5或RAID 6时，用于连接该两块SAS卡.

突出价值点：IBM产品成功实现了从SCSI到SAS的转变。SAS连接线有不同种类和长度，客户可以根据不同需求进行相应选择。

Top


FCoE支持的操作系统

解答：

目前，有如下几个编号的FCoE卡：fc#8275，fc#5708,fc#5270。

对于POWER6 服务器上所使用的FCoE卡：fc#8275，fc#5708，其支持的操作系统如下:

VIOS V2.1.2.0;
AIX 5.3 with the 5300-11 Technology Level, 及以上版本;
AIX 6.1 with the 6100-04 Technology Level, 及以上版本;
SUSE Linux Enterprise Server 10 Service Pack 3, 及以上版本;
Red Hat Enterprise Linux 5.4, 及以上版本;
IBM i 6.1 for NIC through VIOS (not directly supported).

对于POWER7服务器上FCoE卡（fc#8275，fc#5708,fc#5270）所支持的操作系统，可以直接参考POWER7服务器所支持的的操作系统的兼容信息。
http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=1611200J08000

突出价值点：目前Power 520/550/560/570/575/595/750/755/770/780上支持的FCoE卡是fc#5708；JS和PS刀片上支持的FCoE卡是fc#8275；Power 710/730上支持的FCoE卡是fc#5270（Low-Profile PCIe）；Power720/740上支持的FCoE卡是fc#5708和fc#5270。


为什么选择FCoE/FCoEE

解答：

选择FCoE/FCoEE的理由如下：

1.可以节省PCI插槽，一个FCoE卡可以替代一个以太网卡加一个光纤卡。

2.相应节省插槽，可以减少 I/O 抽屉的使用。

3.由于FCoE交换机替代了光纤交换机和以太网交换机，而且 I/O 抽屉减少，因此节省了机柜的使用空间。

4.由于更少的卡和 I/O 抽屉的使用，因此节省了电力和制冷的消耗。

5.使用以太网线替代了原有光纤加以太网线，因此配线更简单。

6.很好的适应性，可以随着时间的推移，在现有硬件的基础上很容易地调整到符合客户的需求。

突出价值点：FCoE能减少数据中心的接口卡、电缆和网络设备，从而使数据中心变得比较简单、绿色环保。在一些大公司，如果能减少电缆数量，将会对空气流动产生积极作用，并减少降温成本。


什么是IBM Systems Director Active Energy Manager

解答：

IBM Systems Director Active Energy Manager目前版本为V4.2, 是IBM Systems Director软件中的插件，是能耗监测管理工具。

对于支持AEM的Power服务器，它既可以对当前能耗和散热情况进行检测，也可以记录和分析能耗和散热历史数据。

对于其他服务器和设备，可以通过智能PDU来监测。

与基于POWER6处理器的EnergyScale技术相结合,可以实现能耗限制和自动降低能耗等控制功能。

其监测功能的使用授权是免费的。

IBM Systems Director Active Energy Manager 可以在IT架构中，通过支持的Power服务器提供平台监控和能耗使用报告。Systems Director Active Energy Manager 通过数据中心控制支持的Power服务器的能耗来提高能量的使用效率，对我们的客户来说，可以真正的节省和降低花费。此解决方案是IBM智慧的地球之动态架构的能源解决方案的组成部分。

IBM Systems Director Active Energy Manager 可以帮助客户通过数据中心更好地了解能耗的使用情况:

*确定能耗的使用；
*精确地测定散热的成本；
*监控IT花费；
*由部门和/或用户进行管理。

突出价值点：IBM POWER6 EnergyScale技术与IBM Systems Director能源管理器(Active Energy Manager, 以下简称AEM)是IBM绿色创新计划的重要基础。基于IBM POWER6处理器的服务器内置了EnergyScale能源管理技术来监控以及节省能源消耗，而AEM作为一个集成的能源管理平台，能够处理和显示EnergyScale收集的数据，调用EnergyScale的相关能源管理功能。


IBM Systems Director 系统软件各个版本包含哪些软件

解答:

IBM新推出的Systems Director系统软件包含三个版本，Systems Director Enterprise Edition，Systems Director Standard Edition和Systems Director Express Edition。下面单独列出了每个版本所包含的相关软件：

Systems Director Enterprise Edition 包括：
* Systems Director Standard Edition 所有功能
* Systems Director VMControl(TM) Enterprise Edition for Power, V2.2
* Tivoli Monitoring (ITM)
* Tivoli Monitoring for Energy Management
* Tivoli Application Discovery and Dependency Manager (TADDM)
* Systems Director Enterprise Edition Installation Launchpad

Systems Director Standard Edition 包括：
* Systems Director Express Edition 所有功能
* Systems Director Active Energy Manager V4.2
* Systems Director VMControl(TM) Standard Edition for Power, V2.2
* Systems Director Network Control V1.1

Systems Director Express Edition 包括：
* Systems Director V6.1
* Systems Director VMControl(TM) Express Edition for Power, V2.2
* Systems Director Service and Support Manager V6.1.2
* Systems Director Transition Manager for HP Systems Insight Manager V6.1


IBM System Director 系统软件有何功能？其三个版本的功能有何区别？

解答:

Systems Director是一套系统管理软件，包括Express, Standard, Enterprise三个版本，下面是三个版本的功能列表。

Systems Director Express版本，包括了一套管理工具，通过提供清晰的IT系统组件的关系图和运行状态，从而降低系统操作复杂度。

其功能包括：

* 提供对物理服务器、虚拟服务器以及存储资源的自动发现和拓扑视图；
* 对运行于Power服务器之上的AIX, IBM i, 和Linux提供虚拟化管理；
* 简化部署、安装和更新步骤；
* 对所监控的系统提供自动报告硬件故障，收集系统服务信息的功能；
* 提供符合行业标准的，对AIX和IBM i的单一系统、平台级别管理功能；
* 通过Launch-in-context功能与HMC集成；
* 通过向导、教程和帮助功能，简单易学。

Systems Director Standard 版本，能够降低部署工作负载时间，从而提高效率，并且还能优化电量的使用。

其功能包括：

* System Director Express版本的所有功能；
* 抓取、导入，创建、删除标准的虚拟镜像；
* 部署标准虚拟镜像；
* 在中心库里面维护虚拟镜像；
* 监控电量的使用，分析电力和散热的趋势；
* 通过支持的工具设备，例如UPS、PDU，感应器，以及机房空调设备单元提供的监控应用等，来实现对旧有系统设备的监控；
* 提供对服务器的电力使用限制(cap)功能；
* 节能模式，会根据处理器的使用率和数据中心设备的海拔高度来进一步优化；
* 对网络设备的发现和状态监控功能。

Systems Director Enterprise 版本，提供高级的性能和可用性管理，为Dynamic Infrastructure提供自动的资源平衡机制。

其功能包括：

* System Director Standard 版本的所有功能；
* 创建、删除系统池，对系统池内的一个服务器上的资源进行管理；
* 在系统池内添加、删除物理服务器；
* Workload Partition (WPAR)的创建和管理；
* LPAR对服务器，对应用的关系的虚拟化；
* 对虚拟环境进行实时的、乃至预告式的监控；
* 对性能管理和容量评估进行预告。

突出价值点：Systems Director为数据中心不同的服务器和存储设备提供了一个统一的、集成的管理界面，大大简化了系统管理，提高系统管理效率，并为云计算提供了切实可行的管理工具。

Top


5765-SEP IBM Systems Director Standard Edition for Power Systems软件和5765-DRP IBM(R) Systems Director for Power Systems的区别是什么

解答：

IBM Systems Director for Power Systems V6.1，即5765-DRP，仅包含Systems Director的license，它和Director其它可用的插件是分开的。
IBM Systems Director Editions for Power V6是一个重新打包和重新定价的Systems Director及其插件的组合。与IBM其它系统软件一样，Systems Director包括易捷版、标准版和企业版，更高的版本包含更多的功能。Systems Director的基本功能包含于任一Systems Director版本当中。

Products | Express | Standard | Enterprise
IBM Systems Director V6.2 | √ | √ | √
IBM Systems Director Transition Manager for HP Systems Insight Manager V6.2 | √ | √ | √
IBM Systems Director Service and Support Manager V6.2 | √ | √ | √
IBM Systems Director VMControl V2.3
VMControl Express Edition | √ | √ | √
VMControl Standard Edition |  | √ | √
VMControl Enterprise Edition |  |  | √
IBM Systems Director Active Energy Manager V4.3
Monitoring |  | √ | √
Management |  | √ | √
IBM Systems Director Network Control V1.2 |  | √ | √
IBM Tivoli Monitoring V6.2.2 Fix Pack 2 |  |  | √
IBM Tivoli Application Dependency Discovery Manager V7.2 |  |  | √
IBM Tivoli Common Reporting for Asset and Performance Management V1.3 |  |  | √
IBM Tivoli Monitoring for Energy Management Reporting and Optimization V6.2.1 |  |  | √

突出价值点：通过重新打包和重新定价，IBM整合了Systems Director软件，并提供了3个版本供客户选择。

Top


5765-AME软件的功能，以及其相应的替代产品

解答：

IBM软件产品AIX Management Edition 5765-AME已于2010/08/17正式停产，此软件功能可被Director Enterprise Edition (5765-EEP)软件替代。

详见此Announcement letter：
http://www-01.ibm.com/common/ssi/ShowDoc.jsp?docURL=/common/ssi/rep_ca/0/877/ENUSZP10-0070/index.html&breadCrum=DET001PT022&url=buttonpressed=DET002PT005&specific_index=DET001PEF502&DET015PGL002=DET001PEF011&submit.x=7&submit.y=8&lang=en_US

AIX Management Edition主要具备以下功能：

监控和管理P系列服务器的关键IT服务和资源；

增进了解P系列服务器的配置和客户应用程序及业务服务之间的关系；

P系列服务器的数据收集和使用情况报告。

突出价值点：IBM System Director Enterprise Edition (5765-EEP)具备完善的系统管理功能，建议客户选择。


目录 产品配置常见问题汇总

目录

IBM Power Systems 常见配置问题汇总

刀片服务器

BladeCenter H机箱中10个I/O插槽的配置规则 (最近更新)

7989-BCH机箱怎样配置冗余的电源以及电源线？ (最近更新)

BladeCenter S电源配置问题

BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项 (最近更新)

当配置Power刀片的刀片中心BladeCenter H 时,都有哪些SFP(光纤连接模块)可以用在该刀片中心？

怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card?

刀箱中配置新的fc#5449 QLogic 8 Gb光纤直通模块有什么需要注意的地方?

如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？ (最近更新)

BCH和BCS上有多种以太网交换机模块，如何为客户选择 (新增)

如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块 (新增)

JS43和PS702是否集成了两个SASController？

刀片做HACMP推荐方案

POWER6

Power 520/550

在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍 (最近更新)

如何在Power 520/550 服务器上创建RAID 5? (最近更新)

如何实现Power 520和550的2个LPAR的RAID功能? (最近更新)

如何配置Power 520服务器内置磁盘分区的功能

如何配置Power 550服务器内置磁盘分区的功能

如何配置Power 520 和550 三个及以上分区

配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜 (最近更新)

能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘? (新增)

Power 550 3.5GHz的处理器是否能升级为4.2GHz或者5.0GHz的处理器

Power 560/570

Power 570的Processor Power Regulator是什么？

如何在Power 570上创建RAID 5? (最近更新)

Power 570在一个CEC中，如何配置2个分区

Power 570在多个分区的情况下，如何实现光驱在分区之间的切换?

如何实现Power 560和570内置硬盘之外增加LPAR

Power 575

Power 575的Infiniband卡(fc5612)，需要订什么Infiniband线缆，才能连接到7874系列Infiniband交换机上？

Power 595

Power 595内存的配置规则

用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜?

怎样在Power 595上配置内置光驱和磁带机?

其他

Power 520/550/560/570/595 CPU, MEM, Disk的配置规则?

POWER7

Power 710/730

对Power 710/730，请问如何配置适配卡来支持HA

Power 710/730服务器的内置磁盘不支持分离背板的功能

Power 710/730的内存配置及规则 (最近更新)

Power 720/740

Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

Power 720/740的内存配置及规则 (最近更新)

Power 750/755

如何在Power 750上实现硬盘背板的分离

如何配置Power 750三个及以上分区

如何实现Power 750的RAID功能 (最近更新)

Power 750/755的内存配置规则

Power 770/780

如何在Power 770/780上实现硬盘背板的分离

如何实现Power 770/780的RAID功能

在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗 (新增)

Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置 (新增)

其他

POWER7服务器 CPU，MEM，DISK的配置规则 (最近更新)

POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项 (新增)

POWER7服务器如何配置3.5英寸的磁盘

POWER7全线产品家族分离背板总结 (新增)

其他

System P 服务器如何选配置电源线? (最近更新)

介绍Power服务器上fc#6577的电源线

如何在e-config中选择7316-TF3?

POWER服务器上的几种 10 Gigabit的以太网卡有什么不同?

配置FCoE卡时的注意事项

用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？ (最近更新)

新发布的SFF硬盘和SSD 硬盘的特性是什么? 如何配置?

为什么必须要配置一对fc#5805的RAID卡？ (最近更新)

fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？ (新增)

Power中异步卡和串口线的选择 (最近更新)

在System P的HACMP方案里，推荐的e-config配置范例

在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？

fc#5802/5803如何配合主机实现分区功能

Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

Power服务器常用I/O抽屉配置方法

System P服务器都支持哪一些类型的I/O Drawer?

怎样配置fc#5796和fc#5802的IO抽屉

7014-T00/T42/B42机柜PDU和电源线的配置介绍


配置 刀片服务器

刀片服务器

BladeCenter H机箱中10个I/O插槽的配置规则 (最近更新)

7989-BCH机箱怎样配置冗余的电源以及电源线？ (最近更新)

BladeCenter S电源配置问题

BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项 (最近更新)

当配置Power刀片的刀片中心BladeCenter H 时,都有哪些SFP(光纤连接模块)可以用在该刀片中心？

怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card?

刀箱中配置新的fc#5449 QLogic 8 Gb光纤直通模块有什么需要注意的地方?

如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？ (最近更新)

BCH和BCS上有多种以太网交换机模块，如何为客户选择 (新增)

如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块 (新增)

JS43和PS702是否集成了两个SASController？

刀片做HACMP推荐方案


BladeCenter H机箱中10个I/O插槽的配置规则

解答:

10个I/O插槽分为三种,其中Bay 1-4为普通模块插槽,Bay 5-6为桥接模块插槽,Bay 7-10为高速模块插槽。Bay 1-2必须放置以太网的交换模块或以太直通模块.

可以放在Bay 1-4上的模块有:
BNT 1/10 Gb Uplink Ethernet Switch Module (fc#1590)
Cisco 3110X Catalyst Switch (fc#3171)
Cisco 3110G Catalyst Switch (fc#3173)
Cisco 3012 Catalyst Switch (fc#3174)
BNT Layer 2/3 Copper Gigabit Ethernet Switch Modules for BladeCenter (fc#3212)
Server Connectivity Module for BladeCenter (fc#3220)
Intelligent Copper Pass-thru Module (fc#5452)

Nortel 10 GB Uplink Ethernet Switch Module (fc#3210)(已停产)
BNT Layer 2-7 GbE Switch Module for BladeCenter (fc#3211)(已停产)
Nortel Networks L2/L3 Fiber Gigabit Ethernet Switch Module (#3213)(已停产)
Cisco Systems Fiber Intelligent Gigabit Ethernet Switch Module (fc#3214)(已停产)
Cisco Systems Intelligent Gigabit Ethernet Switch Module (fc#3215)(已停产)
Optical Pass-thru Module (fc#3218)(已停产)
Copper Pass-thru Module (fc#3219)(已停产)

可以放在Bay 3-4上的模块有:
Cisco Systems 4Gb 20-port Fibre Channel Switch Module (fc#3242)
IBM BladeCenter SAS Connectivity Module(fc#3267)
QLogic 20-port 8 Gb SAN Switch Module (fc#3284)
Brocade 10-port 8 Gb SAN Switch Module for IBM BladeCenter (fc#5045)
QLogic 8 Gb Intelligent Pass-thru Module (fc#5449)
Brocade 20-port 8 Gb SAN Switch Module for IBM BladeCenter (fc#5869)

QLogic 4Gb 20-port Fibre Channel Switch Module (fc#3202)(已停产)
QLogic 4Gb 10-port Fibre Channel Switch Module (fc#3203)(已停产)
Brocade 20-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3206) (已停产)
Brocade 10-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3207)(已停产)
McDATA 4Gb 20-port Fibre Channel Switch Module (fc#3208)(已停产)
McDATA 4Gb 10-port Fibre Channel Switch Module (fc#3209)(已停产)
Cisco Systems 4Gb 10-port Fibre Channel Switch Module (fc#3241)(已停产)
QLogic 10-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3243)(已停产)
QLogic 20-port 4 Gb SAN Switch Module for IBM BladeCenter (fc#3244)(已停产)
QLogic 4 Gb Intelligent Pass-Thru Module for IBM BladeCenter (fc#3245)(已停产)
Optical Pass-thru Module (fc#3218)(已停产)
Copper Pass-thru Module (fc#3219)(已停产)

不可以在Bay 3 和Bay 4 之间混插以太网连接模块（包括铜口Pass-thru Module）和SAN连接模块，而混插光口的Pass-thru Module和以太网连接模块（或SAN连接模块）是允许的。Bay 5-6上的Bridge modules提供到Bay 7-10的连接，它们不直接与刀片连接。Bay 7-10支持高速的协议比如4X InfiniBand。

可以放在Bay 7或 Bay 9上的模块有:

Cisco Nexus 4001I Switch Module for IBM BladeCenter H(fc#2241)
Voltaire 40 Gb Infiniband Switch Module for IBM BladeCenter(fc#3204)
4X InfiniBand Pass-Thru Module for IBM BladeCenter (fc#3216)
Multi-Switch Interconnect Module (fc#3239)
1个(fc#3239)将两个高速模块插槽转换为两个普通插槽，可以放置在Bay 1-4上的模块都可以放置在转换后的普通插槽上。
BNT 10-port 10 Gb Ethernet Switch Module for IBM BladeCenter(fc#3248)
10 Gb Ethernet Pass-Thru Module(#5412)

4X InfiniBand Pass-Thru Module for IBM BladeCenter (fc#3216)(已停产)
Cisco Systems 4X InfiniBand Switch (fc#3217)(已停产)

请参考销售手册中的Description备注

BladeCenter　H 销售手册

突出价值点：BCH支持14个刀片服务器，拥有10个I/O插槽，目前有20多种可选的交换或者直通模块，可根据客户的需求，在BCH上合理选择相应的模块。

Top


7989-BCH机箱怎样配置冗余的电源以及电源线？

解答:

IBM刀片中心(BladeCenter)是放置刀片服务器(BladeServer)的机箱。目前有五种机箱可以选择。型号分别是BC-E,BC-H,BC-T,BC-HT,BC-S。其中BC-E是一款入门级机箱，7U高度，可以放置14片刀片服务器。BC-H是一款高性能机箱，9U高度，可以放置14片刀片服务器。BC-T和BC-HT是符合电信标准的机箱。BC-S机箱内部可以放置12块磁盘，6片刀片服务器。

现将BC-H机箱电源与电源线配置的注意事项做详细的介绍。

从上图中可以看到BC-H中的电源模块放置在机箱的上下两端。上端可以放置两个电源模块，下端可以放置两个电源模块。BC-H机箱最多可以放置四个电源模块（每个电源模块提供2980W功率）。每个电源模块的位置都被编号。具体编号如上图所示。电源模块的配置要遵守以下几条规则：

电源模块要成对配置。

第一、二号位置上放置的电源模块叫标准电源模块，在定购机箱时这两个位置上的模块是必须要购买的，其Feature Code为：fc#9058，这两个电源模块是负责给一至七号刀片服务器和一 至四，七至十号I/O模块供电的。第三、四号位置上放置的电源模块叫可选电源模块，其Feature Code为：fc#3205，这两个模块是负责给八至十四号刀片服务器和五到十号I/O模块供电的。

注意：fc#3200 2900W的电源已经于2010年10月29日停产。替代的电源为2980W的电源模块，默认的电源模块编号为：fc#9058，可选电源模块编号为：fc#3205。

在BC-H电源线配置方面，BC-H机箱在购买时默认不带电源线，电源线需要随机箱单独购买。在中国购买BC-H机箱时要购买编号为fc#6673的电源线，下图为电源线示意图，圆形的插头是连接到BC-H机箱上，另外三个方形的插头连接到机柜的PDU上。三个方形插头其中有两个是为BC-H机箱的电源模块供电的，另一个插头是为风扇供电的。

如果要把购买的BC-H机箱放置到机柜中，目前只有一款7014-B42的机柜可以放置BC-H机箱。7014-T00/42都不能用来放置BC-H机箱。

请参阅IBM红皮书: SG247523

下载地址: http://www.redbooks.ibm.com/redbooks/pdfs/sg247523.pdf

突出价值点：为系统提供冗余的电源保护，增强系统的可用性。

Top


BladeCenter S电源配置问题

解答：

在e-config中，目前BladeCenter S只支持一种电源：

fc#4505 IBM BladeCenter S 950W/1450W Auto-Sensing PS (C14)

该电源可配置如下的电源线：
BladeCenter S to PDU:
fc#6458 Power Cable - Drawer to IBM PDU, 14-foot, 250V/10A

BladeCenter S to WALL:
fc#6493 Power Cord (9-foot), To Wall/OEM PDU, (250V, 10A), Plug Type #62

另外，fc#4548 IBM BladeCenter S 950W/1450W Auto-Sensing PS (C20)，该电源已于2009-12-30停产。

什么时候需要添加第二对电源模块？

BladeCenter S的所有电源模块都在同一个电源域(Power Domain)中，为每个刀片、模块供电。当需要在BladeCenter S上配置多于2个刀片或者加第二个DSM(Disk Storage Module)，或者在bay 2和bay 4装模块的时候，必须配置第二对电源模块。

突出价值点：可以将BladeCenter S放到IBM 19英寸的机柜里，将fc#6458电源线连接到C13标准的PDU(fc#7188/9188)上，目前可以放置的机柜为：7014-T42、7014-T00以及7014-B42；也可以将其放到OEM的19英寸机柜里，此时需要配置fc#6493的电源线来进行连接。

Top


BladeCenter S中的SAS模块NSSM(fc#3267)和RSSM(fc#3734)的对比，以及配置注意事项

解答：

NSSM(fc#3267):IBM 刀片中心SAS普通连接模块(IBM BladeCenter SAS Connectivity Module)。

.支持BladeCenter S 和 BladeCenter H刀片中心；
.不支持RAID功能；
.支持 TS2240 磁带机；
.支持 DS3200 盘阵；
.配置可以1个,推荐2个；
.要求刀片内配置SAS子卡。

RSSM(fc#3734):IBM 刀片中心SAS RAID控制交换模块（SAS RAID Controller Switch Module）。

.仅支持在BladeCenter S刀片中心,用于对BladeCenter S内部的磁盘提供RAID功能的支持；
.支持RAID 0, 1, 5, & 10；
.支持 TS2240 磁带机；
.不支持 DS3200 盘阵；
.配置必须要求2个；
.要求刀片内配置SAS子卡。

注意：fc#3734 RSSM不支持和fc#3267 NSSM同时存在于BladeCenter S中。

fc#3267和fc#3734支持：
JS12/22刀片中的fc#8250 CFFv SAS 卡
JS23/43/PS700/PS701/PS702刀片中的fc#8246 CIOv SAS 卡

关于 SAS RAID Controller Switch Module的兼容列表，参考如下链接：

IBM BladeCenter S SAS RAID Module Interoperability Matrix
ftp://ftp.software.ibm.com/systems/support/system_x_pdf/ibm_fw_bcsw_s0cl-interoperability_1.30.pdf

突出价值点：使用SAS Connective Module(fc#3267)连接的BCS里的硬盘，目前只能分配给指定的刀片，供某个刀片独立使用，不能实现刀片之间的存储共享；而SAS RAID Module(fc#3734)可以实现存储共享。

Top


当配置Power刀片的刀片中心BladeCenter H时，都有哪些SFP(光纤连接模块)可以用在该刀片中心？

解答：

主要有短波和长波两种属性的模块可以用在刀片中心BladeCenter H上。每一个FC(feature code)代表着一个SFP模块。

在配置Switch以及SFP时候，我们一定还要考虑冗余路径的问题，所以Switch和SFP数量上都不能少。在为刀片中心BladeCenter H配置交换机的时候，大家要注意所有20口的交换机会有6个对外的接口，e-config工具只会默认配置一个SFP，所以其余的5个端口大家如果想要使用，必需手动的选择SFP数量；而对于所有10口的交换机，会有3个对外的接口，e-config工具也只会默认配置一个SFP给交换机，其余的2个端口大家如果想要使用，必需手动的选择数量。

以下是几种常用的SFP模块:

fc#3261 Cisco SYSTEMS 4 GB SHORT-WAVE LENGTH SFP MODULES (Cisco 4GB 短波光纤模块 一个)
主要用在fc#3241 Cisco 4 Gb 20 port的光纤交换机或者fc#3242 Cisco 4 Gb 10 port的光纤交换机使用。

fc#3238 IBM SHORT WAVE SFP MODULE, 4 GB (IBM 4GB 短波光纤模块 一个)
主要用在fc#3206 Brocade 20-port 4 Gb 光纤交换模块上或者用在fc#3207 Brocade 10-port 4 Gb 光纤交换模块上。

fc#3286 8Gb SFP+ Short Ware optic transceiver (QLOGIC 8 Gb 短波光纤模块 一个)
主要用在 fc#3284 QLOGIC 8 Gb 20 port的光纤交换机。

fc#3282 IBM 10 Gb Ethernet 850 nm Fiber SFP+ Transceiver (IBM 10 Gb ethernet 850nm 光纤收发模块 一个)
主要用在 fc#1590 BNT 1/10 Gb Uplink Ethernet 交换机上。

fc#5358 Brocade 8 Gb SFP+ Short-wave Optic Transceiver(Brocade 8Gb短波光纤模块 一个)
主要用在fc#5045 Brocade 8 Gb 10-port 和 fc#5869 Brocade 8 Gb 20-port光纤交换模块上 。

fc#3236 IBM SHORT WAVE SFP MODULE (IBM 短波光纤模块 一个)(已停产)
IBM Short Wave SFP Module for connecting switches to Storage Area Networks
主要用在fc#3213 Nortel 20 port 光纤网络交换机或者fc#3214 Cisco 20 port 的智能光纤网络交换机上使用。

fc#3237 IBM LONG WAVE SFP MODULE （IBM 长波光纤模块 一个）(已停产)
IBM Long Wave SFP Module for connecting switches to Storage Area Networks

fc#3262 Cisco SYSTEMS 4 GB LONG-WAVE LENGTH SFP MODULES (Cisco 4GB 长波光纤模块 一个)(已停产)
主要用在fc#3241 Cisco 4 Gb 20 port的光纤交换机或者fc#3242 Cisco 4 Gb 10 port的光纤交换机使用。

突出价值点：目前，BCH上可以配置5种SFP模块，这5种SFP模块可以用在Cisco 4Gb的光纤交换模块,Brocade 4Gb/8Gb的光纤交换模块,Qlogic 8Gb的光纤交换模块以及BNT 1/10Gb Uplink ethernet交换模块上。

Top


怎样配置和使用刀片上的fc#8252-QLogic Ethernet and 4 Gb Fibre Channel Expansion Card

解答：

fc#8252同时拥有两个4Gb光纤接口和两个1Gb的以太网口，会占用刀片服务器的一个PCI-E插槽，fc#8252在对外连接使用之前，首先必须先在刀片机箱（BladeCenter H）上配置一个多路转换模块MSIM:fc#3239-Multi-Switch Interconnect Module，这个fc#3239将会把刀片机箱（BladeCenter H）上四个上下结构的高速交换槽位转换成左右结构的标准交换槽位，分别是bay 7，8，9，10；其中左侧的两个位置是负责fc#8252的两个以太网口通信的，右侧的两个位置是负责fc#8252的两个4Gb光纤接口对外通信的。如图下图所示：

突出价值点：fc#8252同时拥有两个4Gb光纤接口和两个1Gb的以太网口，相当于一块双口1Gb以太网卡和一块双口4Gb光纤卡，但#8252只占用刀片服务器的一个PCI-E插槽，从而节省了PCI槽位。

Top


刀箱中配置新的fc#5449 QLogic 8 Gb光纤直通模块有什么需要注意的地方

解答：

使用这个智能直通模块有如下注意事项：

1.不支持直连SAN存储设备
这个智能直通模块不支持直接连接SAN存储设备，例如磁带机或磁盘等。

2.可连接大量设备
这个智能直通模块在一个fabric中没有理论上的最大连接上限，这个最大值取决于这个fabric中所支持的设备数量。多达16个NPIV的WWNs可以通过透明直通模式分配到一个外部SFP端口，在full-fabric模式下可以支持到256个。

3.不支持级联
只有在full-fabric模式下这个模块才支持级联。

4.交换功能
对于这个智能直通模块，交换功能并不适用，比如FICON、ISL Trunking和一些管理服务。这些功能将在full-fabric模式得到支持。

补充：您可以通过购买适当的许可将这个智能直通模块升级为full fabric的20口交换模块。

更多信息请参考红皮书：
《Implementing the QLogic Intelligent Pass-thru Module for BladeCenter》


如何在BladeCenter H和BladeCenter S刀箱上配置直通模块？

解答：

 |  | Pass-Thru Feature | External Port | Cable | 对应关系
BladeCenter H | 支持以太网协议 | fc#5452-Intelligent Copper Pass-thru Module | 14个RJ-45 | 普通网线 | 1-1
 | 支持SAN | fc#5449-QLogic 8 Gb Intelligent Pass-thru Module | 6个 | fc#3286-8 Gb SFP+ Short Wave Optic Transceiver | 可以进入配置指定mapping （NPIV）技术
 | 支持以太网、FC和FCoE协议 | fc#5412-10Gb Ethernet Pass-Thru Module | 14个 | fc#3282-IBM 10 Gb Ethernet 850 nm Fiber SFP+ Transceiver | one to one mapping
BladeCenter S | 支持以太网协议 | fc#5452-Intelligent Copper Pass-thru Module | 14个 | 普通网线 | 1-1连接
 | 支持SAN | fc#5449-QLogic 8 Gb Intelligent Pass-thru Module | 6个 | fc#3286 -8 Gb SFP+ Short Wave Optic Transceiver | 可以进入配置指定mapping （NPIV）技术

Top


BCH和BCS上有多种以太网交换机模块，如何为客户选择

解答：

在为客户选择以太网交换机时，需要考虑以下几个方面：

1)价格；

2)厂商(客户是否偏好某一厂商)；

3)交换机本身的相关参数：
(a) 支持以太网协议的层次：L2，L2/L3，还是支持到L7；
(b) 未来客户需求的变化。比如目前1G就够用，但在不久的将来也许就变成10G才够用，如果是这样，可以现在就考虑为客户配置10G的交换机；
(c) 可管理性(管理工具、CLI命令接口，管理软件)；
(d) 上行/下行速率(1Gb还是10Gb)；
(e) 性能(带宽、时延)；
(f) 耗电量(单个交换机也许影响不大，但是当数据中心里有很多台设备，差异就体现出来了)。

需要说明的是，有的客户可能倾向于思科的网络交换机，但是，其实客户也可以考虑选择BNT的网络交换机。因为，BNT的网络交换机与思科的有相似的CLI，能操作思科网络交换机的工程师，对BNT网络交换机的操作也易于上手。

突出价值点：IBM为客户提供了多种以太网交换模块。客户可以根据实际需求来灵活选择。


如何在POWER7刀片服务器和BCH上配置具有FCoE功能的子卡和交换模块

解答：

BCH中支持FCoE功能的交换模块有：
fc#2241 Cisco Nexus 4001I Switch Module for IBM BladeCenter H
fc#3248 BNT 10-port 10Gb Ethernet Switch Module for BladeCenter

但需注意：fc#2241 Cisco Nexus 4001I Switch Module for IBM BladeCenter H交换模块需要额外购买fc#2242 Software Upgrade License for Cisco Nexus 4001I软件升级许可，来启用FCoE功能。

在POWER7刀片服务器中，可以配置fc#8725 QLogic 2-port 10 Gb Converged Network Adapter (CFFh)子卡，来连接BCH上的FCoE交换模块。

突出价值点：通过FCoE技术，不但减少服务器内部子卡的数量和刀片中心交换模块数量，更大大减少了连接线缆数量，从而提高散热能力，降低能耗需求。


JS43和PS702是否集成了两个SASController？

解答：

JS43和PS702只集成了一个SAS Controller。

通常大家会觉得，JS43为2个JS23的叠加，PS702为2个PS701的叠加，并且所有的部件都是重复的，其实并非如此。JS43为一个JS23外加了一个扩展单元（fc#8446),PS702为一个PS701外加了一个扩展单元（fc#8358）。

在扩展单元中，并不包含JS23或者PS701的所有部件，比如集成的SAS Controller等一些部件并不在扩展单元中。

如果JS43/PS702要实现分区，可以通过IVM实现分区的管理。将SAS Controller的所有硬盘分配给分区VIOS，并由VIOS将硬盘指派给其他的分区使用。

需要注意，目前，IVM不支持每台服务器大于1个逻辑分区，且JS43/PS702不支持HMC，所以JS43/PS702不支持双VIOS的配置。

另外，JS43/PS702最大支持2个双口的光纤通道卡和双口网卡+双口光纤通道卡(fc#8252)，所以可以给2个LPARs配置冗余的磁盘IO。JS43/PS702共有4个集成的以太网端口，其中包含IVE卡，该卡是可以不通过VIOS就将网络端口分给多个分区使用。


刀片做HACMP推荐方案

解答：

一个推荐的配置：

JS22：

两个集成的以太网端口和一个以太网和FC混合卡(fc#8252，提供2个以太网端口和2个FC端口)

BladeCenter H：

2个以太网交换模块(用于刀片集成的以太网端口，占用BCH的I/O bay 1和bay 2)
2个以太网交换模块(安装在MSIM上)
2个FC交换模块(安装在MSIM上)
2个Multi Switch Interconnect Module(fc#3239)

外部共享硬盘：

HACMP 心跳：通过共享硬盘来实现心跳功能

如下是MSIM的介绍：

突出价值点：刀片相对其他Power服务器成本低，加入HACMP之后，适合于对小型应用进行双机或集群的热备容灾方案。

Top


配置-POWER6

POWER6

Power 520/550

Power 560/570

Power 575

Power 595

其他


配置 Power 520/550

Power 520/550

在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍 (最近更新)

如何在Power 520/550 服务器上创建RAID 5? (最近更新)

如何实现Power 520和550的2个LPAR的RAID功能? (最近更新)

如何配置Power 520服务器内置磁盘分区的功能

如何配置Power 550服务器内置磁盘分区的功能

如何配置Power 520 和550 三个及以上分区

配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜 (最近更新)

能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘? (新增)

Power 550 3.5GHz的处理器是否能升级为4.2GHz或者5.0GHz的处理器


在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

解答：

目前，Power550上可以配置三种磁带机：
fc#5619 80/160GB DAT160 SAS Tape Drive;
fc#5661 DAT320 160/320 GB Tape Drive;
fc#5746 Half High 800GB/1.6TB LTO4 SAS Tape Drive;

fc#5619,fc#5661和fc#5746默认包含一个的磁带机，一个清洗带和测试带。

磁带机fc#5619和fc#5746所使用的磁带可以直接在e-config工具中配置：
fc#5689 DAT160 Data Cartridge 为5盒一包的数据磁带；
fc#5747 IBM LTO Ultrium 4 800 GB Data Cartridge 为5盒一包的数据磁带。

fc#5661磁带机所使用的磁带目前还不可以直接通过e-config工具配置，需要单独从市面上购买。

突出价值点：在Power 520和550上有单独的空间放置内置磁带机，与配置外置的磁带机相比，不需要单独的空间来放置外置磁带机，且也不用单独配置PCI卡来连接外置磁带机，相对更节省成本。


如何在Power 520/550服务器上创建RAID 5？

解答:

对Power 520/550服务器内置磁盘创建RAID 5需要选择以下组件：

Power 520服务器：

1. 需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且需要配置fc#8310,fc#8340或者fc#8346的硬盘背板，实现内置硬盘的RAID功能。
2. fc#5902的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)的RAID功能。
3. fc#5903的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)和IO抽屉(fc#5802)上SAS硬盘的RAID功能。
4. fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。
5. fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉（fc#5886）和IO抽屉（fc#5802）上SAS硬盘的RAID功能。该卡主要替代fc#5903的RAID卡。

Power 550服务器：

1. 需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且需要配置fc#8310,fc#8340或者fc#8346的硬盘背板，实现内置硬盘的RAID功能。
2. fc#5902的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)的RAID功能。
3. fc#5903的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)和IO抽屉(fc#5802)上SAS硬盘的RAID功能。
4. fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。
5. fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉（fc#5886）和IO抽屉（fc#5802）上SAS硬盘的RAID功能。该卡主要替代fc#5903的RAID卡。

其中Power 520/550的方案1，配置fc#5679(SAS RAID Enablement)的RAID子卡和支持RAID子卡的硬盘背板 fc#8310/fc#8340/fc#8346,可以实现内置硬盘的RAID功能。fc#5679这块卡，它不会占用主板的PCI槽位，可以为客户节省PCI槽位。

注意：fc#5902和fc#5903的RAID卡已经停产了，可以通过配置一对fc#5805的SAS RAID卡来替代fc#5902/5903的RAID卡。

突出价值点：多种RAID卡的选择，更灵活的配置，确保系统的高可用性。


如何实现Power 520和550 的2个LPAR的RAID功能

解答：

Power 520/550支持多种内部硬盘结构,具体请参见《Power 520六种硬盘背板的介绍》和《Power 550六种硬盘背板的介绍》。

如果要实现Power 520/550 2个LPAR，每个LPAR 3块硬盘(3.5"或者2.5"的SAS硬盘)的RAID功能，可通过如下方法完成：

1.第一个LPAR通过内部的SAS卡连接内部的硬盘背板(fc#8310/fc#8340)，集成SAS卡可以连接RAID子卡fc#5679，实现RAID功能，支持RAID 0,1,5,6和10，RAID子卡fc#5679还支持175MB的cache。

2.第二个LPAR通过外接SAS卡fc#5904 + SAS线fc#3679 + SAS线fc#3669(550)或fc#3670(520)来实现RAID功能.

如果要实现Power 520/550 2个LPAR，每个LPAR 4 块硬盘(3.5"或者2.5"的SAS硬盘)的RAID功能，可通过如下方法完成：

如果配置3.5"的SAS硬盘：

1.第一个LPAR通过内部的SAS卡连接内部的硬盘背板(fc#8310)，集成SAS卡可以连接RAID子卡fc#5679，实现RAID功能，支持RAID 0,1,5,6和10，RAID子卡fc#5679还支持175MB的Cache。

2.第二个LPAR通过SAS卡连接fc#5886的扩展柜。扩展柜可通过2个fc#5805的SAS RAID卡连接（fc#5805是成对配置的）。fc#5805可以实现写Cache数据和RAID校验的映射。适配卡支持SAS的冗余链路，在一条SAS链路出问题的时候，自动进行链路切换，支持RAID 0,1,5,6和10，可通过fc#3661，3662，3663的SAS线连接fc#5886的扩展柜；或者配置fc#5904的SAS RAID卡连接fc#5886的扩展柜来实现RAID功能。

如果配置2.5"的SAS硬盘：

通过fc#8340(8个槽位)的硬盘背板实现，第一个分区通过集成的SAS卡 + RAID子卡(fc#5679)实现RAID,第二个分区通过外接SAS卡fc#5904 + SAS线fc#3679 + SAS线fc#3669(550)或fc#3670(520)来实现RAID功能。

突出价值点：不同RAID卡的组合使用，确保系统的高可用性。


如何配置Power 520 服务器内置磁盘分区的功能？

解答:

环境:Power 520(产品,平台,机型,软件版本,等)

配置内置磁盘分区功能需要满足以下要求:

1. 配置磁盘背板为fc#8310(使用3.5"SAS磁盘)或fc#8340/fc#8346(使用2.5"SAS磁盘)。

2. 选择一种下面所列SAS卡，配置1个:
.fc#5912 PCI-X SAS卡
.或fc#5901 PCIe SAS卡
.或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3670内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3670，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 520的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3670分离背板的线和fc#3679的线控制。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 550 服务器内置磁盘分区的功能？

解答:

环境:Power 550(产品,平台,机型,软件版本,等)

配置内置磁盘分区功能需要满足以下要求:

1. 配置磁盘背板为fc#8310(使用3.5"SAS磁盘)或fc#8340/fc#8346(使用2.5"SAS磁盘)。

2. 选择一种下面所列SAS卡，配置1个:
fc#5912 PCI-X SAS卡
或fc#5901 PCIe SAS卡
或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3669内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3669，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 550的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 520和550 三个及以上分区

解答：

由于在Power 520/550中，内置硬盘能实现2个分区的配置，要实现3个及以上分区的配置，需要通过I/O扩展实现：

有两种配置方式：1.是通过添加SAS的卡和fc#5886的SAS扩展柜；2.是通过添加fc#5802的IO抽屉实现；

1.前两个分区，正如在如何配置Power 520 服务器内置磁盘分区的功能？和如何配置Power 550 服务器内置磁盘分区的功能?中介绍的，需要配置fc#8340/fc#8310的硬盘背板，fc#3669和fc#3679的SAS线，以及fc#5912/fc#5901的SAS卡；

2.第三个分区主要的配置如下：

(1) 通过SAS卡和fc#5886的SAS硬盘扩展柜：

fc#5912/fc#5901的SAS卡，fc#5886的SAS扩展柜，以及相应的YO的SAS的线，在e-config中，可以配置如下的YO线：

fc#3691 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 1.5 M
fc#3692 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 3 M
fc#3693 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 6 M
fc#3694 - SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 15 M

一般，e-config工具，将自动添加fc#3692 YO的SAS线。

(2) 通过添加fc#5802的IO抽屉实现：

fc#5802支持最大18块SFF SAS硬盘，每个fc#5802支持1,2或者4个硬盘通道(可通过fc#5802上的Switch进行通道数量的选择)，当为1个分区时，最大的硬盘数为18块 SFF SAS硬盘；当为2个分区时，每个通道支持的最大9块SFF SAS硬盘；当为4个分区时，每个通道支持最大的SFF SAS 硬盘数分别为：5，4，4，5；每个分区的硬盘通道都需要配置fc#5901的SAS卡以及相应数量的fc#3688 SAS 的线(AT)。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


配置Power 520/550时，为什么有时会自动添加fc#5886的硬盘扩展柜

解答:

最新的e-config配置Power 520, 550时，缺省硬盘背板为fc#8340, 缺省硬盘为fc#3647。

fc#8340是支持SFF 2.5"硬盘的背板，但fc#3647为3.5"的硬盘，只能放在fc#8308, 或者fc#8310背板，或者fc#5886硬盘扩展柜中。这样e-config就会为这块硬盘自动加一个fc#5886。

解决办法：
手工把硬盘背板更改为fc#8310或者fc#8308即可。


能否为Power 550配置8块fc#3647的SAS硬盘?以及如何放置8块硬盘?

解答：

在Power 550的硬盘背板上，最大支持配置6块fc#3647 146GB SAS硬盘，具体的硬盘背板的信息如下：

fc#8308 = 6 x 3.5" DASD Backplane with no external SAS port
fc#8310 = 6 x 3.5" DASD backplane with an external SAS port

以上两种硬盘背板都可以支持fc#3647的硬盘，但是最大只能放置6块3.5英寸的硬盘。如果要配置8块fc#3647的3.5英寸SAS硬盘，需要将其中的6块硬盘放置到硬盘背板上，另外2块硬盘放置到fc#5886的EXP 12S硬盘扩展柜里。

针对在Power 550上配置8块fc#3647 3.5英寸SAS硬盘的情况，需要进行如下的配置：

1.fc#8310 具有对外SAS端口的硬盘背板；

2.fc#3668 为一根从硬盘背板到系统后挡板的SAS线缆，该SAS线缆用于将硬盘背板的外对SAS端口连接到系统的后挡板，可以支持通过YI的SAS线缆连接到fc#5886上；

3.fc#3687 SAS Cable (YI) System to SAS Enclosure, Single Controller/Dual Path 3M，该SAS线缆主要用于通过fc#3668的SAS线缆，将一台fc#5886的硬盘扩展柜连接到主机集成的SAS端口上；

4.fc#5886 EXP 12S硬盘扩展柜。

注意：通过以上的配置，fc#5886上的硬盘是由fc#8310上集成的SAS控制器管理，如果在fc#8310上配置了fc#5679的RAID子卡，此时，fc#5679的RAID子卡，可以实现fc#8310和fc#5886上硬盘的RAID功能。


Power 550 3.5GHz的处理器是否能升级为4.2GHz或者5.0GHz的处理器

解答：

Power 550可以从3.5GHz的处理器升级为4.2GHz，但是不可以升级到5.0GHz。

5.0GHz的处理器需要新的背板是不能升级的原因之一。

升级时需要注意：新加的处理器需要完全重新购买，也就是说不存在费用方面的抵销，升级需要将3.5GHz的处理器移除，将新的4.2GHz的处理器放到背板上。

同时，Power 550处理器必须运行在同一主频上，因此升级时需要将所有的3.5GHz的处理器替换掉。


配置Power 560/570

Power 560/670

Power 570的Processor Power Regulator是什么？

如何在Power 570上创建RAID 5? (最近更新)

Power 570在一个CEC中，如何配置2个分区

Power 570在多个分区的情况下，如何实现光驱在分区之间的切换?

如何实现Power 560和570内置硬盘之外增加LPAR


Power 570的Processor Power Regulator是什么？

解答：

Power 570的Processor Power Regulator是处理器稳压器，这个部件提供处理器运行时所需的电压调节。

每个系统抽屉都有三个处理器稳压器，第三个处理器稳压器可以为处理器提供冗余的电源保护，增强系统的可用性。只要系统抽屉中至少有两个工作的稳压器，那么处理器将持续运行。出错的（即第三个）稳压器可热拔插更换，但必须留在系统中直至备件替换。

如果一个系统抽屉中只有两个处理器稳压器，就不能为处理器提供任何冗余的稳压功能。当且仅当只有一个系统抽屉的情况下，配置一个或两个fc#5620处理器卡(3.5GHz主频)时，才可以仅配置两个处理器稳压器。这种情况下，处理器稳压器不能给处理器提供冗余电源保护。需要注意的是，这种两个稳压器的配置是e-config工具在只有一个或两个fc#5620时的默认配置。所有其他的配置，每个系统抽屉均必须配置三个稳压器。

突出价值点：为处理器提供冗余的电源保护，增强系统的可用性。


如何在Power 570上创建RAID 5

解答:

RAID卡fc#5902/fc#5903/fc#5805/fc#5908可以给Power 570的内置磁盘创建RAID 5，在硬件配置方面有三种情况。

第一种情况：给一个CEC单元内的6块磁盘创建RAID 5。

当给一个CEC单元内的6块磁盘创建RAID 5时，有两种配置方式：
1.1x fc#5908,1x fc#3651,1xfc#3679(AI SAS Cable)的配置方式；
2.2x fc#5902/fc#5903/fc#5805(fc#5902/fc#5903/fc#5805卡在e-config配置工具中必须成对配置),1x fc#3651,1x fc#3667 (YR Cable), 每个fc#5902/fc#5903/fc#5805卡上的一个接口通过fc#3667线缆连接到fc#3651上保证冗余。具体连接方式见下图。

第二种情况：给两个CEC单元内的12块磁盘创建RAID 5。

当给两个CEC单元内的12块磁盘创建RAID 5时，有两种配置方式：
1.1x fc#5908，2x fc#3651(每个CEC单元一个)，2xfc#3679(AI SAS Cable)的配置方式；
2.2x fc#5902/fc#5903/fc#5805(fc#5902/fc#5903/fc#5805卡在e-config配置工具中必须成对配置),2x fc#3651 (每个CEC单元一个), 2x fc#3667 (YR Cable), 每个fc#5902/fc#5903/fc#5805卡上的两个接口通过fc#3667线缆连接到fc#3651上保证冗余。具体连接方式见下图。

第三种情况：给三个CEC单元的18块硬盘创建RAID 5。

当给三个CEC单元内的18块磁盘创建RAID 5 时，在硬件配置方面需要满足：

1x fc#5908，3x fc#3651(每个CEC单元一个)，3xfc#3679(AI SAS Cable)的配置方式。具体的连接方式，见下图：

注意：fc#5805替代fc#5903的SAS RAID卡，但是在Power 570上，fc#5805的SAS RAID卡只能通过MES的方式进行订购。

突出价值点：为客户数据保护提供多种选择。Power 570在做RAID5的时候，有四种RAID卡可以选择：fc#5902，fc#5903，fc#5805，fc#5908.其中fc#5902，fc#5903，fc#5805必须成对的配置才能实现RAID5，fc#5902为PCI-X的卡，其缓存为175MB；fc#5903/fc#5805为PCIe的卡，其缓存为380MB；fc#5908为占用两个PCI-X的槽位的RAID卡，其缓存为1.5Gb。fc#5902,fc#5903,fc#5805的RAID卡均为双口的，最多支持2个系统抽屉的12块硬盘做RAID；fc#5908RAID卡为三端口，最多支持3个系统抽屉的18块硬盘做RAID，客户可以根据需要进行选择相应的RAID卡。

Top


Power 570 在一个CEC中，如何配置2个分区

解答：

Power 570每个系统柜有6个磁盘槽位，具有分离背板(Split Backplane)功能的选件能够将6个磁盘槽位分成2组(每组3块磁盘)，并且AIX或Linux可以分别使用这两个磁盘组。两个磁盘组分别使用不同的磁盘控制器(一个板载集成的，一个PCI的)， 增加的一个组对于一些数量较少的分区和磁盘控制器镜像是非常有意义的。

可以通过如下两种配置方案实现9117-MMA每个CEC划分两个分区：

第一种配置方式：可以使用fc#3650 + fc#5912/fc#5901 + fc#3679,那么它们连接的3块SAS盘(第4，5，6号盘)将分配给一个分区;而主板上的6 Pack中的另外3块盘和光驱将会分配给另一个分区使用。这时的光驱是不能够浮动的,也即无法提供DLPAR使用。此种配置方法需要占用两个PCI槽位，fc#5912要使用一个PCI-X槽位或者fc#5911要使用一个PCIe槽位，fc#3650要占用一个PCIe槽位。

第二种配置方式：可以使用fc#5909/fc#5911＋fc#3679，那么它们连接的3块SAS盘(第4，5，6号盘)将分配给一个分区;而主板上的6 Pack中的另外3块盘和光驱将会分配给另一个分区使用。这时的光驱是不能够浮动的,也即无法提供DLPAR使用。采用这种方法只需为fc#5909/fc#5911提供一个PCIe槽位，无需再选择fc#3650，可以节省一个PCIe槽位。

注：fc#5909已于2009年6月26日停产，fc#5911为其替代产品。

fc#5911的SAS卡有三个接口,分离磁盘背板功能会占用其中两个,剩下的一个接口可以用来连接fc#5886的磁盘扩展柜或外置的Media扩展柜,也就是说,可以连接SAS Disk或Tape。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。

Top


Power 570在多个分区的情况下，如何实现光驱在分区之间的切换

解答：

目前，在默认的情况下，Power 570 的光驱不能在分区之间进行切换，可以通过配置外置的光驱设备，实现分区的切换；

也可通过如下的方式实现：在9117-MMA CEC单元中配置fc#3651 + fc#5912/fc#5901 + fc#3679，这样CEC单元中的6块内置磁盘全部连接到fc#5912/fc#5901上，光驱仍然连接到内置的SAS控制器上。光驱和内置磁盘完全分离，光驱可以在不同分区之间切换。以8路处理器的9117-MMA为例，如果客户要求划分两个分区，就可以按照上述方法在一个CEC单元上配置fc#3651 + fc#5912/fc#5901 + fc#3679和光驱，而另一个单元上按照默认配置，这样一个CEC单元上的光驱就可以在两个分区之间切换了。依此类推，12路和16路处理器时也可以按照该方法实施。

注：此方法适合多个CEC做分区的情况。

突出价值点：利用光驱的DLPAR，可以减少硬件的成本，使用还非常方便，是多分区服务器的很好的一个选择。


如何实现Power 560和570内置硬盘之外增加LPAR

解答：

要实现Power 560和570的内置硬盘之外增加LPAR，可以通过两种方式实现：1.是通过添加SAS卡和外置的SAS硬盘扩展柜fc#5886实现；2.是通过添加fc#5802的IO抽屉实现。

主要的配置如下：

1.通过SAS卡和fc#5886的SAS硬盘扩展柜：

fc#5912/fc#5901的SAS卡，fc#5886的SAS扩展柜，以及相应的YO的SAS的线，在e-config中，可以配置如下的YO线：

fc#3691 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 1.5 M
fc#3692 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 3 M
fc#3693 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 6 M
fc#3694 -SAS Cable (YO) Adapter to SAS Enclosure, Single Controller/Dual Path 15 M

2.通过添加fc#5802的IO抽屉：

fc#5802支持最大18块SFF SAS硬盘，每个fc#5802支持1，2，4个硬盘通道(可通过fc#5802上的switch进行通道数量的选择)，当为一个分区时，最大的硬盘数为18块 SFF SAS硬盘，当为两个分区时，每个通道支持的最大9块SFF SAS硬盘，当为四个分区时，每个通道支持最大的SFF SAS 硬盘数分别为：5，4，4，5；每个分区的硬盘通道都需要配置fc#5901的SAS卡以及相应数量的fc#3688 SAS的线(AT)。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


配置Power 575

Power 575

Power 575的Infiniband卡(fc5612)，需要订什么Infiniband线缆，才能连接到7874系列Infiniband交换机上？


Power 575的Infiniband卡(fc#5612)，需要订什么Infiniband线缆，才能连接到7874系列Infiniband交换机上？

解答：

Power 575的Infiniband卡(fc#5612)，一定要在Power 575上订购fc#329x的Infiniband 线缆。

Power 575的Infiniband卡的接口和其他POWER6服务器的接口不同，Power 575上面的接口是QSFP, 其他POWER6服务器上以及7874系列Infiniband交换机上Infiniband 接口是CX4。

fc#329x线缆的接口一端是QSFP，一端是CX4。
7874系列Infiniband交换机里面的线缆fc#330x的两端都是CX4。

参见7874系列交换机的Announcement letter:
http://www.ibm.com/common/ssi/rep_ca/1/872/ENUSAG08-0841/ENUSAG08-0841.PDF

突出价值点：Power 575的Infiniband，比其他服务器的Infiniband能够支持更多的协议，更适合于运行大型、高度并行的计算密集型工作负载，广泛应用于天气和气候建模、计算化学、物理、计算机辅助工程、计算流体力学和石油探测等领域。

Top


配置 Power 595

Power 595

Power 595内存的配置规则

用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜?

怎样在Power 595上配置内置光驱和磁带机?


Power 595内存的配置规则

解答：

1) 对 Processor Book 的规则：
每个Processor Book至少激活16GB。

2) 对内存 Feature 的规则：
对 0/8, 0/16, 0/32GB 的内存，最少要激活50%；
对 0/4, 0/64GB，还有 fc#820x 的套装内存，必须全部激活。

详情见下表：

Feature Code | 内存大小 | 最小激活大小
#5693 | 0/4 GB | 4 GB
#5694 | 0/8 GB | 4 GB
#5695 | 0/16 GB | 8 GB
#5696 | 0/32 GB | 16 GB
#5697 @ | 0/64 GB | 64 GB
#8201 | 32 x #5694 | 256 GB
#8202 | 16 x #5695 | 256 GB
#8203 | 32 x #5695 | 512 GB
#8204 | 16 x #5696 | 512 GB
#8205 @ | 32 x #5697 | 2 TB

注意：内存激活是和服务器的序列号绑定的，如果一组内存移到另外一台服务器上，相应的激活仍然保留在原来的服务器上。


用e-config配置Power 595的时候为什么会自动添加一个19英寸的机柜

解答：

这个是因为在用e-config配置Power 595(9119-FHA)时，选择了SAS硬盘或者SAS固态盘。

Power 595目前可以配置的硬盘有3种：

1) SAS SFF(2.5")硬盘：安装在新推出的fc#5803扩展柜(24"宽)里面；
2) SAS硬盘：安装在fc#5886 EXP 12S扩展柜(19"宽)里面；
3) SAS固态硬盘：安装在fc#5886 EXP 12S扩展柜(19"宽)里面；

注：fc#3279的146.8 GB SCSI硬盘已于2009年11月27日停产了。

如果您为Power 595配置了3.5"的SAS硬盘或者SAS固态硬盘，e-config会自动按照硬盘的数量配置fc#5886。fc#5886无法安装在Power 595的24"的机柜里面，而必须安装在19"的机柜里面。所以，e-config就会自动配置19"机柜(fc#0553, 即7014-T42)。

目前可以选择使用SAS SFF硬盘来避免配置19"机柜，SAS SFF的容量为：73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive。

SAS SFF(2.5")硬盘是放到fc#5803的IO抽屉中，每个I/O抽屉可配26块硬盘。每个I/O抽屉里有4个硬盘背板，每个硬盘背板内分别有7/6/7/6个可热插拔硬盘槽位。每个硬盘背板有独立的SAS链路，可通过档位开关设置支持1/2/4个LPAR分区。需要注意的是，每个分区需要加配1个fc#5901 SAS卡或2个fc#5903 SAS RAID卡来管理。如果使用fc#5903，只支持最大2个LPAR设置。

配置了SAS硬盘的Power 595机柜形式如下图所示：

突出价值点：Power 595支持不同容量和不同尺寸的SAS硬盘，根据不同的硬盘选择相应的IO抽屉。在满足客户硬盘容量需求的情况下，建议选择2.5"的SAS SFF硬盘，其可以直接放到Power 595的24"IO抽屉(fc#5803)中，不用单独配置19"机柜，可以为客户节省成本和空间。

Top


怎样在Power 595上配置内置光驱和磁带机

解答：

在Power 595上配置内置的光驱和磁带机时，首先需要配置介质抽屉fc#5720 (DVD/Tape SAS External Storage Unit), 同时需要配置一块SAS卡与fc#5720连接, fc#5720默认放置在机柜里34U的位置，如果要放到12U的位置可以配置fc#8449(Media Drawer Placement Indicator - U12)。

fc#5720提供一个磁带机槽位和两个光驱槽位,最多可以配置一个磁带机和两个光驱。当在Power 595上配置了fc#5720时,至少要配置一个光驱。

如果Power 595在做分区配置时, 选配了fc#5803的I/O扩展柜,fc#5720必须连接到一个专用的SAS卡上，可以实现在不同分区之间的浮动,现在e-config工具里默认会配置fc#5901的SAS卡来连接fc#5720，当做多个分区时,一定要配置一块单独的一块SAS卡来连接fc#5720。

突出价值点：在Power 595上配置光驱和磁带机，客户可以根据需要选择fc#5720介质抽屉在机柜中的位置。fc#5720里配置的光驱和磁带机通过一块SAS卡连接，就可以在多个分区之间进行动态的漂移，能为客户节省成本，提高硬件设备的利用率。


配置POWER6-其他

其他

Power 520/550/560/570/595 CPU MEM Disk的配置规则?


Power 520/550/560/570/595 CPU,MEM,DISK 的配置规则?

解答:

Power 520
CPU：1(4.2GHz Only),2,or 4 cores @ 4.2 & 4.7GHz

最大内存容量：16GB(1 core)、32GB(2 cores)、64GB(4 cores)

硬盘：6个3.5-inch SAS DASD bays，最大支持2.7TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

Power 550
CPU：2,4,6,or 8 cores @ 3.5 & 4.2 & 5.0 GHz

最大内存容量：64GB(2 core)、128GB(4 cores)、192GB(6 cores)、256GB(8 cores)

硬盘：6个3.5-inch SAS DASD bays，最大支持2.7TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

Power 560
CPU：4,8,or 16 cores @ 3.6 GHz

最大内存容量：96GB(4 core)、192GB(8 cores)、384GB(16 cores)

硬盘：每个enclosure 6个3.5-inch SAS DASD bays，最大支持5.4TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

Power 570
CPU：2,4,8,12 or 16 cores @ 3.5,4.2,4.4,4.7,5.0GHz；4,8,16,24 or 32 cores @ 4.2GHz

最大内存容量：96GB(2 core)、192GB(4 cores)、384GB(8 cores)、576GB(12 cores)、768GB(16 cores)

硬盘：每个enclosure 6个3.5-inch SAS DASD bays(系统最大24个)最大支持10.8TB本地硬盘，包括73.4/146.8/300/450GB 15kRPM SAS Hot-swap

Power 595
CPU：8-64 cores @ 4.2 & 5.0 GHz

最大内存容量：256GB(1 book)、512GB(2 books)、768GB(3 books)、1024GB(4 books)、1280GB(5 books)、1536GB(6 books)、1792GB(7 books)、2TB(8 books)@4.2GHz

512GB(1 book)、1TB(2 books)、1.5TB(3 books)、2TB(4 books)、2.5TB(5 books)、3TB(6 books)、3.5TB(7 books)、4TB(8 books)@5.0GHz

硬盘：每个fc#5803IO抽屉支持26 hot-swap SFF SAS disk bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive 和146.8GB/300GB 10KRPM SAS SFF Disk Drive

查询相关产品销售手册：

Power 520 销售手册

Power 550 销售手册

Power 560 销售手册

Power 570 销售手册

Power 595 销售手册

Top


配置_POWER7

POWER7

Power 710/730

Power 720/740

Power 750/755

Power 770/780

其他


配置 Power 710/730

Power 710/730

对Power 710/730，请问如何配置适配卡来支持HA

Power 710/730服务器的内置磁盘不支持分离背板的功能

Power 710/730的内存配置及规则 (最近更新)


对Power 710/730，请问如何配置适配卡来支持HA?

解答：

Power 710/730不支持PCI槽位扩展，并且内置只有4个PCIe LP槽位。为了满足PowerHA的各关键配件都要冗余的要求，目前推荐配置如下：

1) 网卡 X 2， HBA X 2，用共享磁盘做心跳；

2) 若可用IVE网口来冗余，可只配置一块网卡，但注意：IVE网口和网卡接口要相同，并且IVE不支持热插拔。

配置如下：

网卡 X 1，HBA X 2，剩下的槽位加串口卡 X 1，心跳走串口线心跳。


Power 710/730服务器的内置磁盘不支持分离背板的功能

解答：

Power 710/730服务器的内置磁盘不支持分离背板的功能。

突出价值点：如果客户在入门级服务器需要分离背板的功能，可以选择Power 720/740服务器；Power 710/730服务器并不支持分离背板的功能，但通过选择fc#5268的磁盘背板可以支持内置磁盘的RAID功能。


Power 710/730的内存配置及规则

解答：

Power 710支持的内存配置及规则如下：

Power 710支持DDR3，1066MHz的内存。

一台Power 710最大支持2个Memory riser card，每个Memory riser card支持4个内存槽位。其中系统默认带一个Memory riser card，另一个Memory riser card需单独配置，其编号为：fc#5265。

Power 710 最大支持8个内存槽位，4组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：2GB，4GB或者8GB；

最小配置1组内存，及最小4GB的内存；

最大内存为64GB；

每个Memory riser card上的内存，必须为相同的内存，不同Memory riser card上的内存可以不同；

Power 710支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)。

Power 730支持的内存配置及规则如下：

Power 730支持DDR3，1066MHz的内存。

一台Power 730最大支持4个Memory riser card,每个Memory riser card支持4个内存槽位。其中系统默认带一个Memory riser card，可需单独选配3个Memory riser card，其编号为：fc#5265。

Power 730 最大支持16个内存槽位，8组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：2GB，4GB或者8GB；

最小内存容量为：8GB；

最大内存为128GB；

每个Memory riser card上的内存，必须为相同的内存，不同Memory riser card上的内存可以不同；

Power 730支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)。

注意：至少需要配置2组（4 DIMMs）单条2GB的内存。


配置 Power 720/740

Power 720/740

Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

Power 720/740的内存配置及规则 (最近更新)


Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆？

解答：

Power 720/740服务器实现内置硬盘分离时，不需要添加额外的线缆。

服务器对内部磁盘进行分离背板的功能，必须包含以下内容：

fc#5618 硬盘背板 -- 支持6个SFF磁盘槽位/SATA DVD/半高磁带机；
fc#5631 磁盘背板分离功能组件。

fc#5631是一个额外的SAS控制器芯片，它可以将#5618磁盘背板上的6个磁盘分割成2组各包含3个磁盘驱动器，并且属于fc#5631 SAS控制器下的3个磁盘支持RAID-10的能力，集成SAS控制器所控制的3个磁盘没有此能力。fc#5631 SAS控制器不占用PCI插槽，不能与磁盘背板fc#5630一起订购，不提供RAID-5/6的能力。

突出价值点：Power 720/740具备磁盘背板分离或者实现RAID功能的Feature，便于客户灵活选择合适的功能。


Power 720/740的内存配置及规则

解答：

Power 720的内存配置及规则如下：

Power 720支持DDR3，1066MHz的内存。

一台Power 720最大支持2个Memory riser card,每个Memory riser card支持8个内存槽位。其中系统默认带一个Memory riser card，可需单独选配1个Memory riser card，其编号为：fc#5604。

Power 720 最大支持16个内存槽位，8组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：4GB(4C)，4GB或者8GB(6C or 8C)；

最小配置1组内存，及最小8GB的内存；

最大内存：64GB(4C); 128GB(6C or 8C)；

可以在每个Memory riser card上配置不同的内存；

Power 720支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)；

如果配置单条8GB的内存(fc#4529)，最少支持2组内存(4 DIMMs)。

Power 740的内存配置及规则如下：

Power 740支持DDR3，1066MHz的内存。

一台Power 740最大支持4个Memory riser card,每个Memory riser card支持8个内存槽位。其中系统默认带一个Memory riser card，可需单独选配3个Memory riser card，其编号为：fc#5604。

Power 740 最大支持32个内存槽位，16组内存FC(每组内存fc包含2根内存条)；

单条内存容量为：4GB或者8GB；

最小配置1组内存，及最小8GB的内存；

最大内存：256GB；

可以在每个Memory riser card上配置不同的内存；

Power 740支持1组内存(2 DIMMs)，2组内存(4 DIMMs)，4组内存(8 DIMMs)，6组内存(12 DIMMs)，8组内存(16 DIMMs)，10组内存(20 DIMMs)，12组内存(24 DIMMs)，14组内存(28 DIMMs)，16组内存(32 DIMMs)；

如果配置单条8GB的内存(fc#4529)，最少支持2组内存(4 DIMMs)。

注意：如果Power 740只配置了一个处理器板卡，此时，最大只支持2个Memory Riser Card，可以单独再选配一个Memory Riser Card。
如果Power 740配置了两个处理器板卡，此时，最大支持4个Memory Riser Card，可以单独再选配三个Memory Riser Card。


配置 Power 750/755

Power 750/755

如何在Power 750上实现硬盘背板的分离

如何配置Power 750三个及以上分区

如何实现Power 750的RAID功能(最近更新)

Power 750/755的内存配置规则


如何在Power 750上实现硬盘背板的分离

解答:

Power 750的硬盘背板分离的配置方式与Power 550的背板分离方式相似。

配置内置磁盘分区功能需要满足以下要求:
1. 配置fc#8340的硬盘背板。
2. 选择一种下面所列SAS卡，配置1个:
fc#5912 PCI-X SAS卡
或fc#5901 PCIe SAS卡
或fc#5904 PCI-X DDR 1.5GB cache SAS RAID卡。

3. 增加1个fc#3669内部SAS线分离硬盘背板，1个fc#3679外部SAS线，fc#3679一头连接fc#3669，另一头连接上面所选SAS卡管理另外一半的磁盘。

Power 750的第一个硬盘通道被集成的控制器控制；第二个硬盘通道由选择的SAS卡，配合fc#3669分离背板的线和fc#3679的线控制。

注意：Power 755不支持硬盘背板分离；Power 750 IBM i不支持硬盘背板分离。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何配置Power 750三个及以上分区

解答:

因为分区数较多，所以我们建议通过fc#5802扩展柜来放CEC之外的分区硬盘。DLPAR的DVD光驱和磁带机选用外置设备7214-1U2/7216-1U2。

下面按3分区为例说明。

配置分析：虽然Power 750的CEC有分离硬盘背板，支持两组硬盘，但在fc#5802扩展柜里面分组硬盘更加简单方便。所以我们选择在CEC里面放一组硬盘，在fc#5802里面放两组硬盘来实现共3分区的方法。

详细配置步骤：

1) 计算所有分区的PCI卡的数量，确定fc#5802的数量。
一个fc#5802扩展柜可以放10张PCIe的卡，最多放18块2.5"(SFF)硬盘，最多分作4分区；

在e-config的Expansions页面上设置fc#5802扩展柜的数量。

注意：对于fc#5802，每个12X环路里面最多有2个扩展柜，Power 750 最多能有2个环路。
对于1个处理器板(8-core)的Power 750，最多有1个12X环路。
对于2个或以上处理器板的Power 750，最多有2个12X环路。

对于那些目前和将来客户都不会在里面放置硬盘的fc#5802，可以更换为fc#5877扩展柜。fc#5877除了不能放置硬盘之外，其他特性与fc#5802完全相同。

2) 配置硬盘3分区*2块＝6块。例如我们选用146GB硬盘 fc#1886 = 6

3) 配置SAS卡，fc#5901 * 3, 其中2块用来在fc#5802里面做2个分区，第3块用来链接外置7214-1U2/7216-1U2。
配置SAS线，fc#3688 * 2, 用来在fc#5802中连接fc#5901到每组硬盘。
这样在fc#5802里面就有支持2分区的两组硬盘。

4) 按照所有分区的卡的需求，在Adapters页面上配置卡。在SOSWOS页面上配置7214-1U2/7216-1U2，注意配置磁带机和DVD光驱。

这样，一台支持3分区的Power 750基本配置完成。

对于更多分区要求，都可以按上述流程来配置，注意要点如下：
1) 每个fc#5802最多支持4分区，注意当前Power 750配置支持的最大分区数。
2) 一般为每分区配置2块硬盘，Power 750上应该选用 fc#188x 的 SFF硬盘。
3) 对SAS卡fc#5901，一般为在fc#5802里面的分区数 + 1, 多余的一个来连接7214-1U2/7216-1U2，来实现DLPAR。
4) 对SAS线fc#3688，一般为在fc#5802里面的分区数。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。但成本略高，适合于较重要的应用场景。


如何实现Power 750的RAID功能

解答:

对于Power750，可以通过如下的方式实现硬盘的RAID功能：

(1)需要配置fc#5679 SAS RAID卡，该卡支持RAID 0,1,5,6和10,并且配置fc#8340的硬盘背板，实现内置硬盘的RAID功能。

(2)fc#5805的SAS RAID控制卡。支持RAID 0,5,6和10，实现对硬盘扩展抽屉(fc#5886)和IO抽屉(fc#5802)上SAS硬盘的RAID功能。

(3)fc#5904的SAS RAID控制卡。支持RAID 0,5,6和10，实现对分离硬盘背板后，第二个通道的内置硬盘的RAID功能和硬盘扩展抽屉(fc#5886)的RAID功能。

突出价值点：多种RAID卡的选择，更灵活的配置，确保系统的高可用性。


Power 750/755的内存配置规则

解答:

Power 750/755的内置配置规则如下：

1.支持DDR3的内存；

2.内存是按照一对内存进行配置的，每个Feature Code为2根内存；

3.每个处理器板卡上支持1,2,4对内存，及支持2,4或者8根内存；不支持3对内存；

4.每个处理器板卡上的内存必须一致（不能混合不同容量和不同频率的内存）；

5.最小的内存容量为8GB（2 X 4GB DIMMs）；

最大的内存容量为：

Power 750：512GB（Power 750支持4个处理器板卡，每个处理器板卡上支持8个内存，单条内存最大容量为16GB）；
Power 755：256GB（Power 755支持4个处理器板卡，每个处理器板卡上支持8个内存，单条内存最大容量为8GB）。


配置 Power 770/780

Power 770/780

如何在Power 770/780上实现硬盘背板的分离

如何实现Power 770/780的RAID功能

在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗 (新增)

Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置 (新增)


如何在Power 770/780上实现硬盘背板的分离

解答:

Power 770和780服务器的每个CEC单元默认即支持磁盘背板分离的功能。每个CEC单元集成有2个SAS磁盘控制器，每个控制器管理三块磁盘，除此之外还有一个独立的媒体控制器，可以独立地控制光驱，使其能够在分区之间浮动。

还有一个选项，可以提供磁盘背板3分区的功能。此时每个CEC单元的两个集成的磁盘控制器各自控制两块磁盘，配合单独配置的一个PCI插槽的控制卡控制剩余的两个磁盘。该3分区的磁盘背板的功能需要如下配件：

Feature Code | 描述
fc#1815 | 内部SAS线，提供三分磁盘背板的功能
fc#3679 | 外部SAS线，连接SAS控制器到机箱背部接口
fc#5901 | SAS控制器

这种磁盘背板3分区的选项fc#1815可以配置到任意一个CEC单元，但不能与内部RAID选项fc#5662在同一CEC混用。

突出价值点：LPAR相对虚拟IO的分区，分区之间更加隔离，一个分区的故障不会影响到其他的分区。同时，Power 770/780的内置DVD支持在多个分区之间浮动。


如何实现Power 770/780的RAID功能

解答:

在Power 770/780中，新添加了内置的RAID子卡fc#5662。该RAID子卡为一块175MB Cache RAID - Dual IOA Enablement Card，支持RAID 0,1,5,6和10。可以实现内置硬盘的RAID功能，也可以实现内置硬盘和一个fc#5886硬盘抽屉中硬盘的RAID功能。

如果需要实现CEC抽屉6块硬盘的RAID功能，需要添加fc#5662，此时，CEC抽屉的6块硬盘不支持背板分离；如下图：

如果需要实现CEC抽屉6块硬盘和一个fc#5886硬盘抽屉12块硬盘的RAID功能，需要添加fc#5662的RAID子卡，fc#1819 SAS线，fc#3686/fc#3687 SAS线，以及fc#5886的12S硬盘抽屉。其中，fc#1819的SAS线主要连接硬盘背板后方的SAS端口；fc#3686/fc#3687为YI的SAS 线，用于连接fc#5886的硬盘抽屉。如下图：

突出价值点：在Power 770/780上，直接可以通过RAID子卡实现内置硬盘和外置硬盘的RAID功能，继承了Power 520/550内置RAID子卡对硬盘做RAID的优势。该RAID子卡不占用PCI槽位，方便了用户的配置和使用。


在实现了背板三分区(triple split DASD backplane)的Power 770 CEC中，可以放置6块SSD硬盘吗

解答：

不可以。

因为在实现了三分区的背板(triple split DASD backplane)上，有两个硬盘槽位由一个不具有写缓存的PCIe SAS控制器控制。而SSD硬盘需要控制器具有写缓存。


Power780上，如果处理器用TurboCore模式，处理器激活数量应该如何配置

解答：

在TurboCore模式下，每颗处理器上会有一半的内核会关闭，这部分内核的L3 cache会供给剩下的内核使用，从而对剩余的内核的性能有一个很大的提升。一般来讲，TurboCore状态下的可使用的内核数，等于处理器内核的激活数，但最多不能超过安装的物理处理器内核的一半。所以在订购一个运行在TurboCore模式下的服务器的时候，要至少多订购一倍的物理处理器内核，但激活不需要多订购。

注意，在e-Config中允许订购一台标示为TurboCore模式，处理器激活数量超过物理处理器内核数一半的服务器。多余出来的处理器激活在TurboCore模式下不会用到，但切换到MaxCore模式下会用到。


配置 p7其他

其他

POWER7服务器 CPU，MEM，DISK的配置规则 (最近更新)

POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项 (新增)

POWER7服务器如何配置3.5英寸的磁盘

POWER7全线产品家族分离背板总结 (新增)


POWER7服务器 CPU，MEM，DISK的配置规则

解答:

Power 710
CPU：4 at 3.0GHz; 6 at 3.7 GHz ; 8 at 3.55GHz
最大内存容量：64 GB(4,6,8 Core)
内置硬盘：3或者6个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 720
CPU：4, 6, 8 at 3.0 GHz
最大内存容量：64 GB(4 Core)、128 GB(6,8 Core)
内置硬盘：6或者8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 730
CPU：8 at 3.0GHz or 3.7GHz; 12 at 3.7GHz; 16 at 3.55GHz
最大内存容量：128 GB(8，12，16 Core)
内置硬盘：3或者6个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 740
CPU：4, 8 at 3.3GHz or 3.7GHz; 6,12 at 3.7GHz; 8,16 at 3.55GHz;
最大内存容量：128 GB(4,6 Core)、256 GB(8,12,16 Core)
内置硬盘：6或者8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 750
CPU：8, 16, 24, 32 at 3.0 GHz，3.3 GHz or 3.55GHz
最大内存容量：128 GB(8 Core)、256 GB(16 Core)、384 GB(24 Core)、512 GB(32 Core)
内置硬盘：8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和1300GB 10KRPM SAS SFF Disk Drive.

Power 755
CPU：32 at 3.3 GHz
最大内存容量：256GB(32 cores)
内置硬盘：8个2.5-inch SAS SFF DASD bays,支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 770
CPU：12, 24, 36, 48 at 3.5 GHz
最大内存容量：目前支持1066 MHz DDR3的内存：512 GB(12 Core)、1TB(24 Core)、1.5TB(36 Core)、2TB(48 Core)
内置硬盘：每个enclosure 6个2.5-inch SAS SFF DASD bays，支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.

Power 780
CPU：16, 32, 48, 64 at 3.8 GHz
8, 16, 24, 32 at 4.1 GHz(TurboCore mode)
最大内存容量：目前支持1066 MHz DDR3的内存：512 GB(12 Core)、1TB(24 Core)、1.5TB(36 Core)、2TB(48 Core)
内置硬盘：每个enclosure 6个2.5-inch SAS SFF DASD bays，支持73.4GB/146GB 15KRPM SAS SFF Disk Drive和300GB 10KRPM SAS SFF Disk Drive.


POWER7入门级服务器Power 710/720/730/740是否可以配置冗余电源的选项

解答：

冗余热插拔冷却风扇是所有新的入门级服务器的标准配置。

冗余热插拔电源，对于Power 710和720服务器是可选配置，对于Power 730和740是标准配置。

突出价值点：冗余风扇即使在入门级服务器也是标准配置，冗余电源针对不同的服务器也有更多的选择。


POWER7服务器如何配置3.5英寸的磁盘

解答：

目前所有POWER7系列服务器CEC自身都没有3.5硬盘槽位，客户如需配置3.5英寸硬盘，可以通过添加fc#5886 EXP12S SAS Disk Drawer来实现。

在添加fc#5886 EXP12S SAS Disk Drawer时，既可以通过CEC自身的外部SAS端口来连接，也可以通过额外添加的SAS控制器或RAID控制器来连接。

针对于具体的POWER7服务器，连接fc#5886的方式如下：

Power 710/730:

可以通过fc#5268硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5278和一根YO的SAS线(fc#3691/3692/3693/3694)来连接。

注意：当为4C的Power 710不支持fc#5886的扩展。

Power 720/740:

可以通过fc#5630硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5278/fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接。

注意：当为4C的Power 720不支持fc#5886的扩展。

Power 750/755:

可以通过fc#8340硬盘背板的外部SAS端口和一根YI(fc#3686/3687)的SAS线来连接，也可以通过额外添加的SAS控制器fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接，或者一对SAS RAID控制器fc#5903和一根X的SAS线(fc#3661/3662/3663)来连接。

Power 770/780:

需要通过额外添加的SAS控制器fc#5901和一根YO的SAS线(fc#3691/3692/3693/3694)来连接，或者一对SAS RAID控制器fc#5903和一根X的SAS线(fc#3661/3662/3663)来连接。

突出价值点：通过添加fc#5886 EXP12S SAS Disk Drawer，提高POWER7系列服务器的灵活性和可扩展性。


POWER7全线产品家族分离背板总结

解答：

不同型号的POWER7服务器，分离背板的方法有差异。具体情况如下：

Power 770/780：

每个背板具有两个SAS控制器，不需添加任何部件，背板已经默认被分成了两部分。如果想把背板分离成三部分，需添加如下三种部件（每种部件各一个）：
fc#1815 - Internal SAS cable providing the triple split
fc#3679 - External SAS cable connecting the SAS controller to a bulkhead port
fc#5901 - SAS controller。
另外，内置光驱可以在多个分区间浮动。

Power 750：

跟Power 550一样，需要添加两根线（fc#3669和fc#3679各一根）和一块卡（fc#5912或fc#5901）。注意： 内置的DVD-RAM无法在多个分区间进行漂移。建议客户在外置的1U2上配置光驱，以使光驱在多分区间浮动。

Power 755：

背板不具有分离的功能。

Power 720/740：

在选择fc#5618背板的基础上，再选择fc#5631，以进行背板分离。fc#5631为内置硬盘提供了第二个SAS控制器，但它不占用PCI槽位。注意： 内置的DVD-RAM由fc#5618上的SAS控制器进行控制，因此无法在多个分区间进行漂移。建议客户在外置的1U2上配置光驱，以使光驱在多分区间浮动。

Power710/730：

背板不具有分离的功能。

Blades PS700/701/702：

背板不具有分离的功能。包括PS702在内，这三款刀片都仅有一个集成的SAS控制器。

突出价值点：POWER7服务器的大部分背板都支持分离功能，以满足客户支持多分区的需求。

Top


配置 其他

其他

System P 服务器如何选配置电源线? (最近更新)

介绍Power服务器上fc#6577的电源线

如何在e-config中选择7316-TF3?

Power服务器上的几种 10 Gigabit的以太网卡有什么不同?

配置FCoE卡时的注意事项

用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？ (最近更新)

新发布的SFF硬盘和SSD 硬盘的特性是什么? 如何配置?

为什么必须要配置一对fc#5805的RAID卡？ (最近更新)

fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？ (新增)

Power中异步卡和串口线的选择 (最近更新)

在System P的HACMP方案里，推荐的e-config配置范例

在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？

fc#5802/5803如何配合主机实现分区功能

Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

Power服务器常用I/O抽屉配置方法

System P服务器都支持哪一些类型的I/O Drawer?

怎样配置fc#5796和fc#5802的IO抽屉

7014-T00/T42/B42机柜PDU和电源线的配置介绍


System P 服务器如何配置电源线

解答:

机器型号 | Rack（R）/ Deskside（D） | 直流（DC）/ 交流（AC） | 电源线 feature code | 备注
System p5
9115-505 | R | AC | 6671/6458 |
9110-51A | R | AC | 6671/6458 |
9119-595 | R | AC | 8694 |
System POWER6
8203-E4A | R | AC | 6671/6458 | 不包括 OEM Rack Option
 | D | AC | 6493 |
8204-E8A | R | AC | 6671/6458 | 不包括 OEM Rack Option
 | D | AC | 6493 |
8234-EMA | R | AC | 6671/6458 |
9117-MMA | R | AC | 6671/6458 |
9125-F2A | R | AC | 8696 |
9119-FHA | R | AC | 8694 |
7047-185 | D | AC | 6493 |
9111-285 | D | AC | 6493 |
System POWER7
8231-E2B | R | AC | 6671/6458 | 不包括Oem rack option
8202-E4B | R | AC | 6671/6458 | 不包括Oem rack option
 | D | AC | 6493 |
8205-E6B | R | AC | 6671/6458 | 不包括Oem rack option
 | D | AC | 6493 |
8233-E8B | R | AC | 6671/6458 |
8236-E8C | R | AC | 6671/6458 |
9117-MMB | R | AC | 6671/6458 |
9179-MHB | R | AC | 6671/6458 |
I/O Drawer
7031-D24 | R | AC | 6671/6458 |
7031-T24 | D | AC | 6493 |
7311-D11 | R | AC | 6459 |
7311-D20 | R | AC | 9911 |
7314-G30 | R | AC | 6458 |
HMC
7042-CR6 | R | AC | 6671/6458 |
7042-CR4 | R | AC | 6671/6458 |
7042-C06 | D | AC | 6493 |
7042-C07 | D | AC | 6493 |
7042-C08 | D | AC | 6493 |
Rack
7014-T00 | N/C | AC | 6491 |
 | N/C | DC |  | 客户自备
7014-S11 | N/C | AC | 6491 |
7014-S25 | N/C | AC | 6491 |
7014-B42 | N/C | AC | 6491 |
7014-T42 | N/C | AC | 6491 |

Top


介绍Power服务器上fc#6577的电源线

解答:

fc#6577是一根新的电源线选择，与原来指定电源线不同，此feature的意思是让工厂来为服务器选择到机柜PDU的合适长度的电源线。

如果服务器和T00,T42机柜在一个订单内，并且服务器指示安装到机柜，则这个feature是必选项。

但订购这个feature会造成服务器安装在机柜内，从工厂运输到客户现场。一般不建议这样运输。

所以建议不使用fc#6577这个电源线。

避免的办法有两个：

1. 若服务器和机柜在一个订单内：

把所有机柜的 Codes->Rack Indicator 更改为 fc#9002(Field Integration Indicator, Ship Empty Rack)，把所有自动配置为fc#6577电源线的服务器的 Codes->Rack Indicator 更改为 fc#4650(Rack Indicator-Not Factory Integrated)。
然后做一下Final Validation，e-config会自动按不使用fc#6577的情况来配置电源线。

2. 把服务器和机柜分在两个订单内配置。


如何在e-config中选择7316-TF3

解答：

在e-config中，有两种选择7316-TF3的方式：1、是单独选择7316-TF3；2、是通过服务器的外设选择7316-TF3，具体的如何选择7316-TF3的方式介绍如下

1.单独选择7316-TF3：

首先在Global setting中选择“Allow Standalone Peripherals”，

其次点击“OK”，回到e-config的主页面，选择“3.Peripherals”，然后双击“Displays-Coax InfoWindow/Flat Panel”

在Available Products 列表中，即可选择7316-TF3,并进行配置

2.在服务器的外设进行配置7316-TF3：

以Power 570服务器为例：
Power 570的硬件配置“SOSWOS”页面，在Available Products列表中，选择7316-TF3，双击后即可进行配置。

具体配置图示参见网站：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=1511239B27000

突出价值点：7316-TF3液晶折叠套件可以放置在机柜中，配置了KVM切换器和相应的连线，可以最多连接128台主机，节省大量空间。

Top


Power服务器上的几种 10 Gigabit的以太网卡有什么不同

解答：

在Power 520/550/560/570/595/720/740/750/755/770/780的配置中，支持四种类型的10Gigabit以太网卡，他们分别是：fc#5769，fc#5772，fc#5721，fc#5732。

下面分别做一个简单的介绍：

fc#5769 10 Gigabit的以太网卡，一个高性能，PCIe的网卡，支持LC标准的接头，支持850nm的多模光纤线(MMF)，支持的距离为300m，该网卡支持IEEE 802.3ae 10GBASE-SR标准。

fc#5721 10 Gb，PCI-X 2.0 DDR的以太网卡，支持多模光纤线(MMF)，62.5um的光纤线支持长度为33m，50um的光纤线长度为300m。光纤线为LC标准的接头，该以太网卡支持IEEE 802.3ae标准。

fc#5772 10 Gigabit PCIe的以太网卡，提供高性能的光纤网卡，支持1310nm的单模光纤线(SMF)，支持距离能长达10千米。支持IEEE 802.3ae标准。

fc#5732 10 Gigabit PCIe的高性能以太网卡。通过铜线缆进行连接，支持的距离为15m，支持IEEE 802.3ae 10GBASE-CX4标准。

在Power710/730的配置中，支持两种类型的10 Gigabit 以太网卡，分别是：fc#5272和fc#5275；
在Power720/740的配置中，支持四种类型的10 Gigabit 以太网卡，分别是：fc#5272，fc#5275，fc#5284，fc#5286。

fc#5272，fc#5275的以太网卡均为PCIe Low-Profile(LP)类型的卡，可以用于Power710/730的PCIe Low-Profile槽位，及Power720/740的fc#5610(PCIe Riser Card Gen1) 或者fc#5685（PCIe Riser Card Gen2）的PCI扩展卡上。

fc#5284，fc#5286的以太网卡均为PCIe2 Low-Profile（LP）类型的卡，可以用于Power720/740的PCIe2 Low-Profile槽位，及Power720/740的fc#5685（PCIe Riser Card (Gen2)）的PCI扩展卡上。

下面将对fc#5272，fc#5275，fc#5284，fc#5286这四种10 Gigabit 以太网卡做一个简单的介绍：

fc#5272：PCIe LP 10GbE CX4 1-port Adapter，该卡与fc#5732 PCIe的网卡功能类似，可参考fc#5732的介绍；
fc#5275：PCIe LP 10GbE SR 1-port Adapter，该卡与fc#5769 PCIe的网卡功能类似，可参考fc#5769的介绍；
fc#5284：PCIe2 LP 2-port 10GbE SR Adapter，该卡为双端口，PCIe Gen2的Low Profile 10GbE网卡，其提供2个 10Gb以太网SFP+ SR端口，支持最远300m的光纤线连接。
fc#5286：PCIe2 LP 2-Port 10GbE SFP+ Copper Adapter，该卡为双端口，PCIe Gen2的Low Profile 10GbE网卡, 其提供2个10Gb以太网SFP+ copper twinax端口，支持最远5m的线缆连接。

突出价值点：多种10 Gigabit 以太网卡，提供了不同模式，不同接口，不同距离的选择，在配置上更灵活，适用于各种不同的需求。


配置FCoE卡时的注意事项

解答：

一般注意事项同10GB 以太网卡或者8GB HBA卡。

此外还要考虑：
a) 要确保带宽能够满足以太网+光纤通道的峰值流量之和；
b) 要考虑单端口的最大的以太网负载性能(吞吐量和延迟)；
c) 对操作系统的需求和限制，尤其是IBM i；
d) 确保环境提供FCoE交换机(除非只有直连方式)。

突出价值点：FCoE能减少数据中心的接口卡、电缆和网络设备，从而使数据中心变得比较简单、绿色环保。在一些大公司，如果能减少电缆数量，将会对空气流动产生积极作用，并减少降温成本。


用e-config配置IBM Power System系列服务器中的固态盘SSD时，有哪些注意事项？

解答：

有5种不同的Features，根据服务器的差别配置是有区别的：

Feature Code | Power server 服务器
fc#8273 | JS23/43 刀片
fc#1890 or fc#1909(i)SFF | Power 520/550/710/720/730/740/750/755/770/780 CEC抽屉（fc#8346/fc#8340）
fc#1995 or fc#1996(i) | Power 710/720/730/740/750/770/780
fc#3586 or fc#3587(i) | Power 560/570 CEC抽屉 或者 fc#5886扩展抽屉

配置时我们要注意以下几点：
1) SSD 是不兼容fc#5900和fc#5901和fc#5912卡的；
2) fc#1890 和 fc#1909 是可以配置在Power 520/550/710/720/730/740/750/755/770/780的CEC抽屉以及fc#5802和fc#5803的IO抽屉里；
3) fc#3586和fc#3587是不可以配置在Power 520和Power 550CEC里；
4) fc#5886的扩展抽屉最多支持8块SSD盘，在fc#5886里也不可以混SSD和HDD；包含着SSD的fc#5886不可以再串接其他的fc#5886，也不可以连接到Power 520/550 CEC上的外置接口；
5) SSD和HDD不可以混合在同一个RAID array中；
6) 当Power 520或者Power 550配置分离的硬盘底板时, SSD和HDD是可以被分别安放在左右两边不同的底板域中，但是不可以混合在同一边的底板域里；
7) 当Power 520或者Power 550配置没有分离功能的硬盘底板时, SSD和HDD是可以被混合安放在一个底板里；
8) SSD和HDD的盘是不可以混合在一起做镜像的；
9) 当将SSD放到fc#5802和fc#5803的IO抽屉中，一个抽屉最大支持9块SSD硬盘，且必须通过一对fc#5903/5805的SAS RAID卡连接；
10)fc#1995/fc#1996主要放置到fc#2053/2055的 PCIe RAID & SAS Adapter上。每块卡支持1,2 or 4块fc#1995/fc#1996的SSD硬盘。

突出价值点：固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。

Top


新发布的SFF硬盘和SSD 硬盘的特性是什么？如何配置

解答：

（1）SFF硬盘

Small Form Factor ，2.5英寸硬盘，比HDD硬盘更加节能。

支持的配置环境：
Power 520/550 CEC,Power 710/720/730/740/750/755/770/780 , fc#5802和fc#5803 PCIe 12X I/O Drawer。

现在可以配置的SFF 硬盘容量：
for AIX
-fc#1882 146GB 10K rpm；
-fc#1885 300GB 10K rpm；
-fc#1883 73GB 15K rpm；
-fc#1886 146GB 15K rpm；
for i
-fc#1884 69GB 15K rpm；
-fc#1888 139GB 15K rpm。

（2） SSD硬盘

Solid State Drive (SSD)，固态硬盘。固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。
容量：69GB(fc#1890 or fc#1909(i)SFF/fc#3586 or fc#3587(i))/177GB(fc#1995 or fc#19969(i))

支持的环境：
69GB的SSD硬盘支持的硬件环境：Power 520/550/560/570/575/595/710/720/730/740/750/755/770/780/EXP 12S SAS Drawer/fc#5802/fc#5803；
177GB的SSD硬盘支持的硬件环境：Power 710/720/730/740/750/755/770/780,需要放置到fc#2053/2054/2055的 PCIe RAID & SAS Adapter上。

支持的RAID 配置：RAID 0和5。

配置规则：
internal controller：支持SAS和SSD的混合配置；
internal RAID:不支持SAS和SSD的混合配置；
分离背板：不支持SAS 和SSD 混合配置在一组内；
EXP 12S SAS Drawer：支持8块SSD 硬盘，4个槽位空闲；不支持混合设备；
fc#5802/fc#5803:每对fc#5903的卡，最大8块SSD硬盘；
每块fc#2053/2054/2055的 PCIe RAID & SAS Adapter，支持1,2 or 4块fc#1995/fc#1996的SSD硬盘。

突出价值点：SFF硬盘比HDD硬盘更加节能。固态硬盘具有性能更高，更绿色，更少的功耗及发热等特点。

Top


为什么必须要配置一对fc#5805的RAID卡？？

为什么必须要配置一对fc#805的RAID卡？

解答：

只有存在两个fc#5805 Controller 时，fc#5805 的RAID Cache才能激活。

如果任何一个fc#5805 Controller 的微码检测不到另一个fc#5805 RAID 卡，那么不能激活fc#5805的RAID Cache。

当配置了两个fc#5805 Controller，就可以在两个fc#5805 Controller中都记录写Cache数据和RAID校验的信息，因此，当一个Controller出问题时，RAID Cache能进行数据恢复。

注意：fc#5902和fc#5903的SAS RAID卡也必须成对的配置，但是这两块卡已经停产，目前由fc#5805的SAS RAID 替代。


fc#5805 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter) 与 fc#5903 (PCIe 380MB Cache Dual - x4 3Gb SAS RAID Adapter)有何区别？

解答：

尽管fc#5805与fc#5903的有着相同的CCIN号(574E)和功能，但两者还是有区别的：

由于fc#5805上的电池比fc#5903上的更薄，fc#5805整块卡的厚度比fc#5903要小。

注意：

1. Power 720/740上的PCIe插槽比其它机器型号的PCIe插槽要紧，所以Power 720/740上只能使用fc#5805，不能使用fc#5903。但是，在能使用fc#5903的地方，都可以使用fc#5805。

2.fc#5903已于2011年1月7日停产。


Power中异步卡和串口线的选择

解答：

目前，在e-config中，可以配置的异步卡为fc#5785，fc#5277：

fc#5785: 4 Port Async EIA-232 PCIe Adapter,它是一个4口，EIA-232标准的异步卡，EIA-232为一个9针的接口。

fc#5277: PCIe LP 4-Port Async EIA-232 Adapter, 它是一个4口，EIA-232标准的异步卡，EIA-232为一个9针的接口，其功能与fc#5785类似，但是为PCIe LP的接口，只能用于Power 710/720/730/740上的PCIe LP 槽位。

异步卡的串口线有如下种类：

fc#3124: Serial-to-Serial Port Cable for Drawer/Drawer,3.7米的串口线，该线的两端分别提供了一个25针的连接器；

fc#3125：Serial-to-Serial Port Cable for Rack/Rack，8米的串口线，该线的两端分别提供了一个25针的连接器；

fc#3927：Serial Port Null Modem Cable, 9-pin to 9-pin, 3.7M，3.7米的串口线，该线两端分别提供了一个9针的连接器；

fc#3928：Serial Port Null Modem Cable, 9-pin to 9-pin, 10M，10米的串口线，该线两端分别提供了一个9针的连接器。

通常，两台设备在做PowerHA时，除了选择异步卡还会选择相应的串口线。

对于fc#5785/fc#5277的4口异步卡，有两种类型的串口线可以选择：

1.fc#3124或者fc#3125 的串口线，此时，需要配一个9针到25针的转换头：

fc#3925：Serial Port Converter Cable, 9-Pin to 25-Pin，9针到25针的转换头，通过这个转换头，可以将fc#3124或者fc#3125的串口线连接到异步卡fc#5785/fc#5277上。

2.fc#3927或者fc#3928的串口线。

查询：Sales Manual

Power 产品销售手册查询

突出价值点：在做PowerHA的时候，强烈推荐配置一个非IP网络的心跳的方式，其中串口心跳是最常见的方式之一。心跳机制用来监控集群中节点的状态，进行节点间信息通信，故障判断，事件触发等等重要作用。新推出的fc#5785/fc#5277的4口PCIe异步卡，能够提供更高的性能，并可以用于多款PCIe的IO抽屉中。

Top


在System P的HACMP方案里，推荐的e-config 配置范例

解答:

配置建议：(HACMP相关部分)

1. 双以太网卡
推荐使用双卡，以实现网卡的冗余。双网卡并不是HACMP的最小配置，但是使用双网卡可以在某个网卡失败的时候只做本机的网卡切换，而不必做主机切换。
推荐连接双以太网交换机，避免网络的单点故障。

2. 双HBA卡，避免HBA卡的单点故障。

3. 双SAN 交换机，避免交换机的单点故障。

4. 串口卡和心跳线，用于建立第二网络，传递心跳信息，避免在IP网络失败的情况形成主机孤岛。

5. 每台机器配置1套HACMP软件

注意：

1. 如果是两台不同类型的System P服务器之间做双机，一定要保证节点之间操作系统以及HACMP软件版本的完全一致性。

2.如果客户的环境不属于上面所描述的案例，或者情况复杂，则需要分别考虑IP 、心跳、存储等规划内容，具体请参考 《High Availability Cluster Multi-Processing for AIX 5L Planning Guide》。

3.如果客户使用的不是Ethernet 网络，HACMP支持的网络参考：《High Availability Cluster Multi-Processing for AIX 5L Planning Guide》

4.如果客户不想使用串口心跳，HACMP支持的心跳方式参考：《High Availability Cluster Multi-Processing for AIX 5L Planning Guide》

所需资源和渠道的详情：
参考书目: High Availability Cluster Multi-Processing for AIX 5L Planning Guide Version 5.4
书号:SG24-6769-00
地址:http://www.redbooks.ibm.com/redbooks/pdfs/sg246769.pdf

突出价值点：HACMP是Power平台上的一个成熟的容灾方案，可以支持到最多32个节点，最多两个站点的互相热备灾备，是广大行业关键应用的很好的一个选择。

Top


在e-config配置工具中PowerVM各版本在不同机型上对应的Feature Code编号以及如何配置？

解答:

打开相应Power机型，在分区(CSP/LPAR)子项中找到PowerVM各版本（Feature Code参见下面的列表），它的数量与被激活处理器的数量必须一致.

POWER6 | Express (3 Micro-partitions, VIOS/IVM, Lx86) | Standard (Full Micro-partitioning) | Enterprise (Live Partition Mobility for AIX & Linux)
9119 FHA | NA | #7943 | #8002
9125 F2A | NA | #7949 | #8024
9117 MMA | NA | #7942 | #7995
8234 EMA | NA | #7942 | #7995
8204 E8A | #7983 | #7982 | #7986
8203 E4A | #7983 | #8506 | #8507
8231 E2B | #5225 | #5227 | #5228
8202 E4B | #5225 | #5227 | #5228
8205 E6B | #5225 | #5227 | #5228
8233 E8B | #7793 | #7794 | #7795
8236 E8C | NA | NA | NA
9117 MMB | NA | #7942 | #7995
9179 MHB | NA | #7942 | #7995
7998 61X | NA | #5409 | #5649
7998 60X | NA | #5406 | #5606
7778 23X | NA | #5429 | #5607
8406 70Y | #5225 | #5227 | #5228
8406 71Y | #5225 | #5227 | #5228


fc#5802/5803如何配合主机实现分区功能

解答：

fc#5802

IO抽屉fc#5802有4个磁盘的背板，其中两个为4块硬盘一个通道，两个为5块硬盘一个通道；

fc#5802可以支持1个磁盘通道， 18块硬盘；2个磁盘通道，每个通道9块硬盘；4个磁盘通道，其中2个通道4块硬盘，2个通道5块硬盘；通道数量是通过IO抽屉上有个Mode Switch进行选择的。

注意一点，fc#5802的硬盘通道需要添加SAS Adapter。

4个通道的配置情况：

需要4个SAS PCIe卡+4根fc#3688的AT线。

2个通道的配置情况：

需要2个SAS PCIe卡+2根fc#3688的AT线。

1个通道的配置情况：

需要1个SAS PCIe卡+1根fc#3688的AT线。

在e-config中，默认只会选择1根fc#3688的AT线，当大于1个通道的时候，需要添加相应数量的AT线来实现多个硬盘通道。

fc#5803

IO抽屉fc#5803是适用于Power 595，它和fc#5802的功能类似，但是它支持的通道的硬盘数和fc#5802不同；fc#5803的4个磁盘背板，其中两个为7块硬盘一个通道，两个为6块硬盘一个通道。

fc#5803可以支持一个磁盘通道，26块硬盘；2个磁盘通道，每个通道13块硬盘；4个磁盘通道，其中2个通道7块硬盘，2个通道6块硬盘；通道数量是通过IO抽屉上的Mode Switch进行选择的。fc#5803的磁盘通道需要添加SAS Adapter实现，其配置方式和fc#5802相似。

fc#5802/fc#5803支持的硬盘均为2.5英寸的SFF SAS硬盘。

突出价值点：fc#5802/5803 使用2.5"硬盘，带有PCIe插槽，支持4组硬盘。是目前性能最好的I/O drawer. 具有硬盘槽位多，PCIe槽位多，支持的分区多的优点。

Top


Power520/550/750上的GX卡 fc#5609/fc#5616有什么区别，配置规则如何？

解答:

Power 520/550/750 目前支持两种GX 12X接口卡：fc#5609和fc#5616,可用来提供GX 12X接口以连接12X的I/O扩展柜。

其中fc#5616是SDR的，fc#5609是DDR的，DDR的数据传输速度是SDR的两倍；

fc#5616和fc#5609均支持fc#5796,fc#5802和fc#5877的IO抽屉。

在配置时要注意：

1-core的Power 520是不能配置GX卡的；
2-core的Power 520/550，8-core的Power750只能配置fc#5616，及当配置一块处理器卡时，只能配置fc#5616；
只有4-core及以上的Power 520/550,16-core及以上的Power 750才可以配置/fc#5609，及当Power 550/750配置两块及以上处理器卡时，可以配置fc#5609。

突出价值点：fc#5609 12X Adapter提供更高的带宽，其数据传输速度是fc#5616 12X Adapter的两倍。


POWER服务器常用I/O抽屉配置方法

解答：

 | 外观 | 容量 | 主机接口卡 | 数据连线 | MAX / Loop(Adapter)
fc#5886 | 2U 19" | 12块SAS硬盘 | fc#5912/fc#5901/fc#5278( PCIe LP) fc#5902/fc#5903 fc#5904/fc#5908 | SAS(YO)线 SAS(EE)线 （数量见后面说明及图示） | 4
fc#5796 | 4U 19"半宽 | 6个266MHz PCI-X插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 4
fc#5802 | 4U 19" | 18个SAS SFF硬盘+10个PCIe插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 2
fc#5877 | 4U 19" | 10个PCIe插槽 | Power 520, 550,750: fc#5616/5609 Power 560, 570: fc#1802 Power 720,740: fc#5615 Power 770,780: fc#1808 | N+1根12X线 SPCN线 | 2
7311-D20 | 4U 19" | 12块SCSI硬盘+7个133MHz PCI-X插槽 | fc#5614(Power 520, 550) fc#1800(Power 560, 570) | N+1根RIO-2线 SPCN线 | 6

注意:

1. N为I/O抽屉个数
2. SPCN线的数量是服务器内所有有SPCN接口的I/O抽屉(e.g. fc#5796, fc#5802, 7311-D20)的数量+1
3. fc#5609卡仅支持4-core及以上的power 520, 550,750，并且一台服务器最多一块；
4. fc#5615卡仅支持6-core及以上的Power 720，并且Power 720最大支持一块fc#5615；
5. 一块fc#5912/fc#5901最多可接4台fc#5886，需2根SAS(YO)线，4根SAS(EE)线；连线如图1所示；
6. 若要求每个fc#5886支持一个LPAR，则需要每个fc#5886配置1个fc#5912/fc#5901/fc#5278(LP PCIe)+1根SAS Cable(YO), 连线如图2所示；
7. 如果要求fc#5886中的硬盘做RAID，需要把fc#5912/fc#5901改为成对的fc#5902/fc5903，相应连线会变为SAS Cable(X)，fc#5902/fc#5903支持RAID 0, 5, 6, 10，连线如图3所示；
8. 12X抽屉和RIO-2抽屉不能混在一个IO环路中, fc#5796和fc#5802不能混在一个IO环路中；
9. fc#5802和fc#5877可以在一个环路中；
10. 每个fc#5796需要配置一块fc#6446或者fc#6457；如果主机和抽屉在3米，抽屉和抽屉在1.5米之内，选用fc#6446即可；如果超过这个距离，需要选配fc#6457(带有中继器)。

图1: 1块fc#5912/fc#5901连接4台fc#5886

图2: 1块fc#5912/fc#5901连接1台fc#5886

图3: 2块fc#5902/fc#5903连接1台fc#5886实现RAID

Top


System P系列服务器都支持哪一些类型的I/O Drawer

解答:

Server I/O Drawers/Towers

Drawer | Server Loop Attachment | PCI Slots per Drawer | Disk Bays per Drawer | POWER6 Availability | Max Drawers per Loop | Footprint
#5802 | 12X DDR 6 | 10 PCIe | 18 SFF SAS | Y | 2 | 19" rack
#5877 | 12X DDR 6 | 10 PCIe | 0 | Y | 2 | 19" rack
#5803 | 12X DDR 6 | 20 PCIe | 26 SFF SAS | Y | 1 4 | 24" rack
#5873 | 12X DDR 6 | 20 PCIe | 0 | Y | 1 4 | 24" rack
7311-D20 | RIO-2 | 7 PCI-X | 12 SCSI | limited, mig | 6 | 19" rack 4U
#0595 | RIO-2 1 | 7 PCI-X | 12 SCSI | w/d, mig | 6 | 19" rack 5U
#5095 | RIO-2 1 | 7 PCI-X | 12 SCSI | w/d, mig | 6 | Tower
7314-G30 | 12X SDR | 6 PCI-X DDR | 0 | w/d, mig | 4 | 19" rack 1/2 4U
#5796 | 12X SDR | 6 PCI-X DDR | 0 | Y | 4 | 19" rack 1/2 4U
7311-D11 | RIO-2 | 6 PCI-X | 0 | w/d, mig | 4 | 19" rack 1/2 4U
#5790 | RIO-2 1 | 6 PCI-X | 0 | Y 7 | 6 | 19" rack 1/2 4U
#5094 | RIO-2 1 | 14 PCI-X | 15/45 SCSI | w/d, mig | 6 | Tower
#5294 | RIO-2 1 | 28 PCI-X | 90 SCSI | w/d, mig | 3 2 | 19" rack 36U
#5096 | RIO-2 1 | 14 PCI-X | 0 | w/d, mig | 6 | Tower
#5296 | RIO-2 1 | 28 PCI-X | 0 | w/d, mig | 3 2 | 19" rack 36U
#0588 | RIO-2 1 | 14 PCI-X | 0 | w/d, mig | 6 | 19" rack 8U
#5088 | RIO-2 1 | 14 PC-X | 0 | w/d, mig | 3 5 | Tower
EXP24 7031-D24 | n/a | 0 | 24 SCSI | w/d, mig | n/a | 19" rack 4U
EXP24 #5786 | n/a | 0 | 24 SCSI | Y 10 | n/a | 19" rack 4U
EXP 12S #5886 | n/a | 0 | 12 SAS | Y | n/a | 19" rack 2U
7040-61D 9 | RIO-2 | 20 PCI-X | 16 SCSI | w/d, mig | 1 4 | 24" rack
#5791 9 | RIO-2 | 20 PCI-X | 16 SCSI | w/d, mig | 1 4 | 24" rack
#5794 9 | RIO-2 | 20 PCI-X | 8 SCSI | w/d, mig | 1 4 | 24" rack
#5797 3 9 | 12X | 14 PCI-X DDR, 6 PCI-X | 16 SCSI | Y | 1 4 | 24" rack
#5798 3 9 | 12X | 14 PCI-X DDR, 6 PCI-X | 16 SCSI | Y | 1 4 | 24" rack

1 System i servers used the term “HSL” instead of “RIO”. The terms are interchangeable.
2 Requires two positions on the loop. Physically is two I/O towers in a 19” 36U rack
3 #5797 and #5798 same drawer except #5797 supports longer 12X cables and can be located in an expansion rack. #5798 can not be in expansion rack, only the CEC frame.
4 Logically two drawers in one 4-U foot print. Can be configured with two loops per drawer or one loop per drawer
5 5088 bolted to top of 5094 tower. Thus combination of 5094 + 5088 require 2 positions on loop
6 Runs at DDR speed assuming CEC GX adapter and 12X cable are also DDR. Otherwise runs at SDR.
7 Withdrawn for new orders on Power 595 (9119-FHA), but can be ordered as RPQ 8Q4004
8 Announced withdrawal for Feb 2010. Already withdrawn on Power 595 (9119-FHA), but can use RPQ 8Q4004 8 Withdrawn from marketing effective November 2009
9 Disk bays used by drives formatted for AIX/Linux, not IBM i formatted drives
10 Drawer avaible for existing SCSI disk migration. New SCSI disk withdrawn from marketing
w/d Withdrawn from marketing, not orderable from IBM Manufacturing
Limited 7311-D20 redefined for new orders to always require specific telephony adapters and to require an RPQ. Thus this drawer effectively withdrawn except for special telephony configurations
nan Not Available New – can’t/shouldn’t be ordered with a Power System. Use either equivalent feature code I/O drawer or use newer technology drawer (12X or SAS)
mig Migrate Attachment of existing I/O units supported
Y New I/O drawers orderable from IBM Manufacturing
n/a Not applicable

Server I/O Drawer Attachment

Server Drawer | 520 1-core (0 Loops) | 520 2-,4-core (0-2 Loops) | 550 0-2 Loops | 560 (0-3 Loops) | 570 0-8 Loops | 575 0-1 Loops | 595 1 1-32 Loops
Max 2 all RIO | 0 | 12 | 12 | 18 | 48 | 0 | 95 (IBM i), 12 (AIX)
Max 2 all 12X | 0 | 8 | 8 | 12 | 32 | 1 | 32
#5802 | 0 | Max 4 | Max 4 | Max 6 | Max 16 | 0 | 0
#5877 | 0 | Max 4 | Max 4 | Max 6 | Max 16 | 0 | 0
#5803 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 32
#5873 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 31
7311-D20 | 0 | Max 12 | Max 12 | Max 18 | Max 48 | 0 | 0
#0595 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5095 | 0 | Max 12 | Max 12 | 0 | 0 | 0 | 0
7314-G30 | 0 | Max 8 | Max 8 | Max 12 | Max 32 | 0 | 0
#5796 | 0 | Max 8 | Max 8 | Max 12 | Max 32 | 0 | 0
7311-D11 | 0 | 0 | 0 | 0 | Max 20 | 0 | 0
#5790 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5094 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5294 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
#5096 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5296 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
#0588 | 0 | Max 12 | Max 12 | 0 | Max 48 | 0 | Max 95
#5088 | 0 | Max 6 | Max 6 | 0 | Max 24 | 0 | Max 47
EXP24 7031-D24 | 0 | Max 12 | Max 24 | Max 26 | Max 60 | 0 | 0
EXP24 #5786 | 0 | Max 12 | Max 24 | Max 26 | Max 60 | 0 | Max 110
EXP 12S #5886 | 0 | Max 24 | Max 48 | Max 110 | Max 110 | Max 98 per node | Max 185
7040-61D | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5791 | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5794 | 0 | 0 | 0 | 0 | 0 | 0 | Max 12
#5797 | 0 | 0 | 0 | 0 | 0 | 0 | Max 30
#5798 | 0 | 0 | 0 | 0 | 0 | Max 1 / node | Max 30

1 At least one I/O drawer with PCI slots is required. After May 2009 the #5803/5873 is highly recommended as that initial drawer. Between Nov 2008 and May 2009, the 12X #5797/5798 was highly recommended for that initial drawer. Prior to Nov 2008, at least one #5791 (AIX/Linux) or #5790 (IBM i) was required
2 Though you can mix RIO and 12X I/O drawers on systems with two or more loops, within a loop it must be all RIO drawers or all 12X drawers. Thus if you add 12X loops, you lower the maximum number of RIO drawers, and vice versa. Note this maximum does not include I/O drawers with no PCI slots such as disk-only drawers or removable media drawers.
12X I/O drawers with PCIe slots can not be mixed on the SAME loop as 12X I/O drawers without PCIe slots.

Server Drawer 1 | Power 710 / 730 Express 0 Loops | Power 720 Express 0-1 Loops | Power 740 Express 0-2 Loops | Power 750 Express 0-2 Loops | Power 755 0 Loops | Power 770 0-8 Loops | Power 780 0-8 Loops
#5802 | 0 | Max 24 | Max 4 | Max 4 | 0 | Max 16 | Max 16
#5877 | 0 | Max 24 | Max 4 | Max 4 | 0 | Max 16 | Max 16
7314-G30 | 0 | Max 44 | Max 8 | Max 8 | 0 | Max 32 | Max 32
#5796 | 0 | Max 44 | Max 8 | Max 8 | 0 | Max 32 | Max 32
EXP24 7031-D24 | 0 | Max 124 | Max 24 | Max 24 | 0 | Max 60 | Max 60
EXP24 #57862 | 0 | Max 124 | Max 24 | Max 24 | 0 | Max 60 | Max 60
EXP 12S #5886 | 83 | Max 284 | Max 28 | Max 48 | 13 | Max 110 | Max 110

1 Though you can mix 12X PCI-X DDR I/O drawers with 12X PCIe I/O drawers on a system with two or more loops, within a loop it must be all PCIe or all PCI-X DDR I/O drawers.
2 In addition to the #5786, the EXP24 #5787 Disk Tower is supported, but not orderable, on the Power 750.
3 Disk-only I/O drawers are not supported on 4-core Power 710 Express configurations.
4 12X I/O drawers or disk-only drawers are not supported on 4-core Power 720 Express configurations.

参考链接：http://www-03.ibm.com/systems/power/hardware/reports/factsfeatures.html

Top


怎样配置fc#5796和fc#5802的IO抽屉

解答：

一．对于服务器配置fc#5802/fc#5877的IO抽屉：

在Power 520，550，560，570，720，740，750, 770,780上均可以配置fc#5802/fc#5877的IO抽屉,fc#5802的IO抽屉可以放置18块SFF SAS硬盘和10个PCIe的槽位；fc#5877的IO抽屉可以放置10个PCIe的槽位，下面将详细介绍在不同产品上配置fc#5802/fc#5877的配置方式：

Power 520/550/750: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#5616/5609) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5802/fc#5877数量+1)。
Power 560/570: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#1802) + 2根12X DDR cable + 2根SPCN cable(每个环路的12X DDR cable和SPCN cable的数量为fc#5802/fc#5877数量+1)。
Power 720/740: 配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#5615) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5802/fc#5877数量+1)。
Power 770/780:配置1个fc#5802/fc#5877时需要同时配置GX Loop Adapter (fc#1808) + 2根12X DDR cable + 2根SPCN cable(每个环路的12X DDR cable和SPCN cable的数量为fc#5802/fc#5877数量+1)。

每个GX Loop Adapter的一个环路支持最大2个fc#5802/fc#5877。

二. 对于服务器配置fc#5796的IO抽屉：

在Power 520，550，560，570, 720, 740, 750, 770,780上均可以配置fc#5796的IO抽屉,该IO抽屉可以放置6个PCI-X的槽位。下面将详细介绍在不同产品上配置fc#5796的配置方式：

Power 520/550/750: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#5616/5609) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 560/570: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#1802) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 720/740: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#5615) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。
Power 770/780: 配置1个fc#5796时需要同时配置GX Loop Adapter (fc#1808) + 12X Channel Attach Adapter (fc#6446或fc#6457) + 2根12X DDR Cable + 2根SPCN Cable(每个环路的12X DDR Cable和SPCN Cable的数量为fc#5796数量+1)。

每个GX Loop Adapter的一个环路支持最大4个fc#5796。

注意：

1C的Power 520不支持IO抽屉的扩展；
4C的Power 720不支持IO抽屉的扩展；
4C的Power 520，或者4C及以上的Power 550/750才可以配置fc#5609的12X GX的卡；
Power 720最大支持一个IO 环路。

另外：用于I/O抽屉fc#5796上两种12X Channel Attach卡（fc#6446和fc#6457），主要是用在I/O柜上以提供12X接口的，其区别如下：

fc#6446没有转发器(Repeater)而fc#6457有转发器(Repeater)。

在使用时要注意,fc#6446只能用在单个机柜之内的I/O柜的连接，主机和I/O柜之间不能超过3米,I/O柜之间互连时,如果两个I/O柜上都用fc#6446,则它们之间距离不能超过1.5米,如果只有一个I/O柜用fc#6446(另一个用fc#6457)则距离不能超过3米。fc#6457可以用于放置在两个不同的机柜之间的I/O柜的互连,当I/O柜上都用fc#6457时,主机与I/O柜或两个I/O柜之间允许的最大连接距离是8米。

突出价值点：对于POWER6/POWER7的服务器，提供了PCI-X和PCIe槽位的IO抽屉，可以根据客户的不同需求，进行PCI槽位的扩展，提高了POWER6/POWER7服务器的扩展能力。


7014-T00/T42/B42机柜PDU和电源线的配置介绍

解答：

7014-T00/T42中，有两种PDU可以选择，均为C13的标准：

fc#7188/9188:提供12个接口，机柜默认会配置一个fc#9188的PDU，需要手动配置fc#7188；

fc#5889/7109:提供12个接口，为智能的PDU，可以监测PDU的耗电情况。

所配置的电源线为默认的fc#6491，建议使用冗余的PDU，且PDU数量与电源线数量相同。

7014-B42机柜，有两种标准的PDU，C13和C19的标准。该机柜能同时装入刀片机箱和小型机，放置不同的设备，需要配置不同的PDU。

能放入B42机柜的小型机主要有：POWER5机型: p5 505/505Q、p5 510/510Q、p5 520/520Q、p5 550/550Q、p5 560Q、p5 570；POWER6机型：Power 520、 Power 550、Power 560、Power 570；POWER7机型：Power 710、Power 720、Power 730、Power 740、Power 750、Power 755、Power 770、Power 780。

当放置小型机或者刀片机箱BCS(电源插头为C14标准的fc#4505)时，需要在B42机柜里配置fc#7188/fc#7109的PDU(C13)和fc#6491的电源线；
当放置刀片机箱BCH或者BCS(电源插头为C20标准的fc#4548)时，需要在B42机柜里配置fc#7189的PDU(C19)和fc#6491的电源线。

建议使用冗余的PDU，且PDU的数量和电源线的数量相等。

突出价值点：目前可以配置三种19英寸的IBM机柜，根据不同插头标准，选择不同类型的PDU。T42机柜里，能够配置智能PDU(iPDU)，Active Energy Manager与智能PDU(iPDU)或EnergyScale配合使用，提供最广泛的电源管理。

Top


附录 Power

附录

Power 服务器售前常用工具

1. IBM Power Systems Competitive Sales Tool Version 19.1 (January 19, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/B48EB3335EFE53390025730900271CD0?Opendocument?OpenDocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件

2. TCO/ROI估算工具

一个非常好的TCO/ROI评估工具 - Alinean SCON, 该工具通过数字、图表的方式，直观地展现使用IBM的服务器整合方案可以为客户带来怎样的成本降低和高的投资回报率。Alinean作为第三方工具，不隶属任何厂商，因而更中立，合作伙伴、最终客户都可自行注册使用。

下面列出了工具最近更新的部分信息：

1. 在Questionnaire 页面，添加了更多的信息：
System Group扩展到10个；
Workload Group输入信息进行了更新；
Additional Enterprise Software部分添加了新的软件：
（1）Data Management
（2）Application Serving
（3）Virtualization (includes Systems Software)
（4）Systems Management
（5）Threat Mitigation
（6）Email Applications
2. 在Solution页面，添加了高可用性的选项；在System Management选项里，添加了VMControl子项；
3. 在TCO Analysis页面，Server Hardware Costs worksheet也进行了更新；
4. 添加了对输出报告的翻译工具，可将针对存储和服务器的IBM Systems Consolidation Evaluation Tool的输出报告翻译成简体中文的版本。

工具链接：https://roianalyst.alinean.com/stg/

工具的介绍，可以参考网络课堂《您可以使用的TCO/ROI估算工具 》。

3.在线Power系列服务器产品支持，热点包括：

(1) IBM Power System 常见问题汇总：IBM工程师常遇到的问题汇总

(2) IBM Power System 产品配置常见问题汇总

(3) 网络课堂：以Flash动画的方式对当前热门技术进行介绍，甚至包括用e-Config一步一步的教您如何配置一台服务器.

还有很多其他有用的链接:
http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=1

4.IBM Power服务器参数和特性报告

IBM Power System facts and features，当前Power服务器的各项物理、电气参数，性能指标等的一个汇总报告。
http://www-03.ibm.com/systems/p/hardware/reports/factsfeatures.html

5.IBM 性能报告

System performance report， 所有的IBM Power服务器的性能参数汇总，包括SPEC、TPC、rPerf等参数，是查看Power服务器性能的权威资料。
http://www-304.ibm.com/jct03004c/systems/p/hardware/reports/system_perf.html

6.IBM AIX, VIOS and HMC Facts & Features

IBM AIX, VIOS and HMC Facts & Features，列出了AIX、VIOS和HMC相关的版本以及相应功能的汇总报告。
http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD103130

7.刀片产品（System X和Power刀片）的兼容性文档列表

刀片产品（System X和Power刀片）的兼容性文档列表
http://www-03.ibm.com/servers/eserver/serverproven/compat/us/eserver.html

8.PowerHA兼容性手册

PowerHA兼容性手册中，包含了HACMP v5.4.1、PowerHA v5.5、PowerHA v6.1、PowerHA v7.1与Power服务器、IBM Storage、Adapters、AIX版本的兼容性信息。
http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD105638

9.销售手册

IBM硬件和软件的销售手册
http://www-01.ibm.com/common/ssi/index.wss

10.红皮书网站

全面的IBM技术参考资料网站。
http://www.redbooks.ibm.com

例如：

用“Technical Overview and Introduction”来查询，能够查询到各款IBM Power服务器的技术特点介绍红皮书；
用“PowerVM”来查询，能够查询到现在IBM Power服务器上虚拟技术相关的红皮书。

11.IBM Power产品和友商产品的参数对比

IBM Power产品和友商产品的参数对比链接：
http://www-03.ibm.com/systems/migratetoibm/systems/power/performance.html

12.IBM Power产品白皮书链接

(1) IBM Power产品白皮书

(2) AIX 6.1 信息中心:
http://publib.boulder.ibm.com/infocenter/systems/scope/aix/index.jsp

(3) AIX 5.3 信息中心:
http://publib.boulder.ibm.com/infocenter/pseries/v5r3/index.jsp?topic=/com.ibm.aix.doc/doc/base/aixinformation.htm

(4) AIX 5.2 信息中心:
http://publib16.boulder.ibm.com/pseries/en_US/infocenter/base/aix52.htm

13.IBM Cluster Information Center链接

IBM Cluster Information Center


IBM POWER6家族便捷指南

December 2009

 | BladeCenter JS12 Express | BladeCenter JS22 Express | BladeCenter JS23 / JS43 Express | Power 520 Express | Power 550 Express | Power 560 Express | Power 570 | Power 595
Machine type-model | 7998-60X | 7998-61X | JS23: 7778-23X JS43 = JS23 + FC 8446 | 8203-E4A | 8204-E8A | 8234-EMA | 9117-MMA | 9119-FHA
System package | Blade Server/ BladeCenter | Blade Server/ BladeCenter | Blade Server BladeCenter | 4U, 19" rack or tower | 4U, 19" rack or tower | 4U / node, 19" rack | 4U / node, 19" rack | 42U, 24" CEC frame
# of cores (GHz & processor) | 2 (3.8 GHz POWER6TM) | 4 (4.0 GHz POWER6) | JS23: 4 (4.2 GHz POWER6+) JS43: 8 (4.2 GHz POWER6+) | 1, 2, 4 (4.2 GHz POWER6) 2, 4 (4.7 GHz POWER6+) | 2, 4, 6, 8 (3.5,/4.2 GHz POWER6) 2, 4, 6, 8 5.0 GHZ POWER6+) | 4, 8, 16 (3.6 GHz POWER6+) | 2 to 16 (3.5/4.4 GHz POWER6, 5.0 GHz POWER6+)1 4 to 32 (4.2 GHz POWER6+) | 8 to 64 (4.2 GHz POWER6) 16 to 64 (5.0 GHz POWER6)
Min2 - max. memory | 42 – 64 GB | 4 – 32 GB | JS23: 4–64GB JS43: 8-128GB | 2 2 – 64 GB (max 16 per core) | 4 2 – 256 GB (max 64 per proc card) | 8 – 384 GB (max 96 per proc card) | 2 – 768 GB (max 96 per proc card) | 16 – 4096 GB (max 512 per proc book)
Max CEC disk bays / TB storage | 2 / 0.29 | 1 / 0.14 | JS23: 1 / 0.14 JS43: 2 / 0.29 | 83 / 2.7 | 83 / 2.7 | 12 / 5.4 (6 / 2.7 per drawer) | 24 / 10.8 (6 / 2.7 per drawer) | 26 / 3.8 per PCIe I/O drawer
Max CEC PCI slots | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 23/43: 2/4 PCIe | 3 PCIe + 2 PCI-X DDR | 3 PCIe + 2 PCI-X DDR | 8 PCIe + 4 PCI-X DDR | 16 PCIe + 8 PCI-X DDR | 20 slots per 24" I/O drawer
Max I/O loops (RIO and/or 12X) | 0 | 0 | 0 | 1-core = 0 2-core = 1 4-core = 2 | 2-core = 1, 4->8-core= 2 | 4-core = 1, 8-core = 2, 16-core = 3 | 8 (1 per proc. card) | 32 (4 per proc. book)
Max 12X I/O drawers 4 | 0 | 0 | 0 | 8 or 4 | 8 or 4 | 12 or 6 | 32 or 16 | 30 or 32
Max RIO I/O drawers 4 | 0 | 0 | 0 | 12 | 12 | 18(AIX) 0(IBM i) | 48 | 12 (AIX) 96 (IBM i)
Max disk bays with I/O drawers5 | 2 +12 bays if BladeCenter S | 1 +12 bays if BladeCenter S | 1/2 +12 bays if BladeCenter S | 1-core = 8 2/4-core = 296 | 584 | 1332 | 1344 | 832 (AIX) 2200 (IBM i)
Max PCI slots w/ 12X PCI-X I/O drawers | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 1 | 2 PCIe + 50 PCI-X DDR | 1 PCIe + 50 PCI-X DDR | 7 PCIe + 76 PCI-X DDR | 12 PCIe + 200 PCI-X DDR | 180 PCI-X + 420 PCI-X DDR
Max PCI slots w/ 12X PCIe I/O drawers | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 1 PCIe + 1 PCI-X | 42 PCIe + 2 PCI-X DDR | 41 PCIe + 2 PCI-X DDR | 67 PCIe + 4 PCI-X DDR | 172 PCIe + 8 PCI-X DDR | 640 PCIe
AIX rPerf (Ranges shown for 520 to 595) | 14.71 | 30.26 | JS23: 36.28 JS43: 68.20 | 4.2 GHz: 8.39 - 31.48 4.7 GHz: 20.13 - 39.73 | 3.5GHz: 15.85 - 58.80 4.2GHz: 18.38 - 68.2 5GHz: 21.1 - 78.6 | 3.6GHz: 31.3 - 100.3 | 3.5GHz: 15.85 - 105.75 5.0GHz: 21.16 - 141.21 4.2GHz(4-32): 35.5 - 193.25 | 4.2GHz: 75.58 - 479.89 5.0GHz: 164.67 - 553.01
IBM i CPW (Ranges shown for 520 to 595) | 7100 | 13800 | JS23: 14400 JS43: 24050 | 4.2 GHz: 4300 - 15600 4.7 GHz: 9500 - 18300 | 3.5GHz: 7750–27600 4.2GHz: 9200-32650 5GHz: 10600-37950 | 3.6GHz: 14100-48500 | 3.5GHz: 8150-57600 5.0GHz 11000-77600 4.2GHz (4-32): 16200-104800 | 4.2GHz: 35500-256200 5.0GHz 41000-294700
CoD options | N/A | N/A | N/A | N/A9 | N/A9 | N/A | CUoD, On/Off Utility, Trial | CUoD, On/Off, Utility, Trial
Max partitions AIX+IBM i + Linux | 20 | 40 | 40 (23) 80 (43) | 40 | 80 | 160 | 160 | 254
IBM i level & tier | 6.1 P05 | 6.1 P10 | 6.1 P10 | 5.4 6, 6.1 P05 / P10 | 5.4 6, 6.1 P20 | 6.1 P20 | 5.4, 6.1 P30 | 5.4, 6.1 P50
AIX level & group | 5.3, 6.1 C5 | 5.3, 6.1 C5 | 5.3, 6.1 C5 | 5.3, 6.1 D5 | 5.3, 6.1 E5 | 5.3, 6.1 E5 | 5.27, 5.3, 6.1 F5 | 5.3, 6.1 H5
Linux support | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.6 RHEL 5.1 SLES 10 SP2 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.5 RHEL 5.1 SLES 10 SP1 SLES 11 | RHEL 4.6 RHEL 5.2 SLES 10 SP2 SLES 11
PowerVMExpress | N/A | N/A | N/A | Optional | Optional | N/A | N/A | N/A
PowerVM Standard | Standard | Standard | Standard | Optional 8 | Optional 8 | Optional | Optional | Optional
PowerVM Enterprise | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional

A Power 575 column is not shown due to space constraints in this document.The Power 575 is a high performance cluster built on POWER6 technology and is designed for HPC and other compute intensive workloads.See the detailed Facts/Features document for Power 575 information.
Not all numbers apply to all operating systems.

1 Power 570 2 – 16 core 4.2 GHz and 4.7 GHz withdrawn from marketing 2009
2 JS12 BladeCenter, Power 520, Power 550 DIMM options changed 1H09 for newly shipped servers increasing minimum.Values shown are the new minimums.
3 Power 520 and 550 can have either eight disk SAS SFF disk slots or six 3.5-inch SAS disk slots
4 Assuming maximum number of I/O loops, second number indicates number of PCIe 12X I/O drawers
5 Ignoring SAN drives, using the maximum whether SAS or SCSI, ignoring IBM i disk controller implications
6 The Power 520 4.7 GHz and Power 550 5.0 GHz require IBM i 6.1 at a minimum
7 AIX 5.3 or higher needed for the 4.2, 4.4 and 5.0 GHz Power 570 processors announced October 2008
8 IBM i edition may require PowerVM Standard or higher as a minimum
9 Power 520 (9408-M25) and Power 550 (9409- M50) do provide CoD options

参考链接：ftp://public.dhe.ibm.com/common/ssi/sa/st/n/poy03001usen/POY03001USEN.PDF

注：本POWER6产品参数查阅指南适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。

Top


IBM POWER7家族便捷指南

December 2010

 | BladeCenter PS700 Express | BladeCenter PS701 Express | BladeCenter PS702 Express | Power 710 Express | Power 720 Express | Power 730 Express | Power 740 Express | Power 750 Express | Power 755 | Power 770 | Power 780
Machine type-model | 8406-70Y | 8406-71Y | 8406-71Y | 8231-E2B | 8202-E4B | 8231-E2B | 8205-E6B | 8233-E8B | 8236-E8C | 9117-MMB | 9179-MHB
System package | Blade Server / BladeCenter | Blade Server / BladeCenter | Blade Server / BladeCenter | 2U, 19" rack | 4U, 19" rack or tower | 2U, 19" rack | 4U, 19" rack or tower | 4U, 19" rack | 4U, 19" rack | 4U / node, 19" rack | 4U / node, 19" rack
# of cores (GHz & processor) | 3.0 GHz(4-core) 4 | 3.0 GHz(8-core) 8 | 3.0 GHz(8-core) 16 | 3.0 GHz(4-core) 4 3.7 GHz(6-core) 6 3.55 GHz(8-core) 8 | 3.0 GHz (4-core) 4 3.0 GHz (6-core) 6 3.0 GHz (8-core) 8 | 3.0 GHz(4-core) 8 3.7 GHz(4-core) 8 3.7 GHz(6-core) 12 3.55 GHz(8-core) 16 | 3.3 GHz(4-core) 4, 8 3.7 GHz(4-core) 4, 8 3.7 GHz(6-core) 6, 12 3.55 GHz(8-core) 8,16 | 3.0/3.3GHz(8-core): 8,16,24,32 3.55GHz(8-core): 8,16,24,32 | 3.3 GHz(8-core) 32 | 3.5 GHz(6-core) 4 - 48 | 3.86 GHz (8-core) 4 - 64 4.14 GHz (4-core)5 4 - 32
# of sockets | 1 | 1 | 2 | 1 | 1 | 2 | 1 or 2 | 1, 2, 3, 4 | 4 | 2, 4, 6, 8 | 2, 4, 6, 8
Min - max memory | 8 - 64 GB (1066) | 16 - 128 GB(1066) | 32 - 256 GB (1066) | 4 - 64 GB (1066) | 4 core 8 – 64 GB (1066) 6 or 8 core 8 – 128 GB (1066) | 8 - 128 GB (1066) | 8 - 256 GB (1066) | 8 – 512 GB(1066) (max 128 per proc card) | 128 – 256 GB(1066) (max 64 per proc card) | 32 GB – 2 TB(1066) (max 512 GB per node) | 32 GB – 2 TB(1066) (max 512 GB per node)
Max CEC disk bays / TB storage | 2 / 1.2 TB | 1 / 600 GB | 2 / 1.2 TB | 6 / 1.8 TB | 8 / 2.4 TB | 6 / 1.8 TB | 8 / 2.4 TB | 8 / 2.4 TB | 8 / 2.4 TB | 6 per node / 1.8 TB Max per sys 24 / 7.2 TB | 6 per node / 1.8 TB Max per sys 24 / 7.2 TB
Max CEC PCI slots | Expansion Cards 1 PCIe CIOv 1 PCIe CFFh | Expansion Cards 1 PCIe CIOv 1 PCIe CFFh | Expansion Cards 2 PCIe CIOv 2 PCIe CFFh | 4 PCIe LP | 4 PCIe + 4 PCIe LP (opt.) | 4 PCIe LP | 4 PCIe + 4 PCIe LP (opt.) | 3 PCIe and 2 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 6 PCIe per node 24 per system | 6 PCIe per node 24 per system
Max GX adapter slots | N/A | N/A | N/A | 1 GX++ | 1 GX++ 1 (6- or 8-core systems only) | 2 GX++ | 2 GX++ 1 | 1 socket 1 GX+ 2 or more sockets 1 GX++ and 1 GX+ | 1 GX++ | 2 GX++ per node Max per system = 8 | 2 GX++ per node Max per system = 8
Max 12X I/O PCIe drwrs | N/A | PN/A | N/A | N/A | 22 | N/A | 4 | 4 | 0 | 16 | 16
Max 12X I/O PCI-X drwrs | N/A | PN/A | N/A | N/A | 42 | N/A | 8 | 8 | 0 | 32 | 32
Max disk bays w/ I/O drawers | 2 + 12 bays if BladeCenter S | 1 + 12 bays if BladeCenter S | 2 + 12 bays if BladeCenter S | 102 | 380 | 102 | 416 | 586 | 164 | 1320 | 1320
Max PCI slots w/ 12X PCI-X I/O drawers | N/A | N/A | N/A | N/A | 4 PCIe and 24 PCI-X DDR | N/A | 4 PCIe and 48 PCI-X DDR | 1 PCIe and 50 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 24 PCIe and 192 PCI-X DDR | 24 PCIe and 192 PCI-X DDR
Max PCI slots w/ 12X PCIe I/O drawers | N/A | N/A | N/A | N/A | 24 PCIe | N/A | 44 PCIe | 41 PCIe and 2 PCI-X DDR | 3 PCIe and 2 PCI-X DDR | 184 PCIe | 184 PCIe
AIX rPerf Ranges | 45.13 | 81.24 | 154.36 | 45.13 – 91.96 | 45.13 – 81.24 | 86.66 – 176.57 | 48.33 – 176.57 | 81.24 – 331.06 | N/A | 140.75 – 579.39 | 115.86 – 685.09
IBM i CPW Ranges | 21,100 | 42,100 | 76,300 | 23,800 – 51,800 | 23,800 – 46,300 | 44,600 – 97,700 | 25,500 – 97,700 | 44,600 – 181,000 | N/A | 73,100 – 292,700 | 57,450 – 343,050
Capacity on Demand options | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | CUoD, On/Off, Utility, Trial | CUoD, On/Off, Utility, Trial
Max partitions (10/core) | 40 | 80 | 160 | 80 | 80 | 160 | 160 | 160 – 3203 | 32 (DLPAR Only) | 160 - 4804 | 160 - 6404
IBM i level & tier | 6.1.1, 7.1 Small – P05 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small – P10 | 6.1.1, 7.1 Small -P05 (4-core) P10 (6- or 8-core) | 6.1.1, 7.1 Small -P05 (4-core) P10 (6- or 8-core) | 6.1.1, 7.1 Small – P20 | 6.1.1, 7.1 Small – P20 | 6.1.1, 7.1 Small - P20 | N/A | 6.1.1, 7.1 Medium - P30 | 6.1.1, 7.1 Large - P50
AIX level & group | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Small | 5.3, 6.1, 7.1 Medium | 5.3, 6.1, 7.1 Large
Linux support | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 SP1 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5 | SLES 10 SP3 SLES 11 RHEL 5.5
PowerVM Express | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | N/A | N/A
PowerVM Standard | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | Optional | Optional
PowerVM Enterprise | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | N/A | Optional | Optional
Systems Director (w/VMControl) | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional | Optional

1 The GX++ slot on the Power 720 Express server and the second GX++ slot on the Power 740 Express server are not available if the optional four PCIe low profile slots are used.
2 Not supported on 4-core Power 720 Express configurations.
3 IBM Statement of Direction to increase the maximum number of Micro-Partitions to 320 on the Power 750 Express server.
4 IBM Statement of Direction to increase the maximum number of Micro-Partitions to 640 on Power 770 and 780 servers and to 1000 on the Power 795 server.
5Each Power 780 3.86 GHz processor card has two sockets, with each socket having eight POWER7 processor cores. If run in optional TurboCore mode at 4.14 GHz, only half the cores in each socket are available.

参考链接：ftp://public.dhe.ibm.com/common/ssi/sa/st/n/poy03032usen/POY03032USEN.PDF

注：本POWER7产品参数查阅指南适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。

Top


Power家族服务器一览表

注：本Power家族服务器一览表适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。


Power服务器TPC-C估算器

TPC-C是比较不同硬件和软件配置的OLTP(On-line Transaction Processing)性能的一个指标。

IBM的P系列服务器，每个型号的产品都有几款机型会通过TPC组织的测试来公布TPC-C值。对于那些没有公布TPC-C的机型配置，可以通过这个TPC-C估算器来粗略估算其TPC-C值，以方便用户选择机型。

该估算器的估算方式是通过已发布TPC-C的机型配置的机器为基准，用IBM官方发布的该款机型配置的rPerf与基准机型的rPerf做对比得出的。

注：此TPC-C估算器是为方便用户了解IBM P系列服务器的TPC-C值所开发的小工具，并非官方发布的数据，所估算出的TPC-C值仅供参考。

下载工具


Power产品配置文件中英文翻译工具

通过Power产品配置文件翻译工具，可以将.CSV的英文配置文件翻译成中文的配置文件，方便查看配置信息。

首先打开翻译工具，选择“启用宏”，点击“选择文件”按钮，选择需要进行翻译的.CSV配置文件，然后点击“开始翻译”按钮，将产生一个中文的.xls配置文件，并可对其进行保存操作。

注：此翻译工具为方便用户了解配置文件所开发的Beta版非正式工具，中文的翻译仅供参考，如果您对此工具有任何意见和建议，请及时联系我们(techline@cn.ibm.com)。

下载配置文件中英文翻译工具


Power服务器销售手册快速查询通道

通过下面的列表，找到相关产品，点击"->" 可查到该产品的信息. 或者

输入产品类型号 MTM(Machine 产品号):

例如：Power 550, 可输入 "8204-E8A"

(注意:如果是首次进行查询，需要对所在国家和语言进行设置，确定搜索范围和返回文档的语言，如下所示：

Home Country and Site Language://选择所在国家和语言 | China(English)
Narrow searches to://选择搜索范围 | China
Return documents in English and://选择返回文档的语言 | English
Return a maximum of://选择返回文档的最大值 | 200

点击 continue, 进行重新查询.)

Blade Center

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 适合的应用 | 链接
BladeCenter PS700 | 8406-70Y | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2010/04/13 | - | - | ->
BladeCenter PS701 | 8406-71Y | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2010/04/13 | - | - | ->
BladeCenter PS702 | 8406-71Y | 宽度:59 mm 深度:445 mm 高度:245 mm 重量:8.7 kg | 700(watts) | 2010/04/13 | - | - | ->
BladeCenter JS12 | 7998-60X | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 350(watts) | 2008/04/02 | - | 适用于小型数据库和应用程序服务器。 | ->
BladeCenter JS22 | 7998-61X | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 350(watts) | 2007/11/06 | 2011/01/07 | 用于业务绩效应用程序，例如较小的数据库、OLTP和商业智能； 用于 HPC 工作负载，例如天气预报、地震处理、分子力学和计算流体力学。 | ->
BladeCenter JS23 | 7778-23X | 宽度:29 mm 深度:445 mm 高度:245 mm 重量:4.35 kg | 350(watts) | 2009/04/28 | 2011/04/29 | - | ->
BladeCenter JS43 | 7778-23X | 宽度:59 mm 深度:445 mm 高度:245 mm 重量:8.7 kg | 700(watts) | 2009/04/28 | 2011/04/29 | - | ->
BladeCenter JS21 | 7988-J21 | 宽度:29 mm 深度:445.8 mm 高度:245.2 mm 重量:4.35 kg | 376(watts) | 2007/06/05 | 2009/01/02 | - | ->
BladeCenter H Chassis | 7989-BCH | 高度:400 mm 宽度:442 mm 深度:711 mm 重量:40.82 - 158.8 kg | 45(watts) | 2007/06/05 | - | - | ->
BladeCenter S Chassis | 7779-BCS | 宽度:444 mm 深度:733.4 mm 高度:306.3 mm 重量:40.82 - 108.86 kg | 45(watts) | 2008/04/02 | - | - | ->

Top

POWER7 Systems

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 适合的应用 | 链接
Power 710 | 8231-E2B | Rack-Mount: 宽度:440 mm 深度:706 mm 高度:89 mm(2U) 重量:28.3 kg | 650(watts) | 2010/08/17 | 紧凑2U封装内可靠而又安全的高性能、高能效基础架构和应用程序服务器。凭借 POWER7 工作负载优化技术，Power 710 服务器使用 AIX、IBM i 和 Linux 操作系统可以实现极其快速的事务处理； 这是一款易于购买、安装和管理的服务器，可以无缝地集成至您的现有基础架构，从而缩短部署和实现价值所需的时间。 | ->
Power 720 | 8202-E4B | Rack-Mount: 宽度:440 mm 深度:610 mm 高度:173 mm(4U) 重量:48.7 kg Deskside/Desktop: 宽度:328.5mm with tip plate/183 mm without tip plate 深度:688 mm 高度:541 mm 重量:53.7 kg without tip plate / 57.2 kg with tip plate | 750(watts) | 2010/08/17 | 用于 UNIX、IBM i 和 Linux 工作负载的可靠而又安全的分布式应用程序服务器或整合服务器； IBM i 提供了高度可扩展的防病毒架构，该架构带有稳定的数据库和中间件基础，可以实现高效的业务处理应用程序部署。 | ->
Power 730 | 8231-E2B | Rack-Mount: 宽度:440 mm 深度:706 mm 高度:89 mm(2U) 重量:29.5 kg | 1100(watts) | 2010/08/17 | 高性能、高密度、高能效的服务器，是在虚拟化环境中运行多个应用程序和基础架构工作负载的理想选择； 整合 UNIX 和 x86 Linux 工作负载。 | ->
Power 740 | 8205-E6B | Rack-Mount: 宽度:440 mm 深度:610 mm 高度:173 mm(4U) 重量:48.7 kg Deskside/Desktop: 宽度:328.5mm with tip plate/183 mm without tip plate 深度:688 mm 高度:541 mm 重量:53.7 kg without tip plate / 57.2 kg with tip plate | 1400(watts) | 2010/08/17 | 用于中小型数据库服务器； 用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器。 | ->
Power 750 | 8233-E8B | Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1950(watts) | 2010/02/09 | 用于整合 UNIX、IBM i 和 x86 Linux 工作负载以及虚拟化应用程序服务器； 用于中到大型数据库服务器。 | ->
Power 755 | 8236-E8C | Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1950(watts) | 2010/02/09 | 针对运行高度并行的计算密集型工作负载和算法而优化，例如天气与气候建模、计算化学、物理和石油储量建模等。 | ->
Power 770 | 9117-MMB | 一个系统抽屉: 宽度: 483 mm 深度: 863 mm 高度: 174 mm(4U) 重量: 70.3 kg | 1600(watts)/blk | 2010/02/09 | 用于整合UNIX、IBM i 和x86 Linux工作负载； 适用于中到大型数据库服务器； 适用于中到大型事务处理应用程序，例如ERP 和 CRM； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->
Power 780 | 9179-MHB | 一个系统抽屉: 宽度: 483 mm 深度: 863 mm 高度: 174 mm(4U) 重量: 70.3 kg | 1600(watts)/blk | 2010/02/09 | 适用于大型跨UNIX、IBM i和Linux工作负载的服务器整合； 适用于大型数据库服务器； 适用于大型事务处理应用程序，例如ERP 和 CRM； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->

Top

POWER6 Systems

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 适合的应用 | 链接
Power 520 | 8203-E4A | Deskside/Desktop: 宽度:328.5mm with tip foot/182.3 mm without tip foot 深度:628 mm 高度:540 mm Rack-Mount: 宽度:440 mm 深度:538 mm 高度:173 mm(4U) 重量: Rack-mount:31.75 kg Deskside: 40.8 kg | 850(watts) | 2008/01/29 | 2011/05/27 | 用于分布式 UNIX、IBM i和 LinuxERP/CRM 应用程序服务器； 用于小型数据库服务器； 用于UNIX、IBM i 和Linux工作负载的小规模整合服务器； 用于带有集成数据库和应用程序服务器的完整业务系统。 | ->
Power 550 | 8204-E8A | Deskside/Desktop: 宽度:282.5 mm with tip foot/182.5 mm without tip foot 深度:778 mm 高度:540 mm 重量:57.2 kgwith tip foot/53.7 kg without tip foot Rack-Mount: 宽度:440 mm 深度:730 mm 高度:173 mm(4U) 重量:48.7 kg | 1500(watts) | 2008/01/29 | 2011/05/27 | 适用于UNIX、IBM i和 Linux ERP/CRM应用程序服务器； 用于中型数据库服务器； 用于整合UNIX、IBM i和x86 Linux 工作负载； 用于运行IBM i操作系统的中到大型企业。 | ->
Power 560 | 8234-EMA | 一个系统抽屉: 宽度: 483 mm 深度: 824 mm 高度: 174 mm(4U) 重量: 63.6 kg | 1200(watts)/blk | 2008/10/07 | 2011/01/07 | 用于整合UNIX、IBM i 和x86 Linux工作负载； 适用于中到大型数据库服务器； 用于UNIX、IBM i和Linux ERP/CRM 应用程序服务器。 | ->
Power 570 | 9117-MMA | 一个系统抽屉: 宽度: 483 mm 深度: 824 mm 高度: 174 mm(4U) 重量: 63.6 kg | 1400(watts)/blk | 2007/05/22 | 2011/01/07 | 适用于中到大型事务处理应用程序，例如ERP 和 CRM； 适用于中到大型数据库服务器； 适用于跨UNIX、IBM i和Linux工作负载的服务器整合； 作为包含公司 IT 基础架构各个方面的完整业务系统。 | ->
Power 575 | 9125-F2A | 系统机架尺寸: 宽度:750 mm 深度:1524 mm 高度:2013 mm 重量:1656 kg 一个节点为2U高度 |  | 2008/04/08 | 2010/07/30 | 针对运行大型、高度并行的计算密集型工作负载和算法而优化； 针对天气和气候建模、计算化学、物理、计算机辅助工程、计算流体力学和石油探测的应用亲和性。 | ->
Power 595 | 9119-FHA | 宽度:775 mm 深度:1486-1806 mm 高度:2014 mm 重量:1531-1552 kg | 27500(watts)/CEC+3IO | 2008/04/08 | 2011/07/29 | 用于支持大规模事务处理和数据库应用程序的数据中心； 用于大规模服务器整合，可增加灵活性，降低运营和能耗成本； 用于要求其关键业务型应用程序具有最高级别的RAS的企业。 | ->

Top

p5 Server

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
P5 505 505Q | 9115-505 | 1U | 400(watts) | 2005/10/04 | 2009/05/29 | ->
P5 510 510Q | 9110-51A | 2U | 625(watts) | 2006/02/14 | 2010/07/30 | ->
P5 520, 520Q | 9131-52A | 4U | 600(watts) | 2005/10/04 | 2008/12/12 | ->
P5 550, 550Q | 9133-55A | 4U | 1100(watts) | 2005/10/04 | 2008/12/12 | ->
p5-560Q | 9116-561 | 4U | 1300(watts)/blk | 2006/02/14 | 2009/01/02 | ->
P5-570 | 9117-570 | 4U | 1300(watts)/blk | 2004/07/13 | 2008/08/29 | ->
P5-575 | 9118-575 | 2U 24" | 41,600(watts) | 2005/02/08 | 2008/08/29 | ->
P5-590 | 9119-590 | 24" frame | 16,700(watts) | 2004/10/15 | 2008/08/29 | ->
P5-595 | 9119-595 | 24"frame | 22,710(watts) | 2004/10/14 | 2009/05/29 | ->

Top

pSeries Server

产品线 |  | 产品号 | 发布时间 | 停产时间 | 链接
p610-6C1 |  | 7028-6C1 | 2001/10/04 | 2004/03/09 | ->
p610-6E1 |  | 7028-6E1 | 2001/10/04 | 2004/03/09 | ->
p615-6C3 |  | 7029-6C3 | 2003/05/27 | 2005/12/13 | ->
p615-6E3 |  | 7029-6E3 | 2003/05/27 | 2005/12/13 | ->
p620-6F1 | F85 | 7025-6F1 | 2001/04/17 | 2003/09/12 | ->
p630-6C4 |  | 7028-6C4 | 2002/06/25 | 2005/12/13 | ->
p630-6E4 |  | 7028-6E4 | 2002/06/25 | 2005/12/13 | ->
p640 | B80 | 7026-B80 | 2000/10/03 | 2003/12/12 | ->
p650 |  | 7038-6M2 | 2002/11/12 | 2005/06/21 | ->
p655 |  | 7039-651 | 2002/11/12 | 2005/10/07 | ->
p660-6H1 | H85 | 7026-6H1 | 2001/04/17 | 2003/09/12 | ->
p660-6M1 | M85 | 7026-6M1 | 2001/09/04 | 2003/09/12 | ->
p670 |  | 7040-671 7040-61D 7040-61R | 2002/04/09 | 2005/11/18 |
p680 | S85 | 7017-S85 | 2000/10/03 | 2003/03/28 | ->
p690 | S90 | 7040-681 7040-61D 7040-61R | 2001/10/04 | 2005/11/18 |

Top

RS/6000 Server

产品线 | 产品号 | 发布时间 | 停产时间 | 链接
B50 | 7046-B50 | 1999/09/13 | 2003/09/12 | ->
150 | 7043-150 | 1998/10/05 | 2003/12/12 | ->
260 | 7043-260 | 1998/10/05 | 2000/12/01 | ->
170 | 7044-170 | 2000/02/07 | 2003/12/12 | ->
270 | 7044-270 | 2000/02/07 | 2003/09/12 | ->
F50 | 7025-F50 | 1997/04/15 | 2001/07/17 | ->
H50 | 7026-H50 | 1998/02/09 | 2000/12/01 | ->
H70 | 7026-H70 | 1999/04/06 | 2001/07/17 | ->
F80 | 7025-F80 | 2000/05/09 | 2001/07/13 | ->
H80 | 7026-H80 | 2000/05/09 | 2001/07/13 | ->
M80 | 7026-M80 | 2000/05/09 | 2002/01/31 | ->
S70 | 7017-S70 | 1997/10/06 | 1999/12/13 | ->
S7A | 7017-S7A | 1998/10/05 | 2000/12/01 | ->
S80 | 7017-S80 | 1999/09/13 | 2001/08/31 | ->

Top

Rack

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
RS/6000 Rack | 7014-T00 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1147 mm with front and rear doors; 1042 mm with rear door only. 高度: 1804 mm with standard AC power; (36U) 1926 mm with -48 volt DC power. 空机柜重量: 244 kg | 2000/05/09 | ->
RS/6000 Rack | 7014-T42 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1147 mm with front and rear doors; 1042 mm with rear door only . 高度: 2015 mm with standard AC power (42U) 空机柜重量: 261 kg |  | ->
Rack | 7014-B42 | 宽度: 644 mm with side panels; 623 mm without side panels. 深度: 1098 mm with front and rear doors; 1042 mm with rear door only; 1409 mm with acoustic doors. 高度: 2015 mm with standard AC power(42U) 空机柜重量: 261 kg | 2007/06/05 | ->

Top

I/O Draws

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
Rack-Mounted High-Density Expansion Drawer | 7311-D20 | 宽度:482 mm 深度:610 mm 高度:178 mm(4U) 重量:45.9 kg | 340(watts) | 2002/11/12 | 2010/08/27 | ->
PCI-X I/O Drawer | 7314-G30 | 宽度:224 mm 深度:800 mm 高度:172 mm(4U) 重量:20 kg | 250(watts) | 2007/05/22 | 2009/08/28 | ->

Top

HMC

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
Hardware Management Console | 7042-CR4 | 宽度:440 mm 深度:711.4 mm 高度:43 mm 重量:15.6 kg | 500(watts) | 2007/06/08 | 2009/12/31 | ->
Hardware Management Console | 7042-CR5 | 宽度:440 mm 深度:711 mm 高度:43 mm 重量:15.6 kg | 780(watts) | 2009/10/20 | 2011/01/07 | ->
Hardware Management Console | 7042-CR6 | 宽度:440 mm 深度:711 mm 高度:43 mm 重量:15.9 kg | 194-675(watts) | 2010/08/17 | - | ->
Deskside Hardware Management Console | 7042-C07 | 宽度:216 mm 深度:540 mm 高度:438 mm 重量:16.3 kg | 550(watts) | 2008/04/08 | 2010/09/17 | ->
Deskside Hardware Management Console | 7042-C08 | 宽度:216 mm 深度:540 mm 高度:438 mm 重量:18 kg | 550(watts) | 2010/04/13 | - | ->

Top

Consoles

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
Rack-Mounted Flat Panel Console Kit | 7316-TF3 | 宽度:485 mm 深度:635 mm to 730mm 高度:43.0 mm(1U) 高度(opened):410 mm 重量:12.8 kg Switch fc#4283 高度:1U | 2004/04/27 | ->

Top

Storage Device Enclosure

产品线 | 产品号 | 物理参数 | 发布时间 | 链接
Tape/Optical Storage Device Enclosure | 7214-1U2 | 宽度:446 mm 深度:736 mm 高度:44 mm(1U) 重量:11 kg | 2007/11/30 | ->
Tape/Optical Storage Device Enclosure | 7216-1U2 | 宽度:480 mm 深度:454 mm 高度:43 mm(1U) 重量:5.1-7.1kg | 2010/08/17 | ->

Top


What's New Storage

What's New

1.更新了存储产品配置文件中英文翻译工具：

本期更新了存储产品配置文件中英文翻译工具，在该工具中，更新了XIV中新增的Feature Code信息。

存储产品配置文件中英文翻译工具

2.更新了存储产品竞争工具链接

本期在存储产品速查手册的附录中，更新了最新版本的存储产品竞争工具链接。

Storage产品速查手册附录

3.更新了存储销售手册快速查询通道

本期更新了存储销售手册快速查询通道，在该工具中，添加了TS7650G、 TS2230、TS2240、TS2250、N6210、N6240、SAN32B-E4的销售手册链接。

Storage销售手册快速查询通道

4.更新了存储家族产品一览表

本期更新了存储家族产品一览表，展现了目前在产的产品。

存储家族产品一览表

5.新增的网络课堂：(新增)

(1) IBM XIV Storage System Disaster Recovery 原理

(2) IBM存储产品售前相关工具介绍及使用

(3) IBM DS5020 Technical Introduction

(4) IBM System Storage DS8800产品介绍

(5) IBM Storwize V7000 Introduction

(6) IBM System Stoage SVC 6.1 Update

(7) IBM TPC v4.2 technical overview

(8) IBM TPC for Replication v4.2 technical Overview

(9) IBM Storwize V7000 Software Technical Deep Dive

6.增加了27个新的热点问题： (新增)

(1) EXP5060中SFP模块及线缆的配置及注意事项

(2) EXP5060中磁盘的配置及注意事项

(3) DS5000 Expansion Unit中SFP模块及线缆的配置及注意事项

(4) DS5000 Expansion Unit中磁盘的配置及注意事项

(5) DS5020 firmware 7.70 密码设置规则

(6) DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法

(7) DS5020的常用软件和文档下载网址

(8) Storwize V7000 缺省支持那些高级功能

(9) Storwize V7000 物理组成

(10) Storwize V7000 硬件的SFP配置

(11) Storwize V7000 硬件的HDDs配置

(12) DS8800 体系架构说明

(13) DS8700与DS8800 物理指标与电气特性

(14) DS8700 微码实现的功能介绍

(15) DS8800 e-Config中HA/Cables的配置

(16) 768B 交换刀片与SFP的解释以及配置注意事项

(17) 768B 许可(License)的选择与说明

(18) 384B 交换刀片与SFP的解释以及配置注意事项

(19) 384B 许可(License)的选择与说明

(20) IBM磁带机/磁带库与备份服务器的连接方式

(21) IBM磁带库备份容量评估

(22) IBM磁带机/磁带库与HBA卡，操作系统等兼容性

(23) IBM 3580和3592磁带机的介绍

(24) SVC的Easy Tier功能介绍

(25) N3300的接口类型、功能与数量

(26) N3400的接口类型、功能与数量

(27) N3600的接口类型、功能与数量

7.更新的FAQ：(最近更新)

(1) DS5100 DS5300扩展柜的连接方式，及模块使用的计算

(2) DS5020硬盘配置注意事项

(3) DS5000 e-config配置中TPC软件的选择

(4) DS5000系列 CPU、缓存信息与配置

(5) IBM DS8800硬盘选择及配置

(6) DS8700新产品特性阐述

(7) DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求

(8) DS8700的磁盘配置注意事项

(9) 3758-L32 SFP与线缆的选择与配置

(10) 2498-R06 SFP与线缆的选择与配置

(11) 2498-R06 许可（License）的选择与说明

(12) B24、B40、B80三款SAN交换机SFP模块与光纤线的选择

(13) IBM DCN 交换机性能参数

(14) SONAS产品简介

(15) LTO 磁带是否要配标签，标签的格式是什么样的？

(16) TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型?

(17) TS2900/TS3100/TS3200/TS3310/TS3500的功率和尺寸查询

(18) LTO X 产品的单盘磁带容量, LTO 3/4/5传输速率, 及其读写兼容性

(19) 带库中 Path Failover的功能介绍,是必选的吗

(20) TS7610产品介绍

(21) TS7610，TS7650与TS7650G的区别

(22) TS7610 软、硬件配置及注意事项

(23) TS7650 硬件中Features和Cables的配置

(24) TS7650G 硬件中Storage Link和Attach的配置

(25) 存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置

(26) e-config中磁带的配置介绍

(27) N Series Port/Loop indicator在e-config中的配置方法

(28) N3400与N3300,N3600参数对比

(29) N series CPU、缓存信息

(30) XIV磁盘存储的技术特征与产品优势

(31) SVC 5.1和6.1软件新增功能

(32) DS5000/DS8000的功率和尺寸查询

8.删除的FAQ：

(1) DS5020 CPU、缓存信息与配置

(2) B-Type SAN 交换机的SFP波长分别是多少？

(3) TS7610 软件配置及注意事项

(4) N6400/N6600/N6700/N7900 CPU、缓存信息

(5) XIV在可靠性方面有哪些特点？

(注：本手册删除的FAQ，仍可通过如下链接查询：http://www-900.ibm.com/cn/support/viewdoc/knowledgebase)


IBM Storage 常见问题汇总

目录

IBM Storage 常见问题汇总

Disk Storage

DS4000

什么是Storage Partition？以及如何计算耗费的Storage Partition数量？

DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？

DS4700,DS4800,DS5000,EXP 默认带多少个SFP?

DS5000

IBM System Storage DS5100/DS5300规格一览表

DS5100/DS5300扩展柜的连接方式，及模块使用的计算 (最近更新)

DS5000常用文档下载

DS4000/DS5000电池保护原理与时间

DS4000/DS5000 SN Number、PN Number、配件或整机保修信息查询

DS5020主机接口数量、类型及组合方式

DS5020与DS4700的参数对比

DS5020缓存是否可以升级

DS5020 firmware 7.70 密码设置规则 (新增)

DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法 (新增)

DS5020的常用软件和文档下载网址 (新增)

DS5000支持的扩展柜介绍

DS8000

DS8000 Copy Service特性

DS8000中磁盘相关基本概念

DS8700新产品特性阐述(最近更新)

DS8700 微码实现的功能介绍 (新增)

IBM新一代存储产品DS8800产品介绍

DS8800 体系架构说明 (新增)

DS8700与DS8800 物理指标与电气特性 (新增)

XIV

XIV磁盘存储的功率、尺寸与工作环境

XIV磁盘存储的技术特征与产品优势 (最近更新)

XIV磁盘存储的硬件特征

IBM XIV Storage System Software V10.2新功能

SVC

IBM SVC解决方案有哪些特点和优势

SVC 5.1和6.1软件新增功能 (最近更新)

SVC新一代引擎2145-CF8简介

利用SVC Flashcopy功能实现数据拷贝的速度

SVC的Easy Tier功能介绍 (新增)

Storwize V7000

IBM Storwize V7000新产品介绍

Storwize V7000 缺省支持那些高级功能 (新增)

Storwize V7000 物理组成 (新增)

其他

DS5000/DS8000的功率和尺寸查询 (最近更新)

Tape Library

LTO 磁带是否要配标签，标签的格式是什么样的？(最近更新)

带库驱动器接口的数量与线缆的选择

磁带机与磁带库的区别

IBM磁带机/磁带库与备份服务器的连接方式 (新增)

IBM磁带库备份容量评估 (新增)

IBM磁带机/磁带库与HBA卡，操作系统等兼容性 (新增)

带库中I/O槽位的作用

TS1120与TS1130的区别

TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型? (最近更新)

TS2900/TS3100/TS3200/TS3310/TS3500的功率和尺寸查询(最近更新)

TS3100/TS3200/TS3310光纤驱动器与主机HBA卡连接过程中需要注意什么？

LTO X 产品的单盘磁带容量, LTO 3/4/5传输速率, 及其读写兼容性(最近更新)

3580系列磁带机接口类型描述

IBM 3580和3592磁带机的介绍 (新增)

带库中 Path Failover的功能介绍, 是必选的吗 (最近更新)

TS7610产品介绍 (最近更新)

IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

TS7610，TS7650与TS7650G的区别 (最近更新)

N series

N series 产品的基本技术概念

N系列网关与N系列文件存储的区别

N series产品NAS和SAN功能的区别与配置方法

N series产品兼容性的查询方法

SONAS产品简介 (最近更新)

N series常用软件功能的介绍

N series产品的尺寸、重量与功率

N series支持的最大硬盘、扩展柜的数量

N3400与N3300,N3600参数对比 (最近更新)

N series CPU、缓存信息 (最近更新)

N3300的接口类型、功能与数量 (新增)

N3400的接口类型、功能与数量 (新增)

N3600的接口类型、功能与数量 (新增)

N6040/N6060/N6070三种型号的区别

SAN/Ethernet Switch

B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

B-Type SAN交换机NPIV功能介绍

3758-B32 FCoE与CEE协议应用介绍

2233-IA3 IBM Information Archive Model IA3简介

B24/B40/B80配置中所有License包含的功能

B24、B40、B80三款SAN交换机SFP模块与光纤线的选择 (最近更新)

IBM Converged Switch L32 (3758)交换机介绍

IBM DCN 交换机性能参数 (最近更新)

DR550

IBM System Storage DR550 产品简介


Disk Storage

DS4000

DS5000

DS8000

XIV

SVC

Storwize V7000

其他


DS4000

什么是Storage Partition？以及如何计算耗费的Storage Partition数量？

DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？

DS4700,DS4800,DS5000,EXP 默认带多少个SFP


什么是Storage Partition？以及如何计算耗费的Storage Partition数量

解答:

存储分区（storage partition）是包括主机，主机上的HBA卡以及逻辑磁盘在DS4000/DS5000中的对象集。也就是说，一个或多个LUN与主机或主机组的对应关系定义。定义Storage partition后可以使逻辑盘仅对映射的主机系统可见。

Storage partition可以帮助您映射并屏蔽LUN，使得主机系统只能看到映射的LUN而其他LUN对该主机是透明的。注意，在一个Storage partition中的主机操作系统类型必须是相同的。一个Storage partition包括如下对象：主机组，主机，主机端口，逻辑盘映射。

简单来说，当规划Partition数量时可以参考以下方法：

1.若系统中没有集群Cluster（如：HA双机等）环境或没有多台主机共享访问同一个LUN的情况，那么订购Partition的数量需要大于等于连接存储的主机的数量；

2.若系统中存在集群Cluster（如：HA双机等）环境或存在多台主机共享访问同一个LUN的情况，那么订购Partition的数量需要大于等于主机组的数量与单独映射主机数量之和；

例1：三台主机HostA、HostB、HostC，不存在集群和共享访问的情况，需要至少3个Partition许可；

例2：四台主机HostA、HostB、HostC和HostD，其中HostA和HostB作HA双机，HostC和HostD作另一个HA双机，并且这四台主机没有其他单独访问LUN的需求，那么至少需要2个Partition许可；

例3：两台主机HostA和HostB作HA双机，假设规划lun1和lun2需要它们共享访问，lun3映射给HostA单独访问，lun4映射给HostB单独访问，那么至少需要3个Partition许可；

注意：当DS4000/DS5000工作在集群Cluster方式下或被主机共享访问LUN时，主机端需要使用集群或并行访问的软件配合才可以正常工作。

以下是通过DS Storage Manager查看Partition信息的方法：

在Storage Manager（Subsystem Management）界面选择Storage Subsystem菜单中的Premium Features->list查看使用的Storage Partitioning数量；较新版本管理软件直接在在Storage Manager（Subsystem Management）界面选择Storage Subsystem菜单中的Premium Features... 查看Storage Partitioning数量。

以下是DS4000/DS5000存储支持的partition许可数量：
- DS4200：2,4,8,16,32,64,128；
- DS4700（70A）：2,4,8,16,32,64,128；
- DS4700（72A）：8,16,32,64,128；
- DS4800：8,16,32,64,128,256,512；
- DS5020：2,4,8,16,32,64,128；
- DS5100：8,16,32,64,128,256,512；
- DS5300：8,16,32,64,128,256,512。

参考资料：
书名: 《IBM System Storage DS4000 and Storage Manager V10.10》
书号：SG24-7010-06
页码：151-155
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247010.pdf


DS4000/DS5000的兼容性问题？兼容哪些服务器类型？和HBA卡的兼容？和哪些操作系统兼容？以及兼容的SAN Switch？

解答:

1. 请查看兼容性网站 System Storage Interoperation Center (SSIC)

登陆SSIC网址：http://www-03.ibm.com/systems/support/storage/config/ssic/displayesssearchwithoutjs.wss?start_over=yes

第一步：“Product Family”中选择“IBM System Storage Midrange Disk”；

第二步：“Product Model”中选择DS4000的具体型号，如：DS4700；

第三步：“Product Version”中选择产品的微码信息；

第四步：“Host Platform”选择设备连接的服务器平台类型；

第五步：“Operating System”选择操作系统平台；

第六步：“Connection Protocol”选择连接协议（连接方式）；

第七步：“Server Model”选择服务器的型号；

第八步：“HBA Vendor”选择主机上HBA（FC、SAS、SCSI适配卡）的提供商；

第九步：“HBA Model”选择主机上HBA（FC、SAS、SCSI适配卡）的型号；

第十步：“SAN Vendor”选择SAN交换机的提供商；

第十一步：“SAN Model”选择SAN交换机的型号；

第十二步：“Clustering”选择支持的集群软件；

第十三步：“Multipathing”选择支持的多路径软件。

以上13步并非全部都要选择，我们可以根据实际情况，按需选择，得到符合条件的兼容性信息。

2. 请查看DS4000兼容性列表文档：

参考资料：
《IBM System Storage DS4000 Interoperability Matrix》
下载地址：http://www-03.ibm.com/systems/storage/disk/ds4000/pdf/interop-matrix.pdf

参考资料：
《IBM System Storage DS5000 Interoperability Matrix》
下载地址：http://www-03.ibm.com/systems/resources/systems_storage_disk_ds5000_interop-matrix.pdf

Top


DS4700,DS4800,DS5000,EXP 默认带多少个SFP

解答:

DS4700/DS4800/EXP810/EXP420默认均带有一半的SFP，详情如下：

 | DS4200 | DS4700 | DS4800 | EXP810 | EXP420
默认SFP数量 | 4个 | 70A：4个 72A：6个 | 8个 | 2个 | 2个
最大SFP数量 | 8个 | 70A：8个 72A：12个 | 16个 | 4个 | 4个

另外，fc#2410选件包括一对，即两个SFP模块。

DS5020机头标配带有所有端口的SFP模块，即前端主机端口默认4个，后端扩展柜端口4个，额外配置的主机端口卡（Host Port Card）默认带有SFP模块。

EXP520默认SFP数量为2个，最大SFP数量4个。

DS5100/DS5300主机端口卡（Host Port Card）默认包含所有主机端口的SFP模块，扩展柜端口（Drive Port）需要选配SFP模块，只能选择4对或8对，即8个或16个。

EXP5000 默认SFP数量为2个，最大SFP数量4个；EXP5060默认SFP数量为4个，最大SFP数量8个。


DS5000

IBM System Storage DS5100/DS5300规格一览表

DS5100/DS5300扩展柜的连接方式，及模块使用的计算 (最近更新)

DS5000常用文档下载

DS4000/DS5000电池保护原理与时间

DS4000/DS5000 SN Number、PN Number、配件或整机保修信息查询

DS5020主机接口数量、类型及组合方式

DS5020与DS4700的参数对比

DS5020缓存是否可以升级

DS5020 firmware 7.70 密码设置规则 (新增)

DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法 (新增)

DS5020的常用软件和文档下载网址 (新增)

DS5000支持的扩展柜介绍


IBM System Storage DS5100/DS5300规格一览表

解答：

型号 | 1818-51A, 1818-53A
RAID 控制器 | Dual Active
高速缓存 | 8 GB / 16 GB / 32GB / 64GB total
主机接口 | up to 16 x 4 or 8 Gbps FC host interface cards, Auto-negotiate to 1, 2, and 4 Gbps speeds or Auto-negotiate to 2, 4, and 8 Gbps speeds；up to 8 x 1Gbps iSCSI host interface cards
驱动器接口 | Sixteen 4 Gb/s drive loops support up to 448(1818-D1A) or 480(1818-G1A) drives
1818-D1A扩展所支持的驱动器；EXP810扩展所支持的驱动器（加粗） | 750/7.2K SATA DDM, 1,000 GB/7.2K SATA DDM, 2,000 GB/7.2K SATA DDM, 146.8 GB/15K 4 Gbps FC DDM, 300 GB/15K 4 Gbps FC DDM, 450 GB/15K 4 Gbps FC DDM, 600 GB/15K 4 Gbps FC DDM, 146.8 GB/15K 4 Gbps FC Encryption Capacity DDM, 300 GB/15K 4 Gbps FC Encryption Capacity DDM, 450 GB/15K 4 Gbps FC Encryption Capacity DDM, 600 GB/15K 4 Gbps FC Encryption Capacity DDM, 73GB SSD
RAID 级别 | RAID 0,1,3,5,6和10
存储器分区 | 8,16,32,64,128,256 或 512个存储分区
磁盘驱动器数量、最大值 | 扩展柜1818-D1A或EXP810:（单台支持16块硬盘） 448,不超过28个1818-D1A或者28个EXP810或者28个两者的混合;其中DS5100磁盘数超过224，需要fc#7371； 扩展柜1818-G1A:（单台支持60块1TB SATA硬盘） 480,不超过8个1818-G1A;其中DS5100增加到第八个扩展柜时，需要fc#7371和fc#7372; DS5300增加到第八个扩展柜时，需要fc#7373。
风扇和电源 | 双重冗余，支持热交换
机架支持 | 19"行业标准机架
管理软件 | IBM System Storage DS Storage Manager
SAN 支持 | 请见 http://www-03.ibm.com/systems/storage/disk/ds5000/interop-matrix.html
相对湿度 | DS5000系列控制器外壳 | EXP5000 扩展柜 | EXP5060 扩展柜（1818-G1A）
操作范围 存储范围 转变范围 最大露点 最大梯度 | 20% to 80% 10% to 93% 5% to 95% 26°C (79°F) 每小时 10% | 20% to 80% 10% to 90% 5% to 95% 26°C (79°F) 每小时 10% | 8% to 80% 5% to 90% 5% to 95% 26°C (79°F) 每小时 10%
高度范围 | DS5000 系列控制器外壳 | EXP5000 扩展柜 | EXP5060 扩展柜（1818-G1A）
操作 | 海平面以下 30.5米 (100英尺)至海平面以上 3,048 m (10,000英尺) | 海平面以下 30.5米 (100英尺)至海平面以上 3,000m (9842英尺) | 海平面以下 30.5 米 (100 英尺)至海平面以上 3,000 m (9842 英尺)
存储 | 海平面以下 30.5米 (100英尺)至海平面以上 3,048 m (10,000 英尺) | 海平面以下 30.5米 (100英尺) 至海平面以上 3,000m (9842英尺) | 海平面以下 30.5 米 (100 英尺) 至海平面以上 3,000 m (9842 英尺)
转变 | 海平面以下 30.5米 (100英尺)至海平面以上 12000 m (40,000英尺) | 海平面以下 30.5米 (100英尺)至海平面以上 12000m (40,000英尺) | 海平面以下 30.5米 (100英尺)至海平面以上 12000m (40,000英尺)
热扩散 | DS5000 系列控制器外壳 | EXP5000 扩展柜 | EXP5060 扩展柜（1818-G1A）
Btu/Hr KVA Watts (AC) Amps (240 VAC) | 1,842 0.562 540 2.25 | 1,517 0.462 444 1.85 | 4,884（满配） - 1428 8.62 - 7.19
噪声 | DS5000 系列控制器外壳 | EXP5000 扩展柜 | EXP5060 扩展柜（1818-G1A）
音量 声压 | 6.0 bels 60dBA | 6.5 bels 65dBA | 6.8 bels -
电力输入 | DS5000 系列控制器外壳 | EXP5000 扩展柜 | EXP5060 扩展柜（1818-G1A
通常的电压范围 频率范围 最大操作电压 典型电压值 | 90VAC to 264VAC 50 to 60 Hz 5.40 A at 100 VAC 2.25 A at 240 VAC | 90VAC to 264VAC 50 to 60 Hz 3.90 A at 100 VAC 2.06 A at 240 VAC 115 VAC, 60 Hz, 0.73的电源效率、0.96 的功率因子 230 VAC, 60 Hz, 0.73 的电源效率、0.96 的功率因子 | 200 VAC to 240 VAC 50 to 60 Hz - -

Top


DS5100/DS5300扩展柜的连接方式，及模块使用的计算

解答：

DS5100 DS5300连接扩展柜时：

1、在无EXP5060中继连接的情况下，小于等于8个扩展柜时，每个扩展柜一个单独的环路对(Loop-pair)；当大于8个扩展柜时，再在环路里添加第二个扩展柜。在DS5100 DS5300机头的SFP模块配置中，小于等于4个扩展柜时选4个fc#2412，大于4个扩展柜时选8个fc#2412.在DS5100 DS5300扩展柜的SFP模块配置中，8个以内的扩展柜都不需要额外添加SFP模块（标配带一对SFP模块），8个以上的扩展柜，每个扩展柜添加一对模块。

2、在有EXP5060中继连接的情况下，一个EXP5060占用2个扩展环路，即把一个中继连接的EXP5060当成两个普通扩展柜时的连接，计算模块和线缆。

1-4台扩展柜连接示意图（DS5100/DS5300需要4个fc#2412，扩展柜不需要额外配置SFP模块）

5-8台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，扩展柜不需要额外配置SFP模块）

9-16台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，8台扩展柜不需要额外配置SFP模块，剩下每个扩展柜需要额外配置1个fc#2412）

17-28台扩展柜连接示意图（DS5100/DS5300需要8个fc#2412，8台扩展柜不需要额外配置SFP模块，剩下每个扩展柜需要额外配置1个fc#2412）

EXP5060中继连接时，一个环路占用普通两个环路的端口数量：

Top


DS5000常用文档下载

解答:

用户可以通过以下链接下载到DS5000常用的文档：

DS5000 US Announcement Letter
http://www-01.ibm.com/common/ssi/rep_ca/6/897/ENUS108-546/ENUS108-546.PDF

Installation, User's and Maintenance guide - IBM System Storage DS5000 EXP5000 Storage Expansion Enclosure
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5077661&brandind=5000028

Copy Services User's guide - IBM System Storage DS4000 and DS5000 Storage Manager
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-61173&brandind=5000028

Installation and Host Support Guide - IBM System Storage DS Storage Manager v10.30
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5075652&brandind=5000028

Installation and Migration guide - IBM System Storage DS4000/DS5000 hard drive and storage expansion enclosure
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-57818&brandind=5000028

Installation, User's and Maintenance guide - IBM System Storage DS4000/DS5000 EXP810 Storage Expansion Enclosure
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-63258&brandind=5000028

Installation, User's, and Maintenance guide - IBM System Storage DS5100 and DS5300
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5077659&brandind=5000028

Installing or replacing a cache or flash memory card - IBM System Storage DS5000
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5077726&brandind=5000028

Installing or replacing a host interface card - IBM System Storage DS5000
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5077664&brandind=5000028

Quick Start Guide - IBM System Storage DS5020
http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5082746&brandind=5000028

Quick Start Guide - IBM DS5100 and DS5300 Storage Subsystems, and EXP5000 Storage Expansion Enclosure
http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=MIGR-5080258&brandind=5000028

Replacing a controller - IBM System Storage DS5000
http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5077665&brandind=5000028

DS5000 Disk Storage System Architecture Implementation and Usage
http://publibfp.dhe.ibm.com/epubs/pdf/sg247676.pdf

Top


DS4000/DS5000电池保护原理与时间

解答:

DS4000系列存储Cache电池保护时间标称为72小时。由于DS4000的Cache是一种易失性存储介质，需要持续供电才能存储数据，一旦失去供电Cache中的数据将丢失。如果DS4000打开Cache功能（尤其是write Cache），应用端数据写到Cache中就会返回写成功，但此时数据并没有写到磁盘中（一般需要一定条件触发从Cache写到磁盘，如：10秒以后或Cache容量达到80%等，该过程称作flush），若意外掉电，电池就会保护Cache中的数据，该电池为充电电池，可以保护72小时。

出于数据安全性的考虑，一旦电池失效，DS4000会自动禁用Cache功能，可能导致性能下降，需要尽快维修或更换电池解决。

DS5000系列存储Cache电池保护机制与DS4000不再相同，DS5000的控制器中增加了一个USB闪存，当意外掉电时，DS5000将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。

参考资料：
书名:《IBM System Storage DS4000 and Storage Manager V10.30》
参考链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg247010.pdf

书名:《Introduction to the IBM System Storage DS5000 Series》
参考链接：http://publibfp.boulder.ibm.com/epubs/pdf/sg247676.pdf

突出价值点：DS5000拥有和Cache同样大小的USB闪存，当意外掉电时，所有数据均可以通过电池保护复制到非易失性闪存中，进行永久保存。这样的设计保证了DS5000产品处理数据的零丢失，保证用户数据安全，提高用户整体系统在意外事故中数据的安全可靠与零风险。


DS4000/DS5000 SN Number、PN Number、配件或整机保修信息查询

解答:

DS4000/DS5000存储产品的S/N number可以机器上的标签处查找到。具体位置请参考下图：

"

对于DS4000/DS5000存储产的组件，如控制器，主机接口卡、缓存以及存储扩展柜等部件的S/N number、P/N number等信息，可以通过Storage Manager管理软件查看。

要查看存储系统概要文件，请执行以下步骤：
1. 从Storage Manager Enterprise Management 窗口中打开Storage Subsystem Management 窗口。
2. 选择Storage Subsystem → View → Profile。Storage Subsystem Profile 窗口随即打开。
3. 选择Controllers 选项卡。
4. 滚动列表以查找存储子系统的Part Number 与Serial number。
5. 选择Enclosures 选项卡。
6. 滚动列表以查找支持的存储扩展机柜的Part Number 与Serial number。

注： DS4000/DS5000所有产品的保修政策与时间问题，请联系IBM 销售代表予以确认。IBM 技术热线不提供此类问题的支持。


DS5020 主机接口数量、类型及组合方式

解答：

DS5020有两种类型的主机端口：

1)8Gbps FC主机接口用于连接主机HBA卡或者光纤交换机，实现FC SAN功能；
2)1Gbps iSCSI主机接口用于连接以太网卡、iSCSI卡或者以太网交换机，实现IP SAN功能。

DS5020最少配置4个FC主机端口(每个控制器2个FC主机端口)，也可以再增加4个FC主机端口或者4个iSCSI主机端口。

在e-config中可以配置出三种数量和类型主机接口的DS5020：

1) 既不选择fc#2080，也不选择fc#2081，则DS5020共有4个8Gbps FC主机端口(每个控制器2个FC主机端口)；
2) 选择fc#2080，则DS5020共有8个8Gbps FC主机端口(每个控制器4个FC主机端口)；
3) 选择fc#2081，则DS5020共有4个8Gbps FC主机端口和4个1Gbps iSCSI主机端口(每个控制器2个FC主机端口，2个iSCSI主机端口)。

其中FC主机端口均随机自带SFP模块，此外，到目前为止，以上三种配置的DS5020不能更改或升级主机端口的配置。

突出价值点：支持最新的8Gbps的FC SAN传输速率，能够向下兼容4Gbps，2Gbps方式，具有竞争力的性能以及投资保护特性；支持多种主机端口，满足不同级别客户的不同需求，其中iSCSI接口，能够使客户使用更具性价比的传输方式，完成非关键业务的工作。


DS5020与DS4700的参数对比

解答:

双控制器 | DS4700(70A，72A) | DS5020
处理器 | Intel xScale 667MHz | Intel xScale 1.2GHz
主机端口 | 4个4Gb/s FC； or 8个4Gb/s FC | 4个8Gb/s FC；or 8个8Gb/s FC；or 4个8Gb/s FC and 4个1Gb/s iSCSI
缓存（最小/最大） | 2GB/4GB | 2GB/4GB
总线技术 | PCI-X (1GB/s) | PCI-Express ×8(4 GB/s)
最大硬盘数 | 112 FC/SATA | 112 FC/FDE/SATA
最大连接主机数 | 1024 | 1024
最大LUN数 | 1024 | 1024
最大缓存IOPS | 120,000 IOPS | 200,000 IOPS
磁盘读IOPS | 40,000 IOPS | 50,000 IOPS
磁盘读吞吐量 | 980 MB/s | 1,600 MB/s
RAID级别 | 0，1，3，5，6，10 | 0，1，3，5，6，10

从上述参数可以看到在最大主机端口数和最大磁盘数上两者是相同的，但是DS5020的FC主机端口速率是8Gb/s而且支持1Gb/s的iSCSI接口，这就为链路连接提供了优势。DS5020同时支持全盘加密功能，这也是一个很明显的优势。

对于两者控制器，DS5020比DS4700处理器性能提高了80%，内部总线带宽提高了300%，这两者将DS5020整体性能（最大缓存IOPS）提高了67%。

Top


DS5020缓存是否可以升级

解答:

不可以。DS5020目前支持2GB（每控制器1GB）或4GB（每控制器2GB）缓存，e-config中默认是2GB缓存配置，配置4GB缓存机型需要增加fc#2070选件（如图所示），目前，DS5020不支持将2GB缓存MES升级到4GB缓存。最新缓存配置信息请以官方发布为准。


DS5020 firmware 7.70 密码设置规则

解答:

如果DS5020 firmware 为7.70， 当首次用Storage Manager添加作管理时，要求必须设置密码，密码的设置规则是：8到30个字符，且必须包含至少一个数字，一个小写字母，一个大写字母，和一个不规则字符（如：<> ! @ + # 等），且不允许有空格。另外，该密码是大小写敏感的。

下图是DS5000 Storage Manager 10.70的设置密码窗口截图:


DS5020和B24/B40/B80的8 Gbps 端口无法连通的解决方法

解答:

当DS5020的host port是8 Gbps 的host端口，当和IBM 2498-B24/B40/B80的8 Gbps 端口连接时，且2498-B24/B40/B80的微码版本是6.2.0e 或以上时，将会出现无法连通的情况。

解决方法：

使用下列命令来把2498-B24/B40/B80上和DS520连接的端口设置成IDLE 模式，在2498-B24/B40/B80的命令行窗口下输入下列命令：

#portcfgfillword x 0 (其中x 是交换机的端口号)

当把2498-B24/B40/B80上和DS520连接的端口设置成IDLE 模式后，DS5020将会自动和2498-B24/B40/B80建立起 8 Gbps 的连接。


DS5020的常用软件和文档下载网址

解答:

DS5000 常用软件下载网址:

DS5000 Storage Manger V10.70 32bit (x86) 和 64bit(x64) for Windows2003 和 Windows2008：
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=All&platform=All&function=fixId&fixids=Disk-SM-Windows_x86-Dec-2010-version-10.70.x5.25,Disk-SM-Windows_x64-Dec-2010-version-10.70.x5.25&includeRequisites=1&downloadMethod=http&source=fc

IBM DS Controller firmware version 7.70.38.00 :
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=DS_fw_v7.70.38.00&platform=All&function=fixId&fixids=Disk-CntlFW-Dec-2010-version-7.70.38.00&includeRequisites=1&downloadMethod=http&source=fc

IBM DS ESM/HDD firmare package version 1.72:
http://www-933.ibm.com/support/fixcentral/swg/quickorder?parent=ibm~Storage_Disk&product=ibm/Storage_Disk/DS5020&release=DS_HDDESM_v1.72&platform=All&function=fixId&fixids=Disk-HDDESM-Jan-2011-version-1.72&includeRequisites=1&downloadMethod=http&source=fc

上述3个链接需要输入IBM网站的id和password, 如果没有id可以先注册，再登陆下载。

Linux RDAC Driver Package for IBM DS4000/DS5000 Storage Subsystems:
http://www.lsi.com/rdac/ds4000.html

DS5000 Redbooks 下载网址:
IBM Midrange System Storage Hardware Guide:
http://publib-b.boulder.ibm.com/abstracts/sg247676.html?Open

IBM Midrange System Storage Implementation and Best Practices Guide:
http://www.redbooks.ibm.com/Redbooks.nsf/RedbookAbstracts/sg246363.html?OpenDocument

IBM Midrange System Storage Copy Services Guide:
http://www.redbooks.ibm.com/abstracts/sg247822.html?Open


DS5000支持的扩展柜介绍

解答:

EXP5060是DS5100/DS5300专用的高密度扩展柜，能在一个4U高的柜子里放60块SATA硬盘。EXP5060中包含6个硬盘抽屉，每个抽屉10块硬盘。有效节约客户的空间成本，并且在DS5100/DS5300没有EXP5000扩展柜的前提下，能扩展到480块硬盘。

EXP5060于2010年3月开始支持2TB的SATA硬盘，因此，DS5100/DS5300连接EXP5060后，支持的最大容量由原来的480TB增加至960TB。

EXP5060可以与EXP5000的扩展柜共同接入DS5100或DS5300中，但是两者必须要接入不同的环路内，而不能在同一环路内进行混接，若是DS5100或DS5300后端既有EXP5060又有EXP5000，那DS5100或者DS5300最大支持的硬盘数量为448块。

EXP5000是DS5100/DS5300的专用扩展柜，16个硬盘槽位。支持SATA硬盘，FC硬盘，加密硬盘和SSD硬盘。

EXP520是DS5020的专用扩展柜，16个硬盘槽位。支持SATA硬盘，FC硬盘，加密硬盘。

此外，DS5000系列整体可以用EXP810的扩展柜，以作投资保护。DS5020加EXP810的扩展柜，需要加fc#7414的许可。DS5100/DS5300需要加EXP810则需要走产品部RPQ特殊流程。

突出价值点：EXP5060提供了高可用的SATA盘，这种扩展柜采用了热插拔和冗余双环路的技术，为存储系统提供了连续，可靠的服务。高密度的扩展柜节约了空间成本，从而有效降低了客户的总体拥有成本（TCO）。


DS8000

DS8000 Copy Service特性

DS8000中磁盘相关基本概念

DS8700新产品特性阐述 (最近更新)

DS8700 微码实现的功能介绍 (新增)

IBM新一代存储产品DS8800产品介绍

DS8800 体系架构说明 (新增)

DS8700与DS8800 物理指标与电气特性 (新增)


DS8000 Copy Service特性

解答:

DS8000 提供非常强大的Copy Service 功能。

FlashCopy可以在你需要的任何时间迅速完成拷贝，它提供逻辑卷的快速时间点（Point-in-Time）快照，产生一份源数据卷在某一时刻的一模一样的镜像，并且目标数据卷立即可用。

FlashCopy SE的全称是FlashCopy space efficient.跟标准的DS8000 FlashCopy不同，FlashCopy SE不需要占据FlashCopy源卷那么大的物理空间。也就是说FlashCopy的目标卷是space efficient volume（一个虚拟卷，并没有占据实际的物理空间）。现在，当你需要FlashCopy功能时，你可以有更多的选择，FlashCopy 标准版（配置的物理容量必须两倍于客户的逻辑容量），FlashCopy SE近似FlashCopy 标准版功能，节省更多的物理空间。在FlashCopy SE中，改变量会被存储到repository卷，针对于每一个extent pool你只可以定义一个repository卷。这个extent pool中的FlashCopy SE 目标卷将会共享这一个repository卷。

一般的来说，FlashCopy SE方案最好适用于改变量不大的FlashCopy（源与目标卷）关系中。例如： 那些FlashCopy target卷只需要存在一个相对较短的时间。

DS8000 提供三种典型的数据灾难复制方案。Metro Mirror，Global Mirror, Metro Global Mirror等。

Metro Mirror 是同步数据复制方案，始终保持本地数据和异地数据是一致的。每一次IO都需要在异地的DS8000 上先完成，本地的IO才能完成。这种数据复制功能对本地DS8000的IO性能有影响，根据距离的增加影响会越来越大。理论上，最大支持300 公里的Metro Mirror方案。

Global Mirror 是异步复制方案，本地数据和异地数据不是实时同步的，本地IO的完成跟异地IO没有关系。一般的情况下，异地数据总是和本地数据有着一定的差别（异地的数据没有本地的数据新，差着时间点）。基本上，Global Mirror 对本地DS8000 的IO 性能没有影响。理论上，Global Mirror 不受距离限制。

Metro Global Mirror 是一个三点数据灾备方案，典型的是，同城做一个Metro Mirror的方案，然后在异地配置一个Global Mirror的方案。小范围内的灾难，在同城进行恢复（恢复速度快，数据几乎没有丢失），如果是大范围的灾难，在异地进行恢复（恢复速度慢，丢失一部分的数据）。这是一个完全的数据灾难方案，适用于多种灾难情况，而且能根据具体的情况，三点数据灾难方案可以做相应的调整。

Remote pair Flashcopy 是为了避免当Metro Mirror primary volume成为一个Flashcopy的 target volume时，从Metro Mirror primary volume到Metro Mirror secondary volume发生数据物理移动。在本地DS8000上，只须传送一个inband FlashCopy 命令来触发远程DS8000上的一个Flashcopy操作，而不是从本地DS8000到远程DS8000通过Metro Mirror来mirror数据。这样可以减少对本地DS8000和远程DS8000之间带宽的占用。

当本地DS8000上执行一个Flashcopy命令，开始从Local A 到 Local B的flashcopy。同时，也会有一条相似的inband flashcopy命令通过FC link从本地DS8000传给远程DS8000，开始从Remote A到 Remote B的flashcopy。

目前，本地和远程都只有一份数据，现在想在本地和远程再都增加一份数据，不想占用本地和远程之间的带宽，采用Remote pair Flashcopy方法。

创建Remote Pair FlashCopy的前提条件是：
1．Local A / Remote A 和 Local B / Remote B 必须已经是2对Metro Mirror pairs，且这2对Metro Mirror pairs必须是处于full duplex 状态。
2．Remote A 和Remote B 必须位于同一台DS8000中的同一个Storage Facility Image (SFI)上。

参考资料
书名：《IBM System Storage DS8000 Series Copy Services in Open Environments》
书号：SG24-6788-03
参考章节：Part4，Part6，Part7
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246788.pdf

Top


DS8000中磁盘相关基本概念

解答:

DDM:

一个磁盘驱动器模块(Disk Drive Module (DDM)是一个可替换的单元，包含一块单独的磁盘和它相应的包装。 DDMs 订购是以16块盘为一组，又叫做一个a drive set. 一个 drive set 是跨两个disk enclosures, 8 DDMs 在前面的(front) disk enclosure ，8 DDMs 在后面的(rear) disk enclosure. 当订购disk enclosures 时，它们是成对出现的，每个可以插16块硬盘 。如果任何一个 disk enclosure 没有插满 DDMs, 则空的槽位必须被哑盘(dummy carriers )来填充，又叫做disk enclosure fillers. Disk enclosure fillers 可以以16为一组来订购。

Array sites:

Array site 是用于定义arrays的building blocks。一个 array site 是一组硬盘，由8块相同转速和容量的硬盘组成，这8块硬盘会从位于不同环路里的2个disk enclosures 里选择，例如：4块硬盘来自环路1，另外4块硬盘来自环路2。通常都是4块磁盘来自一个后面的(rear)disk enclosure ，4块磁盘来自前面的(front) disk enclosure 。

Arrays:
一个 array 是在一个array site里创建,创建一个array意味着首先要定义一个特定的RAID 类型，DS8000支持的RAID 类型是RAID-5 和RAID-10 . 对于每一个array site ，你可以选择一个RAID 类型，为一个array选择RAID类型的过程也叫做定义一个 array。
对于DS8000 热备盘的算法（sparing algorithm）,一个array site可以定义0到2个热备盘。 一个array 是定义在一个array site里，当这个array 能被一个device adapter pair 里的每个adapter 访问, 它由一个device adapter来管理. 由哪个adapter 和哪个server 来管理这个 array 会在后来configuration path时作定义。

DS8000有下列6种 RAID 配置可供选择:
- 3+3 RAID 10 配置，Array 包含6块数据盘，其中3块是做镜像的数据盘。该Array Site另外剩下的2块盘作为热备盘。（6+2S）
- 4+4 RAID 10 配置，Array 包含8块数据盘，其中4块是做镜像的数据盘。
- 6+P RAID 5 配置，Array 包含6块数据盘和1块奇偶校验盘。该Array Site另外剩下的1块盘作为热备盘。(6+P+S)
- 7+P RAID 5 配置， Array 包含7块数据盘和1块奇偶校验盘。(7+P)
- 5+P+Q+S RAID 6 配置，Array 包含5块数据盘和2块奇偶校验盘。该Array Site另外剩下的1块盘作为热备盘。
- 6+P+Q RAID 6 配置，Array 包含6块数据盘和2块奇偶校验盘。

Rank:
当定义一个新的rank, 它的名字由DS Storage Manager来选择, 例如：R1, R2, 或 R3, 等等。你必须添加一个array 到一个rank里。目前，一个rank里只能包含一个array，但将来会允许一个rank里有一个或多个arrays。每一个rank里可用的空间将会被划分成extents。extents 是逻辑卷的building blocks。一个 extent 是跨一个array的所有磁盘的条带。创建一个rank 的同时需要会做两件事：
- 这个Array被格式化成或者是 FB (open systems) 或是 CKD (zSeries) 数据。
- 这个Array的容量被分成相同大小的partitions, 叫做 extents. 这个extent 大小取决于extent 类型， FB 或 CKD。一个FB rank 拥有一个extent 的大小是 1 GB。

参考资料：
书名：《IBM System Storage DS8000 Series Copy Services in Open Environments》
书号：SG24-6788-03
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246788.pdf

书名：《IBM System Storage DS8000 Architecture and Implementation》
书号：SG24-6786-07
地址：http://www.redbooks.ibm.com/abstracts/sg246786.html?Open


DS8700新产品特性阐述

解答：

IBM System Storage DS8700相比前一代DS8000产品,为客户提供了更高的性能、更优的可靠性和弹性，及更高的能效。DS8700采用了基于IBM POWER6处理器的控制器、全新内部PCIE光纤连接方式、全新的微码、以及增强的设备适配器，与之前最强大的机型DS8300相比其性能提高了150%，这使得DS8700能够更好地满足更为苛刻的业务应用和业务分析需求。

System Storage DS8700能够支持客户在不中断运行的前提下从基础型号升级到最高级的型号，从而帮助企业可以根据需求扩容，而无需购买全新系统。除具有灵活性和可扩展性外，DS8700还能使客户从上一代产品的投资中获益。比如DS8700支持与上一代型号的硬盘、硬盘盒、工具、脚本和拷贝服务之间的全面兼容。此外，新的System Storage DS8700更具能效，IOPS/watt(每秒读写操作次数)比之前的DS8300提高了50%以上。

DS8700与DS8100/DS8300硬件参数对比：

 | DS8100 | DS8300 | DS8700
DDMs(min-max) | 16-384 | 16-1024 | 16-1024
DDM Interface | FC-AL | FC-AL | FC-AL
FC DDM Types | 146, 300, 450 GB | 146, 300, 450 GB | 300, 450，600GB
SATA DDM Types | 1 TB（停产） | 1 TB（停产） | 2 TB
SSD DDM Types | 73, 146 GB | 73, 146 GB | 73, 146 GB
RAID Types | RAID 5, 6, 10 | RAID 5, 6, 10 | RAID 5, 6, 10
Max Capacity w/146GB DDM | 56 TB | 239.2 TB | 239.2 TB
Max Capacity w/450GB DDM | 173 TB | 717.6 TB | 717.6 TB
Max Number of LUNs / CKD volumes | 64K total | 64K total | 64K total
Max N-Port Logins/Port | 510 | 510 | 510
Max Process Logins | 2K | 2K | 2K
Max Logical Paths / CU | 512 | 512 | 512
Max LUN Size | 2 TB | 2 TB | 2 TB
Dynamic Provisioning | Add / Del | Add / Del | Add / Del
Cache / NVS | 16-128GB/1-4GB | 32-284GB/1-8GB | 32-384GB/1-12GB
Processor | P5 2.2GHz 2-way | P5 2.2GHz 4-way | P6 4.7GHz 2 or 4-way
Host Adapters | ESCON x 2 ports 4 Gb FC x 4 ports | ESCON x 2 ports 4 Gb FC x 4 ports | 4 Gb FC x 4 ports
Host Adapter Slots | 16 | 32 | 32
Max Host Adapter Ports | 64 | 128 | 128
PPRC Fabric | FCP | FCP | FCP
DA Slots | 8 | 16 | 16

更多DS8000存储产品信息请参考：
http://www-900.ibm.com/storage/cn/disk/ds8000/index.shtml

DS8700动态架构高可用性方案介绍：
https://www-900.ibm.com/systems/cn/dihub/products_innovation/storage_advantage/09q4_ds87/index.shtml

DS8700产品架构以及使用红皮书：
http://www.redbooks.ibm.com/redpieces/pdfs/sg248786.pdf

Top


DS8700 微码实现的功能介绍

解答:

IBM System Storage DS8700 的最新微码为5.1版本，提供了如下新功能：

.提供IBM System Storage Easy Tier 功能；

.提供73GB、146GB 与600GB容量固态盘8磁盘组配置；

.提供600 GB 15,000 rpm Fibre Channel 磁盘；

.提供2 TB 7,200 rpm SATA 磁盘；

.提供Quick initialization与Thin Provisioning for open volumes 功能；

.提供Remote Pair FlashCopy功能；

.提供Concurrent code load improvements功能；

.提供Prevent deletion of CKD and FB volumes in use功能；

.提供Disable recovery key功能；

.提供Rekey data keys of an encryption group功能；

.提供z/HPF extended distance。

Top


IBM新一代存储产品DS8800产品介绍

解答：

随着数据的爆炸式增长，许多企业都在竭力管理、保护和维护飞速增长的信息资产并极力减轻风险。在控制服务级别和增长速率的同时降低企业风险并优化存储管理成本，这就需要一个可靠的信息基础架构。IBM DS8800 是IBM新分布的最新一代企业级磁盘存储产品，为客户提供了高性能，高容量，高扩展性与高可靠性的存储产品。

IBM全新的企业级的存储产品DS8800，应用了强大而又久经市场考验的Power6+的控制器，主频由DS8700 的4.7GHz 提升到5GHz，特别使DS8800较之先前产品在顺序读写性能上有了效大提升。

IBM DS8800由于使用了全新的存储磁盘柜的设计，使得整个机器的存储密度增加了。全新存储磁盘柜为2U高，支持24块2.5英寸6Gb SAS或固态盘，从DA卡到它的连接依然通过光纤线。

IBM DS8800包括一个主柜与最多配置两个扩展柜，最大支持1056块磁盘。在双两路的配置下，只能配置一个主柜最多支持240块磁盘。在双四路配置下，最多可以增加2个扩展柜，最多支持1056块磁盘，达到以更小占用空间内集聚更多数据的目的，实现前所未有的性能水平。以便更好的节省机房的空间，降低运营成本。

IBM DS8800最新支持16块4端口或8端口8Gb 长波或短波 Fibre Channel/FICON主机接口卡，并自适应8Gb、4Gb与2Gb的链路速率，最多支持128个主机接口。DS8800另一个重要的提升在于后端设备接口卡升级到了8Gb，极大提升IOPS性能，吞吐率与可扩展性。

IBM DS8800采用前进风，后出风的散热方式，满足用户数据中心的整体规划，以达到节省能源的目的。在内部数据分配方式上，IBM DS880在默认情况下自动将卷组的数据分布在一个extent pool上的所有rank上，以便有效消除热点数据，提升性能与减少管理复杂度。

Top


DS8800 体系架构说明

解答:

IBM DS8800 是IBM新分布的最新一代企业级磁盘存储产品，为客户提供了高性能，高容量，高扩展性与高可靠性的存储产品。

IBM的设计思路是将服务器和大型主机领域的领先技术应用到存储上。DS8800将存储的处理能力分布在前端、控制层、后端3个层次，使得存储的IO响应时间非常快。IBM DS8800采用了全新的IBM POWER6+ 5.0 GHz处理器架构作为其核心的控制器，最大支持384GB缓存并且采用业界独有的各种缓存专利技术，ARP算法成倍提高缓存命中率，AMP算法成倍提高RAID5顺序访问速度，而IWC算法极大提高数据随机写性能。

IBM DS8800内部IO抽屉与控制器之间依然采用了PCI-E点对点光纤连接方式，两台控制器之间保留的RIO-G环路用于处理器之间的通信。

IBM DS8800由于使用了全新的存储磁盘柜的设计，使得整个机器的存储密度增加了。全新存储磁盘柜为2U高，支持24块2.5英寸6Gb SAS或固态盘，从DA卡到它的连接依然通过光纤线。

IBM DS8800内部IO抽屉中安装两种两型的适配卡，即主机适配卡与设备适配卡。其中主机设备卡用于连接前端的主机接口或者SAN网络接口，设备适配卡用于连扫后端的磁盘组并且用于管理、监控与重建RAID。在DS8800中，采用了全新的设备适配卡设计并支持8Gb/s的传输速率。。每个设备适配卡并且必须成对安装以冗余的方式连接后端的磁盘组。

IBM DS8800最新支持16块4端口或8端口8Gb 长波或短波 Fibre Channel/FICON主机接口卡，并自适应8Gb、4Gb与2Gb的链路速率，最多支持128个主机接口。

DS8800 系统架构示意图：

Top


DS8700与DS8800 物理指标与电气特性

解答:

DS8700与DS8800物理指标如下：

DS8700与DS8800电气特性如下：

Top


XIV

XIV磁盘存储的功率、尺寸与工作环境

XIV磁盘存储的技术特征与产品优势 (最近更新)

XIV磁盘存储的硬件特征

IBM XIV Storage System Software V10.2新功能


XIV磁盘存储的功率、尺寸与工作环境

解答：

型号：2810-A14/2812-A14

宽：600mm

深：1092mm

高：1991mm

最大重量：869kg

最大功率：8.4kw

噪声：8.4bels

散热量：26K Btu/hour

温度：10-35摄氏度

相对湿度：25%-80%

由于XIV是由interface module（接口模块）和data module(数据模块)组成，因此不同容量配置的XIV其功率是不一致的，主要区别如下：

Modules | Disks | Power usage 1TB/2TB
 |  | KVA(peak) | KVA(IdIe) | KBTU
6 | 72 | 3.4/3.1 | 2.9/2.8 | 11.0
9 | 108 | 5.0/5.4 | 4.2/4.0 | 16.4
10 | 120 | 5.5/4.9 | 4.7/4.4 | 17.8
11 | 132 | 6.1/5.4 | 5.2/4.7 | 19.3
12 | 144 | 6.7/5.8 | 5.7/5.1 | 20.7
13 | 156 | 7.2/6.2 | 6.2/5.5 | 22.2
14 | 168 | 7.8/6.6 | 6.7/5.9 | 23.6
15 | 180 | 8.4/7.1 | 7.2/6.2 | 25.1

参考资料：

XIV销售手册（Sales Manual）

XIV数据手册（Data Sheet）

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


XIV磁盘存储的技术特征与产品优势

解答：

技术特征：

1.先进的系统架构--分布式算法：数据被“切割”为"分区"，分布式算法自动地将分区跨所有的磁盘,无存储热点；

2.支持1TB或2TB的磁盘；

3.快照(SnapShot)：

差异快照(Differential SnapShot): 只复制更改的数据；

全复制(Full Copy): 后台全复制(克隆)；

多重关系快照(Multiple Snapshot): 可写的快照卷。

4.Thin Provisioning功能:提供硬(物理)和软(虚拟)容量设置,存储空间分配更加灵活方便；

5.同步与异步镜像：可通过以太网、iSCSI及光纤实现；

6.数据迁移：XIV系统可作为主机和旧存储的代理。

产品优势：

1.较低的总体拥有成本(TCO)：

易于管理，节约人力成本；

更加省电，节约空间；

使用SATA硬盘实现FC硬盘的性能；

没有附加软件功能费用。

2.高可靠性：

自愈(self-healing)功能；

30分钟内重建1TB的SATA硬盘。

3.高性能：

先进的分布式算法：使所有硬盘平均负载I/O，避免热点盘和I/O瓶颈；

平均分配的缓存(Cache)，使用先进的缓存算法和高速磁盘与缓存带宽；

通过分布保护机制，磁盘重建(Rebuild)时，不影响系统性能。

4.先进的快照(SnapShot)技术：

支持最多16,000个快照；

先进的ROW快照技术，快照时对生产数据的性能不会产生负面影响。

丰富的存储复制功能集合

1.每卷支持多达16,000 份快照；

2.卷快照，卷拷贝，从快照恢复卷均为瞬时操作。完成时间小于秒级；

3.快照可以更改为可写模，但仍然保持差分(仅占用变化的数据空间)；

4.支持所有快照功能，包括差分快照和物理全拷贝；

5.支持一致组Consistent Group，多个卷可以在同一时间点完成快照，保障数据一致性；

6.部署灵活，可灵活的将快照映射到主机，拷贝快照到卷，复制快照等等；

7.高性能快照：XIV 存储系统将其创新的复制算法和其大规模 CPU 处理能力及 Cache 缓存能力结合，保障快照对性能的影响最小化；

8.传统的 Copy-On-Write 技术为更高效的Redirect-On-Write 技术取代。消除了不必要的内部拷贝动作；

9.Redirect-on-write 操作总是在同一模块内部完成。磁盘之间的数据拷贝通过高速 PCI-X 总线完成。这相对于传统的在模块或控制器之间的拷贝而言极大的提升了性能；

10.快照的写操作开销不依赖于快照的数量和卷的大小；

11.对快照和卷的读操作零开销 。

可靠性方面的优势

XIV 存储系统通过其网格架构及独特的RAID-X 保护机制提供了前所未有的系统可靠性。

这些特性使得系统几乎不受任何单点故障的影响，并大大降低了双重故障的风险。

1.真正的无单点故障
XIV 系统中的冗余架构保障任何单点故障对主机 I/O 均无影响。所有的磁盘，数据模块，交换机或UPS 均为冗余方式配置，并通过 Active-Active 的 N+1 方式提供保护。每一组件均可热插拔，这意味着整个系统无须停机便可实现更替。

2.30分钟重建1TB磁盘驱动器
XIV 系统的设计目标之一便是要最小化双重磁盘故障风险。利用其创新的RAID-X 设计，每一磁盘均会分成很多小的条带，每一条带又会镜像到不同的磁盘之上。这一架构的优越之处在于当磁盘出现故障时，系统中所有的磁盘均会参与重建。在系统利用率达到近 100%的情形下(充满数据)，当一块 1TB 的磁盘驱动器故障时，系统暴露于双重磁盘故障的风险仅为 30 分钟的重建时间。如此短的重建时间极大(成数量级的)的降低了可能因双重故障而带来的数据丢失风险，特别是在同传统存储系统对比时这一优点更加明显。

3.仅重建实际数据
标准的存储系统是在块级完成磁盘重建，无论是否有有效数据完全重建整个磁盘。XIV 存储系统仅重建分配给卷的空间，甚至即使在一个卷的内部也仅重建真正写入的数据部分。因此，单个驱动器故障时的重建时间实际上可能大大小于30分钟，因为并非所有的空间都会分配出去并有数据写入。

4.模块故障时自恢复
XIV 存储系统拥有自恢复机制。在数据模块发生故障时，系统会启动重建机制重建冗余状态。故障的模块可以在系统恢复冗余状态后予以更换，保护系统免受维护人员操作错误的风险。

参考资料：
1.查阅IBM销售手册: XIV销售手册
2.《IBM XIV Storage System- Concepts, Architecture, and Usage》

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


XIV磁盘存储的硬件特征

解答：

型号：2810-A14/2812-A14

支持24 x 4Gb FC及6 x 1Gb iSCSI

高性能：提供GRID存储能力，无数据热点

高可靠性：基于GRID的重建技术

最大180块SATA磁盘，使用1TB/2TB SATA硬盘，提供约79TB/161TB的可用容量

9个数据模块，使用Single Low-Voltage CPU

6个接口模块，使用Dual Low-Voltage CPU

每个模块12块1TB/2TB SATA磁盘

3个UPS

支持120GB系统缓存（每个模块8GB）

支持同步远程镜像、自动精简配置(thin provisioning)、数据迁移及快照技术

目前XIV支持以下几种配置方式

模块总数 | 6 | 9 | 10 | 11 | 12 | 13 | 14 | 15
可用容量 | 27/55 | 43/87 | 50/102 | 54/111 | 61/125 | 66/134 | 73/149 | 79/161
接口模块 | 3 | 6 | 6 | 6 | 6 | 6 | 6 | 6
数据模块 | 3 | 3 | 4 | 5 | 6 | 7 | 8 | 9
硬盘数量 | 72 | 108 | 120 | 132 | 144 | 156 | 168 | 180
FC接口 | 8 | 16 | 16 | 20 | 20 | 24 | 24 | 24
iSCSI接口 | 0 | 4 | 4 | 6 | 6 | 6 | 6 | 6
内存(GB) | 48 | 72 | 80 | 88 | 96 | 104 | 112 | 120

参考资料：

查阅IBM销售手册:Storage System 销售手册查询

注意：内容仅供参考,如有变化,请以官方发布信息为准或咨询IBM技术支持。

Top


IBM XIV Storage System Software V10.2新功能

解答：

1. 异步方式的数据镜像
IBM XIV在10.2版本的微码之后，支持异步方式的数据镜像，并且支持一致性组的拷贝方式，以实现远距离安全的数据镜像。

2. 在线微码升级
IBM XIV在10.2微码中依然支持在线微码升级功能，此功能在10.1版本的微码中就已经可以支持了。通过在线微码升级功能，IBM XIV可以在不停机的状态下，升级系统微码。在升级过程中，XIV内部所有可升级部件都是并行升级的，升级过程非常快，不会对应用造成影响。
在线微码升级过程中，系统中不能有数据重建或者数据迁移的操作，而镜像拷贝功能也会临时的被中止，当升级完成之后，系统自动恢复。

3. ATS monitoring
IBM XIV在10.2微码中，可以通过GUI的方式在本地监控Automatic Transfer Switch (ATS)。ATS是IBM XIV内部的一个硬件组件，位于外部两个电源输入与UPS之间，为UPS提供冗余的电源供应。

4. 支持Symantec Thin Reclamation功能
为XIV的卷提供更为有效的空间分配功能。

Top


SVC

IBM SVC解决方案有哪些特点和优势

SVC 5.1和6.1软件新增功能 (最近更新)

SVC新一代引擎2145-CF8简介

利用SVC Flashcopy功能实现数据拷贝的速度

SVC的Easy Tier功能介绍(新增)


IBM SVC解决方案有哪些特点和优势

解答：

IBM SVC解决方案特点如下：

1.SAN虚拟存储控制器具备灵活的磁盘管理功能，极大的提高了存储管理的效率，例如可动态创建和扩展逻辑卷等。 而且，SVC为各种不同的存储设备提供了一个统一的数据复制平台， 例如瞬间复制 FlashCopy和远程复制 Remote Mirroring。 这些复制功能都允许源磁盘卷和目标磁盘卷可以存在于不同品牌的磁盘阵列上。

2.透明的数据迁移：当SVC被加入到一个现有的SAN 环境中时，不需要做数据迁移， SVC 把现有的磁盘配置原封不动的继承下来（这是SVC的Image mode）， 这样对服务器上的应用是完全透明的。当SVC完全配置好以后， 它又可以将原先磁盘上的卷及数据透明的迁移到其他真正的虚拟卷中。 所有的迁移过程对服务器透明，因此不需要中止应用。

3.IBM SVC是一个软硬件集成化的产品，专业的虚拟存储软件运行在集群式的硬件引擎上。 它使用了定制的IBM System x 服务器，运行的存储操作系统是基于 Linux kernel的。 与SAN网络接口是工业标准的HBA卡。由于SVC是为一个完全开放的存储环境设计的， 兼容各种不同的存储设备。用户可以将各种存储方案融合其中，而不用担心SVC会有什么封闭性。 SAN Volume Controller 天生具备灵活的扩展能力，可以使用户在存储性能和存储容量方面平滑无缝的升级。
例如，扩展控制器个数可以增加性能，而往存储池中增加磁盘则可以增加容量， 这两方面的扩张都可以在线完成，不需要中止应用。SVC的主控台提供了自动向IBM服务中心报警和远程支持的能力。

4.灵活开放的体系结构:
易于实施；
易于在性能和容量双向发展。

5.企业级的高可靠性和稳定性。

IBM SVC解决方案优势如下：

虚拟化是IBM早在40多年前就推出的一项技术，如今在许多新的领域又重新恢复了它的生机：从虚拟服务器到虚拟存储， 优化的网络，虚拟环境中的工作站，以及应用虚拟化。虚拟化技术为企业带来的潜在收益是巨大的， 不仅可以提高存储设备的利用率和业务灵活性，而且还可降低处理的总成本并提高可靠性。

根据所实施的虚拟化的起点、类型和范围不同，客户可以快速获得这些收益。 SVC目前已经发展到了5.1的版本，目前SVC已经有多于2000个实际安装用户， 支持至少50多个存储设备。同时SVC在存储性能理事会测试标准SPC-1和SPC-2的指标都获得最高性能得分， 彰显了IBM在存储领域的领导地位。

-IBM拥有40年的虚拟化技术；
-全球已经销售出13000多台SVC引擎，建立了4000个基于SVC系统；
-全球有超过130个客户参考案例；
-在性能测试中， SVC表现出了及高的性能和扩展能力；
-SVC具有最快的SPC-1基准测试值 (SVC 4.2: 272,500 IOPS)；
-SVC具有最快的SPC-2 基准测试值 (SVC4.2: 7080)；
-SVC可以支持包括IBM和非IBM在内的120多中磁盘存储系统（IBM, EMC, HP, HDS, Sun, Dell, NetApp, Fujitsu, NEC, Bull)；
-IBM从产品，到咨询，到实施，提供一整套服务。

为存储资源提供单点控制 , 可提高管理效率,可帮助支持业务应用程序可用性。

将 SAN 上的多个系统的存储容量整合为一个存储池, 可帮助您将存储作为资源而不仅仅是一组箱子来进行管理，从而满足业务要求, 可帮助管理员超越传统的“SAN 孤岛”，更好地根据需要部署存储, 可帮助提高存储资产的利用率, 使应用程序免受存储基础架构物理变化的影响。

对固态设备 （SSD） 的创新紧密集成支持 专为关键应用程序数据提供超高的性能 SVC 架构可将 SSD 的性能和容量扩展至高达 2.4 TB 和每秒 800,000 次读 I/O，却只需极小的入门级配置，这有助于使 SSD 更加经济实惠 将数据移入/移出 SSD，而不造成中断；在硬盘驱动器上创建固态驱动器数据的副本。

突出价值点:
SVC解决方案实现了存储空间的统一管理和虚拟化。
SVC 解决方案提供了异构存储设备之间的数据迁移，和实现了异构存储设备之间远程镜像功能。

Top


SVC 5.1和6.1软件新增功能

解答:

SVC 6.1 新增功能：

1. Completely redesigned user interface
和new Storwize V7000 GUI用户界面很相似，CLI用户界面没有变化。

2. Easy Tier
支持和V7000和DS8000一样的Easy Tier功能，可以更好的发挥SSD硬盘的性能。

3. Scalability
最大 extent size 增加到原来的4倍，达到8GB；
最大 volume size 增加到256TB；
最大 WWNNs 的数目增加到原来的4倍，达到256。

4. Interoperability
支持新的server software：
VMware vSphere 4.1；
支持新的disk system：
IBM Storwize V7000
IBM System Storage DS8800
EMC Symmetrix VMAX
Compellent Series 20 Storage Controller
Fujitsu Eternus Models DX60, DX80, DX90, DX410, DX8100, DX8300, DX9700。

5. SVC for XIV
针对XIV,采用特殊的license配置。

SVC 5.1 新增功能：

1. Multi Cluster Mirroring
支持四个Cluster之间的MM/GM复制伙伴关系。

2. 8129 relationship support
支持 8192 Metro Mirror and/Global Mirror relationship，之前的版本只支持1024个。

3. Space Efficient VDisks – zero detect
支持将 非SE的VDisk 中没有使用过的容量(zeros)回收到SVC MDG里，把VDisk变为SEV,为客户腾出更多的存储空间，更有效的利用存储。

4. Dual Ethernet port support and iSCSI
SVC 使用集成的两个以太网口来做 iSCSI 访问。

5. Reverse FlashCopy
支持把FlashCopy 的某一个目标VDisk 恢复到源VDisk上，并且不需要停止原有的 FlashCopy关系，并且不需要等原有的FlashCopy关系结束。

6. 256 TB VDisk support
VDisks 最大支持 256 TB。

7. Remote authentication via Tivoli Integrated Portal
SVC 5.1 不仅支持本地认证，也支持远程用户认证。

8. Syslog support
专对当前SVC email and SNMP trap 功能新增的日志。

9. Auto-recovery of node metadata
提高客户的可用性。

10.SVC Console (GUI) Changes
支持Windows 2008。

突出价值点：SAN虚拟存储控制器具备灵活的磁盘管理功能，极大的提高了存储管理的效率，例如可动态创建和扩展逻辑卷等。
而且，SVC为各种不同的存储设备提供了一个统一的数据复制平台，例如瞬间复制 FlashCopy和远程复制 Remote Mirroring。
这些复制功能都允许源磁盘卷和目标磁盘卷可以存在于不同品牌的磁盘阵列上。

Top


SVC新一代引擎2145-CF8简介

解答:

1.新的SVC节点类型，使用 IBM System x3550M2 server：
Intel Core i7 2.4 GHz quad-core processor
24GB of cache (with future growth possibilities)
Four 8Gbps FC ports
IBM Systems Director Active Energy Manager enabled
Two power supplies
A 19-inch rack-mounted enclosure，1U High

2.总线带宽是 8G4的两倍, IOPS最大可以达到8G4的两倍；

3.支持 Solid State Drives (最多每个SVC节点 四个SSD)；

4.在一个 SVC clusters，不同的IO group可以是不同的节点类型；

5.在对原有环境进行替换升级的时候，可以允许不同的节点在一个IO group里；
注：4F2不能升级到5.1 code，所以也不能与CF8共存。

6.SVC 2145-CF8是针对2145-8G4的替换产品。

7.SVC 2145-CF8软件5639-VC5的配置中新增IBM Tivoli Storage FlashCopy Manager的组件，该软件的主要功能是执行近乎即时的应用程序感知快照备份，而对DB2、Oracle、SAP、Microsoft SQL Sever和Microsoft Exchange性能的影响是最低的；提供对Microsoft Exchange数据的高级、精细还原；支持群集应用程序环境（Windows上的MSCS或VCS以及AIX上的HACMP）以及Microsoft Exchange 2007持续复制配置（LCR、CCR和SCR）。

8.SVC5.1以上可以支持iSCSI接口，避免了服务器中光纤通道主机总线适配器（HBA）的成本，同时减少了对光纤通道交换机的需求。

突出价值点：
IBM拥有40年的虚拟化技术；
全球已经销售出13000多台SVC引擎，建立了4000个基于SVC系统；
全球有超过130个客户参考案例；
在性能测试中， SVC表现出了及高的性能和扩展能力；
SVC具有最快的SPC-1基准测试值 (SVC 4.2: 272,500 IOPS)；
SVC具有最快的SPC-2 基准测试值 (SVC4.2: 7080)；
SVC可以支持包括IBM和非IBM在内的120多中磁盘存储系统（IBM, EMC, HP, HDS, Sun, Dell, NetApp, Fujitsu, NEC, Bull)。

Top


利用SVC Flashcopy功能实现数据拷贝的速度

解答:

在SVC上支持从源VDisk到目标VDisk的Flashcopy功能，并且两种VDisk容量必须相同，可以属于同一个或不同的IO group, 但必须属于同一个 SVC Cluster。

利用FlashCopy功能在VDisk间拷贝数据时，无论是从源VDisk到目标VDisk的拷贝还是从目标VDisk到源VDisk的拷贝，拷贝的单位是"Grains".它的大小为256KB or 64 KB，对于每一个grain, FlashCopy的位图(Bitmap)都包含一个bit与之对应。Bit用于记录是否相关的grain已经从源VDisk拷贝到目标VDisk。

通过下表可以了解数据拷贝的速度与grains对应的数量关系：

User% age | Data copied/sec | 256KB grains/sec | 64KB grains/sec
1-10 | 128KB | 0.5 | 2
11-20 | 256KB | 1 | 4
21-30 | 512KB | 2 | 8
31-40 | 1MB | 4 | 16
41-50 | 2MB | 8 | 32
51-60 | 4MB | 16 | 64
61-70 | 8MB | 32 | 128
71-80 | 16MB | 64 | 256
81-90 | 32MB | 128 | 512
91-100 | 64MB | 256 | 1024

参考资料：
书名：《Implementing the IBM System Storage SAN Volume Controller V5.1》
书号：SG24-6423-07
地址：http://www.redbooks.ibm.com/abstracts/sg246423.html?Open

Top


SVC的Easy Tier功能介绍

解答:

SVC产品从6.1版本开始，增加了Easy Tier 分层存储技术。Easy Tier是一种针对SSD固态盘的性能优化技术，它先统计出频繁访问的热点数据所在的数据块(Extents)，然后将这些数据块(Extents)从传统磁盘的Mdisk移动到SSD固态盘的Mdisk，从而有效地优化和提高访问速度和性能。

SVC 的 Easy Tier 具有以下一些特点：

1. Easy Tier 是 SVC 6.1版本的原生(Native)功能，不需要额外费用，只要将软件版本升级到6.1版本，SVC就具备了Easy Tier功能；

2. 完整的 Easy Tier 功能包括两种模式：统计评估模式(measuring或evaluation)和 迁移优化模式(migration或Auto Data Placement)：

a.没有SSD固态盘也可以使用统计评估模式，通常用于评估现有环境配置，以决定需要添加的SSD固态盘数量，以及哪些卷(volume)更有益于使用迁移优化模式；

b.应用迁移优化模式必须要有SSD固态盘，并且同一个存储池(Storage Pool)中，需要配置两种级别(Tier)的Mdisk，即传统磁盘组成的Mdisk和SSD固态盘组成的Mdisk。

3. 目前，由于2145-CF8升级到SVC 6.1后暂时不支持内置的SSD固态盘，因此，如果2145-CF8使用Easy Tier功能只能使用外置存储的SSD固态盘；

4. SVC使用Easy Tier的迁移颗粒度由extent的大小决定，默认值为256MB，最小支持16MB，最大支持8GB。

参考文档
书名：《Implementing the IBM System Storage SAN Volume Controller V6.1》
书号：SG24-7933
章节：Chapter 7. Easy Tier
链接：http://www.redbooks.ibm.com/redpieces/abstracts/sg247933.html?Open

Top


Storwize V7000

IBM Storwize V7000新产品介绍

Storwize V7000 缺省支持那些高级功能 (新增)

Storwize V7000 物理组成 (新增)


IBM Storwize V7000新产品介绍

解答：

IBM Storwize V7000是IBM最新发布的中端磁盘存储系统，提供了无与伦比的性能、可用性、高级功能和高级扩容能力。

IBM Storwize V7000是功能强大的中级磁盘系统，支持轻松使用和快速部署，无需添加资源。IBM Storwize V7000提供固有的IBM存储资源虚拟化、SSD优化和“精简调配”技术，能够提高存储资源利用率，并且允许您重新配置系统来快速轻松地满足不断变化的需求。此外，IBM Storwize V7000的高级功能还允许用户在不中断系统运行的情况下，将数据迁出现有存储设备，从而简化实施流程并且最大限度地避免用户服务中断。IBM Storwize V7000还允许用户使用虚拟化功能和复用现有磁盘系统，从而进一步提高投资回报率(ROI)。

硬件参数：
标准2U机箱
支持24块2.5英寸磁盘驱动器（2076-124/224）或12块3.5英寸磁盘驱动器（2076-112/212）
冗余双活控制器与电源
16GB 缓存
主机接口：8个8Gb FC端口和 4个1Gb iSCSI端口
扩展柜接口：4个6Gb SAS端口
目前支持4个磁盘扩展柜，计划最多支持9个扩展柜（2011年3月31日）
目前最大支持120TB物理容量，计划最大支持240TB物理容量（2011年3月31日）
在一个机器内支持同规格磁盘混插，在一个系统中混合使用12盘位或24盘位的扩展柜

支持的磁盘驱动器：
IBM Storwize V7000 Control Enclosure（2076-112）与IBM Storwize V7000 Expansion Enclosure(2076-212)支持12块3.5英寸磁盘驱动器，有如下选择：
2 TB 3.5" 7.2k Nearline（近线）SAS磁盘

IBM Storwize V7000 Control Enclosure（2076-124）与IBM Storwize V7000 Expansion Enclosure(2076-224)支持24块2.5英寸磁盘驱动器，有如下选择：
- 300 GB 2.5" 10k SAS磁盘
- 450 GB 2.5" 10k SAS磁盘
- 600 GB 2.5" 10k SAS磁盘
- 300 GB 2.5" E-MLC (企业级多级单元) SSD

IBM Storwize V7000先进的软件功能:
全新的用户使用界面，基于web方便使用；
支持RAID 0, 1, 5, 6, 10；
Easy Tier自动分层技术 (动态硬盘 /固态硬盘的管理）；
单卷256个Flashcopy；
支持异构存储虚拟化；
透明数据迁移；
远程/本地数据镜像；
自动精简配置；
RAS 服务与自诊断；
良好的主机、存储及软件兼容性和互操作性；
可与IBM System Director集成；
与TPC, FCM 以及 TSM 的结合以增强管理能力。

Top


Storwize V7000 缺省支持那些高级功能

解答:

V7000缺省支持 Thin Provisioning, FlashCopy, Easy Tier的功能,而Metro and/or Global Mirror和External Virtualization的高级功能是需要选配的。


Storwize V7000 物理组成

解答:

1. SAS 作为盘柜之间的连接方式，支持的硬盘类型：SSD, 10K SAS 和Nearline SAS：
最多240 disk drives 使用 2.5"drives；
最多 120 disk drives使用3.5"drives；
最多加到 9个扩展柜。
2.5-inch (SFF)
.300GB 10K RPM SAS
.450GB 10K RPM SAS
.600GB 10K RPM SAS
3.5-inch (LFF)
.2TB 7,200 RPM NL-SAS
Solid-State (SFF)
. 300GB SAS

2. 双活动, 热插拔控制器；

3. 2种主机连接方式：
Fibre Channel
iSCSI

4. 支持不同类型/磁盘容量的硬盘混插；

5. 每对控制器上有8个 8Gbps FC Ports ，4个 1Gbps iSCSI Ports ，和16GB Cache；

6. 每个控制器或扩展柜模块的高度是2U。


其他

DS5000/DS8000的功率和尺寸查询 (最近更新)


DS5000/DS8000的功率和尺寸查询

解答:

产品型号 | 高(cm) | 宽(cm) | 深(cm) | 最大重量(Kg) | 额定功率(Watts)
DS5020 | 12.95 | 48.26 | 57.15 | 39.92 | 600
DS5100 | 17.45 | 48.18 | 63.49 | 40.90 | 580
DS5300 | 17.45 | 48.18 | 63.49 | 40.90 | 580
EXP810 | 13.21 | 48.26 | 55.88 | 39 | 448.5
EXP520 | 12.95 | 48.26 | 57.15 | 38.56 | 600
DS5000 Expansion Unit | 13.21 | 48.26 | 55.88 | 38.56 | 580
EXP5060 | 17.60 | 48.26 | 86.61 | 102.1 | 1428
DS8700 2-way | 具体尺寸按照配置不同变化 |  |  |  | 6700
DS8700 4-way | 具体尺寸按照配置不同变化 |  |  |  | 7300
DS8700-94E with I/O | 具体尺寸按照配置不同变化 |  |  |  | 7300
DS8700-94E without I/O | 具体尺寸按照配置不同变化 |  |  |  | 5700
DS8800 2-way | 具体尺寸按照配置不同变化 |  |  |  | 6700
DS8800 4-way | 具体尺寸按照配置不同变化 |  |  |  | 7500
DS8800-94E with I/O | 具体尺寸按照配置不同变化 |  |  |  | 7100
DS8800-94E without I/O | 具体尺寸按照配置不同变化 |  |  |  | 7300

Top


Tape Library

LTO 磁带是否要配标签，标签的格式是什么样的？(最近更新)

带库驱动器接口的数量与线缆的选择

磁带机与磁带库的区别

IBM磁带机/磁带库与备份服务器的连接方式 (新增)

IBM磁带库备份容量评估 (新增)

IBM磁带机/磁带库与HBA卡，操作系统等兼容性 (新增)

带库中I/O槽位的作用

TS1120与TS1130的区别

TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型? (最近更新)

TS2900/TS3100/TS3200/TS3310/TS3500的功率和尺寸查询(最近更新)

TS3100/TS3200/TS3310光纤驱动器与主机HBA卡连接过程中需要注意什么？

LTO X 产品的单盘磁带容量, LTO3/4/5传输速率, 及其读写兼容性(最近更新)

3580系列磁带机接口类型描述

IBM 3580和3592磁带机的介绍 (新增)

带库中 Path Failover的功能介绍,是必选的吗 (最近更新)

TS7610产品介绍 (最近更新)

IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

TS7610，TS7650与TS7650G的区别 (最近更新)


LTO 磁带是否要配标签，标签的格式是什么样的？

解答:

Ultrium Tape Drive/Library 的Bar Code Label 要求：

TS2900/TS3100/TS3200/TS3310/TS3500 对 Bar Code Label 要求是必须的(Required)。

Ultrium Tape Drive/Library 的Bar Code Label 格式：

Ultrium Tape Drive/Library 的Bar Code Label 格式：
Ultrium 5 Data Cartridge 的Bar Code Label 格式是：xxxxx0L5
Ultrium 5 WORM Cartridge的Bar Code Label 格式是： xxxxx0LV
Ultrium 4 Data Cartridge 的Bar Code Label 格式是：xxxxx0L4
Ultrium 4 WORM Cartridge的Bar Code Label 格式是：xxxxx0LU
Ultrium 3 Data Cartridge的Bar Code Label 格式是：xxxxx0L3 （注意：e-config中对应的型号 3589-008 已停产）
Ultrium 3 WORM Cartridge的Bar Code Label 格式是：xxxxx0LT （注意：e-config中对应的型号 3589-028 已停产）
Ultrium 2 Data Cartridge的Bar Code Label 格式是：xxxxx0L2 （注意：e-config中对应的型号 3589-006 已停产）
Ultrium 1 Data Cartridge (READ ONLY)的Bar Code Label 格式是：xxxxx0L1
IBM LTO Ultrium Cleaning Cartridge的Bar Code Label 格式是：CLNxxxLx

注意：由于e-config的storage media配置中磁带标签的编码为乱码，因此需要客户在配置磁带的时候按照以上格式手动修改为正确的编码。

参考资料：
书名：《IBM System Storage TS3310 Tape Library Setup and Operator Guide》
书号：GA32-0477
链接：http://publibfp.dhe.ibm.com/epubs/pdf/a3204778.pdf

书名：《IBM System Storage TS3100/TS3200 Tape Library Setup and Operator Guide》
书号：GA32-0545
链接：http://publibfp.boulder.ibm.com/epubs/pdf/15103625.pdf


带库驱动器接口的数量与线缆的选择

解答:

目前TS2900只支持SAS驱动器，TS3100，TS3200，TS3310可以支持SAS，SCSI，以及FC的驱动器，并且可以支持SAS，SCSI以及LTO5 FC的半高驱动器，TS3500(3580-L53)可以支持LTO3,LTO4,LTO5的FC驱动器。

LTO3或者LTO4的光纤或者SAS驱动器上都会有两个端口，但是只有一个是可用的，另一个不可用，因此每个驱动器到服务器端只需要连一根光纤线或者SAS线。LTO5驱动器上有两个可用端口，FC接口是8Gbps，SAS 接口为6Gbps。

LTO3或者LTO4的SCSI驱动器上也会有两个端口，一个端口用来接SCSI终结器，另一个端口接SCSI线缆。

TS3400支持的驱动器有TS1120和TS1130，都是4Gbps光纤接口的驱动器，每个驱动器上会有两个FC接口，都是可用的，每个驱动器到服务器或者光纤交换机可以连两根线起到冗余的作用。


磁带机与磁带库的区别

解答:

磁带机与磁带库主要有以下几方面的区别:
1. 磁带机只能有一个全高或半高驱动器，磁带机型号不同，驱动器类型也不相同，由于驱动器数量的限制磁带机一次只能执行一个备份任务。而磁带库则可以根据不同型号规格选配一个或多个FC,SAS或SCSI驱动器（TS2900除外，TS2900只能有一个SAS驱动器），因此可以一次执行多个备份任务。
2. 磁带机一次只能放置一盘磁带，需要手工更换磁带，而磁带库中有多个槽位一次可放置多盘磁带，实现自动更换磁带，无需手工换带。
3. 由于磁带机只能放置一盘磁带，因此备份容量有限，磁带库则不同，磁带槽位越多备份容量越大。
4. 磁带机适合满足各种各样的小型系统的备份、保存、恢复和归档数据存储需求；对于数据备份需求快速增长的企业来说，磁带库满足了容量，性能，数据保护，可靠性，可用性，经济性和应用等方面的要求。


IBM磁带机/磁带库与备份服务器的连接方式

解答:

磁带机/磁带库与备份服务器的连接取决于磁带机/磁带库的驱动器类型：

1.配置SAS或者SCSI驱动器的磁带机或者磁带库一般与备份服务器直连，并且备份服务器需要配置满足兼容性的SAS卡或者SCSI卡。每个LTO3/LTO4的SAS，SCSI驱动器只能有一个端口与服务器连接，但是每个LTO5的全高SAS驱动器可以有两个端口与服务器，实现冗余(LTO5半高驱动器只有一个端口)；

2.配置光纤驱动器的磁带库则既可与备份服务器直连也可以通过光纤交换机相连，备份服务器需要配置满足兼容性的光纤HBA卡。每个LTO3/LTO4的光纤驱动器只能有一个端口与服务器或者光纤交换机连接，但是LTO5的全高FC驱动器可以有两个端口与服务器或者交换机连接，实现冗余(LTO5半高驱动器只有一个端口)。

参考资料
名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


IBM磁带库备份容量评估

解答:

1.目前TS2900是IBM最低端的磁带库，它共有10个槽位，其中包含一个用来进出磁带的I/O槽位和一个清洗带槽位，剩余的八个槽位是数据带槽位:

a)3572-S3H支持LTO3的驱动器，所能读写的最大磁带容量是LTO3的磁带，LTO3的磁带未压缩容量为400GB，按照2:1压缩比压缩后的容量为800GB，因此理论上3572-S3H所能支持的最大未压缩容量为3.2TB，压缩后的容量为6.4TB；
b)3572-S4H支持LTO4的驱动器，所能读写的最大磁带容量是LTO4的磁带，LTO4的磁带未压缩容量为800GB，按照2:1压缩比压缩后的容量为1.6TB，因此理论上3572-S4H所能支持的最大未压缩容量为6.4TB，压缩后的容量为12.8TB。

2.TS3100支持一个全高的驱动器或者两个半高的驱动器，驱动器类型有：LTO3:半高SAS；LTO4:FC/SAS/SCSI；LTO5:FC/SAS，TS3100最大可以支持24个磁带槽位，不能够扩展，其中包括1个I/O槽位，一个清洗带槽位，22个数据带槽位：

驱动器类型 | 最大数据带槽位数 | 最大未压缩容量 | 最大压缩容量 (2:1压缩)
LTO3 | 22 | 8.8TB | 17.6TB
LTO4 | 22 | 17.6TB | 35.2TB
LTO5 | 22 | 33TB | 66 TB

3.TS3200支持两个全高的驱动器或者四个半高的驱动器，驱动器类型有：LTO3:半高SAS；LTO4:FC/SAS/SCSI；LTO5:FC/SAS，TS3200最大可以支持48个磁带槽位，不能够扩展，其中包括3个I/O槽位，一个清洗带槽位，44个数据带槽位：

驱动器类型 | 最大数据带槽位数 | 最大未压缩容量 | 最大压缩容量(2:1压缩)
LTO3 | 44 | 17.6TB | 35.2TB
LTO4 | 44 | 35.2TB | 70.4TB
LTO5 | 44 | 66TB | 132TB

4.TS3310使用LTO3/LTO4/LTO5光纤磁带驱动器，是一个可以扩展的磁带库，其最大可以支持四个E9U扩展柜，最大可支持18个驱动器，409个磁带槽位，6-54个I/O槽位，其最大备份容量可概括如下：

数据带槽位 (L5B+4E9U) | I/O槽位 | 最大未压缩容量 | 最大压缩容量 2:1压缩比
403 | 6 | 604.5TB (LTO5) 322.4TB (LTO4) 161.2TB (LTO3) | 1209 TB (LTO5) 644.8TB (LTO4) 322.4TB (LTO3)
397 | 12 | 595.5TB (LTO5) 317.6TB (LTO4) 158.8TB (LTO3) | 1191 TB (LTO5) 635.2TB (LTO4) 317.6TB (LTO3)
391 | 18 | 586.5TB(LTO5) 312.8TB (LTO4) 156.4TB (LTO3) | 1173 TB (LTO5) 625.6TB (LTO4) 312.8TB (LTO3)
385 | 24 | 577.5TB(LTO5) 308TB (LTO4) 154TB (LTO3) | 1155TB(LTO5) 616TB (LTO4) 308TB (LTO3)
379 | 30 | 568.5TB(LTO5) 303.2TB (LTO4) 151.6TB (LTO3) | 1137TB(LTO5) 606.4TB (LTO4) 303.2TB (LTO3)
373 | 36 | 559.5TB(LTO5) 298.4TB (LTO4) 149.2TB (LTO3) | 1119TB(LTO5) 596.8TB (LTO4) 298.4TB (LTO3)
367 | 42 | 550.5TB(LTO5) 293.6TB (LTO4) 146.8TB (LTO3) | 1101TB (LTO5) 587.2TB (LTO4) 293.6TB (LTO3)
361 | 48 | 541.5TB(LTO5) 288.8TB (LTO4) 144.4TB (LTO3) | 1083TB (LTO5) 577.6TB (LTO4) 288.8TB (LTO3)
355 | 54 | 532.5TB(LTO5) 284TB (LTO4) 142TB (LTO3) | 1065TB(LTO5) 568TB(LTO4) 284TB(LTO3)

5.TS3500使用LTO和IBM 3592的磁带驱动器，支持高度可扩展的自动数据保留，可显著提高地面空间的利用率并降低成本，为大型机和开放系统提供了高度可扩展的自动化磁带库，可用于中端环境到企业级环境中进行备份和归档，其最大备份容量如下：

型号 | 驱动器类型 | 最大槽位数 | 最大未压缩容量 | 最大压缩容量
L53+D53 | LTO | 6887(L53+15×D53) | 10330TB(LTO5) 5509TB (LTO4) 2754TB (LTO3) | 20660TB(LTO5) 11018TB(LTO4) 5509TB (LTO3)
L23+D23 | 3592 | 6260(L23+15×D23) | 6260TB(TS1130) 4382TB(TS1120) | 18780TB(TS1130) 13146TB(TS1120)
L23+S24 | 3592 | 15110 | 15110TB(TS1130) 10577TB(TS1120) | 45330TB(TS1130) 31731TB(TS1120)
L53+S54 | LTO | 19889 | 29833TB(LTO5) 15911TB(LTO4) 7955TB (LTO3) | 59666TB(LTO5) 31822TB(LTO4) 15910TB(LTO3)

参考资料
名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


IBM磁带机/磁带库与HBA卡，操作系统等兼容性

解答:

1.与磁带机或磁带库相连的服务器上必须配置满足兼容性的SAS卡或SCSI卡或者光纤HBA卡。

2.参考资料：
名称：兼容性列表
链接：ftp://public.dhe.ibm.com/storage/tape/lto_isv_matrix.pdf
SSIC网址：http://www-03.ibm.com/systems/support/storage/config/ssic/displayesssearchwithoutjs.wss?start_over=yes

Top


带库中I/O槽位的作用

解答:

在磁带库的槽位配置中都会预留出I/O槽位，I/O槽位不能用来放置数据带，其主要作用是用作磁带的进出，无需中断磁带库的正常操作，例如，客户需要更换磁带，那么需要先将磁带移动到I/O槽位，再移动出仓，将需要更换的磁带取出重新放入新的磁带。


TS1120与TS1130的区别

解答:

TS1120，TS1130磁带机采用IBM专有技术与普通的LTO磁带机并不兼容，主要体现在高容量，高性能以及存储关键数据的高可用性方面，TS1120与TS1130都支持数据加密功能，借助加密和密钥管理提供信息安全。两者的主要区别有：

1.TS1120(3592-E05)是IBM推出的第二代3592磁带机,TS1120可支持单盘磁带容量300GB,500GB或700GB（采用3:1压缩比可达300GB,1.5TB或2.1TB的容量），采用4Gbps的光纤端口连接，传输速率可达100MB/s。

2.TS1130(3592-E06)是第三代的3592磁带机，可支持128GB,640GB或1TB（采用3:1压缩比可达384GB,1.9TB或3TB的容量）的单盘磁带容量，同样采用4Gbps的光纤端口连接，传输速率可达160MB/s。

参考资料：
Sales Manual 链接：
TS1120 http://www-01.ibm.com/common/ssi/ShowDoc.jsp?docURL=/common/ssi/rep_sm/3/872/ENUS3592-_h03/index.html&breadCrum=DET001PT023&url=buttonpressed=DET002PT005&specific_index=DET001PEF010&DET015PGL002=DET001PEF012&submit.x=9&submit.y=12&lang=zh_CN

TS1130:http://www-01.ibm.com/common/ssi/ShowDoc.jsp?docURL=/common/ssi/rep_sm/6/872/ENUS3592-_h06/index.html&breadCrum=DET001PT023&url=buttonpressed=DET002PT005&specific_index=DET001PEF010&DET015PGL002=DET001PEF012&submit.x=9&submit.y=12&lang=zh_CN


TS2900/TS3100/TS3200/TS3310磁带槽位数和支持驱动器的数量和类型

解答:

TS2900/TS3100/TS3200/TS3310信息：

磁带库型号
 槽位数 支持的驱动器类型
3572-S3H TS2900 最大9
一个IO槽位

Ultrium 3 HH：3 Gbps SAS
3572-S4H TS2900 最大9
一个IO槽位

Ultrium 4 HH：3 Gbps SAS
3573-L2U TS3100 最大24
一个IO槽位

Ultrium 3 LVD SCSI Drive（已停产）
Ultrium 3 Fibre Drive(4Gb)（已停产）
Ultrium 3 Half-high LVD SCSI Tape Drive（已停产）
Ultrium 3 Half-high SAS Tape Drive

Ultrium 4 LVD SCSI Drive
Ultrium 4 Fibre Channel Drive
Ultrium 4 SAS Drive
Ultrium 4 Half-high SAS Drive

Ultrium 5 Fibre Channel Drive(8Gb)
Ultrium 5 Half-high Fibre Channel Drive
Ultrium 5 SAS Drive
Ultrium 5 Half-high SAS Tape Drive
3573-L4U TS3200 最大48
三个IO槽位

Ultrium 3 LVD SCSI Drive（已停产）
Ultrium 3 Fibre Drive(4Gb)（已停产）
Ultrium 3 Half-high LVD SCSI Tape Drive（已停产）
Ultrium 3 Half-high SAS Tape Drive

Ultrium 4 LVD SCSI Tape Drive
Ultrium 4 Fibre Channel Tape Drive
Ultrium 4 SAS Tape Drive
Ultrium 4 Half-high SAS Tape Drive

Ultrium 5 Fibre Channel Drive(8Gb)
Ultrium 5 Half-high Fibre Channel Drive
Ultrium 5 SAS Drive
Ultrium 5 Half-high SAS Tape Drive
3576-L5B 与3576-E9U
TS3310

41到409

6到54个IO槽位(具体信息参看下表)

Ultrium 3 LVD SCSI Drive
Ultrium 3 Fibre Drive(4Gb)

Ultrium 4 SAS Drive
Ultrium 4 Fibre Channel Drive

Ultrium 5 Fibre Channel Drive(8Gb)

TS3310 详细信息：

磁带库配置 | I/O站数量 | 数据带槽位 | 总槽位数量 | 扩展许可数量
5U（L5B） | 6 | 35 | 41 | 没有许可
14U（L5B+E9U） | 6/12/18 | 76/70/64 | 82 | 没有许可
 | 6/12/18 | 127/121/115 | 133 | 一个许可
23U（L5B+2*E9U） | 6/12/18/24/30 | 168/162/156/150/144 | 174 | 一个许可
 | 6/12/18/24/30 | 219/213/207/201/195 | 225 | 两个许可
32U(L5B+3*E9U) | 6/12/18/24/30/36/42 | 258/252/246/240/234/228/222 | 264 | 两个许可
 | 6/12/18/24/30/36/42 | 311/305/299/293/287/281/275 | 317 | 三个许可
41U(L5B+4*E9U) | 6/12/18/24/30/36/42/48/54 | 350/344/338/332/326/320/314/308/302 | 356 | 三个许可
 | 6/12/18/24/30/36/42/48/54 | 403/397/391/385/379/373/367/361/355 | 409 | 四个许可

对于上述磁带库中SAS接口的驱动器，其接口类型都是SFF-8088。目前，SAS 接口类型主要分两种：SFF-8088（MiniSAS）和SFF-8470(SAS)。

通常，在e-config配置中，SAS磁带驱动器对应的线缆选有两种：

一种是SAS/MiniSAS（图1），另一种是MiniSAS/MiniSAS（图2）。

(图一) [image] (图二)

由于在磁带设备端需要用MiniSAS的接头，所以线缆类型的选择取决于主机端SAS HBA卡的接口类型。

目前，在IBM X服务器上常用的SAS卡25R8060是SFF-8088的接口类型，SAS3800X是SFF-8470的接口类型。

参考资料：
书名：《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-05
TS3100 信息：121
TS3200 信息：143
TS3310 信息：169-171
网址: http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


TS2900/TS3100/TS3200/TS3310/TS3500的功率和尺寸查询

解答:

磁带库型号 | 高(cm) | 宽(cm) | 深(cm) | 最大重量(Kg) | 额定功率(Watts)
TS2900 | 4.36 | 44.50 | 84.7 | 18 | 110
TS3100 | 8.76 | 44.74 | 74 | 15.59 | 100
TS3200 | 8.76 | 44.74 | 74 | 21.32 | 100
TS3310-L5B | 21.97 | 44.32 | 80.14 | 38.6 | 200
TS3310-E9U | 62.08 | 44.32 | 80.14 | 39 | 88.5
TS3500 | 具体尺寸按照配置不同变化

参考资料：
书名：《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-05
网址：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf


TS3100/TS3200/TS3310光纤驱动器与主机HBA卡连接过程中需要注意什么？

解答：

1.建议主机端有独立的光纤卡与带库驱动器连接，不要与磁盘整列共用一块光纤卡；

2.如果主机HBA通过光纤交换机连接到带库驱动器，建议光纤交换机中建立独立的Zoning只包含光纤卡端口和驱动器端口；

3.个别使用Qlogic 光纤卡连接如果不能发现带库驱动器，可重启主机按Ctrl+Q进入HBA参数设置界面，进入Configuration Settings->Adapter Settings->Fibre Channel Tape Support确认设置为Enable；

4.在主机中安装相应的带库驱动程序；

5.主机HBA连接TS3100/TS3200后，如果在主机中只可以看到Tape Driver（驱动器），无法发现Media changer(机械手)。以Web方式登录带库配置界面(在带库液晶面板中Configure->Network配置管理ip，管理客户端以网线连接带库管理口，在浏览器中输入所设置的IP地址，默认用户名admin，默认密码secure)，查看Configure Library->General中Library Mode为Random；Configure Library->Drivers中已经勾选Control Path。

参考资料：
书名:《IBM System Storage TS3310 Tape Library Setup and Operator Guide》
书号：GA32-0477
链接：http://publibfp.dhe.ibm.com/epubs/pdf/a3204778.pdf

书名:《IBM System Storage TS3100/TS3200 Tape Library Setup and Operator Guide》
书号：GA32-0545
链接：http://publibfp.boulder.ibm.com/epubs/pdf/15103625.pdf

书名:《IBM Tape Device Drivers Installation and User’s Guide》
书号：GC27-2130
链接：ftp://ftp.software.ibm.com/storage/devdrvr/Doc/IBM_Tape_Driver_IUG.pdf

书名:《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-06
链接：http://www.redbooks.ibm.com/abstracts/sg245946.html

Top


LTO X 产品的单盘磁带容量,LTO3/4/5传输速率,及其读写兼容性.

解答:

LTO 3： (已停产)
容量：400GB(800GB 使用2:1压缩比) 传输速率：80MB/s
LTO 4：
容量：800GB(1600GB 使用2:1压缩比) 传输速率：120MB/s
LTO 5：
容量：1.5TB(3TB 使用2:1压缩比) 传输速率：140MB/s

读写兼容性:
LTO 5代驱动器读写LTO 4代的磁带，传输速率为120MB/s；只读LTO 3代磁带，传输速率为80MB/s；不支持LTO 2代磁带。
LTO 4代驱动器读写LTO 3代的磁带，传输速率为80MB/s；只读LTO 2代磁带，传输速率为35MB/s；不支持LTO 1代磁带。
LTO 3代驱动器读写LTO 2代的磁带，传输速率为35MB/s；只读LTO 1代磁带，传输速率为20MB/s；不支持LTO 4/5代磁带。

参考资料：
书名：《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-05
网址:http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


3580系列磁带机接口类型描述

解答:

目前，3850带机有2种接口类型，有SCSI接口，SAS接口。所有SAS接口都为mini-SAS的标准。全高的SCSI和SAS磁带机后端有两个接口，半高的SCSI和SAS磁带机后端只有一个接口。


IBM 3580和3592磁带机的介绍

解答:

目前IBM用于开放平台的外置磁带机主要有两种3580磁带机和3592磁带机，其中3580磁带机采用的是LTO的技术，其可支持的磁带类型有LTO3的400GB（压缩后可达800GB），LTO4的磁带800GB（压缩后可达1.6TB），最大可以支持LTO5 1.5TB 数据磁带，存储容量可高达3TB，其传输速率可分别为80MBps/120MBps/140MBps；3592磁带机则是采用IBM专有的技术与普通的LTO磁带机并不兼容，主要体现在高容量，高性能以及存储关键数据的高可用性方面，其磁带的规格以及驱动器的传输速率与LTO的规格也不同。

1.3580磁带机根据驱动器类型以及高度不同，目前主要有以下几个型号：

a)3580-H3V(TS2230)：这款磁带机使用的是LTO 3的半高SAS驱动器（SAS接口速率为3Gbps），最大传输速率为60MB/s；

b)3580-H4V(TS2240)：这款磁带机使用的是LTO 4的全高SAS驱动器（SAS接口速率为3Gbps），最大传输速率为120MB/s；

c)3580-H5S(TS2250)：这款磁带机使用的是LTO 5的半高SAS驱动器（采用的是接口速率为6Gbps的SAS驱动器），最大传输速率为140MB/s；

d)3580-L43(TS2340)：这款磁带机使用的是LTO 4的SCSI全高驱动器(SCSI接口速率为3Gbps)，最大传输速率为120MB/s；

e)3580-S53(TS2350): 这款磁带机使用的是LTO 5的SAS全高驱动器（采用的是6Gbps的双端口SAS驱动器），最大传输速率为140MB/s。

2.3592的磁带机有两种型号3592-E05(TS1120)和3592-E06(TS1130)：

a)TS1120(3592-E05)是IBM推出的第二代3592磁带机,TS1120可支持单盘磁带容量300GB,500GB或700GB（采用3:1压缩比可达300GB,1.5TB或2.1TB的容量），采用4Gbps的光纤端口连接，传输速率可达100MB/s；

b)TS1130(3592-E06)是第三代的3592磁带机，可支持128GB,640GB或1TB（采用3:1压缩比可达384GB,1.9TB或3TB的容量）的单盘磁带容量，同样采用4Gbps的光纤端口连接，传输速率可达160MB/s。

参考资料：
a)名称：3580 销售手册 （Sales Manual）
b)名称：3592 销售手册 （Sales Manual）

Top


带库中 Path Failover的功能介绍,是必选的吗

解答：

Path Failover提供控制链路和数据链路的冗余。

控制链路的冗余是指，当主机中HBA卡或者带库中磁带驱动器发生故障时，在不中断当前业务的同时自动切换到另一条链路。

数据链路的冗余是指，在SAN环境中，配置多个环节的冗余设置，当通路故障时，切换当前应用至冗余通路，并提供对故障的校验及恢复。

Path Failover，只有在TS3100以上的磁带库中有，非必选选项，根据客户需要定购，在配置大于两个驱动器，或者多条链路的情况下，推荐配置fc#1682。

参考资料：
书名:《IBM System Storage TS3310 Tape Library Setup and Operator Guide》
书号：GA32-0477
链接：http://publibfp.dhe.ibm.com/epubs/pdf/a3204778.pdf

书名:《IBM System Storage TS3100/TS3200 Tape Library Setup and Operator Guide》
书号：GA32-0545
链接：http://publibfp.boulder.ibm.com/epubs/pdf/15103625.pdf

书名:《IBM Tape Device Drivers Installation and User’s Guide》 (文档较大，请下载完以后阅读)
书号：GC27-2130
链接：ftp://ftp.software.ibm.com/storage/devdrvr/Doc/IBM_Tape_Driver_IUG.pdf

书名:《IBM System Storage Tape Library Guide for Open Systems》
书号：SG24-5946-06
链接：http://www.redbooks.ibm.com/abstracts/sg245946.html

突出价值点：控制路径的切换功能不需要停止现有的操作进程，光纤和SAS接口的全高驱动器在AIX, Linux, Solaris, HP-UX, 和 Windows操作平台上都支持这个功能，如果使用IBM的磁带驱动器，例如：TS1120，TS1130，那么都支持这个功能。
数据路径的切换功能支持使用IBM的光纤LTO3或LTO4的驱动器的带库，支持平台有AIX, Linux, Solaris, HP-UX, 和 Windows，这个功能使得客户能够灵活的配置SAN架构，同时提供了高可用性和有效的管理。


TS7610产品介绍

解答:

1.TS7610是IBM最新推出的一款低端的虚拟带库，针对中型企业需要用于数据保护的更全面方案而设计，TS7610充分利用独特的重复数据删除技术提高了容量需求，以及可靠性和可用性。

2.TS7610可以选择两种容量配置4.4TB（4TiB）和5.9TB（5.4TiB），其硬件组成主要是一个四核2.33GHz的Intel Xeon处理器，24GB的缓存，12块1TB的SATA硬盘，一块双端口的4Gbps光纤HBA卡。虚拟能力：TS7610能虚拟4个TS3500磁带库，64个LTO3虚拟驱动器，8192个虚拟磁带槽位。

3.TS7610支持重复数据删除功能，其重复数据删除比率可达25:1，能实现的备份速率为85MB/s，TS7610适用于每周数据备份少于3TB。

4.2010年11月IBM TS7610推出了一个新功能-OST(OpenStorage)的功能，此功能将IBM TS7610与赛门铁克的NetBackup有效结合，将数据直接备份到磁盘，而不需要TS7610做磁带库虚拟仿真，可以让用于有效的在站点之间将备份数据备份到磁盘上，同时结合了TS7610的重复数据删除的功能，将磁盘利用最大化，此外也可以利用TS7610的远程复制功能实现最多12站点之间的复制，从而降低了带宽提高了性能。但是TS7610中虚拟磁带库(VTL)与OST只能配置一种，不可同时存在。

参考资料：

Data Sheet 链接：ftp://public.dhe.ibm.com/common/ssi/ecm/en/tsd03107usen/TSD03107USEN.PDF

Sales Manual链接：TS7610销售手册链接

红皮书链接：http://www.redbooks.ibm.com/redpieces/pdfs/sg247652.pdf


IBM TS7650 重复数据删除解决方案有哪些优势、可以给客户带来哪些价值

解答：

作为重复数据删除解决方案方面的佼佼者，IBM TS7650 一直受到财富500强企业数据中心的青睐，如今全球已经有多家公司部署了该解决方案，其具体的优势为：

1.超级基于磁盘的数据保护
更高的扩展能力——能够为每个存储系统提供多达1PB的存储容量，即可以提供超过25PB的存储能力；
更有效的性价比——可减少高达25倍的存储需求。

2.高性能的持续重复数据删除
每节点 450MB/s 的在线处理能力，双节点集群高达900 MB/s 的在线处理能力。

3.强大的连续性
在线重复数据删除减少了对操作的影响降低了宕机的风险；
方案很好地集成了现有的备份环境和存储架构。

4.确保了数据完整性
通过逐位数据比对，彻底消除了由于“哈希冲突”等原因所造成的数据误删除。

5.出色的远程复制优势
有效地减少了 WAN 中的带宽；
能够使用“跨数据中心” 的存储并减少磁带的运输；
为灾难恢复提供了一种更快更高效的方式。

重复数据删除解决方案给客户带来的价值：

1.提高服务
TS7650 产品解决方案可以高速、高效地满足企业现有的业务应用、策略和法规的需求，保证了企业的业务连续性。

2.管理风险
IBM TS7650 采用在线重复数据删除方法，进行实时地重复数据删除，这样，当数据写入磁盘时已经进行了重复数据删除操作，从而降低了宕机的风险保证了业务的连续性；
IBM TS7650 解决方案将能够为每个存储系统提供多达 1PB 的存储容量，即可以保存超过 25PB 的用户数据，从而有效地避免了孤岛存储空间的出现；
IBM TS7650 选择了一种模式识别的算法来查找和处理数据冗余，从而降低了大型环境中数据丢失的风险，保证了数据的完整性。

3.降低成本
通过 IBM TS7650 重复数据删除解决方案，您可以减少多达25倍的存储容量需求，并提高存储的利用率，从而有效地帮助您控制IT方面的预算；
通过减少操作中的磁盘容量，您亦有效地降低了企业的IT能源能耗。

突出价值点：
能够在大幅降低基础架构成本的同时，满足企业数据中心基于磁盘的数据保护需求。
该解决方案提供了行业领先的联机重复数据删除性能和每个系统高达 1PB 物理存储容量的可扩展性，可提供高达 25PB 的存储容量。
再结合 IBM 存储，ProtecTIER Gateway 解决方案可提供强大的基于磁盘的存储库，从而改善备份与归档数据的保留和可用性。
TS7650G 结合了虚拟磁带库解决方案与 IBM 获得专利的 HyperFactor 技术所实现的联机重复数据删除功能。 该技术可以在磁盘需求和成本方面实现大幅节省。

Top


TS7610，TS7650与TS7650G的区别

解答:

TS7610是一款低端虚拟带库，而TS7650和TS7650G则是IBM的高端虚拟带库。

TS7610（3959-SM1）是IBM新推出的一款低端虚拟带库，它主要针对中小型企业的快速备份需求，TS7610的基本单元是由一个四核2.33GHZ主频的Intel Xeon处理器，24GB缓存,12块1TB的SATA硬盘和一块双端口的4Gbps的光纤HBA卡组成。TS7610可以提供两种容量配置4.4TB（4TiB）和5.9TB（5.4TiB），可以虚拟4个TS3500磁带库，64个LTO3虚拟驱动器，8192个虚拟磁带槽位,最大可支持25:1的重复数据删除比率。

TS7650（3958-AP1）基本单元是一台System x服务器，18核处理器，2.66GHz主频，24GB内存，其后端默认配置的是DS4700的盘阵内置450GB的光纤硬盘。TS7650根据后端存储控制器和扩展柜的不同组合方式会有三种容量选择，分别是7TB,18TB,36TB,36TB（cluster），这三种容量都是做完RAID之后的可用容量。TS7650所支持的备份速率每节点可达500MB/s，最大可支持25:1的重复数据删除比率，最大可支持12个虚拟带库，256个虚拟驱动器，128,000个虚拟槽位。

TS7650G（3958-DD4）这是一款网关产品，基本单元是一台x3850 X5的服务器，32核处理器，2.27Ghz主频，64GB内存。其后端可接从低端到高端以及第三方的满足产品兼容性的磁盘存储，最大支持的容量可达到1PB，所支持的备份速率每节点可达500MB/s（双节点cluster配置可达1000MB/s），最大可支持25:1的重复数据删除比率，最大可支持16个虚拟带库，256个虚拟驱动器，512,000个虚拟槽位。

参考资料：

TS7610 销售手册链接

TS7650 销售手册链接

TS7650G 销售手册链接


N series 常见问题

N series

N series 产品的基本技术概念

N系列网关与N系列文件存储的区别

N series产品NAS和SAN功能的区别与配置方法

N series产品兼容性的查询方法

SONAS产品简介 (最近更新)

N series常用软件功能的介绍

N series产品的尺寸、重量与功率

N series支持的最大硬盘、扩展柜的数量

N3400与N3300,N3600参数对比 (最近更新)

N series CPU、缓存信息 (最近更新)

N3300的接口类型、功能与数量 (新增)

N3400的接口类型、功能与数量 (新增)

N3600的接口类型、功能与数量 (新增)

N6040/N6060/N6070三种型号的区别


N series 产品的基本技术概念

解答:

N series中的RAID概念

N series支持RAID 4 和 RAID DP两个RAID 级别。

RAID 4和RAID DP之间最大的区别为: RAID 4在同一RAID组中使用单数据校验盘,而RAID DP在同一RAID组中使用双奇偶校验RAID技术，可防止RAID组中任意两块硬盘故障失效，性能几乎毫无影响。

这两种RAID方式的校验数据都是存放在某块（些）盘上的，由于每次的写操作都涉及校验数据的更新，于是校验盘很容易成为整个磁盘系统的瓶颈，但是N系列产品将WAFL文件系统和RAID4或者RAID-DP结合起来解决了这个问题。

这里以RAID4为例：传统的文件系统：由于数据需要写到已经预先分配好的空间去，并没有进行任何的优化，导致数据可能是写到不同盘片的不同轨道。采用了WAFL的RAID4：由于数据没有预先分配位置，而是通过一定的算法进行优化，将数据写到最近的可用的空余磁道，于是使得我们的数据尽可能写在不同盘片的同一个轨道上，这样磁头就不需要在多个轨道之间移动，大大提高了校验盘的写的性能。

N series中的RAID group size

RAID group size是指一个RAID组中支持物理硬盘的最大数量。

RAID 4 group size的要求如下：

对于FC或SAS硬盘，最少2块盘，缺省8块盘，最大14块盘。
对于SATA硬盘，最少2块盘，缺省7块盘，最大7块盘。

RAID-DP group size的要求如下：

对于FC或SAS硬盘，最少3块盘，缺省16块盘，最大28块盘。
对于SATA硬盘，最少3块盘，缺省14块盘，最大16块盘。

N series中的Aggregates 和 Volumes（注意：以下限制仅适用于Data ONTAP 7.3版本）

由一个或多个RAID组（RAID group）组成的Aggregate可以划分为一个或多个Volume。

对于一个N series系统：
最多支持400个RAID group；
最多支持aggregate数目:100；
最大支持aggregate size: 16TB；
最小支持aggregate size：10GB；
一个aggregate中支持最大的RAID Group数目：150；
最小支持FlexVolume size是20MB；
最大支持FlexVolume size是16TB；
最多支持volume数目是200。

N series在Data ONTAP操作系统中 完成 local file system writes, 分为以下6步：

1. Data ONTAP接收到一个 来自host的write 请求，类型可以是 NFS 或 Common Internet File System (CIFS),或FCP 或 iSCSI。
2. 把该请求的data write到non-volatile memory (NVRAM), NVRAM 有电池保护。同时在Cache memory中也会write一份data。Cache memory写的速度会快于NVRAM。
3. 把write成功的反馈给host，host马上继续下一个I/O操作。
4. 稍后，当NVRAM的空间占用超过1/2，或最近一次 consistency point (CP)完成后的时间超过10秒，新的一次的CP会被触发。
5. 从Cache memory中write data到RAID Software。
6. RAID software writes data 到disk上，当write完成，则本次CP即告完成。

参考资料：
书名:《IBM System Storage N series》
书号：SG24-7129-00
页码：84-90
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg247129.pdf

Top


N系列网关与N系列文件存储的区别

解答:

N系列N6000以上有两种产品：网关(NAS gateway)与文件存储(NAS Filer)。

从配置上看对于N系列网关，其后端既能接满足产品兼容性的存储盘阵，又可以接其自身扩展柜，而N系列文件存储的后端接的是其自身的扩展柜，不能接其他存储。

从功能上看N系列网关是一种基于网络的统一存储整合解决方案，旨在为连接有多种类型存储阵列的SAN提供互联网协议（IP）和光纤通道（FC）协议访问方法，N系列网关提供了创新式的数据管理功能，实现了数据共享访问，数据保护和企业级用户关键数据的恢复，以及能够与企业级SAN架构的无缝隙融合。N 系列网关产品支持连接到IBM Enterprise Storage Server（ESS） 系列、IBM XIV Storage System、IBM System Storage DS8000和 DS4000系列；以及各种 EMC、Hitachi、Fujitsu、3PAR 和 HP 存储子系统。

N系列文件存储后端可以按照客户不同的容量需求接不容类型及数量的扩展柜，既能作为普通SAN盘阵实现块级数据访问又能作为文件存储实现网络共享访问。

参考链接：N系列网关的产品兼容性ftp://public.dhe.ibm.com/storage/nas/nseries/nseries_gateway_interoperability.pdf


N series产品NAS和SAN功能的区别与配置方法

解答:

首先，NAS指的是Network Attached Storage，即网络附属存储，而SAN指的是Storage Area Network，即存储区域网络。严格来讲，一个是存储，一个是网络，它们是两种不同的概念，所以这里我们指的是N series产品采用NAS相关的CIFS、NFS协议存取数据与采用SAN相关的FCP、iSCSI协议存取数据的区别。

存储方式 | SAN |  | NAS
全称 | Storage Area Network |  | Network Attached Storage
支持协议 | FCP | iSCSI | CIFS | NFS
与主机连接方式 | FC SAN | IP网络 | IP网络 | IP网络
数据存储方式 | 块级别 |  | 文件级别
文件系统 | 本身不包含文件系统， 需要由使用的操作系统创建 |  | 包含文件系统
共享访问 | 协议本身不支持，需要主机端 使用集群或并行文件系统软件 |  | 协议本身支持共享访问
支持的操作系统 | 支持大部分主流企业级操作系统 |  | Windows和支持 CIFS协议的操作系统 | Unix/Linux以及 支持NFS协议的操作系统


N series产品兼容性的查询方法

解答:

1. N series产品的兼容性可以通过IBM官方网站进行查询，可以通过以下方法进入页面

a)方法一：通过以下链接直接进入
http://www-03.ibm.com/systems/storage/network/interophome.html

b)方法二：通过IBM官方网站进入
首先登陆IBM官方网站www.ibm.com
然后通过下拉菜单Products -> Storage -> Network attached storage 选项进入N series产品页

接下来在NAS产品页，选择一款N series产品，例如：IBM System Storage N3000 Express:

进入N series产品页后，在右侧“Learn more”中选择“Interoperability”

2. N series产品的兼容性页面包括多个兼容性文档，下面介绍各个文档的内容说明:

a）Uninterruptible Power Supply (UPS) support
主要介绍了N series产品与不间断电源（UPS）之间的兼容性。

b）Gateway (connection to back-end storage)
主要介绍了N series Gateway，即N系列网关产品的兼容性，包括可以支持的IBM和第三方阵列柜的型号，版本要求，N series Gateway支持的容量信息以及相关软件的兼容性信息等。

c）Tape (end-to-end solutions)
主要介绍了N series产品连接磁带机、磁带库的兼容性信息，包括HBA卡型号、SAN交换机及其版本、备份软件版本以及磁带机/库微码版本等信息。

d）CIFS (Common Internet File System) and Antivirus support for Windows environments / Mac OS/X support
主要介绍了N series在CIFS，即Windows网络文件共享方式下的兼容性信息，包括Windows补丁（Service Packs）、Windows版本、防毒软件等信息。

e）NFS (Network File System) for UNIX environments
主要介绍了N series在NFS，即Unix/Linux网络文件共享方式下的兼容性信息，包括Unix/Linux系统版本等信息。

f）SAN connectivity for FC and iSCSI protocols
主要介绍了N series产品在FC SAN和iSCSI方式下兼容性信息，包括操作系统版本、iSCSI initiator版本、HBA卡、磁盘管理软件、多路径软件、集群软件等信息。

g）System Manager - Setup, configuration, and provisioning of specific N series storage systems；
DataFabric Manager - Operations Manager and N series Management Console；
OSSV (Open Systems SnapVault) for UNIX and Windows environments；
SnapDrive for UNIX and Windows environments；
SnapManager for Microsoft, Oracle, SAP and VMware applications；
Oracle RAC (Real Application Cluster) environments；
VFM (Virtual File Manager) environments。
以上7篇文档主要介绍了N series相关软件的兼容性信息，可以根据配置软件的情况进行查询。

h）NAS Gateway 500；
NAS (100, 200, 300) and Gateway 300。
以上2篇文档是IBM已停产NAS产品兼容性信息，不属于N series产品家族。

Top


SONAS产品简介

解答:

SONAS是IBM新推出的云存储，支持NAS文件共享协议CIFS，NFS，HTTPs，FTP等。SONAS包含管理节点（Managment Node)，存储节点(Storage Node)，接口节点(Interface Node)，每个节点上安装了GPFS文件系统的软件。SONAS最大支持30个接口节点和60个存储节点，实现最大容量为14.4PB。

IBM SONAS 提供以下特性来满足数据扩展、数据可用性和灵活性需求：

1. 通过使用 15 个磁盘存储扩展机架，可以扩展至高达 14.4 PB 的容量。

2. 允许在单一全局命名空间下轻松、灵活的数据访问，从而能通过单一驱动器盘符（如：Z盘）向所有用户提供单一的文件逻辑视图。

3. 分层存储用于高度可用的重要数据，辅助存储用于较少访问的数据。

4. 支持行业标准协议：CIFS、NFS、HTTP、FTP 和 SCP。

5. 通过冗余的热插拔组件和故障转移实现高度可用性。

IBM SONAS 利用高性能引擎高速扫描极大规模的文件系统。SONAS的先进架构能将您的文件空间虚拟化并整合为单一的、涵盖整个企业的文件系统，从而降低您的总体拥有成本。通过采用 SONAS来整合和管理企业数据，能够避免管理大量分散存储系统时经常出现的问题。SONAS高度可扩展，可以帮助节省空间，从而降低您的资本支出并提高您的运营效率。

图示：SONAS的先进架构将文件空间虚拟化并整合为单一的、涵盖整个企业的文件系统

集中管理、集中部署


N series常用软件功能的介绍

解答:

以下软件许可一般随N series产品自动配置

1.Data ONTAP：N series的操作系统，是必选选件。

2.CFO：即Cluster Failover，在双节点的N series中实现两个节点的故障切换，对于双节点的N series是必选选件，单节点N series无法配置。

3.NearStore：实现近线存储功能，是实现重复数据删除功能（Deduplication）的前提条件，非必选选件，但一般会随e-config自动配置出来。

4.Deduplication：实现重复数据删除功能，需要配合NearStore使用。

以下软件许可需要根据需要进行配置：

1.如果NAS的客户端使用Windows系统,则网络共享许可为CIFS。
如果客户端使用Linux/Unix系统,则网络共享许可为NFS。
如果客户端既有使用Windows系统的又有使用Linux / Unix系统,则网络共享许可需要同时配置CIFS 和NFS。

2.如果使用光纤通道协议(FCP)与主机连接,即该存储与主机以光纤SAN方式连接 则需要配置FCP等相关协议。

3.如果使用iSCSI协议与主机连接,即该存储与主机以IP SAN方式连接 则需要配置iSCSI等相关协议。

4.SnapMirror 可通过FC和IP传输方式实现同步，半同步和异步的异地数据同步。通过在LAN或WAN上高速复制数据，可实现远程容灾和数据分布，为关键应用程序提供最高的数据可用性和最快的恢复速度。

5.SnapRestore 可从SnapShot中在几秒内恢复任意容量的单卷数据，也可恢复单独的文件和目录。

6.SnapShot 秒级瞬间文件系统在线只读的零拷贝模式快照技术，不占用额外空间除非原始数据被更改或删除。每个卷可有255份快照以防止逻辑人为错误，用户可自行访问任意时间点快照进行恢复而不需系统管理员协助。该功能是免费提供的。

7.FlexClone 由于SnapShot创建的快照卷本身是只读的，如果对其进行写操作，我们可以通过FlexClone基于一个SnapShot卷创建一个Clone卷，然后再对Clone卷进行测试或开发等操作，甚至当需要完整保留该卷时，可以将FlexClone卷与源卷分离。

8.SnapLock 以磁盘为基础的高性能WORM（一次写入，多次读出）存储解决方案，在介质上数据仅能被写入一次，永不能被覆盖或改写。SnapLock不同配置能使数据在严格受控或灵活受控环境下应用，如法规遵从，数据可永久或在指定时期以不可擦除，不可重写的状态保存。

参考资料：
书名:《IBM System Storage N series Software Guide》
书号：SG24-7129
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg247129.pdf

Top


N series产品的尺寸、重量与功率

解答：

N series 型号 | 高(mm) | 宽(mm) | 深(mm) | 最大重量(Kg) |  |  | 最大功率(Watts)
 |  |  |  | Model A10 | Model A20 | 每个SAS硬盘
N3300 | 87.5 mm (3.45 in) | 446 mm (17.6 in) | 569 mm (22.4 in) | 19.5 kg (43.0 lb) | 21.5kg (47.4 lb) | 0.8kg (1.8 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3400 | 88.5 mm (3.5 in) | 446 mm (17.6 in) | 569 mm (22.4 in) | 19.5 kg (43.0 lb)-Model A11 | 21.5 kg (47.4 lb)-Model A21 | 每个SAS硬盘 0.8 kg (1.8 lb) 每个SATA硬盘 0.65 kg (1.4 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3600 | 175 mm (6.89 in) | 446 mm (17.6 in) | 582 mm (23 in) | 32.6 kg (71.9 lb) | 35.3 kg (77.8 lb) | 0.8 kg (1.8 lb) | 144GB硬盘 |  |  | 300GB硬盘
 |  |  |  |  |  |  | 400 watts |  |  | 465 watts
N3700 | 133 mm (5.25 in) | 447 mm (17.6 in) | 508 mm (20.0 in) | 35.8 kg (78.8 lb) |  |  | 72GB 10K FC硬盘 | 72GB 15K FC硬盘 | 144GB 10K FC硬盘 | 144GB 15K FC硬盘 | 300GB 10K FC硬盘 | 300GB 15K FC硬盘
 |  |  |  |  |  |  | 389 watts | 371 watts | 389 watts | 394 watts | 389 watts | 389 watts
N5200 | 130 mm (5.13 in) | 449 mm (17.7 in) | 618 mm (24.3 in) | 34.0 kg (75.0 lb) | 68.0 kg (150.0 lb) | - | 329 watts
N5300 | 130 mm (5.12 in) | 449 mm (17.7 in) | 762 mm (30 in)/含线缆管理托 610 mm (24 in) 不含线缆管理托架 | 34 kg (75 lb) |  |  | 358 watts
N5500 | 130 mm (5.13 in) | 449 mm (17.7 in) | 518 mm (24.3 in) | 34.0 kg (75.0 lb) | 68.0 kg (150.0 lb) | - | 384 watts
N5600 | 130 mm (5.12 in) | 449 mm (17.7 in) | 762 mm (30 in)/含线缆管理托 610 mm (24 in) 不含线缆管理托架 | 34 kg (75 lb) |  |  | 387watts
N6040 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.4 kg (97.8 lb) - Model A10 | 52.2 kg (115 lb) - Model A20 | - | 385 watts （200 to 240V） - Model A10 712 watts （200 to 240V） - Model A20
N6060 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.8 kg (98.8 lb) - Model A12 | 53.1 kg (117 lb) - Model A22 | - | 460 watts （200 to 240V） - Model A12 860 watts （200 to 240V） - Model A22
N6070 | 258.7 mm (10.2 in) | 447 mm (17.6 in) | 713.2 mm (28.1 in) 含线缆管理托架 616.6 mm (24.3 in) 不含线缆管理托架 | 44.9 kg (99 lb) - Model A11 | 53.2 kg (117.3 lb) - Model A21 | - | 493 watts （200 to 240V） - Model A11 930 watts （200 to 240V） - Model A21
N7600 | 263 mm (10.4 in) | 446 mm (17.6 in) | 782 mm (30.8 in)/含线缆管理托 695 mm (27.4 in) 不含线缆管理托架 | 54.8 kg (121 lb) |  |  | 935 watts
N7800 | 263 mm (10.4 in) | 446 mm (17.6 in) | 782 mm (30.8 in)/含线缆管理托 695 mm (27.4 in) 不含线缆管理托架 | 54.8 kg (121 lb) |  |  | 935 watts

参考资料
查阅IBM销售手册：Storage System 销售手册查询

IBM System Storage N5200, N5300, N5500, and N5600 Series Hardware and Service Guide
http：//publibfp.boulder.ibm.com/epubs/pdf/c2677855.pdf

IBM System Storage N7600 and N7800 Hardware and Service Guide
http：//publibfp.boulder.ibm.com/epubs/pdf/c2679530.pdf

IBM System Storage N6000 Series Hardware and Service Guide
http：//www-01.ibm.com/support/docview.wss?uid=ssg1S7002553


N series 支持的最大硬盘、扩展柜的数量

解答：

型号 | 最大硬盘 | 最大物理容量 | 扩展柜的数量 | 扩展柜类型 | 硬盘类型
N3300 | 68 | 136TB | 4 | EXN1000 EXN4000 | SAS SATA FC
N3400 | 136 | 272TB | 6 | EXN1000 EXN3000 EXN4000 | SAS SATA FC
N3600 | 104 | 188TB | 6 |  | SAS SATA FC
N6040 | 420 | 840TB | 30 |  | SAS SATA FC
N6060 | 672 | 1344TB | 48 |  | SAS SATA FC
N6070 | 840 | 1680TB | 60 |  | SAS SATA FC
N7900 | 1176 | 2352TB | 84 |  | SAS SATA FC

注意：所有最大容量详细信息，请参考销售手册。

突出价值点：N系列产品目前支持的扩展柜有 EXN1000,EXN3000,EXN4000 通过支持SATA、SAS、FC盘，客户可以根据性能和价格需求合理选择。

Top


N3400与N3300,N3600参数对比

解答:

N3400是IBM新一代N series产品，支持更多的CPU,内存，性能较之N3600提高了2倍，并且具有30％容量提升。N3400集成的SAS端口可以连接EXN3000磁盘扩展柜。所有最大容量详细信息，请参考销售手册。

N3400与N3300,N3600参数对比如下：

 | N3300 | N3400 | N3600
处理器类型 | 2X32-bit Single Core | 2X32-bit Dual Core | 2X32-bit Single Core
处理器核数 | 2 | 4 | 2
缓存 | 2GB | 8GB | 4GB
扩展槽位数 | - | - | 2
板载端口数量和类型 | 4FC 4GbE | 4FC 8GbE 2SAS | 4FC 4GbE
管理端口 | BMC Console | SAS ACP BMC Console | BMC Console
最大硬盘数 | 68 | 136 | 104
最大裸容量 | 136TB | 272TB | 188TB
Data ONTAP 支持最高版本 | 7.3.4 | 8.0 | 7.3.4

注意：以上参数是双节点N3000的配置

参考文档
销售手册（Sales Manaual）
1. N3300：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS2859-_h01/index.html
2. N3400：http://www-01.ibm.com/common/ssi/rep_sm/2/872/ENUS2859-_h02/index.html
3. N3600：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS2862-_h01/index.html

Top


N series CPU、缓存信息

解答:

1.N3300、N3400和N3600是N series中入门级产品，它们的CPU和缓存信息如下：

N series 型号 |  | 单/双节点 | CPU型号 | 处理器个数 | 缓存容量 | NVRAM
N3300 | 2859-A10 | 单节点 | Intel 2.2 GHz Celeron | 1 | 1 GB | 128 MB
 | 2859-A20 | 双节点 |  | 2 | 2 GB | 256 MB
N3400 | 2859-A11 | 单节点 | Intel 1.6GHz Dual Core Xeon LV | 2 | 8 GB | 512 MB
 | 2859-A21 | 双节点 |  | 4 | 16 GB | 1 GB
N3600 | 2862-A20 | 双节点 | Intel 2.2 GHz Celeron | 2 | 4 GB | 512 MB

2.N6040、N6060、N6070和N7900是N series的中高端产品，它们的CPU和缓存信息如下：

N series 型号 |  | 单/双节点 | CPU型号 | 处理器个数 | 缓存容量 | NVRAM
N6040 | 2858-A10 | 单节点 | AMD 2.4GHz 64bit Dual Core Opteron | 1 | 4 GB | 512 MB
 | 2858-A20 | 双节点 |  | 2 | 8 GB | 1 GB
N6060 | 2858-A22 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 2 | 16 GB | 4 GB
N6070 | 2858-A21 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 4 | 32 GB | 4 GB
N7900 | 2867-A21 | 双节点 | AMD 2.6GHz 64bit Dual Core Opteron | 8 | 64 GB | 4 GB

参考资料：
书名：《IBM System Storage N series Hardware Reference》
书号：REDP-4658
链接：http://www.redbooks.ibm.com/redpapers/pdfs/redp4658.pdf


N3300的接口类型、功能与数量

解答:

上图是N3300-A20双节点型号的后视图，总共两个控制器，包括：
1. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：2个，用于本地管理和维护。

N3300-A10是单节点型号，相比N3300-A20少一个控制器，包括：
1. FC光纤端口：2个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：2个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：1个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：1个，用于本地管理和维护。

Top


N3400的接口类型、功能与数量

解答:

上图是N3400-A21双节点型号的后视图，总共两个控制器，包括：
1. SAS端口(QSFP)：2个，用于连接EXN3000系列扩展柜；
2. ACP端口(RJ45)：2个，通过以太网实现对EXN3000扩展柜的管理功能；
3. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
4. 千兆以太网端口(RJ45)：8个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
5. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
6. 串行管理端口(RJ45)：2个，用于本地管理和维护。

N3400-A11是单节点型号，相比N3400-A21少一个控制器，包括：
1. SAS端口(QSFP)：1个，用于连接EXN3000系列扩展柜；
2. ACP端口(RJ45)：1个，通过以太网实现对EXN3000扩展柜的管理功能；
3. FC光纤端口：2个，用于FCP主机访问服务或连接扩展柜；
4. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
5. 远程LAN管理端口(RJ45)：1个，用于远程监控、管理和维护；
6. 串行管理端口(RJ45)：1个，用于本地管理和维护。

Top


N3600的接口类型、功能与数量

解答:

上图是N3600-A20双节点型号的后视图，总共两个控制器，包括：
1. FC光纤端口：4个，用于FCP主机访问服务或连接扩展柜；
2. 千兆以太网端口(RJ45)：4个，用于管理、NAS(CIFS、NFS)服务、iSCSI服务、远程复制服务等；
3. 远程LAN管理端口(RJ45)：2个，用于远程监控、管理和维护；
4. 串行管理端口(RJ45)：2个，用于本地管理和维护；
5. PCIe扩展插槽：2个，用于扩展端口，包括，千兆、万兆以太网、FC、SAS，FCoE端口等。

Top


N6040/N6060/N6070三种型号的区别

解答：

以下指标为双节点模式下, 最大端口数为主机集成端口与IO扩展卡所包括端口数之和。

 | N6070 | N6060 | N6040
最大裸容量 | 1680TB | 1344TB | 840TB
最大磁盘数量 | 840 | 672 | 420
缓存 | 32GB | 16GB | 8GB
最大缓存 | 160GB | 80GB | 72GB
最大千兆网络端口 | 36 | 36 | 36
万兆网络支持 | Yes | Yes | Yes
最大4Gbps 光纤端口 | 40 | 40 | 40
8Gb光纤端口 | Yes | Yes | Yes
扩展PCI槽位 | 8 | 8 | 8
尺寸 | 6U | 6U | 6U

注意：以上为双节点模式下指标, 最大端口数为主机集成端口与IO扩展卡所包括端口数之和。

Top


SAN/Ethernet Switch

B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

B-Type SAN交换机NPIV功能介绍

3758-B32 FCoE与CEE协议应用介绍

2233-IA3 IBM Information Archive Model IA3简介

B24/B40/B80配置中所有License包含的功能

B24、B40、B80三款SAN交换机SFP模块与光纤线的选择 (最近更新)

IBM Converged Switch L32 (3758)交换机介绍

IBM DCN 交换机性能参数 (最近更新)


2233-IA3 IBM Information Archive Model IA3简介

解答:

要点

· 提供统一的存储池，存储所有类型数据，包括结构化和非结构化、合规性或非合规性；
· 通过支持多种信息采集方式以及信息保护级别提供灵活性；
· 通过多种访问方式存储信息；
· 可扩展至高达 608TB（原始容量）；
· 在保留策略允许删除之前，保持信息完整性，并通过增强的篡改保护功能提高信息安全性；
· 利用重复数据删除及压缩功能优化存储；
· 允许使用混合介质（磁盘、磁带和虚拟磁带），从而提供极低的总拥有成本 （TCO）。

在满足您的信息保留需求时：无论是长期保留高价值的内容，满足行业保留法规，还是遵守公司管理要求，您都需要一个安全、可扩展而又经济高效的归档解决方案。IBM 信息归档是新一代的信息保留解决方案， 可作为所有类型数据（结构化或非结构化）的归档库，从而帮助任何规模的企业满足业务、法律或法规等全方面的信息保留需求。

IBM 信息归档可通过以下方式帮助您降低成本、提高运营效率并管理风险：

降低成本

· 借助内置的重复数据删除、压缩及分层存储管理功能降低磁盘容量需求。
· 避免了为结构化和非结构化的信息保留两种单独平台的需要。
· 通过将信息移动到较低成本的存储层（包括磁带）降低对主存储的需求。
· 单一管理点有助于减少管理归档信息所需的人力。
· 能够使用单一归档平台管理多个业务范围 （LOB） 的归档信息，从而可减少占地空间并降低能源成本。

提高运营效率

· 支持行业标准接口和协议可最大限度地减少对信息保留的投资
· 安装和配置轻松，可在更短时间内实现价值
· 其单一用户界面和 RAS 特性可简化对归档信息的管理
· 提供了在一个 IBM 信息归档中配置多达三个单独信息库（集合）的灵活性

管理风险

· 旨在帮助您的企业满足最严格的信息保留要求。
· 提供合规的存储库：不可擦除、不可重写的 （NENR） 和单写多读 （WORM） 保护。
· 通过正在申请专利的最新增强型篡改保护功能增强保护能力。

常见特性

· 可扩展至 608TB（原始容量）
· 提供受保护的存储以确保数据完整性和真实性
· 不可擦除、不可重写 （NENR） 数据保留
· 单写多读 （WORM） 数据保护
· 每个信息归档提供三个可配置的信息集合
· 提供多种保护级别
· 通过多种访问方法存储信息：
o System Storage Archive Manager （SSAM） 接口
o 行业标准接口 （NFS）
· 重复数据删除
· 压缩
· 分层存储库
· 正在申请专利的增强篡改保护

硬件概要

· 最高 608TB 存储量（主机架“2231-IA3”中 224TB 原始容量，扩展机架“2231-IS32”中 2 X 192TB 原始容量）
· 1台 Remote Support Manager 服务器（必需）
· 1个 KVM（必需）
· 1台管理服务器（必需）
· 2台 SMC 交换机（必需）
· 1个 FC 10/100/1G（必需）
· 2台 24端口 Brocade（可选）
· FC 交换机（可选，但成对提供）
· 1台 Ingest/Retrieve（S2M 服务器） - （必需）
· 2台 2231-S2M 服务器（可选用以提高性能）
· 1个 2231-D1A 磁盘控制器（必需）
· 2个 2231-D1A 磁盘控制器（可选 － 对于更多的集合，每个集合 1个控制器）
对于第 1个磁盘控制器，多达 6个 2231-D1B 磁盘扩展抽屉；对于第 2个和第 3个磁盘控制器多达 5个 2231-D1B

Top


3758-B32 FCoE与CEE协议应用介绍

解答:

FCoE并不是要代替传统的光纤通道技术，而是在不同连接传输层上对光纤通道进行拓展。FCoE的价值在于在同样的网络基础体系上用户有权利选择是将整个逻辑网络全部当成传输存储数据与信号的专用局域网，或是作为混合存储数据、信息传送及其它数据传输的共用网络。FCoE是在继续保持用户对光纤通道SAN所期望的高性能和功能性的前提下，将存储传输融入以太网架构。

FCoE的核心在于，能够在为在以太网（CEE）上传输FC的封装协议(Lossless Ethernet: CEE)，因此，FCoE的一个数据帧的组合就显得尤为重要，因此，其至少具有三个特点和需求：

- Fibre Channel数据帧依旧: FC没有任何改变, 使用相同的名称
- Ethernet需要更大的数据帧(Jumbo Frames): 大于1500 bytes
- Ethernet必须变成无丢失的，保证传输完整的存储数据

在FCoE标准应用中，CEE增强型以太网是其中最重要的关联部分。由于FCoE协议需要基于一个网络承载，而显然FCoE的使命，在以太网上传输FC的数据，因此，需要一个拥有FC特性的以太网来服务于FCoE。因此，CEE，增强型以太网是其中最重要的相关部分，传输FCoE存储数据、数据中心应用系统和集群，CEE是一种Lossless的以太网，即无丢失以太网，其能够无损的传输FCoE的数据——FC与以太网的设计在连接上最大的不同：FC一旦连接便肯定100%可用，而以太网只是保证你的连接，而无法保证可用性，也就说，数据无法正常传输，或速率极低，是可以被允许的。在CEE中，改变了这些以太网的弊端。

FCoE所能够带来的显著好处：

- 减少服务器和交换机端口数
- 减少线缆和电力消耗
- 增加链路使用效率
- 使用10Gb CEE，传输速度高
- 增加存储网络连接2/3层应用和虚拟机的数量
- 网络将来降低成本, 更多链接选择


B-Type SAN交换机NPIV功能介绍

解答:

N_Port ID Virtualization (NPIV) 将单个光纤端口虚拟成多个独立的端口，为每个连接到该物理端口的不同类型操作系统提供独立的端口标识（对每个操作系统看起来就像有自己独立的物理端口一样）。NPIV分配一个独立的virtual port ID给每个光纤通道协议设备。它允许你去分配虚拟地址而不影响现有连接和设备。虚拟端口有与N_port相同的属性，因此能够提供Fabric相关的所有服务。

每个NPIV设备有独立的 Device PID, Port WWN, 和 Node WWN，执行同Fabric中其他端口相同的功能。也就是说，NPIV虚拟出的多个virtual devices与连接在非NPIV端口的普通设备无异，zone配置对于NPIV端口和非NPIV端口也没有区别，能够根据domain和port符号，或WWN，或两者兼有的方式划分。对于完全由virtual N_Port ID构成的Zone，必须使用WWN_Zone。

B-tyoe SAN交换机端口的NPIV配置方法如下：

在命令行下使用portCfgNPIVPort 打开和关闭port的NPIV功能。
例如：打开port 10的NPIV功能:
switch:admin>portCfgNPIVPort 10,1


B-Type交换机默认是否带有SFP? 是否有端口激活许可? 级联是否需要License

解答:

1.2498-B24/B40/B80分别是24/40/80端口的光纤存储交换机。这些交换机上的SFP模块都需要花钱购买，如果购买的SFP模块超过了交换机默认激活的端口数量，就需要购买端口激活的许可。

2.2498-B24默认激活8个端口，端口激活许可是fc#7200，一个fc#7200激活8个端口，最多购买两个fc#7200。默认支持级联。

3.2498-B40默认激活24个端口，端口激活许可是fc#7400，一个fc#7400激活8个端口，最多购买两个fc#7400。默认支持级联。注：e-config中会有一个feature #8S1022,此feature可用在端口全激活的时候，此时只购买一个fc#7400,再选一个fc#8S1022就可以免费激活第二组8端口，但是fc#8S1022这个feature需要过IBM内部RPQ的流程方可配置，若要配置此feature请联系IBM相关销售人员。

4.2498-B80默认激活48个端口，端口激活许可是fc#7800，一个fc#7800激活16个端口，最多购买两个fc#7800。默认支持级联。

以下产品停产或即将停产：

1.2005-B16/B5K/B64分别是16/32/64端口的光纤存储交换机。这些交换机上的SFP模块都需要花钱购买，如果购买的SFP模块超过了交换机总端口数的一半，就需要购买端口激活的许可。

2.2005-B16默认激活8个端口，端口激活许可是fc#7515，一个fc#7515激活4个端口，最多购买两个fc#7515。默认不支持级联，即E_Ports，需要fc#7450 Full Fabric的激活许可，一个Fabric里最多支持10台。

3.2005-B5K默认激活16个端口，端口激活许可是fc#7514，一个fc#7514激活8个端口，最多购买两个fc#7514。默认即支持级联。

4.2005-B64默认激活32个端口，端口激活许可是fc#7520，一个fc#7520激活16个端口，最多购买两个fc#7520。默认即支持级联。

参考资料：

书名：《IBM System Storage SAN24B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002303

书名：《IBM System Storage SAN40B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002302

书名：《IBM System Storage SAN80B-4 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?uid=ssg1S7002301

书名：《IBM System Storage SAN16B-2 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001367

书名：《IBM System Storage SAN32B-3 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001748

书名：《IBM System Storage SAN64B-2 Installation, Service, and User’s Guide》
网址：http://www-1.ibm.com/support/docview.wss?rs=567&uid=ssg1S7001462

书名：《Implementing an IBM/Brocade SAN with 8 Gbps Directors and Switches》
地址：http://www.redbooks.ibm.com/redbooks/pdfs/sg246116.pdf

Top


B24/B40/B80配置中所有License包含的功能

B24、B40、B80配置中所有License包含的功能

解答：

B24：

fc#7201 B24 Enterprise Package：包含fc#7202、fc#7204、fc#7205、fc#7206、2×fc#7200
fc#7202 Fabric Watch：交换机运行中状态、性能、安全等监控管理；
fc#7203 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7204 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况
fc#7205 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7206 Adaptive Networking：自动优化网络服务以配合应用数据流，可以通过优先级设定对带宽的使用量；
fc#7200 8-Port Activation：8端口激活许可，B24默认只激活8个端口，通过该许可能够将端口激活到16个或24个。此外激活端口的数量需要和SFP模块的数量相同。

B40：

fc#7401 包含了除fc#7403,fc#7407和fc#7409以外的所有License；
fc#7403 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7404 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；
fc#7405 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7406 Adaptive Networking：自动优化网络服务以配合应用数据流，可以通过优先级设定对带宽的使用量；
fc#7407 Integrated Routing：EX_port激活的License，支持 FC-router功能
fc#7409 FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7400 8端口激活的License。B40默认只激活24个端口，通过该许可能够将端口激活到32个或40个。此外激活端口的数量需要和SFP模块的数量相同。

B80：

fc#7801 包含了除fc#7803,fc#7807和fc#7809以外的所有License；
fc#7803 Extended Fabric：支持超过10KM的远距离传输，通常配合10km以上的LW SFP模块使用；
fc#7804 Advanced Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；
fc#7805 Trunking Activation：激活两台交换机之间的多端口Trunking绑定；
fc#7806 Adaptive Networking：自动优化网络服务以配合应用数据流；
fc#7807 Integrated Routing：EX_port激活的License，支持 FC-router功能；
fc#7809 FICON w/CUP Activation：FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7800 16端口激活的License。B80默认只激活48个端口，通过该许可能够将端口激活到64个或80个。此外激活端口的数量需要和SFP模块的数量相同。

此外，这三款交换机默认支持Fabric级联（ISL）、Advanced Zoning以及NPIV功能，无需购买许可。

突出价值点：IBM SAN Switch B-Type，光纤交换机附带很多功能License以及管理软件，对用户而言，搭载功能License以及管理软件的交换机，可以达到节省成本、简化管理及保护投资等效益功能，可以有效保证用户SAN网络环境的功能性、安全性、易管理性，并可藉此达到整合存储管理工具、提高服务器及存储系统使用效能等功能。

Top


B24、B40、B80三款SAN交换机SFP模块与光纤线的选择

解答:

打开三款交换机的e-Config配置中的Connet页面，可以看到SFP模块和光纤线，其中:

4Gbps/8Gbps：SFP接口速率为4Gb或8Gb；

SW/Short Wave：短波SFP模块，配合多模光纤线，用于短距离内数据传输；

LW/Long Wave：长波SFP模块，配合单模光纤线，用于远距离距离数据传输；

ELW：增强型长波SFP模块，配合单模光纤线，用于10km以上的远距离数据传输；

8-Pack：SFP模块8个一包，可以按包选择；

Fibre Cable multimode：多模光纤，配合SW短波SFP使用；

Fibre Cable siglemode：单模光纤，配合LW长波SFP使用；

OM3 Cable：第三代多模光纤，增加了多模光纤的传输距离，配合SW短波SFP使用；

另外，SFP的数量必须等于默认端口数与激活端口数之和。例如一台B40，默认激活24端口，然后再激活8个端口，那么我们需要订购32个SFP模块。光纤线缆可以根据需要选配，但最多不能超过交换机的端口总数。

以下是B-type各种SFP模块的波长，其中：

4GB 短波SPF：发射波长830-860nm；接收波长770-860nm；

4GB 长波 4KM SFP：发射波长1280-1345nm；接收波长1260-1600nm；

4GB 长波 10KM SFP：发射波长1285-1345nm；接收波长1260-1600nm；

4GB 长波 30KM SFP：发射波长1285-1345nm；接收波长1260-1600nm；

8GB 短波SPF：发射/接收波长840-860nm；

8GB 长波 10KM SFP：发射/接收波长1260-1360nm；

8GB 长波 25KM SFP：发射/接收波长1260-1360nm；

10GB 短波 SFP：发射波长840-860nm；接收波长840-860nm；

10GB 长波 SFP：发射波长1260-1355nm；接收波长1260-1355nm。


IBM Converged Switch L32 (3758)交换机介绍

解答:

3758-L32是一种架顶式FCoE交换机，带有24个用于连接LAN的万兆以太网端口和8个用于连接光纤通道SAN的光纤通道端口（最高速度达8 Gbps）。这种可靠的高性能交换机可提供先进的光纤通道服务并支持CEE功能，由DCFM管理软件进行管理。

3758-L32是一种采用1U机型设计的架顶式FCoE交换机。它带有8个8GB 的光纤通道端口和24个支持万兆以太网功能的Converged Enhanced Ethernet（CEE）端口。CEE端口既可以传输存储流量，又可以传输LAN流量，因此不需要独立的SAN和LAN适配器及线缆。

3758-L32通过融合网络适配器（CNA）连接到服务器。经过整合的SAN和LAN服务器端口及相应的线缆可以简化服务器机柜中的配置和布线，从而降低设备采购成本。这种设计可以帮助减少杂乱的线缆，降低与功耗和冷却相关的运营成本。

由于FCoE可以继续使用光纤通道结构和服务，因此3758-L32可以无缝地集成到现有的光纤通道环境中，帮助企业利用一个统一的管理框架管理与FCoE相连的设备。企业还可以利用Brocade DCFM等功能强大的Fabric管理应用。

光纤通道端口
8个光纤通道通用（E、F、M和FL）端口，速率为1、2、4和8 Gbps
24个万兆以太网端口 (CEE端口)

FcoE特性
完整的T11 FCoE实体和FCoE桥接
硬件引擎中内置的FCoE转换实体可提供：
光纤通道封装的检测和FCoE Fabric架构登录帧的重定向
FCoE以太网数据包中光纤通道帧的封装（FC > FCoE）
光纤通道目的地虚拟Fabric架构和目的地FC_ID到以太网虚拟LAN及目的地MAC地址的映射
Fabric架构提供的MAC地址（FPMA）支持通过Fabric架构分配的FC_ID创建新的以太网MAC地址

CEE特性
数据中心桥接eXchange（DCBX）
基于优先级的流控制（PFC）- IEEE 802.1Qbb
增强传输选择（ETS）– IEEE 802.1Qaz

性能
光纤通道：1、2、4和8 Gbps线速，全双工
CEE：10 Gbps线速

介质类型
光纤通道介质类型：行业标准的小型可热插拔（SFP）和SFP+，LC连接器；短波激光（SWL）和长波激光（LWL）；最大距离取决于光缆和端口速率；支持SFP+（2、4和8 Gbps）及SFP（1、2和4 Gbps）光收发器
CEE介质类型：可热插拔的万兆以太网SFP+可支持短距离（SR）和长距离（LR）光收发器的任何组合；1、3或5米的Twinax铜缆

尺寸
宽：42.9厘米（16.9英寸）
高：4.3厘米（1.7英寸）
深：63.4厘米（25.0英寸）

系统重量
13.0公斤（28.6磅），双电源FRU，无收发器

电源
最大功耗：350瓦
一般功耗：306瓦
输入电压：85 到 264 VAC ，常规
输入线频率：47到63 Hz
冲击电流：最大60安培
最大电流：12V DC时29安培

更多信息请参考：《IBM汇聚交换机B32 安装、服务和用户指南》

Top


IBM DCN 交换机性能参数

解答:

以下列表分别描述了IBM DCN M系列、R系列、S系列、C系列以及G系列5类交换机的性能参数:

IBM M 系列
型号 | IBM Ethernet Router B04M | IBM Ethernet Router B08M | IBM Ethernet Router B16M
背板交换容量 | 960Gbps | 1.92Tbps | 3.84Tbps
数据交换容量 | 400Gbps | 800Gbps | 1.6Tbps
数据包转发能力 | 240Mpps | 480Mpps | 1Bpps
交换矩阵冗余 | 2+1 | 2+1 | 3+1
管理引擎冗余 | 1+1 | 1+1 | 1+1
电源冗余 | M+N | M+N | M+N
I/O用户板卡插槽 | 4 | 8 | 16
最大10GE端口密度(XFP) | 16 | 32 | 64
最大1GE端口密度(RJ45/SFP) | 80 | 160 | 320
最大OC 192/STM 64 POS端口密度 | 8 | 16 | 32
最大OC 48/STM 16 POS端口密度 | 32 | 64 | 128
最大MAC地址数量 | 1M | 1M | 1M
最大VLAN数量 | 4.096 | 4.096 | 4.096
IP v4 硬件路由 | 512K | 512K | 512K
IP v6 硬件路由 | 112K | 112K | 112K
每Trunk支持的最大端口数 | 32 | 32 | 32

IBM R 系列
型号 | IBM Ethernet Switch B04R | IBM Ethernet Switch B08R | IBM Ethernet Switch B16R
背板交换容量 | 960Gbps | 1.92Tbps | 3.84Tbps
数据交换容量 | 400Gbps | 800Gbps | 1.6Tbps
数据包转发能力 | 286Mpps | 571Mpps | 1.142Bpps
交换矩阵冗余 | 2+1 | 2+1 | 3+1
管理引擎冗余 | 1+1 | 1+1 | 1+1
电源冗余 | M+N | M+N | M+N
I/O用户板卡插槽 | 4 | 8 | 16
最大非线速10GE端口密度(XFP) | 64 | 128 | 256
最大线速10GE端口密度(XFP) | 16 | 32 | 64
最大1GE端口密度(RJ45/SFP) | 192 | 384 | 768
最大OC 192/STM 64 POS端口密度 | 无 | 无 | 无
最大OC 48/STM 16 POS端口密度 | 无 | 无 | 无
最大VLAN数量 | 4.096 | 4.096 | 4.096
IP v4 硬件路由 | 512K | 512K | 512K
IP v6 硬件路由 | 64K | 64K | 64K
每Trunk支持的最大端口数 | 32 | 32 | 32

IBM S 系列
型号 | IBM Ethernet Switch B08S | IBM Ethernet Switch B16S
背板交换容量 | 600Gbps | 1.08Tbps
数据交换容量 | 464Gbps | 848Gbps
数据包转发能力 | 304Mpps | 636Mpps
交换矩阵冗余 | 1+1 | 1+1
管理引擎冗余 | 1+1 | 1+1
电源冗余 | N+1 | N+1
I/O用户板卡插槽 | 8 | 16
最大非线速10GE端口密度(XFP) | 20 | 36
最大1GE端口密度(RJ45/SFP) | 192 | 384
最大1GE POE端口密度(RJ45/SFP) | 192 | 384
现场升级到PoE能力 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096

IBM C 系列
型号 | IBM Ethernet Switch B24C(C or F) | IBM Ethernet Switch B48C(C or F) | IBM Ethernet Switch B50C(C or F)
交换性能 | 88Gbps | 96Gbps | 136Gbps
转发性能 | 65Mpps | 71Mpps | 101Mpps
100/1000Mbps端口密度（RJ-45 or SFP） | 24 | 48 | 48
100/1000Mbps端口密度（RJ-45/SFP组合端口） | 4 | 4(F没有) | 没有
10G端口 | 2 | 2 | 2
缓存 | 128 | 128 | 192
冗余电源 | 支持内置冗余 | 支持内置冗余 | 支持内置冗余
AC/DC支持 | 支持 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096 | 4,096

IBM G 系列
型号 | IBM Ethernet Switch B48G(C or F) | IBM Ethernet Switch B50G
交换性能 | 136Gbps | 136Gbps
转发性能 | 101Mpps | 101Mpps
100/1000Mbps端口密度（RJ-45 or SFP） | 48 | 48
100/1000Mbps端口密度（RJ-45/SFP组合端口） | 4 | 4
10G端口 | 2 | 2
冗余电源 | 支持内置冗余 | 支持内置冗余
AC/DC支持 | 支持 | 支持
最大VLAN数量 | 4,096 | 4,096
堆叠支持 | 不支持 | 8
堆叠带宽 | 没有 | 40

下表是IBM DCN交换机与Brocade交换机的型号对照表:

IBM DCN 交换机与 Brocade 交换机型号对照表
IBM Name | IBM Model | Brocade Name
IBM m-series Ethernet routers
IBM Ethernet Router B04M | 4003-M04 | NetIron MLX-4
IBM Ethernet Router B08M | 4003-M08 | NetIron MLX-8
IBM Ethernet Router B16M | 4003-M16 | NetIron MLX-16
IBM r-series Ethernet switches
IBM Ethernet Switch B04R | 4003-R04 | BigIron RX-4
IBM Ethernet Switch B08R | 4003-R08 | BigIron RX-8
IBM Ethernet Switch B16R | 4003-R16 | BigIron RX-16
IBM c-series Ethernet switches
IBM Ethernet Switch B24C (C) | 4002AC2 | NetIron CES 2024C
IBM Ethernet Switch B24C (F) | 4002BC2 | NetIron CES 2024F
IBM Ethernet Switch B48C (C) | 4002-C4A / 4002AC4 | NetIron CES 2048C
IBM Ethernet Switch B48C (F) | 4002-C4B / 4002BC4 | NetIron CES 2048F
IBM Ethernet Switch B50C (C) | 4002-C5A / 4002AC5 | NetIron CES 2048CX
IBM Ethernet Switch B50C (F) | 4002-C5B / 4002BC5 | NetIron CES 2048FX
IBM s-series Ethernet switches
IBM Ethernet Switch B08S | 4003-S08 | FastIron SX 800
IBM Ethernet Switch B16S | 4003-S16 | FastIron SX 1600
IBM g-series Ethernet switches
IBM Ethernet Switch B48G | 4002-G4A / 4002AG4 | FastIron GS 648P
IBM Ethernet Switch B50G | 4002-G5A / 4002AG5 | FastIron GS 648P-STK
IBM Converged Switches
IBM Converged Switch B32 | 3758-L32 | Brocade 8000

HPC(高性能计算)与IBM DCN 交换机的解决方案概述及优势分析

1. 以太网技术 —— 高性能计算互联技术的趋势:

- 以太网时延逐渐接近于其他连接方式：IBM 具有业界领先的低时延；

- 成本低：和Infiniband等互联技术相比，具有较低的成本，大量使用使得千兆和万兆以太网价格快速下降，大部分服务器内置千兆网卡，使得服务器方面的成本较低；

- 普遍应用，基于标准：
. 基于 IEEE 802.3 标准；
. 企业 LAN 中广泛应用；

- 可扩展到数千个节点：随着数据处理量的加大，需要数千个节点计算单元，完成越来越大的、庞大的数据量计算；

- 基础网络需要频繁重新配置时尤其适用： 随着计算模型的频繁变化，需要频繁的变化高性能计算的连接方式，以太网能够很好的对其适应；

- 易于管理：以太网具有“即插即用、维护简单”等特点，能够和高性能计算系统很好的结合，使高性能计算系统的使用成本大大降低。

2. 用户需求分析

- 服务器间的时延最小化常常是一个关键因素；

- 端口密度最大化：
. 具有高密度GE和10GE的大型交换机；
. 在大规模集群中，不得不考虑空间的利用；

- 性能最高化：
. 无阻塞或尽可能的低阻塞；

- 成本最低化

- 网络可视化

- 大规模集群中，需要考虑电源功耗

- 大规模集群中，需要考虑散热系统

3. IBM公司交换机在高性能计算行业的特点和优势：

- 高性能：全系列、全线速性能，业界单机性能最强大的二、三层交换机家族，单机箱实现2Bpps的IPv4/IPv6包处理能力；

- 高可靠：高可靠冗余交换引擎、电源和管理模块，并支持无中断冗余切换，为业界平均水平的3倍；

- 低时延：在各种负载下呈现稳定的时延，64B字节帧10ec,9KB巨帧35ec （业界同等产品通常为30-70ec）；

- 可扩展性：业界领先的无阻塞128个10GE接口或1536个1GE接口的提供能力，满足大型HDC网络需要和未来发展的扩展空间；

- 投资保护：提供线速100GE未来扩展能力和IPv6的线速转发和路由；同系列内所有接口板卡通用，电源模块通用，管理界面相同；

- 低成本和绿色环保：
. 电源消耗较竞争对手低30-50％ ；
. 空调需求较竞争对手低40-50％；
. UPS需求约为竞争对手50% ；
. 空间占用约为竞争对手70%；
. 全系列提供内置冗余交流电源，节省成本增加可靠性。

- 网络应用可见：硬件实现基于sFlow的应用流量统计，以帮助网络性能的深入分析和优化。

4. IBM交换机部分HPC客户一览表：

国内
客户名称 | 节点数
中石油东方地球物理公司 | 3000
大庆油田研究院 | 624
大庆油田物探院 | 624
中石油北京研究院 | 624
中石化北京研究院 | 256
中石化南京物研所 | 256
中石化中原油田 | 256
长庆油田研究院 | 500
中海油塘沽研究院 | 100+
中海油湛江研究院 | 100+
公安部网安中心 | 2000
中科院计算所 | 1000+
香港邵氏影城 |
北京化工大学 |
青岛海洋大学 |
北京航空航天大学 |
北京师范大学 |
中国传媒大学 |
西安交通大学 |
中山大学 |
国外
客户名称 | 国家
Atralian Center for Adv Computing & Comms | Atralia
Weta Digital | New Zealand
Amerada Hess | US
Ascent Media | US
Caltech | US
Dreamworks | US
Indtrial Light and Magic | US
Los Alamos National Laboratory | US
Lucas | US
Prediction Company | US
Sandia National Laboratory | US
SGI | US
Sony Imageworks | US
UC Irvine Department of Physics and Astronomy | US
University of Arizona | US
C-Information Sciences Institute | US
Verisign | US
Vanderbilt University | US

5. IBM HPC应用领域：

- 石油勘探；

- 科学计算；

- 电影动画制作；

- 气象预报与分析；

- 大容量的数据处理；

- 军事科学；

- 地震灾难预测。

Top


DR550

IBM System Storage DR550 产品简介


IBM System Storage DR550 产品简介

解答：

IBM System Storage DR550 可帮助企业克服高效地管理和保护关键业务信息这一日渐严峻的挑战。
IBM System Storage DR550 受 IBM 和非 IBM 企业内容管理应用程序支持，可以针对所有类型的数据提供安全、可扩展且经济高效的信息保留解决方案。

使用 IBM System Storage DR550 进行归档可以帮助公司：
- 通过将不活动的业务数据保存在经济高效的安全存储库中来应对数据增长挑战；
- 在整个数据生命周期内进行管理，支持数据保留、数据安全性和生命周期结束时的销毁；
- 通过使用多个低成本的存储层(磁盘、磁带、光盘)降低长期存储数据的成本；
- 提高操作效率；
- 满足法规、非法规的数据保留要求。

IBM System Storage DR550 产品特点：
- 适用于各种类型内容的存储库：结构化和非结构化的数据；
- 基于策略和基于事件的数据管理可以防止信息被有意或无意删除或修改；
- 将数据作为不可擦除和不可重写数据保存，直至保留策略允许删除为止；
- 使用磁盘可扩展至 224 TB，连接磁带可扩展至数 PB；
- 通过在归档内使用多个存储层(磁盘、磁带和光盘)，提供了低 TCO；
- 借助磁盘和磁带加密选件增强了安全性和保护功能；
- 删除保留功能可以保留内容以满足法规或审计需要；
- 支持主要的归档应用程序；
- 屡获殊荣且久经行业考验。

IBM System Storage DR550 可帮助企业克服高效地管理和保护关键业务信息这一日渐严峻的挑战。

DR550软硬件组成如下：

DR550-DR1 软硬件组成：
- 1套DR550 25U EIA 机柜
- 1台DR550 SSAM服务器
- 1台DR550存储阵列
- 0-3台存储阵列扩展柜
- 0、1、2台FSG文件网管服务器
- 1台KVM四合一
- AIX OS
- IBM Director software
- System Storage Archive Manager
- File System Gateway Software
- Remote Support Manager
- Storage Manager for DR550

更多关于DR550产品详细信息，请参考IBM官方网站：
网站地址：http://www-900.ibm.com/storage/cn/disk/dr/index.shtml

Top


IBM Storage 常见配置问题汇总

目录

IBM Storage 常见配置问题汇总

Disk System

DS5000

DS5020硬盘配置注意事项 (最近更新)

DS5020 SFP与线缆配置方法

DS5100/DS5300磁盘配置注意事项

DS5000系列 CPU、缓存信息与配置 (最近更新)

DS5100/DS5300 e-config配置注意事项

DS5100/DS5300 SFP与线缆配置方法

DS5100/DS5300 主机接口卡的配置方法

DS5000 e-config配置中TPC软件的选择(最近更新)

EXP5060中SFP模块及线缆的配置及注意事项 (新增)

EXP5060中磁盘的配置及注意事项 (新增)

DS5000 Expansion Unit中SFP模块及线缆的配置及注意事项 (新增)

DS5000 Expansion Unit中磁盘的配置及注意事项 (新增)

DS8000

DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？ (最近更新)

DS8700 function Auth 中各license的配置

DS8700软件的选择

DS8700的CPU、缓存的选择及配置

DS8700硬盘选择及配置

DS8700的磁盘配置注意事项 (最近更新)

DS8700 OEL value unit计算及配置方法

IBM DS8800硬盘选择及配置(最近更新)

DS8800 e-Config中HA/Cables的配置 (新增)

XIV

IBM XIV 硬盘选择及配置

SVC

SVC(2145-CF8) 硬件的Features和Cables配置

SVC(2145-8A4) 硬件的Features和Cables配置

SSPC 硬件的Features和Power Cords配置

Storwize V7000

IBM Storwize V7000 线缆及模块的配置

Storwize V7000 硬件的SFP配置 (新增)

Storwize V7000 硬件的HDDs配置 (新增)

Tape System

存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置 (最近更新)

e-config中磁带的配置介绍 (最近更新)

TS3100/TS3200/TS3310/TS3500要实现LTO加密功能所需的配置

3584-L53配置注意事项

TS7610 软、硬件配置及注意事项 (最近更新)

TS7650 硬件中Features和cables的配置 (最近更新)

TS7650G 硬件中Storage Link和Attach的配置(最近更新)

N series

N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

N Series Port/Loop indicator在e-config中的配置方法 (最近更新)

N3300/N3400/N3600硬盘配置与容量问题

SAN/Ethernet Switch

3758-L32 SFP与线缆的选择与配置 (最近更新)

2005-R04 SFP与线缆的选择与配置

2005-R04 许可（License）的选择与说明

2498-R06 SFP与线缆的选择与配置 (最近更新)

2498-R06 许可（License）的选择与说明 (最近更新)

768B 交换刀片与SFP的解释以及配置注意事项 (新增)

768B 许可(License)的选择与说明 (新增)

384B 交换刀片与SFP的解释以及配置注意事项 (新增)

384B 许可(License)的选择与说明 (新增)

DR550

DR550配置中，可以选择的Key Application包含哪些


Disk System_配置

Disk System

Disk System

DS5000

DS5020硬盘配置注意事项 (最近更新)

DS5020 SFP与线缆配置方法

DS5100/DS5300磁盘配置注意事项

DS5000系列 CPU、缓存信息与配置 (最近更新)

DS5100/DS5300 e-config配置注意事项

DS5100/DS5300 SFP与线缆配置方法

DS5100/DS5300 主机接口卡的配置方法

DS5000 e-config配置中TPC软件的选择 (最近更新)

EXP5060中SFP模块及线缆的配置及注意事项 (新增)

EXP5060中磁盘的配置及注意事项 (新增)

DS5000 Expansion Unit中SFP模块及线缆的配置及注意事项 (新增)

DS5000 Expansion Unit中磁盘的配置及注意事项 (新增)

DS8000

DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求？ (最近更新)

DS8700 function Auth 中各license的配置

DS8700软件的选择

DS8700的CPU、缓存的选择及配置

DS8700硬盘选择及配置

DS8700的磁盘配置注意事项 (最近更新)

DS8700 OEL value unit计算及配置方法

IBM DS8800硬盘选择及配置(最近更新)

DS8800 e-Config中HA/Cables的配置 (新增)

XIV

IBM XIV 硬盘选择及配置

SVC

SVC(2145-CF8) 硬件的Features和Cables配置

SVC(2145-8A4) 硬件的Features和Cables配置

SSPC 硬件的Features和Power Cords配置

Storwize V7000

IBM Storwize V7000 线缆及模块的配置

Storwize V7000 硬件的SFP配置 (新增)

Storwize V7000 硬件的HDDs配置 (新增)


DS5020硬盘配置注意事项

解答：

目前，DS5020有四类可选的硬盘：

1. 7200转的SATA硬盘，容量大小为：1TB和2TB；

2. 15000转的FC硬盘，容量大小为：300GB，450GB，600GB；

3. 15000转的加密FC硬盘，容量大小和普通FC硬盘一致；

4. 固态硬盘（SSD），容量大小为：73GB，300GB。

在DS5020中，如果配置加密硬盘，必须配置相应的加密许可fc#7410。在配置33-64个硬盘时，需要加fc#7393的硬盘容量许可，在配置65-112个硬盘时，需要加fc#7394的硬盘容量许可。此外，DS5020可以支持磁盘混插，不需要任何license。

突出价值点：支持加密硬盘，能在不增加客户成本和不牺牲性能的前提条件下更好的保护客户数据；支持不同容量、转速磁盘的混插，满足不同应用对磁盘的要求，更好的节约客户成本，实现价值最大化。

Top


DS5020 SFP与线缆配置方法

解答:

SFP是Small Form-factor Pluggable的缩写，它是电信号与光信号进行转换的接口器件。SFP模块一般分为用于近距离传输的Short Wave短波模块，以及用于远距离传输的Long Wave长波模块，其中短波模块一般配合Multimode多模光纤线缆使用，长波模块一般配合Singlemode单模光纤线缆使用。此外，光纤接口设备还有LC和SC的接口规格，一般较早设备采用SC标准，较新的设备采用LC标准。在DS5020中使用的SFP模块为Short Wave短波模块，光纤线缆为多模光纤，接口规格为LC。此外，新一代的OM3线缆也属于多模LC-LC光纤，但是OM3光纤线缆比传统多模光纤，在相同速率下支持更远的距离。DS5020有两个控制器，每个控制器上有两种类型的FC接口需要使用SFP模块，它们分别是用于连接前端主机或SAN交换机的HostPort，以及用于连接后端扩展柜的Drive Channel Port。

DS5020根据FC端口的配置数量，自带相应数量的SFP模块，不需要单独订购SFP模块（注意：DS5020扩展柜EXP520上的SFP模块需要根据需要选配）。

DS5020根据主机接口卡的不同配置，最少支持4个、最大支持8个8Gbps Host Port；以及4个Drive Channel Port。在e-config中最多可以订8条光纤线缆，光纤线缆包括1米、5米、25米LC-LC的普通多模光纤，以及新一代OM3 10米LC-LC多模光纤，OM3多模光纤线缆除以根为单位订购外，还能以4根为一包订购。此外，光纤线缆还可以在SAN交换机和EXP520扩展柜的e-config中订购，光纤线缆的数量需要根据实际需求和配置来选择。


DS5100/DS5300磁盘配置注意事项

解答：

1、DS5100和DS5300主柜中不能放置硬盘，硬盘必须配置在1818-D1A扩展柜或1818-G1A中。

2、1818-D1A即EXP5000目前支持750GB,1000GB和2000GB的7.2K SATA硬盘；支持146GB、300GB、450GB和600GB的4Gbps 15K FC硬盘；以及146GB、300GB、450GB和600GB的4Gbps 15K FC加密硬盘，同时D1A中还支持73GB的固态盘，为了提高性能，推荐每个扩展柜中配置一块固态盘，固态盘最多可配20块；订购加密硬盘同时还需要在DS5100或DS5300主柜中选择fc#7358加密硬盘激活许可。1818-D1A e-config硬盘配置中16-Pak为16块硬盘一包，配置硬盘时可以单盘配置，也可以选择16盘一包配置。目前，DS5100和DS5300最大支持28个1818-D1A扩展柜即448块硬盘，但是当DS5100中1818-D1A数量大于16个，即硬盘数量大于256时，需要购买fc#7371。

3、1818-G1A 也称EXP5060，它是高密度扩展柜，每个扩展柜支持最小2个、最大6个硬盘包，目前每个盘包包括10块1000GB或2000GB 7.2K SATA硬盘，DS5100和DS5300最大支持8个EXP5060扩展柜即480块硬盘。EXP5060数量为8个即满配时，DS5100需要购买fc#7371和fc#7372，而DS5300只需要购买fc#7372。

4、EXP5060可以和EXP5000可以混和使用在DS5000不同环路上，混合模式下最大支持448块硬盘。

突出价值点：
1、 DS5100和DS5300若满配SATA盘，最大容量可达到960TB（使用2TB的SATA盘），若是满配FC盘，最大容量可达268.8TB（使用600GB 15K 4Gbps FC盘），在满足一定的微码版本的情况下DS5100和DS5300支持FC，SATA，FDE,SSD的混插，满足不同应用对磁盘的要求，更好的节约客户成本，实现价值最大化。
2、支持加密硬盘，加密盘是在硬件的级别上对硬盘实现加密，能在不增加客户成本和不牺牲性能的前提条件下更好的保护客户数据；支持固态硬盘，更快的数据存取和吞吐量，更好的可靠性以及较低的电源功率消耗，DS5100和DS5300后端8个环路，可让驱动器在多环路有效传递，避免后端过度饱和，实现更高的性能和更高效的利用。

Top


DS5000系列 CPU、缓存信息与配置

解答：

1.DS5100和DS5300 CPU、缓存信息与配置：

DS5100和DS5300每控制器含一个Intel Xeon 2.8 GHz处理器。

DS5100和DS5300目前支持8GB(每控制器4GB)、16GB(每控制器8GB)、32GB(每控制器16GB)以及64GB(每控制器32GB)的数据缓存，e-config中分别对应fc#2030、fc#2031、fc#2033和fc#2034；此外，DS5100和DS5300还拥有4GB(每控制器2GB)的专用控制器缓存。目前，DS5100和DS5300采用PCI-Express作为内部总线，从而提高了DS5100和DS5300的整体性能。

此外，DS5100和DS5300的控制器中增加了一个USB闪存，当意外掉电时，DS5100和DS5300将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。

网络课堂:http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000

2.DS5020 CPU、缓存信息与配置：

DS5020每控制器含一个Intel xScale 1.2 GHz处理器。

DS5020目前支持2GB(每控制器1GB)或 4GB(每控制器2GB)缓存，e-Config中默认是2GB缓存配置，配置4GB缓存机型需要增加fc#2070选件，目前，DS5020不能从2GB缓存MES升级到4GB；DS5020采用PCI-Express作为内部总线，从而提高了DS5020的整体性能。

此外，DS5020的控制器中增加了一个USB闪存，当意外掉电时，DS5020将电池保护下的缓存数据保存到专用的闪存中，由于闪存是一种非易失性存储介质，当数据转移到闪存后，即使充电电池失效，仍然可以保证掉电时的缓存数据不丢失。因此理论上DS5000中的缓存信息可以永久保存。


DS5100/DS5300 e-config配置注意事项

解答:

1．DS5100/DS5300的e-config配置中，有Adapters的选项，这个卡区别于DS4000配置中用在主机端的HBA卡。在DS5000的机头上，本身是没有主机接口的，需要配置这种Adapter来配置主机端口。如下图，每个fc#2050(4G)或fc#2052(8G)包含2块4端口的卡(即8端口)，在DS5100/DS5300中可以选择8个或16个FC端口；

fc#2060包含2块双端口的1GbE iSCSI卡(即4端口)，在DS5100/DS5300中可以选择4个或8个iSCSI端口。

2．接口卡上不用另配模块，那么在SFP的选择中，所选的SFP模块都是接在扩展端口，连接扩展柜用的。DS5000共有16个扩展端口，可以配置8或者16个模块(即4个fc#2412或8 fc#2412)

3．DS5100/DS5300是8/16/32/64GB Cache可选。
在DS5100/DS5300中，FC和SATA硬盘的混插是不需要License的，在e-config配置中，没有这个选项。
在DS5300中，如果连接8台EXP5060，需要fc#7373。
在DS5100中，如果连接8台EXP5060，需要fc#7371和fc7372；如果连接16台以上1818-D1A(EXP5000)需要fc#7371。
注：EXP5060是一款可容纳60块1TB SATA硬盘的扩展柜。

Top


DS5100/DS5300 SFP与线缆配置方法

解答:

DS5100/DS5300可以配置两块或者四块4端口FC主机接口卡，e-config中每个fc#2050或fc#2052代表两块4端口4Gbps或8Gbps FC主机接口卡，并且每块配置的主机接口卡均满配相应端口数量的SFP模块； DS5100/DS5300还可以配置iSCSI主机接口卡，但是iSCSI主机接口卡不需要SFP模块。

DS5100/DS5300默认拥有16个扩展柜连接端口，默认没有自带SFP模块，可以选择配置4对或8对SFP模块。e-config中每个fc#2412表示两个SFP模块，当扩展柜数量小于等于4时，建议选择4个fc#2412，当扩展柜数量大于4时，建议选择8个fc#2412。

线缆可以选择fc#5601，fc#5605和fc#5625，分别对应1米，5米和25米FC多模 LC-LC线缆，以及fc#5810 OM3 FC多模 LC-LC线缆，fc#5818是4个一包的OM3 FC多模 LC-LC线缆，OM3线缆在相同速率下可以支持更远的传输距离；连接主机端口的线缆需要根据主机或FC交换机数量以及连接方式决定；用于连接扩展柜端口的线缆建议在配置扩展柜时进行选择，每个扩展柜选择两根即可。

网络课堂：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000


DS5100/DS5300 主机接口卡的配置方法

解答:

DS5100/DS5300 e-config配置中，FC主机接口卡是安装在DS5100/DS5300上，用于连接主机HBA卡或者光纤交换机，iSCSI主机接口卡是安装在DS5100/DS5300上，用于直连或通过以太网交换机连接网卡、iSCSI卡。

目前有三种类型的主机接口卡可供配置，它们分别是：

1. fc#2050代表2块4口（Quad）4Gbps FC主机接口卡；
2. fc#2052代表2块4口（Quad）8Gbps FC主机接口卡；
3. fc#2060代表2块2口（Dual）1GbE iSCSI主机接口卡。

其中FC主机接口卡均随卡满配相应端口数量的SFP模块，DS5100/DS5300中可以配置2块或者4块主机接口卡，也就是说可以从fc#2050、fc#2052和fc#2060中选择1组或2组，最多支持16个FC主机接口或者8个iSCSI主机接口。


DS5000 e-config配置中TPC软件的选择

解答:

1.目前，DS5020中Related SW选项中有两个配置选项：

a)5608-E14 IBM Tivoli Storage Productivity Center for Disk Midrange Edition

b)5608-WC0 IBM Tivoli Storage Productivity Center standard Edition

2.配置注意事项：

a)5608-E14是IBM Tivoli软件针对中端存储(DS3000、DS4000、DS5000)推出的。能够用一个终端实现设备配置、性能监控及管理的一款软件，方便客户对IBM中端存储进行统一的管理和监控。

b)5608-WC4是IBM TPC软件的标准版本，它包含了对SAN网络中磁盘阵列、数据、网络性能的管理，能对各存储设备进行统一的管理和监控，收集并分析各个存储的提供的数据，实现资源的优化和性能的最大化。

c)在e-config配置中，5608-E14默认已经配置。该软件是可选组件，根据客户的要求配置。如客户无配置要求，可以删除该软件配置。

参考资料：
1.名称：5608-E14销售手册(Sales Manual)：

2.名称：5608-WC0销售手册(Sales Manual)


EXP5060中SFP模块及线缆的配置及注意事项

解答:

1.在EXP5060配置中有光纤模块和光纤线缆的选择:

a)fc#2412为一对光纤模块；
b)线缆规格为1米、5米、25米三种。

2.配置注意事项：

a)EXP5060默认自带了两个SFP模块。EXP5060的连接方式有3种：与DS5000扩展柜混连；非中继连接(no-tranked)；中继连接(tranked)：

(1)与DS5000扩展柜混连，环路里的第一个扩展柜不需要配置模块，环路里的第二个以上的扩展柜需要添加一对模块；
(2)非中继连接(no-tranked)，环路里的第一个扩展柜不需要配置模块，环路里的第二个以上的扩展柜需要添加一对模块；
(3)中继连接(tranked)，环路里的第一个扩展柜需要配置一对模块，环路里的第二个以上的扩展柜需要添加两对模块。

b)在非中继连接(no-tranked)时，每个扩展柜需要有两根光纤线连接；在中继连接(tranked)时，每个扩展柜需要有四根光纤线连接。长度根据具体的机房环境来选择。


EXP5060中磁盘的配置及注意事项

解答:

EXP5060是DS5100/DS5300专用的高密度扩展柜，在4U高的柜子里能支持最少20块，最大60块硬盘（10个一包），EXP5060只支持SATA硬盘:

a) 1 TB,2 TB 7200转的SATA硬盘；

b) 支持不同容量SATA硬盘混插。


DS5000 Expansion Unit中SFP模块及线缆的配置及注意事项

解答:

1.DS5000 扩展柜(DS5000 Expansion Unit)是DS5100/DS5300的专用扩展柜，配置中有光纤模块和光纤线缆的选择:

a)fc#2412为一对光纤模块；

b)线缆规格为1米、5米、25米三种。

2.配置注意事项：

a)DS5000扩展柜(DS5000 Expansion Unit)默认自带了两个SFP模块。当该扩展柜是扩展环路中的第一个柜子时，不需要添加SFP模块，当该扩展柜是扩展环路中的第二个或者以上的柜子时，需要添加一个fc#2412；

b)每个扩展柜需要有两根光纤线连接，长度根据具体的机房环境来选择。


DS5000 Expansion Unit中磁盘的配置及注意事项

解答:

1.目前DS5000扩展柜(DS5000 Expansion Unit)的配置中，有4类硬盘的配置：

a) 1 TB,2 TB 7200转的SATA硬盘；

b) 300 GB，450 GB，600 GB 15000转的光纤硬盘(单个/16个一包)；

c) 300 GB，450 GB，600 GB 15000转的光纤加密硬盘(单个/16个一包)；

d) 73 GB，300 GB 的固态硬盘(SSD)。

2.配置注意事项：

a)DS5000扩展柜(DS5000 Expansion Unit)最大支持16块硬盘，支持任何形式的硬盘混插。


DS8000的配置中，各种License的功能介绍，与磁盘容量的对应关系，如何选择以适应不同的高级功能需求

解答:

DS8000配置中，主要有以下许可(License)功能:

1. OEL:

是按照客户订购的DS8000的裸容量来购买的许可（license）,许可（license）的容量不得少于物理容量。如：DS8000一共订购了10TB容量的硬盘，则需要客户订购至少10TB的OEL许可（license）.该许可（license）是必须的。

除此之外DS8700新增加了OEL value unit 许可，此许可是根据磁盘的性能，容量，转速等特性来收费。OEL value unit也是必配的许可，配置时容量不少于econfig中指示的point值。

2. PTC:

是按照客户订购的DS8000的裸容量来购买PTC(point time copy)即Flashcopy的许可（license），许可（license）的容量不得少于物理容量。该许可（license）是可选的。

它包含：PTC,PTC add,SE,SE add 4个选项。

a.PTC:
是标准的FlashCopy许可(License)。

b.SE:
是FlashCopy SE的许可(License)。

c.SE add:
是如果客户在已经订购了PTC的基础上，加订Flashcopy SE的许可(License)。

d.PTC add:
是如果客户在已经订购了SE的基础上，加订标准FlashCopy的许可(License)。

3. RMC：

是按照客户订购的DS8000的裸容量来购买RMC(remote mirror copy)即Remote mirror的许可（license），该许可（license）的容量不得少于物理容量。该许可（license）是可选的。

它包含：MGM,MM,GM,GM add,MM add。

a.MM(Metro Mirror)：
是按照客户订购的DS8000的裸容量来购买Metro Mirror的许可(License)。
MM(Metro Mirror)的原理是：本地DS8000和远程DS8000的逻辑卷之间实现实时同步镜像,两个DS8000的距离最大可达300公里。

b.GM(Global Mirror)：
是按照客户订购的DS8000的裸容量来购买Global Mirror的许可(License)。
GM(Global Mirror)的原理是：本地DS8000和远程DS8000的逻辑卷之间实现异步镜像,两个DS8000的距离可以更远。

c.MGM(Metro/Global Mirror):
是按照客户订购的DS8000的裸容量来购买3 site Metro/Global Mirror的许可(License)。
MGM(Metro/Global Mirror)的原理是：先是本地DS8000和远程第一个DS8000的逻辑卷之间实现实时同步镜像,远程第一个DS8000再和远程第二个DS8000逻辑卷之间实现异步镜像。

d.GM add: 是如果客户在已经订购了MM(Metro Mirror)的基础上，加订GM(Global Mirror)的许可(License)。

e.MM add: 是如果客户在已经订购了GM(Metro Mirror)的基础上，加订MM(Global Mirror)的许可(License)。

注意：在DS8700与DS8800配置中，没有GM add与MM add许可，需要订购标准的GM与MM许可。

4. RMZ：

是按照客户订购的DS8000的裸容量来购买RMZ(Remote Mirror for Z/OS)即Remote Mirror的许可(License).

客户的应用环境是Z/OS的情况下，要想实现DS8000的Remote Mirror功能需要购买的许可(License)，许可(License)的容量不得少于物理容量。该许可(License)是可选的。

5. PAV:

是按照客户订购的DS8000的裸容量来购买Parallel Access Volumes (PAV)的许可(License)。

该license是客户的应用环境是Z/OS的情况下，能够实现单个Z系列的服务器来并发处理针对同一个逻辑卷的多个I/O操作,从而可以大大减少设备的排队延时时间。license的容量不得少于物理容量。该license是可选的。

参考资料：
查阅IBM销售手册:Storage System 销售手册查询

Top


DS8700 function Auth 中各license的配置

解答:

在DS8700 function Auth中新增加了OEL value unit 许可，此许可是根据磁盘的性能，容量，转速等特性来收费。OEL value unit是必配的许可，配置时容量不少于e-config中指示的point值。OEL的容量的license在DS8700中是免费的，配置时不少于物理容量。

如果客户需要Easy tier的功能，需要增加IBM System Storage Easy Tier许可（fc#7083）,这个许可是免费的。Easy tier实现在SSD磁盘与FC/SATA混合的环境下，自动将热点数据迁移到SSD磁盘上,其他的数据放在普通的磁盘上以提升性能同时实现分级存储。Easy tier还可以实现整卷迁移到不同类型的磁盘上。Easy tier是IBM DS8000 5.1版本微码的新功能。

PTC是实现快照功能的license， 包括PTC与SE两种类型。PTC是是标准的Flashcopy许可，而SE是Flashcopy SE的许可。配置这两种许可时，不得少于物理容量。PTC为DS8700选配许可。

RMC是用于在开放平台上的远程镜像功能，包括MM，GM与MGM三种类型。MM许可是实现本地与远程DS8000逻辑卷之间实时同步镜像的许可。GM实现本地与远程DS8000逻辑卷之间实时异步镜像的许可。MGM实现三站点间数据镜像的许可。即先是本地DS8000和远程第一个DS8000的逻辑卷之间实现实时同步镜像,远程第一个DS8000再和远程第二个DS8000逻辑卷之间实现异步镜像。MM，GM与MGM均为DS8700选配许可，配置时不少于物理容量。

RMZ是用在大机上的远程镜像功能，PAV也是用在大机上的，这些都是选配的，配置时不少于物理容量。


DS8700软件的选择

解答:

DS8700中可以选配TPC软件,IBM Tivoli Storage Productivity Center是实现存储及相关设备管理的解决方案。它提供了管理整个存储环境及相关设备的所需功能。通过TPC界面不仅能够管理和配置存储环境中的各种异构的存储设备，能够管理交换机和主机，还能够获取各设备的性能统计数据以及性能调优的建议。TPC可以减少用户管理各种存储设备的开销，提高存储设备的性能，提供了一种可配置的、简单易用的存储实时监控功能。

通过IBM Tivoli Storage Productivity Center，存储的已用及可用的空间分配、各设备的可访问性、设备上的事件、性能和各种存储以及数据库都可以被统一地监控和管理。TPC采集各设备使用情况的数据，并对该历史数据进行分析。用户可以定制显示这些数据的方式。其次，TPC提供了各种可由用户订制而后自动运行的管理模式和界面。另外，用户可通过TPC定义警报的触发条件以及接收警报的方式。比如，设备的当前配置存在违反用户定义的配置规则的危险，或者设备的组件已经损坏，这些都是TPC可报告的事件。

IBM Tivoli Storage Productivity Center提供了用户管理复杂的存储环境的全套方案，包括TPC for Data, TPC for Disk, TPC for Replication, TPC for Standard Edition 等版本。TPC for Data, TPC for Disk对于各自所针对管理的存储环境中的设备, 都提供相关设备配置数据和性能数据的采集， 用户可订制的数据显示及设备运行情况的实时监控，和修改配置的功能。 TPC for Standard Edition 包含了TPC for Data, TPC for Disk两个版本的所有功能。

TPC for Replication有助于管理IBM DS8000，ESS800，DS6000与SVC所提供的高级复制功能。它使用基于向导的会话和复制设置定义，自动管理和配置复制服务并对其提供简单的操作控制，包括在同方向或反方向开始、暂停和继续。TPC for Replication还提供工具以监控和管理复制会话。

目前TPC for Replication最新版本为 V4.2， 包括一些新功能和增强功能：
·适用于开放系统的 OpenSwap，可提高系统的可用性；
·增强的 PPRC 通路管理，确保冗余的端口组合；
·Disaster Recovery Planner，集成存储和复制功能；
·DS8000多重全局镜像支持,提高了性能，支持多个 GM 会话；
·对副本集执行软拷贝删除，改进了对会话/复制服务迁移的支持；
·对IBM System Storage SAN 卷控制器（SVC）的增量 FlashCopy 支持。


DS8700的CPU、缓存的选择及配置

解答:

DS8700中有两种CPU卡：2-way processor card和4-way processor card。

在选择2路CPU时，缓存有32/64/128GB的三种选择。在选择4路CPU时，缓存有32/64/128/256/384GB的5种选择。

在选择2路CPU的时候，DS8700最大支持128块硬盘，即不支持扩展柜。当选择4路CPU的时候，DS8700支持最大1024块硬盘，即4个扩展柜。

突出价值点：全新 DS8700 的 POWER6 处理器采用的是主频为 4.7Ghz 的处理器。每个处理器有两块处理器卡，每块处理器卡中可以容纳 2 个处理器。这样每个处理器最多就能容纳 4 个 POWER6的处理器。除此之外，相比于现有 DS8000 系列产品中每块处理器卡拥有 8 个DIMM 插槽，在DS8700 中增加到 12 个。这样，DS8700 将整个系统所能够容纳的内存数量从现有 DS8000 的256GB 提升到了 384GB。

采用新的硬件之后，DS8700 中的所有系统部件都可以同步更换，甚至从 2 路处理器到更强大的 4 路处理器的升级都不会对客户的应用造成影响。IBM DS8700 进一步简化系统管理的复杂度，使得用户可以更方便地使用存储设备的各项功能。在能源消耗受到高度重视的全球大环境下，DS8700 在保证海量数据处理性能和高可用性的前提下，可以用更少的能耗来达到所需的性能指标。

DS8700 延续了 DS8000 系列产品的良好传统；更为关键的是，在对高端存储设备的硬件进行升级的时候，用户的应用不会被中断。此外，与 DS8300 相同的硬盘和硬盘仓，以及和 DS8300 完全兼容的镜像服务，还可以全面保护客户现有的 DS8000 系列产品投资。


DS8700硬盘选择及配置

解答:

IBM DS8700 在4路CPU（4-way CPU)的配置时，最多可以支持4个磁盘扩展柜，最多支持1024块硬盘。在2路CPU（2-way CPU)的配置时，只包含一个主柜，最多支持128块硬盘。

在e-config工具中，IBM DS8700的磁盘配置方法与DS8000其它型号一致，都以磁盘组（Drive Set）的方式来订购，每个磁盘组包含16块磁盘。

IBM DS8700支持FC磁盘、可加密FC磁盘，SATA盘与固态盘四种类型。其中可加密FC磁盘不能与其它类型磁盘在DS8700中混用。

固态盘除了支持标准的磁盘组配置外,还支持半组(half Driver Set)的配置,即个磁盘组里8块磁盘。需要特别注意，每台DS8700里，只能订一个半组的固态盘磁盘组，而DS8700最大支持256块固态盘。

在IBM DS8700中，固态盘只支持RAID 5，FC磁盘支持RAID 5，6，10, 而SATA磁盘支持RAID6，10。

DS8700同样支持CoD类型的磁盘。

通过下表，用户可以了解IBM DS8700具体支持的磁盘信息与Value Unit许可数量，它是根据磁盘的性能，容量，转速等特性来收费。

Feature Number | Size | Drive type | Drive speed | Encryption drive | Non-encryption drive | Value Units Required
6014 | 73 GB | SSD half set | N/A | No | Yes | 6
6114 | 146 GB | SSD half set | N/A | No | Yes | 9
6214 | 600 GB | SSD half set | N/A | No | Yes | 25
6016 | 73 GB | SSD | N/A | No | Yes | 12
6116 | 146 GB | SSD | N/A | No | Yes | 18
6216 | 600 GB | SSD | N/A | No | Yes | 50
2416 | 300 GB | FC | 15K rpm | No | Yes | 6.8
2616 | 450 GB | FC | 15K rpm | No | Yes | 9
2716 | 600 GB | FC | 15K rpm | No | Yes | 11.5
5116 | 300 GB | FC | 15K rpm | Yes | No | 6.8
5216 | 450 GB | FC | 15K rpm | Yes | No | 9
2916 | 2 TB | SATA | 7.2K rpm | No | Yes | 20


DS8700的磁盘配置注意事项

解答：

1.DS8700硬盘配置以Set为单位，每个Drive Set包括16块硬盘，并且最少配置一个DriveSet。

2.DS8700 2-way CPU型号最大支持128块硬盘，不支持连接2421-94E扩展柜，最大支持8个Drive Set，即128块硬盘。

3.DS8700 4-way CPU型号最大支持1024块硬盘，最多支持4个2421-94E扩展柜，其中机头最大支持8个Drive Set，即128块硬盘，前三个2421-94E扩展柜最大支持3*16个Drive Set，即768块硬盘，第四个2421-94E扩展柜最大支持8个Drive Set，即128块硬盘。

4.目前DS8700支持146GB,300GB,450GB，600GB 15000转的FC盘，600GB 标准SSD固态盘包和半包配置，2TB SATA盘，300GB,450GB 15000转的FDE加密盘。另外还支持FC，SATA或者FDE的CoD随需激活的硬盘。DS8700默认的微码为R5.1，支持上述硬盘。

5.DS8700中最多支持256块SSD固态盘，固态盘支持RAID 5；2TB SATA盘支持RAID 6和RAID 10。

6.DS8700中，如果配置FDE全加密盘，需要配置Tivoli Key Lifecycle Manager (TKLM) V2.0 软件fc#5608-A99；此外，全加密盘不能与其他类型的硬盘混插。

Top


DS8700 OEL value unit计算及配置方法

解答:

Value Unit是根据磁盘大小,转速来衡量磁盘性能的一个指标，value unit值越大，磁盘性能越好。

Feature Number | Size | Drive type | Drive speed | Encryption drive | Non-encryption drive | Units Required
6014 | 73 GB | SSD half set | N/A | No | Yes | 6
6114 | 146 GB | SSD half set | N/A | No | Yes | 9
6016 | 73 GB | SSD | N/A | No | Yes | 12
6116 | 146 GB | SSD | N/A | No | Yes | 18
2016 | 73 GB | FC | 15K rpm | No | Yes | 3.3
2216 | 146 GB | FC | 15K rpm | No | Yes | 4.8
2416 | 300 GB | FC | 15K rpm | No | Yes | 6.8
2616 | 450 GB | FC | 15K rpm | No | Yes | 9
2716 | 600 GB | FC | 15K rpm | No | Yes | 11.5
5016 | 146 GB | FC | 15K rpm | Yes | No | 4.8
5116 | 300 GB | FC | 15K rpm | Yes | No | 6.8
5216 | 450 GB | FC | 15K rpm | Yes | No | 9
2816 | 1 TB | SATA | 7.2K rpm | No | Yes | 11
2916 | 2 TB | SATA | 7.2K rpm | No | Yes | 20

在用e-config配置的时候，e-config系统会自动算出value unit的值，并且自动配出，不需要人为配置。


IBM DS8800硬盘选择及配置

解答：

IBM DS8800 是IBM新分布的最新一代企业级磁盘存储产品，为客户提供了高性能，高容量，高扩展性与高可靠性的产品。

IBM DS8800包括一个主柜与最多配置两个扩展柜，最大支持1056块磁盘。在e-Config工具中，DS8800的磁盘配置方法与DS8000其它型号一致，都以磁盘组(Driver Set)的方式来订购，每个磁盘组包含16块磁盘。

在e-Config工具中，IBM DS8800当选择“2-Way Processor Card”(fc#4301)时，只能配置一个主柜，不能增加扩展柜。如果选择fc#1250 Business Class连接的光纤线缆,主柜中最多支持15个磁盘组，共240块磁盘。如果选择fc#1246标准连接的光纤线缆,主柜中最多只支持9个磁盘组，共144块磁盘。

当选择“4-Way Processor Card”(fc#4302)时，如果选择fc#1250 Business Class连接的光纤线缆,最多配置一个扩展柜，此时主柜最多支持15个磁盘组，共240块磁盘。扩展柜里最多支持21个磁盘组，共336块磁盘。所以Business Class连接的光纤线缆最多只支持576块磁盘。如果选择#1246标准连接的光纤线缆，最多可以配置两个扩展柜。此时主柜最多支持15个磁盘组，共240块磁盘，第1个扩展柜最多支持21个磁盘组，共336块磁盘。第2个扩展柜最多支持30个磁盘组，共480块磁盘。所以标准连接的光纤线缆使得DS8800最多可以支持1056块磁盘。

IBM DS8800支持SAS盘，可加密SAS盘与固态盘三种类型。其中可加密SAS盘不能与SAS盘在DS8800混用。SSD只支持RAID 5，而SAS盘支持RAID 5，6，10。DS8800同样支持CoD类型的磁盘。

DS8800支持的磁盘具体型号如下：
300 GB SSD drive
146 GB 15,000 rpm SAS
450 GB 10,000 rpm SAS
600 GB 10,000 rpm SAS

450 GB 10,000 rpm FDE SAS
600 GB 10,000 rpm FDE SAS

146 GB 15,000 rpm CoD SAS
450 GB 10,000 rpm CoD SAS
600 GB 10,000 rpm CoD SAS
450 GB 10,000 rpm FDE CoD SAS
600 GB 10,000 rpm FDE CoD SAS

Top


DS8800 e-Config中HA/Cables的配置

解答:

在DS8800 e-Config "Host/Adapter"选项中，可以配置用于连接前端主机或SAN交换机的主机接口卡，有4端口或者8端口及长波与短波的选择。
当选择“2-Way Processor Card”(fc#4301)时，DS8800主柜至少要配置2块，最多可以配置4块主机接口卡，最多达到32个主机接口。
当选择“4-Way Processor Card”(fc#4302)时，如果选择fc#1250 Business Class连接的光纤线缆, DS8800主柜最多可以配置4块主机接口卡，最多达到32个主机接口。最多支持一个扩展柜，扩展柜里可以最多增加8块主机接口卡，最多达到64个主机接口。所以在此种配置下，DS8800整机最多支持96个主机接口。如果选择fc#1246标准连接的光纤线缆，DS8800主柜最多可以配置8块主机接口卡，最多达到64个主机接口。最多可以配置两个扩展柜，在第一个扩展柜中还可以支持8块主机接口卡64个主机接口。所以在此种配置下，DS8800整机最多支持128个主机接口。

共有四种类型可以选择：
(fc#3153) 8Gb 4 port SW FCP/FICON Adapter PCIe
(fc#3157) 8Gb 8 port SW FCP/FICON Adapter PCIe
(fc#3253) 8Gb 4 port LW FCP/FICON Adapter PCIe
(fc#3157) 8Gb 8 port LW FCP/FICON Adapter PCIe

通常情况下，如果选择短波的主机接口卡，则配置50微米的多模光纤线；如是选择了长波的主机接口卡，则配置9微米长波的光纤线。
现在大部分主机HBA卡接口与SAN交换机接口均为LC类型，所以我们选择LC类型的光纤线，即fc#1410和fc#1420。如果客户的主机HBA卡或交换机接口为SC类型，由于DS8800主机接口为LC类型，所以此时需要选择LC/SC类型的光纤张，即fc#1411和fc#1421。

Top


IBM XIV 硬盘选择及配置

解答：

在IBM XIV存储系统中，可以配置1TB或者2TB的SATA磁盘。但是这两种磁盘不能在一套XIV系统中混合使用。

在e-config工具中，当选择“2TB DCPU”标识时，就可以在下面的网格单元选择中，选择单盘容量为2TB的接口（fc#1102）与数据（fc#1107）网格单元。

如果选择“Dual-CPU”标识，那么在下面的网格单元选择中，选择单盘容量为1TB的接口（fc#1101）与数据（fc#1106）网格单元。

在IBM XIV系统中，不论在网格单元中选择1TB还是2TB的磁盘，都还可以选择配置“Capacity on Demand(CoD)”类型的网络单元，即先购买全部网格硬件与现阶段所需要的网格单元数量激活许可，然后再根据需求在未来12个月内补订余下的网格单元激活许可。

如果选择“2TB DCPU Capacity on Demand(CoD)”标识，那么就必须订购含2TB磁盘的6个接口网格单元（fc#1112）与9个数据网格单元（fc#1117）总共15个单元。最少订4个网格单元的许可(fc#1121)，最大可订15个许可即激活全部单元。“CoD Standard order”（fc#0301）是一个仅用于管理目的的标识，当订满15个激活许可时，这个feature将会自动消失。

如果选择“Dual-CPU Capacity on Demand(CoD)”标识，那么就必须订购含1TB磁盘的6个接口网格单元（fc#1111）与3个数据网格单元（fc#1116）总共9个单元。最少订4个网格单元的许可(fc#1120)，最大可订9个许可即激活全部单元。同样，“CoD Standard order”（fc#0301）是一个仅用于管理目的的标识，当订满15个激活许可时，这个feature将会自动消失。

在IBM XIV系统中，最多可以配置6个接口网格单元与9个数据网格单元，每个网格单元都具有CPU、内存与磁盘。两种类型的网格单元区别只在于接口单元具有连接前端主机或交换机的FC或iSCSI接口。

通过下表用户可以查询不同数量的网络单元对应的磁盘容量，接口数量、功耗、内部还宽，CPU数量与内存等信息。

Top


SVC(2145-CF8) 硬件的Features和Cables配置

解答：

(fc#5305) 5 m Fiber Optic Cable LC-LC
该feature提供一根 5-meter，2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#5325) 25 m Fiber Opt Cable LC-LC
该feature提供一根 25-meter，2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#5608) 8 Gbps LW SFP
SVC V5.1支持split a SVC I/O group 跨长距离。 8 Gpbs LW SFP feature code fc#5608 是目前支持用于该配置的唯一硬件。该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#0010) Storage Engine Preload
该feature 提供由IBM 工厂在SVC Storage Engine上预安装required SVC Storage Software，该feature缺省就是选中的。

Top


SVC(2145-8A4) 硬件的Features和Cables配置

解答：

(fc#5305) 5 m Fiber Optic Cable LC-LC
该feature提供一根 5-meter, 2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#5325) 25 m Fiber Opt Cable LC-LC
该feature提供一根 25-meter, 2端是LC接口的fiber optic cable. 该feature不是必选的，最大的数量是4，最小的可选数量是0。

(fc#0010) Storage Engine Preload
该feature 提供由IBM 工厂在SVC Storage Engine上预安装required SVC Storage Software . 该feature缺省就是选中的。

Top


SSPC 硬件的Features和Power Cords配置

解答：

(fc#00xx) Preload Features
该feature 是订货方式的选择，中国大陆地区这里要选0018 TotalStorage Productivity Center Basic Edition will be ordered in AAS/e-config。

(fc#1810) Dual Power Supply Option
该feature 提供一个另外的 redundant 670 Watt Power Supply 且带有一根 Y-cable来增强电源的冗余可用性。一般都建议订购该feature。

(fc#9100) Console Keyboard/Display/Drawer
该feature 提供一个Console Keyboard/Display/Drawer。

(fc#117x - fc#118x) Power Cords
该feature是电源线，中国大陆地区这里要选 # 1183 Power Cord，Group 13 China (250V，10A)。该feature是必须选的，最大的数量是3，最小的数量是1。如果选了双电源，该featue的数量要选2。

Top


IBM Storwize V7000 线缆及模块的配置

解答：

V7000默认都带有8个8Gbps的短波（SW）主机端口，在e-config配置中，能配置2-8根光纤线，无需再配置短波模块。

V7000的主机接口，支持长波（LW）的直接连接。在e-config配置时，如果选择8Gbps 长波（LW）模块（fc#5608），那么在出厂时，会把短波（SW）模块换成长波（LW）模块。


Storwize V7000 硬件的SFP配置

解答:

Storwize V7000 硬件的SFP配置：

Storwize V7000的控制器盘柜一共有8个8 Gbps FC host ports, (每个RAID controller 有4个 8 Gbps FC ports ) 且缺省每个8 Gbps FC host port都已经插有短波(SW)的SFP transceivers。一般情况下，不需在该页面选择，即#5608的数量为0。如果客户有特殊的长波SFP transceivers连接需求，此页面中可以选择另外订购最多8个#5608 8Gbps长波(LW)的SFP transceivers。


Storwize V7000 硬件的HDDs配置

解答:

上面是窗口是2076-124的硬盘配置窗口，2076-224同上。
选择V7000控制器盘柜中的硬盘的数量，最多可以配置24块硬盘。
有4种硬盘的类型可以选择，分别是:

fc#3203 300GB 2.5in 10k HDD；
fc#3204 450GB 2.5in 10k HDD；
fc#3206 600GB 2.5in 10k HDD；
fc#3504 300GB 2.5in SDD。

其中fc#3203，fc#3204，fc#3206是SAS硬盘；fc#3504是SSD硬盘。

V7000控制器盘柜支持SAS 硬盘, Nearline SAS 硬盘, 和SSD硬盘在一个IBM Storwize V7000 Control Enclosures 和 IBM Storwize V7000 Expansion Enclosures盘柜里混插。

上面是窗口是2076-112的硬盘配置窗口，2076-212同上。

选择V7000控制器盘柜中的硬盘的数量，最多可以配置12块硬盘。

有1种硬盘的类型可以选择，#3302 2TB 3.5in 7.2k HDD 是 Nearline SAS 硬盘。

Top


Tape System

存储设备(Disk/Tape/SAN/NAS/SVC)的电源线的如何配置 (最近更新)

e-config中磁带的配置介绍 (最近更新)

TS3100/TS3200/TS3310/TS3500要实现LTO加密功能所需的配置

3584-L53配置注意事项

TS7610 软、硬件配置及注意事项 (最近更新)

TS7650 硬件中Features和cables的配置 (最近更新)

TS7650G 硬件中Storage Link和Attach的配置 (最近更新)


存储设备(Disk/Tape/SAN/NAS/SVC)的电源线如何配置

解答:

1. Disk:
a.DS4000/DS5000及EXP810/EXP520/EXP5000/EXP5060扩展柜：选择fc#9840“Peoples Republic of China”。
b.DS6000及其扩展柜：选择fc#9890 “Peoples Republic of China”。
c.DS8000及其扩展柜：选择fc#9091 AV Voltage: 380-480, 电源线选择fc#1090 line cord。
d.Storwize V7000：选择fc#9730 PDU电源线 或 fc#9726 中国地区墙插电源线。

2. Tape:
a.TS2900：桌边型电源线选择fc#9840“Peoples Republic of China”；机架型电源线选择fc#7006 “Rack Mount Kit with Device to PDU Line Cord”。
b.TS3100/TS3200/TS3310：桌边型电源线选择fc#9840“Peoples Republic of China”；机架型电源线选择fc#9848 “Rack to PDU Line Cord”。

3. SAN:
a.IBM SAN-B系列(2005-BXX)：桌边型电源线选择fc#9840“Peoples Republic of China”。
b.2106-C36机柜：“Optional PDU pair”选择fc#9766 “Korea”；“Power cords”选择fc#9835 “Single phase(Korea)”。

4. NAS:
所有产品均选择fc#9008 “Power Cord, China”。

5. SVC:
选择fc#9726 “Power Cord, China”。

参考资料:
查阅IBM销售手册:Storage System 销售手册查询


e-config中磁带的配置介绍

解答:

1.在磁带库的e-config配置中，TS2900、TS3100以及TS3200的硬件e-config配置中会自动配置feature号为#8305，#8405，#8505的磁带，这种磁带是五盘一包，但是这种磁带并不带标签，一般不建议客户配置这种磁带。建议客户到e-config的Storage Media中配置相应的带标签的磁带。

2.Storage Media中的磁带分类主要常用的有，3589-004（清洗带），3589-010（LTO4带标签的数据带），3589-011（LTO4不带标签的数据带），3589-014（LTO5带标签的数据带），3589-015（LTO5不带标签的数据带），以上几种磁带配置中清洗带为五盘一包，数据带为20盘一包，这几种磁带主要用于3580磁带机或者支持LTO驱动器的磁带库中。

3.由于e-config的Storage Media配置中磁带标签的编码为乱码，因此需要客户在配置磁带的时候手动修改为正确的编码。LTO4的标签应为xxxxx0L4,LTO5的标签应为xxxxx0L5。


TS3100/TS3200/TS3310/TS3500要实现LTO加密功能所需的配置

解答:

要实现TS3100,TS3200,TS3310的加密功能，首先需要配置LTO 4/ LTO 5的驱动器，其次需要购买fc#5900的加密激活license，在配置完成后会自动加载TKLM即IBM Tivoli Key Lifecycle Manager软件来实现加密功能。

要实现TS3500加密功能，首先需要配置LTO 4/ LTO 5或者TS1120 / TS1130的驱动器，其次需要配置fc#1604，fc#1690，fc#9900的加密激活许可，在配置完成后会自动加载TKLM即IBM Tivoli Key Lifecycle Manager软件来实现加密功能。

注意：请参考备份软件兼容性列表，确认当前版本支持带库驱动器类型。

突出价值点：通过在驱动器中给磁带加密实现硬件加密，这种加密技术能够提供更好的压缩比，从而节省磁带空间。此外，这种加密技术不需要额外的加密设备（如：加密机）和软件支持，从而节约成本、简化管理。

Top


3584-L53配置注意事项

解答：

3584-L53目前支持2种驱动器，3588-F3B和3588-F4A。fc#1514为驱动器上架套件，必须大于等于驱动器个数，fc#9681/fc#9682/fc#9679为驱动器的安装方式标示，数量必须等于驱动器个数。

在配置TS3500机头槽位时，有几种选择，如果不选任何选项，那么3584-L53默认激活了64个槽位，选中fc#1643，则槽位升级到一半即129个，再选中fc#1644，槽位全部激活，有261-287个槽位（4个以上驱动器，槽位跟驱动器数量有冲突）。

3584-L53有两种支持的扩展柜，3584-S54和3584-D53。D53是普通扩展柜，能加12个驱动器，最大支持440个磁带槽位。S54是高密度扩展柜，不能加驱动器，只能增加槽位。在S54中，有一个fc#1646的槽位激活选项，不选这个选项，S54是660个槽位，选上这个选项之后能扩展至单个柜子1320个磁带槽位。S54扩展柜适合于客户机房空间不足，而对容量要求又很高的情况。另外，在配置S54的时候，需要在L53机头上配置fc#9050和fc#9205的license。

3584-L53双机械臂的配置注意事项：1）3584-L53中至少有一个3584-D53的扩展柜； 2）必须保证有一个无驱动器的D53，将其放在最右边，同时在D53中，选择fc#1440 service bay B，并去掉额外的电源模块fc#1451 ；3）在L53中，选择fc#9040 High Availability Library选件，并在最左边添加一个3584-HA1作为控制机柜。

3584-L53驱动器与槽位的关系表：

按需扩展的feature类型 | 驱动器的数量 | I/O槽位数 | 槽位的总数量
默认 | 0-12 | 16 | 64
Intermediate(半数激活) | 0-12 | 16 | 129
Full (全激活) | 0-4 | 16 | 287
Full (全激活) | 5-8 | 16 | 273
Full (全激活) | 9-12 | 16 | 261
Full (全激活) | 0-4 | 32 | 245
Full (全激活) | 5-8 | 32 | 231
Full (全激活) | 9-12 | 32 | 219

突出价值点：企业级的磁带库产品，按需扩展容量。磁带槽位、驱动器的灵活配置能更好的满足不同用户的不同需求。支持动态逻辑带库划分，动态槽位扩展等虚拟化管理。双机械臂的配置为企业级带库用户在多磁带槽位的情况下寻找抓取最优路径，提高了带库效率。

Top


TS7610 软、硬件配置及注意事项

解答：

1. 硬件配置注意事项：

TS7610虚拟带库支持2个4Gbps 光纤主机端口，在e-config配置中，默认会有一块双端口的HBA卡(fc#3459)。

TS7610支持两种容量，4.4TB(fc#9313)和5.9TB(fc#9314)，在配置中可以选择。容量的变更是通过软件的方式来实现的，并非增加硬盘等的硬件方式，没有费用产生。

2. 软件配置注意事项：

TS7610中5639-TAA软件是必配的的选项，他是TS7610实现虚拟带库功能的基础。

在5639-TAA软件的配置中包含Base和Replication两个选项，Base选项包含了重复数据删除的功能，是必选的。Replication选项能够支持数据在TS7610、TS7650和TS7650G之间复制的功能，根据客户要求选配。

参考文档
销售手册(Sales Manaual)
http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS3959-_h01/index.html


TS7650 硬件中Features和cables的配置

解答：

TS7650G(3958-DD4)Features和Cables的配置:

(fc#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(fc#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(fc#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2.

(fc#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(fc#3447) Cluster Connection Kit
这个产品号提供一个network power control switch, 2 个ethernet switches, 及相关的线缆和上架硬件，用来创建一个 clustered 配置在两个 TS7650 Servers之间.#3447（The Cluster Connection Kit）必须和 两个 TS7650 Servers放在同一个机柜中。如果有两个 TS7650 Servers做cluster，则#3447是必须的，否则，不需要订，两个做 cluster的TS7650 Servers只需在其中的一个上订购一个fc#3447。缺省的数量是0，最大数量是1。

(fc#9306) ProtecTIER EE V2 load
表示在TS7650 server上配置的软件版本是ProtecTIER Enterprise Edition V2 (PID 5639-XXB) . 是必须要订的，缺省的数量是1，最大/最小数量都是1。

(fc#9340) Rack Mount DD1
表示TS7650G Server 需要放入客户提供的工业标准的 19英寸机柜. 是必须要订的，缺省的数量是1，最大/最小数量都是1。

(fc#6025) 25 Meter LC/LC Fibre Channel Cable
该feature提供一根 25 meter (82 ft.) 50.0/125 micrometer 的短波多模光纤线缆，在光纤线缆两端有LC duplex 接口. 可以用来连接TS7600 server和switch，或host，或者是后端的disk subsystem。不是必须要订的，缺省的数量是4，最大数量都是8. 最小数量都是0。

(fc#9700) No Factory Cables
当订购新机器时，不需要从工厂订购任何光纤线缆时，选择该feature。不是必须要选的，缺省的数量是0，最大数量都是1. 最小数量都是0。

TS7650(3958-AP1)Features和Cables的配置

(fc#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(fc#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(fc#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(fc#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(fc#3170) 16 2.27 GHz Processor Cores
表示提供一个 x3850 X2 processor。 是必须要选的，最大数量都是2， 最小数量都是1。

(fc#3707) 4.8 TB FC Disk Expansion
表示是DS5020 expansion drawer，带有 16 块FC 硬盘. 是必须要选的，最大数量都是6, 最小数量都是1。

(fc#3708) 4.8 TB FC Disk Controller
表示是DS5020 controller ，带有 16 块FC 硬盘. 是必须要选的，最大数量都是2，最小数量都是1。

(fc#08XX) Initial Configuration Indicators
表示是初始配置容量的标示符。

以下分别是是VTL和OST支持的4种配置方案：

(fc#6025) 25 Meter LC/LC Fibre Channel Cable
该feature提供一根 25 meter (82 ft.) 50.0/125 micrometer 的短波多模光纤线缆，在光纤线缆两端有LC duplex 接口。可以用来连接TS7600 server和switch，或host，或者是后端的disk subsystem。不是必须要订的，缺省的数量是4，最大数量都是8。最小数量都是0。

(fc#9700) No Factory Cables
当订购新机器时，不需要从工厂订购任何光纤线缆时，选择该feature。不是必须要选的，缺省的数量是0，最大数量都是1。最小数量都是0。

Top


TS7650G 硬件中Storage Link和Attach的配置

解答：

(fc#903X) Attach
表示TS7650G后端连接的盘阵的类型。其中fc#9030，#9031，#9033表示后端连接一台或多台新的DS8000，DS5000，XIV，fc#9038表示后端连接一台或多台除以上三款型号外新的IBM磁盘存储，fc#9039表示后端连接一台或多台已经购买的磁盘存储（注意：以上存储必须符合TS7650G兼容性）。

该窗口可以直接添加TS7650G所连接的盘阵，一般建议不在这个窗口里添加，而是单独做一个该盘阵的配置下订单。

Top


N series 配置

N series

N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

N Series Port/Loop indicator在e-config中的配置方法 (最近更新)

N3300/N3400/N3600硬盘配置与容量问题


N series扩展柜EXN1000/EXN4000/EXN3000的e-config配置

解答：

N series有三种扩展柜可以连接,一种支持SATA硬盘,一种支持FC硬盘，另一种支持SAS/SATA硬盘。

1. 连接EXN1000扩展柜：

当配置EXN1000的SATA扩展柜时，要先在e-config工具里"Ports/Loops Indicator"选项下配置fc#9559 SATA环路数(每个环路最多能接6个EXN扩展柜)。

然后在e-config工具里"Disk Expansions"选项下添加EXN1000的扩展柜，在配置EXN1000时要注意"Cable"里面选择是第一个直连到系统柜的，还是要连接到其他扩展柜的。

其中，EXN1000的"Disks"项根据需求选择磁盘大小和数量，最小5块，最大14块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

2. 连接EXN4000扩展柜：

当配置EXN4000的FC扩展柜时，要先在e-config工具里"Ports/Loops Indicator"选项下配置fc#9558 FC环路数(每个环路最多能接6个EXN扩展柜)。

然后去e-config工具里"Disk Expansions"选项下添加EXN4000的扩展柜，在配置EXN4000时要注意"cable"里面选择是第一个直连到系统柜的，还是要连接到其他扩展柜的。

其中，EXN4000的"Disks"项根据需求选择磁盘大小数量，最小5块，最大14块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

3. 连接EXN3000扩展柜：

当配置EXN3000的SAS/SATA扩展柜时，首先要在e-config工具中“Adapters/Cables”下选择SAS接口的PCIe卡(N3400板载有SAS接口，不用配)，单控制器中SAS卡的数量为奇数，双控制器SAS卡的数量为偶数，不需要在e-config工具里"Ports/Loops Indicator"选项下配置fc#9558 或 fc#9559。然后在e-config工具里"Disk Expansions"选项下添加EXN3000的扩展柜，在配置EXN3000时要注意"Cable"里面选择是在stack的最底部，还是非底部。

其中，EXN3000的"Disks"项根据需求选择磁盘大小数量，最小5块，最大24块；"Power Cord"项中如果连接机架PDU选择fc#9000，如果配置墙插电源线选择fc#9008；"Misc.Feature"项中如果购买了N series专用机柜选择fc#9201，否则选择fc#9202。

IBM于2009年10月20日推出一种新的N系列扩展柜EXN3000，这是一款4U高的扩展柜，可以配置24块SAS或者SATA硬盘。

EXN3000提供了廉价高可用性的SAS口连接方式，它通过N系列的板载或者PCIe SAS卡连接，因此可以支持它的N系列存储有N3400，N3600，N6040，N6060，N6070，N7900。

参考资料：
查阅IBM销售手册：Storage System 销售手册查询


N Series Port/Loop indicator在e-config中的配置方法

解答:

(fc#9557) Num.of FC Target Ports：表示连接前端主机或SAN交换机的FC端口数量，如果设置该数量（非0），需要选择相关FCP许可，如：fc#6569或fc#6574；

(fc#9558) Num.of FC Storage Loops：表示连接后端FC扩展柜EXN4000的环路对数量，每环路对最多支持6个扩展柜。通常，一个环路对由2个FC端口组成，如果选择了fc#9560，那么一个环路对由4个FC端口组成。如果集成的FC端口数量不足，还需要选择相应的Adapter，如：fc#1014或fc#1029；

(fc#9559) Num. of SATA Storage Loops：表示连接后端SATA扩展柜EXN1000的环路数量，每环路对最多支持6个扩展柜；通常，一个环路对由2个FC端口组成，如果选择了fc#9560，那么一个环路对由4个FC端口组成。如果集成的FC端口数量不足，还需要选择相应的Adapter，如：fc#1014或fc#1029；

(fc#9560) Dual-path FC Cabling：表示采用多根光纤冗余连接到扩展柜，增加可靠性，但会占用更多FC端口，只适用于双节点的配置。

另外，如果配置EXN3000扩展柜，无需在这里配置，只需要配置足够的SAS端口即可

下面以一台双节点N6060（2858-A22）为例，假设我们需要8个端口用于连接前端主机实现FCP服务，以及2个FC环路和2个SATA环路，并且不需要扩展柜冗余连接:

在e-config中选择①Port/Loop indicator，通过②Max 8可以知道2858-A22集成了8个FC端口，根据假设中的需求将③fc#9557置为8，④和⑤分别置为2,⑥置为0:

由于选择了fc#9557，还需要配置FCP许可。我们需要在e-config中选择⑦Licensed Functions，然后双击⑧进入许可配置菜单:

在许可配置中，选择⑨Licensed Functions 6xxx/7xxx，然后选择⑩FCP许可 fc#6569:

此外，根据需求，总共需要16个FC端口，其中8个集成端口用于连接前端主机，还需要配置4个环路对，即8个端口用于连接扩展柜。
在e-config中选择⑾Adapters/Cables,然后⑿选择2块fc#1029:

Top


N3300/N3400/N3600硬盘配置与容量问题

解答:

N3300配置方法如下：
N3300主柜支持12块 SAS或SATA硬盘。目前，N3300支持以下容量、类型的硬盘：
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3300支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
最大支持连接4台EXN1000或EXN4000。

N3300主柜最大支持12块硬盘、4台扩展柜最大支持56块，总共最大支持68块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3300最大支持68TB物理容量。

N3300配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3300配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数。

由于N3300上FC端口数量的限制，如果配置了扩展柜，对于N3300-A10，由于无法配置fc#9557，即没有FC端口用于连接前端主机，将不能使用FCP协议；
对于N3300-A20，可以支持FCP，但是fc#9557和fc#9560（冗余连接扩展柜）不能并存。

N3400配置方法如下：
N3400主柜支持12块 SAS或SATA硬盘。目前，N3400支持以下容量、类型的硬盘:
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3400支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
- EXN3000，支持SAS和SATA硬盘，每个扩展柜支持最少5块、最大24块SAS或SATA硬盘
最大支持连接6台EXN1000或EXN4000，或者4台EXN3000。

N3400初始订单最大支持108块硬盘、升级订单最大支持136块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN3000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs SAS硬盘
- 450GB 15K转 4Gpbs SAS硬盘
- 600GB 15K转 4Gpbs SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3400最大支持136TB物理容量。

N3400配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3400配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数；
N3400配置EXN3000扩展柜时，由于其板载集成了SAS端口，因此不需要增加接口选件。

由于N3400上FC端口数量的限制，如果配置了扩展柜，对于N3400-A11，由于无法配置fc#9557，即没有FC端口用于连接前端主机，将不能使用FCP协议；
对于N3400-A21，可以支持FCP，但是fc#9557和fc#9560（冗余连接扩展柜）不能并存。

N3600配置方法如下：
N3600主柜支持20块 SAS或SATA硬盘。目前，N3600支持以下容量、类型的硬盘:
- 300GB 15K转SAS硬盘
- 450GB 15K转SAS硬盘
- 600GB 15K转SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
注意：主柜中的硬盘必须是相同类型、相同容量的硬盘。

N3600支持以下类型的扩展柜：
- EXN1000，支持SATA硬盘，每个扩展柜支持最少5块、最大14块SATA硬盘
- EXN3000，支持SAS或SATA硬盘，每个扩展柜支持最少5块、最大24块FC硬盘
- EXN4000，支持FC硬盘，每个扩展柜支持最少5块、最大14块FC硬盘
最大支持连接6台EXN1000、EXN3000或EXN4000。

N3600主柜最大支持20块硬盘、6台扩展柜最大支持84块（尽管EXN3000物理上支持更多的硬盘槽位，但是目前最大也只支持84块硬盘），总共最大支持104块硬盘。

EXN1000扩展柜目前支持以下类型、容量的硬盘：
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN3000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs SAS硬盘
- 450GB 15K转 4Gpbs SAS硬盘
- 600GB 15K转 4Gpbs SAS硬盘
- 500GB 7.2K转SATA硬盘
- 1TB 7.2K转SATA硬盘
- 2TB 7.2K转SATA硬盘
EXN4000扩展柜目前支持以下类型、容量的硬盘：
- 300GB 15K转 4Gpbs FC硬盘
- 450GB 15K转 4Gpbs FC硬盘
- 600GB 15K转 4Gpbs FC硬盘
注意：同一个扩展柜中的硬盘必须是相同类型、相同容量的硬盘，同一个环路中必须使用相同类型的扩展柜。

目前，在Data ONTAP 7.x版本下，N3600最大支持104TB物理容量。

N3600配置EXN4000扩展柜时，还需要在e-config中选择fc#9558，即FC扩展柜环路数；
N3600配置EXN1000扩展柜时，还需要在e-config中选择fc#9559，即SATA扩展柜环路数；
N3600配置EXN3000扩展柜时，还需要在e-config中选择fc#1060 SAS卡。

Top


SAN/Ethernet Switch

3758-L32 SFP与线缆的选择与配置 (最近更新)

2005-R04 SFP与线缆的选择与配置

2005-R04 许可（License）的选择与说明

2498-R06 SFP与线缆的选择与配置(最近更新)

2498-R06 许可（License）的选择与说明(最近更新)

768B 交换刀片与SFP的解释以及配置注意事项 (新增)

768B 许可(License)的选择与说明 (新增)

384B 交换刀片与SFP的解释以及配置注意事项 (新增)

384B 许可(License)的选择与说明 (新增)


3758-L32 SFP与线缆的选择与配置

解答:

3758-L32是一种机架式FCoE交换机，带有24个用于连接LAN的万兆以太网端口和8个用于连接光纤通道SAN的光纤通道端口(最高速度达8 Gbps)。这种可靠的高性能交换机可提供先进的光纤通道服务并支持CEE功能，由DCFM管理软件进行管理。

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于3758-L32中的24个CEE端口中，配合OM3 Cable(线缆)使用。

SR：短波(Short Reach)模式。

LR：长波(Long Reach)模式。

Twinax：双绞线(铜缆)，自带转接模块，可以直接插在3758-L32的24个CEE端口中，有1米、3米、5米三种长度的线缆，支持10Gbps传输速率，支持热插拔。

8Gbps SW SFP：速率8Gbps的短波SFP模块，只用于3758-L32的8个FC端口中，配合multimode(多模光纤)使用。

8Gbps 10KM LW SFP：速率8Gbps的长波SFP模块，最长传输距离10KM，只用于3758-L32的8个FC端口中，配合siglemode(单模光纤)使用。

8-Pack：8个一包，可以按包选择，等同于选择8个独立的模块或线缆。

线缆参数描述：

fc#5605 5m Fibre Cable LC/LC multimode 50u: 5米长度，LC到LC接口多模光纤，配合短波模块(SW SFP)使用；

fc#5625 25m Fibre Cable LC/LC multimode 50u: 25米长度，LC到LC接口多模光纤，配合短波(SW SFP)模块使用；

fc#5721 31m Fibre Cable LC/LC multimode 9u: 31米长度，LC到LC接口单模光纤，配合长波(LW SFP)模块使用；

fc#5810 10m OM3 Cable LC/LC: 10米长度，LC到LC接口，配合10Gbps SFP+模块使用。


2005-R04 SFP与线缆的选择与配置

解答:

2005-R04交换机集光纤通道交换、路由功能和硬件辅助IP光纤通道（FCIP）流量转发功能于一身。该交换机带有16个4 Gbit/sec光纤通道端口和2个千兆以太网端口，可提供很高的性能，使存储应用不论采用哪种协议都可以以线速运行。

fc#2410 4 Gbps SW SFP Transceiver：4Gbps接口速率短波SFP转接模块，配合多模光纤线缆使用。

fc#2420 4 Gbps 10KM LW SFP Transceiver：4Gbps接口速率，上限10KM传输距离长波转接模块，配合单模光纤线缆使用。

fc#2430 4 Gbps 4KM LW SFP Transceiver：4Gbps接口速率，上限4KM传输距离长波转接模块，配合单模光纤线缆使用。

fc#2440 4 Gbps 30KM ELW SFP Transceiver：4Gbps接口速率，上限30KM传输距离超长波转接模块，配合单模光纤线缆使用。

fc#2550 1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口以太网转接模块，配合以太网线使用。

Fibre Cable multimode：多模光纤，配合SW(短波)SFP使用。

Fibre Cable siglemode：单模光纤，配合LW(长波)SFP使用。

注意：2005-R04中，SFP转接模块可以配置的转接模块数量只有4个和满配18个两种配置，其它数量的SFP模块配置不被允许。


2005-R04 许可（License）的选择与说明

解答:

fc#7530 FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；

fc#7537 High-Performance Extension Activation(req. FOS v6.1.1)： 激活满配情况下16个4Gbps光纤端口以及2个1Gbps光纤以太网端口，并提供很多功能以增加整体传输性能，要求2005-R04操作系统版本在6.1.1以上；

fc#7538 FICON Accelerator Activation：提供FICON端口到Z/OS的连通性，并且提供Z/OS使用FCIP协议实现远程镜像（Global Mirror）的复制链路的加速功能；

fc#7576 R04 Performance Monitoring Activation：SAN环境整体性能监控，监控点到点之间带宽使用情况；

fc#7577 R04 Enhanced Trunking Activation：激活两台交换机之间的多端口Trunking绑定。


2498-R06 SFP与线缆的选择与配置

解答:

4Gbps/8Gbps：SFP接口速率为4Gbps/8Gbps；

SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；

LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；

ELW(Enhance Long Wave):超长波SFP模块，配合单模光纤线，用于超长距离数据传输；

1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；

8-Pack：SFP模块8个一包，可以按包选择；

4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用，其中配置10KM/25KM/30KM的长波SFP模块，必须配置fc#7742 Extended Fabric许可(license)。

线缆参数描述：

fc#5605 5m Fibre Cable LC/LC multimode 50u: 5米长度，LC到LC接口多模光纤，配合短波模块(SW SFP)使用；

fc#5625 25m Fibre Cable LC/LC multimode 50u: 25米长度，LC到LC接口多模光纤，配合短波(SW SFP)模块使用；

fc#5721 31m Fibre Cable LC/LC multimode 9u: 31米长度，LC到LC接口单模光纤，配合长波(LW SFP)模块使用；

fc#5810 10m OM3 Cable LC/LC: 10米长度，LC到LC接口，配合10Gbps SFP+模块使用。

注意：
2498-R06中，默认激活4个FC端口以及2个以太网端口，要激活全部22个端口(16个FC端口以及6个以太网端口)，必须添加fc#7732许可(License)，SFP收发模块可以配置的数量最小配置4个最大配置44个(44个，实际端口数量的2倍，R06实际拥有22个端口)。


2498-R06 许可（License）的选择与说明

2498-R06 许可(License)的选择与说明

解答:

fc#7731 R06 Enterprise Bundle:许可(License)包，其中包含fc#7734 Performance Monitor、fc#7735 Trunking Activation、fc#7736 Adaptive Networking以及fc#7740 Fabric Watch；

fc#7732 R06 Port Activation 12 FC,4 IP :激活全部端口可用，2498-R06默认激活4个FC端口以及2个以太网端口，要使用全部22个端口(16个FC端口以及6个以太网端口)，必须添加FC7732许可(License)；

fc#7733 R06 8 Gbps Advanced Extension :激活两个功能：FCIP Trunking，可以把R06中的以太网端口绑定(最多4个端口)，以达到增加带宽和链路冗余的效果；Adaptive Rate limiting(ARL),在带宽压力比较大的时候，ARL可以限制其它TCP连接速率，以保证R06的以太网传输带宽；

fc#7734 R06 Performance Monitor：SAN环境整体性能监控，监控点到点之间带宽使用情况；

fc#7735 R06 Trunking Activation : 激活两台交换机之间的多FC端口Trunking绑定；

fc#7736 R06 Adaptive Networking :可以设定某一链路的基本带宽，可以在压力大的带宽中保证该链路的基本带宽以及性能；

fc#7737 R06 FICON w/CUP Activation：激活连接Z/OS FICON接口时，可以使用带内管理用的License；

fc#7739 R06 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由(FCR)功能；

fc#7740 R06 Fabric Watch:为交换机提供关于状态、性能以及安全性方面的前期诊断和预警，可以把故障排除在发生之前；

fc#7742 R06 Extended Fabric:支持超过10KM以上的远距离连接，根据产品不同，调整交换机内部buffer，最远可以达到3000KM，配合LW(长波)模块或者ELW(超长波)模块以及单模光纤线使用。


768B 交换刀片与SFP的解释以及配置注意事项

解答:

768B e-Config中Connection选项中主要配置各种不同类型端口的刀片(Blade)，以及适应不同类型端口的SFP模块。一台768B最少配置1片刀片(Blade)最多配置8片刀片(Blade)，除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块。

1．768B 交换刀片(Blade)解释说明:

fc#3816：16个8Gb光纤端口交换刀片(Blade)；
fc#3832：32个8Gb光纤端口交换刀片(Blade)；
fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，比如使用光纤环路(Loop)协议的磁带机以及磁带库等设备；
fc#3864：64个8Gb光纤端口交换刀片(Blade)，自带64个8Gbps 短波光纤转接模块(SFP)；
fc#3850：光纤路由交换刀片(Blade)，提供16个光纤端口以及两个以太网口，提供FC协议到IP协议的转换功能；
fc#3870：6个10Gb光纤端口交换刀片(Blade)；
fc#3880：24个10Gb CEE端口交换刀片(Blade)，配合10Gbps fc#2117、fc#2118、fc#2151、fc#2158 SFP+转接模块使用；
fc#3890：12个8Gbps端口扩展刀片(Blade)，可以支持2个10Gbps以太网端口或者10个1Gbps以太网端口，配置组合为10个1Gbps以太网端口，或者2个10Gbps以太网端口，或者10个1Gbps以太网端口以及1个10Gbps以太网端口，要使用10Gbps以太网端口，必须配置fc#7892 10GbE Activation。

2. 768B SFP模块解释说明：

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于fc#3880 FCoE 10GbE 24-port Blade中的24个CEE端口中，配合OM3 Cable(线缆)使用；
SR：短波(Short Reach)模式；
LR：长波(Long Reach)模式；
4Gbps/8Gbps:SFP接口速率为4Gb或8Gb；
SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；
LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；
ELW(Extend Long Wave):远距离传输长波SFP模块，配合单模光纤线使用；
XFP：10Gb光纤模块；
8-Pack：SFP模块8个一包，可以按包选择；
1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；
4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用。

3. 配置注意事项：

a)768B中交换刀片(Blade)根据需求至少配置1片，最多配置8片，每类型交换刀片(Blade)所提供的端口数量以及端口类型都是不一样的，在配置时需要注意，按照实际需求选择正确的交换刀片(Blade)。除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块；
b) 8-Pack SFP模块包，等同于配置8个独立的SFP模块；
c) fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，无法连接磁带机以及磁带库等必须使用光纤环路(Loop)协议的设备。

Top


768B 许可(License)的选择与说明

解答:

768B e-Config中License/Cables选项中主要配置光纤交换机中高级管理和高级功能的许可(License)以及应用于连接不用端口类型的线缆配置，可以根据具体的需求进行选择。

1．许可解释：

fc#7870 Inter-Chassis Cable Kit：提供必需的线缆使一台768B背板串联到另外一台768B交换机，以形成一台更大的交换机，配合fc#7885或fc#7882订购；
fc#7880 SAN768B Pair of Upgrade Power Supplies：再添加额外的两个电源支持，768B默认带有两个电源，选上这个功能后，总共4个电源支持；
fc#7885 Inter-Chassis License：激活一台768B的背板互联功能，以形成一台更大的交换机；
fc#7886 SAN768B FICON w/CUP Activation: 激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7887 FCIP/FC High-Performance Extension：激活FC到IP的路由转换功能，前提为768B 必须配置fc#3850：光纤路由交换刀片(Blade)；
fc#7888 FICON Accelerator: 提供FICON端口到Z/OS的连通性，并且提供Z/OS使用FCIP协议实现远程镜像(Global Mirror)的复制链路的加速功能；
fc#7889 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由(FCR)功能；
fc#9010 SAN768B Server Application Optimization，Initial：激活下单流程的优化；
fc#7882 Inter-Chassis License，Half：激活一半768B交换机啊背板互联功能，使一半768B背板串联到另外一台768B交换机的一半或者背板串联到另外一台384B交换机。

2. 线缆参数说明：
a) Fibre Cable multimode：多模光纤，配合SW(短波)SFP使用；
b) Fibre Cable siglemode：单模光纤，配合LW(长波)SFP使用；
c) OM3 Cable：第三代多模光纤，适合运行10 Gbps链路；
d) 4-Pack: 4根线缆一包，可以按包选购。

3. 注意事项：
a) 所有的高级许可(License)都有特定的应用功能以及应用上的必要条件，在配置选择时，需要根据用户准确需求进行配置；
b) 光纤线缆的选择需要根据所配置的交换刀片(Blade)以及SFP类型进行选择。

Top


384B 交换刀片与SFP的解释以及配置注意事项

解答:

384B e-config中Connection选项中主要配置各种不同类型端口的刀片(Blade)，以及适应不同类型端口的SFP模块。一台384B最少配置1片刀片(Blade)最多配置4片刀片(Blade)，除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块。

1．384B 交换刀片(Blade)解释说明:

fc#3816：16个8Gb光纤端口交换刀片(Blade)；
fc#3832：32个8Gb光纤端口交换刀片(Blade)；
fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，比如使用光纤环路(Loop)协议的磁带机以及磁带库等设备；
fc#3864：64个8Gb光纤端口交换刀片(Blade)，自带64个8Gbps 短波光纤转接模块(SFP)；
fc#3850：光纤路由交换刀片(Blade)，提供16个光纤端口以及两个以太网口，提供FC协议到IP协议的转换功能；
fc#3870：6个10Gb光纤端口交换刀片(Blade)；
fc#3880：24个10Gb CEE端口交换刀片(Blade)，配合10Gbps fc#2117、fc#2118、fc#2151、fc#2158 SFP+转接模块使用；
fc#3890：12个8Gbps端口扩展刀片(Blade)，可以支持2个10Gbps以太网端口或者10个1Gbps以太网端口，配置组合为10个1Gbps以太网端口，或者2个10Gbps以太网端口，或者10个1Gbps以太网端口以及1个10Gbps以太网端口，要使用10Gbps以太网端口，必须配置fc#7892 10GbE Activation。

2. 384B SFP模块解释说明：

SFP+：光纤转接模块收发器，支持SR(Short Reach)短波、LR(Long Reach)长波模式，短波或者长波的SFP+模块可以支持连接10Gb链路，SFP+模块只用于fc#3880 FCoE 10GbE 24-port Blade中的24个CEE端口中，配合OM3 Cable(线缆)使用；
SR：短波(Short Reach)模式；
LR：长波(Long Reach)模式；
4Gbps/8Gbps:SFP接口速率为4Gb或8Gb；
SW(Short Wave)：短波SFP模块，配合多模光纤线，用于短距离内数据传输；
LW(Long Wave)：长波SFP模块，配合单模光纤线，用于长距离数据传输；
ELW(Extend Long Wave):远距离传输长波SFP模块，配合单模光纤线使用；
XFP：10Gb光纤模块；
8-Pack：SFP模块8个一包，可以按包选择；
1Gbps Copper SFP Transceiver：1Gbps接口速率，铜口SFP模块，连接以太网线使用；
4KM/10KM/25KM/30KM：最长传输距离分别为4KM/10KM/25KM/30KM的长波SFP模块，配合单模光纤使用，其中配置10KM/25KM/30KM的长波SFP模块，必须配置fc#7803 Extended Fabric Activation许可(License)。

3. 配置注意事项：

a)384B中交换刀片(Blade)根据需求至少配置1片，最多配置4片，每类型交换刀片(Blade)所提供的端口数量以及端口类型都是不一样的，在配置时需要注意，按照实际需求选择正确的交换刀片(Blade)。除fc#3864 64个8Gb光纤端口交换刀片(Blade)外，其他刀片(Blade)均不带SFP模块，需要按照端口类型配置SFP模块；
b) 8-Pack SFP模块包，等同于配置8个独立的SFP模块；
c) 选择10KM、25KM、30KM 长波SFP模块，需要配置 fc#7803 Extended Fabric Activation许可(License)；
d) fc#3848：48个8Gb光纤端口交换刀片(Blade)，不支持环路(Loop)设备，无法连接磁带机以及磁带库等必须使用光纤环路(Loop)协议的设备。

Top


384B 许可(License)的选择与说明

解答:

384B e-Config中License/Cables选项中主要配置光纤交换机中高级管理和高级功能的许可(License)以及应用于连接不用端口类型的线缆配置，可以根据具体的需求进行选择：

1．许可解释：

fc#7803 384B Extended Fabric Activation：支持超过10KM到80KM的远距离传输缓存调整；
fc#7870 SAN384B Inter-Chassis Cable Kit：提供必需的线缆使一台384B背板串联到另外一台384B或者背板串联到另外一台768B交换机，以形成一台更大的交换机；
fc#7884 SAN384B FICON w/CUP Activation: 激活连接Z/OS FICON接口时，可以使用带内管理用的License；
fc#7887 FCIP/FC High-Performance Extension：激活FC到IP的路由转换功能，前提为384B 必须配置fc#3850：光纤路由交换刀片(Blade)；
fc#7888 FICON Accelerator: 提供FICON端口到Z/OS的连通性，并且提供Z/OS使用FCIP协议实现远程镜像(Global Mirror)的复制链路的加速功能；
fc#7890 Integrated Routing:可以设定端口为EX-Port类型，并提供光纤路由(FCR)功能；
fc#9020 SAN384B Server Application Optimization，Initial：激活下单流程的优化；
fc#7712 2499-192 Firmware Update 1 year：1年微码升级服务，2499-192默认带有1年微码更新服务，可以通过订购fc#7712许可(License)再增加1年升级服务，用以保证新功能的更新；
fc#7713 2499-192 Firmware Update 2 years：2年微码升级服务，2499-192默认带有1年微码更新服务，可以通过订购fc#7713许可(License)再增加2年升级服务，用以保证新功能的更新。

2. 线缆参数说明：

a) Fibre Cable multimode：多模光纤，配合SW(短波)SFP使用；
b) Fibre Cable siglemode：单模光纤，配合LW(长波)SFP使用；
c) OM3 Cable：第三代多模光纤，适合运行10 Gbps链路；
d) 4-Pack: 4根线缆一包，可以按包选购。

3. 注意事项：

a) 所有的高级许可(License)都有特定的应用功能以及应用上的必要条件，在配置选择时，需要根据用户准确需求进行配置；
b) 光纤线缆的选择需要根据所配置的交换刀片(Blade)以及SFP类型进行选择。

Top


DR550配置

DR550

DR550配置中，可以选择的Key Application包含哪些


DR550配置中，可以选择的Key Application包含哪些

解答:

DR550配置中，可以选择的Key Application并不是选择相应的应用平台后会提供相应的软件或平台支持，而只是对于DS550应用于不同应用平台的了解以及调研。

fc#9250 Key Application:IBM FileNet
IBM FileNet P8 核心内容管理解决方案平台，提供以内容为中心的企业流程管理包，该平台帮助企业用户管理日益攀升的信息量和减少企业流程消耗的时间和成本,DR550提供到FileNet的接口，可以与整体解决方案平台有效融合。这个特性表示DR550从IBM FileNet应用中存储数据。

fc#9251 Key Application:IBM Content Manager or Commonstor
IBM 企业内容管理解决方案平台，提供可扩展企业范围内的存储系统，以便对关键业务内容进行捕获、创建、整理、管理、通过工作流传达、存档并进行生命周期管理，提高企业级连接能力和信息访问能力，帮助企业充分利用商业知识和信息获取更多价值。这个特性表示DR550从IBM Content Manager或者Commonstor应用中存储数据。

fc#9252 Key Application:Other
其他可以应用DS550 API的应用软件平台。这个特性表示DR550从不在列表中的其他应用中存储数据。

fc#9253 Key Application:IBM Optim
IBM企业数据管理解决方案平台，跨数据生命周期设计、开发、部署和数据库应用程序管理提供了全面的集成数据管理环境。Optim能够归档事务处理的历史记录，并以安全、成本有效的方式存储这些记录。这个特性表示DR550从IBM Optim应用中存储数据。

Top


附录 Storage

附录

Storage System售前常用工具

1.IBM System Storage Competitive Sales Tool Version 10.15（December 21, 2010）

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/4F68C0CF2311C10D002573720020B21B?Opendocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件

2.TCO Comparison Tool for Disk Storage Systems

软件简介：
TCOnow! for Disk可以帮助我们比较现有磁盘存储与新购方案中的磁盘存储的成本。在新方案中，我们也可以通过TCOnow! for Disk对IBM与其他厂商（如EMC、HP和日立）的磁盘成本进行比较。此外，还可以对磁盘存储潜在的高级功能与软件进行比较，提高了成本计算与比较的准确性。
TCOnow! for Disk还具有以下便捷功能：
1.快速便捷的TCO计算与分析；
2.个性化的价格报告；
3.快速生成直观的图形化建议方案书。

https://www-304.ibm.com/partnerworld/wps/servlet/mem/ContentHandler/tstotcocomptool113005

访问方法：
第一步：点击TCOnow！工具的链接；
第二步：进入“PartnerWorld: sign in”界面，在IBM ID和Password文本框中输入用户名和密码；
第三步：进入工具安装页面，根据链接和安装步骤进行下载和安装即可；或参考附件的视频教程进行安装（点击页面最下面的“tconowfordiskdemov04.exe”，下载执行即可观看）。

系统要求：
Windows 2000 (Service Pack 4) 或 Windows XP；
Internet Explorer v6.x 或 以上；
需要连接到Internet。

安装步骤：
首先，登陆 link 注册您的公司信息，详细信息请登录查询（注意：只有IBM Business Partners可以使用）；

第一步：安装CIOview Player软件：
1. 下载“CIOview Player setup.exe”本地硬盘，双击该文件（CIOview Player软件 下载链接）；
2. 安装开始，完成后，点击“Finish”；
注意：CIOview Player需要Microsoft’s .NET Framework。如果没有安装.NET Framework，安装程序会自动通过Internet安装该软件，安装时的文件名为“dotnetfx.exe”，软件提供商为InstallShield Software Corp.安装完成后可能会重启计算机。

第二步：注册 CIOview Player：
1. 打开“开始 -> 程序 -> CIOview Player -> CIOviewPlayer V4”；
2a.第一次运行时，工具自动显示未注册的对话框，填写注册表格，点击“Register”；
2b.如果没有自动显示注册表格，点击“Help -> Register”，然后填写注册表格，点击“Register”；
(注意：填写邮件地址域名须为授权代理公司的邮件域名，否则可能收不到许可文件。)
3. 关闭CIOview Player。

第三步：激活CIOview Player许可，打开一个 TCOnow! for Disk 工程：
1. 检查您关于CIOview的email信息，邮件内包括CIOview的个人唯一许可，以下两种方法可以激活；
a）点击email中的链接，打开CIOview Player目录，拖拽许可文件到打开的目录；
b）复制粘贴许可文件（player.license.txt）到“CIOview Player V4”的安装目录；
2. 打开“开始 -> 程序 -> CIOview Player -> CIOviewPlayer V4”；
3. 打开“Content -> Browse for Additional Content Modules”；
4. 在列表中找到并选中"TCOnow! for Disk"，点击Install；
5. 安装完成后，打开“File -> New -> TCOnow! for Diks”，创建一个 TCOnow! for Disk 工程。

3.TCO/ROI估算工具

一个非常好的TCO/ROI评估工具 - Alinean SCON, 该工具通过数字、图表的方式，直观地展现使用IBM的服务器整合方案可以为客户带来怎样的成本降低和高的投资回报率。Alinean作为第三方工具，不隶属任何厂商，因而更中立，合作伙伴、最终客户都可自行注册使用。

工具链接：https://roianalyst.alinean.com/stgz/

工具的介绍，可以参考网络课堂《您可以使用的TCO/ROI估算工具 》。

4.在线存储产品支持，热点包括：

(1) IBM 存储产品常见问题汇总：IBM工程师常遇到的问题汇总

(2) IBM 存储产品配置常见问题汇总

(3) 网络课堂：以Flash动画的方式对当前热门技术进行介绍，甚至包括用e-config一步一步的教您如何配置一台服务器.

还有很多其他有用的链接:
http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=4

5.IBM System Storage and TotalStorage products（英文）存储产品资料查询

IBM System Storage and TotalStorage products，包括IBM全线的存储产品，根据存储产品的字母顺序，可以方便查询相关信息
http://www-03.ibm.com/systems/storage/product

6.IBM System Storage Interoperability Matrices 存储产品兼容性文档列表

IBM System Storage Interoperability Matrices 包括最新的Disk、Tape、SAN和NAS等存储产品的兼容性文档
http://www-03.ibm.com/systems/storage/product/interop.html

7.IBM System Storage Interoperation Center在线存储产品兼容性查询

IBM System Storage Interoperation Center，可以根据存储产品的型号，查询兼容的微码版本、应用主机、系统平台、SAN交换机以及HBA卡等信息。
http://www-03.ibm.com/systems/support/storage/config/ssic

8.FC HBA Search Tool 存储产品光纤通道卡兼容性查询工具

FC HBA Search Tool， 可以根据产品类型和系统平台，查询所有的System Storage 产品的光纤通道卡（HBA）兼容性信息
http://www-03.ibm.com/systems/support/storage/config/hba/index.wss

9.销售手册

IBM硬件和软件的销售手册
http://www-01.ibm.com/common/ssi/index.wss

10.红皮书网站

全面的IBM技术参考资料网站。
http://www.redbooks.ibm.com

例如：

用“Technical Overview and Introduction”来查询，能够查询到各款IBM Power服务器的技术特点介绍红皮书
用“N series”来查询，能够查询到现在Nseries存储产品相关的红皮书。

11.IBM Publications Center，可以查询IBM所有相关产品文档，其中包括中文资料

http://www.elink.ibmlink.ibm.com/publications/servlet/pbi.wss

12.IBM 存储产品白皮书链接：

http://www-03.ibm.com/support/techdocs/atsmastr.nsf/Web/WhitePapers

存储白皮书查询列表


存储家族产品一览表

存储家族产品一览表中，展现了目前存储的主要产品，下面的文档中列出了存储产品的参数信息。

注意：本存储家族服务器一览表适用于设备当前情况，如产品有任何变化，我们将在下一版本更新。


存储产品配置文件中英文翻译工具

通过存储产品配置文件翻译工具，可以将.CSV的英文配置文件翻译成中文的配置文件，目前我们的工具支持对DS4700, DS4800, DS5020, DS5100, DS5300, DS8100, DS8300, DS8700, DS8800, B24, B40, B80, SVC 8A4/CF8, XIV, TS2900, TS3100, TS3200, TS3310, TS3500产品的硬件Feature Code进行自动翻译。

首先打开翻译工具，选择“启用宏”，点击“选择文件”按钮，选择需要进行翻译的.CSV配置文件，然后点击“开始翻译”按钮，将产生一个中文的.xls配置文件，并可对其进行保存操作。

注：此翻译工具为方便用户了解配置文件所开发的Beta版非正式工具，中文的翻译仅供参考，如果您对此工具有任何意见和建议，请及时联系我们(techline@cn.ibm.com)。

下载配置文件中英文翻译工具


存储销售手册快速查询通道

通过下面的列表，找到相关产品，点击"->" 可查到该产品的信息. 或者

输入产品类型号 MTM(Machine 产品号):

例如：DS4200, 可输入 "1814-7VA"

(注意:如果是首次进行查询，需要对所在国家和语言进行设置，确定搜索范围和返回文档的语言，如下所示：

Home Country and Site Language://选择所在国家和语言 | China(English)
Narrow searches to://选择搜索范围 | China
Return documents in English and://选择返回文档的语言 | English
Return a maximum of://选择返回文档的最大值 | 200

点击 continue, 进行重新查询.)

Storage System

Disk System

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
XIV | 2810-A14 | 宽度: 600 mm 深度: 1,092 mm 高度: 1,991 mm 重量: 876 kg | 8.4 KW | 2008/08/12 | - | ->
 | 2812-A14 | 宽度: 600 mm 深度: 1,142 mm 高度: 1,991 mm 重量: 884 kg | 8.5 KVA | 2009/07/14 | - | ->
Storwize V7000 | 2076-112 | 宽度: 483 mm 深度: 630 mm 高度: 87.5 mm 重量: Drive-ready (without drive modules installed): 17.7kg Fully configured (12 drive modules installed): 27.2 kg | 380(watts) | 2010/10/07 | - | ->
 | 2076-212 |  | 175(watts)
 | 2076-124 | 宽度: 483 mm 深度: 630 mm 高度: 87.5 mm 重量: Drive-ready (without drive modules installed): 17.7kg Fully configured (12 drive modules installed): 25.2 kg | 530(watts)
 | 2076-224 |  | 205(watts)
DS4200 | 1814-7VA | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2006/08/08 | 2009/06/30 | ->
DS4700-70A | 1814-70A | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2006/05/09 | 2009/12/11 | ->
DS4700-72A | 1814-72A
DS4800-80A | 1815-80A | 宽度: 481.75 mm 深度: 634.92 mm 高度: 174.5 mm 重量: 36.38 kg | 540(watts) | 2006/05/23 | 2009/12/31 | ->
DS4800-82A | 1815-82A |  |  | 2005/05/10 | 2009/12/31 | ->
DS4800-84A | 1815-84A |  |  | 2005/05/10 | 2009/03/31
DS4800-88A | 1815-88A |  |  | 2005/08/30 | 2009/03/31 | ->
DS5000 | 1818-51A | 宽度: 481.75 mm 深度: 634.92 mm 高度: 174.5 mm 重量: 40.90 kg | 580(watts) | 2008/08/26 | - | ->
 | 1818-53A
DS5020 | 1814-20A | 宽度: 482.6 mm 深度: 571.5 mm 高度: 129.5 mm 重量: 39.92 kg | 600(watts) | 2009/08/25 | - | ->
DS6800 | 1750-522/EX2 | 宽度: 478 mm 深度: 610 mm 高度: 134 mm 重量: 56.4 kg | 550(watts) | 2006/08/22 | 2010/06/11 | ->
DS8100-1Year | 2421-931 | 宽度 847 mm 深度 1183 mm 高度 1930 mm Model 921/931 1189kg Model922/932 1248kg Model 9A2/9B2 1248kg Model 92E 9AE 1089kg Model 921/931 1189kg Model 922/932/9A2/9B2 1248kg Model 92E/9AE 1089kg | 5000 + N * 6000(watts) | 2006/10/31 | 2010/09/30 | ->
DS8300-1Year | 2421-932 |  | 7000 + N * 6000(watts)
DS8700-1Year | 2421-941 | 宽度 847 mm 深度 1183 mm 高度 1930 mm Model 941 1209kg Model 94E 1109kg | 6.7 KW（2-way） 7.3 KW（4-way） | 2009/10/20 | - | ->
DS8800-1Year | 2421-951 | 宽度 845 mm 深度 1226 mm 高度 1933 mm Model 951 1324kg Model 95E 1307kg | 6.7 KW（2-way） 7.5 KW（4-way） | 2010/10/07 | - | ->

Top

EXP

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
EXP5000 | 1818-D1A | 宽度: 482.60 mm 深度: 558.80 mm 高度: 132.10 mm 重量: 38.56 kg | 580(watts) | 2008/08/26 | - | ->
EXP5060 | 1818-G1A | 宽度: 482.60 mm 深度: 866.10 mm 高度: 176.0 mm 重量: 102.1 kg | 1428(watts) | 2009/10/20 | -
EXP520 | 1814-52A | 宽度: 482.6 mm 深度: 571.5 mm 高度:129.5 mm 重量: 38.56 kg | 600(watts) | 2009/08/25 | - | ->
EXP810 | 1812-81A | 宽度: 482.6 mm 深度: 558.8 mm 高度: 132.1 mm 重量: 38.56 kg | 448.5(watts) | 2006/02/28 | - | ->
EXP420 | 1812-8VA | 宽度: 482.6 mm 深度: 558.8 mm 高度: 129.5 mm 重量: 38.56 kg | 600(watts) | 2006/08/08 | 2009/12/11 | ->

Top

Tape System

Tape Library

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
TS2900 | 3572-S3H 3572-S4H | 宽度: 445 mm 深度: 847 mm 高度:43.6 mm 重量:18 kg | 2008/08/26 | - | ->
TS3100 | 3573-L2U | 宽度: 447.5 mm 深度: 810 mm 高度: 97.6 mm 重量: 15 kg | 2006/04/11 | - | ->
TS3200 | 3573-L4U | 宽度: 447.5 mm 深度: 810 mm 高度: 185.2 mm 重量: 21.3 kg | 2006/05/09 | - | ->
TS3310 | 3576-L5B + E9U | L5B: 宽度: 443.2 mm 深度: 801.4 mm 高度: 219.7 mm 重量: 38.6 kg E9U: 宽度: 443.2 mm 深度: 801.4 mm 高度: 401.1 mm 重量: 49.9 kg | 2005/10/11 | - | ->
TS3400 | 3577-L5U | 宽度: 437 mm 深度: 895 mm 高度: 221 mm 重量: 36.9 kg | 2007/02/13 | 2010/09/24 | ->
TS3500 | 3584-L23 / 3584-L53 | 宽度: 782 mm 深度: 1212 mm 高度: 1800 mm 重量: 481 kg | 2006/05/09 | - | ->
TS7500/TS7700 | 3952-F05 | 宽度: 644 mm 深度: 1098 mm 高度: 1804 mm 重量: Minimum:261 kg Maximum:659 kg | 2005/10/11 | - | ->
TS7530 | 3954-CV7 | 宽度: 483 mm 深度: 711 mm 高度: 178 mm 重量: Minimum: 29.5 kg Maximum: 43.2 kg | 2008/05/13 | 2009/08/28 | ->
TS7610 | 3959-SM1 | 宽度: 449 mm 深度: 707 mm 高度: 88 mm 重量: 30 kg | 2010/07/20 | - | ->
TS7650 | 3958-AP1 | 宽度: 644 mm 深度: 1098 mm 高度: 1804 mm 重量: 728.0 kg | 2009/02/10 | - | ->
TS7650G | 3958-DD1 | 宽度: 443.6 mm 深度: 720.2 mm 高度: 172.8 mm 重量: 43.2 kg | 2008/08/29 | 2009/03/28 | ->
TS7650G | 3958-DD3 | 宽度: 443.6 mm 深度: 720.2 mm 高度: 172.8 mm 重量: 43.2 kg | 2009/02/10 | 2010/12/03 | ->
TS7650G | 3958-DD4 | 宽度: 443.6 mm 深度: 712.1 mm 高度: 172.8 mm 重量: 43.2 kg | 2010/10/26 | - | ->

Top

Tape

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
TS1040(Ultrium 4) | 3588-F4A | 宽度: 186 mm 深度: 455 mm 高度: 89 mm 重量: 5.07 kg | 2007/04/24 | - | ->
TS1130 | 3592-E06 | 宽度: 195 mm 高度: 95 mm Length, front of bezel to rear of closed retention latch: 467 mm 重量: 5.7 Kg | 2008/07/15 | - | ->
TS1120 | 3592-E05 | 宽度: 194.5 mm 深度: 467 mm 高度: 95 mm 重量: 5.7 kg | 2005/10/11 | - | ->
TS2230 | 3580-H3L | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 6.45 kg | 2006/10/31 | 2010/11/26 | ->
TS2230(LTO3 SAS) | 3580-H3S | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 4.5 kg | 2007/07/10 | 2010/12/03 | ->
TS2230 | 3580-H3V | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/11/09 | - | ->
TS2240(LTO4 SAS) | 3580-H4S | 宽度: 250.00 mm 深度: 275.00 mm 高度: 60.00 mm 重量: 4.5 kg | 2007/10/23 | 2010/12/03 | ->
TS2240 | 3580-H4V | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/11/09 | - | ->
TS2250 | 3580-H5S | 宽度: 213.00 mm 深度: 332.00 mm 高度: 58.00 mm 重量: 4.3 kg | 2010/04/12 | - | ->
TS2340(LTO SCSI) | 3580-L43 | 宽度: 250.20 mm 深度: 292.10 mm 高度: 120.6 mm 重量: 6.45 kg | 2007/04/24 | - | ->
TS2340(LTO SAS) | 3980-S43 |  |  | 2010/11/26

Top

SVC

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
SVC EE | 2145-8A4 | SVC Storage Engine 宽度: 440 mm 深度: 559 mm 高度: 43 mm 重量: 10.1 kg | 2008/10/28 | 2010/11/05 | ->
SVC | 2145-8G4 | SVC Storage Engine 宽度: 440 mm 深度: 740mm 高度: 43 mm 重量: 13.0 kg | 2007/05/22 | 2009/12/12 | ->
SSPC | 2805-MC3 | 宽度: 440 mm 深度: 711 mm 高度: 43 mm Single pack 重量: 18.44 kg Pallet load 重量: 204.12 kg | 2008/10/28 | 2010/01/22 | ->
SVC | 2145-CF8 | 宽度: 440 mm 深度: 737 mm 高度: 43 mm 重量: 14.0 kg | 2009/10/20 | - | ->

Top

Nseries

产品线 | 产品号 | 物理参数 | 发布时间 | 停产时间 | 链接
N3300 | 2859-A10, A20 | 宽度:446 mm 深度:569 mm 高度:87.5 mm 重量:19.5 kg - Model A10 重量:21.5 kg - Model A20 重量:Add 0.8 kg for each SAS drive | 2007/08/28 | - | ->
N3400 | 2859-A11, A21 | 宽度:446 mm 深度:569 mm 高度:88.5 mm 重量:19.5 kg - Model A11 重量:21.5 kg - Model A21 重量:Add 0.8 kg for each SAS drive Add 0.65 kg for each SATA drive | 2010/02/09 | - | ->
N3600 | 2862-A10, A20 | 宽度: 446 mm 深度: 582 mm 高度: 175 mm 重量: 32.6 kg- Model A10 重量: 35.3 kg- Model A20 重量: Add 0.8 kg for each SAS drive | 2007/08/28 | A10:2009/11/30 A20:2011/04/22 | ->
N3700 | 2863-A10, A20 | 宽度: 447 mm 深度: 508 mm 高度: 133 mm 重量: 35.8 kg | 2005/07/28 | 2008/10/31 | ->
N5200 | 2864-A10, A20 | 宽度: 449 mm 深度: 518 mm 高度: 130 mm 重量: 34.0 kg - Model A10 重量: 68.0 kg - Model A20 | 2005/11/08 | 2009/02/27 | ->
N5300 | 2869-A10, A20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N5600 | 2868-A10, A20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2006/11/14 |  | ->
N5300 Gateway | 2869-G10, G20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N5600 Gateway | 2868-G10, G20 | 宽度: 449 mm 深度: 610 mm 高度: 130 mm 重量: 34 kg | 2007/05/22 |  | ->
N6040, N6070 | 2858-A10, A20, A11, A21 | 宽度: 447 mm 深度: 616.6 mm 高度: 258.7 mm 重量: Model A10: 44.4 kg Model A20: 52.2 kg Model A11: 44.9 kg Model A21: 53.2 kg | 2008/08/26 | A10：2011/04/22 A11：2009/11/30 A20：2011/04/22 A21：- | ->
N6060 | 2858-A12,A22 | 宽度: 447 mm 深度: 616.6 mm 高度: 258.7 mm 重量: Model A12: 44.8 kg Model A22: 53.1 kg | 2009/02/10 | A12：2009/11/30 | ->
N6210 | 2858-C10,C20 | 宽度: 447 mm 深度: 713 mm with cable management arms； 655 mm without cable 高度: 130 mm 重量: Model C10：29.7 kg Model C20：34.6 kg | 2011/01/25 | - | ->
N6240 | 2858-C21,E11,E21 | 宽度: 447 mm 深度: 713 mm with cable management arms 655 mm without cable management arms 高度: Model C21/E11：130 mm Model E21：260 mm 重量: Model C21：34.6 kg Model E11：32.9 kg Model E21：65.9 kg | 2011/01/28 | - | ->

Top

SAN

产品线 | 产品号 | 物理参数 | 功率 | 发布时间 | 停产时间 | 链接
B16 | 2005-B16 | 宽度: 428.5 cm 深度: 307.3 cm 高度: 42.9 cm 重量: 3.99 kg without media | 66(watts) | 2005/07/26 | 2008/11/29 | ->
B32 | 2005-B5K | 宽度: 42.87 cm 深度: 26.4 cm 高度: 4.35 cm 重量: 4.9 kg, dual power supplies, no SFPs | 60(watts) | 2007/04/24 |  | ->
B64 | 2005-B64 | 宽度: 428 mm 深度: 610 mm 高度: 86 mm 重量: 13.7 kg without media | 245(watts) | 2006/05/09 |  | ->
B24-4 8GB | 2498-B24 | 宽度: 428.8 mm 深度:306 mm 高度:42.9 mm 重量:4.35 kg | 57(watts) | 2008/05/13 | - | ->
B40-4 8GB | 2498-B40 | 宽度: 428.8 mm 深度:610 mm 高度:42.9 mm 重量:9.34 kg | 91(watts)
B80-4 8GB | 2498-B80 | 宽度: 428.8 mm 深度:610 mm 高度:86 mm 重量:15.6 kg | 91(watts)
SAN768B | 2499-384 | 宽度: 437.4 mm 深度: 732 mm 高度: 612.4 mm 重量: 103.50 kg |  | 2008/02/12 | - | ->
SAN04B-R | 2005-R04 | 宽度:635 mm 深度:429 mm 高度:424.4 mm 重量:12.43 kg |  | 2008/05/13 | 2010/11/27 | ->
SAN06B-R | 2498-R06 | 宽度:431.8 mm 深度:641.4 mm 高度:44.5 mm 重量:10.9 kg |  | 2009/11/10 | - | ->
SAN32B-E4 | 2498-E32 | 宽度: 429 mm 深度: 648 mm 高度: 87 mm 重量: 22.4 kg |  | 2010/11/09 | - | ->

Top


携手 IBM，开启虚拟化之旅

随着世界更加互联互通，事务量和信息量对 IT 基础架构的要求日益上涨。客户正在寻求可满足要求的灵活 IT 基础架构。在智慧的地球上，企业正在部署虚拟化基础架构以使业务更加敏捷。带有集成服务管理的虚拟化启用了智慧基础架构，它有助于您：

整合并共享资源，释放物理基础架构。

整合新资源和现有资源，以实现更敏捷的、以业务为中心的基础架构。

根据需要，随时随地交付低成本的服务，以满足业务目标。

与 IBM 合作，通过虚拟化实现更大价值

IBM 具有深厚的专业知识、经认可的方法以及全面的综合性解决方案组合，可很好的对虚拟化提供支持，因此是唯一一家能帮助您实现这些目标的企业。IBM 利用智慧的系统、软件和服务，以全面的视角实施转型，使虚拟化不仅可以应用于平台级别，还可以跨操作系统和中间件应用，从而更灵活地实现人员、流程和技术的重新组合。最终将得到一个更高效且有效的基础架构。IBM 的优势包括：

能够将整合和虚拟化的触角从机器资产延伸到存储产品、网络、台式机和应用程序，以灵活响应服务需求的变化。

虚拟化解决方案与系统管理程序不相关，让您可以灵活地将 IBM 系统管理程序与其他 x86 系统管理程序集成，而不是锁定某个供应商。

集成服务管理提高了虚拟化环境的可视性、可控性和自动化，有助于您更高效且有效地部署和管理工作负载。

咨询方法，该方法利用上千次客户合作经验来帮助您定义和执行虚拟化项目。

可将平台调整至对虚拟化环境提供更好地支持，从而加大了虚拟系统密度并提高了虚拟化要求苛刻的生产工作负载所需的性能。

平台管理功能，可利用跨多种虚拟化技术和硬件平台的虚拟化环境，简化对物理基础架构的管理并实现统一管理。

利用全面的产品服务组合，提供可适用于任何业务规模和任何业务需求的解决方案，从而帮助从各方面来优化您的企业服务。

种类丰富的部署模型，包括 IBM 托管的、专用的（处于防火墙后）或混用的云交付模型。

根据您的特定需求，IBM 可以充分利用虚拟化和集成服务管理来：

. 整合资源
. 管理工作负载
. 自动化流程
. 优化交付

Top


目录 全新企业级数据中心发展之路 - IT优化

全新企业级数据中心发展之路 - IT优化

全新企业级数据中心发展之路 - IT优化

全新企业级数据中心发展之路 - 服务器虚拟化

全新企业级数据中心发展之路 - 存储虚拟化

全新企业级数据中心发展之路 - 应用虚拟化

全新企业级数据中心发展之路 - 网络虚拟化

全新企业级数据中心发展之路 - 通过虚拟化实现整合

全新企业级数据中心发展之路 - 节能降耗，打造绿色数据中心


全新企业级数据中心发展之路 - IT优化

物理整合是进行物理上乃至地理上的整合，而逻辑上的整合就要通过虚拟化来完成了。走向虚拟化，就踏入了 IT 优化之路的拓展阶段。

究竟什么是虚拟化呢？事实上，虚拟化技术的核心思路就是，通过软件或固件管理程序（Hypervisor）构成虚拟化层并对其进行管理，把物理资源映射为虚拟资源（如图 3-1 所示）。这些虚拟资源在使用上和物理资源的特性相差很少或没有差别。如下图所示，可以被虚拟化的资源包括了服务器、存储、网络等资源（也包括了一些比较专用的设备）。

图 3 - 1 虚拟化的概念

虚拟化技术的根本目的就是通过有效管理虚拟资源和物理资源之间的映射关系来达到充分共享物理资源的目的，同时为应用系统提供较好的服务水准。

不难想象，有效利用虚拟化技术所实现的这种从独占到共享的转变，可以进一步实现整合、简化 IT 基础架构、提高 IT 资源的整体利用率，降低管理成本等等。根据具体的实现，还可以增强 IT 基础架构的可用性，有利于实现在业务不中断的条件下进行系统维护工作。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3.shtml

Top


全新企业级数据中心发展之路 - 服务器虚拟化

服务器虚拟化就是把服务器所拥有的物理资源通过虚拟化技术映射成虚拟资源。而这些虚拟资源从操作系统的使用和应用的使用上是相对独立的。这样，就可以在同一台物理计算机上运行多个独立的操作系统及相互独立的应用。服务器所拥有的资源（如CPU、内存、磁盘和网络资源等）可以被这些应用环境（或独立的操作系统）共享。配合其他诸如工作负载管理（Workload Management）等技术，可以让服务器在满足不同类型的工作负载的服务水平的同时，充分利用服务器的物理资源。

虚拟化技术早在上世纪 60 年代就开始随着 IBM 大型主机推向市场。随着技术的发展，目前业界已经有多种服务器虚拟化技术，例如 IBM 大型主机的逻辑分区技术和虚拟机技术；UNIX 服务器领域有 IBM PowerVM（动态逻辑分区，微分区）；HP 的 nPAR、vPar 技术；Sun 的 Dynamic System Domain 分区技术；PC 服务器上有 VMware、Xen 等技术。这些技术基本上覆盖了各个规模的用户群，给客户的服务器整合方案带来多种选择。

从技术上讲，各个厂商的服务器虚拟化技术主要可以划分为下列四种类型：

.硬件分区（Hardware Partition）或物理分区

通过硬件分区实现服务器虚拟化的技术架构如图 3-2 所示：

物理分区架构图
图 3 - 2 物理分区架构图

硬件分区技术是在支持多个物理单元板的服务器上实现的，分区资源以单元板为单位进行划分，一台物理服务器可以被划分成多个物理分区，代表产品有 HP 的 nPAR、vPAR，和 Sun 的 Dynamic System Domains 等。

.逻辑分区

与物理分区不同，逻辑分区的资源划分不依赖于其物理 位置，因此，每个分区中的 CPU 资源分配粒度为一颗物理 CPU 或以更小的粒度为单位。逻辑分区技术的架构如图 3-3所示：

逻辑分区架构图
图 3 - 3 逻辑分区架构图

不同厂家基于自身硬件设备的特点提供了不同类型的逻辑分区技术。例如 IBM LPAR技术、SUN 的 LDom 技术等。

.虚拟机

除了基于硬件实现的虚拟化技术，还出现了基于软件的虚拟机技术，该技术不再对硬件资源进行划分，而是在硬件上首先部署一套 Host 系统，再在其上运行 Guest 操作系统,其架构如图 3-4所示：

虚拟机架构图
图 3 - 4 虚拟机架构图

其代表产品有 VMware，微软的 Virtual PC/Server、HP IVM、Xen 等。

.操作系统层面的虚拟化（Operating system-level virtualization）

操作系统层面的虚拟化不同于前面三种虚拟化技术，它是通过在同一个操作系统内建立相对独立的分区来实现的，其结构图如图 3-5 所示：

操作系统分区架构图
图 3 - 5 操作系统分区架构图

IBM AIX 6.1 提供的 WPAR、Sun Solaris Container 就是这种类型的虚拟化技术，Virtuozzo/OpenVZ 是面向 Linux 的操作系统虚拟化技术。

上面所列的四种虚拟化技术都有各自的优缺点，可根据用户的具体需要进行选择：

.硬件分区之间的独立性更强，可靠性相对更高，但其灵活性较差。
.操作系统级的虚拟化技术有利于更大限度地使用系统资源，减少需要维护的操作系统个数。
.基于 Hypervisor 的逻辑分区不但可以极大地提高资源使用率，还提供了良好的性能和动态调配资源的能力，可以在同一台主机的不同分区中安装异构的操作系统。
.虚拟机技术虽然可以提高资源的利用率，但由于资源的分配是通过软件实现，各分区系统的性能受到的影响相对较大。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_1.shtml

Top


全新企业级数据中心发展之路 - 存储虚拟化

存储虚拟化即是把分散的、不同品牌或不同级别的存储产品统一到一个或几个大的存储池下，用户看见的不再是孤立的、分散的系统，而是一个统一的整体。用户管理的也是一个整体存储，而不是一个一个的具体的系统。如图 3-6 所示，通过在物理存储系统和服务器之间增加一个虚拟层，将使用者（例如服务器）使用的物理存储虚拟化成逻辑存储。使用者只和逻辑存储打交道，而存储硬件的增减、调换、分拆、合并对使用者完全透明。对于存储的管理者来说，存储虚拟化的引入，使得存储管理更加统一，管理效率提高。同时，资源的使用率也大幅提高。

存储虚拟化
图 3 - 6 存储虚拟化

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_2.shtml

Top


全新企业级数据中心发展之路 - 应用虚拟化

应用的虚拟化实质上就是应用基础设施的虚拟化，在应用基础设施层面提供应用组件的动态部署，提供完整、统一的系统映像以实现全面、深入的集中监控和管理；并基于服务水平协议（Service Level Agreement）动态调整和分配计算资源。

应用基础设施的虚拟化广义上分为下面两个阶段：

第一阶段：现在的应用架构允许逻辑上分为 Web 层、应用层和数据库层。在每个应用层可以通过部署多个实例来提高扩展能力、可用性和性能。这些实例通过前置的负载分发和应用提供的集群技术给用户提供一个逻辑整合的视图。下图就是这样的一个示例：

采用三层部署的应用架构示例
图 3 - 7 采用三层部署的应用架构示例

总的来说，我们可以通过下述三种方式实现这一阶段的应用架构虚拟化：

.通过在多个应用实例前使用负载均衡器来实现应用的虚拟化。
.通过使用调度程序来接受作业的提交，并把作业分发到最合适的服务器来处理。比如 Tivoli Dynamic Workload Broker (TDWB) 和 Grid 技术。
.使用更加成熟的集群技术来实现多个应用实例的单一系统映像。比如 IBM System z 主机的 Parallel Sysplex 和 WebSphere XD。
.第二阶段：为进一步提升业务的表现，我们需要把现有的模式扩展到下一代的应用虚拟化。应用需要从业务流程处理的角度，重新构架成基于模块化组件的模式。每一个模块化组件都有能力被部署到多个共享环境中的虚拟资源上。这些自我控制的应用元素可以在一个高度集成的环境中相互独立地运行，他们之间信息和数据的交互是统一一致的。这个模式将增强基本 SOA 架构中对应用的部署和管理，达到更好的满足增长的业务需求的目的。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_3.shtml

Top


全新企业级数据中心发展之路 - 网络虚拟化

在网络领域中，虚拟化并不是一项新兴的技术。虚拟网络允许不同需求的用户组访问同一个物理网络，但从逻辑上对它们进行一定程度的隔离，以确保安全。在上世纪 90 年代，2 层交换是园区局域网的标志性特征，虚拟局域网 (VLAN) 是在一个通用基础设施中将局域网划分为不同工作组的标准。除了 VLAN，基础设施虚拟服务还包括虚拟路由器和交换机等。在虚拟路由中，相同物理交换机中的路由进程为每个应用环境单独提供路由功能。在虚拟交换中，两个物理交换机被视为一个设备，从而简化了代码维护与配置管理工作，但更重要的是，通过支持跨越不同物理交换机的端口通道和状态来提供物理冗余。

现在，传统的客户端、服务器连接到网络上；基于 Web 的新型应用的客户端、服务器连接到网络上；多媒体应用也可以连接到网络上；所有的应用都连接到网络上。网络的需求和实现越来越复杂，在 IT 预算紧缩的情况下，网络物理整合的趋势不可避免。因此越来越需要利用虚拟化技术整合和简化网络资源。基于网络的虚拟化适用于多用户组环境，可将各组彼此隔离，并在多层应用环境中将每个层次或整个多层环境彼此隔离。网络虚拟化不但简化了数据和网络管理的复杂性，也进一步提升了数据的安全性。

网络虚拟化可以实现以下功能：

.访问控制：确保能识别合法用户和设备，对其分类，并允许其接入获得访问授权的网络。
.路径隔离：确保各用户或设备都能高效地分配到正确、安全的可用资源集，如常见的 VPN 技术。
.服务保障：确保合法的用户和设备能访问相应的服务。
凭借网络虚拟化解决方案，企业能在单一物理基础设施上部署多个封闭用户组，并在整个局域网中保持高标准的安全性、可扩展性、可管理性和可用性。凭借其虚拟化特性和对于集中服务的支持，帮助部署了此框架的企业更好、更高效地利用网络资产，即使对设备、系统、服务和应用的需求有所增长，也能实现成本节约。

通过实现网络虚拟化，可以满足下列几种需求：

.企业中存在不同级别的访问权限：
几乎每个企业都需要解决方案来为客户、厂商、合作伙伴以及园区局域网上的员工授予不同的访问级别。

.法规遵从性
部分企业受法律或规定的要求，必须对较大的机构进行分区。例如，在金融公司中，银行业务必须与证券交易业务分开。

.过大的企业需要简化网络
对于非常大型的园区网络，如机场、医院或大学来说，过去，为保证不同用户组或部门间的安全性，就必须构建和管理不同的物理网络，这种做法既昂贵又难以管理。

.网络整合
在合并和收购时，通常需要迅速集成所收购公司的网络。

.外包
随着外包和离岸外包的普及，子承包商必须证明各客户的信息间完全隔离。尤其当一家承包商服务于相互竞争的公司时，这尤为重要。

.提供网络服务的企业
零售连锁公司为其他公司支持售货亭或为加油站提供互联网接入；同样，服务于多家航空公司和零售商的机场能使用单一网络来提供隔离服务和共享服务。

通过网络虚拟化的实施，可以为企业创建一个强大的智能化信息网络的框架。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_4.shtml

Top


全新企业级数据中心发展之路 - 通过虚拟化实现整合

虚拟化模式是全新企业级数据中心在简化和共享阶段均需要使用的方法。通过采用虚拟化技术，可以实现服务器处理能力的共享、存储系统的共享和网络资源的共享。物理整合模式和虚拟化模式是相辅相成的。我们用物理整合模式的思路来规划，用虚拟化技术得到更高的效益。在对资源的全面整合过程中，信息整合和应用整合是更高层面的两个重要的整合元素，它可以使服务器和存储设备的整合变得更加有效，实现更加完美的基础架构整合。我们在本节将分别介绍这些内容。

服务器虚拟化技术及整合思路

虚拟化技术是通过 上世纪 60 年代具有划时代意义的 IBM 商用大型主机 System/360 正式推向市场的。到目前为止，业界已经有多种服务器虚拟化技术，例如 IBM 主机的逻辑分区技术和虚拟机技术；UNIX 服务器的动态逻辑分区和微分区；HP 的 nPAR、vPar 技术；Sun 的 Dynamic System Domain 分区技术；PC 服务器的 VMware, Virtual Server、Xen 等技术。基本上覆盖了各个规模的用户群，给客户的服务器整合方案带来多种选择。

（一）IBM 大型主机系统的虚拟化

1. 逻辑层虚拟化技术

.1) 逻辑分区

Processor Resource/Systems Manager (PR/SM) 是 System z 的 Hypervisor 技术，它允许在同一个处理器上运行多个不同的逻辑分区（LPAR）。目前，IBM System z 主机服务器支持 60 个这样的逻辑分区。逻辑分区分为独占式和共享式两类。

在独占式分区中，分配给这些分区的逻辑资源不会被其他 LPAR 共享；而共享式分区中所分配的资源是可以共享的。共享式分区使得一个 LPAR 中空闲的资源可以被其他忙碌的 LPAR 所使用。与独占式分区相比，共享式分区提高处理器的整体使用率。

.2) 内部网络

HiperSockets 是一台物理主机中逻辑分区之间通信的技术，数据交换的速率达到内存访问级的速度。利用 HiperSockets 可以节省网络设备，如路由器、交换机、Hub、网线等，最终达到节省成本的目的。此外，HiperSockets 还保证内部通信的安全性，由于数据不会经过服务器外部的网络，不会有被窃取或篡改的危险。

.3) I/O 通道

System z 服务器多逻辑通道子系统示意图
图 3 - 8 System z 服务器多逻辑通道子系统示意图

图 3-8 是一个典型的多逻辑通道子系统共享示意图。System z 主机服务器经过通道子系统和 I/O 设备相连接；物理通道子系统又可划分为多个不同的逻辑通道子系统（Logic Channel Subsystem Image）供不同的逻辑分区使用；整个设计方案使得不同的 LPAR 可以共享地使用物理 I/O 设备。

2. 操作系统层虚拟化技术

.1) Parallel Sysplex (并行耦合系统)

Parallel Sysplex 是由 IBM 提出的一种主机共享一切的集群概念。用来确保运行在 System z 平台上应用的高可用性和处理能力的横向扩展性。 在 Parallel Sysplex 这个紧密耦合的集群中，集群中的 z/OS 系统使用共享的软硬件资源，协同处理负载，统一协调管理，使得这个集群就像一个服务器一样。Parallel Sysplex 具有动态负载均衡、数据共享、高可用性等特征。

一个典型的 Parallel Sysplex 示意图如下所示：

System z 服务器 Parallel Sysplex 典型示意图
图 3 - 9 System z 服务器 Parallel Sysplex 典型示意图

从上图可以看到，Parallel Sysplex 中包含多个 z/OS 系统，他们运行在 System z 上的多个 LPAR 上。这些 LPAR 共享磁盘和数据。Coupling Facility（CF）提供这个集群中各个 z/OS 之间共享的内存。系统和系统之间通过专用的链路通讯以协调各自的负载。系统时钟(System Timer) 提供了不同 LPAR 主机之间统一的时间源。

.2) 虚拟机操作系统

z/VM 是 Mainframe 在软件层次虚拟化的代表。z/VM 的虚拟化技术有能力让客户在一台 Mainframe 上运行成百上千个 Linux 服务器集群，同时也可以和其他的操作系统交互，比如 z/OS。z/VM 还支持其他的客座操作系统 (Guest System)，比如 z/OS、z/VSE、z/TPF 甚至 z/VM 本身。z/VM 实现主机各类硬件资源的虚拟化，包括处理器、内存、 I/O 设备和网络设备（如局域网、交换机）等的虚拟化。

3. System z 虚拟化典型示例

System z 服务器整合与虚拟化典型构架
图 3 - 10 System z 服务器整合与虚拟化典型构架

上图所示为典型的 System z 服务器整合与虚拟化架构。如图所示，System z 主机服务器通过 PR/SM 将物理分区划分为多个逻辑分区（LPAR），每个逻辑分区都分配了自己的 CPU、存储、 I/O 通道等；LPAR1 上运行 z/VM 操作系统，其上运行若干虚拟 Linux 服务器，通过 z/VM 的控制程序实现这些 Linux 服务器之间的资源调度；LPAR2 和 LPAR3 上分别运行 z/OS 操作系统，其中 LPAR2 上运行 DB2 与 WebSphere，LPAR3 上运行联机交易与 B 批处理作业，它们都通过 WLM（Workload Manager）对工作负载进行管理；LPAR4 运行 z/VM 操作系统，其上运行一个 Linux 虚拟服务器和一个 z/OS 操作系统；同时，LPAR2、LPAR3 和 LPAR4 使用 IRD 来配合 WLM 对 z/OS 适用的共享资源进行智能调度。

（二）开放平台服务器的虚拟化技术

开放平台服务器的品牌较多，虚拟化技术的实现也不尽相同。对于 UNIX 服务器，常用的虚拟化技术主要有三种：硬件物理分区、逻辑分区和基于操作系统之上的分区；对于 X86 平台系统，常用的技术是虚拟机。下面就针对这四种技术做进一步讨论。

1. 硬件分区技术

在硬件分区技术中，分区沿硬件的边界划分。每个分区可以运行同一个操作系统的不同版本或不同的操作系统。基于硬件物理分区技术划分的分区需要足够的硬件资源来满足运行在他上面的操作系统和应用的需求。
硬件物理分区具有以下特性：

.完全的硬件隔离：在单个系统内部提供了在物理上完全隔离的硬件环境。通过在每个单元板中使用自定义的芯片组来实现，确保一个分区中的硬件故障不会影响系统中的其它分区。
.完全的软件隔离：分区就像是单独的物理系统。它们可以运行具有不同版本、不同补丁级别、不同种类的单独操作系统，一个分区的软件错误不会影响到另一个分区。
.单元板为最小移动粒度：配置分区的最小单位是单元板（包括 CPU,内存等）。将单元板（CPU,内存）从一个分区移到另一个分区的时候，需要重新启动相关分区。
.支持多个操作系统：每个分区都有其自己的硬件和软件环境。可以在每个分区中安装不同的操作系统，如 UNIX、Linux、Windows 等，分别支持不同的应用。

2. 逻辑分区技术

逻辑分区是在逻辑上划分单个系统所需的 CPU、内存和 I/O 资源，实现在一台物理服务器上创建多个逻辑服务器（逻辑分区）。与硬件分区必须以物理单元板为 CPU 分配单位所不同，逻辑分区对 CPU 的划分粒度要精细得多，可以以少于 1 颗物理 CPU 为粒度（最少可以到 1/10 颗物理 CPU）。每个逻辑分区相互独立，拥有自己的逻辑 CPU、内存和 I/O 等设备，可以同时运行完全不同的操作系统，如同时运行 UNIX,、Linux,、i5/OS 等。此类分区技术是在系统的微码（Hypervisor）级别实现的。下面是逻辑分区的架构示意图：

逻辑分区技术
图 3 - 11 逻辑分区技术

逻辑分区具有如下几个主要的特性：

1) 同一台物理主机上支持多个操作系统

逻辑分区支持在同一台物理主机上同时支持多种操作系统，或是相同操作系统的不同版本。分区与分区之间相互独立，互不影响。因此，个别分区的操作系统环境出现问题不会导致整个物理主机不可用。

2) 可灵活调配 CPU 的微分区

微分区允许多个分区共享一组物理处理器（Shared Processor Pool）。一个分区可以以 1/10 的物理处理器资源来分配。Hypervisor 基于工作流量调节分配给每个微分区的 CPU 处理能力。通过参数调优，系统管理员可以控制每个微分区可以使用的CPU处理能力的上限值。

3) 动态性

动态特性是指可以动态地添加、删除分区中的系统资源，或在分区之间移动系统资源，例如 I/O 适配器、CPU、内存等资源，而不需要在修改前后重新启动系统或分区。技术人员可以在需要时将资源动态分配到需要的地方，动态地调整整个系统的硬件资源分配，平衡所有分区的硬件，使整个系统的硬件资源得到合理的分配，充分发挥整体系统性能及提高资源使用率。

4) 虚拟 I/O

虚拟 I/O 技术支持存储资源虚拟化和网络资源虚拟化。虚拟 I/O 服务器是一个特别的分区，用于提供 I/O 资源的共享，即将虚拟存储和虚拟网络资源提供给虚拟 I/O 客户机分区使用。

逻辑分区技术
图 3 - 12 逻辑分区技术

.a) 存储的虚拟：

虚拟 I/O 服务器分区可以将它物理连接的存储设备虚拟化，供虚拟 I/O 客户端分区使用。在虚拟 I/O 客户端逻辑分区中，用户可以像访问本地物理存储设备一样的方式访问这些虚拟设备。通过建立两个虚拟 I/O 服务器可以提高系统可用性，即将 I/O 客户端逻辑分区同时连接两个虚拟 I/O 服务器，通过多路径 I/O 的功能来提高 I/O 的可靠性。

.b) 网络的虚拟：

各个虚拟 I/O 客户端分区之间可以建立虚拟以太网（VLAN）。定义在同一个 VLAN 上的逻辑分区可以进行数据通讯，网络速度可以超过 1Gbit/s。使用虚拟以太网，用户可以很方便地实现同一台主机上不同逻辑分区间的通信，在节省大量物理以太网适配器、扩展空间和物理线路的同时提高分区之间地通信带宽，并且通讯是通过系统总线实现的，有效的防止了各种网络工具的侦听，提高网络安全性。

在虚拟 I/O 服务器分区上还可以通过共享以太网卡的技术实现客户端逻辑分区与外部网络的通讯，此时虚拟 I/O 服务器起到一个桥接的作用。

虚拟 I/O 服务器可以将多块物理网卡映射到一个虚拟共享网卡上，实现负载均衡及网卡的互为备份。通过在两个虚拟 I/O 服务器中分别建立虚拟共享网卡，客户机逻辑分区可以通过这两个虚拟共享卡跟外部网络进行通讯，提高通讯的可靠性。

5) 逻辑分区在不同物理主机之间的动态迁移

逻辑分区的动态迁移
图 3 - 13 逻辑分区的动态迁移

这一特性允许一个活动的逻辑分区动态地从一台物理主机迁移到另一台物理主机上，在迁移的过程中，不需要中止分区中正在运行的应用，应用只经历瞬时停顿（几秒钟）。分区迁移将源系统（指定的 LPAR）上的所有运行环境迁移到目标系统，包括内存数据、处理器的运行状态、连接的所有虚拟设备、以及正在使用的客户连接等。

逻辑分区的动态迁移功能可以给客户带来以下好处：
.减少计划性停机。如果需要对一台服务器进行计划内的维护，像增加硬件、安装软件、安装补丁等操作，可以通过此功能将活动的逻辑分区动态地迁移到其它服务器上，而不需要停止业务。
.动态调整服务器工作负载。根据每个业务的工作负荷，通过此方法可以动态地平衡各个服务器的运行能力，将负载高的服务器上的应用分区动态地迁移到负载小的服务器。
.给服务器整合带来更大的方便，动态的将分散的各个应用系统迁移到高性能的服务器上，在不影响服务的前提下，完成服务器的整合。

3. 基于操作系统的分区技术

使用这种虚拟化技术可以将同一个操作系统中的资源进一步划分为不同“分区”，这些分区的环境也是相对独立的，分别有自己的运行环境，可以运行不同的应用，但它们共用一套操作系统内核，这一点与硬件分区和逻辑分区有质的区别。

基于操作系统的分区
图 3 - 14 基于操作系统的分区

一般来讲，这种分区是通过操作系统的命令创建的，一个操作系统中的所有工作负载分区共享操作系统的系统资源。分区建立后，就会在操作系统之上形成一套独立的运行环境。显然，操作系统出现问题会影响到运行于其上的各个分区。每个分区都是跟整体操作系统具有相同类型、相同版本的操作环境。这种分区技术主要是满足需要在同一个操作系统中运行多个应用，良好地在应用之间平衡系统资源，提高整体资源利用率的目的。由此可见，这种分区技术进一步为服务器的虚拟化提供了一种方便。IBM AIX 6.1 提供的 Workload Partition 和 Sun Solaris 的 Containers 提供的就是这种虚拟化分区技术。

4. 基于 X86 平台的虚拟机技术

虚拟机需要一个操作系统作为最基本的平台，其它系统在它上面运行。作为平台的这个操作系统叫 HOST OS，称之为“主系统”；在主系统上运行的其它系统都叫 GUEST OS，称之为“子系统”或“客户系统”。通过虚拟机，可以在一台物理的机器上模拟出多台机器，目前市场上虚拟机技术的典型代表产品是 VMware 和 Xen。下面为 VMware 的实现机制示意图:

基于 VMware 的虚拟化
图 3 – 15 基于 VMware 的虚拟化

针对 x86 架构的服务器可以通过 VMware 或 Xen 的虚拟机技术实现逻辑分区的功能，在单一的 x86 架构的硬件平台上并发地运行多个操作系统，如 Windows（NT，2K，2003）、Linux（RedHat, SuSE）、Novell Netware、Sun Solaris 和 Free BSD x86 等。通过这一功能可以将不同的应用部署在同一台物理服务器上，相互之间具有安全的隔离性，不受病毒或者某个应用引起的系统崩溃的影响。从而实现众多中小应用的整合，充分均衡硬件资源，实现资源的最佳优化，彻底改变服务器利用率不高的问题。

存储整合思路

（一）存储整合与虚拟化的原则

存储整合与虚拟化是整个企业的信息技术整合与虚拟化的一部分，在设计和规划时，我们要遵从以下的原则：
.标准化
.数据安全与一致性需要得到保证
.存储管理统一化和规范化
.架构具有良好的可扩展性
.具备一定的灵活性

1. 标准化

整合与虚拟化的目的之一是要实现有效的管理，而有效管理是建立在架构的标准化基础上。整合与虚拟化本身需要建立相关的标准，针对存储整合与虚拟化，要建立数据存储标准。例如首先要确定什么应用的数据需要整合，什么应用的数据可以整合在一起；然后，根据应用和数据的关键性，并结合性能要求，确定采用什么方式和架构来存储数据。存储架构也需要标准化，为提高存储投资的有效性，企业的存储往往采用层次化架构，即根据数据不同的重要性和性能要求，采用性价比相当的存储来保存数据。这样，就要制定针对不同层次的存储架构标准，以确定采用什么设备实现。

企业随着不断的发展，其信息技术架构可能会变得越来越复杂，整合与虚拟化需要一个过程，但在整合的过程中，信息技术架构还需要发展。为保证整合与虚拟化目标的最终实现，也需要对发展中的信息技术架构制定相应的标准，使得新加入的存储系统满足整合与虚拟化的标准，并能融入到整合与虚拟化的架构中。这样，既保证了整合与虚拟化过程中的发展，又避免因为发展而导致整合与虚拟化的重复工作。

2. 数据安全与一致性

为了更有效地利用存储资源，在整合与虚拟化中的存储是建立在共享架构基础上的，这样，必然会带来数据安全与一致性问题。不能因为整合与虚拟化的共享，而导致破坏数据的安全和一致性。

为了保证数据原有的安全特性，在整合与虚拟化中，需要清楚地了解各个应用数据的存储特点，数据是独享还是共享，共享是哪几个应用共享，共享的级别是什么，数据存取是文件级还是块设备级。存储网络是如何划分的，是否会出现越界存储。

这些安全的实现可以依赖于存储网络上的区域划分（Zoning），共享存储设备上的 LUN Masking，以及虚拟化设备上逻辑卷与物理卷的对应等技术。

3. 存储管理统一化和规范化

存储整合与虚拟化是对多个应用系统或整体信息技术架构，这样就要求管理的统一和规范。存储管理的统一是建立在标准之上，存储管理包括对存储设备的管理，对存储网络的管理，对服务器连接的管理。

对整合与虚拟化存储环境的管理，要建立相应的规范并严格遵守。这样的存储环境中，很多设备是共享的，所以要严格管理，以避免越界存储或数据安全和一致性问题。应该建立完善的存储申请、审批和具体分配流程。可以设置分级管理制度，针对整合与虚拟化空间要求，结合存储架构，做层次化管理。对于任何针对存储的变更要求，也要建立规范的变更管理要求，并经严格评估。

整合的存储架构以及虚拟化存储极大地帮助了管理员进行存储管理，前提是所有的存储都在整合的架构下，并接受虚拟化管理。这样，就要求存储架构的扩展，必须满足整合和虚拟化的规范化要求。

存储管理的规范要落实，针对存储的配置要做详细的记录，并随变更及时更新。

4. 架构具有良好的可扩展性

为保证企业的不断发展，进而对信息技术架构乃至存储架构发展的要求，整合与虚拟化存储，在技术实现上，要充分考虑架构的可扩展性。

架构的扩展性体现在存储容量扩展和存储性能扩展等方面。当业务发展要求更大的存储空间时，架构能易于扩展存储容量。在整合的环境中，可以根据容量与性能的平衡，考虑纵向或横向扩展。纵向扩展，整合的程度更高；横向扩展，整体性能提高更快。在虚拟化的环境中，不但要考虑到存储的容量扩展，而且要考虑到虚拟化本身的扩展，也要从容量和性能的平衡点考虑。

5. 具备一定的灵活性

对于大型企业，会有很多应用，存储上需要遵从整合与虚拟化的原则。但由于各个应用的差异性，就要求在具体实现上有一定的灵活性，也保证对不同应用需求的支持。而且企业的发展，也会出现企业之间的并购，这样就会整合并购企业的信息技术架构，包括存储架构。为了能顺利整合多样化的架构，并保护现有的投资，就要求整合与虚拟化具有一定的灵活性，以兼容一定的多样化架构

（二）存储整合与虚拟化的设计要点

整合与虚拟化的实现，要从全局整体考虑，在设计时需要关注如下的重点：

.数据安全性

在共享的环境中，如何保证数据的安全性和一致性，是设计的要点之一。具体包括共享数据的分配、存储网络的划分、以及存储设备 LUN Masking 的设定等。

首先要确定在共享的存储设备或存储池中，保存了什么样的数据，什么应用的数据，据此来分配存储设备或存储池的空间，使得多个应用的数据存储，能够在共享的基础上，保证性能。

然后就要确定存储网络的划分，在 SAN 的环境中，服务器要与相应的存储划分在大的虚拟存储网络中，最终确定服务器上HBA卡与存储的主机连接通道是如何连接的。在存储网络层面，划分了服务器与存储的关联关系，决定了服务器能将数据存储到那些存储空间，避免了服务器的越界使用存储以及服务器之间的相互干扰。

对于多台服务器共享同一存储设备或存储池的情况，需要根据服务器具体划分存储的空间，那么就需要在存储设备或存储池上做相应的 LUN Masking，以保证共享设备上的存储空间被那些服务器存取。针对集群环境要求，要考虑逻辑卷的共享，同时，需要服务器上有相应的机制保证数据的安全性和一致性。

.异构平台的支持

由于种种原因，企业中信息技术架构不可能完全一样，服务器平台可能多种多样，例如 UNIX、Windows、Linux 等，UNIX 也可能是 IBM AIX、HP－UX、Sun Solaris 等。而存储平台也是多种多样。例如 IBM 、EMC、HDS、NetApp 等。即使是同一厂商，也可能是不同产品系列。

在设计存储整合与虚拟化时，要考虑到对异构平台的支持，包括服务器异构平台和存储异构平台，这对于企业信息技术架构的发展至关重要。

.高可用性

整合意味着集中，而集中后，风险也相对集中。为了规避整合后的风险，高可用性也是设计的要点之一。

高可用性设计要避免架构上的单点故障点，包括存储设备和虚拟化设备。设备本身需要冗余的部件，同时要考虑冗余的设备，包括整合的存储设备和虚拟化设备。同时，要设计数据如何在冗余的设备间拷贝同步，这可以利用存储设备本身的数据镜像功能，或利用虚拟化设备的数据镜像功能。

.集中管理、标准化管理

对于整合和虚拟化的环境，存储的集中管理与标准化管理是保证数据安全与一致性的关键。在设计选择架构和设备时，要确定其有标准化的管理接口，能够接受集中管理的请求。

（三）存储整合与虚拟化的其它考虑点

.与服务器整合的统一考虑

存储整合与虚拟化是整个信息技术整合与虚拟化的一部分，与其它部分的整合与虚拟化有相互关联，尤其与服务器整合有着密切联系。在设计存储整合与虚拟化时，要考虑到存储架构的变化对服务器的影响。例如，存储整合后，对服务器的性能是否有影响；存储虚拟化，服务器连接的网络需要调整，网络区域需要从新定义等。

因为存储整合会涉及到与服务器的连接，服务器也需要做相应的调整。可以考虑，在进行存储整合的同时，进行服务器整合，同理于服务器整合。这样做的好处是一次大的调整会完成两部分整合，在完善计划的情况下，对于应用系统的停机影响会缩短。

.数据迁移的考虑

存储整合与虚拟化的过程中，常常会涉及到数据迁移。整合会涉及到将数据从原有的、独立的存储空间迁移到新的、统一的存储空间，虚拟化会涉及到数据从原有的物理存储空间迁移到新的逻辑存储空间。如何实现数据迁移也是整合与虚拟化的考虑点。

数据迁移可以利用相关工具（专有设备或软件产品）或虚拟化设备，做到透明的迁移，即在应用不停机的情况下，完成数据迁移，减少停机对业务的影响。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_5.shtml

Top


全新企业级数据中心发展之路 - 节能降耗，打造绿色数据中心

能源是地球上有限的资源。人类生产力的不断发展，使人类的生活水平不断提高，但同时也在加速耗尽地球的能源储备。能源的急剧消耗也带来污染等环境问题，例如伴随产生的二氧化碳形成地球的温室效应，直接威胁人类的生存。在需要寻找新的环保能源的同时，也要提高现有能源的使用效率。

数据中心作为一个用电单位，也需要提高能源使用效率。而事实上，由于硬件的计算能力不断提升，计算密度不断增大，数据中心在用电和冷却方面的能耗已经引起了人们的高度重视。

两三年前，数据中心的一个机柜的用电功率通常在 2 千瓦，而产生每平方英尺 40 瓦的散热；而在当今的高密度运算环境下，一个机柜的用电功率在 10 千瓦、15 千瓦、甚至是 25 千瓦，散热在每平方英尺 350 瓦至 500 瓦。计算设备对用电和冷却要求的提高很容易超出数据中心原来的设计能力。计算设备消耗大量的电能，维持数据中心的冷却也要使用大量的电能。数据中心能源消耗不断增大。

近年来能源成本不断升高，电费在数据中心的整体拥有成本中所占的比例不断增加，提高数据中心能源效率所带来的成本节省可以是非常明显的。

数据中心已经从单纯追求运算能力，变成追求运算能力和能源效率的绿色数据中心了。如下图所示，一个数据中心的整体用电可以分为三大部份： IT 设备用电、冷却用电和其它用电，而 IT 设备用电则还要通过 UPS（不间断电源）、PDU（电源分送单元）、开关和电缆等设施。

数据中心的用电分布
图 3 - 29 数据中心的用电分布

实现绿色数据中心的目标是提高能源利用率，其途径有以下三种：

.尽量减少数据中心的整体用电量。
.尽量增大数据中心整体用电中用于 IT 系统的比例。
.尽量减少用于非计算设备（电源转换、冷却等）的用电消耗。

参考链接：http://www-900.ibm.com/cn/support/guide/itoebook3_6.shtml

Top


虚拟化概述：模式的观点

什么是虚拟化？

虚拟化（Virtualization）对于不同的人来说可能意味着不同的东西，这要取决与他们所从事的工作领域的环境。通用的解释是它包含许多使服务器得到加强的虚拟机。有经验的程序员可能还记得，曾有一段时间他们担心是否有可用内存来存放自己的程序指令和数据。现在最基本的操作系统提供了虚拟内存的功能，这样程序员就不用再考虑这个问题了。IBM对大型机使用的 VM 可以允许多个用户和应用程序共享同一台机器，相互之间不会产生任何干扰。我们发现在很多计算平台上都实现了这种概念，或者通过软件来提供这种概念。
然而，虚拟化技术的内涵远远不止于虚拟内存和虚拟服务器。目前，我们已经有了网络虚拟化、微处理器虚拟化、文件虚拟化和存储虚拟化等技术。如果我们在一个更广泛的环境中或从更高级的抽象（如任务负载虚拟化和信息虚拟化）来思考虚拟化技术，虚拟化技术就变成了一个非常强大的概念，可以为最终用户、应用程序和企业提供很多优点。

虚拟化技术有很多定义，下面就给出了一些这样的定义。然而，对于本文的讨论来说，IBM 给出的简洁定义以及资源的逻辑表示形式的概念都可以用来作为不同的虚拟模式的示例。

“虚拟化是以某种用户和应用程序都可以很容易从中获益的方式来表示计算机资源的过程，而不是根据这些资源的实现、地理位置或物理包装的专有方式来表示它们。换句话说，它为数据、计算能力、存储资源以及其他资源提供了一个逻辑视图，而不是物理视图。” —— Jonathan Eunice, Illuminata Inc.

“虚拟化是表示计算机资源的逻辑组（或子集）的过程，这样就可以用从原始配置中获益的方式访问它们。这种资源的新虚拟视图并不受实现、地理位置或底层资源的物理配置的限制。” —— Wikipedia

“虚拟化：对一组类似资源提供一个通用的抽象接口集，从而隐藏属性和操作之间的差异，并允许通过一种通用的方式来查看并维护资源。” —— Open Grid Services Architecture Glossary of Terms

“虚拟化是资源的逻辑表示，它不受物理限制的约束。” —— IBM 公司

为什么要进行虚拟化？

虚拟化的主要目的是对 IT 基础设施进行简化。它可以简化对资源以及对资源管理的访问。

消费者可以是一名最终用户、应用程序、访问资源或与资源进行交互的服务。资源是一个提供一定功能的实现，它可以基于标准的接口接受输入和提供输出。资源可以是硬件，例如服务器、磁盘、网络、仪器；也可以是软件，例如 Web 服务。

消费者通过受虚拟资源支持的标准接口对资源进行访问。使用标准接口，可以在 IT 基础设施发生变化时将对消费者的破坏降到最低。例如，最终用户可以重用这些技巧，因为他们与虚拟资源进行交互的方式并没有发生变化，即使底层物理资源或实现已经发生了变化，他们也不会受到影响。另外，应用程序也不需要进行升级或应用补丁，因为标准接口并没有发生变化。

IT 基础设施的总体管理也可以得到简化，因为虚拟化降低了消费者与资源之间的耦合程度。因此，消费者并不依赖于资源的特定实现。利用这种松耦合关系，管理员可以在保证管理工作对消费者产生最少影响的基础上实现对 IT 基础设施的管理。管理操作可以手工完成，也可以半自动地完成，或者通过服务级协定（SLA）驱动来自动完成。

在这个基础上，网格计算可以广泛地利用虚拟化技术。网格计算可以对 IT 基础设施进行虚拟化。它处理 IT 基础设施的共享和管理，动态提供符合用户和应用程序需求的资源，同时还将提供对基础设施的简化访问。

虚拟化是如何工作的？

虚拟化可以通过很多方法来证实。它不是一个单独的实体，而是一组模式和技术的集合，这些技术提供了支持资源的逻辑表示所需的功能，以及通过标准接口将其呈现给这些资源的消费者所需的功能。这些模式本身都是前面介绍过的各种不同虚拟形式的重复出现。

图 1. 虚拟化的概念

下面是在实现虚拟化时常常使用的一些模式和技术：

1. 单一资源的多个逻辑表示 这种模式是虚拟化最广泛使用的模式之一。它只包含一个物理资源，但是它向消费者呈现的逻辑表示却仿佛它包含多个资源一样。消费者与这个虚拟资源进行交互时就仿佛自己是惟一的消费者一样，而不会考虑他正在与其他消费者一起共享资源。虚拟机就是这种模式的一个例子。硬件物理分区和逻辑分区（如 IBM System p、System z 和 System i 服务器）或软件产品（如 VMware、Microsoft Virtual Server 和 Xen）都实现了服务器的虚拟化。数据库视图的使用将数据与消费者隔离开来，这样可以基于消费者的角色和身份验证对资源进行访问，即使在所有消费者同时访问相同的数据库时，也不会出现任何问题。另外，网格使用虚拟化技术来管理网络上的数据，并在逻辑上将其作为一个系统呈现给消费者。下面的两个图示说明了服务器和信息的虚拟化。

图 2. 单一资源的多个逻辑表示

2.多个资源的单一逻辑表示 这种模式包含了多个组合资源，以便将这些资源表示为提供单一接口的单个逻辑表示形式。在利用多个功能不太强大的资源来创建功能强大且丰富的虚拟资源时，这是一种非常有用的模式。存储虚拟化就是这种模式的一个例子。IBM 的 SAN Volume Controller 可以将几个存储卷组合在一起，将它们呈现为一个大型的单一存储设备。消费者并不知道自己的数据被分散到了多个磁盘上。在服务器方面，集群技术可以提供这样的幻想：消费者只与一个系统（头节点）进行交互，而集群事实上可以包含很多的处理器或节点。实际上，这就是从 IT 技术设施的角度看到的网格可以实现的功能。多种资源集都是通过一个简化的用户界面呈现出来，例如用户使用的门户，或应用程序使用的标准接口。从计算角度来看，网格在接受任务请求，对任务负载进行调度和管理，并在提供资源和返回结果的同时提供任务负载虚拟化的能力。

图 3. 多个资源的单一逻辑表示

图 4. 网格对基础设施进行虚拟化

3.在多个资源之间提供单一逻辑表示 这种模式包括一个以多个可用资源之一的形式表示的虚拟资源。虚拟资源会根据指定的条件来选择一个物理资源实现，例如资源的利用、响应时间或临近程度。尽管这种模式与上一种模式非常类似，但是它们之间有一些细微的差别。首先，每个物理资源都是一个完整的副本，它们不会在逻辑表示层上聚集在一起。其次，每个物理资源都可以提供逻辑表示所需要的所有功能，而不是像前一种模式那样只能提供部分功能（例如，前一种模式是文件的一部分，这种模式是文件的一个完全副本）。这种模式的一个常见例子是使用应用程序容器来均衡任务负载。在将请求或事务提交给应用程序或服务时，消费者并不关心到底是几个容器中执行的哪一个应用程序的副本为请求或事务提供服务。消费者只是希望请求或事务得到处理。一个具体的例子是 IBM 的 WebSphere Application Server Extended Deployment。另外一个例子是文件虚拟化，其中为了满足冗余或性能的需要，可能为数据维护提供多个副本。当消费者访问文件时，文件系统（如通用并行文件系统 (GPFS)）就会定位这些文件众多副本中的一个，但是消费者并不知道正在使用的文件副本的具体位置。

图 5. 在多个资源之间提供单一逻辑表示

4.单个资源的单一逻辑表示 这是用来表示单个资源的一种简单模式，就仿佛它是别的什么资源一样。启用 Web 的企业后台应用程序就是一个常见的例子。在这种情况下，我们不是修改后台的应用程序，而是创建一个前端来表示 Web 界面，它会映射到应用程序接口中。这种模式允许通过对后台应用程序进行最少的修改（或根本不加任何修改）来重用一些基本的功能。也可以根据无法修改的组件，使用相同的模式构建服务。

图 6. 单个资源的单一逻辑表示

5.复合或分层虚拟化 这种模式是刚才介绍的一种或多种模式的组合，它使用物理资源来提供丰富的功能集。信息虚拟化是这种模式一个很好的例子。它提供了底层所需要的功能，这些功能用于管理对资源、包含有关如何处理和使用信息的元数据以及对信息进行处理的操作的全局命名和引用。IBM WebSphere Information Server 就是这样一个例子，它提供了一些利用到异构资源和统一元数据的广泛连接来集成、丰富和传递信息所需的功能，有些体系架构或框架，例如 Open Grid Services Architecture（OGSA）或者 Grid Computing Components，实际上都是虚拟化的组合或虚拟化的不同层次。这个框架中的每一层都是更低一层的抽象，它为上层提供了一个定义好的接口。随着我们在这个架构中的层次（或框架堆栈）的上升，底层提供的资源都组合成了更复杂的功能。例如，任务负载虚拟化和信息虚拟化就为已经虚拟化过的基础设施（系统、存储和网络）提供了更高级的虚拟化。

图 7. 网格计算组件

关于虚拟化管理

对于任何虚拟化环境来说，一个非常重要的方面是减少动态的和复杂的 IT 基础设施的管理和维护需求。另外，通过软件和工具实现的模式和技术都支持这些管理任务。这些模式和技术的组合可以实现以下功能：

.为 IT 基础设施中所有资源的管理访问提供单一且安全的接口；

.允许管理员对所有资源进行诊断；

.对所有资源进行配置和修改管理；

.发现并维护可用资源目录；

.监视资源并记录它们平时的健康状况；

.当某个条件达到已建立的上限值时，触发器就会执行相应操作；此时执行的操作可能包括通知管理员手工作出响应，也可能会根据正确的条件自动进行响应；

.根据资源的使用情况、可用性和服务级别要求提供资源或收回资源；资源的提供可以手工、半自动或根据建立好的策略自动完成；

.获得并维护资源的使用和检测信息，并提供适当的报告，例如对资源消耗进行记录；

.提供补充最终用户或应用程序安全性的安全机制；

.为满足最终用户和应用程序 SLA 而记录所有资源的性能信息。

参考链接：http://www.ibm.com/developerworks/cn/grid/gr-virt/

Top


目录 Power虚拟化介绍

Power虚拟化介绍

Power Systems 虚拟化简介

System p 中的虚拟化 - 逻辑分区

Power 动态虚拟化

IBM PowerVM 概述

PowerVM 虚拟化

PowerVM 磁盘虚拟化

AIX 6.1 中的工作负载分区入门

IBM AIX 上工作负载分区(Workload Partition)管理的介绍

虚拟化实现经济高效的优势

看服务器虚拟化如何降低大成本


Power Systems 虚拟化简介

自从引入 POWER5 技术以来，虚拟化提供了许多出色的特性。它是服务器整合的基础；有助于减少计划内停机时间，对于绿色计算领域很重要。更快更大的服务器不但有更多的可用内存，而且包含 Virtual I/O (VIO) 服务器、Virtual Ethernet、Shared Ethernet Adapter (SEA)、Virtual SCSI 和 Micro-Partitioning 等功能。另外，Simultaneous multi-threading (SMT) 可以显著提高大多数工作负载的性能。但是，使用这些特性的关键是至少要安装 AIX V5.3（或 Linux），这是使用这些新特性所需的 OS 版本。基于 POWER6 处理器的服务器上的 AIX V6 提供更高级的虚拟化特性。

POWER5, POWER6和POWER7服务器的另一个好处是，它们可以在同一台服务器上的不同 LPAR 中同时运行多个不同的 OS。一台服务器可以同时运行 AIX V5.3、AIX V6.1、AIX V7.1、SUSE Linux Enterprise Server 和 Red Hat Enterprise Linux，它们都在自己的 LPAR 中运行。另外，可以使用 VIO 服务器功能支持它们。Hardware Management Console (HMC) 或 Integrated Virtualization-Manager (IVM) 软件管理服务器。

选项和术语

与虚拟化有关的术语比较混乱。术语分为三个领域：CPU、内存和 I/O（网络和磁盘）。但糟糕的是，一些命令使用略有不同的缩写词表示相同的东西。在 POWER6/POWER7 处理器上，通过称为 PowerVM 的特性提供虚拟化。这个特性在 POWER5 系统上称为 Advanced Power Virtualization。POWER6/POWER7系列包含三个服务器版本：Express、Standard 和 Enterprise。Express 版只能在入门级系统（Power 520，Power 550，PS700，PS701，PS702， Power 710，Power 720，Power 730，Power 740，Power 750）上使用，它的功能有限，比如只支持 IVM 和在 VIO 服务器中包含三个 LPAR。Standard 版提供所有虚拟化特性，但是不包括两个为 Enterprise 版保留的功能。Enterprise 版在 Standard 版的基础上增加了 live partition mobility 和 Active Memory Sharing 功能。

对于 POWER5, POWER6和POWER7服务器，总是运行 POWER Hypervisor，它提供把物理实体（CPU、内存和 I/O 设备等）与实际软件或 LPAR 隔离开的功能。通过运行 VIO 服务器支持客户机 LPAR 可以进一步增强虚拟化功能。VIO 服务器是定制的 LPAR，提供 SEA 和 Virtual SCSI 功能以及 Live Partition Mobility 和 Active Memory Sharing。以前，即使 LPAR 很少使用 I/O 卡，也必须把整个槽分配给 LPAR；通过使用 VIO 服务器，可以在 LPAR 之间共享 PCI 槽中的卡。这可以显著减少 I/O 抽屉、I/O 卡和相关成本。

设置

一定要了解内存和 CPU 资源的三个设置。最小值是引导 LPAR 所需的最低量；在 LPAR 正常引导时，如果资源可用，它会使用期望值；最大值是正在运行的 LPAR 可以使用动态 LPAR 操作把资源提高到的上限。

Virtual Ethernet 和 SEA

Virtual Ethernet 是从 AIX V5.3 开始引入的，它并不需要 PowerVM。它让两个 LPAR 可以通过 Hypervisor 和 Vrtual Ethernet 通道通信。Virtual Ethernet 传输网络通信流需要一些 CPU 和内存。它还支持 Virtual LAN 和其他安全机制。

SEA 利用 Virtual Ethernet。SEA 并不把以太网适配器分配给 VIO 服务器上的每个 LPAR，而是把实际适配器（或聚合在一起的适配器组）分配给 VIO 服务器。LPAR 使用 Virtual Ethernet 与 VIO 服务器通信，必须传输到机器外的通信流都通过 VIO 服务器中的 SEA 发送出去。为了提供冗余，通常用两个 VIO 服务器作为 SEA，一个设置为主 SEA，另一个在执行故障转移时运行。SEA 可以减少系统上以太网卡的数量并提供故障转移和冗余。

Virtual SCSI

以前，如果希望为 LPAR 提供引导磁盘，就必须为连接磁盘的卡提供一个槽，这个槽是这个 LPAR 专用的。随着服务器越来越大、越来越快，需要在其中整合更多的 LPAR，这会显著增加引导 LPAR 所需占用的磁盘和槽数量，更何况还有实际数据磁盘。Virtual SCSI 让 VIO 服务器拥有适配器和磁盘，VIO 服务器可以分割磁盘并把部分磁盘（或整个磁盘）提供给 LPAR，让客户机 LPAR 认为自己拥有完整的引导磁盘。例如，根据 rootvg 的干净程度，大多数 LPAR rootvg 的大小在 30 到 45 GB 之间。目前最小的磁盘大约为 146 GB。通过使用 VIO 服务器，这个 146 GB 的磁盘可以轻松地分割为三个逻辑卷，每个逻辑卷可以作为一个 LPAR 的引导卷。即使为了提供冗余使用两个 VIO 服务器，这仍然可以显著减少磁盘、PCI 卡和 I/O 抽屉。

内存

以前，内存的情况还非常简单：内存是 LPAR 专用的。一定要记住，用来跟踪真实内存到虚拟内存映射的 Hypervisor 页面表条目的大小是根据 LPAR 的最大内存计算的，而不是根据期望内存。用户根据经验设置 LPAR 的最大内存，让 Hypervisor 的开销不会超过必要量太多。例如，如果服务器有 128 GB 内存，而 LPAR 的期望内存为 4 GB，那么把最大内存设置为 8 GB 左右而不是 128 GB。

这些页面表条目的 Hypervisor 开销的计算方法通常是，最大内存设置除以 64，然后向上取整到最接近的逻辑内存块大小。对于上面的示例，如果把最大内存设置为 128 GB，Hypervisor 就会为这个 LPAR 的页面表条目保留至少 2 GB 内存，尽管期望值只是 4 GB。如果最大内存设置为 8 GB，那么只保留 128 MB（根据逻辑内存块大小，也可能保留 256 MB）。

IBM 发布了 Active Memory Sharing 特性。这个工具提供可以由分区共享的内存池，允许在某些情况下过量使用内存，这样就不必购买很多内存。Active Memory Sharing 需要 AIX V6.1（或 IBM i 或 Linux）、POWER6/POWER7硬件和一些特定的固件版本。它还需要 PowerVM Enterprise 版，要求 LPAR 中的所有资源都是虚拟化的，LPAR 必须在共享处理器池中（使用 Micro-partitioning）。

Active Memory Sharing 是为内存需求变化大的 LPAR 设计的。VIO 服务器有一组特殊的 Active Memory Sharing 分页设备，在另一个 LPAR 需要内存时，可以根据设置时选择的选项交换出 LPAR 的内存。Active Memory Sharing 并不适用于内存使用量非常稳定或需要可预测的高性能的工作负载。它非常适合大多数测试和开发环境。

CPU

讨论 CPU 时使用的术语也很混乱。在 IBM Power Systems 环境中，CPU 表示单一处理器或单一处理器核。对于其他厂商，不一定是这种含义，所以最好使用 “核” 这个词，尤其是在讨论许可证时。

核要么分配给 LPAR，要么放在共享处理器池中。有一个特性称为 Dedicated Donating，但是它的行为基本上与共享处理器池相似。对于专用的核，在引导时把物理核分配给 LPAR，同一个核一直由这个 LPAR 使用。因为一个时钟周期提供 10 毫秒 (ms) 的分派窗口，所以核的分派窗口是 10 ms。当前没有分配给专用 LPAR 的所有核通常都放在共享处理器池中。

在 POWER6 技术出现之前，只有一个共享处理器池。POWER6 服务器支持最多 64 个池，默认的池是Pool 0。如果把 LPAR 定义为使用共享处理器池，它们就可以使用 Micro-Partitioning 功能。这意味着可以给 LPAR 分配一个核的十分之一，如果设置正确，LPAR 可以动态地收缩和增长。

基于 POWER5 处理器的 Power Systems 服务器支持 SMT。在基于 POWER5 和 POWER6 处理器的服务器上，许多寄存器是双重的，而POWER7的SMT能达到4，所以可以在同一个分派窗口中给同一个核分派多个线程，让它们同时运行，这样就可以利用流水线寄存器复制提供的优势。

虚拟 CPU、处理单元和逻辑 CPU 这三个概念会给理解处理能力设置造成困扰。首先，处理能力基本上是衡量可以使用的资源的指标。就像一品脱的瓶子有固定的容量，在给 LPAR 分配 CPU 和内存等资源时，也是指定可以使用的资源量。

专用的 CPU

在专用环境中，有一个核的服务器会显示一个处理器（可能在 lsdev –Ccprocessor 的输出中表示为 proc0）。如果关闭 SMT，vmstat 中的 lcpu 会显示有一个逻辑 CPU，lparstat 显示一个在线的虚拟 CPU。在这种情况下，这两个概念不会造成混淆。在关闭 SMT 时，vmstat 中的 lcpu=1 意味着一个真实的核分配给这个 LPAR。在分派线程时，它被分派给 proc0，proc0 代表真实的核。

如果打开 SMT 并运行 vmstat 和 lparstat，会在 vmstat 中看到 lcpu=2，而 lparstat 显示一个在线的虚拟 CPU。在专用环境中，没有虚拟 CPU 这样的概念，但是命令术语不变。lparstat 中的虚拟 CPU 实际上就是真实的 CPU。但是，如果打开 SMT，就会出现逻辑 CPU 的概念。每个逻辑 CPU 代表可以在同一个核上同时运行的线程之一。现在可以使用 mpstat –s 查看分派线程的情况。在打开 SMT 时，vmstat 中的 lcpu=2 意味着有一个核。在分派线程时，它被分派给逻辑 CPU，而逻辑 CPU 映射到 proc0，proc0 代表真实的核。

在专用环境中，有 5 个关键的设置：最小处理器数量、期望处理器数量、最大处理器数量、dedicated donating 以及一个决定在 LPAR 不运行时是否把核返回给池的选项。期望处理器数量是这个 LPAR 在引导时尽可能尝试使用的数量。专用 LPAR 的所有处理器设置都是表示核数的整数。

共享的 CPU

在共享 CPU 的环境中，虚拟处理器或 CPU 的概念是有意义的。核放在处理器池中，然后通过特定的设置给 LPAR 分配这个池。在核分配方面，现在有 6 个设置：最小、期望和最大处理器单元，最小、期望和最大虚拟处理器数量。因为可以把核的一部分分配给 LPAR，所以使用 “处理器单元 (PU)” 这个词，而不使用核。

例如，我们为一个 LPAR 设置最小值 0.1 PU、期望值 0.8 PU 和最大值 6 PU。还为它设置最小值 1 个虚拟处理器、期望值 2 个虚拟处理器和最大值 6 个虚拟处理器，而且它是不封顶的。打开 SMT。LPAR 按照期望设置（0.8 PU 和 2 个虚拟处理器）引导。

vmstat 命令显示 LCPU 为 4，lparstat 显示 2 个在线的虚拟 CPU。vmstat 和 lparstat 都显示标称处理能力为 0.8，vmstat 还显示 %entc 和 pc 字段。

PU 的期望设置（这里是 0.8）也称为标称处理能力。在 vmstat 中，%entc 是标称处理能力中正在使用的百分比，pc 是当前使用的处理器单元数量。在 LPAR 引导并获得期望的 PU 时，就会保证它随时可以使用期望的 PU。如果 LPAR 不使用这些 PU，Hypervisor 可以把它们分配给另一个 LPAR。如果 LPAR 是不封顶的，它可以超过它的标称处理能力，使用其他 LPAR 不使用的处理器资源。

虚拟处理器数量在共享的环境中有几个用途。首先，虚拟处理器数量决定 LPAR 认为它有多少个核。如果 VP=2，那么 LPAR 有 proc0 和 proc2，它认为自己有 2 个物理核。对于期望设置为 0.8 PU 的情况，这相当于有 2 个虚拟处理器，每个的初始分派窗口为 4 ms（对于完整的核应该为 10 ms）。在分派这两个虚拟处理器时，它们可以分派给相同或不同的核。系统会尝试把它们分派到以前运行它们的核上，但是不保证这一点。必须特别注意虚拟处理器设置，因为它们还告诉 LPAR 可以增长到多大，而且一些软件厂商使用它们计算许可证费用。

在前面的示例中，LPAR 是不封顶的，共享处理器池中有 6 个核，标称处理能力为 0.8，虚拟处理器数量设置为 2；打开了 SMT。在这种情况下，LCPU 显示为 4：因为有两个虚拟处理器，然后由于打开 SMT 而加倍。另外，尽管这个 LPAR 是不封顶的，但是它在增长时不能超过 2 PU，因为虚拟处理器数量实际上起到上限的作用。要想使用池中的所有 6 个核，必须把虚拟处理器数量设置为 6。不封顶的 LPAR 可以超过它的标称处理能力（期望的 PU），但是不能超过期望的虚拟处理器数量或池大小（以其中比较小的值为准）。

关于 Micro-partitioning 技术还要注意几点：

.与专用的核一样，完整的核的分派时间是 10 ms 的时间片。
.标称处理能力为 0.3 意味着一个核的百分之 30，即 3 ms 的时间片。
.标称处理能力为 1.4 意味着，对于每个 10 ms 的时间片，LPAR 有 14 ms 的处理时间（显然需要跨多个核）。对于 2 个虚拟处理器，这相当于每个核上 7 ms。
.对于一个核，分配的虚拟处理器越多，分派窗口就越小。
.根据标称处理能力、虚拟处理器数量和中断数量，一个 LPAR 可以在多个核上运行。
.期望的虚拟处理器数量不能超过标称处理能力的 10 倍或 64（以其中比较小的值为准）。

对于不封顶的 LPAR，每个虚拟处理器可以增加它使用的处理能力，但是不超过一个完整的核（即 10 ms）。因此，即使一个 LPAR 的标称处理能力只有 0.8，但是如果它有两个虚拟处理器而且不封顶，在有资源可用的情况下，它可以增长到 2 个完整的核。但是，如果虚拟处理器数量设置为 1，它就不能超过一个核。如果 LPAR 设置为封顶的，规则就不一样了；封顶的 LPAR 不能超过它的标称处理能力。因此，如果这个 LPAR 是封顶的，它就不能超过 0.8 PU（见表 1）。

表 1.共享 CPU

 | 不封顶 LPAR1 | 不封顶 LPAR2 | 封顶 LPAR3
标称数量 | 2.0 | 2.0 | 2.0
需要的虚拟处理器数量 | 4.0 | 6.0 | 4.0
最大增长 | 4 PU | 6 PU | 2.0

虚拟化的好处和困难

显然，明智地实现虚拟化可以显著地节省资源。但是，要想理解虚拟化背后的概念，一定要掌握相关术语。标称处理能力、处理器单元、虚拟处理器、处理能力和池尤其重要。

参考链接：http://www.ibm.com/developerworks/cn/aix/systemmaga/200912/virtualization_power_system/

Top


System p 中的虚拟化 - 逻辑分区

您可以使用逻辑分区来承载各种不同的操作系统，通过在分区中分配操作系统和应用程序所需的硬件资源，您就可以创建这些分区。System p 中的虚拟化为不同的逻辑分区之间提供了严格的隔离。虚拟化具有一个重要的特性，在对逻辑分区进行动态配置和重新配置时，无需重新启动整个物理计算机，也不会影响到其他分区。
为了对虚拟化、硬件、固件和操作系统提供支持，我们需要必要的支持。POWER Hypervisor 是在 POWER5 中实现虚拟化的一个固件组件。本文介绍了 POWER Hypervisor 的作用，以及它如何在一个分区的环境中提高性能。

什么是虚拟化呢？

在计算的世界中，虚拟化是对物理资源进行抽象的一种机制。它提供一种逻辑的方式，以便查看物理资源、它们的组织独立性、实现或者地理位置。

准虚拟化的介绍

准虚拟化 是一种在 System p 中实现的虚拟化，它定义了名为 Hypervisor 的新层。该层位于硬件之上，并且使用称为 hypervisor调用的硬件，通过一组低层的例程进行操作。操作系统通过这些 Hypervisor 调用为 Hypervisor 提供了接口。

逻辑分区

System p 中的准虚拟化是通过进行逻辑分区来实现的。逻辑分区不同于物理分区，后者以物理边界对资源和硬件进行划分以创建相应的分区。在进行物理分区时，每个分区可能运行相同的操作系统、或者相同操作系统的不同版本。I/O 资源、处理器和内存并不在多个分区之间进行共享，因此，它们是完全隔离的。

在进行逻辑分区时，通常使用一些物理处理器、内存和 I/O 设备来创建逻辑分区。对于要分配给一个分区的资源数量，并没有具体规定（尽管在建立一个分区时，存在必须分配的最少资源）。因此，物理处理器、内存和 I/O 可以分配给一个或多个分区。每种资源可以采取任何比例来进行分配。某些资源可以在所有的分区中共享，如电源供应。可以创建的分区的总数依赖于系统处理器模型和可用的资源。

一个分区，也称为 LPAR，可以与其他分区进行通信，就好像每个分区都是一台独立的计算机一样。可以独立地激活和重新启动各个分区（独立于其他的分区）。

图 1. 逻辑分区

每个逻辑分区都可以运行一个独立的操作系统、或者相同操作系统的不同版本，但是在不同的分区之间，软件是相互隔离的。如果一个分区中的操作系统出了故障，在其他分区中运行的操作系统不会受到任何影响。类似地，一个分区中运行的应用程序不会对在其他分区中运行的应用程序产生任何影响。

所有的分区都共同使用整个物理内存空间。然而，每个分区都有它自己的内存空间，这对性能不会有任何影响。可以通过独立的地址映射机制来维护地址的隔离。

可以在不同的分区之间动态地分配和重新分配资源，而不会影响其他分区，也无需重新启动这些分区。对软件而言，对物理资源所做的更改和重新分配也可能是透明的。在执行应用程序期间，当为一个逻辑分区分配物理 CPU 失败的时候，这种透明性的意义非常重大。对正在 CPU 中运行的应用程序而言，对出现问题的 CPU 的替换是透明的。

POWER Hypervisor 的介绍

POWER Hypervisor 也称为来自 POWER5 的 phyp，是在 System p 中实现准虚拟化的重要组件。它是一个全局固件映像，位于分区内存之外的物理地址零处的第一个物理内存块中。在启动系统的时候，它将获得控制权，并收集相关的信息（该系统中提供了多少内存、I/O 和其他资源）。POWER Hypervisor 拥有并控制系统的全局资源，并且它负责建立逻辑分区，并定义分区的边界。它将跟踪分配给分区的资源，并在各个分区之间提供隔离。

POWER Hypervisor 使用全局分区页表执行虚拟内存管理，并管理分区尝试访问超出其分配限制之外的内存的请求。我们将在后面的部分中更详细地讨论 POWER Hypervisor 的功能，包括调度和内存管理。

动态逻辑分区

您不仅能够将硬件逻辑地划分为多个 LPAR，而且 IBM 还提供了在分区正常运行时动态添加、删除或在分区之间移动资源的能力。您可以对正在运行的分区添加或删除 CPU、内存或 I/O 槽，而不必首先关闭该 LPAR。动态逻辑分区 (DLPAR) 为您的计算环境提供了大量的灵活性。随着环境条件的改变，您能够通过将硬件资源移动到需要的地方而不中断对 LPAR 的服务来作出反应。使用此特性的选项数不胜数。但是要注意，并非所有应用程序都能够完美地处理 CPU 或内存的删除，因此，当您开始在生产环境中使用此特性之前，需要在您的特定的环境中进行测试。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-syspvirtualization/

Top


Power 动态虚拟化

PowerVM 领先技术与一体化管理两手抓 系统灵活部署，业务动态响应！

提到机房的运营和管控，每个 IT 管理人员都希望做到--

无论物理设备还是虚拟设备，都能实现统一管理和控制，简化管理；
无论调整应用还是新增应用，都能实现快速维护和部署，轻松搞定；
无论正常业务还是突发需求，都能实现资源灵活调配和共享，波澜不惊；
无论增加设备还是计划停机，都能实现业务持续运行不中断，尽在掌握。

如何做到服务器的虚拟化已经成为大多数企业的首选。

通观企业虚拟化的实施情况，水平高低不齐、层次深浅不一，新的问题随即产生：

虚拟能否成功“落地”虚拟化的管理已经成为虚拟化生态链关注的重点！

IBM Power Systems 再一次在业界率先提出“两手抓两手都要硬”的虚拟化服务管理，即虚拟化技术+一体化管理=IBM Power Systems 动态虚拟化！

通过PowerVM虚拟化技术和自下而上的完整的服务管理方案，让您的基础架构具备最好的灵活性，实现真正的云计算架构，动态响应业务的需求。

一手加强虚拟化技术 灵活调配，动态响应业务

凝聚 IBM 40余年领先的虚拟化技术研发和实践经验的 IBM Power Systems 虚拟化解决方案，可帮助企业实现资源动态调配整、虚拟分区动态部署迁移、虚拟环境的高可用性等功能，提供随需部署和调配系统资源以灵活适应业务需求，提高 IT 服务水平。

.虚拟化处理器、内存和 I/O 资源：提高资源利用率，降低系统成本

IBM Power服务器具备的动态虚拟化技术，通过无人企及的 CPU、内存、I/O、网络等资源的动态逻辑分区技术和微分区技术，可以动态灵活地移动、增减系统资源，随时将资源动态分配到需要的地方，从而大大提供资源的利用效率和灵活性。

虚拟处理器 最大支持64颗 CPU，以 1/100 CPU 的颗粒度根据分区系统负载和业务运行特点，动态调整共享 CPU 资源，大大提高系统利用率和灵活性。

虚拟内存 Active Memory Sharing 智能地在分区间迁移内存，从而提高内存利用率以及内存使用的灵活性。

虚拟 I/O 将客户端分区的 I/O 资源（磁盘、磁带、以太网）进行虚拟化可简化管理并降低系统成本。

.动态分区实时迁移（Live Partition Mobility）：UNIX 业界独领风骚

IBM POWER6/POWER7 独有！在服务器间移动正在运行的分区，减少计划内停机时间。根据动态业务需求，允许您将正在运行的分区无间断地从一个物理服务器迁移到另一个物理服务器，而不会对基础服务产生任何影响。这项迁移操作将传输整个系统环境，包括处理器的状态、内存、附加的虚拟设备，以及连接的用户。整个操作只需几秒即可完成，可以维护整个系统的完整性！动态分区实时迁移功能有助于减少计划内宕机影响；在不影响应用的情况下，动态负载均衡，合理利用资源；在不中断服务的情况下，采用新技术；移除低利用率服务器上的负载，并关闭空闲服务器，节省能源，实现计划内零停机成本、整体宕机成本降低 59%、耗能降低 89% 和空间占用减少 87%！

.工作负载分区（WPAR，Workload Partition）和动态应用程序迁移（Live Application Mobility）：基于 AIX6 核心技术的纯软虚拟化

工作负载分区 WPAR 是基于 AIX6 的全新软件虚拟技术，用于隔离用户和应用程序。它不依赖于硬件特性，是多种 AIX 核心技术的综合体现。WPAR 是由软件创建的、AIX 6映像中的虚拟化的操作系统环境，使多个系统环境共享一个 AIX6 操作系统，而对于所承载的应用程序来说，每个工作负载分区都是一个安全的、隔离的环境。它能够动态调整服务器能力，满足不断变化的工作负载需求。

动态应用程序迁移是 AIX 6.1 的一项独特创新，允许您移动工作负载，而不是整个分区，能实现应用的快速部署！实际的迁移目标 WPAR 可以是不同的服务器，但并不一定必须是不同的服务器。方便您在一些具备混合物理体系结构(POWER5, POWER6, POWER7)的环境中使用它，灵活调配。它可以将应用程序从需要计划停机以便进行维护的系统中移动到别处；通过将工作负载从不堪重负的服务器移动到负载较轻的服务器，它还可以用于提高性能；而且，通过采用这种方式移动工作负载以允许物理服务器在非高峰期间进入睡眠状态，它还可以帮助节约电能。

一手加强一体化管理 简化管理，实现动态部署

IBM Power Systems 的一体化管理解决方案将 IBM Systems Director 和 AIX 企业版或 Management Edition for AIX 配合使用，涵盖了从底层的资源管理，到中间层的平台级管理，再到企业级服务管理，通过一个统一的平台 Systems Director，管理跨平台的物理资源和虚拟资源，轻松实现虚拟化方案及应用的快速部署和维护服务，完美实现 IT 资源管理与业务服务管理的有效关联，使 IT 运营与业务目标相匹配，真正有效地解决用户的管理问题，提高 IT 服务水平，动态响应业务需求。

.AIX Enterprise Edition (AIX EE): 跨系统管理，实时负载迁移，企业级服务管理

整合 AIX6 优异特性，IBM 独有！AIX 企业版将 AIX 6 和企业管理功能加入到单一的、易于订购的产品中，可在提高可用性、提高运营效率、在虚拟化的环境中测量资源的使用情况，简化管理虚拟化 AIX 环境的流程。AIX 企业版通过更透彻地了解 IT 资源对业务服务交付产生了哪些影响，为服务管理奠定坚实的基础。

.Management Edition for AIX： 低成本获得量身定制的企业级服务管理

精选 Tivoli 管理模块！低成本地实现 IT 资源管理与业务服务管理的有效关联，控制、管理并优化业务，使 IT 运营与业务目标相匹配，快速部署和维护服务以适应业务动态需求。而其他某些品牌产品只能提供一体化庞大昂贵的服务管理解决方案，不能响应企业业务需求提供量体裁衣的企业级适用方案。

.Systems Director管理系统：实现跨平台跨厂商IT资源优化管理

免费提供，可节省 21％ 管理成本！为平台管理提供一体化的方法，有效调配并管理数据中心的所有虚拟和物理资源，提供配置、发现、系统健康状态监控、自动响应以及电源和虚拟化管理等功能，同时充分利用行业标准，支持多种跨 IBM 和非 IBM 平台的操作系统和虚拟化技术，使 IT 专家能够同时管理多个 IT 环境中的物理和虚拟系统，缩短故障排除时间，提高系统可用性，并提高 IT 管理效率和提高系统使用率进而降低成本。

参考链接：http://www-31.ibm.com/systems/cn/dihub/products_innovation/power_advantage/powervmsolution.shtml#max

Top


IBM PowerVM 概述

虚拟化在 System p 上的价值

IT 部门的主要目标之一是快速响应新增或更改系统部署的业务需求。这就要求尽可能快速且经济有效地：

.部署新的应用程序或系统
.更改现有系统的计算能力或服务标准

典型的（非虚拟化的）IT 部署需要指定和配置许多组件并确定它们的规模：

.服务器
.网络和交换机
.SAN
.存储

这种选择和购买新硬件的方法会导致部署花费的时间很长，而且成本很高。通过使用 IBM System p 虚拟化，可以快速且经济有效地响应业务需求。另外，PowerVM 还可以提高服务器的利用率，这会：

.减少服务器的管理成本，因为物理服务器更少了。
.通过提高现有服务器的利用率，减少供电和制冷成本。
.可以立即部署虚拟资源，减少系统投入生产的时间。

随着服务器供电和制冷成本的不断增加，虚拟化功能已经成为服务器和资产设计和规划中最重要的部分之一。由于考虑到经济和环境因素，企业迫切需要减少服务器资产的能源消耗。IBM System p 虚拟化可以尽可能充分地利用服务器资源，有助于满足对 IT 服务日益增长的需求，缓解政府法律法规的影响。

毫不夸张地说，许多项目取得成功正是由于采用了 IBM System p 虚拟化。能够使用服务器上可用的处理能力在几分钟内提供新的微分区，这使项目能够快速地响应体系结构中的变化。再结合使用 Capacity Upgrade on Demand 和 PowerVM AIX 6 工作负载分区等补充技术，IBM System p 上的 PowerVM 就更吸引人了。

IBM System p 服务器上的 PowerVM

下面几节概述 PowerVM 的特性。

什么是 PowerVM ？

PowerVM 是一个包含一系列硬件和软件特性的品牌，它使系统能够更灵活地适应各种工作负载。

PowerVM 是 Power Systems virtualization 的新名称。它包含微分区、逻辑分区、虚拟 I/O、Hypervisor 等特性。表 1 说明 PowerVM 品牌中这些特性的情况。

表 1. PowerVM 特性名称

老名称 | 新名称 | 支持此特性的软件或硬件
Power Systems Virtualization | PowerVM | 无 - 统称
Advanced POWER Virtualization (APV) | PowerVM Editions | POWER 硬件(POWER5/POWER6)
 | PowerVM Express Edition | PowerVM Express Edition
APV Standard Edition | PowerVM Standard Edition | POWER5 或 POWER6 硬件
APV Enterprise Edition | PowerVM Enterprise Edition | POWER6 硬件
System p Application Virtual Environment (p AVE) | PowerVM Lx86 | POWER5 或 POWER6
Live Partition Mobility | PowerVM Live Partition Mobility | POWER6 硬件
AIX 6 Workload Partitions Manager | PowerVM AIX 6 Workload Partitions Manager | AIX 6.1
AIX 6 Workload Partitions | PowerVM AIX 6 Workload Partitions | AIX 6.1

PowerVM Editions

PowerVM Editions 是基于 POWER5,POWER6或者POWER7处理器的 IBM System p 上的可选硬件特性。

PowerVM Express Edition 可以在基于 POWER6/7 技术的 Power 520，Power 550，PS700，PS701，PS702， Power 710，Power 720，Power 730，Power 740，Power 750服务器上使用，它包含以下特性：
.每个服务器最多三个分区
.Shared Dedicated Capacity
.PowerVM Lx86，支持在这些服务器上运行基于 x86 的 Linux 应用程序。
.虚拟 I/O 服务器
.Integrated Virtualization Manager
.Power Hypervisor

PowerVM Standard Edition 支持基于 POWER5 的系统，支持更多的 LPAR；对于基于 POWER6/7 的系统，还提供 Multiple Shared Processor Pools。

PowerVM Enterprise Edition 只能在基于 POWER6/7 的系统上使用，增加了 PowerVM Live Partition Mobility和Active Memory Sharing 特性。

表 2 说明各个 PowerVM Editions 中包含的特性。

PowerVM editions | Express | Standard | Enterprise
PowerVM Hypervisor | Yes | Yes | Yes
Dynamic Logical Partitioning | Yes | Yes | Yes
Maximum partitions | 3 per server | 254 per server | 254 per server
Management | VM Control, IVM | VM Control, IVM, HMC | VM Control, IVM, HMC
Virtual I/O Server | Yes | Yes (Dual) | Yes (Dual)
Integrated Virtualization Manager | Yes | Yes | Yes
PowerVM Lx86 | Yes | Yes | Yes
Suspend/Resume | No | Yes | Yes
N_Port ID Virtualization | Yes | Yes | Yes
Multiple Shared Processor Pool | No | Yes | Yes
Shared Storage Pools | No | Yes | Yes
Thin Provisioning | No | Yes | Yes
Active Memory Sharing | No | No | Yes
Live Partition Mobility | No | No | Yes

POWER Hypervisor

POWER Hypervisor 是在 IBM System p 上实现虚拟化的基础，它可以把硬件划分为多个分区，并确保它们之间是隔离的。
POWER Hypervisor 在基于 POWER5, POWER6和POWER7 的服务器上总是启用的，它负责跨共享的物理处理器分配逻辑分区工作负载。POWER Hypervisor 还确保分区安全性，它可以提供分区间通信，支持虚拟 I/O 服务器的虚拟 SCSI 和虚拟以太网等功能。

并发多线程

并发多线程 (SMT) 是 IBM 的一种微处理器技术，它允许在同一个物理处理器上同时运行两个单独的硬件指令流（线程）。SMT 可以显著提高处理器和系统的总体吞吐量。SMT 最初是在基于 POWER5 的服务器上引入的，在基于 POWER6/7 的服务器上效率又得到了进一步提升。

逻辑分区和处理器计算能力
可以把逻辑分区看作一个逻辑服务器，它能够引导操作系统并运行工作负载。

逻辑分区

自从 2001 年推出 IBM pSeries 690（一种基于 POWER4 的服务器）以来，在基于 IBM POWER 的系统上已经可以使用 LPAR 技术。一组系统资源（完整的 POWER 微处理器、内存和 I/O 资源）可以分组为分区 —— LPAR。因为资源分配是一个逻辑功能，所以可以根据需要和物理服务器中可用的资源灵活地确定资源数量。

物理共享处理器池和微分区

基于 IBM POWER5 的服务器引入了共享处理器分区功能。
这些共享的处理器分区（称为微分区）从一个物理处理池中分配处理器资源。
分配给微分区的处理器计算能力数量（标称计算能力）从一个物理处理器的十分之一直到物理共享处理器池的所有计算能力。物理共享处理器池可以包含的物理处理器数量从一个直到系统上安装的所有处理器。
可以以一个物理处理器的百分之一作为增量更改微分区的标称计算能力。

微分区可以是有上限（capped）的，也可以是无上限（uncapped）的。这两种模式的定义如下：

.有上限
有上限的微分区定义了标称计算能力，可以保证它获得这些能力。在任何情况下，有上限的微分区获得的处理器资源都不会超过它的标称计算能力。

.无上限
无上限的微分区也定义了标称计算能力，可以保证它获得这些能力。但是，在某些情况下，它可以获得更多的处理器资源。通常，如果无上限的微分区是可运行的（有要执行的实际工作），而且物理共享处理器池中有空闲的处理器周期，就会按照权重把多余的处理器周期分配给这个微分区。

有上限和无上限的微分区可以共存，它们都从物理共享处理器池获得处理器资源。

Multiple Shared-Processor Pools

在基于 POWER6/7 的系统上，支持 Multiple Shared-Processor Pools。这个功能让系统管理员可以创建一组微分区，并控制它们可以从物理共享处理器池获得的处理器计算能力。

Multiple Shared-Processor Pools 使用物理共享处理器池中的处理器计算能力 —— 系统中只能有一个物理共享处理器池。每个 Shared-Processor Pool 有相关联的标称池计算能力，这些计算能力供这个 Shared-Processor Pool 中的微分区使用。

保证 Shared-Processor Pool 中的微分区获得它们的标称计算能力。另外，Shared-Processor Pool 中未使用的处理器周期可以重新分配给同一个 Shared-Processor Pool 中符合条件的微分区。

多余的处理器周期可能来自 Reserved Pool Capacity，这是专门为 Shared-Processor Pool 保留的处理器计算能力，但是这些计算能力没有分配给 Shared-Processor Pool 中的任何微分区。

当 Shared-Processor Pool 中的微分区集负载很重时，它们可以使用它们的 Shared-Processor Pool 之外的处理器计算能力（假设它们是无上限的），直到指定的最大值 Maximum Pool Capacity。

Shared-Processor Pool 中未充分使用处理器计算能力的微分区会放弃以这种方式分配的处理器计算能力。

如果系统管理员没有创建其他 Shared-Processor Pool 的话，所有微分区都使用一个默认的 Shared-Processor Pool (Shared-Processor Pool0)。Shared-Processor Pool0 有一些特殊的性质，确保它与基于 POWER5 的微分区和物理共享处理器池的操作一致性。

图 1. 显示一个基于 POWER6 的服务器的体系结构概况，其中定义了两个 Shared-Processor Pool。

图 1. 显示一个基于 POWER6 的服务器的体系结构概况，其中定义了两个 Shared-Processor Pool。

图 1 基于 POWER6 的服务器的体系结构概况，定义了 MSPP。

最多可以有 64 个 MSPP。除了默认的 MSPP，还有 63 个用户定义的 MSPP。

Shared Dedicated Capacity

基于 POWER6 的服务器能够回收利用专用处理器分区中未使用的处理器周期。然后，把这些未使用的周期提供给与微分区相关联的物理共享处理器池。这可以尽可能充分地利用处理器。

系统管理员可以控制哪些 LPAR 可以提供未使用的周期。必须在 LPAR 配置文件中指定 LPAR。

虚拟以太网

虚拟以太网功能由 POWER Hypervisor 提供。POWER Hypervisor 实现以太网传输机制和一个支持 VLAN 功能的以太网交换机。虚拟 LAN 可以在逻辑分区之间实现安全的通信，不需要物理 I/O 适配器或线缆。可以在多个分区之间安全地共享以太网带宽，这可以提高硬件利用率。

虚拟 SCSI

虚拟 SCSI 由 POWER Hypervisor 提供。虚拟 SCSI 可以在分区之间实现安全的通信并通过一个虚拟 I/O 服务器连接存储设备。

虚拟 SCSI 和虚拟 I/O 服务器功能的组合可以共享存储适配器带宽，还可以把单一磁盘划分为小片段。然后，可以在多个分区之间共享适配器和磁盘，这会提高利用率。

虚拟磁盘 I/O 功能由虚拟 SCSI 和虚拟 I/O 服务器的组合提供，可以以灵活且可靠的方式共享物理磁盘 I/O 适配器。同一服务器上的多个逻辑分区可以使用同一个物理磁盘 I/O 适配器和相关联的磁盘系统。这有助于整合磁盘 I/O 资源，减少所需的磁盘 I/O 适配器数量。

虚拟 I/O 服务器

在 PowerVM 中，可以通过辅助服务器连接物理资源，这样就可以在逻辑分区之间共享这些资源。虚拟 I/O 服务器可以使用虚拟的存储和网络适配器，因此可以使用虚拟 SCSI 和虚拟以太网功能。

对于存储虚拟化，可以使用以下设备：

.直接连接虚拟 I/O 服务器的完整磁盘
.连接虚拟 I/O 服务器的 SAN 磁盘
.在前面两种磁盘上定义的逻辑卷
.基于文件的存储，使用的文件可以驻留在前面两种磁盘上
.光学存储设备

对于虚拟以太网，可以在虚拟 I/O 服务器上定义共享的以太网适配器，从而连接虚拟以太网和物理以太网。

虚拟 I/O 服务器有助于整合 LAN 和磁盘 I/O 资源，减少所需的物理适配器数量，同时满足服务器的非功能性需求。对存储设备的支持情况，请参见以下网站：
http://www14.software.ibm.com/webapp/set2/sas/f/vios/documentation/datasheet.html

虚拟 I/O 服务器可以在专用处理器分区上运行，也可以在微分区上运行。在 Advanced POWER Virtualization on IBM System p: Virtual I/O Server Deployment Examples, REDP-4224 中可以看到虚拟 I/O 服务器和相关 I/O 子系统的各种配置。

Integrated Virtualization Manager

Integrated Virtualization Manager (IVM) 是一个基于 Web 浏览器的管理界面，支持基于 POWER5, POWER6或者POWER7的系统的某些型号。IVM 驻留在虚拟 I/O 服务器中。

IVM 系统不需要 HMC，但是每个系统需要一个单独的 IVM 实例。因此，对于单独部署的小型系统推荐使用 IVM。

Live Partition Mobility

Live Partition Mobility 是 PowerVM Enterprise Edition 中提供的一种功能，它依赖于许多组件，包括：
.POWER Hypervisor
.虚拟 I/O 服务器（或 IVM）
.Hardware Management Console（或 IVM）

Live Partition Mobility 可以把正在运行的 AIX 或 Linux 分区从一个物理 POWER6 服务器转移到另一个，不需要停止运行。分区的转移包括分区正在运行的所有应用程序。这个特性的一些应用和优点如下：
.从服务器转移出分区，然后就可以对服务器执行计划内维护，而不会中断服务或干扰用户
.把负载重的分区转移到更大的机器上，而不会中断服务或干扰用户。
.根据工作负载需求，把分区转移到适当的服务器；通过调整服务器资产的利用率，维持服务水平，同时尽可能降低成本。
.在非高峰时间整合利用率不高的分区，这样就可以关闭未使用的服务器，从而节省供电和制冷成本。

关于 Live Partition Mobility 的更多信息，请参见 IBM System p Live Partition Mobility, SG24-7940。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/powervm-1/index.html/

Top


PowerVM 虚拟化

借助 PowerVM 进行虚拟化
PowerVM 为 IBM Power Systems上的AIX、IBM i 和 Linux 操作系统提供了行业领先的虚拟化技术。PowerVM 针对客户端 VM 虚拟化处理器、内存、存储和 I/O 资源，可提高资产利用率、增强基础架构灵活性并降低成本。

要点

.通过将多种工作负载整合到 Power Systems平台，进一步减少 IT 成本；

.优化企业 IT 资源的利用，从而进一步提高服务水平和投资回报；

.最大限度降低系统管理和自动化标准流程的复杂性；

.快速扩展以提供最多的系统资源，满足最苛刻的任务关键型工作负载要求；

.通过迁移服务器之间的实时工作负载来减少计划内停机，从而最大限度提高可用性。

由于新应用程序的推出和不可预期的变化，IT 基础架构仍会不可避免地日益复杂。但是，增添服务器以响应新工作负载的每个要求，可推动对更多数据中心空间、功率、散热、网络布线、数据存储和管理资源的需求。此类复杂性会导致低效。解决方案便是虚拟化，从而支持企业将多个操作系统和软件堆栈整合至一个平台。

PowerVM为 IBM Power Systems 服务器及刀片服务器提供了行业领先的虚拟化解决方案。PowerVM 基于十年多的演进和创新，代表一流的企业虚拟化技术，由大多数 Power Systems 所有者广泛部署于全球生产环境之中。

IBM Power Systems 系列服务器包括久经验证的工作负载整合平台，可以帮助客户在提高整体性能、可用性和能效的同时，有效控制成本。借助这些服务器和 IBM PowerVM 虚拟化解决方案，企业可以整合大量的应用程序和服务器、充分虚拟化系统资源，从而提供一个更具灵活性的动态 IT 基础架构。换言之，IBM Power Systems 服务器结合 PowerVM 技术可以无限自由地提供虚拟化优势。

PowerVM 为采用 IBM POWER处理器的系统上的 AIX、IBM i和 Linux环境提供了行业领先的虚拟化技术。IBM Power Systems 服务器结合 PowerVM 技术可以支持您构建动态基础架构、降低成本、管理风险并提高服务级别。

此外，由于 IBM Power Systems 平台采用行业领先的 POWER6与 POWER7处理器，具有先进的 RAS （可靠性、可用性和可服务性） 特性、极致的可扩充性和领先性能2，而 PowerVM 正是在此基础上构建而成的，因此能够提供安全灵活的虚拟化环境。

支持的操作系统版本

.AIX 5.3、AIX 6.1 与 AIX 7
.IBM i 6.1 与 IBM i 7.1
.Red Hat Enterprise Linux 5 与 Red Hat Enterprise Linux 6（Red Hat 公布时）
.SUSE Linux Enterprise Server 10 与 SUSE Linux Enterprise Server 11

支持的硬件平台

采用 POWER5、POWER6和 POWER7处理器的 IBM Power Systems

PowerVM特性及优势

功能 | 优点
PowerVM Hypervisor | .在一个系统上支持多个操作环境
微分区 | .每个处理器内核最多支持 10 个 VM
动态逻辑分区 | .处理器、内存以及 I/O 资源可以动态地在 VM 间迁移 .VM 可以使用专用或共享（限制或不限制）的处理器资源 .处理器资源可以根据工作负载需求自动在 VM 间迁移
共享处理器池 | .可以限制一组 VM 的处理器资源来协助降低软件许可成本
共享存储池 | .多个 Power Systems 服务器和 VIOS 的存储资源可集中到存储池中，以优化资源利用
集成虚拟化管理器 | .简化入门级 Power Systems 服务器及刀片服务器的 VM 创建和管理
PowerVM Lx86 | .支持在一个 Linux on PowerVM 分区中运行多个 x86 Linux 应用程序
实时分区迁移 | .Live AIX 与 Linux VM 可以在服务器间灵活迁移，从而有效减少计划内停机
Active Memory Sharing | .将内存从一个 VM 智能传送至另一个 VM，以提高内存利用率
NPIV | .简化管理并提高光纤通道 SAN 环境的性能
系统规划工具 | .借助 PowerVM 简化 Power Systems 服务器的规划与安装

参考链接：http://www-31.ibm.com/systems/cn/power/software/virtualization/index.shtml

Top


PowerVM 磁盘虚拟化 - vSCSI 和 NPIV 混合实现

历史回顾

我们先简要回顾一下基于 UNIX 的服务器的磁盘连接技术发展过程。在 Fibre-Channel 技术出现之前，主流的磁盘连接技术是 Small Computer Systems Interface (SCSI)。服务器直接连接基于 SCSI 的磁盘驱动器，使用它们存储 OS 和数据，见图 1。

图1.SCSI 连接

引入 Fibre-Channel 连网技术之后，Storage Area Networks (SAN) 开始流行了。企业开始把数据转移到基于 SAN 的磁盘子系统上，磁盘子系统通过 Fibre Channel 适配器连接到服务器上，见图 2。这实现了集中的数据存储，可以提高可靠性、磁盘访问速度和利用率。对于大多数实现，OS 仍然驻留在服务器内的本地 SCSI 磁盘驱动器上。

图2. Fibre Channel 连接

图2. Fibre Channel 连接

这种配置成为基于 UNIX 的服务器的标准部署模型，一直持续了很多年，实践证明它非常可靠。但是，虚拟服务器的出现给这个模型带来了挑战。现在的虚拟服务器能够运行数十甚至数百个虚拟操作系统。给虚拟服务器中的每个操作系统分配专用的物理 Fibre-Channel 适配器是不可行的；必须改变磁盘连接模型了。

虚拟 SCSI

POWER5 处理器、AIX 5.3 和 PowerVM 的组合把磁盘和局域网虚拟化引入了 Power Systems 服务器。引入了一种新的 LPAR —— VIOS。它提供磁盘和局域网虚拟化支持。对于磁盘虚拟化，VIOS 允许使用 vSCSI 接口把基于 SAN 的磁盘逻辑单元号（Logical Unit Number，LUN）映射到客户机 LPAR，见图 3。

图3.虚拟 SCSI 连接

图3.虚拟 SCSI 连接

vSCSI 机制让 VIOS 可以通过虚拟的 SCSI 连接把磁盘卷提供给客户机 LPAR。VIOS 拥有物理磁盘卷，这些磁盘卷可以是本地连接的，也可以是基于 SAN 的。客户机 LPAR 使用 vSCSI 接口访问磁盘卷；对于客户机 LPAR，这些磁盘卷就像是本地连接的 SCSI 硬盘驱动器 (hdisk)。
有了 vSCSI 实现，VIOS 管理员就可以控制客户机 LPAR 的所有磁盘分配。首先，SAN 管理员把每个基于 SAN 的 LUN 分配给 VIOS。然后，VIOS 管理员必须把 LUN 分配给客户机 LPAR。因为最终把 LUN 分配给客户机 LPAR 是在 VIOS 级上进行的，SAN 管理员并不知道哪个 LPAR 使用哪些 LUN，由 VIOS 管理员维护分配信息。注意，在这个方面，vSCSI 模型与图 1 中的原始 SCSI 磁盘实现非常相似，都是由系统管理员负责所有磁盘分配。
N_Port ID Virtualization
NPIV 提供另一种在 VIOS 上实现磁盘虚拟化的方法。在使用 NPIV 时，分配给 VIOS 的物理 Fibre-Channel 适配器可以与 64 个下游虚拟 World Wide Name (WWN) 相关联。然后，可以把虚拟 WWN 分配给客户机 LPAR。

简单地看，可以把运行 NPIV 的 VIOS 看作虚拟的 SAN 交换机，它在物理 SAN 和客户机 LPAR 之间提供连接。在使用 NPIV 时，存储管理员直接把基于 SAN 的磁盘 LUN 分配给使用此磁盘的客户机 LPAR。因此，存储管理员知道磁盘被分配给哪个 LPAR。使用 NPIV 还会大大减轻 VIOS 管理员的负担，让他们不必管理分配给客户机 LPAR 的所有基于 SAN 的磁盘 LUN。在这种环境中，客户机 LPAR 使用“从 SAN 引导”过程从基于 Fibre Channel 的 SAN 磁盘子系统装载 OS。从 SAN 引导要求客户机 LPAR 管理员知道 SAN 配置。

混合的 vSCSI 和 NPIV 实现

正如前面提到的，vSCSI 是 PowerVM 提供的第一种磁盘访问虚拟化技术。它的效果非常好，许多企业都使用它。从管理的角度来说，vSCSI 恢复了原始 UNIX 服务器实现模型的管理方式，在原始模型中提供给客户机 LPAR 的所有磁盘都是本地连接的 SCSI 磁盘。VIOS 管理员管理所有 OS 和数据磁盘卷，这与为服务器配置本地 SCSI 磁盘驱动器时相似。对于使用大量数据的服务器，这个任务会变得非常困难，因为他们要负责处理磁盘冗余和备份。一种解决方案是实现混合的磁盘虚拟化模型，见图 4。

图 4.混合连接

在混合模型中，OS 磁盘使用 vSCSI，数据磁盘使用 NPIV。这效仿图 2 中的传统环境，在那种环境中使用本地 SCSI OS 磁盘和通过 Fibre Channel 连接的数据磁盘。客户机 LPAR 管理员使用 vSCSI 提供的磁盘安装和管理 OS。所有数据磁盘通过 NPIV 接口上的虚拟 Fibre-Channel 连接提供给客户机 LPAR。从磁盘配置和管理方面来说，这个模型让客户机 LPAR 管理员能够集中精力管理 OS 磁盘卷，而让 SAN 管理员集中精力管理数据卷。

本文的英文原文最先在 IBM Systems Magazine 在线网站（www.ibmsystemsmag.com）上发布。

参考链接：http://www.ibm.com/developerworks/cn/aix/systemmaga/5/powervm_disk_virtualization/index.html?ca=drs

Top


AIX 6.1 中的工作负载分区入门

AIX 6.1 中的工作负载分区入门

如果您是一名负责维护和使用 IBM System p 服务器的系统管理员，那么您可能对使用逻辑分区 (LPAR) 的虚拟化和服务器整合比较熟悉。使用硬件管理控制台（Hardware Management Console，HMC）或者集成虚拟管理器（Integrated Virtualization Manager，IVM），您可以迅速地定义新的 LPAR、安装 AIX或者 Linux、配置您的操作系统、安装各种应用程序，然后启动新的虚拟服务器。

AIX 6.1 引入了一种新的虚拟化机制：工作负载分区 (WPAR)。在本文中，您将了解有关 WPAR 的基础知识、它们与 LPAR 之间的不同之处，以及如何快速而方便地在您的 AIX 6.1 系统中尝试使用它们。本文还提供了根据经验获得的一些基本规则，以帮助您选择最适合于您的虚拟化方法，并分步指导您创建第一个 WPAR。然后，您将研究一些附加的生命周期管理任务，您可以通过 AIX 命令行或者系统管理界面工具 (SMIT) 来执行这些任务。因为本文的目的是提供概要性的介绍，所以您将看到相关信息的链接，这些信息可以帮助您了解这种新技术的所有技术细节。最后，您将回顾一些更高级的 WPAR 特性，包括使用一种新的管理工具 IBM Workload Partitions Manager for AIX（WPAR 管理器）实现动态应用程序迁移（将正在运行的、基于 WPAR 的应用程序从一个 AIX 系统迁移到另一个 AIX 系统的能力）。

什么是 WPAR 呢？

与 LPAR（在服务器的固件级别进行创建和管理）有所不同，AIX WPAR 是一些软件分区，这些分区由 AIX 操作系统的单个实例进行创建，并共享该实例的资源。这意味着，要创建 WPAR，您必须使用 AIX 6.1，但是您可以在所有支持 AIX 6.1 的 System p 硬件（包括 POWER4、POWER5、POWER6和POWER7 硬件）上创建 WPAR。您并不需要使用 HMC 或者 IVM 来创建或者管理 WPAR。

有两种类型的 WPAR：

.系统 WPAR

.应用程序 WPAR

系统 WPAR

系统 WPAR 是自主的虚拟系统环境，这些环境拥有它们自己的私有文件系统、用户和组、登录、网络空间和管理域。对用户和应用程序来说，系统 WPAR 看起来几乎和一个完整的 AIX 系统没有两样。它支持各种操作系统服务（如 telnet），因此，如果已经对网络信息进行了配置，那么用户就能够以 root 用户、或者任何其他已定义用户的身份，使用 telnet 连接到系统 WPAR、执行各种命令，以及运行各种应用程序，就像在任何其他的 AIX 系统中一样。

下面介绍了两个简单的示例，在这两种情况下，系统 WPAR 可能会很有价值：

.如果您是一位系统管理员，并且所管理的 AIX 系统是在一所大学的计算机科学专业的某个班级中使用，那么您可以为每位学生创建一个系统 WPAR。每个学生都可以是他们自已的私有虚拟环境中的 root 用户，他们可以定义用户、安装各种应用程序、编写程序完成他们班上的作业。如果让某个学生键入 rm –r *，以了解所发生的具体操作，那么将会发现，该操作仅仅只是破坏了他的 WPAR，一个 WPAR 中的灾难性事故不会危害到其他的 WPAR 或者全局 AIX 环境。在学期结束的时候，您可能会运行一个脚本，以删除并清空这个班上所有的 WPAR。

.如果您希望建立一个应用程序开发或者测试环境，那么您可以在系统 WPAR 中创建这个环境。您不需要使用一台专门的服务器或者 LPAR，但是如果这个新的环境出现严重的问题，那么任何负面影响将仅限于这个 WPAR。

应用程序 WPAR

应用程序 WPAR 为应用程序及其资源的隔离提供了一种相应的环境，以便在应用程序级别支持检查点、重新启动和重新部署。从本质上说，应用程序 WPAR 是一种对正在运行的应用程序或者进程所进行的包装，以实现隔离性和移动性。它不具备系统 WPAR 所提供的某些系统服务，例如，无法登录或使用 telnet 登录到应用程序 WPAR。当应用程序 WPAR 中所运行的应用程序终止时，这个 WPAR 也将终止并退出。如果您希望支持动态应用程序迁移（也就是说，如果您希望能够将正在运行的应用程序从一个 AIX 系统迁移到另一个 AIX 系统的时候），那么应用程序 WPAR 是最有价值的。您可能希望重新部署应用程序，以避免因执行计划的维护任务而造成的停机时间，或者通过将应用程序移动到一台功能更强大的服务器来提高性能。

WPAR 与 LPAR 有什么不同之处呢？

如前所述，与 LPAR 一样，您不需要访问 HMC 或者 IVM 来创建 WPAR。WPAR 是轻量级的环境，并且安装起来更便捷，因为它们在所处的系统中共享许多文件系统和全局 AIX 系统资源。在使用 LPAR 时，您需要安装完整的操作系统，而系统 WPAR 的创建仅需要安装少量文件系统的私有副本，并且应用程序 WPAR 甚至能够共享更多的全局系统资源。因此，可以在很短的时间内创建 WPAR，而无需使用任何安装介质。对于 WPAR 所进行的管理和维护，应该是比较简单的，因为只需要较少的 AIX 许可证，并且您不需要在诸多的虚拟系统中安装修复和更新程序。有一个命令可用于使用全局系统中相应的文件集来对 WPAR 的文件集进行同步，因此您可以选择将 AIX 修复程序传播到 WPAR、或者使用系统文件的当前版本继续运行。

LPAR 提供了工作负载的高度隔离性，而 WPAR 则可以为特定的工作负载，特别是临时工作负载（如开发或者测试环境），提供“足够的”隔离性。类似地，使用 LPAR，您可以对资源的使用进行更大的控制，例如，通过将整个处理器或者处理器的一部分精确地分配给 LPAR 来实现。对于使用 WPAR，您虽然无法在资源的分配上进行如此精确的控制，但是您可以将目标份额或者 CPU 使用率的百分比分配给一个 WPAR（如果已经使用了 AIX 工作负载管理器，那么您可能非常熟悉这种份额和百分比资源分配方案）。对于内存、进程数目和其他资源的分配，也存在着类似的区别。

WPAR 管理器

IBM Workload Partitions Manager for AIX（WPAR 管理器）是一种平台管理解决方案，它为在一组运行 AIX 6.1 的托管系统中管理工作负载分区提供了一个集中式的控制点。这些托管系统可以是位于同一个物理服务器中的 LPAR，也可以位于多个不同的物理服务器中。使用 WPAR 管理器，您可以监视多个托管的 AIX 系统中的多个 WPAR 的运行状况和状态。您还可以执行所有的基本 WPAR 生命周期操作，包括创建、查看和管理属性，以及启动、停止和删除。

WPAR 管理器还支持在一组托管服务器的系统中对 WPAR 进行重新部署。WPAR 管理器支持下面两种类型的重新部署：

.手工重新部署，这种类型的重新部署任务由用户发起。
.基于策略的重新部署，这种类型的重新部署由 WPAR 管理器发起，根据重新部署策略中所定义的工作负载条件进行重新部署。

WPAR 管理器并不是 AIX 中的一部分，它是一个需要单独购买的许可程序（程序编号为 5756-WPM）。但是，如果您正在使用 Open Beta Program 期间下载的 AIX 6 映像，那么您可能拥有该测试版中附带的 WPAR 管理器的早期版本。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-workload/

Top


IBM AIX 上工作负载分区(Workload Partition)管理的介绍

2007年发布的POWER6主机以及 AIX 6 有两个类似的新特性，但是他们是不完全相同的：工作负载分区（WPAR）移动性和 在线应用程序移动性（Live application mobility）。

.工作负载分区（WPAR）移动性：它是 AIX 6 和 WPAR 管理器的一个特性，可以在 POWER4，POWER5, POWER6和POWER7上实现。
.在线应用程序移动性（Live application mobility）：它是依靠于 POWER6 芯片的一个特殊功能，它只能在 POWER6的系统上实现，同时也可以在 AIX 5.3 LPARs（逻辑分区环境）下实现。

WPAR

对于大多数应用程序来说，WPAR 就好像是一个 AIX 的启动实例。通常，在 WPAR 中，应用程序无需修改就可以运行。

在 WPAR 中，应用程序：
.具有私有的执行环境
.与 WPAR 之外的其他进程、信号和文件系统隔离开来（文件系统的隔离仅仅适用于系统 WPAR）
.可能具有专门的网络地址
.具有进程间的通信，它局限于在同一工作负载分区中执行的进程。

在一个全局环境中，可能存在两种类型的工作负载分区。
.系统 WPAR —— 几乎是一个完整的 AIX 环境。
.应用程序 WPAR —— 适合于一个或者多个进程执行的轻型环境。

系统 WPAR

系统 WPAR 与典型的 AIX 环境非常类似。每个系统 WPAR 都拥有专门的、可写入的文件系统，尽管它可能采用只读模式共享全局环境 /usr 和 /opt 文件系统。在启动系统 WPAR 的时候，将为这个 WPAR 创建一个 init 进程，而由该进程生成其他进程和守护进程。例如，一个系统 WPAR 包含一个 inetd 守护进程，以便支持全部的网络容量，并允许以远程的方式登录到一个系统 WPAR。它还运行一个 cron 守护进程，以便能够对进程的执行进行调度。

应用程序 WPAR

如果可以使用 AIX 命令行接口的某个命令启动一个应用程序，或者一组应用程序，那么就可以由一个应用程序 WPAR 来承载它们。作为参数将这条命令传递给 wparexec 命令，它将创建一个应用程序 WPAR。所传递的这个命令退出之后，将终止该工作负载分区。

应用程序分区共享全局环境的文件系统。它并不拥有任何专门的存储。

应用程序分区可以运行守护进程。但是应用程序分区不会运行任何系统服务守护进程，如 inetd、srcmstr 等等。不能够以远程的方式登录到应用程序分区，或者以远程的方式执行应用程序 WPAR 中的操作。

在线应用程序移动性（Live application mobility）

对于工作负载分区的两种类型（系统 WPAR 和应用程序 WPAR），可以对其进行相应的配置，以支持迁移或重定位。

从一个 LPAR 迁移到另一个 LPAR，也可能是从一个物理系统迁移到另一个物理系统的能力，可以应用于处于活动状态的分区。在这种情况下，将对应用程序进行活动重定位（对其进行热迁移），而无需停止该应用程序。在对应用程序进行迁移的时候，用户所感觉到的只是该应用程序的响应时间可能稍微长一点。

工作负载分区的迁移使用检查点和重新启动特性来迁移工作负载分区。检查点可以保存应用程序的当前状态，然后在新的系统或者操作系统实例中，从先前保存的状态开始，重新启动它。

分区迁移并不能替代高可用性解决方案。其前提是在不中断应用程序的同时，允许按照计划将工作负载从一个系统迁移到另一个系统。这可能出现在对服务器进行硬件维护或者固件安装的情况下。通常情况下，工作负载并不需要了解迁移工作的存在。但是在将任何内容迁移到产品环境之前，我们建议进行适当的规划和测试。

图 1 描述了将 WPAR 重定位用于工作负载的平衡，其中在两个服务器之间对两个应用程序进行了迁移，以平衡这两个服务器的负载。

图 1

Global environment , System and Application WPARs

何时使用工作负载分区

工作负载分区提供了管理 AIX 环境的新的可能性。它们填补了用于 System p6 平台的其他虚拟化解决方案的不足。接下来的场景提供了一些示例，说明何时可以从 WPAR 的使用中受益。

服务水平协议的改进

可能需要对 IT 基础设施中的硬件组件进行维护操作，而这些维护操作需要关闭组件电源。如果应用程序不是提供持续可用性的服务器集群中的一部分（可能是因为技术、组织方面的原因，或者是因为成本的原因），那么 WPAR 可以帮助缩短该应用程序的停机时间。使用动态的分区迁移特性，可以将正在一台物理服务器中执行的应用程序临时迁移到另一台服务器中，而不会在执行服务器物理维护操作期间，出现应用程序中断。

遗留硬件投资的保护

尽管使用 POWER4 IBM Eserver pSeries服务器的客户无法利用物理的或者基于 Hypervisor 的虚拟化技术，但是 WPAR 技术仅仅依赖于 IBM AIX Version 6.1，而不依赖于任何基础硬件。可以在基于 POWER4、POWER5、POWER6和POWER7的服务器中使用它。

资源使用的优化

IBM System p 系列提供了许多通过虚拟化技术（如 LPAR、DLPAR 和微分区）以优化资源使用的方式。由于它所具有的独一无二的特征，WPAR 技术填补了现有解决方案功能的不足。因为 WPAR 具有迁移特性，所以可以根据一组服务器的整体资源，对服务器进行大小调整和规划，而无需在每台服务器中分别执行。可以将多个应用程序分配到一台服务器，直到使用其资源的 100%。

资源分配的细粒度控制

WPAR 技术提供了一种新的方式，以执行资源控制。WPAR 资源控制是工作负载管理器 (WLM) 技术的重用，但是采用某种方式对其进行了封装，即对于系统管理员来说，WLM 是不可见的。系统管理员不需要了解 WLM。通过 WPAR 命令行的选项和 SMIT 接口，可以实现资源的控制。

安全控制和权限命令

WPAR 技术支持角色的专门化，并且可以帮助将给予某个人的权限限制为他需要进行控制的范围。系统工作负载分区拥有它们自己的用户集，独立于在全局环境级别所定义的用户集。对于在系统工作负载分区中使用 root 的用户，他仅对这个 WPAR 中可见的资源拥有超级用户权限。他不能控制全局环境资源，如网络适配器或者物理设备，而且他不能对属于其他工作负载分区的资源进行操作。

软件栈的简化处理

WPAR 技术可以帮助系统管理员简化维护操作系统和应用程序软件栈的工作。它允许在多个应用程序之间共享一个 AIX 实例，并且使得各个应用程序运行于自己的环境中，从而在应用程序之间提供隔离性。在这种情况下，一个 AIX 实例中所整合的应用程序越多，系统管理员需要执行的操作系统修复应用程序、备份、迁移和其他操作系统维护任务就越少。然而，必须说明，这样的整合需要所有的应用程序运行在相同的版本和操作系统维护级之下。

应用程序操作系统环境的简化处理

可以在可阅读的规范文件中存储工作负载分区的配置。可以由现有工作负载分区中的操作系统生成这些规范文件，或者以手工的方式对这些规范文件进行编辑、创建或修改。如果在一个环境中，系统管理员必须管理多个应用程序环境，那么 WPAR 技术可以帮助他迅速地克隆和定义新的应用程序环境。

业务连续性：灾难/故障恢复

可以将 WPAR 技术作为解决方案中的一个元素进行集成，以提供业务连续性规划。 WPAR 的检查点特性允许捕获正在执行的应用程序的快照，而无需使用专门的代码。然后，将应用程序检查点映像保存到一个文件，稍后使用该文件恢复应用程序的执行。与应用程序数据的备份结合在一起，WPAR 检查点特性可以为那些没有使用其他解决方案（如 HACMP 或者服务器集群）的应用程序提供一种替代的灾难，或者故障恢复解决方案。

支持“绿色”计算策略

使用 WPAR 的动态应用程序重定位特性意味着，在使用率较低的情况下，您可以灵活地将一些工作负载整合到更少的操作服务器平台。在这个策略中，您仍然可以提供连续的应用程序可用性，但是只需要开启更少数量的服务器就可以完成这个任务。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/Introduction_wpar.html

Top


虚拟化实现经济高效的优势

当前环境下，成本压力在成长型企业中更为突出。而无节制的追求减少成本，是否真的能给企业带来稳定发展的生机?

现在，从以下您身边的困境中，或许可以找到解决方案：
.业务发展使得服务器数量快速增加，管理、维护、能源、人力及空间等成本急剧攀升；
.现有服务器系统利用率低，甚至只有 5%-10%；
.IT 基础架构无法随需部署和调配资源，不能灵活应对业务需求的变化。

如何规避无效的成本浪费，让 IT 真正成为提升业务价值的利器，从而最终实现成本减少，企业盈利提升？“虚拟化”就是最好的选择。近期调查显示，中国有超过 50%的用户已经或正计划采用虚拟化技术，56.9%认为其投资回报率超过 10%，94.7%对该技术持积极认可的态度。

您需要的是一个以合理的投资，来提升效率、降低成本，并能提高企业核心竞争力的方案。凝聚 IBM 40余年领先的虚拟化技术研发和实践经验的 IBM PowerVM 虚拟化解决方案 (PDF, 1.93MB)，能有效整合多个服务器和应用，优化 IT 资源和管理，从多层次减少总体成本，在关键业务层面灵活应对不断变化的市场需求。

让我们一起来看：某企业通过虚拟化成功使用一台中低端 IBM Power Systems 550 服务器，整合原有某友商的 9台 Unix 服务器所带来的无法估量的收益。

系统整合优化，节省总成本达 72%！ Minimise

.IBM 专为成长型企业打造了超值的易捷版虚拟化方案，以一台服务器的投入获得多台服务器的价值，同时节省高达 50%人员成本和 94%管理维护成本。而某友商的同级别产品不能提供虚拟化方案。

.IBM 虚拟化微分区(Micro-Partitioning)技术可将每 1个处理器的处理能力分到多达 10个虚拟的服务器，即不同的逻辑分区。而某友商产品不支持单一处理器分区资源共享和分区间 I/O 共享，虚拟化能效大打折扣。

.源自 IBM 大型机成熟的动态逻辑分区（Dynamic Logical Partitioning）技术，通过动态调配各分区资源到需要的地方，大幅提升利用率，并可降低高达 50%硬件需求和 92%软件授权使用费，今天 IBM Power 平台的低端产品也同样拥有此功能。

.IBM POWER6独有动态分区实时迁移(Live Partition Mobility)功能，可使多台服务器分享系统资源。通过整合不同服务器的工作负载，关闭不用的服务器，减少 89%耗能和 87%空间。

20年稳定可靠平台，业务损失成本降到最低！ Minimise

.支持非凡虚拟化功能的 IBM Power Systems 硬件平台在可靠性、可用性和可服务性(RAS)方面做了多项创新，拥有业界首屈一指的稳定性。例如采用 IBM 大型机独有的断点程序技术，令 CPU 出错几率骤降 30%，极大减少系统宕机。

.独有的动态分区实时迁移能动态将应用程序从一个服务器迁移到另一个服务器，使计划内停机成本为零。

10毫秒动态响应业务，赢更多商机，获更高利润！ Minimise

.虚拟化解决方案支持跨多个系统调配应用，从而优化整体资源，实现对新工作负载的适应性，确保对新业务需求的即时响应。

.IBM 虚拟化技术能以 10毫秒甚至更快的响应速度，规划新的操作系统映像。

.动态分区实时迁移可将工作负载从负载较重的服务器分区移动到空闲的服务器分区，以应对不断变化的工作负载和业务需求，并可以节省不必要的服务器资源的浪费。

.AIX 6.1的工作负载分区（Workload Partition）功能不仅方便资源调整，更可在不同 AIX 操作系统间进行切换，以响应业务变化。

参考链接：http://www-31.ibm.com/cn/express/migratetoibm/power/virtual/index.shtml#max

Top


看服务器虚拟化如何降低大成本

随着数据中心的不断扩展，那些应用单一的服务器正在给企业带来不断增长的成本压力。

全新的 IBM Power Systems，拥有业界最全面、最成熟的虚拟技术，在提供卓越可用性的同时，帮助企业大规模降低基础设施成本

Power 秘籍: 看服务器虚拟化如何降低大成本

.秘籍 1：最大化实现服务器整合，数据中心运作成本平均下降超过 72%！

PowerVM虚拟化技术可实现大规模服务器整合：单一整合的服务器性能相当于某些厂商 39台同级别服务器的效能总和，2台 Power 570 即可成功整合其它厂商 15台甚至 30台服务器，更能节省 86-94% 服务器维护成本、82-84% 软件支持成本，以及 36-50% 人员管理成本。

.秘籍 2：虚拟化对系统利用率的提高可高达 60%-80%！

与传统的服务器使用率只能达到 20% 相比，IBM Power 通过以下虚拟化技术，可显著提高利用率：

.微分区：微分区允许多个分区共享一组物理处理器的处理资源。一个分区可以以 1/10 的物理处理器资源来分配。微分区最主要的优点是通过自动分配每个分区需要的处理器资源而增加了整个系统资源的利用率。

.虚拟 I/O 服务器和虚拟 LAN 适配器：可同时运行多项应用软件，共享昂贵的磁盘，光学设备及通信和光纤通道适配器，降低复杂性和管理成本。

.多个共享处理池技术：最新开发的多个共享处理器池技术可在不中断业务的情况下，均衡分配处理能力，提高吞吐量并降低软件许可成本。

.共享专用容量：可以在保证某分区对专用CPU资源的绝对优先权的条件下，将空闲资源放置资源池中充分共享。

.秘籍 3：以最高效的资源部署，可节省能源开销高达 65%

据 IDC 分析，供电和冷却的费用相当于新增服务器费用的 50%，通过虚拟化技术，IBM Power 能够大规模降低服务器数量，从而降低能耗。

.秘籍 4：Power 虚拟化实时分区迁移技术创造零停机成本，整体宕机成本可降低 59%。

Power 的虚拟化技术独创了实时分区迁移（Live Partition Mobility, LPM）技术，能够将正在运行的分区不间断地从一台物理服务器移到另一台上，避免计划中和计划外的应用程序中断。这项技术大幅降低了单台设备宕机对整个系统的影响和迁移的高成本，更提高应用可用性，系统迁移过程中所造成的混乱将从此与您隔绝。

而某些其他产品则需要对 UNIX 系统和应用中断性重启，造成业务的中断。

Virtualised SAN and Network Infrastructure

在全新 IBM Power Systems 平台上，已针对各个行业、不同规模的企业量身推出了 IBM system Power 570 和 IBM system Power 550 等多款 UNIX 服务器产品，随时满足您的不同应用。

IBM 已帮助千余用户实现了从其他平台向 Power Systems 的顺利迁移。现在您还有机会因此获得价值一万美元的 IBM 服务器迁移服务。

参考链接：http://www-31.ibm.com/systems/cn/dihub/products_innovation/power_advantage/opendooredm.shtml

Top


目录 Power虚拟化相关技术介绍

Power虚拟化相关技术介绍

PowerVM 和 POWER7 处理器

IBM 动态分区迁移(Live Partition Mobility)技术-概述

PowerVM 新特性 - Active Memory Sharing 入门

PowerVM 新特性 - Active Memory Sharing 的计划

Active Memory Sharing 与双 Virtual IO Server 和 Live Partition Mobility

IBM PowerVM Workload Partitions Manager for AIX, Version 2.1

IBM Linux for Power 安装工具包 PowerVM Lx86 原理及应用

用 VMControl V2.2 优化 Power Systems

在 PowerVM 环境中使用 IBM Systems Director VMControl V2.1 简化 AIX 映像管理


PowerVM 和 POWER7 处理器

大多数人都听到过很多关于 IBM 新的 45nm 芯片 POWER7 的消息，比较了解它的功能创新。这些创新包括一个新的产品系列（POWER7服务器系列）和动态能源优化功能，它们让用户能够使用 IBM EnergyScale技术节约服务器本身的能源消耗。POWER7 处理器现在还可以提供 8 个处理器核，这是基于 POWER6 处理器的老式服务器的 4 倍，一个核每个线程能够执行4个任务。

与此同时，大多数人也应该熟悉 PowerVM 的特性，包括微分区、虚拟 I/O 服务器（VIO）、集成虚拟化管理器、共享专用处理能力、多个共享处理器池、活动分区移动性，以及 N Port ID 虚拟化和虚拟磁带等不太广为人知的特性。PowerVM 的创新和改进对于 POWER7 有哪些意义呢？本文将讨论这个问题。

改进微分区

POWER6 芯片和 PowerVM 的一般功能支持每个核 10 个分区，最大限制是每台服务器 254 个分区。目前最高端的 Power 780 可以支持最多 64 个 POWER7 核，即支持最多 640 个分区。通过今年晚些时候将进行的 Power 590 替换，POWER7 处理器最终能够扩展到最多 1000 个分区。

TurboCore

这个模式动态地选择最好的线程化方法，可以是采用两线程形式的 SMT 或每个核 4 个线程。这是一种新型的智能的线程化技术，它会根据应用程序的需求动态地切换处理器线程化模式，从而提供最高的每线程性能或最大应用程序吞吐量。这里有一个需要权衡的因素：每个核的线程多有利于并行处理，而线程少能够提高单一处理流的性能。

这个特性还有助于工作负载优化。Power 780 的主要特性之一是 TurboCore 技术，这种技术允许用更少的核运行系统，从而利用芯片上的其他核增加缓存。在 TurboCore 模式下，任何 POWER7 系统的最高时钟频率都可以达到 4.1 GHz。

Active Memory 扩展

这个特性有助于更有效地管理内存。有效处理能力可以超过系统上安装的内存。它使用内存内数据压缩增加可以放在内存中的数据量，这会提高 POWER7 系统的总处理能力。系统本身管理数据压缩，这个过程对于应用程序是完全透明的。还可以为受管理系统上的每个 LPAR 配置此特性；这意味着可以只在重要的 LPAR 上启用它。启用之后，OS 压缩 LPAR 内存，内存的其余部分保持未压缩状态。因此有两种池：压缩的和未压缩的。AIX 会根据工作负载利用率和 LPAR 配置动态地分配内存。

VMControl

VMControl 是一个与 IBM Systems Director 和 VMControl Image Manager 结合使用的跨平台解决方案，它帮助用户通过部署虚拟用具创建虚拟服务器。这个软件是 IBM Systems Director 的虚拟化插件，现在可以在 POWER7 服务器上用它管理虚拟化。可以在共享的存储库中创建随时可以运行的虚拟映像；可以按照管理 LPAR 的方式创建和管理系统池（在标准版中），系统池实际上是虚拟映像的集合，可以在多台服务器上运行这些映像。可以使用一个指示板作为整体管理数据中心资源。VMControl 可以自动执行虚拟基础设施管理、提高工作负载弹性（高可用性）和减少虚拟服务器的部署时间。VMControl 提供全企业范围的服务器、存储、网络和软件管理平台。安装之后，VMControl 集成在基于浏览器的 Systems Director 界面中，可以用它管理 Systems Director 基础设施中已有的系统。

VMControl 还支持系统池等重要功能。它可以简化虚拟服务器管理，提高业务工作负载弹性，甚至有助于在 Power Systems 服务器上实现云计算。

创造历史

总之，新的 PowerVM 创新使 PowerVM 成为最先进的虚拟化技术。UNIX 或 x86 环境中的任何其他技术都无法与之相比。IBM 会继续在虚拟化领域保持领先，延续其长达 40 年的虚拟化发展史。

参考链接：http://www.ibm.com/developerworks/cn/aix/systemmaga/4/powervmandpower7/index.html

Top


IBM 动态分区迁移(Live Partition Mobility)技术-概述

动态分区迁移 (Live Partition Mobility) 允许您将正在运行的 AIX 和 Linux 分区，以及它们所承载的应用程序从一个物理服务器迁移到另一个物理服务器，而不会对基础服务产生任何影响。这项迁移操作只需要花费几秒钟的时间即可完成，可以维护整个系统事务的完整性。这项迁移操作将传输整个系统环境，包括处理器的状态、内存、附加的虚拟设备，以及连接的用户。

IBM System p 系统旨在提供行业中最高的独立可用性。对于一些企业来说，有时候必须重组它们的基础设施，以满足新的 IT 需求。通过允许将正在运行的生产应用程序从一个物理服务器移动到另一个物理服务器，动态分区迁移允许对系统（以及您的用户）进行无干扰的维护或者更改。这减轻了以前由于临时需要关闭系统而对分区和应用程序所导致的影响。

现在，即使是小型的 IBM System p 服务器通常也都会承载许多逻辑分区。随着所承载分区数目的不断增长，要找到一个可以为所有分区所接受的维护窗口也变得越来越困难。动态分区迁移允许您对分区进行移动，这样一来，您就可以在最适合的时候（而不是在给用户带来最少不便的时候），在计算机上执行先前会产生影响的操作。

动态分区迁移可以帮助您满足越来越严格的服务水平协议 (SLA)，因为它允许您主动地将正在运行的分区和应用程序从一个服务器移动到另一个服务器。

将正在运行的分区从一个服务器移动到另一个服务器的能力，为您提供了平衡工作负载和资源的能力。对于一个重要应用程序的资源需求，如果出现了意料之外的峰值，并且同时出现了对服务器资源的争用，那么您可以将它移动到一台更大的服务器，或者将其他的、不重要的分区移动到不同的服务器，并使用所释放的资源来满足这个峰值。

动态分区迁移还可以作为一种服务器整合机制来使用，因为它提供了一种简便的方法，以便将应用程序从单独的、独立的服务器移动到整合服务器。如果对于某些分区中的工作负载，其资源需求在一段时间内出现较大范围的波动（例如，在月末或者季度末出现峰值工作负载），那么您可以在非峰值时期，使用动态分区迁移将这些分区整合到一个服务器中，这样一来，您就可以关闭不使用的服务器。然后在峰值到来之前，再将这些分区移动到它们自己的、经过充分配置的服务器中。通过在非峰值时期，减少运行计算机所需的电能,以及使它们保持冷却所需的电能，这个方法还可以节省能量。

动态分区迁移可以实现自动化，并集成到系统管理工具和脚本中。对多个并发迁移的支持允许您快速地转移某些系统中的工作负载。对于单个分区、指定时间点的迁移，HMC 提供了一个易于使用的迁移向导。

动态分区迁移有助于实现连续的可用性目标。它可以实现下列功能：
.通过动态地将应用程序从一个服务器移动到另一个服务器，可以减少计划停机时间。
.通过允许您将工作负载从负载较重的服务器移动到具有空闲容量的服务器，可以应对不断变化的工作负载和业务需求。
.通过允许您简单地整合工作负载，并关闭不使用的服务器，可以减少能量的消耗。

动态分区迁移将是 IBM System p 虚拟化连续性架构中的下一个重要亮点。它可以和其他虚拟化技术（如逻辑分区、动态工作负载分区和 SAN 卷控制器）相结合，以提供一个全面虚拟化的计算平台，该平台提供了当今生产数据中心所需的系统和基础设施的灵活程度。
简介
分区迁移操作既可以在关闭某个分区的时候（非活动状态）执行，也可以在某个分区正在提供服务的时候（活动状态）执行。

在活动分区迁移期间，不会对系统操作或者用户服务产生任何影响。例如，可以将承载动态生产数据库（包含常规的用户活动）的分区迁移到另一个系统，而不会损失任何数据和连接性，也不会对正在运行的事务产生任何影响。

逻辑分区可以在两个基于 POWER6的系统之间进行迁移，假设目标系统具有足够的资源来承载该分区。对于非活动迁移、或者活动迁移来说，在处理单元或者分区内存大小方面都没有任何限制。

跨系统的灵活性是必需的

在设计和部署信息技术解决方案的时候，基础设施的灵活性已经成为一项重要的标准。应用程序需求经常发生变化，使得它们所依赖的硬件基础设施必须能够在很短的时间内适应新的需求，但应该尽可能对服务级别产生最少的影响。必须采用一种非常简单和安全的方式来应用配置更改，无需管理员进行过多的干预，以减少变更管理的成本，并降低相关的风险。

基于 POWER5 的系统中所引入的高级 POWER虚拟化特性，在每个系统的内部都提供了极好的灵活性。处理器容量的虚拟化和内存的合理分布，再加上网络和磁盘的虚拟化，可以使管理员在单个系统中创建多个细粒度的逻辑分区。可以根据实际的应用程序需求，自动地、实时地在多个分区之间分布计算能力，而不需要用户进行任何操作。由基于策略的控制，或者由管理员使用非常简单和安全的操作来完成系统配置的变更，这些操作不会对服务造成中断。

尽管单个系统的虚拟化极大地改善了 IT 解决方案的灵活性，但是，客户的服务需求常常要求对整个基础设施具有比较全面的认识。在许多情况下，将跨多个系统对应用程序进行分布，从而确保全局系统资源的隔离、优化和基础设施对新的工作负载的适应性。

在复杂的环境中，最耗时的活动之一是，将工作负载从一个系统传输到另一个系统。进行这样的迁移可能有很多种原因，例如：
.资源平衡
对于某个工作负载来说，一个系统没有足够的资源，而另一个系统具有足够的资源。
.新系统的部署
必须将正在现有系统中运行的工作负载迁移到新的、功能更强大的系统中。
.可用性需求
当一个系统需要进行维护时，它所承载的应用程序是不允许停止的，可以将它们迁移到另一个系统中。

如果没有提供迁移分区的方法，那么所有的这些活动都需要经过认真规划，由技术娴熟的人员来执行，并且这些活动常常会导致很长的停机时间。在某些情况下，SLA 可能会相当严格，以致于无法允许实施计划的停机。

动态分区迁移就是解决这一问题的答案

基于 POWER6 的系统所提供的动态分区迁移专门用于将整个逻辑分区从一个系统迁移到另一个系统。动态分区迁移使用了一种简单的自动化过程，该过程可以将配置从源系统传输到目标系统，而不会影响它所承载的应用程序，以及操作系统和应用程序的设置。

动态分区迁移使得管理员可以更好地对数据中心中资源的使用进行控制。它允许在一定程度上实现重新配置，而这在过去是无法实现的，可能是由于非常复杂、或者仅仅因为服务水平协议不允许为了体系结构变更而停止应用程序。这种迁移过程只能在关机状态或者动态分区中执行。有两种可供使用的迁移类型：

非活动迁移——关闭逻辑分区，并将其移动到目标系统中。
活动迁移——在提供服务的同时执行分区的迁移，而不会影响用户的活动。

非活动迁移

非活动迁移将一个处于关闭状态的逻辑分区的定义及其网络和磁盘的配置，从一个系统移动到另一个系统。不需要对网络或者磁盘设置进行额外的更改，并且在迁移完成后就可以激活这个分区。

非活动迁移过程将负责有关系统的重新配置。
.使用与源系统中相同的配置，在目标系统中创建一个新的分区。
.保存网络访问和磁盘数据，并使其可以用于新的分区。
.在源系统中，将删除该分区的配置，并释放所有相关资源。

如果一个系统由于计划维护而停机，或者因为其他的原因而停止服务，那么就可以执行非活动迁移。它以一种受控的方式执行，并且只需要最少限度的管理员交互，这样一来，就可以在很短的时间内安全地、可靠地执行非活动迁移。

如果该分区所提供的服务不能中断，那么可以通过使用活动迁移的特性对其进行重新部署，这样就不会对服务造成任何影响。

活动迁移

使用活动迁移，可以将一个正在运行的分区从源系统移动到目标系统，而不会影响分区操作或者用户服务。

除了在该过程期间，不停止操作系统、应用程序和它们所提供的服务之外，活动迁移所执行的操作与非活动迁移相同。逻辑分区的物理内存内容从一个系统复制到另一个系统，这使得用户几乎感觉不到所进行的传输。

在活动迁移期间，应用程序继续处理它们的正常工作负载。可以对磁盘数据事务、正在运行的网络连接、用户上下文和完整的环境进行没有任何损失的迁移，并且可以在任何时间对任何生产分区进行迁移。

在分区的计算和内存配置方面没有任何限制，并且可以并发地执行多个迁移。非活动迁移和活动迁移可以处理各种分区，这些分区可以具有任何处理单元和内存大小配置。

体系结构

动态分区迁移需要特定的硬件基础设施。其中包括几个平台组件。

硬件基础设施

要进行逻辑分区迁移，需要满足以下几项要求：

.由相同的硬件管理控制台 (HMC) 所控制的两个基于 POWER6 的系统。

支持可选的、冗余 HMC 配置。

.目标系统必须具有足够的 CPU 和内存资源，以承载移动分区（正在运行的分区配置文件，因为可能存在备选的生产配置文件）。

.移动分区的操作系统、应用程序和数据必须存储于外部存储子系统的虚拟存储中。

.移动分区不能使用任何物理适配器。

.必须使用一个或者多个虚拟 I/O 服务器对移动分区的网络和磁盘访问进行虚拟化。
.两个系统中的虚拟 I/O 服务器必须具有一个共享的以太网适配器，并且配置为连接到与该移动分区相同的以太网网络。
.两个系统中的虚拟 I/O 服务器必须能够提供对该移动分区正在使用的所有磁盘资源的虚拟访问。

动态分区迁移需要特定的硬件和微码配置（目前仅在基于 POWER6/7 的系统中是可用的）。

执行迁移的过程将识别源系统中移动分区的资源配置，然后对源系统和目标系统进行相应地重新配置。因为硬件配置的重点是 HMC，所以对其进行了增强，以协调迁移分区的过程。必须使用相同的 HMC 来管理这两个系统。

在迁移期间，移动分区的配置不会发生任何变化。目标系统必须能够承载该移动分区，并且在开始迁移之前，必须具有足够的空闲处理器和内存资源，以满足该分区的需求。对移动分区的大小没有任何限制；它甚至可以使用源系统中由虚拟 I/O 服务器所提供的所有资源。

操作系统和应用程序数据必须存储于源系统的外部磁盘中，因为在完成到目标系统的迁移之后，移动分区的磁盘数据必须是可供使用的。因此，需要外部的、共享的访问存储子系统。

该移动分区不能拥有任何物理适配器，并且必须使用虚拟 I/O 服务器进行网络和外部磁盘访问。支持对使用多个虚拟 I/O 服务器的分区进行迁移。

因为移动分区的外部磁盘空间必须可用于源系统和目标系统中的虚拟 I/O 服务器，所以您不能使用存储池。每个虚拟 I/O 服务器都必须使用物理磁盘（而不是逻辑卷）来创建虚拟目标设备。

必须在激活分区迁移任务之前建立虚拟网络连接，同时通过迁移过程执行虚拟磁盘设置。

源系统和目标系统必须具有合适的、共享以太网适配器的环境，以承载正在进行移动的分区。源系统中移动分区正在使用的所有虚拟网络都必须能够作为目标系统中的虚拟网络使用。

在 VIOS 中，由 PVID 所定义的 VLAN 在服务器的范围之外没有任何意义，因为所有数据包在桥接时都是不带标记的。CEC 1 中的 VLAN 1 属于 192.168.1 网络的一部分，而 CEC 2 中的 VLAN 1 属于 10.1.1 网络的一部分，这种情况是可能的。

因为两个网络都是可能的，所以您不能确定 VLAN 1 是否存在于两个服务器中。您必须检查在这两个服务器中，VLAN 1 是否映射到相同的网络。

图 1 显示了支持动态分区迁移的基本硬件基础设施。每个基于 POWER6 的系统都经过了配置，具有一个虚拟 I/O 服务器分区。移动分区只能对网络和磁盘资源进行虚拟访问。目标系统中的虚拟 I/O 服务器连接到相同的网络，并配置为访问与移动分区所使用的相同的磁盘空间。为了进行说明，将所有设备的编号都显示为零，但在实际中，它们可能会有很大的区别。

图 1 支持动态分区迁移的硬件基础设施

该迁移过程将在目标系统中创建一个新的逻辑分区。这个新的分区使用目标系统的虚拟 I/O 服务器，以访问相同移动分区的网络和磁盘。在活动迁移期间，将复制移动分区的状态，如图 2 中所示。

图 2 迁移期间的移动分区

当迁移完成之后，不再将源虚拟 I/O 服务器配置为提供对外部磁盘数据的访问。设置目标虚拟 I/O 服务器，以允许移动分区使用该存储。最终的配置如图 3 中所示。

图 3 完成迁移之后的最终配置

相关组件

动态分区迁移功能将更改两个相关系统的配置，并且对于活动迁移，将对迁移进行管理，而不中断由正在移动分区中运行的应用程序所提供的服务。

迁移管理器功能位于 HMC 中，并且负责两个系统的配置。它负责检查是否满足所有的硬件和软件先决条件。在向用户提供迁移状态的同时，它在两个系统中执行所需的命令，以完成迁移工作。

当执行非活动迁移的时候，HMC 将引起两个系统中的配置更改。在活动迁移期间，在迁移过程中将传输移动分区的运行状态（内存、寄存器等等）。

将活动迁移的内存管理分配给每个系统中的移动者服务分区（mover service partition ）。在活动分区迁移期间，源移动者服务分区从源系统中提取移动分区的状态，并将其通过网络发送到目标移动者服务分区，该分区则更新目标系统中的内存状态。

任何虚拟 I/O 服务器分区都可以配置为移动者服务分区。

动态分区迁移在移动分区的内存大小，或者连接到移动者服务分区的网络类型方面，都没有什么特定的需求。在内存传输的过程中，不会中断移动分区的活动，并且在低速网络中，如果涉及到大量的内存配置，那么该过程可能比较费时。我们建议使用较高带宽的连接，如千兆以太网。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/live-mobility/

Top


PowerVM 新特性 - Active Memory Sharing 入门

Active Memory Sharing 是 IBM PowerVM 的高级内存虚拟化技术，向 IBM Power Systems 提供系统内存虚拟化功能，允许多个逻辑分区共享公共的物理内存池。

IBM Power System 的物理内存可以按专用模式或共享模式分配给多个逻辑分区。

.系统管理员能够将一些物理内存分配给一个逻辑分区，将一些物理内存分配给一个由其他逻辑分区共享的池。

.单个分区可以具有专用或共享的内存。

。专用模式（Dedicated mode）

IBM Power System 平台已经支持专用内存模式多年了。在逻辑分区之间优化可用内存的分布是系统管理员的任务。如果某个逻辑分区的性能受到内存约束的影响，其他逻辑分区具有未使用的内存，那么管理员可以手动做出反应，即发出一个动态内存重新配置命令。重新配置又受到自由内存可用性和管理员的反应时间的支配。

。共享模式（Dedicated mode）

使用共享内存模式时，由系统自动决定物理内存到逻辑分区的最佳分布，基于内存页需求调整内存分配。管理员只为共享内存池保留物理内存，给内存池分配逻辑分区。

Active Memory Sharing 可以用来提高系统的内存利用率，方法是降低系统内存需求，或者允许在现有系统上创建额外的逻辑分区。

本文主要介绍 Active Memory Sharing 技术，还会简要介绍组件和功能。

系统要求

为了使用 IBM PowerVM 的 Active Memory Sharing 特性，需要满足以下最小要求：
.一台基于 POWER6/POWER7处理器的 IBM Power System 服务器
.企业版 PowerVM 处于激活状态
.固件级别 340_075
.针对 HMC 管理系统的 HMC 版本 7.3.4 服务包 2 (V7R3.4.0M2)
.针对 HMC 和 IVM 管理系统的虚拟 I/O 服务器版本 2.1.0.1-FP21
.AIX 6.1 TL 3
.Novell SuSE SLES11

注意：要获得有关 Linux 支持的最新信息，请参见以下资源：
.IBM PowerVM Active Memory Sharing Performance
ftp://ftp.software.ibm.com/common/ssi/sa/wh/n/pow03017usen/POW03017USEN.PDF
.Using Active Memory Sharing on SLES11
http://www.ibm.com/developerworks/wikis/display/LinuxP/Using+Active+Memory+Sharing+on+SLES11

专用内存和共享内存

一台 IBM Power System 服务器上可以有多个独立的操作系统，每个系统使用一部分系统资源。操作系统运行在一个逻辑分区中，该分区只能够访问系统管理员配置的资源（比如处理器、内存和 I/O）。

系统资源可以专用于单个逻辑分区，也可以在一组逻辑分区之间共享。具体的选择取决于几个考虑因素，比如性能期望、整体资源优化和成本。通常，单个系统既配置有专用资源，也配置有共享资源。

逻辑分区对其所有的专用资源具有独占的访问权限。该设置在资源访问时间上也许有性能优势，但是失去的是高度依赖于逻辑分区负载的资源利用率。在服务器上，可能有些逻辑分区的专用资源负担过重，导致性能降低，而其他一些逻辑分区的资源则基本上没怎么用。

资源共享允许多个逻辑分区在 hypervisor 的控制下访问相同的资源，hypervisor 的作用是监视负载、应用分配规则以及分时访问资源。单个逻辑分区将共享资源看作自己对其具有完全的访问权限。由 hypervisor 管理实际访问，避免冲突或抵触，并允许访问那些具有最高资源需求的逻辑分区。

例如，PowerVM 的 Micro-Partitioning 特性被广泛用于共享处理器。管理员可以定义一个物理处理器池，逻辑分区可以创建为具有一组虚拟处理器和池访问规则。系统 hypervisor 根据访问规则和所有逻辑分区的负载，将物理处理器分配给虚拟处理器一段时间。分配对于给虚拟处理器（就好像是物理处理器一样）分配线程的操作系统是透明的。

PowerVM 的 Active Memory Sharing 特性允许系统内存的共享。除了传统的向单个逻辑分区分配专用内存之外，管理员还可以创建在一组逻辑分区之间共享的内存池。

系统中的每个逻辑分区可以配置为具有专用内存或共享内存，如图 1 所示。

图 1. 共享和专用内存逻辑分区

图 1. 共享和专用内存逻辑分区

专用内存分区具有根据其配置而保留的系统内存。内存大小是系统逻辑内存块大小（logical memory block size）的倍数（16、64、128 或 256 MB），内存只要一激活就会全都分配给逻辑分区。

共享内存分区被配置为具有是系统逻辑内存块大小倍数的逻辑内存空间，但是物理内存是由 Power Hypervisor 基于逻辑分区的运行时内存需求从共享内存池分配的。内存分配具有非常好的粒度，这取决于 hypervisor 的页大小，当前是 4 KB。

Active Memory Sharing 允许内存资源的过量使用（overcommitment）。由于逻辑内存根据逻辑分区的内存需求而与物理内存匹配，所以，所有逻辑分区的逻辑内存之和可以大于共享内存池的大小。

每个逻辑分区被允许使用所有分配的逻辑内存。当物理内存的累积使用达到池的大小时，hypervisor 可以透明地从共享内存分区窃取内存并分配给另一个共享内存分区。如果删除的内存页包含数据，那么数据将被存储到分页设备上，内存页内容在分配给另一个逻辑分区之前被清除。如果新分配的页包含数据，那么数据将从磁盘设备还原。

由于分页磁盘活动具有逻辑内存访问时间方面的成本，所以 hypervisor 跟踪内存使用情况，以窃取在近期可能不会用到的内存。共享内存分区的操作系统通过提供关于页面使用情况的线索以及释放内存页而与 hypervisor 合作，以限制 hypervisor 分页。

共享内存池

为 Active Memory Sharing 特性启用的系统可以配置为具有单个共享内存池。池是使用 Hardware Management Console (HMC) 或 Integrated Virtualization Manager (IVM) 创建的。

共享内存池是由 hypervisor 作为一个整体管理的一组物理内存块。池中的内存是在创建池时保留的，不能够再分配给其他专用内存分区。为了由共享内存分区独占使用，共享内存池直接由 hypervisor 管理。

例如，在具有 16 GB 实际内存的系统上，可以创建一个 10 GB 的共享内存池。剩下的 6 GB 内存将用于创建专用内存分区。用于共享内存池的 10 GB 内存马上被保留下来，即使没有定义或激活共享内存分区。

通过使用 HMC 或 IVM 界面，共享内存池的大小可以随时动态更改。池最大可以增大到可供逻辑分区使用的最大系统内存，最小可以减小到给专用内存分区提供额外的内存。

如果没有活跃的共享内存分区，池也可以动态地被删除，但是这样会阻止已定义的共享内存分区再次以共享内存模式被激活。

共享内存池配置需要定义一组分页设备，用于将多余的内存页存储到临时存储设备上。对与共享内存分区相关的分页设备的访问权限由同一系统上的分页虚拟 I/O 服务器提供。在创建池时，必须确定将给池提供分页服务的分页虚拟 I/O 服务器。

每个共享内存分区都需要一个专用的分页设备才能启动。分页设备是在共享内存分区被激活时、基于逻辑分区的最大逻辑内存配置的可用性和大小而选择的。如果没有适合的分页设备可用，那么激活操作将会失败，显示一条错误消息，指出所需的分页设备大小。

分页设备可以动态地从共享内存池配置被添加或删除。设备只有在其没有分配给任何正在运行的逻辑分区时才可以被删除。如果逻辑分区在设备删除之后被激活，那么将从可用的分页设备中选择一个新的设备。

如果系统中没有可用的共享内存池，则不可能定义任何新的共享内存分区。共享内存池一旦可用，它就可以最多支持 128 个共享内存分区。

分页虚拟 I/O 服务器

当 hypervisor 需要释放共享内存池中的内存页时，内存内容必须存储到一个分页设备上，以便数据在以后再次被访问时可以还原。此活动叫做分页活动，由共享内存池配置中为分页定义的虚拟 I/O 服务器来执行。

多个虚拟 I/O 服务器逻辑分区可以出现在一个系统上，并且可由单个共享内存池使用。分页虚拟 I/O 服务器必须配置为具有专用内存，因为它是在为池本身提供服务。

分页虚拟 I/O 服务器设计为最多处理 128 个共享内存分区。

当 hypervisor 决定必须执行分页活动时，它会发送一个请求到分页虚拟 I/O 服务器，将属于特定逻辑分区的特定内存页复制到相应的分页设备，或者从中复制出来。分页虚拟 I/O 服务器执行该动作，然后向 hypervisor 通知完成。同一时间可能会发出多个分页请求。

对于每个活跃的共享内存分区，都需要一个单独的分页设备，该设备可以是以下之一：
.逻辑卷
.本地附加存储器
.SAN 附加存储器
.iSCSI 附加存储器

选择分页设备时应该考虑设备可以提供的响应时间。当需要执行分页活动时，共享内存分区的逻辑内存访问时间取决于磁盘设备的响应时间，推荐使用高性能且可靠的设备。

注意：使用 Integrated Virtualization Manager (IVM) 时，自动创建的所有分页设备都是逻辑卷。因此，在考虑物理设备需求时应该记住这一点。物理卷可以手动地加以选择。

在 HMC 管理的系统中，用户最多可以给共享内存池分配两个分页 VIOS 分区，以提供对分页设备的访问。这种冗余分页 VIOS 配置改善了，出现计划内或计划外 VIOS 中断时共享内存分区的可用性。

有关配置共享内存池具有冗余分页 VIOS 分区的额外信息，可在 LPAR Configuration Guidelines 中找到。

享内存分区

一定义好共享内存池，就可以在系统中创建共享内存分区。逻辑分区为了被定义为共享内存分区，必须满足以下需求：
.使用共享的处理器。
.使用虚拟 I/O，包括以下适配器：
.虚拟以太网适配器
.虚拟 SCSI 适配器
.虚拟光纤通道适配器
.虚拟串行适配器
.运行在逻辑分区中的操作系统可以是 AIX、IBM i 或 Linux。
.最低 AIX 级别是版本 6.1 TL 03
.最低 IBM i 级别是版本 V6R1 PTF SI32798
.Novell SuSE SLES11

注意：有关 Linux 支持的最新信息，请参见以下资源：
.IBM PowerVM Active Memory Sharing Performance
ftp://ftp.software.ibm.com/common/ssi/sa/wh/n/pow03017usen/POW03017USEN.PDF
.Using Active Memory Sharing on SLES11
http://www.ibm.com/developerworks/wikis/display/LinuxP/Using+Active+Memory+Sharing+on+SLES11

通过修改其分区配置并以新的配置重新启动逻辑分区，现有的专用内存分区可以更改为共享内存模式。由于共享内存分区不允许专用的适配器，所以有必要进行正确的规划。

逻辑内存和物理内存

逻辑分区内存扇区的概要文件（profile）已经增强，允许选择专用内存或共享内存。分配给逻辑分区的内存然后被定义为专用内存或逻辑内存。

在共享内存分区中，两个参数定义了内存配置：

逻辑内存（Logical memory）

操作系统管理和可以访问的内存数量。使用中的逻辑内存页可能会由物理内存或池的分页设备备份。

内存权重（Memory weight）

由 hypervisor 用来区分从共享内存池向逻辑分区分配物理内存的优先次序的相对数值。较高的值增加更多物理内存被分配给逻辑分区的可能性。

跟专用内存分区一样，共享内存分区也具有最小、所需和最大内存配置值。对于共享内存分区，这些值控制分区的逻辑内存大小。当分区启动时，hypervisor 给它分配一个等于所需值的实际逻辑内存值。一个分区可以使用的物理内存数量受到为分区配置的逻辑内存数量的限制。例如，假设一个分区被配置为具有 10 GB 逻辑内存，那么分区可以使用的最大物理内存数量就是 10 GB，尽管分区实际使用的物理内存数量可能小于这个数值。

如果一个逻辑分区的内存需求随着时间而改变，那么就可能动态修改分配给它的逻辑内存的大小（假设满足最小和最大逻辑内存限制）。例如，一个具有 4 GB 逻辑内存的逻辑分区可能会宿主需要更多工作内存的附加应用程序：逻辑内存的大小然后可以增加到 8 GB，只要最大逻辑内存大小大于等于 8 GB 即可。

逻辑内存内容放置受 hypervisor 的控制，由它决定内容应该存储到物理内存中，还是存储到分页空间设备中。Hypervisor 通过向逻辑分区分配物理内存，以及使用分页虚拟 I/O 服务器在磁盘上存储一些逻辑内存，来管理共享内存池内容。

当属于共享内存分区的虚拟处理器引用一个物理内存页未备份的逻辑内存页时，将在 hypervisor 级别发出页失败，并且虚拟处理器被 hypervisor 挂起，从而释放它在使用的物理处理器。只有在 hypervisor 已经让被引用的页变得可用之后，虚拟处理器才会再次变得可运行。

Hypervisor 进行内存页窃取从操作系统角度是透明的，但是当 hypervisor 需要从页空间还原内存内容时，页窃取可能会增加内存访问时间。性能效果会因选择释放哪些页以及每个逻辑分区在访问多少内存而不同。

内存分类

为了整体优化共享内存的使用，hypervisor 和每个共享内存分区宿主的操作系统之间存在着协作。

操作系统知道逻辑内存页的重要性，并提供关于页使用情况的线索。它标记每个逻辑内存页，指出其有多重要，从而允许 hypervisor 区分页的优先次序，降低对共享内存分区性能的影响。

被借用页

借用过程（loaning process）可以改善 hypervisor 与每个操作系统之间的协作。不是仅仅执行页窃取，hypervisor 也请求释放一些逻辑内存页，而操作系统可以选择哪些页更适合于释放。通过借用页，操作系统减少了 hypervisor 的活动，改善了内存池的整体性能。

AIX 操作系统使得调优选择借用哪些逻辑页的算法成为可能。图 2 展示了一个例子，即 hypervisor 在给定时间所做的逻辑内存到物理内存的映射。共享内存分区拥有逻辑内存，并向 hypervisor 提供页使用情况分类（页线索）。物理内存的使用由 hypervisor 基于整个池的当前内存需求以及共享内存分区如何访问内存而独占地进行管理。

尽管 I/O 映射的页总是能分配到物理内存，但是所有其他页可能会被放置到物理内存中或者分页设备上。自由页和被借用页从共享内存分区的角度来看不具有内容，因而它们不需要复制到分页设备。

图 2. 逻辑内存到物理内存映射示例

图 2. 逻辑内存到物理内存映射示例

操作系统保留有逻辑内存和物理内存使用情况的统计数据，允许管理员监视共享内存分区的状态。具体来说，可以随时知道有多少物理内存在使用中，有多少自由内存处于被借用状态，与共享内存分区相关的 hypervisor 页失败数量，以及处理此类页失败所花费的平均时间。

注意：从用户空间应用程序的角度来看，Active Memory Sharing 的引入根本不需要任何更改，因为共享内存配置不影响应用程序的行为。只是内存访问时间相对于专用内存的访问时间来说可能会有改变，但是内存共享的优势会提高系统资源利用率，对 IT 基础设施是极为有利的。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/powervm-activememory/1/

Top


PowerVM 新特性 - Active Memory Sharing 的计划

.“Active Memory Sharing 前提条件”：快速概述部署 Active Memory Sharing 环境需要满足的所有前提条件。

.“部署考虑事项”： 讨论识别和选择适合配置 Active Memory Sharing 的工作负载的一些基本原则。

.“确定 Active Memory Sharing 的规模”：描述确定 Active Memory Sharing 环境规模的工具和过程。

Active Memory Sharing 前提条件

表 1 列出 Active Memory Sharing 需要的最低级别。
表 1.Active Memory Sharing 需求

组件

最低级别

注解

硬件

基于 POWER6 处理器的服务器

需要这个硬件级别是因为它提供启用 AMS 的机制。

管理的系统的固件

340_075

在 ASMI 主屏幕上检查这个级别。

PowerVM

Enterprise Edition

硬件特性代码，或启用 CoD 的特性。

  • HMC
  • IVM
  • 代码：V7R3.4 service pack 2
  • 与 Virtual I/O Server 相同
  • 在 HMC/IVM 主屏幕上检查
  • 使用 Updates 检查版本

Virtual I/O Server

2.1.1.10-FP-21

在 VIOS shell 中执行 ioslevel

AIX

6.1.3.0 TL 3

在 AIX 中执行 oslevel -s

IBM i

IBM i 6.1 + 最新的累积 PTF 包 + SI32798

在 IBM i 提示上执行 DSPPTF

Linux

Novell SuSE SLES11

针对 ESP 客户的提示：在 ESP (Early Ship Program) 期间，AMS 特性需要单独的激活码。

您的 ESP 计划协调人负责获取系统信息，生成并向您提供参与计划的每个系统的激活码。获得激活码之后，必须使用 HMC、IVM 或 ASMI 界面输入激活码。

除了激活 PowerVM Enterprise Edition 之外，ESP 协调人还会提供一套 VIOS 命令。必须把这些命令上传到 VIOS 上并执行以激活 AMS。

部署考虑事项

有了 Active Memory Sharing，就可以通过整合工作负载提高总体内存利用率。下面讨论识别这些工作负载所涉及的概念和基本规则，以及如何部署 Active Memory Sharing 环境。

过量使用

在 Active Memory Sharing 环境中，配置的逻辑内存量可以超过共享内存池中的物理内存量，这就可能导致过量使用（overcommitment）。

每个共享内存分区认为自己拥有更多内存，这会导致过量预订逻辑内存。

根据环境和工作负载，可能出现三种共享内存场景。

Non overcommit
共享池中可用的真实内存量足够多，超过了配置的逻辑内存总量。

Logical overcommit
在给定的时刻，正在使用的逻辑内存量等于共享内存池中的物理内存量。也就是说，配置的逻辑内存总量可以大于物理内存量，但是工作集不会超过物理内存量。

Physical overcommit
工作集内存需求可以超过共享池中的物理内存量。因此，逻辑内存必须由池中的物理内存和分页设备共同支持。

在发生过量使用时，Hypervisor 使用分页设备存储过剩的逻辑内存，它通过 paging Virtual I/O Server 访问分页设备。

工作负载选择

在选择要使用 Active Memory Sharing 部署的工作负载时，首先必须了解工作负载和它们的内存需求。一定要在一段时间内（天 / 周 / 月）在专有内存模式下监视工作负载高峰和低谷，从而适当地确定共享内存池的大小。

如果发现部署的一些工作负载不会达到其物理内存消耗上限，那么这些工作负载适合配置 Active Memory Sharing。另外，在选择工作负载时有一些要考虑的一般原则。

正如 “过量使用” 所述，在某些场景中可以过量使用内存。在选择工作负载时，需要同时决定内存配置。下面提供为各个场景选择合适的工作负载的一般规则。

Active Memory Sharing logical overcommit 适合于具有以下特征的工作负载：
.时间 “多元化” 的工作负载。例如，在 AM/PM 场景中，多个工作负载的高峰和低谷相互交错，因此可以采用 logical overcommit 方法，而不需要消耗超过池中物理内存量的内存。
.平均内存使用量需求低的工作负载，可以通过整合它们满足 logical overcommit。
.负载不稳定的工作负载，比如零售商总部和大学环境。
.故障转移和备用分区，它们用于提供冗余，只在主服务器停机时需要资源，冗余服务器不需要专有的资源。
.测试和开发环境。

Physical overcommit

Active Memory Sharing physical overcommit 适合于具有以下特征的工作负载：
.当前在 AIX 操作系统上运行并使用大量 AIX 文件缓存的工作负载。
.对 I/O 延迟不敏感的工作负载，比如文件服务器、打印服务器和网络应用程序。
.在大多数时候不活跃的工作负载。

Dedicated memory partitions （专有内存分区）

建议对于以下工作负载使用专有内存分区：
.服务质量要求高的工作负载。
.由于高峰负载稳定，内存使用量一直很高的工作负载。
.需要可预测的性能的工作负载。
.高性能计算工作负载，比如以科学计算为主的工作负载，它们保持很高的 CPU 利用率和内存带宽需求。

整合因素

“工作负载选择” 的说明选择了工作负载之后，必须考虑以下因素：
.为选择的工作负载设置合适的逻辑内存和物理内存比率。
.决定工作负载的共享内存权值，权值决定工作负载的优先级。
.根据内存比率，决定分页设备配置。如果比率高，就需要按照 “分页设备计划” 和后面部分中的“调优” 中的建议优化分页设备。
.在 physical overcommit 环境中，决定是否采用积极借用并确定应用程序借用级别，从而提供可接受的性能。借用级别是针对每个操作系统设置的。因此，在同一个系统中可以有多个借用级别共存。
.通过重新平衡资源优化利用率。即使系统的 CPU 和内存带宽利用率很低，物理内存也可能限制共享处理器分区的数量。

分页设备计划

Active Memory Sharing 分页设备的计划与操作系统分页设备并没有什么差异。

如果高性能是优先考虑的需求，那么在发生分页时，希望它尽可能快地执行。下面的配置建议有助于提高分页设备的性能和可用性：
.配置某种磁盘冗余，比如镜像或 RAID5。
.使用比较小的条带（stripe）。
.跨尽可能多的磁盘子系统硬件分散 I/O 负载。
.在适配器或存储子系统上使用写缓存。
.尽可能使用物理卷而不是逻辑卷。
.根据性能需要确定存储硬件的大小。
.在使用之前，确保清除 HMC 为分页设备的物理卷设置的 PVID。

确定 Active Memory Sharing 的规模

本节讨论用来确定 Active Memory Sharing 需求规模的一些模型。
确定 Virtual I/O Server 资源规模

应该像以前一样为 LPAR 配置 Virtual I/O Server 的标准磁盘和网络 I/O。建议使用 IBM Systems Workload Estimator 工具帮助确定 VIOS 的规模。
http://www.ibm.com/systems/support/tools/estimator/index.html

对于 Active Memory Sharing，Virtual I/O Server 扮演新的角色。如果把它指定为 paging Virtual I/O Server，还必须考虑存储子系统和分页速率。

表 2 为根据估计的分页速率和存储子系统类型估算每个共享内存分区的 CPU 占用提供指导。
表 2.根据活动量和存储类型估算的 CPU 占用需求

存储类型 | 内部存储 | 低水平存储 | 中等存储 | 高端存储
分页速率
低 | 0.005 | 0.01 | 0.02 | 0.02
中等 | 0.01 | 0.02 | 0.04 | 0.08
高 | 0.02 | 0.04 | 0.08 | 0.16

注意：分页速率越高，在 Virtual I/O Server 分区中发生的 I/O 操作就越多，因此处理器占用需求会增加。
图 1 以图形方式显示表 2 中的信息，说明这些值之间的关系。

图 1.支持 AMS 分页设备所需增加的 CPU 占用

图 1 支持 AMS 分页设备所需增加的 CPU 占用

例如，如果要部署五个共享内存分区，共享内存池分页设备采用中等存储解决方案，那么建议为 Virtual I/O Server 增加 (5 * 0.04) = 0.2 CPU 占用，这样当五个共享内存分区同时发生中等速率的 hypervisor 分页时，有足够的计算资源可以处理分页。

要点：为了提高性能，可以部署只用于执行 AMS 分页的 VIOS，因此把分页 I/O 与其他 VIOS 功能（比如虚拟磁盘和虚拟网络 I/O）隔离开。在投入生产之前，建议对配置进行测试。

确定共享内存分区的 CPU 规模

与 Active Memory Sharing 相关联的大多数任务都会要求 hypervisor 消耗更多 CPU 周期。在过量预订内存配置中，CPU 使用量的增加取决于以下因素：
.对物理内存页面的访问速率
.物理内存与逻辑内存的比率
.磁盘访问的速率

如果没有过量使用内存，CPU 使用量的增加量是最低的，只有额外的虚拟化软件层消耗少量 CPU 周期。

注意：对于“确定 Virtual I/O Server 资源规模” 中讨论的分页操作，它们使用的 CPU 周期与专有内存分区中操作系统必须执行分页时消耗的周期差不多。

参考链接：http://www.ibm.com/developerworks/cn/aix/redbooks/powervm-activememory/3/

Top


Active Memory Sharing 与双 Virtual I/O Server 和 Live Partition Mobility

简介

通过配置 Active Memory Sharing 可以实现通常用虚拟 SCSI 或 Shared Ethernet 配置得到的同等可用性和灵活性水平。尽管 PowerVM 虚拟化层非常健壮，但是有时候仍然需要计划内停机，例如为了让环境处于最新的受支持的状态。使用双 Virtual I/O Server 配置，可以让一个 Virtual I/O Server 停止运行，同时保持共享内存分区在线。结合使用 Live Partition Mobility 和 Active Memory Sharing，可以灵活地把共享内存分区转移到另一个物理服务器。例如，如果希望重新平衡工作负载或者一个物理服务器要进行维护，动态地转移分区会非常有用。

本文的第一部分解释如何为 Active Memory Sharing 配置双 Virtual I/O Server。第二部分讨论结合使用 Live Partition Mobility 和 Active Memory Sharing。本文假设您基本了解 Active Memory Sharing 的概念。

Active Memory Sharing 与双 Virtual I/O Server

首先，必须有至少两个 Virtual I/O Server，它们的运行级别支持受管理系统上的 Active Memory Sharing。如果有两个以上的 Virtual I/O Server，只能把其中两个定义为分页 VIOS 分区。

要作为共用分页空间设备使用的磁盘必须是 SAN 上的完整物理磁盘。这些物理磁盘必须分配给两个分页 VIOS 分区。不能使用本地磁盘或划分为逻辑卷的磁盘作为共用分页空间设备。磁盘的保留策略属性必须设置为 no_reserve。实际上，在把磁盘配置为共用分页空间设备时，保留策略属性会自动地设置为 no_reserve。

在把分页空间设备添加到共享内存池中时，如果设备满足上述条件，会自动地识别为共用分页空间设备。

在同一个共享内存池中，可以同时有共用的和独立的分页空间设备。如果这样做，一定要确保共用分页空间设备数量与冗余的共享内存分区的数量匹配。

在定义共享内存池时，指定应该作为分页 VIOS 分区的两个 Virtual I/O Server。对于使用冗余分页 VIOS 分区的每个共享内存分区，一个 Virtual I/O Server 定义为主分页 VIOS 分区，另一个定义为从分页 VIOS 分区。正常情况下，由主分页 VIOS 分区提供分页功能。如果主分页 VIOS 分区停止运行或者执行手工切换，就向从分页 VIOS 分区执行故障转移。

为了平衡分页活动产生的 I/O 负载，可以为每个共享内存分区分别设置主和从分页 VIOS 分区。例如，如果有四个共享内存分区，可以让其中两个使用 Virtual I/O Server 1 作为主分页 VIOS 分区，另外两个使用 Virtual I/O Server 2 作为主分页 VIOS 分区。

分页设备选择

在激活共享内存分区时，会自动地选择合适的分页空间设备。如果共享内存分区使用冗余的分页 VIOS 分区，那么会分配共用的分页空间设备。如果没有共用的分页空间设备可用，分区就无法激活。在这种情况下，仍然可以通过在 HMC 命令行上使用带 --force 选项的 chsysstate 命令来激活分区，但是不可能执行故障转移。

如果激活一个没有配置冗余分页 VIOS 分区的共享内存分区，就分配独立的分页空间设备（如果可能的话）。如果没有独立的分页空间设备可用，Hypervisor 会分配共用的分页空间设备（如果可能的话）。在这种情况下，只使用一个分页 VIOS 分区，无法执行故障转移，尽管分页空间设备本身实际上能够提供冗余。

配置示例

下一节讨论一个为 Active Memory Sharing 配置双 Virtual I/O Server 的真实示例。图 1 给出目标配置的概况。受管理系统配置一个共享内存池，这个池有 2 GB 的真实内存。Virtual I/O Server lpar_1_solchio05 和 lpar_2_solchio06 配置为分页 VIOS 分区。对于共享内存分区 lpar_6_sotchax11，分页 VIOS 分区 lpar_1_solchio05 配置为主，lpar_2_solchio06 配置为从。物理磁盘 hdisk17 分配给这两个 Virtual I/O Server，所以它可以作为共用分页空间设备。它作为共享内存分区 lpar_6_sotchax11 的分页空间设备。

图 1. 示例配置

共享内存池配置

首先配置共享内存池。在 HMC 上，选择要创建共享内存池的受管理系统。然后，通过选择 Configuration > Virtual Resources > Shared Memory Pool Management 启动共享内存池向导。在定义分页 VIOS 分区时，选择两个 Virtual I/O Server。在图 2 所示的示例配置窗口中，lpar_1_solchio05 定义为 paging VIOS 1，lpar_2_solchio06 定义为 paging VIOS 2。

图 2. 创建共享内存池

窗口显示 paging VIOS 1 和 2 定义

在以后创建共享内存分区时，将默认使用这里定义的分页 VIOS 分区。在默认情况下，Paging VIOS 1 将作为主分页 VIOS 分区，Paging VIOS 2 作为从分页 VIOS 分区。但是，可以修改默认设置，为每个共享内存分区分别定义主和从分页 VIOS。

分页空间设备配置

接下来，选择分页空间设备。共用分页空间设备在 Redundancy Capable 栏中显示 True。在图 3 中的示例中，hdisk17 是共用分页空间设备。可以通过 Virtual I/O Server lpar_1_solchio05 和 lpar_2_solchio06 访问它。

图 3. 添加分页空间设备

屏幕显示选择了 lpar_1_solchio05 和 lpar_2_solchio06

使用 HMC 命令行配置共享内存池

如果希望使用 HMC 命令行创建共享内存池，应该使用清单 1 所示的 chhwres 命令。第一个 chhwres 命令创建共享内存池。第二个 chhwres 命令在共享内存池中添加分页空间设备。在使用 chhwres 命令添加共用分页空间设备时，只需要指定一个分页 VIOS 分区。HMC 会自动地识别出这个设备是冗余的并相应地配置它。在清单 1 中，lshwres 命令显示 hdisk17 是冗余的，但是 chhwres 命令只指定 lpar_2_solchio06 作为分页 VIOS 分区。

清单 1. 使用 HMC 命令行创建共享内存池

# chhwres -r mempool -m IBM_MMA_P6_102615A_SOLCHMS05\
-o a -a "pool_mem=1024,max_pool_mem=4096,\
\"paging_vios_names=lpar_1_solchio05,lpar_2_solchio06\""

# chhwres -r mempool -m IBM_MMA_P6_102615A_SOLCHMS05\
-o a -p lpar_2_solchio06 --rsubtype pgdev --device hdisk17

# lshwres -r mempool -m IBM_MMA_P6_102615A_SOLCHMS05 --rsubtype pgdev | sed 's/,/\n/g'
device_name=hdisk17
paging_vios_name=lpar_1_solchio05
paging_vios_id=1
size=40960
type=phys
state=Inactive
phys_loc=U789D.001.DQD21L0-P1-C1-T1-W5005076801203E85-L1B000000000000
is_redundant=1
redundant_device_name=hdisk17
redundant_paging_vios_name=lpar_2_solchio06
redundant_paging_vios_id=2
redundant_state=Active
redundant_phys_loc=U789D.001.DQD21L0-P1-C2-T1-W5005076801403E85-L1B000000000000
lpar_name=lpar_6_sotchax11

创建共享内存分区

在创建或更新共享内存分区概要文件时，可以在内存配置部分中找到选择分页 VIOS 分区的选项。图 4 给出一个示例。在默认情况下，Primary Paging VIOS 和 Secondary Paging VIOS 字段会预先设置为在配置共享内存池时指定的分页 VIOS 分区。可以在这里修改默认设置。例如，为了在两个分页 VIOS 分区之间平衡负载，可以为每个分区分别设置主和从分页 VIOS。如果修改了现有分区概要文件中的主/从设置，需要重新激活分区，修改才能生效。可以使用 chhwres 命令切换正在运行的分区的分页 VIOS 分区，稍后在 分页 VIOS 分区故障转移 一节中解释。

如果希望设置非冗余的分区，那么把 Secondary Paging VIOS 字段设置为 none。

图 4. 创建共享内存分区

窗口显示 lpar_1_solchio05 作为主分页 VIOS，lpar_2_solchio06 作为从分页 VIOS

分页 VIOS 分区故障转移

如果一个分页 VIOS 分区停止运行或者手工触发故障转移，就会从一个分页 VIOS 分区故障转移到另一个。故障转移对于共享内存分区是透明的。

执行故障转移之后，当原来的分页 VIOS 分区重新运行时，并不会自动地切换回来。如果希望恢复原来的主/从配置，可以手工切换受影响的分区的分页 VIOS。可以在 HMC 命令行上使用带 -so 选项的 chhwres 命令切换分页 VIOS 分区。这个功能不能通过 HMC GUI 使用。如果在两个分页 VIOS 分区都重新可用之后去活并重新激活共享内存分区，那么仍然使用分区概要文件中定义的主/从设置。

在 HMC GUI 中，激活的分页 VIOS 分区显示在分区属性的 Memory 选项卡中。在 HMC 命令行上，可以使用 lshwres 命令查看。

清单 2 演示如何显示和切换激活的分页 VIOS 分区。第一个 lshwres 命令显示分区 lpar_6_sotchax11 的激活的分页 VIOS 分区是 lpar_1_solchio05。可以在 lshwres 命令中使用 --filter 和 -F 选项限制命令的输出。然后，执行 chhwres 命令切换分页 VIOS 分区。在此之后，在 lshwres 命令输出中可以看到激活的分页 VIOS 分区已经变成了 lpar_2_solchio06。

清单 2. 切换分页 VIOS 分区

hscroot@sibwthmc01:~> lshwres -r mem -m IBM_MMA_P6_102615A_SOLCHMS05 --level lpar \
> --filter "lpar_names=lpar_6_sotchax11" \
> -F curr_paging_vios_name
lpar_1_solchio05

hscroot@sibwthmc01:~> chhwres -r mem -m IBM_MMA_P6_102615A_SOLCHMS05 \
> -p lpar_6_sotchax11 -o so

hscroot@sibwthmc01:~> lshwres -r mem -m IBM_MMA_P6_102615A_SOLCHMS05 --level lpar \
> --filter "lpar_names=lpar_6_sotchax11" \
> -F curr_paging_vios_name
lpar_2_solchio06

Active Memory Sharing 与 Live Partition Mobility

如果希望对共享内存分区使用 Live Partition Mobility，那么在目标服务器上必须有共享内存池和合适的可用的分页空间设备。目标服务器上共享内存池的大小不必与源服务器上的相同。

如果可能的话，在目标系统上保持被迁移分区的分页 VIOS 冗余配置。但是，在迁移向导中有修改分页 VIOS 配置的选项。图 5 显示可用的选项。可以把共享内存分区从采用冗余分页 VIOS 设置的服务器转移到只有一个分页 VIOS 分区的服务器。

图 5. 在迁移期间指定冗余选项

窗口解释分页 VIOS 冗余，显示需要分页 VIOS 冗余

在目标服务器上，迁移共享内存分区的效果与在共享内存池中添加新分区相同。根据共享内存池中的可用物理内存数量和正在运行的共享内存分区的内存需求，可能会重新平衡各个共享内存分区的内存分配。因此，当迁移完成时，在目标系统上分配给这个分区的物理内存量通常与源系统上分配的内存量不一样。

在迁移操作期间，换出到分页空间设备上的所有内存先被读入真实内存中，然后传输到目标服务器。因此，如果内存的很大一部分已经被换出了，那么迁移操作的持续时间会比较长。迁移操作完成之后，释放源服务器上的分页空间设备，可以供其他分区使用。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-activemem/index.html#resources

Top


IBM PowerVM Workload Partitions Manager for AIX, Version 2.1

关于 WPAR、WPAR Manager 和 IBM Systems Director 的背景知识

工作负载分区

AIX 工作负载分区 (WPAR) 是从 AIX 操作系统的单个实例创建的软件分区，它们共享该实例的资源。有两种 WPAR：

.系统工作负载分区：自治的虚拟系统环境，它们有自己私有的根文件系统、用户和组、登录、网络空间和管理域。大多数传统的系统服务在工作负载分区级上虚拟化，可以在每个 WPAR 中被独立地使用和管理。另外，我们可以为此类分区设置检查点和执行重新定位。
.应用程序工作负载分区：它们并不提供系统 WPAR 那样的高度虚拟化的系统环境。它们提供的环境用于隔离应用程序及其资源，支持应用程序级的检查点、重新启动和重新定位。
可以使用 mkwpar 和 chwpar 等 AIX 命令在 AIX 6.1 系统上创建、修改、启动、停止和删除 WPAR。

WPAR Manager

WPAR Manager 是一个系统管理应用程序，它提供一个基于浏览器的用户界面，用于在多个 AIX 系统上管理 WPAR。它支持在您的环境中的多个 AIX 6.1 系统上执行前面列出的基本 WPAR 生命周期操作。WPAR Manager 还支持 WPAR 的检查点和重新启动，以及在 AIX 系统之间动态地重新定位 WPAR。在以前的版本中，这个产品是使用 AIX 许可证的程序，可以安装在 AIX、Linux或 Windows服务器上。在 Version 2.1 中，这个产品已经变成了一个 IBM Systems Director 6.1 高级管理器，可以在与 Systems Director 相同的服务器上运行，可以在集成的用户界面中使用标准的 Systems Director 功能，比如系统发现、目录信息收集和自动的软件更新。必须注意一点：与以前的 WPAR Manager 版本不同，使用 WPAR Manager Version 2.1 要求您安装并熟悉 IBM Systems Director。

IBM Systems Director

IBM Systems Director 6.1 是 IBM Director 平台管理工具的新版本。ISD 提供一个集成的基于浏览器的用户界面，用于执行常见的系统管理任务；还提供整个 IT 环境的单一全局视图，包括物理组件和虚拟组件。除了基本的 ISD 功能（可以免费下载）之外，还有专门的高级管理器，它们可以免费下载，或者需要免费的试用许可证（可以付费升级到永久许可证）。可用的高级管理器包括 Active Energy Manager、VMControl 以及用于从以前的 Director 版本或其他厂商的系统管理工具迁移的工具。

下载和安装 WPAR Manager

在本节中，假设已经下载、安装和配置了 IBM Systems Director 6.1，而且您熟悉使用 ISD 执行系统管理任务的基本知识。如果需要执行这些步骤，请参见 ISD 服务器代码的 下载 页面上的说明。

用 IBM ID 登录之后，从 IBM Systems Director Plug-ins 页面下载 WPAR Manager 安装软件。
可以使用 Download Director 应用程序或 http 协议下载适合您的服务器平台的代码。把压缩的安装映像复制到 ISD 服务器上并解压文件。

安装映像是一个 InstallAnywhere 可执行文件，针对 AIX 和 Linux 的文件名是 WparMgr21Setup.bin，针对 Windows 的是 WparMgr21Setup.exe。运行安装映像需要根权力或管理员权力。在默认情况下，安装以 GUI 或控制台模式启动，指导您通过一系列面板或屏幕并输入所需的信息，然后开始安装。还支持 静默安装。

安装可执行文件在 ISD 安装目录中安装一套 Eclipse 特性和插件。它还安装 WPAR Manager 所需的一些配置文件以及子代理安装映像（详细信息见 远程子代理安装）。

安装过程完成之后，重新启动 ISD（在 WPAR Manager 安装过程中重新启动或手工启动），WPAR Manager 应该会启用了，使用为期 60 天的临时试用许可证。在 ISD 中开始设置和使用 WPAR Manager 的最佳位置是 WPAR Manager Summary 页面，可以通过 ISD Welcome 页面访问这个页面。

静默安装选项

对于静默安装，必须提供响应文件，而且必须用 –i 标志启动安装可执行文件，这是 InstallAnywhere 的标准做法。例如，在 AIX 上，用以下命令启动静默安装：

WparMgr21Setup.bin –i silent –f <response_file>

其中的 <response_file> 包含响应文件的路径。

采用控制台或 GUI 模式的安装会生成响应文件，可以用来执行静默安装，也可以自己创建响应文件。

响应文件是一个简单的文本文件，至少包含以下选项：
.LICENSE_ACCEPTED
必须把它设置为 true，表示接受所有许可协议。

.RESTART_DIRECTOR
如果希望在安装 WPAR Manager 之后自动地重新启动 ISD，应该把它设置为 true，否则设置为 false。正如前面提到的，在 ISD 中启用 WPAR Manager 需要重新启动 ISD。

使用 Setup Advisor 执行安装后配置

在第一次启动刚安装的 WPAR Manager 时，在使用它之前，需要执行几个额外的配置步骤。Setup Advisor 是一个向导界面，帮助用户完成这些步骤。
通过单击 ISD Welcome 页面上 WPAR Manager 项下面或 WPAR Manager summary 页面右上角的链接启动 Setup Advisor。Setup Advisor 的每个页面包含一些说明性文本、到 ISD Information Center 中其他内容的链接和一个按钮，按这个按钮即可执行当前步骤的 Director 任务（例如 System Discovery 或 Collect Inventory）。
Setup Advisor 引导您执行以下任务：
1.发现已经存在 WPAR 的 AIX 系统，或者要创建 WPAR 的 AIX 系统。
2.请求访问发现的每个系统，这要提供 Director 用来执行系统身份验证的管理员用户 ID 和密码。
3.在管理的 AIX 系统上安装 WPAR Manager 子代理，它扩展基本的 Director 代理软件，支持 WPAR 操作。关于这个任务的详细信息，参见 远程子代理安装。
4.在管理的每个 AIX 系统上收集目录信息。这个步骤把正在运行 WPAR Manager 子代理的系统识别为 "WPAR-capable" 系统，还会发现在 WPAR-capable 系统上已经存在的 WPAR。
5.查看或修改一些基本的 WPAR Manager 设置。
6.在管理的系统上可选地创建一个或多个 WPAR。
完成从 Setup Advisor 启动的每个 Director 任务之后，要关闭 Director 页面并返回到 Setup Advisor 开始下一步。完成所有 Setup Advisor 任务之后，就可以在您的环境中的 WPAR-capable AIX 系统上创建和管理 WPAR 了。

远程子代理安装

正如前一节中提到的，WPAR Manager 需要在管理的 WPAR 所在的所有端点系统的 ISD 代理上安装子代理。本节详细解释安装 WPAR Manager 子代理的过程。可以以两种方式安装 WPAR Manager 子代理：

1.在 ISD 控制台中执行远程子代理安装。在 ISD 服务器上安装 WPAR Manager 的过程中，会在 ISD 服务器上提供子代理安装软件并注册为可安装的代理。使用用于安装代理的标准 ISD 向导在所选的系统上安装子代理。这是安装 WPAR 子代理的推荐方法，也是 Setup Advisor 采用的方法。

2.使用安装映像执行手工安装，可以从下载 WPAR Manager 安装映像的下载站点获得子代理的安装映像。
这两种方法都在端点上安装 wparmgt.agent 和 mcr.rte 文件集。安装的文件集的版本必须满足端点的 AIX 技术级别的要求。
远程子代理安装使用 ISD 中 Update Manager 提供的功能。在不使用 Setup Advisor 的情况下，远程安装子代理的步骤如下：

(1).在 ISD 控制台中，展开 Release management 并单击 Agents。显示 Agents 页面。还可以使用特定 AIX 端点的上下文菜单进行导航，然后选择 Install Agent；在这种情况下，从第 4 步继续操作。
(2).在表格中选择 Common Agent Subagent Packages。
(3).选择 CommonAgentSubagent WPAR Manager Agent 包的最新版本。
(4).单击 Install Agent。显示代理安装向导的第一个页面。
(5).在 Welcome 页面上，单击 Next。
(6).在 Agents 页面上，单击 Next。如果使用端点的上下文菜单导航到这里，现在必须选择要安装的子代理（第 2 步和第 3 步）。
(7).在 Systems 页面上，执行以下操作：
。选择要安装 WPAR Manager 代理的系统的名称。
。单击 Add > Next > Finish。
(8).单击 OK 完成安装。

在准备安装时，创建了两个系统任务。与安装成功或失败相关的所有消息出现在第二个任务中，这个任务在后台运行。要查看第二个任务，可检查 Task Management 下面的 Active and Scheduled Jobs 列表。寻找标题中包含 'Agent Installation' 的任务。
对于手工安装，应该把代理安装包直接下载到 AIX 端点上并解压。这会创建一个目录结构，其中包含多个 AIX 技术级别所需的文件集。
应该进行检查，确保满足这些文件集的前提条件：
.bos.wpars version 6.1.2 或更高版本；支持最新的特性需要 6.1.4
.ISD agent version 6.1.2
导航到与端点系统的 AIX 技术级别对应的目录，使用以下命令安装 WPAR 子代理。

installp -acqgYXd . wparmgt.agent

这会自动地安装两个文件集，wparmgt.agent 和它依赖的 mcr.rte。

基于策略的 WPAR 重新定位

WPAR Manager 允许系统管理员通过启用和配置重新定位策略来平衡 WPAR-capable 系统的工作负载。2.1 版提供的内置功能包括：

.自动重新定位：系统管理员可以在 WPAR-capable 系统上设置最大利用率阈值，从而当内存或 CPU 利用率超过可接受的水平时自动地重新定位 WPAR。使用 MCR 异步移动功能重新定位 WPAR，这个功能允许在重新定位期间 WPAR 中的应用程序和进程继续运行。

.只通知模式：当 WPAR-capable 系统的利用率超过阈值时，通知系统管理员，但是禁用自动的重新定位。可以使用此信息决定什么时候把 WPAR 手工地重新定位到利用率低的系统。

.WPAR 级的策略排除：在 WPAR 级禁用自动的重新定位功能。换句话说，可以声明对于某些 WPAR 不应该执行自动的重新定位。仍然可以手工地重新定位使用这种设置的 WPAR。

.重新定位域：重新定位域是一组 WPAR-capable 系统，用于在自动重新定位期间限制转移 WPAR 的目的地。在自动重新定位期间，只有相同重新定位域中的系统可以作为重新定位 WPAR 的目的地。

启用 WPAR 重新定位策略功能要求系统管理员做以下事情：

.创建策略
.指定所需的阈值
.给策略指定一个或多个重新定位域

创建 WPAR 重新定位策略之后，分配给策略的重新定位域中的每个 WPAR-capable 系统将受到监视。

当策略所影响的系统的工作负载超过策略中指定的性能指标阈值时，系统上运行的 WPAR 成为动态重新定位的候选 WPAR。WPAR Manager 将分析超过策略中指定的阈值的情况，决定是否需要执行自动的重新定位。详细的分析和结果显示在发生阈值突破的系统的 Properties 页面的 Applied Activities 面板中。Applied Activities 面板中提供的信息有助于系统管理员了解在自动重新定位期间选择 WPAR 和目标系统的分析过程。

WPAR Manager 对新的 AIX 6.1 WPAR 特性的支持

在最近的版本中，AIX 工作负载分区增加了几个新功能。WPAR Manager 增加了对这些功能的支持，下面介绍最近的一些改进。

WPAR 拥有的 rootvg 卷组

在以前的版本中，系统 WPAR 只能使用 WPAR 所在的机器本地的文件系统，或者使用 NFS 通过网络访问远程系统上的文件系统。从 AIX 6, TL 04 开始，WPAR 增加了新功能，包括配置驻留在 SAN 存储设备上的自含的文件系统。与以前支持的配置相比，这种配置具有以下优点：

.WPAR 管理员能够独自管理 WPAR 的根文件系统（/、/var、/tmp、/home 等等），不需要全局管理员参与。
.应用程序移动不再限于基于 NFS 的配置。可以在共享同一 SAN 集群的系统之间重新定位 WPAR。

图 1 给出一个简单的基于 SAN 的 WPAR 配置：

图 1. 基于 SAN 的 WPAR 配置

图中显示两个系统，A 和 B。它们都连接到同一个 SAN 磁盘阵列

这种配置（WPAR 根文件系统驻留在 SAN 磁盘中）称为 “WPAR 拥有的 rootvg” 或 “rootvg WPAR”。为了创建采用这种配置的 WPAR，分配给这个 WPAR 的至少一个 SAN 磁盘的设备控制设置必须设置为 rootvg。

创建 WPAR 之后，可以通过添加更多磁盘来扩大 rootvg 卷组。全局 AIX 管理员给 rootvg 分配每个磁盘并设置磁盘的设备控制。分配磁盘之后，WPAR 管理员运行 cfgmgr 命令在 WPAR 环境中配置设备（必须为创建 WPAR 之后添加的所有设备执行这个步骤）。

WPAR 总内存限制资源控制

总内存限制资源控制是一个新的资源控制特性，允许以绝对值的形式设置总内存限制。在此之前，资源控制只能使用表示为百分数的相对值。通过使用这种新的资源控制特性，WPAR 的总内存限制可以设置为 1 MB 到 8,796,093,022,207 MB（大约 8388608 TB 或 8192 PB (Petabyte) 或 8 EB (Exabyte)）之间的任何值。还可以设置每个进程的内存限制。每个进程的限制本身受到总内存限制的限制。在默认情况下这两个资源限制都是禁用的。

非 AIX 文件系统中的 WPAR

WPAR Manager 现在支持在可写的通过 namefs 挂装的非 AIX 文件系统（比如 GPFS）中进行文件备份。也可以关闭这个选项。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-wparmanager/index.html

Top


IBM Linux for Power 安装工具包 PowerVM Lx86 原理及应用

IBM PowerVM Lx86 基本概念

IBM PowerVM Lx86 是 IBM 基于 Power 系列服务器所开发的众多虚拟化技术的软件之一，其设计目的是为了将 x86 Linux 应用软件整合到 Linux for Power 中，从而使 x86 Linux 应用软件获得 IBM Power 服务器所特有的高可靠性、高可用性、高服务性。IBM powerVM Lx86 的主要功能是使 x86 Linux 应用软件，特别是那些没有原代码只有二进制代码的 x86 Linux 应用软件在不经过任何修改的情况下就可以运行在 Linx for Power 操作系统上。IBM 巴西 Linux 技术中心的开发人员已经将 IBM PowerVM Lx86 整合到 Linux for Power 安装工具集中。IBM Power 服务器用户可以通过 IBM Linux for Power 安装工具集所提供的 IBM PowerVM Lx86 管理向导方便、快捷地在 Linux for Power 上布署 IBM PowrVM Lx86 并运行 x86 Linux 应用软件。

在分析 IBM PowerVM Lx86 工作原理之前，我们首先介绍 IBM PowerVM Lx86 所涉及的几个基本概念：

.The translator：The translator 是 PowerVM Lx86 的主要组成部分。它的作用是将 x86 指令动态地翻译成 Power 指令并且将 x86 Linux 的内核调用转换成 Linux for Power 内核调用。
.The libraries：The libraries 是 x86 Linux 环境中运行应用程序所需的程序库。
.x86World：x86World 是指将 x86 Linux 通用库、x86 Linux 系统命令、x86 Linux 二进制代码和系统文件安装在 Linux for Power 操作系统的一个目录中，从而组成的 x86 运行环境。x86World 在缺省情况下被安装于 Linux for Power 操作系统中的 /i386 目录中。
.VxE：VxE 是指虚拟 x86 环境，即 Virtual x86 Environment 的缩写。VxE 是 IBM PowerVM Lx86 的重要组成部分，它是保证 x86 应用软件在 Linux for Power 上正常运行所必须的。The translator 和 x86World 是 VxE 中的两个极为重要的组件。
.Power System：Power System 是指具有支持 PowerPC 精简指令集的 Power 处理器的服务器。

在了解了 IBM PowerVM Lx86 所涉及基本概念后，我们可以通过图 1 对 IBM PowerVM Lx86 的工作原理做简要的阐述：

在图 1 中我们可以看出，对于 Linux for Power 操作系统而言，运行于 VxE 中的 x86 Linux 应用软件只是其中的一个进程。因此，Linux for Power 的应用软件可以与 x86 Linux 应用软件的并行运行于 Linux for Power 操作系统中。

IBM PowerVM Lx86 工作过程分为以下几步：

在 Linux for Power 操作系统上运行 x86 Linux 应用软件时，首先需要将 x86 Linux 应用软件二进制代码装载入内存中。在内存中的 x86 Linux 二进制被调用时，IBM PowerVM Lx86 翻译器对其进行解码并对常用代码进行优化。常用代码是指点那些被多次调用的指令，对常用代码进行优化的目的是下次再次调用同样的代码时不需要再次被翻译，从而加快 x86 Linux 应用软件执行速度。当一条指令被多次执行时，IBM PowerVM Lx86 会在后台将此指令进行优化并将其存入永久存储池中。在对常用代码进行优化之后，IBM PowrVM Lx86 翻译器将解码后的 x86 指令转换成 Power 指令。

图 1. IBM PowerVM Lx86 工作原理

图 1. IBM PowerVM Lx86 工作原理

IBM PowerVM Lx86 硬件软件需求

如果您是 IBM Power 服务器的用户并且希望在您的服务器上使用 IBM PowerVM Lx86，请先检查您所拥有的 IBM Power 服务器和您希望拥有的 Linux 发行版是否是 IBM PowerVM 所支持的。表 1 和表 2 分别列出了 IBM PowrVM Lx86 1.3 版本所支持的 IBM Power 服务器和 Linux 发行版。

表 1. IBM PowerVM Lx86 支持的 Power System 服务器

处理器型号 | 服务器型号
POWER 5/5+ | P5 520/550/570/590/595
POWER 6 | P6 520/550/560/570/575/595
 | IBM BladeCenter JS12/JS22/JS23/JS24
POWER 7 | P7 710/720/730/740/750/770/780
 | IBM BladeCenter PS700/701/702

IBM PowerVM Lx86 对 RedHat 和 SuSE 这两个 Linux 发行版的企业版本具有良好的支持。IBM PowerVM Lx86 目前还不支持 RedHat 和 SuSE 的桌面版本。表 2 列出了 IBM PowerVM Lx86 所支持的 Linux 发行版。

表 2. IBM PowerVM Lx86 支持的 Linux 发行版

Linux for Power Release | X86 Linux Release
Red Hat Enterprise Linux 4 U4 | Red Hat Enterprise Linux 4 U3/U4
Red Hat Enterprise Linux 4 U5 | Red Hat Enterprise Linux 4 U3/U4/U5
Red Hat Enterprise Linux 4 U6 | Red Hat Enterprise Linux 4 U3/U4/U5/U6
Red Hat Enterprise Linux 4 U7 | Red Hat Enterprise Linux 4 U3/U4/U5/U6/U7
Red Hat Enterprise Linux 5 U2 | Red Hat Enterprise Linux 5 U2
SuSE Linux Enterprise Server 9 SP3 | SuSE Linux Enterprise Server 9 SP3
SuSE Linux Enterprise Server 9 SP4 | SuSE Linux Enterprise Server 9 SP3/SP4
SuSE Linux Enterprise Server 10 | SuSE Linux Enterprise Server 10
SuSE Linux Enterprise Server 10 SP1 | SuSE Linux Enterprise Server 10/SP1
SuSE Linux Enterprise Server 10 SP2 | SuSE Linux Enterprise Server 10/SP1/ SP2

IBM PowerVM Lx86 功能及特点：

.IBM PowerVM Lx86 可以使 Linux for Power 用户在不做任何移植工作的情况下就可以 Linux for Power 上运行 x86 Linux 应用软件。
.IBM PowerVM Lx86 是标准的 Linux for Power 用户空间应用程序。它不需对 Linux for Power 内核做任何修改。
.IBM PowerVM Lx86 既支持在 Linux for Power 虚拟化的环境 Power 中运行，也可以在不支持 Linux for Power 虚拟化环境的 Power 服务器中运行。
.IBM PowerVM Lx86 可以与 Linux for Power 中的其它应用软件同时运行。
.IBM PowerVM Lx86 可以将 X86 Linux 指令映射到 Power 处理器所支持的精简指令集。

IBM PowerVM Lx86 限制

虽然 IBM PowerVM Lx86 可以支持大多数 x86 Linux 应用软件， IBM PowerVM Lx86 还是有一定限制的。下面列举了无法在 IBM PowerVM Lx86 环境中运行 x86 Linux 应用软件的几种情况：

.IBM PowerVM Lx86 不支持直接对硬件设备（如显卡）等的操作。
.IBM PowerVM Lx86 不支持需要特殊内核模块的应用或需要使用 Linux for Power 发行版未提供的内核模块的应用。
.IBM PowerVM Lx86 不支持 Intel 在 1997 年发布的 Intel IA-32 指令集手册以外的指令。
.IBM PowerVM Lx86 不支持 RHEL4 U4 以前、SLES9 SP3 以前的 Linux for Power 发行版。
.IBM PowerVM Lx86 不支持 x86 Linux 所特有的系统管理工具和配制工具。
.x86 Linux 没有独立的 IP 地址，x86 Linux 与 Linux for Power 使用相同的 IP 地址。
.IBM PowerVM Lx86 不支持 x86 Linux 与 Linux for Power 之间的内存共享。

参考链接：http://www.ibm.com/developerworks/cn/linux/l-cn-powervmlx86/index.html

Top


用 VMControl V2.2 优化 Power Systems

使用虚拟化技术管理 IT 基础设施不仅会帮助组织更好地控制环境，还有助于在实现业务目标的同时降低成本。

IBM Systems Director 支持 PowerVM 环境，它是用于管理异构多服务器环境的 IBM 工具。这个工具提供高级管理选项，比如工作负载生命周期管理、健康状态检查和拓扑映射，还能够对监视到的事件采取措施。

VMControl V2.2 是一个 IBM Systems Director 插件，它代表从管理虚拟化到使用虚拟化更好地管理整个 IT 基础设施的转变。它们的设计目的是降低管理成本、提高资产利用率以及把基础设施性能与业务目标联系起来，从而帮助降低虚拟环境的总拥有成本。

VMControl 有三个版本，适合虚拟化部署程度不同的客户站点：

.VMControl Express Edition 提供基本的虚拟机器生命周期管理。
.VMControl Standard Edition 增加了管理完整虚拟映像库的功能，可以从正在运行的系统捕捉信息，把信息作为可重用的虚拟映像存储在存储库中。
.VMControl Enterprise Edition 可以创建系统池（支持同时运行多个虚拟映像所用的计算资源的动态集合），让用户能够管理其中的虚拟工作负载。

VMControl 的高级虚拟化管理功能为组织提供了一种构建先进的云计算环境的方法。

在 VMControl V2.2 的众多特性中包括经过改进的 Performance Summary 视图，它为所有类型的主机、虚拟服务器和操作系统显示超过 25 种实时 Power Systems 监视器。一个重要的特点是 Performance Summary 视图在表格中集中显示相关资源，从而反映虚拟资源的使用情况。

本文主要讨论 Power Systems 可用的监视器，可以使用 HMC 或 IVM 管理的系统获得它们。

Performance Summary 视图是 IBM Systems Director 6.1.2 的标准组件；但是，只提供最基本的监视器集。如果安装 VMControl V2.2 的任何版本，就可以访问更多的监视器。这个显示工具可以为所选的系统或服务器集显示多个即时数据监视器。监视器在用户界面页面中分组显示，根据正在显示的监视器进行分组，标签为 “Processor” 的页面显示与处理器相关的所有监视器，“Memory” 页面显示与内存相关的所有监视器，“Network” 页面显示与网络相关的所有监视器，等等。因为 VMControl V2.2 中可以使用的监视器非常多，这样的分组有助于按逻辑组织数据。

可以从 IBM Systems Director 中的以下位置启动 Performance Summary 视图：

.Power Systems Summary 页面
.主页面左边导航面板中的 Status and health 类别
.Virtual Servers and Hosts 视图
.Monitors 视图

与 Performance Summary 视图交互

图 1 显示 Performance Summary 视图，这里显示的是 Processor 页面。表格中的行代表目标主机、虚拟服务器和处理器池，列显示各种即时数据监视器。您会发现表格中有一些空的单元格。这表示某一监视器不适用于某一目标。

图 1. Performance Summary 示意图

图 1. Performance Summary 示意图

通过使用面板上的上下文选择器，可以选择不同的主机或虚拟服务器。但是，不能选择共享的处理器池；它们会出现在层次结构中，因为其中显示的虚拟服务器从这些处理器池分配了处理器单元。

在 Memory 页面上，可以按照相似的方式显示共享内存池的即时数据监视器，只要在使用从这些池分配的内存的主机和虚拟服务器上启用了 Active Memory Sharing（AMS）。

可以使用表格顶部的 Select Column Monitors 按钮选择可用监视器的子集，让它们作为列显示。这样就可以根据环境的需要选择监视器。

可以通过 Action 菜单直接控制监视器的阈值，可以在监视器超过指定值时提供视觉标志。还可以使用阈值触发事件操作计划，比如发送电子邮件。在 Performance Summary 视图中，可以非常方便地激活、编辑、禁用或删除阈值。

一定要明智地使用 Performance Summary 视图，要限制同时查看的即时数据监视器数量。这也是这个显示工具组织成多个页面的原因之一。在查看 Processor 页面时，内存和网络监视器数据收集会停止。当切换到 Memory 页面时，处理器和网络监视器数据收集会停止。

在表格中添加多个监视器列和许多资源行可能会给 IBM Director 服务器带来性能问题。例如，在表格中向下翻页查看更多行时，会为视图中添加的新行启动监视器数据收集。但是，当页面向上回翻时，在视图中不再出现的行的监视器数据收集并不停止。

不需要定制 Performance Summary 视图，因为这个显示工具会记住为目标和监视器选择的最新值。选择了服务器、虚拟服务器和监视器并配置所需的列之后，每当使用 IBM Systems Director 主页面左边的导航面板重新启动 Performance Summary 视图时，它就会使用这些设置。

使用 Performance Summary 视图监视系统

性能问题有时候很难诊断，但是 Performance Summary 视图可以帮助诊断。我们来看三个示例。

示例 1：如果应用程序性能很差，可以使用监视器和 Performance Summary 视图按以下步骤诊断和纠正问题：
1. 选择正在运行这个性能低下的应用程序的虚拟服务器。
2. 在第二个上下文选择器中选择 Virtualization Manager Monitors。
3. 单击 Select Column Monitors 按钮，在对话框中把 CPU 利用率监视器从 Available 列表转移到 Selected 列表中。

收集即时数据之后，会发现 CPU 利用率非常高。可以查看这个虚拟服务器、共享处理器池和主机的处理器数量和标称处理器数量。一种可能的解决方法是按以下步骤使用 HMC 重新分配处理器单元：
1. 在表格中选择性能差的虚拟服务器的行。
2. 使用 Actions 菜单选择 Extended Management>Dynamic Logic Partitioning>Processor>Add or Remove。
3. 在 HMC 对话框中修改分配的虚拟处理器。

对这个值的修改会立即生效。几分钟之后，会看到 Performance Summary 视图中的数据发生变化，数据应该表明问题已经得到解决。
示例 2：尽管 Performance Summary 视图并不是作为 AMS 调优工具设计的，但是它有助于诊断内存使用问题。

与前一个示例一样检查 CPU 利用率监视器，发现 CPU 利用率并不是问题。在 Performance Summary 视图中切换到 Memory 页面，可以看到 Page Faults/sec、Page-In Delay (sec)、Physical Memory (MB)、Available Memory (MB) 和 Memory Overcommitment (MB) 等内存监视器。可以通过这些监视器更好地了解虚拟服务器和主机上的内存使用情况。

您可能希望包含位于这个主机的其他虚拟服务器，从而同时查看它们的内存监视器。大量的 Page Faults/sec 意味着需要重新分配内存。另外，如果 Memory Overcommitment 的值较高，就说明虚拟服务器试图使用的内存量超过了共享内存池能够提供的内存量。

因为不能从 IBM System Director 直接启动 HMC Shared Memory Pool Management 对话框，您需要单独访问 HMC 并启动 Shared Memory Pool Management 以修改内存分配。所做的修改会反映在 Performance Summary 视图中。

示例 3：可以在 Performance Summary 视图中添加以下监视器以便寻找网络配置中的瓶颈：
.Bytes Received/sec
.Bytes Transmitted/sec
.BC Packets Transmitted/sec
.BC Packets Received/sec

在 Network 页面上，可以查看 Host Ethernet Adapter (HEA) 的监视器。要想修改 HEA 配置，应该访问 HMC 控制台并为主机服务器选择 Hardware Information>Adapters 下面的 Host Ethernet。

卓越的性能
世界各地的企业 IT 团队正在通过实现虚拟化解决方案来降低成本、提高服务水平和控制风险。有了 IBM Power Systems 和 PowerVM，就可以大规模地虚拟化 IT 资源，实现出色的性能、弹性和灵活性。

通过使用 IBM Systems Director 和 VMControl（包括新的 Performance Summary 视图），可以密切地监视虚拟工作负载的特征并进行调优，从而确保卓越的性能和最优的系统利用率。

参考链接：http://www.ibm.com/developerworks/cn/aix/systemmaga/201002/controlling_your_environment/

Top


在 PowerVM 环境中使用 IBM Systems Director VMControl V2.1 简化 AIX 映像管理

Network Installation Manager (NIM) 让 POWER用户能够简便高效地通过几种类型的网络执行各种软件安装和维护任务。现在，在 IBM Systems Director 产品系列中出现了一个新的虚拟化工具 IBM Systems Director VMControl V2.1，它可以跨多个虚拟化平台进行简便和集中的映像管理。与使用 NIM 相比，PowerVM 管理员可以使用 IBM Systems Director VMControl 更简便更快速地管理 AIX 映像。

IBM Systems Director VMControl 概述

IBM Systems Director VMControl 是一个跨平台的解决方案，有助于快速部署虚拟设备，从而创建配置了所需的操作系统和应用程序的虚拟服务器。IBM Systems Director VMControl 包含：

.免费功能，允许为 z/VM创建和管理虚拟服务器。

.可选的付费功能，允许在环境中创建、导入和部署虚拟设备。在下载并安装 IBM Systems Director VMControl 时会得到一个为期 60 天的评估许可证。

IBM Systems Director VMControl 的付费部分 IBM Systems Director VMControl Image Manager 允许执行以下任务：

.发现环境中现有的映像存储库，把基于标准的外部映像作为虚拟设备导入自己的存储库。
.捕捉正在运行的虚拟服务器，从而获得访客操作系统、正在运行的应用程序和虚拟服务器定义。在捕捉虚拟服务器时，在映像存储库中创建一个虚拟设备，它具有与虚拟服务器相同的定义，可以在环境中多次部署。
.从 Internet 或其他外部源导入采用 Open Virtualization Format (OVF) 格式的虚拟设备包。在导入虚拟设备包之后，可以在自己的数据中心部署它们。
.快速部署虚拟设备以创建新的虚拟服务器，满足不断变化的业务需求。

可以在以下平台上部署虚拟设备：

.由 Hardware Management Console 或 Integrated Virtualization Manager 管理的 IBM Power Systems服务器(POWER5,POWER6和POWER7)。
.在 z/VM 系统管理程序上运行的 Linux on System z 系统。

使用 VMControl 管理 AIX 映像
VMControl 应用于 IBM Systems Director 管理域。它引入一个映像存储库。对于 POWER，映像存储库是一个 NIM 主服务器；对于 z/VM，它是一个 z/VM Management Accessibility Point 服务器。图 1 说明 VMControl 在 POWER 环境中的结构。

图 1. VMControl 的结构

VMControl 有两个部分；一个是 Director Server 中的插件，另一个是在带 CAS 代理的 NIM 主服务器上安装的子代理。安装了 VMControl 子代理的 NIM 主服务器作为映像存储库，能够存储、捕捉和部署映像。

准备和设置 VMControl

在 POWER 平台上使用 VMControl 的需求如下：

.IBM Systems Director Server 应该是 6.1.1.2 或更高版本。
.如果 Power CEC 由 HMC 管理，那么 HMC 应该是 7.3.4.2, PTF MH01181 或更高版本。
.如果 Power CEC 由 IVM，那么 IVM 应该是 2.1.0.10 或更高版本。
.NIM 主服务器的 AIX 版本应该至少是 6.1.3。

用户应该按以下步骤设置 VMControl：

1.安装并配置 Director Server，把它升级到 6.1.1.2 或更高版本。找到并请求访问管理 POWER 主机的 HMC 或 IVM。

2.用 GUI 或静默模式在 Director Server 中安装 VMControl。安装之后，用户就可以使用 VMControl 的免费部分和为期 60 天的评估许可证。当许可证过期后，用户必须购买和安装永久许可证，才能继续使用与映像相关的 VMControl 功能。安装完成之后，Director Server 的欢迎页面中显示 IBM Systems Director VMControl（见图 2）。

图 2. Director Server 的欢迎页面

Director Server 的欢迎页面

3.设置一个 NIM 主服务器，它通过网络连接 Director Server、HMC 和 IVM。

4.在 Director Server 中找到并请求访问 NIM 主服务器，把 Director CAS 代理加到它上面，升级到 6.1.1.1 或更高版本。因为 VMControl 的安装过程已经把 VMControl NIM 子代理作为 “CommonAgentSubagent_VMControl_NIM-2.1.0” 添加到 Director Server 中了，现在可以直接使用 Director Release Manager 把 VMControl NIM 子代理安装到 NIM 主服务器上。重新启动 NIM 主服务器上的 CAS 代理以启用这个子代理。VMControl 的当前版本只支持一个映像存储库，所以只有在 Director 管理域中添加的第一个 NIM 主服务器会成为映像存储库。

5.在 VMControl 汇总页面上，在 NIM 主服务器上启动 Discover Virtual Appliances 任务。任务完成之后，会列出 NIM 主服务器上存储的所有虚拟设备。现在，VMControl 准备好了，用户可以在 VMControl 页面上执行捕捉和部署。

图 3. VMControl 的汇总页面

作为虚拟设备导入 OVF/OVA 格式的文件集

VMControl 可以在 IBM 系统上提供和管理虚拟设备。虚拟设备是虚拟服务器的一种表示方式，其中包含经过配置和测试的操作系统、中间件和软件应用程序，还有描述虚拟服务器的元数据。

元数据描述服务器资源，包括：

.CPU 的数量（专用的和共享的）
.内存大小
.I/O 和网络
.IP 地址、主机名等配置变量

磁盘映像包含操作系统、中间件和其他应用程序。

Distributed Management Task Force (DMTF) Open Virtualization Format (OVF) 对虚拟设备结构和打包格式进行了标准化。VMControl 支持 OVF 文件集和 TAR 文件（扩展名为 .ova）形式的虚拟设备。对于在 POWER 上运行的 AIX，虚拟设备包含一个 AIX mksysb 映像和 .ovf 文件，.ovf 文件描述服务器上的资源和生产信息。对于 zLinux，它包含 .ovf 文件和一个 .gz zLinux 映像。导入到 VMControl 中之后，文件集存储在映像存储库中（NIM 主服务器上的 /export/nim/appliances），并作为用于部署的虚拟设备列出。可以从 Internet 或 IBM Systems Director Server 本地路径导入 OVF 文件集。

图 4. VMControl Import 向导的 Source 页面

VMControl Import 向导的 Source 页面

捕捉任务

可以通过捕捉任务捕捉虚拟服务器或现有的 mksysb 映像文件，创建虚拟设备。

可以捕捉三种虚拟服务器：

.运行 AIX V5.3， AIX V6.1或者AIX V7.1的 IBM Power Systems（POWER5,POWER 6和POWER7）虚拟服务器（逻辑分区）
.在 z/VM 系统管理程序上运行的 Linux on System z 系统

在捕捉 Power Systems 虚拟服务器之前，要确保管理虚拟服务器的 Hardware Management Console (HMC) 或 Integrated Virtualization Manager (IVM) 出现在 IBM Systems Director 中。另外，确保在 IBM Systems Director 中发现了要捕捉的虚拟服务器和其中运行的操作系统。

满足所有前提条件之后，可以在 VMControl 欢迎页面中的资源导航器中右键单击一个虚拟服务器并选择 Capture，启动 Capture 向导。在向导中，只需输入虚拟设备的名称和描述，然后选择要捕捉的虚拟服务器作为源。

图 5. Capture 向导的欢迎页面

VMControl 还提供系统管理命令行界面 smcli captureva，可以把 NIM 创建的 mksysb 映像文件打包为虚拟设备。

捕捉之后，创建新的虚拟设备，它包含描述虚拟服务器的元数据和映像的引用。映像包含源虚拟服务器的完整操作系统和软件应用程序。新的虚拟设备显示在 VMControl 主页上的虚拟设备列表中。然后可以部署它，创建包含完整操作系统和软件应用程序的新的虚拟服务器，或者覆盖现有的虚拟服务器。这样就可以非常方便地执行克隆和备份/恢复操作。

部署

部署任务可以部署虚拟设备，创建新的虚拟服务器或覆盖现有的虚拟服务器，还可以创建不包含操作系统和其他软件的虚拟服务器。可以为生成的虚拟服务器定制各种属性，比如网络设置。

可以在以下平台上部署 IBM Systems Director VMControl 中已经捕捉或导入的虚拟设备：

.由 Hardware Management Console 或 Integrated Virtualization Manager 管理的 IBM Power Systems 服务器（POWER5, POWER6和POWER7）
.在 z/VM 系统管理程序上运行的 Linux on System z 系统

例如，可以把虚拟设备部署在 POWER 上，创建新的虚拟服务器。从 VMControl 欢迎页面启动 Deploy 向导，或者在资源导航器中右键单击一个主机服务器 (CEC) 或虚拟设备，然后选择 Deploy。

图 6. Deploy 向导的欢迎页面

然后，可以选择虚拟设备和要创建虚拟服务器的目标（Power 环境中的 CEC）。对于部署到现有的虚拟服务器，目标是虚拟服务器 (LPAR)。选择存储池和虚拟网络之后，可以定制虚拟服务器的 TCP/IP 网络设置。

图 7. Deploy 向导的 Product 页面

Deploy 向导的 Product 页面

部署作业完成之后，会在目标主机上创建一个虚拟服务器，它具有指定的网络设置以及与捕捉为虚拟设备的系统相同的配置，比如 CPU、内存、操作系统、中间件和软件应用程序。对于部署到现有的虚拟服务器，取消创建虚拟服务器的过程，把虚拟设备直接部署到现有的虚拟服务器。如果没有指定虚拟设备，VMControl 可以创建不包含操作系统的纯粹的虚拟服务器，这就像是在 HMC 中创建 LPAR。

VMControl 命令

VMControl 包含一组用来执行映像管理任务的命令。用户可以列出能够捕捉和部署的虚拟设备、映像存储库和服务器。另外，可以使用这些命令捕捉正在运行的虚拟服务器的 AIX OS，以及把虚拟设备部署到现有或新的虚拟服务器：

.captureva：从虚拟服务器或现有的 AIX mksysb 映像文件捕捉虚拟设备。
.deployva：把虚拟设备作为工作负载部署到新的或现有的虚拟服务器。
.importva：把虚拟设备导入 IBM Systems Director VMControl Image Manager 中。
.lscapsrv：列出可以捕捉为虚拟设备的服务器。
.lscustomization：列出在运行 captureva、deployva 或 importva 命令时可以定制的虚拟设备属性。
.lsdeploytargets：列出可以部署虚拟设备工作负载的目标服务器或主机。
.lsrepos：列出存储库。
.lsva：列出虚拟设备。

参考链接：http://www.ibm.com/developerworks/cn/aix/library/au-aiximagemanagement/index.html

Top


Power虚拟化相关链接

实战篇：

1.在 JS22 上实现 Live Partition Mobility

2.IBM PowerVM 实战手册，第 1 部分 : 前言及设计

3.IBM PowerVM 实战手册，第 2 部分 : VIO server 准备及安装

4.IBM PowerVM 实战手册，第 3 部分 : VIO server 配置及微分区的实施

5.IBM p5 服务器逻辑分区

6.IBM AIX 上工作负载分区(Workload Partition)管理的介绍：了解和计划 WPAR

7.AIX 6 系统工作负载分区（System WPAR）管理指南

8.PowerVM 新特性 - Active Memory Sharing - 详细架构

9.PowerVM 新特性 - Active Memory Sharing - 配置和管理

10.IBM Power 服务器上动态逻辑分区操作的若干制约因素，第 1 部分: 处理器篇

11.IBM Power 服务器上动态逻辑分区操作的若干制约因素，第 2 部分: 内存篇

12.IBM Power 服务器上动态逻辑分区操作的若干制约因素，第 3 部分: 适配器篇

13.虚拟化环境下搭建 DB2 pureScale 群集

14.使用 IBM Systems Director 6.1 实现 IBM PowerVM 的管理

案例：

1.通过处理器虚拟化实现技术和业务收益

2.Murray Goulburn 通过与 IBM 合作，解决了发展和灵活性挑战

3.从“海业霸主”到“信息之王”——IBM Power Systems 整合效应助理中海油实现业务腾飞

4.Power — 打造天音通信发展的优势平台

5.和宏实业：全效的资源管理，带来稳固的领导地位

6.Power 平台助力梦娜成为国内优质品牌

白皮书：

1.《PowerVM与x86 虚拟化性能比较》

2.《如何帮助客户获得虚拟化优势》(559KB)

3.《虚拟化技术提高业务灵活性》(582KB)

红皮书：

1.《PowerVM Virtualization on IBM System p: Introduction and Configuration Fourth Edition》

2.《IBM PowerVM Virtualization Introduction and Configuration》

3.《IBM PowerVM Virtualization Managing and Monitoring》

4.《Getting Started with PowerVM Lx86》

5.《SAP Applications on IBM PowerVM》

6.《PowerVM Virtualization Active Memory Sharing》

7.《IBM PowerVM Live Partition Mobility》

8.《PowerVM Migration from Physical to Virtual Storage》

9.《Introduction to Workload Partition Management in IBM AIX Version 6.1》

10.《Workload Partition Management in IBM AIX Version 6.1》

相关链接：

IBM Power 系列主机虚拟化专题

PowerVM 虚拟化

IBM 虚拟化解决方案

PowerVM Forum(英文)

PowerVM销售手册(英文)

Top


目录 存储之虚拟化介绍

存储之虚拟化介绍

IBM System Storage SAN 卷控制器 - 概述

IBM System Storage SAN 卷控制器 - 规格

IBM System Storage SAN 卷控制器 - 特性与优势

IBM SVC 存储虚拟化产品助力盛大在线实现异构存储容灾

IBM Storwize V7000 中端磁盘系统 - 概述

IBM Storwize V7000 中端磁盘系统 - 规格

IBM Storwize V7000 中端磁盘系统 - 特性与优势

采用内置存储效率功能的全新中端磁盘系统

解读IBM存储虚拟化的两大法宝

Evli应用IBM绿色存储虚拟化成功案例


IBM System Storage SAN 卷控制器 - 概述

要点

.简单且更高效的管理：通过单点访问，使用网络浏览器管理整个网络
.提高存储效率：更好地利用存储容量，使企业能够充分利用先前未使用的磁盘容量
.经过优化的存储分层：新的 IBM System Storage Easy Tier 功能能够简便、自动地优化固态存储部署
.灵活性和可扩展性：系统可以不中断地从最小配置扩展至最大配置
.更易于使用：凭借基于通用 IBM XIV 界面的全新用户界面，SVC 有助于更大程度地加速部署和提高生产效率

San Volume Controller

在不增加复杂性的情况下管理信息爆炸

您的存储需求是否增长过快？管理这种增长的成本是否占用越来越多的 IT 预算？您是否想在不增加基础架构复杂性的情况下更好地使用现有存储设备？IBM System Storage SAN 卷控制器第 6.1 版可帮助解决这些问题，让您获取更灵活、响应更迅速且更高效的存储环境。IBM System Storage SAN 卷控制器可为各环境（从大型企业到小型企业以及中型市场公司）提供众多存储虚拟化优势。

易于实施

SAN 卷控制器软件已经预装在 SVC 存储引擎上，一旦将引擎连接到您的存储区域网络 （SAN），即可快速实施。SVC 存储引擎基于久经考验的 IBM System x服务器技术，而且始终以冗余对的形式部署，可提供极高的可用性。

SVC 可控制现有存储，从而保留您现有的全部信息。此功能可帮助加速及简化实施，同时帮助将额外存储的需求最小化。一旦实施 SVC，您便可以根据需要迅速轻松地对配置进行更改。

SAN 卷控制器第 6.1 版是以 IBM XIV Storage System 为模型的全新图形用户界面，一直以来深受客户欢迎。新的用户界面更易于使用并囊括多种内建 IBM 推荐功能，以帮助简化存储配置并使新用户能够利用快速学习方法迅速入门。

iSCSI 服务器连接

SVC 支持使用基于 IP 网络的 iSCSI 协议来连接到服务器，这可以帮助降低成本和简化服务器配置。iSCSI 连接避免了服务器中光纤通道主机总线适配器 （HBA） 的成本，并降低了对光线通道交换机端口的需求。此新功能可能对 IBM BladeCenter服务器配置特别有吸引力。

补充服务器虚拟化

如上所述，使用 SAN 卷控制器的存储虚拟化可以对使用 VMware vSphere 等技术的服务器虚拟化形成补充。

服务器虚拟化可帮助加速配置新服务器映像，因为配置会成为一项软件操作，而不需要更换硬件。同样，使用 SVC 进行配置可通过软件和自动精简配置来实现，可成为一项几乎完全自动化的功能。如果不使用 SVC，则服务器配置可能会因配置存储的需求而变得缓慢。

例如 VMotion 之类的功能支持物理服务器之间的应用程序迁移。同样，SVC 可支持在存储系统之间进行无中断的数据迁移。此外，SVC 可帮助使存储可用于所有连接的服务器，从而大大提高使用 VMotion 的灵活性。如果不使用 SVC，则可能会由于存储专用于特定的服务器而限制 VMotion 的使用。

由于 SVC 对服务器显示为单一存储类型，服务器映像中只需要一种驱动程序类型，从而简化了虚拟服务器的配置，也简化了对这些服务器映像的管理。同样，SVC 使得可以轻松更换存储或将数据从一个存储类型移至另一存储类型，因为这些更改都不要求更改服务器映像。如果不使用 SVC，存储类型的更改则可能要求对服务器映像进行中断性更改。

服务器虚拟化可通过在生产及恢复站点支持使用不同物理配置，来帮助提高灵活性并降低灾难恢复的成本。这些不同的物理基础架构上使用通用的虚拟服务器配置。同样，SVC 支持在生产和恢复站点使用不同的物理存储配置，但在各个站点创建相同的虚拟配置。如果不使用 SVC，则生产与恢复站点的物理存储配置必须相似，从而可能会增加成本。

在为多个虚拟服务器克隆启动驱动器时，可以使用 SVC FlashCopy “快照”复制功能来帮助降低存储要求。使用此功能时，仅针对服务器之间的差异使用额外存储量，而不是每个启动驱动器都需要存储量。

许多客户都运行包含各种虚拟化和非虚拟化服务器的混合环境，或者今后打算这样做。SVC 提供了以一致的方式操作的外部存储虚拟化功能，并且为所有连接的服务器提供一致的服务，无论这些服务器是否被虚拟化。与之相比，基于服务器的存储虚拟化技术因服务器而异，因此不但不能降低复杂性，还会使混合环境变得更加复杂。

减少用于副本的存储量

复制数据时，SAN 卷控制器 FlashCopy “快照”复制功能可仅针对源与目标之间的差异（而不是针对整个目标卷容量）使用额外的物理存储，从而显著降低存储要求。

对于从生产数据复制的测试环境，可以使用此功能来帮助降低存储量要求。例如，SAP 用户经常保留多个生产数据副本用于测试。使用 FlashCopy “快照”复制功能来维持这些测试环境可以帮助显著降低所需的物理存储量。

简化配置

SAN 卷控制器将硬件和软件整合至一个高度可扩展的模块化集成解决方案。“I/O 组”通过将一对基于 IBM System x 服务器技术的冗余“存储引擎”与英特尔 至强 5500 2.40GHz 四核处理器、24GB 缓存和 4个 8Gbps 光纤通道端口相结合而形成。如图 1 所示，高度可用的 I/O 组是 SAN 卷控制器群集的基本配置元素。向群集添加 I/O 组可提高群集的性能和带宽。

入门级 SAN 卷控制器配置包含 1个 I/O 组，可以横向扩展到支持 4个 I/O 组，并可纵向扩展至支持多达 1024台主机服务器和多达 8192个卷。这一配置灵活性意味着 SAN 卷控制器配置能以极具吸引力的价格从小开始，适应较小的环境或试验项目，然后随着您业务的增长而扩展，以便管理更大的存储环境。

SAN 卷控制器第 6.1 版支持高达 256个虚拟化磁盘系统，以及容量最高达 1PB 的卷（均为原限值的四倍）。

提高能效

为能降低成本和出于对环境的担忧，许多数据中心如今都在专注于降低能耗。SAN 卷控制器堪称帮助您提高数据中心能效的关键工具。它通过几个显著的方式来实现此目标：

.SVC 可以在不中断应用程序的前提下将数据从较旧的磁盘系统迁移至较新的磁盘系统，这有助于您更轻松、更快捷地实施更节能的存储。
.SVC 可以简化分层存储基础架构的实施并提高较低层存储的性能，这有助于对部署的混合存储进行优化，并且可以更好地使用较低层存储。
.SVC 可帮助提高存储的利用率并减少将来对额外存储的需求，这有助于降低所需存储的总量，从而帮助降低能耗。自动精简配置和“快照”功能旨在进一步扩展此优势。
.Easy Tier 功能可以自动将更多活动数据迁移到固态驱动器，这有助于使用更少更节能的磁盘驱动器来降低能耗。

专用于动态基础架构的技术

IBM 提供了一套丰富的多样化集成虚拟化解决方案，涵盖了从 x86 系统到 System z 大型机，再到利用 SAN 卷控制器进行存储虚拟化以及这些领域之外的范畴。此外，为了充分利用这些解决方案的优势，IBM 还可以与客户进行高效合作，共同开发关键业务战略和流程 － 所有这一切都将以既定的最佳实践作为指导。

在 IBM 的帮助下，当今的企业可以利用在整个组织内全方位改进 IT 工作方式的过程中发现的许多良机来应用虚拟化技术。

常见功能

.整合源自多家供应商的存储量，实现集中管理
.通过提供更灵活的存储资产访问来提高存储利用率
.通过单一界面实现对整合存储的管理，从而提高管理员的生产效率
.使主机应用程序免受物理存储基础架构更改的影响
.支持分层存储环境，从而使存储成本与数据价值相匹配
.跨多家供应商的存储系统应用基于通用网络的复制服务
.在不中断应用程序的情况下，支持存储系统之间的数据迁移
.首款包含对固态驱动器 （SSD） 的紧密集成支持的存储虚拟化系统
.支持可服务多个生产站点的整合灾难恢复站点
.支持从磁盘备份实现近乎即时的恢复

硬件摘要

.基于 IBM System x3550 M2 服务器
.英特尔至强5500 2.40GHz 四核处理器
.24GB 缓存
.4个 8Gbps FC 端口
.支持固态驱动器（每个 SVC 节点多达 4个）
.两个电源
.与其上一代产品节点 （2145-8G4） 相比可以倍增带宽
.与其上一代产品节点 （2145-8G4） 相比倍增 IOPS
.19inch 机架安装机柜
.支持 IBM Systems Director Active Energy Manager

参考链接：http://www-03.ibm.com/systems/cn/storage/software/virtualization/svc/index.shtml

Top


IBM System Storage SAN 卷控制器 - 规格

规格
共享 SMP 处理器配置 | .英特尔 至强 5500 系列四核
处理器缓存内存 | .每个引擎 24GB
主机适配器接口 | .4端口 8Gbps 光纤通道
驱动器接口 | .SAS
磁盘驱动器数量 | .每个 SVC 节点多达 4个 SSD 设备
设备适配器数量 | .SAS
最大物理存储量 | .每个 I/O 组高达 600GB 可用 SSD 容量或一个 8节点群集中高达 1PB 的容量
磁盘容量 | .146GB
RAID 级别 | .RAID 0、RAID 1、RAID 5、RAID 6 和 RAID 10
尺寸（高x宽x深） | .1.7"x17.3"x29" （4.3x44x73.7cm）
最大重量 | .30.3磅（14千克）
工作环境
湿球温度 | .工作 23°C .关机 27°C .存放和装运 29°C
相对湿度 | .工作和关机 8% 至 80% .存放 5% 至 80% .装运 5% 至 100%
电源 | .标配 2个 PSU
电功率 KAVA（最小值/最大值） | .200 - 240VAC，3.8A，50/60Hz
保修期 | .1年
IBM System Storage SAN 卷控制器支持的环境一览表
存储系统支持 | 下列存储系统的特定型号： .IBM TotalStorage Enterprise Storage Server、IBM System Storage DS3000、DS4000、DS5000、DS6000、DS8000、N 系列 .IBM XIV Storage System .EMC Symmetrix VMAX、DMX 和 8000 系列型号 .EMC CLARiiON CX 系列型号和 FC4700 .Hitachi Data Systems Thunder、Lightning、TagmaStore、AMS、WMS、Universal Storage Platform .Sun StorEdge 系统、Sun StorageTek 系统、FlexLine 200 .Hewlett Packard MA8000、EMA12000、EMA16000、EVA 系列、MSA 系列、XP 系列 .NetApp FAS .Bull StoreWay .Fujitsu Eternus .NEC iStorage .Pillar Axiom .Texas Memory Systems RamSan-500 .Xiotech Emprise 5000 .Compellent Fluid Data
主机多路径软件 | .IBM System Storage 多路径子系统设备驱动程序 （SDD） .Symantec/Veritas Volume Manager 3.5 MP3、4.0、4.1、4.3、5.0 .适用于 HP-UX 的 PVLinks .适用于 Windows 和 IBM AIX 的 MPIO .适用于 Solaris 的 MPxIO .本机 NetWare 多路径驱动程序 .适用于 VMware ESX 2.5 和更高版本的本机 VMware 多路径驱动程序 .适用于 OpenVMS、Tru64、SGI Irix 的本机多路径驱动程序 .适用于某些 DS4000 环境的 RDAC 多路径软件
操作系统支持 | .IBM AIX V4.3.3 .IBM AIX 5L V5.1、V5.2、V5.3 .IBM AIX V6.1 .IBM z/VSE V4.2 .IBM PowerVM 虚拟 I/O 服务器 1.2、1.3、1.4、1.5 .Microsoft Windows 2000、2003 和 2008 .Microsoft Hyper-V .Novell NetWare V6.5 .Sun Solaris 8、9、10 .VMware ESX 2.1、2.5.2、2.5.3、3.0.2、3.5、3i .VMware vSphere 4 .HP-UX 11.0、11i V1、V2、V3 .Red Hat Enterprise Linux、Advanced Server 2.1、3.0、4.0、5.0 .SUSE Linux Enterprise Server 8、9、10、11 .Citrix Xen Server .HP Tru64 5.1A、5.1B .HP OpenVMS 7.3-2、8.2、8.3 .SGI Irix 6.5.28、Altix SLES 9 .Mac OS X Server 10.5 .IBM N 系列网关 .NetApp V 系列 .ONStor 群集 NAS 网关
 | .如需有关 HBA 和这些操作系统的群集支持的信息，请访问ibm.com/systems/storage/software/virtualization/svc/（英文），然后单击“互操作性”。请访问http://www.ibm.com/storage/support/2145 (英文)
SAN 交换机支持 － 下列供应商的选定型号 | .Brocade .McDATA .Cisco .CNT
服务 | .客户工程师 （CE） 安装 .1 年部件和服务硬件保修 .含 1年软件维护 .通过 Web 下载软件升级和修补程序包，可以不中断系统进行安装
IBM Global Services 存储服务 | .咨询和设计 。备份和持续性规划 。性能利用和容量规划 .集成和部署 。安装、布线和现场准备 。迁移和整合 。教育和培训 .运营和管理 。系统支持和维护

如需最新的更详细 SVC 互操作性信息，请访问：ibm.com/systems/storage/software/virtualization/svc/interop.html （英文）

参考链接：http://www-03.ibm.com/systems/cn/storage/software/virtualization/svc/specifications.shtml

Top


IBM System Storage SAN 卷控制器 - 特性与优势

功能 | 优势
为存储资源提供单点控制 | .可提高管理效率 .可帮助支持业务应用程序可用性
可统一管理 SAN 上多个存储设备的存储资源 | .可帮助您将存储作为资源而不仅仅是一组箱子来进行管理，从而满足业务要求 .可帮助管理员超越传统的“SAN 孤岛”，更好地根据需要部署存储设备 .可帮助提高存储资产的利用率 .使应用程序免受存储基础架构物理变化的影响
基于 IBM System x 技术的“存储引擎”群集对 | .用于 SVC 设备的高度可靠的硬件基础 .可避免单点硬件故障
对固态驱动器 （SSD） 的创新紧密集成支持 | .专为关键应用程序数据提供超高的性能 .SVC 架构可将 SSD 的性能和容量扩展至高达 1PB 和每秒 800,000次读 I/O，却只需极小的入门级配置，这有助于使 SSD 更加经济实惠 .将数据移入/移出 SSD，而不造成中断；在硬盘驱动器上创建固态驱动器数据的副本
可扩展至支持多达 1024台主机服务器 | .可根据业务状况提供增长空间
易用的图形化管理界面 | .提供用于存储配置、管理和服务任务的单一界面，而无需考虑存储设备供应商。基于 XIV 的 GUI 旨在使 SVC 更易于使用、更高效，且能够使用网络浏览器从网络上随时随地对其进行访问。 .可帮助管理员更高效地使用其现有的存储资产。
动态数据迁移 | .在设备之间迁移数据，而无需使用该数据的应用程序离线 .管理和扩展存储量，而无需中断应用程序
管理分层存储 | .可帮助在分层存储环境中平衡性能需求与基础架构成本
基于网络的高级复制服务 | .利用 FlashCopy 跨多个存储系统复制数据 .借助反向 FlashCopy 更快地从磁盘备份恢复，该功能支持从磁盘备份副本实现近乎即时的恢复 .根据需要跨越城市和全球距离复制数据，以创建高可用性的存储解决方案 .借助新的多群集镜像功能帮助降低实施业务持续性的成本，该功能使单个整合灾难恢复中心可支持多达三个生产数据中心
自动精简配置和“快照”复制 | .只有当数据更改时，才可通过使用物理存储显著降低物理存储需求 .通过随需自动存储配置来提高存储管理员的生产效率
服务器连接的 iSCSI 支持 | .iSCSI 连接可免除服务器中光纤通道主机总线适配器 （HBA） 的成本并降低了对光纤通道交换机的需求。此新功能可能对 IBM BladeCenter 服务器配置特别有吸引力。
IBM Tivoli Storage FlashCopy Manager 应用程序感知型快照 | .执行近乎即时的应用程序感知型快照备份，并只会对 DB2、Oracle、SAP、Microsoft SQL Server 和 Microsoft Exchange 造成极小的影响 .提供先进、精细的 Microsoft Exchange 数据还原 .支持群集的应用程序环境（Windows 上的 MSCS 或 VCS 以及 AIX 上的 HACMP）以及 Microsoft Exchange 2007 持续复制配置（LCR、CCR 和 SCR）

参考链接：http://www-03.ibm.com/systems/cn/storage/software/virtualization/svc/features.shtml

Top


IBM SVC 存储虚拟化产品助力盛大在线实现异构存储容灾

IBM宣布盛大在线采用 IBM SVC 存储虚拟化产品作为其 IT 建设支撑平台的一部分，IBM SVC 以其独特的存储效率管理能力和领先的技术支持及服务，帮助盛大在线在不影响主营业务的前提下进行主营业务机房的平滑迁移和异地容灾备份。

盛大在线是盛大集团的子公司，作为领先的互动娱乐服务平台，盛大在线致力于提供多元化的互动娱乐服务和综合解决方案。通过完善的数据分发和支持系统、销售支付计费系统以及客户服务系统等，为互联网用户获取数字内容产品提供优选渠道，并为互联网企业定制专业化的用户服务体系。此次盛大在线采购了包括 IBM SVC 虚拟化存储产品的一系列 IBM 产品用于核心数据的灾备和机房迁移。

盛大在线首席技术官朱敬表示：“IBM SVC 产品具有高度灵活、领先的性能和缓存功能，能够将不同设备整合起来统一管理，优化设备性能、提高速度，在不增加采购成本的前提下大大提高了存储效率。此外，IBM 持续稳定的技术支持和服务创新也带给我们很大保障。”

高效存储 节约成本

IBM SVC 存储虚拟化产品可以有效整合基于不同管理平台下的存储设备、实现统一管理，消除盛大在线不同时期采购的不同品牌设备的管理和操作差异，实现业务在不同架构间的平滑迁移，消除存储孤岛，充分保证业务的连续性和在线业务的响应速度，为业务应用提供高效的数据访问能力。IBM SVC 产品充分利用了现有存储设备资源，根据业务需求的变化，灵活、平滑地规划和调配存储资源，实现设备的最佳工作状态，提高存储效率。

朱敬在谈到存储效率提升时表示：“我们不再担心应用层面的数据迁移所面临的障碍，IBM SVC 虚拟化产品可以在虚拟层进行数据迁移，消除过去数据迁移的逻辑隐患。同时灵活扩展存储空间，在业务峰值时段灵活调配存储资源，有效降低服务器和存储成本，实现了资源的最大利用率。”

强大实施 专业支持

谈到产品服务方面，朱敬说：“IBM 的售前、售后团队在业界拥有很好的口碑。在此次项目中，我们与 SVC 存储研发团队就项目流程进行了多次交流，他们为此提供了稳定的技术支持和服务，有效地保障了产品的稳定性。我们非常信任 IBM 的产品和服务。”

IBM 在北京、上海、台北建立的 IBM 中国系统与科技研发中心（IBM China Systems and Technology Laboratory）是 IBM 在中国的三大研发中心之一，该中心除了与全球同步进行产品研发外，还会根据中国客户推出定制化的服务和产品。此次，IBM 实验室的开发人员和专家从幕后走到台前，帮助盛大在线实施业务迁移，根据盛大在线的业务特点对 SVC 存储产品进行配置，用高质专业的技术服务达到了客户的项目需求。

IBM 系统与科技部存储产品部大中华区总经理黄建新说：“一直以来，我们都非常关注和重视 IBM SVC 在中国市场的应用前景。这次 IBM 与盛大在线的成功合作，再次印证了 SVC 独特的产品和客户价值。SVC 拥有高可靠性、灵活的磁盘管理功能、扩展性和易管理性，实现了异构间的统一数据复制平台、瞬间复制和远程复制，帮助客户实现高效的存储管理和最大化资源价值。”

盛大在线的数据迁移和灾备项目尚在持续进行，IBM SVC 的优势逐渐显现出来。朱敬表示：“目前，IBM SVC 在项目中正在处于稳步成长期，我们感觉：IBM SVC 性能稳定、灵活，效率高、总体投入成本相对较低。未来，我们会逐渐把更多主营业务全部转移到 IBM SVC 存储产品上，逐步实现云存储，最终实现按需分配的美好愿景。”

参考链接：http://www.ibm.com/news/cn/zh/2010/11/23/z392714x97733s79.html

Top


IBM Storwize V7000 中端磁盘系统 - 概述

.IBM Storwize V7000 为中型企业提供了先进且易于使用的企业级存储功能
.集成的 IBM System Storage Easy Tier 功能通过自动将数据迁移至高性能的固态驱动器 （SSD） 可使性能提高达 200%
.自动精简配置允许您仅采购需要的磁盘容量
.动态迁移可以在迁移关键数据的同时，提供连续的应用程序可用性
.IBM FlashCopy 复制可支持更快速、更高效的数据拷贝以用于在线备份、测试或数据发掘
.IBM Systems Director 提供了灵活的服务器和存储管理功能
.易于使用的数据管理采用图形用户界面和鼠标点击式系统管理能力
.城域镜像和全局镜像在系统之间同步或异步地复制数据以提高备份效率
.固态磁盘 （SSD）适用于要求高磁盘速度和快速数据访问的应用程序
.RAID 0、1、5、6 和 10

在如今的存储管理环境下，打破复杂性升高和数据爆炸式增长的循环可能是一大挑战。购买和管理存储的老办法已变得不那么有效。由于资源的限制，无论物理存储资源还是人力资源，IT 组织必须迅速采取行动以优化和简化其基础架构。不受控制的复杂性和增长随着时间的推移只会变成更大的问题。

中小型组织可能还面对着一系列的挑战：
.有中断的迁移
.难以部署分层存储
.无法在多台服务器之间共享存储
.由于服务器和存储管理工具相互隔离导致生产效率降低、成本升高
.不能像虚拟服务器一样使用虚拟化存储作为工具来优化开支、资源和能力

为了克服这些挑战并使企业能够应对瞬息万变的市场，IBM Storwize V7000 提供了与虚拟化服务器环境互为补充的虚拟化存储系统，具有无与伦比的性能、可用性、先进的功能和高度可扩展的容量，这在中端磁盘系统中是前所未有的。IBM Storwize V7000 是一个强大的中端磁盘系统，经过精心打造，不仅易于使用还可实现快速部署，而无需额外的资源。Storwize V7000 是虚拟化存储，通过内置的 SSD 优化和"自动精简配置"技术可提供更高的效率和灵活性。Storwize V7000 的高级功能还支持无中断地从现有存储迁移数据，从而简化实施并最小化对用户造成的中断。IBM Storwize V7000 还允许您对现有的磁盘系统进行虚拟化和重新利用，从而提供更高的投资回报 （ROI） 潜能。

产品特性

.将频繁访问的数据自动迁移至高性能的固态驱动器 （SSD）
.配备支持需要动态增长的业务应用程序，同时仅消耗它们实际所使用的空间
.迁移能力可提供无中断的迁移功能提供效率和业务价值
.支持近乎即时的复制数据进行备份或进行应用测试
.集成的即时复制能力以满足关键业务需求
.集成工具和能力可进行服务器和存储管理

硬件摘要

.2U 机架安装式机箱
.二十四个 2.5 英寸驱动器托架（型号 124）或者十二个 3.5 驱动器托架（型号 112）
.每个机箱使用 2076-112 型号上的 2 TB 近线 SAS 磁盘驱动器模块，物理存储容量最高可达 24 TB；或者每个机箱使用 600 GB SAS 磁盘驱动器模块，物理存储容量最高可达 14 TB
.SAS 磁盘驱动器、近线 SAS 磁盘驱动器和 SSD
.冗余双主动式智能 RAID 控制器
.16 GB 高速缓存内存（每个内部 RAID 控制器 8 GB）作为基本特征
.8 个 8 Gbps FC 主机端口（每个 RAID 控制器 4 个 8 Gbps 光纤通道端口）和 4 个 1 Gbps iSCSI 主机端口（每个 RAID 控制器 2 个 1 Gbps iSCSI 主机端口），每个端口带有一个 RJ-45 连接器
.RAID 控制器最多可支持连接 9 个扩展机箱，最高配置可达 240 TB 物理存储容量
.双电源和散热组件

参考链接：http://www-03.ibm.com/systems/cn/storage/disk/storwize_v7000/index.shtml

Top


IBM Storwize V7000 中端磁盘系统 - 规格

主机接口 | SAN 连接的 8Gbps 光纤通道 （FC） 主机连接和 1Gbps iSCSI 主机连接
用户界面 | 图形化用户界面 （GUI）
受支持的驱动器 | 3.5英寸磁盘驱动器： .2TB 3.5英寸 7.2k 近线 SAS 磁盘 2.5inch 磁盘驱动器： .300GB 2.5英寸 10k SAS 磁盘 .450GB 2.5英寸 10k SAS 磁盘 .600GB 2.5英寸 10k SAS 磁盘 .300GB 2.5英寸 E-MLC（企业级多级单元） SSD
RAID 级别 | RAID 0、1、5、6和 10
支持的最大驱动器数量 | 240
风扇和电源 | 全冗余、热插拔
机架支持 | 标准 19英寸
管理软件 | IBM Storwize V7000软件
每个控制器的缓存量/缓存总量 | 8GB/16GB
各个系统附带的高级功能 | IBM System Storage Easy Tier、IBM FlashCopy、自动精简配置
附加的可用高级功能 | 远程镜像、外部虚拟化、IBM FlashCopy Manager、TPC Midrange Edition、Tivoli Storage Manager FastBack、IBM Systems Director
保修 | 硬件：标准为 3 年， 软件：1 年
复制服务 | FlashCopy、FlashCopy Manager、城域镜像（同步）、全局镜像（异步）
尺寸 | 12托架机箱 2076-112和 2076-212 宽：483毫米（19.0英寸） 深：630毫米（24.8英寸） 高度：87.9毫米（3.46英寸） 24托架机箱 2076-124和 2076-224 宽：483毫米（19.0英寸） 深：630毫米（24.8英寸） 高度：87.9毫米（3.46英寸）
重量 | 12 托架机箱： .驱动器就绪（未安装驱动器模块）：17.7千克（37.6磅） 。完全配置（安装 12个驱动器模块）：27.2千克（59.8磅） 24 托架机箱： .驱动器就绪（未安装驱动器模块）：17.7千克（37.6磅） 。完全配置（安装 24个驱动器模块）：25.2千克（55.4磅）
受支持的系统 | 如需目前支持的服务器、操作系统、主机总线适配器、群集应用以及 SAN 交换机和导向器的清单，请参阅位于以下网址的 System Storage 互操作性表：ibm.com/systems/support/storage/config/ssic/ (英文)
ISV 解决方案 | 有关我们合作伙伴独立软件供应商 （ISV） 的高质量解决方案列表，包括解决方案摘要和白皮书的访问方式，请参考：ibm.com/systems/storage/solutions/isv (英文)

参考链接：http://www-03.ibm.com/systems/cn/storage/disk/storwize_v7000/specifications.shtml

Top


IBM Storwize V7000 中端磁盘系统 - 特性与优势

特性 | 优势
IBM Systems Director | .为物理和虚拟服务器基础架构提供集成的管理，包括监控和维修以实现更高的可用性和运营效率
动态迁移 | .提供无中断的迁移功能提供效率和业务价值
IBM System Storage Easy Tier | .将频繁访问的数据元素自动迁移至高性能 SSD
自动精简配置 | .支持需要动态增长的业务应用程序，同时仅消耗实际使用的空间
IBM FlashCopy | .创建近乎即时的活动数据副本，该副本既可用于备份，也可用于并行处理活动；支持备份以恢复损坏的数据
固态驱动器 （SSD） | .用于要求高磁盘速度和快速数据访问的应用程序，并且支持分层存储环境
IBM Tivoli Storage FlashCopy Manager | .帮助最小化备份带来的影响、提供近乎即时的恢复；缩短备份与恢复时间、简化管理并实现日常任务自动化处理。
城域/全局镜像 | .允许在系统之间同步或异步地复制数据以提

参考链接：http://www-03.ibm.com/systems/cn/storage/disk/storwize_v7000/features.shtml

Top


采用内置存储效率功能的全新中端磁盘系统

继续传承开发并交付业界领先存储技术的理念，IBM 推出了 IBM Storwize V7000，这是一款创新的存储产品，交付了优异的存储高效技术，卓越的易于使用能力和性能，而且所有这些均集成到一个全面的模块化设计中，其价格也极具竞争力。
IBM Storwize V7000 整合了 IBM 的某些前沿技术（尤其是仅适用于企业级存储系统的某些技术），提高了中端磁盘系统中存储效率的标准。这一前沿的存储系统拓展了 IBM 提供的全面存储产品服务组合，可帮助企业改善应对信息爆炸的方法。

易于使用

IBM Storwize V7000 采用功能强大且易于使用的开创性 GUI 简化了管理。该界面可帮助企业改善存储性能、效率和利用率，同时提高存储管理员的生产力。IBM Storwize V7000 包括以下功能，以增强易用性：

.预安装软件
.简化的供应
.联机数据迁移
.简化的远程镜像
.简化的应用程序性能调优

快速

IBM Storwize V7000 利用已经验证的行业基准来帮助企业改善服务级别，同时提供优越的性能。IBM Storwize V7000 提供以下性能特征：

.System Storage Easy Tier 技术
.性能管理
.多个存储层

高效

IBM Storwize V7000 将前沿 IBM 存储效率技术整合到模块化设计中，简化了更多存储技术的添加。效率的提高转化成为存储利用率的提高、能源成本和管理成本的降低，以及存储器泛滥的减少。IBM Storwize V7000 效率侧重点包括以下项：

.存储虚拟化
.自动精简配置
.空间节省 FlashCopy
.存储资源管理

经济实惠
IBM Storwize V7000 拥有动态的模块化紧凑设计，为经济实惠的中端磁盘系统设定了全新的标准。已无需再像原来那样购买整个机箱，然后随着时间推移不断用磁盘仓进行填充，IBM Storwize V7000 采用各个模块化组件为企业提供了更多的灵活性，同时降低了空间需求。之后，容量和功能可根据需要增加，且与传统中端磁盘系统相比，所造成的中断更少。

参考链接：https://www-31.ibm.com/storage/cn/news/center/storwize_v7000/index.shtml

Top


解读IBM存储虚拟化的两大法宝

在传统的开放系统环境中，主机系统拥有自己的存储资源，每个系统管理员需要针对每一种系统来控制存储资源的分配、使用和管理。此外，每一台服务器还拥有一个单独配置和管理的文件系统。据有关权威调查显示，传统的存储环境中，开放系统的容量利用率仅为40%至50%，这种低使用率造成了企业不得不耗费大量的额外成本来满足存储扩容的需求。

因此随着存储技术的不断发展，存储虚拟化技术与方案以其真正意义上的开放，在众多IT技术中脱颖而出。在虚拟存储环境下，存储对用户来说将变得透明，用户可以不必关心存储设备的功能差别、容量大小、设备类型和制造商如何，所有的设备将被统一管理，而且赋予统一的功能如Flashcopy、远程灾备等。今天，存储虚拟化已经不再是一个陌生的词汇，越来越多的企业开始关注存储虚拟，同时将其实施到IT规划中。

IBM TotalStorage SAN Volume Controller(SAN卷控制器以下简称SVC)和 IBM TotalStorage SAN File System(SAN文件控制器以下简称SFS)是IBM旗下两款虚拟化产品，有助于系统整合，更好地共享和利用数据，通过系统简化显著减少存储管理点和服务器的数量。

SVC：消除存储边界

面对着激烈的市场竞争，任何数据丢失和运营中断的情况都是企业所不能容忍的。然而，由于历史的原因，在传统的SAN网络中，每种存储系统都自成一体。复杂的存储基础架构，众多不同品牌的存储产品，不仅对日常存储管理带来很多不利，而且更难做到在不影响应用的前提下，迁移数据、改变或升级存储。

针对上述需求，借助虚拟存储将复杂的存储环境简单化，消除异构平台所造成的信息传递壁垒，实现了随需应变的存储体系，让存储真正实现按需分配是最好的解决办法。基于此，IBM的SVC是整个SAN网络的控制器，将整个SAN中的各种存储设备整合成一个巨大的存储池，充分利用存储资源并按需分配存储空间、性能和功能。

在很多传统的SAN磁盘阵列中，数据复制操作限于在存储内部进行或在同类磁盘之间进行。但在虚拟化SAN中，由于SVC是为一个完全开放的存储环境设计的，兼容各种不同的存储设备。用户可以将各种存储方案融合其中，而不用担心SVC会有什么封闭性。SVC允许用户横跨不同供应商的多个存储子系统使用一组单一的高级拷贝服务，如 FlashCopy和对等远程拷贝MetroMirror。该软件可通过扩展支持实现当前所有非IBM 磁盘存储系统的虚拟并对这些系统进行管理，帮助客户通过中央视图简化异构存储环境管理并实现管理的自动化。

SVC将存储控制功能集中到存储网络中可以实现平台统一。而统一的文件系统可以集中到SAN上，实现不同平台间的文件共享和数据生命周期管理。基于开放的集中式设备管理工具实现了资源管理和基于策略的自动化，同时可以通过SAN网管理、备份/恢复以及存储资源管理软件实现存储管理。此外，SVC还实现了虚拟存储层(Virtualization Layer)的功能，将存储智能加入到SAN的网络中。

现在用户可以按照应用不断变化的需求来分配存储，而不再受制于存储子系统设备在功能和性能上的限制。SVC又是一个SAN网络的中心管理控制点，而且它对服务器的操作系统和存储子系统透明。这一能力可以真正帮助客户实现异构环境的容灾。

IBM SVC在解决异构存储环境中的信息共享、灾难备份时是最富技术含量和最成熟的虚拟工具，在业界产生了很深远的影响。至今为止 IBM 已经帮助全球超过 1000 的客户通过虚拟技术来简化 IT 基础架构。如今，IBM公司又在原有的技术基础上，新推出SVC 3.1版本，将虚拟的性能大大增强，同时在可扩展性和互操作性方面有了进一步的提高，因而能够管理更大和更加多样化的环境，该版本可以同时管理1024个主机，支持所有主要主机和操作系统，性能大大提高。缓存容量也较前代版本提升了一倍，扩展至8GB。

SFS：让开放如此简单

SFS为开放系统环境引入了一种创新、高性价比和有效的模型。其中，公司的数据资产和数据存储资源由业务部门拥有，并不依赖于平台企业公用设施管理。这一模型的优势在于将数据的物理存储和设备与数据的管理使用隔离开来。因为这一虚拟存储公用设施通过系统管理的存储资源创建，客户可以自由选择和实现那些最适合其业务应用需求的数据存储技术。

SFS的应用案例拓扑，同样也是软硬件结合的产品，为用户复杂异构后台存储提供同一文件存储环境。

与SVC很相似，SFS是一个安装在SAN中的文件系统，也是一个软硬件结合的产品。它为各种不同的操作系统平台提供了一个统一的文件存储环境，将多个独立的文件系统抽象为一个共享文件系统，从而解决了传统SAN架构中的文件和数据管理问题，实现文件级的数据共享、存储分配和Serverless的数据备份，而且与SVC一样，它也具备了按照策略动态地调整存储设备配置，透明的迁移数据等虚拟存储SAN控制器的功能，而所有功能目的是围绕着文件级的存储服务展开的。

不仅如此，SFS又将分布式文件系统的设计理念和系统架构向前推进了一步。它们除了具有一般的分布式文件系统的特性之外，还采用SAN作为整个文件系统的数据存储和传输路径。它们采用带外(out-of-band)结构，将文件系统原数据在高速以太网上传输，由专门的原数据服务器来处理和存储。SAN File System采用了基于策略的文件数据位置选择方法，能有效地利用系统的资源，提高性能，降低成本。

IBM文件系统虚拟化(SFS)作为Out-of-band产品，虚拟存储控制器(Metadata server)处于系统数据通路之外，是基于Linux设计的高性能的集群SERVER，不直接参与数据的传输，服务器可以直接经过标准的光纤交换机存储设备进行访问。虚拟存储控制器对所有存储设备进行配置，并将配置信息提交给所有服务器。服务器在访问存储设备时，不再经过虚拟存储控制器，而是直接使存储设备并发工作，同样达到了增大传输带宽的目的。

同时文件系统虚拟化为不同操作系统的主机提供统一的文件系统，防止出现SERVER孤岛，可以达到SAN上的文件级共享(File level). 文件系统虚拟化可以实现Server Free备份、Cluster的自动接管、各种COPY功能及同一的文件管理。

虚拟化提升存储价值

虚拟技术正在促进存储业界的变革，IBM 的虚拟化存储解决方案支持统一的开放标准，可以统一管理不同存储设备厂商的产品，打破了存储领域一贯的厂商独家产品的壁垒。而且随着企业的数据增长，可以随时替换老化的设备或者增加新的设备，而不影响业务的正常运作，管理员不需要再像以前那样在夜里所有业务都停止的情况下才能开展工作。

在虚拟化环境中，所有的存储管理操作，例如系统升级、建立和分配虚拟磁盘、改变RAID级别、扩充存储空间等都可自动实现，使存储管理变得轻松简单。因此，企业需要通过开放性的虚拟存储解决方案构筑一个真正开放的存储环境，通过管理复杂的底层存储环境，存储虚拟化技术能够帮助简化基础设施，进而使用如跨企业创建单一虚拟信息池这样的技术帮助企业显著地降低IT管理成本。存储虚拟化解决方案是IBM随需应变信息战略的主要组成部分，它将帮助客户整合业务流程，更好的满足核心功能需求，在未来的信息时代里保持核心竞争力。

参考链接：http://virtual.51cto.com/art/201008/220653.htm

Top


Evli应用IBM绿色存储虚拟化成功案例

随着电子商务、多媒体、电子邮件和数据挖掘的发展，业务系统对存储容量的要求越来越大，每字节存储的硬件价格虽然在降低，但管理的成本却不断上升，因为随着容量及设备的增加，企业面临着管理上的很多问题。

应用背景

伴随着电子商务、多媒体、电子邮件和数据挖掘的发展，业务系统对存储容量的要求越来越大，每字节存储的硬件价格虽然在降低，但管理的成本却不断上升，因为随着容量及设备的增加，企业面临着管理上的很多问题。例如：存储设备往往是来自不同供应商的存储系统，如何实现对异构存储环境的整合和管理?如何在不增加人员或运营成本的情况下管理日益增加的存储容量?如何进一步提高存储设备的使用效率?如何对存储容量实现无缝扩展以满足应用需求?如何实现不同供应商的存储系统之间的灾备? 然而，“绿色”和虚拟化被IBM赋予了相辅相成的关系，绿色是目的，虚拟是手段，服务器、存储、网络、软件就是绿色的传播者。所以如何降低管理成本，降低整个存储的TCO(Total cost ownership)已经成为企业必须解决的问题，这些问题的答案就是绿色存储虚拟化技术。

用户需求

Evli的业务主要分布在美国和欧洲，所有的运转都建立在由Evli Investment Research的金融分析师所进行的广泛的研究工作上。这些分析师提供广泛的宏观经济以及特定公司的研究报告，这些有助于为客户提供附加值，并促进了后续的业务成功。

在银行业，高度的可用性和从计算机系统获取快速的响应是至关重要的，因为客户需要业务能以24×7的方式运行。为了符合联邦政府的需求，银行还需要一个灾难恢复方案来防止重要数据的丢失。尽管过去Evli没有在客户满意度或系统可靠性方面出现过问题，但银行希望避免那些能够让客户取不到钱的潜在计算机问题。

为了达到这个目标，Evli开始寻求一个低成本高收益的计算系统，它具有灾难恢复方案，并能提供顶级的性能和高可用性。该方案需要有足够的灵活性，从而能很容易地适应快速变化的金融业。

实施方案

虚拟存储是一种具有智能结构的系统，它允许客户以透明有效的方式在磁盘和磁带上存储数据，统一管理磁盘空间，使得客户的存储系统容纳更多的数据，也使得更多的用户可以共享同一个系统。在虚拟存储环境下，无论后端物理存储是什么设备，服务器及其应用系统看到的都是其物理设备的逻辑映像。即使物理存储发生变化，这种逻辑映像也不会改变，系统管理员不必再关心后端存储，只需专注于管理存储空间，所有的存储管理操作，例如系统升级、建立和分配虚拟磁盘、改变RAID级别、扩充存储空间等都比以前容易的多，存储管理变得轻松简单。

在虚拟存储环境下，存储对用户来说将变得透明，用户可以不必关心存储设备的功能差别、容量大小、设备类型和制造商如何，所有的设备将被统一管理，而且赋予统一的功能如Flashcopy、远程灾备等。

从存储的发展趋势来看，基于网络的虚拟化是发展的潮流。基于网络的虚拟存储可分为带内(In-band)或带外(Out-of-band)的虚拟存储架构。

在高性能的存储域网络的基础上，我们已经可以实现另外两种更高层次的存储虚拟化，即在物理层实现基于数据块的虚拟化和基于文件系统的虚拟化存储(SAN上的统一文件系统)。

IBM虚拟引擎(SVC)为In-band产品，是模块化的结构，可以有多个Cluster节点组成，每个节点有大的CACHE和高性能的处理器，位于存储和主机之间，可以把不同存储设备组成一个大型的存储池，其中的若干存储设备以一个统一逻辑设备存在，可以被系统中所有服务器访问，防止出现存储设备的信息孤岛。虚拟存储控制设备有多个数据通路与存储设备连接，多个存储设备并发工作，同时主机也可以有多条数据通路同虚拟引擎，多条路径并发工作。可以做到共享不同厂家存储设备，实现统一管理、远程灾备、本地的快闪备份及在线数据迁移等功能，真正的实现不同存储之间的Block级别的共享。

IBM文件系统虚拟化(SFS)为Out-of-band产品，虚拟存储控制器(Metadata server)处于系统数据通路之外，是基于Linux设计的高性能的集群SERVER，不直接参与数据的传输，服务器可以直接经过标准的光纤交换机存储设备进行访问。虚拟存储控制器对所有存储设备进行配置，并将配置信息提交给所有服务器。服务器在访问存储设备时，不再经过虚拟存储控制器，而是直接使存储设备并发工作，同样达到了增大传输带宽的目的。

同时文件系统虚拟化为不同操作系统的主机提供统一的文件系统，防止出现SERVER孤岛，可以达到SAN上的文件级共享(File level). 文件系统虚拟化可以实现Server Free备份、Cluster的自动接管、各种COPY功能及同一的文件管理。

IBM有完善的虚拟化产品，构成了全面的开放的虚拟化存储解决方案。同时用户可以针对自己的需求有多种选择，IBM将协助客户真正的实现虚拟存储，智能管理。

实施过程

在评估了几种方案后，Evli选择了IBM虚拟化存储解决方案来保护企业数据，从管理、会计以及人力资源(HR)功能到银行应用以及客户帐号信息。

银行使用了在芬兰赫尔辛基的两个站点的远程镜像，大约相距10公里。每个站点都配备了运行着Linux的IBM eServer xSeries 360服务器以及运行着HP-UX 11i的Hewlett-Packard/UNIX服务器来支持它的业务关键数据和应用。一个站点运行在IBM TotalStorage FAStT700 Storage Server上，另一个站点使用了IBM TotalStorage Enterprise Storage Server。

使用SVC虚拟化存储平台，解决了不同类型的存储服务器IBM TotalStorage Enterpreise Storage Server Model 800以及IBM TotalStorage FAStT700 Storage Server之间的数据复制问题。

使用SAN Volume Controller的PPRC和FlashCopy，使这些服务器用IBM存储软件进行了数据镜像处理，这提供了具有最优灾难恢复能力的层次化存储。

这个解决方案构建于两个主要的操作系统：HP-UX 11i和Linux，使用了VMWare ESX Server 2.0.1，它允许这些操作系统的几个实例同时在一台机器上运行，公司通过服务器虚拟化可以最佳的使用服务器的计算能力。

实施成果

IBM解决方案给Evli提供了一个计算平台，这使得公司能够快速适应未来的工业和调整性改变。这个新解决方案提供了层次化存储，用低成本换取了高性能。通过允许所有的服务器，包括Microsoft Windows服务器在一个平台上被巩固，它还帮助银行显著的缩减了运行费用。

Evli已经用VmWare虚拟了大约60个Windows和Linux服务器，就直接硬件花费一项就节省了约60,000欧元。当公司考虑缩减了的运行和维护费用时，所带来的节省将更加令人印象深刻。

"IBM存储解决方案独特的兼容性是使得IBM解决方案成为最好的一个主要原因。此外，IBM解决方案还有独特的方式来提供灾难恢复解决方案，它能在中端存储(midrange)和高端存储(high end storage)之间进行PPRC(对等网络远程复制)。同时在相同的支持虚拟服务器概念的管理层中使用低成本存储和性能磁盘能够大大节省操作和硬件费用。"——Ari Kyhala，IT-Director， Evli Pankki Oyj。

参考链接：http://cio.zdnet.com.cn/cio/2010/0322/1672813.shtml

Top


存储虚拟化相关链接

成功案例：

1.Denbighshire Council cuts storage costs and increases flexibility - Implementing an IBM Virtualised Disk Solution with help from Celerity

2.IDS Scheer AG shows how virtualization dramatically simplifies a complex IT infrastructure

3.重庆电力公司 CCS 系统存储整合项目

白皮书：

1.《IBM Storage Virtualization Guide for SAP landscapes and SAP private Clouds》

2.《Exchange 2010 High Availability and Disaster Recovery with SAN Volume Controller Replication》

3.《Deploying Oracle RAC 10g with ASM on AIX using IBM System Storage SAN Volume Controller》

4.《Leveraging SAN Volume Controller (SVC) Advanced Copy Services for Oracle User-Managed Backup and Recovery | Oracle RAC 10g with ASM》

5.《Deploying Oracle RAC 10g with ASM on Red Hat Enterprise Linux and SUSE Linux Enterprise Server with IBM SAN Volume Controller》

6.《IBM SAN Volume Controller Performance Configuration Guidelines for Implementing Oracle Databases with Automatic Storage Management (ASM)》

7.《IBM DS8000 Storage Virtualization Overview Including Storage Pool Striping, Thin Provisioning, Easy Tier》

红皮书：

1.《Implementing the IBM System Storage SAN Volume Controller V6.1》

2.《Implementing the IBM System Storage SAN Volume Controller V5.1》

3.《SAN Volume Controller Best Practices and Performance Guidelines》

4.《Using the SVC for Business Continuity》

相关链接：

IBM System Storage SAN 卷控制器

IBM Storwize V7000 中端磁盘系统

SVC 2145-CF8销售手册链接

Storwize V7000销售手册链接

Top


IBM专家热门推荐书籍

本期，《速查手册》更新了推荐热门书籍栏目。由IBM资深专家为我们推荐了与产品和技术相关的热门书籍，便于我们对IBM产品和技术的学习。

热门白皮书推荐

热门红皮书推荐


热门白皮书推荐

Power

1.《Configuring AIX Clusters for High Availability Using PowerHA SystemMirror for Systems Director》（英文）

简介：今天，高可靠的环境是至关重要的，能保证应用实现每天24小时不间断地运行是其成功的关键。在一个24x7x365的业务环境中，需要满足高可用性和可靠性的要求，就需要一个高可靠的应用。

AIX集群节点可以通过IBM Systems Director来配置一个高可靠的环境。System Director工具为集群的配置和管理提供图形化和命令行的管理界面(GUI和CLI)。

配置一个高可靠的应用程序除了需要很清楚的了解应用本身外，同时还需要了解PowerHA SystemMirror。因此，成功地配置一个高可靠的应用是一件具有挑战的事情。

在本白皮书中主要介绍了如何安装PowerHA SystemMirror Director插件，如何通过GUI和CLI的方式来配置和管理集群，并通过举例的方式提供每个步骤的截图。本白皮书为配置集群的技术人员提供一个便捷的参考指南。

2.《Power Systems SAN Multipath Configuration Using NPIV》（英文）

简介：本文介绍了Power服务器SAN端口使用NPIV的虚拟化功能配置SAN多路径的步骤。使用这种虚拟化功能，可以提高HBA端口的利用率，并减少HBA的需求。本白皮书主要介绍了在AIX的操作系统下，如何配置NPIV。

Storage

1.《IBM Easy Tier on DS8000, SVC and Storwize V7000 Deployment Considerations Guide》（英文）

简介：这本白皮书可以帮助IBM人员、代理商和客户规划、实施基于SSD固态盘的Easy Tier功能。Easy Tier功能可以应用到 IBM DS8000，SAN Volume Controller (SVC) 或 Storwize V7000等硬件产品。本文说明了如何部署SSD盘，使用Easy Tier的常见问题，以及一些需要注意的地方。

2.《New TSM 6 High Availability/Disaster Recovery - Electronic vaulting using deduplicated remote copy storage pools》（英文）

简介：这本白皮书描述了 Electronic Vaulting 解决方案，该方案基于 Tivoli Storage Manager 6 软件，它将保存在本地存储池中经过重复数据删除的数据复制到远程站点。通过DB2 HADR功能，本地服务器的数据库信息也被复制到远程备用服务器。

Top


热门红皮书推荐

Power

1.《IBM Power 710 and 730 Technical Overview and Introduction》（英文）

简介：该红皮书介绍了支持AIX, IBM I 和Linux操作系统的Power 710和730，及其重要的创新技术和卓越的性能，主要包含如下内容：

- 支持主频为3.0GHz, 3.55GHz和3.7GHz的POWER7处理器；
- IBM POWER7 专用的三级缓存提供了更高的带宽、性能和可靠性；
- 集成的1Gb或者10Gb的IVE卡，并提供了本地硬件的虚拟化功能；
- IBM PowerVM 虚拟化技术包含了PowerVM Live Partition Mobility和PowerVM Active Memory Sharing 技术；
- Active Memory Expansion技术提供了更多可用内存；
- IBM EnergyScale 技术提供电源监控，省电，热能测量等；
- 高的可用性、可靠性和可维护性。

本书提供了Power710和730的技术细节的描述，适用于希望更好地了解IBM Power System产品的专家精读。

2.《IBM Power 720 and 740 Technical Overview and Introduction》（英文）

简介：该红皮书介绍了支持AIX, IBM I 和Linux操作系统的Power 720和740，及其重要的创新技术和卓越的性能，主要包含如下内容：

- 支持主频为3.0GHz, 3.55GHz和3.7GHz的POWER7处理器；
- IBM POWER7 专用的三级缓存提供了更高的带宽、性能和可靠性；
- 集成的1Gb或者10Gb的IVE卡，并提供了本地硬件的虚拟化功能；
- IBM PowerVM 虚拟化技术包含了PowerVM Live Partition Mobility和PowerVM Active Memory Sharing 技术；
- Active Memory Expansion技术提供了更多可用内存；
- IBM EnergyScale 技术提供电源监控，省电，热能测量等；
- 高的可用性、可靠性和可维护性。

本书提供了Power720和740的技术细节的描述，适用于希望更好地了解IBM Power System产品的专家精读。

3.《IBM AIX Version 7.1 Differences Guide》（英文）

简介：本红皮书主要介绍了AIX 7.1标准版的新功能。它旨在帮助系统管理员，开发人员和用户了解AIX的新功能，并将这些新功能用于已有系统环境中。

AIX 7.1支持的新功能如下：

- Domain Role Based Access Control
- 增强的Workload Partition功能
- 增强的Topas性能工具
- 支持Terabyte segment
- 支持Cluster Aware AIX

AIX 7.1版本提供了很多新的功能，该红皮书可以帮助您了解相关新功能的介绍。

Storage

1.《IBM System Storage DS8800 Architecture and Implementation》（英文）

简介：IBM System Storage DS8800是IBM DS8000系列产品中最高级的机型，凭借新的 IBM POWER6+ 控制器、速度更快的 8Gbps 主机与设备适配器以及 6Gbps SAS（串行连接 SCSI）驱动器，新的 DS8800 型号可以大大提升性能。IBM System Storage Easy Tier 功能能够在多层系统中帮助优化固态存储部署。IBM System Storage DS8800 带来了高性能、高容量的安全存储系统，旨在为最苛刻的异构存储环境提供最高水平的性能、灵活性、可扩展性、弹性和总体价值。

该书介绍了IBM System Storage DS8800的相关概念、架构和操作方法。

本红皮书可以作为用户对DS8800进行规划、安装、配置的参考资料，也可以作为帮助用户了解DS8700架构和相关组件的文档。

2.《IBM Scale Out Network Attached Storage: Architecture, Planning, and Implementation Basics》（英文）

简介：IBM Scale Out Network Attached Storage (IBM SONAS)是一款可以高扩展型网络连接存储产品，它可以在企业级环境中管理庞大的信息库，通常这些信息库要求超大的容量、高速的性能以及高可用性。

通过NFS、CIFS、HTTP和FTP等网络协议，IBM SONAS为多种存储需求提供一系列可靠的，可扩展的解决方案。

利用内置的RAID技术、镜像、远程复制、快照和备份等功能为数据提供保护，并且提供简便的管理接口使安装、管理和维护变得简单、易懂。

该书详细介绍了SONAS产品的软硬件组成，以及配置、规划和调优等。

Top


虚拟租赁计划(VLP)

该虚拟租赁计划(VLP)提供免费远程访问IBM的硬件，包括在IBM AIX、IBM i和Linux操作系统中运行的基于IBM POWER6和 IBM POWER5处理器的服务器。

全自动的 IBM Virtual Loaner Program (VLP) 是使用 IBM 平台开发和演示软件解决方案的灵活而经济高效的方法。VLP 可供全球 IBM PartnerWorld 成员免费使用，具备以下关键优势：

.基于 Web 的预约、系统管理和用户支持；

.多语言支持，包括简体中文、马来语、日语、西班牙语、葡萄牙语、法语和韩语；

.高度安全地按需访问 IBM Power Systems 平台，其中包括 IBM AIX, IBM i、Linux SLES 和 RHEL；

.保存和恢复系统映像以供将来使用；

.通过 IBM 软件访问目录免费访问 IBM 中间件；

.能够测试最新的 Power Systems 虚拟化技术；

.实时 Web 对话和基于电子邮件的用户支持；

.制作 VLP 预约教程：ibm.com/partnerworld/wps/static/flash/flamovie/vlp_reservation072507.swf

VLP 特性：

.IBM Power Systems：POWER7、POWER6、POWER5；

.IBM Power 570 和 IBM BladeCenter POWER 服务器；

.IBM AIX 5.3 和 AIX 6.1；

.IBM i 5.4 和 IBM i 6.1；

.Red Hat：RHEL4 和 RHEL5; SUSE：SLES9、SLES10 和 SLES11；

.IBM 软件（从 IBM 软件访问目录 (SAC) 提供）；

.IBM PowerVM Lx86、Dynamic LPAR、Live Partion Mobility、Live Application Mobility、Workload Partitions 和 Micropartitions。

VLP 拥有优良的记录。自 2004 年以来，VLP 已为超过 2000 个 IBM 业务合作伙伴的 14000 多个系统预约提供支持。

VLP连接 的用户指南(中文)

VLP连接 的用户指南(英文)

详细了解 VLP 或请求租赁，请访问：VLP网站。

Top


竞争分析工具

本期更新了Power, 存储和System X 产品的竞争分析工具及链接，便于大家快速查询与友商相应产品之间的竞争分析信息。

1. IBM Power Systems Competitive Sales Tool

Version 19.1 (January 19, 2011)

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/B48EB3335EFE53390025730900271CD0?Opendocument?OpenDocument

2.IBM System Storage Competitive Sales Tool

Version 10.15（December 21, 2010）

http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/4F68C0CF2311C10D002573720020B21B?Opendocument

    3.IBM System x and BladeCenter Competitive Sales Tool

    Version 6.6 (January 26, 2011)

    http://partners.boulder.ibm.com/src/compdlib.nsf/BPSearchView/866349302F36EA6A872571D000760F0C?Opendocument

访问方法：
第一步：点击相应产品竞争工具的链接
第二步：进入"PartnerWorld: sign in"界面，在IBM ID和Password文本框中输入用户名和密码
第三步：进入工具下载页，在工具图标（后缀为exe文件）上单击鼠标右键，选择“目标另存为...(Save as...)”，将工具保存到本地
第四步：运行下载的exe文件


2010年第4季度热门问题排行榜

本期热门问题排行榜, 由高到低列出了第4季度客户最常问的20个问题，便于大家查看和学习。

2010年第4季度热门问题排行榜 - Power

2010年第4季度热门问题排行榜 - Storage


Power和Storage产品技术支持信息周报

Power&Storage产品技术支持信息周报

为了帮助IBM合作伙伴更方便、更及时地获得IBM最新的产品和技术信息，IBM中国技术支持中心推出“技术周报”的免费支持服务，每周以手机短信、电子邮件和发布在IBM技术支持网站的方式，提供最近一周"常见的五至十个技术问题和答案"，内容主要针对System Power与存储产品，服务对象是和IBM签约的合作伙伴。如果您需要免费订阅或退订此服务，请联系IBM 业务合作伙伴专线 800-810-1166 分机 5060。

Power and Storage技术周报

Power and Storage技术周报

2011-02, 第一期，Power&存储 产品技术支持信息周报

2011-01, 第三期，Power&存储 产品技术支持信息周报

2011-01, 第二期，Power&存储 产品技术支持信息周报

2011-01, 第一期，Power&存储 产品技术支持信息周报

2010-12, 第五期，Power&存储 产品技术支持信息周报

2010-12, 第四期，Power&存储 产品技术支持信息周报

2010-12, 第三期，Power&存储 产品技术支持信息周报

2010-12, 第二期，Power&存储 产品技术支持信息周报

2010-12, 第一期，Power&存储 产品技术支持信息周报

2010-11, 第四期，Power&存储 产品技术支持信息周报

2010-11, 第三期，Power&存储 产品技术支持信息周报

2010-11, 第二期，Power&存储 产品技术支持信息周报

2010-11, 第一期，Power&存储 产品技术支持信息周报

2010-10, 第三期，Power&存储 产品技术支持信息周报

2010-10, 第二期，Power&存储 产品技术支持信息周报

2010-10, 第一期，Power&存储 产品技术支持信息周报

2010-09, 第四期，Power&存储 产品技术支持信息周报

2010-09, 第三期，Power&存储 产品技术支持信息周报

2010-09, 第二期，Power&存储 产品技术支持信息周报

2010-09, 第一期，Power&存储 产品技术支持信息周报

2010-08, 第四期，Power&存储 产品技术支持信息周报

2010-08, 第三期，Power&存储 产品技术支持信息周报

2010-08, 第二期，Power&存储 产品技术支持信息周报

2010-08, 第一期，Power&存储 产品技术支持信息周报

2010-07, 第四期，Power&存储 产品技术支持信息周报

2010-07, 第三期，Power&存储 产品技术支持信息周报

2010-07, 第二期，Power&存储 产品技术支持信息周报

2010-07, 第一期，Power&存储 产品技术支持信息周报

2010-06, 第四期，Power&存储 产品技术支持信息周报

2010-06, 第三期，Power&存储 产品技术支持信息周报

2010-06, 第二期，Power&存储 产品技术支持信息周报

2010-06, 第一期，Power&存储 产品技术支持信息周报

2010-05, 第四期，Power&存储 产品技术支持信息周报

2010-05, 第三期，Power&存储 产品技术支持信息周报

2010-05, 第二期，Power&存储 产品技术支持信息周报

2010-05, 第一期，Power&存储 产品技术支持信息周报

2010-04, 第四期，Power&存储 产品技术支持信息周报

2010-04, 第三期，Power&存储 产品技术支持信息周报

2010-04, 第二期，Power&存储 产品技术支持信息周报

2010-04, 第一期，Power&存储 产品技术支持信息周报

2010-03, 第五期，Power&存储 产品技术支持信息周报

2010-03, 第四期，Power&存储 产品技术支持信息周报

2010-03, 第三期，Power&存储 产品技术支持信息周报

2010-03, 第二期，Power&存储 产品技术支持信息周报

2010-03, 第一期，Power&存储 产品技术支持信息周报

2010-02, 第三期，Power&存储 产品技术支持信息周报

2010-02, 第二期，Power&存储 产品技术支持信息周报

2010-02, 第一期，Power&存储 产品技术支持信息周报

2010-01, 第四期，Power&存储 产品技术支持信息周报

2010-01, 第三期，Power&存储 产品技术支持信息周报

2010-01, 第二期，Power&存储 产品技术支持信息周报

2010-01, 第一期，Power&存储 产品技术支持信息周报

2009-12, 第五期，Power&存储 产品技术支持信息周报

2009-12, 第四期，Power&存储 产品技术支持信息周报

2009-12, 第三期，Power&存储 产品技术支持信息周报

2009-12, 第二期，Power&存储 产品技术支持信息周报

2009-12, 第一期，Power&存储 产品技术支持信息周报

2009-11, 第四期，Power&存储 产品技术支持信息周报

2009-11, 第三期，Power&存储 产品技术支持信息周报

2009-11, 第二期，Power&存储 产品技术支持信息周报

2009-11, 第一期，Power&存储 产品技术支持信息周报

2009-10, 第三期，Power&存储 产品技术支持信息周报

2009-10, 第二期，Power&存储 产品技术支持信息周报

2009-10, 第一期，Power&存储 产品技术支持信息周报

2009-09, 第五期，Power&存储 产品技术支持信息周报

2009-09, 第四期，Power&存储 产品技术支持信息周报

2009-09, 第三期，Power&存储 产品技术支持信息周报

2009-09, 第二期，Power&存储 产品技术支持信息周报

2009-09, 第一期，Power&存储 产品技术支持信息周报

2009-08, 第四期，Power&存储 产品技术支持信息周报

2009-08, 第三期，Power&存储 产品技术支持信息周报

2009-08, 第二期，Power&存储 产品技术支持信息周报

2009-08, 第一期，Power&存储 产品技术支持信息周报

2009-07, 第五期，Power&存储 产品技术支持信息周报

2009-07, 第四期，Power&存储 产品技术支持信息周报

2009-07, 第三期，Power&存储 产品技术支持信息周报

2009-07, 第二期，Power&存储 产品技术支持信息周报

2009-07, 第一期，Power&存储 产品技术支持信息周报

Top


《IBM售前技术火线速查手册》调查反馈

《IBM售前技术火线速查手册》调查表

注： 为必填选项

1.姓名：

2.公司(非IBM BP请详细填写公司名称,IBM客户请填写客户)：

3.请选择您在销售过程中，经常用到的IBM售前配置工具：

IBM售前技术火线速查手册
e-Config配置工具（Power和存储）
TPCC计算小工具
POWER6/POWER7产品e-Config配置输出文件转中文小工具
存储产品e-Config配置输出文件转中文小工具
电源计算工具
销售手册快速查询通道
其它

4.《IBM售前技术火线速查手册》的推出是否对您有所帮助：

5.请具体指出本手册在下列哪些方面为您提供了帮助：

提高现有技术水平
了解新的技术知识
发现新的商机
其它

6.请选择您对《IBM售前技术火线速查手册》2011年第1期的满意度：

(10为满意度最高，1为满意度最低)

7.您认为本手册每周能帮助您节省多少工作时间：

小于5小时
5-10小时
10-20小时
20小时以上

8.《IBM售前技术火线速查手册》在内容方面您比较满意哪些方面：

售前常见问题汇总
售前常见配置问题汇总
携手IBM，开启虚拟化之旅
IBM专家推荐热门书籍
竞争分析工具
2010年4季度最热门问题
Power&Storage产品技术支持信息周报
其它

9.您希望我们今后在哪些技术领域及解决方案方面给您提供更多的技术支持（包括其他改进意见）：


如何获取《IBM售前技术火线速查手册》新版本

关于《IBM售前技术火线速查手册》下载的信息：

下载网址： http://www-900.ibm.com/cn/support/viewdoc/uprosupport?pageid=0&category=7&docordown=7

下载方式：具体方式如下图，通过选择“Cross Platform”，然后点击“Go”，可以查询到最新版的《IBM售前技术火线速查手册》，然后进行登录和下载。

手册使用介绍：

课程名称：《IBM售前技术火线速查手册》使用介绍
课程介绍：教您如何使用《IBM售前技术火线速查手册》及IBM技术支持工程师日常使用的查询工具
课程回放：https://sas.elluminate.com/dr.jnlp?suid=D.C79E79573E026A4A43AD0A52D5AB94&sid=2008517

如何开通下载权限和注册方式?

. 如果您已有个人售前技术咨询专号(Service ID)，并为IBM技术支持网的注册用户，可以直接下载最新版的《IBM售前技术火线速查手册》；

. 如果您已有个人售前技术咨询专号(Service ID)，但还未成为IBM技术支持网的注册用户，请从如下链接去注册您的个人用户名。请注意，在注册中“联系方式”一项，需要填写与Service ID所对应的手机号，否则将有可能无法下载此手册；

注册网址：https://www-900.ibm.com/cn/support/register.jsp

. 如果您已是IBM技术支持网的注册用户，但未申请个人售前技术咨询专号(Service ID)，请致电 800-810-1166 或 010-82456688，分机5060申请开通下载此手册的权限。

请您阅读并遵守此手册的使用条款，下载完此手册后请勿网站上载及传播。如果您对此手册的下载有任何疑问，请致电业务合作伙伴专线800-810-1166 或010-82456688，分机5060。

如果您有任何意见和建议，请您在此手册的调查反馈表中，直接填写并提交，我们期待您的任何反馈。感谢您的合作与支持！


联系我们

如果您有任何意见和建议，欢迎与我们联系。

E-mail： techline@cn.ibm.com

Tel：8008101166-5060 / (010)82456688-5060

IBM中国技术支持中心 编制


使用条款

《IBM售前技术火线速查手册》（下面简称为“速查手册”）,非IBM正式电子出版物,仅供IBM内部销售人员和IBM核心合作伙伴参考使用。使用此“速查手册”，您即承认您已阅读、理解并同意受这些条款的约束，并遵守所有适用的法律和法规。如果您不同意这些条款，请不要使用此“速查手册”。

IBM 可随时通过更新“速查手册”来修改这些“使用条款”以及此“速查手册”中包含的任何其他信息，而无需通知您。IBM 还可以随时对此“速查手册”中描述的产品、服务或程序进行改进或更改，而无需另行通知。

此“速查手册”包含所有权声明和版权信息，您必须遵守并服从所有相关的条款。未经 IBM 事先的书面同意，不得在其他网站上载、张贴、传播、分发或使用此“速查手册”及其中的所有内容创作演绎作品，除非 IBM 授予您一份非专属的、不可转让的且有限的许可，允许您仅在您的计算机上为了您个人使用而非商业性使用此“速查手册”的目的访问和显示此“速查手册”内的内容。此许可权的条件是：您不修改此“速查手册”的内容，完整地保留所有的版权、商标和其他专有权声明并且您接受该内容随附的任何条款、条件和声明，及此“速查手册”中的所有其他规定。

如果您未遵守此“速查手册”上的条款、条件和声明，则授予您的任何权利将自动终止，而无需事先通知，并且您必须立即销毁您所拥有或掌握的所有已下载资料副本。除了前一段中的有限许可权，IBM不授予您关于任何专利、商标、版权或其他专有权或知识产权的任何明示的或暗含的权利或许可。您不得在另一个 Web 站点或任何其他介质中设置此“速查手册”任何内容的镜像。

特定免责条款

此“速查手册”的信息不附带任何有关正确性、最新性及完整性的承诺和保证，并且此“速查手册”可能包含有技术方面不够准确的地方或排字错误。IBM 不承担以下责任（且明确声明免除以下责任）：更新此“速查手册”使信息保持最新或者确保任何已张贴信息的准确性或完整性。因此，关于此“速查手册”中描述的任何服务、产品或其他事项作出任何决策之前，您应该确认所有已张贴信息的准确性和完整性。

IBM 不保证任何被告知／报告的问题将由 IBM 解决，即使 IBM 选择为了解决某个问题提供信息，也是如此。

业务关系

此“速查手册”可能提供非 IBM Web 站点和资源的链接或引用。IBM 对于任何非 IBM Web 站点或第三方资源（包括任何 Lenovo Web 站点）不作任何声明、保证或其他承诺，即使这些 Web 站点或第三方资源可能引用了任何 IBM 站点，或者可从任何 IBM 站点访问或链接到任何 IBM 站点。到某个非 IBM Web 站点的链接并不意味着 IBM 认可此类 Web 站点的内容或使用或其所有者。此外，IBM 不是您可能与任何第三方签署协议的任何交易的一方也不对任何交易负责，即使您从某个 IBM 站点了解到此类第三方（或使用到此类第三方的链接），也是如此。因此，您承认并同意，IBM 不对此类外部站点或资源的可用性负责，也不对可从那些站点或资源上获得的任何内容、服务、产品或其他资料承担任何责任或义务。

当您访问某个非 IBM Web 站点（即使该站点可能包含 IBM 徽标），请理解该 Web 站点与 IBM 无关并且 IBM 不控制该 Web 站点上的内容。您须谨慎从事，避免遭受病毒、蠕虫病毒、特洛伊木马和其他可能的破坏性程序入侵并采取您认为适当的方式保护您的信息。

翻译

此“速查手册”中某些文本提供有英语以外的其他语言。文本可能由人员翻译或者仅由计算机软件翻译，而没有人的参与或审核。这些翻译版是为了您的方便起见提供的，关于 翻译（无论机器翻译的或人翻译的）的准确性或完整性，IBM 不作任何声明或承诺。请参阅下面的“不保证声明”以了解更多的条款和条件。

不保证声明

使用此“速查手册”所带来的风险由您自行承担。所有资料、信息、产品、软件、程序和服务均“按现状”提供，不附有任何形式的保证或担保。在法律许可的最大范围内，IBM 明确声明免除所有明示的、暗含的、法定的和其他保证、担保、声明或承诺，包括但不限于有关适销、适用于某种特定用途以及有关所有权和知识产权的非侵权的保证。在不受任何限制的情况下，IBM 不保证，此“速查手册”将不中断、及时、安全或无错误。

您理解并同意，如果您下载或以其他方式获得此“速查手册”，则您自行决定执行上述操作，且风险由您自行承担，并且您须自行负责可能产生的任何损害赔偿，包括数据的丢失或对您的计算机系统的损害。

某些司法区域的强制性法律不允许对保证有所排除，在此情况下则上述排除可能不适用于您。

责任限制

任何情况下，对于此“速查手册”导致的或由于使用此“速查手册”或由于使用链接到、引用此“速查手册”或通过此“速查手册”访问的任何站点或资源，或者由于使用、下载或访问任何资料、信息、产品或服务而导致的或与之相关的任何直接的、间接的、附带的、特别的、惩戒性的或任何种类的后果性的损害赔偿，包括但不限于任何利润的损失、商业中断、可节省金额的损失或者程序或其他数据的丢失，IBM 均不对任何一方负责，即使 IBM 已被明确告知可能有此类损害赔偿时，也是如此。这种关于责任的排除和放弃适用于所有诉因，无论是基于合同、保证、民事侵权行为还是任何其他法律理论。

附加的或不同的条款、条件和声明可能适用于通过此“速查手册”提供的特定资料、信息、产品、软件和服务。如有任何冲突，此类附加的或不同的条款、条件和声明将优先适用于这些“使用条款”。请参阅相应的协议或声明。

Top


2010年第4季度热门问题排行榜 - Power

(1) System P 系列 Server 的 CPU, Memory, IO 的带宽

(2) 如何配置Power 550服务器内置磁盘分区的功能

(3) 如何配置Power 520和550 3个及以上分区

(4) 7014-T00/T42/B42机柜PDU和电源线的配置

(5) Power 550六种硬盘背板的介绍

(6) System P Server 的外置磁带和光驱存储设备(7214-1U2)可支持多少个媒体设备

(7) Power 570 在一个CEC中，如何配置2个分区

(8) Power 720/740 硬盘背板介绍

(9) Power 720/740支持的PCI槽位信息

(10) P系列服务器的切换器(7316-TF3，fc#4283)及相关的线缆的图解

(11) PowerHA Standard Edition V6.1 和 PowerHA Enterprise Edition V6.1 分别包含什么功能

(12) 在e-config中，Power 520/550 可以配置的内置磁带机和磁带介绍

(13) 如何在Power770/780上实现硬盘背板的分离

(14) 在System P 的HACMP方案里，推荐的e-config 配置范例

(15) Power 720/740服务器内置硬盘如何分离背板，是否需要添加额外的线缆

(16) Power中异步卡和串口线的选择

(17) 如何在Power750上实现硬盘背板的分离

(18) 什么是PowerVM

(19) 如何在Power 520/550服务器上创建RAID 5？

(20) 7989-BCH机箱怎样配置冗余的电源以及电源线

Top


2010年第4季度热门问题排行榜 - Storage

(1) DS5020 e-config中Adapters选项配置

(2) DS5020 e-config中Features选项配置

(3) DS5020 接口类型、数量及相关问题

(4) DS5100/DS5300 主机接口卡的配置方式

(5) TS7650(3958-AP1)硬件中Features的配置

(6) TS7650G(3958-DD4)硬件中features的配置

(7) DS5100 License配置(Host kit、Storage Partition、FlashCopy、VolumeCopy、ERM等)

(8) DS5020 SFP与线缆配制方法

(9) DS5020硬盘配置注意事项

(10) B24/B40/B80三款SAN交换机SFP模块与光纤线的选择

(11) DS5100/S5300 SFP与线缆配置方法

(12) TS7650G 软件的配置

(13) DS5000系列 CPU、缓存信息与配置

(14) TS7650G硬件中Console的配置

(15) TS3100 e-config中feature选项的配置

(16) DS8700的磁盘配置注意事项

(17) TS3310 e-config中Feature选项的配置

(18) TS3500 e-config中drive选项的配置

(19) B24/B40/B80配置中所有License包含的功能

(20) TS3200 驱动器与线缆选择及配置


DS5020 e-config中Adapters选项配置

解答:

1.目前DS5020机头的配置中，有两种主机接口卡的配置：
a)2个双端口的8 GB光纤主机接口卡；
b)2个双端口的1 GB iSCSI主机接口卡。

2.配置注意事项：
a)DS5020默认带有4个8 GB光纤主机接口；
b)当在e-config配置中选择2080时，该DS5020即有8个8 GB光纤主机接口；
c)当在e-config配置中选择2081时，改DS5020即有4个8 GB光纤主机接口和4个1 GB iSCSI主机接口；
d)fc#2080和fc#2081选项只能在初始配置时定制，后期不可扩展；
e)所有主机接口都自带有SFP模块，不需要额外配置。

参考资料：DS5020销售手册（Sale Manual）


DS5020 e-config中Features选项配置

解答:

配置注意事项：

a)DS5020默认2GB缓存，即每个控制器1GB，当添加fc#2070时，就变成4GB缓存，即每控制器2GB。该缓存扩展模块只能在出厂前设定，后期不可升级；

b)DS5202当添加到33-64块硬盘时，需要添加fc#7393的磁盘数量许可（license）；

c)DS5202当添加到65-112块硬盘时，需要添加fc#7394的磁盘数量许可（license）；

d)fc#7401为DS5020快照(Flash Copy)功能的激活，该功能激活后，对同一个逻辑卷（LUN）只可保留4个时间点的快照数据。一般客户没有特殊数说明，配置该激活即可；

e)当客户需要对同一个逻辑卷（LUN）保留4个以上时间点的快照数据时，则需要添加fc#7402。把对同一个逻辑卷（LUN）的快照个数扩展到8个时间点；

f)fc#7403为卷拷贝(Volume Copy)的功能激活许可；

g)fc#7404快照(Flash Copy)和卷拷贝(Volume Copy)功能的打包许可，包含了fc#7401和fc#7403；

h)fc#7405为DS5020远程镜像（Enhanced Remote Mirror）功能的激活，该功能激活后，可实现32组逻辑卷（LUN）之间实现镜像。一般客户没有特殊数说明，配置该激活即可；

i)当客户需要对大于32组逻辑卷（LUN）进行镜像的时候，则需要添加fc#7406。把远程镜像的镜像对从32组扩展到64组；

j)当客户需要配置加密硬盘的时候，必须添加fc#7410加密激活许可（license）；

k)目前，DS5020支持两种扩展柜，EXP520及EXP810。当需要连接EXP810扩展柜时，需要添加fc#7414许可，确保EXP810的正常连接。另，在DS5020的配置界面中并没有EXP810的配置界面，需要单独配置；

l)fc#8S1106是一个只有内部sales可以订购的特殊许可，需要走产品部的RPQ流程。该许可为并行访问的功能。

参考资料：DS5020销售手册（Sale Manual）


DS5020 接口类型、数量及相关问题

解答:

1. 主机通道端口（Host Channel Port）:

DS5020有两种类型的主机端口，8Gbps FC主机接口用于连接主机HBA卡或者光纤交换机，实现FC SAN功能；1Gbps iSCSI主机接口用于连接以太网卡、iSCSI卡或者以太网交换机，实现IP SAN功能。DS5020最少配置4个FC主机端口（每个控制器2个FC主机端口），也可以再增加4个FC主机端口或者4个iSCSI主机端口。在e-config中可以配置出三种数量和类型主机接口的DS5020：

1) 既不选择fc#2080，也不选择fc#2081，则DS5020共有4个8Gbps FC主机端口（每个控制器2个FC主机端口）；
2) 选择fc#2080，则DS5020共有8个8Gbps FC主机端口（每个控制器4个FC主机端口）；
3) 选择fc#2081，则DS5020共有4个8Gbps FC主机端口和4个1Gbps iSCSI主机端口（每个控制器2个FC主机端口，2个iSCSI主机端口）；其中FC主机端口均随机自带SFP模块，此外到目前为止，以上三种配置的DS5020不能更改或升级主机端口的配置。

2. 扩展磁盘通道端口（Drive Channel Port）

DS5020一共有4个扩展磁盘通道端口，每个控制器2个，并且随机自带SFP模块。该端口用于连接后端的扩展柜，如：EXP520或EXP810。每两个端口（每个控制器一个）形成一组冗余扩展磁盘通道对（Redundant drive channel pair），每个通道组最多可以连接3台扩展柜。由端口数可知，DS5020可以形成2组通道对，最多连接6台扩展柜。

3. 其他端口

1) 以太网管理端口（RJ45）：DS5020一共有4个以太网管理端口，每个控制器2个。一般配合DS Storage Manager软件实现带外（out-of-band）配置与管理DS5020。
2）串行管理口（PS/2）：DS5020一共有2个以太网管理端口，每个控制器1个。用于IBM服务人员对DS5020进行诊断操作。


DS5100 License配置(Host kit、Storage Partition、FlashCopy、VolumeCopy、ERM等)

解答:

fc#77xx Host kit是必选项（至少选择一项），可以根据连接DS5100服务器的操作系统，选择相应的Host kit；

fc#89xx Storage Partition是必选项，根据客户需求选择相应数量，最少8个Partition, 最多512个Partition。关于Partition更多信息可参考以下链接：
http://www-900.ibm.com/cn/downloadfiles/tsc/faq/2694056L12000.doc

fc#203x Cache Memory是必选项，DS5100支持8、16、32和64GB缓存，可以根据性能需求选择；

Flash/VolumeCopy，Enhanced Remote Mirror，Disk Encryption Activation是可选项，实现快照/卷拷贝，远程拷贝与加密功能。

fc#7350是Flash/VolumeCopy，包括快照功能和卷拷贝功能选件。快照功能可以很快完成数据卷的拷贝，对于测试、备份等应用有很大帮助。VolumeCopy是数据从源卷到目标卷的完全复制，是数据的物理拷贝。通常VolumeCopy与Flashcopy结合使用。它利用了FlashCopy能够生成一份数据时间点快照的功能，保证了在卷拷贝数据复制过程中源卷的可用性和目标卷数据的一致性。Flash/VolumeCopy是在同一个DS5100内实现的功能。

fc#7353是Enhanced Remote Mirror增强型远程镜像选件，可以把本地DS5000上的数据通过光纤同步或者异步复制到远端的DS5000上，从而可以实现DS5000数据的容灾。fc#7356可以将镜像对数量从64个提高到128个。Enhanced Remote Mirror是在两台DS5100之间实现的功能。

fc#7358是磁盘加密选件，需要配合扩展柜中的fc#552x和fc#554x加密硬盘使用。全盘加密（FDE）磁盘驱动器能够显著减少所存储数据存在的安全漏洞。遵从“受信任存储器组（Trusted Storage Group，TCG）”企业安全子系统分类规范的 FDE 磁盘驱动器获得国家安全局（National Security Agency）的资格认证，提供了具有政府级别加密功能的安全性。

此外，DS5100默认支持SATA和FC硬盘混插，如果一个DS5100存储子系统包括FC和SATA硬盘，不需要购买许可，默认即可支持。

fc#7371是扩展柜许可选件，DS5100默认最大支持16个1818-D1A，如果1818-D1A大于16个，需要选择该选件；fc#7371，最大支持28个1818-D1A扩展柜。

fc#7372是扩展柜许可选件，DS5100默认最大支持7个EXP5060高密度扩展柜，如果配置8个EXP5060，需要该选件fc#7372和fc#7371，最大支持8个EXP5060扩展柜。

网络课堂：http://www-900.ibm.com/cn/support/viewdoc/detail?DocId=7593538L02000


TS3100 e-config中feature选项的配置

解答:

1.TS3100 e-config配置中features选项的配置注意事项:

a)fc#5900是加密激活的许可(license)只有LTO4或LTO5的驱动器才支持硬件加密功能，LTO3的驱动器并不支持此功能；

b)fc#7703是不带 IBM 标识(logo)的许可；

c)fc#1682是路径冗余的功能激活许可(license)。这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的；

d)fc#7002是上架套件，fc#9848是PDU电源线，若需要将TS3100放置在机柜中，这两个许可是必选的，而且必须同时选择；

e)fc#8106,fc#8109都是额外的磁带仓，用于批量更换磁带，一般不需要订购，TS3100缺省已经配有2个可移动的magzine，提供24个槽位，其中包括1个I/O槽位；

f)fc#8002是清洗带，每个选件表示1盘清洗带；

g)fc#8305,#8405,#8505分别为LTO3,LTO4,LTO5的数据磁带，均为5盘一包，不带标签（一般不建议客户配置这种不带标签的数据带）。

2.参考资料
a)名称：TS3100 销售手册（Sales Manual）
链接：http://www-01.ibm.com/common/ssi/rep_sm/1/872/ENUS3573-_h01/index.html

b)名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
章节：第八章
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


TS3200 驱动器与线缆选择及配置

解答:

TS3200最大支持的2个全高或4个半高驱动器，以下是驱动器和接口类型：

fc#8043 SCSI LTO3 全高 接口：HD68
fc#8044 FC LTO3 全高 接口：LC
fc#8046 SCSI LTO3 半高 接口：HD68
fc#8047 SAS LTO3 半高 接口：mini-SAS

fc#8143 SCSI LTO4 全高 接口：HD68
fc#8144 FC LTO4 全高 接口：LC
fc#8145 SAS LTO4 全高 接口：mini-SAS
fc#8147 SAS LTO4 半高 接口：mini-SAS

fc#8244 FC LTO5 全高 接口：LC
fc#8245 SAS LTO5 全高 接口：mini-SAS
fc#8247 SAS LTO5 半高 接口：mini-SAS
fc#8248 FC LTO5 半高 接口：LC

对于SCSI、SAS和FC的驱动器，需要根据驱动器接口类型和主机通道卡的接口类型以及TS3200与主机的距离，选择适当标准和长度的线缆；

其中对于SAS驱动器，目前SAS 接口类型主要分两种：SFF-8088(MiniSAS) 和SFF-8470(SAS)。IBM所有SAS磁带机或者磁带库后端接口类型都是SFF-8088。

在SAS磁带设备e-config配置时，在线缆选项中，会有两种线缆选择：

一种是SAS/MiniSAS。

一种是MiniSAS/MiniSAS。

在磁带设备这端需要用MiniSAS的头，所以线缆类型的选择取决于主机端SAS HBA卡的接口类型。

目前，在IBM X服务器上常用的SAS卡25R8060是SFF-8088的接口类型，SAS3800X是SFF-8470的接口类型。


TS3310 e-config中Feature选项的配置

解答:

1. fc#7003是上架套件，fc#9848是PDU电源线，若需要将TS3310放置在机柜中，这两个许可是必选的，而且必须同时选择；

2. fc#1640是扩展柜槽位激活的许可，#1640的数量与扩展柜E9U的数量相同，若不激活#1640,扩展柜只有半数46个槽位激活，反之则是全部92个槽位激活；

3. fc#1650是高级报告功能，它主要提供了介质完整的分析报告和驱动器资源利用率的功能，这也给用户分析数据提供了图形化显示并以此来帮助用户评估磁带库性能和驱动器利用率；

4. fc#1682是路径冗余的功能激活许可(license)。这个许可包含控制链路（control path）的冗余及数据链路（data path）的冗余两部分，是选配的；

5. fc#5900是加密激活的许可(license)。只有LTO4或LTO5的驱动器才支持硬件加密功能，LTO3的驱动器并不支持此功能；

6. fc#9900是加密出版物，该许可免费；

7. fc#8002是清洗带；

8. fc#9210,#9211,#9212,#9215分别为连接各类型操作系统的许可。

参考资料
1.名称：TS3310 销售手册（sales manual）
链接：http://www-01.ibm.com/common/ssi/ShowDoc.jsp?docURL=/common/ssi/rep_sm/1/872/ENUS3576-_h01/index.html&InfoType=DD&InfoSubType=SM&panelurl=index.wss&paneltext=HW+%26+SW+desc+%28Sales+manual,+RPQ%29

2.名称：《IBM System Storage Tape Library Guide for Open Systems》
书号：sg245946
章节：第十章
链接：http://www.redbooks.ibm.com/redbooks/pdfs/sg245946.pdf

Top


TS3500 e-config中drive选项的配置

解答:

TS3500有两种型号3584-L53和3584-L23，两者支持的驱动器类型不相同，槽位数量也不相同，在e-config配置中drive的配置注意事项：

1.3584-L53：

a)fc#9681/#9682/#9685分别表示工厂安装3588-F3B/F4A/F5A驱动器，其数量与所配置的驱动器数量一致,最大不能超过12；
b)fc#9679/9696表示现场安装驱动器，其数量与驱动器数量一致，最大不能超过12；
c)fc#9001无驱动器的标识；
d)fc#1678是3588驱动器安装协助，该feature可与fc#9679/9696同时配置，表示是否需要现场安装协助；
e)fc#1514是LTO驱动器上架套件，其数量与驱动器数量一致，最大不能超过12。

2.3584-L23：
a)fc#9680/#9683分别表示工厂安装3592-E05/E06驱动器，其数量与所配置的驱动器数量一致,最大不能超过12；
b)fc#1674表示现场安装驱动器，其数量与驱动器数量一致，最大不能超过12；
c)fc#9001无驱动器的标识；
d)fc#1513上架套件通常用于3592-E05，最大数量不超过12；
e)fc#1515上架套件用于3592-E06/EU6，最大数量不超过12。

3.参考资料
名称：TS3500 销售手册（sales manual）

Top


TS7650(3958-AP1)硬件中Features的配置

解答:

TS7650(3958-AP1)Features配置如下：

(#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(#3170) 16 2.27 GHz Processor Cores
表示提供一个 x3850 X2 processor，是必须要选的，最大数量都是2，最小数量都是1。

(#3707) 4.8 TB FC Disk Expansion
表示是DS5020 expansion drawer，带有 16 块FC硬盘，是必须要选的，最大数量都是6，最小数量都是1。

(#3708) 4.8 TB FC Disk Controller
表示是DS5020 controller，带有 16 块FC硬盘，是必须要选的，最大数量都是2，最小数量都是1。

(#08XX) Initial Configuration Indicators
表示是初始配置容量的标示符。

以下分别是VTL和OST支持的4种配置方案：

Top


TS7650G 软件的配置

解答:

1．在配置完成了TS7650G的硬件后，双击e-config窗口中中间栏的software Products（software Platform）

2．在下列窗口中，不做任何修改，直接点击next按钮.

3. 在下列窗口中，不做任何修改，直接点击next按钮

4. 在下列窗口中，不做任何修改，直接点击next按钮

5. 在下列窗口选择软件的warranty时间，缺省是1年，也可以选择3年等其他年限。

6．在下列窗口中可以选择软件功能的license，其中5639-XXB ProtecTier VTL Per Server缺省选中，不需修改，Capacity support表示是重复数据删除功能的license，cluster support表示是cluster 功能的license，replication support表示是远程复制功能的license。

7．在下列窗口中，不做任何修改，直接点击next按钮.

8．接下来的窗口依次分别是前面选择的Capacity support/cluster support/replication support 的容量的定义窗口

9．下列软件配置完成的窗口，直接点击configure按钮完成软件配置

Top


TS7650G(3958-DD4)硬件中features的配置

解答:

TS7650G(3958-DD4)Features的配置如下:

(#9022) VTL
该许可表示这台ProtecTIER系统作为一个虚拟带库使用。该模式下需配置2个fc#3458，即2块8Gbps双端口光纤HBA卡用于连接前端主机。

(#9023) OST
该许可表示这台ProtecTIER系统作为一个OpenStorage使用。该模式下需配置2个fc#3456，即2块1Gbps四端口以太网卡用于连接前端主机。OST功能需要配合主机端的NetBackup备份软件使用。

(#3458) 8GB FC Dual Port HBA - Host
表示8Gbps FC dual-port PCIe HBA，提供TS7650G和主机系统或光纤交换机的连接。是必须要订的，缺省的数量是2，最大/最小数量都是2。

(#3456) 1GB quad port ethernet adapter
表示一个四端口 1Gbps 10/100/1000Base-TX PCIe 以太网适配器，端口为RJ-45标准用于连接Cat6以太网线，该卡支持IEEE 802.3ab 1000Base-T标准，最远传输距离可达100米。

(#3447) Cluster Connection Kit
这个产品号提供一个network power control switch, 2 个ethernet switches, 及相关的线缆和上架硬件，用来创建一个 clustered 配置在两个 TS7650 Servers之间.#3447（The Cluster Connection Kit）必须和 两个 TS7650 Servers放在同一个机柜中。如果有两个 TS7650 Servers做cluster，则#3447是必须的，否则，不需要订，两个做 cluster的TS7650 Servers只需在其中的一个上订购一个#3447。缺省的数量是0，最大数量是1。

(#9306) ProtecTIER EE V2 load
表示在TS7650 server上配置的软件版本是ProtecTIER Enterprise Edition V2 (PID 5639-XXB)，是必须要订的，缺省的数量是1，最大/最小数量都是1。

(#9340) Rack Mount DD1
表示TS7650G Server 需要放入客户提供的工业标准的 19英寸机柜，是必须要订的，缺省的数量是1，最大/最小数量都是1。

Top


TS7650G硬件中Console的配置

解答:

在e-config配置中，TS7650G(3958-DD4)硬件的Console用于配置其管理选件，其中:

(fc#2714) Console Expansion
该选件提供一根线缆来连接 TS3000 System Console (TSSC)，和一个 Ethernet hub 来扩展连接到 TSSC的单元数量。该选件最多可提供 14 个来自fc#2715 或另一个 fc#2714的连接。

(fc#2715) Console Attachment
该选件提供一根线缆来连接到 TS3000 System Console的Ethernet hub，一个TS3000 System Console最多可以连接40个fc#2715 这样的连接。

(fc#5513) KVM adjacent frame connection
该选件提供一根线缆将1-2台TS7650G连接到KVM Switch。

(fc#5514) 2nd server in adjacent frame
该选件表示这是第二台连接到KVM Switch的TS7650G。

(fc#2722) TS3000 System Console
该选件提供一个TS3000 System Console。选件fc#2722包括一个 1U高的服务器（Server），键盘（keyboard），显示器（display）， 鼠标（mouse）和 以太网交换机（Ethernet switch）。该选件还必须配置fc#2733，fc#5510和fc#5512。

(fc#2733) Internal Modem
该选件提供一个内置调制解调器（Internal Modem）安装在 1U 服务器上。

(fc#5510) Install KVM Switch
该选件提供KVM Switch，线缆和上架套件。

(fc#5512) KVM Display, Keyboard, Mouse
该选件提供KVM显示器，键盘，鼠标和上架套件。

关于 System Console配置， 一般建议在第一台TS7650G上配置System Console，选择fc#2722 (TS3000 System Console)，如果还有其他的TS7650G在同一地点运行,可以选择在其他的TS7650G配置 fc#2714 或 fc#2715。

Top


机柜

后门热交换器技术


优化交付

目标

概述

虚拟化的终极目标是搭建企业云，全面实现“可云化”。而现阶段，通过 IT 交付的项目量非常巨大，计算环境和架构的搭建往往需要几周，浪费了宝贵的时间。企业需要优化业务的服务交付方式，更多地将 IT 与业务融合，解放IT，帮助业务人员完成自我服务和资源随需取用，适应业务变化。

IBM 企业云解决方案：

IBM 拥有全套的企业云管理和资源平台，满足客户建造私有云所需的计算、存储、网络和软件，使得企业在安装的数小时内便可拥有“云”平台。

优势

支持持续的成本节约

.自动保留和回收计算能力，以充分利用资源。

.利用业务就绪云计算产品来支持标准化，从而大幅提高生产力并快速实现投资收益率。

.了解基于用途的成本，以发掘效率商机并帮助理清退款。

改进服务交付

.提供自助服务功能，以便将应用程序堆栈作为服务提供。

.确保将资源提供给与企业客户最相关的工作负载。

.支持弹性调整，以免发生破坏性的容量不足的情况。

提高业务敏捷性

.加快新服务或资源的供应并调整已确定的服务的规模，以便动态地提高业务敏捷性。

.支持创造性，使业务决策几乎完全摆脱基础结构的约束。

.通过开发几乎可以随时随地（无论处于企业内部还是外部）对虚拟资源进行“现收现付”的自助服务访问，来保护业务资本。

企业云成功案例

功能

IBM 产品

优化交付

.Smart Business Development & Test Cloud（英文）
IBM 基础架构优化服务——IBM 智慧业务测试云在一个高度安全的私有云环境下，提供一个对动态需求可扩展的虚拟化测试服务器资源。与传统测试方式不同，这种模式极大降低了设置一个测试环境的许多手动模式和传统步骤。随着需求的虚拟化资源设置，我们可以帮助您减少资本投资，同时通过弹性的可扩展性来应对动态的业务需求。
自动配置帮助您缩短配置周期，降低 IT 人力成本，减少配置错误，简化环境和改善解决方案质量。
效果：
.通过对需求的虚拟化测试资源配置的优化，帮助减少资本和认证多达 50%-75%
.通过测试环境的自动配置，帮助降低运行和人力成本多达 30%-50%
.通过改进测试供应，使得创新和上市时间从数周缩短至几分钟，并减少测试周期
.通过减少来自错误配置和糟糕的模拟效果的缺陷，改进 15%-30%的质量
.IBM CloudBurst（英文）
.IBM WebSphere CloudBurst Appliance
.云基础设施策略和设计服务
.IBM Smart Business Development and Test on the IBM Cloud（英文）

存储优化

.Smart Business Storage Cloud（英文）
Smart Business Storage Cloud 提供了一个存储虚拟化的解决方案，旨在通过快速部署一个可扩展的、全球的文件系统，部署及管理选择的灵活性，来应对数据存储的挑战。
效果：
.通过简化数据和提高可扩展性来增强创新和提高生产力
.通过存储整合降低运营成本和总体成本
.通过提供持续的专业管理知识来支持您的数据存储环境
.通过开发一个灵活的云存储基础架构使您随时访问存储系统
.IBM Scale Out Network Attached Storage (SONAS)
基于 SoNAS 的文件存储云，实现对文件系统的按需获取和随时扩展：
.SoNAS 是本方案的核心产品，SoNAS 从基础架构层面为“云”（公共云和私有云）用户提供受管理的文件存储服务，存储基础设施在云内是不可见的，具备弹性、可扩展的特点，保障业务不间断运行。
.单一、可扩展、包括企业所有文件及数据的企业档案库；能够为大规模社区的最终用户提供服务；
.实现价值增值的核心数据管理平台，对数据进行存档、备份/恢复及内容管理；
.提供丰富的功能：管理、检索、复制、分层、合规和数据安全。
方案优势：
.强大的可扩展能力，能够为大规模社区的最终用户提供服务；
.凭借智能负载均衡技术（内嵌 IBM 独有的 GPFS 通用并行文件系统技术），获得无与伦比的整体性能；
.每千兆字节（GB）的成本效益更高；
.传统的网络附加存储（NAS）设备的优越功能；
.支持节点无缝可扩展性，高性能地处理大型文件；填补技术空白。
.IBM 块存储云解决方案：
.IBM 块存储云，提供优化的块存储资源服务：为企业内部的数据库用户提供受管理的块存储服务，存储基础设施在云内是不可见的，具备弹性、可扩展的特点，保障业务不间断运行。
方案由以下三部分构成：
.需要纳入块存储云的硬件资源——XIV 网格架构磁盘存储系统（裸设备）；
.管理软件—— Tivoli Storage Productivity Center 标准版（简称 TSPC 标准版）；
.部署服务及客户化服务（可选）
方案优势:
.经过优化的整体数据吞吐量，提供出色的性能；
.快速存取数据，确保关键业务应用的高效运作；
.相比同类解决方案，提供最高级别的弹性，确保关键应用随时可用；
.XIV 实现了 100% 虚拟化网格架构、100% 均衡负载、100% 自动化管理、100% 自动恢复/自愈；
.为云方案的升级和扩展做好准备。
.IBM Information Archive

桌面客户机
优化

.Smart Business Desktop Cloud
IBM Smart Business Desktop Cloud，可以帮助您“随时随地”访问应用、信息和资源与任一项目为基础的综合管理服务方法。它可以让你减少昂贵的物理存储需求以及实现虚拟机的随时随地的创建，它还可以帮助你降低IT成本和复杂性，同时增强灵活性和控制力。
效果：提高员工生产力，获得更大灵活性，降低对台式机、笔记本电脑和其他客户硬件的依赖。
更多详情
.IBM Smart Business Desktop on the IBM Cloud
.IBM Tivoli Asset Discovery

与业务保持
一致的运营

.IBM Tivoli Business Services Manager (TBSM)
.IBM Tivoli Service Request Manager
.IBM Change and Configuration Management Database
.IBM Smart Analytics System

金融管理

.IBM Tivoli Usage and Accounting Manager (TUAM)（英文）
.IBM Tivoli License Compliance Manager (TLCM)
.IBM Tivoli Business Services Manager (TBSM)

Top


整合资源

目标

概述

对大多数企业而言，虚拟化的最初动力是降低成本。服务器无序蔓延而且效率低；运营成本、能源冷却、空间耗费严重，缺乏经验丰富的员工将工作负载迁移至虚拟环境中；虚拟化后工作负载的服务协议水平 SLAs 无法满足要求，只有部分 IT 架构实现虚拟化……通向“集中系统整合”的征程任重道远。

IBM 解决方案：

提供一整套为虚拟化设计和优化的涵盖硬件、软件和服务的系统。这些系统可以通过虚拟化作为大量服务器系统整合的平台。IBM 可以根据企业的需求帮助企业规划和实施系统整合策略。

优势

支持持续的成本节约

.利用行业中旨在托管最高虚拟机数量的平台，实现更高效的成本支出。

.通过使用与系统管理程序无关的解决方案，避免供应商锁定。

.通过先进的环保技术和管理软件，降低对能耗、散热和占地面积的需求。

改进服务交付

.利用评估、设计和实施服务，可快速部署新虚拟系统和新工作负载。

.从行业中的众多适用于利用功能部件（如扩展内存、活动内存故障转移、高级 RAS 及其他功能部件）进行虚拟化的服务器和存储产品服务组合中进行选择，进而优化服务级别。

.利用先进的应用程序和数据迁移工具，帮助节省时间并最大程度地减少运营中断。

提高企业敏捷性

.通过高密度的虚拟机以及领先的 RAS 功能部件降低基础结构复杂性，从而使 IT 可以更快地响应业务需求。

.有助于更轻松地集成多种环境，获得理想的技术组合，以实现服务目标。

.利用广泛的虚拟化选项生态系统，这些选项旨在应对当前和将来的挑战。

IBM 虚拟化方案

功能

IBM 产品

资源虚拟化

服务器虚拟化
.大型机（英文）
IBM System z 单台具有 z/VM 和 LPAR 的 IBM System z 就可整合一个数据中心的各类应用，可以分成成百乃至上千个虚机，单个虚机可配置多达 25，576个配置。
更多详情（英文）
.Unix：IBM Power Systems
IBM PowerVM技术，可以使Power Systems提供本地、基于硬件的虚拟化和整合。 PowerVM 可以比VMware环境节省 34%的IT成本。
更多详情
.x86：IBM System x 和 BladeCenter
IBM 全新的 eX5 系统，采用第五代 x 架构。突破内存瓶颈，提供 6倍于以前的内存扩展能力。每个插槽更多的内存和更高性能，将服务器的数量减少至一半，相同的软件许可成本下可多运行 82%的“虚拟服务器”，许可费成本下降 50%、存储成本下降 97%。此外，通过预先设置、工作优化及 IBM System Director，实现整合的单点管理，让系统部署更简便，运营管理更简单。
更多详情

存储虚拟化
IBM XIV、SAN Volume Controller、IBM ProtecTIER Deduplication 和 IBM 虚拟磁带库
IBM 存储系统的 SAN Volume Controller 技术提供的存储虚拟化，可以支持几乎所有的存储系统 ，通过将存储容量整合到一个存储资源池中，帮助您简化存储基础架构，对信息进行生命周期管理并维护业务持续性。
结果：将磁盘利用率提高 30%；减少 20%对未来数据增长的需求；存储管理效率加倍；消除存储相关宕机时间；FlashCopy 降低 75%存储空间。
更多详情

桌面云：Smart Business Desktop Cloud（英文）
IBM Smart Business Desktop Cloud，可以帮助您提供“随时随地”的访问应用，信息和资源与任一项目为基础的综合管理服务的方法。它可以让你减少昂贵的物理存储需求以及实现虚拟机的随时随地的创建，还可以帮助您降低 IT 成本和复杂性，提高员工生产力，获得更大灵活性和降低对台式机、笔记本电脑和其他客户硬件的依赖。
更多详情（英文）

应用程序
IBM WebSphere Virtual Enterprise
更多详情

策略与规划

.数据中心与设施战略服务
.服务器优化和集成服务：服务器整合效率研究
.存储优化和集成服务 ：转型策略
.网络策略和优化服务 - 针对整合和虚拟化的网络基础架构进行优化
IBM 可以帮助您利用最新的网络技术和架构，全面响应、整合和虚拟化IT环境；可以帮您评估和规划网络从一个相对静态的环境到一个优化的可以快速响应的环境。

工作负载迁移

.数据迁移服务
.针对 System z Linux 的整合和迁移解决方案

整合、安全性和网络服务

设施、服务器和存储器
.IT 设施整合与重定位服务
.针对 System x 的实施服务：适用于 VMware 的 Service Pac
.针对 Power 的实施服务 – PowerVM（英文）
.服务器优化和集成服务（英文）
.服务器优化和集成服务
.存储优化和集成服务
.维护和技术支持服务
应用程序
.中间件集成服务
安全性和网络
.针对 VMware 的虚拟服务器安全性
.Proventia 虚拟网络安全平台
.针对数据中心网络的网络集成服务：整合和虚拟化
融资
.包括租赁、项目融资、回购、售后回租和资产恢复服务

Top


管理工作负载

目标

虽然整合可以减少基础架构中的物理服务器的数量，但实际会增加虚拟系统的数量， 进而提高了复杂性。这些虚拟系统需要通过虚拟化软件对您的工作负载进行整合系统管理和监控，企业必须了解如何通过虚拟化软件来进行有效的虚拟化管理。

优势

支持持续的成本节约

.利用容量和能源管理，支持进一步整合并降低数据中心成能源本。

.在整个基础结构中启用公共集成管理工具，而不考虑域或平台。

.提高 IT 员工生产力。

改进服务交付

.加快问题和瓶颈的识别和纠正。

.实时反映组件之间的依赖关系，以预先主动识别潜在问题。

.自动化例程管理任务，以缩短响应时间并减少用户错误。

提高业务敏捷性

.利用参考体系结构和决策支持框架，加快规划和实施

.利用开放标准并复用标准化设计元素，以创建更加模块化的体系结构。

.预先主动地规划业务未来的容量和能源需求。

IBM 虚拟化方案

功能 | IBM 产品
发现和监控 | .IBM Systems Director VMControl VMControl V2.2 简化了涉及多重虚拟化技术和硬件平台的虚拟环境管理，将你从“虚拟化的地窖”中解放出来并实现整个企业的可见度及控制。 .IBM Tivoli Monitoring (ITM) .IBM Tivoli Application Discovery and Dependency Manager .IBM Tivoli TotalStorage Productivity Center .IBM Tivoli Asset Discovery
映像管理 | .IBM Systems Director Standard Edition / Enterprise Editions IBM Systems Director 提供一个统一的总体 IT 环境景观，包括 IBM 和非 IBM 的服务器、存储和网络。这就允许终端客户任务能在单个工具中完成，并且促进了 IT 连续性和处理标准化，以达到更低成本的系统管理。仅 Systems Director 6.1就能节省 34%的管理成本。 .IBM Tivoli Provisioning Manager for Image Management .IBM Tivoli Provisioning Manager for Operating System Deployment .IBM Tivoli System Automation .IBM SAN Volume Controller .IBM BladeCenter 虚拟光纤交换机 .IBM Blade Center Open Fabric Manager .IBM Tivoli Storage Productivity Center Software：虚拟和物理存储资源的整合管理工具
能耗管理 | .IBM Systems Director Active Energy Manager .IBM Tivoli Monitoring for Energy Management
工作负载管理 | .IBM Tivoli Dynamic Workload Broker (TDWB) .IBM Tivoli Application Dependency Discovery Manager .WebSphere Virtual Enterprise
管理服务 | .软件支持服务 .基础结构策略与规划服务 .服务管理策略与规划 .服务管理实施服务 .服务器托管服务 .存储和数据托管服务

Top


自动化流程

目标

概述

构建了一个虚拟化环境，但却没有一个标准化的流程、应用或服务交付方式。手工流程花费时间并且消耗资源，尤其当跨越多个平台和操作系统工作的时候，效率就会降低，所以这一阶段需要通过流程自动化和标准化来带动整体服务水平提升。

IBM 解决方案：

IBM 可提供帮助您业务进行全球化的一系列的方法和工具，围绕最佳实践、业务规则、优先级，进行标准的自动化出来，来提升流程的效率及效果。

优势

支持持续的成本节约

.各孤立部门间提供的产品包括机器、操作系统、应用程序、存储器和网络，使新服务的上市时间从数天缩短至几分钟。

.使用自动化流程减少人为错误。

.实施基于策略的基础结构，以符合不断变化的法规需求。

改进服务交付

.利用具有更强自我感知和自我修复的基础结构，支持更高服务级别。

.更好地管理急剧增加的需求，并将真正需求与基础结构的安全性攻击区分开来。

.通过自动提供和重新分配业务所需的资源，确保业务优先级与 IT 优先级保持一致。

提高业务敏捷性

.支持利用多种 IT 选项，制定基于业务的决策。

.降低业务策略实施的风险和成本。

.确保基础结构服务与业务目标保持一致。

IBM 虚拟化方案

功能 | IBM 产品
供应 | .IBM Tivoli Provisioning Manager (TPM) .IBM Tivoli Provisioning Manager for OS development .IBM Tivoli Provisioning Manager for Images .IBM Tivoli Storage Productivity Center
自助服务部署 | .IBM Tivoli Service Automation Manager (TSAM)
自动化 | .IBM Systems Director VMControl Enterprise Edition IBM Systems Director VMControl 企业版 VMControl 企业版使用户能够创建和修改系统池，在池内调整移动动态虚拟工作量，创造最优的虚拟环境，提升弹性以应付导致计划内或计划外停机时间 注：如果您想与SWG建立联合虚拟计划请参考以下软件产品： Tivoli Workload Automation software: 使资源自动配置需求和监控应用程序。它能主动检查常见问题，并自动采取预定义的业务规则为基础的行动，指定是否要重新启动或关闭某一个特定出现问题的组件. 效果：在POWER系统里，Tivoli Service Automation Manager与Power/VM hypervisor联合能够减少75％的故障；比较传统的单机x86环境和手动部署方法企业可以削减97％的劳动成本。 更多详情 .IBM Tivoli License Compliance Manager (TLCM) .IBM Tivoli System Automation
自动化服务 | .IT 生命周期管理和治理服务 包括 IT 服务管理，服务台和资产管理功能。我们的服务管理方法有助于改善对配置的控制，改变和资源管理流程，同时加快实施，有助于降低时间效益和降低风险。 创建动态的可见度和整个IT基础设施管理服务，积极诊断、预防和响应性能问题 利用强大和动态管理能力，以更好地协调业务和技术，提高质量，影响和效益的IT服务交付 更多详情 .存储优化和集成服务

Top